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User Guide Documentation
This User Guide is written for both WindowsXP/Vista and Power Macintosh and Intel 
platforms. Before using this User Guide section, install any one of the three Designer 
Elements 3D modeling programs either Cobalt™, Xenon™ or Argon™. Instructions and 
System Requirements are contained in the Getting Started manual. This manual is 
divided into sections which group chapters according to the topic. Each chapter 
provides information about tools, commands and other features.

Menus and Submenus
As is standard for all programs, Ashlar-Vellum’s Designer Elements 3D modeling 
programs provide menus and submenus for choosing commands and performing other 
operations.

Choosing Commands
The manual directs you to choose commands contained in submenus of other menus, 
like the pull down menu. For example, it might be necessary to select Lock in the Group 
submenu of the Layout menu. That appears in this manual as Layout>Group>Lock.

Margin Notes
This manual includes margin notes that provide information to assist in the using of this 
program. There are three types of margin notes: Tip, Tech Note and Referral. These 
notes are given special treatment so that they are instantly recognizable and easy to 
significance and locate them for future reference.

Tip
A tip provides instructions for getting the most out of the program. Tips may show how to 
speed up an operation or how to perform some timesaving drawing technique.

Tech Note
A technical note provides additional technical information that may help when using a 
tool.

Referral
A referral points to related information contained somewhere else in the manual for the 
particular topic being addressed.
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Style Conventions
This manual uses various style conventions which highlight certain terms or phrases. 
The list below includes an explanation and an example in parentheses. The conventions 
are as follows:

Terminology
For those new to surface and solids modeling, there are many terms or phrases that 
might be unfamiliar or used differently from your experience. These terms are defined 
the first time they are used in the manual as well as in the Glossary.
Some important terms include:

Bold Tool palette names (Light palette); Tool names (Single Line 
tool); Keyboard-entered text; Definition terms (as shown in 
these style conventions)

Italic Terms used for the first time in a chapter; (Iso Lines); Drafting 
Assistant notations (midpoint); tool and dialog box options 
(Angle box); book references (User Guide); Message Line 
directions (Single Line: Pick the beginning point.); margin note 
headings (Tip); menu commands (Zoom Previous); filenames 
(prefs.ini); stand alone extensions (.dwg); directory names; 
drawing names

Bold and Italic Command series (Layout>Group>Lock)

ALL CAPITALS Key names on the keyboard (ENTER, RETURN)

Title Capitalization Dialog box names (Edit Objects); menu names (Pen menu); 
special Vellum phrases (the Drafting Assistant)

all lower case File names (prefs.ini); stand-alone file extensions (.dwg)

Curves Refer to all lines, arcs, ellipses, conics, circles, splines and 
polygons created using one of the wireframe tools.

Instance Refers to an object that's moved to or placed in a different 
location after performing an operation on it. While creating a 
solid, add a blend and move it, the solid is now a translated 
instance. The original is still located in the previous position 
although it is not displayed. Creating a master symbol, an 
instance occurs when placing the symbol in the drawing. An 
instance is associative to the original geometry. Any change 
made to the original is reflected in the instance (Cobalt and 
Xenon only). If the object is copied and pasted, the 
associativity is broken.
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Using the Mouse
The mouse is your communication device; use it to tell the computer what to do. Use the 
mouse to indicate locations, choose commands, select tools and construct objects.
This manual uses the following terms for mouse activities:

Chapter Breakdown

The chapters are grouped into nine sections dealing with a specific area.

Parent/child Refers to objects that are related to each other in such a way 
that changing one (the parent) affects the other (the child). This 
is an important feature in Cobalt and Xenon. Argon does not 
have this functionality. This associativity works much the 
same way Vellum 3D or Vellum Solids worked with 
dimensioning objects and editing. When changing an object in 
Vellum, the dimension changes. Cobalt and Xenon have taken 
this idea to a higher level involving geometry. After creating a 
curve, extruding and then filleting it, it is possible to go back to 
the first curve and edit it and the entire object adjusts. Cobalt™ 
and Xenon™ have the intelligence to remember the 
relationship between the parent curve and all other operations 
performed on the resulting object.

Pointer An arrow or any other graphic symbol that allows selection or 
creation of an object. Move the pointer to point to a command 
or an object on the screen. Depending on its location, the 
pointer is an arrow or may look like the current tool.

 

To move the pointer, move the mouse. 

Point Move the mouse until the pointer is over the necessary item.

Press Press and hold down the mouse button.

Click Quickly press and release the mouse button once.

Double-click Click the mouse button twice, quickly in succession.

Drag Press and hold down the mouse button, move the mouse, then 
release the mouse button.

Curves Refer to all lines, arcs, ellipses, conics, circles, splines and 
polygons created using one of the wireframe tools.

Arrow Pointer Selection Arrow Center-Point Circle
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Sections

Referral: Specific page information on a particular tool or command can be
found in the index.

Appendices

Overview Chapters 1 through 4 introduce some basic features of the 
Designer Elements 3D modeling programs, including the 
program Window, the Drafting Assistant and information on 
selecting objects.

Setting the 
Environment

Chapters 5, 6 and 7 explain pen and preference settings and 
drawing techniques.

Wireframe Modeling Chapters 8 through 18 cover wireframe modeling including 
curve tools as lines, arcs, circles, splines, polygons, etc.

Surface Modeling Chapters 14, 15 and 16 introduce surface modeling and 
provide information about surface modeling tools such as 
Infinite Plane, Skin, Net, Tube, Tangent, etc.

Solids Modeling Chapters 17 through 19 explain solid modeling and contain 
information on such solids modeling tools as the Sphere 
Primitive, Block Primitive, Cylinder Primitive, Lathe Solid, Pipe 
Solid, Blend Solid, Hole, Boss, Protruded Feature, etc.

Editing Chapters 20 through 25 explain tools and commands for 
editing curves, surfaces and solids, including such tools as 2-
entity Fillet, Simple Trim, Connect Curve, Plane Surface 
Intersection, Boolean Surface, Subtract Solid, Shell Solid, 
Taper Solid, Deform Face, etc.

Adding Details Chapters 26 through 29 contain information on text, 
dimensions, patterns and fills, crosshatching and symbols.

Drawing Display Chapters 30, 31, 32 and 33 offer information on viewing the 
geometry, layers, planes and rendering.

Documents Chapters 34 through 38 contain information on file 
management, importing, exporting, page setup and producing 
production drawings.

Advanced 
Parametrics

Chapters 39 and 40 provide information about using Cobalt's 
parametric capabilities.

Operators Describes all math operators accepted by the data fields.

Special Characters Lists all special characters not directly available from the 
keyboard and symbols to use in this Designer Elements 
program.

Shortcuts Contains a list of the default Shortcuts

Spline Text Files Provides instructions for creating spline text files to import.
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Other

Graphics
Most of the graphics in the manuals apply to both platforms. In those instances that 
require a platform and software reference, a Windows graphic is used. When necessary, 
both Windows and Macintosh graphics are included.

Shader Attribute 
Definitions

Contains the definitions of shader attributes used when using 
the advanced shader rendering capabilities.

Glossary Defines terminology used in CAD drafting and in this Designer 
Elements program.

Index Lists this Designer Elements program tools, features and 
actions and their page location.

Tips Contains additional tips for using this Designer Elements 
program.

Operators Describes all math operators accepted by the data fields.
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First Look
This chapter describes the “first look” components of the Ashlar-Vellum Designer 
Elements including Cobalt, Xenon and Argon. A brief overview of useful features may be 
all you need to know if you are familiar with CAD software. The following topics are 
covered:
• Parts of the Designer Elements Window
• Menu Bar
• Update Installer
• Automated Support Ticket Preparation
For more information about standard elements such as menus, scroll bars, File menu 
commands, and dialog boxes, refer to the Windows or Macintosh User Guide that came 
with your computer.

Parts of the Designer Elements Window
When starting the Cobalt, Xenon or Argon programs the following window appears.

Title Bar Menu Bar

Message Line

Trackball

Tool palettes

Triad

Drawing Area

Coordinate System

Work Layer Indicator
Status Line

Locator Indicator

Scroll Bar
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Title Bar Includes the title of the active document and buttons for 
controlling the window to minimize, maximize and close it. 

Menu Bar Displays the menus of commands and settings. It is possible to 
make choices from the menus with the mouse or by using 
special key combinations.

Tool Palette Are the drawing and editing tool icons used for constructing, 
editing and annotating geometry. Only the most basic tool 
palette is displayed on initial startup. The Surface tool palette 
and Solids tool palette are not automatically displayed, unless 
specified through Preferences. See Preference Settings.

Tool Tip Displays a brief description of the tool the cursor is held over. 
Tool Tips are activated or deactivated by choosing 
File>Preferences>General. If a shortcut is assigned to a tool, 
the shortcut displays with the tip.

Pointer Shows the active position on the screen. For wireframe tools, 
when the pointer is in the drawing area, its shape represents 
the current tool.

Axis Displays the current view orientation of the x, y and z axis in 
the center of the screen.

Triad Displays the current view orientation of the x, y and z axis with 
a representation of the current work plane.

Location Indicator Shows the x, y and z coordinates of the pointer location at the 
top of the drawing area.

Message Line Displays the name of the current tool and step-by-step 
instructions for using the tool. For some tools, the Message 
Line includes an additional subpalette.

Drawing Area Consists of multiple layers for constructing and annotating 
geometry. 

Status Line Displays the coordinate location and other geometric 
characteristics of the current object based on the World 
coordinate system.

Coordinate System 
Axis

Shows the current coordinate system. It is possible to choose 
between the default global or world coordinate system and a 
user-defined coordinate system.

Scroll Bars Move around a drawing. The scroll buttons move one line at a 
time.

Work Layer Indicator Displays the name of the current layer and provides a menu for 
changing the work layer, creating a new layer and accessing 
the Layer Manager.
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Tool Palette
A tool palette is a group of tool icons that represent tools for drawing, editing and 
annotating geometry. This graphic is the main tool palette:

Selecting a Tool from the Tool Palette
1. Position the arrow pointer on the icon of the tool.

2. Click the mouse button.
The icon appears highlighted to indicate its selection.

Floating Tool Palettes
All tool palettes are floating tool palettes. Once a palette is displayed, it is possible to 
move it to any location in the drawing area simply by dragging the palette by its title bar. 
Save the palette to that location for future files by choosing File>Preferences>General 
and click the Save Now button.

Line Tools

Circle Tools

Arc Tools

Ellipse/Conic Tools

Rectangular Tools

Spline Tools

Text Tools

Dimension Tools

Fillet/Chamfer Tools

Trim Tools

Curve Utility Tools

Transformation Tools

Smart Walls Tools

Selection tools
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Tool Subpalettes
All of the tools in tool palettes contain a subpalette of tools with related functions. The 
arrow in the lower-right corner of the first icon represents the presence of a subpalette. 
This graphic shows the Wireframe tool palette with all of its submenus.

Selecting a Tool from a Subpalette
1. Position the arrow pointer on the 

tool.

2. Press the mouse button.
The subpalette appears to the right of 
the tool. 

3. Drag the pointer to highlight the 
desired tool.

4. Release the mouse button.
The selected tool replaces the previous tool in the tool palette. The 
highlighted icon in the tool palette shows that the selection from the 
subpalette is the active or current tool.

The new tool is visible in the tool palette until another tool is selected from 
the same subpalette. The tools in the subpalette remain in the same order; 
only the tool displayed in the tool palette changes.
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Once a tool is selected, additional information appears to help with the construction. The 
Pointer, Pointer Locator, Message Line, and Status Line all provide feedback about the 
active tool.
To select a tool already displayed in the tool palette, click it. It is not necessary to select 
it from the subpalette.

Tear Away Palettes
All tool palettes containing subpalettes are capable of “tearing away” from the parent 
palette located anywhere in the drawing area. The graphic here is the Ellipse/Conic tool 
palette.

Dragging the mouse to the right across the subpalette beyond the last tool, the 
subpalette “tears away” from the parent tool palette. Save the palette in this location by 
choosing File>Preferences>General and click on the Save Now button. Close the 
palette by clicking on the close button in its title bar.
When tearing 
away multiple 
tool palettes 
and dragging 
them near 
each other, 
they snap to a 
left alignment.

Right Mouse Button
This Designer Elements program accesses commands through the right mouse button. 
For Macintosh users who do not have a right mouse button, these same commands are 
available by holding down the CTRL key and pressing the mouse button.
Different sets of commands display depending on whether the button is pressed while 
on or off an object or when a drawing view is activated.

Over No Object
Click the right mouse button (Windows) or CTRL + mouse button 
(Macintosh) in the white space of the drawing, and the popup 
menu on the right appears.
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The menu includes the following commands:

Zoom Select, 
Zoom All, 
Zoom Window, 
Zoom In
Zoom Out
Zoom Previous

Are the same as those in the View menu.

Dynamic Pan, 
Dynamic Zoom,
Dynamic Rotate

Perform the same function as the Dynamic Pan, Dynamic 
Zoom and Dynamic Rotate tools in the View tool palette. 
When one of these commands is selected, the pointer icon 
becomes that of the tool. It is possible to perform the operation 
once and then the icon reverts back to the selected tool.
To perform multiple operations, hold down the SHIFT key 
before selecting the command. When the SHIFT key is 
released, the icon reverts back to the selected tool.

View Displays all default views and any user-defined views.

Planes Displays the same commands as those in the Planes menu, 
with the exception of the Show Work Plan command.

Select All Specifies which object types to select.

DeSelect Deselects any selected objects.
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Show All Specifies which hidden object types to show.

Hide All Specifies which object types to hide.

Planes Displays the same commands as those in the Planes menu, 
with the exception of the Show Work Plan command.
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Over An Object
When an object is selected, place the pointer over the 
selected object and click the right mouse button 
(Windows) or CTRL + mouse button (Macintosh), the 
popup menu on the right appears.

The menu includes the following: 

Hide, Show Only Are the same as those in the Show-Hide dialog box that hide or 
show the object.

Resolution Displays a menu to change the object’s resolution to Super 
Fine, Very Fine Medium or Coarse.

Style Displays a menu of commands for creating and modifying pen 
styles. A pen style is a collection of pen attributes such as 
color, weight and pattern.

Color Displays a menu to change the color or the object. These are 
the same color options available when choosing Pen>Color. 
The More option displays the color palette.

Weight Sets the pen width of the current pen pattern and the selected 
lines without changing any other pen characteristics. 

Pattern Determines the appearance of lines on the screen and during 
plotting. Any line thickness of less than .016 inch appears one 
pixel wide on the screen. When printing or plotting such lines, 
they appear with the weights.

It is also possible to set a line weight based on units, pixel 
thickness and through the More option by the point size or 
model space.
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Layer Changes the object’s layer to any layers in the file, whether or 
not a layer is hidden. It also includes The More command. 
Selecting More displays the following dialog box:

Click on the Create New Layer button and then click OK to 
move the object to the new layer. The new layer is titled with a 
default name (for example, Layer3). It is possible to change the 
name through the Layer Manager (Layout>Layer Manager).

Edit Objects Displays the Edit Objects dialog box.

Change Object Type Changes an object's type. This is helpful for editing as well as 
exporting geometry to software that may not support a 
particular type of entity. After using this command for a 
particular operation, this program remembers the selected 
conversion type (Curves, Surface, Mesh or Solids for a Solid 
object) until the option type is changed. This command 
converts: Solids to solids, meshes, surfaces or curves. 
Surfaces to meshes, surfaces or curves. Curves to lines, 
polylines or splines. When selecting this command a dialog 
box similar to the one below appears.

For more information See “Change Object Type” on page 5-15

Save As Symbol Evokes the Symbol Manager dialogue box to create a new 
symbol that is used to define 2D or 3D shapes that frequently 
occur throughout a drawing. Once the symbols are created use 
the Symbol tools to place them into the drawing.

Object Name Displays the name of the object in the menu. Change the 
object’s name by clicking on the name. The following dialog 
box appears: 
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Over Multiple Selected Objects
The common properties of multiple objects can be modified via the right-click menu. The 
ambiguity dialog box appears if more than one item is clicked. Choose the All Selected 

Type a new name and click OK to make the change.

Copy as ACIS Solid Creates a copy of the part that was right-clicked. The copy is 
placed directly on top of the original part. This new part 
contains no history of the original part.

Copy As Instance Creates a copy of the part that was right-clicked. The copy is 
placed directly on top of the original part. This new part is an 
instance of the original, therefore any changes made to the 
original part will be reflected in the new part.

Copy Part History Creates a copy of the part that was right-clicked. The copy is 
placed directly on top of the original part. This new part 
contains the exact history of the original part but is managed 
as a completely separate entity.

Transparency Makes it possible to see through the part. To adjust the amount 
of transparency applied to the part, select View>Shade 
Options... and move the transparency slider.

Object 
Characteristics

Provides geometric characteristics for a wireframe object. For 
example, an ellipse displays the major radius, the minor radius 
and circumference.

Layer Changes the object’s layer to any layers in the file, whether or 
not a layer is hidden. It also includes The More command. 
Selecting More displays the following dialog box:
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option from the Pick Object dialog and the properties modified in the right-click pop-up 
menu will apply to all the selected objects.

Selected Drawing View
When a drawing view is selected and the right mouse button 
(Windows) or CTRL + mouse button (Macintosh) clicked, the 
popup menu appears:
These commands are identical to those in the Drawing View pull-
down menu. See “Drawing Composition for Cobalt & Xenon” for 
information on these commands.

Smart Pointer & Wireframe Tools
Having selected a tool, move the pointer into the drawing area. The pointer shape 
represents the tool.
Some of the pointers, like the Single Line pointer, are simple cross-hairs. Others, such 
as the Opposite-point Circle pointer, resemble the tool.
The pointer, called a smart pointer, displays 
indicators for multi-step procedures. Each 
smart pointer has a dot, the hot spot, showing 
the next point to specify. The dot changes 
position on the pointer during each step of the 
construction. 
For example, the Opposite-point Circle pointer, 
illustrated above, shows that the first click of 
the mouse places a point on one edge of the circle being created. After a location is 
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clicked, the hot spot moves to the other side of the pointer, showing that the next click 
places a point on the opposite edge of the circle. See the graphic below.

After the second location is clicked, the circle appears. The hot 
spot moves back to its original position on the pointer, so another 
circle can be created.

Location Indicator
The Location Indicator is located next to the Layer indicator at 
the bottom of the drawing area.

This indicator continuously tracks the pointer location when the pointer is in the drawing 
area, displaying the X, Y and Z coordinates of the current location relative to the origin. 
The origin (0,0,0) appears in the center of the screen when a new document is opened. 
If the Axis are displayed, the origin is at the intersection of the x, y and z axes.

Message Line
The Message Line across the top of the drawing area provides concise instructions for 
the use of the current tool.
For example, after selecting the Center-point Circle tool, the Message Line appears as 
illustrated here.

The instructions in the Message Line for some tools also indicate optional activities. For 
example, holding down the CTRL (Windows) or OPTION (Macintosh) key while using 
the Center-point Circle tool, the next mouse click creates a copy of the last circle with 
the center placed where clicked.

Status Line
The Status Line provides measurements, angles, X, Y and Z coordinates and delta 
values for the current construction. The current tool determines the number of status 
fields and which of the status fields highlights after the construction. For example, if the 
Center-point Circle tool is selected, the Status Line shows the X,Y and Z coordinates 
for the center of the circle and the diameter.

Tech Note: The number of decimal places displayed in the Status Line fields
is determined by the decimal setting in the Units page of Preferences.

When the last point of the circle is clicked, the diameter (D) entry field highlights in the 
Status Line to indicate that it is active. It shows the diameter of the circle just created. If 
a new number is typed, and the ENTER (Windows) or RETURN (Macintosh) key is 
pressed, the diameter of the just created circle changes.
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It is possible to change any or all entries in the Status Line. If the entry is changed 
before the tool operation, the values automatically register when clicking in the drawing 
area for the particular operation. If a value is entered after the geometry is created and 
then ENTER (Windows) or RETURN (Macintosh) is pressed, the changes are made to 
the geometry and no more changes can be made in the Status Line.
The number of decimal places displayed in the data fields is determined by the Precision 
setting in the Units page of Preferences.
The Status Line uses the World coordinate system for all values entered in the data 
fields. Values can be entered in inches, feet, millimeters, centimeters, meters and 
mathematical expressions (ex. 10”+2.54 cm).
When the units in Preferences are set to feet and inches, it’s important to be aware of 
the following rules:
• All numbers are assumed to be feet unless accompanied by the unit symbol, like “ for 

inches. Entering a 1.5 in the field is read as 1.5 feet. For 1.5 inches, enter 1.5”, 1.5i, 
1.5in, 1.5 inch, etc.

• For fractions of inches, each entry must include the unit symbol. For example, 5 feet 6 
5/8 inches must be entered 5’ 6” 5/8”. Internally this is converted as 5’ + 6” + 5/8”. If 
the inch symbol is not included with the fraction, 5/8 will be interpreted as a fraction of 
a foot.

Tip: It is also possible to change objects with the Edit Objects command or by
double-clicking on the object to display the Edit Objects dialog box.

Copying and Pasting Status Line Entries
It is possible to copy and paste Status Line text for use in another data field.
For Windows, hold down the right mouse button and use the Copy and Paste 
commands available in the menu. The Copy and Paste commands in the Edit menu 
cannot be used.
For Macintosh, use +C to copy and +V to paste text. The Copy and Paste 
commands in the Edit menu cannot be used. These function only for Designer Elements 
program data.

Moving between Status Fields
Use the TAB key to move to the right, highlighting the next field. When pressing ENTER 
(Windows) or RETURN (Macintosh), the entry either changes or the construction 
redraws according to the new specifications in the Status Line. Use the mouse to 
activate a Status Line field.
Use the Status Line arrows to scroll if any of the fields are off screen.

Expression Parsing
The Status Line entry fields also accept mathematical, trigonometric, and exponential 
operators. Position the cursor in the text field and type in the additional operation. See 
Appendix A for the list of supported operators.
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Coordinate System Axis
The coordinate system axis, at the left of the Status Line, displays 
the coordinate system currently set for the file. Choose either the 
Global (world coordinate system) or a user-defined coordinate 
system. Clicking on the axis displays a menu from which to set 
the coordinate system.
The default system is the Global coordinate system. See Chapter 7 for more 
information.

Axis
The Axis displays the current view orientation of the x, y and z axis in the 
center of the screen. When views are changed, the axis adjust accordingly. 
Turn off the display by choosing View>Show Axis. If it is not necessary the 
Axis to display at start up, choose File>Preferences>General and 
deselect the Axis option.

Triad
The Triad displays in the upper-left 
corner of the drawing area to 
illustrate the orientation of the x, y, z 
axis and the work plane. The 
example below uses the default view 
definitions.

The Triad represents the principle of 
the right-hand rule—a memory aid for the 
relative directions of the positive axes. With 
the right palm upturned, the thumb (x) 
points right, the index finger (y) points 
straight ahead, and the middle finger (z) 
points up. If you move the hand to indicate 
the x and y-axes, you can easily see the 
direction of the z-axis.
To turn off the Triad choose Planes>Show 
Triad. If it is not necessary for the Triad to 
display at start up, choose 
File>Preferences>General and deselect 
the Triad option.
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Drawing Area
Use the drawing area for all construction, editing and annotation of geometry. Think of 
the drawing area as a sheet of paper of unlimited size that is used to construct full-size 
unscaled drawings. Use the scroll bars to move the sheet so the portion to work on 
is visible in the window.

Displaying the Grid
If it is necessary to work with a grid in the 
drawing area, choose Planes>Show Grid.
Choose Window>Snap and the Snap 
Options dialog box appears. Choose To Grid 
and the constructions snap to the grid, 
meaning that any clicked geometry point 
snaps onto the closest grid point.

Scroll Bars
The scroll bars move the sheet up and down or right and left. Display different parts of 
the drawing sheet by dragging the slider of a scroll bar to the approximate location. For 
example, the right, center, or left position in the horizontal scroll bar displays the right 
side, middle, or left side of the drawing, respectively. 
Click the arrows at the end of the scroll bars to move the sheet one line at a time.

Work Layer Indicator
The Work Layer Indicator in the lower-left corner of the screen shows which layer is the 
current work layer. New geometry goes on the work layer. To make the construction go 
on a specific layer, first make it the current layer.

Select the work layer in either of two ways:
• Click on the arrow to the left or right of the layer name and the layer will move 

backward or forward to another layer.
• Position the pointer over 

the Work Layer Indicator, 
then press the mouse 
button. All available layers 
are then displayed in a 
pop-up menu from which a 
different layer can be 
selected to be the current 
work layer. Drag to the 
new work layer. All new geometry is placed on that layer. It is also possible to create 
a new layer and display the Layer Manager from the Work Layer Indicator.

Menu Bar
The program menus contain related commands and settings.

File Contains commands that effect entire documents, including 
opening and closing files, setting preferences and defining the 
Print Setup (Windows) or Page Setup (Macintosh).

Edit Use this menu for commands to select and manipulate objects. 
These include copying and pasting as well as changing an 
object’s direction, resolution, layer and type.
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Mouse versus Keyboard
Cobalt, Xenon and Argon menu items can be chosen with the mouse or with a 
combination of keys on the keyboard. For example, here are various methods for 
displaying the Edit menu.
Windows and Macintosh:
• Click on Edit in the menu bar.
Windows only:
• Press the ALT key and then type E.
• Press the ALT key and then press the RIGHT ARROW key until Edit is highlighted in 

the menu bar; then press ENTER.
There are also various methods for choosing commands with the keyboard. For 
example, use any of the following methods to choose Planes>Show Grid.
Windows:
• Press ALT and L and then type G.
• Press ALT and then use the RIGHT ARROW key to highlight Layout and press 

ENTER. Then press the DOWN ARROW key to move the highlighted area to Show 
Grid and press ENTER.

• Hold down the CTRL key and type G.

Layout Contains commands and settings that specify the drawing area 
and provide program features and functionality such as the 
Grid, Layer Manager, Group and Align.

View Displays the document such as choosing and setting views 
and zoom options.

Planes Contains commands for choosing and defining the work plane.

Pen Specifies pen characteristics (color, weight, and pattern), 
polygon patterns, polygon fill, crosshatching and arrows.

Text Sets the font, size, style and case of the text (lower, upper and 
title capitals).

Dimension Use this menu to specify dimensions, their format and 
tolerance.

Verify Obtains information about the file and specific objects in the 
file. These include properties of an object, direction, curvature 
and object counts.

Window Displays tool palettes, the Design Explorer, Trackball, etc.

PhotoRender Contains commands for photo-realistically rendering the 
geometry, setting options for rendering and placing lights.

Animation Use this menu for generating Quicktime movies.

Help Offers PDFs of the manuals links to the Ashlar-Vellum Web site 
for updates and support.

File Contains commands that effect entire documents, including 
opening and closing files, setting preferences and defining the 
Print Setup (Windows) or Page Setup (Macintosh).



Menu Bar

2-17

The first method is the mnemonic method. Press the ALT key with the appropriate letters 
for the menu and command as indicated by the underlined character in the names.
Macintosh:
• Hold down the  (command) key and type G.
The third method for Windows and the only one available for Macintosh is a keyboard 
accelerator. When available it is denoted by the key sequence listed on the menu.
While keyboard functionality is always available, this manual generally describes 
making choices with the mouse. 

Tip: Windows only: Hold down the ALT key and type a letter to select the first
item that begins with that letter, then use the arrow keys to move to the
desired selection. Once the choice is highlighted, press the ENTER key.

Submenus
Commands followed by an arrow symbol have 
submenus which display when the command is 
highlighted.
1. Pull down the menu.

2. Click on a command followed by an arrow 
symbol.
The submenu displays.

3. Click on the submenu.
4. Click the desired command.
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Dialog Boxes
When a command followed by an ellipsis 
(…) is chosen, such as Edit Objects in the 
Window menu, a dialog box appears.
Dialog boxes qualify the chosen command 
by adding information. For example, in the 
Edit Objects dialog box here, it is possible 
to change the specifications of the selected 
object.
If a dialog box obscures the view of the 
drawing area, move it to a new location by 
dragging it with the pointer on the Title bar.

Tech Note: Windows only: Designer Elements program dialog boxes do not
support using the large font setting in the Setting page of the Display
Properties dialog box for the Operating System.

Tech Note: To copy and paste data between data fields in dialog boxes, the
Copy and Paste commands cannot be used. For Windows, press the right
mouse button and use the commands in the menu. For Macintosh, use
CTRL+C to copy and CTRL+V to paste.

Option Buttons
Option buttons indicate mutually exclusive choices. Only one option can be selected at 
a time. Click the option and the button turns black, as shown by the inches option below.

Check Boxes
Check boxes, as shown above, provide options that can be switched on and off and 
which are not mutually exclusive. A check mark shows the option that is set.
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List/Entry Fields
Some dialog boxes contain lists of options, 
displaying an arrow to provide access to the 
list.
Some have fields that allow an entry to be 
typed. For example, type a value in the 
Scale entry field in the Drawing Size dialog 
box or choose from the pull-down menu, 
indicated by the arrow. See the graphic 
here.

In most cases clicking OK saves the 
changes.

Asterisks

When an item in the dialog 
box displays an asterisk 
(*), it is possible to specify 
a value by clicking or 
dragging in the drawing 
area with the mouse. This 
feature is particularly 
useful for specifying 
location because it is not 
necessary to know any x, y 
and z coordinates. 

Apply Buttons
Some dialog boxes have an Apply button that applies the specification currently set. The 
dialog box can be left open to set other specifications.
For example, once an object is changed in the Edit Objects dialog box, click apply and 
leave the dialog box open for future changes.

Closing a Dialog Box
If a dialog box contains an OK or Cancel button or an action button such as Open, the 
dialog box closes when the button is clicked. Otherwise, dismiss the dialog box 
manually by double-clicking the Control Menu (Windows) or clicking the Close Button 
(Macintosh) in the upper-left corner of the box.

Toggling Commands
Commands that set a condition (such as Snap To Grid and Arrow At Start) display a 
check mark in the menu to indicate that they are active. To turn a command off, choose 
it and the check mark will disappear.
In the case of pen patterns and text characteristics, the check shows the current setting.
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Update Installer
Cobalt, Xenon and Argon feature an installation program to quickly check the website 
for newly available updates. Using this feature under Help>Check Web for Updates… 
downloads and installs just the update, not the entire program. 

This method keeps in place:
• Designated Preference settings. 
• Current registration codes.
• User serial numbers.
It is recommended that this feature be used at least once a month with current software 
to be sure that the latest build of the major version number is being used.
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Automated Support Ticket Preparation
To receive the assistance from our technical support experts, submit a ticket via email 
directly from your system. The email will automatically capture your particular product 
and system information, but you MUST include the following within the body of the 
email:
1. Tell us exactly what the difficulty is.

2. Attach any files or screen captures to help us understand the issue.
3. Include ALL contact information including an alternate email address, your cell 

phone and desk phone. Our support team does not have regular access to your 
sales file.

4. Include a subject line descriptive of the problem.
5. Make sure that you use your actual mail client.
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The Drafting Assistant
The Drafting Assistant is the feature that makes all Ashlar-Vellum Designer Elements 
programs unique among design and drafting software products. The Drafting Assistant 
thinks like a drafter. It automatically knows where construction lines are typically wanted 
and displays them temporarily when they are necessary. 
The Drafting Assistant also makes it easy to select existing points for construction by 
displaying information about the pointer’s location in the drawing area. If a Drafting 
Assistant notation displays when clicked, the construction snaps onto the geometry 
precisely, without requiring finely tuned eye-hand coordination or tedious selection of 
special modifiers, modes, or other specialized construction tools.
The following topics are covered in this chapter:
• Snapping onto Geometry
• The Drafting Assistant page of Preferences includes the following options:
• Permanent Stroke Construction Lines
• Drafting Assistant and Display

Snapping onto Geometry
When the pointer is in the drawing area, it 
has a snap point function. The snap point 
locks onto specific points on existing 
objects as the pointer is moved near them.
The Drafting Assistant tells when the snap 
point is on an object.
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The Drafting Assistant displays 
information about the location of the snap 
point. This information appears either 
beside the pointer or next to the object 
itself. 

The Drafting Assistant indicates when a 
snap point locks onto the following object 
points.

Center

The center of an arc or circle is indicated here. Move the 
pointer across the arc or circle to display on for the arc 
or circle, then move the pointer near the center to display the 
center point notation.

Endpoint

This shows the endpoint of lines, arcs, circles, ellipses 
and splines. 

Midpoint

The midpoint of lines, arcs, circles, ellipses and splines is 
indicated this way.

Intersection

This shows the intersection of two curves including geometry, 
construction lines and Drafting Assistant alignments.

Quadrant

These designate the quadrant points on an arc or circle 
displayed at 3 o’clock, 6 o’clock, 9 o’clock and 12 o’clock. 

Vertex

The vertices of an ellipse, spline, or dimension point are shown 
this way.
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Using Tangents and Perpendiculars
Clicking a point on an arc or circle and dragging the pointer away at about a 45° angle, 
the Drafting Assistant locks onto the tangent. Dragging away at a 90° angle the Drafting 
Assistant locks onto a perpendicular.

Holding down the mouse button, the line remains tangent or perpendicular while the 
ending point is dragged around the object. 
This is a useful feature if, for example, it is 
necessary to create a line from and tangent to 
an existing circle to the tangent point of another 
circle.

Once a line is tangent to the circle, it can be 
dragged to the tangent point on the other circle, 
with the tangency maintained at both ends.

The Drafting Assistant locks onto a tangent or 
perpendicular only when the Drafting Assistant 
starts from the on notation. It is not possible to begin from a specific point, such as 
endpoint, quadrant or vertex.

Drafting Assistant Axis Locking
The Drafting Assistant supports locking to the X, Y or Z axis. To lock to one of these axis 
hold down the corresponding key on the keyboard (X, Y or Z). The Drafting Assistant will 
only show alignment points in that axis.

Tangent

Perpendicular
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Customizing the Drafting Assistant
When first initializing the program, the Drafting Assistant automatically activates. 
Customize the Drafting Assistant by using the Snaps command or changing the 
preferences in the Snap page of the Preferences dialog box.

Snaps
This option box, found in the Window menu, displays the Snaps 
dialog box and activates and deactivates the different snap modes 
of the Drafting Assistant.

When an option is activated the Drafting Assistant operates in the 
following manner as a pointer moves across geometry:

Snaps Enable This enables the Drafting Assistant. Snaps that are checked 
display. Deselecting this option turns the Drafting Assistant off.

Endpoints Displays object endpoints.

Midpoints Displays object midpoints.

Curve Intersections Displays intersections between objects display.

Curve On Displays the point nearest to the pointer with an on notation.

XYZ Align Displays alignments along the x, y and z axes.

Tangents/
Perpendiculars

Displays tangents and perpendiculars for the geometry.

Face On Displays a face notation for solid objects. 

Edge On Displays all notations normally associated with curves, such as 
endpoint, midpoint, and vertex for solid objects.

Work Plane Creates a curve using referencing points on 3D objects but 
confined to the current 2D work plane. This snap works best 
when the current work plane is being viewed. See the example 
here for clarification.

Example: To reference points from three 
objects, display the Work Plane icon for the 
Front plane.

Change the view to front and draw a curve 
using the points from the objects with the 
help of the Drafting Assistant.



Snapping onto Geometry

3-5

Each of these snap options have shortcut equivalents. See Shortcuts for more 
information on using Shortcuts.
To turn off an option, click the check box to remove the mark next to the option name. By 
default, Solid Face Projections, Project to Work Plane, To Grid and Plane Only are 
turned off.

Drafting Assistant Preferences
Choosing File>Preferences>Drafting Assistant, the following dialog box appears.

The Drafting Assistant page of Preferences includes the following options: 

Change the view to see the curve aligned 
with the current work plane. The dotted 
lines show that the curve aligns with the 
object points.

To Grid Snaps to grid alignment points when using the grid.

Plane Only Shows snap points for objects only on the current work plane.

Hit Radius This setting determines the detection distance in pixels. When 
the pointer is within the specified Hit Radius, the Drafting 
Assistant notations are displayed and the object is selected 
when the mouse is clicked. The default Hit Radius is 12 pixels.

If it is complicated to specify locations that are close together 
because the Drafting Assistant snaps to an existing control 
point, do any of the following:

•Decrease the Hit Radius. 

•Zoom in so more pixels separate the existing point and the 
point to select.

•Lock on a point by pressing the mouse button and typing the 
letter that represents the point (m for midpoint, for example). 
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Drafting Assistant Construction Lines
In addition to snapping onto geometry, the Drafting Assistant displays dynamic 
construction lines. The three types of construction lines used most frequently—vertical, 
horizontal and 45° angle lines—display automatically during construction. These 
construction lines appear temporarily to help align geometry. Once a point is set, the 
Drafting Assistant construction line disappears so that the drawing is not cluttered with 
extraneous lines.
Dynamic construction lines extend automatically from the last point created. To activate 
other points so the Drafting Assistant displays construction lines relative to them, simply 
move the pointer over the geometry to activate or “wake-up” its control points, then 
move away horizontally or vertically.
Of course, there is also the option to create permanent construction lines and other 
shapes, as described later in this chapter.

Setting the Hit Radius to zero disables the single click 
selection of the Selection tool. (Dragging a selection fence and 
double-clicking to select all objects will still work.) Instead, 
consider using the Select Mask in the Window menu to specify 
that some objects cannot be selected.

Alignment Angles These angles define the dynamic construction lines that the 
Drafting Assistant automatically uses. To change the 
orientation of the drawing, change these specifications. 
For example, set these angles to 30°, 90° and 150° for an 
isometric drawing. The defaults are 0° (horizontal) and 90° 
(vertical). Use a semicolon to separate the values.

To display a dynamic construction line through a point, move 
the pointer to the point to activate it (a diamond appears). 
Construction lines automatically display through the active 
point. It is possible to have as many as eight active points. 
Activating the ninth point, the first one in the series 
deactivates.

Creation Angles These lines are used by the Drafting Assistant only when 
creating geometry and they are not part of the list of lines 
generated from the eight active points. The defaults are 45° 
and -45°. Use a semicolon to separate the values. 

% Point This shows the divisions of a line for Drafting Assistant 
notations. The default is 0.0.

For example, to divide a line into quarters, enter 25. This 
instructs the Drafting Assistant to show when the pointer is 
25% of the distance along a line.
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Using the Drafting Assistant’s Construction Lines 
After indicating the first endpoint of a line, move the pointer 
horizontally, vertically, or in a 45° direction, and the dynamic 
construction line appears. The figure here illustrates a 45° construction 
line relative to the endpoint of an existing line.

Displaying Dynamic Construction Lines while Constructing Geometry
1. Click a point to begin new geometry.

2. Move the pointer away from the point horizontally, vertically, or at a 45° angle. 
3. While the construction line is visible and the Drafting Assistant displays on, click the 

next point. 
The point is placed exactly on the construction line, even though the pointer wasn’t 
exactly on that line while clicking. The dynamic construction line disappears. 

Tech Note: It is possible to have as many as eight active points; activating the
ninth point in a series deactivates the first point.

Displaying Dynamic Construction Lines with Existing Geometry 
1. On selected geometry, without pressing the mouse button, move the pointer over an 

existing point. 

The point notation (endpoint or midpoint, for example) shows that the point is active. 
2. Move the pointer horizontally or vertically. 

A construction line appears through the point. 
3. While the construction line is visible and the Drafting Assistant displays on, click the 

desired point in the construction.
The point is placed exactly on the construction line, even though the pointer wasn’t 
exactly on that line while clicking. The dynamic construction line disappears.

The figure here illustrates intersecting construction lines drawn through two existing, 
active points.

Once the Drafting Assistant become familiar it streamlines design and drafting tasks.
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Setting New Drafting Assistant Construction Angles
Add to or change the angles that the Drafting Assistant uses for dynamic construction 
lines by choosing File>Preferences>Drafting Assistant. Enter the new construction 
line angles, separated by semicolons, in the Alignment and Creation Angles fields.

Locking the Drafting Assistant to the Work Plane
By holding down the Shift key, the Drafting Assistant locks to the x, y and z axes of the 
work plane. Only align:x, align:y and align:z construction lines appear.

Permanent Stroke Construction Lines
In addition to the Drafting Assistant’s dynamic construction lines, it is possible to create 
construction lines that display until they are hidden or removed. 
Stroke construction lines are lines created with the mouse. Hold down the SHIFT+CTRL 
keys (Windows) or the  key (Macintosh) and drag the mouse horizontally or vertically. 
Working in the drawing area, the Drafting Assistant helps to place the stroke precisely.
Construction lines automatically appear on the Construction layer, not the work layer of 
the drawing. Having inadvertently deleted the Construction layer, it recreates the next 
time a construction line is created. 
Hide the construction layer to view or print the drawing without construction lines. 
Construction lines can be selected in the usual manner from any layer; the Construction 
layer doesn’t have to be the work layer. (More information on layers can be found in 
Layers). 
To get rid of all construction lines, choose Layout>Delete Constructions. Everything on 
the construction layer deletes and not just the construction lines.
Holding down the SHIFT+CTRL keys (Windows) or the 
 key (Macintosh) changes the mouse pointer to the 
Stroke pointer ().

Tip: Use strokes to create construction lines in the process of using a tool. 
Windows users: When both the CTRL and SHIFT keys are used by a tool,
Stroke construction lines cannot be created while in the tool.

Using Stroke Construction Lines
Construction lines are as long as the dimensions of the viewing area of the screen or the 
printing region (as designated in Print Setup (Windows) or Page Setup (Macintosh) in 
the File menu), whichever is larger.
For example, using the Connected Lines tool, create a construction line that extends 
through the center of a circle:

Drag Result

Vertically A vertical construction line appears through the first point of 
the stroke.

Horizontally A horizontal construction line appears through the first point of 
the stroke. 
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1. Hold down the SHIFT+CTRL keys (Windows) or the  key (Macintosh). The pointer 
becomes the stroke pointer ().

2. Move the pointer near the center of the circle.
The Drafting Assistant snaps onto the center point.

3. Drag the mouse vertically or horizontally away from the midpoint.
The construction line appears through the center in the process of creating connected 
lines after releasing the SHIFT+CTRL keys (Windows) or the  key (Macintosh). 

The Construction Command
Stroke construction lines are useful for creating lines through existing points. To create a 
construction line at a location other than an existing point or at a particular angle, use 
the Construction command.

Using the Construction Command - CTRL+K (Windows); +K (Macintosh)
This command in the Layout menu creates a 
construction line on the construction layer of the 
current document.
Specify the angle of the construction line or the 
offset from a reference point defined by the X, Y 
coordinates. The asterisk shows that the values 
can be specified by clicking or dragging the mouse; 
values can also be typed into the fields.
The distance dragged will always be entered in the 
Offset data field as a positive value, regardless of 
the direction dragged.
Only one set of values can be entered for a new construction line at a time. Multiple 
angles or offsets cannot be entered to create multiple construction lines.

Tip: Multiple angles or offsets cannot be entered to create multiple
construction lines.

Specifying the Construction Line Angle with the Mouse
1. Click the Angle field.

2. Drag a vector in the drawing area. 
The angle of the vector line appears in the Angle field.

Specifying the Construction Line Offset with the Mouse
1. Click the Offset field.

2. Drag the offset distance in the drawing area. 
The dragged distance appears in the Offset field. Be aware that 
the offset is determined by the angle of the construction line as 
shown.

Specifying X, Y Coordinates with the Mouse
The coordinates of the last specified point appear in the X and Y 
fields, but they can be changed by doing the following:
1. Click the X field.

2. Enter new coordinates
or
In the drawing area, click the location of the point through which the construction line 
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should pass. The coordinates are entered automatically for both the X and Y fields.
Creating Parallel Construction Lines
It is possible to create parallel construction lines by creating one construction line using 
this field, then creating new lines with the Parallel Line tool.

Creating Construction Geometry
Non-construction geometry is placed on the work layer. It is possible to create 
temporary construction geometry, such as arcs or circles, by making the construction 
layer the work layer, creating the geometry and switching to another layer to continue 
the work. 

Tech Note: When creating construction geometry on the construction layer,
change layers before creating the actual geometry. Choose Layout>Delete
Constructions to delete everything on the construction layer and not just
construction lines. Choose Undo to restore the geometry and move it to
another layer.

Creating Construction Geometry 
1. In the Layout menu, choose Layer Manager. (The dialog box will say Design 

Explorer because two boxes [Design Explorer and Layer Manager] are combined.)

2. Click in the work 
layer column 
just to the left of 
Construction. 
(Move the pen-
cil to that layer.)

3. Click the Close 
button in the 
upper right cor-
ner of the win-
dow. The Layer 
Manager closes 
and the Con-
struction layer is 
now the work 
layer. The Work 
Layer Indicator 
at the bottom left of the screen shows the current layer.

4. Create the geometry for construction. 
5. When the construction geometry is complete, make another layer the work layer by 

changing the layer in the Layer Manager or the Work Layer Indicator.
6. Continue the work. 
Once the construction geometry is no longer necessary, choose Layout>Delete 
Constructions to remove all geometry on the construction layer. 
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Removing Construction Lines
To delete one or two of the construction lines, select the lines to remove, and then 
choose the BACKSPACE (Windows) or DELETE (Macintosh) key. All the construction 
lines, created by choosing Layout>Delete Constructions, can be removed.

Delete Constructions
This command in the Layout menu deletes all construction lines and any geometry on 
the construction layer. The Drafting Assistant’s dynamic construction lines appear only 
temporarily and are not affected by this command. Any geometry on the construction 
layer (regardless of the pen style used) deletes by this command.
To retrieve deleted construction geometry use the Undo command.

Drafting Assistant and Display
The Drafting Assistant accurately creates and places objects. When creating an object 
that shares a common control point with another object, both control points are in the 
same X, Y, Z location.
Zooming in on that specific control point, depending on the resolution capabilities of the 
monitor, it may appear that the objects are not connected at the control point. This is a 
limitation of the hardware. The Drafting Assistant has correctly located the geometry.
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Selecting Objects
Once objects are constructed, it is possible to change them. To make changes, select 
the desired object. In Cobalt, Xenon and Argon, the step at which the object is selected, 
depends on the operation. Modifying an object is always a two-step process.

Modifying with a Tool
1. Select the tool.

2. Select the object to be modified.
For example, use the Divide tool to divide a curve into multiple pieces.

Modifying with a Menu Command
1. Select the object.

2. Specify the action for the selected object. 
For example, select a circle and then change the pen pattern to Center to indicate a 
bolt-hole circle. 
The following topics are covered: 
• Objects 
• Indicating Selection & Preferences 
• Selection Process
• Deep Select Tool
• Eye Dropper Tool

Objects
A single piece of geometry is an object. 

Several objects that have been grouped with the Group command are also an object 
and are selected when any member in that group is clicked.

Referral: Selecting points is described later in this chapter.
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A point is an object, too. Every type of geometry contains one or more points, 
sometimes called control points. A line has two control points, one at the beginning and 
one at the end of the line. By selecting an object and choosing Edit>Show Points, the 
points are visible on the selected object. When selecting a point without selecting the 
geometry it defines, Cobalt, Xenon or Argon treats the point as an object. 

Indicating Selection & Preferences 
When selecting an object, its appearance shows that it is selected in a specific color. 
The default color chosen is red. It is possible to designate another color as well as 
choose other settings for selecting objects by choosing File>Preferences>Select. The 
following selection page is displayed.

Pick Box
The pick box is an invisible box centered 
about the pointer tip. The default size of 
the box is 8 x 8 pixels. The pick box 
requires the pointer to be moved over 
the desired object only within the target 
area. When the mouse button is clicked 
on objects that are within the bounds of 
the pick box are selected. See the 
graphic below.

Select Fence
The selection fence is a rubber banding selection window. Choose between one of two 
settings: Entire Object Extents or Partial Object Extents.
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Selection Color
It is possible to choose any color for the selection color. In the Selected Entities Color 
section click New and the standard color display appears. Choose the color, click OK 
and return to the Select page of the Preferences display. Once the selection color 
changes, all current and future selected items appear in the new color.
Do not use black for indicating selection because black is the default color for all curves.

Wire Weight
When selecting a curve the line weight of 
the curve will increase in accordance with 
the setting in the drop down box. The line 
weight is specified in pixels. Choose 
between 0 (does not increase the weight of 
the selected curve) and 4 (increases the 
weight of the selected object to four 
pixels).

Entire Object Extents Only objects that lie completely within the pick window are 
selected. In the graphic below, only the circle is selected.

Partial Object Extents Any object that lies even partially within the selection fence 
window is selected. In the graphic above, both the circle and 
the spline are selected.



Selecting Objects

4-4

Transparency
When selecting a surface or a solid object, the surface or solid becomes transparent. 
The Transparency slider controls how transparent the object becomes. A value of 0 
means no transparency is added to the selected object. A value of 100 means the object 
will be fully transparent showing only the edges.

Selection Process
Selecting an object does not affect the properties of the object. A selected object 
highlights, but this highlighting goes away once the object is deselected. Select an 
object by using either the Selection tool or by the hollow selection tool that appears 
temporarily when using one of the editing tools.
Use the Selection tool to select both objects and points. While the selection process for 
objects and points is quite similar, there is enough difference to merit separate attention.

Selecting Objects with the Selection Tool
To select an object, begin by clicking the Selection tool in the main tool palette. It is 
possible to select one object, SHIFT-click more than one object, or drag a selection 
fence around a group of objects. 

Selection Tool

The Selection tool in the main tool palette 
selects one or more objects (curves, solid 
edges, faces, points, etc.) in the drawing 
area. The graphic here shows the selection 
of a solid face.
Use the Selection tool to edit previously 
created geometry. Click on the object to be 
edited and use the Status Line to edit the 
parameters of the object.
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Tip: Having trouble selecting objects when displaying many objects? Try
using the Selection Mask, a selection fence, or rotate the view slightly and try
again.

Selecting a Single Object
1. Click the Selection tool in the tool palette. The Message Line reads: 

Selection: Select [Shift=Extend, Ctrl (Windows) or Option (Macintosh) = 
Copy].

2. Move the pointer to an object and click. The object is selected, and any 
previously selected objects are deselected.

Referral: The Pick Objects command in the Planes menu is for setting the
work plane not for selecting objects on which to perform an operation. See
Planes for more information.

Double-selecting a Single Object

Double-click on an object to display that object’s characteristics. This brings up the Edit 
Objects dialog box. Make changes to the object through this box. See “Edit Objects” on 
page 26. for more information.

Selecting Multiple Objects by SHIFT-clicking
1. Choose the Selection tool in the tool palette.

2. Move the pointer to an object and click.
3. Press down the SHIFT key.
4. While holding down the SHIFT key, click other objects to be selected.
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The clicked objects are selected. If one of the selected objects is clicked again, it 
deselects.

5. Release the SHIFT key.
Selecting Multiple Objects by Dragging
To select more than one object, drag a selection fence around the objects.
1. Click the Selection tool in the tool palette.

2. Drag a selection fence around the objects to select.
To select most of the objects within an area, drag a selection fence to select all the 
objects, and then deselect the objects that do not need to be selected by holding down 
the SHIFT key and clicking them.

Selecting One or More Objects When They Overlap (Ambiguity Popup Box)
Often with more complex drawings, geometry overlaps to such an extent that it's difficult 
to select one object without zooming very close to it. This Designer Elements program 
has made this easier with the Ambiguity Popup box. When attempting to select one 
object among many objects close together, the popup menu appears.

By moving the pointer over an object name in the popup, the object it represents 
highlights in the selection color but is not yet selected. Click on the object name in the 
popup to accept that choice. Move the pointer beyond the extents of the popup window, 
and the window will automatically move, showing what is underneath the window.
The Ambiguity box lists faces for such tools that require the selection of a face (draft, 
shell, fillet and extrude).
There are two options for closing the Ambiguity box without selecting an object:
• Click the Close button or box in the title bar
• Click outside the popup box

Tip: Specify the selection of only certain objects, layers, or colors by setting a
selection mask with the Select Mask command. 
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Selecting All Objects
There are two ways to select everything in the document.
• Select the Selection tool and choose Edit>Select All (CTRL+A (Windows) or +A 

(Macintosh).
• Double-click the Selection tool.

Tip: Select All is useful to make a global change in a drawing, such as
changing the width of all lines.

Editing Common Properties on Multiple Objects 
The common properties of multiple objects can be 
modified via the right-click menu. The ambiguity dialog box 
appears if more then one item is clicked. Choose the All 
Selected option from the Pick Object dialog and the 
properties modified in the right-click pop-up menu apply to 
all the selected objects. 

Copying with the Selection Tool
The Selection tool can be used to copy wireframe, surface 
and solid objects. Be careful when copying surfaces and 
solids. By holding down the CTRL (Windows) or OPTION 
(Macintosh) key and dragging a surface or solid an 
instance of the original object is created. All changes made to the original object are 
automatically reflected in the instance (Cobalt and Xenon only). To not create an 
instance, select the original object, choose Edit>Copy and then Edit>Paste. 

Selecting Points 
Selecting points differs from selecting objects because points are not always visible. 
Being able to select points is useful in two situations: stretching selected geometry 
(described later in this chapter) and control point selection for transformations.

Show/Hide Points Command
This command in the Edit menu toggles the display of the control points (endpoints, 
midpoints, center points and vertex points) for selected objects. When points are 
displayed, select a point by clicking it. If points are not displayed, select a point by 
dragging a selection fence around the location of the point. 
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To show points for an individual selection, choose Window>Edit Objects and change 
the control points setting from Hidden to Visible.

Selecting and dragging a line, the line and the endpoints move. By selecting and 
dragging only an endpoint of the line, the endpoint moves and the line length changes 
while the other endpoint of the line remains fixed.
The appearance of a selected point is not affected by the zoom scale or the line width of 
the geometry.

Displaying Points

1. Select the geometry.

2. Choose Edit>Show/Hide Points to toggle the display of points on and off.
To turn off the point display once the points of an object are showing, select the object 
again and choose either Edit> Hide Points or the Control Points option in the Edit 
Objects dialog box. The graphic illustrates some curves with their associated points.

Showing and Hiding Points with Stroke
When holding down the SHIFT+CTRL keys (Windows) or the  key (Macintosh) and 
clicking an object, the display of the object’s points toggles on or off. If the points are 
hidden when clicking the object, the points display.

Selecting Points
It is possible to select a control point whether the points are visible or not. To select 
points:
1. Chose the Selection tool.

2. Drag a selection fence around the loca-
tion of the point.
The selected point displays as a square.
When a point is selected, the entire curve 
highlights, however the edits will affect 
only the selected point.
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Selectable Points Command
This command in the Edit menu selects points that aren't displayed. When Selectable 
Points is not set, points cannot be selected by dragging a fence.
If points are displayed, click the point to select it. If points are not displayed, to select a 
point, drag a selection fence around it. The following example illustrates the use of 
Selectable Points.

Selecting Objects Using Other Tools
When using editing tools, such as Chamfer or Trim, it is necessary to select the 
objects on which to perform the operation. As was mentioned earlier in the 
chapter, select the tool first and then the objects.
Select an editing tool and move the pointer into the drawing area, it becomes a 
hollow selection arrow.
Having finished selecting, the pointer becomes a general tool cursor.
This outline arrow must not be confused with the Selection tool.

Selecting Objects with Commands
Cobalt, Xenon and Argon provide three selection commands, Select All, Select Mask 
and Select Chain.

Select All 
CTRL+A (Windows); +A (Macintosh)
When the Selection tool is chosen, this command in the Edit menu selects all objects 
except those on a hidden layer or excluded by the Selection Mask. Double-click the 
Selection tool to select all objects.

Selection Mask Command
This command in the Window menu limits selection by object type, layer and color. Only 
objects that are highlighted in the dialog box are selected. The object type list includes 
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such things as points, lines, splines, mesh, surfaces, solids, text, dimensions, images, 
symbols, groups, lights, decals, draw view, cross hatch, etc.
For example, if circles are not highlighted when choosing Select All, everything but the 
circles is selected. In this way, select such combinations as only blue splines or only red 
objects on a particular layer. 

Using the Selection Mask
1. Choose Window>Selection Mask.

The Selection Mask dialog box appears.

The highlighted items respond to all selection methods and can be detected by the 
Drafting Assistant.

2. Click the items to select so they are highlighted. 
While the dialog box is visible, select, create and edit geometry. Move the dialog box if it 
covers geometry you work on. The Selection Mask resets itself to the default setting of 
Select All after the box is closed. 
When an item in the dialog box is not highlighted, the Drafting Assistant and all the tools 
cannot detect it, even though it is visible on the screen.
The Selection Mask is useful in a complex drawing for changing particular groups 
of objects. Use this feature to export some but not all geometry.
If layers are added when the Selection Mask dialog box is displayed, the Selection Mask 
dialog box automatically updates.

Selecting or Deselecting Listed Items
• To select one item - Windows: With all items selected, click on the item and the rest of 

the list will be deselected. Macintosh: Press the Clear All button and click on the 
desired item.

• To deselect a list quickly, press the Clear All button.
• To select a contiguous group of items, click on the item at the top or bottom of the 

desired group list and drag up or down to select the other items in the group.
• To select or deselect non-contiguous items, hold down the CTRL (Windows) or the  

key (Macintosh) and click on the items.
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Select Chain Command
This command selects curves that are connected to the selected object. To use the 
Select Chain command:
1. Select the beginning of a curve as shown by the arrow in the left graphic below.

2. Choose Edit>Select Chain.
3. All objects connected to the start or end are selected, as in the right graphic below.

Deselecting
To deselect an object, click anywhere in the drawing area where there is no object, or 
click any of the creation tools in the tool palette.
To deselect an object that was selected in a multiple selection operation, while the 
objects are still selected, hold down the SHIFT key and click the objects to deselect.

Deep Select Tool

This tool applies different colors and materials to each face of an object. 
To apply a color to a face, use the Deep Select tool from the Selection tool palette, 
choose the face and designate the color from the Pen menu.
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The Edit Object window shows only the color of the overall object without the changes 
made by the Deep Select. 
Some materials adopt the color of the object faces if the Use Object Color check box is 
checked in the Render Material Settings dialog box.

Picture 1: An object with different colors on the faces.
Pictures 2 and 3: Materials adopt the color of the object faces with the Object Color 
option checked.
To apply a material to a face, use the Deep Select tool from the Selection tool palette, 
choose the face and designate the material from the Window>Render Library menu. 

The material for each face appears in the Design Explorer as a ball  and can be 
edited.
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Materials per Face are also editable through the Edit Objects box. Turn on or off the 
material under the Material Faces tab.

Using the Deep Select Tool to Apply a Color
1. Select the Deep Select tool from the Selection tools palette. The Message Line 

reads: Deep Select: Pick solid faces [Shift = Extend].

2. Select the face to be changed.
3. Go to Pen>Color and choose the color desired.

The selected face changes the color.
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Using the Deep Select Tool to Apply a Material
1. Select Deep Select tool, from the Selection tools palette. The Message Line reads: 

Deep Select: Pick solid faces [Shift = Extend].

2. Choose the face and designate the material from the Window>Render Library 
menu. 

3. Right-click on the material and choose Apply to Solid Face(s).

4. Alternatively, choose the material from the Render Library menu, right-click it and 
select Apply to Solid Face(s) from the context menu. Then choose the face of the 
solid. The material is applied. 

5. Render the object to see the changes.

Eye Dropper Tool

This tool copies object characteristics, such as line font, color, pattern, arrow at start and 
end, and render materials, from one object to another.
Specify which object characteristic to copy using the Eye 
Dropper Filter dialog box. To display this box, select the tool 
then press the CTRL (Windows) or OPTION (Macintosh) key.
The listed characteristics include: line font, color, layer and 
render material.
This tool does not affect the resolution, dimensions, iso lines or 
the size and shape of the object. In the graphic below, the left block characteristics were 
applied to the cylinder without materials (middle graphic). The right graphic shows the 
cylinder with the same render material as the block after using this tool.
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Using the Eye Dropper Tool
1. Select the Eye Dropper tool from the Selection tools palette. The Message Line 

reads: Eye Dropper: Select objects to copy from. [Ctrl = Filter (Windows) or Option = 
Filter (Macintosh)].

2. Select the object with the characteristics to be copied.
The Message Line now reads, Eye Dropper: Select object to modify. [SHIFT = 
Extend].

3. If you do not want all object characteristics copied, press the CTRL (Windows) or 
OPTION (Macintosh) key to display the Eye Dropper Filter dialog box. Otherwise, 
skip to step 5.

4. Deselect those items in the dialog box that do not need to be copied.
5. Select the objects to receive the characteristics.

The object’s characteristics change to those of the referenced object.
It is also possible to select the object before selecting the tool. Doing so, select the 
reference entity and the object automatically changes. If the change involves applying a 
material, render the drawing to confirm the change.

There are no Status Line entries.
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Editing Objects
This Designer Elements program provides a variety of editing commands to edit 
geometry quickly and easily. Some commands deal with the placement of the geometry 
like Cut and Align. Some commands change the appearance of the object like Change 
Resolution. Still others change the geometry like Change Object Type and Edit Objects.
The chapter includes these sections:
• Basic Editing Commands
• Advanced Editing Commands
• Object Commands

Basic Editing Commands
These commands provide some standard editing features like: Cut, Paste, Undo and 
Redo.

Cut 
CTRL+X (Windows); +X (Macintosh)
This command in the Edit menu removes the selected object(s) and places them on the 
Clipboard. Each selection being cut or copied to the Clipboard replaces the previous 
Clipboard contents.

Cutting Objects
1. Select the object to cut.

2. Choose Edit>Cut.
Once a selection is cut, it can be pasted. Use Cut and Paste to move geometry or text 
around the document or from one document to another. The cut selection can even be 
pasted onto a document in a different application.

Moving Geometry with the Cut Command
1. Select the object(s) to move.

2. Choose Edit>Cut.
3. Display the location where the selection will appear in the drawing area, scrolling if 

necessary.
4. Choose Edit>Paste. 
The object appears in the center of the drawing area on the original layer on which it 
was created or onto the work layer if it’s from a different application. The object 
is selected so it can be moved, if necessary.
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Copy 
CTRL+C (Windows); +C (Macintosh)
This command in the Edit menu places a copy of the selection onto the Clipboard 
without deleting the original selection. The copy can be pasted elsewhere in the current 
document or into a different document. The copied selection can be even pasted into a 
document created with a different application.

Tech Note: Do not use Copy and Paste to create an instance of a solid. By
doing so the parent/child relationship is broken. (Cobalt and Xenon only) Use
the Move tool instead. For more information see Move Tool

Copying Objects
1. Select the object(s) to be copied.

2. Choose Edit>Copy.
The selection goes on the Clipboard and it remains in the current document.

Copy Pict/Copy Bitmap
Use the Copy Bitmap command to specify a region to copy as a Raster image. The 
image can be then pasted back into the same document, to another document or to a 
different application.

Paste 
CTRL+V (Windows); +V (Macintosh)
This command in the Edit menu pastes a copy of the Clipboard contents onto the center 
of the drawing area. The Clipboard contents are not changed when the Paste command 
is used. 
The selection can also be pasted into another document or into a document created with 
another application.
To create an even distribution of geometry, use one of the Duplicate tools which are 
located in the Transformation tools palette.

Tech Note: The Copy and Paste commands cannot be used to copy entries
in data fields like in the Status Line and dialog boxes. For Windows, press the
right mouse button and use the commands in the menu. For Macintosh, use
z+C to copy and z+V to paste.

Rules:
1. If the object was cut or copied from a Designer Elements program document, when 

it is pasted into another Designer Elements program document it goes on the work 
layer regardless of the layer from which it was cut or copied. A pasted selection 
retains its original attributes.

2. Objects cut or copied from non-Ashlar-Vellum documents are pasted onto the work 
layer.
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The Clipboard
The Cut and Copy commands place a copy of the selected object on the Clipboard. The 
Clipboard is a buffer—a temporary storage place that holds the last cut or copied 
selection. The contents of the Clipboard are objects, not bitmaps (unless Copy Bitmap is 
chosen).

Erasing/Deleting Geometry
This program provides two methods for erasing objects:
• Select the object(s) then press the BACKSPACE (Windows) or DELETE (Macintosh) 

key. (It is possible to retrieve what is deleted with the Undo command.)
• Select the object(s), then choose Edit>Cut. (It is possible to retrieve what is cut by 

using the Paste command, as long as nothing else has been cut or copied.)
Trying to delete an object that is the parent in a parent/child relationship, this warning 
message will appear (Cobalt and Xenon only):

When deleting objects in this program the data is still retained in the file until it is deleted 
again. If objects are deleted before closing a file, perform the operation again to ensure 
that the data is removed.

Undo 
CTRL+Z (Windows); +Z (Macintosh)
This command in the Edit menu reverses the last action. An infinite number of times can 
be undone in this Designer Elements program. When choosing Undo, the last action 
taken is displayed next to the command.
It is possible to Undo actions that create and edit geometry and text but not actions that 
do not change the contents of the drawing such as resizing the window or quitting.
When using a tool which involves a multi-step process, such as creating a 3-entity Fillet, 
choosing Undo reverts to the beginning of the process. Some activities can be 
terminated by pressing the ESC key.

Redo
This command in the Edit menu reverses the Undo command. It is possible to redo an 
infinite number of times in this Designer Elements program. When choosing Redo, the 
last action taken is displayed next to the command.
It is possible to Redo actions that create and edit geometry and text but not actions that 
do not change the contents of the drawing such as resizing the window or quitting.
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Advanced Editing Commands
These commands provide more specific editing features/functions involving location, 
selection and display.

Change Resolution
This command, located in the Edit menu or in the right-click menu, changes the display 
resolution of curves, surfaces and solids.
A higher resolution means that this program uses more line segments to display curves 
on the screen so they look smoother but take longer to draw.
For surfaces and solids a higher resolution also means that the program uses more 
facets to display the objects. It is possible to control the number of iso lines used to 
display surfaces with this command.
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The dialog box contains the following options:

Resolution Contains radio buttons for five resolution types Course, 
Medium, Fine, Very Fine and Super Fine.

Iso Lines Contains the data fields for U and V isopram (iso) lines and the 
Force U=V check box.

The U and V data fields set the number of iso lines drawn for a 
surface. Iso lines are constant parameter curves that lie on a 
surface typically defined in parameter space. The parameter 
space coordinate system uses U and V coordinates where U = 
horizontal and V = vertical. A zero (0) in both fields turns off Iso 
lines. The appropriate U/V values may enhance the visual 
appearance of the surface at the expense of drawing speed. 
The letters, U and V are industry standard space coordinates.

The Force U=V check box automatically sets equal number of 
U and V lines. Entering a new value in one automatically 
changes the other iso line value.

Show Silhouettes Controls whether the program draws the silhouette edges of 
objects. Silhouette edges are view-dependent and can cause a 
significant reduction in drawing speed. A check in the box turns 
on the silhouette.

Precise Facets Enlarges the number of the segments of a solid to make the 
surface look smoother.

Even Distribution Enlarges the number of the segments of a curve to make the 
surface look smoother.

OK Closes the dialog box and saves the new settings to make the 
surface look smoother.

Cancel Closes the dialog box without saving the changes.
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Using the Change Resolution Command
1. Select the object to change resolution.

2. Choose Edit>Change Resolution. The Object Resolution dialog box appears.
3. Select the desired resolution.
4. Click OK to save the resolution and close the dialog box.

or:
1. Select the object to change resolution.

2. Right-click the object. Choose Resolu-
tion option from the context menu.

3. Select the desired resolution.
The object resolution changes.

Change Layer
This command in the Edit menu moves selected objects to a different layer and creates 
new layers.

Using the Change Layer Command
1. Select the object to move to a different layer.

2. Choose Edit>Change Layer. The following Change Layer dialog box appears:

Click on the pull-down menu and select the layer to which to move the selected 
object. If the layer doesn't exist, click the Create New Layer button. A new layer 
appears in the layer field. Enter a new name if necessary.
Click OK to close the dialog box. The selected object is now placed on the selected 
layer.
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Grouping Objects
A group is a collection of objects or 
shortcuts that this Designer Elements 
program treats as one unit. When 
moving a group, all members of the 
group move as a single unit. Deleting a 
group, all members are deleted.

Group Command
This command located in the Layout 
menu includes a submenu with these 
commands: Group, Ungroup, Lock and 
Unlock.

Using the Group Command
1. Select the objects to be grouped.

2. Select Layout>Group>Group.
Creating temporary groups is useful when moving multiple objects. Drag a selection 
fence around several objects to treat them as a single unit while they are selected.
This Designer Elements program supports nested groups. It is possible to create a 
group and then include it in a second group with other objects or groups.
There are two options to add new objects to an existing group. By selecting the group 
and the new object, then choosing the Group command, a group within a group is 
created. To make all of the objects be in a single group, follow these directions:
1. Select the group.

2. Choose Layout>Group>Ungroup. The geometry is ungrouped and the individual 
objects remain selected.

3. Hold down the SHIFT key and select the geometry to add to the group.
4. Choose Layout>Group>Group.
Follow a similar procedure to remove members from a group.

Grouping Rules
• Grouped objects cannot be extruded, revolved or modified.
• If the color of a group is changed and then the objects are ungrouped, all individual 

objects retain the new color.
• When grouping objects the 

Group command now ignores 
objects that only have a point 
selected. In the graphic below, 
the three top objects are 
completely selected and only 
one control point for the bottom 
block. When using the 
command the control point is 
ignored. This is helpful when 
there are many objects located 
close to each other making it 
difficult to select the desired 
objects without selecting 
portions of others.

• When grouping objects on different layers, the group layer is the current work layer. If 
the objects are ungrouped, however, the objects return to their original layers.
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Ungroup Command
The Ungroup command separates selected grouped objects or short cuts into their 
individual components. If the group contains objects that were originally on different 
layers than the group layer, when ungrouped, the objects return to their original layers.

Using the Ungroup Command
1. Select the group.

2. Choose Layout>Group>Ungroup.

Lock Command
It is possible to lock any object or shortcut. Once it is locked it cannot be modified, 
selected, translated, rotated or the position or shape of a locked object cannot be 
changed in any way.

Tip: The lock command not only prevents any changes to the locked object, it
prevents them from being selected.

Using the Lock Command
1. Select the objects to lock.

2. Choose Layout>Group>Lock.
To protect an entire document from modification:
1. Choose Edit>Select All.

2. Choose Layout>Group>Lock.
Selected objects can also be locked by clicking the locked box in the Edit Objects dialog 
box.

Unlock Command
Any Designer Elements program object or shortcut that previously has been locked can 
be unlocked.
1. Choose Layout>Group>Unlock.

2. Select the locked object by clicking on the object or dragging a selection fence 
around it. The locked object is unlocked and selected.

Arrange Command
The Arrange command in the Layout menu repositions overlapping objects. This is a 
common command for graphics programs and is helpful in editing complicated 
drawings.
This command displays a submenu of the following commands: Move Forward, Move to 
Front, Move to Back and Move Backward.

Move Forward Moves the selected object up one position in the display.

Move to Front Moves the selected object to the top (or in front) of all other 
objects in the display.

Move to Back Moves the selected object to the back of the display.

Move Backward Moves the selected object down one position in the display.
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Align Command

This command in the Transformation tool palette moves selected objects, including text, 
relative to other objects.
The Align command includes a submenu with these options, Left Sides, Right Sides, 
Tops, Bottoms, Centers Horizontal, Centers Vertical, To Grid, Spaced Vertical and 
Spaced Horizontal.

The following figure illustrates each of these options.
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Left Sides Aligns the left sides of selected objects.

Right Sides Aligns the right sides of selected objects.

Tops Aligns the tops of selected objects.

Bottoms Aligns the bottoms of selected objects.

Centers Horizontal Aligns the center points of selected objects to the same x 
location.

Centers Vertical Aligns the center points of selected objects to the same y 
location.
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Using the Align Command
1. Select the objects to align.

2. Choose the alignment tool from the Transformation tool palette. Select the align-
ment option from the message line. The Message Line reads: Enter Alignment 
Point.

3. Choose the point at which the objects will align.

Object Commands
These commands modify various aspects of the geometry including direction, type and 
size.

Change Direction
This command in the Edit menu reverses the orientation of curves and surfaces.
Sometimes it is necessary to change the direction of curves to straighten twisted 
surfaces. Changing the direction of surfaces reverses their normals which can change 
the way rendered surfaces respond to lighting.
The graphic below shows the direction of a surfaces using the Edit>Change Direction 
command. The right graphic shows the changes made by using Change Direction.

Using the Change Direction Command
1. Select the object to change its direction.

2. Click Edit>Change Direction.
This Designer Elements program displays temporary arrows along the object to show its 
direction. Pick View>Redraw Screen to make them disappear.

To Grid Aligns the left and bottom portion of an object to the closest 
grid point. The grid does not have to be displayed to use this 
option.

Spaced Vertical Equally distributes the selected objects relative to each other.

Spaced Horizontal Equally distributes the selected objects relative to each other.
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Referral: This command can impact the rendering of the object. See Render
Option Combinations and View Rotation and Flip Normal Example for more
information.

Change Object Type
This command in the Edit menu or in the right-click context menu changes an object's 
type. This is helpful for editing as well as exporting geometry to software that may not 
support a particular type of entity. After using this command for a particular operation, 
this program remembers the selected conversion type (Curves, Surface, Mesh or Solids 
for a Solid object) until the option type is changed.
This command converts:
• Solids to solids, meshes, surfaces or 

curves.
• Surfaces to meshes, surfaces or curves.
• Curves to lines, polylines or splines.
When selecting this command a dialog box 
appears.

Tech Note: Only a polysolid, also known as a disjoint solid or multi-lump
solid, can be converted to its component, single-lump solids.
Only a polysurface can be converted to component single surfaces.

The dialog box contains the following standard options:

When converting a model 
containing links, before the 
conversion proceeds, the dialog 
box on the right displays for 
confirmation that the links will 
be removed by completing the 
conversion.

Selected Object 
section

This section contains the conversion options. The options differ 
depending on whether a wireframe, surface or solid object is 
selected.

Delete Originals Selecting this box deletes the original objects following the 
object conversion.

Use Work Layer Selecting this box places converted objects on the work layer.

OK Convert the object.

Cancel Cancels the command.
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Changing Curves 
When choosing the Change Object Type 
command after selecting a curve, the dialog 
box on the right box appears.
It is possible to convert the curve to Line 
Splines. To delete the original curve click the 
Delete Originals check box.

Curves to Lines Option
When the Lines option is selected a curve or set of curves can be converted to lines. 
Use this command to change a spline into a collection of lines or smart polygons into 
individual lines.

If the Delete Originals option is checked the program removes the parent curve after 
exploding it, leaving only the curves.

Curves to Polylines Option
When the Polylines option is selected, curves or a set of curves are 
converted into polylines. The graphic here is an example of a circle 
converted into a polyline. Unlike the line option which would convert 
a circle into multiple line segments, this option converts the circle 
into one polyline.

Curves to Through Spline Option
The Through Spline option converts a line, conic, arc, circle, or 
ellipse into a through spline. A through spline’s shape, slope and 
control points can be edited. The resulting spline is fit to within a 
0.001 drawing unit tolerance of the original curve. If the Delete 
Originals option is checked, the parent curve is removed after 
exploding it, leaving only the splines.The graphic here is an 
example of a circle converted into a through spline.

Curves to Vector Spline Option
When the Vector Spline option is selected, a line, conic, arc, circle, or ellipse is 
converted into a vector spline. A vector spline’s shape, slope and control points can be 
edited. The resulting spline is fit to within a 0.001 drawing unit tolerance of the original 
curve. If the Delete Originals option is checked, the parent curve is removed after 
exploding it, leaving only the splines.
The convert curve command is also useful for removing excessive numbers of control 
points from constrained splines. The left graphic below shows a spline containing 50 
points. The Change Object Type command reduces that number to five while 
maintaining a tolerance of 0.001 inches shown in the right graphic.

After selecting a type click OK and the object will convert.
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Curves to Bezier Option
The Bezier option converts a line, conic, arc, circle or ellipse into a 
bezier spline. The bezier spline’s shape can be edited by moving 
the control points and the slope of the spline at those points. If the 
Delete Originals option is checked, the parent curve is removed 
after exploding it, leaving only the splines.

Converting Text to Curves
1. Create text using one of the Text tools.

2. Choose Edit>Change Object Type.
3. In the Change Type dialog box choose 

curves.
4. Click OK.

Each letter of the text converts into a 
closed grouped curve. Now any curve 
operation on the text curve can be 
performed.

Changing Surfaces
When choosing the Change Object Type command after selecting a surface, this dialog 
box appears:

Surface To Curves Option
The Curves option converts a surface into a collection of editable vector splines. Modify 
the shape, slope and location of the spline control points as necessary. If the Delete 
Originals option is checked, the parent surface is deleted after exploding it, leaving only 
the curves. The resulting curves may consist of lines, arcs, circles, ellipses or splines.
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Surface To Surfaces Option
Selecting the Surfaces option explodes a surface composed of multiple faces into 
discrete surfaces. Once the surface is exploded individual surfaces can be edited, 
moved to a different layer, transform or removed.

Surface To Mesh Option
If the Mesh option is checked, the surface is converted to a triangular mesh. Meshes are 
useful for sharing program data with applications that cannot import precise surfaces. 
Exploding surfaces to mesh allows editing individual vertices. 

The precise mathematical representation of a solid or surface must often be converted 
into a collection of imprecise planar facets. These facets, for example, may be used to 
export a model to the STL format, and when changing a solid or surface (Edit>Change 
Object Type) to a mesh. The amount error that results from this conversion is controlled 
by the settings in the mesh parameters dialog box.
During the conversion, vertex points are distributed on the surface or solid. These 
vertices are then grouped into 3-sided and 4-sided facets. The conversion is deemed 
acceptable when the generated vertices and facets satisfy the settings. The five 
available settings are: Surface Deviation, Normal Deviation, Edge Length, Aspect Ratio 
and STL Facets. These settings are defined in the sections below.
Change the facet settings as needed in the dialog and then click the Update button to 
see the number of facets and vertices generated. Determining the combination of 
settings that will work for a given situation can be a bit of an art. If one setting becomes 
too tight the other settings will have no effect. If one setting becomes too loose, it will 
have no effect.
Keep in mind that under “real” circumstances the settings are used by the faceting 
algorithms if possible. It is often not possible to satisfy all settings simultaneously. In this 
situation the algorithm decides which settings to “loosen.”
When exploding a 
surface into a mesh, the 
mesh dialog box 
appears with 
characteristics for 
specifying the resolution 
of the mesh.
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The dialog box includes:

The mesh in the left graphic below was created with a Normal Deviation of 10 and a Max 
Edge Length of 0.1. The right graphic was created with a Normal Deviation of 20 and a 
Max Edge Length of 0.

Aspect Ratio Sets the maximum ratio between triangle edges. It prevents 
forming long narrow triangles. Enter a value in the field or use 
the slide to set the value.

Surface Deviation Sets the maximum acceptable distance between the facet and 
the surface represented by the mesh. Enter a value in the data 
field or use the slide to set the value.

Normal Deviation Sets the maximum angular deviation between adjacent facets. 
The default is 20 degrees. Use 10 for extremely dense 
meshes. Enter a value in the data field or use the slide to set 
the value.

Edge Length Sets the maximum acceptable edge length for facets. Enter a 
value in the data field or use the slide to set the value.

Mesh Count Includes the Update button and information on the Number of 
Facets and Vertices. Click the Update button to calculate the 
approximate number of facets based on mesh characteristics. 
The Number of Facets and Vertices information display 
question marks until the Update button is clicked. The 
calculated values replace the question marks.

Smoothing Selecting this option creates facets that are regularly spaced. 
The left graphic here shows an object without smoothing. The 
right shows the object with mesh smoothing.

Default Params Reverts the mesh parameters to the program default values.

STL Facets Forces the facets generated to be suitable for 
stereolithography usage. This setting is usually used when 
exporting STL files.
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After setting the desired values, click OK and the object will convert. If more than one 
surface is selected to convert, the dialog box bellow appears:

Click Yes to use the same mesh conversion values for all selected surfaces.

Changing Solids
When choosing the Change Object Type 
command after selecting a solid this dialog 
box appears:

Solid To Curves Option
If the Curves option is selected, the solid is converted into 
a collection of editable vector splines. The shape, slope 
and location of the spline control points can be modified. 
If the Delete Originals option is checked, the parent solid 
is removed after exploding it, leaving only the curves. The 
resulting curves may be lines, arcs, circles, ellipses or 
splines.

Solid to Surfaces Option
Selecting the Surfaces option explodes a solid into discrete 
surfaces. Once the solid is exploded, individual surfaces 
can be modified, moved to a different layer, transformed or 
removed.

Solid To Mesh Option
If the Mesh option is checked, the solid converts to a 
triangular mesh. Exploding solids to meshes allows editing 
individual vertices. 
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When exploding a solid into a mesh, the mesh dialog box appears with characteristics 
for specifying the resolution of the mesh:

The dialog box includes:

After entering the desired values, click OK and the object will convert. If more than one 
solid is selected to convert, the following dialog box appears:

Click Yes to use the same mesh conversion values for all selected solids.

Aspect Ratio Sets the maximum ratio between triangle edges. It prevents 
forming long narrow triangles. Enter a value in the data field or 
use the slide to set the value.

Surface Deviation Sets the maximum acceptable distance between the facet and 
the surface represented by the mesh. Enter a value in the field 
or use the slide to set the value.

Normal Deviation Sets the maximum angular deviation between adjacent facets. 
The default is 20 degrees. Use 10 for extremely dense 
meshes. Enter a value in the data field or use the slide to set 
the value.

Edge Length Sets the maximum acceptable edge length for facets. Enter a 
value in the data field or use the slide to set the value.

Mesh Count This section includes the Update button and information on the 
Number of Facets and Vertices. Click the Update button to 
calculate the approximate number of facets based on mesh 
characteristics. The Number of Facets and Vertices information 
display questions marks until the Update button is clicked. The 
calculated values replace the question marks.

Default Params Reverts the mesh parameters to the program default values.

STL Facets Forces the facets generated to be suitable for 
stereolithography usage. This setting is usually used when 
exporting STL files.
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Solids To Solids Option
Use the Solids option to break one solid up into several smaller units. This option comes 
in handy for editing only one part of a larger solid.
To find out the mass properties of several solids as if they are combined into one, first 
unite them and analyze their properties. After the measurement is completed use the 
Change Object Type Solid option to break the part back into individual pieces.

Change Dimensions
When choosing the Change Object Type 
command after selecting a dimension, this 
dialog box appears.
Use this to change dimensions into lines and 
text. This is helpful when exporting files with 
dimensions that may not be supported by the 
other software.

Simplify Object
This command in the Edit menu will examine the selected objects and if the entity falls 
within tolerances, will do the following:
• Convert zero length curves to points.
• Convert circular splines to arcs or circles.
• Convert straight splines to lines.
• Convert NURB surface or solid faces to analytics.
Potential NURB shapes converted to analytic shapes include cylinders, cones, spheres, 
tori and planes. Candidate shapes for simplification include data imported via IGES, 
Step, Rhino and Alias. Also some surfaces created in the Designer Elements programs 
are initially created as NURBS and may simplify to an analytic shape.
Some advantages of analytic representation of shapes over NURBS that are analytic 
operations are considered exact whereas NURBS are precise. Analytic operations 
execute much faster internally and take up less memory in RAM and less space when 
the file is saved. For example, an IGES file can be reduced by half after using the 
Simplify Object command.
Note: Using the Simplify Objects command may cause loss of part history on complex 
objects.

Edit Objects
This command in the Window menu edits selected objects by changing individual 
characteristics such as: weight, layer, resolution and other specifications. 
The Edit Objects dialog box can be displayed in two ways:
• Select the object by choosing Window>Edit Objects.
• Double-click on the object.
Note: It is not possible to double-click on editing operations performed on a solid such 
as blending, placing holes, shelling etc. except from within the Design Explorer (Cobalt 
and Xenon only). (See a later section for information on the Design Explorer.)
Changes made through this dialog box can be reversed with the Undo command.
When choosing Edit Objects a dialog box similar to the one here displays containing 
between two and four possible tabs: Geometry, Display, Attributes and Material.
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Geometry Tab
All tools that create geometry will include a 
geometry tab in the Edit Objects dialog box.

The specific characteristics listed depend 
on the object selected. The object selected 
in this case was a line and includes the 
following characteristics: Length, Angle, 
End 1 (X, Y and Z values) and End 2 (X, Y 
and Z values). All values appear in this 
dialog box as whole numbers and decimals, 
depending on the decimal setting in 
Preferences.

Entering Values
Values can be entered in this dialog box in any units desired. These will automatically be 
converted into the units set in Preferences. See Units.
When units are set to feet and inches (in the Preferences dialog box) it’s important to be 
aware of the following rules:
• All numbers are assumed to be feet unless accompanied by the unit symbol like “ for 

inches. Entering a 1.5 in the field is read as 1.5 feet. If it is necessary 1.5 inches, 
enter 1.5”, 1.5i, 1.5in, 1.5 inch, etc.

• To enter fractions of inches, each entry must include the unit symbol. For example, 5 
feet 6 5/8 inches must be entered 5 6” 5”/8. Internally this is converted as 5’ + 6” + 5”/
8. If the inch symbol is not included with the fraction, 
5/8 will be interpreted as a fraction of a foot.

Drawing views created for Layouts have their own Geometry page. Some editing 
operations like Split Solid contain no specific geometry characteristics and therefore do 
not have a Geometry page.
Every chapter in this manual that deals with objects includes a Geometric 
Characteristics section listing all characteristics specific to the object. Those features 
that do not have specific characteristics are noted accordingly.
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Display Tab
This page in Edit Objects appears for surface and solid objects only.
The graphic shows the characteristics 
included in the Display page for a surface 
object.

Transparency Makes an object or multiple selected objects to be transparent 
when it is enabled.

Iso Lines Controls the number of isopram lines drawn for a surface. 
These iso lines are constant parameter curves that lie on a 
surface, typically defined in parameter space. The parameter 
space coordinate system uses U and V coordinates, where U = 
horizontal and V = vertical. A zero (0) in both fields turns off iso 
lines. The appropriate U/V values may enhance the visual 
appearance of the surface at the expense of drawing speed. 
The letters U and V are industry standard space coordinate 
identifiers.

Silhouette Controls whether silhouette edges of objects are displayed. 
Silhouette edges are view dependent and can cause a 
significant reduction in drawing speed. The pull-down menu 
displays the options: On, Off and Smart. Smart Silhouettes 
display a silhouette only if it does not degrade the display 
performance.

Environment Maps Provide interactive feedback on surface aesthetics. These are 
used to interactively evaluate curved surfaces in real-time. A 
real-time environment map is a way to simulate the reflections 
seen while examining a reflective model. Click the Edit button 
to use the feature. See Real-Time Environment Maps for the 
information on how to use the environment maps.

Curvature Creates a curvature plot of the surface. When selecting the 
command from the Verify>Surface Analysis>Curvature 
Settings or on Display tab of the Edit Object window, after 
pressing the Edit button the Curvature Plot Settings dialog box 
appears. See Curvature Command for information on using it.
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Attributes Tab
This tab displays a standard list of 
characteristics for the selected object.

The attributes include:

For wireframe objects this tab also includes: Pattern, Weight, Arrow Start and Arrow 
End.

Draft Angle Evaluates the drafts of an object for molding purposes. When 
pressing Edit button the Draft Angle dialog box appears with 
the draft angle analysis. See Draft Angle for information on 
using it.

Name Displays the name of the object. Enter a new name if 
necessary.

Resolution Displays the resolution setting for the object. Select any of the 
options listed in the pull-down menu. See the Object 
Resolution section for more information.

Color Displays the color of the selected object. Choose any color for 
the object.

If the object is on a layer with an override color, the object will 
display in the override color but the Edit Objects color field will 
display the actual color of the object.

Control Pts Displays the status of the control points, hidden or visible. 
Either setting can be chosen.

Layer Displays the layer where the object is located. Place the object 
on any available layer.

Locked Locks the object preventing it from being selected or modified. 
This is the same operation that occurs when choosing 
Layout>Group>Lock.
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Material Tab
This tab appears for objects that have 
rendering materials applied to them. 

The material characteristics include the 
following:

Reflectivity Sets the material’s reflectivity. Values can be entered between 
zero (0) and one (1). Entering a zero in the field renders a flat 
finish. Entering a one in the field renders a mirrored finish.

Transparency Sets the transparency of the material. Values can be entered 
between zero (0=transparent) and one (1=opaque). This option 
only works correctly when objects are rendered with ray trace 
rendering commands.

Roughness Sets the roughness of the material. Values can be entered 
between zero (0) and one (1).

Scale Aets the scale of the material. Typically scale increases the 
size of the detail. Values can be entered equal to or greater 
than zero (0).

Texture File Displays the selected material. The pull-down menu lists all 
images in the texture folder. For those materials that do not 
support textures this menu is not available.

Enable Shadow Cast Specifies if an object casts shadows. This is valuable for 
reducing the shadows present in complex drawings. When 
checked the selected object casts shadows.

Enable Shadow 
Receive

Specifies whether an object will receive shadows from other 
objects. This ability is valuable for reducing the number of 
shadows present in complex drawings. When checked the 
selected object receives shadows.

Double Sided Facets Provides additional rendering control for surfaces. Objects with 
normals facing away from the line of sight are not rendered. 
When checked all objects are rendered regardless of the 
normal direction. 
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Using the Edit Objects Command
1. Select an object to edit.

2. Choose Window>Edit Objects and the 
dialog box appears.
The dialog box contains between two or 
four possible tabs depending on the 
selected object, Geometry, Display, 
Attributes or Materials.

3. Click on the tab containing the desired 
information.

4. Change the information in an entry box 
by double-clicking the entry data field 
and typing a new entry. Do not press 
ENTER (Windows) or RETURN (Macin-
tosh). Many data fields have pop-up 
menus for selection. Press the down 
arrow and then drag to the necessary 
selection.

5. Make changes in other entry fields as 
required.

6. Click Apply and the changes automatically occur on the selected geometry.
7. Click Close to close the Edit Objects dialog box. 
Use Undo or Redo to reverse changes made through this dialog box.
Coordinates are measured in the units set in the Units page of Preferences.
When doing a lot of editing leave the Edit Objects dialog box displayed. Ths way it is 
possible to select the object, make the changes in the dialog box, click Apply and then 
go on to the next object. 
If more than one object is selected when choosing Edit Objects, only the common 
information is displayed. Entries are blank when the information isn’t common. For 
example, if two concentric circles are selected, the center will be displayed in the Edit 
Objects box but the diameter box will be blank.
When selecting several objects and then choosing Edit Objects, all of the objects will 
reflect the changes made in the dialog box. For example, selecting all dimensions and 
changing the text entry in the Edit Objects dialog box to 2, all the dimensions will display 
a 2.

Select this option for objects that cause light refraction like 
glass. When left unchecked facets on the back side of the 
glass are ignored resulting in an inaccurate rendering.

Is Backdrop Object Optimizes rendering calculation time for an object like a wall, 
that functions only as a backdrop for other objects. Since the 
object automatically receives light due to its large size, the 
program does not need to spend much time performing light 
ray calculations.

Advanced button Displays the Render Material Settings dialog box. Use this 
dialog to change the advanced rendering settings used on the 
selected object. 
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Moving an Object to a Different Layer
1. Select the object(s) to be moved.

2. Choose Window>Edit Objects.
3. Click the arrow for the Layer entry field.
4. Pick the layer from the list.
5. Choose Apply.

Links
Many of the objects created in Cobalt and Xenon are associated with other objects in 
parent-child relationships. Associative objects retain a history of how they were created 
and a set of rules that define their geometric description. By modifying a parent object 
(an object that defines another object), and the dependent or child object is 
automatically regenerated. For example, consider a skinned surface that is defined by 
two lines. If one of the lines is modified, the skinned surface will automatically 
regenerate.
Two commands deal with Links: Resolve and Remove.

Resolve Links Command
This command is in the Edit menu. When modifying an entity that is part of a parent-
child relationship, the word Edit in the menu bar and the command Resolve Links 
highlight in red.
In most cases, Cobalt or Xenon will resolve the links in a parent/child relationship 
automatically and the words will un-highlight when finished. If the words stay red, select 
Edit>Resolve Links to force the program to resolve the relationship.
Saving a file containing links that are not resolved, the following warning appears:
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Remove Links Command
The Remove Links command in the Edit menu deletes all associative links between a 
parent and child.
Select this command and the following warning appears:

This is a warning that the selected object has a parent/child relationship to another 
object and that deleting this object not only deletes the history tree but cannot be 
undone.
Press the Yes button to continue the Remove Links command or No to discontinue.

Referral/Tech Note: Do not use the Remove Links command to remove a
feature from the history tree. This removes all parent/child associativity for the
geometry. Use the Design Explorer instead. See a later section for
information on the Design Explorer.

Design Explorer
The Design Explorer, found in the Windows menu, is a valuable feature for traversing 
the drawing's design history. It offers a Windows-style tree structure with expandable 
branches that display the associative geometry used in the creation of all of the entities 
in the drawing. The Design Explorer Feature Tree displays the most recent items at the 
top of the list. Think of stacking new items or features on top of old ones. 

The figure shows a solid cube with a hole in one face. The Design Explorer window 
identifies the entity as a part and shows that it consists of a block and a hole feature. 
Click on items in the tree and the corresponding part in the drawing will highlight.
If an item is selected in the Design Explorer when the Edit Objects dialog box is 
displayed, the dialog box automatically updates to reflect the selected item.
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In/Out/History Links

Notice the numbers in brackets [ ] after each feature in the tree such as:
LINE_3991 [0/1/0]
These numbers represent links that go into and out of the feature, or that form a 
separate history. Out Links are always above In Links.

Render Links
The Render Links feature 
organizes all persistent parts 
of the model in the Design 
Explorer. If material or decals 
are placed on the model, or if 
drawing views are created, 
they group separately from 
any geometry operations 
under the Render Links 
category.
This makes it possible to 
modify the part without having 
to replace material or recreate 
views.
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Output Link
In the picture bellow the circle has an output link to hatch.

Design Explorer Commands
The Design Explorer also includes several of its own menu of commands. For Windows 
users, (and Macintosh users with a two-button mouse) click the right mouse button on 
the feature name to display the menu. For a one-button mouse, hold down the CTRL 
key and click on the feature. Depending on where the right click is and when, one of the 
following menus appear:

These commands are described on the following pages.
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Open

The Open 
command 
accesses the 
history link as a 
top-level feature, 
as shown in the 
picture below.
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Rename
The Rename command renames any of 
the entities. It displays this dialog box.
Enter the new name and click OK.

Suppress Feature/Unsuppress Feature
These commands turn off or on a particular feature in the solid history tree. They toggle 
between each other depending on whether an operation is suppressed. 
When a feature is suppressed, the solids rebuilt as if the operation never occurred. This 
feature can be unsuppressed and reintegrated into the part at a later time. The graphic 
below shows a part and the Design Explorer open. 
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This next graphic shows the same part with all of the holes suppressed. Notice the “S” 
displayed over the operation icon in the Design Explorer.

Some uses for feature suppression include the following:
• FEA Models: when creating FEA (Finite Element Analysis) models, certain features 

may not need to be included in the analysis.
• Part Regeneration: removing certain features may speed up rebuilding the part, 

including display time.
• Shelling: if a part fails to shell, turn off blends and other features that may prevent a 

successful shelling operation. Then, using the Reorder Feature command, the 
shelling operation can be moved before the suppressed feature in the history tree so 
that shelling succeeds. Finally, unsuppress the selected feature using the 
Unsuppress Feature command.
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Using the Suppress Feature Command
1. Select the model which contains the feature to suppress.

2. Choose Window>Design Explorer to display the history tree.
3. Expand the tree to display the desired feature by clicking on the plus (+) sign to the 

left of the part name.
4. Select the desired feature.

The feature highlights.
5. Click the right mouse button on a two-but-

ton mouse or press the CTRL key with a 
one-button mouse to display the Design 
Explorer menu.

6. Choose the Suppress Feature command.
The feature suppresses and the model 
regenerates without the feature. The Design 
Explorer now displays an “S” over the 
operation icon.

Using the Unsuppress Feature Command
The Unsuppress Feature command replaces 
the Suppress Feature command in the Design Explorer menu for suppressed features 
only.
1. In the Design Explorer select the suppressed feature.

2. Click the right mouse button (Windows) or press the CTRL key with a one-button 
mouse to display the Design Explorer menu.

3. Choose the Unsuppress Feature command.
The feature reappears and the model 
regenerates. The feature icon no longer 
displays an “S.”



Object Commands

5-33

Reorder Feature
A part may be modified by rearranging its 
features. The Reorder Feature command 
moves features up or down in the history tree. 
In the graphic on the right, the shell operation 
occurred after the holes were placed.

Using the Reorder command, the shelling 
operation was moved before the hole 
operation, resulting in the model shown here.

Using the Reorder Feature Command
1. Select the part.

2. Open the Design Explorer and display the tree to expose the feature to reorder.
3. In the Design Explorer menu select the Reorder Feature command.

The Message Line reads: Feature Reorder: Click on new location in Design Explorer.
4. Click on the operation below to move the selected operation.

The operation moves and the part regenerates. 

Tech Note/Tip: It is not possible to move or reorient a feature to any side of a
solid that is not visible. The operation automatically believes that one of the
visible faces is chosen. Rotate the solid so that the face is visible before
choosing the Move Feature command.

Move Feature
The Move Feature command repositions holes and bosses within the assembly.
Using Move Feature Command
1. Select the feature in the Design Explorer to move. The feature is selected in the 

drawing area.

2. Display the Design Explorer menu by clicking the right mouse button on a two-but-
ton mouse or pressing the CTRL key with a one-button mouse.
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3. Select the Move command. The Message Line appears guiding the appropriate 
steps.

4. Click a new center on the solid. The feature is repositioned.
Add Curve
This command adds a curve to a profile or the elements of a profile in the Extrude, Skin, 
Lathe, Cutout, Protrude, Boss and Hole tools. 

Replace Profile
This command replaces a profile or the elements of a profile in the Extrude, Skin, 
Lathe, Cutout, Protrude, Boss and Hole tools. 

Remove Feature
This command deletes a feature from the assembly.

Edit Parameters
This command displays the Edit Objects dialog box. Double-click any item in the tree to 
open Edit Objects.

Expand Item
This commands expands the part of the tree under the selected item.

Collapse Item
This command collapses the part of the tree under the selected item.

Expand Branch
This command expands the entire branch that includes the selected item.

Collapse Branch
This command collapses the entire branch that includes the selected item.

Close Window
This command closes the Design Explorer.

Force Resolve Links
This command resolves all unresolved child geometry. Selecting the part and displaying 
the Design Explorer, a red “R” appears over any child operation icons that is not 
resolved.

This will occur if the Enable Auto Resolve option in the General page of Preferences is 
turned off. When activated, all child geometry is automatically resolved when a parent is 
modified. When deactivated use the Force Resolve Links command to resolve child 
geometry.
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Design Explorer Rules
• Within the Design Explorer, a 

curve within a profile cannot be 
selected and its length cannot 
be edited through the Edit 
Objects dialog box. Attempting 
this will make a later operation 
invalid. The message here 
appears when Apply in the Edit 
Objects dialog box is chosen.
Click OK to restore the original length.
For example, to lengthen a line that has been extruded to a solid, the change in length 
does not affect the lines connected to the edited line. The closed profile would be 
destroyed. To lengthen a line use the Move tool and select the endpoint of the line and 
move it. By default, it will select and move the endpoints of all lines connected at that 
endpoint.

• The Design Explorer will only show one part at a time.
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Drawing Techniques
This chapter provides techniques for creating geometry and setting up the drawing area. 
The following topics are covered:
• Object Creation Methods
• Status Line
• Coordinate System Axis
• Message Line
• Trackball
• Drawing Display Commands
• Drawing at Full Scale
• Default versus Selected Object Settings
• Escape Key

Object Creation Methods
In Vellum 3D and Vellum Draft, there were two methods for creating objects, clicking and 
dragging. In Cobalt, Xenon and Argon surface and solid objects are created by clicking 
only. Wire frame geometry can be created with either method.
As geometry is created, a rubberband image of it appears showing how the object will 
look when the last point is clicked.
To make object creation easier, the wireframe tools contain a feature called Smart 
Pointers. When working with a tool, the cursor icon shows the points that must be 
indicated to create an object with that tool. 

Each dot on the icon represents a point to be placed by clicking. The smart pointer 
indicates the order for designating points.



Drawing Techniques

6-2

Creating a Line by Clicking
1.Click the Single Line tool in the main tool palette. The Message Line 
reads: Single Line: Pick beginning point [Ctrl = Copy Previous (Windows) 
or Option = Copy Previous (Macintosh)].

2.Move the pointer to the drawing area and click to set the starting point 
of the line. 
3.Move or drag the mouse to the desired location for the endpoint of the 
line. When doing so, a rubberband image of the line appears. 

4. Release the mouse button or click to set the endpoint. 
Immediately after construction, it is possible to make changes in the Status Line at the 
bottom of the drawing area to alter the length or position of the line. If the geometry is 
not satisfactory, just press the BACKSPACE (Windows) or the DELETE (Macintosh) key.

Note: With the wire frame tools, it is possible to use
either the click and drag method of creating objects or
the click, click method as described here.

Status Line
When a tool from a tool palette is selected, Status Line entry boxes appear along the 
bottom of the drawing area. The Status Line contains data fields that provide information 
about the current construction. For example, when the Single Line or Connected Lines 
tool is active, the Status Line contains data fields for the X, Y and Z coordinates of the 
beginning point and the delta X, Y and Z values. It also contains the value of the length 
and angle of the line.

The Status Line can be used in three ways:
• To create an object with keyboard entries only.
• To edit an object that was just created and is still selected.
• To edit a previously created object that is selected again.
• To create additional wireframe objects using the current tool.
When constructing an object, the status data field containing the specification that is 
most likely to be changed is active (the data field is highlighted). For example, when a 
line is drawn with the Single Line tool, the Length data field is highlighted so that a new 
value for the length can be entered. Just type a value. Press ENTER (Windows) or 
RETURN (Macintosh) and the line is redrawn at the new length.
The number of decimal places displayed in the data field can be set by going to 
File>Preferences>Units.
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Using the Status Line
To make an entry in a different status data field, use one of four selection methods:
• Press the TAB key to cycle the selection highlight through the status data fields from 

left to right.   
• Click inside the status data field and the pointer becomes an I-beam text cursor.
• Double-click inside the status data field to select the entire contents of the data field. 
• Click the data field label to select the entire contents of the data field.

Units and the Status Line
Values can be entered in inches, feet, feet and inches, millimeters, centimeters, meters 
and mathematical expressions (e.g. 10”+2.54 cm).
When the units in Preferences are set to feet and inches, it’s important to be aware of 
the following rules:
• All numbers are assumed to be feet unless accompanied by the unit symbol, such as 

“ for inches. Entering a 1.5 in the field is read as 1.5 feet. To set 1.5 inches, enter 1.5”, 
1.5i, 1.5in, 1.5 inch, etc.

• To enter fractions of inches, each entry must include the unit symbol. For example, 5 
feet 6 5/8 inches must be entered 5’ 6 5/8”. Internally this is converted as 5’ + 6” + 5/
8”. If the inch symbol is not included with the fraction, 
5/8 will be interpreted as a fraction of a foot.

Copying and Pasting Status Line Entries
Status Line text can be copied and pasted or used in another data field.
For Windows, select the Status Line text, hold down the right mouse button and use the 
Copy and Paste commands available in the menu that appears. Do not use the Copy 
and Paste commands in the Edit menu.
For Macintosh, use +C to copy and +V to paste text. The Copy and Paste 
commands in the Edit menu are unavailable. These function only for the Designer 
Elements object data (i.e. line, circle, etc.)

Status Line Entries and Tool Operations
Information entered in the Status Line is registered in two different ways depending on 
when in the geometry creation process it occurs. 
• When a tool is selected, it is possible to immediately enter values in the Status Line 

data fields. When the tool operation is performed, those values will be used to create 
the object.

• When the object is created with a tool and is still selected, enter new values in the 
Status Line data fields. To move from field to field use the TAB key. When ENTER 
(Windows) or RETURN (Macintosh) is pressed, the object changes to reflect those 
values. Once ENTER (Windows) or RETURN (Macintosh) is pressed, future changes 
can only be made to the object through the Edit Objects dialog box.

• When entering values in the Status Line, the accuracy of the geometry depends on 
the number of decimal places entered by the user.

• The Status Line references the current coordinate system current work plane. All 
values in the Status Line are based on the current coordinate/work plane system.
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Tech Note: There are two methods for making Status Line entries in Cobalt,
Xenon and Argon. The first is to select a tool, create the object, type the new
values and press ENTER (Windows) or RETURN (Macintosh). The selected
geometry changes. In the second method, select the tool, type the desired
values in the Status Line and press ENTER (Windows) or RETURN
(Macintosh). The values are now registered. Then create the geometry with
the tool.

Using the Status Line with Drawing Tools
Once an object is drawn, the specifications can be adjusted in the Status Line including 
the length, angle and location. It is possible to make these changes immediately before 
constructing another object, selecting a different tool or choosing a command, however, 
it is not necessary.
It is possible to make only one series of changes in the Status Line (in as many fields as 
necessary); after ENTER (Windows) or RETURN (Macintosh) is pressed the program 
redraws the object to the specifications. After this, subsequent changes must be made 
using the Edit Objects command in the Edit menu.
Try the following exercises to create and change a single line with the Status Line.

Altering Geometry in Progress with Status Line
1. Select the Single Line tool. The Message Line reads: Single Line: Pick beginning 

point [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].

2. Click two locations in the drawing area. The length (L) field automatically highlights 
in the Status Line.

3. Type 3. The 3 is entered directly in the L field.
4. Press the TAB key to select the next status field. The angle (A) field now highlights.
5. Enter 15.
6. Press ENTER (Windows) or RETURN (Macintosh).

Pressing ENTER (Windows) or RETURN (Macintosh) completes the data entry for 
this object. The line is redrawn 3 units long and at a 15° angle.

Remember that when ENTER (Windows) or RETURN (Macintosh) is pressed, the 
program constructs the object based on the specifications in the Status Line.

Creating Additional Geometry with the Status Line
1. With the Single Line tool still selected from the previous example, click two more 

points. 

2. Type 4.
3. Press the TAB key and type 25 in the Angle field.
4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.
Creating New Geometry with the Status Line
1. Choose the Selection tool so the Status Line clears.

2. Click the Single Line tool again.
The X status field is active, showing that a value for the X coordinate of the line's 
beginning point may be entered.
Do not press ENTER (Windows) or RETURN (Macintosh) until step #14.

3. Type 0.
4. Press the TAB key. The Y data field highlights. 
5. Type 0.
6. Press the TAB key. The Z data field highlights.
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7. Type 0.
8. Press the TAB key.

The dX data field highlights. The dX value is the delta X, the numeric difference 
between the beginning and ending X coordinate.

9. Type 2.
10. Press the TAB key. The dY data field highlights. 
11. Type 2.
12. Press the TAB key. The dZ data field highlights.
13. Type 0.
14. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.

Creating Geometry Offset from a Point
To create geometry offset from an existing point, use the Status Line to specify 
the offset.

Creating Geometry Offset from a Point
1. Select the tool to be used.

2. Move the pointer over the control point from which the offset is desired.
3. Click once to lock onto that point.
4. Finish creating the geometry.
5. With the geometry still selected, click in the appropriate X, Y, or Z data field in the 

Status Line, placing the text cursor at the end of the entry.
6. Type the offset (such as + 3) and press ENTER (Windows) or RETURN (Macintosh).
7. Continue with the construction.

Coordinate System Axis
The coordinate system axis, at the left of the Status Line, displays the coordinate system 
currently set for the file. Choose either the global (world coordinate system) or a user-
defined coordinate system. The graphic below represents the global coordinate system. 
The default system is the Global coordinate system.

The global system aligns with the X, Y and Z axes (X = 1, 0, 0; Y = 0, 1, 0; Z = 0, 0, 1). 
The user-defined coordinate system is set by the user. Planes labeled as 
DynWorkPlane or UserWorkPlane# are part of the user-defined coordinate system. See 
“Work Plane” for information on the Work Plane Manager and defining work planes.
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Choosing a Coordinate System
1. Choose the coordinate system by clicking on the coordinate system axis icon at the 

far left of the Status Line.

A menu displays.
2. Choose the Global Work Plane or any user-defined work 

plane.
The work plane and coordinate system are now set.

3. Continue designing.

Referral: See Work Plane for information on defining a work plane.

Message Line
The Message Line is an 
important feature when drawing. 
After selecting a tool, the line 
displays the tool name and the 
first step in its use.
Some tools display a subpalette 
and a pull-down option list. As 
each step is finished, the next step displays until all steps are completed. The Message 
Line may also display additional commands that can be used with the tool.

Trackball
The Trackball rotates the view orientation of the 
geometry in the drawing area. It is also possible to 
rotate the view around an object by selecting it before 
using the Trackball. If the object includes features 
such as holes, select the hole through the Design 
Explorer to do the rotation. (Selecting a hole results in 
a view rotation around the hole center by referencing 
the faces and edges introduced by the hole.)
To display the Trackball, choose Window>Trackball. 
When the Trackball displays, a check mark appears in 
front of the command in the Windows menu. The 
Trackball can be dragged to any location in the 
drawing area.
Toggle the Trackball between the sphere display and 
the step display. Both displays include a Views pull-
down menu.

Axis Locking
The Trackball will lock rotations to an X, Y or Z axis. 
Hold down the X, Y or Z key on the keyboard while 
using the mouse in the Trackball window and the 
Trackball will rotate only in the direction of the key 
being pressed.

Tip: Axis locking applies to geometry also.
Hold down the X,Y or Z key while creating
geometry and it will be locked to that axis.
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Sphere Trackball
The Sphere Trackball drags your view to the desired rotation. Drag 
beyond the boundary of the trackball and continue the rotation. The 
sphere trackball is the default display.

Using the Sphere Trackball
1. Choose Window>Trackball.

2. Drag the pointer on the Trackball to rotate the view.
The model rotates while dragging. See the section below for “Setting View Rotation 
Options”. The model continues rotating if the pointer is dragged past the edge of the 
trackball display and until the mouse button is released.

Setting View Rotation Options
Set view rotation options for the Sphere 
Trackball in the View Rotation Options 
dialog box.

To display the dialog box, double-click on 
the gray area of the Sphere Trackball.

The View Rotation Options dialog box 
appears containing the following:

Choose only one of the four rotational options at a time, Model Type, Screen Type, 
Model Point Origin or Object Center Origin.
Click OK to accept your settings and close the dialog box or Cancel to close the dialog 
box without accepting the changes.

Step Trackball
The Step Trackball rotates the view in regular angle increments or in a continuous 
movement and provides addition options in the View Rotation Options dialog box.

Type Sets the rotation type, Model or Screen. 

The Model option rotates the view around the x, y and z axis as 
displayed by the Axis icon. 

The Screen option rotates the view around the screen axis with 
the x axis oriented horizontally, the y axis oriented vertically 
and the z axis oriented normal to the screen.

Origin Sets the origin at either the Model Point or the Object Center.

The Model Point option determines the rotational point. Enter 
either the values in the x, y and z data fields or click on the 
geometry to set the location (values are entered automatically).

The Object Center option rotates the geometry around the 
center of the objects in the drawing. This center is calculated 
by the program. When this option is selected, the x, y, and z 
data fields are unavailable.
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Change the Sphere Trackball to the Step Trackball by clicking the 
arrow button on the right side of the Trackball title bar.

The Step Trackball includes the following icons:

Using the Step Trackball
1. Choose Window>Trackball.

2. Click on the arrow button on the right side of the Trackball title bar to change the dis-
play to the Step Trackball.

3. Click one of the directional arrows. The model rotates a specified number of 
degrees. Or...
Click on the Step Rotation icon to toggle the display to the Continuous Rotation icon 
and click one of the directional arrows. Click on the circular arrow icon to stop the 
rotation.

Setting View Rotation Options

Directional Arrows Rotate the view in a specific direction. Clicking the vertical 
arrows rotates the geometry about the x axis. Clicking the 
horizontal arrows rotates the geometry about the y axis. 
Clicking the angled arrows rotates the geometry about the z 
axis. (In the View Rotation Options dialog box, choose either 
the model or screen axis to reference the rotation when using 
these arrows. See the section bellow, “Setting View Options,” 
for more information.)

Step Rotation This display, represented by the stair icon, toggles with 
Continuous Rotation. With the step icon displayed, 
rotation moves through stepped increments in the 
selected direction.

Set the degree increment for the steps in the View Rotation 
Options dialog box. See the section bellow, “Setting View 
Options,” for more information.

Continuous Rotation This display, represented by the circular arrow, toggles 
with Step Rotation. With this icon displayed, rotation is 
a continuous motion in the selected direction. 

Temporarily halt the rotation by placing the cursor over the 
arrow and pressing. When the mouse is released, the rotation 
continues. To stop the continuous rotation, click the circular 
arrow icon.
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Set view rotation options for the Step 
Trackball in the View Rotation Options 
dialog box.

To display the dialog box, double-click on 
the black area of the Step Trackball. View 
Rotation Options containing these 
options:

Choose only one of the four rotational options at a time, Model Type, Screen Type, 
Model Point Origin or Object Center Origin.
Click OK to accept the settings and close the dialog box or Cancel to close the dialog 
box without accepting the changes.

Trackball View Menu

Type This option sets the rotation type, Model or Screen. 

The Model option rotates the view around the x, y and z axis as 
displayed by the Axis icon. The option rotates the model 
around one stationary axis. See the graphic here.

The Screen option rotates the view around the screen axis with 
the x axis oriented horizontally, the y axis oriented vertically 
and the z axis oriented normal to the screen.

Step Angle This sets the rotation angle for the Step Trackball.

Origin This sets the origin at either the Model Point or the Object 
Center.

The Model Point option determines the rotational point. Enter 
either the values in the x, y and z data fields or click on the 
geometry to set the location (values are entered automatically.

The Object Center option rotates the geometry around the 
center of the objects in the drawing. This center is calculated 
by the program. When this option is selected, the x, y, and z 
data fields are grayed out.
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The Trackball has a pull-down menu for specifying the view or saving the current view. 
The views available in this menu include the default views and any user-defined views.

Using the Trackball View Menu
1. Move the pointer to the current view name dis-

played at the bottom of the Trackball window.

2. Press the mouse button.
The Trackball Views menu displays.

3. Choose the view orientation to be displayed in the 
current window.
The view orientation changes the view window as 
specified. A check mark appears next to the 
selected view, as shown here.

View Rotation Short Cut
Rotate the view by holding down the SHIFT key and 
pressing one of the keyboard arrows. This rotates the 
view a specified number of degrees.
It is also possible to change your view with the following keyboard short cuts: a - Side 
View, s - Front View, d - Top View, f - Isometric View and g - Trimetric View.

Drawing Display Commands
There are a number of commands that display features that may assist in creating 
geometry. These include: Show/Hide Triad, Show/Hide Axis, Show/Hide Work Plane, 
Show/Hide Points and the Grid commands.

Show/Hide Triad
This command in the Planes menu toggles the display of the Triad symbol 
in the upper-left corner of the view windows. The Triad illustrates the 
orientation of the x, y, z axes and the work plane. See Triad for more 
information.

Show/Hide Axis
This command in the View menu toggles the display of the Axis 
symbol at the drawing origin. The Axis establishes the direction 
of the x, y and z axes. The Axis can clarify the geometry 
location when rotating the view.
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Show/Hide Work Plane
This command in the Planes menu toggles the display of 
the Work Plane icon on the geometry. The graphic below 
shows the work plane set to the Top plane.

Show/Hide Points
This command in the Edit menu toggles the display of the control points for selected 
objects. See Selecting Objects for more information.

Grid
The grid overlays the drawing and can help to create and align geometry. The grid is 
made up of horizontal and vertical lines of dots. The grid commands, Show/Hide Grid 
and Snap to Grid are found in the Planes menu. Set the Grid preferences (spacing, the 
number of divisions, display appearance and startup options by choosing 
File>Preferences>Grid.

Show/Hide Grid Command
This command in the Planes menu toggles the display of the grid. The grid is always 
aligned with the work plane's x and y axis. It is possible to display the grid when viewing 
any plane.

Snap to Grid Command
This command in the Window>Snaps menu toggles on and off and is normally used 
with the grid. However, this command does not require that the grid is displayed.
When Snap to Grid is on (a check mark appears next to the name), the Drafting 
Assistant snaps all geometry to the grid. In other words, if the grid is set to .25 inch 
spacing, it is impossible to construct an object closer than .25 inch to another object.

Tip: If a gray rectangle appears in the drawing area when the program first
starts, choose File>Page Setup. The option, Show Page Breaks in Drawing
Windows may be selected. The gray rectangle is the page bounds.

Drawing at Full Scale
Whether designing or drafting a highly detailed blueprint, the geometry should be 
created at its actual size. This Designer Elements program constructs the part using full-
scale specifications and then sets the visual scale of the drawing. In this way, the part 
dimensions to its true-to-life measurements. Drawing at full scale has the following 
advantages:
• Scaling mistakes are eliminated.
• Dimensions are automatic. (It is necessary to dimension manually if the drawing is 

not at full scale.)
• Associative dimensions in Cobalt and Xenon update when the object is edited 

(manual dimensions do not).
• The size relationship of imported parts is compatible.
Once the project is drawn, it can be dimensioned and scaled visually to fit into a 
standard drawing size, if needed, with the Print Setup command (Windows) or Page 
Setup command (Macintosh) in the File menu. Regardless of how the drawing is set up, 
the actual size of the geometry remains constant unless it is edited.
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To ensure that the geometry is contained within a specified page bounds at a 1:1 scale, 
the page bounds can be displayed. See Page Setup and Printing for more information.
When a new Designer Elements program document is opened, the drawing area is an 
infinitely large sheet so that anything can be designed at full size. As a simple example, 
here's how to draw and view a line 83 feet long:
1. Draw a line, specifying 83' for the length. 

The line extends off the screen. 
2. Choose View>Zoom All.

The entire 83 foot line is visible on the screen.
Using the draw to scale/Zoom All method, it is easy to create accurate full-scale 
drawings which are displayed at any magnification. The actual size of an object is not 
affected by zoom magnification or reduction. 
Zoom All magnifies or reduces all objects on the drawing to fill the screen— regardless 
of the size of the objects.

Default versus Selected Object Settings
When no object is selected, any setting changes made to Selectable Points, Grid, Axis, 
Triad, Show Points, Construction Lines, User-defined plane, Pen, Text, Dimension, tool 
palettes (choice, status and location) and Render become the default for all open files 
and the current session. When an object is selected, any change made will only affect 
the object.

Escape Key
When geometry becomes quite complex, the time required for operations to complete 
will inevitably lengthen. It is possible to interrupt the command by pressing the ESC key.
Use ESC to deselect both an object and the tool as outlined here. 

Tap ESC the first time to deselect an object, 
such as this line.

Tap it the second time to deselect the 
current tool, returning to the Select tool. 
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Introduction to Wireframe Modeling
Cobalt, Xenon and Argon all create 
wireframe, surface and solid models. The 
most basic model is the wireframe model. A 
wireframe consists of the geometry that 
makes up the edges of the object. The word 
“wireframe” relates to the idea of a wire that 
is bent to follow an object's edges. A 
wireframe model is the simplest 
mathematical representation of an object.
Wireframes in the Desiger Elements consist 
of points, lines, arcs, circles, ellipses, 
conics, splines or a combination of any of 
these. These particular wireframes are also 
collectively referred to as curves. Although 
wireframes are limited in the amount of model content they represent, they are powerful 
building blocks for creating more complex models composed of surfaces and solids.
A wireframe model can often be used in place of a prototype (to run simulations and 
tests on the computer rather than in the laboratory). Models can be used for checking 
visual specification, measuring distances between points within the model and 
observing the visual and real intersections of lines.
The topics discussed in this chapter include:
• Wireframe Tools
• Wireframes and the Drafting Assistant
• Wireframes, Selection and Display
• Object Types and Edit Objects
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Wireframe Tools
The next few chapters in this section describe how to create wireframe geometry with 
the Desiger Elements program tools. They also provide information on how the Drafting 
Assistant makes designing faster and easier.
Wireframe tools are contained in the main 
tool palette, located at the left side of the 
drawing area.
It is possible to change the default status 
(open or closed) and location of the main 
tool palette by choosing the status and 
location and quitting the Designer 
Elements program. The next time the 
program is launched, the palette will 
retain the status and location chosen.

Each icon in the palette is the first in the 
subpalette of tools grouped together by 
purpose, as shown below. 

Information on using each tool is contained in the chapters that follow.

Line tools

Arc tools

Circle tools

Ellipse/Conic tools

Polygon tools

Spline/Helix tools
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Wireframes and the Drafting Assistant
The Drafting Assistant recognizes several useful snap locations associated with 
wireframe objects. These dynamic snap locations include:
• Endpoints
• Midpoints
• Intersections
• Projections
• Centers
• Vertices
• Tangencies
The Drafting Assistant recognizes such points in all three dimensions, making 3D 
drafting much easier.

Wireframes, Selection and Display
Wireframes are selected when they are within the selection fence or the boundaries of a 
single pick box as defined in Preferences (see Preference Settings). Conics, ellipses, 
splines and circles have resolution attributes that impact the screen display and printer 
output. Change the resolution of the selected object by choosing Edit>Change 
Resolution.

Changing an Object's Resolution
1. Select the object.

2. Choose Edit>Change Resolution.

The Object Resolution dialog box appears.

There are five resolution options: Super Fine, Very Fine, Fine, Medium and Coarse. 
Very Fine is the default option..

Coarse Medium Fine Very Fine Super Fine
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Objects Characteristics and Edit Objects
All wireframe objects created with a Desiger Elements program tool are defined by their 
own geometric, display and attribute characteristics. The Edit Objects dialog box 
provides information for these three categories. Where the display and attribute 
characteristics are identical for wireframe objects, the geometric characteristics differ 
according to a particular object.
For example: A line created by the Single Line tool includes the following geometric 
categories: Length, Angle, End 1 (X, Y and Z values) and End 2 (X, Y and Z values).
Chapters 10 through 14 introduce the wireframe tools. With every tool description there 
is a list of the geometric characteristics displayed in the Edit Objects dialog box. For 
information on using the Edit Objects command and the dialog box, see Editing Objects.
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Transforming Geometry
This Designer Elements program provides tools and commands to transform the 
geometry with respect to scale, location and orientation.
This chapter covers the following topics:
• Transformation Tools
• Transforming Techniques

Transformation Tools

The tools on the Transformation tool palette include: move, rotate, expand or shrink 
and mirror objects; polar, linear, spherical  and cylindrical duplicate; and align. Select the 
object to transform before or after selecting a Transformation tool.
Objects can be copied and transformed at the same time by holding down the CTRL 
(Windows) or the OPTION (Macintosh) key while specifying the transformation.
Press the SHIFT key to select additional objects after selecting a transformation tool 
(see the Message Line). As soon as the SHIFT key is released the Transformation tool 
is active again.
Enter values for each tool in the Status Line to perform the operation either before or 
after the operation is complete. If the values are entered after selecting the tool but 
before performing the operation, the first click in the drawing area automatically 
registers all Status Line values. If values are entered after performing the operation and 
while the object is still selected, pressing ENTER (Windows) or RETURN (Macintosh) 
updates the object to reflect the new values.

Geometric Characteristics
There are no geometric characteristics specific to these tools. The geometric 
characteristics are based on the objects. For information on the geometric 
characteristics of an object, see its related chapter.

Item vs. Faces
All of the Transformation tools, with the exception of the Alignment tool, support the 
movement of individual faces in addition to entire items. 
When one of these tools is selected, the Item/Faces buttons appear in 
the Message Line and the Message Line changes accordingly.
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To transform or copy only certain faces of an object:
1. Select the appropriate transformation tool.

2. Click the Faces button in the Message Line.
3. Select the face or faces to transform. To copy press CTRL.
4. Select the beginning and ending reference points as directed by the Message Line. 
After completing the action, while the object is still selected, enter new values in the 
Status Line fields to modify the face transformation. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

Move Tool

The Move tool moves selected objects, including control points to a new location. Copy 
the selection by holding down the CTRL (Windows) or OPTION (Macintosh) key. 
Selecting more than one object remain them in the same position relative to each other.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when moving objects with this tool.

Tech Note: Use this tool to create an instance of a solid rather than cutting/
copying and pasting which breaks the parent/child relationship. (Cobalt and
Xenon only.)
An instance is created when performing an operation on a solid or surface
and then moving it to another location. This instance object displays its own
unique Geometry page in Edit Objects.

Using the Move Tool 
The object may be selected before or after selecting this tool. The Message Line adjusts 
to accommodate this ability.
1. Select the Move tool. 

2. Click the Item or Face icon in the Message Line. The Message 
Line reads: Move: Select objects to move. [Shift = Extend]
Click the Item or Face icon in the Message Line. If the objects are 
already selected skip to step 4. The Message Line reflects the previous selection.

3. Select the object(s) to be moved.
The Message Line reads: Move: Pick beginning reference point. [Shift=Select, 
Ctrl=Copy (Windows) or Option=Copy (Macintosh)]

4. If necessary, use SHIFT-click to select more objects, and then pick a beginning 
point. The Message Line now reads, Move: Pick ending reference point. 
[Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)] 

5. Click an ending reference point or drag the selected object(s) to a new location. 
The reference and destination points need not be on the object(s) being moved. The 
move is performed relative to the specified points. 
The Status Line contains the dX, dY and dZ values of the move distance and direction. 

After the move and while the object is still selected, change a value in a data field and 
press ENTER (Windows) or RETURN (Macintosh) to accept the value.
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Tech Note: Be aware that when using this tool on an object that has had a
subtraction boolean operation, it is necessary also to move the subtracted
object. Otherwise, the subtraction operation may be altered or lost.

Rotate Tools

When selecting the Rotate tools icon a drop down menu appears in the Message Line 
containing two tools, Rotate by Angle (or by one point) and Rotate by 3 Points.

Use them to rotate a selected set of objects around a point in any axis, or to create a 
circular array. 
When rotating by one point or by three points, the selection can be copied by holding 
down the CTRL (Windows) or OPTION (Macintosh) key while selecting the objects. 
When selecting more than one object, they remain in the same position relative to each 
other.

Rotate by Angle Tool

This tool rotates one or more objects around a specified point. 
The Message Line contains a pull-down menu for specifying the 
rotation axis. 

The options include:

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when rotating objects with this tool.

Work Plane Normal Rotates the objects about the normal vector of the work plane.

X-Axis Rotates the objects about the X axis.

Y-Axis Rotates the objects about the Y axis.

Z-Axis Rotates the objects about the Z axis.

Arbitrary Rotates the objects about an axis specified by picking two 
points on screen.
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Using the Rotate by Angle Tool
Select the object before or after selecting this tool. The Message Line adjusts 
accordingly.
1. Select the Rotate tool. 

2. Click the Item or Face icon in the Message Line.
3. Select the Rotate by Angle tool in the Message Line. The Message 

Line reads: Rotate: Select items [or feature faces] to rotate. [Shift = 
Extend].
If the objects are already selected, skip to step 4. The Message Line reflects the 
previous selection.

4. Select the objects to rotate. 
The Message Line reads: Rotate by Angle: Enter location to rotate about 
[Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)].

5. Use SHIFT-click to select more objects. 
6. Select the rotation axis from the pull-down menu.
7. Specify the center of rotation.

The object is rotated.
The Status Line contains the X, Y and Z values of the rotation point and the rotation 
angle. After completing the rotation click in any data field and enter a new value.

Rotate 3 Points Tool

The Rotate 3 Points tool rotates an object 
based on three defining points, the center of 
rotation, a beginning reference point, and an 
ending reference point. The program 
determines the rotation angle from the two 
reference points. The two reference points 
need not be on the object.
Important: (Windows users) Because the 
CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the 
Stroke Zoom function (CTRL+SHIFT keys) is 
not available when rotating objects with this 
tool.
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Using the Rotate 3 Points Tool
Select the object before or after selecting this tool. The Message Line adjusts to 
accommodate this ability.
1. Select the Rotate tool. 

2. Click the Item or Face icon in the Message Line.
3. Select the Rotate 3 Points tool in the Message Line. The Message 

Line reads: Rotate: Select items [or feature faces] to rotate. [Shift = 
Extend]
If the objects are already selected, skip to step 4. The Message Line reflects the 
previous selection.

4. Select the objects to rotate. 
The Message Line reads: Rotate: Pick center of rotation [Shift=Select, Ctrl=Copy 
(Windows) or Option=Copy (Macintosh)]. If necessary, use SHIFT-click to select more 
objects. 

5. Click the rotation point. 
6. Click the first reference point.
7. Click the second reference point. 

The object is rotated. 
The Status Line contains the rotation angle.

After the rotation is completed and while the object is still selected, enter a new value if 
necessary. Press ENTER (Windows) or RETURN (Macintosh) to accept the value. 

Resize/Scale Tool

The Resize/Scale tool enlarges or reduces objects. The Message 
Line contains a pull-down menu with two options:

It is possible to copy the selection as it is scaled by holding down the CTRL (Windows) 
or OPTION (Macintosh) key. If more than one object is selected, they remain in the 
same position relative to each other. 
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when stretching objects.

Using the Resize/Scale Tool - Uniform Option.
This option/tool expands or shrinks the curves, surfaces and 
solids uniformly. Select the object before or after selecting this 
option. The Message Line adjusts accordingly. The graphic here 
shows uniformly scaled curves.

Uniform Maintains the proportions of the stretched objects. It can be 
used for curves, surfaces and solids.

Differential Specifies separate scales in the X, Y and Z axes. It can be 
used for curves, surfaces and solids.
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1. Select the Resize and Scale tool. In The Message Line reads: Resize and Scale: 
Select items [or feature faces] to scale [Shift = Extend].

2. Click the Item or Face icon in the Message Line.
If the objects are already selected skip to step 4. The Message Line 
reflects the previous selection.

3. Select the object(s) to scale. The option pull-down menu appears.
4. Select the Uniform option from the menu. When moving the pointer into the drawing 

area the pointer becomes the expand/shrink icon, shown here.

The Message line now reads, Resize/Scale: Pick anchor point [Shift = Select, Ctrl = 
Copy (Windows) or Option = Copy (Macintosh)]. It is possible to select more objects.

5. Click the anchor point on the geometry. This point remains fixed in the stretch. Use 
the SHIFT key to select more objects to stretch for this operation.
The Message Line now reads, Resize/Scale: Pick beginning reference point [Ctrl = 
Copy (Windows) or Option = Copy (Macintosh)].
The beginning reference point is a point on the geometry used in conjunction with the 
ending reference point to set the scale of the operation. Rather than specifying 
reference points just enter a value in the Scale data field and press ENTER 
(Windows) or RETURN (Macintosh) and the object will scale.

6. Click the beginning reference point.
The Message Line reads: Resize/Scale: Pick ending reference point [Shift=Select, 
Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

7. Click the ending reference point. The scale factor is calculated based on the begin-
ning reference point and this point.
The selected object is resized. The Scale is displayed in the Status Line data field.

After completing the scale and while the object is still selected, enter a new value scale. 
Press ENTER (Windows) or RETURN (Macintosh) to accept the new value.
The Status Line contains the Scale factor. Entering a number between zero (0) and one 
(1) reduces the object. Entering a value above 1 enlarges the object. 

Using the Resize/Scale Tool - Differential Option
This option/tool scales the curves, surfaces and solids differentially. Select the object 
before or after selecting this option. The Message Line adjusts to accommodate this 
ability. The graphic here shows a differentially scaled solid.

1. Select the Resize/Scale tool. The Message Line reads: Resize/Scale: Pick items [or 
feature faces] to scale. [Shift = Extend]

2. Click the Item or Face icon in the Message Line. 
If the objects are already selected skip to step 3. The Message Line 
reflects the previous selection.
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3. Select the object(s) to scale.
The option pull-down menu appears.

4. Select the Differential option from the menu. When moving the pointer into 
the drawing area the pointer becomes the scale icon, shown here:
The Message Line reads: Scale: Enter point to scale about. [Shift = Select, 
Ctrl = Copy (Windows) or Option=Copy (Macintosh)]. If necessary, use SHIFT-click to 
select more objects.

5. Enter the X, Y and Z Scale values in the Status Line.
6. Click a point about which the object will be scaled. 
The Status Line contains the X-Scale, Y-Scale and Z-Scale data fields.

After completing the scale, while the object is still selected, new values can be entered. 
Press ENTER (Windows) or RETURN (Macintosh) to accept the new values. 

Tech Note: When using the Differential option of the Resize/Scale tool for
surfaces and solids, the stretched object displays its own Geometry page in
Edit Objects.

Mirror Tool

The Mirror tool creates a mirror image of an 
object or objects on the opposite side of a 
reference line. Copy the selection by holding down 
the CTRL (Windows) or OPTION (Macintosh) key. 
Selecting more than one object they remain in the 
same position relative to each other. 
The Message Line contains a pull-down menu 
with five options for specifying the mirror 
reference line or plane.

Tip: When using the plane options, it may be helpful to display the Axis for
reference. Choose Layout>Show Axis.

2 Points Mirrors the object around the reference created by the two 
specified points.

XY Plane Mirrors the object around the XY plane.

ZY Plane Mirrors the object around the ZY plane.

ZX Plane Mirrors the object around the ZX plane.

3 Points Mirrors the object around the mirror plane specified by three 
points.
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Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when mirroring objects.

Using the Mirror Tool - 2 Points Option
The object can be selected before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
1. Select the Mirror tool. The Message Line reads: Mirror: Pick items [or feature faces] 

to mirror [Shift = Extend].

2. Click the Face or the Item icon in the Message Line.
If the objects are already selected, skip to step 4. The Message Line 
you see reflects the previous selection.

3. Select the object(s) to be mirrored.
An option pull-down menu appears.

4. Select the 2 Points option in the pull-down menu. The Message Line reads: Mirror: 
Pick beginning of reference line. [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)]
If necessary, use SHIFT-click to select more objects.

5. Click a location to set the beginning of the reference line around which the object 
mirrors. The Message Line now reads, Mirror: Pick end of reference line. [Ctrl = 
Copy (Windows) or Option = Copy (Macintosh)]
Drag to specify the beginning and endpoints and the object mirrors.

6. Click to locate the end of the reference line. 
The reference line need not be parallel to the object.

Using the Mirror Tool - XY Plane Option
The object can be selected before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
1. Select the Mirror tool. 

2. Click the Item or Face icon. The Message Line reads: Mirror: Pick 
items [or feature faces] to mirror. [Shift = Extend]
If the objects are already selected skip to step 4. The Message Line 
reflects the previous selection.

3. Select the object(s) to be mirrored.
An option pull-down menu appears.

4. Select the XY Plane option in the pull-down menu. The Message Line reads: Mirror 
1 Point: Enter 1 point for mirror origin. [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)]
Use SHIFT-click to select more objects.

5. Click a point in the XY plane to specify a reference point for the mirror.
Using the Mirror Tool - ZY Plane Option
The object can be selected before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
1. Select the Mirror tool.

2. Click the Item or Face icon. The Message Line reads: Mirror: Select 
items to mirror [Shift = Extend].
If the objects are already selected skip to step 3. The Message Line 
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reflects the previous selection.
3. Select the object(s) to be mirrored. An option pull-down menu appears.
4. Select the ZY Plane option in the pull-down menu. The Message Line reads: Mirror 

1 Pt: Enter 1 point for mirror origin [Shift= Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)].
Use SHIFT-click to select more objects.

5. Click a point in the ZY plane to specify a reference point for the mirror.
Using the Mirror Tool - ZX Plane Option
The object can be selected before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
1. Select the Mirror tool. 

2. Click the Item or Face icon. The Message Line reads: Mirror: Pick 
items [or feature faces] to mirror. [Shift = Extend]
If the objects are already selected skip to step 4. The Message Line 
reflects the previous selection.

3. Select the object(s) to be mirrored. An option pull-down menu appears.
4. Select the ZX Plane option in the pull-down menu. The Message Line reads: Mirror 

1 Point: Enter 1 point for mirror origin. [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)]
Use SHIFT-click to select more objects.

5. Click a point in the ZX plane to specify a reference point for the mirror.
Using the Mirror Tool - 3 Pts Option
The object can be selected before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
1. Select the Mirror tool. 

2. Click the Item or Face icon. The Message Line reads: Mirror: Pick 
items [or feature faces] to mirror. [Shift = Extend]
If the objects are already selected skip to step 4. The Message Line 
reflects the previous selection.

3. Select the object(s) to be mirrored.
An option pull-down menu appears.

4. Select the 3 Points option in the pull-down menu. The Message Line reads: Mirror 3 
Points: Enter 3 points for mirror plane. [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)]
Use SHIFT-click to select more objects.

5. Click three points to specify a reference plane for the mirror.
There are no Status Line entries for the Mirror tools.

Copy along Path Tool

The Copy along Path tool copies an object along a 
path by the number of specified times. The objects will 
be equally spaced along the curve.
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Align the copies along the X, Y and Z axis (the 
alignment axis). The graphic here shows a polygon 
created in the Top plane with a Z alignment axis.

Using the Copy Along Path Tool 
Select the object before or after selecting this tool. The Message Line adjusts to 
accommodate this ability.
1. Select the Copy along Path tool. 

2. Select the Item or Face icon in the Message Line. The Message 
Line reads: Copy Along Path: Select items [or feature faces] to 
duplicate. [Shift = Extend]
If the objects are already selected skip to step 3. The Message Line reflects the 
previous selection.

3. Select the objects to copy.
The Message Line now reads: Copy along Path: Select the translation path for 
objects.

4. Enter the number of objects to copy in the Qty (Quantity) field of the Status Line.
5. Click the path curve. The Message Line reads: Copy Along Path: Enter copy origin.
6. Click the point where the copy should begin. The Message Line reads: Copy: along 

Path: Enter two points for alignment axis.
The copies can be aligned along the X, Y or Z axis. Use the Drafting Assistant to 
choose the desired axis.

7. Pick two points on the screen to show where to align the object(s).
The Status Line contains the Qty (Quantity) field displaying the number of objects this 
Designer Elements program will create. Set this value before copying the objects.

Linear Duplicate Tool

The Linear Duplicate tool creates copies of an object in a rectangular array.
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To complete the array, set the 
number of horizontal rows and 
vertical columns and the amount of 
space between each object in the 
array. This is done through the 
Linear Duplicate dialog box.

The dialog box contains the 
following options:

Number per row (Columns section) This field sets the total number of objects 
per row. Be sure to include the selected object in this total 
count.

If the number is unknown, use math operators to determine the 
number of copies. For example, to place studs 16 inches apart 
on a 17 foot wall, enter (17*12)/16. The program will truncate 
the result to 12 copies.

Offset X*, Y*, Z* (Columns section) These fields set the offset length in the X, Y 
or Z direction for the duplicated objects. These values work 
with the Total offset and Step offset options. Enter these values 
or drag in the drawing area to enter the values.

Total offset (Columns section) When selected, this option specifies that the 
offset values in the X, Y and Z fields are the total offset values 
from the selected object to the last copy.

Step offset (Columns section) When selected, this specifies that the 
values in the X, Y and Z fields are step offset values from the 
selected object to the first copy.

Number of rows (Rows section) This field sets the total number of rows.
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The asterisk (*) indicates that the value automatically fills in when dragging the pointer 
in the drawing area to indicate the offset or spacing.

Using the Linear Duplicate (Rectangular Arrays) Tool
Select the object before or after selecting this tool. The Message Line adjusts to 
accommodate this ability.

1. Select the Linear Duplicate tool. 

2. Select the Items or Faces icon in the Message Line. 
3. The Message Line reads: Linear Duplicate: Select objects for linear 

duplicate. [Shift = Extend]
If the objects are already selected the Linear Duplicate dialog box appears. Skip to 
step 4.

4. Select the object(s) to be duplicated. The dialog box appears. 
The Message Line now reads: Input Set  (followed by hints for the highlighted field in 
the dialog box)

Spacing* (Rows section) This field sets the perpendicular spacing for 
rows. This field operates with the Total spacing and Step 
spacing options. 

Total spacing (Rows section) When selected, this option specifies that the 
Spacing value is the total spacing from the selected object to 
the last copy. This option works with the Spacing field.

Step spacing (Rows section) When selected, this option specifies that the 
Spacing value is the distance from the first selected object to 
the first copy. This option works with the Spacing field.

OK/Cancel Click OK to complete the operation. Click Cancel to 
discontinue the operation.
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5. Enter the number of columns in the Number per row data field.
6. Select offset option, either Total or Step.
7. If the Offset X* field is not selected, click in the field.
8. Move the pointer to the drawing area and drag to indicate the offset for the row of 

copies. Values automatically appear in the X*, Y* and Z* data fields.
9. Select the spacing option, either Total or Step.
10. If the Spacing* field is not selected, click in the field.
11. Move the pointer to the drawing area and drag to indicate the spacing for the spac-

ing for the rows.
12. Click OK to close the dialog box and create the duplicates.
There are no Status Line entries.

Polar Duplicate Tool

The Polar 
Duplicate tool 
copies a selection 
around a central 
point. The entities 
in the selection 
may be rotated as 
they are copied or 
remain upright. 

The number and 
location of duplicates are 
controlled through the Polar 
Duplicate dialog box.
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The dialog box contains the following options:

Number Sets the total number of objects. Be sure to include the 
selected object in this total count.

Center X*, Y*, Z* Set the X, Y and Z location for the center of the circular array. It 
is possible to enter these values or click the place in the 
drawing area for the center.

Translate duplicates When selected, creates copies in the same orientation as the 
original object. When this option is not selected, copies are 
rotated around the center specified. 

Ref X*, Y*, Z* Represent the reference point for the Translate duplicates 
option.

Ref X, Y and Z determine the imaginary point duplicated 
around the center specified. The selected objects are 
reproduced in the same position relative to each imaginary 
point duplicated. The imaginary Ref point and center point are 
indicated in the example here.

Specify the Ref point by entering values or clicking at the 
desired location in the drawing area.

Angle Specifies the angle of rotation. This field operates with the 
Total angle and Step angle options.

Translate Duplicates 
Option On

Translate Duplicates 
Option Off
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The asterisk (*) indicates that the value automatically fills in when dragging the pointer in 
the drawing area to indicate the offset or spacing.

Using the Polar Duplicate Tool
Select the object before or after selecting this tool. The Message Line adjusts 
accordingly.
1. Select the Polar Duplicate tool

2. Select the Items or Faces icon in the Message Line. The Message 
Line reads: Polar Duplicate: Select items [or feature faces] to polar 
duplicate. [Shift = Extend]
If the objects are already selected the Polar Duplicate dialog box appears. Skip to step 
4.

3. Select the object to be duplicated. The dialog box appears.
The Message Lines reads, Input Set  (followed by hints for the highlighted field in the 
dialog box)

4. Enter the number of objects in the circular array.
5. If the Center X* data field is not selected, click in the field.

Total angle When selected, this option specifies that the angle value is the 
total number of degrees between the center of the selected 
object and the center of the last object. (If 360° is the specified 
angle, the last object is the selected object.) The result on the 
left has a rotation angle of 3600, where the result on the right 
changes the rotation angle to 1200

Step angle (Rotation section) When selected this option specifies that the 
angle value is the angle between the center of two adjacent 
objects.

Grid Fills the area of the pattern with the maximum amount of the 
features.

Rings Designates the number of concentric rings in a pattern.

Spacing Designates the spacing between the rings.

OK/Cancel Click OK to complete the operation. Click Cancel to 
discontinue the operation.

Ref X*, Y*, Z* Represent the reference point for the Translate duplicates 
option.

360° Rotation Angle 120° Rotation Angle
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6. Move the pointer to the drawing area and click the center point of the array in the 
drawing area. Values automatically appear in the X*, Y* and Z* data fields.

7. To make objects to be upright in the same orientation as to the selected objects, 
select the Translate Duplicates option.

8. If Translate Duplicates is specified, click a location for the reference point in the 
drawing area.

9. Select the angle option, Total or Step.
10. Enter the angle of rotation in the Angle field or drag in the drawing area along the 

desired angle using the Draft Assistant.
11. Click OK.
There are no Status Line entries. 

Spherical Duplicate Tool
The Spherical Duplicate tool copies a selection of either items or faces in a sphere 
around a central point.

The number and location of duplicates are controlled through the Spherical Duplicate 
dialog box. 

The dialog box contains the following options:

Center X*, Y*, Z* Sets the X, Y and Z location for the center of the spherical 
array. Enter these values or click the location in the drawing 
area for the center.

Axis Direction X*, Y*, 
Z*

Sets the direction of the axis from which all the parallels will be 
calculated.

Prim Meridian X*,Y*, 
Z*

Sets the principal meridian which is the beginning point of 
calculating of location of all the other meridians. 
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The asterisk (*) indicates that the value is automatically filled in when dragging the 
pointer in the drawing area to indicate the offset or spacing.

Using the Spherical Duplicate Tool

1. Select the Spherical Duplicate tool.

2. Select Item or Faces from the Message Line. 
3. The Message Line reads: Spherical Duplicate: Select Feature Faces [or Items] to 

spherically duplicate.
4. Select the item or faces to duplicate. The dialog box appears.
5. Enter the values for axes location or click them with the pointer in the drawing area 

and the values will appear in the appropriate field. 
6. Specify the number of features/items to be duplicated in vertical and horizontal 

directions and the angle for which the feature/item to be duplicated on the sphere's 
surface.

7. Click OK.
The face/item duplicates according to the specified values.

Vertical Number Sets the total number of faces or items in the 
plane, going through the axis of the sphere. Be 
sure to include the selected one in this total count.

Vertical Angle Sets the angle between objects in the plane that goes through 
the axis of the sphere.

Horizontal Number Sets the number of repetitions of the item or face in 
the horizontal plane along the specified axis of the 
sphere.

Horizontal Angle Designates the angle by which the objects, specified in the 
Vertical Number and Vertical Angle, are twisted.

Total Angle Defines the angle to which the duplication will be spread. A 
360° angle spreads the features or items all along the sphere.

Step Angle Sets the angle of the single step for which the feature/item will 
be duplicated.

Associative 
Duplicates

Creates each duplicate as an instance of the original. 

Center X*, Y*, Z* Sets the X, Y and Z location for the center of the spherical 
array. Enter these values or click the location in the drawing 
area for the center.
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To modify the duplication, use Status Line entry fields, the Feature Tree, or double click 
the object to open Edit Object dialog box. 

The Spherical Duplicate tool duplicates a face in accordance with the data set in the 
Spherical Duplicate dialogue box.

Cylindrical Duplicate Tool

The Transformation tools palette now includes a Cylindrical Duplicate tool for items 
and faces. The Cylindrical Duplicate tool copies a selection of either items or faces in a 
cylinder around a central axis.
The Cylindrical Duplicate tool has options found in the Message Line when the tool is 
selected:
These options set the axis of the cylinder.
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The number and location of duplicates are controlled through the Cylindrical Duplicate 
dialog box. 

The dialog box contains the following options:

The asterisk (*) indicates that the value is automatically filled in when dragging the 
pointer in the drawing area to indicate the offset or spacing.

Using the Cylindrical Duplicate Tool

1. Select the Cylindrical Duplicate tool.

2. Select Item or Faces from the Message Line. 

Number Sets the number of items/faces in the ring.

Center X*, Y*, Z* Sets the X, Y and Z location for the center of the cylindrical 
array. Enter these values or click the location in the drawing 
area for the center.

Rotation Angle* Designates the area used for the duplication, measured in 
degrees.

Rings Sets the number of circles of items/faces in the cylinder array.

Spacing Specifies the distance between the rings.

Turn Angle Designates the shift of the following ring relative to the 
previous around the axis.

Hexagon Designates that each ring of the items/faces is located one-half 
twist relative to the previous one.

Associative 
Duplicates

Creates each duplicate as an instance of the original.
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3. The Message Line reads: Cylindrical Duplicate: Select items/[or feature faces] to 
cylindrically duplicate.

4. Select the item or faces to duplicate. The dialog box appears.
5. Enter the values for the center of the cylinder duplicate and number of the items/

faces in a ring of the cylinder duplicate. It is possible to click in the drawing area to 
specify the center.

6. Fill in the Rotation and Rings along Axis fields as desired.
7. Click OK.
The duplication is performed reflecting the values specified in the Cylindrical Duplicate 
dialog box.
To modify the feature duplication, use the Status Line entry fields, the Feature Tree, or 
double click the feature to open Edit Object dialog box. 
This graphic shows an object with a face to be duplicated with the Cylinder Duplicate 
tool. 

The settings in the dialog box 
duplicate the features as in this
picture.

This graphic shows the same
features duplicated with the Hexagon
option checked.
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Align Objects Tool

Cobalt, Xenon and Argon can align any object created using the Align tool. This 
includes aligning text objects with other text objects and text objects with geometry.

Using the Align Command
1. Select the Align tool.

2. Select the alignment type from the pull down menu in the Message Line.
3. Hold down the SHIFT key and select the text and geometry to align.
4. Click in the drawing area to pick an alignment point.
The objects align.
For more detailed information regarding the Align Tool see Editing Objects

Transforming Techniques
There are many ways to accomplish the same transformation task in this Designer 
Elements program. This section includes some of those ways.

Moving Objects with Tools
When an object is selected, move the pointer near the object until the 4-way Move 

symbol appears as shown below, and drag the object to a new location.
Note: If the 4-way Move symbol doesn't appear, make sure the Selection tool is active.
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Using the Drafting Assistant for Moving
When the pointer becomes the 4-way Move symbol, drag the object around and see the 
Drafting Assistant’s notations relative to the object’s location when pressing the mouse 
button. This way, if the pointer is moved over a control point so the Drafting Assistant 
activates it, it is possible to align the object being moved with that point.

Selected Move versus Move Tool
Objects can be moved either with the Selection tool or with the Move tool.

Moving with the Selection Tool

The move function of the 
Selection tool allows free 
movement of the selected 
object.
To move a circle from one location to another as shown above, use the Selection tool 
and the Drafting Assistant to align the 90° quadrant with the corner of the rectangle. The 
circles do not need to touch the rectangle to be aligned with it.

Moving with the Move Tool

The Move tool in the Transformation subpalette moves the selection with reference to 
other geometry in the X, Y and Z direction.
Move a 1-inch square 2 inches in the X direction and 1 inch in the Y direction. See the 
following graphic.

1. Select the Move tool.

2. Select the square to be moved.
3. Click one corner of the square when the endpoint notation is displayed.

2X -1Y 0Z

endpoint
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4. Enter 2 in the dX entry field on the Status Line and -1 in the dY entry field. A positive 
or negative value entered in the Status Line determines the direction along the X or 
Y axis. A negative value moves the object to the left or down on the screen and a 
positive value moves the object to the right or up.

5. Press the ENTER (Windows) or RETURN (Macintosh) key. The square is moved.

Moving Objects to Another Layer
1. Choose Window>Edit Objects.

2. In the Layer field, scroll down to the layer on which the object will be relocated.
3. Click OK. The object is now located on the new layer.

Copying Objects with Tools
Copy selections with the Copy command, as discussed earlier, or by holding down the 
CTRL (Windows) or OPTION (Macintosh) key using these tools:
• Selection tool
• Single Line tool
• Center-Point and Opposite-Point Circle tools
• Ellipse tools
• Conic tools
• Polygon tools
• Project Curve tool
• Transformation tools

Copying with the Selection Tool
Hold down the CTRL (Windows) or OPTION (Macintosh) key and drag a copy of the 
selection to a new location. 
When using the Selection tool to copy a surface or solid using this technique, create an 
instance of the original object. All changes made to the original object are automatically 
reflected in the instance (Cobalt and Xenon only). If you do not want to create an 
instance, select the original object, choose Edit>Copy and then Edit>Paste. 
1. Choose the Selection tool.

2. Select the object(s) to copy.
3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
4. Drag a copy of the selection to a new location. The copy is placed on the current 

work layer.

Copying with the Geometry Tools
Make copies with the following drawing tools:
• Single Line tool
• Center-Point and Opposite-Point Circle tools
• Ellipse tools
• Conic tools
• Polygon tools
• Project Curve tool
To create a copy with the drawing tools proceed as follows:
1. Construct the geometry to copy.

2. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
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3. Click a new location. The click determines the location of the first point specified 
during the construction of the original geometry (the center of a Center-Point Circle, 
for example).

Copying with the Transformation Tools
Hold down the CTRL (Windows) or OPTION (Macintosh) key while using a 
transformation tool to make a copy of the selected geometry.
1. Select one of the transformation tools.

2. Select the object to copy and transform.
3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
4. Perform the transformation according to the directions in the Message Line.

Copy CTRL (Windows) or OPTION (Macintosh) versus Copy Command
Normally, using the copy option of a geometry tool is faster than using the Copy and 
Paste commands in the Edit menu. The Copy and Paste commands are useful for 
copying to a different document or application.

Sizing Objects with Tools
Normally an object is sized with the Selection tool. In some cases it is useful to use the 
Move tool for sizing objects.

Sizing an Object with the Selection Tool
Stretch objects by selecting a point and dragging it to a new location.
1. In the Edit menu, be certain that Selectable Points is set.

2. Click the Selection tool.
3. Drag a selection fence around the control points that represent the area to stretch.
4. Drag the points to a new location.

Intersecting lines can be dragged
to new lengths.

A line can be dragged to a new
length.
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Sizing an Object with the Move Tool
The Move tool specifies the distance the selected point(s) should be moved by specific 
values along the dX, dY  and dZ direction in the Status Line.
To move the corner of the single line rectangle in the next graphic with the Move tool, 
proceed as follows:
1. In the Edit menu, be sure that Selectable Points is set.

2. Click the Selection tool.
3. Drag a selection fence around the lower right corner of the rectangle.

4. Select the Move tool.
5. Enter +1 in the dX data field, a -1 in the dY field and a 0 in the dZ field.

Press the ENTER (Windows) key or the RETURN (Macintosh) key.
The corner of the rectangle is moved the distance specified in the Status Line.

Selected Sizing versus Expand/Shrink Tool
Dragging a control point of a selected object not only changes the size of the object, but 
distorts the object by changing the proportion between height and width. 

The Resize/Scale tool on the Transformation subpalette enables resizing geometry 
while maintaining its proportions.

In addition, proportions can be specified by clicking points on other geometry. For 
example, resize an object to fit within another object by clicking the boundary into which 
the resized object must fit.

Use the Resize/Scale tool to enlarge or 
shrink a shape proportionally
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Architectural Features

Architectural features such as walls, doors and windows are introduced further in this 
chapter. 
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Wall Tool
Similar to those found in Graphite, Smart Walls are double lines that are automatically 
trimmed at the intersections when the walls are on the same layer. Thickness, height, 
angle and length are specified in the Status Line. Optional properties include hatch 
pattern, hatch color, trimming, single or double lines and wall orientation such as center 
line, inside or outside.

Using the Wall Tool
1. Select the Single Wall tool. 

2. Choose one of the 
3. The Message Line reads: Single Wall: Pick the first wall point.
4.
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Door Tool
Doors are inserted in wall segments. When viewed from the top, the arc and width of the 
door appear. From all other views, the door appears as a 3D object. Options include 
single and double doors.

Window Tool
The Windows tools if for adding windows to a wall segment. Like the doors, the windows 
appear appropriately in top vs. other three-dimensional views. Windows can have 
overlapping, tight or standard sills.
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Pen Settings
This chapter describes various options for adapting Cobalt, Xenon and Argon to your 
needs.

Default versus Selected Object Settings
When no object is selected, any changes made to the settings become the default for all 
open files. When an object is selected, any change made will only affect the object.
The following topics are covered:
• Style
• Color
• Weight
• Pattern
• Arrowheads
There are three options for setting pen characteristics, pen color, weight and pattern.
It is possible to change the pen characteristics for selected objects or choose one or 
more of these characteristics as the default setting for a file.

Changing the Pen Characteristics of an Object
1. Select the object.

2. Choose Pen>Color, Weight or Pattern and select any one for the selected object. 
This change only affects the selected objects. It does not affect the default setting for 
future objects created.

Changing the Default Pen Characteristics
To change a pen characteristic so that all future objects have that characteristic, choose 
the characteristic without having any object selected.

Style
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The Pen>Style menu contains commands for 
creating and modifying pen styles. A pen style 
is a collection of pen attributes such as color, 
weight and pattern.
User Pen Styles are available globally and not 
just per drawing. New pen styles are 
automatically saved in a PenStyles.ini file so 
they are available for all drawings once a new 
style is created.
Pen Styles are dynamic. This means that after 
pen styles are created and assigned to a 
drawing, it is possible to go back and modify 
the pen style and have all objects using that 
pen style update.
The first three menu options provide tools to 
easily create, delete and modify user defined 
pen styles. The next nine pen styles are factory-set and can only be changed by hand 
editing the PenStyles.ini file.

Creating a New Pen Style
To create a new pen style choose Pen>Style>New 
from the drop down menu. Specify the name, color, 
weight, pattern and scale, clicking OK to create the 
new style. All pen styles created are listed below the 
factory-set pen styles.

Deleting a Pen Style
To delete a pen style choose Pen>Style>Delete from 
the drop down menu and choose one of the user-created styles. The factory-set pen 
styles cannot be deleted.

Modifying a Pen Style
To modify a pen style choose Pen>Style>Modify from the drop down menu. Change the 
style in the dialog box and press Apply for the changes to take effect.

Color
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There are 256 color options including 239 user 
definable colors and 17 predefined colors. Each 
definable color can be assigned independently 
from the 16.7 million colors available.
The color submenu displays eight of the defined 
colors by name, including black, white, red, 
yellow, green, cyan, blue and magenta. The 
submenu also includes the More option, which 
displays a color palette with more colors.

Tip: The fill color for polygons is set in the Pen Color. See Fill and
Crosshatching.

Displaying the Color Palette
1. Choose Pen>Color>More.

The Color palette appears.
2. Display 8, 16, 144 or the full 256 color palette. The 

default color palette displays 256 colors. Click the 
button in the upper right corner of the title bar.
Cycle through the number of colors displayed by 
continuing to click the same button.

Specifying the Color of the Current Pen
1. Choose Pen>Color. The submenu appears.

2. Choose the color desired.
The pen takes on the new color selected in the submenu.

This Color command specifies the color of the current pen and any other selected 
geometry without changing any other pen characteristics.

Defining Colors
It is possible to define as many as 239 colors. When a color is defined it is defined for 
both the file and for the program.
Because the color displays are different for Windows and Macintosh machines, the 
process for defining a color varies slightly. See your Windows or Mac documentation for 
information on how to define custom colors on your platform.
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1. To define a new color, choose Pen>Color>More. The color palette displays.

2. Double-click on one of the definable colors.
The first 17 are not definable. If you attempt to redefine one of those you receive the 
following error message.

If the color is definable, the color display dialog box for your platform appears. Follow 
the directions in your Windows or Mac operating system documentation on how to 
create a custom color.

3. Once the color is selected, click OK, the color display closes and returns to color 
palette.

4. Double-click on the color name field, 
where the old name currently dis-
plays. The following dialog box 
appears.

5. Enter the new name for the color 
and click OK.
The color palette returnes once again 
with the new color name shown.

6. Repeat this process to define up to 
239 colors.

These colors save with the file and the program for future use.

Weight
This command in the Pen menu sets the pen width 
of the current pen pattern and the selected lines 
without changing any other pen characteristics.
It is also possible to set a line weight based on 
units, pixel thickness and through the More option 
by the point size or model space.

Units
The line weights shown depend on the units 
selected in the Preferences dialog box. If metric 
units are selected, the line weight shows in 
millimeters instead of inches.

Pixels
The pixel weight depends on the screen resolution 
and so remains constant from zoom to zoom.
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More
Choose More and the Pen Weight dialog box appears. 
Enter the size and select the units of measure from the 
drop down menu.
Click OK to accept the pen weight or Cancel to close the 
More dialog box.

Note: Any line thickness of less than .016 inch appears one pixel wide on
the screen. When printing or ploting such lines, they appear with the
different weights.

Tip: Even if the preference settings are set to one type of unit, such as
inches, in this dialog box the pen units can be set to a different unit of
measure, such as millimeters, if desired.

Specifying a New Weight for the Current Pen
1. Choose Pen>Weight. The submenu appears.

2. Drag to the desired weight. 
The pen takes on the new weight, selected in the submenu.

Pattern
The pen pattern determines the appearance of lines on the screen and during plotting. 
Any line thickness of less than .016 inch appears one pixel wide on the screen. When 
printing or ploting such lines, they appear with the weights.
The default pen pattern is Solid. The default color for all patterns is black. The default 
weight for all patterns is 1 pixel.
There are nine default pen 
patterns in the Pattern submenu 
of the Pen menu.
Create custom pen patterns and 
access them through the Line 
Pattern dialog box by choosing 
Pen>Pattern>More.
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Line Pattern Manager
The Line Pattern manager appears 
when Pen>Pattern>More is chosen. 
If nothing is selected the dialog box is 
called Default Line Pattern and the 
pattern becomes the default pattern 
for the drawing. If an object is 
selected the dialog box is called 
Object Line Pattern and the pattern 
selected only applies to the selected 
object. Both dialog boxes display the 
pen patterns that are available for 
creating and editing geometry. It is 
possible to edit these patterns using 
the options provided.

The Line Pattern manager contains the following items:

New Patterns
Each line pattern displays according to two description lines of the Cadd.lin file in the 
Environ folder.

Add new patterns by opening the file in an ASCII text editor and creating two new 
description lines per pattern.
The first line contains the pattern line name plus a descriptor string. The second line 
contains the length attribute for dashes, spaces and dots. A zero (0) value indicates a 
dot and a negative value indicates a blank space.

Creating a New Pattern
1. Quit your Designer Elements program, if it is running.

2. Open the Cadd.lin file in an ASCII text editor.
3. After the last line pattern, enter the name of the new pattern. Give it a name not 

already used.

Patterns This section contains all the patterns available.

Scale This field contains the value by which the pattern dashes and 
spaces are multiplied to obtain the same pattern at a different 
size. Enter a specific value or use the slide to set the scale. 
The graphic below is an example of the phantom line with 
scale values of 1, 2 and 3.

(Scale 1) ___ _ _ ___ _ _ ___ _ _ ___ _ _ ___ _ _ 

(Scale 2) ______ __ __ ______ __ __ ______ __ 

(Scale 3) ____________ ____ ____ __________
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4. In the same line, enter a descriptor string. This string is simply a visual representa-
tion of the pattern that will display in the Line Pattern Manager next to the name. 
(See the other patterns for an example). Use the periods, dashes and the space key 
on your keyboard to create the descriptor.

5. Begin the second line with a capital “A” followed by the length of the attributes. Each 
attribute should be followed by a comma and contain no spaces.

6. Save the file.
7. Restart your Designer Elements program.

Tech Note: The location of the Cadd.lin file for the line patterns varies with the
program, the version, the platform and the version of the operating system. It
can be found under User, Workgroup, System (Mac only) and/or Program. For
specific information on your version try the knowledgebase in the Support
Center on the website at www.ashlar.com.

Editing Patterns
Any pattern can be edited in two ways:
• Make changes to the Cadd.lin file in an ASCII editor.
• Choose settings in the Line Pattern Manager.

Making Changes in the Cadd.lin file
1. Quit the Designer Elements program, if it is running.

2. Open the Cadd.lin file, in an ASCII text editor.
3. Make the desired changes to the patterns. If a default pattern, name or descriptor is 

changed, it will be reflected in the Pattern submenu.
4. Save the file.
5. Restart the Designer Elements program.

Tip: To make changes to the default patterns, copy the original file to another
location or rename it and keep it in the same location before making changes.
Then, if it is necessary to return to the original factory settings, simply replace
the Cadd.lin file with this original file. 

Tech Note: The location of the Cadd.lin file for the line patterns varies with
the program, the version, the platform and the version of the operating
system. It can be found under User, Workgroup, System (Mac only) and/or
Program. For specific information on your version try the knowledgebase in
the Support Center on the website at www.ashlar.com.

Choosing Settings in the Line Pattern Manager
1. Choose Pen>Pattern>More. The Line Pattern Manager displays.

2. Select the pattern to modify.
3. Enter a value in the Scale field.
4. Click OK to accept the changes or Cancel to close the Line Pattern Manager. 

If any objects are selected, they will reflect the changes. The current pen pattern will 
not be affected unless it was the pattern that was edited.
If no objects are selected, clicking OK will change the current pen pattern to the edited 
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pattern.
Important: Changes made here affect all open files.

Specifying a New Pattern for the Current Pen
1. Choose Pen>Pattern. The submenu appears.

2. Drag to the desired pattern. The pen takes on the new pattern, selected in the sub-
menu.

Specifying a New Pattern for a Selected Object
1. Select the object.

2. Choose Pen>Pattern.
3. Drag to the desired pattern. The pen takes on the new pattern, selected in the sub-

menu.

Construction Line Pattern
A construction line uses a dotted line pattern. It cannot be modified and is not affected 
by changes to the dot pattern. The default color is magenta. To create construction 
geometry on the construction layer, use the dotted line pattern.

Arrowheads
To use arrowheads on lines or circular arcs 
that are not a part of dimensions, specify the 
placement of arrowheads in the Pen menu. Have 
an arrowhead at the beginning or end of a line or 
circular arc, or at both the beginning and end.

Arrowhead Types
The Arrowheads submenu offers eight arrowheads 
for arrow lines. Select the preferred style.
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Arrow Size Command
This command in the Pen menu specifies the size of the selected arrowhead.

By changing any value in the Length, Height, Side, or Angle entry fields, the values are 
changed in the other entry fields accordingly.

Arrow At Start
This command in the Pen menu places an arrowhead at the beginning of selected and 
subsequent lines and circular arcs. Choose the type of arrowhead from the Pen menu. A 
check indicates the current arrowhead setting. Change the default setting by saving 
changes in the preferences file.

Arrow At End
This command in the Pen menu places an arrowhead at the end of selected and 
subsequent lines and circular arcs. Choose the type of arrowhead from the Pen menu. A 
check indicates the current arrowhead setting. Change the default setting by saving 
changes in the preferences file.

The start and end of a line and an arc are determined by the point that was created first.

Diameter/Length Specifies the diameter or length of circular arrow styles and the 
length of all slash or standard arrow styles. The value here 
affects all Length, Side and Angle fields. The value displays in 
the current units specified in the Units page of the Preferences 
dialog box.

Length Specifies the length of the arrowhead as the horizontal 
distance from its tip to the furthest extension of its base.

Height Specifies the height of the arrowhead as the vertical distance 
of its base.

Side Specifies the length of the edge of the arrowhead.

Angle Specifies the angle of the tip of the arrowhead.

No arrow at start No arrow at end

Arrow at start
No arrow at start

Arrow at start

No arrow at end

Arrow at end
Arrow at end
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Line Tools

The Line tools in the Line tool palette create line segments, connected lines, lines 
parallel to existing lines and points. Creating a line, the coordinate locations, line length 
and angle from horizontal appear in the Status Line. All geometry appears in the current 
pen specifications for color, weight and pattern.
Values for each tool can be entered in the Status Line to define a line after it is created. 
If values are entered in the selected Status Line data field after creating the line and 
while the line is still selected, pressing ENTER (Windows) or RETURN (Macintosh) 
updates the line to reflect the new values.
The topics explained here include
• Single Line Tool
• Mid-point Line Tool
• Connected Lines Tool
• Parallel Line Tool
• Point Tool
• Modifying Lines
Cobalt, Xenon and Argon do not support Smart Wall entities found in Graphite. All 
imported Smart Walls are converted into individual curves.

Single Line Tool

This tool draws a line between two points. Click points to draw a line.

Point 2

Point 1
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Using the Single Line Tool
1. Select the tool. The Message Line reads: Single Line: Pick the beginning point. [Ctrl 

= Copy Previous] (Windows) or [Option = Copy Previous (Macintosh)].

2. Click to place the first endpoint of the line.
3. Move the cursor to a new location. A rubberband image appears that previews the 

construction.
4. Click to place the last point of the line.
To copy the line just created, as the Message Line indicates, hold down the CTRL 
(Windows) or the OPTION (Macintosh) key and click once in the drawing area to set the 
beginning point. An identical line appears beginning where it is clicked and on the 
current work plane.
The Status Line contains the X, Y, and Z coordinates of the beginning, the relative 
location of the end (delta X, delta Y and delta Z), the line length, and the angle from 
horizontal. (If any of the fields do not display, click the arrow at the right end of the 
Status Line). Once a line is drawn, the Length field is active in the Status Line.

Drawing a Line Perpendicular to Another Object
1. Construct the object.

2. Move the pointer to the object until a Drafting Assistant on notation appears (end-
point, midpoint, quadrant etc., will not work, only “on”).

3. Drag straight away from the object in a perpendicular direction. A perpendicular line 
will appear attached to the object. Notice that the line stays perpendicular but slides 
along the object.

4. Drag to the desired length.

Drawing a Line Tangent or Perpendicular to an Arc, Circle or 
Ellipse
1. Construct an arc, circle, spline or ellipse.

2. Choose the Single Line tool. 
3. Move the pointer to the arc until a Drafting Assistant on notation appears (endpoint, 

midpoint, quadrant etc., will not work, only “on”).
4. Drag in the appropriate direction (straight out for perpendicular or at an angle for 

tangent) until the Drafting Assistant perpendicular or tangent notation appears. 
5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line 

around the arc to the desired location and extend the line to the desired length.

Geometric Characteristics
A single line is created by clicking two points and is made up of the following 
characteristics: Length, Angle, End 1 (X, Y and Z values) and End 2 for X, Y and Z 
values). This information is listed in the Edit Objects dialog box under the Geometry tab. 
To display the dialog box, select the line and choose Window>Edit Objects or double-
click on the line.

Mid-point Line Tool

This tool creates a line object by specifying the mid point and end point.
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Using the Mid-point Line Tool
1. Select the Mid-point Line tool from Line tool palette. The Message Line reads: Mid-

point Line: Pick center point [Ctrl = Copy previous] (Windows) or [Option = Copy 
Previous] (Macintosh). 

2. Pick the center point. The Message Line reads: Mid-point Line: Pick end point.
3. Pick the end point of the line.

To copy this just-created line, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click once in the drawing area to set the starting point. An 
identical line appears beginning at the point clicked on the current work plane.
The Status Line contains the X, Y, and Z coordinates of the beginning, the relative 
location of the end (delta X, delta Y and delta Z), the line length, and the angle from 
horizontal. Once a line is drawn, the Length field is active in the Status Line. Specify 
the end point for the region to stretch. 

Mid-point Line object has two end control points and a mid control point. Move the end 
control point to change line length or/and angle from the horizontal.

Geometric Characteristics
A mid point line is created by clicking the center point and end point and is made up of 
the following characteristics: Length, Angle, End 1 (X, Y and Z values) and End 2 for X, 
Y and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the line and choose Window>Edit 
Objects or double-click on the line.

Connected Lines Tool

This tool draws lines in which the endpoint of one line segment is the beginning point of 
the next. 

Using the Connected Lines Tool
1. Select the tool. The Message Line reads: Connected Lines: Pick the beginning 

point.

2. Click to indicate the endpoints of the line segments. 
Press the ESC key, or choose Undo to remove the last segment if a point within the 
process is clicked by mistake.
After the beginning point is set, the Message Line changes to reflect the next step.

3. Indicate the last point by double-clicking, hitting the ESC key or by choosing another 
tool.
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After completing at least one 
segment with the Connected 
Lines tool, create a tangent arc off 
of the last line by holding down the 
CTRL (Windows) or the OPTION 
(Macintosh) key (the pointer 
temporarily changes to an “arc” 
icon) and clicking or dragging to 
the next point. The Message Line 
notes this added feature. Several 
tangent arcs can be strung 
together by continuing to hold down the CTRL (Windows) or OPTION (Macintosh) key.
The radius of arcs created with this method cannot be edited in the Status Line. 
The Status Line contains the X, Y and Z coordinates of the beginning, the relative 
location of the end (delta X, delta Y and delta Z), the line length and the angle from 
horizontal. Once a line segment is drawn, the Length field is active in the Status Line.

Geometric Characteristics
A connected line is multiple single lines connected at their endpoints. Lines are made up 
of the following characteristics: Length, Angle, End 1 (X, Y and Z values) and End 2 (X, 
Y and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the line and choose Window>Edit 
Objects or double-click on the line.

Parallel Line Tool

This tool constructs a line parallel to an existing 
line in the X or Y axis of the current work plane.

Using the Parallel Line Tool
1. Select the tool. The Message Line reads: 

Parallel Line: Drag new line off existing 
line.

2. Drag off the desired line and release to indicate the position for the new parallel line. 
A rubberband line moves with the pointer. The distance field is active in the Status 
Line and displays the distance from the original line that was dragged. 
If the value is typed in and ENTER (Windows) or RETURN (Macintosh) is pressed, 
the parallel line moves the offset distance specified.
The Status Line contains the Offset data field.

Geometric Characteristics
A parallel line is a duplicate of a line created by the Single Line tool or the Connected 
Lines tool. The line is made up of the following characteristics: Length, Angle, End 1 (X, 
Y and Z values) and End 2 (X, Y and Z values). This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the line 
and choose Window>Edit Objects or double-click on the line.
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Point Tool

When the Point tool is selected, a subpalette appears in the Message Line, with three 
tools, Point at an XYZ Location, Points on a Curve and Points on Surface.

Choose the appearance of the points using any of 
these tools. Press the CTRL (Windows) or the 
OPTION (Macintosh) key to display the Point 
Markers dialog box.
Click the radio button for the desired marker 
(crosshairs plus, crosshairs x, empty diamond or 
empty square) and click OK to close the dialog box. 
When clicking to place the point in the drawing area, 
the point is represented by the new marker. The 
Point Marker style cannot be saved as a preference.

Using the Point at an XYZ Location 
Tool

Create individual points in the drawing area with this tool.
1. Select the Point tool from the palette.

2. Select the Point at an XYZ Location tool 
in the Message Line. The Message Line 
reads: Point: Enter point. [Ctrl = Markers (Windows) or Option = Markers (Macin-
tosh)].

3. Click a point in the drawing area.
The Status Line contains the X, Y and Z location of the point.

Using the Points on a Curve Tool

This tool places a series of points distributed 
equally along a curve (remember that curves include lines, circles, ellipses, arcs and 
splines). This tool cannot be used on polygons created using one of the Polygon tools.
1. Select the Point tool from the palette.

2. Select the Point on a Curve tool in the Message Line. The Message Line reads: 
Point on Curve: Select curves to distribute points on. [Ctrl = Markers (Windows) or 
Option = Markers (Macintosh), Shift = Extend].

3. Enter the number of points that need to be distributed along the curve in the #Pts 
data field of the Status Line.
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4. Select the curve. To select more than one curve, hold down the SHIFT key before 
selecting the first curve and while selecting succeeding curves.
Points are equally distributed along the curve. For closed curves, the start and 
endpoint are the same.

The Status Line contains the number of points to distribute along a selected curve.

Using the Points on a Surface Tool

This tool places a series of points distributed equally along a surface.
1. Select the Point tool from the palette.

2. Select the Points on a Surface tool in the Message Line. The Message Line reads: 
Point on Surface: Select surface(s) to distribute points on. [Ctrl = Markers (Win-
dows) or Option = Markers (Macintosh), Shift = Extend].

3. Enter the number of points to distribute along the surface in two perpendicular direc-
tions in the #U and #V data fields of the Status Line. U and V represent perpendicu-
lar coordinate directions along the surface. (The letters U and V are standard 
identifiers for surface coordinates.)

4. Select the surface.   To select more than one surface, hold down the SHIFT key 
before selecting the first surface and while selecting succeeding surfaces.
Points are equally distributed in a grid like pattern across the surface.

The Status Line contains the number of points to distribute in the U and V direction for 
the surface.

Geometric Characteristics
A point is created by a single click placed in one or more locations depending on the tool 
used. Points are made up of the following characteristics: X, Y and Z coordinates and 
the Display Style of the Point (crosshair plus, crosshair x, empty diamond, empty 
square). This information is listed in the Edit Objects dialog box under the Geometry tab. 
To display the dialog box, select the point and choose Window>Edit Objects or double-
click on the point.

Modifying Lines
A line can be modified in a number of ways. See Editing Objects for information on the 
Editing tools. After creating a line, change any value including length if the line is still 
selected.
For example, type a new length, press ENTER (Windows) or RETURN (Macintosh) and 
the length changes. If the length is not correct, choose Edit>Undo and the line returns 
to the previous length. To change the length of the line again, either select the line with 
the selection tool and edit information in any of the status line boxes or double click on 
the line to bring up the Edit Objects dialog box and edit all aspects of the line there.
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Arc & Circle Tools
This chapter contains information on the Arc and Circle tools available in the Designer 
Elements program. Creating an arc or circle, the coordinate locations and radius/
diameter appear in the Status Line. The arc or circle is also drawn with the current pen 
specifications for color, weight and pattern.
To define an object, after it is created, enter values in the Status Line for each tool. If 
values are entered in the selected Status Line data field after creating the object and 
while the object is still selected, pressing ENTER (Windows) or RETURN (Macintosh) 
updates the object to reflect the new values.
The tools explained here include:
• Arc Tools
• Circle Tools

Arc Tools

The Designer Elements program features three arc tools: Center-point Arc, 3-point Arc 
and Tangent-point Arc.

Center-point Arc Tool

This tool draws an arc based on three 
points: the center point, the beginning 
point and the endpoint of the arc.

Using the Center-point Arc Tool
1. Select the tool. The Message Line reads: Center-point Arc: Pick Center.

2. Click the center point of the arc. The Message Line now indicates the next 
step in using the tool.

3. Click the beginning point of the arc which will also define the radius.

Center Pt.

Start Pt.

End Pt.
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4. Moving the cursor to place the final point, a rubberband arc appears. Click the final 
point.

To construct an arc greater than 180°, create one of 180° or less, double-click the arc to 
bring up the Edit Objects dialog box and enter the desired degrees.
The Status Line contains the X, Y and Z coordinates of the center of the arc, the Radius, 
the starting angle from horizontal, A, and the delta angle from the start, dA. The Radius 
field is active in the Status Line.

Geometric Characteristics
The center-point arc is created from a center point and two arc points. Arcs are made up 
of the following characteristics: Diameter, Start Angle, End Angle, Start (X, Y and Z 
values) and End (X, Y and Z values). This information is listed in the Edit Objects dialog 
box under the Geometry tab. To display the dialog box, select the arc and choose 
Window>Edit Objects or double-click on the arc.
The Start and End Angles refer to the angles tangent to the arc point relative to the work 
plane.

3-point Arc Tool

This tool draws an 
arc through three 
specified points. 

Using the 3-point Arc Tool
1. Select the tool. The Message Line reads: 3-point Arc: Pick 

first point. [Ctrl = Tangent to object (Windows) or Option = 
Tangent to object (Macintosh)].

2. Click the first endpoint of the arc.
Notice that the Message Line indicates the next step in using the tool.

3. Click the second point of the arc. A rubberband arc appears as the cursor is moved 
to a third position.

4. Click the last point of the arc. The arc is created.
The arc is drawn from the first indicated position, through the second position and ends 
at the third position. For each of the three clicks that define the arc, if the CTRL 
(Windows) or the OPTION (Macintosh) key is held down and some other object is 
clicked, the program defines the arc to be tangent to that object at the nearest tangency 
point.
The Status Line contains the X, Y and Z coordinates for each of the three points.

Geometric Characteristics
A 3-point arc is created by placing three points and are made up of the following 
characteristics: Diameter, Start Angle, End Angle, Start (X, Y and Z values) and End (X, 
Y and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the arc and choose Window>Edit 
Objects or double-click on the arc.
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Tangent-point Arc Tool

This tool draws an arc beginning at the first specified point. The second specified point 
is the direction vector and the third pecified point indicates the endpoint of the arc. 
Essentially, the Tangent-point Arc tool first creates a line then creates an arc tangent to 
the line and erases the line.

Using the Tangent-Point Arc Tool
1. Select the tool. The Message Line reads: Tangent-point Arc: 

Pick beginning point of arc (tangent line).

2. Click the starting point. This is both the starting point of the 
arc and the starting point of the temporary tangent line.
The Message Line displays the next step for using the tool.

3. Click the endpoint of the tangent line. 
4. Click the endpoint of the arc. The arc is drawn between the first and last clicked 

points, tangent to the line between the first and second points.
The Status Line contains the X, Y and Z coordinates of the endpoints of the arc and the 
angle of the tangent line.

Geometric Characteristics
A tangent-points arc is created by clicking points for the tangent line and the arc and are 
made up of the following characteristics: Diameter, Start Angle, End Angle, Start (X,Y 
and Z values) and End (X, Y and Z values). This information is listed in the Edit Objects 
dialog box under the Geometry tab. To display the dialog box, select the arc and choose 
Window>Edit Objects or double-click on the arc.

Circle Tools

The Circle tools include the Center-point Circle, Opposite-Point Circle, 3-point Circle 
and Tangent Circle.
The Center-point tool uses the center and diameter of the circle. The 3-point tool uses 
three points and can be tangent to existing objects. The Tangent-point tool draws 
a circle tangent to two objects, using the diameter specified by the user.
The circle is drawn with the current pen specifications for color, weight and pattern.

First Pt. Second Pt.

Third Pt.
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Center-point Circle Tool

This tool draws a circle specified by the 
center point and diameter.

Using the Center-Point Circle Tool
1. Select the tool. The Message Line reads: Center-point Circle: Pick center. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Click the center of the circle. A rubberband circle appears guiding the construction 
as the cursor is moved.

3. Click the second point which determines the circle's radius.
To create a copy of the last circle hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click once in the drawing area to set the center point. An identical 
circle appears centered at the point clicked on the current work layer.
The Status Line contains the X, Y and Z coordinates of the center and the diameter of 
the circle. Diameter is the active status field.

Geometric Characteristics
A center-point circle is created by clicking the center point and a point on the circle. 
Circles are made up of the following characteristics: Diameter and Center (X, Y and Z 
values). This information is listed in the Edit Objects dialog box under the Geometry tab. 
To display the dialog box, select the circle and choose Window>Edit Objects or double-
click on the circle.

Opposite-Point Circle Tool

This tool draws a circle specified by 
the diameter. 

Using the Opposite-Point Circle Tool
1. Select the tool. The Message Line reads: Opposite-point Circle: Pick first point on 

circle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Click two locations to indicate the diameter. After the first point is clicked, a rubber-
band circle appears to guide in the construction.

Center Point
Point on

Start Point End Point



Circle Tools

11-5

To create a copy of the last circle hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click once to place the center point of the new circle. An identical 
circle appears centered at that point on the current work layer.
The Status Line allows specifying the X, Y and Z coordinates representing the endpoints 
of the diameter.

Tip: It is possible to select the center point of an opposite point circle if its
control points are displayed using the Show Points command in the Layout
menu.

Geometric Characteristics
An opposite-point circle is created by clicking two points to establish the diameter. 
Circles are made up of the following characteristics: Diameter and Center (X, Y and Z 
values). This information is listed in the Edit Objects dialog box under the Geometry tab. 
To display the dialog box, select the circle and choose Window>Edit Objects or double-
click on the circle.

3-point Circle Tool

This tool draws a circle 
through the selected points. 

Using the 3-point Circle Tool
1. Select the tool. The Message Line reads: 3-point Circle: Pick first point. [Ctrl = Tan-

gent to object (Windows) or Option = Tangent to object (Macintosh)].

2. Click the first point on the circle.
Notice that the Message Line displays the next step for using the tool.

3. Click the second and third points. After the second point a rubberband circle 
appears guiding the construction.

Placing any of the three points on an existing object, the circle is drawn through that 
point. If an object is clicked while holding down the CTRL (Windows) or OPTION 
(Macintosh) key, the circle is drawn tangent to the object rather than through the 
indicated point. Combine the placement of these points to create a circle through a 
specific point of one object and tangent to another object, or tangent to three objects, 
etc.
The Status Line contains the X, Y and Z coordinates for each of the three points.

Geometric Characteristics
A three-point circle is created by clicking three points to set the boundary of the circle. 
Circles are made up of the following characteristics: Diameter and Center (X, Y and Z 
values). This information is listed in the Edit Objects dialog box under the Geometry tab. 

First Point

Second PointThird Point
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To display the dialog box, select the circle and choose Window>Edit Objects or double-
click on the circle.

Tangent Circle Tool

This tool draws a circle tangent to 
two objects.

Using the Tangent Circle Tool
1. Select the tool. The Message Line reads: Tangent Circle: Enter diameter then pick 

first tangent object.

2. A diameter for the circle can be entered in the Status Line data field.

3. Click the objects to which the circle is to be tangent.
Tap the CTRL (Windows) or OPTION (Macintosh) key to flip the circle to any alternative 
positions possible for  placement tangent to the two objects. 

Geometric Characteristics
A tangent circle is created by entering the circle diameter and clicking on objects to 
establish tangency. Circles are made up of the following characteristics: Diameter and 
Center (X, Y and Z values). This information is listed in the Edit Objects dialog box 
under the Geometry tab. To display the dialog box, select the circle and choose 
Window>Edit Objects or double-click on the circle.
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Ellipse & Conic Tools

This chapter contains information on using the Ellipse tools and Conic tools. While 
creating an ellipse, the coordinate locations, lengths of the control rectangle and angles 
appear in the Status Line. While creating a conic, the rho value appears in the Status 
Line. These objects are also drawn with the current pen specifications for color, weight 
and pattern.
The values for each tool can be entered in the Status Line to define an object, after the 
object is created. If values are entered in the selected Status Line data field after 
creating the object and while the object is still selected, pressing ENTER (Windows) or 
RETURN (Macintosh) updates the object to reflect the new values.
The tools explained here include:
• 2-point Center Ellipse Tool 
• Opposite-corner Ellipse Tool
• 3-point Center Ellipse Tool
• 3-corner Ellipse Tool
• Modifying Ellipses
• 2-point Conic Tool
• 3-point Conic Tool
• 4-point Conic Tool

Refferal: The rho value definition can be found in Conic
Tools and 2-point Conic Tool.

Ellipse Tools

Create ellipses with four tools: 2-point Center, Opposite-corner, 3-point Center and 3-
corner. These tools in the main tool palette construct ellipses inscribed within an 
invisible rectangle or parallelogram. The 2-point Center Ellipse tool uses the center 
point and one corner location of the rectangle. The Opposite-corner Ellipse tool uses 
opposite corners of a rectangle. The 3-point Center Ellipse tool uses the center point, 
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the midpoint of a side and the corner of the parallelogram. The 3-corner Ellipse tool 
uses three corners of a parallelogram.
Ellipses are defined by their major and minor diameters, the start and end angles and 
their centers. The start and end angles specify the start and end location of the ellipse 
measured from the major axis.

Tip: Graphite users: Ellipses are enhanced in this program and are defined by
centers.

The graphic here shows an ellipse with a start and end angle of 
90° and 180°.
The ellipse is drawn with the current pen specifications for color, 
weight and pattern.

2-point Center Ellipse Tool 

This tool constructs an ellipse inscribed 
within a rectangle defined by two 
specified points: the center point and one 
corner of the rectangle.

Using the 2-point Center Ellipse Tool
1. Select the tool. The Message Line reads: 2-point Center Ellipse: Pick center of 

ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Click to establish the center of the ellipse.
Notice that the Message Line displays the next step for using the tool.

3. Click to establish the corner of the rectangle defining the ellipse.
If the two points are on the vertical or horizontal axis, a straight line is drawn.

Copy the last ellipse by holding down the CTRL (Windows) or the OPTION (Macintosh) 
key and clicking where the center will be. The copy is placed on the current work layer.
In the Status Line, specify the X, Y and Z coordinates of the center point and the length 
and angle of the semi-major and semi-minor axes of the ellipse. 

Geometric Characteristics
A 2-point center ellipse is created by placing the center point and corner of the control 
rectangle. It is made up of the following characteristics: Major Diameter, Minor Diameter, 
Start Angle, End Angle, and Center (X, Y and Z values). This information is listed in the 
Edit Objects dialog box under the Geometry tab. To display the dialog box, select the 
ellipse and choose Window>Edit Objects or double-click on the ellipse.

Y

X
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Opposite-corner Ellipse Tool

This tool draws an ellipse inscribed in a 
rectangle specified by opposite corners.

Using the Opposite-corner Ellipse Tool
1. Select the tool. The Message Line reads: Opposite-corner Ellipse: Pick first corner 

of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macin-
tosh)].

2. Click to establish one corner of the rectangle defining the ellipse.
Notice that the Message Line displays the next step for using the tool.

3. Click to establish the opposite corner of the defining rectangle.
If the two points are on the vertical or horizontal axis, a straight line is drawn.

Copy the last ellipse by holding down the CTRL (Windows) or the OPTION (Macintosh) 
key and clicking to place the lower-left point. The copy is placed on the current work 
layer.
In the Status Line, specify the X, Y and Z coordinates of the lower-left point, the length of 
the major and minor axes, L1 and L2 and angle of the major and minor axes, A1 and A2 
of the ellipse. 

Geometric Characteristics
An opposite-corner ellipse is created by placing two points that represent the corners of 
the control rectangle and is made up of the following characteristics: Major Diameter, 
Minor Diameter, Start Angle, End Angle and Center (X, Y and Z values). This information 
is listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the ellipse and choose Window>Edit Objects or double-click on the ellipse.

3-point Center Ellipse Tool

This tool constructs an ellipse inscribed 
within a parallelogram calculated from 
three specified points: a center point, a 
midpoint of a side and a corner of the 
parallelogram.
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Using the 3-point Center Ellipse Tool
1. Select the tool. The Message Line 

reads: 3-point Center Ellipse: Pick 
center of the ellipse. [Ctrl = Copy 
previous (Windows) or Option = 
Copy previous (Macintosh)]. The Message Line guides each successive step.

2. Click to establish the center of the ellipse.
3. Click to establish the midpoint of the side of the control parallelogram defining the 

ellipse.
4. Click to establish the corner of the control parallelogram defining the ellipse.
If the three points are on the vertical or horizontal axis, a straight line is drawn. Copy the 
last ellipse by holding down the CTRL (Windows) or the OPTION (Macintosh) key and 
clicking where the center will be. The copy is placed on the current work layer.
In the Status Line, specify the X, Y and Z coordinates of the center point and the length 
and angle of the sides of the parallelogram. 

Geometric Characteristics
A 3-point center ellipse is created by placing the center point, midpoint of the side and 
the corner of the control parallelogram. It is made up of the following characteristics: 
Major Diameter, Minor Diameter, Start Angle, End Angle and Center (X, Y and Z values). 
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the ellipse and choose Window>Edit Objects or double-
click on the ellipse.

3-corner Ellipse Tool

This tool draws an ellipse inscribed in a 
parallelogram defined by three corners.

Using the 3-corner Ellipse Tool
1. Select the tool. The Message Line 

reads: 3-corner Ellipse: Pick first 
corner of control parallelogram. [Ctrl 
= Copy previous (Windows) or 
Option = Copy previous (Macintosh)]. The Message Line guides each successive 
step.

2. Click to establish one corner of the parallelogram defining the ellipse.
3. Click to establish another corner of the defining parallelogram.
4. Click to establish the final corner of the defining parallelogram.
If the three points are on the vertical or horizontal axis, a straight line is drawn. Copy the 
last ellipse by holding down the CTRL (Windows) or the OPTION (Macintosh) key and 
clicking to place the lower-left corner of the parallelogram. The copy is placed on the 
current work layer.
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The Status Line specifies the X, Y and Z coordinates of a corner and the length and 
angle of the sides of the parallelogram. 

Geometric Characteristics
A 3-corner ellipse is created by placing the three points that represent the corners of the 
control rectangle and is made up of the following characteristics: Major Diameter, Minor 
Diameter, Start Angle, End Angle and Center (X, Y and Z values). This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the ellipse and choose Window>Edit Objects or double-click on the ellipse.

Modifying Ellipses
Modify any ellipse in a number of ways:
• After it’s created and while it’s still selected, by entering new values in the Status Line.
• By using the Transformation tools ( see Transforming Geometry).
• By using Edit Objects.
• By selecting a control point and dragging it to a new location. The number of control 

points available to edit is based on the tool used to create the ellipse. A 2-point 
Center ellipse has 2 control points.

Conic Tools

Create conics with three tools: 2-point Conic, 3-point Conic and 4-point Conic. The 2-
point Conic tool uses the start point and end point to define the conic. The 3-point 
Conic tool uses the start point, end point and slope control point to define the conic. The 
4-point Conic tool uses the start point, end points, slope control point and shoulder 
point to define the conic. The rho value is the dimension ratio of the distance from the 
center point to the shoulder point and the center point and the slope control point. The 
graphic below illustrates the definitions of the conic characteristics.

When using a conic tool a rubberband image appears after placing all but the last point. 
This shows the ellipse before it is drawn. The conic is drawn with the current pen 
specifications for color, weight and pattern.

2-point Conic Tool

This tool constructs a conic calculated from three specified 
points: the start point, end point and slope control point.
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Using the 2-point Conic Tool
1. Select the tool. The Message Line 

reads: 2-point Conic: Pick start 
point. [Ctrl = Copy previous (Win-
dows) or Option = Copy previous 
(Macintosh)]. The Message Line guides each successive step.

2. Pick the start point of the conic. As the cursor is moved to place the second point, a 
rubberband image appears.

3. Pick the end point to complete the conic.
Modify the rho value in the Status Line and press ENTER (Windows) or RETURN 
(Macintosh) to accept the new rho value. Rho values must be between .501 and .999. 
A rho value of .501 will create a straight line. A rho value of .999 will create a conic 
with a 90° angle.

Create a copy of the last conic by holding down the CTRL (Windows) or the OPTION 
(Macintosh) key and clicking to indicate the start point. The copy is placed on the current 
work layer.
The Status Line specifies the rho value of the conic.

Geometric Characteristics
A 2-point conic is created by placing two points; the start point and end point and is 
made up of the following characteristics: Rho, End 1 (X, Y and Z values) and End (X, Y 
and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the conic and choose Window>Edit 
Objects or double-click on the conic.

3-point Conic Tool

This tool constructs a conic calculated from three 
specified points: the start point, end point and 
slope control point.

Using the 3-point Conic Tool
1. Select the tool. The Message Line reads: 3-point Conic: Pick start point. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message 
Line guides each successive step.

2. Pick the start point of the conic.
3. Pick the end point of the conic. Once this third point is placed, a rubberband image 

appears.
4. Pick the shoulder point to complete the conic.

Modify the rho value in the Status Line and press ENTER (Windows) or RETURN 
(Macintosh) to accept the new rho value. Rho values must be between .501 and .999. 
A rho value of .501 will create a straight line. A rho value of .999 will create a conic 
with a 90° angle.

Create a copy of the last conic by holding down the CTRL (Windows) or the OPTION 
(Macintosh) key and clicking to indicate the start point. The copy is placed on the current 
work layer.



Conic Tools

12-7

The Status Line specifies the rho value of the conic.

Geometric Characteristics
A 3-point conic is created by placing three points; the start point, end point and slope 
control point and is made up of the following characteristics: Rho, End 1 (X, Y and Z 
values) and End 2 (X, Y and Z values). This information is listed in the Edit Objects 
dialog box under the Geometry tab. To display the dialog box, select the conic and 
choose Window>Edit Objects or double-click on the conic.

4-point Conic Tool

This tool constructs a conic calculated from four 
specified points: the start point, end point, slope 
control point and shoulder point.

Using the 4-point Conic Tool
1. Select the tool. The Message Line 

reads: 4-point Conic: Pick start 
point. [Ctrl = Copy previous (Win-
dows) or Option = Copy previous 
(Macintosh)]. The Message Line guides each successive step.

2. Pick the start point of the conic.
3. Pick the end point of the conic.
4. Pick the slope control point of the conic. Once this third point is placed, a rubber-

band image appears.
5. Pick the shoulder point to complete the conic.
Modify the rho value in the Status Line and press ENTER (Windows) or RETURN 
(Macintosh) to accept the new rho value. Rho values must be between .501 and .999. A 
rho value of .501 creates a straight line. A rho value of .999 creates a conic with a 90° 
angle.
Create a copy of the last conic by holding down the CTRL (Windows) or the OPTION 
(Macintosh) key and clicking to indicate the start point. The copy is placed on the current 
work layer.
The Status Line specifies the rho value of the conic.

Geometric Characteristics
A 4-point conic is created by placing four points; the start point, end point, slope control 
point and shoulder point and is made up of the following characteristics: Rho, End 1 (X, 
Y and Z values) and End 2 (X, Y and Z values). This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the conic 
and choose Window>Edit Objects or double-click on the conic.
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Polygon Tools

These tools draw rectangles, inscribed polygons, circumscribed polygons, arbitrary 
polygons and polygons from curves. The polygon is drawn with the current pen 
specifications for color, weight and pattern.
After the polygon is created, and while it is still selected, it is possible to refine its size 
and shape by entering values in the Status Line. Press ENTER (Windows) or RETURN 
(Macintosh) the polygon updates to reflect the new values.
Every polygon tool but the Polygon from Curves tool, provides 
two options for creating polygons, Single Line and Smart Polygon. 
These options are available through a pull-down menu in the 
Message Line.
Polygons created with the Single Line option, are composed of individual lines that can 
be modified independently. These polygons can be filleted/chamfered, extruded, 
revolved, offset or relimited.
Polygons created with the Smart Polygon option are true polygons, whose width and 
height can be modified. These objects cannot be filleted/chamfered, extruded, revolved, 
offset, or relimited with the 2D wireframe tools, however, it is possible to perform 3D 
operations such as extrudes, blends and revolutions on these entities. To perform these 
operations on a smart polygon with 2D wireframe tools convert it into individual lines by 
choosing Edit>Change Object Type and select the line option. See “Change Object 
Type” on page 15. for more information.
The tools explained here include:
• Rectangle Tool
• Inscribed Polygon Tool
• Circumscribed Polygon Tool 
• Star Polygon Tool
• Arbitrary Polygon Tool
• Polygon from Curves Tool
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Rectangle Tool 

When the Rectangle tool is selected, a subpalette appears in the Message Line 
containing four tools for creating rectangles: by center and corner point, by diagonals, 
by center and axis, and by corner and axis.

The rectangle tools create rectangles from the selected points as directed by the 
specific tool.

Center/Corner Rectangle Tool 

This tool draws a rectangle, using the center and corner specified.

Using the Center/Corner Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Center/Corner Rectangle tool in the Message Line. The Message Line 
reads: Rectangle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or 
Option = Copy previous (Macintosh)].

3. Pick the center point of the rectangle. As the cursor is moved, a rubberband image 
appears.

4. Pick rectangle corner.
With the rectangle still selected, the width and height of the rectangle can be changed 
by entering the values in the Status Line fields and pressing ENTER (Windows) or 
RETURN (Macintosh). The width and the height of a rectangle can be also changed in 
the Edit Objects dialog box.
Create a copy of the last rectangle by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking where the upper-left corner will be.
The Status Line specifies the X, Y and Z coordinates of the first point, as well as the 
width and height of the rectangle. Width is the active status field.

Diagonal Rectangle Tool

This tool draws a rectangle based on two corners along a diagonal.

Using the Diagonal Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Diagonal Rectangle tool in the Message Line. The Message Line reads: 
Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option 
= Copy previous (Macintosh)].

Corner

MidpointCenter

CornerCorner
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3. Click one corner of the rectangle. As the cursor is moved a rubberband image 
appears.

4. Click the opposite corner of the rectangle.
With the rectangle still selected, the width and height of the rectangle can be changed by 
entering the values in the Status Line fields and pressing ENTER (Windows) or 
RETURN (Macintosh). The width and the height of a rectangle can be also changed in 
the Edit Objects dialog box.
A copy of the last rectangle can be created by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking where the upper-left corner will be. 
The Status Line specifies the X, Y and Z coordinates of the first point, and the 
rectangle’s width and height. Width is the active field.

Create a square by aligning the second point on the 45° construction line. If the two 
points are on the vertical or horizontal axis, a straight line is drawn. To draw a square 
from the center rather than opposite corners, use one of the other polygon tools, 
specifying four sides. 

Center/Axis Rectangle Tool

This tool draws a rectangle using the center, midpoint and corner.

Using the Center/Axis Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Center/Axis tool in the Message Line. The Message Line reads: Rectan-
gle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or Option = 
Copy previous (Macintosh)].

3. Click the center point of the rectangle.
4. Click the midpoint of the rectangle side. As the cursor is moved a rubberband image 

appears.
5. Click the opposite side of the rectangle.
With the rectangle still selected, the width and height of the rectangle can be changed by 
entering the values in the Status Line fields and pressing ENTER (Windows) or 
RETURN (Macintosh).
The width and the height of a rectangle can be also changed in the Edit Objects dialog 
box.
To create a copy of the last rectangle, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click where the upper-left corner will be.
The Status Line specifies the X, Y and Z coordinates of the first point, as well as the 
width and height of the rectangle. Width is the active status field.

Corner/Axis Rectangle Tool

This tool draws a rectangle using the specified corners.

Using the Corner/Axis Rectangle Tool
1. Select the Rectangle tool from the palette.
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2. Select the Corner/Axis Rectangle tool in the Message Line. The Message Line 
reads: Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or 
Option = Copy previous (Macintosh)].

3. Click the first corner of the rectangle.
4. Click the second corner of the rectangle. As the cursor is moved, a rubberband 

image appears.
5. Click the opposite point.
With the rectangle still selected, the width and height of the rectangle can be changed 
by entering the values in the Status Line fields and pressing ENTER (Windows) or 
RETURN (Macintosh).
The width and the height of a rectangle can also be changed in the in Edit Objects dialog 
box.
To create a copy of the last rectangle hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click where the upper-left corner will be.
The Status Line specifies the X, Y and Z coordinates of the first point, as well as the 
width and height of the rectangle. Width is the active status field.

Geometric Characteristics
A rectangle polygon is created by picking the appropriate points as directed by the 
selected tool in the rectangle subpalette. A rectangle is made up of the following 
characteristics according to the Edit Objects dialog box: Length and Width and includes 
the option to Show Frame and Show Fill. 
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes places a fill within the polygon, based on 
the default pattern and fill currently selected in the Pen menu. This information is listed 
in the Edit Objects dialog box under the Geometry tab. To display the dialog box, select 
the polygon and choose Window>Edit Objects or double-click on the polygon.

Inscribed Polygon Tool

This tool creates a polygon where the radius of the 
circumscribing circle determines the location of the polygon’s 

vertices. 

The default polygon is a hexagon, but the number of sides can 
be specified in the Status Line. The Status Line shows a 
diameter for the circle, the standard way of describing a 
polygon inscribed in a circle.

Using the Inscribed Polygon Tool
1. Select the tool. The Message Line reads: 

Inscribed Polygon: Pick center of polygon. 
[Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Click the center of the polygon. The Message Line reads: Inscribed Polygon: Pick 
vertex of polygon. As the cursor is moved, a rubberband polygon appears guiding 
the construction. 
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3. Pick a point on the circumference of the circumscribing circle to complete the poly-
gon.

To create a copy of the last inscribed polygon hold down the CTRL (Windows) or 
OPTION (Macintosh) key and click where the center will be.
The Status Line specifies the X, Y and Z coordinates of the center, the diameter of the 
circle defining the polygon, and the number of sides. Diameter is the active Status Line 
selection, and the default number of sides is six.

Geometric Characteristics
An inscribed polygon is created by picking the center and the vertex of the polygon. It is 
made up of the following characteristics according to the Edit Objects dialog box: 
Diameter, Sides, Scribe Type and includes the option to Show Frame and Show Fill.
Scribe Type refers to circle type used to define the polygon. Choosing Circle Outside 
places the polygon within the circle, defining an inscribed polygon. Choosing Circle 
Inside places the polygon on the outside of the circle, defining a circumscribed polygon. 
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes, places a fill within the polygon, based 
on the default pattern and fill currently selected in the Pen menu. This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the polygon and choose Window>Edit Objects or double-click on the polygon.

Circumscribed Polygon Tool

This tool draws a polygon in which the radius/diameter of 
the circle determines the midpoint of the sides. The default 
shape is a hexagon but the number of sides can be 
specified in the Status Line. Notice that the Status Line 
shows the diameter for a circle, the standard way of 
describing a polygon circumscribed around a circle.

Using the Circumscribed Polygon Tool

1. Select the tool. The Message Line reads: 
Circumscribed Polygon: Pick center of 
polygon. [Ctrl = Copy previous (Windows) 
or Option = Copy previous (Macintosh)].

2. Click the center of the polygon and the midpoint of one of the sides, as directed by 
the Message Line.
After the first point is placed, a rubberband polygon appears guiding construction.

To create a copy of the last circumscribed polygon hold down the CTRL (Windows) or 
OPTION (Macintosh) key and click where the center will be.
The Status Line specifies the X, Y and Z coordinates of the center, the diameter of the 
circle defining the polygon, and the number of sides. The default number of sides is six. 
Diameter is the default Status Line selection.
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Geometric Characteristics
A circumscribed polygon is created by picking the center and the midpoint of the 
polygon side. It is made up of the following characteristics according to the Edit Objects 
dialog box: Diameter, Sides, Scribe Type and includes the option to Show Fill and Show 
Frame. 
Scribe Type refers to circle type used to define the polygon. Choosing Circle Outside 
places the polygon within the circle, defining an inscribed polygon. Choosing Circle 
Inside places the polygon on the outside of the circle, defining a circumscribed polygon. 
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes, places a fill within the polygon, based 
on the default pattern and fill currently selected in the Pen menu. This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the line and choose Window>Edit Objects or double-click on the polygon.

Star Polygon Tool

The Star Polygon tool creates and object with three control points including center, 
inside and outside vertexes.

Using the Star Polygon Tool
1. Select the Star Polygon tool from Polygon 

Tools palette. The Message Line reads: 
Star Polygon: Pick center of star polygon. 
[Ctrl = Copy previous] (Windows) or 
[Option = Copy Previous] (Macintosh).

2. Pick the center point. The Message Line reads: Star Polygon: Pick outside vertex of 
star polygon.

3. Pick the outside vertex. The Message Line reads: Star Polygon: Pick inside vertex of 
star polygon. [Shift = Deform star].

4. Pick the inside vertex. Press the SHIFT key to create a non-symmetric star polygon. 
5. The Status Line contains the Vertices field. Enter the desired number for the star 

polygon.
The Status Line contains the X, Y, and Z coordinates of the star center, inside and 
outside diameters of the star (D1 and D2), star vertices number. 

Symmetric Star Non-symmetric Star
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Geometric Characteristics
A star polygon is created by placing the center, picking the outside and inside vertexes. 
It is made up of the following characteristics according to the Edit Objects dialog box: 
Show Frame, Show Fill, Diameter 1, Dameter 2, Vertices.
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes, places a fill within the polygon, based 
on the default pattern and fill currently selected in the Pen menu. 
Diameter 1 represents the value of the diameter of an imaginary circle inscribed within 
the inside vertexes. Diameter 2 represents the value of the diameter of an imaginary 
circle circumscribed around the outside vertixes of the star poligon. The vertexes option 
sets the number of points out of the star poligon. This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the 
polygon and choose Window>Edit Objects or double-click on the polygon.

Arbitrary Polygon Tool

This tool draws a polygon with the number of sides 
determined by the chosen points.

Using the Arbitrary Polygon Tool
1. Select the tool. The Message Line reads: 

Arbitrary Polygon: Pick first point. [Ctrl = 
Copy previous (Windows) or Option = 
Copy previous (Macintosh)].

2. Click the next point as directed by the Message Line.
3. Continue clicking points to complete the desired polygon. Single click the last point 

to close the polygon at its starting point. 
Double-click to place the last point that is not the starting point of the polygon, and the 
program closes the polygon automatically.

To create a copy of the polygon hold down the CTRL (Windows) or OPTION (Macintosh) 
key and click where the center will be.
The Status Line specifies the X, Y and Z coordinates of the first point. X is the default 
Status Line selection.

Geometric Characteristics
An arbitrary polygon is created by placing the desired points for the polygon. It is made 
up of the following characteristics according to the Edit Objects dialog box: Defining 
Point and the options to Show Fill and Show Frame. 
Defining Point refers to the chosen’s point X, Y and Z location. The section below 
Defining Points lists the points with the X, Y and Z location. The selected point is 
displayed in the Defining Point fields. Each point can be edited individually.
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
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wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes, places a fill within the polygon, based 
on the default pattern and fill currently selected in the Pen menu. This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the polygon and choose Window>Edit Objects or double-click on the polygon.

Polygon from Curves Tool

This tool creates a polygon from the chosen curves. The curves do not have to be 
connected to create a polygon. If these curves are not connected, the tool adds curves 
to complete the polygon. The polygon created when a curve is missing depends on the 
order of the curve selection. 
Once the polygon is created a parent/child relationship has been established between 
the original curves and the polygon. The original curves selected are still available for 
editing and any change made will affect the polygon. Due to this same parent/child 
relationship, in order to move the polygon and retain the relationship, the curves and the 
polygon must be selected. Break the relationship by selecting them and choosing 
Edit>Remove Links. See Remove Links Command for more information.
The graphic below on the left represents five different curves. The graphic on the right is 
the one polygon created after using the tool.

Using the Polygon from Curves Tool
1. Select the tool. The Message Line reads: 

Polygon from Curves: Select a collection 
of curves [Shift = Extend].

2. Select all the desired curves. If the curves are selected individually, hold down the 
SHIFT key before beginning the selection.
A polygon is created from those curves.

There are no entries in the Status Line.

Geometric Characteristics
Using this tool a polygon is created by selecting specific curves. No new geometry is 
created. The following characteristics are listed in the Edit Objects dialog box: Show Fill 
and Show Frame.
Show Frame refers to the display of the polygon. Show Fill refers to the placement of a 
fill within the polygon. Setting Show Frame to No, turns off the wireframe display. (If the 
wireframe is not displayed and does not contain a fill, the geometry will become invisible 
when Apply is clicked.) Setting Show Fill to Yes, places a fill within the polygon, based 
on the default pattern and fill currently selected in the Pen menu. This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the polygon and choose Window>Edit Objects or double-click on the polygon.
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Spline Tools

The spline tools in the main tool palette create NURBS (Non-Uniform Rational B-
Splines). These NURB splines are smooth curves created by a complex mathematical 
formula.
NURB splines provide designers with two interrelated functions. First, curvature continu-
ity remains intact when the curve is changed. Kinks don't develop as the spline is 
altered. Second, NURB splines provide localized control of a complex curve by chang-
ing the control points.

Tech Note: Cobalt, Xenon and Argon create B-Splines of the third and fourth
order.

These properties are essential in aerodynamic designs. Air molecules moving over a 
wing surface must flow smoothly for maximum aero-dynamic lift. If the surface does not 
maintain curvature continuity, the air molecules separate from the wing surface and 
cause a vacuum. Such a vacuum causes an eddy as the molecules try to fill it. This 
disruption of air flow increases the drag, which is not a part of an effective design.
Complete curvature continuity also improves styling. The appearance of a car is one of 
the major sales factors. The potential buyer would not be impressed if the showroom 
lights’ reflection on the car rippled and wavered. It is complete curvature continuity that 
makes a smooth reflection.
Localized control of complex curves allows making minor modifications without 
adversely affecting the shape. For example, if a new, bigger engine wouldn’t fit under a 
perfectly-designed hood, use a NURB spline to raise the center of the hood without 
changing the basic design. NURB splines are also valuable for injection mold designs to 
eliminate the swirl of plastic as it is injected into the mold. Such designs provide better 
surface finishes and allow thinner cross-sections in the die.
The spline creation tools include Through-points B-spline, Vector Spline, Bezier 
Spline and Freehand Spline. At the most basic level these splines are the same. For 
the Through-points B-spline and the Bezier Spline, there is additional step of 
interpolating the points to calculate a control polygon which is hidden from view. For the 
Vector Spline the interpolation step is eliminated because the accessible control polygon 
is defined.
Spline control points automatically lock after placement. One point can be selected and 
moved without affecting the other control points.
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Enter values in the Status Line to define a spline after the spline is created. If values are 
entered in the selected Status Line data field after creating the spline and while the 
spline is still selected, pressing ENTER (Windows) or RETURN (Macintosh) updates the 
spline to reflect the new values. The tools explained here include:
• Through-point B-spline Tool
• Vector Spline Tool
• Bezier Spline Tool
• Freehand Spline on Surface Tool
• Helix Curve Tool
• Add Control Point Tool 
• Remove Control Point Tool 
• Modify Slope Tool
• Elevate Curve Tool
• Fair Curve Tool

Through-point B-spline Tool

The Through-points B-spline tool draws a spline through the specified points. Use this 
tool to make the B-spline to interpolate a collection of points. The interpolation algorithm 
is based on predefined B-spline blending functions, control point locations and imposing 
curvature continuity across the curve length. This results in a smooth spline created 
through the points.

Using the Through-Points B-Spline Tool
1. Select the tool. The Message Line reads: Through-points B-spline: Pick control 

points. (End = ESC, Double-click).

2. Click the points for the vectors of the spline.
3. Double-click the last point or hit the ESC key.
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The Status Line shows the X, Y and Z coordinates for each point as it is placed.

When creating a spline that crosses over itself, the Drafting Assistant is not be able to 
find that intersection. This is by design.

Geometric Characteristics
A Through-points B-spline is created by picking the desired points. A spline is made up 
of the following characteristics according to the Edit Objects dialog box: Start and End 
Angles (relative to work plane) and Defining Point.
Angles refer to the degrees of the tangent relative to the work plane for the spline. 
Change the Start and End Angles by clicking within the check box and entering the 
angle.
Defining Point refers to the X, Y and Z location of the active point. X, Y and Z values for 
each point can be edited individually using these fields.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the spline and choose Window>Edit Objects or double-
click on the spline.

Vector Spline Tool 

This tool draws a spline using vectors determined by the specified points. The Vector 
Spline tool uses each placed point that as the vertex of a vector for the spline it creates. 
Vector splines are smooth curvature, continuous B-splines created from the defined 
control polygon. The polygon influences the shape (position and tangencies) of the 
spline. Except for the start and end points, the control polygon does not necessarily lie 
on the spline.
Choosing Edit>Show Points displays all the control points used to define the spline and 
can be selected to edit the spline. This provides the additional benefit of being able to 
smooth the spline to eliminate inflections. To determine whether or not the spline has 
inflections, choose Verify>Curvature. An inflection is located where the curvature 
changes from one side of the spline to the other.

Tip: With the Vector Spline tool all original points used to create the spline
will display when the spline is selected.
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Using the Vector Spline Tool
1. Select the tool. The Message Line reads: Vector Spline: Pick control points (End = 

ESC, Double click).

2. Click the points for the vectors of the spline.
3. Double click the last point.
The program uses these vectors as the control points. The spline is tangent to the first 
and last vectors and passes between the remaining control points.
The Status Line shows the X, Y and Z coordinates of each point as they are placed.

Geometric Characteristics
A vector spline is created by picking control points and is made up of the one 
characteristic according to the Edit Objects dialog box: the Defining Point (X, Y and Z 
location). Defining Point refers to the active point’s X, Y and Z location.   Each point can 
be edited using the X, Y, Z fields. This information is listed in the Edit Objects dialog box 
under the Geometry tab. To display the dialog box, select the spline and choose 
Window>Edit Objects or double-click on the spline.

Bezier Spline Tool

This tool creates curvature 
continuous (C2) splines 
through a collection of user 
defined points. At each 
control point, it is possible to 
control the direction and the 
magnitude of the tangent. 
After creating a spline with 
this tool, it is possible to move 
the control points, change the 
slope (direction) and the influence of a control point using the spline vector.
The influence of a control point is determined by the length of the control point’s vector. 
The longer the vector, the greater the influence a control point has on the spline. It is 
possible to adjust the length of control point vector but maintain the slope. The left 
graphic shows a Bezier spline, a selected control point and the direction it will be moved 
to change the influence but maintain the slope. The right graphic shows the spline with a 
longer vector.

To change the spline use Add Control Point, Remove Control Point and Modify Slope 
tools.
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Using the Bezier Spline Tool
1. Select the tool. The Message Line reads: Bezier Spline: Pick control points (End = 

ESC, Double click).

2. Click the points of the spline.
3. Double click the last point.
The Status Line shows the X, Y and Z coordinates of each point as they are placed.

Geometric Characteristics
A Bezier spline is created by picking control points and is made up of the following 
characteristics according to the Edit Objects dialog box: the Defining Point (X, Y and Z 
location) and the points list. This list includes the spline control points and the slope 
points (if displayed). Display the slope points by selecting the spline and choosing 
Edit>Show Points. Defining Point refers to the active point’s X, Y and Z location.   Each 
point can be edited using the X, Y, Z fields. This information is listed in the Edit Objects 
dialog box under the Geometry tab. To display the dialog box, select the spline and 
choose Window>Edit Objects or double click on the spline.

Freehand Spline on Surface Tool

The Freehand Spline tool samples points as the cursor moves and creates a smooth 
spline through the sampled data. Once selected this tool has two options located in the 
Message Line: the Freehand Spline tool and the Freehand Spline on a Surface tool. 
While the Freehand Spline tool creates a spline on the current workplane, the Freehand 
Spline on a Surface tool creates the spline on a designated surface or on one face of a 
solid or polysurface. 

Using the Freehand Spline Tool

1. Select the tool. The Message Line reads: Freehand Spline: Press and drag mouse. 
[Ctrl = AutoClose (Windows) Option = AutoClose (Macintosh)]

2. Click and drag the mouse on the screen.
3. Release the mouse button to create the freehand spline.

Using the Freehand Spline on a Surface Tool

1. Select the tool. The Message Line reads: Freehand Spline on Surface: Select sur-
face or face. [Ctrl = AutoClose (Windows) Option = AutoClose (Macintosh)]
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2. Select the surface or solid on which to draw.
3. Click and drag the mouse over the selected surface, keeping the points on the sur-

face.
4. Release the mouse button to complete the spline.

Helix Curve Tool

The Helix Curve tool draws a curve based on its start point, end point, Pitch, diameter, 
length and draft angle. The endpoint defines the length and orientation of the helix. Pitch 
is the distance between helix peaks (two adjacent turns of the helix). The number of 
turns in the helix is equal to the length of the helix divided by the pitch. The draft angle 
must be a value less than 90°.
Create a standard helix (left graphic, below), a spiral (middle graphic, below) by entering 
zero for the helix length, or a swept solid using a helix with a draft as the sweep path 
(right graphic, below). 

Tech Note: To sweep a surface on a helix, the helix must be created using
this tool. See Sweep Surface Tool - Along 2 Points for information on using
the Sweep Surface tool.

Using the Helix Curve Tool
1. Select the Helix Curve tool. The Message Line reads: Helix Curve: Pick start and 

end of helix [Ctrl (Windows) or Option (Macintosh) = Left-handed helix].

2. The Status Line contains the Pitch, Diameter, Length and Draft Angle data fields.

Enter the desired values in the appropriate fields. Tab between fields.
3. Pick the start and end point of the helix. A right-handed helix is created.
While the helix is still selected, the Status Line values can be changed. Type the new 
values and press ENTER (Windows) or RETURN (Macintosh) and the helix updates.
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Geometric Characteristics
A helix is created by picking the start and end point and specifying the pitch and 
diameter. A helix is made up of the following characteristics according to the Edit 
Objects dialog box: the Diameter, Pitch, Length and Draft Angle.
There is also a check box to change the helix direction. By default, using this tool 
creates a right-handed helix. The helix can be changed to a left-handed helix by 
deselecting the Right-handed Helix option and clicking Apply or Close. If a left-handed 
helix is already created, the box is not checked.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the helix and choose Window>Edit Objects or double-
click on the helix.

Add Control Point Tool 

This tool adds another control point to an existing spline, both within the spline and 
outside of the spline to extend it.

Using the Add Spline Control Point Tool
1. Select the tool. The Message Line reads: Add Control Point: Select the spline to add 

point to (Shift = Extend).

2. Click on the spline to add a point.
3. Pick the desired location(s) for the new control point(s).
Note: To see the new control point(s), as well as the existing control points, first select 
the spline and then choose Edit>Show Points (or use the Edit Objects dialog box to 
specify whether the Control points are visible or hidden).
There are no Status Line entries for this tool.

Remove Control Point 
Tool 

This tool removes a control point from 
an existing spline. A spline must have 
more than two control points to use 
this tool.
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Using the Remove Control Point Tool
1. Select the tool. The Message Line reads: Remove Control Point: Select the spline 

point to remove (Shift = Extend).

2. If the control points of the spline are not displayed, select the spline and choose 
Edit>Show Points.

3. Pick the control point to be removed.
There are no Status Line entries for this tool.

Modify Slope Tool 

This tool changes the endpoint slope of an existing spline created using the Through-
points B-spline tool. There are five options for changing the slope: Release Slopes, 
Reference, Reverse, Explicit and Release Magnitudes.

Using the Modify Slope Tool - Release Slopes Option
1. Select the tool. 

2. Choose the Release Slope option in the pull-down menu of the Message Line. The 
Message Line reads: Modify Slope: Select spline slope(s) to release.

3. If the control points of the spline are not displayed, select the spline and choose 
Edit>Show Points.

4. Pick the spline slope control endpoint to be freed.
The slope control endpoint returns to its original position.

There are no Status Line entries for this tool.

Release Slopes Releases the spline slope returning it to its originally created 
slope control point. This is helpful if you’ve adjusted the slope 
of a spline has been adjusted in numerous locations along and 
needs to be returned to the shape originally created.

Reference Uses the slope of other curves or surfaces as a reference to 
make the selected curves tangent.

Reverse Reverses a curve 180°.

Explicit Sets the exact slope of the curve relative to the work plane 
(between 0° and 360°). A slope of 0° makes the curve tangent 
to the plane. Choose Planes>Show Work Plane when using 
this option.

Release Magnitudes Releases the spline slope magnitude returning it to its 
originally created magnitude. This is helpful if the magnitude is 
adjusted in numerous locations along the spline and it is 
necessary to return to the spline that was originally created. 
(This only works with Bezier splines.)
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Using the Modify Slope Tool - Reference Option
1. Select the tool. 

2. Choose the Reference option in the pull-down menu of the Message Line. The Mes-
sage Line reads: Modify Slope: Select the spline end to set slope.

3. If the control points of the spline that need to be modified are not displayed, select 
the spline and choose Edit>Show Points.

4. Pick the spline to mod-
ify. In the graphic here, 
it's the spline displaying 
points.

5. Pick the curve, surface 
or solids whose slope is 
to be referenced.
The icon now becomes a 

target icon.
6. Click on the endpoint of 

the curve to be modi-
fied, (The curve and the 
reference object do not 
have to connect.) The 
curve slope adjusts.

There are no Status Line 
entries for this tool.

Using the Modify Slope Tool - Reverse Option
1. Select the tool.

2. Choose the Reverse option in the pull-down menu of the Message Line. The Mes-
sage Line reads: Modify Slope: Select spline slope point to reverse.

3. If the control points of the spline are not displayed, select the spline and choose 
Edit>Show Points.

4. Pick the spline slope control endpoint to be reversed, as in the left graphic below. 
The slope control endpoint reverses 180° (right graphic).

There are no Status Line entries for this tool.
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Using the Modify Slope Tool - Explicit Option
1. Select the tool.

2. Choose the Explicit option in the pull-down menu of the Message Line. The Mes-
sage Line reads: Modify Slope: Select spline slope point for explicit set.

3. If the control points of the spline are not displayed, select the spline and choose 
Edit>Show Points.

4. Pick the spline control endpoint to be set. An Input 
String dialog box appears.

5. Enter the Angle for the slope in the data field and click 
OK. The dialog box closes and the slope of the spline is 
adjusted. (Click Cancel to close the dialog box without 
changing the angle value.)

There are no Status Line entries for this tool.

Using the Modify Slope Tool - Release Magnitudes Option
1. Select the tool. 

2. Choose the Free Magnitudes option in the pull down menu. The Message Line 
reads: Modify Slope: Select spline magnitude to release.

3. If the control points of the spline are not displayed, select the spline and choose 
Edit>Show Points.

4. Select the bezier curve slope or control point to be released.
The Bezier slope resets to a natural magnitude.

Elevate Curve Tool

This tool elevates the degree of a curve, introducing more control points. These control 
points can be used to modify the curve.

Note: The Elevate Curve Tool changes the object type of the
curve being elevated to a vector spline.

Curves are defined by NURB polynomial equations. The most basic question possible is 
used to define the curve. Shapes defined by higher degree polynomials have more 
control points than those defined by lesser degree polynomials. This tool raises the 
degree level for a shape, providing more control points for curve manipulation. Curves 
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can be elevated up to the 22nd degree, however, it is recommended to never elevate a 
curve higher than 9 degrees. The left side of the graphic below shows the original 
ellipse. The right side of the graphic below shows the ellipse elevated one degree.

Using the Elevate Curve Tool
1. Select the Elevate Curve tool. The Message Line reads: Elevate Curve: Pick curve 

to elevate.

2. Select the curve to elevate.
The curve elevates one degree.
There are no entries in the Status Line.

Fair Curve Tool

The Fair Spline command provides a tool to globally smooth a curve. Fairing a spline 
optimally moves control vertices to locations that minimize large curvature variations. 
Curves eligible for fairing are limited to vector splines. It’s helpful to watch the control 
vertices move as the spline is fired with the Edit>Show Points command. Use the 
Verify>Curvature tool to visually inspect the curvature graph of a curve.

Using the Fair Spline Tool
1. Select the tool. 

2. The Message Line reads: Fair Spline: Select curve to fair.
3. Click on the spline to fair.
The status line displays a move tolerance value for the tool. The 
move tolerance is the maximum distance a spline control vertex 
will be allowed to move towards its optimal position.
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Wireframe Editing Tools
Once an object is created it can be selected and altered by choosing a command or 
using a tool to edit it. This chapter describes common editing activities and compares 
different methods for performing the same action. Use the editing tools to change an 
object’s geometry, size, location or orientation. They are collected in three subpalettes in 
the main tool palette.
For each tool enter values in the Status Line to perform the editing operation before or 
after the operation is complete. If the values are entered after selecting the tool but 
before performing the operation, the first click in the drawing area automatically 
registers all Status Line values. If values are entered after performing the operation and 
while the curve is still selected, pressing ENTER (Windows) or RETURN (Macintosh) 
updates the curve to reflect the new values.
Many of the editing tools require a two step process for their usage. The first step after 
choosing the tool may be to select one or more objects. The second step performs the 
editing operation. Once the first step is completed any other objects cannot be selected 
to include in the same operation. To select additional objects reset the tool and start 
again.

Tech Note: These editing tools cannot be performed on grouped objects,
only curves.

There are no unique geometric characteristics listed in the Edit Objects dialog box for an 
object after using these tools. For example, a fillet between two lines creates an arc. 
Edit Objects lists the parameters for an arc.
The following topics are explained:
• Fillet/Chamfer tools
• Trim tools
• Curve Extras tools

Fillet and Chamfer Tools

These tools on the main tool palette construct fillets and chamfers from corners formed 
by nonparallel lines or curves. The program automatically trims fillets and chamfers by 
default. If they do not need trimming, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key while selecting the objects to fillet or chamfer.
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All filleted curves being trimmed must be in the same plane.

2-entity Fillet Tool

This tool constructs an arc tangent to the two specified objects.

Using the 2-entity Fillet Tool
1. Select the 2-entity Fillet tool. The Message Line reads: 2-entity Fillet: Pick first 

entity. [Shift=Corner, Ctrl=No trim (Windows) or Option=No Trim (Macintosh)].

2. Enter the arc radius in the Status Line. The default radius is .50 inch. 
3. Click the first curve. The Message Line reads: 2-entity Fillet: Pick second entity. 

[Ctrl=No trim] (Windows) or [Option=No Trim (Macintosh)].
It is also possible to hold down the SHIFT key and click once inside the corner to fillet. 
(See the Message Line at the top of the drawing area for a reference to this feature.) 
Holding down the CTRL (Windows) or OPTION (Macintosh) key while selecting the 
objects to fillet, the objects are not trimmed. Fillets create the smallest possible arc 
between the selected geometry.
The Status Line contains the Radius of the fillet.

3-entity Fillet Tool 

This tool constructs a fillet tangent to the three chosen objects.

Using the 3-entity Fillet Tool
1. Select the 3-entity Fillet tool. The Message Line reads: 3-entity Fillet: Pick three 

entities [Ctrl=No Trim (Windows) or Option=No Trim (Macintosh)].
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2. Click the three objects to fillet.
Holding down the CTRL (Windows) or OPTION (Macintosh) key while selecting the 
objects to fillet, the objects are not trimmed.
There are no Status Line entries.

2-entity Chamfer Tool

This tool creates a chamfer across a corner at the 
specified distance from the intersection of two lines.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when creating a chamfer with this tool.

Using the 2-entity Chamfer Tool
1. Select the 2-entity Chamfer tool.

2. In the Status Line specify the chamfer's distance from the corner. (The default dis-
tance is .50 inch.)

3. Click the first curve. The Message Line reads: 2-entity Chamfer: Pick second entity. 
[Shift = Corner, Ctrl = No trim (Windows) or Shift = Corner, Option = No trim (Macin-
tosh)]. 

It is also possible to hold down the SHIFT key and click once inside the corner to 
chamfer. 
The face of a part, rather than just the edges, may be selected for a chamfer. Use the 
Ambiguity box to specify the edge or face when performing the operation.
The lines are automatically trimmed or extended. Holding down the CTRL (Windows) or 
the OPTION (Macintosh) key while selecting the objects to chamfer, the objects are not 
trimmed.
The Status Line specifies the distance (Length) from the chamfer to the intersection of 
the corner lines.

Angular Chamfer Tool

This tool creates a chamfer at the specified angle 
and distance from the corner. The specified angle is 
the angle between the chamfer and the second line 
of the corner. The specified length is the distance between the corner and the 
intersection of the chamfer and the second line of the corner. The second line of the 
corner refers to the second line chosen when creating the chamfer.

Using the Angular Chamfer Tool
1. Select the Angular Chamfer tool. The Message Line reads: Angular Chamfer: Pick 

first entity [Ctrl = No trim (Windows), Option = No trim (Macintosh)].
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2. In the Status Line, enter the length for the intersection of the chamfer and the sec-
ond line of the corner. The default length is .50 inch. 

3. In the Status Line also enter the angle between the chamfer and the second side. 
The default Angle is 45°.

4. Click the first curve. The Message Line reads: Angular Chamfer: Pick second entity. 
[Ctrl=No trim (Windows) or Option=No Trim (Macintosh)].

It is also possible to hold down the SHIFT key and click once inside the corner to 
chamfer. 
The face of a part, rather than just the edges, may be selected for a chamfer. Use the 
Ambiguity box to specify the edge or face when performing the operation.
The lines are automatically trimmed or extended by default. Holding down the CTRL 
(Windows) or the OPTION (Macintosh) key while selecting the objects to chamfer, the 
objects are not trimmed.
The Status Line sets the distance (Length) from the intersection as well as the Angle.

Trim Tools

The Trim tools on the tool palette lengthen or shorten lines, curves and polylines. Select 
the limiting object(s) before or after selecting the tool. If every object that needs 
selecting is not selected, hold down the SHIFT key for the tool becomes a temporary 
Selection tool and click additional objects after the Trim tool is selected.
When trimming curves using one of these tools the following warning will appear if the 
operation will delete the entire curve.

Click Yes to proceed with the operation or No to exit the operation.

Simple Trim Tool

This tool shortens a curve to the specified 
boundary. Holding down the CTRL (Windows) 
or the OPTION (Macintosh) key while using this tool, it becomes the Relimit tool.
When trimming a Through Point B-spline or Bezier spline an editable vector spline 
results. It is possible to move its control points and change its shape and slope. In some 
situations trimming a curve results in a spline. This spline is also an editable vector 
spline.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when trimming with this tool.
Rule: Point to what to remove.
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Using the Simple Trim Tool
1. Select the Simple Trim tool. The Message Line reads: Simple Trim: Select boundar-

ies for simple trim. [Shift = Extend]

If the boundaries are already selected, proceed to step 3.
2. Select the object that limits the trim.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Simple Trim: Pick section to trim [Shift=Select Boundary, Ctrl=Relimit 
(Windows) Option=Relimit (Macintosh)].

3. Click the section of the object to be discarded.
There are no Status Line entries.

Relimit Tool

This tool lengthens or shortens a curve to 
the specified boundary. Hold down the 
CTRL (Windows) or the OPTION 
(Macintosh) key while using this tool to 
make it the Trim tool. The Relimit tool will not relimit arcs.
When relimiting a Through Point B-spline or Bezier spline an editable vector spline 
results. Move its control points and change its shape and slope. In some situations 
relimiting a curve results in a spline. This spline is also an editable vector spline.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when relimiting geometry with this tool.
Rule: Point to what to keep. 

Using the Relimit Tool

1. Select the Relimit tool. The Message Line reads: Relimit: Select boundaries for 
relimit [Shift = Extend].

If the boundaries are already selected, proceed to step 3.
2. Select the object that limits the change.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Relimit: Pick section to keep [Shift=Select Boundary, Ctrl=Trim (Windows) 
Option=Trim (Macintosh)].

3. Click the section of the object to retain.
There are no Status Line entries.

Segment Tool

This tool divides a curve at 
intersections with other lines 
or curves.
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When segmenting a Through Point B-spline or Bezier spline an editable vector spline 
results. It is possible to move its control points and change its shape and slope. In some 
situations segmenting a curve results in a spline. This spline is also an editable vector 
spline.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when segmenting curves with this tool.

Using the Segment Tool
1. Select the Segment tool. The Mes-

sage Line reads: Segment: Select 
boundaries for segment [Shift = Extend].

If the boundaries are already selected, proceed to step 3.
2. Select the objects that limit the segmentation.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Segment: Pick entity [Shift=Select Boundary, Ctrl=Current Pen (Windows) or 
Option=Current Pen (Macintosh)].

3. Click the object to be segmented.
The selected object is segmented at the boundary objects. Even though the 
segmentation cannot be seen on the screen, parts of the segmented line can be 
selected by choosing it with the Selection tool. In order to see the segmentation on the 
screen, first select the boundaries and the object to segment, then choose Edit>Show 
Points. The endpoints of the segmented parts are displayed.
Holding down the CTRL (Windows) or OPTION (Macintosh) key while selecting the line 
to be segmented the new segment appears in the characteristics of the current pen 
style.
There are no Status Line entries.

Divide Tool

This tool subdivides a curve into a 
specified number of equal-length 
segments. The left graphic above 
shows a single line. The right graphic shows the line divided into four segments with the 
control points displayed.
When a Through Point B-spline or Bezier spline is divided, an editable vector spline 
results. Its control points can be moved to change its shape and slope. In some 
situations dividing a curve results in a spline. This spline is also an editable vector 
spline.

Using the Divide Tool
1. Select the Divide tool. The Mes-

sage Line reads: Divide: Pick curve 
to divide. [Shift=Extend]

2. Set the No. of Segments value in the Status Line.
3. Select the object to divide.

The object divides. The individual segments are not indicated unless their control 
points are turned on.

The Status Line sets the number of segments in the curve.
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Corner Trim Tool

This tool creates a corner from two specified objects. 
Lines are extended or shortened to create the 
corner.
Conduct a corner trim on a Through Point B-spline or Bezier spline to result in an 
editable vector spline. Move its control points to change its shape and slope. In some 
situations trimming a curve results in a spline. This spline is also an editable vector 
spline.

Using the Corner Trim Tool
1. Select the Corner Trim tool. The 

Message Line reads: Corner Trim: 
Pick portion of first entity to retain. 
[Shift=Corner].

2. Select the first curve. 
3. Select the second object.
As an alternative to picking two entities, press and hold the SHIFT key and click inside 
the about-to-be-created corner.
There are no Status Line entries.

Divide at Location Tool

This tool breaks one curve into two at a chosen point.
Dividing a Through Point B-spline or Bezier spline using 
this tool an editable vector spline results. Move its control points to change its shape and 
slope. In some situations dividing a curve results in a spline. This spline is also an 
editable vector spline. It is also possible to divide 360° circles and ellipses.

Using the Divide at Location Tool
1. Select the Divide at Location tool. The Message Line reads: Divide at Location: 

Pick curve to divide at location: [Shift=Extend].

2. Select the curve. The Message Line reads: Divide at Location: Pick divide point. 
3. Choose the point on the curve where the division will be made.
There are no Status Line entries.

Connect Curve Tool

This tool connects curves. The program provides two options, Move Curve Point and 
Join. The Join option also includes the ability to set a tolerance. (The tolerance field 
does not apply to the default Move Curve Point option.)
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Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when connecting curves with this tool.

Using the Connect Curve Tool - Move Curve Point Default
Move Curve Point is the default 
option when using the tool. 
Using this option moves the 
endpoint from the second 
selected curve to the endpoint of 
the first selected curve. This option is useful for creating closed profiles to extrude, 
revolve, or sweep to create solid models.
1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select 

two curves to connect end points [Ctrl=Join (Windows) or Option=Join (Macintosh)].

2. Select the first curve near the endpoint where it will connect the curve.
3. Select the second curve near the endpoint that needs moving.

The second curve’s endpoint moves to the endpoint of the first curve. The other 
endpoint of the second curve remains fixed.

The Status Line contains a Tolerance data field. This field only applies to the Join option.

Using the Connect Curve Tool - Join Option
The Join Curve option replaces the two 
selected curves with a new spline curve. 
The selected lines must share a tangent. 
This tool will also join two polylines within a 
specified tolerance distance. This is helpful when curves are converted into polylines 
using the Change Object command and later it is necessary to join them. Select the Join 
Curve option as picking the two curves.
1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select 

two curves to connect end points [Ctrl=Join (Windows) or Option=Join (Macintosh)].

2. If desired, specify a tolerance distance in the Status Line to which the resulting 
curves will fit.

3. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and select the 
two curves.
Any discontinuities between the selected lines are eliminated.

The Status Line contains the Tolerance data field.
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Curve Utility Tools

The Curve Utility tool palette contains tools for offsetting and exploding curves.

Offset Curve Tool

The Offset Curve tool offsets curves by a location or a specified distance. The curves 
can be part of a wireframe object, surface edge (Offset to Value tool only) or solid edge. 
Groups cannot be offset. The graphic here is an example of an offset solid ege.

One or more curves can be offset using the following options.

The Offset Curve tool includes a subpalette with two tools, Offset to Value and Offset 
by Point.

When offsetting a Through Point B-spline or Bezier spline an editable vector spline 
results. Move its control points to change its shape and slope. In some situations 
offsetting a curve results in a spline. This spline is also an editable vector spline.
Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when using this tool.

Automatic trimming for 
curves offset inside curves.

Curves offset outside of 
curves with the arc 
corners for the offset.

Curves offset outside of 
curves with extended corners 
for the offset.
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Offset to Value Tool

This tool creates an offset curve at a specified distance from the original curve, surface 
edge or solid edge. When offsetting surface edges there is the option of placing the 
offset on the surface. It is possible to offset one curve or edge or connected curves or 
edges.

Using the Offset to Value Tool - One Curve, Surface Edge or Solid Edge
1. Select the Offset Curve tool.

2. Select the Offset to Value tool in the Message Line. The Message Line reads: Off-
set Curve: Pick curves to offset distance. [Ctrl=Extend Corner (Windows) or 
Option=Extend Corner (Macintosh)] [Shift=Extend]

3. Enter an offset distance in the Offset data field of the Status Line.
4. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter off-

set direction. 
Selecting a surface edge, the Offset 
dialog box appears asking if the offset 
lie on the surface.
Click Yes to place the offset on 
surface. Click No and proceed with 
the next step.

5. Pick a point on either side of the 
curve or edge to specify the offset 
direction. The offset direction must be 
parallel to the curve or edge. The pro-
gram offsets the curve by the distance set in the data field.

While the offset curve is selected a new offset distance may be specified in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the Offset distance.

Using the Offset to Value Tool - Connect Curves or Solid Edges
For connected curves or edges there are multiple offset options: extending exterior 
offsets so they connect with an arc intersection, extending exterior offsets with a corner 
intersection or trimming intersecting offsets for interior offsets.
1. Select the Offset Curve tool.

2. Select the Offset to Value tool in the Message Line. The Message Line reads: Off-
set Curve: Pick curves to offset distance [Ctrl=Extend Corner (Windows) or 
Option=Extend Corner (Macintosh)] [Shift=Extend]

3. Enter an offset distance in the Offset data field of the Status Line.
4. Select the curves or edges to offset. The Message Line reads: Offset Curve: Enter 

offset direction.
5. Select the type of offset.

Exterior Offset - Arc Intersection: Pick a point on the outside of the curves or edges.
Exterior Offset - Corner Intersection: Hold down the CTRL key (Windows) or the 
OPTION key (Macintosh) and pick a point on the outside of the curves or edges.
Interior Offset: Pick a point on the inside of the curves or edges.
The program offsets the curves or edges by the distance set in the Status Line data 
field.
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While the offset curves are selected a new offset distance may be entered in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the Offset distance.

Offset by Point Tool

This tool creates an offset at the point specified. It is possible to offset one curve or solid 
edge or connected curves or solid edges.

Using the Offset by Point Tool - One Curve or Solid Edge
1. Select the Offset Curve tool.

2. Select the Offset by Point tool in the Message Line. The Message Line reads: Off-
set Curve: Pick curves to point [Ctrl=Extend Corner (Windows) or Option=Extend 
Corner (Macintosh)] [Shift=Extend]

3. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter off-
set point.

4. Pick the desired point for the offset. The Designer Elements program offsets the 
curve to that point. The offset value is displayed in the Offset data field in the Status 
Line.

While the offset curve is selected it is possible to enter a new offset distance in the 
Status Line. Press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the offset distance.

Using the Offset by Point Tool - Connected Curves or Solid Edges
1. Select the Offset Curve tool.

2. Select the Offset by Point tool in the Message Line. The Message Line reads: Off-
set Curve: Pick curves to point [Ctrl=Extend Corner (Windows) or Option=Extend 
Corner (Macintosh)] [Shift=Extend]

3. Select the curves to offset. The Message Line reads: Offset Curve: Enter offset 
point.

4. Select the type of offset.
Exterior Offset - Arc Intersection: Pick a point on the outside of the curves.
Exterior Offset - Corner Intersection: Hold down the CTRL key (Windows) or the 
OPTION key (Macintosh) and pick a point on the outside of the curves.
Interior Offset: Pick a point on the inside of the curves.
The program offsets the curves at that point. The offset value is displayed in the Offset 
data field in the Status Line.

5. Pick the desired point for the offset. The Designer Elements program offsets the 
curve to that point. The offset value is displayed in the Offset data field in the Status 
Line.

While the offset curves are selected it is possible to enter a new offset distance in the 
Status Line. Press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the offset distance.
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Extrude Curve Tool

This tool copies a curve at a distance and in the 
specified direction. It connects its endpoints by two lines 
back to the original curve. In the graphic to the right the 
lower curve is extruded to form the polygon.

Using the Extrude Curve Tool
1. Click the Extrude Curve tool. The Message Line reads: Extrude Curve: Pick curves 

to extrude [Shift=Extend].

2. Select the curve(s) to extrude. The Message Line reads: Extrude Curve: Specify two 
points for extrusion direction.

3. Click two points to indicate where the new extruded curve will be placed. The direc-
tion of the extrusion is specified by the order in which the points are picked. This 
Designer Elements program applies the specified distance and direction.

While the object is selected it is possible to change the extrusion distance in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the extrusion’s dX, dY and dZ values and the Distance.

Tip: To extrude an object click to define the extrusion rather than drag. 
To extrude a curve at an angle not normal to the curve, change the view.
Example: Create a rectangle in the top plane. Change the plane to the front
plane and place the extrude points to define an angle and length.

Tech Note: A Smart Polygon cannot be revolved. It must first be converted
into single lines using the Change Object Type command. See Polygon
Tools for more information on polygon types. 
To define the axis of revolution click the points rather than drag.

Revolve Curve Tool

This tool revolves a curve around an axis.

Using the Revolve Curve Tool
1. Select the Revolve Curve tool. The Message 

Line reads: Revolve Curve: Pick curves to 
revolve. [Shift=Extend]

2. Select the curve(s) to revolve. The Message Line reads: Revolve Curve: Specify 
two points for the revolution axis.

3. Click two points to indicate the axis of revolution. The direction of the revolution is 
specified by the order the points are picked. The program rotates the curve about 
the axis by the number of steps and through the angle set in the data fields on the 
status line.
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While the object is still selected it is possible to change the number of steps and the 
angle of revolution in the Status Line. Press ENTER (Windows) or RETURN 
(Macintosh).
The Status Line contains the number of steps and the angle of revolution.

Project Curve Tool

The Project Curve tool projects 3D curves, including solid edges onto a 2D plane. Arcs, 
circles and ellipses maintain their precise shape when being normally projected to their 
definition. Being projected otherwise, a spline is used with a default curve tolerance of 
0.001 inches. This spline is an editable vector spline.
When projecting a Through Point B-spline or Bezier spline an editable vector spline 
results. Move its control points to change its shape and slope. In some situations 
projecting a curve results in a spline.
The select curves are created 
on the plane and replace the 
original curves unless the CTRL 
key (Windows) or OPTION key 
(Macintosh) is held down. The 
graphic here shows a model 
projected to XY, XZ and YZ 
planes.
The left graphic below shows a 
model with four solid edges 
selected (displayed in black). 
The right graphic shows the 
edges projected to the XZ 
Plane.
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Plane Options
The pull-down menu in the Message Line provides five options for choosing the plane: 
XY Plane, XZ Plane, YZ Plane, Work Plane and Pick Infinite Plane.

The following figures, displayed in the Isometric view, explain the projection options. All 
graphics used for the individual planes are also displayed in the Isometric view.

XY Plane Choosing this option projects the selected curves into the XY 
plane (Top) where X=0 and Y=0.

XZ Plane Choosing this option projects the selected curves into the XZ 
plane (Front) where X=0 and Z=0.

YZ Plane Choosing this option projects the selected curves into the YZ 
plane (Side) where Y=0 and Z=0.
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Use the Plane commands in the Plane menu to define the plane. Set the work plane to 
the desired plane before using this option.

Projection Options
When projecting curves this Designer Elements program takes those curves and creates 
new geometry on the specified plane. There are two options, Default and Copy.

Project Curves - Default Option
This option takes the selected geometry. See the 
graphic here. Notice that the selected geometry no 
longer appears on the original part.

Project Curves - Copy Option
This option copies the selected geometry. To 
choose this option hold down the CTRL key 
(Windows) or OPTION (Macintosh). See the 
graphic here.

Projecting & Multiple Curve Selection
After selecting the tool, it is possible to select multiple lines for projection by holding 
down the SHIFT key and selecting the desired lines, as noted in the Message Line.

Work Plane Choosing this option projects the selected curves into the work 
plane. For this example, the work plane was defined using the 
sloped face of the object.

Pick Infinite Plane Choosing this option projects the selected curves to the 
specified infinite plane.
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Select multiple lines or an entire object by dragging a selection fence 
around the entire object. When projecting the object, all curves that 
are normal to the projection plane are recreated as points in the new 
curve. The graphic here shows a YZ projection. The cross hairs 
represent the points.
Important: (Windows users) Because the CTRL and SHIFT keys are 
programmed to perform specific operations for this tool, the Stroke 
Zoom function (CTRL+SHIFT keys) is not available when projecting 
curves with this tool.

Using the Project Curve Tool
1. Select the Project Curve tool. The Message Line reads: Project Curve: Pick curves 

to project. [Ctrl=Copy (Windows) or Option=Copy (Macintosh)] [Shift=Extend]

2. From the pull-down menu in the Status Line choose the projection plane.
3. Select the curves to project. Hold down the SHIFT key or drag a selection fence to 

select multiple lines. The Message Line now reads, Project Curve: Specify point in 
projection plane. [Ctrl=Copy (Windows) or Option=Copy (Macintosh)]

4. Pick the point on the projection plane where the curves should be projected. The 
selected lines are replaced with lines projected on the selected plane.
To project a copy of the lines hold down the CTRL key (Windows) or OPTION key 
(Macintosh) before selecting the point.

There are no Status Line entries.

Tech Note: If ENTER (Windows) or RETURN (Macintosh) is pressed instead
of specifying a point, the projection is placed at the origin.

Explode Edge Tool

This tool creates a curve from a surface or solid 
edge. For surfaces and solids, Iso lines can be 
also exploded when displayed on the geometry. 
This ability is useful when constructing geometry 
off an object.
When exploding a solid edge, solid Iso line, 
surface edge or surface Iso line, the new curve is placed on the work layer and assumes 
its color characteristic. If the layer has no specific color characteristic, the curve displays 
in the color selected in the Pen menu. If the exploded edge or Iso line results in a spline, 
a vector spline results. Move its control points to change its shape and slope.

Using the Explode Edge Tool
1. Select the Explode Edge tool. The Message 

Line reads: Explode Edge: Pick edges to 
explode. [Shift=Extend]

2. Select the surface or solid edge or Iso line from which to create a curve.
The curve is created at the same location as the selected edge.

There are no entries in the Status Line.
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Introduction to Surface Modeling
A surface/mesh model is a more complete and less ambiguous representation than a 
wireframe model. Surface models take the representation of an object one step beyond 
wireframe models by defining the area between selected boundaries with smooth 
equations. Mesh models also go beyond wireframe models but are defined by nodes or 
vertices. Consequently, surface and mesh modeling provides a way to create complex 
shapes such as cars, ships and aircraft.
In Cobalt, Xenon and Argon, surfaces are based on Spatial Technology’s ACIS 
Geometry Engine. ACIS surfaces are composed of Non Uniform Rational B-Splines 
(NURBs). NURBs provide a highly precise yet flexible mathematical definition for 
modeling even the most demanding free-form shapes. Surfaces generated with the 
Designer Elements programs are suitable for precise geometric analysis and can be 
passed to computer-aided manufacturing applications that support SAT or IGES file 
formats.

The Designer Elements programs have 5 tools for creating surfaces. Every tool but the 
Infinite Plane tool can display a surface with Iso Lines. Iso (or isopram) lines are 
constant parameter curves that lie on a surface (defined mathematically in parameter 
space). U/V Iso lines refer to parameter space coordinates where U and V are letter 
identifiers. U Iso lines run perpendicularly to V Iso lines on a surface.
Values for each tool can be entered in the Status Line to define a surface, either before 
or after creating the surface. If the values are entered after selecting the tool but before 
creating the surface, the first click in the drawing area automatically registers all Status 
Line values. If values are entered in the selected Status Line data field after creating the 
surface and while the surface is still selected, pressing ENTER (Windows) or RETURN 
(Macintosh) updates the surface to reflect the new values. 
Many of the tools use a two step process. The first step after choosing the tool may be 
to select one or more objects. The second step is to perform the editing operation. Once 
the first step is completed (which may involve holding down the SHIFT key to select 
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multiple objects), it is not possible to select more objects to include in the same 
operation. To select additional objects, reset the tool and start again.
The topics discussed in this chapter include:
• Surface Modeling Tools
• Surfaces, Selection and Display
• Surface Associativity
• Cutting and Pasting Surfaces
• Exporting Surfaces
• Objects Types and Edit Objects
• Surface Control Vertex Modification

Surface Modeling Tools
The surface modeling tools are accessible from the 
Surfaces tool palette. The Surfaces tool palette 
automatically displays when Cobalt, Xenon or Argon is 
first launched. If the palette is closed and it is 
necessary to display the palette again, choose 
Window>Surfaces.
The palette will appear under the main tool palette on 
the left side of the screen.

Save the open status of the palette and its location, 
simply by quitting the program. The next time the program is launched, the palette will 
be open and placed in the last location.
Each icon in the palette is the first in a subpalette of tools grouped together with a 
similar purpose. From top to bottom they include:

Surface Primitives

Surface from 
Curves

Surface Utilities

Feature Surfaces

Local Surface Tools
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Surface Primitive Tools

The Surface Primitives tool palette has tools for quickly creating surfaces from simple 
shapes and parameters. This tool palette offers Infinite Planes, Speheres, Blocks, 
Cylinders and Pyramids. (For more information on these tools see Surface Primitive 
Tools.)

Surface From Curves Tools

Use the Surfaces From Curves tools to construct surfaces built upon curves. This tool 
palette has the Net, Ruled, Skin, Cover, Revolution (lathe), Extruded, Swept, Swept 
2 rail and Pipe surface tools. (For more information see Surface From Curves Tools..)

Feature Surface Tools

The Feature Surface tool palette constructs surfaces built upon other surfaces. The 
tools in this palette include Offset, Loft, Draft, Fillet and Tangent Cover Surface. (For 
more information on these tools see Derived Surface Tools.)

Surface Utilites Tools

After surfaces are constructed or imported into the model, they can be refined or 
combined with the surfaces with other entities. The program provides several tools 
which make these tasks easy to complete. The Surface Utilities palette has tools such 
as Entity Intersections, Projections, Joining, Trimming and Silhouette Curves 
commands. (For more information see Surface Utility Tools.)

Local Surface Tools

Tools in the Local Surface palette modify the internal shape or definition of a surface. 
Example tools located in this palette include, Surface Slope Matching, Rebuilding, 
Untrimming, Degree Elevation and Knot Insertion. (For more information on these 
tools see Surface Modification Tools.)

Surfaces, Selection and Display
To select a surface click anywhere within its boundary, however, the fastest way is if the 
surface's edge is selected. A surface is displayed by its boundary edges and any 
existing interior holes. A surface's edge resolution can be increased with the Change 
Resolution command in the Edit menu.

Changing an Object's Resolution
1. Select the object.

2. Choose Edit>Change Resolution.
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The following Object Resolution dialog box appears.

Choose one of five resolutions, Super Fine, Very Fine, Fine, Medium and Coarse. Select 
the desired resolution and click OK to close the dialog box. The object changes 
accordingly. 
3. Enter the desired number of Iso lines. Check the Show Silhouettes box.

The number of isopram lines drawn for a surface. These Iso (isopram) lines are 
constant parameter curves that lie on a surface, typically defined in parameter space. 
The parameter space coordinate system uses U and V coordinates. A 0 (zero) in both 
fields turns off Iso lines. The appropriate U/V values may enhance the visual 
appearance of the surface at the expense of drawing speed. The letters, U and V are 
space coordinate identifiers (U = horizontal, V = vertical) that are the industry 
standard. The Force U=V check box automatically sets equal number of U and V 
lines. Entering a new value in one automatically changes the other isoline value.
The Silhouette check box controls the silhouette edges of objects. Silhouette edges 
are view dependent and can cause a significant reduction in drawing speed. A check 
in the box turns on the silhouette.

4. Click OK to close the dialog box and save the new settings.

Surface Associativity
Surfaces are associative to the original curves used to create them. Changing the curve 
automatically changes the dependent surface. For example, creating a skin surface 
from three arcs and changing the radius of one of the arcs, the skin surface 
automatically updates to reflect the change. Use the Edit>Remove Links command to 
remove all associativity with the surface if curve changes should not affect the surface. 
Another important issue to remember with the curve/surface associativity is that if the 
curve is deleted, the surface deletes as well. Since it is defined by the curve, it is no 
longer valid.

Cutting and Pasting Surfaces
When a surface is cut into the paste buffer, two sets of data get stored. The first set of 
data is a Designer Elements program object that will precisely paste into the current file 
or into another Designer Elements program drawing. The second set of data is a 
collection of display vectors in the bitmap format. This data can be pasted into other 
Windows or Macintosh programs that support the clipboard.

Exporting Surfaces
The Designer Elements programs provides several methods for exporting surfaces into 
other applications. Our primary goal is to preserve as much data a possible during the 
export. Use the following export option order when exporting surfaces:
• ASIS (.SAT)
• Parasolids (.x_t) (Windows only)
• ProE (.g) (Windows only)
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• STEP
• DXF with imbedded .sat
• IGES
• Stereolithography (.stl) (Mesh surfaces only)

Objects Types and Edit Objects
Every surface or mesh object created with a Designer Elements program tool is defined 
by its own characteristics, and includes geometric characteristics and attributes. These 
are displayed in the Edit Objects dialog box. While the characteristics listed in the 
Attributes tab are identical, the characteristics listed in the Geometry tab vary with each 
object.
Chapters 16, 17, 18, 19, 20, and 21 describe the surface tools. Included with every tool 
description is a list of the characteristics displayed for the object when Edit Objects is 
chosen. For information on using the Edit Objects command and the dialog box, see 
Editing Objects.

Surface Control Vertex Modification
Our Designer Elements program supports the ability to manipulate the control points for 
all surface face type NURB surfaces. All other surfaces like net, skin and cover, must be 
converted into the surface face type using the Change Object Type command. 
Remember that using the Change Object Type command removes all links from the 
surface.
After showing points on the selected surface you can select any point and move it to a 
new location. With this ability you can create such things as creases and other surface 
variations. If surface smoothness is a concern, be sure to use the surface evaluation 
plot available through the Verify menu or the advanced rendering features. See Surface 
Evaluation. 
The left graphic below shows a sphere converted into a surface and displaying its 
control points. The right graphic shows the surface after control point modification 
creating a heart shape.

Performing a Control Vertex Modification
1. Select the surface you want to modify.

2. Choose Window>Edit Objects to verify that the surface is a surface face.
If it is continue on with step 5.

3. Choose Edit>Change Object Type.
4. Select the Surface option and click OK.



Introduction to Surface Modeling

16-6

If the surface you selected is 
linked to another object the 
following warning box 
appears:
Click Yes to continue 
conversion.

5. Choose Edit>Show Points 
to display the surface con-
trol points.

6. Using the Selection tool, 
drag the control points as 
desired.
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Surface Primitive Tools

Infinite Plane Tool

The infinite plane is the simplest surface supported by the Designer Elements programs. 
An infinite plane is defined by a location and a normal. The plane surface is useful for 
generating cross-sections through meshes, surfaces or solids.
The Infinite Plane tool has six creation methods listed in the pull-down menu of the 
Message Line.

The choices above are accessed from the Message Line, in the pull down pictured 
below.

After creating an infinite plane, it is represented on the screen by the following icon:

X-Station Creates a plane with normal X=1, Y=0, Z=0.

Y-Station Creates a plane with normal X=0, Y=1, Z=0.

Z-Station Creates a plane with normal X=0, Y=0, Z=1.

Normal Location Creates an arbitrary plane by specifying the location and 
normal.

3 Pts in Plane Specifies a plane by three points. The normal is calculated 
from the three points.

Along Curve Lays an evenly spaced series of planes along a selected 
curve. The plane’s normals lie parallel to the curve.
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Using the X-, Y- and Z-Station Planes Option
1. Select the Infinite Plane tool.

2. Pick X-, Y- or Z-Station from the drop down list on the Message Line. The Message 
Line reads: Infinite Plane: Pick location for plane.
To create the surface in a plane different from the one currently set, change the plane 
before moving on to the next step.

3. Click the point on the screen where the plane will be. An icon for the plane appears 
at that location.

The Status Line displays the X, Y and Z 
location for the plane.
Modify the location by typing new values in the appropriate fields. Tab to move from field 
to field. Pressing ENTER (Windows) or RETURN (Macintosh) and the plane location 
changes to reflect those values. All future changes must be made in the Edit Objects 
dialog box.

Tip: Determine the distance between two infinite planes by selecting the
planes and choosing Verify>Minimum Distance.

Using the Normal and Location Plane Option
1. Select the Infinite Plane tool.

2. Pick Normal Loc from the drop down list on the Message Line. The Message Line 
reads: Infinite Plane: Enter 3 points (1-Normal End, 2-Normal Start, 3-Loc).
To create the surface in a plane different from the one currently set, change the plane 
before moving on to the next step.

3. Click the point where the plane's normal will end, the point where the plane's normal 
will start, and the point where the plane will be placed.

There are no entries in the Status Line.

Using the Infinite Plane Tool to Create a Three Point Plane
1. Select the Infinite Plane tool.

2. Pick 3 Pts In Plane option from the drop down list on the Message Line. The Mes-
sage Line reads: Infinite Plane: Enter 3 points in the plane.
To create the surface in a plane different from the one currently set, change the plane 
before moving on to the next step.

3. Click three points. The plane icon appears at the specified location.
There are no entries in the Status Line.

Using the Infinite Plane Tool to Create a Plane Along a Curve
1. Select the Infinite Plane tool.

2. Pick Along Curve from the drop down list on the Message Line. The Message Line 
reads: Infinite Plane: Pick curve to distribute planes along [Shift=Extend].

3. Click a curve on the screen. The Input String dialog box 
appears.
Enter the number of planes to place along the curve. Click 
OK to accept the change and close the dialog box. Click 
Cancel to close the dialog box without accepting the 
changes.
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The planes are created along a curve. The example here shows 5 planes along a 
curve.

If the curve is selected, the Input String dialog box reappears to change the number of 
planes placed along the curve.
There are no entries in the Status Line.

Infinite Plane Tool - Along the Curve Option and the Plane/Surface Intersec-
tion Tool
Use the Along Curve option of the Infinite Plane tool with the Plane/Surface 
Intersection tool to quickly create cross sections through solid models. 
1. Select the Infinite Plane tool and select the Along Curve option. 

2. Create the planes along a curve adjacent to the solid model. 
3. Choose the Plane/Surface Intersection 

tool and pick the planes on the curve with 
which to cut the solid. The graphic here 
shows one example.

4. Select the solid. The Plane/Surface Inter-
section tool projects the planes through 
the solid. The Designer Elements program 
puts each projected plane on a separate 
layer after clicking the AutoLayers box on 
the Message Line before creating them.

5. The intersections display.
There are no entries in the Status Line.

Referral: See Plane/Surface Intersection Tool for information on using the
Plane/Surface Intersection Tool.
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Clipping Planes
Dynamic display clipping planes provide a means to slice through the model and hide 
the display to either side of the plane.
In order to use an Infinite Plane as a Clipping Plane bring up the Shade Options 
dialog box located in the View Menu and select the Use Clip Planes option.

Using an Infinite Plane as a Clipping Plane
1. Select the Infinite Plane tool. The Message Line reads: Infinite Plane: Pick location 

for plane.

2. Place the infinite plane in the drawing.
3. Right-Click on the infinite plane and select the Use a Clip Plane menu option.
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4. All objects are visually clipped and sectioned. The perpendicular arrow represents 
the normal, which indicates the direction of the clipped part of the unit.

5. Adjust the plane visually using the handles on the plane indicator. There are 3D han-
dles on the corners, midpoints and center of the clip plane. Midpoint markers rotate 
the clip plane. Hold the SHIFT key to rotate in 45-degree steps.

Corner markers pan the plane along the normal. The central marker moves the clip 
plane to any location.
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6. Edit the plane properties with the Edit Object dialog box. Double click the plane to 
open the Edit Objects. Use the Scale option to size the plane.

Auto The diagonal of the clip plane is equal to the length of the 
diagonal of an imaginary bounding box of all the objects to be 
clipped.

Fixed Shows just the plane object in the plane origin.
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7. Modify the color of the clip plane cut with the Section drop down menu. 

Object Color Makes the section the same color as the object, thus the 
clipped part looks like the solid object as in the picture below. 

Plane Color Makes the section the same color as the plane.

None  The section area appears transparent.
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8. Set the transparency of the clip plane in the View>Shade Options dialog.

9. The geometry tab of the Edit Object dialog box provides the following options:

Set the options and click the Apply button to activate the settings.

This is also referred to as changing the surface normal or flipping normals.
To turn off the clipping plane option go to the View>Shade Options menu and deselect 
the Use Clip Plane option. By default this option is on.

Location Sets the location of the plane origin.

Normal Sets the direction of the normal.

Angle 1 Sets the turn angle along the X axis. 

Angle 2 Sets the turn angle along the Y axis.

Apply Activates edited settings.



Sphere Surface Tool

17-9

Geometric Characteristics
An infinite plane is created by choosing points or curves as directed by the Message 
Line. An infinite plane is a surface made up of the following characteristics according to 
the Edit Objects dialog box: the Location for the X, Y and Z location and the Normal for 
the DX, DY and DZ location.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the plane and choose Window>Edit Objects or double-
click on the plane.

Sphere Surface Tool

This tool creates a sphere surface using a center and radius point.

Using the Sphere Surface Primitive Tool
1. Select the Sphere Surface Primitive tool. The Message Line reads: Sphere Primi-

tive: Enter center and radius point for sphere.

2. In the drawing area click the center point and radius point.
The Status Line contains X,Y and Z data fields for the sphere center point and dX, dY 
and dZ fields to reference distance and direction of the radius.

Block Surface Tool

The Block Surface Primitive creates a cubic or rectangular shaped object with six 
surfaces in a group.

Using the Block Surface Primitive Tool
1. Select the Block Surface Primitive tool. The Message Line reads: Block Primitive: 

Enter center and length points.

2. In the drawing area click the center and length points for the block.
The first point clicked is the center point. This is the bottom center of the resulting block. 
The second point clicked controls not only the length, but the orientation of the block.
The Status Line contains X, Y and Z data fields for the block base center point plus dX, 
dY and dZ for the height. In addition, it is possible to specify L and W for the length and 
width of the block.

Cylinder Surface Tool

This tool creates a cylindrical surface primitive.

Using the Cylinder Surface Primitive
1. Select the Cylinder Surface Primitive tool. The Message Line reads: Cylinder Prim-

itive: Enter start and end points for cylinder.

2. In the drawing area click the start and end points for the cylinder.
The first point clicked is the cylinder base center point. The second point clicked controls 
not only the length, but the orientation of the cylinder.
The Status Line contains X, Y and Z data fields for the cylinder base center point plus 
dX, dY and dZ for the height. In addition, specify D for the diameter of the cylinder.
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Pyramid Surface Tool

This tool creates a pyramid surface.

Using the Pyramid Surface Primitive
1. Select the Pyramid Surface Primitive tool. The Message Line reads: Pyramid Primi-

tive: Enter start and end points for pyramid.

2. In the drawing area click the start and end points for the pyramid.
The first point clicked is the pyramid base center point. The second point clicked 
controls the length and orientation of the pyramid.
The Status Line contains X, Y and Z data fields for the pyramid base center point plus 
dX, dY and dZ for the height. In addition, specify D for the pyramid base diameter and 
the #Sides for the number of sides.
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Surface From Curves Tools.

Net Surface Tool

The Net Surface tool creates a surface defined by a grid of M rows and N columns, 
where M and N are letter identifiers referring to the number of rows or columns. Curves 
suitable as boundaries for net surfaces include arcs, circles, lines, splines, ellipses and 
conics. These curves cannot be grouped.
The curves may be in different planes. If 
the curves lie in the same plane, the 
Designer Elements program creates a 
simple planar surface within the curve 
boundary. If the curves lie out of plane, the 
program fits a curved net surface similar to 
a Coons patch mesh to the boundary 
curves. A Coons patch is a three or four sided nurb surface. The left graphic below 
shows four curves. The right graphic shows the resulting net surface with the referenced 
curves in gray.
It is also possible to specify a point entity for 
the start or end of the net surface, creating a 
degenerative surface.

Tech Note: A net surface is not the same as a mesh. Net surfaces are nurb
surfaces. A mesh is defined by nodes or 3D vertices.
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Using the Net Surface Tool 
1. Select the Net Surface tool. The Message Line reads: Net Surface: Pick (M) curves 

defining surface [Shift=Extend].

2. Hold down the SHIFT key and pick two or more 
curves along one direction. The objects appear 
selected as in the graphic here (Curves 1 and 2).
When the SHIFT key is released, the objects are 
deselected. The Message Line now reads, Net 
Surface: Pick (N) curves defining surface 
[Shift=Extend].

3. Hold down the SHIFT key once again, and pick two 
or more curves to complete the boundary for the 
surface.
When the mouse button is released the net surface 
is created. The graphic here shows the net surface 
from the example above.

As the example shows here, the curves defining the 
surface do not have to be connected. The Designer 
Elements program calculates the intersecting area of 
the selected curves and creates the net surface from 
that area.
There are no entries in the Status Line.

Geometric Characteristics
A net surface is created by choosing curves as directed by the Message Line. A net 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. It is possible to display Iso Lines 
on the surface by entering the value in the U and V data fields and clicking Apply. A grid 
of U and V lines will display on the surface. There are options for the Silhouette setting, 
Smart, Off or On.
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Ruled Surface Tool

The ruled surface tool is used to create surfaces that are linear between the selected 
spans. Ruled surfaces are developable surfaces.  Developable surfaces can be unrolled 
into flat patterns without stretching or shrinking.

Using the Ruled Surface Tool
1. Select the Ruled Surface tool. The Message Line reads: Ruled Surface: Pick 

curves for defining surface. [Shift=Extend]

2. If there are more than two curves being used for the ruled surface hold down the 
SHIFT key and select all the curves. When the SHIFT key is released the surface is 
created

As the example shows, the curves defining the surface do not have to be connected. 
The Designer Elements program calculates the intersecting area of the selected curves 
and creates the ruled surface

Geometric Characteristics
A ruled surface is created by choosing curves as directed by the Message Line. A ruled 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. There are options for the Silhouette setting, Smart, Off 
or On.

Skin Surface Tools

A skin surface fits a network of 
NURB patches to a collection of 
curves that act as cross-sections for 
the final surface. The curves that are 
skinned can be open, closed or 
grouped. Curves suitable for 
skinning include lines, arcs, circles, 
ellipses, conics and splines. Create 
a standard skin surface or closed 
(tangent) skin surface. It is also 
possible to specify a point entity for 
the start or end of the surface, 
creating a degenerative surface.
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Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when creating a skin surface.

Tech Note: Do not confuse the Skin Surface tool with the Cover Surface tool.
The curves selected for this tool are used as cross-sections. They cannot be
connected or intersecting. A warning message will appear if invalid curves for
the operation are chosen. To surface curves that are connected or closed use
the Cover Surface tool.

There are two tools in the Message Line, Skin Curve and Skin with Guide Curves.

There is also an Advanced Skin Options dialog box that gives more control of how the 
object looks when skinned.

It contains the following options:

Close Last Section 
with First

The close option may be used when the user needs to 
construct a body closed in one direction (v direction). The 
default is an open (not closed) body. The surface is continuous 
at each profile.  If a set of closed profiles is provided, the face 
normals of the skin or loft body point outside, away from the 
body material. When a set of open profiles is provided, the 
surface normals of the skin surface is oriented along the 
surface normals and no attempt is made to change the surface 
normal orientation.  When using this option profiles are not to 
be provided in the same position.

Simplify Surface The simplify option simplifies the created surface to a conical 
surface, if applicable. If all of the cross sections lie on a conical 
surface (plane, cylinder, cone, sphere or torus), the conical 
surface is created instead. The value of 0.000001 is used to 
determine whether or not the cross section lies on an analytical 
surface (planar, conical, spherical or toroidal). The default is 
not simplified.
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Standard Skin Surface
An open skin surface is a surface that has open ended in all directions. Select the 
curves in the order that they need to be skinned. When selecting the successive curves 
(or n# sections), create a surface between the curves. The individual curves are not 
surfaced. To surface curves connected end to end use the Cover Surface tool. See a 
later section in this chapter.

Tech Note: The term, N# sections, refers to the curve sections selected to
create a surface. The letter N is the generic identifier.

Auto-Align Sections The align sections option may be used to allow the skinning 
algorithm to align the direction of the curves  in the selection 
list.  Closed loops of wires can also be aligned. The default is 
aligned.

Arc Length 
Parameterization

The arc length option is used to choose arc length or 
isoparametric parameterization of the skinning  surfaces. In 
isoparametric parameterization the surface parameter in the v 
direction follows the cross section curves. In arc length 
parameterization the surface parameter follows lines of 
constant length. The default is arc length parameterization.

Minimize Twist The twist option may be used to minimize the twist of the 
surface produced. Twist minimization aligns closed curves 
such that the start of the second curve is aligned to the start of 
the first curve. Even if a body’s shape is unaffected by twisting, 
a surface with a twist could produce unexpected results when 
faceting and rendering.  By default, twist minimization is on. 
Twist minimization is also an involved calculation that may not 
be carried out.

Perpendicular Skin The take–off vector is a tangent vector going out of the starting 
edge or surface and into the skinned surface. The 
perpendicular option is used to specify the direction of the 
take–off vector, perpendicular to the edge. The default is in the 
loft direction because a perpendicular take–off vector can 
cause self–intersections to the surface.

Draft Angle Skinning with draft angles provides the ability to control the 
take–off vectors of the two outer skinning profiles. The “draft” 
angle is defined as an angle off the plane of the wire at every 
point along the skinning profile. In addition to the user 
supplying the angle itself, one may also supply a magnitude for 
the take–off vector.  The draft angle and magnitude is constant 
for the entire profile. However, different draft angles may be 
applied to the two outer profiles. In addition skinning with draft 
angles supports open and closed profiles and skinning to a 
point. When skinning to a point the algorithm constructs its own 
normal vector. The outer profiles must be planar when not 
degenerate. Use the Edit Object dialog box to access the skin 
magnitude.
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The curves must have the same 
direction. If the curves have 
different directions the resulting 
surface will twist from section to 
section, as shown here.

To avoid creating twisted 
surfaces, check the curves' 
directions by choosing 
Verify>Direction. If the curves do 
run in different directions, adjust 
or redraw them before creating 
the surface. The graphic here 
shows curves with the same 
direction and the resulting 
surface.
This tool also provides an option 
for creating closed tangents.

Closed Skin Surface
A closed or tangent skin surface is continuous end to end. 
When using this option, the Designer Elements program 
automatically closes the skin such that the first section 
equals the last section making the slopes along the edge 
tangent continuous. The graphic here shows spline curves 
used to create a closed skin surface with the Skin with 
Guide Curves tool.
When these splines are skinned normally, the left model 
here results. When skinned using the closed skin option, 
the right model results.

Skin Curve Surface Tool

This tool creates a skin surface 
between two or more curves. The 
surface edges are defined by the 
limits of the selected curves. A 
standard skin surface or a closed 
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skin surface can be created. The figure here shows a open skin surface created from 
three curves.

Creating a Standard Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do not run 

in the same direction, adjust them so that they do.

2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
4. Select the curves in the order that the surface is to be skinned. To select more than 

two curves hold down the SHIFT key. A selection fence can not be used to select the 
curves.

There are no entries in the Status Line.

Creating an Closed Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do not run 

in the same direction, adjust them so that they do.

2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Closed (Windows) or Option (Macintosh) Shift=Extend].

3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
4. (Windows) Select the curves in the order that the surface is to be skinned. To select 

more than two curves hold down the SHIFT key. (The selection fence can not be 
used to select the curves.) After selecting the last curve and while still holding down 
the SHIFT key, hold down the CTRL key. Release the SHIFT key and then the CTRL 
key.
(Macintosh) Hold down the OPTION key and select the curves in the order that the 
surface is to be skinned. To select more than two curves hold down the 
SHIFT+OPTION keys. The selection fence can not be used to select the curves. 
The tangent surface is created.
There are no entries in the Status Line.

Skin with Curve Guides Surface Tool

This tool creates a skin surface between two or more curves using curves as guides to 
define the edges. Guide curves gives the control over the skin surface. Use one or more 
guide curves to influence the surface.
In the left graphic below, the profile curves are black and the guide curves are gray. The 
right graphic shows the skinned surface.
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Guide Curve Rules
• Curves can go in any direction and need not be consistent with the others.
• Curves cannot loop and must be “well-behaved.” 
• The curves must connect with each profile that is to be used for surface creation.
Note: Guide curves only affect the geometry of the surface created between the profiles 
to which the guide curves are attached. Also, if the guide curve passes through vertices, 
the two adjoining surfaces follow the curve profile.
It is possible to create a standard skin surface or a closed skin surface.

Creating a Standard Skin Surface
1. Check curve directions of the profile curves by choosing Verify>Direction. If all of 

the curves do not run in the same direction, adjust them so that they do.

2. Create one or more guide curves.
3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 

for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message 
Line.

5. Select the curves in the order that the surface is to be skinned. To select more than 
two curves, hold down the SHIFT key. A selection fence can not be used to select 
the curves.
The Message Line now reads, Skin Surface: Pick guide curves [Shift = Extend].

6. Select the guide curves.
The skin surface is created.

There are no entries in the Status Line.

Creating a Closed Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do not run 

in the same direction, adjust them so that they do.

2. Create one or more guide curves.
3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 

for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message 
Line.

5. (Windows) Select the curves in the order that the surface is to be skinned. To select 
more than two curves hold down the SHIFT key. (The selection fence can not be 
used to select the curves.) After the last curve is selected and while still holding 
down the SHIFT key, hold down the CTRL key. Release the SHIFT key and then the 
CTRL key.
(Macintosh) Hold down the OPTION key and select the curves in the order that the 
surface is to be skinned. To select more than two curves hold down the 
SHIFT+OPTION keys. The selection fence can not be used to select the curves. 
The Message Line now reads, Skin Surface: Pick guide curves [Shift = Extend].

6. Select the guide curves.
The tangent surface is created.
There are no entries in the Status Line.
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Geometric Characteristics
A skin surface is created by choosing curves as directed by the Message Line. A skin 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. There are options for the Silhouette setting, Smart, Off 
or On.

Cover Surface Tool

The Cover Surface tool creates a surface from curves connected end to end. The tool 
tip calls these curves n-sided. Curves suitable as boundaries for covered surfaces 
include arcs, circles, lines, splines, ellipses, conics and grouped curves. 
The curves may be in different planes. If 
the curves lie in the same plane this 
Designer Elements program creates a 
simple planar surface within the curve 
boundary. If the curves lie out of plane, 
this program fits a Gregory surface to the 
boundary curves. A Gregory surface is a 
nurb surface with five or more sides.

Using the Cover Surface Tool 
1. Select the Cover Surface tool. The Message Line reads: Cover Surface: Pick 

curves for cover surface [Shift=Extend].

2. To select more than one curve hold down the SHIFT key before selecting the first 
curve.

3. Select the curves. Do not worry about the order in which they are selected. 
The cover surface is created.

If not all of the curves selected are connected end to end, as shown in the figure below, 
the program warns with a Profile Error dialog box and marks the gaps in the selected 
curves.
If gaps are detected, two warning messages appear. The first one says, "Gaps detected 
in profile. Would you like to examine gaps?"
Click No to ignore the 
gaps and continue.
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Click Yes, and another message appears: "Gaps in profile are shown with red indicators. 
Use Undo to remove indicators. Hint: gaps can also be caused by duplicate or 
overlapping geometry in the profile."

Click OK to remove the message and view the 
profile with red Xs where gaps are detected. 
After noting the gaps, use Edit>Undo to clear 
the indicators or drag a selection box around 
them and press Delete. The indicators are 
created as geometric points, adding geometry to 
the drawing. 
There are no entries in the Status Line.

Geometric Characteristics
A cover surface is created by choosing curves as directed by the Message Line. A cover 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. Options for the Silhouette setting include Smart, Off or 
On

Revolved Surface Tool

The Revolve Surface tool creates a surface by revolving a set of curves (called the 
profile) around a central axis.
In the Message Line, there is a subpalette displaying two tools for revolving profiles: 
Revolved Surface about Two Points and Revolved Surface about a Curve.

Revolving curves connected at their endpoints the resulting revolution creates one 
surface.
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Revolved Surface about Two Points Tools

This tool revolves a curve about two 
chosen points. The direction of the 
Angle of Revolution is determined 
by the order in which the points that 
define the axis are picked. Use the 
Right Hand Rule to determine the 
direction that the surface will 
revolve. 
See Triad for more information on the Right Hand Rule.

Using the Surface of Revolution Tool - About Two Points
1. Select the Revolved Surface tool.

2. Select the Resolve Surface About Two Points tool in the Message Line. The Mes-
sage Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].

3. Enter the angle through which to revolve the curve in the Angle data field of the Sta-
tus Line.

4. Select the curve or curves to revolve. 
The Message Line directs to enter two points for lathe (or revolution) axis. 

5. Click two points to define the Axis of Revolution. 
If the Axis of Revolution crosses any 
of the profile curves this error 
message appears:
Pick a new non-intersecting axis to 
complete the surface of revolution.
The surface is created.

Change the Angle while the surface is 
still selected by highlighting the Angle 
field, entering a new value and 
pressing ENTER (Windows) or RETURN (Macintosh). The surface adjusts accordingly. 
Any future modification to angle must be made through the Edit Objects dialog box.

Revolved Surface about a Curve Tool

This tool revolves a curve 
about an existing curve that is 
chosen. The direction of the 
angle of revolution is 
determined by the direction in 
which the axis of revolution 
curve was drawn. Use the 
Right Hand rule to determine the direction for the revolution. See Chapter 2 for more 
information about the Right Hand Rule.

Using the Revolved Surface Tool: About a Curve
1. Select the Revolved Surface tool.

2. Select the Resolve Surface About Curve tool in the Message Line. The Message 
Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].
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3. Enter the angle through which to revolve the curve in the Angle data field on the Sta-
tus Line.

4. Select the curve or curves to revolve.
5. Select the curve to use as the Axis of Revolution. If the Axis of Revolution crosses 

any of the profile curves and error message appears. Choose another curve or 
adjust the curve as required.
The surface is created.

Change the Angle while the surface is still selected by highlighting the Angle field, 
entering a new value and pressing ENTER (Windows) or RETURN (Macintosh). The 
surface will adjust accordingly. Any future modification to angle must be made through 
the Edit Objects dialog box.

Geometric Characteristics
A revolved surface is created by choosing a curve to revolve and the axis of revolution. 
A revolved surface has the following geometry characteristics according to the Edit 
Objects dialog box: Rot. Angle, End 1 (X, Y and Z values) and End 2 (X, Y and Z 
values).
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. You have options for the Silhouette setting, Smart, Off 
or On.

Sweep Surface Tool - Along 2 Points

The Sweep Surface tool sweeps a curve along a path defined by the user. The path 
chosen depends on the Sweep Surface tool used. This Designer Elements program 
automatically aligns, orders and sets the direction of the curves for the sweep path.
This tool sweeps a curve along 
a two point vector. The sweep 
surface starts from the curve 
and moves in the direction and 
distance indicated by two 
chosen points. The resulting 
surface is associative to the 
original sweep curve. Change 
the curve and the surface 
automatically updates.
To check information on the sweep use commands in the Verify menu. Grouped curves 
can be sweeped with this tool.

Tip: To sweep a curve at an angle not perpendicular to the curve, change the
view to specify the sweep points. Example: drawing a rectangle in the top
plane, change the view to front and specify the points at the desired angle.

Using the Sweep Surface Tool: Along 2 Points
1. Select the Sweep Surface Along 2 Points tool. The Message Line reads: Pick 

curve(s) to sweep [Shift=Extend].

2. Select the curve to sweep. The Message Line reads: Sweep 2 Pts Surface: Enter 
two points for sweep direction.
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3. Click two points to define the vector. The order the points are clicked specifies the 
direction of the sweep. 
The vector cannot run in the 
same direction as the curve. If 
a vector is defined in that 
direction this message 
appears:
Select the curve again and 
click two other points to define 
the vector.
The sweep surface is created.

The values in these data fields can be changed while the surface is still selected by 
highlighting the desired field and entering in a new value. Use the Tab key to move from 
field to field. Press ENTER (Windows) or RETURN (Macintosh) and the surface will 
adjust accordingly. Any changes made after this must be made in the Edit Object dialog 
box.
The Status Line displays delta values for the X, Y and Z coordinates of the vector and 
the distance of the sweep.

Geometric Characteristics
A swept surface is created by choosing a curve to sweep and the points for the two 
points defining the vector. A swept surface along two points has the following geometry 
characteristics according to the Edit Objects dialog box: Distance and Vector (dX, dY 
and dZ values).
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. There are options for the Silhouette setting, Smart, Off 
or On.

Sweep Surface Tool - Along 1 Rail

This tool creates a surface by sweeping an open, closed or grouped curve along another 
curve. The resulting surface is associative to both the path and the sweep curve.
Modifying either automatically updates 
the associative sweep surface. Only one 
curve can be sweeped at a time.

Using the Sweep Surface Tool: 
Along 1 Rail
1. Select the Sweep Surface Along 1 

Rail tool. The Message Line reads: 
Sweep 1 Rail Surface: Pick curve to sweep [Shift=Extend].

2. Click the sweep curve. The Message Line reads: Sweep 1 Rail Surface: Pick sweep 
axis [Shift=Extend].

3. Click the rail curve. The surface is created.
There are no entries in the Status Line.

Geometric Characteristics
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A swept surface is created by choosing a curve to sweep and a curve that acts as the 
rail for the sweep. A swept surface along one rail has no specific geometry 
characteristics according to the Edit Objects dialog box. There are tabs for both Display 
and Attributes.
Display contains settings for Iso lines and Silhouette. Iso Lines can be displayed on the 
surface by entering the value in the U and V data fields and clicking Apply. A grid of U 
and V lines will display on the surface. There are options for the Silhouette setting, 
Smart, Off or On.

Sweep Surface Tool - Along 2 Rails

The sweep along two rails method creates a swept surface by sweeping an open, 
closed or grouped profile between two rail curves. A rail can also be closed, back 
tracking over itself like a circle. This tool supports the maintaining of the profile height 
along the rail by holding down the CONTROL (Windows) or OPTION (Macintosh) key. 
This tool does not support multiple or grouped curves for the rails. A simple two rail 
sweep is shown in the graphic here.

As mentioned, it is also possible to use closed curves or curves that backtrack as the 
rails. In the left graphic below, the top circle and bottom ellipse are the rails and the 
spline is the curve being swept. The right graphic shows the swept surface.

The rail curves define the orientation and scale of the swept surface as it moves 
between them. The resulting surface is associative to both rails and the sweep curve. 
Modifying any of the three will automatically update the associative sweep surface.

Using the Sweep Surface Tool: Along 2 Rails
1. Select the Sweep Surface tool.

2. Select the Sweep Surface Along 2 Rails tool in the Message Line. The Message 
Line reads: Sweep 2 Rail Surface: Pick curves or group to sweep. [Ctrl or Option = 
Maintain Height][Shift = Extend]

3. Click the profile to sweep and then choose the two rails for the sweep path.
A swept surface is created.
Hold down the Ctrl or Option key to maintaine the profile height.

There are no entries in the Status Line.
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Geometric Characteristics
A swept surface is created by choosing curves or grouped profiles that act as the rails 
for the sweep. A swept surface along two rails has no specific geometry characteristics 
according to the Edit Objects dialog box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. Iso Lines can be displayed on the 
surface by entering the value in the U and V data fields and clicking Apply. A grid of U 
and V lines will display on the surface. There are options for the Silhouette setting, 
Smart, Off or On.

Sweep Rules
• Double-click the surface to display the Edit Objects dialog box. Picking the surface 

and the original sweep curve with Edit>Select All, or by dragging a selection fence, 
the Edit Objects dialog box will list only the attributes of the two entities and will omit 
the sweep surface's geometry information. Therefore, always select the surface by 
double-clicking it. With the second click, the Edit Objects dialog box appears 
automatically.

• To perform a helical sweep, the helix must originate in this Designer Elements 
program. Imported helix curves do not follow the helix curve law and the sweep 
operation requires this for a proper sweep.

• If sweped curves are connected at their endpoints, the resulting sweep creates one 
surface.

Tube Surface Tool

Tube Surface tool quickly and efficiently creates a tube or pipe along a reference curve. 
This tool support grouped curves. A radius must be specified small enough to prevent a 
self-intersecting surface.

Using the Tube Surface Tool
1. Create a curve that would act as the center line for the tube.

2. Select the Tube Surface tool. The Message Line reads: Tube Surface: Pick tube 
center line [Shift=Extend].

3. Click the curve for the tube's center line.
4. Enter a new tube radius in the data field on the Status Line, if required. Press 

ENTER (Windows) or RETURN (Macintosh) and the radius of the tube will change 
accordingly.

To specify a tube radius before the tube is created, type the value in the Radius data 
field and then select the curve and the tube surface will be created with the specified 
radius.
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Geometric Characteristics
A tube surface is created by choosing a curve that will act as the center line for the tube. 
A tube surface has the following geometry characteristic according to the Edit Objects 
dialog box: Diameter of the tube.
Display contains settings for Iso Lines and Silhouette. Iso Lines can be displayed on the 
surface by entering the value in the U and V data fields and clicking Apply. A grid of U 
and V lines will display on the surface. There are options for the Silhouette setting, 
Smart, Off or On.
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Derived Surface Tools

Offset Surface Tool

Offset Surface tool makes a new surface based on an existing or parent surface, offset 
by a chosen amount. An infinite plane can be also offset.
The offset surface is created by first selecting the parent surface and specifying the 
offset surface. Offset surfaces maintain a constant distance normal to the parent 
surface. The direction of the offset is the surface normal direction. It is possible to 
specify negative offsets. Do not offset a surface a distance greater than the smallest 
radius of curvature or a degenerate surface can be created.

If a zero offset is specified, the Designer Elements program creates an associative copy 
of the selected surface at the same location.
it is also possible to 
offset solids faces. 
Single select a 
particular face or box 
select the entire 
solid to offset all of 
its faces. A positive 
offset for a solid, 
creates a surface 
outside the solid. A 
negative offset 
creates a surface towards the inside of the solid.
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Using the Offset Surface Tool
1. Select the Offset Surface tool. The Message Line reads: Offset Surface: Pick sur-

faces to offset [Shift=Extend].

2. Enter an Offset distance in the data field of the Status Line.

3. Click the parent surface. A duplicate surface appears at the offset distance.

Geometric Characteristics
An offset surface is created by choosing the parent surface and specifying an offset 
distance. An offset surface is composed of the offset value according to the Edit Objects 
dialog box. There are tabs for both Display and Attributes.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. There are options for the Silhouette setting, Smart, Off 
or On.

Lofted Surface Tool

The Lofted Surface tool creates a smooth, transitional surface between surfaces edges 
and any number of interior non-surface edges. To create a tangent surface select the 
edge of the start surface and the edge of the end surface. 
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Using the Lofted Surface Tool
1. Select the Lofted Surface tool. The Message Line reads: Lofted Surface: Pick 

edges for lofted surface.[Shift=Extend].

2. Enter a new bulge factor in the Bulge data field in the Status Line, if desired. The 
bulge factor controls the magnitude of the slope of the surface edges.

3. Click an edge on each surface 
to be joined by the tangent sur-
face. When a tangent surface is 
created, the screen shows only 
one connecting line. Choose 
View>Shade Now to see the 
tangent surface. If Shade Now 
is set to anything other than 
wireframe in the Shade Options 
dialog box, the lofted surface 
appears in the chosen mode.

Once created, the lofted surface can 
be modified in the Edit Objects 
dialog box accessed through the 
Design Explorer. The start bulge 
factor controls the magnitude of the 
slope from the starting edge, 
whereas the end controls the slope 
at the end curve. The reverse Edge 
Direction options are provided to fix 
twisting of the Tangent surface 
resulting from different edge 
directions. 
The figure shows two bulb surfaces joined with a tangent surface using different bulge 
factors. The left figure uses a 0.25 bulge factor; the center figure uses a 10.0 bulge 
factor; the right figure uses a 3.0 start bulge factor and a 0.5 end bulge factor.

A bulge factor of .25 is used at 
both ends.

A bulge factor of 10 is used at 
both ends.

A bulge factor of 3 is used at the 
top end and 0.50 factor at the 
bottom end.
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Geometric Characteristics
A lofted surface is created by choosing the 
two connecting surfaces. The bulge factor 
for the lofted surface edges can be edited 
in the Edit Objects dialog box. Tangent 
Edge 1 controls the first edge chosen and 
Tangent Edge 2 controls the last edge 
chosen.
Display contains settings for Iso Lines and 
Silhouette. Display Iso Lines on the 
surface by entering the value in the U and 
V data fields and clicking Apply. A grid of U 
and V lines will display on the surface. 
There are options for the Silhouette 
setting, Smart, Off or On.

Draft Surface Tool

The Draft Surface tool extends a surface to create a new 
surface attached to the end of the original surface. This 
Designer Elements program provides data fields for angle 
and length that give the control over how the surface is 
generated. Entering 0° in the Angle data field extends the 
surface tangent to the original. Entering 90° extends the 
surface perpendicularly.
There are two options to set the new surface tangency; Default and Align Curve. The 
default option is automatic when using this tool. It creates a draft surface aligned with 
the original surface derivatives, based on the product of the surface tangent and normal. 
The graphic below shows the original geometry and the resulting draft surface.

By holding down the CTRL key (Windows) or OPTION key (Macintosh), choose the 
Align Curve option listed in the Message Line. When using this option, a draft surface is 
created based on the product of the alignment curve tangent and the surface normal. 
The graphic below shows the original geometry and the resulting draft surface.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when creating a draft surface.
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Using the Draft Surface Tool
1. Select the Draft Surface tool. The Message Line reads: Draft Surface: Select curve 

on surface [Ctrl=Align Curve].

2. Enter a new angle and/or length in the data fields in the Status Line, if necessary.

3. Click a curve (edge) on the surface to draft or extend the surface. When the edge is 
seleced, the whole surface is highlighted until this Designer Elements program cre-
ates the draft.

Both the angle and the length of the Draft can be changed by entering new values in the 
data field while the geometry is still selected. Pressing ENTER (Windows) or RETURN 
(Macintosh) will make the change. Any other changes must be made in the Edit Objects 
dialog box.

Geometric Characteristics
A draft surface is created by choosing a curve to draft and entering the desired angle 
and length of the draft. A draft surface has the following geometry characteristics 
according to the Edit Objects dialog box: Angle and Length.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines on the surface 
by entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the surface. There are options for the Silhouette setting, Smart, Off 
or On.

Fillet Surface Tool

The Fillet Surface tool blends two surfaces that share an edge or intersection. This tool 
does not extend surfaces.
When filleting two intersecting surfaces, there are four places where the fillet can be 
placed. The fillet is created where the surface directions are positive for both surfaces. 
The surface direction can be determined by selecting and choosing Verify>Direction. 
Change the direction by choosing Edit>Change Direction. The left graphic here shows 
two intersecting surfaces. The right graphic shows the surfaces blended.

Using the Fillet Surface Tool
1. Select the Fillet Surface tool. The Message Line reads: Fillet Surface: Pick two sur-

faces to blend [Shift=Extend].

2. Select the two intersecting or connected surfaces that share an edge
The surfaces are filleted.
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To change the fillet radius, type the value in the Radius data field in the Status Line and 
press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the Radius for the blend.

Geometric Characteristics
A fillet surface has the following geometric characteristic according to the Edit Objects 
dialog box: Radius of the fillet.
The Display page of Edit Objects contains settings for Iso Lines and Silhouette. Display 
Iso Lines on the surface by entering the value in the U and V data fields and clicking 
Apply. A grid of U and V lines will display on the surface. There are options for the 
Silhouette setting, Smart, Off or On.

Tangent Cover Tool

The Tangent Cover surfaced creates a surface that is tangent to four neighboring 
surfaces. The surfaces must form a closure. Curves can be selected for some of the 
boundaries however if there is a choice, use surface edges for the boundary of the 
tangent cover surface.

Using the Tangent Cover Surface Tool
1. Select the Tangent Cover Surface tool. The Message Line reads: Tangent Cover 

Surface: Pick four edges/curves for cover surface.

2. Select the surface edges and or curves. Select them inhead to tail fashion. The tan-
gent cover surface is created.

Note: The first surface selected is the driving surface. Changing the order of the surface 
selection can change the final results.
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Surface Utility Tools 

Cobalt, Xenon and Argon all provide several editing tools in the Surface Editing tool 
palettes. The tools perform such operations as intersecting existing surfaces and solids 
with other entities, projecting curves onto surfaces, adding to or subtracting from and 
intersecting 2D planar surfaces as well as joining or trimming surfaces. 

Surface Editing Tools
Many of the editing tools require a two step process for their use. The first step after 
choosing the tool may be to select one or more objects. The second step performs the 
editing operation. Once the first step is completed other objects cannot be selected to 
include in the same operation. To select additional objects reset the tool and start again.
Note: These tools do not support the use of grouped objects.
The geometric characteristics listed in the Edit Objects dialog box after editing an object 
using these tools are the same as the object's standard characteristics. For example, if a 
curve/surface intersection is performed, the Edit Objects dialog would display 
characteristics of the resulting curve.

Selecting Objects within the Editing Tools
With these editing tools select the objects for performing an operation. When 
selecting the tool and moving the cursor into the drawing area it becomes a hollow 
selection arrow (shown here).
After finishing selection the pointer becomes a general tool pointer (shown here.)
This hollow selection arrow must not be confused with the Selection tool.

Plane/Surface Intersection Tool

The Plane/Surface Intersection tool calculates the intersection of an infinite plane with 
a curve, surface or solid. The resulting cut is automatically associative with the plane 
and the object so that if either entity is modified, the cut will update (Cobalt and Xenon 
only).
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Auto Layers Option
This tool provides an Auto Layer option in the Message Line. When this option is 
enabled, the program puts each section cut on a separate layer and names the layer 
according to the location of the cut. For example, the graphics here show a solid block 
with three intersecting planes.

With the Auto 
Layers option 
enabled each 
section is placed 
on a separate 
layer. The Layer 
Manager graphic 
below shows the 
new layers.
Important: 
(Windows users) 
Because the CTRL 
and SHIFT keys 
are programmed to 
perform specific 
operations for this 
tool, the Stroke 
Zoom function 
(CTRL+SHIFT 
keys) is not 
available when 
using this tool.

Tip: When the Auto Layers option is used with the Increment Layer command
(ALT+0 - Windows, z+0 - Macintosh) and Decrement Layer (ALT+9-Windows,
z+9-Macintosh), to change layers, it provides a convenient way of examining
every 2D cut of a 3D model.
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Intersecting a Plane with a Curve
When a plane intersects with a curve, a point intersection results. The left graphic below 
shows a plane and three curves. The right graphic displays the intersection points for 
the plane and the curves.

1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersec-
tion: Pick the planes to slice objects with. [Ctrl = Auto Layers] [Shift = Extend]

2. Click the plane to use for intersecting the curve. Hold down the SHIFT key to pick 
more than one plane. The Message Line reads: Plane/Surface Intersection: Pick 
objects to intersect with plane. [Shift=Extend]

3. Click the curves to intersect with the plane.
The intersection point displays. The point is associative to the plane and curve. 
Modifying either the plane or the curve automatically updates the location of the point. 
(Cobalt and Xenon only)

There are no entries in the Status Line.

Intersecting a Plane with a Surface
When a plane intersects with a surface, a curve intersection results. If the curve is a 
spline, it is a vector spline capable of being edited.

1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersec-
tion: Pick planes to slice objects with.  [Ctrl = Auto Layers] [Shift=Extend]
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2. Click the plane to use to intersect the surface. Hold down the SHIFT key to pick 
more than one plane. The Message Line reads: Plane/Surface Intersection: Pick 
objects to intersect with plane. [Shift=Extend]

3. Click the surface to intersect with the plane.
The intersection curve displays. The curve is associative to the plane and surface. 
Modifying either the plane or the surface automatically updates the location of the 
curve (Cobalt and Xenon only).

There are no entries in the Status Line.

Intersecting a Plane with a Solid
When a plane is intersected with a solid, a curve intersection results. If the curve is a 
spline, it is a vector spline capable of being edited.

1. Click the tool in the tool palette. The Message Line reads: Plane/Surface Intersec-
tion: Pick planes to slice objects with. [Ctrl = auto Layers] [Shift=Extend].

2. Click the plane to use to intersect the solid. Hold down the SHIFT key to pick more 
than one plane. The Message Line reads: Plane/Surface Intersection: Pick objects 
to intersect with plane. [Shift=Extend]

3. Click the solid to intersect with the plane.
The intersection curve displays. The curve is associative to the plane and solid. 
Modifying either the plane or the solid automatically updates the location of the curve 
(Cobalt and Xenon only).

There are no entries in the Status Line.

Curve/Surface Projection Tool

The Curve/Surface Projection tool supports projecting curves onto surfaces and solids 
along a direction vector. Specify the direction vector by clicking two points. The new 
curve is associative to the object. When modifying the object the projected curve will 
automatically update (Cobalt and Xenon only).
Select the Curve/Surface Projection tool from the Surface Utilities tool palette and 
these options appear in the Message Line:
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Through Projects a curve on a surface that intersects the entire object.

To Entity Projects a curve where it first touches the object.

To Face Projects a curve only on the specified face. 
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Projecting a Curve to a Surface
With this tool a curve projects onto a surface. If the curve is a spline, it is a vector spline 
capable of being edited.

1. Select the tool in the tool palette. Choose the necessary option in the Message Line. 
The Message Line reads: Curve/Surface Projection: Pick curves to project onto sur-
face. [Ctrl = Imprint] [Shift=Extend]

2. Click the curve to project onto the surface (it does not highlight). Hold down the 
SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface 
Projection: Pick ONE surface or solid for curve projections. [Shift=Extend]

3. Click the surface or solid onto which to project the curve.
4. Enter two points for the projection vector.

The curve projects onto the surface.
There are no entries in the Status Line.

Projecting a Curve to a Solid
This tool projects a curve onto a solid. If the curve is a spline, it is a vector spline 
capable of being edited.

1. Click the tool in the tool palette. Select the necessary option in the Message Line. 
The Message Line reads: Curve/Surface Projection: Pick curves to project onto sur-
face. [Ctrl = Imprint] [Shift=Extend].

2. Click the curve to project onto the solid (it does not highlight). Hold down the SHIFT 
key to pick more than one curve. The Message Line reads: Curve/Surface Projec-
tion: Pick ONE surface or solid for curve projections. [Shift=Extend]

3. Click the solid onto which to project the curve.
4. Enter two points for the projection vector.

The curve projects onto the solid.
There are no entries in the Status Line.
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Surface/Surface Intersection Tool

The Surface/Surface Intersection tool calculates the intersection of two existing 
surfaces or a surface and a solid. Select the two objects and the tool creates one or 
more curves. The curves are associative with both objects (Cobalt and Xenon only). 
When changing either object the intersection curve will update. To remove the 
associative link, use Edit>Remove Links.

Intersecting a Surface with a Surface 
Use this tool to intersect two surfaces producing a curve intersection. If the curve is a 
spline, it is a vector spline capable of being edited.

1. Select the tool in the tool palette. The Message Line reads: Surface/Surface Inter-
section: Pick two surfaces or solids for intersection.

2. Click on the two surfaces. An intersection curve displays.
There are no entries in the Status Line.

Intersecting a Surface with a Solid
Use this tool to intersect a surface with a solid.

1. Click the tool in the tool palette. The Message Line reads: Surface/Surface Intersec-
tion: Pick two surfaces or solids for intersection.

2. Click the two surfaces. An intersection curve displays.
There are no entries in the Status Line.

Curve/Surface Intersection Tool

The Curve/Surface Intersection tool calculates the intersection of a curve and a 
surface or solid. The tool creates a collection of point objects. The points are associative 
to both the curve and object (Cobalt and Xenon only).
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Intersecting a Curve with a Surface
This tool intersects a curve with a surface.

1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersec-
tion: Select curves to intersect surface/solids. [Shift=Extend]

2. Click the curve to intersect the surface. Hold down the SHIFT key to pick more than 
one curve. The Message Line reads: Curve/Surface Intersection: Select surfaces or 
solids to intersect with curve. [Shift=Extend]

3. Click the surface to intersect with the curve. The intersection points display.
There are no entries in the Status Line.

Intersecting a Curve with a Solid
Intersect a curve with a solid with this tool.

1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersec-
tion: Select curves to intersect surface/solids. [Shift=Extend]

2. Click the curve to intersect the solid. Hold down the SHIFT key to pick more than 
one curve. The Message Line reads: Curve/Surface Intersection: Select surfaces or 
solids to intersect with curve. [Shift=Extend]

3. Click the solid to intersect with the curve. The intersection points display.
There are no entries in the Status Line.

Boolean Surface Tools

Cobalt, Xenon and Argon all support 2D boolean operations on planar surfaces created 
with the cover surface command. The Boolean Surface tool adds surfaces together, 
subtracts surfaces from one another, and finds the intersection of two or more surfaces. 
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Use the new curves created from boolean operations for 2D property analysis or as 
profiles for solid extrusions, sweeps and lathe operations.

There are three tools for performing boolean operations: Add 
Boolean Surface, Subtract Boolean Surface and Intersect 
Boolean Surface.
For the purposes of explaining these tools the objects to the 
right are used.

Add Boolean Surface Tool

This tool adds two objects to create a third object.
1. Select the Boolean Surface tool.

2. Select the Add Boolean Surface tool in the Message 
Line. The Message Line reads: Boolean Surface: Pick planar surface to add to. 
[Shift=Extend]

3. Select the surface to which another will be added. The Message Line reads: Bool-
ean Surface: Pick planar surface to add. [Shift=Extend]

4. Select the surface to be added.
There are no entries in the Status Line.

Tip: To get volume, density and other properties of geometry in the drawing,
combine them with this tool whether or not they are connected.

Subtract Boolean Surface Tool

This tool subtracts one surface from another.
1. Select the Boolean Surface tool.

2. Select the Subtract Boolean Surface tool in the Message 
Line. The Message Line reads: Boolean Surface: Pick planar surface to subtract 
from. [Shift=Extend]

3. Select the surface from which you will subtract another. The Message Line reads: 
Boolean Surface: Pick planar surface to subtract. [Shift=Extend]

4. Select the surface to be subtracted. One surface is subtracted from the other.
There are no entries in the Status Line.

Intersect Boolean Surfaces Tool

This tool retains the intersecting portion of two surfaces.
1. Select the Boolean Surface tool.

2. Select the Intersect Boolean Surface tool in the Message 
Line. The Message Line reads: Boolean Surface: Pick planar surface to intersect 
with. [Shift=Extend]
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3. Select the surface with to intersect another. The Message Line reads: Boolean Sur-
face: Pick planar surface to intersect. [Shift=Extend]

4. Select the surface to be intersected. The intersecting portion of the surfaces is dis-
played.

There are no entries in the Status Line.

Connect Surface Tool

The Connect Surface tool merges two surfaces into one. The resulting surface retains 
the original surfaces mathematical definitions, but a selection operation treats both 
surfaces as one. Unlike the Add Boolean Surface tool the Connect Surface tool can be 
used with non-planar surfaces. The left graphic below displays two separate but 
connecting surfaces. The graphic on the right displays one surface that retains the 
characteristics of the individual surfaces.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when using this tool.

Using the Connect Surface Tool
1. Click the Connect Surface tool in the tool palette. The Message Line reads: Con-

nect Surface: Pick two surfaces to connect. [CTRL = Advanced (Windows) or 
OPTION = Advanced (Macintosh)] [Shift=Extend].

2. For advanced settings tap the CTRL 
key (Windows) or the OPTION key 
(Macintosh) to display the Stitching 
Options dialog box to enter the maxi-
mum stitch and heal gap sizes, simplify 
spline surfaces or use tolerant edges.

3. Click the two surfaces to connect. The 
surfaces become one surface but 
retain their individual mathematical 
definitions.

There are no entries in the Status Line.

Split Surface Tool

Use the Split Surface tool to cut away portions of a surface. It is possible to trim a 
surface to another surface, curve or solid. Unlike the Subtract Boolean Surface tool the 
Split Surface tool can be used with non-planar surfaces.
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Tech Note: The Split Surface tool will not work with grouped surfaces.

Using the Tool to Split a Surface with a Surface
Use this tool to trim a surface to a surface.

1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Sur-
face: Pick surface to split.

2. Select the surface to split. The Message Line reads: Split Surface: Pick curves, sur-
face, or solid to split with.

3. Select the entity that defines the trim area. The program splits the surface at the 
intersection of the two entities. The objects won't appear differently on the screen. 
Delete any unnecessary portions.

There are no entries in the Status Line.

Using the Tool to Split the Surface to a Curve
Use this tool to trim a surface to a 
curve.
1. Select the Split Surface tool 

in the tool palette. The Mes-
sage Line reads: Split Sur-
face: Pick surface to split.

2. Select the surface to trim. The 
Message Line reads: Split 
Surface: Pick curves, surface, 
or solid to split with. 
[Shift=Extend]

3. Select the entity that defines the trim area. The program splits the surface at the 
intersection of the surface and curve. The objects won't appear differently on the 
screen. Delete any unnecessary portions.

There are no entries in the Status Line.

Using the Tool to Split a Surface with a Solid
Use this tool to split a surface to a 
solid.
1. Select the Split Surface tool in 

the tool palette. The Message 
Line reads: Split Surface: Pick 
surface to split.

2. Select the surface to split. The 
Message Line reads: Split Sur-
face: Pick curves, surface, or 
solid to split with.
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3. Select the entity that defines the split area. The program splits the surface at the 
intersection of the surface and the solid. The objects won't appear differently on the 
screen. Delete any unnecessary portions.

There are no entries in the Status Line.

Silhouette Curves Tool

The Silhouette Curves tool creates curves from the bounding edge of an object relative 
to a user-defined projection direction. The curves produced by this tool are, in most 
cases, non-planar. This tool is useful for producing injection mold drawings.

Using the Silhouette Curves Tool
1. Select the Silhouette Curves tool, The Message Line reads: Silhouette Curves: Pick 

surface/solids for silhouettes. [Shift = Extend]

2. Select the objects on which silhouette curves are necessary. The message line now 
reads, Silhouette Curves: Specify two points for view direction.

The example below shows the progression of use with the Silhouette Curves tool.
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Surface Modification Tools

Match Surface Tool
Cobalt, Xenon and Argon provide tools for modifying and evaluation the local faces of 
surfaces. 

This tool imposes a smooth transition from one surface to another neighboring surface. 
It also performs greater surface manipulation by inserting a knot and elevating the 
degree of the surface.
There are two options available for this tool: Match 
G1 Slope and Match G2 Slope, Insert Knot. These 
are accessed through the pull-down menu in the 
Message Line.

Rules and Notations for using the Match Surface Tool and Options
• Surfaces cannot be trimmed. (Any surface that has had a relimit or another editing 

operation conducted on it is a trimmed surface.) To match untrimmed surfaces, first 
untrim them using the Untrim Surface tool before matching them. See a later section 
about this.

• Surfaces must share the same edge being within 0.001 inches or 0.0254 mm of each 
other.

• The direction and slope of the surfaces do not matter.
• Matching two surfaces with the G1 Slope or G2 Slope options adjusts the slope of the 

first surface to that of the second. To reduce the influence of the matched slope on 
the surface, elevate its degree using the Elevate Surface tool before matching the 
surfaces. See a later section about this tool.
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Match G1 Slope Option
Use this option to match two untrimmed surfaces with G1 continuity. G1 matched 
surfaces are tangent continuous at their shared edge. The graphics on the left below are 
the two original surfaces. The graphics on the right below are the same surfaces using 
the G1 Slope option

Tech Note: G1 stands for geometric continuity matched to the first derivative,
tangency. G1 matched surfaces are tangent continuous.

Using the G1 Slope Surface Option
1. Select the Match Surface tool.

2. From the pull-down menu in the Message Line, 
select Match G1 Slope. The Message Line 
reads: Match Surface: Pick surface edge to modify tangency.

3. Click on the edge of the surface to modify.
Be sure to click on the edge and not somewhere on the body of the surface. The 
entire surface highlights. The Message Line now reads, Match Surface: Pick surface 
edge to match.

4. Click on the surface edge to which the first surface is being matched.
The slope of the first surface edge now matches the second surface edge with a G1 
continuity. Verify this continuity by using the surface evaluation feature. In a surface 
evaluation plot, stripes represent the slope of the surface.
These stripes line up from the first surface to the second surface for G1 continuous 
surfaces.
See the Surface Evaluation section at the end of this chapter for information.
There are no entries in the Status Line.
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Match G2 Slope Option
Use this option to match two untrimmed surfaces with G2 continuity. G2 matched 
surfaces are tangent and curvature continuous at their shared edge. The graphics on 
the left below are the two original surfaces. The graphics on the right below are the 
same surfaces using the G2 Slope option.

Tech Note: G2 stands for geometric continuity matched to the first and
second derivative tangency and curvature continuous. G1 matched surfaces
are tangent and curvature continuous.

Using the G2 Slope Surface Option
1. Select the Match Surface tool.

2. From the pull-down menu in the Message Line, select Match G2 Slope. The Mes-
sage Line reads: Match Surface: Pick surface edge to modify tangency.

3. Click on the edge of the surface to modify.
Be sure to click on the edge and not somewhere on the body of the surface. The 
entire surface highlights. The Message Line now reads, Match Surface: Pick surface 
edge to match.

4. Click on the surface edge to which the first surface is being matched.
The slope of the first surface edge now matches the second surface edge with a G2 
continuity. Verify this continuity by using the surface evaluation feature. In a surface 
evaluation plot, stripes represent the slope of the surface. These stripes line up from 
the first surface to the second surface for G2 continuous surfaces.
See the Surface Evaluation section at the end of this chapter for information.

There are no entries in the Status Line.



Surface Modification Tools

21-4

Rebuild Surface Tool

The Rebuild Surface tool reconstructs an approximating surface to the surface to 
rebuild. The tightest tolerance achieved is displayed in a dialog box.  If the tolerance 
achieved is not tight enough, use undo to put the surface back in its orginal condition.
The Rebuild Surface tool is useful for converting analytics to cubic NURBs, trimmed 
surfaces to untrimmed surfaces, and repairing surfaces.  The rebuild tool is limited to 
surfaces with 3 or 4 sides.

Using the Rebuild Surface Tool
1. Select the Rebuild surface tool.  The Message Line reads: Rebulid Surface: Pick 

surface to rebuild.

2. Click the surface to rebuild.
There are no status line entries for this command.
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Untrim Surface Tool

Using this option removes all trim boundaries on a surface face. The left graphic below 
shows a trimmed surface. The right graphic shows the surface after this option is used.

Using the Untrim Surface Option
1. Select the Untrim Surface tool.

2. From the pull-down menu in the Message Line, select Untrim Surface. The Mes-
sage Line reads: Untrim Surface: Pick surface to untrim.
The surface untrims.

There are no entries in the Status Line.

Elevate Surface Tool

This tool elevates the degree of a surface introducing more control points. These control 
points can be used to modify the surface.
NURB surfaces are defined by polynomial equations. The most basic equation possible 
is used to define the surface. Where cylindrical and spherical shapes are defined by 
second degree polynomials, skin, cover and net surfaces are defined by third degree 
polynomials due to their complexity. Shapes defined by higher degree polynomicals 
have more control points than those defined by lesser degree polynomials. This option 
raises the degree level for a shape providing more control points for surface 
manipulation.

Surfaces can be elevated up to the 22nd degree, however, it is recommended not to 
elevate a curve higher than 9 degrees. Degree elevation is useful when trying to match 
surfaces and minimize the effect of the match on the surface.
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Using the Elevate Surface Tool
1. Select the surface for which to add control points.

2. Choose Window>Edit Objects to verify that the surface is a surface face.
If the surface is a surface face continue with step 5.

3. Choose Edit>Change Object Type.
4. Select the Surface option and click OK.

If the surface selected is 
linked to another object, the 
following warning box 
appears.
Click Yes to continue 
conversion.

5. Choose Edit>Show Points 
to display the surface control 
points.

6. Select the Elevate Surface 
tool. 

7. From the pull-down menu in the Message Line select: Elevate Degree. The Mes-
sage Line reads: Elevate Surface: Pick surface to elevate.

8. Select the surface.
The surface elevates to the next degree.

There are no entries in the Status Line.

Insert Knot Tool

This tool adds a row or column of control points to a surface. The surface must be 
untrimmed and the surface face type. Net, skin and cover surfaces must be converted 
into the surface face type using the Change Object Type command in the Edit menu. 
Verify the surface type by double-clicking on the surface to display the Edit Objects 
dialog box.
Knot insertion is valuable to adjust a surface shape at a location where there are no 
control points. Knot insertion is also useful when trying to match surfaces and minimize 
the effect of the match on the surface. The left graphic below displays the control points 
of the original surface. The right graphic shows an additional row of control points at the 
right end of the surface.

After inserting control points using this option, other control points may have shifted. 
This is automatically done to preserve the surface shape.
There are two options in the Insert Knot tool: At Location and Across Surface. At 
Location inserts one row or column of knots near designated spot, depending on the 
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edge selected.  Across Surface inserts multiple rows and columns of knots equally 
spaced across a surface.

Using the Insert Knot Tool - At Location Option
1. Select the surface to which control points are being added.

2. Choose Window>Edit Objects to verify that the surface is a surface face.
If it is continue on with step 5.

3. Choose Edit>Change Object Type.
4. Select the Surface option and click OK.

If the selected surface is 
linked to another object, the 
following warning box 
appears.
Click Yes to continue 
conversion.

5. Choose Edit>Show Points 
to display the surface control 
points.

6. Select the Insert Knot tool.

7. From the pull-down menu in the Message Line select At Location. The Message 
Line reads: Insert Knot: Pick surface to insert a new knot.

8. Select the surface. The Message Line now reads: Insert Knot: Specify location for 
new knot.

9. Select a location along an edge of the surface for the new row or column of knots.
A new series of knots are added. To add another row or column of knots select the 
surface again.

There are no entries in the Status Line.

Using the Insert Knot Tool - Across Surface Option
1. Select the surface to which control points are being added.

2. Choose Window>Edit Objects to verify that the surface is a surface face. If it is, 
continue on with step 5.

3. Choose Edit>Change Object Type.
4. Select the Surface option and click OK.

If the selected surface is linked to another object, the following warning box appears.
Click Yes to continue conversion.

5. Choose Edit>Show Points to display the surface control points.
6. Select the Insert Knot tool.
7. From the pull-down menu in the Message Line select Across Surface. 
8. In the Status Line enter the number of rows and columns of knots to be inserted 

across the surface in both directions.
9. The Message Line reads: Insert Knot: Pick surface to insert a new knot. [SHIFT = 

Extend]
Select the surface.  

There Status Line contains the Number of Knots data field specifying the number of rows 
or columns of knots in both directions.
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Introduction to Solid Modeling
A solid model is an unambiguous 3D representation of an object, composed of 
selectable faces. A solid model is unambiguous because the mathematical descriptions 
completely define the inside and outside of a 3D object. 
Unlike wireframes and surfaces which define lengths and areas, solids accurately 
provide volume, mass, moments of inertia, centroids and interference information. 
Solids also generate stereolithography models useful for demonstrating prototype 
concepts or for creating forms for molds or castings.
Ashlar-Vellum's Cobalt, Xenon and Argon are all based on Spatial Technologies’ ACIS 
Geometry Engine. ACIS provides a precise boundary representation of solids suitable 
for design projects sensitive to accuracy. In ACIS, linear and quadric geometry is exactly 
represented analytically while free-form geometry is represented as Non Uniform 
Rational B-Splines (NURBs). Unlike faceted solid modelers, ACIS maintains a high level 
of accuracy as boolean operations are performed or features are added. Because the 
ACIS engine is so accurate, parts modeled with it are suitable for applications that 
demand precision, like numerical control. All of the Designer Elements programs 
provide several sets of tools with which to create or modify solids: Primitives, Profiles, 
Features and Editing.
The topics explained here include:
• Solid Modeling Tools
• Drafting Assistant and Solids
• Solids, Selection and Display
• Solid Associativity
• Solids and Instances
• Cutting and Pasting Solids
• Exporting Solids
• Object Types and Edit Objects
• Error Messages
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Solid Modeling Tools
The solid modeling tools are accessible from the 
Solids tool palette. The Solids tool palette displays 
automatically when the program is first launched. To 
toggle the palette display on and off, use 
Window>Solids. 
The palette appears under the main tool palette on the 
left side of the screen.

The five solid modeling subpalettes contain groups of 
tools for creating primitives, profiled solids, features 
and editing solids.

Primitives
A primitive is a simple shape such as a sphere, slab, block, cylinder, etc. 

The Primitives subpalette contains the following tools: Sphere, Slab, Block, Cylinder, 
Cone, Torus, Prism, Pyramid and Ellipsoid. Sphere Surface Tool explains these tools.

Profiles
A profile is a curve or collection of curves that enclose an area. Create a solid from a 
profile by revolving, extruding, or sweeping a curve or pipe profile along a path. 

Primitive Tools

Profile Tools

Feature Tools

Solid Utility Tools

Local Face Tools
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The Profiles subpalette's contains the following tools: Lathed, Extrude, Sweeps (path, 2-
rail), Cutout, Protruded Feature, Skinned Solid and Pipe Solid. Solids from Curves Tools 
explains these tools.

Features
A feature simplifies building or modifying a solid by constructing common design 
elements with a single command.

The Features subpalette's contains the following tools: Blends (constant, linear, 
variable), Chamfer (constant, angle, linear) Holes (simple hole, counter bore, counter 
sink), Boss, Shell and Bend. Solid Feature Tools explains these tools.

Solid Utility Tools
When creating the geometry it is possible to perform various operations such as splitting 
a solid or placing a draft. The Solid Utility tools provide various ways of editing solid 
objects.

The Solid Editing tool subpalette contains the following tools: Boolean (Union, Subtract, 
Intersect), Trim, Split, Stitched, Thicken, Lofted, Rib Feature and Lip Feature (Remove 
and Add). Solid Utility Tools explains these tools. 

Local Solid Face Tools
When creating or importing geometry various operations can be performed. The Local 
Solid Face Tools provide a means to modify individual faces of the solid geometry.

The Local Solid Face subpalette contains the following tools: Draft Solid, Match Face, 
Move Face, Offset Face, Remove Face, Replace Face, Parting Line and Deform Face 
(by distance, to a point or to a curve). Solid Face Modification Tools explains these tools.

Drafting Assistant and Solids
The Drafting Assistant recognizes a variety of intelligent snap locations for solids 
including all hard vertices, user supplied points (grips), hole centers, cylinder centers, 
alignments, alignment intersections and fillet centers. The Drafting Assistant works the 
same for a solid as it does for a curve.
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Solids, Selection and Display
A solid can be selected by clicking on an edge or within a face. Selecting the solid on its 
edge is considerably faster than selecting within a face (the Designer Elements program 
has to cast a ray to see if it pierces the solid).

Displaying Solid Edges
Solids display three types of edges, Hard, Silhouette and Smart Silhouette. Hard edges 
are permanent edges and are present in all views. A Silhouette edge is a temporary 
edge that displays when the surface normal makes a 90 degree angle with the view 
normal. Smart Silhouettes display a silhouette only if it does not degrade the display 
performance.
It is possible to set one of these as the default by choosing File>Preferences>Display 
and selecting the option.

Object Resolution
A solid's edge resolution can be increased with the Change Resolution command in the 
Edit menu.
Choose one of five resolution settings: Super Fine, Very Fine, Fine, Medium or Coarse. 
Click a radio button next and then click OK to close the dialog box. The object will 
change accordingly.

Changing an Object's Resolution
1. Select the object.

2. Choose Edit>Change Resolution.

The Object Resolution dialog box appears.

3. Enter the desired number of Iso lines. Check the Show Silhouettes box if desired.
The number of Iso Lines control the isopram lines drawn for a solid face. These Iso 
(isopram) lines are constant parameter curves that lie on a surface, typically defined in 
parameter space. The parameter space coordinate system uses U and V coordinates. 
A 0 (zero) in both fields turns off Iso lines. The appropriate U/V values may enhance 
the visual appearance of the face at the expense of drawing speed. The letters, U and 
V are space coordinate identifiers (U = horizontal, V = vertical) that are the industry 
standard. The Force U=V check box automatically sets equal number of U and V 
lines. Entering a new value in one automatically changes the other isoline value.
The Silhouette check box controls the silhouette edges of objects. Silhouette edges 
are view dependent and can cause a significant reduction in drawing speed. A check 
in the box turns the silhouette on.
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4. Click OK to close the dialog box and save the new settings.

See Change Resolution for more information.

Solid Associativity
Solid objects are associative to the original curves used to create them. Changing the 
curve automatically changes the dependent solid. For example, creating a lathed solid 
from four curves and changing the length of one of them, the lathed solid automatically 
updates to reflect the change. Use the Edit>Remove Links command to remove all 
associativity with the solid if curve changes must not affect the solid. Another important 
issue to remember with the curve/solid associativity is that if the curve is deleted, the 
solid deletes as well. Since it is defined by the curve, it is no longer valid.

Solids and Instances
When performing an operation on a solid and moving it to another location, or when 
copying a solid, an instance of the original is created. Displaying the Edit Objects dialog 
box, the object is referred to as an instance.

Instances and Moving Solids
When creating an instance by 
moving the modified solid to another 
location, the information appears as 
an instance operation in the Design 
Explorer. The original object is still 
located in previous position, although 
it is not displayed. 
When selecting the Instance 
Translate item in the Design Explorer 
and then open the Edit Objects 
dialog box, the only geometry 
characteristics provided are the 
offset distances from the original 
solid.

Instances, Copying Solids and Associativity
Holding down the CTRL (Windows) or OPTION (Macintosh) key while moving the object 
with the Selection tool creates an instance copy of the original solid. There are two 
instance operations in the history tree in the Design Explorer. The first, called Instance, 

Silhouette On Silhouette Off
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is the copying operation. The second, called Instance: Translate is the translation 
operation moving the copied solid to a different location. 

Displaying the Edit Objects dialog box for the Instance item shows there are no unique 
geometric characteristics. Opening the history tree further the original solid is exposed 
and its characteristics can be viewed through the Edit Objects dialog box.
By copying a solid and thereby, creating an instance, this instance is associative to the 
original solid. All changes made to the original solid will automatically be made on all 
instances created from the original. For example, if a hole is added to the original after 
creating the instance, the hole is also added to all instances. Choose Edit>Resolve 
Links for this to occur. 
If an operation is performed on the original after an instance is created that conflicts with 
an operation already performed on that instance, two successive errors are received, a 
Reorder Error and a Resolve Links error (shown below). Choose Edit>Undo to return 
the part to the original state. 

When performing operations on an instance, they are listed in the Design Explorer and 
do not affect the original. If the link between the original and the instance is broken, 
changes made to the original will not affect the instance.
Be aware when creating multiple instances, whether instancing the original part or 
another instance. This is important if it is necessary to break the link between the 
original and an instance. If there are any instances created from that instance, their 
associativity to the original is broken as well. So, to break the link between one instance 
and the original, all other instances should be created from the original solid.
If it is not necessary to create an instance, select the original solid, choose Edit>Copy 
and then Edit>Paste. It is also possible to select the instance and choose Edit>Remove 
Links, however, the object geometry cannot be edited using the technique.
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Cutting and Pasting Solids
By cutting and pasting a solid all associativity relationships are lost. After cutting and 
pasting a part, it is not possible to edit any of its features. Cutting and pasting a solid 
does, however, provide an easy way to remove a part's history tree, thereby minimizing 
the amount of memory it consumes.

Cutting and Pasting on the Macintosh
By cutting and pasting a solid object into is Designer Elements program on a Macintosh 
computer, the object is represented in both PICT2 and VS Object form. When both 
forms are present, cut and paste a representation of the solid into other applications and 
cut and paste a true solid back into the Designer Elements program drawing.

Exporting Solids
To export a solid model created in this program to another application, convert the model 
to a standard format. Three formats are supported:
1. When exporting to an application that supports ACIS, generate a SAT file. SAT files 

contain precise geometry and topology, so the other application can import the 
solid's data as it was created in Cobalt, Xenon or Argon.

2. Convert the solid into polylines or meshes with the Change Object Type command in 
the Edit menu. After converting the model, use the DXF export command to create 
an ASCII DXF file.

3. Export solids through the IGES translator as solid entities or as a collection of 
trimmed surfaces.

Object Types and Edit Objects
Every solid object created with Cobalt, Xenon or Argon tools are defined by their own 
characteristics and include geometric characteristics and attributes. These are 
displayed in the Edit Objects dialog box. While the categories listed in the Attributes tab 
are identical, the categories listed in the Geometry tab vary with each object.
For example: A line created by the Single Line tool includes the following categories: 
Length, Angle, End 1 for X, Y, and Z, and End 2 for X, Y and Z.
Solids Primitive Tools and Solids from Curves Tools introduce the solids tools that create 
the objects. Included with every tool description is a list of the categories displayed for 
the object when Edit Objects is chosen. For information on using the Edit Objects 
command and the dialog box, see Design Explorer Commands.

Error Messages
Error Messages provide more feedback when trying to perform operations such as 
shelling, local face modeling and so on. The Designer Elements program determines 
why the operation failed and provides a hint to the feature that may have caused the 
problem.
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Solids Primitive Tools

Primitives are simple solid shapes. Primitives can be created by picking one point, two 
points or diagonals. Each Designer Elements program primitive is defined by a unique 
set of characteristics which can be edited.
Values for each tool can be entered in the Status Line to define a solid either before or 
after creating the solid. If the values are entered after selecting the tool but before 
creating the solid, the first click in the drawing area automatically registers all Status 
Line values. Entering values in the selected Status Line data field after creating the solid 
and while the solid is still selected, then pressing ENTER (Windows) or RETURN 
(Macintosh) updates the solid to reflect the new values.
The Primitive tools are explained in the order of the palette and include:
• Sphere Primitive Tool
• Slab Primitive Tool
• Block Primitive Tool
• Cylinder Primitive Tool
• Cone Primitive Tool
• Torus Primitive Tool
• Prism Primitive Tool
• Pyramid Primitive Tool
• Ellipsoid Primitive Tool

Sphere Primitive Tool

Cobalt, Xenon and Argon create a sphere from a center point and radius or from two 
diagonal points on a bounding box. When selecting the Sphere Primitive tool, a 
subpalette appears in the Message Line containing three options for creating spheres: 
Sphere 1 Point, Sphere 2 Point and Sphere by Diagonals.

The Drafting Assistant recognizes the points picked to define the sphere.
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Sphere 1 Point Option

This tool draws a sphere using the specified center point and the 
radius entered in the Status Line.

Using the Sphere 1 Point Option
1. Select the Sphere Primitive tool.

2. Select the Sphere 1 Point option in the Message Line. The Message Line reads: 
Sphere Primitive: Enter center point for sphere.

3. Click a point in the drawing area.
The sphere is created in the specified location.

While the sphere is still selected, change the X, Y, Z location of the center point and the 
radius, if desired. Press ENTER (Windows) or RETURN (Macintosh) to accept the new 
values.
The Status Line contains X, Y and Z data fields for the sphere center point and the 
Diameter data field. 

The program creates one point spheres independently of the construction plane’s 
orientation.

Sphere 2 Point Option

This draws a sphere from the center point and specified radius.

Using the Sphere 2 Point Option
1. Select the Sphere Primitive tool.

2. Select the Sphere 2 Point option in the Message Line. The Message Line reads: 
Sphere Primitive: Enter center and radius point for sphere.

3. Click the center point and the radius point in the drawing area.
The sphere is created.

While the sphere is still selected, change the X, Y, Z location of the center point and dX, 
dY and dZ values for the radius, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains X, Y and Z data fields for the sphere center point and dX, dY 
and dZ fields to reference distance and direction to the radius.

Sphere by Diagonals Option

This draws a sphere based on the two corners of the sphere’s 
specified bounding box.
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Using the Sphere By Diagonals Option
1. Select the Sphere Primitive tool.

2. Select the Sphere by Diagonals option in the Message Line. The Message Line 
reads: Sphere Primitive: Enter diagonal corners for sphere.

3. Click two points in the drawing area.The sphere is created. 
The program places the sphere’s center midway between the two points and 
calculates the radius from the smallest length of the enclosing box.

While the sphere is still selected, change the X, Y, Z location of the first corner point and 
dX, dY and dZ values to the second corner, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.
The Status Line contains X, Y and Z data fields for the first point and the dX, dY and dZ 
fields for the distance and direction to the second point.

Geometric Characteristics
A sphere primitive is created by picking one or two points to specify the sphere’s center 
point, radius or bounding box corners, and is made up of the following characteristics: 
Center (X, Y, and Z values) and Diameter. This information appears in the Edit Objects 
dialog box under the Geometry tab. To display the dialog box, select the sphere and 
choose Window>Edit Objects or double-click on the sphere.

Slab Primitive Tool

Create a solid slab primitive by extruding a series of closed planar points. If the points 
do not close, the program automatically closes them. It also checks for invalid or 
overlapping slab points. If one or more are detected, no slab is created.
Cobalt, Xenon or Argon determines the extrusion direction from the order in which the 
points are entered. It constructs the slab in the direction of the right hand rule (see Triad 
for information on the right hand rule). Although the slab’s points must be coplanar, they 
do not have to be in the current construction plane. Specify only a draft angle for the 
slab.

Using the Slab Tool
1. Select the Slab Primitive tool. The Message Line reads: Slab Primitive: Enter 3 or 

more points for slab. (Double-click last point).

2. Click the three or more points to describe the slab. (Be careful that the points are not 
overlapping.)
The slab is created with the height and draft angle listed in the Status Line.
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While the slab is still selected, the height and draft angle can be changed in the Status 
Line, if desired. Press ENTER (Windows) or RETURN (Macintosh) to adjust the slab to 
the new values.
The Status Line contains the Height and Draft Angle data fields.

Geometric Characteristics
A solid slab primitive is created by picking three or more points for the slab’s corners 
and is made up of the following characteristics: the Height and Draft Angle, and the 
Defining Points (X, Y, and Z values) of the slab’s corner points. This information is listed 
in the Edit Objects dialog box under the Geometry tab. The section below Defining 
Points displays the selected point. Each point can be edited individually using the X, Y 
and Z fields. To display the dialog box, select the slab and choose Window>Edit 
Objects or double-click the slab.

Block Primitive Tool

The block primitive is a cubic or rectangular solid. When selecting the Block Primitive 
tool a subpalette appears in the Message Line containing three block options: Block 1 
Point, Block 2 Point and Block by Diagonals.

Block 1 Point Option

This draws a block using the specified center point and 
the Height entered in the Status Line.

Using the 1 Point Block Option
1. Select the Block Primitive tool.

2. Select the Block 1 Point option in the Message 
Line. The Message Line reads: Block Primitive: 
Enter center point for block base.

3. Click a point in the drawing area.
The block is created with its base centered at the 
chosen point. The block’s orientation is determined 
by its length, width, and height along the x, y, and z 
axes of the work plane.

While the block is still selected, it is possible to change the X, Y, Z location of the base 
center point and length, width and height of the block, if desired. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z location of the block base center point and 
Length, Width and Height of the block.
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Block 2 Point Option

This option draws a block between the center points 
of each end.

Using the 2 Point Block Option
1. Select the Block Primitive tool.

2. Select the Block 2 Point option in the Message 
Line. The Message Line reads: Block Primitive: 
Enter centerline points for block.

3. Click two points in the drawing area.
The block is created centered on the point chosen 
with a height equal to the distance between the 
two chosen points.

While the block is still selected, it is possible to change the X, Y, Z location of the base 
center point, the dX, dY and dZ to the second point for defining the width and height of 
the block and the length, if desired. Press ENTER (Windows) or RETURN (Macintosh) 
to accept the new values.
The Status Line contains the X, Y and Z location of the block base center point, the dX, 
dY and dZ to the second point for defining the Width, Height and Length of the block.

Block by Diagonals Option

This draws a block based on the two base corners and 
the specified height.

Using the Block by Diagonals Option
1. Select the Block Primitive tool.

2. Select the Block by Diagonals option in the Mes-
sage Line. The Message Line reads: Block Primi-
tive: Enter start diagonal point. [Shift=Square]

3. Click two points in the drawing area to specify two 
diagonal corners of the block’s base. 
Hold down the SHIFT key to draw a square.

4. After the first two points are placed The Message Line reads: Block Primitive: Enter 
height.

5. Drag to set the height of the block.
The block is created. Working in the top, front or side view, pick a point, and the 
program will make the block’s height equal to its width. Working in 3D view, select the 
point to set the desired height.

While the block is still selected, it is possible to change the X, Y, Z location of the first 
corner or the length, width and height of the block, if desired. Press ENTER (Windows) 
or RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the first chosen corner and the solid’s 
Length, Width and Height.
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Geometric Characteristics
A solid block primitive is created by picking one or two points to specify the center point 
of the block’s base, the block’s height, or the locations of two of the block’s corners. The 
block is made up of the following characteristics: Length, Width and Height. This 
information is listed in the Edit Objects dialog box under the Geometry tab. To display 
the dialog box, select the block and choose Window>Edit Objects or double-click the 
block.

Cylinder Primitive Tool

Cobalt, Xenon and Argon create circular 
and elliptical cylinder primitives. The 
cylinder is defined by a base radius ratio 
and a height. The base radius ratio 
defines the ratio between the major 
radius (R1) and minor radius (R2). A 
circular cylinder’s base ratio equals one. 
Any other value yields an elliptical 
cylinder. The graphic gives a visual 
representation of these definitions.
When the Cylinder Primitive tool is 
selected, a subpalette appears in the Message Line containing three cylinder options: 
Cylinder 1 Point, Cylinder 2 Point and Cylinder by Diagonals.

Cylinder 1 Point Options

This option draws a cylinder using the specified center point and 
the radius and height entered in the Status Line.

Using the Cylinder 1 Point Option
1. Select the Cylinder Primitive tool.

2. Select the Cylinder 1 Point option in the Message Line. The Message Line reads: 
Cylinder Primitive: Enter center point for cylinder.

3. Click a point in the drawing area. 
The cylinder is created with its base centered at the chosen point. The cylinder 
extends along the z axis of the current construction plane.

While the cylinder is still selected, it is possible to change the X, Y, Z location of the base 
center point and radius and height of the cylinder, if desired. Press ENTER (Windows) 
or RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the cylinder’s base center point and 
its Diameter and Height.
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Cylinder 2 Point Option

This tool draws a cylinder from the center point of the base, the 
second point for the height and radius.

Using the Cylinder 2 Point Option
1. Select the Cylinder Primitive tool.

2. Select the Cylinder Two Point option in the Message Line. The 
Message Line reads: Cylinder Primitive: Enter start and end 
points for cylinder.

3. Click two points in the drawing area.
The cylinder is created with its height is equal to the distance between the two chosen 
points and with its top and bottom centered on those points.

While the cylinder is still selected, it is possible to change the X, Y, Z location of the base 
center point, the dX, dY and dZ to the second point for defining the distance and 
direction of the cylinder and the radius, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the base center point, the dX, dY and 
dZ values for the distance and direction to the second point, and the Diameter.

Cylinder by Diagonals Option

This option draws a cylinder based on the two base 
corners and the height.

Using the Cylinder by Diagonals Option
1. Select the Cylinder Primitive tool.

2. Select the Cylinder by Diagonals option in the Mes-
sage Line. The Message Line reads: Cylinder Primitive: Enter start diagonal point. 
[Shift=Square]

3. Click two points in the drawing area to specify two diagonal corners of the cylinder 
base’s bounding box. 
Hold down the SHIFT key to draw a circular base. 

4. The Message Line reads: Cylinder Primitive: Enter height.
5. Drag to set the height of the cylinder.

The cylinder is created. Working in the top, front or side view, pick a point and the 
program makes the cylinder’s height equal to that of the last drawn cylinder (or equal 
to one inch if this is the first drawn cylinder). Working in a 3D view it is possible to 
select the point to set the desired height.

While the cylinder is still selected, it is possible to change the X, Y, Z location of the 
cylinder’s base center point, the dX, dY, and dZ values for the distance and direction to 
the second point, and the cylinder’s height, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the cylinder’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point and the Height.



Solids Primitive Tools

23-8

Geometric Characteristics
A cylinder primitive is created by picking one point to specify the center point of the 
cylinder’s base, two points for the center point and height, or three points for the corners 
of the bounding box and the cylinder’s height. It is made up of the following 
characteristics: Height, Diameter (Major axis) and Diameter Ratio (D1/D2 or R1/R2). 
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the cylinder once and choose Window>Edit Objects or 
double-click the cylinder.

Cone Primitive Tool

The cone primitive has an elliptical base at one end and a point at the other. Like the 
cylinder, the cone is defined by a base radius ratio and a height. 
The ratio defines the 
relationship between the 
major radius (R1) and minor 
radius (R2). A circular cone’s 
base ratio equals one. Any 
other value yields an elliptical 
cone.
When selecting the Cone 
Primitive tool a subpalette 
appears in the Message Line containing three cone options: Cone 1 Point, Cone 2 
Point and Cone by Diagonals.

Cone 1 Point Option

This option draws a cone using the specified center point and 
the radius and height entered in the Status Line.

Using the Cone 1 Point Option
1. Select the Cone Primitive tool.

2. Select the Cone 1 Point option in the Message Line. The Message Line reads: 
Cone Primitive: Enter center point for cone.

3. Click a point in the drawing area.
The cone is created with its base centered at the chosen point. The cone extends 
along the z axis of the current work plane.

While the cone is still selected, change the X, Y, Z location of the base center point and 
radius and height of the cone, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the cone’s base center point and its 
Diameter and Height.
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Cone 2 Point Option

This tool draws a cone from the center point of the base at the 
height and specified radius.

Using the Cone 2 Point Option
1. Select the Cone Primitive tool.

2. Select the Cone 2 Point option in the Message Line. The 
Message Line reads: Cone Primitive: Enter start and end 
points for cone.

3. Click in the drawing area to set the start (center) point and the end (tip) point of the 
cone.
The cone is created with its height equal to the distance between the two chosen 
points and with its top and bottom centered on those points.

While the cone is still selected, change the X, Y, Z location of the base center point, the 
dX, dY and dZ to the second point for defining the distance and direction of the cone and 
the radius, if desired. Press ENTER (Windows) or RETURN (Macintosh) to accept the 
new values.
The Status Line contains the X, Y and Z values for the base center point, the dX, dY, dZ 
values for the distance and direction to the second point (tip) and the Diameter.

Cone by Diagonals Option

This tool draws a cone based on the two base 
corners and the specified height.

Using the Cone by Diagonals Option
1. Select the Cone Primitive tool.

2. Select the Cone by Diagonals option in the 
Message Line. The Message Line reads: Cone Primitive: Enter start diagonal point. 
[Shift=Square]

3. Click two points in the drawing area to specify two diagonal corners of the cone 
base’s bounding box.
Hold down the SHIFT key to draw a circular base. 
After doing this step, the Message Line reads: Cone Primitive: Enter height.

4. Drag to set the height of the cone.
The cone is created. Working in the top, front or side view, pick a point, and the 
program makes the cone’s height equal to that of the last drawn cone (or equal to one, 
if this is the first drawn cone). Working in a 3D view, select the point to set the desired 
height.

While the cone is still selected, change the X, Y, Z location of the cone’s base center 
point, the dX, dY, and dZ values for the distance and direction to the second point (tip), 
and the cone’s height, if desired. Press ENTER (Windows) or RETURN (Macintosh) to 
accept the new values.
The Status Line contains the X, Y and Z values for the cone’s base center point, the dX, 
dY and dZ values for the distance and direction to the second point, and the Height.
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Geometric Characteristics
A cone primitive is created by picking one point to specify the center point of the cone’s 
base, two points for the center point and height, or three points for the corners of the 
bounding box and the cone’s height. It is made up of the following characteristics: 
Height, Top Diameter, Diameter Ratio (D1/D2 or R1/R2) and Bottom Diameter. This 
information is listed in the Edit Objects dialog box under the Geometry tab. To display 
the dialog box, select the cone once and choose Window>Edit Objects or double-click 
the cone.

Torus Primitive Tool

The torus primitive looks like a doughnut. It is 
generated by sweeping a circle around another 
implied circle. The torus is defined by a center 
point, the diameter of the torus, called the Major Diameter, and the tube’s diameter, 
called the Minor Diameter. The graphics below illustrate these dimensions.

When selecting the Torus Primitive tool, a subpalette appears in the Message Line with 
three torus options: Torus 1 Point, Torus 2 Point and Torus by Diagonals.

Torus 1 Point Option

This draws a torus using the specified center point and 
the Major Diameter (D1) and the Minor Diameter (d2) of 
the Status Line.

Using the Torus 1 Point Option
1. Select the Torus Primitive tool.

2. Select the Torus 1 Point option in the Message Line. The Message Line reads: 
Torus Primitive: Enter center point for torus.
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3. Click in the drawing area to set the center.
A torus is created with its center at the chosen point. The torus lies perpendicular to 
the z axis of the current work plane.

While the torus is selected, change the X, Y, Z location of the base center point, the 
Major diameter (D1) and the Minor diameter (d2), if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the torus’ center point, D1 (Major 
diameter) and D2 (Minor diameter).

Torus 2 Point Option

This draws a torus from the center point 
and radius.

Using the 2 Point Torus Option
1. Select the Torus Primitive tool.

2. Select the Torus 2 Point option in the 
Message Line. The Message Line 
reads: Torus Primitive: Enter center 
and radius point for torus.

3. Click the center point and the radius point in the drawing area.
A torus is created with a center point at the first point and the major diameter at the 
second point.

While the torus is still selected, change the X, Y, Z location of the base center point, the 
dX, dY and dZ to the second point for defining the distance and direction, the Major 
Diameter (D1) and Minor Diameter (d2), if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the values.
The Status Line contains the X, Y and Z values for the torus’s center point, the dX, dY 
and dZ values for the distance and direction to the second point, the D1 (Major 
Diameter) and D2 (Minor diameter).

Torus by Diagonals Option

This option draws a torus from the 
center point, major radius and minor 
radius.

Using the Torus by Diagonals 
Option
1. Select the Torus Primitive tool.

2. Select the Torus by Diagonals option in the Message Line. The Message Line 
reads: Torus Primitive: Enter start diagonal point. [Shift=Square]

3. Click twice to specify two diagonal corners of the torus’ bounding box.
Hold down the SHIFT key to draw a square bounding box. 

4. The Message Line reads: Torus Primitive: Enter height.
5. Drag to set the height of the torus.
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Working in the top, front or side view, pick a point. The Designer Elements program 
calculates the torus’ Minor Diameter based on the location of that point. Working in a 
3D view, it is possible to select the point to set the Minor Diameter.

While the torus is still selected, change the X, Y, Z location of the torus’ center point, the 
dX, dY, and dZ values for the distance and direction to the second point (Major 
Diameter), and the torus’ Minor Diameter, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the torus center point, the dX, dY and 
dZ values for the distance and direction to the second point D1 (Major Diameter) and the 
D2 (Minor Diameter).

Geometric Characteristics
A torus primitive is created by picking one point to specify the center point of the torus, 
two points for the center point and Major Diameter, or three points for the corners of the 
bounding box and the torus’ Minor Diameter. It is made up of the following 
characteristics: Major Diameter, Minor Diameter, and Center (X, Y, and Z values). This 
information is listed in the Edit Objects dialog box under the Geometry tab. To display 
the dialog box, select the torus and choose Window>Edit Objects or double-click the 
torus.

Prism Primitive Tool

The prism primitive is composed of three 
or more sides, all perpendicular to the 
solid’s base.
Selecting the Prism Primitive tool, a 
subpalette appears in the Message Line 
containing three prism options: Prism 1 
Point, Prism 2 Point and Prism by Diagonals.

Prism 1 Point Option

This option draws a prism using the specified center point 
and the radius, height and number of sides listed of the 
Status Line.

Using the Prism 1 Point Option
1. Select the Prism Primitive tool.

2. Select the Prism 1 Point option in the Message Line. The Message Line reads: 
Prism Primitive: Enter center point for prism.

3. Click in the drawing area to set the base's center point.
A prism is created with its base centered at the chosen point. The prism extends along 
the z axis of the current work plane.
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While the prism is still selected, change the X, Y, Z location of the base center point, the 
radius, height and number of sides, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the prism’s base center point and its 
Diameter, Height, and Number of Sides.

Prism 2 Point Option

This draws a prism from the center 
point and at the specified height.

Using the 2 Point Prism Option
1. Select the Prism Primitive tool.

2. Select the Prism 2 Point option in the Message Line. The Message Line reads: 
Prism Primitive: Enter start and end points for prism.

3. Click in the drawing area to set the start point (center) and the end point (height).
A prism is created with its height equal to the distance between two points of the 
choice and its top and bottom centered on those points.

While the prism is still selected, change the X, Y, Z location of the base center point, the 
dX, dY and dZ to the second point for defining the distance and direction, the radius and 
the number of sides, if desired. Press ENTER (Windows) or RETURN (Macintosh) to 
accept the new values.
The Status Line contains the X, Y and Z values for the prism’s base center point, the dX, 
dY and dZ values for the distance and direction to the second point and the prism’s 
Diameter and Number of Sides. 

Prism by Diagonals Option

This tool draws a prism from two corner points, 
representing the prism’s bounding box and a 
third point for the height.

Using the Prism by Diagonals Option
1. Select the Prism Primitive tool.

2. Select the Prism by Diagonals option in the Message Line. The Message Line 
reads: Prism Primitive: Enter start diagonal point. [Shift=Square]

3. Click two points in the drawing area to specify two diagonal corners of the prism 
base’s bounding box.
Hold down the SHIFT key to draw a square bounding box. 

4. The Message Line reads: Prism Primitive: Enter height.
5. Drag to set the height of the prism.

Working in the top, front or side view, pick a point, and the program makes the prism’s 
height equal to the last drawn prism (or equal to one inch if this is the first drawn 
prism). Working in 3D view it is possible to select the point to set the desired height.

While the prism is still selected, change the X, Y, Z location of the prism’s base center 
point, the dX, dY, and dZ values for the distance and direction to the second point and 
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the prism’s height, if desired. Press ENTER (Windows) or RETURN (Macintosh) to 
accept the new values.
The Status Line contains the X, Y and Z values for the prism’s base center point, the dX, 
dY and dZ values for the distance and direction to the second point and the prism’s 
Height and Number of Sides.

Geometric Characteristics
A prism primitive is created by picking one point to specify the center point of the prism’s 
base, two points for the center point and height, or three points for the corners of the 
bounding box and the prism’s height. It is made up of the following characteristics: 
Height, Diameter, Diameter Ratio (D2/D1 or R2/R1) and Sides. This information is listed 
in the Edit Objects dialog box under the Geometry tab. To display the dialog box, select 
the prism and choose Window>Edit Objects or double-click the prism.

Pyramid Primitive Tool

A pyramid contains three or more flat 
faces which converge to a common 
vertex at the tip. 
A pyramid is created by defining the 
diameter of the base, the height and the number of sides. 
Selecting the Pyramid Primitive tool a subpalette appears in the Message Line 
containing three pyramid options: Pyramid 1 Point, Pyramid 2 Point and Pyramid by 
Diagonals.

Pyramid 1 Point Option

This draws a pyramid using the specified center point and the 
radius, height and number of sides listed of the Status Line.

Using the 1 Point Pyramid Tool
1. Select the Pyramid Primitive tool.

2. Select the Pyramid 1 Point option in the Message Line. The Message Line reads: 
Pyramid Primitive: Enter center point for pyramid.

3. Click in the drawing area to set the center.
A pyramid is created with its base centered at the chosen point. The pyramid extends 
along the z axis of the current work plane.

While the pyramid is still selected, change the X, Y, Z location of the base center point, 
the radius, height and number of sides, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the pyramid’s base center point and 
its Diameter, Height and Number of Sides.
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Pyramid 2 Point Option

This option draws a pyramid from the base center point and the 
height.

Using the 2 Point Pyramid option
1. Select the Pyramid Primitive tool.

2. Select the Pyramid Two Point option in the Message Line. The Message Line 
reads: Pyramid Primitive: Enter start and end points for pyramid.

3. Click two points in the drawing area.
A pyramid is created whose height is equal to the distance between the two chosen 
points and whose top and bottom are centered on those points.

While the pyramid is still selected change the X, Y, Z location of the base center point, 
the radius, height and number of sides, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the pyramid’s base center point, the 
dX, dY and dZ characteristics for the distance and direction to the second point and the 
pyramid’s Diameter and Number of Sides.

Pyramid by Diagonals Option

This option draws a pyramid from the corner of the 
pyramid’s bounding box and the specified height.

Using the Pyramid By Diagonals Option
1. Select the Pyramid Primitive tool.

2. Select the Pyramid by Diagonals option in the Message Line. The Message Line 
reads: Pyramid Primitive: Enter start diagonal point. [Shift=Square]

3. Click two points in the drawing area to specify two diagonal corners of the pyramid 
base’s bounding box.
Hold down the SHIFT key to draw a square bounding box. 

4. The Message Line reads: Pyramid Primitive: Enter height. 
5. Drag to set the height of the pyramid.

Working in the top, front or side view, pick a point, and a pyramid is created with a 
height equal to that of the last drawn pyramid (or equal to one inch if this is the first 
drawn pyramid). Working in a 3D view it is possible to select the point to set the 
desired height.

While the pyramid is still selected change the X, Y, Z location of the pyramid’s base 
center point, the dX, dY, and dZ values for the distance and direction to the second point 
and the pyramid’s height, if desired. Press ENTER (Windows) or RETURN (Macintosh) 
to accept the new values.
The Status Line contains the X, Y and Z values for the pyramid’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point and the 
pyramid’s Height and Number of Sides.
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Geometric Characteristics
A pyramid primitive is created by picking one point to specify the center point of the 
pyramid’s base, two points for the center point and height, or three points for the corners 
of the bounding box and the pyramid’s height. It is made up of the following 
characteristics: Height, Top Diameter, Diameter Ratio (D2/D1 or R2/R1), Bottom 
Diameter and Sides. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the pyramid and choose Window>Edit 
Objects or double-click the pyramid.

Ellipsoid Primitive Tool

An ellipsoid primitive is created from a center point, center point and radius, or two 
diagonal points on a bounding box.

Selecting the Ellipsoid Primitive tool a subpalette appears in the Message Line 
containing three options for creating ellipsoids: Ellipsoid 1 Point, Ellipsoid 2 Point and 
Ellipsoid by Diagonals.

Ellipsoid 1 Point Options

This option creates an ellipsoid using the specified center 
point and the X, Y and Z diameters entered in the Status 
Line. The Drafting Assistant displays a vertex notation at 
the center point. 

Using the Ellipsoid 1 Point Option
1. Select the Ellipsoid Primitive tool.

2. Select the Ellipsoid 1 Point option in the Message Line. The Message Line reads: 
Ellipsoid Primitive: Enter center point for ellipsoid.

3. Click a point in the drawing area.
The ellipsoid appears.

While the ellipsoid is still selected, it is possible to change the X, Y and Z location of the 
center point and the diameters. Press ENTER (Windows) or RETURN (Macintosh) to 
accept the new values.
The Status Line contains the X, Y and Z values for the center point and DiamX, DiamY 
and DiamZ for the ellipsoid diameters. 

Ellipsoid 2 Point Option

This creates an ellipsoid using the center point and the 
specified radius. The Drafting Assistant displays vertex notations at the center point and 
radius.
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Using the Ellipsoid 2 Point Option
1. Select the Ellipsoid Primitive tool.

2. Select the Ellipsoid 2 Point option in the Message Line. The Message Line reads: 
Ellipsoid Primitive: Enter center and radius point for ellipsoid.

3. Click the center point and radius point in the drawing area.
The ellipsoid appears.

While the ellipsoid is still selected, change the X, Y and Z location of the center point, 
the dX, dY and dZ values for the first radius and the two radiuses not specified in the 
operation (R1 and R2). Press ENTER (Windows) or RETURN (Macintosh) to accept the 
new values.
TheStatus Line contains the X, Y and Z values for the center point, the dX, dY, dZ, R1 
and R2 values.

Ellipsoid by Diagonals Option

This creates an ellipsoid based on two corners of the 
ellipsoid’s bounding box and the specified height. The 
Drafting Assistant displays vertex notations at the bounding 
box corners.

Using the Ellipsoid by Diagonals Option
1. Select the Ellipsoid Primitive tool.

2. Select the Ellipsoid by Diagonals option in the Message Line. The Message Line 
reads: Ellipsoid Primitive: Enter start diagonal point. [Shift = Square]

3. Click two points in the drawing area to specify two diagonal corners of the ellipsoid’s 
bounding box. 
Hold down the SHIFT key to draw a rectangular base. 

4. The Message Line reads: Ellipsoid Primitive: Enter height.
5. Drag to set the height of the ellipsoid.

The ellipsoid appears. Working in the top, front or side view, pick a point, and the 
program makes the ellipsoid’s height equal to that of the last drawn ellipsoid (or equal 
to one inch if this is the first drawn ellipsoid). Working in a 3D view it is possible to 
select the point to set the desired height.

While the ellipsoid is still selected, it is possible to change the X, Y, Z location of the 
ellipsoid’s base point, the dX, dY, and dZ values for the distance and direction to the 
second point, and the ellipsoid’s height. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.
The Status Line contains the X, Y and Z values for the cylinder’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point. 

Geometric Characteristics
An ellipsoid primitive is created by picking one point to specify the center of the 
primitive’s base, two points for the center point and height, or three points for the 
corners of the bounding box and the ellipsoid’s height. It is made up of the following 
characteristics: Center X, Y and Z and Diameter 1, Diameter 2 and Diameter 3.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the cylinder and choose Window>Edit Objects or double-
click on the cylinder.
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Solids from Curves Tools 

A profile is a closed section created from curves, polygons or surfaces (planar and non-
planar). Lathe, extrude, or sweep a profile to create a solid.

Creating Associative Profiles in Cobalt & Xenon
When making a solid from a profile, Cobalt and Xenon create a parent/child relationship 
between the profile (the parent) and the solid (the child). By changing the parent, Cobalt 
or Xenon automatically regenerates the child. For example, by lathing a rounded 
rectangle polygon, then changing the polygon's radius, the solid will update to the new 
size. The graphic here shows how to use the same 2D profile to create three different 
objects.

Tech Note: The ASIC kernel supports grouped profiles as well as grouped
curves for profiles.
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Creating Solids from Profiles
Cobalt, Xenon and Argon all support five tools for creating solids from profiles. For each 
tool enter values in the Status Line to define a solid, either before or after creating the 
solid. By entering the values after selecting the tool but before creating the solid, the first 
click in the drawing area automatically registers all Status Line values. When entering 
values in the selected Status Line data field after creating the solid and while the solid is 
still selected, pressing ENTER (Windows) or RETURN (Macintosh) updates the solid to 
reflect the new values.

Tech Note: These tools do not support using the Select Chain command to
select multiple grouped profiles, however, multiple grouped profiles can be
extruded at one time.

The topics explained in the chapter include the following:
• Lathed Solid Tool
• Extrude Solid Tool
• Swept Solid Tool
• Sweep 2 Rail (Paths) Solid
• Cutout Feature Tool
• Protruded Feature Tool
• Cutout and Protruded Curve Checks
• Skinned Solid Tool
• Solids from Profiles Curve Checks
• Pipe Solid Tool

Lathed Solid Tool

The Lathed Profile tool creates a solid by revolving a profile around an axis line. Lathe 
profiles are composed of individual, grouped or nested group curves. A profile that 
intersects itself cannot be lathed, as can happen with splines and polygons.

Using the Lathed Solid Tool
Before using this tool create a profile and a curve for lathe axis.
1. Click the Lathe Solid tool. The Message Line reads: Lathed Solid: Select objects to 

lathe. [Shift=Extend]

2. The Status Line contains the Degree and Draft Angle fields. Enter the desired val-
ues for the lathed solid. Tab between data fields.

When the draft angle is zero, the sides of the solid lie parallel to the profile normal. If 
the draft angle is positive, the sides will be forced outward from the normal. Negative 
draft angles force the sides inward toward the normal.

3. Pick a curve or curves to lathe. If selecting more than one curve, hold down the 
SHIFT key before selecting the first curve. 
The curves making up the profile must be closed. If they are not, two warning 
messages appear. The first one says, "Gaps detected in profile. Would you like to 
examine gaps?"
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Click No to ignore the gaps 
and continue.
Click Yes, and another 
message appears: "Gaps in 
profile are shown with red 
indicators. Use Undo to 
remove indicators. Hint: 
gaps can also be caused by 
duplicate or overlapping 
geometry in the profile."

Click OK to remove the message and view the 
profile with red Xs where gaps are detected. 
After noting the gaps, use Edit>Undo to clear 
the indicators or drag a selection box around 
them and press Delete. The indicators are 
created as geometric points, adding geometry to 
the drawing.
The Message Line now reads: Lathed Solid: 
Pick line for lathe axis. [Shift=Extend] 

4. Pick the line around which to rotate the curves 
and make the solid object.
Cobalt, Xenon or Argon determines the direction of revolution from the direction in 
which the line was drawn. The left graphic shows a view of a profile and a line drawn 
in the direction of the arrow. The right graphic shows the profile lathed 90°.

After clicking the line, the object is lathed.
While the object is still selected it is possible to edit the number of degrees in the 
revolution angle and the draft angle for the entire solid. Enter the new values and press 
ENTER (Windows) or RETURN (Macintosh) and the solid updates.
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Geometric Characteristics
A lathed profile solid is created by picking one or more curves from which to construct 
the solid and a line about which to rotate the curves. The lathed solids is made up of the 
following characteristics: Lathe Angle and Draft Angle. This information is listed in the 
Edit Objects dialog box under the Geometry tab. To display the dialog box, select the 
lathed solid and choose Window>Edit Objects or double-click the lathed solid.

Extrude Solid Tool

The Extrude Solid tool extends the selected profile along a vector. Extruded profiles are 
composed of lines, circles, ellipses, closed splines, polygons, grouped curves (including 
nested groups) and surfaces. 

Be careful when selecting circles for extrusion. If one of them is actually a sphere, the 
following error message appears:

This tool supports extruding a non-planar surface. 

The Extrude Solid tool uses the plane of the selected profile for the extrusion rather 
than the work plane normal, providing greater flexibility.



Extrude Solid Tool

24-5

In the Message Line there are five extrusion options:

The following are examples of each type of extrusion:
Extrude by Distance

Extrude by Vector

Distance Extrudes a specified distance normal to the plane of the profile. 
The distance can be positive or negative.

Vector Extrudes a profile along a vector whose distance is defined by 
the user supplied points.

Mid Plane Extrudes a profile in both directions using the plane of the 
profile.

To Entity Extrudes along a vector terminating at a surface or solid. The 
terminating body is not unioned with the extruded body.

Thin Extrudes an open or closed profile by a vector and thickness.
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Extrude by Mid Plane

Extrude to Entity

Thin Extrude

Note: The Thin Extrude tool has a toggle key that changes the location of the extrude. 
Use the CRTL key (Windows) or the OPTION key (Macintosh) to toggle the extrusion 
between the right side, left side or offset (mid plane) directions. Examples of the toggle 
directions are below.

Offset/Mid Plane Left Side ExtrudeRight Side Extrude
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Access these toggle directions in the 
Edit Objects dialog box. It is necessary, 
however, to access the Edit Objects 
box through the Design Explorer in 
order to change these directions.

Using the Extrude Solid Tool
Before using this tool create a profile to extrude.
1. Click the Extrude Profile tool. The Message Line reads: Extrude Solid: Select close 

objects to extrude by vector. [Shift=Extend]

2. The Status Line contains the dX, dY and dZ values, the Distance of the extrusion 
vector and the Draft Angle. Enter the desired Distance and the Draft Angle for the 
extruded solid. Tab between data fields.

When the draft angle is zero, the sides of the solid lie parallel to the profile normal. If 
the draft angle is positive, the sides will be forced outward from the normal. Negative 
draft angles force the sides inward towards the normal.

3. Pick one or more curves to 
extrude. As the Message 
Line indicates, they must be 
closed. If they are not, two 
messages appear. The first 
one says, "Gaps detected in 
profile. Would you like to 
examine gaps?" Click No to 
ignore the gaps and con-
tinue.

Tech Note: Some draft angles and extrusion heights will cause the solid to
self-intersect. If this happens, reduce the draft angle or increase the
extrusion height.
When selecting multiple profiles if one of them is not planar, a warning will
appear. Correct this or an ACIS error will occur.

Click Yes, and another message appears: "Gaps in profile are shown with red 
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indicators. Use Undo to remove indicators. Hint: gaps can also be caused by duplicate 
or overlapping geometry in the profile."

Click OK to remove the message and view the profile with red Xs where gaps are 
detected. After noting the gaps, use Edit>Undo to clear the indicators or drag a 
selection box around them and press Delete. The indicators are created as geometric 
points, adding geometry to the drawing.
Cobalt, Xenon and Argon place markers at the gap 
locations so it is easy to find and close them.
The Message Line now reads: Extrude Solid: 
Specify two points for extrusion direction and 
length.

4. Pick two points on the screen. The extruded solid is 
created.
If the extrusion vector defined by its points travels in a positive direction, the extrusion 
lies along the profile's normal. If the extrusion vector is negative, the extrusion 
direction lies opposite the profile's normal.
The following error message appears if choosing points that are tangential to the 
profile:

While the object is still selected edit the dX, dY, and dZ values for the extrusion vector's 
distance and the draft angle for the entire solid. Enter the new values and press ENTER 
(Windows) or RETURN (Macintosh) and the solid updates.

Tech Note: Enter the extrusion distance for each new profile recreated even
if the distance is the same as the previous extrusion.

Geometric Characteristics
An extruded profile solid is created by picking one or more curves from which to 
construct the solid, and then picking two points to indicate the extrusion's distance and 
direction. It is made up of the following characteristics: Distance, Draft Angle, and the 
Direction of the vector (DX, DY and DZ). This information is listed in the Edit Objects 
dialog box under the Geometry tab. To display the dialog box, select the extruded solid 
and choose Window>Edit Objects or double-click the extruded solid.
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Swept Solid Tool

The Swept Solid tool creates a solid by 
sweeping the profile along a curve. Extruded 
profiles are composed of lines, circles, ellipses, 
closed splines, polygons, grouped curves, 
curves and surfaces (including nested groups).
Important: Be careful that there are no gaps or 
overlapping curves in the profile.
The Swept Solid tool has two pull down options 
in the Message Line. The first pull down controls the profile orientation as it is swept 
along the path. This pull down has three options:

The second pull down controls how the profile is terminated. This pull down has three 
options:

Note: Sweep Perpendicular was the default sweep behavior in some previous versions 
of Cobalt, Xenon, Argon and Vellum Solids.

Using the Swept Solid Tool
Before using this tool, create a profile and a curve for the sweep.
1. Click the Swept Solid tool. The Message Line reads: Swept Solid: Select closed 

profile to sweep. [Shift=Extend]

2. The Status Line contains the Twist Angle and Draft Angle data fields. Enter the twist 
angle through which the solid will twist from beginning to end, and a draft angle, if 
desired.

Sweep In Place The profile is not translated or aligned to the path.

Sweep Perpendicular The profile is translated and aligned perpendicular to the path.

Sweep Rigid The profile orientation is maintained regardless of path 
tangency.

Curve Extents The profile is swept across the entire curve extents.

To Body The profile is terminated at a surface or solid.

Between Points The user specifies two points on the path.
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3. Pick one or more curves for 
the profile. As the Message 
Line indicates, they must be 
closed. If they are not, two 
messages appear. The first 
one says, "Gaps detected in 
profile. Would you like to 
examine gaps?" Click No to 
ignore the gaps and con-
tinue.
Click Yes, and another message appears: "Gaps in profile are shown with red 
indicators. Use Undo to remove indicators. Hint: gaps can also be caused by duplicate 
or overlapping geometry in the profile."

Click OK to remove the message and view the profile with red Xs where gaps are 
detected. After noting the gaps, use Edit>Undo to clear the indicators or drag a 
selection box around them and press Delete. The indicators are created as geometric 
points, adding geometry to the drawing. 
Cobalt, Xenon and Argon place markers at the 
gap locations so it is easy to find and close 
them.
The Message Line now reads: Swept Solid: 
Enter location for sweep profile origin. 

4. Pick the point on the screen where the sweep 
will begin.
The Message Line now reads: Swept Solid: Pick curve(s) for sweep path. 
[Shift=Extend]

5. Pick the curve or curves along which to sweep the profile.
The swept solid is created.

While the object is still selected edit the twist and draft angles. Enter the new values and 
press ENTER (Windows) or RETURN (Macintosh) and the solid is adjusted.

Geometric Characteristics
A swept profile solid is created by picking one or more curves from which to construct 
the solid, picking the point where the sweep will start, and then picking the curve along 
which the profile will sweep. It has two characteristics, Twist Angle and Draft Angle. 
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the swept solid once and choose Window>Edit Objects or 
double-click the swept solid.



Sweep 2 Rail (Paths) Solid

24-11

Sweep 2 Rail (Paths) Solid 

The Sweep 2 Rail Solid tool creates a solid by sweeping the profile along two curves. 
Extruded profiles are composed of lines, circles, ellipses, closed splines, polygons, 
grouped curves (including nested groups) and surfaces.
Important: Be careful that there are no gaps or overlapping curves in the profile.

Using the Sweep 2 Rail Solid Tool
Before using this tool, create a profile and a curve for the sweep.
1. Select the Sweep 2 Rail Solid tool. The Message Line reads: Sweep 2 Rail Solid: 

Pick curves or group to sweep. [Ctrl = Maintain Height] [Shift = Extend]

2. Pick the curves or group that defines the profile to sweep.
3. Choose the first rail that the profile will be swept along.
4. Choose the second rail that the profile will be swept along.
There are not status line entries for this tool.

Geometric Characteristics
A swept two rail profile solid is created by picking a closed profile then picking the two 
rails (curve or group of curves) along which the profile will be swept. There are only two 
tabs in the Edit Objects dialog box for this tool: Display and Attributes.

Cutout Feature Tool

This tool subtracts material from a solid. The cutout is formed from a 2D profile. This 
profile is located on or in the solid and composed of grouped curves. Specify a Draft 
Angle in the Status Line.
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Using the Cutout Feature Tool
1. Create a 2D profile with a curve or polygon tool and place it on or in the solid where 

the cutout will begin.

2. Select the Cutout Feature 
tool. The Message Line reads: 
Cutout Feature: Pick solid for 
cutout.

3. Select the solid to be cut. The Message Line now reads: Cutout Feature: Pick 
closed curves or polygon for cutting. [Shift=Extend]

4. Select the profile previously created.
5. Specify two points to indicate the direction and length of the cutout.
While the solid is still selected, change the distance, draft angle and direction of the 
cutout in the Status Line. Type the desired values in the data fields and press ENTER 
(Windows) or RETURN (Macintosh).
The Status Line contains the extrusion dX, dY and dZ values, the extrusion Distance 
and the Draft Angle.

Geometric Characteristics
A cutout is created by selecting a profile, the solid through which to cut and the distance 
and direction of the cut. It is made up of these characteristics according to Edit Objects: 
Distance, Draft Angle and Direction (dX, dY, dZ values). To modify the hole 
characteristics, select the hole using the Design Explorer and choose Window>Edit 
Objects or double-click on the cutout name. 

Protruded Feature Tool

This tool adds a piece to an existing solid. The protrusion is formed from a 2D profile. 
The profile does not need to be attached to the original solid and can be grouped 
curves.

Termination Types
The Message Line contains a pull-down menu to choose 
where the protrusion will end. There are two options: 
Vector and To Face.

Vector Defined by two chosen points, the vector determines the length 
and direction of the protrusion.

To Face This option extends the protrusion to a face on the solid.
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Using the Protruded Feature Tool - Vector Option
1. Create a 2D profile where the protrusion will begin.

2. Select the Protruded Feature 
tool. The Message Line reads: 
Protruded Feature: Pick solid 
for protrusion.

3. Select the Vector Termination Type from the pull-down menu in the Message Line. 
4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or 

polygon for adding. [Shift=Extend]
5. Select the profile previously created.
6. Specify two points for protrusion direction and length.
While the solid is still selected, change the direction and distance of the protrusion and 
the draft angle in the Status Line. Type the desired values in the data fields and press 
ENTER (Windows) or RETURN (Macintosh).

Using the Protruded Feature Tool - Face Option
1. Create a 2D profile where the protrusion will begin. (It need not be on the solid.)

2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: 
Pick solid for protrusion.

3. Select the To Face Termination Type from the pull-down menu in the Message Line.
4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or 

polygon for adding. [Shift=Extend]
5. Select the profile previously created.
6. Select the face on the solid where the protrusion will end. 
7. Specify two points for the protrusion direction. By specifying the direction, not the 

length, it is not necessary to reference the curve or the solid.
While the solid is still selected, change the direction and distance of the protrusion and 
the draft angle in the Status Line. Type the desired values in the data fields and press 
ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the protrusion dX, dY and dZ values, the protrusion's Distance 
and Draft Angle.

Geometric Characteristics
A protrusion is created by selecting a profile, the solid from which to extend the profile, 
and the distance and direction of the protrusion. It is made up of these characteristics 
according to Edit Objects: Distance, Draft Angle and Direction (dX, dY, dZ values). It 
also contains the Offset Both Directions check box. To modify the protrusion 
characteristics, select the protrusion using the Design Explorer and choose 
Window>Edit Objects or double-click on the protrusion name. 

Cutout and Protruded Curve Checks
To assist in performing cutout and protrude operations, Cobalt, Xenon and Argon 
provide two curve checks: gaps and planar.

Curve Gap Check
The software provides functionality to assist in finding gaps in extruded profiles and 
fixing them. If gaps are detected, two warning messages appear. 
The first one says, "Gaps detected in profile. Would you like to examine gaps?" 
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Click No to ignore the gaps and 
continue.
Click Yes, and another message 
appears: "Gaps in profile are 
shown with red indicators. Use 
Undo to remove indicators. Hint: 
gaps can also be caused by 
duplicate or overlapping 
geometry in the profile."

Click OK to remove the message and view the 
profile with red Xs where gaps are detected. After 
noting the gaps, use Edit>Undo to clear the 
indicators or drag a selection box around them and 
press Delete. The indicators are created as 
geometric points, adding geometry to the drawing. 

Planar Curves Check
The planar check warns if the selected curves for 
the cutout or protrusion are not planar.

Skinned Solid Tool

The Skinned Solid tool creates a solid from a collection of closed profiles. Create skin 
solids using profiles composed of individual curves (such as circles or ellipses) or 
grouped curves. A profile composed of individual curves does not have to be grouped 
for use with this tool.
There are two options in the Message Line: Basic Skinned Solid and Skinned Solid 
with Guide Curves.
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The Advanced Skin Options dialog box provides additional control of the appearance of 
skinned objects. To activate the box tap the CTRL key (Windows) or Option key 
(Macintosh). .

It contains the following options:

Close Last Section 
with First

Constructs a body closed in one direction (v direction). The 
default is an open (not closed) body. The surface is continuous 
at each profile.  If a set of closed profiles is provided, the face 
normals of the skin or loft body point outside, away from the 
body material. When a set of open profiles is provided, the 
surface normals of the skin surface are oriented along the 
surface normals and no attempt is made to change the surface 
normal orientation.  When using this option profiles are not to 
be provided in the same position.

Simplify Surface Simplifies the created surface to a conical surface, if 
applicable. If all of the cross sections lie on a conical surface 
(plane, cylinder, cone, sphere or torus), the conical surface is 
created instead. The value of 0.000001 is used to determine 
whether or not the cross section lies on an analytical surface 
(planar, conical, spherical or toroidal). The default is not 
simplified.

Auto-Align Sections Allows the skinning algorithm to align the direction of the 
curves  in the selection list.  Closed loops of wires can also be 
aligned. The default is aligned.

Arc Length 
Parameterization

Specifies the arc length or isoparametric parameterization of 
the skinning  surfaces. In isoparametric parameterization the 
surface parameter in the v direction follows the cross section 
curves. In arc length parameterization the surface parameter 
follows lines of constant length. The default is arc length 
parameterization.

Minimize Twist Minimizes the twist of the surface produced. Twist minimization 
aligns closed curves such that the start of the second curve is 
aligned to the start of the first curve. Even if a body’s shape is 
unaffected by twisting, a surface with a twist could produce 
unexpected results when faceting and rendering.  By default, 
twist minimization is on. Twist minimization is also an involved 
calculation that may not be carried out.
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Basic Skinned Solid 
Option

This option creates a skinned 
solid between two or more 
sections. The solid edges are 
defined by the limits of the 
selected curves within each 
section. The figure here shows a 
skinned solid created from three 
sections.

Using the Basic Skinned Solid Option
1. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed 

curves or polygons for solid from sections. [Shift = Extend]

2. Select the Basic Skinned Solid option in the Message Line.
3. Hold down the SHIFT key and select the closed curves.

The solid is created.
There are no entries in the Status Line.

Perpendicular Skin Specifies the direction of the take–off vector, perpendicular to 
the edge. The take–off vector is a tangent vector going out of 
the starting edge or surface and into the skinned surface. The 
default is in the loft direction because a perpendicular take–off 
vector can cause self–intersections to the surface.

Draft Angle Provides the ability to control the take–off vectors of the two 
outer skinning profiles. The “draft” angle is defined as an angle 
off the plane of the wire at every point along the skinning 
profile. In addition to specifying the angle itself, it is also 
possible to supply a magnitude for the take–off vector.  The 
draft angle and magnitude is constant for the entire profile. 
However, different draft angles may be applied to the two outer 
profiles. In addition skinning with draft angles supports open 
and closed profiles and skinning to a point. When skinning to a 
point the algorithm constructs its own normal vector. The outer 
profiles must be planar when not degenerate.  Use the Edit 
Object dialog box to access the skin magnitude.
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Skinned Solid with Guide Curves Option

This option creates a skinned 
solid between two or more 
sections using additional curves 
as guides to define the skin. 
Guide curves provide control over 
the skinned solid. Use one or 
more sets of guide curves to 
influence the solid. In the graphic 
the circles are skinned using the 
spline as a guide.

Guide Curve Rules
• Curves can go in any direction but the skin behaves better if the directions are 

consistent.
• Curves cannot loop and must be “well-behaved.” 
• The curves must connect with each profile used for the solid creation.

Using the Skinned Solid with Guide Curves Option
1. Create the section curves and guide curve.

2. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed 
curves or polygons for solid from sections. [Shift = Extend]

3. Select the Skinned Solid with Guide Curves options in the Message Line.
4. Hold down the SHIFT key and select the closed curves for all of the sections.

Release the SHIFT key and the Message Line now reads: Skinned Solid: Pick guide 
path for skinned solid. [Shift = Extend]

5. Select the guide curves.
The solid is created.

There are no entries in the Status Line.

Geometric Characteristics
A skinned solid object is a solid created from sections and is made up of the same 
characteristics as any solid object.

Solids from Profiles Curve Checks
In order to create objects using the Lathed Solid, Extruded Solid and Swept Solid 
tools, the profiles must be closed and planar.

Closed Curves Check
The Closed Curves Check warns 
if the profile contains gaps. If 
gaps are detected, two warning 
messages appear. The first one 
says, "Gaps detected in profile. 
Would you like to examine 
gaps?" 
Click No to ignore the gaps and 
continue 
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Click Yes, and another message appears: "Gaps in profile are shown with red indicators. 
Use Undo to remove indicators. Hint: gaps can also be caused by duplicate or 
overlapping geometry in the profile."

Click OK to remove the message and view the 
profile with red Xs where gaps are detected. After 
noting the gaps, use Edit>Undo to clear the 
indicators or drag a selection box around them 
and press Delete. The indicators are created as 
geometric points, adding geometry to the 
drawing.

Pipe Solid Tool

The Pipe Solid tool provides a quick and easy way to create pipes and tubes. Select a 
curve for the pipe's center line and specify the pipe's inner and outer diameter values. 
Create a pipe by selecting curves connected end to end. Create one pipe at a time with 
this tool.
When making a pipe solid, the program creates an intelligent link between the solid and 
its parent center line. When moving or modifying the center line, the pipe updates 
automatically. A pipe with an Inner Diameter of zero is a solid cylinder.

This tool does not support grouped curves for creating a pipe solid.

Using the Pipe Solid Tool
Before using this tool create a curve for the pipe.
1. Click the Pipe Solid tool. The Message Line reads: Pipe Solid: Select curve for pipe 

path. [Shift=Extend]

The Status Line contains the Outside Diameter and Inside Diameter data fields.

2. Enter values in the Status Line data fields. 
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An Inside Diameter of zero creates a solid cylinder. Tab between the fields.
3. Select the curve. To select more than one curve, hold down the SHIFT key before 

selecting the first curve.
A pipe is drawn.

While the object is still selected edit the Outside Diameter and the Inside Diameter. 
Enter the new values and press ENTER (Windows) or RETURN (Macintosh) and the 
solid is adjusted.

Geometric Characteristics
A pipe solid is created by selecting one or more curves and entering specifying the inner 
and outer diameters. A pipe solid is made up of the following characteristics: Outer 
Diameter, Inner Diameter and Wall Thickness. This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the 
extruded solid and choose Window>Edit Objects or double-click the pipe.
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Solid Feature Tools 

After creating a solid model from a primitive or a profile, use any of the feature tools to 
modify it. These tools cannot be used on grouped objects.
Values for each tool can be entered in the Status Line either before or after creating the 
feature. When entering the values after selecting the tool but before creating the feature, 
the first click in the drawing area automatically registers all Status Line values. If values 
are entered after creating the feature and while it is still selected, pressing ENTER 
(Windows) or RETURN (Macintosh) updates the feature to reflect the new values.
Many of the tools use a two step process. The first step after choosing the tool may be 
to select one or more objects. The second step is to perform the editing operation. Once 
the first step is completed (which may involve holding down the SHIFT key to select 
multiple objects), other objects cannot be selected to include in the same operation. To 
select additional objects reset the tool and start again.
After adding features to the solid, they can be modified by selecting them in the Design 
Explorer and choosing Window>Edit Objects or double-clicking on their names in the 
Design Explorer (Cobalt and Xenon only).
All features are associative. Any modifications made to the parent will automatically alter 
all child objects that reference it (Cobalt and Xenon only).
The topics explained here include:
• Blend Tools
• Chamfer Edge Tools
• Hole Feature Tools
• Boss Feature Tool
• Shell Solid Tool
• Bend Tool
• Twist Solid Tool
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Blend Tools

The Blend tools create fillets or rounds along the edge of a solid. When selecting the 
Blend tool, a subpalette appears in the Message Line containing two subtools for 
creating blends: Constant Blend and Variable Blend.

Each of these subtools includes a 
pull-down menu containing options 
for creating that type of blend. 
These options include for the 
Constant Blend tool: 
• Radial Blend
• Elliptical Blend
• Vertex Blend
For the Variable Blend tool they are: 
• Linear Blend
• By Position Blend
• Fixed Width Blend
• Hold Line Blend
Many of these options also have 
advanced capabilities that are accessed 
by tapping the CTRL (Windows) or 
OPTION (Mac) key. These advanced 
settings are outlined next.

Tech Note: The Blend tools perform a similar operation on solids to what
the fillet tool performs on a wireframe.
In the solids world, blend refers to both filleting and rounding. A filleting
operation adds material to a concave intersection. A rounding operation
removes material from a convex intersection.
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Advanced Blend Capabilities
The Advanced Blend Options dialog box contains the following:

Automatic Chain-
select of Shared 
Edges

Checking this box blends all edges that share a tangent with 
the selected edges. This is the default setting. Without this 
checked only the selected edges blend. The left graphic shows 
three edges blended with the Constant Radial Blend tool with 
this option selected. The right graphic shows two edges 
blended with the 

Feature Interaction 
(Slower)

Checking this box applies a blend that intersects a cutout or 
protrusion. Without this checked the feature may be deleted. 
With this checked the cutout is taken into account. The 
graphics here illustrate this. The left graphic is the original part 
with a hole cutout to half the part’s depth. The middle graphic is 
the blended part without this option selected. The right graphic 
is the blended part with the option selected.

The same thing occurs with a protrusion as shown below. As 
before, the left graphic is the original part, the middle graphic is 
the part without the option selected, and the right graphic is the 
part with the option selected.

Using this option results in a longer blending time.

Specify Cross 
Section Orientation

Checking this box specifies the orientation of the cross-section 
for the blend. This is especially valuable for blending an edge 
between faces containing a draft and to maintain the arc. See 
the next section for instructions on using this option.
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If the model contains a problem that prevents a successful blending operation, an ACIS 
Error dialog box appears highlighting the location of the problem.

Specifying a Cross Section Orientation for a Blend
By default, this Designer Elements program uses the selected edge to define the 
orientation of the cross-section resulting in an arc shape for the blend. However, when 
applying a blend to an object with a draft or taper, the cross-section of the resulting 
blend is elliptical because the blended edge is not perpendicular to the intersecting 
faces. To maintain the arc shape for the cross-section, use the Specify Cross Section 
Orientation option in the Advanced Blend Options dialog box. 
The graphic below shows a tapered object (tapered on the left and front sides) with a 
cross-section blend on the left and a standard blend on the right. By holding down the 
right mouse button (Windows) or CONTROL and the mouse button (Macintosh), the 
object shape is verified. (In the case of the cross-section blend an acurve object is 
listed. Use one of the Arc tools to trace the shape and verify that the blend shape is an 
arc.)

The graphic to the right is a top view of a 
similar shape and provides the 
measurements for the blends.
Before using this option, create a curve 
along the z axis for specifying the cross-
section orientation.
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Using the Cross Section Orientation Option
Although the example here uses the Radial option of the Constant Blend tool, this 
option is also available for Constant Elliptical Blends, Variable Linear Blends, Variable 
By Position Blends, Variable Fixed Width Blends and Variable Hold Line Blends.
1. Create a curve along the z-axis.

2. Select the Blend tool.

3. In the Message Line select the Constant Blend tool and the Radial option for the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. 
[Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]

4. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced Blend 
Options dialog box.

5. Select the Specify Cross Section Orientation option and click OK to close the dialog 
box.

6. Select the edge(s) for the blend.
The Message Line now reads: Blend Solid: Pick curve to define cross section 
orientation.

7. Select the curve.
The blend is created.

Constant Blend Tool

When selecting this tool, its option pull-down menu 
appears.

There are three Constant Blend options: Radial, Elliptical and Vertex Blend.
Important: (Windows users) When a Constant Blend option uses the CTRL and SHIFT 
keys to perform specific operations for the tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when blending.

Using the Radial Option
This option adds a blend with a constant radius along the selected edges and with a 
radius specified in the Status Line.

Tip: When having difficulty creating a radial blend, try creating a variable
linear blend using the same radius for the beginning and the end. ACIS uses
a different algorithm for linear blends.

By selecting three or more edges, a smooth vertex blend or a setback blend can be 
created. A setback is the distance that a blend extends back along the object edge from 
the vertex of the intersecting edges. A spherical corner results at the intersection of the 
three edges. The left graphic below shows a three-edge blend with no setback; the 
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middle graphic shows the same object with a setback and the right graphic is a setback 
illustration.

1. Select the Blend tool.

2. In the Message Line select the Constant Blend subtool and the Radial option from 
the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to 
blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
Set the advanced blend options by pressing CTRL (Windows) or OPTION Macintosh), 
if desired.

3. To create a setback, enter the value in the Status Line data field.
4. Select the edge(s) and/or face(s) for the blend.
While the blend is still selected, the radius of the blend can be changed in the Status 
Line. Type a new value and press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the Radius and Setback for the blend.

Geometric Characteristics
A constant radial blend is created by choosing a solid edge and specifying a radius and 
setback, if desired. It is made up of these characteristics according to Edit Objects: 
Setback, Radius and a list of the edges blended with their radii. 
The blend can be selected using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. The changes to the settings can be made on the 
Display and Attribute pages. See Design Explorer.

Using the Elliptical Option
This option adds a blend with a constant elliptical radius along the edges, based on the 
radii specified in the Status Line. When using this option the automatic chain select of 
Shared Edges feature does not function. Either select all intersecting edges before 
blending or blend each edge separately. The left graphic below shows a basic elliptical 
blend. The middle graphic shows an elliptical blend with a mitered edge. The right 
graphic illustrates the radius variables.
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1. Select the Blend tool.

2. In the Message Line select the Constant Blend tool and the Elliptical option from 
the pull-down menu. The Message Line reads: Elliptical Blend: Pick edges to blend, 
[Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
Set the advanced blend options by tapping CTRL (Windows) or OPTION (Macintosh), 
if desired.

3. Enter radius values for the ellipse, R1 and R2, in the Status Line data field. R1 is the 
major axis radius and R2 is the minor axis radius.

4. Select the edge(s) for the blend.
While the blend is still selected, the two radii of the blend can be changed in the Status 
Line to change the elliptical ration. Type a new value and press ENTER (Windows) or 
RETURN (Macintosh).
The Status Line contains the major and minor axis radii for the blend.

Geometric Characteristics
A constant elliptical blend is created by choosing a solid edge and specifying the radii for 
the major and minor axis of the ellipse. It is made up of these characteristics according 
to Edit Objects: R1, R2 and a list of the edges blended with their radii. 
The blend can be selected using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. Changes to the settings can be made on the 
Display and Attribute pages. See “Design Explorer” on page 34.

Using the Vertex Blend Option
This option adds a vertex blend at the intersection of three or more edges based on the 
radius specified in the Status Line. The left graphic shows an example of a vertex blend. 
The right graphic illustrates the radius variables.

1. Select the Blend tool.

2. In the Message Line select the Constant Blend tool and the Vertex Blend option 
from the pull-down menu. The Message Line reads: Vertex Fillet: Select vertex to 
blend. [SHIFT = Extend]

3. Enter a radius in the Status Line data field.
4. Select the vertex for the blend.
While the blend is still selected the radius of the blend can be changed in the Status 
Line. Type a new value and press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the radius (R) for the blend.
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Geometric Characteristics
A constant vertex blend is created by choosing three or more solid edges and specifying 
a radius. It is made up of one characteristic according to Edit Objects: Radius.
The blend can be selected using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. Changes to the settings are made on the Display 
and Attribute pages. See “Design Explorer” on page 34.

Additional Examples
The Constant Blend tool creates a variety of blends. Here are some examples of 
advanced blends and the steps to create them.

Mitered Blend
A mitered blend is created by turning off the Automatic 
Chain-select of Shared Edges option in the Advanced Blend 
Options dialog box and selecting each edge individually. A 
mitered corner results at the intersection of the three edges.

Creating a Mitered Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool 
and the Radial option from the pull-down menu. The Message Line reads: Radial 
Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced 
(Macintosh), Shift=Extend]

3. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced Blend 
Options dialog box.

4. Turn off the Automatic Chain-select of Shared Edges option and click OK.
5. Enter the desired radius in the Status Line.
6. Select each of the edges individually to create a mitered intersection. (If the SHIFT 

key is held down, a smooth vertex blend will be created rather than a mitered 
blend.)
To have a different radius for each edge blend, enter the new value in the Radius data 
field before selecting the edge.
A mitered blend is created.

Multi-radius Blend with and without a Setback
A multi-radius blend is created after applying a constant radial blend to an object and 
then changing the radius of each edge through the Edit Objects dialog box. A setback to 
this blend can be added through Edit Objects or when creating the radial blend initially. 
The left graphic shows a multi-radius blend. The middle graphic shows the same object 
with a setback. The right graphic shows a multi-radius, multi-edge blend with a setback.

1. Select the object.

2. Choose Window>Design Explorer. 
3. Expand the history tree to display the fillet blend. (Cobalt and Xenon only)
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4. Double-click on the fillet blend to display the Edit Objects dialog box.
5. Select the edge with the radius to change. The radius value appears in the data 

field. Enter a new radius.
Change the other radii, if desired.

6. Click Apply to accept the changes and the geometry updates.
Two-edge or One-edge Vertex Blend
Create two- and one-edge vertex blends by first creating a constant radial blend. Using 
the Design Explorer, double-click on the blend to display the Edit Objects dialog box. For 
a two-edge vertex blend change the radius of one-edge to zero. For a one-edge vertex 
blend, change two radii to zero. The left graphic below shows the two-edge vertex blend 
and the right graphic a one-edge vertex blend.

Disjoint Blend
A disjoint blend is a blend between faces that do not touch or are on two separate 
bodies. To create this blend in the past it was necessary to perform a boolean operation. 
A disjoint blend is created by specifying a radius for the blend, selecting the two faces or 
objects and specifying a blend help position.
The help position tells the program where to begin 
calculating the blend. Visualize a sphere with this help 
position at its center. This sphere rolls along the virtual 
blend between the two bodies as this Designer Elements 
program calculates the actual blend. The sphere 
diameter equals twice the blend radius. The illustration 
here shows the help sphere and the help position for two 
disjoint bodies and applies to all disjoint blend 
operations.
The graphics below are two examples of objects before 
and after a disjoint blend is created.

Tips:
• If a help position does not create the blend try another location in the same quadrant.
• When creating a blend between objects of different colors, the color of the first object 

selected becomes the color of the new blended object.
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Creating a Disjoint Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool and the Radial option from the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. 
[Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]

3. Hold the SHIFT key down and select the objects. The Message Line now reads: 
Constant Blend: Specify help position.

4. Click the help position location. (If the help position does not create the blend try 
another location in the same quadrant.)
A disjoint blend is created.

Disjoint Edge-to-face Blend
A disjoint edge-to-face blend is created by selecting the edge and face of an object. 
What makes this blend unique is that the Designer Elements program specifies a radius 
for the blend that is greater than the distance from the edge to the face. 
In the graphic here a one inch blend is applied using 
the inside top edge of the object and its inside bottom 
face. The user supplied help position is important in 
this blend. If the wrong location is chosen, the blend 
will not work. The one inch radius is larger than the 
distance from the edge to the face.

Disjoint Face-to-face Remote Blend 
A disjoint face-to-face remote blend is created when applying a blend to two faces that 
do not share the same edge. In graphic below, a face-to-face remote blend is applied to 
the top and right face separated by a chamfer. Below are the before (chamfered block) 
and after pictures (blended top and right face separated by the chamfer).
Before

After

Notice in the Design Explorer, shown above, that the fillet blend does not replace the 
chamfer but follows the chamfer operation in the history tree.
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Edge-to-face Roll Blend
An edge-to-face roll blend is created by specifying a 
radius, selecting an edge and face to blend and choosing 
a help position. The graphic to the right shows the 
original object used for this blend.
The left graphic below shows the edge to face roll blend 
in which the vertical edge and the inside bottom face are 
selected. Using the Drafting Assistant, the help position is 
located out from the shared edge/face corner vertex 
along the z axis. The right graphic shows the default blend if the vertical faces and 
inside bottom faces were selected.

Blend with Cutouts
A blend with cutouts is created by applying a blend to 
faces that contain cutouts using the Constant Blend tool. 
There are no special steps to create this blend.

Extrapolation Blend
An extrapolation blend is created when applying a constant radial blend to an edge with 
a radius that is larger than what the intersecting face will accommodate. The intersecting 
face extends to accept the blend. The left graphic below is the original object. The right 
graphic shows that the faces were extended to accommodate the blend.

Creating an Extrapolation Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool and the Radial option from the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. 
[Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]

3. Enter the radius in the Status Line.
4. Select the edge to blend.

The blend is created and the intersecting side extends as necessary.
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Variable Blend Tool
When selecting this tool its option 
pull-down menu appears.
There are five variable blend options: 
Linear, By Position, Radius Curve, 
Fixed Width and Hold Line.
Important: (Windows users) When a 
Variable Blend option uses the 
CTRL and SHIFT keys to perform specific operations for the tool, the Stroke Zoom 
function (CTRL+SHIFT keys) is not available when blending.

Using the Linear Option
This option adds a blend with a tapered radius along the selected edges. Specify the 
beginning radius (R1) and the ending radius (R2) in the Status Line.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Linear option from the 
pull-down menu. The Message Line reads: Linear Blend: Pick edge to linearly 
blend. [Pick edge near R1]

3. Select the edge along which to make the blend. 
The solid edge closest to the point of selection becomes R1.

While the blend is still selected the radii (R1 and R2) can be changed in the Message 
Line. Type the new values and press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains R1 (beginning radius) and R2 (ending radius) for the linear 
blend.

Geometric Characteristics
A variable linear blend is created by choosing a solid edge and specifying a radius for 
the beginning and end of the blend. It is made up of these characteristics according to 
Edit Objects: Radius 1 and Radius 2. 
The blend can be selected using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. Changes to the settings can be made on the 
Display and Attribute pages. See Design Explorer.

Using the By Position Option
This option adds a blend with a varied radius along the selected 
edges. Specify the various radii in the Status Line.
1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the 
By Position option from the pull-down menu. The Message 

R1

R1

R2

R2



Blend Tools

25-13

Line reads: Position Blend: Pick edge(s) for variable radius blend. [End=ESC,Dbl 
Click] [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh)] [Shift=Extend].

3. Select the edge along which to make the blend. The Message Line reads: Position 
Blend: Specify location for radius value [End=ESC, Dbl Click].

4. Enter a radius in the R field of the Status Line.
5. Specify the location(s) along the selected edge for the radius.

As a radius is applied to a location the value 
appears on the edge.

6. Enter a new radius in the R field.
7. Specify the location for this radius along the edge.

Continue following this procedure until all the desired 
radii have been entered. Double-click the last place 
radius point and the variable by position blend is 
created.

The Status Line contains the Radius for the blend.

Geometric Characteristics
A variable position blend is created by choosing a solid edge and various radii at 
different locations along the edge for the blend. It is made up of these characteristics 
according to Edit Objects: a list of the edges blended with their radii and Param points, 
Radius and Param value. Param is the percentage point location along the edge for the 
selected item in the list. When selecting one of the items in the list its Radius displays in 
the Radius data field and its percentage point location displays in the Param field.
Select the blend using the Design Explorer. Double-clicking on the item in the Design 
Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. Make changes to the settings using the Display 
and Attribute pages. “Design Explorer” on page 34.

Using the Radius Curve Option
This option adds a blend based on a specified radius curve. Before 
using this option, create an open curve in the positive xy quadrant. 
This curve cannot cross over itself or backtrack. A circle or a loop 
would not make acceptable curves. The graphic here is an example 
of an acceptable curve.
This curve defines the radius distribution. The start 
point of the curve represents the start point of the 
edge. The y value of the curve represents the 
radius. The x length of the curve is divided into 
percentages. The y value at a particular 
percentage point on the curve is mapped as the 
radius to the same percentage point along the 
selected solid edge.
One advantage of this tool is the ability 
to modify the blend by changing the 
curve. It is also possible to add or 
remove control points to the radius 
curve to change the blend. The blend is 
associative to the curve. Changing the 
curve, automatically changes the blend. 
Attempting to delete the curve, the 
following dialog box appears:
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Deleting the curve changes the object from a solid block to an ACIS solid.
1. Create the curve that will be referenced for the blend.

To ensure that the curve is in the positive xy quadrant, change the view to Top and 
draw the curve using the Axis as a reference.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Radius Curve option 
from the pull-down menu. The Message Line reads: Radius Curve Blend: Pick edge 
for variable radius blend.

3. Select the solid edge. The Message Line now reads: Radius Curve Blend: Pick 
radius curve (in positive xy plane).

4. Select the radius curve.
The blend is applied to the edge.
There are no Status Line entries.

Geometric Characteristics
A variable radius curve blend is created by choosing a solid edge and a curve in the 
positive xy quadrant to specify the radii along the edge. According to Edit Objects, a 
radius curve blend contains no unique geometric characteristics. Changes to the 
Display and Attribute settings cannot be made through the Edit Objects dialog box. The 
blend radius cannot be changed through the Edit Objects dialog box. It must be done 
using the original curve. Select the curve and change the x or y location in Edit Objects 
or drag the control point on the curve to the new positive x, or y location (The z location 
must remain at zero).

Using the Fixed Width Option
This option adds a blend with a fixed width along the selected edges adjusting the blend 
radius to maintain the width. This is important when placing a blend along the edge of 
two faces where the angle changes. Specify the width in the Status Line. In the graphic, 
the left boss has a constant radial blend with a .5 inch radius and the right graphic a 
fixed width blend with a .5 inch width.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Fixed Width option 
from the pull-down menu. The Message Line reads: Fixed Width Blend: Pick edges/
faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh)], 
[Shift=Extend]

3. Enter the fixed width for the blend in the Status Line.
4. Select the edge for the blend.

A fixed width blend is created.
The Status Line contains the width (W) of the blend.

Width

Width
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Geometric Characteristics
A variable fixed width blend is created by choosing a solid edge and specifying the blend 
width. It is made up of these characteristics according to Edit Objects: Radius and a list 
of edges blended with their associated width.
Select the blend using the Design Explorer. Double-clicking on the item in the Design 
Explorer or choosing Edit Objects command from the Design Explorer menu displays 
the Edit Objects dialog box. Make changes to the settings on the Display and Attribute 
pages. “Design Explorer” on page 34 for more information.

Using the Hold Line Option
This option adds a blend to the hold line curve specified, adjusting the blend radius as 
needed to fit the line.
Hold Line Rules:
• The hold line curve should be one curve (circle, ellipse or spline). If the curve is not 

closed, a linear blend is applied where there is no hold line using the open ends of the 
curve for the radius values.

• Although the hold line curve does not have to be on the plane of the surface, it should 
be close to it and in the same plane as the surface. Curves not on the surface are 
projected to the closest surface to calculate the blend.

• Grouped curves are not supported.
The left graphic shows a part with a spline on the slanted face. The right graphic shows 
the same part using the spline as the hold line for the blend.

1. Create a hold line curve.

2. Select the Blend tool.

3. In the Message Line, select the Variable Blend tool and the Hold Line option from 
the pull-down menu. The Message Line reads: Hold Line Blend: Pick edges/faces to 
blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh)], [Shift=Extend]

4. Select the edge for the blend. The Message Line now reads, Hold Line Blend: Pick 
curve for hold line. [Shift = Extend]

5. Select the hold line curve.
A hold line blend is created.
There are no Status Line entries.

Geometric Characteristics
A variable hold line blend is created by choosing a solid edge and a curve for the hold 
line. According to the Edit Objects, a hold line blend contains no unique geometric 
characteristics. Changes are made to the Display and Attribute settings through the Edit 
Objects dialog box.
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Chamfer Edge Tools

The Chamfer Edge tools create flat surfaces along a specified 
edge. The graphic here shows a chamfered solid along all four 
edges.
When the Chamfer Edge tool is selected, a subpalette 
appears in the Message Line containing two chamfer edge 
subtools: Constant Length and Variable Length.
Each of these tools includes a pull-
down menu containing options for 
creating that type of chamfer. For the 
Constant Length tool these include: 
• Constant Length Chamfer
• Two Lengths Chamfer
• Length Angle Chamfer
• Vertex Chamfer
For the Variable Length tool they are: 
• Variable Lengths Chamfer
• Four Lengths Chamfer
• Lengths Angles Chamfer
• By Position Chamfer
• Fixed Width Chamfer
Many of these options also have advanced capabilities that are accessed by tapping the 
CTRL (Windows) or OPTION (Mac) key. These advanced settings are outlined next.
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Advanced Chamfer Capabilities
The Advanced Chamfer Capabilities dialog box contains the following options:

Automatic Chain-
selectof Shared 
Edges

Checking this box chamfers all edges that share a tangent with 
the selected edges. This is the default setting. Without this 
checked only the selected edges chamfer. The left graphic 
shows three edges chamfered using the Constant Length 
Chamfer tool with the option selected. The right graphic shows 
two edges chamfered using the Constant Length Chamfer 
tool without the option selected.

Feature Interaction 
(Slower)

Checking this box applies a chamfer that intersects a cutout or 
protrusion. Without this checked the feature may be deleted. 
With it checked the cutout is taken into account. The graphics 
illustrate this. The left graphic is the original part with hole 
cutout to half the part’s depth. The middle graphic is the 
chamfered part without this option selected. The right graphic 
is the chamfered part with the option selected.

Without this checked for a protrusion the chamfer takes 
precedence over the protrusion. The left graphic below is the 
original part. The middle graphic is the part without the option 
selected. The right graphic is the part with the option selected.

Using this option results in a longer chamfering time.
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Constant Length Chamfer Tool

When this tool is selected, its option 
pull-down menu appears. 
There are four constant length 
options: Length, Two Lengths, 
Length Angle and Vertex Chamfer.

Using the Length Option
This option adds a 45° chamfer based on the specified length to edge distance along 
the selected edges or faces. The left graphic is an example of an object using this 
option. The middle graphic here shows a .5 inch chamfer with a vertex setback of 1.0. 
(Create this by selecting three or more edges with a setback at the corner vertex.) The 
right graphic illustrates the variables.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the 
Constant Length Chamfer tool and 
the Length option from the pull-down menu. The Message Line reads: Chamfer 
Edge: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = 
Advanced (Macintosh)] [Shift = Extend]

3. Enter a setback value in the Setback data field of the Status Line, if desired, for 
three or more intersecting edges.

4. Select the edges or faces of a part to chamfer. Use the Ambiguity box to specify the 
edge or a face if necessary.
The chamfer is created.

While the chamfer is still selected, it is possible to change L1 and the setback length in 
the Status Line or the Edit Objects dialog box. Type the desired values in the data field 
and press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains L1 and the Setback.

Geometric Characteristics
A constant length chamfer is created by choosing a solid edge or face and specifying 
the length to the edge. It is made up of two characteristic according to Edit Objects: 
Setback and Length. The setback is the distance from the shared vertex of three or 
more edges that the chamfer extends. It also includes an edge list displaying the edge 
name and its associate length. 

L1

L1
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Using the Two Lengths Option
Using this option adds a chamfer based on the specified length to edge distances along 
the selected edges or faces to create a constant length chamfer.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Chamfer tool and the Two 
Lengths option from the pull-down menu. The Message Line reads: Chamfer Edge: 
Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = 
Advanced (Macintosh)] [Shift = Extend]

3. Enter L1 and L2 values in the Status Line.
4. Select the edges or faces of a part to chamfer. Use the Ambiguity box to specify the 

edge or a face If necessary.
The chamfer is created.

While the chamfer is still selected it is possible to change the L1 and L2 values in the 
Status Line or the Edit Objects dialog box. Type the desired values in the data field and 
press ENTER (Windows) or RETURN (Macintosh).
Swap chamfer values by tapping the Ctrl (Windows) or Option (Mac) key. 
The Status Line contains L1 and L2.

Geometric Characteristics
A constant two length chamfer is created by choosing a solid edge or face and 
specifying the lengths to the edge. It is made up of two characteristics according to Edit 
Objects: Length 1 and Length 2. 

Using the Length and Angle Option
This option adds a chamfer at an angle and a constant length to the edge specified in 
the Status Line. The angle is measured from the tangent of the selected edge to the 
chamfered edge (see the right graphic).

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Chamfer tool and the Length and 
Angle option from the pull-down menu. The Message Line reads: Chamfer Length 
Angle: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = 
Advanced (Macintosh)] [Shift=Extend]

L1

L2
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3. Enter an L1 and angle in the Status Line data fields.
4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify 

the edge or a face when performing the operation.
While the chamfer is still selected it is possible to change the length and angle in the 
Status Line or Edit Objects dialog box as needed. Type the desired values in the data 
fields and press ENTER (Windows) or RETURN (Macintosh).
Swap chamfer values by tapping the CTRL (Windows) or OPTION (Mac) key. 
The Status Line contains L1 and the A chamfer angle data fields.

Geometric Characteristics
A constant length angle chamfer is created by choosing a solid edge or face and 
specifying an angle and length. It is made up of these characteristics according to Edit 
Objects: Setback and Angle. The setback is the distance from the shared vertex of three 
or more edges that the chamfer extends.

Using the Vertex Chamfer Option
This option adds a constant vertex chamfer to the intersection of three edges. The 
length is measured from the vertex to the edge as indicated in the right graphic below.

The faces next to the intersecting edges must be planar and 
have the same convexity or concavity. The graphic here shows 
convex and concave vertex chamfers.
1. Select the Chamfer Edge tool.

2. In the Message Line select the Constant Length Chamfer 
tool and the Vertex Chamfer option from the pull-down 
menu. The Message Line reads: Vertex Chamfer: Select 
vertex to chamfer. [SHIFT = Extend].

3. Enter an L1 value in the Status Line data field.
4. Select the vertex to chamfer. 
While the chamfer is still selected it is possible to change the length in the Status Line or 
Edit Objects dialog box. Type the desired value in the data field and press ENTER 
(Windows) or RETURN (Macintosh).
The Status Line contains L1 chamfer length.

Geometric Characteristics
A vertex corner chamfer is created by choosing a vertex and specifying a length. It is 
made up of one characteristic according to Edit Objects: Radius 1. 

Additional Examples
Here are a few chamfer variations using the constant chamfer tools.
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Multi-edge Chamfer with Mitered Corner
This chamfer is created using the Length option of the 
Constant Length Chamfer tool. In the Advanced Chamfer 
options dialog box turn off the Automatic Chain-select of 
Shared Edges option and then chamfer each edge separately.

Multi-edge Chamfer with Varied Lengths and Setback
This chamfer is created using the Length option of the 
Constant Length Chamfer tool. 
1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Cham-
fer tool and the Length option from the pull-down menu. 
The Message Line reads: Chamfer Edge: Pick solid edges/faces to chamfer. [Ctrl = 
Advanced (Windows) or Option = Advanced (Macintosh)] [Shift=Extend]

3. Enter a setback value in the Setback data field.
4. Hold down the SHIFT key and select the edges to chamfer them. 
5. Using the Design Explorer, double-

click on the chamfer to display the 
Edit Object dialog box.

6. In the edge list select an edge. It’s 
associated L1 value appears in the 
length data field.

7. Enter a new value in the field.
Change other values as desired.

8. Click apply and the chamfer 
updates.

Complex Chamfer
This Designer Elements program supports complex chamfering 
for intersecting objects with or without setbacks. The example 
here includes setbacks.

Variable Chamfer Edge Tool

When this tool is selected its pull-
down option menu appears.
There are five variable length options: 
Lengths, Four Lengths, Lengths 
Angles, By Position and Fixed 
Width.
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Using the Lengths Option
This option adds a chamfer tapered linearly along the edge from two specified setback 
lengths, L1 and L2.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the 
Variable Length Chamfer tool and 
the Lengths option from the pull-down menu. The Message Line reads: Linear 
Chamfer: Pick edges/faces to linearly chamfer. (Pick edge near L1) [Ctrl = 
Advanced (Windows) or Option = Advanced (Macintosh)].

3. Enter the L1 (the beginning setback length of the chamfer) and L2 (the ending set-
back length of the chamfer) values in the Status Line data fields.

4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify 
the edge or a face when performing the operation.

While the chamfer is still selected it is possible to change the setback lengths (L1 and 
L2) in the Status Line or Edit Objects dialog box. Type the desired values in the data 
fields and press ENTER (Windows) or RETURN (Macintosh).
Swap chamfer values by tapping the CTRL (Windows) or OPTION (Mac) key. 
The Status Line contains the chamfer setback lengths, L1 and L2.

Geometric Characteristics
A variable length or linear chamfer is created by choosing a solid edge and specifying a 
length for the beginning and end of the chamfer. It is made up of these characteristics 
according to Edit Objects: L1, L2 and a list of the edges chamfered with their 
corresponding lengths.

Using the Four Lengths Option
This option adds a chamfer tapered linearly along the edge using four specified setback 
lengths, L1, L2, L3 and L4.

1. Select the Chamfer Edge tool.

2. In the Message Line select the Variable Length Chamfer tool and the Four 
Lengths option from the pull-down menu. In the Message Line select the Linear 
Chamfer tool. The Message Line reads: Chamfer Length: Pick solid edges to cham-
fer. [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] [Shift=Extend]
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3. Enter the L1 and L2 values for the beginning setback lengths of the chamfer and L3 
and L4 values for the ending setback lengths of the chamfer in the Status Line data 
fields.

4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify 
the edge or a face when performing the operation.

While the chamfer is still selected it is possible to change the setback lengths in the 
Status Line or the Edit Objects dialog box. Type the desired values in the data fields and 
press ENTER (Windows) or RETURN (Macintosh).
Swap chamfer values by tapping the Ctrl (Windows) or Option (Mac) key. 
The Status Line contains the chamfer setback lengths, L1, L2, L3 and L4. 

Geometric Characteristics
A variable four lengths chamfer is created by choosing a solid edge and specifying a 
lengths for the beginning and end of the chamfer. It is made up of these characteristics 
according to Edit Objects: L1, L2, L3, L4 and a list of the edges chamfered with their 
corresponding lengths.

Using the Variable Lengths and Angles Option
This option adds a chamfer with the specified lengths and angles for the beginning and 
end of the chamfer along the selected edge. The angles are measured from the tangent 
of the selected edge to the chamfered edge (see the right graphic).

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Variable Length Chamfer tool and the Lengths and 
Angles option from the pull-down menu. The Message Line reads: Chamfer Length 
Angle: Pick solid edges/faces to chamfer [Ctrl = Advanced (Windows) or Option = 
Advanced (Macintosh)] [Shift=Extend].

3. Enter an L1 and A1 (angle) for the beginning of the chamfer and L2 and A2 (angle) 
for the end of the chamfer in the Status Line data fields.

4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify 
the edge or a face when performing the operation.

While the chamfer is still selected, it is possible to change the lengths and angles in the 
Status Line or the Edit Objects dialog box. Type the desired values in the data fields and 
press ENTER (Windows) or RETURN (Macintosh).
Swap chamfer values by tapping the Ctrl (Windows) or Option (Mac) key. 
The Status Line contains L1, A1, L2 and A2 data fields.

Geometric Characteristics
A variable length angle chamfer is created by choosing a solid edge and specifying the 
beginning and end chamfer angles and lengths. It is made up of these characteristics 
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according to Edit Objects: L1, Angle 1, L2, Angle 2 and a list of the edges chamfered 
with their corresponding lengths and angles.

Using the Variable By Position Option
This option adds a chamfer with a varied lengths along the edges selected. Specify the 
lengths in the Status Line. To create a degenerative chamfer with this option specify a 
zero length at both ends of the edge. The left graphic shows a varied length chamfer. 
The right graphic shows a degenerative chamfer.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Variable Length Chamfer tool and the By Position 
option from the pull-down menu. The Message Line reads: Position Chamfer: Pick 
edges for variable position chamfer. [End = ESC, Double Click] [Ctrl = Advanced 
(Windows) or Option = Advanced (Macintosh)] [Shift=Extend]

3. Select the edge along which to make the chamfer. The Message Line reads: Posi-
tion Chamfer: Specify location for length value [End=ESC, Dbl Click].

4. Enter a setback length in the Length field of the Status Line.
5. Specify the location(s) along the selected edge for the chamfer.

When specifying the location the length appears in red 
at that point and all additional locations. The values 
remain until the last chamfer point double-clicked and 
the chamfer is created. The graphic illustrates this.

6. Enter a new length in the Length field.
7. Specify the location for this length along the edge.

Continue following this procedure until all the desired 
lengths are entered. Double-click the last place 
chamfer point and the variable by position chamfer is 
created.

The Status Line contains the Length for the chamfer setback.

Geometric Characteristics
A variable by position chamfer is created by choosing a solid edge and various setback 
lengths at different locations along the edge for the chamfer. It is made up of these 
characteristics according to Edit Objects: a list of the edges chamfered with their widths 
and Param points, Width (which corresponds to the Status Line length) and Param 
value. Param is the percentage point location along the edge for the selected item in the 
list. When one of the items in the list is selected its Length displays in the Width data 
field and its percentage point location displays in the Param field.

Using the Fixed Width Option
This option adds a chamfer with a fixed width along the selected edges, adjusting the 
chamfer length to maintain the width. This is important when placing a chamfer along of 
the edge of two faces where the angle changes. Specify the width in the Status Line. 
The left graphic shows a sloped block with two bosses where the left boss has at 
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constant length chamfer and the right boss has a variable fixed width chamfer. The right 
graphic illustrates the fixed width characteristic.

1. Select the Chamfer Edge tool.

2. In the Message Line select the Variable Length Chamfer tool and the Fixed Width 
option from the pull-down menu. The Message Line reads: Fixed Width Chamfer: 
Pick edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced 
(Macintosh)] [Shift=Extend]

3. Enter a width in the W data field of the Status Line.
4. Pick the edge(s) for the chamfer.
While the chamfer is still selected it is possible to change the width in the Status Line or 
the Edit Objects dialog box. Type the desired values in the data fields and press ENTER 
(Windows) or RETURN (Macintosh).
The Status Line contains the width for the chamfer.

Geometric Characteristics
A variable fixed width chamfer is created by setting a chamfer width and selecting the 
edge for the chamfer. It is made up of these characteristics according to Edit Objects: 
Width and a list of the edges chamfered with their width. When one of the items in the 
list is selected its width displays in the Width data field.

Hole Feature Tools

The Hole Feature tools model bolt holes found frequently in mechanical design parts. 
These holes are predefined features that remove cylindrical shapes from objects. Holes 
can be placed through models, along face edges at corner vertices and on planar and 
non-planar faces. The graphic below is an example of a simple hole.

Holes are associative in Cobalt and Xenon. Modify them at any point in the design 
process.
When selecting the Hole Feature tools a subpalette appears containing three tools for 
creating holes: Simple, Counter Bore and Counter Sink.
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Through Types
The Message Line also contains a pull-down menu to 
choose a Through Type for the hole. There are four 
options: Depth, Through, First Blind and To Face.

Tech Note: To place a hole through an object that will intersect a blend, use
the Depth option rather than the To Face option. If To Face is used, when the
hole intersects the blend, a face change occurs and the hole ends.

Depth Extends the depth of the hole to the value specified in the 
Status Line.

Through Extends a hole through the selected solid.

First Blind Extends a hole to the first open face.

To Face Extends a hole to the selected face.
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Hole Direction
The Message Line contains a pull-down menu to specify 
a boss direction. There are five options: Normal, X-Axis, 
Y-Axis, Z-Axis and 2-Pts.

Simple Hole Tool

This tool creates straight, cylindrical holes through the 
selected solid. Specify the X, Y and Z center location, depth, 
diameter and draft angle of the hole in the Status Line.

Using the Simple Hole Tool

1. Select the Hole tool.

2. In the Message Line select the 
Simple Hole tool. The Message 
Line reads: Simple Hole: Pick solid face to place hole.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message line. 

4. Select the face where to locate the hole.
5. Select the location for the center of the hole.
6. If the 2-Pts direction is selected, click two points to specify the direction.

The hole is created.
While the solid is still selected, the hole depth can be changed in the Status Line. Type 
the desired value in the data field and press ENTER (Windows) or RETURN 
(Macintosh).
The Status Line contains the hole's X, Y and Z center location, Diameter and Draft 
Angle.

Geometric Characteristics
A simple hole is created by choosing the solid face and the location of the hole. It is 
made up of these characteristics according to Edit Objects: Hole Type, Thru Type, Hole 
Depth, Diameter and Draft Angle. To modify the hole characteristics, select the hole 
using the Design Explorer and choose Window>Edit Objects or double-click on the 
hole name. For more information on the Design Explorer, see Edit Objects.

Normal Creates a hole perpendicular to the solid face.

X-Axis Creates a hole along the X-axis.

Y-Axis Creates a hole along the Y-axis.

Z-Axis Creates a hole along the Z-axis.

2-Pts Creates a hole in the direction specified by two user defined 
points.
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Counter Bore Tool

This tool creates a counter bore hole based on the values 
specified in the Status Line. A counter bore consists of the 
bore and the hole. The bore is a straight-sided cylinder with a 
diameter larger than the hole. The hole extends from the end 
of the bore and completes the counter bore. See the graphic 
here.

Using the Counter Bore Hole Tool
1. Select the Hole tool.

2. In the Message Line select the Counter Bore Hole tool. The Message Line reads: 
Counter Bore: Pick solid face to place counterbore.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message Line. 

4. Select the face to place the counter bore.
5. Specify the location for the center of the counterbore hole.
6. If the 2-Pts direction is selected, click two points to specify the direction.

The bore is created.
While the solid is still selected the depth, diameter and draft angle of the hole and the 
bore depth and radius can be changed in the Status Line. Type the desired values in the 
data fields and press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the counter bore's Depth, Diameter, Draft Angle, Bore Depth 
and Bore Diameter.

Geometric Characteristics
A counter bore is created by choosing the solid face and the location of the hole. It is 
made up of these characteristics according to Edit Objects: Hole Type, Thru Type, Hole 
Depth, Diameter, Draft Angle, Counter Bore Diameter and Depth. To modify the hole 
characteristics, select the hole using the Design Explorer and choose Window>Edit 
Objects or double-click on the hole name. See Design Explorer for more information.

Counter Sink Tool

This tool creates a hole with angled sides, called the sink and 
a hole that extends from the sink. A counter sink hole can be 
contrasted with a counter bore hole where the bore has 
straight sides.

Using the Counter Sink Hole Tool
1. Select the Hole tool.

2. In the Message Line select the Counter Sink Hole tool. The Message Line reads: 
Counter Sink Hole: Pick solid face to place countersink.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message line.

4. Select the face where to locate the hole.
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5. Select the location for the center of the hole.
6. If the 2-Pts direction is selected, click two points to specify the direction.

The hole is created.
While the solid is still selected the depth, diameter and draft angle, sink radius and sink 
angle can be changed in the Status Line. Type the desired values in the data fields and 
press ENTER (Windows) or RETURN (Macintosh).
The Status Line contains the countersink's Depth, Diameter, Draft Angle, Sink Diameter 
and Sink Angle.

Geometric Characteristics
A counter sink hole is created by choosing the solid face and the location of the hole. It 
is made up of these characteristics according to Edit Objects: Hole Type, Thru Type, 
Hole Depth, Diameter, Draft Angle, Counter Sink Diameter and Angle. To modify the 
hole characteristics, select the hole using the Design Explorer and choose 
Window>Edit Objects or double-click on the hole name. “Design Explorer” on page 34 
for more information.

Boss Feature Tool

This tool creates a boss by adding a cylinder of a specified size to another solid and 
filleting the intersection of the two. A boss can be placed on planar and non-planar 
surfaces. Specify the height, diameter and fillet radius in the Status Line.

Boss Direction
The Message Line contains a pull-down menu to specify 
a boss direction. There are five options: Normal, X-Axis, 
Y-Axis, Z-Axis and 2-Pts.

Normal Creates a boss perpendicular to the solid face.

X-Axis Creates a boss along the X-axis.

Y-Axis Creates a boss along the Y-axis.

Z-Axis Creates a boss along the Z-axis.

2-Pts Creates a boss in the direction specified by two user defined 
points.
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Using the Boss Feature Tool
1. Select the Boss Feature tool. The Message Line reads: Boss Feature: Pick solid 

face to place boss.

2. Select the boss direction from the pull-down menu.
3. Select the face to locate the boss.
4. Specify a location for the boss center.
5. If the 2-Pts direction is selected, click two points to specify the direction.

The boss is created.
While the solid is still selected the height, diameter and fillet radius of the boss can be 
changed in the Status Line. Type the desired values in the data fields and press ENTER 
(Windows) or RETURN (Macintosh).
The Status Line contains the boss’ Height, Radius and Fillet Radius.

Geometric Characteristics
A boss is created by choosing the solid face and specifying the values for the cylinder. It 
is made up of these characteristics according to Edit Objects: Height, Diameter and 
Fillet Radius. To modify the boss characteristics, select the boss using the Design 
Explorer and choose Window>Edit Objects or double-click on the boss name. See 
Design Explorer for more information.

Shell Solid Tool

The Shell Solid tool hollows out a solid with a thickness 
specified.
This tool also includes an error detection routine. If the 
model contains a problem that prevents the completion of 
the local face modeling operation, an ACIS error dialog box appears with the problem 
location highlighted.

After shelling, the face thickness can be edited in the Edit Objects dialog box.
This tool also gives the option of keeping the core of the shelled object by using the 
CTRL (Windows) or SHIFT (Mac) key.
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Using the Shell Solid Tool
1. Select the Shell Solid tool. The Message Line reads: Shell Solid: Pick solid to shell 

[Ctrl = Keep Core (Windows) or Option = Keep Core (Macintosh)]

2. In the Status Line, enter the desired offset or thickness of the shell.
3. Select the solid. The Message Line reads: Shell Solid: Pick open faces 

[Shift=Extend]. 
4. Select the face or faces that will be open. The object shells.

Clicking in an area with no faces, the object will be hollowed out with no open faces.
While the solid is still selected, a new value may be entered in the offset field. Press 
ENTER (Windows) or RETURN (Macintosh) to accept the change.
The Status Line contains the offset or shell thickness.

Tech Note: Like all tools, set the thickness of the shell after the operation,
using the Status Line. When working with small objects, it may be necessary
to change the default thickness first to shell successfully.

Geometric Characteristics
A shelled solid is created by choosing a solid, specifying an offset and the face(s) to 
open. It is made up of these characteristics according to Edit Objects: Offset thickness, 
Suppress Face check box and a list of the solid faces with the respective offset distance. 
This list is only available if the operation is selected in the Design Explorer first and then 
display the Edit Object dialog box. See Design Explorer for more information.

Bend Tool

The Bend tool creates a solid by bending a solid about an axis through a given radius.
There are three subtools in the Message Line: Bend One End, Bend Center and Bend 
Along Path.

Using Bend One End
1. Click the Bend Solid tool. Select the Bend One End tool in the Message Line. The 

Message Line reads: Bend One End: Pick Solid to Bend.

2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired 
values for the bend solid. Tab between data fields.

3. Pick the solid to bend.
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4. The message line now reads, Bend One End: Enter two points for bend axis. Spec-
ify two points for the bend axis. The two points represent the inner tangent line for 
the bend solid. After clicking the two points, the solid is bent about the axis.

5. The Message Line now reads: Bend One End: Pick Solid to Bend [Option = Flip 
Material]. Press the CTRL (Windows) or OPTION (Mac) key to flip the end that is 
bent. 

While the object is still selected, the bend radius and bend angle can be edited. Enter 
the new values and press ENTER (Windows) or RETURN (Macintosh) and the solid 
updates
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Using Bend Center

1. Click the Bend Solid tool. Select the Bend Center subtool in the Message Line. The 
Message Line reads: Bend Center: Pick Solid to Bend.

2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired 
values for the bend solid. Tab between data fields.

3. Pick the solid to bend.
4. The message line now reads, Bend Center: Enter two points for bend axis. Specify 

two points for the bend axis. The two points represent the inner tangent line for the 
bend.   After clicking the two points, the solid is bent about the axis.

5. The Message Line now reads: Bend Center: Pick Solid to Bend [Ctrl = Flip Material 
(Windows) or Option = Keep Material (Macintosh)]. Press the CTRL (WIndows) or 
OPTION (Mac) key to flip the side of the material that was bent.

Using Bend Along Path

1. Click the Bend Solid tool. Select the Bend Along Path subtool the Message Line. 
The Message Line reads: Bend Along Path: Pick Solid to Bend.

2. Pick the solid to bend.

Bend Axis Resulting BendSolid to Bend

Flipped Material
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3. The message line now reads, Bend Along Path: Pick curve to bend solid to. Choose 
the curve.

4. The Message Line now reads, Bend Solid: Enter two points for bend height axis. 
Specify two points for the bend axis. The two points represent the point at which the 
bend will start.

5. The Message Line now reads, Bend Solid: Enter two points for alignment axis. 
Choose the points on the solid to aligned with the curve.

Geometric Characteristics 
A bend is created by choosing a solid and either two points to bend around or a path to 
bend along. For the Bend One End and Bend Center it is made up of these 
characteristics according to Edit Objects: Radius and Angle. For the Bend Along a Path 
there are no geometric characteristics. 

Twist Solid Tool
This tool adds angular twisting to a solid, surface 

or curved object.
The Message Line contains a pull-down menu to 
specify a type of geometric continuity between 
twisted area of the object and non-twisted area. There are three options: Match G0 
Slope, Match G1 Slope and Match G2 Slope.
The Match G0 Slope, Match G1 Slope, and Match G2 Slope specify the orientations of 
the non-twisted portions of the body. If Match G0 Slope or Match G1 Slope is specified, 
the entire body is rotated about the twist axis by the given amount before the twist is 
performed. Match G2 Slope indicates that the portion of the body below the twist's 
starting region retains its orientation with respect to the current coordinate system.
The following images demonstrate the difference between G0, G1 and G2 modes.

 G 0  G 2 G 1
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The difference between Start Angle and End Angle represents the amount, in degrees, 
that the twist region is warped about the axis. Both Start Angle and End Angle can be 
greater than or multiples of 360 degrees in order to obtain multiple turns within the 
twisting region. 

Using the Twist Solid Tool 
1. Select the Twist tool from Solid Utility tool palette. The Message Line reads: Twist 

Solid: Pick solid to twist.

2. The Status Line contains the Start Angle and End Angle fields. Enter the desired val-
ues for the twist. Tab between data fields. 

3. Pick the solid object to twist. The Message Line reads: Twist Solid: Enter two points 
for twist axis.

4. Specify the start point for the region to twist.
5. Specify the end point for the region to twist.
Two planes set perpendicular to the twisting axis through the specified points define the 
twist region. The Start Angle and End Angle values define the angle of rotation of 
relative to the initial state.

Geometric Characteristics
A twist is created by picking the solid to twist and specifying the two points for the twist 
axis. It is made up of these characteristics according to Edit Objects: Start Angle, End 
Angle, Length, Width and Height. To modify the twist characteristics, select the twist 
using the Design Explorer and choose Window>Edit Objects or double-click on the 
twist name. See Design Explorer for more information.
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Solid Utility Tools
After creating a solid model it's often necessary to modify it. Cobalt, Xenon and Argon 
provide tools to accomplish this. Use Boolean routines to add solids to each other, 
subtract them or create a new solid from their intersections. Use other tools to split a 
solid in two, stitch several surfaces together to form a solid, hollow out a solid to create 
a shell, change a solid face's draft angle or collectively change the draft angles of a set 
of upper and lower surfaces.
Values for each tool can be entered in the Status Line to perform the editing operation 
either before or after the operation is completed. When entering the values after 
selecting the tool but before performing the operation, the first click in the drawing area 
automatically registers all Status Line values. When entering values after performing the 
operation and while the solid is still selected, pressing ENTER (Windows) or RETURN 
(Macintosh) updates the solid to reflect the new values.
All editing operations conducted on a solid using Cobalt or Xenon are associative. In 
these two programs any modifications made to the parent will automatically alter all 
child objects that reference it.
The topics covered in this chapter include Solid Editing tools.
Cobalt, Xenon and Argon provide utilities tools located in the subpalette of the Solids 
tool palette. The utilities include the Boolean tools: Union Solid, Subtract Solid and 
Intersect Solid, plus Trim Solid, Split Solid, Stitched Solid, Thicken Solid, Lofted 
Solid, Rib Solid and Lip Solid.

Tech Note: The add, subtract and intersect tools replace the two original
solids with a new composite solid. The only way to recover the original solids
after a boolean union or intersection is to undo the command or in Cobalt or
Xenon suppress or remove the feature from the Feature Tree. Another
technique for retaining the originals is to copy or instance them and Boolean
the copies or instances.
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Union Solid Tool

The Union Solid tool combines two or more solids into one. In the left graphic below 
Solid A and Solid B are individual solids. The right graphic is a single solid.

Using the Union Solid Tool
1. Select the Union Solid tool. The Message Line reads: Union Solid: Pick solid to add 

to.
2. Select the initial solid.
3. Select the solid(s) to add to the first solid. Hold down the SHIFT key before selecting 

the first solid to select multiple solids.
There are no Status Line entries.

Subtract Solid Tool

The Subtract Solid tool subtracts one or more solids from another. In the right graphic 
Solid B is subtracted from Solid A.

Using the Subtract Solid Tool
1. Select the Subtract Solid tool. The Message Line reads: Subtract Solid: Pick solid 

to subtract from.

2. Select the initial solid.
3. Select the solid(s) from which to subtract the first solid. Hold down the SHIFT key 

before selecting the first solid to select multiple solids Hold the CTRL key (Windows) 
or OPTION key (Mac) to retain the items subtracted.

There are no Status Line entries.
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Intersect Solid Tool

The Intersect Solid tool creates a new solid from the common volume of two 
intersecting solids. The right graphic below is the intersection of Solid A and Solid B.

Using the Intersect Solid Tool
1. Select the Intersect Solid tool. The Message Line reads: Intersect Solid: Pick two 

solids to intersect.

2. Select the two solids to form the intersect solid.
There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a boolean solid.

Trim Solid Tool

The Trim Solid tool trims a solid with a curve, surface, or solid. The Trim tool is useful 
for removing material from a base solid. In addition to trimming to surfaces or another 
solid, the Trim Solid tool has the unique ability to trim a solid to a curve. In the case of a 
curve, an internal surface is built that sweeps into the screen or sweeps by user-defined 
vector. Use the pull down menu to specify the preference.

In the case of trimming a solid to a surface or other solid, the pull down option has no 
bearing on the results.

Trim Solid to Curve. Trim Solid to Surface.
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Using the Trim Solid Tool
1. Click the Trim Solid tool. The Message Line reads: Trim Solid: Pick curve or surface 

to trim solid.

2. The Message Line now reads: Trim Solid: Pick solid to trim. [CRTL (Windows) or 
OPTION (Macintosh) = Flip direction to remove]

3. The solid is trimmed to the curve, removing the solid in the direction of the arrows.

4. Press the Control or Option key to change the material that is kept.

Note: Press the Control or Option key to change the direction of the material to be 
removed after the trim is completed. Do not hold the Control or Option keys during the 
trimming process.
When trimming a solid to another solid the portion that is kept is the portion that was 
selected by the user.
There is no Status Line for the trim solid tool.

Trim Solid to Solid.
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Split Solid Tool

The Split Solid tool divides a solid into two 
parts. Cobalt, Xenon and Argon use an infinite 
plane, surface, or solid as the splitting entity, so 
construct the splitting object before making the 
split.

Using the Split Solid Tool
1. Select the Split Solid tool. The Message 

Line reads: Split Solid: Pick solid to split.

2. Select the solid. The Message Line reads: Split Solid: Pick surface for splitting solid. 
3. Select the infinite plane or surface to split the solid.
There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a split solid.

Stitched Solid Tool

The Stitched Solid tool creates a closed solid from a 
collection of surfaces. The color and resolution of the 
first surface selected are used for the stitched solid.
The tool uses healing technology to repair 
any small gaps in the model and creates a 
solid only if the selected surfaces create a 
closed body. This tool also provides three 
stitching options. Press the CTRL key 
(Windows) or OPTION key (Macintosh) to 
display the Stitching Options dialog box.

The dialog box contains the following 
options:

Maximum Heal Gap 
Size

Sets the maximum size that the program will attempt to stitch 
to objects. Enter a value between 0 and 1.

Example: If the gap size is .1 but the object has a gap of .2, the 
surfaces won’t stitch.

Simplify Spline 
Surfaces to Analytics

Sets whether spline surfaces are simplified when they are 
stitched. Solids use surfaces as their underlying geometry. 
These surfaces can be either Analytic surfaces or B-Spline 
Nurb surfaces. Analytic surfaces are used to create cylinders, 
cones and spheres. B-Splines surfaces are used to create a 
variety of shapes. ACIS is “turbocharged” for analytic surfaces.
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Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when stitching solids.

Using the Stitched Solid Tool
1. Select the Stitched Solid tool. The Message Line reads: Stitched Solid: Pick sur-

faces to create solid from. [Ctrl=Advanced] (Windows) or Option=Advanced (Macin-
tosh) [Shift=Extend]

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Stitching 
Options dialog box.

3. Specify the settings and click OK. Click Cancel to close the dialog box.
4. Hold down the SHIFT key and select the surfaces or drag a selection fence around 

them.
The surfaces are stitched into a solid.

There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a stitched solid.

Thicken Solid Tool

The Thicken Solid tool thickens surfaces and solids. Specify the desired thickness. A 
positive or negative value determines the direction of the thickening. The left graphic 
shows a surface and the right graphic shows the thickened surface, now a solid.

When selected, the program attempts to simplify the spline 
surfaces. If the surfaces create a standard shape such as a 
cylinder, they convert into analytic surfaces. This conversion 
speeds up the calculation process for the solid and for the file. 
By default, this option is not selected.

Use Tolerant Edges Determines whether tolerant edges will be used if a model 
can’t stitch because of a gap. When selected and an edge 
can’t stitch, it is marked as tolerant. Only operations that 
involve the entire edge can be conducted.

If this option is not selected and the program discovers a gap 
larger than specified in the Maximum Heal Gap Size data field 
the following dialog box appears.
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Using the Thicken Solid Tool
1. Select the Thicken Solid tool. The Message Line reads: Thicken Solid: Pick surface 

or solid to thicken. [CTRL or OPTION = Flip thickness side].

2. Type the desired thickness in the Thickness data field in the Status Line.
3. Select the surface or solid object to be thickened. The program thickens the 

selected object.
By pressing the CONTROL or OPTION key it is possible to toggle which side of the 
surface is thickened.
While the object is still selected, enter a new value in the Thickness data field and press 
ENTER (Windows) or RETURN (Macintosh) to change the thickness.
The Status Lines contains the Thickness value for the thickened object.

Geometric Characteristics
A thickened solid object is created by specifying a thickness and selecting the object. A 
thickened object is made up of the Thickness characteristic according to the Edit 
Objects dialog box. To modify the characteristics of the thickened object select the 
object using the Design Explorer (Cobalt and Xenon only) and choose Window>Edit 
Objects or double-click on the face name.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering the 
value in the U and V data fields and clicking Apply. A grid of U and V lines will display on 
the object. There are three Silhouette settings, Smart, Off and On.
See Design Explorer for more information.
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Lofted Solid Tool

This tool creates a tangent solid between two neighboring solids using a specified bulge 
factor. The higher the bugle factor the more influential the slope of the tangent for the 
selected solid. A loft solid with a bulge factor of zero (0) creates a discontinuous loft. 
The graphics below illustrate the effects of the bulge factor.

This tool does not support lofting if one of the solids is a sphere. If a sphere is selected 
no loft is created.

Using the Lofted Solid Tool
1. Select the Lofted Solid tool. The Message Line reads: Lofted Solid: Pick two faces 

for lofted solid.

2. Enter a value in the Bulge data field. 
Be careful not to apply a bulge so large that it results in a self-intersecting body. If it 
does, the following error message appears. 

Also be aware that bulge factors that are too small with respect to the solids may 
prevent later feature operations such as shelling and blending.

3. Select a solid face.
4. Select a face on the other solid.

One loft solid is created from the two solids using the shared faces for tangent 
conditions.

Bulge Factor = 0 Bulge Factor = 5

Bulge Factor 1 = 5; Bulge Factor 2 = 15 (Set in 
Edit Objects)

Bulge Factor 1 = 8; Bulge Factor 2 = 10 (Set in 
Edit Objects)
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The Status Line contains the Bulge data field.

Geometric Characteristics
A lofted solid is created by selecting a face on two solids. It is made up of the following 
characteristics according to the Edit Objects dialog box: Bulge 1 and Bulge 2. Bulge 1 
applies to the bulge between the first face selected and the lofted solid. Bulge 2 applies 
to the bulge between the second face selected and the lofted solid. To display the Edit 
Objects dialog box for the lofted solid only, double-click the lofted solid item in the 
Design Explorer.

Rib Solid Tool

Cobalt's Rib Solid tool extrudes and thickens a 
closed or open profile into a base solid. The 
profile is terminated up to the first face it reaches 
in the direction of the extrude. 
The Rib Solid Tool has three options that appear 
in the Message Line when the tool is selected:

Check the Extend Rib Profiles box to automatically extend the rib to meet the 
corresponding faces of the related solid. If left unchecked the rib will only be as long as 
the profile line.

One Side Extrudes from one side or the other of the profile line using a 
negative or positive number to control both the thickness and 
the side.

Two Sides Extrudes the distances specified for both directions from the 
profile line. 

Mid Line Extrudes an equal distance in both directions from the profile 
line.

One Side
Two Sides

Mid Line

Extend Rib Profiles
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Using the Rib Solid Tool
1. Select the Rib Solid tool. 

2. Specify the necessary option in the Message Line.
3. The Message Line reads: Rib Feature: Pick solid for rib.

4. Select the solid to which to add the rib. The Message Line reads: Rib Feature: Pick 
rib profile. [Shift = Extend]
After selecting the rib profile, specify the thickness of the rib. This 
is done in the Status Line entry box pictured here.

5. Once the rib profile is selected, the Message Line reads: Rib Feature: Specify 2 
points for rib direction.
For the tool to function correctly, the direction should run into the solid to which the rib 
feature is added.

To edit the thickness of the rib after placing it, go through the Design Explore and 
access the Edit Objects box associated with the rib. The examples below show the tool 
use progression.

Geometric Characteristics
A rib solid is created by selecting a solid for rib, rib profile and two points for rib 
direction. It is made up of the following characteristics according to the Edit Objects 
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dialog box: thickness, draft angle, rib type, direction. To display the Edit Objects dialog 
box for the rib solid only, double-click the ribbed solid item in the Design Explorer.

Lip Solid Tool

Cobalt’s Lip Solid tool sweeps a profile about a collection of edges and either adds or 
subtracts the resultant sweep to or from the base solid. The given profile is automatically 
aligned perpendicular to the selected edge. In addition, a reference point is specified 
such that the profile is translated from the reference point to the start position along the 
edge selected. When the base solid is regenerated, the profile is always translated from 
the reference position to that on the edge and then realigned.

Note: While picking a face for the Lip Solid tool, all edges of the selected face are used 
for the lip tool. 
The Lip Solid tool has two options in the Message Line, Add Feature and 
Remove Feature.

Using the Lip Solid Add Feature Tool

1. Select the Lip Solid tool. The Message Line reads: Lip Feature Add: Pick curves for 
lip profile. [Shift = Extend]

2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify 
profile origin.
The center of the circle is selected to be the origin in this example.

3. The Message Line reads: Lip Feature Add: Pick edges for profile to sweep. [Shift = 
Extend]

4. Pick the edges of the solid to which to add the lip feature. In the example above, the 
edges of the green block were chosen.

Lip Solid Add Feature Tool example.
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Using the Lip Solid Remove Feature Tool

1. Select the Lip Solid tool. The Message Line reads: Lip Feature Remove: Pick curves 
for lip profile. [Shift = Extend]

2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify 
profile origin.
The center of the circle is selected to be the origin in this example.

3. The Message Line reads: Lip Feature Remove: Pick edges for profile to sweep. 
[Shift = Extend]

4. Pick the edges of the solid from which the lip feature profile will be removed. In the 
example below, the edges of the green block were chosen.

Note: The remove feature on both block edges cannot be used at the same time.
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Solid Face Modification Tools 

The Solid Face Modeling tools perform operations on faces independently of how the 
part was created. This means that parts from other 3D systems can be imported and 
edits to the geometry performed. 
These tools also include an error detection routine. If the model contains a problem that 
prevents the completion of the local face modeling operation, an ACIS error dialog box 
appears with the problem location highlighted.

Draft Face Tool

Choosing the Draft Face tool applies a draft to a group of selected faces. Positive tapers 
(draft) add material. Negative tapers (draft) remove material. The taper direction is 
relative to the pull-direction defined by the current work plane and a neutral point.

Rules
• The work plane cannot be parallel to the face or faces that are tapered. The work 

plane defines the pull-direction or direction of draw, the direction the part would eject 
from a mold.

• The neutral point is the position on the face or edge that remains fixed while the face 
tapers.
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• The taper is the angle that the face rotates relative to the neutral point. The value can 
be negative or positive and the rotation occurs relative to the work plane. Typically 
positive values add material and negative values remove material. The graphics here 
illustrate the relationship between that work plane and the taper angles.

Using the Draft Tool
1. Select the Draft Solid 

tool. The Message Line 
reads: Draft Solid: Pick 
reference face or edge 
for draft (click nothing for work plane].

2. Select the reference face, edge or work plane. This tells 
the program the pull direction of the normal for the taper.
When selecting the reference, an arrow displays indicating 
the normal direction. An example is shown here.
The Message Line now reads, Draft Solid: Pick faces of a 
solid to draft. [Shift=Extend]

3. Select a face or hold down the SHIFT key to select more 
than one face. The Message Line now reads, Draft Solid: 
Specify taper neutral position.

Tech Note: Make sure the chosen face is not normal to the z-axis. If it is,
nothing will happen. Change the work plane and try again.

4. Click a point on the screen to serve as the neutral position. The neutral position will 
remain constant. 
Cobalt, Xenon and Argon apply the taper or draft relative to a pull direction defined by 
the normal.

While the solid is selected, the Draft angle can be changed in the Status Line. Press 
ENTER (Windows) or RETURN (Macintosh) and the taper updates.
The Status Line contains the Draft angle.
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Modifying Drafted Solids
Modify the draft angle of the solid by choosing the draft in the Design Explorer for the 
solid and displaying the Edit Objects dialog box. If there is more than one face drafted, 
specify a different draft for each one. Click Apply to accept the changes.

Geometric Characteristics
A draft solid is created by choosing a solid, specifying a draft, the face for the draft and 
the neutral point position. It is made up of these characteristics according to Edit 
Objects: Draft angle and the solid face list with the drafts. This list is only available if the 
operation is selected in the Design Explorer first and then the Edit Object dialog box is 
displayed. See “Edit Objects” on page 5-25 for more information on the Design Explorer.

Match Face Tool

The Match Face tool matches the selected surface to a referenced surface. This tool 
only works if the referenced surface is analytical (planar or circular). A nurb surface is 
not an analytical surface.

Planar Example
This is an example of matching the top face of the 
right model to the top face of the left model, which 
acts as a reference. Imagine the top planar face of 
the left solid extended beyond its bounds, as shown 
in the left graphic here. When the operation is 
complete the NURB face of the right solid is 
replaced with the planar face, as shown in the right graphic. The solid is extended to the 
imaginary intersection with the top planar face of the left solid.

Here’s another example of the match face option. The left graphic shows a select face 
on a solid object. The right graphic shows the face matched to the sloped face.
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Elliptical Example
This left graphic below shows an example of matching a side face of the rectangular 
solid to the elliptical solid, which acts as a reference. When the operation is complete 
the solid is extended to the elliptical solid and the planar face becomes an elliptical face, 
shown in the right graphic.

Using the Match Face Tool
1. Select the Match Face tool. The Message Line reads: Match Face: Pick face to 

modify.

2. Select the face of the solid to modify or match to another face. To select more than 
one face be sure to hold down the SHIFT key before selecting the first face.
The Message line now reads, Match Face: Pick face to match to.

3. Select the face of the solid that the selected face will match.
The face is matched.

The Status Line contains no entries.

Geometric Characteristics
A matched face has no specific characteristics. To modify the Display and Attribute 
characteristics of the matched face, select the face using the Design Explorer and 
choose Window>Edit Objects or double-click on the face name.
The display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering 
the value in the U and V data fields and clicking Apply. A grid of U and V lines will 
display on the object. There are three Silhouette settings: Smart, Off and On.
See Edit Objects for more information.

Move Solid Element Tool

The Move Solid Element tool moves edge, vertex or the selected group of faces by a 
vector defined with the Drafting Assistant.
The Move Face tool has three options to specify moving 
a vertex, edge or face.



Move Solid Element Tool

27-5

The graphics below show the operation of moving the vertex. The left graphic shows the 
original geometry with the selected geometry and the right graphic shows the geometry 
with the vertex moved.

The graphics below show the operation of moving the edge. The first graphic shows the 
original geometry with the selected edge, the second graphic shows the vector for 
moving and the third graphic shows the geometry with the edge moved.

When moving more than one face, the selected faces cannot be perpendicular to the 
others. This tool is available for moving a flat face and fillet, or a face and a hole. The 
graphics here show just such an operation. The left graphic shows the original geometry 
with the selected faces and the right graphic shows the geometry with two faces moved.

Tech Note: When using the Move Face option, do not move the whole face
off a solid or an error message will occur.

Using the Move Solid Element Tool
1. Select the Move Solid Element tool.

1 2

3
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2. Select the desired option to move a vertex, edge or face. The Message Line reflects 
the option chosen. For Move Face it reads: Move Face: Pick faces of a solid to 
move [Shift=Extend].

3. Select the face, vertex or edge of the solid to move. To select more than one, hold 
down the SHIFT key before selecting the first one.
The Message Line now reads: Move Face: Pick two points for move. The points 
define a vector with DX, DY, DZ values. Either click two points or enter the desired 
values in the Status Line. 

4. Select the two points to specify dX, dY, dZ values for the move. The order the points 
are selected determines whether the value is positive or negative.
The selected face, edge or vector moves to the new location.

While the element is still selected, enter new values in the dX, dY, or dZ data fields in 
the Status Line. Press ENTER (Windows) or RETURN (Macintosh) to update the move.
The Status Line contains the dX, dY and dZ values of the move.

Geometric Characteristics
A move vertex, edge, face has distance and direction characteristics according to the 
Edit Objects dialog box. To modify the Geometry, Display and Attribute characteristics of 
the moved solid element, select the element using the Design Explorer and choose 
Window>Edit Objects or double-click on the feature name.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering the 
value in the U and V data fields and clicking Apply. A grid of U and V lines will display on 
the object. There are three Silhouette settings, Smart, Off and On. See Edit Objects for 
more information.

Offset Face Tool

The Offset Face tool offsets the selected faces. Adjacent faces and edges are adjusted 
as necessary for the offset. The left graphic below shows the original object. The right 
graphic shows a positive offset of the left and top face.

Using the Offset Face Tool
1. Select the Offset Face Modeling tool.

2. The Message Line reads: Offset Face: Pick faces of a solid to offset [Shift=Extend].
3. In the Status Line enter a value in the data field. A positive value enlarges the object 

and a negative value reduces the object.
4. Select the face of the solid to offset. To select more than one face be sure to hold 

down the SHIFT key before selecting the first face.
The selected face moves the offset specified.
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While the object is still selected, new values can be entered in the data field in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh) to update the offset.
The Status Line contains the Offset value.

Geometric Characteristics
An offset face is defined by its offset value according to the Edit Objects dialog box. To 
modify the offset or the Display and Attribute characteristics of the offset face, select the 
face using the Design Explorer and choose Window>Edit Objects or double-click on 
the face name.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering the 
value in the U and V data fields and clicking Apply. A grid of U and V lines will display on 
the object. There are three Silhouette settings, Smart, Off and On. For more information 
see Edit Objects.

Remove Face Tool

The Remove Face tool removes a face from a solid, extends the adjacent faces and 
relimits the solids as necessary. This is useful for removing holes and fillets from 
geometry imported without a history tree. The left graphic shows the original object. The 
right graphic shows the object with the holes and a fillet removed.

Using the Remove Face Tool
1. Select the Remove 

Face tool.

2. The Message Line 
reads: Remove Face: Pick faces of a solid to remove. [Shift=Extend]

3. Select the face of the solid to remove. To select more than one face be sure to hold 
down the SHIFT key before selecting the first face.
The selected face is removed.

There are no Status Line entries.
Warning: A face can only be removed 
from a solid as long as the integrity of a 
solid is retained after the face removal. A 
face of a cube cannot be removed if the 
cube has a blend; only the blend can be 
removed. Attempting to remove a face 
that will challenge the solid's integrity, 
the following error message appears.
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Geometric Characteristics
A removed face has no specific characteristics.

Replace Face Tool

The Replace Face tool replaces the selected face with the new face specified. The new 
face must have the same boundaries or edges as the original face.

Using the Replace Face Tool
1. Select the Replace Face tool.

2. The Message Line reads: Replace Face: Pick face to replace.
3. Select the face of the solid to replace. To select more than one face be sure to hold 

down the SHIFT key before selecting the first face.
The Message line now reads: Replace Face: Pick new surface.

4. Select the replacement face.
The original face is replaced.

The Status Line contains no entries.

Replace Face Example
In the block shown here, the top face will be replaced with a warped 
surface.

1. Select the Rectangle tool and trace over the top face of the 
block.

2. Select the Through Point B-Spline tool and create a three point 
spline from the midpoint of one edge to the midpoint of the oppo-
site edge.

3. Using the Selection tool, select the center control point of the 
spline and drag it up along the z axis some distance.

4. Select the Skin tool.
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5. Select the Guide Curves option from the Message Line.

6. Select the skin curves consisting of the right edge curves, 
(curves 1, 2 and 3 in the graphic).

7. Select the guide curves consisting of the top and bottom curves 
(curves 1 and 2 in the graphic) to complete the skin surface.

8. Select the Replace Face tool.

9. Select the top face of the block to replace.
10. Select the just created net surface to replace the face.

The top face of the solids is replaced.

Geometric Characteristics
A replaced face has no specific characteristics. To modify the Display 
and Attribute characteristics, select the face using the Design 
Explorer and choose Window>Edit Objects or double-click on the 
face name.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering the 
value in the U and V data fields and clicking Apply. A grid of U and V lines will display on 
the object. There are three Silhouette settings, Smart, Off and On. For more information 
see Edit Objects.

Parting Line Solid Tool

The Parting Line tool automatically applies draft angles to a collection of upper and 
lower surfaces. These faces are determined by the location of the parting line curve. 
This Designer Elements program uses curves as the parting entity so the curves must 
be created before using the tool.

Rules
• The work plane cannot be parallel to the face or faces that are tapered. The work 

plane defines the pull-direction or direction of draw, the direction the part ejects from 
a mold.
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• The taper is an angle that the face rotates relative to the neutral point. The value can 
be negative or positive and the rotation occurs relative to the work plane. Typically, 
positive values add material and negative values remove material. The graphics here 
illustrate the relationship between that work plane and the taper angles.

• If having difficulty placing a draft on a solid, try changing the work plane and 
attempting the draft again.

The left graphic shows an object with a parting line curve. The right graphic shows the 
object after using the tool.

Using the Parting Line Solid Tool
1. Select the Parting Line tool. The Message Line reads: Parting Line Solid: Pick solid 

for parting line.

2. Select the solid to part. The Message Line reads: Parting Line Solid: Pick curves for 
parting line.

3. Select the parting line curves. To select more than one curve be sure to hold down 
the SHIFT key before selecting the first curve.

While the solid is still selected, change the upper and lower taper values. Press ENTER 
(Windows) or RETURN (Macintosh) and the part updates.
The Status Line contains the Upper Taper and the Lower Taper angle for the solid.
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Modifying Parting Line Solids
To modify the taper angles of the solid, choose the taper in the Design Explorer for the 
solid and display the Edit Objects dialog box. Modify the taper angle for the Upper and 
Lower Tapers. Click Apply to accept the changes.

Geometric Characteristics
A parting line solid is created by choosing a solid, intersecting curve and the upper and 
lower taper. It is made up of these characteristics according to Edit Objects: Draft angle 
and the solid face list with the tapers. This list is only available if the operation is 
selected in the Design Explorer first and then the Edit Object dialog box is displayed. 
See Edit Objects for more information.

Deform Face Tool

The Deform Face tool deforms surfaces and solid faces. When selecting the Deform 
Face tool, a subpalette appears in the Message Line containing three options: Deform 
with Gain, Deform to Point and Deform to Curve.

All deform face examples will use the solid block here to 
illustrate each Deform Face tool.
If, after using the Deform Face tool and building the model, it is 
necessary to edit the deformed face, access the Edit Objects 
dialog box through the Design Explorer.

The Deform Face Edit Objects box contains the following options:

Gain The gain value is similar to a constraint pressure applied to the 
surface. Use positive gain to inflate the surface and negative to 
deflate. Depending on the stiffness and resolution of the 
surface practical gains can range anywhere from 0 to 1000000.

Stretch Factor The stretch factor controls the deformable surface's resistance 
to stretching. A surface with a large stretch value is said to be 
stiff. Deformable surfaces with large stretch values act like 
soap bubbles seeking to always minimize their area. This 
results in flatter looking surfaces that allow regions of rapid 
bending.



Solid Face Modification Tools

27-12

The following options apply only to pressure deformations, the first option icon. They do 
not apply to deformations to a point or curve. Be sure to use higher resolutions when 
using the below options to ensure tangency and curvature precision with the results.

Deform Face with Gain Option

This option applies a pressure gain (negative or positive) to the 
selected surface or face. The gain displays in the Status Line. 
Large gains distort the object while small gains barely move the 
object. The pressure applies to the entire surface or face. A 
location for the deformation can not be specified. Use the 
Deform Face to Point option for that ability. The graphic shows 
the top face deformed using this option.

Using the Deform Face with Gain Tool
1. Select the Deform Face 

tool.

2. Select the Deform Face 
with Gain option in the Message Line. The Message Line reads: Deform Face: Pick 
face to deform with pressure.

3. Type the desired pressure in the Gain data field of the Status Line.

Bend Factor The bend factor controls the deformable surface's resistance to 
bending. Deformable models with large bend values act like 
elastic beams attempting to distribute regions of bending over 
large areas and typically generate very fair shapes. 

Resolution The resolution slider controls the precision of the resultant 
deformed shape by inserting additional control points to the 
surface.   Higher resolution values will show more detail for the 
given deformation values. Lower resolution values calculate 
faster but with less detail. When using the tangent and 
curvature options, start with a resolution factor of 80 for best 
results.

No Tangency The No Tangency option deforms the face and allows the 
shape at the edges to deform.

Local Face Tangent The Local Face Tangent option deforms the shape but 
preserves the existing tangents of the face.

Shared Faces 
Tangent

Shared Face Tangent modifies all faces that share edges with 
the face being modified. The modification imposes tangencies 
at all shared edges.

Shared Faces 
Curvature

The Shared Face Curvature option modifies all faces that 
share edges with the face being modified. The modification 
imposes curvature continuity at all shared edges.

Shared Faces 
Tangent 

The Shared Face Tangent Fixed option will only modifies the 
selected face to be tangent to all faces that share an edge with 
the selected face.

Shared Faces 
Curvature 

The Shared Face Curvature Fixed option only modifies the 
selected face to be curvature continuous to all faces that share 
an edge with the selected face.
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The number can be a positive or negative value.
4. Select the face or surface to deform. 

The object is deformed. Render the object using any render option other than 
wireframe to view the deformation.

While the object is still selected, enter a new value in the Gain data field and press 
ENTER (Windows) or RETURN (Macintosh) to change the gain.
The Status Line contains the Gain value for the deformation. 

Deform Face to Point Option

This option applies a pressure gain (negative or positive) to the selected surface or face 
passing through a specific point in space. Choose a point on the object to begin the 
deformation and the point’s final location. The left graphic shows the initial point on a 
solid face and its final location. The right graphic shows the rendered object and the 
point.

The pressure gain displays in the Status Line.

Using the Deform Face to Point Option
If the deformation should pass through a point not already in the drawing, create the 
point before using this tool.
1. Select the Deform Face tool.

2. Select the Deform Face to Point tool in the Message Line. The Message Line 
reads: Deform Face: Pick face to deform.

3. Type the desired pressure in the Gain data field of the Status Line.
4. Select the surface or face to deform.

The Message Line reads: Deform Face: Pick location to deform from.
5. Click a location on the selected surface/face to set the point from which the face 

deforms.
The Message Line reads: Deform Face: Pick location to deform to.

6. Click the final location for the face point where the deformation begins.
The object deforms. Render the solid using any rendering option other than wireframe 
to view the deformation.

While the surface or face is still selected, enter a new value in the Gain data field and 
press ENTER (Windows) or RETURN (Macintosh) to change the gain. 
It is possible to move the point later by dragging it to a new location or using the Edit 
Objects dialog box when the point is selected. The deformed object automatically 
updates.
The Status Line contains the Gain value for the deformation. 
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Deform Face to Curve Option

This option applies a pressure gain (negative or positive) to the selected surface or face 
attached to a specified curve. Create the curve before using this option. The left graphic 
shows the object with the curve. The right graphic shows the rendered image and the 
curve.

The pressure gain displays in the Status Line. A high enough gain forces the surface or 
face to pass through the curve. The curve is associative to the deformation. Moving the 
curve changes the associated deformation.

Using the Deform Face to Curve Option
If it is necessary for the deformation to use a curve not already in the drawing, create the 
curve before using this option.
1. Select the Deform Face tool.

2. Select the Deform Face to Curve option in the Message Line. The Message Line 
reads: Deform Face: Pick face to deform to curve.

3. Type the desired pressure in the Gain data field of the Status Line.
4. Select the surface or face to deform.

The Message Line reads: Deform Face: Pick curve constraint.
5. Select the curve.

The object is deformed. Render the object using any render option other than 
wireframe to view the deformation.

While the object is still selected, enter a new value in the Gain data field and press 
ENTER (Windows) or RETURN (Macintosh) to change the gain.
The Status Line contains the Gain value for the deformation. 

Geometric Characteristics
A deformable surface or face is created by selecting object and using pressure, a point 
or curve. This deformed surface or face is made up of the following characteristics 
according to the Edit Objects dialog box: Gain, Stretch Factor, Bend Factor and 
Resolution. The dialog box also contains the Keep Boundary Tangents option.

Gain Displays the pressure applied to the surface or face. Enter a 
different gain and click Apply.

Stretch Factor Sets the resistance of the surface or face to the stretching. 
Higher values result in a flatter surface. Lower values result in 
a smoother surface. Enter a value or use the slide to specify a 
factor.
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To modify the Display and Attribute characteristics of the deformed surface or face 
select it using the Design Explorer and choose Window>Edit Objects or double-click on 
the item’s name.
Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering the 
value in the U and V data fields and clicking Apply. A grid of U and V lines will display on 
the object. There are three Silhouette settings, Smart, Off and On.
See Edit Objects for more information.

Stretch Solid Tool

The Stretch Solid tool stretches a solid along an 
axis. When selecting the Stretch Solid tool, a drop down menu appears in the Message 
Line containing two options: Match G0 Slope and Match G1 Slope. These options 
specify the translations of the non-stretched portions of the body.

Following images show the difference between G0 and G1 modes.

Bend Factor Sets the surface or face resistance to bending. Higher values 
prevent sharp radical changes to the surface. Enter a value or 
use the slide to specify a factor.

Resolution Sets the number of internal grids used to calculate the 
deformation. Higher values increase the influence of the bend 
and stretch factors to pressure gains. Lower values decrease 
the influence, providing quick results but few discriminating 
features to the surface. Enter a value or use the slide to specify 
a resolution.

Keep Boundary 
Tangents

Determines whether the edges of the surface or face remain 
tangent. When selected, the edges are tangent. This left 
graphic here shows the top deformed solid face without 
tangent edges. The right graphics shows the deformed face 
with tangent edges.

Match G0 Slope Indicates that the portion of the body below the stretch's 
starting region retains its position.

Match G1 Slope Translates the entire body along the stretch axis by the given 
distance before the stretch is performed.

Match G0 Slope Match G1 Slope
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Using the Stretch Tool
1. Select the Stretch tool 

from Solid Utility tool 
palette. The Message 
Line reads: Stretch 
Solid: Pick solid to stretch.

2. Pick the solid object to stretch. The Message Line reads: Stretch Solid: Enter two 
points for stretch region.

3. The Status Line contains the Distance field. Enter the desired value for the stretch.
4. Specify the starting point for the region to stretch.
5. Specify the end point.
Two planes perpendicular to the stretch axis through the specified points define the 
region to stretch.

Geometric Characteristics
A stretched distance is created by picking the solid to stretch and entering two points for 
stretch region. This stretch is made up of the following characteristics according to the 
Edit Objects dialog box: Distance, Name, Resolution, Color, Control Points, Layer. 
See Edit Objects for more information.
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Assembly Modeling Tools
Cobalt and Xenon provide tools for doing assembly modeling. These tools are 
located in their own tool palette. Choose Window>Assembly to display the 
tool palette.
The Assembly Modeling tools include: Assembly Connect, Assembly Mate, 
Assembly Align and Assembly Insert.

Each tool performs a 
particular operation involving two solids. 
The following error appears if an 
operation is attempted on a single solid.

Tech Tip: Mate or align the faces first, then set the connection points. 

Assembly Connect Tool

The Assembly Connect tool connects one solid to another at a specified connection 
point. The resulting part is associative. When moving one solid the other moves as well 
to maintain the connection. The left graphic shows two solid objects. The right graphic 
shows the solids after connecting them. 

This tool supports connection points along object edges and on locations recognized by 
the Drafting Assistant such as center, midpoint and endpoint. It is not possible to relate 
more than one solid to another in a single command.

Using the Assembly Connect Tool
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1. Select the Assembly Connect tool. The Message Line reads: Assembly 
Connect: Pick solid to move.

2. Select the solid.
The Message Line now reads: Assembly Connect: Pick the connection 
point location on selected solid to move.

3. Using the Drafting Assistant select the connection point on the solid to be 
moved.
The Message Line reads: Assembly Connect: Pick solid to move to.

4. Select a different solid to which the first solid will be moved.
The Message Line reads: Assembly Connect: Pick new location on the selected solid 
for first solid selected.

5. Using the Drafting Assistant select the connection point on the stationary solid 
where the first solid will be connected.
The two solids are connected.

The Status Line contains no entries.

Geometric Characteristics
A connected assembly is made up of two solids. It does not include characteristics that 
are unique. To modify Display and Attribute characteristics of an assembly, select the 
object using the Design Explorer and choose Window>Edit Objects or double-click on 
the face name. See Edit Objects for more information.
The Display tab of the Edit Object window contains settings for Iso Lines and Silhouette. 
Display Iso Lines by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on the object. There are three Silhouette settings: 
Smart, Off and On.

Assembly Mate Tool

The Assembly Mate tool mates planar faces. Specify an offset distance between mated 
faces. The normals of the mated faces point in opposite directions. This tool only 
ensures that the selected faces are co-planar. To align the faces, use the Assembly 
Align tool. The left graphic shows the two solids. The right graphic shows the solids 
after mating them.

Tech Tip: Don't be alarmed when using the Mate tool if the solid moves a
long way from it's original position. The solids will be mated. Use the
Connection tool to specify the exact connection and bring them back together.

Using the Assembly Mate Tool
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1. Select the Assembly Mate tool. The Message Line reads: Assembly Mate: 
Pick solid face to mate.

2. Select the solid face to mate.
The Message Line now reads: Pick solid face to mate with.

3. Select the face of a different solid with which to mate the first.
The two solids are now mated.

4. To offset the first solid a certain distance from the second, enter a value in 
the Status Line data field and press ENTER (Windows) or RETURN (Mac-
intosh).
The objects are offset the specified distance but are still co-planar.

The Status Line contains the Offset data field.

Geometric Characteristics
A mate assembly is made up of two mated solid objects and includes an Offset value 
according to the Edit Object dialog box. To modify the characteristics of a mate 
assembly, select the assembly using the Design Explorer and choose Window>Edit 
Objects or double-click on the face name. 
The Display tab of the Edit Object dialog window contains settings for Iso Lines and 
Silhouette. Display Iso Lines by entering the value in the U and V data fields and clicking 
Apply. A grid of U and V lines will display on the object. There are three Silhouette 
settings: Smart, Off and On.

Assembly Align Tool

The Assembly Align tool aligns a face of two solid objects and supports cylindrical, 
spherical and planar faces. This tool reorients the parts so that the faces are aligned in 
the same direction. The left graphic shows the two solid. The right graphic shows the 
solids after aligning them.

Tech Tip: Don't be alarmed when using the Mate tool if the solid moves a
long way from it's original position. The solids will be mated. Use the
Connection tool to specify the exact connection and bring them back together.
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Using the Assembly Align Tool
1. Select the Assembly Align tool. The Message Line reads: Assembly Align: 

Pick solid face to align.

2. Select the solid face to align.
The Message Line now reads: Assembly Align: Pick solid face to align with.

3. Select the face of a different solid with which to align.
The two solids are now aligned.

The Status Line contains no entries.

Geometric Characteristics
An aligned object is made up of two aligned solids and includes an Offset value 
according to the Edit Object dialog box. To modify the characteristics of an aligned 
object, select the object using the Design Explorer and choose Window>Edit Objects 
or double-click on the face name. See Edit Objects for more information.
The Display tab of the Edit Object window contains settings for Iso Lines and Silhouette. 
Display Iso Lines by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on the object. There are three Silhouette settings: 
Smart, Off and On.

Assembly Insert Tool

The Assembly Insert tool aligns and mates the faces of two solid objects. The align 
faces must be cylindrical and the mate faces must be planar. This tool is very useful for 
inserting bolts into holes. The left graphic shows two bolts and another solid. The right 
graphic shows the bolts inserted into the solid.

In the example, the bolt cylinder is aligned with the circular hole and its planar face 
mated with the planar face of the other solid though which the hole passes.

Using the Assembly Insert Tool
1. Select the Assembly Insert tool. The Message Line reads: Assembly 

Insert: Pick solid face to align.

2. Select the solid face to align.
The Message Line now reads: Assembly Insert: Pick solid face to align 
with.

3. Select the face of a different solid with which to align the first.
The Message Line reads: Assembly Insert: Pick solid face to mate.

4. Select the solid face to mate.
The Message Line now reads, Assembly Insert: Pick solid face to mate with.

5. Select the face of a different solid with which to align the first.
The first solid is now inserted into the second solid.
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6. To offset the first solid a certain distance from the second, enter a value in the Status 
Line data field and press ENTER (Windows) or RETURN (Macintosh).
The objects are offset the specified distance but are still co-planar.

The Status Line contains the Offset data field.

Geometric Characteristics
An inserted object is composed of two aligned and mated solids and includes an Offset 
value according to the Edit Object dialog box. To modify the characteristics of an 
inserted object, select the object using the Design Explorer and choose Window>Edit 
Objects or double-click on the face name. See Edit Objects for more information.
The Display tab of the Edit Object window contains settings for Iso Lines and Silhouette. 
Display Iso Lines by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on the object. There are three Silhouette settings: 
Smart, Off and On.
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Object Properties & Verification
Geometric Properties
The Verify menu gives access to a variety of commands that provide information about 
the file or about specific objects.

X, Y, Z Command
The XYZ command displays the model coordinate 
values of the selected point. A selected value may be 
edited and changed.

Angle 3 Points Command
The Angle 3 Points command calculates the angle formed 
by three chosen points.
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Distance Point-to-Point Command
The Distance Point-to-Point 
command calculates the distance 
between two points taken from the 
Drafting Assistant.

Minimum Distance Command
The Minimum Distance command 
calculates the smallest distance 
between two selected objects.
This command is useful for 
checking if two objects interfere 
with each other. It will calculate 
the minimum distance between 
any combination of curves, 
surfaces or solids.

Length Command
This Length command calculates the length of a line, spline, arc, circle, conic, surface or 
solid. In the case of surfaces and solids the command adds all edge lengths, providing a 
perimeter length value as shown in the graphic here.

Area Command
The Area command calculates the area of closed curves or a surface. These curves 
include basic objects such as circles and ellipses but also splines connected to create 
an enclosed area.
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Volume Command
The Volume command calculates the volume of a closed object.

Properties Command
The Properties command calculates a solid's volume, center of gravity, principle 
moments, or moments of inertia. 

The Properties dialog box includes the following sections:

Material This pull-down menu specifies a material type. 

The menu includes a wide range of materials, many in multiple 
varieties, including cast iron, lead, steel, aluminum, brass, 
copper, zinc, nickel, magnesium, titanium, wood, ceramic, 
aggregate, plastic, composite and liquids.

Custom materials may also be defined by editing the 
materials.ini file. See the Ashlar-Vellum Support Center 
Knowledgebase for details. Select one of these materials and 
the associated density displays in the Density field. Enter your 
own values for the User-defined material.
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Tech Note: The material selected here is set separately from material
hatching used for geometry in a section view. 
See Crosshatching for more information on crosshatching and Section View
Tools for more information on section views.

Interference Command
This command in the Verify menu checks the interface volume of two or more solids to 
determine an intersection or interference. If an interference is found the Interference 
Check Results dialog box appears:

Basic This section includes the volume, weight and density of the 
selected object. The density is based on the selected material.

Advanced This section includes the center of gravity, moments of inertia 
and axis information.

Create This section includes three check boxes: ASCII file, Point at 
C.G. and Pr. Axis Lines.

ASCII File - Clicking in the check box exports the information 
contained in this dialog box to an ASCII file. When clicking OK 
to close the Properties dialog box, the Save Document As 
window appears asking for a name and location for the ASCII 
file.

Point at C.G. - Clicking in this check box, places a point at the 
center of gravity for the selected object. Click OK to close the 
dialog box and a C. G. point appears. The style of the point is 
based on the selected style for the Point tool. See Point Tool 
for more information.

Pr. Axis Lines - Clicking in this check box, gives the axis 
direction vectors for the coordinate system where the products 
of inertia vanish.
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The dialog box contains the interference list window, the Keep Intersection Solids check 
box, and the Save, Print and Done buttons.

Using the Interference Command
1. Display the model as a wireframe.

2. Select the solids on which to perform the check.
3. Choose Verify>Interference.

If an interference is encountered, the Interference Check Results dialog box appears 
listing the interference and displaying the interference solids in black on the model.

4. To retain these interference solids in the model, check the Keep Intersection Solids 
box.

5. Click Save or Print to save or print the log of the interference solids.
6. Click Done to close the dialog box.

If the Keep Intersection Solids box is checked, the model displays the intersection 
solids.
Example:
The model here displays three intersecting solids.

By choosing Verify>Interference on these selected models (shown below in 
wireframe), the Interference Check Results dialog box appears and the interference 
solids are shown in black.

Interference Window This window lists the interference between the selected solids 
and includes Solid 1 and Solid 2 (the solids, names), 
Interference (the interference solid name), Volume (the volume 
of the interference solid), and the C.G. (the center of gravity for 
the interference solid at the x, y and z location).

Keep Intersection 
Solids

When checked, this option retains the intersection solids in the 
drawing.

Save Click this button to save the interference data to a log file which 
can be opened in any text editor.

Print Click this button to print the interference data.

Done Click this button to close the dialog box.
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If no interference is found the following dialog box appears.
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Object Counts Command
This command counts the number of objects in the 
current drawing.
For grouped objects, each individual object is 
counted as well as the group itself.

Check Object Command

The Check Object command examines an object for proper data structure and topology, 
and issues geometric warnings associated with ACIS data. This includes checks for 
curves, surfaces, and solids.   The tool is frequently used in conjunction with imported 
data created from non-ACIS kernels. Some of the many items checked include:
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Data Structure Checks 
• Entities have appropriate child-level entity, such as body has lump, face has edges, 

etc. 
• Presence (non-NULL) and closure of back pointer from child to parent, for example 

body's lump points to body. 
• The coedge on spline surface has pcurve. 
• Pcurve indexing (0/+-1/+-2) is appropriate. 
• The pcurve has non-NULL 2D B-spline curve. 
• If edge has non-NULL curve, then curve must have equation. 
Topological Checks 
• Loops must be closed in both the next and previous directions. 
• Apex edge loops are correct. 
• Coedge has a partner, except apex coedge. 
• All coedge partners point to same edge. 
• Sequential coedges share a vertex. 
• Edge is in exactly one of start and end vertex edge groups. For example, edge can be 

reached for 1 value of i using start()->edge(i)->coedge() and partner and next (or 
previous) pointers. 

Geometric Checks 
• Face gaps along shared edges and vertices.
• Entities with geometry must have non-NULL geometry. For example, a face points to 

a surface. 
• Analyzes a curve or surface for C1/G1 discontinuities.
• Self intersecting surfaces.
• Analytic surfaces have valid definitions. 
• Pcurve surface matches face surface (warning only if not equal since surface could 

be trimmed). 
• Pcurve forms agrees with curve form, such as closed, open, periodic. 
• Pcurve parameter period agrees with curve period. 
• Pcurve at points 0, 1/3, 2/3, and 1 way along curve must lie on the edge and tangent 

directions at these points must roughly agree, such as have positive dot product. This 
also tests the following: 

• Spline surface form is set correctly, such as surfaces closed in u report this. Checks 
the underlying 3D B-spline surface at 10 points along seam to verify form. 

• Coedge vertices do not lie on spline surface singularities. 
• Face normal is consistent with coedge direction.
• Start and end vertices of coedge lie on face.
• Edge lies on face. Checks at 10 points along edge.
• Start and end vertices lie on edge geometry. 
• Faces are ordered correctly around edge, according to sidedness. 
• Coedges are ordered correctly around edge, according to face curvature.
• Edge has same sense as curve (taking reverse bit into account).
• Checks curve has correct form. 
• Edge parameter range is good and agrees with start and end points. 
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• Check edge for bad approximation direction.
• D3 checks on intcurve (option that can be turned on).
• No two vertices have the same location. 
• Optional face/face intersection checking (option check_ff_int).
One or more objects may be selected with the Check Object command. A report is 
presented in the above dialog box. The dialog box has the following options:
• Save As: Saves the reported as an ASCII file.
• Repair: Attempts to repair any errors that were reported.
• Next Object: Step to the next item in the list.
• OK: Exit back to the program.

Surface Evaluation
Cobalt, Xenon and Argon all have methods to evaluate the smoothness of the surfaces. 
This is useful for identifying surface irregularities. The curvature evaluation is 
accomplished by placing the surface inside a brightly lit imaginary cylinder with 
longitudinal stripes. The cylinder stripes are reflected onto the surface to convey the 
surface smoothness. This is especially important when matching surfaces using the 
Match Surface tool. The graphics here show the surface evaluation for two matched 
surfaces using no surface matching (G0), G1 and G2 surface matching.

Notice how the bands of black differ from graphic to graphic. In the G0 Matched 
Surfaces graphic (no surface match), the right surface bands are parallel. In the G1 
Matched Surfaces graphic, the right surface bands are not as parallel showing that the 
surface was adjusted to match the left surface. In the G2 Matched Surface graphic, the 
right surface bands show how the surface has even further adjusted to match the left 
surface.
Evaluate the surfaces either through the Verify menu using the Surface Analysis 
commands or via the Display tab of the Edit Object window or through the Advanced 
Rendering feature.

G0 Matched Surfaces G1 Matched Surfaces G2 Matched Surfaces
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Evaluation Through the Verify Menu and Edit Object Window
The Surface Analysis commands quickly evaluate the smoothness of one or more 
surfaces. All analysis colors are preset with these commands. To define your own 
settings, use the surface evaluation shader through the Advanced Rendering feature. 
See Surface Evaluation further ahead in this chapter.
There are five surface 
analysis commands: 
Environment Map, 
Curvature, Draft Angle, 
Normals and Zebra. 
The same commands are 
available on the Display tab 
of Edit Object Window. 

Real-Time Environment Maps
Cobalt, Xenon and Argon feature real-time environment mapping in Verify menu and the 
Edit Objects window. 

Environment maps provide interactive feedback on surface aesthetics. They are used to 
interactively evaluate curved surfaces in real-time. A real-time environment map is a 
way to simulate the reflections seen while examining a reflective model.
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To use this feature: 
1. Select an object for examination.

2. Activate the Surface Analysis icon in the View palette.

3. Choose Verify>Surface Analysis>Environment Map or check the Environment 
Map option in the Edit Objects dialogue box on the Display tab. To edit the environ-
ment map, press the Edit button. The Environment Map Settings dialog box opens.

4. Choose any Shader Type and the corresponding attributes and values, then click 
OK.

5. When an object in the drawing area is selected and the Real-time Environment Map 
icon is clicked, one of the following Shader Types appear:

Wrapped Image The graphic on the right appears without an environment. The 
graphic on the left uses the real-time environment map to 
mirror an applied surrounding environment of a sun room.
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Plain Applies a plain color to the object. Choose the color from the 
drop down menu and use the sliders to modify the color.

Zebra Choose the Zebra thickness value and stripe orientation in the 
Attribute and Attribute Value fields. To make it easier to 
visualize the surface flow and transition between surfaces of 
tangent planes, use the Surface Match tool. After matching the 
planes the surfaces flow smoothly.
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Curvature Command
This command creates a curvature plot of the surface. 
Whether select the command from the Verify>Surface 
Analysis>Curvature Settings, or on Display tab of the Edit 
Object window press the Edit button the Curvature Plot 
Settings dialog box appears containing: Analysis Styles, 
Selected Only check box, Recalculate and Recalculate All 
buttons, Histogram, Color Spectrum and Histogram Data 
Fields.
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The dialog box contains the following elements:

Plot Style Contains the styles for the analysis and include: Gaussian, 
Mean, Min Radius and Max Radius. A description and 
illustration of each style is provided in the next section.

Selected Only Applies the settings only to selected objects.

Recalculate Updates the surface curvature analyses for the plot style 
selected.

Recalculate All Updates the surface curvature analyses for all the plot styles.

Histogram Represents the frequency of a curvature smoothness (change 
in a curve over the change in curvature) using the color 
spectrum. The length of the bar represents the frequency. The 
program calculates this histogram and displays it so that the 
entire graph fits into the dialog box area.

Color Spectrum Bar Displays the color spectrum used to create the histogram.

Histogram Data 
Fields

Displays the maximum and minimum values used to calculate 
the histogram. When initially selecting the command, the 
program scans the surface(s) and sets the minimum and 
maximum fields for curvature. If different values are entered in 
the fields so that a large number of curvature values fall 
outside of the specified range, a red line appears at the end(s) 
where the values fall. All values are still calculated even 
though they are not displayed due to the specified range. In the 
graphic here the large number of values fall outside the 
maximum value of 0.006.
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Tech Note: The Split Surface tool will not work with grouped surfaces.

Plot Styles
There are four curvature plot styles to choose from when selecting the Curvature 
command: Gaussian, Mean, Min Radius and Max Radius.

Making changes to the values, the program waits for two 
seconds of non-action before recalculating the histogram, 
giving time to change the values before the image is rendered 
again.

Return to the range initially displayed by clicking on the 
selected option again. (The option does not deselect when 
doing this.) Windows users can also reset the maximum and 
minimum values by clicking right mouse button near the 
respective end of the spectrum.

Gaussian Creates a Gaussian curvature plot on the selected surface. 
The plot registers the change in a curve over the change in 
curvature. Mathematically, the Gaussian value is the product of 
the kmin (minimum radius curvature) and kmax (maximum 
radius curvature) of each vertex. (The letter “k” refers to the 
curvature.) Any sharp change in color represents a 
discontinuity.
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Mean Creates a mean curvature plot. Mathematically, the mean 
value is the average of the kmin (minimum radius curvature) 
and kmax (maximum radius curvature) of each vertex. (The 
letter “k” refers to the curvature.) The graphic here is an 
example.

Min Radius Creates minimum radius curvature plot. Mathematically, the 
plot is the kmin values (minimum radius curvature) of each 
vertex. (The letter “k” refers to the curvature.) The graphic here 
is an example. 
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Max Radius Creates maximum radius curvature plot. Mathematically, the 
plot is the kmax value (maximum radius curvature) of each 
vertex. (The letter “k” refers to the curvature.) The graphic here 
is an example. 
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Using a Curvature Surface Analysis Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Curvature Settings or double click the object to 
open the Edit Object window, click on the Display tab and press the Edit button.
The dialog box displays with the analysis. The geometry also displays the analysis.

3. Select a Plot Style if the desired style is not already selected.
A new curvature analysis appears.

4. To display a certain analysis/color area, place the pointer at the location over the 
color spectrum and click the mouse. 

Notice that a triangular indicator appears at the selected location and the related color 
highlights in the histogram. The same color highlights in black on the surface.

5. To remove the triangular indicator, click in the dialog box outside of the color spec-
trum bar.

6. Change the histogram values in the data fields and press the Recalculate button to 
update the surface curvature analyses for the plot style selected, or press the 
Recalculate All button to update the surface curvature analyses for all the plot styles 
along with the histogram and analysis.
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Draft Angle
This command evaluates the drafts of an object for molding 
purposes. When selecting this command the Draft Angle 
dialog box appears. It is accessible through Verify>Surface 
Analysis>Draft Angle Settings or by checking the option 
on the Display tab of the Edit Object window and pressing 
the Edit button. When selecting this command the Draft 
Angle dialog box appears.

The dialog box contains the following elements:

Selected Only Specifies whether to apply the settings only to the selected 
objects.

Recalculate Updates the surface analyses.

Recalculate All Updates the surface analyses.

Histogram Represents the frequency of a draft angle using the color 
spectrum. The length of the bar represents the frequency.

The program calculates this histogram and displays it so that 
the entire graph fits into the dialog box area.

Color Spectrum Bar The section displays the color spectrum used to create the 
histogram.

Histogram Data 
Fields

Display the maximum and minimum values used to calculate 
the histogram. When initially selecting the command the 
program scans the surface(s) and sets the min and max fields 
for the draft angle analysis.

When entering different values in the fields, so that a large 
number of values fall outside of the specified range, a red line 
appears at the end(s) where the values fall. All values are still 
calculated even though they are not displayed due to the 
specified range.

Making changes to the values, the program waits for two 
seconds of non-action before recalculating the histogram, 
giving time to change the values before the image is rendered 
again.

Return to the range initially displayed by clicking on the 
selected option again. (The option does not deselect when 
doing this.) Windows users can also reset the maximum and 
minimum values by right mouse clicking near the respective 
end of the spectrum.
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Tech Tip: The draft angle analysis is based on the relative angle between the
normal to the surface and the normal to the current work plane.

Using the Draft Angle Command
1. Select the object.

2. Choose Verify>Surface Analysis>Draft Angle or check the option on the Display 
page of the Edit Object dialog box and click the Edit button.
The dialog box displays with the analysis. The geometry also displays the analysis.

3. To display a certain analysis/color area place the pointer at the location over the 
color spectrum and click the mouse. 
A triangular indicator appears at the selected location and the related color highlights 
in the histogram. The same color highlights in black on the surface.

4. To remove the triangular indicator click in the dialog box outside of the color spec-
trum bar.

5. Change the histogram values in the data fields and the histogram and analysis auto-
matically recalculates.

Normals
This command creates a normals plot of the 
surface. When selecting the command the 
Normal Plot Settings dialog box appears.

The dialog box contains the following 
elements:

Number of Stripes Specifies the number stripes that appear on the surface.

Stripe Direction Provides three direction options: X-Axis, Y-Axis and Z-Axis.

Colors Specifies the Stripe Color option and swatch, Background 
Color option and swatch; the color pull-down menu and RGB 
data fields and sliders.

Stripe Color option: sets the stripe color from the color pull-
down menu or the RGB fields.

Background Color option: sets the surface background color 
from the color pull-down menu or the RGB fields.
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This graphic shows an example of a normal surface analysis.

Using the Normal Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Normals.
The dialog box displays with the analysis. The geometry also displays the analysis.

Zebra
This command creates a zebra plot of the 
surface. When selecting the command the 
Zebra Plot Settings dialog box appears.

The dialog box contains the following 
elements:

Number of Stripes Specifies the number stripes that appear on the surface.

Stripe Direction Provides three direction options: X-Axis, Y-Axis and Z-Axis.

Colors Specifies the Stripe Color option and swatch, Background 
Color option and swatch, the color pull-down menu, and RGB 
data fields and sliders.

Stripe Color option: Sets the stripe color from the color pull-
down menu or the RGB fields.

Background Color option: Sets the surface color from the color 
pull-down menu or the RGB fields.
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This graphic shows an example of a zebra surface analysis.

Using the Zebra Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Zebra.
The dialog box displays with the analysis. The geometry also displays the analysis.

Surface Evaluation Through the Advanced Rendering Feature
It is possible to evaluate the surfaces using user-defined attributes through the 
Advanced Rendering feature.
1. Select the surface.

The surface must have a material applied to it.
2. Double-click on the surface to display the Edit Objects dialog box.
3. On the Material page of Edit Objects dialog box, click the Advanced button.
4. From the Color class choose the surface evaluation type. The following window dis-

plays:
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The following list of attributes is available:

5. Specify the value for each attribute.
6. Click the Update button to preview the surface evaluation in the preview window.

Select the Auto option to make the preview window automatically update each time an 
attribute is changed.
Select the Scene Preview option to view material setting changes in real time.

7. Click OK to save the changes and close the dialog box.
Close the Edit Objects dialog box to have a clean screen when rendering.

8. Render the scene using one of the photorealistic commands in the PhotoRender 
menu.
The rendered scene shows the surface evaluation.

Draft Evaluation 
This Designer Elements program can evaluate the drafts of an object for molding 
purposes. This feature is available through the Verify menu, the Advanced Rendering 
capabilities and on Display tab of the Edit Objects window.

base color Sets the base color of the cylinder used for the evaluation. This 
color is reflected onto the surface. If the surface color is dark 
and the base color is white, there will not be much change to 
the surface color when rendered.

band color Sets the band or stripe color for the cylinder. This color is also 
reflected onto the surface. Use a color that is clearly visible to 
create the surface evaluation.

center Sets the center of the evaluation cylinder. Click the desired 
location in the drawing and the numbers automatically enter 
into the X, Y and Z data fields.

axis Specifies the cylinder axis (0 = X axis, 1 = Y axis, 2 = Z axis).

radius Sets the cylinder radius.

bands Sets the total number of bands around the evaluation cylinder.

coverage This attribute sets the ratio of the area covered by the bands to 
the area not covered (displaying the base color). Entering a 
zero displays only the base color. Entering a one displays only 
the band color.

fuzz Controls the fuzziness of the band (0 = sharp band edges, 1 = 
fuzzy band edges).

minimum angle This attributes controls the angle of the normal along the 
cylinder axis that defines the length of the cylinder and thus the 
reflection on the surface. Smaller values create longer 
cylinders.

scale Controls the overall scale of the pattern produced and 
accurately accounts for changes to the scale at which the 
geometry is modeled.
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Draft Evaluation Through the Verify Menu or Edit Object Window
The Draft Angle in the Verify 
menu or on the Display page of 
the Edit Object window quickly 
evaluates the draft angles of a 
model.
All analysis colors are preset with 
this commands. To define custom 
settings, use the draft evaluation 
shader through the Advanced 
Rendering feature. 

This command evaluates the drafts of an object.
The dialog box contains the following elements:

Selected Only Applies the settings only to selected objects.

Histogram Represents the frequency of a draft angle using the color 
spectrum. The length of the bar represents the frequency.

The program calculates this histogram and displays it so that 
the entire graph fits into the dialog box area.

Color Spectrum Bar Displays the color septum used to create the histogram.

Histogram Data 
Fields

Display the maximum and minimum values used to calculate 
the histogram. When initially selecting the command, the 
program scans the surface(s) and sets the min and max fields 
for the draft angle analysis.

If different values are entered in the fields so that a large 
number of values fall outside of the specified range, a red line 
appears at the end(s) where the values fall. All values are still 
calculated, even though they are not displayed due to the 
specified range.
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The graphic here is an example of a draft angle analysis.

If changes are made to the values, the program waits for two 
seconds of non-action before recalculating the histogram, 
giving time to change the values before the image is rendered 
again.

Return to the range initially displayed by clicking on the 
selected option again. (The option does not deselect when 
finished.) Windows users can also reset the maximum and 
minimum values by right mouse clicking near the respective 
end of the spectrum.
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Using the Draft Angle Command
1. Select the object.

2. Choose Verify>Surface Analysis>Draft Angle or double click the object to open 
the Edit Object dialog box, check the option on the Display page and click the Edit 
button.
The dialog box displays with the analysis. The geometry also displays the analysis.

3. To display a certain analysis/color area, place the pointer at the location over the 
color spectrum and click the mouse.

Notice that a triangular indicator appears at the selected location and the related color 
highlights in the histogram. The same color highlights in black on the object.

4. To remove the triangular indicator click in the dialog box outside of the color spec-
trum bar.

5. Change the histogram values in the data fields and the histogram and analysis auto-
matically recalculates.

Draft Evaluation Through Advanced Rendering 
Using the Advanced Rendering feature, it is possible to specify custom draft angle 
settings. When displaying the Render Material Settings dialog box, choose the draft 
angle evaluation type and the options appear.
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The draft angle evaluation type contains the following attributes:

In the graphic below, depending upon whether you are viewing it in black and white or 
color, the pass color areas are blue or medium gray, the overhang color areas are black 
and the warning color areas are green or light gray.

Using the Draft Evaluation Feature
1. Double click on the object to be evaluated to display the Edit Objects dialog box.

A material must already have been placed on the object.
2. Click the Advanced button to display the Render Material Settings dialog box.
3. Select draft angle evaluation from the Shader Types list.
4. Specify the settings for the attributes.
5. Click OK to close the dialog box and save the settings.
6. Render the object using one of the photo-realistic commands.

The object displays using the specified draft evaluation colors and values.

pull direction Specifies the direction the object is pulled from the mold. Enter 
the values for the pull direction or drag in the drawing area to 
have the values automatically entered. The asterisk next to the 
dX, dY and dZ names indicate this ability.

draft angle Specifies the draft angle required to pull the object out. This 
angle is usually 1°. Entering a 0 results in the fail color zone 
disappearing when the scene is rendered.

tolerance angle Specifies the degree of tolerance added to the draft angle that 
still allows the object to be pulled from a mold but with difficulty. 
Entering a 0 results in the warning color zone disappearing.

pass color Specifies the color of the object for those areas where the draft 
angles are satisfactory. The surface normals fall between 90°+ 
draft angle + tolerance angle and 180° with the pull direction.

warning color Specifies the color that appears on the object when the surface 
normals fall between 90°+ draft angle and 90°+ draft angle + 
tolerance angle.

fail color Specifies the color of the object in those areas where the 
object cannot be pulled from the mold. The surface normals fall 
between 90° and 90°+ draft angle.

overhang color Specifies the color that appears for any part of the mold 
overhanging the object. An overhang on the mold prevents the 
object from being pulled from the mold.
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Mesh Creation Tools 

A mesh is a collection of planar elements typically with three or four sides. It is 
equivalent to the 3D Mesh element found in DXF files.
Use meshes to model bodies that span areas and for calculating wetted areas and 
volume attributes. Although less accurate than surface modeling, mesh modeling uses 
less memory, and still provides considerable flexibility for those who prefer to design 
only with cross sections. 
Unlike a surface, a mesh object is not defined by a mathematical formula but by nodes 
and 3D vertices. The resolution or precision of a mesh is determined by the number of 
vertices.
A mesh object can be used to create output for rapid prototyping machines and for 
compatibility with programs that can only read meshes out of AutoCAD DXF and DWG 
files. A mesh object is helpful to people who want to control the exact number of facets 
created for each model.
Of the mesh tools available in the Designer Elements program, the Ruled Mesh tool is 
the most powerful. This tool creates sections and “skins” them together to obtain areas. 
Skins can be combined into bodies to calculate body area curves. Calculations of the 
area underneath the curve also yield the body’s volume.
Values for each tool can be entered in the Status Line to define a mesh, either before or 
after creating the mesh. If the values are entered after selecting the tool but before 
creating the mesh, the first click in the drawing area automatically registers all Status 
Line values. If you enter values in the selected Status Line data field after creating the 
mesh and while the mesh is still selected, pressing ENTER (Windows) or RETURN 
(Macintosh) updates the mesh to reflect the new values.
All three of the Designer Elements programs support four tools for creating mesh 
objects, 3-point Mesh, 4-point Mesh, Ruled Mesh and Extrude Mesh. The topics 
explained in this chapter include: 
• 3-point Mesh Tool
• 4-point Mesh Tool
• Ruled Mesh Tool
• Extrude Mesh Tool
• Mesh and Rendering
• Mesh Notations
To access the Mesh tools go to Window>Mesh.
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3-point Mesh Tool

The 3-point Mesh tool creates a flat plate triangular object from 
three selected points.

Using the 3-point Mesh Tool
1. Select the tool. The Message Line reads: 3-point Mesh: Enter 3 locations for mesh.

To create the mesh in a plane different than the one currently set, change the plane 
before moving on to the next step.

2. Click three points to define the mesh boundary.
The mesh is created.

There are no entries in the Status Line.

Tech Note: To select a mesh object immediately after creating it, choose the
Selection tool. Otherwise, new mesh objects will continue being created.

Geometric Characteristics
A three-point mesh is created by picking the three desired points. A mesh is made up of 
the following characteristic according to the Edit Objects dialog box: the Defining Point 
for the X, Y and Z location.
Defining Point refers to the X, Y and Z location of the chosen point. The section below 
Defining Points lists the points with the X, Y and Z location. The selected point is 
displayed in the Defining Point fields. Each point can be edited individually using these 
fields.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or double-
click on the mesh.

4-point Mesh Tool

The 4-point Mesh tool creates a flat plate quadrangular object 
from four selected points.

Using the 4-point Mesh Tool
1. Select the tool. The Message Line reads: 4-point Mesh: Enter 4 locations for mesh.

To create the mesh in a plane different than the one currently set, change the plane 
before moving on to the next step.

2. Click four points to define the mesh boundary. 
The mesh is created.

There are no entries in the Status Line.
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Geometric Characteristics
A four point mesh is created by picking the four desired points. A mesh is made up of the 
following characteristics according to the Edit Objects dialog box: the Defining Point for 
the X, Y and Z location.
Defining Point refers to the X, Y and Z location of the chosen point. The section below 
Defining Points lists the points with the X, Y and Z location. The selected point is 
displayed in the Defining Point fields. Each point can be edited individually using these 
fields.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or double-
click on the mesh.

Ruled Mesh Tool

The Ruled Mesh tool creates an M by N 
mesh from a collection of curves. M is the 
number of curves selected to define the 
mesh boundary. The mesh is created from 
the order in which they are selected. N is 
number of segment lines displayed on the 
mesh. The graphic above shows a mesh 
curve with M = 4 (curves) and N = 20 (grid lines).
The Ruled Mesh tool provides several options 
that control mesh spacing. Pick them from the 
drop down list in the Message Line. 

The options include:

Using the Mesh Curve Tool
1. Select the tool. The Message Line reads: Ruled Mesh: Select curves in order of 

meshing [Shift=Extend].

2. Select a mesh spacing option from the pull-down menu.
3. The Status Line displays the N data field which represents the number of mesh seg-

ments lines that will be distributed across the mesh.

If a different number of segments is necessary, enter the new value in the data field. 
The default value is 25.

Equal Distance Mesh points are spaced equally.

Half Cosine (Fwd) Mesh points are spaced more closely at the forward end of the 
mesh, according to a half cosine.

Half Cosine (Aft) Mesh points are spaced more closely at the back end of the 
mesh, according to a half cosine.

Full Cosine Mesh points are spaced more closely at both ends of the 
mesh, according to a full cosine.
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4. Click two or more curves to define the mesh boundary. These curves should not be 
connected. To select more than two curves, hold down the SHIFT key before select-
ing the first curve. 
Select the curves in the order that the mesh is created.

Geometric Characteristics
A ruled mesh is created by selecting the desired curves. A mesh curve is made up of the 
following characteristics according to the Edit Objects dialog box: the Distribution setting 
(Equal, Half Cosine (Forward), Half Cosine (Aft) or Full Cosine) and Segments (N) 
which make up the mesh.
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or double-
click on the mesh.

Extrude Mesh Tool

The Mesh Extrude tool sweeps a 
collection of curves along a vector, 
creating N mesh segments.

Using the Extrude Mesh Tool
1. Select the tool. The Message Line reads: Extrude Mesh: Select objects to extrude 

[Shift=Extend].

2. The Status Line displays data fields to enter the delta values for the extrusion and 
the number of N segments for the mesh.

3. Click one or more curves to sweep. To select more than one curve, hold down the 
SHIFT key before selecting the first curve.

4. To enter a different value for the N segments than currently listed, select the field 
and type the new value. After the curves are selected, The Message Line reads: 
Extrude Mesh: Enter two points to extrude.

5. Click two points to set the direction and the distance of the extrusion. The points do 
not have to be on the selected curves.
The mesh is created.

To modify the mesh while it's still selected, type the value in the appropriate field tabbing 
between fields as necessary. Press ENTER (Windows) or RETURN (Macintosh) and the 
mesh curve will be modified.

Geometric Characteristics
An extruded mesh is created by selecting the desired curves and the extrusion values 
that define the distance and direction. An extruded mesh is made up of the following 
characteristics according to the Edit Objects dialog box: Vertex Count, Facet Count and 
Segments. This information is listed in the Edit Objects dialog box under the Geometry 
tab. To display the dialog box, select the mesh and choose Window>Edit Objects or 
double-click on the mesh.
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Mesh and Rendering
Mesh is displayed according to the Static Render setting in the Rendering Option dialog 
box. It is possible to display the mesh as Wireframe, Flat, Gouraud, Gouraud w/Edges, 
Phong, Phong w/Edges, Hidden and Hidden with Dimmed. See “Shade Options” for an 
explanation of these options.

Mesh Notations
The following notations will be helpful as for creating mesh objects.
• Mesh objects are not surfaces. They are defined by nodes or 3D vertices.
• Since mesh objects are not surfaces, the Surface Editing tools, contained in the third 

set of tools within the Surface tool palette, cannot be used.
• It is possible to convert surfaces and solids into meshes and convert a closed mesh 

back into a solid.
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Text
To add some basic annotations to the drawing, use one of the text tools. The text can be 
created and edited. Use the Text menu to set the characteristics such as font, text size, 
case and alignment. The topics discussed in this chapter include:
• Text Tools
• Text Commands
• Text Handling

Text Tools

Cobalt, Xenon and Argon three tools for creating text: Horizontal Text, Text Along a 
Curve and Text at an Angle. The text tools in these programs do not use text boxes. 
Simply click the cursor at the location where the text will begin and start typing. Press 
ENTER (Windows) or RETURN (Macintosh) to end one text object and begin another. 
These text objects move independently.

Horizontal Text Tool

The Horizontal Text tool creates horizontal text at the specified location. 

Using the Horizontal Text Tool
1. Select the Horizontal Text tool from the main tool palette. The Message Line reads: 

Enter location for text. [Press Mouse to End]

2. Place the cursor at the beginning location for the text and click. The cursor becomes 
a text cursor.

3. Enter the desired text. Press ENTER (Windows) or RETURN (Macintosh), to begin 
a new and separate line of text that is aligned left with the previous line.

Since this is a separate text line it can be moved independently.
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Text Along a Curve Tool

The Text Along a Curve tool creates text along the specified curve.

Tech Note: This tool may not support all of the system’s fonts. True Type
fonts that don’t form closed polygons are not supported.

Using the Text Along a Curve Tool
1. Create the curve along which the text will appear, placing the points in the order that 

the text will be placed. For a horizontal line created left to right, the text appears left 
to right. For a vertical line created top to bottom, the text appears top to bottom.

2. Select the Text Along a Curve tool from the main tool palette. The Message Line 
reads: Select path for text. [Shift=Extend]

3. Select the just created curve. The cursor becomes a text cursor placed at the start 
point of the curve.

4. Enter the desired text. It displays horizontally.

5. Press ENTER (Windows) or RETURN (Macin-
tosh) and the text line molds to the curve.

A parent/child relationship exists between the curve 
and the text. Any change made to the curve affects 
the text. Select any curve control point and drag it to a new location and the text 
updates.
If the curve is not long enough for the text, extend the curve by selecting a curve 
endpoint and dragging it to a new location.
This tool only supports one line of text per curve. The text can not be moved 
independently of the curve. To hide the curve with the text, change the curve color to 
blend with the background or place the curve on the construction layer. Then it still will 
be possible to edit the text appearance on screen by editing the curve.

Text at an Angle Tool

The Text at an Angle tool creates text at the angle and specified location.

Tip: If the angle is entered in the Status Line after typing the text, hit ENTER
(Windows) or RETURN (Macintosh) twice. The first time registers the values
and the second changes the text angle to the new angle.

1. Select the Text at an Angle tool from the main tool palette. The Message Line 
reads: Enter location for text.

2. In the Status Line, enter the angle for the text in the Angle data field. Press ENTER 
(Windows) or RETURN (Macintosh) to register the value.
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3. Place the cursor at the beginning location for the text and click. The cursor becomes 
a text cursor.

4. Enter the desired text. The text displays horizontally.
5. Press ENTER (Windows) or RETURN (Macintosh) and the text 

angle changes.

Geometric Characteristics
A text object is created by clicking the location of the start point of the text and typing the 
desired text. A text object is made up of the following characteristics according to the 
Edit Objects dialog box: Text and Angle. To display the dialog box, select the text and 
choose Window>Edit Objects or double-click on the text.

Bounded Box Text Tool

Bounded Box Text is defined by two diagonal points used to specify the width and height 
of a text box. Text is automatically wrapped to the width of the box. The text box also 
supports left, right and center justifications.
In addition, double click on the text to make edits directly on the screen. On screen 
editing supports cutting, pasting and copying into the text box. For example, copy a 
paragraph from Microsoft Word and paste it into a text box.

Text Commands
All Text commands are contained in the Text menu and include 
commands for changing the text font, size, style and case.

Font
This command in the Text menu changes 
the font for selected text or future text 
entries. 
The menu lists fonts installed on the 
computer and one Plotter font. Use the 
Plotter font whenever creating text for a 
drawing that is intended to be sent to a 
plotter, since plotting Postscript or TrueType 
fonts takes much more time and fonts may 
be substituted.
If text is selected and the font is changed, 
only the selected text is affected. If no text 
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is selected and the font is changed, this sets the default font for future entries until 
another font is chosen.
Special characters and accents are available as described in Appendix B.

Size
This command in the Text menu sets the font 
size for the selected text or for future text entries 
in the current document.
If text is selected and the size is changed, only 
the selected text is affected. If no text is selected 
and the text size is changed, the default size is 
set for future entries.
The size can be specified as either points (12 pt) 
or as units (.156 inches) as defined in the Units 
page of Preferences. If no unit is specified, the 
program picks the default unit.

Specifying a Non-standard Text Size as the 
Default Size
Choosing User from the Size submenu brings up 
a dialog box to specify the exact text size. 
Choose a point size or the units for the drawing. 
1. Choose Text>Size>User.

2.Select the size option, either Points or Units by clicking 
in the appropriate radio button.
3.Enter the size. 
Choose Model to measure in the current units as set in 
Units page of Preferences.
4.Click OK to accept the change and close the dialog box. 
Click Cancel to close the dialog box without accepting the 
changes.

The size specified stays in effect until another size is chosen. 

Style
This command in the Text menu sets the style (such as Bold or Underline) for selected 
text or future text entries.

The specified style stays in effect until another default style is chosen. A check indicates 
the current style.
To change the style of one text line, select the text and choose Text>Style and 
necessary option. This does not affect the default style setting.
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Case
Cobalt, Xenon and Argon all support three text cases: lower case, 
UPPER CASE and Title Caps.

Case cannot be set as a default setting like font, size and style. It simply changes the 
case of any selected text.

Using the Case Options
1. Select a text line.

2. Choose Text>lower case, UPPER CASE or Title Caps.
The text line changes to reflect the choice.

Tip: To change from UPPER CASE to Title Caps, first change the text to
lower case and then change the case to Title Caps.

Text Handling
It is possible to perform various operations on the text like editing, moving etc.

Editing Text
To edit created text, select the text 
line and choose Window>Edit 
Objects.
In the Text entry field, make any 
desired changes. Click Apply to 
accept the changes and then Close 
to exit the dialog box. Click Close 
without hitting Apply to close the box 
without making any changes.

Moving Text
To move text, choose the Selection 
tool, select the desired text and drag 
the text to a new location.

Screen Horizontal Text
As seen in the picture above, the Edit Objects dialog box contains a check box for 
keeping text horizontal to the screen. With the box checked, the text will stay horizontal 
to the screen when using the Trackball to rotate the drawing. With the box unchecked, 
the text will stay horizontal to the plane it was created on. For example, if text is created 
in the top view and the view is switched to the trimetric, text will appear as if it were lying 
flat.

lower case Displays text all in lower case letters.

UPPER CASE Displays text in upper case letters.

Title Caps Displays the first letter of each word in upper case and the 
remaining letters in lower case.
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Convert Text into Lines, Curves, Poligons.
It is possible to change the object type of the text.
1. After the text is typed, choose Select tool. 

2. Right click on the text and choose the Change Object 
Type option from the context menu. 
The Change Type dialog window appears. 

3. Choose the type to which to convert the text.
4. Uncheck the Delete Originals to leave the original 

text. In the picture below, the example on the left shows the result where original 
text was deleted, in the right example, the text was left. When the original text is not 
deleted, both the text and the new object can be selected and further edited with the 
Edit Object dialog..

5. Uncheck Use Work Layer box to be able to save the new object on any layer except 
the work layer.
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Dimensions
This chapter explains how to use the dimension tools in Cobalt, Xenon or Argon. The 

following topics are covered:
• Dimension Menu
• Dynamic Dimensions
• Dimension Tools
• Smart Dimension Tool
• Horizontal Dimension Tools
• Vertical Dimension Tools
• Oblique Dimension Tool
• Ordinate Dimension Tools
• Radial Arrow Out Dimension Tool
• Radial Arrow In Dimension Tool
• Diameter Arrow In Dimension Tool
• Diameter Arrow Out Dimension Tool
• Angular Dimension Tool
• Dimension Appearance
• Dimensions and Drawing Views

Dimension Menu
The Dimension menu contains commands for setting the format for dimensions. Before 
starting dimensioning, choose the Dimension tool from the Dimension tool palette.
Like the other tool palettes, the Dimension palette is a floating tool palette. Select 
dimension tools in the same way as tools from the main tool palette. A few of the tools 
have subpalettes with subtools and options for those tools.

Dynamic Dimensions
Cobalt and Xenon's geometric dimensions are dynamic—when a change to the 
dimension control points is made, the dimension text changes also. This is not true if the 
# symbol is overwritten in the data field or Edit Objects with a set value/text string.
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The dynamic nature of the dimension entities is a tremendous time saver in that not only 
do the numbers in the dimension update when the control points are moved, but the 
graphical characteristics will also change when a new dimension style is applied. The 
units can be changed from English to metric (in the Units page of Preferences) and 
every dimension on the drawing will reflect the change.
When extending a line by selecting the endpoint of the line and dragging it to a new 
position, the dimension changes also because the dimension has a control point at the 
same position of the line's endpoint. So when selecting the endpoint of the line the 
dimension control point is also selected.

Dimensions are dynamic relative to the points they measure. If the length of a line is 
changed using Edit Objects, the dimension will not update because the point was not 
changed. To correct the dimension, select the dimension’s vertex point and drag it to the 
new endpoint of the line.

Dimension Tools
The Dimensions palette is located in the 
standard tools palette.
These tools can be used to measure either an 
object or the area between objects. Once an 
object (or space) is dimensioned, the 
dimensions update when you make changes to 
the geometry are made (Cobalt and Xenon 
only).
Some of the dimensioning tools, such as the 
Horizontal and Vertical tools, require that two 
points be selected; others, such as the Radial 
and Diameter, require only one. The location 
and the status (on/off) of the Dimension palette 
is automatically saved when exiting the 
program.

Dimensions and the Work Plane
Dimensions appear in the current work plane 
of the active view. (They are defined by the 
coordinate system of the work plane at the time 
they are created.) Set the work plane to 
correspond to the view before beginning adding 
text or dimensions in a view. 
For example, if the current work 
plane is Top, dimensions appear 
parallel to the work plane regardless 
of the view. See the graphic here. 
All point-to-point dimensions are 
also placed parallel to the work 
plane. Working in the front plane and 
using the horizontal dimension tool, 
the dimension would be placed parallel to the front plane.
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Dimension Smart Pointer
The dimension pointer is a smart pointer with a hot spot—the dot shows which side of 
the object to select first.

If you select as indicated by the position of the dot and cross hair, the text appears 
above or to the right of the leader. Selecting in the opposite order, the text appears 
below or to the left of the leader.

Dimensioning Objects and Placement
1. Select the appropriate dimension tool.
2. Click the points to measure.

Dimensions automatically use the dimension pen style and current dimension text 
characteristics. To change the dimension pen color or weight, do so in the Dimension 
menu.

3. Move the dimension to a new location if it is not in the necessary location.

Moving the Dimension
After placing a dimension, it is possible to reposition it relative to the geometry. The 
steps differ depending on the tool. The dimension can be repositioned after it has been 
placed with the Selection tool.
1. Choose the Selection tool.

2. Place the Selection tool over the dimension text and it becomes the Move 
symbol.

3. Drag the dimension to the desired location.
To select more than one dimension drag a selection fence 
around them.

The text can also be repositioned along the dimension line 
by dragging it along the line.
For radial and diameter dimensions, reposition the dimension’s control point by dragging 
a selection fence around the tip of the dimension line arrow.

Dimension Status Line Fields
The Horizontal, Vertical, Parallel, Angular, Center Mark and Balloon Dimension tools 
each have Status Line fields associated with them.
The Status Line field, similar to the one below, appears when one of these dimensioning 
tools is selected. Those Status Lines that differ are noted with the tools.

The # symbol in the text field indicates that the dimension is the actual value of the 
object’s measurement. If this symbol is deleted, the dimension will no longer be 
associative (that is, it won’t update if the geometry it measures is changed).
It is also possible to add text before or after the # symbol which will display with the 
dimension text.

Geometric Characteristics
Dimension text is created automatically when an object is dimensioned and is made up 
of one characteristic according to Edit Objects, Text.

1.524
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Automatically Placing Dimensions on a Separate Layer
Cobalt, Xenon and Argon automatically create a Dimension layer. Dimensions 
automatically go on that layer except in the case of dimensions placed in drawing views. 
These drawing view dimensions go on the Sheet View layer. For more information see 
Drawing Views.
If the Dimension layer is accidently 
deleted, the program automatically 
recreates the layer if the file is 
closed and opened. If it is 
necessary to delete the Dimension 
layer and there are objects on it, 
the program displays the following 
warning.

Dimensions and Edit Objects
In the Edit Objects dialog box the text characteristic field includes a # symbol for all 
dimensions, which indicates the dimension is the actual value of the object's 
measurement. If the # symbol is deleted and another value is entered, the dimension is 
fixed and will not update if the units or the size of the geometry is changed. 
Some of the dimensioning tools, such as the Radial tools, add a letter in the text status 
box which appears in the dimension itself.
Text can be added before or after the # symbol. Enter parentheses to enclose the 
resulting dimension in parentheses (#), or enter # 2 Plcs to display the dimension 
followed by the text 2 Plcs. When including the # symbol, the measurement of the 
geometry is used as well as the added text.
Edit Objects also includes dimension characteristics including a Units data field. This 
field sets the units for a selected dimension to those in Preferences or another settings. 
This dimensions a part with mixed units. The graphic below shows an example of mixed 
units with the Edit Objects dialog box.
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Dimensioning Surfaces and Solids
Surfaces and solids can be dimensioned using the Horizontal, Vertical and Parallel 
dimension tools only. The Radial, Diameter and Angular Dimension tools can only be 
used for wireframe objects.

Smart Dimension Tool

This tool in the Dimension tool palette 
quickly places horizontal, vertical, 
radial and diameter dimensions with a 
single click. These dimensions are 
associative to the curves. As the curve 
is changed, the dimension 
automatically updates (Cobalt and 
Xenon only). This tool is especially 
useful for drawing views.

Using the Smart Dimension Option
1. Select the tool from the Dimension tool palette. The Message Line reads: Smart 

Dimension: Pick curve to dimension.

2. Select the curve.
The dimension appears. You can drag the dimension to a new location. Dimension 
and extension lines automatically redraw.

Horizontal Dimension Tools

These tools dimension objects or spaces horizontally or measure the distances between 
linear objects.

When selecting the Horizontal Dimension tools, a subpalette 
appears in the Message Line containing three options, Horizontal 
Dimension, Horizontal Base Line Dimension and Horizontal 
Chain Dimension.

Horizontal Dimension Option
This option dimensions objects or spaces 
horizontally. 

Using the Horizontal Dimension Option
1. Select the Horizontal Dimension option. Choose the Horizontal 

Dimension tool from the Message Line. The Message Line 
reads: Horizontal: Pick first dimension point.

2. Click the left point of the geometry. 
The Message Line now reads, Horizontal: Pick next dimension point.

.797
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3. Click the right point. 
The dimension appears. Drag it as necessary to a new location. Dimension and 
extension lines automatically redraw.
Click the points in the opposite order to display the dimension below the objects.

Horizontal Base Line Dimension Option

This tool dimensions objects or spaces from a base 
point.

Using the Horizontal Base Line Dimension 
Option
1. Select the Horizontal Dimension tools. Choose 

the Horizontal Base Line Dimension option. The 
Message Line reads: Horizontal Base Line: Pick 
first dimension point.

2. Click the base point of the geometry. 
The Message Line now reads, Horizontal Base Line: Pick next dimension point.

3. Click the point. The dimension appears.
4. Click the next place for the dimension. This dimension appears above the first mea-

sured from the base point. Continue clicking the points to dimension. Each dimen-
sion can dragged to a new location. Dimension and extension lines automatically 
redraw.
Click the points in the opposite order to display the dimension below the objects.

Horizontal Chain Dimension Option

This option dimensions objects or spaces from end 
to end, horizontally. 

Using the Horizontal Chain Dimension Option
1. Select the Horizontal Dimension tools. Choose the Horizontal Chain Dimension 

option. The Message Line reads: Horizontal Chain: Pick first dimension point.

2. Click the first point on the geometry. 
The Message Line now reads, Horizontal Chain: Pick next dimension point.

3. Click the point. The dimension appears.
4. Click the next place for the dimension. This dimension appears measured from the 

last point clicked. Continue clicking all the points to be dimensioned. Each dimen-
sion can be dragged to a new location. Dimension and extension lines automatically 
redraw.
Click the points in the opposite order to display the dimension below the objects.

Vertical Dimension Tools

These tools measure an object or the vertical space or the distance 
between vertical objects. When the Vertical Dimension tools are 
selected, a subpalette appears in the Message Line containing 
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three options: Vertical Dimension, Vertical Base Line Dimension and Vertical Chain 
Dimension.

Vertical Dimension Tools

This tool dimensions an object or space vertically.

Using the Vertical Dimension Tools
1. Select the Vertical Dimension tool. The Message Line reads: Vertical: Pick first 

dimension point.

2. Click the top point of the geometry first.
The Message Line now reads, Vertical: Pick next dimension point.

3. Click the bottom point. 
The dimension appears. Drag it to a new location. Dimension and extension lines 
automatically redraw.
Click the points in the opposite order to display the dimension below the objects.

Vertical Base Line Dimension Option

This tool dimensions objects or spaces from a base point.

Using the Vertical Base Line Dimension Option
1. Select the Vertical Dimension tools. Choose the Verti-

cal Base Line Dimension tool. The Message Line 
reads: Vertical Base Line: Pick first dimension point.

2. Click the base point of the geometry. 
The Message Line now reads, Vertical Base Line: Pick next dimension point.

3. Click the point. The dimension appears.
4. Click the next place for the dimension. This dimension appears to the right of the 

first measured from the base point. Continue clicking all the points to be dimen-
sioned. Each dimension can be dragged to a new location. Dimension and exten-
sion lines automatically redraw.
Click the points in the opposite order if to display the dimension below the objects.

Vertical Chain Dimension Option

This tool dimensions objects or spaces from end to end, 
vertically.

Using Vertical Chain Dimension Tool
1. Select the Vertical Dimension tools. Choose the Verti-

cal Chain Dimension tool. The Message Line reads: 
Vertical Chain: Pick first dimension point.

2. Click the first point on the geometry. 
The Message Line now reads, Vertical Chain: Pick next dimension point.

4.000
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3. Click the point. The dimension appears.
4. Click the next place for the dimension. This dimension appears measured from the 

last point clicked. Continue clicking all the points to be dimensioned. Each dimen-
sion can be dragged to a new location. Dimension and extension lines automatically 
redraw.
Click the points in the opposite order to display the dimension below the objects.

Oblique Dimension Tool

This tool measures space or objects parallel or point to point.

Using the Oblique Dimension Tool
1. Select the Oblique Dimension tool. The Message Line reads: Oblique: Pick first 

dimension point.

2. Click the left point of the geometry first.
The Message Line now reads, Oblique: Pick next dimension point.

3. Click the right point.
The dimension appears. It can be dragged to a new location. Dimension and 
extension lines automatically redraw.
Click the points in the opposite order to display the dimension below the objects.

Ordinate Dimension Tools

This tool dimensions objects or spaces from a 
base point. When the Ordinate Dimension Tool 
is selected, a subpalette appears in the message 
line with two options: Horizontal Ordinate 
Dimension and Vertical Ordinate Dimension. 
Use the Selection tool to move, position or create 
an elbow ordinate.

Horizontal Ordinate Dimension Option
This option adds dimensions horizontally along a baseline.

Using the Horizontal Ordinate Dimension Tool
1. Select the Horizontal Ordinate Dimension option from the Message Line. The 

Message Line reads: Horizontal Ordinate: Pick first dimension point.

2. Click the base point of the geometry. 
The Message Line now reads, Horizontal Ordinate: Pick second dimension point.

3. Click the next point. The dimension appears, measured from the base point.
4. Click the next point for the dimension. This dimension appears measured from the 

base point. Continue clicking all the points to be dimensioned. To display a dimen-
sion at the base point, click the base point after dimensioning all other points.
Drag each dimension to a new location. Dimension and extension lines automatically 
redraw.
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Vertical Ordinate Dimension Option
This option adds dimensions vertically along a line.

Using the Vertical Ordinate Dimension Option
1. Select the Horizontal Ordinate Dimension option. The 

Message Line reads: Vertical Ordinate: Pick first dimen-
sion point.

2. Click the base point of the geometry. 
The Message Line now reads, Vertical Ordinate: Pick 
second dimension point.

3. Click the next point. The dimension appears, measured 
from the base point.

4. Click the next point for the dimension. This dimension appears measured from the 
base point. Continue clicking all the points to be dimensioned. To display a dimen-
sion at the base point, click the base point after dimensioning all other points.
Each dimension can be dragged to a new location. Dimension and extension lines 
automatically redraw.

Radial Arrow Out Dimension Tool

This tool measures the radius of a circle, arc, or fillet with the 
arrow on the side of the arc indicated when the arc is picked.

Using the Radial Arrow Out Dimension Tool
1. Select the Radial Arrow Out Dimension tool. The Message Line reads: Radial 

Arrow Out: Select arc/circle.

2. Click near the circle, arc or fillet to be to dimensioned.
The dimension is placed on the outside of the selected object. When the dimension 
appears, the leader line is placed at the nearest 15° increment from the clicked 
location. Move the dimension by choosing the Selection tool, selecting the 
dimension, placing the pointer over the end of the leader line, and when the pointer 
becomes the Move symbol, dragging the text to a new location.

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. This tool 
can be used only on curves, not surfaces or solids.

Radial Arrow In Dimension Tool

This tool measures the radius of a circle, arc, or fillet with the 
arrow inside the geometry.

Using the Radial Arrow In Dimension Tool
1. Select the Radial Arrow In Dimension tool. The Message Line reads: Radial Arrow 

In: Select arc/circle.
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2. Click near the circle, arc or fillet to be dimensioned.
The dimension text appears inside the object. The arrow line starts from the arc 
center. When the dimension appears, the leader line is placed at the nearest 15° 
increment from the clicked location. Move the dimension by choosing the Selection 
tool, selecting the dimension, placing the pointer over the end of the leader line, and 
when the pointer becomes the Move symbol, dragging the text to a new location. 

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. This tool 
can be used only on curves, not surfaces or solids.

Diameter Arrow In Dimension Tool

This tool measures the diameter of a circle.

Using the Diameter Arrow In Dimension Tool
1. Select the Diameter Arrow In Dimension tool. The Message Line reads: Diameter 

Arrow In: Select arc/circle.

2. Click near the circle or arc to dimension.
The dimension appears inside the object (depending on the circle and font size). 
When the dimension leader line is placed at the nearest 15° increment from the 
clicked location. Move the dimension by choosing the Selection tool, selecting the 
dimension, placing the pointer over the end of the leader line, and when the pointer 
becomes the Move symbol, dragging the text to a new location.

For 3D geometry, diametric dimensions are created in the plane of the circle. This tool 
can be used only on curves, not surfaces or solids.

Diameter Arrow Out Dimension Tool

This tool measures the diameter of a circle. 

Using the Diameter Arrow Out Dimension Tool
1. Select the Diameter Arrow Out Dimension tool. The 

Message Line reads: Diameter Arrow Out: Select arc/circle.

2. Click near the circle or arc to dimension.
The dimension appears outside the object. When the dimension appears the leader 
line is placed at the nearest 15° increment from the clicked location. The dimension 
can be moved by choosing the Selection tool, selecting the dimension, placing the 
pointer over the end of the leader line, and when the pointer becomes the Move 
symbol, dragging the text to a new location.

For 3D geometry, diametric dimensions are created in the plane of the circle. This tool 
can be used only on curves, not surfaces or solids.

Ø.838

Ø .838
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Angular Dimension Tool

This tool measures the angle between two lines.

Using the Angular Dimension Tool
1. Select the Angular Dimension tool. The Message Line reads: Angular: Pick first 

line.

2. Click on the first line near the endpoint from which the angle will be measured.
The Message Line now reads, Angular: Pick second line.

3. Click on the second line.
The inside angle is measured between the lines. The program always measures the 
smaller angle between the selected lines.

Dimensioning intersecting lines don’t confuse the 
intersection with the midpoint of the lines.
The Angular Dimension tool will not dimension 
angles over 180°. For 3D geometry, Angular 
dimensions are created in the plane of the two 
lines. This tool can only be used on curves not 
surfaces or solids.

Center Mark Dimension Tool

This tool creates a center line mark for circles and arcs. The center 
mark overlap can be defined in the Status Line or the Edit Objects dialog 
box. The overlap units are based on those in the Units page of Preferences.

Using the Center Mark Dimension Tool
1. Select the Center Mark Dimension tool. The Message Line reads: Center Mark: 

Select circle for center mark [Shift = Extend].

2. Select the circle or arc to dimension. Hold down the SHIFT key if to dimension more 
than one object at the same time.
The Axis overlap value can be changed in the Status Line. Type the value and press 
ENTER (Windows) or RETURN (Macintosh) and the overlap updates.
The Status Line contains the Axis overlap data field.

45

midpoints

intersection

To dimension this angle...

...you have to click here
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Balloon Dimension Tools

These tools dimension objects with a callout balloons. 
There are nine balloon options available in the 
Message Line: Circle, Rectangle, Triangle, Inverted 
Triangle, Octagon, Ob-round, Split Circle, Split 
Rectangle and Callout.

Use the Status Line or the Edit Objects dialog box to change the text or width of the 
balloon dimension. The width units are based on those set in the Units page of 
Preferences.

Using a Balloon Dimension Tools
1. Select the Balloon Dimension tools. 

2. Select the desired balloon shape. The Message Line reads: Balloon: Enter 2 points 
for balloon dimension.

3. Click the point on the geometry for the dimension arrow.
4. Click the second point to specify the location of the symbol.

The balloon symbol appears. 
5. Enter the text and frame width in the Status Line data fields. Press ENTER (Win-

dows) or RETURN (Macintosh) to update the dimension.
Move the dimension by choosing the Selection tool, selecting the dimension, placing 
the pointer over the end of the leader line and when the pointer becomes the Move 
symbol, dragging the text to a new location.

Balloon dimension text does not increment as additional balloons are placed. Enter 
specific text in the balloon dimension, if necessary.
The Status Line contains Text and Width data fields.

Geometric Characteristics
According to the Edit Objects dialog box a balloon dimension includes the following 
characteristics: Frame, Width, Text 1, Text 2 (when a split balloon is used) and 
Extension. The Frame pull-down menu lists all available balloon symbols. Width defines 
the symbol width. Text 1 sets the upper text in a split balloon. Text 2 sets the lower text 
in a split balloon. 
The extension is the line distance from the symbol to the leader line. In 
the graphic here the horizontal line is the extension.

Length Along Curve Dimension Tool
This tool dimensions curved objects such as splines.

Using the Length Along Curve Dimension Tool
1. Select the Length Along Curve Dimension tool. The Message Line reads: Length 

Dimension: Specify two points along curve.

2. Click the first point along the curve.
3. Click the second point along the curve.
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GD&T Feature Control Tool
Selecting this icon from the Dimensioning Tools palette activates the new 
Geometric Dimensioning & Tolerancing (GD&T) GD&T tool in Cobalt. When the 
GD&T icon is selected, three options appear in the message line: Datum 

Feature, Datum Target and Feature Control Frame.

Using the Datum Feature Option 
1. Select the GD&T icon.

2. Choose the Datum Feature option from the Message Line. The 
Message Line reads: Datum Feature: Input 2 Points (Arrow 
and Shoulder).

3. Click the point on the geometry for the dimension arrow.
4. Click the second point to specify the location of the symbol.
The datum feature appears.
5. Enter the text in the Status Line data fields. Press ENTER (Windows) or RETURN 

(Macintosh) to update the dimension.
6. Move the dimension by choosing the Selection tool, selecting the dimension, plac-

ing the pointer over the end of the leader line, and when the pointer becomes the 
Move symbol, dragging the text to a new location.

7. Enter specific text in the dimension, as necessary.
8. The Status Line contains Text data fields.

Using the Datum Target Option
1. Select the GD&T icon.

2. Choose the Datum Target option from the Message Line. The 
Message Line reads: Datum Target: Input 2 Points (Arrow and 
Shoulder).

3. Click the point on the geometry for the dimension arrow.
4. Click the second point to specify the location of the symbol.
5. The datum target appears.
6. Enter data for the upper and lower section in the Status Line data fields. Press 

ENTER (Windows) or RETURN (Macintosh) to update the dimension.
7. Move the dimension by choosing the Selection tool, selecting the dimension, plac-

ing the pointer over the end of the leader line, and when the pointer becomes the 
Move symbol, dragging the text to a new location.

8. Enter specific text in the dimension, as necessary.
9. The Status Line contains Upper and Lower data fields.

Using the Feature Control Frame 
The option displays the Feature Control Frame to format data for the dimensions.
1. Select the GD&T tool icon.

2. Choose the Feature Control Frame from the Message Line. 
The Message Line reads: Feature Control Frame: Input 2 
Leader Points (Arrow and Shoulder).

3. Click the point on the geometry for the dimension arrow.
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4. Click the second point to specify the location of the symbol. The Feature Control 
dialog box appears. Fill in the dialog box using the parameters below.

Size Tab 
The Size tab defines the basic dimension and tolerance values along with other optional 
modifiers. This size specification is also known as the Limits of Size. Selecting one of 
the five Tolerance Layout radio buttons controls the tolerance style. The dialog controls 
are re-positioned to match the current Tolerance Layout selection.

Feature Control 
The Feature Control tab defines the geometric relationships for the dimensioned 
feature. Selecting one of the four Frame Style radio buttons controls the layout for the 
feature control frames. The supported frame styles are: None, Single, Dual, and 
Composite. The dialog controls are re-positioned to match the current Tolerance Layout 
selection. The Feature Control tab also uses two additional support dialogs; Unit Basis 
and Datum Reference. The Unit Basis dialog is displayed by clicking on the region of the 
dialog box. The Datum Reference dialog is displayed by clicking on the region of the 
dialog box.

Unit Basis Dialog
When appropriate for a feature, the Unit Basis Dialog defines the unit basis interval 
(sub-region) over which the tolerance value is applied. The unit basis interval can be 
one of “None,” “Linear,” and “Area.” A “None” interval (the default) applies the allowed 
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tolerance over the entire feature. A “Linear” interval applies the allowed tolerance per 
any linear sub-length along the feature. An “Area” interval applies the allowed tolerance 
per any rectangular sub-area of the feature. If a linear interval is defined, the Feature 
Control tab page will display a /L indicator. If an area interval is defined, the Feature 
Control tab page will display a /LxW indicator.

Datum Reference Dialog
When appropriate for a feature, the Datum Reference Dialog associates existing datum 
planes (local coordinate origin) with the dimension. A maximum of 3 datums (Primary, 
Secondary, Tertiary) can be associated with a feature control frame. A datum must be 
fully defined in order to add another datum reference. A datum consists of a datum letter 
(any combination of the letters A-H,J-N,P,R-Z. I,O, and Q are not allowed) and an 
optional modifier symbol. For a multiple datum, a second datum letter and optional 
modifier symbol follow a dash.

Dimension Appearance 
Cobalt, Xenon and Argon automatically create dimensions 
according to ANSI Y14.5, DIN, ISO or JIS standards. Many 
companies and individuals, however, have developed their 
own standards. The commands in the Dimension menu control 
virtually every aspect of the dimension appearance without 
having to construct dimensions manually and while retaining 
the Vellum’s smart dimensions.
Settings made in the Dimension menu affect the currently 
selected dimension and all future dimensions.

Linear
This command in the Dimension menu a 
sets the decimal precision.
All dimensions in this program are displayed 
in decimals regardless of the units set in 
Preferences. 
If feet/inches units are set in Preferences, 
objects over one foot in length will display 
both feet and inches.

Cobalt, Xenon or Argon do not support 
dimensioning in fractions. The default is 
three decimal places.

1’ - 7”1’ - 7”
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Tech Note: The number of decimals displayed with the dimensions is not
affected by the number of decimals specified for units in Preferences.

Linear Tolerance
The Linear command in the Dimension menu sets the tolerance for the following Linear 
Dimension tools: Horizontal Dimension tool, Vertical Dimension tool, Oblique 
Dimension tool, Angular Dimension tool and Smart Dimension tool. Choose 
Dimension>Linear to select one of the seven tolerance options.
The following graphic shows the appearance of each tolerance option if the limits shown 
in the Status Line are entered.

It is possible to use the Edit Objects box to override the + or - for either of these as 
needed.
When a Dimension tool is selected, such as the Horizontal Dimension tool, the Status 
Line includes data fields for the upper and lower tolerances, as shown here.

To set the number of decimal places for 
the linear tolerance, choose 
Dimension>Linear Tol.
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Angular 
This command in the Dimension menu sets 
the format of Angular dimensions. 
It is possible to set degrees, minutes and 
seconds for angular dimensions. The default 
format is degrees and minutes. 

Text
This command in the Dimension menu 
specifies the position and orientation of 
dimension text.
The default is Horizontal text. The Break-in, 
Over and Under options produce text that is 
aligned with dimension leader lines. Over 
and Under display text above or below leader 
lines while Break-in places the text between 
leader lines.
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Font
This command in the 
Dimension menu picks the 
font for dimension text. The 
fonts in this list are the same 
as those available in the Font 
submenu from the Text 
menu.
The Font submenu in the Text 
menu has no effect on 
dimensions. 

Tip: This command only affects dimensions.To change the font of other text
objects, choose Text>Font.

Size
This command in the Dimension menu 
picks the size of dimension text only. The 
sizes in this list are the same as those 
available in the Size submenu from the Text 
menu.
The Size submenu from the Text menu has no 
effect on dimensions. 

Selecting the User option specifies a non-
standard font size for dimension text.

Selecting the Model option displays the text 
size in the Units specified in Preferences. 
Selecting the Points option, displays the 
point size of the text. Select the desired 
radio button, enter a value in the data field 
and click OK.

Tip: This command only affects dimensions. To change the size of other text
objects, use Edit Objects or the Size submenu from the Text menu.
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Style
This command in the Dimension menu lets you 
pick the style of dimension text, Normal, Bold, 
Italic and Underline. The styles in this list are 
the same as those available in the Style 
submenu from the Text menu. However, these 
settings do not affect those in the Text menu.

Tip: This command only affects dimensions. To change the style of other
text objects, use the Style submenu from the Text menu. 
The Style submenu from the Text menu has no effect on dimensions.

Color
This command in the Dimension menu specifies the 
color of the dimension. The default color is blue.
The Color submenu from the Pen menu has no effect on 
dimensions.

Tip: This command only affects dimensions. To change the color of other
objects, use Edit Objects or the Color submenu from the Pen menu.
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Weight
This command in the Dimension menu specifies 
the weight of dimension lines.
Dimension lines are typically drawn in the 
thinnest weight available. For this Designer 
Elements program, that is 0.002" or 0.05mm. 
The default weight is 0.002" or 0.05mm.

Tip: This command only affects dimensions. To change the weight of other
objects, use Edit Objects or the Weight submenu from the Pen menu. The
Weight submenu from the Pen menu has no effect on dimensions.

Layer
This command in the Dimension menu specifies the layer on 
which dimensions are placed. This command does not apply 
to dimensions placed within drawing views. These are 
automatically placed on the Sheet View layer. See Drawing 
Views for information.
When selecting this command the following dialog box 
appears:

Dimensions can be placed on any visible layer. In the pull-
down menu, select a layer for the dimensions. The default 
layer is the Dimension layer. 

Place the dimensions on a new layer not yet created by clicking the Create New Layer 
button. The data field displays the new layer name. Give the layer a new name if 
desired. Click OK to save the change.
If the layer on which dimensions are to be placed is hidden or deleted, future 
dimensions will be placed on the current work layer.
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Arrowheads 
This command in the Dimension menu specifies the 
type of arrowhead used for dimensions. 

Tip: This command only affects
dimensions. To select the arrowhead type
for lines or arcs, use the Arrowheads
submenu from the Pen menu. 
The Arrowheads submenu from the Pen
menu has no effect on dimensions. 

Arrow Size Com-
mand
This command in the Dimension menu specifies the size of 
the selected arrowhead.
When selecting this command, the following dialog box 
appears: 

This dialog box includes:

Diameter/Length This value is the diameter or length of dots, slash and standard 
arrow styles. The value here affects all Length, Side and Angle 
fields. The value displayed is in the current units specified in 
the Units page of the Preferences dialog box.



Dimensions

32-22

Changing any value in the Length, Height, Side, or Angle entry fields, the program will 
change the values in the other entry fields accordingly.

Witness Lines
This command in the Dimension menu lets 
specifies which sides of the linear dimension 
should have witness lines. 
A check mark indicates that a witness line 
will be placed at the specified location. This 
option is useful to plot a drawing that 
contains baseline or chain dimensions. Turn 
off one or more of the overlapping witness 
lines to prevent the plotter from drawing 
multiple witness lines when only one is 
needed.
The Start of a dimension is the first point 
clicked. The End of a dimension is the last 
point clicked. The default settings have 
witness lines at both the start and end of a 
dimension.
This command affects only linear 
dimensions. Radial and diametric 
dimensions are not affected by the settings 
made in the Witness Lines command.

Dimension Standards
The dimension standards feature has been modified to manage and define the 
standards and specify which standard is used from the Standards submenu in the 
Dimension menu.
A user-defined standard contains all the current Dimension menu settings at the time 
the Standard Settings dialog box appears. This includes dimension text font, style and 
size. It does not include the Witness Line setting.

Tech Note: The default dimension standard is ANSI. The actual setting does
not save with files.

Length This value is the length of the arrowhead as the horizontal 
distance from its tip to the furthest extension of its base.

Height This value is the height of the arrowhead as the vertical 
distance of its base.

Side This value is the edge length of the arrowhead.

Angle This value is the angle of the tip of the arrowhead.
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Standards Settings Manager
Dimension standards are set through the Standards Settings 
dialog box displayed by choosing Dimension>Standards 
Settings.

Standard This pull-down sets the dimension standard. Cobalt, Xenon 
and Argon contain settings for ANSI, DIN, ISO, JIS and the 
new Architecture, Dual Side, Dual Stacked and Stacked 
Fraction default standards. These default standards cannot be 
altered, however, user-defined standards can be created and 
saved under their own name. Examples of each default 
standard follow this section.

Text Offset This entry field controls the distance from the base of the 
dimension text to the leader lines. A positive entry places the 
text above the leader lines, and a negative value places it 
below the leader lines. A zero value places the text on the 
leader lines.

# Next Offset This entry field controls the perpendicular distance between 
subsequent leader lines.

First Offset This entry field controls the perpendicular distance between 
the object being dimensioned and the leader line and 
dimension text.

Changes to this value only affect new dimensions.

Arrow Leader This entry field controls the distance the leader lines extend 
beyond the witness lines when the arrows appear outside of 
the witness lines.

Ext Over This entry field controls the distance the witness lines extend 
beyond the leader lines.

Ext Gap This entry field controls the distance between the dimension 
point and the witness lines.
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Delete Click this button to delete a user-defined standard. (This button 
is unavailable for the ANSI, DIN, ISO, JIS, Architecture, Dual 
Side, Dual Stacked and Stacked Fraction default standards.)

Cancel Click this button to close the dialog box without accepting any 
changes.

Save As Click this button to save the settings for a user-defined 
standard under a new name.

Save Click this button to save changes to a user-defined standard. 
(This button is unavailable for the ANSI, DIN, ISO, JIS, 
Architecture, Dual Side, Dual Stacked and Stacked Fraction 
default standards.)

ANSI Standard DIN Standard

ISO Standard JIS Standard

Architectural Standard Dual Side Standard

Dual Stacked Standard Stacked Fraction Standard
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Setting the Standard
A Standards menu sets the standard as 
the default or change the standard for a 
selected dimension. If user-defined 
standards are created, they are also 
listed in the Standards menu.

Choosing a Standard
Choose one of the predefined standards 
or a user-defined standard. Changing 
the standard will also change the 
Dimension menu settings. If no 
dimension is selected, the default 
standard is set. If one or more 
dimensions are selected, the standard is 
changed for the selected dimensions.
1. Choose Dimension>Standards.

2. In the Standards submenu, choose 
one of the listed standards.

3. Click OK to accept the standard as 
the default and close the dialog box.

Creating a User-defined Standard
1. Choose Dimension>Standards Settings.

2. Enter values in the desired fields.
3. Click Save As.

An Input String dialog box appears with a Standard Name 
data field.

4. Enter a new name in the data field.
5. Click OK to close the dialog box and save the new stan-

dard.
This user-defined standard can be later deleted through 
the Standards Settings dialog box. This standard also 
adds to the Standards menu.

Dimensions and Drawing Views
If dimensions in the drawing view go outside the bounds of the view so that they are not 
seen, choose the Frame to Extent command in the Drawing View menu. Or drag the 
view edge manually to completely display the dimension. For information see Drawing 
Views.
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Dimensions created in drawing views are placed on the Sheet View layer rather than the 
Dimension layer. This turns off all other layers including the Dimension layer when 
printing the sheet. This is helpful when dimensioning the original geometry and it is not 
necessary to print those dimensions.
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Fill and Crosshatching
Cobalt Xenon and Argon apply fill to smart polygons and to apply crosshatching to the 
geometry. This is especially useful for setting certain objects apart visually.
This chapter covers the following topics:
• Fill Pattern and Fill Color
• Crosshatching

Fill Pattern and Fill Color
Cobalt Xenon and Argon provide Fill Patterns and Fill Color for Smart Polygons created 
with the Polygon tools: Rectangle, Inscribed Polygon, Circumscribed Polygon, Arbitrary 
Polygon and Polygon from Curves. These patterns and colors highlight the polygons or 
separate overlapping polygons visually in the drawing. After creating the polygon, place 
a fill pattern and fill color in the polygon. Changes made to the polygon the pattern and 
color automatically update.

Tech Note: Fill Pattern and Fill Color are not the same as Crosshatching or
Solid Fills. Fill Pattern and Fill Color are predefined bitmaps and cannot be
edited.

There are two fill commands in the Pen menu: Fill Pattern and Fill 
Color.
These commands work with each other. Using the Fill Pattern 
command, choose the pattern for the polygon. Using the Fill Color 
command, choose the pattern color.
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Fill Pattern
A wide variety fill patterns are available. Patterns 
appear parallel to the work plane and only in the view 
in which they were added. In other words, patterns 
are drawn correctly when viewed along the z-axis of 
the work plane.
When selecting the Fill Pattern command a submenu 
displays. There is the option to choose None (for no 
fill) or one of eight patterns (including solid fill) as 
shown here.

Selecting Pen>Fill Pattern>More, the Patterns option 
box appears providing more patterns.

The patterns are enlarged below for clarity.

These patterns are not editable. They are predefined bitmaps. The default pattern is 
None.



Fill Pattern and Fill Color

25-3

Choosing a Fill Pattern
1. Choose the Selection tool.

2. Select the polygon to display with a fill pattern. Hold 
down the SHIFT key to select more than one polygon.
One example is displayed here.

3. Choose Pen>Fill Pattern and one of the fill patterns.

(Choose a fill pattern from the Patterns option box, for a 
selection box to appear around the pattern.)
The polygon is filled with the selected pattern.

Fill Patterns and Holes
Cobalt, Xenon and Argon do not support the placement of 
“holes” in polygons. A polygon, however, can be placed 
within another polygon and a solid white fill can be chosen 
to give the illusion of a hole.
Using the example above the following result is obtained.

Overlapping Objects and Patterns
Since multiple objects with multiple patterns can be 
displayed in the drawing, some overlapping may occur.
The order of the overlapping is specified in two ways:
• Select the objects with the Selection tool in the reverse order that they are displayed 

on the screen
• Adjust the placement of the objects using the Arrange command in the Layout menu 

(see Arrange Command on using this command).

Use the Group command in the Layout menu to keep the patterned objects in the 
specified order.

Changing the Existing Pattern of a Polygon
1. Select the existing polygon with the Selection tool.

2. In the Pen menu, choose a new pattern from the Fill Pattern submenu.
The fill pattern changes as specified.

Removing the Fill Pattern
1. Select the existing polygon with the Selection tool.

2. In the Pen menu, choose None from the Fill Pattern submenu.
The fill pattern is removed.

Double-click the object to display the Edit Objects dialog box and change the Fill 
characteristic from Yes to No.
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Fill Color
This command in the Pen menu works only with the 
Fill Pattern command.
The submenu displays the same colors available for 
creating geometry (see Pen Settings).
A specific color can be chosen for all fill patterns. 
The default color is black.

Choosing a Fill Color
1. Choose the Selection tool.

2. Select the polygon to fill.
Hold down the SHIFT key to select more than 
one polygon.

3. Select the fill color. The color displays.
The new fill pattern color is displayed in the 
polygon.

It is not possible to choose a fill color for a polygon 
that does not contain a pattern.

Changing the Color of an Existing Fill
1. Select the existing polygon by clicking it with the Selection tool.

2. In the Pen menu, choose a new color from the Fill Color submenu.
The fill pattern color changes as it is specified.

Crosshatching
This Designer Elements program can crosshatch any enclosed area in the drawing and 
then automatically update the crosshatching when the geometry is changed. Select a 
closed area containing a hole or cutout and the program accurately excludes the cutout 
area from the crosshatching. Crosshatching can also be applied to section cuts made 
through the geometry when using the drawing composition tools.
The Pen menu contains two crosshatching commands: Cross Hatch and Hatch. Use 
these to apply crosshatch patterns to the geometry.

Cross Hatch Patterns
You have a wide variety of crosshatch patterns available to in both ISO and DIN styles. 
Choosing Pen>Cross Hatch brings up a dialog box. If no objects are selected the dialog 
box is called, Default Cross Hatch. If objects are selected, the dialog box is called 
Object Cross Hatch.
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The dialog box contains the following options:

ISO Patterns
If the ISO standard is chosen, the ISO categories and crosshatch patterns display in the 
dialog box.

The categories for the ISO standard are:

Standard This option sets the crosshatching standard. Select either the 
ISO (International Standards Organization) standard or the DIN 
(German Standards Institute) standard from the pull-down 
menu.

Category This section lists the hatch categories available for the 
selected standard.

Cross Hatch This section lists the crosshatch patterns available for the 
selected category.

Pattern Window This window, to the right of the Cross Hatch list, displays the 
selected crosshatch pattern.

Rotation (Settings) This field sets the rotation angle of the crosshatch 
pattern.

Scale (Settings) This field sets the scale of the crosshatch pattern.

Set Default (Default Cross Hatch dialog box) Click this button to set the 
default crosshatch pattern for the drawing.

Apply (Object Cross Hatch dialog box) Click this button to apply the 
crosshatch pattern to the selected object.

Metals The patterns in this category include: Iron, Steel, Bronze/
Copper, Zink, Aluminum and Titanium.

Masonry The patterns in this category include: Brick and Concrete.

Other The patterns in this category include: Rubber, Electric, Marble/
Glass, Thread, Grass, Earth, Fabric, Insulation and Mud.
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DIN Patterns
If the DIN standard is chosen, the DIN categories and crosshatch patterns display in the 
dialog box.

The categories for the DIN standard are:

Crosshatch Command
This command in the Pen menu applies crosshatching to the geometry.

Setting the Default Hatch Patterns
When no objects are selected, set the default crosshatch pattern for the current session 
of this Designer Elements program.
1. Choose Pen>Cross Hatch. The Default Cross Hatch dialog box appears.

2. Choose the crosshatch standard from the pull-down menu.

Metals The patterns in this category include: Bronze, Steel (Alloy), 
Steel (Non-Alloy), Cast Iron, Metal (Light) and Metal (Heavy).

Minerals The patterns in this category include: Rock, Sand, Clay, Peat/
Humus Soil, Coal, Salt and Sandstone.

Plants The patterns in this category include: Wood (Horizontal Grain), 
Wood (Vertical Grain), Wood (Materials), Wood (Cut) and Tar.

Other The patterns in this category include: Masonry (Brick Work), 
Masonry (Increased Strength), Masonry (Light Brick), Masonry 
(Pumice) Plaster Plate, Plaster (Mortar I), Plaster (Mortar II), 
Concrete (Reinforced), Concrete (Non-reinforced), Concrete 
(Pumice) and Concrete (Waterproof).
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3. Choose the category and the crosshatch pattern. The pattern appears in the pattern 
window.

4. Specify a rotation angle and scale.
5. Click Set Default. The default crosshatch pattern is set.
6. Click the Close button (Windows) or the Close box (Macintosh) to close the dialog 

box.
If the Hatch command is chosen, in the Pen menu this default pattern is applied to the 
selected geometry.

Applying a Crosshatch Pattern for an Object
If one or more objects are selected, choose a specific crosshatching for them without 
changing the default.
1. Select the object to crosshatch.

2. To apply the default crosshatch, choose Pen>Hatch and the object is crosshatched.
To apply a different crosshatch, choose Pen>Cross Hatch. The Object Cross Hatch 
dialog box appears.

3. Choose the crosshatch standard from the pull-down menu.
4. Choose the category and the crosshatch pattern. The pattern appears in the pattern 

window.
5. Specify a rotation angle and scale.
6. Click Apply. The pattern is applied to the selected object.
7. Click the Close button to close the dialog box.

Geometric Characteristics
According to the Geometry page of the Edit Objects dialog box, crosshatching has the 
following characteristics: Rotation and Scale. Change the values and click ENTER 
(Windows) or RETURN (Macintosh) to alter the hatching.

Hatch Command
This command in the Pen menu crosshatches the selected objects using the default 
crosshatch pattern.
1. Select the object to crosshatch.

2. Choose Pen>Hatch.
The selected object crosshatches with the default pattern.

Editing Hatching
Edit a crosshatch pattern for a selected object by changing the pattern, rotation or scale. 
To change the hatch pattern select the hatching within the object and choose 
Pen>Cross Hatch. Change the hatching and click Apply.
To change the hatch pattern rotation angle and scale use the Object Cross Hatch dialog 
box or in the Edit Objects dialog box.

Crosshatching and Section Cuts
Crosshatching is especially valuable for sections cuts created using the drawing 
composition tools.
When hatching is placed in a section cut the default hatch pattern is used. Like any other 
crosshatch pattern, it is possible to change the pattern, rotation and scale. In the same 
section, choose different hatch patterns for objects cut. See “Drawing Composition for 
Cobalt & Xenon” for information on sections and the drawing composition tools.
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Symbols
In this Designer Elements program, symbols are used to define 2D or 3D shapes that 
frequently occur throughout a drawing. They can be wireframe, surface or solid objects. 
When used properly, symbols and instances dramatically speed the design and drafting 
process while reducing the file size.
An instance is a copy of the original or master geometry. It is created when placing a 
symbol in the drawing or modifying that symbol by moving, rotating or scaling it.
A symbol consists of a master symbol composed of geometry (text and dimensions are 
not supported) which is instanced into a drawing by clicking the placement location. 
Once a symbol is placed use the Transformation tools to move, rotate, scale or mirror it.
Symbols are created and organized through the Symbol Manager. Once the symbols 
are created use the Symbol tools to place them into the drawing. 
The following topics are covered in this chapter:
• Symbol Palette
• Symbol Manager
• Creating Symbols
• Symbol Tools
• Symbol Example
• Transforming a Symbol
• Editing a Symbol
• Symbols and Rendering
• Symbols and Files

Symbol Palette
The symbol tools are contained in the Symbol tool palette. To display the 
palette choose Window>Symbols.
The default status of the Symbol palette is closed and the default location is 
below the main tool palette. Like the other palettes, it is possible to save the 
status and location of the palette anywhere in the drawing area.

There are two tools for placing symbols into the drawing, Symbol 1 Point and Symbol 2 
Point. Before using these tools, create the symbol through the Symbol Manager. Once 
the symbol is created, use one of these tools to place it into the drawing.
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Symbol Manager
Use the 
Symbol 
Manager 
to create 
and 
organize 
symbols 
in the 
drawing 
file. To 
display 
the 
Symbol 
Manager 
select one 
of the symbol tools and press the CTRL key (Windows) or the OPTION key (Macintosh).
The Symbol Manager contains the following elements:

Symbol Name This list displays the names of all master symbols contained in 
the file whether or not they are instanced into the drawing.

# Used This lists the number of times a master symbol is instanced 
into the drawing.

Preview The Preview panel displays a 2D preview of the selected 
symbol in window.

Rename This renames any of the symbols in the drawing. When initially 
creating a symbol, Cobalt, Xenon or Argon automatically 
provide a name.

To change the symbol name, select the symbol name from the 
list and enter a new name in the Rename data field. The name 
updates as it is typed.

New New opens the Edit Symbol drawing screen for creating a new 
symbol.

Edit Edit opens the Edit Symbol drawing screen to edit a selected 
symbol in the Symbol Name list.

Delete This deletes the selected symbol and all instances (copies) of 
the symbol in the drawing.

If there are instances of 
the symbol in the 
drawing when clicking 
this button, the 
following dialog box 
appears.

Click Yes to delete the symbol and all instances or No to close 
the box and return to the Symbol Manager.
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Creating Symbols
Creating symbols is identical to creating any geometry. Symbols cannot contain text or 
dimensions. When creating a symbol, a master is created. Place copies or instances of 
this symbol into the drawing using one of the symbol tools.
1. Select a symbol tool.

2. Press CTRL (Windows) or OPTION (Macintosh) to display the Symbol Manager.
3. Click the New button. The Symbol Edit screen displays.

The screen is almost identical to the standard drawing area except for the EXIT Edit 
Symbol button and the Symbol Edit name in the Work Layer Indicator.

4. Create the symbol geometry using any of the tools and commands in the program. 
5. When completing the symbol geometry, click the EXIT Edit Symbol button to return 

to the standard drawing area.
Follow these steps to create more symbols for the file.
Like all other geometry, symbols are saved with the file. They do not become a part of a 
library for use with other files.
Cobalt, Xenon or Argon do not support text or dimensions with symbols.

EXIT Edit Symbol Click this button in the upper right corner of the drawing area 
when finishing creating the symbol geometry to return to the 
drawing area.

Symbol Edit This name in the Work Layer Indicator designates the Symbol 
Edit screen. This layer is not accessible in the Layer Manager.

The Axis is located at the origin for a master symbol. 
The origin is represented by this marker.
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Symbol Tools
Two symbol tools are included for instancing symbols into the drawing, Symbol 1 Point 
and Symbol 2 Points.

Symbol 1 Point Tool

The Symbol 1 Point tool places a copy of the selected symbol at the specified location. 
The symbol x-axis is aligned with the x-axis of the work plane.

Using the Symbol 1 Point Tool
1. Select the Symbol 1 Point tool. The Message Line reads: Symbol 1 Point: 

Enter location for symbol [Ctrl (Windows) or Option (Macintosh) = Symbol 
Manager].

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the 
Symbol Manager.

3. Select the symbol to place in the drawing.
4. Click OK to close the Symbol Manager dialog box.

The Message Line displays the name of the selected symbol.
5. Click in the drawing area to set the symbol's origin (as defined by the master). 

The symbol is placed in the drawing. It is possible to place any amount of instances of 
the symbol.

Symbol 2 Points Tool

The Symbol 2 Points tool places a copy of the selected 
symbol at the origin and specified lever point. The lever 
point defines a rotation for the inserted angle and 
represents the top right corner of the symbol. See the 
graphic here.

Using the Symbol 2 Points Tool
1. Select the Symbol 2 Points tool. The Message Line reads: Symbol 2 

Points: Enter symbol origin and lever point [Ctrl (Windows) or Option (Mac-
intosh) = Symbol Manager].

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the 
Symbol Manager.

3. Select the symbol to place in the drawing.
4. Click OK to close the Symbol Manager dialog box.

The Message Line displays the name of the selected symbol.
5. Click the location for the symbol origin. The location is the symbol origin defined by 

the master symbol.
6. Click the lever point. The symbol is placed in the drawing. 

It is possible to place any number of copies of the symbol in the drawing.

Origin Lever
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Symbol Example
Try this simple example of creating and placing a symbol.
1. Open a new file.

2. Choose Window>Symbols to display the Symbol tools palette, if it is not already 
displayed.

3. Select the Symbol 2 Points tool.
4. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display 

the Symbol Manager.
5. Click on the New button. The Symbol Edit screen appears.
6. Create an object similar to the graphic here.

7. Once the symbol is completed, select the Symbol 2 Point tool and then click the 
EXIT Edit Symbol button in the lower right corner.
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8. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Sym-
bol Manager.

The symbol geometry is displayed in the Preview window with a default name in the 
Symbol Name list.

9. In the Rename field, which is already highlighted, type BoomBox. As it is typed, the 
name is replaced in the Symbol Name list.

10. Click OK to accept the name and close the Symbol Manager.
The Message Line now includes the name, BoomBox. (If it does not, click the Symbol 
2 Points tool again.)

11. In the drawing click to place the origin point.
12. Move the cursor to the right horizontally using the Drafting Assistant and click to 

place the lever point.
The BoomBox symbol is placed in the drawing. If a lever point is clicked at a 45° 
angle, the BoomBox Symbol would have been placed at that angle.

13. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol 
Manager. The # Used field shows that the symbol was instanced once in the draw-
ing.
Using the Transformation tools it is possible now to perform numerous operations on 
the symbol.

Transforming a Symbol
Once a symbol is placed it is possible to use the Transformation tools to do some 
manipulation. Move, rotate, scale or mirror the symbols. Follow the steps for using these 
tools found in “Transforming Geometry” on page 1.
A symbol can be moved with the arrow keys and the Selection tool. Select a symbol by 
dragging a selection fence around it.
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Editing a Symbol
Symbols cannot be edited in the drawing area, only in the Symbol Edit screen.
1. Select a symbol tool.

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol 
Manager.

3. Select the symbol to edit.
4. Click on the Edit button.

The Symbol Edit screen displays.
5. Make the changes.
6. Click the EXIT Edit Symbol button.

All symbol instances of the edited master symbol are updated.

Symbols and Rendering
This Designer Elements program does not support the rendering of symbols. To render 
a symbol, open the symbol through the Symbol Manager, copy the symbol and paste it 
into the drawing. Then the object, which is no longer a symbol, can be rendered.

Symbols and Files
Sometimes it is possible to have symbols to use in more than one file or that were 
created elsewhere.

Using Symbols in Other Files
Symbols are file-specific. Symbols created in one file are not automatically available as 
symbols for other files. It is possible, however, to copy and paste the geometry of one 
symbol opened in the Symbol Manager or one file into a new Symbol Edit screen of 
another file. This way it is not necessary to recreate the geometry.
Cobalt, Xenon and Argon do not support Symbol libraries.

Importing
Import drawing files into this program and then place that geometry within the Symbol 
Edit screen by copying and pasting. Make additions to the symbol in the Symbol Edit 
screen.
Cobalt, Xenon and Argon do not automatically support importing symbols from Graphite. 
Geometry from a symbol file can be imported into Cobalt, Xenon or Graphite copied and 
then pasted into the Symbol Edit screen as mentioned above.
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Viewing Geometry
In this Designer Elements program the geometry is created in one model space and can 
be viewed from many different angles and view scales as needed. A view describes the 
orientation of the eye position and direction toward the geometry.   A number of tools 
and commands are used to view the geometry. The following topics are covered:
• The View Palette
• Shade Options
• Zooming
• Panning a View
• View Displays
• View Rotation
• View Commands
• Views and Planes
• Views and Zoom Scale

The View Palette 
The View palette of Cobalt, Xenon and Argon provides tools for various viewing options. 
They include the Zoom, Dynamic Pan, Dynamic Zoom, and Dynamic Rotate tools, all of 
which are described in detail further on in this chapter. 

In addition to these tools, the palette also offers shortcuts to the following view options: 
Wireframe, Hidden Lines Dimmed, Hidden Lines Removed, Static Shade, Surface 
Analysis and Perspective.

Wireframe Displays the model in wireframe.

Hidden Lines 
Dimmed

Displays the model in wireframe with hidden lines dimmed.

Hidden Lines 
Removed

Displays the model in wireframe with hidden lines removed.

Static Shade Displays the model shaded with the last Static Shade setting 
designated in the Shade Options dialog box accessed by 
View>Shade Options, including Flat, Gouraud, Gouraud w/
Edges, Phong, Phong w/Edges.
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Shade Options
This Designer Elements program designs, displays and edits the models in a wide range 
of visualization modes. These include the static and dynamic options, wireframe, Flat 
shading, Gouraud shading, Phong shading, Hidden Line, Preview Render, Raytrace 
Render modes. Basic rendering is implemented under Open GL available through the 
video card. Do not select the objects to render them.

Tech Note: This Hidden Line mode is different from the hidden line images
that appear in Drawing Views when using the Model to Sheet command. See
Model to Sheet Command for more information.

Shade Now 
CTRL+T (Windows); +T (Macintosh)
This Shade Now command in the View menu, 
displays the geometry using the Render Now setting 
selected in the Render Options dialog box (see the 
next section).
To use this command, choose View>Shade Now.
All surface and solid geometry in the drawing 
renders.

Shade Options
This Designer Elements program provides a number 
of options for rendering the geometry.
When choosing View>Shade Options, the following 
dialog box displays.

The dialog box includes the following rendering categories:

Surface Analysis Toggles the display of the real time surface analysis. 

Perspective Displays the model using perspective.
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There are the following rendering options:

Static Render Defines how the geometry displays when the view is stationary. 
This Designer Elements program automatically repaints the 
object if this setting is changed and saved.

Dynamic Render Defines how the geometry displays as the view is rotated. 

Render Now Defines how the geometry displays when choosing 
View>Shade Now. 

When clicking the 
arrow in a category 
pull-down menu 
appears.

Wireframe Displays only the edges of the 3D model. This is the 
normal repaint display mode.

Flat Displays the geometry with a painter’s algorithm 
using constant shading techniques.

Gouraud Displays the geometry based on calculated light 
intensities at each vertex. This rendering method 
uses Open GL (Windows) or QuickDraw 3D 
(Macintosh). 

Gouraud w/Edges Displays the model with face edge boundaries, 
silhouettes and isolines of a surface or solid on top of 
a rendered model. Specify the edge color in the 
Display page of Preferences (see Display).

Phong Displays the geometry based on calculated light 
intensities at each pixel location.
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Phong w/Edges Displays the model with face edge boundaries, 
silhouettes and isolines of a surface or solid on top of 
a rendered model. Specify the edge color in the 
Display page of Preferences (see Display).

Hidden Displays only the visible edges of the  geometry. 
Since this is a rendering mode, any text in wireframe 
does not display. Text and wireframe objects do not 
display in this mode.

Hidden w/Dimmed Displays the visible edges with the hidden edges of 
the geometry dimmed. Since this is a rendering 
mode, any text in wireframe does not display. Text 
and wireframe objects do not display in this mode. 

Preview Render 
(shadows off)

Creates a quality rendering of the scene. It renders most 
rapidly of all the commands since there are no ray tracing and 
shadow calculations.

Preview Render 
(shadows on)

Creates a more realistic rendering than Preview Render 
(shadows off) with shadows. It renders quickly since there is no 
ray tracing.

Raytrace Render 
(shadows on/off)

Creates a high quality rendering of the scene. The processing 
time is extended with addition of the ray tracing operation and 
shadow calculations.
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The dialog box also includes another render option setting:

Tech Note: If the Dynamic Render mode is set to Phong with Edges, and
the model vanishes, that’s the result of light reflection. Adjust the light levels
or location and render again.

Flip Normal Example
If the following object is imported and rendered without the Flip Normal 
option checked, parts of the object appear dark.

Check the Flip Normal option and render the object 
again. The normals pointing away from you are flipped and the 
darkened areas of the object render more acceptably. 
Choose Edit>Change Direction to flip the direction of the normals. 

Setting the Shade Options
1. Choose View>Shade Options. The dialog box displays.

2. Select the render options if necessary.
3. Click OK and the options are accepted. (Click Cancel to close the dialog box without 

saving the settings.)

Raytrace Render 
(shadows on/off, anti-
alias)

Creates the highest quality rendering of the scene, eliminating 
jagged edges. It uses the accuracy of ray tracing with anti-alias 
over-sampling. The computational time is significantly longer. 
The Advanced Setting dialog box controls the sampling 
calculations.

Custom Uses the custom render presets designated in the Advanced 
Settings>Photo-realistic Render Settings dialog window.

Default Uses the default factory render settings designated in the 
Advanced Settings>Photo-realistic Render Settings dialog 
window.

Flip Normals Flips the light normal on objects. The Flip Normals box is 
checked by default. This Designer Elements program 
automatically repaints the object if this setting is changed and 
saved.

When displaying a rendered object, its appearance is 
determined by the light locations and the object orientation. If 
light normals are pointed away from the viewer, the object will 
appear dark. This can happen when geometry is imported from 
another program.
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If the Flip Normal or the Static Render settings are changed, this Designer Elements 
program automatically repaints. 

These settings save as the default settings when exiting the program.
If Gouraud w/Edges or Phong w/
Edges are chosen and it is 
necessary to display the model 
with isolines or silhouette, 
double-click on the model to 
open the Edit Objects dialog box. 
In the Display page, specify the 
desired settings and click Apply.

Z-Buffer Curves Toggles on or off OpenGL depth buffering of curves as they are 
displayed in context with surfaces and solids. With this option 
on, curves behind surfaces or solids are hidden and visible 
when turned off.

Show Facet Edges Toggles on or off the edges of the display facets. The facet 
density is determined by the entity resolution.

Use Clip Planes Indicates whether to process clip planes for OpenGL 
rendering.  When turned on, all planes entities that are marked 
as clip planes will clip the current view. To mark a plane as a 
clip plane, right click over the entity and select the appropriate 
option in the menu.

Backface Culling Enhances OpenGL performance. When this option is on, 
OpenGL ignores all facets from solids that have normals facing 
away from the viewing direction. Turn this feature off if there 
are hybrid solids that mix open surfaces with solids, otherwise 
the surface may appear invisible in OpenGL display modes.

Anti-Alias Tells the OpenGL drivers to enable anti-aliasing of edges.

Clip At Eye Point Toggles on or off clipping at the eye point. If off, clipping is 
automatically determined based on the extents of the given 
model.
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Render Option Combinations and View Rotation
Because the rendering options deal with the display of the geometry, the rendering 
categories operate with each other and are affected by the view.

Shade Options Example
1. Create some geometry. 

2. In the Shade Options dialog box, set Render Now to Hidden w/Dimmed and Static 
Render to Wireframe.

3. Click OK to save the setting and close the dialog box. 
4. Choose View>Shade Now and the geometry is displayed in Hidden w/Dimmed view 

mode.
5. Rotate the view. The geometry is now displayed as wireframe because of the Static 

Render setting.

Use Transparency Indicates whether to process objects marked with a 
transparency flag for OpenGL transparency. When turned on 
all surface and solid entities that are marked as transparent will 
clip the current view. To mark an object as transparent, right 
click over the entity and select the transparent option from the 
menu. 

The slider value indicates a global transparency setting. A 
setting of 100 implies no transparency and a value of 0 implies 
fully transparent. Below is an example of an object containg 
transparent parts.
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Lights & Facets
All facets are illuminated according to how much light falls on their vertices (the 
intersection of perpendicular isolines). If a light source is positioned over a large flat 
surface (such as a floor), it will appear that the source is not casting light. Set the object 
resolution to Very Fine or Super Fine to increase the facet density and enhance the 
lighting result. See “Change Resolution” on page 5 for more information on resolution.

Zooming 
Cobalt, Xenon and Argon offer several ways to change the magnification of the drawing 
by zooming in and out using commands, zoom tools, and strokes.

Zoom Commands
Zoom In, Zoom Out, Zoom All, Zoom Previous, Zoom Window, Zoom Home and Zoom 
Ratio from the View menu change the view magnification of the geometry depending 
upon the selection and input. To zoom a particular area, use the Stroke feature or the 
Zoom tool, described later in this chapter.

Zoom All 
CTRL+F (Windows); +F (Macintosh)
This command in the View menu zooms in or out to make all objects on the drawing fill 
the screen, regardless of the size of the objects. 

Zoom In 
CTRL+] (Windows); +] (Macintosh)
This command in the View menu zooms in to the screen center by a factor of two.

Zoom Out 
CTRL+[ (Windows); +[ (Macintosh)
This command in the View menu zooms out from the screen center by a factor of two. 

Zoom Previous
This command in the View menu zooms to the previous magnification.

Zoom Window 
ALT+4 (Windows); +4 (Macintosh)
This command in the View menu drags a selection fence around the desired view 
window (from the upper left to the lower right).

Zoom Home 
ALT+6 (Windows); +6(Macintosh)
This command in the View menu adjusts the view scale so that the origin of the drawing 
(0, 0, 0) is centered on the screen. 

Fine Resolution Very Fine Resolution Super Fine Resolution
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Zoom Ratio Command
This command in the View menu displays an Input String 
dialog box. Enter a ratio in the data field. A value of .5 
zooms out by a factor of two. A value of 2 zooms in by a 
factor of two. Click OK to close the dialog box and save 
the value. The drawing scales to the value.

Zoom, Pan and Rotate Tools 

The Zoom tools are located in the View tool palette. 

Zoom Tool

This tool zooms in or out by the specified factor. The default factor is two. It is possible 
also to specify a zoom scale (1 = full scale) in the Scale field of the Status Line. Zooming 
causes a visual rather than a physical change. Holding the CTRL (Windows) or Option 
(Mac) key changes the tool to zoom out.

Tip: Using the CTRL (Windows) or the OPTION (Macintosh) key, toggle
between the Zoom In and Zoom Out tool.

1. Choose the Zoom In tool. The Message Line reads: Zoom In: Pick area to enlarge. 
[Ctrl (Windows) or Option (Macintosh) = Zoom Out]

To get a specified zoom scale, enter the value in the Scale data field.
2. Click in the drawing area; that position is displayed in the center of the screen and 

the drawing is enlarged or reduced by a factor of two. It is possible to drag a selec-
tion fence around an area so only that area is displayed.

The Status Line contains the Scale data field.

Pressing the CTRL (Windows) or the OPTION (Macintosh) key while using this tool 
causes it to change to the Zoom Out tool.

Using the Dynamic Pan Tool

This tool is located in the View tool palette at the bottom of the main tool palette. 
1. Select the Dynamic Pan tool. The Message Line reads: 

Dynamic Pan: Drag mouse to translate view.

The pointer becomes a hand icon.

2. Place the pointer over the section of the screen to move and drag.
When releasing the mouse, the view has been repositioned. Notice that the scroll bars 
have adjusted accordingly. 

Dynamic Zoom Tool 

This tool zooms in or out by the amount specified by your stroke in the drawing area. 
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1. Choose the Dynamic Zoom tool. The Message Line 
reads: Dynamic Zoom: Drag mouse to zoom view. 
Move right zooms out.

2. Move the cursor to the drawing area. The cursor becomes the dynamic zoom 
icon. 

3. Drag the mouse to the right to zoom out or to the left to zoom in. The view scale 
changes according to the stroke.

Stroke Zoom 
Use stroke commands to zoom, magnify or reduce drawing. Stroke commands are 
useful because they don’t require you to get out of the tool being used in order to zoom. 
Hold down the SHIFT+CTRL keys (Windows) or the  key (Macintosh) and drag 
diagonally across the screen as described below. The pointer takes on the z shape 
when holding down the SHIFT+CTRL (Windows) or the  key (Macintosh) keys.

Tech Note: Windows users: The Stroke Zoom function is not accessible for
tools that already use the SHIFT and CTRL keys. This note is repeated in the
chapters containing the tools to which this applies.

This Designer Elements program remembers up to eight zoom strokes, enabling the 
return to previous zoom magnifications.

Note: For Zoom In and Zoom Out, the size and location of the stroke rectangle is 
important for determining the result of the Zoom operation. For Zoom Previous, the size 
and location of the stroke rectangle is irrelevant, since all cases just give the previous 
magnification. 

Zooming and Views
This Designer Elements program retains the last zoom scale that was set in a particular 
view. By zooming in a particular view, then changing views and zooming in the new 
view, the view scale in the previous view is not affected. 

Using Stroke Zoom  

Drag Diagonally Result 

Upper left to lower 
right

Zoom In: centered over the stroked area. 

Lower right to upper 
left

Zoom Previous: reverses Zoom In stroke to the previous 
magnification. 

Upper right to lower 
left

Zoom Out: the current screen reduces to the size of the area 
defined by the stroke. 

Lower left to upper 
right

Zoom Previous: reverses Zoom Out stroke to previous 
magnification. 

Drag the pointer
diagonally
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Panning a View 
It is possible to move the view around to better see the geometry. Cobalt, Xenon and 
Argon provide the Dynamic Pan tool that enables doing this without using the scroll bars. 
Simply hold down the space bar, click on the geometry and drag to the desired location.

View Displays 
There are two view types in this program: pre-defined and user-defined. Use these to 
set the view orientation of the geometry.

Pre-defined Views
Cobalt, Xenon and Argon provide five standard views: Side, Front, Top, Isometric and 
Trimetric. Each view is defined by Eye Point locations on the X, Y and Z axes or the 
Azimuth and Elevation. Changing the values in either Eye Point or Azimuth/Elevation 
automatically changes the other fields.
These values can be changed as desired. In File>Preferences>General, set the view 
definitions to Default or Aerospace. Included with each view is a description based on 
the view definition and its associated values.

Tech Note: An azimuth is an angle measured clockwise from the selected
point to the vertical.

Side Default: The view of the y, z plane. The Eye Point values are: X 
= 500, Y = 0.0, Z = 0.0. The Azimuth value is 0.0. The 
Elevation is 90.0. 

Aerospace: The view of the x, z plane. The Eye Point values 
are: X = 0.0, Y = -500.0, Z = 0.0. The Azimuth value is 0.0. The 
Elevation is 90.0. 

Front Default: The view of the x, z plane. The Eye Point values are: X 
= 0.0, Y = -500.0, Z = 0.0. The Azimuth value is 0.0. The 
Elevation is 90.0. 

Aerospace: The view of the y, z plane. The Eye Point values 
are: X = -500.0, Y = 0.0, Z = 0.0. The Azimuth value is 0.0. The 
Elevation is 90.0. 

Top Default & Aerospace: The view of the x, y plane. The Eye Point 
values are: X = 0.0, Y = 0.0, Z = 500.0. The Azimuth value is 
0.0. The Elevation is 0.0. 

Isometric The view of the axes is rotated as shown. 

z

y

x

Isometric

Trackball
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User-defined Views 
There is the ability to define any new view using the New View command or the 
Trackball. There is also the ability to modify these views using the Modify View 
command.
User-defined Views are saved with the current file. They are not saved as defaults for 
the program. 

New View Command 
The New View command, 
located in the View menu, 
specifies a new view based 
on a current view or entirely 
independent of any of the 
available views.
Choosing the New View 
command brings up the 
dialog box and contains the 
following options: 

Default: The Eye Point values are: X = 500.0, Y = -500.0, Z = 
500.0. The Azimuth value is -45.0. The Elevation is 54.736. 

Aerospace: The Eye Point values are: X = -500.0,   Y = -500.0, 
Z = 500.0. The Azimuth value is -45.0. The Elevation is 54.736. 

Trimetric The view of the axes rotated as shown.

 Default: The Eye Point values are:   X = 382.176, Y = -256.20, 
Z = 195.712. The Azimuth value is -33.837. The Elevation is 
66.957. 

Aerospace: The Eye Point values are: X = -382.176, Y = -
256.20, Z = 195.712. The Azimuth value is 33.837. The 
Elevation is 66.957. 

View Name Contains the name of the current view. 

Create By Specifies the new view; Eye Pt/Reference Pt, Azimuth/
Elevation and Rotate Current View. 

Eye Pt/Reference Pt - creates a view based on two sets of 
values. The Eye Pt refers to the location of the viewer's eye. 
The Reference Pt refers to an existing point on a model. An 
asterisk next to the fields denotes the ability to click the 
location in the drawing area and have the values automatically 
entered in the fields.

z

y

x

Trimetric

Trackball
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Specifying a View with the New View Command 
1. Choose View>New 

View. 

The New View dialog box 
displays the name and 
location of the current 
view with its 
corresponding values. 
The View Name is 
highlighted.

2. Enter the new name for 
the view. 

3. Select one of the Create By methods for defining the view. Enter the appropriate val-
ues according to the Create By option chosen. 
For the Eye Pt/Reference Pt method, click the appropriate points in the drawing and 
the values will be entered automatically into the data fields. 

4. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close 
the dialog box without saving the view.) 

Once a new view is created, select it by choosing View>User View and the view name 
or choosing the view in the Trackball pull-down menu. 
Be aware that simply rotating the view does not alter the orientation of the work plane in 
3D space (except for the Side, Front and Top views). 

Azimuth/Elevation - specifies the angle of the azimuth and the 
elevation of the eye with respect to the view.

Rotate Current View - rotates the current view by a specified 
amount. The values entered in these fields affect the related 
fields in the other Create By options.

OK Saves the new view and closes the dialog box. 

Cancel Closes the dialog box without saving the view.
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Trackball - Save Current View 
Define a view using the Trackball command, Save Current View, at the bottom of the 
Trackball pull-down menu.

Tip: When changing a view of the geometry but making no changes to the
geometry, the Save command is unavailable. To save the view, create an
object and then delete it. The Save command is now available and can be
used to save the view with the file.

1. Display the Trackball.

2. Rotate the view as desired. 
3. Click the view name on the Trackball to display 

the pull-down menu. 
4. Select Save Current View and release the 

mouse. The new view saves. 
When displaying the pull-down menu again, the 
new view is listed as User View1. 

See the addition of a DynView, which is the current non-standard view. 
All views defined in this way are numbered sequentially. Rename these views by 
choosing View>Modify View.

Modifying a View
It is possible to modify only user-defined views. A standard view cannot be modified. An 
attempt to do so creates a duplicate of the view except for the changes made. This new 
view becomes a user-defined view which can be renamed as desired. Choose 
View>User View, to display the modified view. 
To change the name or any coordinate locations for user-defined views, use the View 
Properties command in the View menu. 

Using the Modify View Command 
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1. Choose View>View Properties and select the view to change. The Modify View dia-
log box displays. 

This dialog box is identical to the New View dialog box except for its title. 
2. Make all of the desired changes in the appropriate fields. (See the New View section 

earlier in this chapter for an explanation of the data fields.) 
3. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close 

the dialog box without saving the view.) 

Deleting a View
Delete any DynViews or user-defined views using the Delete command in the View 
menu. Choose View>Delete View and the view to remove.

The current view or the standard views cannot be deleted. This command is unavailable 
if there are no user-defined views. 
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View Rotation
Views can be chosen in a number of ways: 
• Choosing a standard view from the View menu or the Trackball. 
• Choosing a user-defined view from the View menu or the Trackball. 
• Choosing an undefined view by rotating the Trackball. 
• Using the Dynamic Rotation tool. 
• Using the SHIFT and arrow keys.

Choosing a Predefined View 
To use any of the five standard views mentioned earlier choose one in the View menu or 
in the Trackball pull-down menu.

See Trackball for more information on using it.

Choosing a User-defined View 
To use any of the user-defined views, choose one in the User View submenu of the 
View menu or in the Trackball pull-down menu.

The User View command in the View menu is not available when no user views have 
been defined. 

Choosing an Undefined View 
Choose undefined views by using the Trackball to rotate the view to a new orientation. 
Notice that when rotating the view with this method the view name changes to DynView. 
This view has been added to the Trackball pull-down menu and is a temporary view that 
will change as the view is rotated using the Trackball. One advantage of this feature is 
that it is not necessary to define this view but it will still be available until the next 
Trackball rotation. 

Dynamic Rotate Tool 
The Dynamic Rotate tool, located in the View tool palette, rotates the view 
dynamically around any axis.

1. Select the Dynamic 
Rotate tool. The 
Message Line 
reads: Dynamic Rotate: Drag mouse to rotate view.
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The cursor becomes a plus (+) sign. 
2. Drag the cursor to change the view. 

or 
Enter values in the Status Line to rotate the view a specified angle. 

Press ENTER (Windows) or RETURN (Macintosh) and the view changes. 

Using the Shift and Arrow keys 
In any view hold down the SHIFT key and use the arrow keys to rotate the view. 

View Commands 
Redraw Screen 
CTRL+R (Windows); +R (Macintosh)
This command in the View menu refreshes the screen. Sometimes when making 
changes to the constructions the geometry may not be redrawn cleanly. 

Redrawing the Screen 
To redraw all of the geometry and remove extraneous geometry choose the Redraw 
Screen command from the View menu. 

Stopping a Screen Refresh
Windows: Press the ESC or BREAK key to stop the redrawing of the screen. For 
interrupting long operations such as redraw or linear and polar duplicate, use the 
BREAK key. If the operation was initiated by a Control key command (such as CTRL+R 
for redraw) the ESC key is read by MS-Windows and it brings up a task list at the end of 
the operation. 
Macintosh: press ESC or the  (Command) key to stop the redrawing of the screen. 

View the Plane
This command located in the View menu, changes the view to the current work plane.

Show/Hide 
This command in the Window menu helps manage the display of objects in the drawing. 
Choose which objects display at a given time. When choosing 
Windows>Show/Hide, the following list of commands appears.

Using the Hide Command 
1. Select the Hide command. The Message Line reads: Select 

entities to hide. [Shift = Extend] 

2. Select an object. The object hides from view. 

Using the Show Command 
1. Select the Show command. The Message Line reads: Select entities to show. [Shift 

= Extend] 

2. Select an object by clicking on the approximate location of the object or using a 
selection fence. The object shows on the screen. 

Using the Show ALL Command 
Select the Show ALL command to display all objects on active layers in the drawing. 
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Using the Invert Command 
Select on the Invert command to display all objects currently hidden and hide all objects 
currently displayed.

Using the Show Only Command 
1. Select the Show Only command. The Message Line reads: Select entities to show 

only. [Shift = Extend] 

2. Select the object to display. Hold down the SHIFT key to select more than one 
object. 
All other objects in the drawing are hidden. 

Tile
In some cases, multiple files are open at the same time. Rather than having to switch 
back and forth between them, they may be displayed all at once. In the Windows menu 
choose Tile Vertically or Tile Horizontally (Windows) or Tile (Macintosh).

Arrange Icons (Windows only)

On occasion many open files may be reduced to their title bars but arranged 
haphazardly around the screen. 
Choose Window>Arrange Icons and the files will be neatly arranged in the lower left 
corner of the screen.

Open File Windows 
The bottom of the Window menu shows the names of all the open program files. To 
bring a different document to the top choose it from the list.
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Views and Planes 
To view geometry, choose a particular view orientation as discussed in this chapter. To 
create geometry, choose a particular plane on which to draw. 
To eliminate the potential confusion between work planes and view, the Front, Side and 
Top views are tied to their respective planes. For example, choose the Top view, the Top 
plane is selected in the Plane menu and all other planes are grayed out. For more 
information see Planes. 

Views and Zoom Scale 
Cobalt, Xenon and Argon link the view to the zoom scale. Each view remembers the last 
zoom scale set in that view. Change the view and alter the zoom scale and it won't affect 
the zoom scale of any other view.
Example: In the Top view set the zoom scale to 1:2. Choose the Isometric view and 
change the scale to 1:4. Return to the Top view and the scale returns to 1:2.
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Layers
Think of visible layers as transparent pages and hidden layers as invisible pages. Use 
layers to show and hide various components of the drawing. They are particularly useful 
in helping to view and print complex drawings. For example, when dimensioning a part, 
the dimensions can be placed on a separate layer which can be displayed or not, as 
required. Layers enable printing different versions of the same document.
• Hide the dimension layer to present a design to a planning team and show the 

dimensions when presenting the drawing to engineers. 
• Hide certain drawing components when printing or plotting. For example, hide the 

construction layer so that construction lines and geometry don’t print but remain in 
the drawing ready for further design changes. 

• Construct different layouts using one layer as the basis. For example, use one layer 
to define the basic shape of an object and then use other layers to try different 
methods of detailing.

Cobalt, Xenon and Argon each provide up to 32,700 layers in the drawing. Layers must 
be visible to select objects on them. Layers do not have an orientation or origin. 
The topics explained in this chapter include:
• Layer Manager
• Creating New Layers
• Creating New Layers
• Renaming Layers
• Deleting Layers
• Hiding Layers
• Showing Layers
• Locking Layers
• Unlocking Layers
• Making a Layer the Active Work Layer
• Layers and Pen Color
• Layers and Pen Style
• Layers and Copying/Pasting Objects
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Layer Manager
CTRL+L (Windows); +L (Macintosh)
The Layer Manager creates, deletes, hides, displays 
and renames layers, as well as sets layer 
specifications. The work layer is the active layer on 
which geometry is created. There are three ways to 
open the Layer Manager.
The Layer Manager dialog box is integrated with the 
Design Explorer dialog box.
1. Open the Design Explorer (Window>Design 

Explorer).

2. Choose Layout>Layer Manager:
3. Click on the Work Layer Indicator to display the 

pop-up menu and choose the Layer Manager com-
mand.

The Layer Manager dialog box appears.

The Layer Manager contains the following elements:

Active Work Layer Sets the active work layer. To change the active work layer 
move the pencil icon to the layer to be added to geometry.

Layer List Displays all layers in the file.

Layer List
Show/Hide Layer

Active Work Layer

Lock Layer
Layer Color
Object Count

Add Layer

Add Sublayer
Delete Layer
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By right clicking on a layer the following menu pops up:

Show/Hide Layer Shows whether a layer is visible or hidden. The active work 
layer cannot be hidden.

If the Show Layer icon displays, a layer is visible.

Layer Lock If this column contains a Lock icon next to a layer, the 
layer is locked. Objects on this layer cannot be selected 
or modified.

Layer Color Sets the color for all objects on a layer. The original colors of 
objects are retained but they are displayed in the layer color as 
it takes precedent.

Object Count Displays the number of objects on the layer.

Move Up Moves the selected layer up one position in the dialog box.

Move Down Moves the selected layer down one position in the dialog box.

New Layer Adds a layer to the layer list. Layers are numbered 
sequentially, Layer 1, Layer 2, etc. This option also has a 
button at the bottom of the Layer Manager dialog box.

New Sublayer Adds a sublayer to the selected layer. These layers are 
controlled by their parent layer. If you show/hide the 
parent the sublayer responds in kind. This option also 
has a button at the bottom of the Layer Manager dialog box.

Delete Layer Deletes the selected layer. The active work layer cannot 
be deleted.This option also has a button at the bottom of 
the Layer Manager dialog box.

Rename Renames the highlighted layer. Also it is possible to click twice 
on a layer name, once to select the layer and the second time 
to rename it.

Show All Shows all layers.

Hide All Hides all layers except the active work layer.

Lock All Locks all layers including the active work layer.

Unlock All Unlocks all layers.
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Default Layers
When opening a new drawing the default layers include: Construction, Dimension and 
Layer 1.

Tech Note: Dimensions placed in drawing views go on the Sheet View layer.
See Drawing Composition for Cobalt & Xenon for more information.

Any geometry or text that is visible can be edited regardless of its layer. To make some 
geometry unselectable but still visible use the Selection Mask in the Window menu or 
lock the layer containing the geometry. Also the Selection Mask specifies the 
selectability of layers.

Creating New Layers
There are three ways to create a new layer: using the Layer Manager, the Work Layer 
Indicator or the Isolate Layer command.

Using the Layer Manager
1. Display the Layer Manager dialog box.

2. Click the new layer button. A new layer is added to the layer list.
Name the layer by clicking twice on the layer name, once to select the layer 
and the second time to rename it. Cobalt, Xenon and Argon each support up to 
32,700 layers. 

3. The new layer is added.

Tip: If the Selection Mask is open and a new layer is added, the Selection
Mask automatically updates.

Construction Automatically accepts all Construction lines created with stroke 
commands or with the Construction dialog box. If this layer is 
accidentally deleted, it automatically recreates when a 
construction line is created.

Dimension Automatically accepts dimensions on the layer selected from 
the Layer list of the Dimension menu. The default layer is the 
Dimension layer. Generally, this layer should be reserved for 
dimensions.

Layer 1 Is the current work layer for new files. If the file only contains 
the default layers all geometry will normally be placed on Layer 
1.
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Using the Work Layer Indicator
1. Click on the Work Layer 

Indicator to display the 
pop-up menu.

2. Choose the New Layer 
command.
A new layer is created and 
automatically set as the 
active work layer.

Using the Isolate Layer Command 
Alt+7 (Windows); +7(Macintosh)
1. Choose Layout>Isolate Layer.

The Isolate Layer dialog box appears.
2. Click Create New Layer.

A new layer is created and the name is 
placed in the entry field.

3. Click OK to close the dialog box and 
save the new layer. The layer is now 
the active work layer and all other lay-
ers are hidden.

Renaming Layers
1. Display the Layer Manager dialog box.

2. Click twice on the layer to rename, once to select the layer and the second time to 
rename it.

Deleting Layers
1.Display the Layer Manager dialog box.

2.Select the name of the layer from the list box.
3. Click on the trash can in the 

lower right corner of the dia-
log box. The layer is deleted.

4. If the layer contains any 
geometry on it a warning 
appears.
Click OK to delete the layer or 
Cancel to close the warning 
box without deleting.

Hiding Layers
Hide one layer at a time or all layers but the active work layer.

Hiding One Layer
1. Display the Layer Manager dialog box.

2. Click on the show icon (the eye) to the right of the layer name to turn hide.
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The Show icon disappears and the layer is now hidden.

Hiding all Layers
1. Display the Layer Manager dialog box.

2. Right click on a layer name and choose Hide All.
3. Close the Layer Manager dialog box.
Notes:
• The active work layer cannot be hidden.
• If a layer is hidden and Select All and delete are chosen, the objects on the hidden 

layer are not deleted.

Showing Layers
It is possible to turn on one or all layers in the drawing.

Showing One Layer
1. Display the Layer Manager dialog box.

2. Click the box to the left of the layer name to turn on Show.
A Show icon appears next to the layer’s name in the list.

Showing all Layers
1. Display the Layer Manager dialog box.

2. Right click on a layer name and choose Show All.

Locking Layers
1. Display the Layer Manager dialog box.

2. Click in the Lock Layer column next to the desired layer and the lock icon appears.

The layer locks.

Unlocking Layers
1. Display the Layer Manager dialog box.
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2. Click on the lock icon in Lock Layer column next of the desired layer. The lock icon 
disappears and the layer unlocks.

Making a Layer the Active Work Layer
There are number of ways to make a layer the active work layer. These include: using 
the Layer Manager, the Work Layer Indicator, the Isolate Layer command, the Increment 
Layer command or the Decrement Layer command.

Using the Layer Manager
1. Display the Layer Manager dialog box if it is not already displayed.

2. Click in the Work Layer column to the left of the desired layer.
The selected layer becomes the work layer as shown by the pencil icon.

3. Close the dialog box and save the change.

Using the Work Layer Indicator
1. Click on the Work Layer 

Indicator to display the 
menu.

2. Select the layer to make 
the active work layer.
The selected layer 
becomes the active work 
layer.

Using the Isolate Layer Command
Alt+7 (Windows); +7 (Macintosh)
1. Choose Layout>Isolate Layer.

The Isolate Layer dialog box 
appears.

2. Click on the arrow in the Layer 
entry field to display all available 
layers.

3. Select the desired layer.
4. Click OK to save this layer as the 

work layer and close the dialog box. All other layers are hidden.

Increment Layer 
ALT+0 (Windows); +0 (Macintosh)
Choosing this command in the Layout menu makes the next layer in the Layer Manager 
dialog box the active work layer and hides all other layers. This command cannot be 
used if the active work layer is the last layer in the list.

Decrement Layer
ALT+9 (Windows); +9 (Macintosh
Choosing this command in the Layout menu makes the previous layer in the Layer 
Manager dialog box the active work layer and hides all other layers. This command 
cannot be used if the current work layer is the first layer in the list.
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Layers and Pen Color 
It is possible to override the color for all objects on a layer. 
Objects created on this layer use the current pen color but are displayed in the layer 
color.
Objects created on another layer and in another color placed on this layer have their 
color display overridden. They retain their original color but display in the layer color. If 
the object is moved to another layer with no color override, it displays in its own color.

Using the Layer Color Override
1. Display the Layer Manager tab of the Design Explorer dialog box if it is not already 

displayed.

2. Click in the Layer Color column next to the desired layer. A color patch appears dis-
playing the first color available, white.

3. Click on the color patch to advance to the next patch color.
4. For a list of available colors, to designate a custom color, or to remove colors right 

click (or CTRL+click on a single button mouse) on the column to display the color 
menu.

5. Click OK to close the dialog box and save the change.

Layer Color Warning
The program displays a warning if the color of an object on a layer with a specified color 
is attempted to be changed. 

As the box indicates, the color cannot be changed unless the color override for that 
layer is removed.
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Layers and Pen Style
Line styles can be assigned to layers. The selected pen style will be the new default for 
that layer when active, for all future geometry, until another style is selected. A different 
pen style can be set for each layer as desired. It can be used only when the layer is 
active. 

Using the Pen Style Override
1. Display the Layer Manager 

tab of the Design Explorer 
dialog box if it is not 
already displayed.

2. Click on the layer to acti-
vate. Right click on the 
layer to modify the line 
style. 

3. Choose the Independent 
Pen Defaults option from 
the context menu. All lay-
ers that are overridden 
appear in italics in the 
Design Explorer.

4. Go to Pen>Style and 
choose one of the patterns 
available.

5. The Independent Pen 
Defaults option becomes 
checked in the right click 
menu and the style name 
is indicated below in the 
parentheses.

Layers and Copying/Pasting Objects
When objects are copied on a specific layer in one file into another file containing those 
same layers, the objects are not automatically placed on the specific layer. The copied 
objects are placed on the work layer.
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Planes
A plane is an infinite surface on which geometry can be created. Cobalt, Xenon and 
Argon provide predefined planes, Front, Side and Top and the ability to create user-
defined planes.
If a plane is chosen as the work plane, all geometry created from that point on is placed 
on that plane. The work plane is an x, y plane with an origin of 0, 0, 0 for all data input. 
Move the work plane as desired by creating a customer plane or choosing one of the 
predefined planes.

Referral: Planes can also be created by using the Infinite Plane tool in the
Surfaces tool palette. See Surface Primitive Tools for more information.

As you learn to use this Designer Elements program, attempt to use the Z-Drafting 
Assistant without moving the work plane. Even though the Z-Drafting Assistant does a 
lot of the work, the work plane is still an essential element of 3D modeling.
The Z-Drafting Assistant assumes that geometry is being created in the current work 
plane unless it snaps to an align:z or to a logical snap point that is not in the current 
work plane.
Use a work plane to properly position geometry in the following cases:
• To create geometry that is not parallel to the work plane and does not snap to one of 

the Drafting Assistant’s constraints like endpoint or midpoint.
• To create geometry that requires less than three points for its specification such as 

the Center-point Circle, Rectangle or 2-point Ellipse.
Those tools which use three points for specification can be drawn non-parallel to the 
work plane.
The Plane menu and the Work Plane Manager, accessed through the coordinate system 
axis, contain all of the commands for creating and setting the work plane.
The topics explained in this chapter include:
• Work Plane
• Work Plane and Views
• Work Plane and World Coordinates
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Work Plane
The work plane is an important feature of any CAD program. In conventional CAD 
programs it is necessary to specify both the orientation of the work plane and its exact 
location along the z-axis.
In this Designer Elements program, specify only the orientation of the work plane. Once 
that is done, all parallel planes act equally as the current work plane (e.g. the Drafting 
Assistant identifies the location of the work plane automatically).

Another way to explain the relationship presented in the graphics above is to remember 
the role of the Drafting Assistant. For new geometry to be placed on the same plane as 
another piece of geometry either create a user-defined work plane at that location or 
brush over that “old” geometry to wake up one of its control points like midpoint or 
endpoint. The program will then retain this plane information as the new geometry is 
created.
If no object exists or no geometry is referenced for plane information, the program 
places the new object geometry onto the work plane.

Show Work Plane Command
Choosing this command in the Plane menu displays the work plane icon in the drawing. 
The left graphic below shows the work plane icon in the Top plane. The right graphic 
shows the icon in the Isometric view.

The work plane icon is a helpful reference for creating geometry on multiple planes.
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Work Plane 
The Work Plane Manager, accessed through the coordinate system icon in the Status 
Line, is a menu of commands that defines, deletes, displays the properties of and saves 
the current work plane. It also shows or hides the work plane. 
Display this menu by clicking on the coordinate system axis icon to the left 
of the Status Line.

The Work Plane Manager menu displays.

New Command
This command, found in the Planes Menu (Planes>New Work Plane) defines a new 
work plane. An unlimited number of planes can be defined. When choosing this 
command, the Define Work Plane dialog box appears.

The dialog box contains the following items.

The asterisk (*) next to the field indicates the ability to specify locations by clicking in the 
drawing area. The values can be entered manually.

Using the New Command to Define a Work Plane
1. From the work plane manager menu, choose New. 

The Define Work Plane dialog box appears.
2. Enter the values for the origin, right and up arms of the work plane. The locations 

can also be specified by clicking in the drawing area.
3. Enter in name for the work plane in the Name data field.

If a name is not entered, the default name displayed in the field will save with the work 
plane coordinates.

4. Click OK to save the new plane.
5. Display the work plane manager menu again.

Notice that the new work plane is listed and is the current work plane. It is possible 
now to operate in the user-defined coordinate system.

Name Displays the work plane name. If a unique name is not entered, 
the name field displays UserWorkPlane01 or some other 
numbered increment.

Origin These fields display the X, Y and Z coordinates for the origin of 
the work plane.

Right These fields display the DX, DY and DZ coordinates for the 
right arm of the work plane. 

Up These fields display the DX, DY and DZ coordinates for the up 
arm of the work plane.
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Referral: For information see Coordinate System Axis.

Delete Command
Use this command, located in the Planes Menu (Planes>Delete Work Plane) to delete a 
user-defined work plane. It is not possible to delete the GlobalWorkPlane or 
DynWorkPlane items.
1. Select the user-defined work plane to delete.

2. Choose the Delete command. A warning box appears explaining that the operation 
cannot be reversed and asking for confirmation. 

3. Click Yes to delete the plane.

Properties Command
This command displays the properties of the selected work plane.
1. Choose a user-defined work plane.

2. Choose the Properties command. The Define Work Plane dialog box appears dis-
playing the name and the X, Y, Z coordinates of the work plane.

3. Change any value and click OK to close the dialog box and save the changes.

Save Current Command
This command saves the current work plane and adds it to the list of work planes in the 
Work Plane manager. It is automatically titled with the next available default label. If 
there are no other user-defined planes using a default label, the plane is titled, 
UserWorkPlane01.
This plane can be renamed by selecting the name and choosing the Properties 
command in the Work Plane manager.

Show Work Plane Command
This is the same command available though the Planes menu. Choosing the command 
displays the work plane icon in the drawing.

Work Plane Identification
Determine if the current work plane is global or user-defined through the coordinate 
system/work plane icon displayed to the left side of the Status Line.
The Global Work Plane icon is a miniature version of the axis icon. 
When a user-defined work plane or dynwork plane is chosen, an 
altered axis icon displays in the Status Line, as shown here.
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Setting the Work Plane
In the Planes menu there are commands for setting the 
work plane. A work plane may be defined other than the 
standard planes. For example, to work on an angled 
face, reorient the work plane.
It is possible to set the work plane six ways. From the 
Planes menu, choose a predefined plane, Front, Side or 
Top or use one of these commands, Use View, 3 Pts, 
Pick Objects and Define. As explained earlier, the work 
plane manager menu also can be used to define and set 
the work plane.
Work planes created using the Use View, 3 Pts, Pick 
Objects and Define commands do not save for use later. 
They are only available until another work plane is set. 
Use the New command in the work plane manager to 
define and save a work plane with the file. If objects are 
created on a temporary work plane, use the Pick 
Objects command and select the objects on that plane 
to set the work plane to them. (See a later section on 
using the Pick Objects command.)

Tech Note: Being in the Front, Side or Top view, the work plane is already
set to the respective plane and the other two predefined planes in the Plane
menu are unavailable. Temporary planes created with the User View, 3 Pts,
Pick Objects and Define commands are not saved for future use.

Choosing a Predefined Plane
1. Click or drag on the Plane menu to display the submenu.

2. Select one of the predefined planes. 
All three predefined planes are only available when 
the view is set to Isometric, Trimetric or a user-defined 
view.
The work plane has changed to the selected plane.

Choosing the Front plane sets the x-axis to 0, 1, 0 and the y-axis to 0, 0, 1. 
Choosing the Side plane sets the x-axis to 1, 0, 0 and the y-axis to 0, 0, 1. 
Choosing the Top plane sets the x-axis to 1, 0, 0 and the y-axis to 0, 1, 0.

Choosing the Use View Command
This command sets the work plane to be coincident with the screen; the origin is in the 
center of the screen; the x-axis is coincident with the width of the screen; the y-axis is 
coincident with the height of the screen.
This sets the plane to match the screen in all views which is particularly useful when 
moving from view to view while drafting.
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Choosing the 3 Pts Command
This command sets a temporary work plane from the three specified points. This 
command is especially helpful to create non-parallel planes.

Referral: See Infinite Plane Tool for information on using it.

1. Choose Plane>3 Pts. The Message Line reads: Work Plane: Enter three points for 
work plane (1 origin, 2 x-axis, 3 y-axis).

2. Click in the drawing area to indicate the origin point for the new work plane.
3. Click a point to define the positive x-axis.
4. Click a point to define the positive y-axis.

A temporary work plane is created.

Choosing the Pick Objects Command
This command sets the work plane based on selected objects. This includes selecting 
an infinite plane icon.
1. Choose Planes>Pick Objects. The Message Line reads: Work Plane: Select 

objects to set Work Plane [Shift = Select].

2. Select a curve or curves located in the plane set as the work plane.
The work plane changes to the plane of the objects. Choose Plane>Show Work 
Plane to verify that the new plane is selected.

Use this tool to set the work plane to the face of a solid object.

Tech Note: This tool does not create a plane between curves on different
planes. It only sets the plane to objects already in a plane.

Using the Work Plane Manager to set the Work Plane
1. Click on the work plane icon at the left of the Status Line.

2. From the menu select a work plane. (This menu displays the global 
work plane and any user-defined work planes.)
The selected work plane is now set.

Work Plane Snapping
A short cut was added to allow rapid work plane positioning and alignment. This has 
been accomplished by further integration of the work plane with the Drafting Assistant. 
By default the short cut is set to the “C” key. When pressing the short cut key associated 
with work plane snapping, the following behavior will be:
• Work plane origin moves to Drafting Assistant snap location. Aligns to the Top plane.
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To work on this face...

...click on points 1,2,3
(3-point plane)
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• Pressing C a second time changes from Top to Side work plane orientation.
• A third time changes from Side to Front work plane orientation.
• The fourth time C is pressed changes from Front to a user-defined work plane 

orientation.
• The fifth time C is pressed changes from back to top plane.
If the face snap options is on, pressing the short cut key will automatically align with 
respect to the face normal.
Note: an object must be selected in order for the work plane snapping short cut to work.

Work Plane Dimming
This menu command provides a means to dim objects that do not lie in the work plane.

Moving the Origin
Occasionally, it may be necessary simply to move 
the origin of the work plane. This is especially 
useful for measuring distances. For example, open 
a document and start drawing without regard to the 
location of the origin, then move the origin to a 
convenient location for future reference. 

Set Origin
This command sets a new origin in the current work 
plane.

Specifying a New Origin
1. Choose Planes>Set Origin. 

2. Click in the drawing area to indicate the location for the new origin. 
The origin of the current work plane moves but the orientation of x, y, z remains the 
same. 

To move the origin and change the orientation of the work plane, use either the 3 Pts 
command or the Define Plane command.

The origin might be 

...but it can be moved here for 
more convenient measurement

here to begin... 

.
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Offsetting the Work Plane 
Using this Designer Elements program, the work plane normal may be moved a certain 
distance to the current work plane so that new geometry will snap to it. The Offset 
command in the Planes menu gives this ability. 

Tip: Use the 3 Pts command in the Planes menu if the new plane is not
parallel.

Using the Offset Command 
1. Display the work plane icon. (This is not required but it will help to visualize the off-

set.) 

2. Choose Planes>Offset. 
The following dialog box displays.

3. Enter the distance to offset (negative or positive) the 
work plane in the data field. The units for the distance 
are based on the Units page of Preferences. 

4. Click OK to accept the value and close the dialog box.
The work plane has changed. Click Cancel to close the 
dialog box without accepting the value.

Work Plane and Views
Standard Views
To create geometry, choose a particular plane on which to draw. To view geometry in 
this Designer Elements program, choose a particular view orientation. 
To eliminate the potential confusion between work planes and views Cobalt, Xenon and 
Argon has tied the Front, Side and Top views to their respective planes. For example, if 
the Top view is chosen, the Top plane is selected in the Plane menu as the work plane 
and all other planes are unavailable.
For more information about Views see “Viewing Geometry”.

View the Plane
This command in the View menu changes the view to the current work plane.

Work Plane and World Coordinates 
Cobalt, Xenon and Argon use the world coordinate system (as opposed to the User 
Coordinate System) for defining planes.
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Lighting
Cobalt, Xenon and Argon provide default lights to display the objects. But excellent 
photo-realistic rendering requires more than just the defaults. That’s why these Designer 
Elements programs provide directional, ambient and sun light sources with geometric 
pattern and color temperatures. This chapter describes how to use each of these 
including:
• Directional Lighting
• Ambient Lighting
• Default Lighting
• User-defined Lighting Layouts
• Photo-realistic Sunlight for Stills and Animations
• Lights & Facets

Tech Note: For more artistic elements, refer to Appendix E, Photo-realism
Fundamentals.

Directional Lighting

The Distant Light source, Spot Light source and Point Light source are directional 
sources. Location and direction can be specified for each source. Place these lights in 
the drawing by using the Light tool palette. 
These light sources also support shadows when working within the advanced rendering 
environment.

Light Palette
The Light tool palette does not automatically display when launching this Designer 
Elements program. To display the palette choose Window>Lights.

The Light tool palette includes the Distant Light ( ), Spot Light ( ), Point 

Light ( ), Linear Tube Light ( ), Tube Light From Curve ( ), 

Rectangular Area Light ( ), Area Light from Selected Surface ( ). Light 
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sources placed using this palette contribute light color and intensity to all objects that lie 
within their influence and are used to define the light. 
Light sources appear in the drawing as symbols in the wireframe and basic render 
modes for construction purposes. The light source symbols do not appear when using 
the photorealistic rendering commands unless Visualize Light option is checked in the 
Edit Objects dialog box to show the light source while rendering.
Activate the Create Solid Body option in the Message Line to be able to edit the source 
of light through the Edit Object dialog box.

The solid body of the light appears in the Design Explorer and can be edited on the 
Geometry tab of the Edit Object dialog box. 

Light sources can be hidden using the Show/Hide command or moved to a separate 
layer and hidden. However both actions turn off the light.

Distant Light Source

A distant light 
source illuminates 
a scene with 
parallel rays of light 
as if they emanate 
from a very distant 
light source. Like 
the sun, this source 
illuminates all 
parallel surfaces 
equally.

Using the Distant Light Tool
1. Select the Distant Light tool. The Message Line reads: Distant Light: Enter location 

and direction positions.

2. Click a point to set the location of the light.
3. Click the next point to establish the direction of the light. 
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The exact distance is not important. A distant light source symbol appears in 
the drawing composed of a cylinder with an arrow pointing along the source 
center-line.

If Show Points in the Edit menu is checked, the center-line 
extends from the source location to the direction point, as in the 
graphic here.
Place more lights as desired. Adding lights, render the model again to verify the 
lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page, a distant light source is made up of the 
following characteristics: Type and Intensity. It also includes the Enable Light check box, 
Cast Shadows check box and its associated pull-down menu and the Cast Volumetric 
Shadows check box. The Attenuation menu is not available since a distant light source 
illuminates all surfaces equally.
Flip Direction button changes the direction of the light source for 180 degrees.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. When checked, the light is on. The default setting is on.
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
type options: hard, medium, soft and blurry.
The ability to control shadow casting is especially valuable in a scene containing 
multiple light sources. Too many shadows can render a scene confusing. This check box 
setting only applies when rendering the scene with Preview Render (shadows on) or 
Raytrace Render (shadows on, Anti-Alias). See Photo-realistic Rendering Commands. 
The light source color is accessible through the Attributes page.

Spot Light Source

A spot light source illuminates a scene 
with a cone of light emanating from a 
local source. This source functions 
similarly to a flashlight.

Using the Spot Light Tool
1. Select the Spot Light tool. The Message Line reads: Spot Light: Enter location and 

direction positions.

2. Click the first point to set the location of the light.
3. Click the next point to establish the direction of the light. 

Distance is only important to set the light with an attenuation (see the 
Geometric Characteristics section for information on attenuation). The default 
setting does not include attenuation. A spot light source symbol appears in the 
drawing, composed of an inner and outer cone and an arrow pointing along 
the source center-line.
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If Show Points in the Edit menu is checked, the center-line extends 
from the source location to the direction point. The sides of the cone 
extend to a plane normal to the direction, and end at the direction 
point, as in the graphic here.
Place more lights as desired. As lights are added, render the model to verify the 
lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page, a spot light source is made up of the 
following characteristics: Type, Intensity, Attenuation, Cast Volumetric Shadows, the 
Cone Angle data field, Falloff Angle data field, Falloff Rate data field and the Slide check 
box. It also includes the Enable Light check box, Cast Shadows check box and its 
associated pull-down menu and Flip Direction button.
Flip Direction button changes the direction of the light source for 180 degrees.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
type options: hard, medium, soft and blurry. 
The ability to control shadow casting is especially valuable in a scene containing 
multiple light sources. Too many shadows can render a scene confusing. This check box 
setting only applies when rendering the scene with Preview Render (shadows on) or 
Raytrace Render (shadows on, Anti-Alias). See Photo-realistic Rendering Commands.
Slide check box enables the associated drop down for browsing the image which will be 
used for shining through.
For Attenuation Settings see further.

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. The 
following attenuation options are available:

Use clamped attenuations in situations where the distance from a light source to an 
object is less than one 1” (25.4 mm). Clamped attenuations do not increase intensity 

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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when the distance is less than 1” (25.4 mm). Unclamped situations are more realistic 
and apply to most situations.
Cone Angle controls the maximum spread of 
the spot light. Objects that lay outside the 
area defined by the cone does not receive 
light. Objects that lay within the cone receives 
light according to the specified attenuation, 
falloff angle and falloff rate.
Falloff Angle controls the sharpness of the 
spot light’s edge. The smaller the angle is the 
sharper the edge. The light intensity diminishes from full intensity at the inner cone to 
zero at the outer cone. The value for the falloff angle ranges from zero (0) degrees to 
Cone Angle/2 degrees.
Falloff Rate controls how light is 
distributed within the spot light’s cone. 
The intensity diminishes from the center 
line of the cone outward with the cosine 
of the angle raised to the power of the 
falloff rate. A falloff rate of zero (0) results 
in uniform light within the cone. Higher 
values produce more pronounced falloff. 
The falloff rate can be any value from 
zero (0) to ten (10). 
The graphic here shows the light 
attenuation and falloff rate for a spot light 
with an intensity of 24.
The Slide check box controls whether a 
spot light functions as a slide projector 
and projects an image on the scene. The example below shows the lighting scene with 
the spot light location and the lighting environment with and without the slide image.

The light source color is accessible through the Attributes page.

Point Light Source

A point light illuminates a scene with 
light emanating in all directions. A 
candle or a table lamp is a type of point 
light.

The scene Without slide image With slide image

p
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Using the Point Light Tool
1. Select the Point Light tool. The Message Line reads: Point Light: Enter location.

2. Click to set the source location of the light.
Distance is only important to specify an attenuation (see the Geometric 
Characteristics section for information on attenuation). The default setting 
does not include attenuation. A point light source symbol appears in the 
drawing with arrows pointing outward If Show Points in the Edit menu is 
checked, the source location point displays.
Place more lights as desired. As lights are added, render the model again to verify the 
lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page, a point light source is made up of the 
following characteristics: Type, Intensity, Attenuation. It also includes the check boxes, 
Enable Light and Cast Shadows and its associated pull-down menu and the Cast 
Volumetric Shadows check box.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is also the option of setting the type of shadow casting. There are four 
shadow type options: hard, medium, soft and blurry. This check box setting only applies 
when rendering the scene with Preview Render (shadows on) or Raytrace Render 
(shadows on, Anti-Alias). See “Photo-realistic Rendering Commands” in this chapter.
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. There are 
the following attenuation options:

Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase intensity when 

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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the distance is less than 1” (25.4 mm). Unclamped situations are more realistic and 
apply to most situations.
The light source color is accessible through the Attributes page.

Linear Tube Light

Use linear tube lights for fluorescent lighting effects. 

Using the Linear Tube Light
1. Select the Linear Tube Light tool. 

2. Activate the Create Solid Body 
option in the Message Line to create 
a pipe body that presents source of light. When the light is visualised it looks like on 
the right picture above.

The Message Line reads: Pick first point of linear tube light.
3. Following the prompts in the Message Line, pick two points to specify the beginning 

and the end of the tube.
4. In the Edit Objects dialog box, check the Visualize Light option to show the light 

source while rendering.
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The solid body of the light appears as a pipe in the Design Explorer and can be edited 
on the Geometry tab of the Edit Object dialog box.

The linear tube light symbol appears on the screen. 
5. Render the scene.
Geometric Characteristics
According to the Edit Objects Geometry page, linear tube light source is made up of the 
following characteristics: Type, Intensity, Attenuation, Cast Volumetric Shadows. It also 
includes the Enable Light check box, Cast Shadows check box and its associated pull-
down menu and Visualize Light check box.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
type options: hard, medium, soft and blurry. This check box setting only applies when 
rendering the scene with Preview Render (shadows on) or Raytrace Render (shadows 
on, Anti-Alias). See Photo-realistic Rendering Commands.
Visualize Light check box makes the rendered light source look like a fluorescent lamp. 
Works only when Create Solid Body option was enabled while creating the light source.

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. There are 
the following attenuation options:

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.
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Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase 

Tube Light From Curve

Use curved tube lights for neon lighting effects, specifying a light source along a curve.

1. Using the Tube Light From Curve

1. Create a curve such as an arc, circle or spline, along which to create a light source.

2. Choose Tube Light from Curve in the Lights tool palette.
3. Activate the Create Solid Body option in the Message Line to create a pipe body 

that presents source of light. When the light is visualised it looks like on the right pic-
ture above.

4. Following the prompts in the Message Line, pick the curve created. 
5. In the Edit Objects dialog box, check the Visualize Light option to show the light 

source while rendering.
The solid body of the light appears as a pipe in the Design Explorer and can be edited 
on the Geometry tab of the Edit Object dialog box.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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The symbol for this light source appears on the screen. 
6. Render the scene.
Geometric Characteristics
According to the Edit Objects Geometry page, tube light from curve source is made up 
of the following characteristics: Type, Intensity, Attenuation, Cast Volumetric Shadows. 
It also includes the Enable Light check box, Cast Shadows check box and its associated 
pull-down menu and Visualize Light check box.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
type options: hard, medium, soft and blurry. This check box setting only applies when 
rendering the scene with Preview Render (shadows on) or Raytrace Render (shadows 
on, Anti-Alias). See Photo-realistic Rendering Commands.
Visualize Light check box makes the rendered light source look like a neon lamp. Works 
only when Create Solid Body option was enabled while creating the light source.

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. There are 
the following attenuation options:

Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase 

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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Rectangular Area Light

Area lights create a lovely diffused light. Simply create a rectangle and have it glow as a 
light source. Use these lights in stills and animations for improved realism for photo-
realistic renderings.

Using the Rectangular Area Light
1. Select Rectangular Area Light tool from Lights palette in the Window menu.

2. Following the prompts in the Message Line, click three points to build the rectangu-
lar area to be the light source.

3. In the Edit Objects dialog box, check the Visualize Light option to show the light 
source while rendering.
The rectangular light symbol appears on the screen.

4. Render the scene. 
Geometric Characteristics
According to the Edit Objects Geometry page, rectangular area light source is made up 
of the following characteristics: Type, Intensity, Attenuation, Cast Volumetric Shadows. It 
also includes the Enable Light check box, Cast Shadows check box and its associated 
pull-down menu, Visualize Light check box and Flip Direction button.
Flip Direction button changes the direction of the light source for 180 degrees.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
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type options: hard, medium, soft and blurry. This check box setting only applies when 
rendering the scene with Preview Render (shadows on) or Raytrace Render (shadows 
on, Anti-Alias). See Photo-realistic Rendering Commands.
Visualize Light check box makes the rendered light source look like a rectangular neon 
lamp when the scene is rendered. 

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. There are 
the following attenuation options:

Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase 

Area Light from Selected Surface

This kind of light emanates from a glowing surface achieving a perfect photo-realistic 
effect for stills and animations.

Using the Area Light From Selected Surface
1. Create any surface object.

2. Choose Area Light from Selected Surface in the Lights tool palette.

3. Following the prompts in the Message Line, pick the surface.
4. In the Edit Objects dialog box, check the Visualize Light option to show the light 

source while rendering.

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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The area light source symbol appears.
5. Render the scene.
Geometric Characteristics
According to the Edit Objects Geometry page, area light from selected surface light 
source is made up of the following characteristics: Type, Intensity, Attenuation, Cast 
Volumetric Shadows. It also includes the Enable Light check box, Cast Shadows check 
box and its associated pull-down menu, Visualize Light check box and Flip Direction 
button.
Flip Direction button changes the direction of the light source for 180 degrees.
The Enable Light check box turns off a light while retaining the intensity, direction and 
location settings. 
The Cast Volumetric Shadows check box enables simulation of a full range of effects 
occurring in a participating medium, i.e. attenuation within the medium, light filtration 
through a colored medium and first order light scattering inside the medium with 
volumetric shadows.
The Cast Shadows check box controls whether a shadow is cast by an object when a 
particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-down 
menu, there is the option of setting the type of shadow casting. There are four shadow 
type options: hard, medium, soft and blurry. This check box setting only applies when 
rendering the scene with Preview Render (shadows on) or Raytrace Render (shadows 
on, Anti-Alias). See Photo-realistic Rendering Commands.
Visualize Light check box makes the rendered light source look like a rectangular neon 
lamp when the scene is rendered. 

Attenuation Settings
Attenuation controls how quickly the light intensity 
diminishes with the distance from the light. There are 
the following attenuation options:

Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase 

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the following formula, 
Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the following formula, 
Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the following formula, 
Intensity /distance.

Unclamped 
Quadratic

Light intensity diminishes according to the following formula, 
Intensity /distance2.
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Ambient Lighting
Ambient light contributes light color and intensity to all objects in the scene. Ambient 
light penetrates all holes, indentations and cutouts of an object, illuminating all surfaces 
equally. Ambient light does not cast shadows. 
Choose View>Ambient Light Settings to display the dialog box.

The dialog box contains the following options:

After choosing the ambient settings, click OK. When saving the file, the ambient light 
setting is also saved.

Modifying the Lights
As designing the geometry and rendering it, view it under various lighting conditions, 
either by changing the layout or editing the light source.

Modifying Ambient Light
Ambient light can be modified through the Ambient Light Setting dialog box in the View 
menu. Adjust the color and intensity level and click OK to save the changes. Choose 
PhotoRender>Render to display the geometry with the new settings.

Modifying Directional Lights
Modify directional lights (Distant, Spot and Point) in a number of ways including moving, 
deleting and changing the intensity and color.

Moving a Light Source
Light sources are objects and can be 
moved like any other object. The Distant 
and Spot Light sources have two control 
points, the source location and the source 
direction. It is possible to move one or both 
points, the Point Light source has one 
control point, the source location.

Color This area sets the ambient light color. Either choose a color 
from the menu, enter a Red, Green, or Blue value in the 
respective data field or drag the RGB slides to the desired 
value. A color preview appears to the right of the sliders. The 
default ambient light color is white.

Intensity This option sets the ambient level. Either enter the value in the 
data field or use the slide to set the intensity. Zero (0) is off.
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Moving the Entire Light Source
Select the source. Place the cursor over the source location point and drag it to the new 
location. Choose PhotoRender>Render to display the image with the new light setting.

Moving the Control Points
Select the source and choose Edit>Show Points to display the control points. Drag a 
selection fence around the desired point and move it to the new location. Choose 
PhotoRender>Render to display the model with the new light setting.

Editing a Directional Light Source
Perform comprehensive editing on directional light sources through the Edit Objects 
dialog box. The options available depend on the light source.

Geometry Tab

Attributes Tab

Type Choose from the three lights available: Distant, Spot and Point.

Intensity Change the light intensity. Any value equal to or greater than 
zero is valid. Zero (0) turns the light source off. 

Attenuation (Spot and Point lights only) Controls how quickly the light 
intensity diminishes with the distance from the light.

Enable Light This check box controls the activation of the light source. When 
checked, the light is on. This check box turns off a light while 
retaining the intensity, direction and location settings. The 
default setting is on.

Cast Shadows This check box controls the display of shadows when a light 
shines on an object. A pull-down menu offers four shadow 
types: hard, medium, soft and blurry. This command works with 
Preview Render (shadows on) and Raytrace Render (shadows 
on, Anti-Alias) rendering commands.

Cone Angle (Spot light only) Controls the maximum spread of the spot light.

Falloff Angle (Spot light only) Controls the sharpness of the spot light’s 
edge.

Falloff Rate (Spot light only) Controls how light is distributed within the spot 
light’s cone.

Slide (Spot light only) This check box controls whether a spot light 
functions as a slide projector and projects an image on the 
scene.

Name Enter a specific name for the source.

Resolution This characteristic does not apply to light sources.

Color Specify any color for the light source. The pull-down menu 
offers the standard colors and the More option, which displays 
the color palette when selected.

Control Pts Display or hide the control points of the light source.

Layer Place a light source on any layer. The menu displays all 
available layers.

Locked  Lock the light source to prevent modification.
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Click Apply to accept the changes and then Close to exit the dialog box. Choose 
PhotoRender>Render to display the geometry with the new light settings.

Deleting a Light Source
To delete a light source, select the source and press the BACKSPACE key (Windows) or 
the DELETE key (Windows and Macintosh).

Default Lighting
This Designer Elements program provides default lighting for the geometry when using 
the Render command. The default lighting is based on the viewer’s eye location and 
direction to provide a high quality rendering of the geometry. The default light source 
cannot be modified. However, specify own ambient light with the default lighting. When 
placing own light sources, the default light source deactivates.

User-defined Lighting Layouts
Create own lighting layout using that layout for other drawings by exporting the lights to 
a stand-alone Designer Elements program file. This lighting file can then be imported 
into other files. To export a lighting set, do the following:
1. Select all the light sources by selecting each individually or using the Selection 

Mask.

2. Choose File>Export. 
3. Select the Designer Elements program format. 
4. Choose the Selected Only option.
5. Click OK and save the file as desired.
Now it is possible to import this lighting into other Designer Elements program files.
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Photo-realistic Sunlight for Stills and Animations
Cobalt, Xenon and Argon v8 feature photo-realistic sunlight settings for stills and 
animations using location, date and time. This makes it easy to do light and shadow 
studies for architectural designs. 

1. Select PhotoRender>Edit Sunlight. The Sunlight Settings dialog box appears.

2. Enter a city from the list for the longitude and latitude to show automatically, or click 
Add to include a custom location using longitude and latitude, and the time zone 
plus or minus from Greenwich Mean Time.
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3. Click Orientation and in the Sunlight Orien-
tation box set the position of the sunlight 
by North and East vectors.

4. Enter the desired date and time. This 
specifies the intensity of the sunlight auto-
matically.

When set to automatic mode, the sunlight color is determined by the coordinates and 
the date and time. In the Custom mode, it is possible to set any plain color. In the By 
Temperature mode, the sunlight color is determined by the color temperature. The 
temperature rate can be varied within 150 K and 20,000 K. 
Intensity Settings specify the exact amount of the sunlight that illuminates the square 
unit of the area. Auto uses the parameters specified in the Coordinates, Date/Time, and 
Sun Color. The Custom option provides the Intensity Units drop down menu with Lux, 
Kilolux and Footcandle options where Lux = Lumen/m2, Kilolux = 1000 Lux, Footcandle 
= Lumen/in2.
Sky Type Settings designate the Sky Parameters which also influence the sunlight 
intensity. 

Cloudiness Is set between 0 and 0.999. Either use the slider or input field 
to specify the level of cloudiness between Clear, Intermediate 
and Overcast. The greater the value the more overcast the sky. 

Pressure Set it to Low, Normal or High with the slider or input the value 
between 0 and 2500 in the field. 

Alpha Specifies the type of the locality. Use the slider to choose 
between Mountain, Rural and Maritime locality or set the value 
between 0 and 2 in the input field. 

AOD Specifies the type of the atmosphere. Use the slider to choose 
between No Aerosol, Clear and Dusty atmosphere or enter the 
value between 0 and 1 in the input field.

This rendering is set for 1 pm.

This rendering is set for 6 pm.
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The rendering results will reflect the correct position of the sun at that time and season 
of the year.
If the Draw Compass option is checked, the compass symbol appears in the left bottom 
corner of the screen. The compass symbol sets the orientation of the scene. 

Lights & Facets 
All facets are illuminated according to how much light falls on their vertices (the 
intersection of perpendicular isolines). If a light source is positioned over a large flat 
surface (such as a floor), it will appear that the source is not casting light. Set the object 
resolution to Very Fine or Super Fine to increase the facet density and enhance the 
lighting result. See Change Resolution for more information on resolution.

Fine Resolution Very Fine Resolution Super Fine Resolution
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Display Materials, Decals & 
Environments
Cobalt, Xenon and Argon come with a library of materials, decals, foregrounds and 
backgrounds to make rendering easier. There is also a tool for implementing photo-
realistic environment maps that reflect the surrounding world on an object’s surface. 
This chapter discusses:
• Render Library
• Editing the Rendered Scene
• Photo-realistic Environment Maps for Stills and Animations

Tip: Additional packages for materials, decals and environments are available
for separate purchase from Ashlar-Vellum. Please see the website at
www.ashlar.com.
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Render Library
This Designer Elements program 
comes with an extensive render 
library containing materials and 
decals that can be applied to objects 
and background and foreground 
properties that can be applied to the 
scene. This library is contained in the 
Render Library tool palette. Choose Window>Render Library to display the tool 
palette.
Resize the palette 
horizontally or 
vertically by dragging 
its edges or corners.

The palette contains 
the preview area, library type 
menu, category menu and scroll 
bar. The type menu controls which 
library displays on the palette. The 
Decals library type is shown in the 
graphic here.

Render Library Items
The render library menu contains four render libraries: Backgrounds, Decals, 
Foregrounds and Materials. Select any library by clicking on it or using the up or down 
arrow keys on the keyboard.

Within each library render images are divided into categories and displayed in the 
category menu. Select any category within the category menu by clicking on it or using 

Backgrounds Contains pre-defined background effects that can be applied to 
a scene.

Decals Contains pre-defined decals that can be applied to renderable 
objects.

Foregrounds Contains pre-defined foreground effects that can be applied to 
a scene.

Materials Contains pre-defined material properties that can be applied to 
renderable objects.
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the up or down arrow keys on the keyboard. The Glass category for Materials is shown 
in the graphic here. 

In addition to the render image categories each library also includes two standard 
categories, [All] and [System].

Most of the items in the Render Library define the color of the objects regardless of their 
pen color. However, for greater variety some materials use the object’s color. These 
include the following: Glass (Colored), Masonry (Brick-Colored), Metal (Polished), Misc. 
(Plain, Plain Rough, Plain Texture, Screen), Nature (Clouds), Patterns (Check Board, 
Cubes, Grid, Polka Dot Solid, Polka Dot Wrapped), Plastic (Clear Rough, Clear Texture, 
Opaque Rough, Opaque Texture, Stone (Marble), Wood (Simple) and Decals.
When placing one of these materials on an object, the material displays using the 
object’s color. For example: Brick-colored masonry placed on a blue object renders as 
blue masonry; Clear Rough Plastic placed on the yellow object renders with a yellow 
tint; Clouds placed on a red object renders as white clouds on a red object; Polka Dots 
placed on a green object renders as green dots on a white object.

Using the Materials Library
The Materials library contains materials to apply to the model. A material defines the 
surface color, transparency, reflectivity and roughness properties of a model. it is 
possible to produce a wide variety of visual appearances with different combinations of 
these attributes.

[All] Selecting this category displays every image in the chosen 
library.

[System] Selecting this category displays images originally shipped with 
this Designer Elements program.
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The categories in the Materials library include Flooring, Glass, Masonry, Metal, Misc, 
Nature, Patterns, Plastic, Stone, Tiled Textures, Walls, Wood and Woven Textures.

Flooring Render images include: Tile 1, Tile 2, Tile 3, Tile 4, Tile 5, Tile 
6, Tile 7, Wood Slats 1 and Wood Slats 2.

Glass Render images include: Clear, Colored and Mirror. The Clear 
and Colored options only display correctly when using one of 
the ray trace rendering commands.

Masonry Render images include: Block Stone, Brick (Colored), Brick 
(White), Brick (Peach), Cobble Stone, English 1, English 2, 
Flemish, Pavement (Gray), Pavement (Red), Rustic, Stone 
Wall.

Metal Render images include: Aluminum, Aluminum (Circular 
Brushed), Aluminum (Linear Brushed), Chromium, Cobalt, 
Copper, Gold, Graphite, Mercury, Nickel, Palladium, Platinum, 
Polished, Silver and Tungsten.

Misc Render images include: Bubble Wrap, Chisel, Plain Rough, 
Plain Texture and Screen.

Nature Render images include: Clouds, Clover, Grass, Leather, Skin, 
Sky 1, Sky 2 and Sponge.

Patterns Render images include: Checker Board, Cubes, Grid, Polka 
Dot Solid and Polka Dot Wrapped.

Plastic Render images include: Clear Rough, Clear Texture, Opaque 
Rough, Opaque Texture and Translucent. The Clear Rough, 
Clear Texture and Translucent options only display correctly 
when using one of the ray trace rendering commands.

Stone Render images include: Conglomeration, Granite, Gravel, 
Limestone, Marble, Marble (Gray), Marble (Pink), Sand and 
Silt.

Tiled Textures Render images include: Knurl, Knurl 2, Mesh 1, Mesh 2, Pitted, 
Splatter, Swarf, VS Logo and Waffle.

Walls Render images include: Diamond Paper, Tile 1, Tile 2, Tile 3, 
Tile 4 and Tile 5.

Wood Render images include: Bark, Beech, Black Limb, Black Palm, 
Black Palm 2, Bocotec, Brazilian Ebony, Brazilian Rosewood, 
Bubingac, Canary, ChakteKok, Cocobola, Cork 1, Cork 2, 
CurlyKoac, Flamewood, Gabon Ebony, Goncalo Alvesc, Holly, 
Honduran Rosewood, Indonesian Rosewood, Kingwood, 
Lacewood, Lignum Vitae, Macassar Ebony, Madagascar 
Rosewood, Mahogany, Maple, Narrac, Pau Ferr, Pear, 
Pernambuco, Peroba Rosa 2, Pine, Pink Ivory, Primavera, 
Satinwood, Sawdust, Sheduac, Simple, Spalted, Tulipwood, 
Verawood, Walnut and Zebrawood.

Woven Textures Render images include: Basket 1, Basket 2, Denim 1, Denim 2, 
Dog Tooth, Hessian, Loop and Webbing.
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The graphic shown is an example of Cobble Stone masonry applied to a 
block.

Tech Note: Using highly reflective material for an object in an empty space,
the rendered image may disappear since there is nothing to reflect. Add some
surrounding environment and render again.

Applying Materials
1. Choose Window>Render Library to display the dialog box.

2. Select the materials library and desired category in their respective menus.
3. Place the pointer over the desired render image and drag. As the image is dragged 

over the drawing, the pointer becomes the material application symbol.

4. Continue dragging to the object to which to apply the image. The object highlights. 
Release the mouse button.
You can apply a material to multiple objects simultaneously by selecting one or more 
objects while holding down the SHIFT key, position the cursor over the preview image, 
then right click the mouse button. 

Tip: To apply different materials to different faces of a solid see Material
Editing

Choose Apply Material to the Seleted 
Object(s) from the context menu.

5. Apply more images to the objects as desired. 
Then render the drawing using one of the 
commands in the Render menu.

Material per Face
Different materials may be applied to each face 
using the Deep Select tool.

To apply a material to a face:
1. Select Deep Select tool, choose the face and designate the material from the Win-

dow>Render Library menu. 

Application Symbol
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2. Right-click on the material and choose Apply to Solid Face(s).

3. Alternatively, choose the material from the Render Library menu, right-click it and 
select Apply to Solid Face(s) from the context menu. Then choose the face of the 
solid. The material is applied. Render the object to see the changes. 

The material for each face appears in the Design Explorer as a ball  and can be 
edited.
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Materials per Face are also editable through the Edit Objects box. Turn on or off the 
material under the Material Faces tab.

Geometric Characteristics
When applying materials to an object, a Material page is added to the Edit Objects 
dialog box. Each material potentially has a large set of characteristics determined by the 
internal material definition. These characteristics have been mapped to a basic set or 
common characteristics and include the following items: Reflectivity, Transparency, 
Roughness, Scale, Texture File, Enable Shadow Cast check box, Enable Shadow 
Receive check box, Double Side Facets check box and Is Backdrop Object check box. 
These characteristics are explained in the Material Editing.

Removing or Replacing Material
To remove material from an object, drag the None symbol from the Render 
Library to the object and the material is removed. The symbol is shown here.
One material can be replaced with another by simply dragging the new 
material image to the desired object. It is also possible to replace a material 
by displaying the Edit Objects dialog box, selecting the Material page and from the 
Texture file pull-down menu, choose another texture.
See Material Editing for more information.

Using the Decals Library
The Decals library contains pre-defined decals that can be applied to the model. A decal 
overrides the local surface color properties of an object to which it is applied.

When applied to an object, the decal snaps to its surface and adjusts its shape (planar 
rectangle, cylindrical patch or spherical patch) according to the selected surface. The 
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decal shape is automatically determined by the surface curvature using one of this 
Designer Elements program internal wrap modes, Planar, Cylindrical or Spherical.
The categories in the Decals library include Misc and Digits.

Planar Wrap This mode projects artwork along the decal’s 
normal vector and appears on the surface at the 
specified location. The graphic shows a planar 
decal symbol. The gray arrows indicate the normal 
direction. The area defined by the artwork and the 
normals (the dotted lines) is the planar wedge.

The graphic shows planar wrapping for 
one object using two decals. One decal 
extends beyond the surface edge and 
wraps along the other adjacent surface 
as defined by the planar wedge. The 
object’s reflection appears in the mirror 
behind it.

Cylindrical Wrap This mode projects artwork along the surface normals of an 
imaginary cylinder that passes through the decal’s location 
point. The decal molds itself to the selected object adjusting to 
the object’s radius. The area defined by the artwork and the 
normals are the decal wedge area.

The graphic here shows a cylindrical decal symbol 
with the normal direction indicated by the arrows. 
Any portion of the object that lies within the area 
bounded by cylindrical wedge (the dotted area in 
the graphic) and its normal displays the artwork. If 
the decal extends past the object edge, the decal will drag 
towards the center of the object.

The graphic here shows cylindrical 
wrapping for one object composed of 
a cylinder, bracket and block. The 
decal extends beyond the edge of the 
cylinder and bends toward the center 
of the cylindrical wedge, wrapping 
around the object. The object’s reflection appears in the mirror 
behind it.

Spherical Wrap This mode projects artwork along the surface 
normals of an imaginary sphere that passes 
through the decal’s location point. The decal 
molds to the selected object adjusting to the 
object’s radius. The graphic shows a spherical symbol with the 
normal direction indicated by the arrows. Any portion of the 
object that lies within the spherical wedge (the dotted area in 
the graphic) and its normal displays the artwork.

The graphic shows spherically 
wrapping for one object composed of a 
sphere and a bracket.
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This graphic is another example of the decal wrap modes.

Applying Decals
1. Choose Window>Render Library to display the dialog box.

2. Select the desired library and category in their respective 
menus.

3. Place the pointer over the desired render image and drag. As the image is dragged 
over the drawing, the pointer becomes the decal symbol.

4. Continue dragging the decal to the object to which it is to be applied. Use the axes 
included with the symbol for alignment. Release the mouse button.

Apply more decals to the objects as desired. Then render the drawing using one of the 
commands in the Render menu.

Tip: To prevent a decal from showing through an object, select the decal and
display the Edit Objects dialog box. Deselect the Auto Wrap option and select
either the cylindrical or spherical wrap mode. 

Removing or Replacing Decals
To remove a decal from an object select the decal and delete it like any other object. 
Replace one decal with another using the Edit Object dialog box.

Geometric Characteristics
A decal is considered an object in this Designer Elements program. When a decal is 
applied, the Edit Objects dialog box contains characteristics specific to a decal object. 
The characteristics include: Rotation, Width, Height, Wrap Mode, Auto Wrap check box, 
Lock Normal check box, Masking, Stencil and Logo.

Misc Render images include: Eroded. When an object is rendered 
with this decal, the object material appears to be wearing 
away.

Digits Render images include the numbers 0 through 9.

Decal Symbol

Rotation This field sets the rotation angle of the decal. The default value 
is 0. Entering a new value (between 0 and 360) and clicking 
Apply rotates the decal around the decal normal by the 
specified angle.

Width/Height These fields set the decal’s coverage area.The values are 
linear or arc lengths depending on the wrap mode.

Wrap Mode This field displays the decal wrap mode. It also includes a pull-
down menu listing the three wrap modes, planar, cylindrical 
and spherical.

When Auto Wrap is not selected, use the wrap mode list to set 
the decal wrap mode. If the decal is moved to another object, 
the wrap mode does not change.
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Auto Wrap This check box control the wrap operation. When this box is 
checked, the wrap mode is matched to the surface curvature of 
the underlying object. The computed wrap mode is displayed in 
the Wrap Mode field. If the decal is moved to another face of 
the object, the wrap mode is re-calculated.

When this box is left unchecked, the wrap mode is set using 
the Wrap Mode pull-down menu. 

One possible application of this is to apply a decal to a fillet. 
Uncheck auto wrap and lock normal and place the decal over 
the fillet.

Lock Normal This check box locks the normal of the decal. When this box is 
checked, the decal’s normal is always perpendicular to the 
object at the selected surface. When left unchecked, the decal 
can be placed at any angle with respect to the surface.

By selecting the decal and choosing 
Edit>Show Points, two control points 
display, the stencil control point and 
the normal point.

Select the stencil control point and drag it to a new angle. 
Select Lock Normal again and click Apply, the decal snaps 
back to the normal location.

Radius (Cylindrical and Spherical wrap only) Specify a radius for the 
center point or the stencil control of the decal, different from 
the default value listed.

When placing a decal on a face it automatically projects 
through to the back face. Changing this value such that the 
radius falls within the body results in the decal appearing only 
on the face to which it was applied.

Masking This menu controls how a decal is applied on an object’s 
surface. There are two options, Stencil and Factor.

Stencil masking uses an image file to 
define the regions of the decal artwork 
that will show on an object’s surface. The 
graphic here uses a star stencil and 
mesh artwork. 

Factor masking is used to put a full image on an object surface. 
Where stencil masking only places artwork on the object as 
defined by the stencil, factor masking places the entire artwork 
image on the object with no cropping. This can be used for 
placing logos on objects or artwork on walls. 
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The graphic here shows the same 
artwork with factor masking instead of 
stencil masking.

Stencil (Appears when Stencil Masking is selected) This field displays 
the name of the image file used. These stencil files are located 
in the Textures folder within the PhotoRender folder. To use 
own stencils in this Designer Elements program, place them in 
this folder.

When creating stencils, it is important to know that a stencil is 
composed of pixels using the RGB color system. The red 
component (per RGB) of each pixel in the stencil image file is 
used as the color mix factor. A red value of 0.0 indicates that 
0% of the artwork color is used at the pixel location. Thus, that 
pixel color is determined by the color of the object’s material. A 
red value of 1.0 indicates that 100% of the artwork color is 
used at the pixel location in place of the color of the object’s 
material. An intermediate value results in a mixture of the 
artwork color and the underlying material color.

Example: Creating a stencil that is 100% red (RGB), only the 
artwork color projected onto the object is used. If the red 
percentage is lowered, some of the underlying material color 
mixes in. If black and red is used in the stencil, those areas 
that are black (or a 0% red value) use the underlying material 
color when the artwork is projected. Any color other than black 
or red in the stencil is ignored.

Typically, a stencil file is composed of fully red and fully black 
pixels. This provides a clean cropping of decal artwork. 
However, aged effects can be created using a stencil image file 
that consists of a mottled red patch on a black background.

In equation form, this combination translates into: 
SurfaceColor=ArtWorkColor*RedVal+MaterialColor*(1.0-
RedVal). 

This formula shows how this Designer Elements program 
references the stencil file.

Factor slide (Appears when Factor Masking is selected) This slide sets the 
value for Factor masking. Factor masking uses a single mix 
factor to compute the artwork material color combination. This 
masking is similar to Stencil masking except that there is only 
one value used for all pixels.
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Using the Backgrounds and Foregrounds Libraries
Backgrounds and foregrounds can be used to set the overall scene. Only one 
foreground and one background can be used per rendered drawing.

Backgrounds Library
The Backgrounds library contains pre-defined background effects that can be applied to 
the model. Backgrounds control the appearance of those regions of a scene that do not 
contain objects.

When the slider is set to the far left, representing 0.0, the decal 
color is set by the object’s material. When the slider is set to 
the far right, representing 1.0, the decal color is used. The left 
graphic below has a 0.0 factor setting. The right graphic has a 
1.0 factor setting.

In equation form the combination translates into: 
Surface=ArtWorkColor*MixFactor+MaterialColor*(1.0-
MixFactor). 

Logo This menu sets the source for the decal’s 
artwork. There are two options, Color and 
Image. In the example here, the 
DigitCourier2 is used as the decal stencil 
and a pebble image is used as the 
artwork.

Color logos use a solid color for the decal artwork. By default 
the color of the decal stencil is used when placed on an object. 
Change the color of the decal by selecting it and choosing a 
different color in the Pen menu or on the Attributes page of the 
Edit Object dialog box.

Image logos use an image file for the decal artwork.

Image (Appears when Image is selected from the Logo menu.) This 
pull-down menu lists the images available for decal artwork. 
These images are located in the Textures folder within the 
Photo Render folder. To use own images place them in this 
folder. See User-defined Images for more information.
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The categories in the Backgrounds library include Images, Misc and Nature.

The graphic shown is an example of a cloud background. 

Foregrounds Library
The Foregrounds library contains pre-defined foreground effects 
that can be applied to the model. Foregrounds effect the way the 
space between the eye point and the scene objects alter the 
rendering results.

The categories in the Foregrounds library include Misc and Nature.

The graphic shown is an example of a snow foreground. 

Applying a Background or Foreground
1. Choose Window>Render Library to display the dialog box.

2. Select the desired foreground or background library.
3. Place the pointer over the desired render image and drag. As the image is dragged 

over the drawing, the pointer becomes the application symbol.
4. Drag to the drawing area and release the mouse button.

Removing or Replacing Backgrounds and Foregrounds
To remove a background or foreground from a scene drag the None symbol 
from the Render Library to the object and the material is removed. The No 
Material symbol is shown here.
Replace one background or foreground with another by dragging the new 
image to the scene.

Geometric Characteristics
Foregrounds and Backgrounds have no geometric characteristics therefore are not 
accessible through the Edit Objects dialog box. However, they can be edited using the 
Edit Foreground or Edit Background commands in the Render menu. For information, 
see Background and Foreground Editing.

Images Render images include: VS Logo.

Misc Render images include: Graduated (Gray Black, Purple White, 
Red White, White Black, White Gray, White Purple, White Red) 
and Plain (Black, Gray, White).

Nature Render images include: Clouds.

Misc Render images include: Depth Cue (Black, Gray and White).

Nature Render images include: Fog (Heavy, Light), Ground Fog 
(Deep, Shallow) and Snow (Light, Heavy).
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User-defined Images
Own material and decal images can be used in this Designer Elements program when 
used with the Edit Objects dialog box. This ability is useful to have specific materials or 
decals unique to your company and industry. On possible use is the application of 
company logos to objects in the drawing.
To prevent distortion all texture images should be square. LightWorks, the rendering 
engine, maps textures to a 1” square when the scale is set to 1.0.

Creating Custom Decals
To apply own decals, create own decal stencils and artwork. Since the artwork projects 
through the stencil, any bitmap image is acceptable. Create the artwork image using any 
graphic program that supports bitmaps.
To create a stencil do the following:
1. Create the shape of the stencil.

2. Color the stencil using a percentage of red depending on the desired stencil affect.
Set the Red value (RGB color) to 255 or 100% red to project the artwork color onto 
the object without using the material’s color. Lower the Red value to mix some of the 
underlying material’s color with the artwork color. Use black in those areas where only 
the material’s color must be added when the artwork is projected.

Applying User-defined Material Images
1. Create own bitmaps images.
2. Place them in the Textures folder located within the PhotoRender folder stored with 

the program.
These textures will not appear as an image in the Render Library.

3. Apply a Designer Elements program supplied texture to the object.
4. Double-click on the object to display the Edit Objects dialog box.
5. From the Texture file menu select the image created.
6. Click Apply and render the scene. Your own material is displayed on the object.

Applying User-defined Decal Images
1. Create your own bitmap images, both the decal stencil and the decal artwork.

Make sure to follow the stencil and artwork formulas as directed earlier in this chapter.
2. Place the stencils and image in the Textures folder located within the PhotoRender 

folder stored with the program.
3. Double-click on the decal to display the Edit Objects dialog box.
4. From the Stencil menu in Edit Objects select the stencil image created.
5. In the Logo menu choose the Image option.
6. From the Image menu, select the artwork image created.
7. Click Apply and render the scene.

Your own decal is displayed in the scene.
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Custom Decals From Alpha Images
It is possible to create custom decals. To accomplish this:
1. Go to Window>Render Library.

2. Right-click in the gray space of the Render Library dialog box to bring up the context 
menu and choose the Create New option. The Add Decal dialog box appears.

3. Fill in the Name and Category fields or choose the Category from the drop down 
menu on the right. 

4. Choose Image from the Masking drop down menu.
5. Specify the image file name from the Image drop down menu or browse the system. 

To browse the image, navigate to the file location in the Open window, select the file 
and press Open. The system confirms that the file has been successfully copied. Click 
OK in the window. Also click OK in the Add Decal dialog.

6. The custom decal is created with the desired file. The newly created decal can be 
used in the same way as all the other decals from the library.
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Decal Material Options
Materials can be applied to decals as well as to the objects. The picture shows a label 
on a bottle, which was applied as a decal, and a material was applied to the decal. So 
the decal has its own material options.

To edit the decal material, right click on the Material in the Design Explorer’s Feature 
Tree.
Displacement and Reflectance options are available for decal materials in the Render 
Material Settings.
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Editing the Rendered Scene
This Designer Elements program now gives the access to Lightworks shader 
technology. Instead of one shader, there are now five different shaders to render the 
scene. Change the object materials or the background and foreground images.
Once materials are applied to the objects and a background or foreground are applied if 
desired, it is possible to edit them.

Material Editing
Cobalt, Argon and Xenon provides a wealth of pre-defined render materials. Sometimes 
though, it is necessary to edit these materials or perhaps start from scratch to create 
your own. There are two levels of editing materials of an object; the first is through the 
Material page in the Edit Objects dialog box; the second is through the Render Material 
Settings dialog box accessed through the Material page.

Tip: When using materials such as polished metal setting the reflectivity to a
value less than one may produce a better rendering.

The Material page of the Edit Objects dialog box include the following characteristics or 
options:

Reflectivity This field sets the material’s reflectivity. Values can be entered 
between zero (0) and one (1). Entering a zero in the field 
renders a flat finish. Entering a one in the field renders a 
mirrored finish.

Transparency This field sets the transparency of the material. Values can be 
entered between zero (0=transparent) and one (1=opaque). 
This option only works correctly when objects are rendered 
with ray trace rendering commands.
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Roughness This field sets the roughness of the material. Values can be 
entered between zero (0) and one (1).

Scale This field sets the scale of the material. Typically scale 
increases the size of the detail. Values can be entered equal to 
or greater than zero (0).

Texture File This field displays the selected material. The pull-down menu 
lists all images in the texture folder. For those materials that do 
not support textures this menu is not available.

Enable Shadow Cast This check box specifies if an object casts shadows. This is 
valuable for reducing the shadows present in complex 
drawings. When checked the selected object casts shadows.

Enable Shadow 
Receive

This check box specifies whether an object will receive 
shadows from other objects. This ability is valuable for 
reducing the number of shadows present in complex drawings. 
When checked the selected object receives shadows.

Double Sided Facets This check box provides additional rendering control for 
surfaces. Objects with normals facing away from the line of 
sight are not rendered. When checked, all objects are 
rendered, regardless of the normal direction. 

Select this option for objects that cause light refraction, like 
glass. When left unchecked facets on the back side of the 
glass are ignored resulting in an inaccurate rendering.

Is Backdrop Object This check box optimizes rendering calculation time for an 
object, like a wall, that functions only as a backdrop for other 
objects. Since the object automatically receives light due to its 
large size, this Designer Elements program does not need to 
spend much time performing light ray calculations.

Advanced button Clicking this button brings up the Render Material Settings 
dialog box. Use this dialog to change the advanced rendering 
settings used on the selected object. See the next section for a 
detail description of these settings.
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Render Material Settings
When clicking the Advanced button on the Material page of the Edit Objects dialog box, 
the following dialog box appears.

The dialog box includes the following sections and options:
Shader Class
This section displays the shader class. Select the class from the pull-down menu. There 
are five shader classes: Color, Displacement, Reflectance, Transparency and Texture 
Space. The shader types, their associated attributes and values vary with the shader 
class. Each shader class works independently of the others. The setting for one shader 
does not affect another. However, the settings in each class work together to create the 
final object appearance when it’s rendered.

Shader Types This section lists the shader types for the selected class. 
Select the type from the list. Each set of types is unique to the 
class. Each type has its own set of attributes.

Attributes This section displays the attributes for the selected type. Select 
an attribute for the type from those listed. Each attribute has its 
own set of values.

Attribute Value This section usually displays the values for the selected 
attribute. Choose or enter the attribute value. The value range 
appears at the lower left corner of the dialog box. The values 
can be numerical, an image file or a color setting. An Edit 
button displays in this section when a shader attribute is 
selected. Clicking this button displays a copy the dialog box to 
select the shader from the same shader type list as the original 
dialog box.

Preview Sample This section displays the preview window shape list, preview 
window, the Auto option and an Update button.

The preview window shape list sets the object shape shown in 
the window. There are five shapes available from the pull-down 
menu: cone, cube, cylinder, object and sphere. This feature 
allows you to see how the same shading characteristics 
appear on different shapes. Object, which displays the actual 
shape, is the default shape.
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After specifying the settings for an object from the desired classes and types, this 
Designer Elements program combines the settings from all five shaders (Color, 
Displacement, Reflectance, Transparency, Texture Space) to render the object with one 
of the photorealistic commands. The settings work together to create the final effect.

The preview window displays the shape based on the shader 
class, type, attributes and values currently set.

The Auto option controls whether the preview image is 
automatically refreshed when a material setting changes. 
Checking this box results in an automatic refresh. When 
checked, the Update button is unavailable.

The Update button controls the manual refresh of the preview 
window. Click the button to refresh the preview window image 
after making a material setting change.

Range This area, at the lower left edge of the dialog box, displays the 
value range for the selected attribute.

Auto Check this to view material setting changes display in real time 
right away after the settings are changed.

Update Updates the view of the object. If Scene Preview is unchecked, 
the material changes are displayed in Render Material Settings 
dialogue box, if Scene Preview is checked the changes display 
in the main scene.

Scene Preview Real time photo-realistic material changes display in the 
Render Material Settings dialogue box if the Scene Preview 
box is not checked.

OK Click this button to close the dialog box and save the settings. 
The selected object automatically updates to reflect the 
changes.

Cancel Click this button to close the dialog box without saving the 
changes.
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Color Class
Use this class to define the object color. The color shader types allow you to specify a 
color from one color to more complex patterns of color. The shader types are listed 
alphabetically. For the purposes of this explanation, the types are grouped into following 
categories:

All shader attributes are defined in Appendix F: Shader Attribute Definitions.

Tech Note: Enter values in the attribute value field and change to another
shade type, those values are not retained. To experiment with various
settings, record the values before changing shader types.

Curvature These types use color to show the object’s curvature and 
include: absolute, gaussian, geometric and mean.

Texture These types are 3D color shaders that give the object a 
specific appearance. The texture shaders include: birch, blue 
marble, cherry, chrome, maple, marble, oak, pine, plain, simple 
wood, solid clouds, solid polka and wood.

These shaders are different from image shaders in that they 
calculate a particular pixel color in 3D space for the object 
based on the type attributes. Imagine the object carved out of a 
block of the selected texture. In contrast, an image shader 
uses the associated 2D bitmap to determine the object color 
rather than individual pixels.

Evaluation These types use color to evaluate the selected object and 
include: draft angle and surface. See the Geometric Properties 
for information of surface and draft evaluation. Also see 
Surface Evaluation and Draft Evaluation.

Wrapped Image These types use an associated 2D bitmap image to determine 
the object color. The image is wrapped around and mapped to 
the entire object. These types include: wrapped image and 
wrapped filtered image. The available images are located in 
the Textures folder inside the PhotoRender folder.

Wrapped Textures These types are 2D color shaders that are wrapped around the 
object. Unlike wrapped image shaders, these shaders 
calculate the shader color based on the attribute values and 
are not associated with a bitmap image. These shaders 
include: birch floor, wrapped brick, wrapped checker, wrapped 
cherry floor, wrapped diagonal, wrapped grid, wrapped maple 
floor, wrapped oak floor, wrapped pine floor, wrapped polka, 
wrapped s stripe, wrapped t stripe, wrapped textured brick and 
wrapped wood floor.

Decal The decal shader type defines the decal texture space, 
transparency and color.

Turbulent The turbulent shader type creates an agitated or turbulent 
effect using color and contrast.
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Displacement Class
Use this class to define the roughness of an object. The displacement shader types 
specifies a variety of roughness patterns. The shader types are listed alphabetically. For 
the purposes of this explanation, the types are grouped into following categories:

All shader attributes are defined in Appendix F: Shader Attribute Definitions.

Tech Note: Remember that by definition applying a reflectance to an object
means that the object will have something to reflect. If there is no background
on other object in the scene to reflect, when rendered the object may
disappear.

Reflectance Class
Use this class to define the object’s reflectance. The reflectance shader types specify a 
variety of reflectance values and patterns defining a surface’s finish. If no reflectance is 
specified for a material, the default Gouraud type finish is applied.
The shader types are listed alphabetically. For the purposes of this explanation, the 
types are grouped into following categories:

Displacement These types create a displacement calculated in 3D space 
using the pattern defined by the shader’s attributes and 
include: casting, flat, leather and rough. Like the Color texture 
shaders, imagine that the object is carved out of a 
displacement shader block.

Wrapped 
Displacement

These types create a displacement by wrapping the 2D pattern 
defined by the type attributes around the object. The shaders 
include: wrapped dimple, wrapped knurl, wrapped leather, 
wrapped rough and wrapped tread plate.

Wrapped Image These types use an associated 2D bitmap image to determine 
the displacement and include: wrapped bump map and 
wrapped old bump map. When using an image for 
displacement, the shader examines the % color change from 
pixel to pixel to determine the displacement. For example, an 
image with black and white stripes might appear as a groove 
displacement. Gradual color changes in an image result in a 
more general displacement from pixel to pixel. The available 
images are located in the Textures folder inside the 
PhotoRender folder.

None This type creates no displacement.

Standard These types are reflectance modelers that provide a particular 
appearance according to the shader selected. These shaders 
include: chrome 2D, constant (color), matte finish, metal finish, 
multilayer paint, phong, plastic, translucency and translucent 
plastic.

Ray Trace These type modelers are reflectance simulations using ray 
tracing. They range in accuracy from approximations to 
physically accurate. These shaders include: conductor 
(metallic), dielectric (glass), glass (approximation) and mirror, 
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All shader attributes are defined in Appendix F: Shader Attribute Definitions.

Transparency Class
Use this class to define the transparency of the object. This shader types set transparent 
or opaque nature of an object. These shaders can create transparency effects which 
range from simple to complex and irregular. The shader types are listed alphabetically. 
For the purposes of this explanation, the types are grouped into following categories:

All shader attributes are defined in Appendix F: Shader Attribute Definitions.

Texture Space Class
Use this class to define the plane of the texture space or how textures are projected to 
the object. If no texture space is selected, the texture is projected down the z axis and 
uses the z plane. The types include the following:

Wrapped These type reflectance shaders wrap the reflectance image 
around the object creating the effect specified by the shader. 
These shaders include: wrapped anisotropic (parallel ridges), 
wrapped circular anisotropic (circular ridges), wrapped mirror 
map and wrapped woven anisotropic (woven threads).

Decal This reflectance shader defines the decal and base color 
reflectance.

Standard These types create a transparent effect based on the shader 
selected and include: eroded, glow, plain (based on the red 
component of the color selected where red is transparent and 
black is opaque) and plain coverage (based on a value).

Wrapped These types create a transparent effect by wrapping the effect 
around the object and include: wrapped checker, wrapped grid, 
wrapped mask and wrapped square.

Wrapped Image These types create a transparent effect by wrapping a 2D 
image around the object and include: wrapped image and 
wrapped mask. The available images are located in the 
Textures folder inside the PhotoRender folder.

None This type creates no transparent effect.

arbitrary plane This type specifies the vector along which the texture is 
projected.

auto axis This type automatically chooses either the x, y or z axis, 
depending on the normal of the object face.

cylindrical This type projects the texture image to a cylindrical space 
using the user-defined origin to set the texture’s starting point.

spherical This type projects the texture image to a spherical space 
around the radials.

uv This type projects the texture onto the object using the uv 
coordinate system.

x plane This type projects the texture to a constant x plane where the 
positive z axis is up.

y plane This type projects the texture to a constant y plane where the 
positive z axis is up.
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All shader attributes are defined in Appendix F: Shader Attribute Definitions.

Using the Render Material Settings Dialog Box to Edit Your Object
1. Double click on the object being modified to open the Edit Objects dialog box.

Remember that a material must already have been applied to the object.
2. Select the Material page.
3. Click the Advanced button to display the Render Material Settings dialog box.
4. Select the desired settings for each shader class, as desired.
5. Preview the object using the Update button or the Auto option.
6. Click OK, when the settings are satisfactory, to close the dialog box and save the 

settings.
Another object can be selected for editing or use the Eye Dropper tool to apply the 
same setting from this object to another object. The Eye Dropper tool copies object 
characteristics such as line font, color, pattern, arrow at start and end and render 
materials from one object to another. See the Eye Dropper Tool for information on the 
Eye Dropper tool.

7. Render the scene with one of the photorealistic commands. The objects now appear 
based on the settings specified for each object. 
See Photo-realistic Rendering Commands for information on using them.

Background and Foreground Editing
To edit the background or foreground appearance already applied to the scene, choose 
PhotoRender>Edit Background or Foreground. (If a background or foreground is not 
applied to the scene, no dialog box appears.) The Shader Settings dialog box appears.

This dialog box is almost identical to the one that appears when editing object materials 
and is divided into the same sections, Shader Class, Shader Types, Attributes, Attribute 
Value and Preview Sample. See Material Editing for a description of each section.
For certain shader types the Attribute value is the Edit button. Clicking the button opens 
another Shader Settings dialog box that is identical to the first. Select the shader type, 
attributes and attribute values and click OK. You are returned to the first Shader Settings 
dialog box.

z plane This type projects the texture to a constant z plane where the 
positive y axis is up.
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Background Settings
The Shader Settings dialog box contains only the Background class and its related 
types, attributes and values. The shader types are listed alphabetically and include:

Foreground Settings
The Shader Settings dialog box contains only the Foreground class and its related 
types, attributes and values. The shader types are listed alphabetically and include:

clouds This shader type creates a cloudy background.

graduated This shader type displays a graduated background in the 
specified color.

image This shader type applies a background from an image file. The 
available images are located in the Textures folder inside the 
PhotoRender folder.

mixed This shader type mixes background shaders according to the 
mixing ratio. Ratios between 0 and .5 favor the base shader. 
Clicking on the Edit button in the Attribute Value section opens 
a second Shader Settings dialog box for choosing the shader.

none No background appears in the scene.

plain This shader type displays one color background.

ray cube This shader type displays a background using primary and 
secondary shaders to deal with refractions and reflections. 
One shader is used for background areas that are directly 
visible. The other shader is used for the refraction component. 
For example, if this Designer Elements program casts a ray 
that does not intersect any geometry, the primary shader is 
used. If the ray does intersect geometry the ray is reflected and 
uses the secondary shader.

scaled image This shader type applies the background from an image file 
which is scaled to fill the drawing window. The available 
images are located in the Textures folder inside the 
PhotoRender folder.

two planes This shader type applies a background using a back and front 
shader to deal with refractions and reflections. One shader is 
used for background areas that are directly visible. The other 
shader is used for the refraction component. For example, 
having a mirrored object and set the front shader to one type 
and the back shader to another, the shaders are reflected on 
the object.

depth cue This shader applies a background color with a linear 
attenuation of the color between a specified near and far value. 

fog The shader applies a gradual fog to the scene based of the 
color, density and distance specified by the user.

fog light This shader creates a light scattering effect when used with 
point and spot light sources.

ground fog This shader simulates fog that decreases gradually with 
altitude.
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Photo-realistic Environment Maps for Stills and 
Animations
A shiny object in a real world scene will exhibit reflections on its surface. These relate to 
a phenomenon called specular reflection, which occurs when light energy on the surface 
is reflected immediately, without being absorbed by the material. There are two 
categories of specular reflections. The first is known as incoherent reflection and 
manifests itself as highlights. Highlights are specular reflections of light sources and 
appear as bright regions when they are reflected in a surface. The second category is 
known as coherent reflection, and appear as mirror-like reflections of other objects 
within the scene. An extreme example of this is a wall mirror, but the same property is 
exhibited by many types of surfaces, such as machined metals, chrome, and polished 
floors and tables.
In computer graphics, reflection mapping is an efficient method of simulating a complex 
mirroring surface using a predefined texture image. The texture is used to store the 
image of the environment surrounding the rendered object. There are several ways of 
storing the surrounding environment. The most common ones store a single texture 
containing the image of the surrounding as reflected on a mirrored ball.
Environment mapping is a method of quickly calculating reflections. It is similar to ray 
tracing, however, ray tracing is much more accurate since everything in the room must 
be modeled. Environment mapping, on the other hand, substitutes a picture so that 
items are reflected on the model for visual effect. Photo-realistic environment maps are 
a handy tool when the details of the reflection are less important.

Referral: Real-time environment maps, as opposed to photo-realistic ones,
are also available for surface analysis of objects. See Surface Evaluation for
details.

light scattering This shader creates an atmospheric scattering of light effect 
more general than that created by the fog light shader.

none No foreground appears in the scene.

scattering medium This shader simulates a dense scattering medium based on 
various settings including color, shadows, attenuation and 
density.

snow This shader simulates the effect of falling snow.
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Seven photo-realistic environment map styles are included in Cobalt, Xenon and Argon. 
They include: 

Cube A cubic environment map at infinite distance with six 
independent images.

Fixed Cube A cubic environment map at a fixed distance and location from 
the model, composed of six images.

Cross A cubic environment map at infinite distance using one 
composite image assembled in a photo editing program.

Fixed Cross A cubic environment map at fixed distance and location using 
one composited image.

Spherical A spherical environment map at infinite distance using one 
fisheye image of 180°.
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Using a Photo-realistic Environment Map
There are two ways to apply a photo-realistic environment map.
To apply a reflection map to a rendering:
1. Go to Window>Render Library and select Environment Map from the drop down 

menu of the Render Library dialogue box. Then specify the type of the environment 
map.

2. The system queries whether or not to apply an environment background. 
3. Choose Yes for the environment box to appear around the object that reflects it. 

Choose No for the object to reflect the surrounding environment while the 
environment stays invisible.

4. Check the Use Environment Map option in the PhotoRender Menu.
5. Apply the environment map by choosing one of the first nine options from the Photo-

Render Menu.
Alternatively: 
1. Use the PhotoRender>Edit Photorender Environment Map command. The dia-

logue box appears.

Latlong A panoramic environment map at infinite distance using a 360° 
panoramic image. 
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2. Choose the type of the environment map from the drop 
down menu.

3. Select the image(s) for the environment map. 
For most environment map types only one image 
can be specified. 
If Cube is chosen, all the six image drop downs 
can be specified. Use the Browse option in the 
drop down menu to locate your own image. 
If Fixed Cube is chosen, all the six images, plus 
the center point and size of the environment map 
can be specified. Check Auto to let the program 
set the environment map parameters.

4. Click the Add to Render Library button to apply. 
Specify the name of the map to add to the render 
library and click OK. 

After designating environment map settings click OK.
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Photo-realistic Images
Cobalt, Xenon and Argon provide advanced rendering tools that control the definition 
and generation of photo-realistic images, including ray-tracing. Unlike the basic 
rendering functionality, advanced rendering is not used during geometry construction 
and editing. Advanced rendering is a back-end tool that interacts with the geometry 
already created. Advanced rendering is implemented using the LightWorks rendering 
engine for both Windows and Macintosh. Discussions in this chapter include:
• Advanced Rendering Settings
• Interleaved Wireframe Geometry
• Raytrace Rendering
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Advanced Rendering Settings
Use PhotoRender>Advanced Settings to bring up the Photo-realistic Render Settings 
dialog box to designate custom settings. User Settings are used only when selecting 
Render (User Settings) from the PhotoRender menu. Common Settings and Sunlight 
settings influence rendering when any other option from the PhotoRender menu is 
chosen.
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Advanced settings include:

Allow Shadows Enables or disables shadows.

Anti-aliasing Enables or disables all forms of anti-aliasing. Checking this 
box accesses the advanced anti-aliasing settings including 
those for edges, shadows, reflections and texture quality. The 
default value is unchecked, meaning that no anti-aliasing is 
performed.

Anti-aliasing of 
Edges 

Anti-aliases the edges of geometry when rendered. The default 
is unchecked. Note that if the overall Anti-aliasing box is not 
checked, then checking this will have no effect.

Anti-aliasing of 
Shadows 

Anti-aliases the edges of shadows when rendered. Setting this 
provides the most complete form of anti-aliasing, including the 
edges of reflected or refracted geometry. Note that checking 
this will override all other anti-aliasing settings (except the 
overall Anti-aliasing control).

Anti-aliasing of 
Reflections

Anti-aliases reflected and refracted textures when rendered. 
The default value is unchecked. Note that if the overall Anti-
aliasing box is unchecked, then modifying this will have no 
effect.

Texture Quality When set to high, anti-aliasing is enabled for textures and 
material shaders which support anti-aliasing. The default 
setting is low, which means that no texture anti-aliasing takes 
place.

Oversampling Level Sets the Oversampling Level which applies very simple anti-
aliasing to the rendering if required. Setting a value greater 
than 1 results in over-sampling of each pixel. The color of each 
pixel is sampled many times and then an average color 
calculated. There is a noticeable effect on rendering speed if 
this value is increased. The valid range is 1 to 16, the default 
being 1 with no oversampling performed. Note that if the Anti-
aliasing box is unchecked, then modifying this value will have 
no effect. Also if Anti-alias Shadows is on, it overrides this 
setting.

Transparency Enables or disables transparency.

Reflections Enables or disables ray-traced reflections.

Max Ray Bounces Controls the number of ray trace bounces used during 
rendering. The smaller the number the faster ray tracing will be 
for complex scenes. If the value is set to be too low then 
effects, such as multiple reflections, may not be rendered 
correctly. Ashlar-Vellum recommends starting with the default 
setting of 6 and adjusting it from there.

Min Ray Contribution Controls the minimum contribution made by a secondary ray 
(reflected, refracted or alpha ray) before it is ignored. A value 
of 5 means that if the traced ray would contribute less than 5 
percent to the total illumination at the pixel of interest then its 
contribution is ignored.
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Tech Note: The pre-set options accessed from the PhotoRender menu use
a value of 10 for ray bounces, reflections and refractions.

Custom Render Presets
Advanced Settings can be changed as necessary. Go to PhotoRender>Advanced 
Settings. In the Advanced Settings dialog box modify the settings as desired, press the 
Save button, then type in a new name for this group of settings. 

The new settings will be available in the Preset drop down menu of the Photo-realistic 
Render Settings dialog and also in the Shade Now option in the Shade Options dialog. 
The objects can be rendered only in the Render [User Settings] mode of the 
PhotoRender menu.

Override Global 
Bounces

Enables or disables the following two controls. If checked it 
allows control of maximum reflections and refractions. If left 
unchecked then all ray depths are the same as Max Ray 
Bounces.

Max Reflections Controls how many levels of reflection are considered during 
renders. The lower the number of reflections, the faster ray 
tracing will be for complex scenes. If the value is set to be too 
low then any multiple reflections may not be rendered 
correctly.

Max Refractions Is the same as Max Reflections, but applies to refracted or 
alpha rays.
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Interleaved Wireframe Geometry

It is possible to interleave 3D wireframe geometry in photo-renderings including all types 
of edges, curves, dimensions and text.
To enable interleaved wireframe geometry:
1. Check the Use Interleave Wireframe Geometry option in the PhotoRender menu or 

in the Photorealistic Render Settings window.
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2. Select the Edit Interleaved Wireframe Geometry Settings option in the PhotoRender 
menu or press the Edit button next to the Interleave Wireframe Geometry option in 
the Photo-realistic Render Settings dialog.
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3. The Interleave Wireframe Settings dialog box appears.

In this window separately toggle On/Off rendering for wireframe geometry and object 
edges (Render Wireframe and Render Edges check-boxes). Also set color and weight 
properties for wireframe rendering. If the Use Common Line Weight option is checked 
then PhotoRender uses the selected weight for all wireframe objects rendering. 
Otherwise PhotoRender uses object weight for rendering. This box also sets rendering 
color options by checking the Use Common Line Color check-box and specifying a color. 

Raytrace Rendering
This Designer Elements program photo-realistically renders the geometry. Specify 
rendering settings and choose among various commands before rendering the scene.

Photo-realistic Rendering Settings
Change the low-level behavior of the rendering engine through the Photo-realistic 
Render Settings dialog box. Choose PhotoRender>Advanced Settings to display the 
dialog box.
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The dialog box contains the following options:

Raytrace Max 
Reflections

Controls the maximum number of bounces a ray travels. Once 
a ray has reached the specified limit no further color 
calculations occur for that ray. The images of a mirror-walled 
room, shown here, demonstrate the effect of changes in the 
value.

Max Reflections = 2 Max Reflections = 6 Max Reflections = 16

Raytrace Over-
Sample Cutoff

Controls the threshold for adaptive image over-sampling. 
When the rendering operation encounters a significant color 
change in the image, it will be sampled until the largest of the 
red, green and blue components for the adjacent color 
samples do not differ by more than the specified value. The 
value can be between 0.0 and 1.0. Enter a value or use the 
slider to set the sampling limit. The default value is 0.1.

Use Anti-Alias 
Feature Following

Controls the application of Feature Following. When checked, 
a second pass is made over an image bringing out small 
geometric feature details that may have been lost due to ray 
sampling aliasing.

Use Transparency 
Shadows

Controls the behavior of shadow generation for transparent 
objects. When checked, the transparent object casts a shadow 
as determined by its shape and color. When left unchecked, 
the transparent object casts an opaque shadow.

One example of this is a stained 
glass window. When checked, 
the window projects color 
shadows. Left unchecked, the 
window projects an opaque 
shadow.

Use View Clip 
Distances

Controls the near and far clipping plane behavior. Near and far 
planes are normal to the view vector and are at a specified 
distance from the eye point. Any objects or portions of objects 
that lie before the near clipping plane and after the far clipping 
plane are ignored. As implied, an object can be sliced if 
intersected by a clipping plane. 

When checked, the Near and Far data fields become available. 
Enter the Near and Far distances. The units are based on 
those set in Units page of Preferences. 
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Photo-realistic Rendering Commands
There are four render to window commands in this Designer Elements program: Preview 
Render (shadows off), Preview Render (shadows on), Raytrace Render (shadows off) 
and Raytrace Render (shadows on, Anti-Alias).

The graphic here shows an example 
of a clipped image.

When left unchecked, clipping planes are automatically set to 
the near and far view extents of the model and the objects in 
view are rendered. This box is left unchecked by default.

Use Materials Toggles On/Off the material applied to each object.

Use Ambient Light Enables ambient light and allows setting its intensity and color.

OK Saves the new settings and closes the dialog box.

Cancel Exits the dialog box without saving the settings.

Defaults Returns the settings to the factory state.

Preview Render 
(shadows off)

Creates a quality rendering of the scene. It renders most 
rapidly of all the commands since there are no ray tracing and 
shadow calculations.

Preview Render 
(shadows on)

Creates a more realistic rendering than Preview Render 
(shadows off) with shadows. It renders quickly since there is no 
ray tracing.
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When using a rendering command any objects with no specified material have a default 
material/shader applied to them the first time the scene is rendered. The default shader 
settings are as follows: Color shader - plain, Reflectance shader - Phong, Transparency 
shader - none and Displacement shader - none.
The DefaultVSMFile entry in the [RenderOptions] section of the Render.ini file controls 
the default material. If the DefaultVSMFile entry is not found, the material specified by 
the MiscPlain material is used.
For more information on shader types, see the Material Editing.

Rendering the Geometry
Cobalt, Xenon and Argon all render the entire scene or a specified area.

Rendering the Entire Scene
This Designer Elements program renders the entire scene 
with one command, showing how the applied materials 
appear on the objects. The graphic is rendered using the 
Raytrace Render (shadows on, Anti-Alias).

1. Apply materials to the objects in the scene.

2. Choose PhotoRender> and the command.
The scene renders.

Rendering an Area
When applying materials to the objects, it is possible to 
see the results from one specific area of the scene. The 
area render feature gives that ability. Using the CTRL 
(Windows) or OPTION (Macintosh) key, specify an area to 
render. In the graphic only the area around the left object 
is rendered.

Raytrace Render 
(shadows on/off)

Creates a high quality rendering of the scene. The processing 
time is extended with addition of the ray tracing operation and 
shadow calculations.

Raytrace Render 
(shadows on/off, anti-
alias)

Creates the highest quality rendering of the scene, eliminating 
jagged edges. It uses the accuracy of ray tracing with anti-alias 
over-sampling. The computational time is significantly longer. 
The Advanced Setting dialog box controls the sampling 
calculations.
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1. Apply materials to objects in the scene.

2. Hold down the CTRL (Windows) or OPTION (Macintosh) key and from the Photo-
Render menu, select one of the photorealistic commands.
The Message Line reads: Advanced Render: Box area to render. 

3. While still holding down the CTRL (Windows) or OPTION (Macintosh) key, drag a 
selection fence to define the rendering area.

4. Release the CTRL (Windows) or OPTION (Macintosh) key and the mouse button.
The area renders.

Render to File
In addition to the commands for rendering the scene to a window, render the image to a 
file. Choose PhotoRender>Render to File to display the dialog box.

Tech Note: This Designer Elements program does not support directly
printing a photo-realistic image. Use the Render to File command on the
image, open the file in a graphics application and print.

The dialog box contains the following options:

Render Mode Specifies the render mode used in creating the file. Phong and 
Gouraun shading options can be used when rendering to a file.

Image Type This section provides output file types. These include eight 
image format types: Windows bitmap (bmp), Targa (tga), TIFF 
(tif), JPEG (jpg), Lightworks (lwi) and Encapsulated Postscript 
(eps).

Image Width/Height Specifies the image size in pixels. To have a six inch wide 
image with 300 dpi, enter 6”*300 in the Width data field.

These fields function with the Match Width/Height to Drawing 
Window Aspect check box.

Match Width/Height 
to Drawing Window 
Aspect

Specifies the image’s width to height ratio equals the drawing 
window’s width to height ratio. Entering a value in either the 
Width or Height field automatically enters a corresponding 
value in the other field. With the box unchecked, enter any 
value.

Open Resulting File Opens the resulting file when checked.

Save Saves the file and closes the dialog box.

Cancel Exits the dialog box without creating a file.
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Creating Image Files
This Designer Elements program creates publication quality images with higher 
resolution images than produced on a typical computer monitor.
1. Create the drawing and apply the render materials to the objects.

2. Choose PhotoRender>Render to File.
3. Choose the render mode from the pull-down menu. Phong and Gouraud shading 

options can be used when rendering to a file.
4. Choose the image file format.

5. Enter the desired width and height values. If the Match Width/Height to Drawing 
Window Aspect box is checked, only enter a value in one field.

6. Check Open Resulted File if necessary to view it at once.
7. Click Save to create the file.

Display Last Image Command
Use this command in the Render menu to display the previously rendered scene without 
having to render the scene again. This command is helpful if a dialog box appears or the 
mouse is inadvertently clicked and the rendered image is lost. This command saves 
time if the scene is rendered with one of the photorealistic commands.
Note: If the geometry is rotated after rendering the scene and then this command is 
used, the image that appears reflects the last rendering and not the current drawing 
orientation.

Rendering and Multi-processors
If your computer uses multi-processors and an image is rendered with one of the photo-
realistic commands, this Designer Elements program will make use of those processors 
to separate the image into pieces and thus improve the rendering time.
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Animation
Cobalt, Xenon and Argon can create five types of movies. The animation features are 
available through the Animation menu.

Of the five movies types, the first three, Walk-through, Fly-by and Paths, specify a path 
for the camera movement through a scene and require that QuickTime be installed on 
the Windows or Macintosh computer. The last two, Object VR and Panoramic VR, 
specify the pan or tilt of the camera but the camera path is predefined.
Note: Background images can be used for Walk-through, Fly-by and Path animations. 
They cannot be used for Object VR and Panoramic VR animations.

QuickTime Movies with Camera Movement
The Walk-through, Fly-by and Path movies define the movement of the camera using a 
curve. Proceeding through the steps to create a movie two dialog boxes appear, the QT 
Movie dialog box and the Compressor dialog box. These are almost identical for all 
three of these movie types and specify the movie settings.
Curve Rules:
• One or more curves can be selected for a path.
• Although path curves should normally be connected, they do not need to be. 

Disconnected curves will result in a non-continuous jump in the movie.
• Curves cannot be grouped.
• Check the curve direction using Verify>Show Curvature to ensure that the direction 

is correct for the desired animation.
• Select the curves in the desired order.
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The QT Walk-through Movie dialog box is shown here.

The dialog box includes the following options:

Render Mode The pull-down menu sets the render mode for the movie. There 
are eight options: Preview (shadows off), Preview (shadows 
on), Raytrace (No Shadows) and Raytrace (Shadows), 
Raytrace (No Shadows, Anti-alias), Raytrace (Shadows on, 
Anti-Alias), Phong and Gourund.

Image Type This field displays the image type as mov (QT Walk-through 
Movie) and cannot be changed in this dialog box. It is set when 
the animation type is chosen.

Image Width/Height These data fields specify the image size in pixels. To have a six 
inch wide image with 300 dpi, enter 6”*300 in the Width data 
field.

These fields function with the Match Width/Height to Drawing 
Window Aspect check box.

Match Width/Height 
to (Drawing Window 
Aspect)

When checked, the image’s width to height ratio equals the 
drawing window’s width to height ratio. Entering a value in 
either the Width or Height field automatically enters a 
corresponding value in the other field. With the box unchecked, 
any value can be entered.

Description This field contains the movie description which displays when 
the movie is viewed. Enter the movie description.

Copyright This field contains the movie copyright which displays when 
the movie is viewed. Enter the copyright information.

Camera This section contains the FOV (Field of View) angle and the 
Frames for the movie. The FOV field sets the view angle for 
the camera. The default angle is 55°. The Frames field sets the 
number images to be generated for the movie. The default 
number is 10.

Save Click this button to save the file and close the dialog box.
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The Compressor Settings dialog box, shown here, includes the following options: 

Use Sunlight Check this box to include sunlight settings.

Edit Sunlight Click here for the Sunlight Settings dialog box. See “Photo-
realistic Sunlight for Stills and Animations” on Lighting for more 
information about sunlight settings.

Cancel Click this button to exit the dialog box without creating a file.

Compressor Type The pull-down menu sets the compressor type. The types 
include Animation, BMP (Windows only), Cinepak, Component 
Video, DV - NTSC, DV - PAL, Graphics, H.261, H.263, Intel 
Indeo Video® 4.4 (Windows only), Intel Video® R3.2 
(Macintosh only), Intel Raw (Macintosh only), Motion JPEG A, 
Motion JPEG B, None, Photo - JPEG, Planar RGB (Windows 
only), PNG, Sorenson Video, TGA (Windows only), TIFF 
(Windows only) and Video. The movie quality is affected by the 
compression setting.

Compressor Color A color option can be chosen from the pull-down menu. The 
options vary according to the compressor type chosen.

Quality This slider sets the movie quality.

Motion This section includes the Frames per second data field and the 
key frame every x frames check box/data field.

Frames per second: Enter the number of frames per second or 
use the pull-down menu to specify the number.

Key frames every x frames: Enter a number in the data field to 
guarantee that a specific or key frame will be played back 
during a certain time frame. Playback speed is affected by the 
computer speed on which the movie is run. If it is necessary 
later to sync sound to the movie track, a key frame provides 
some control. For example: to create a movie set to 20 frames 
per second and a key frame every 100 frames, a key frame will 
be marked every 5 seconds. When the movie is played, the 
movie will skip frames so that every 5 seconds, the key frame 
is viewed. This syncs a sound track to be the movie using the 
key frame setting.
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Walk-through Animation
This animation command creates a Walk-through movie using a curve to define the 
camera path. The eye point is on the curve. As the camera moves along the curve, its 
orientation is tangential to and along the curve at the eye point. The graphics illustrate 
the eye point and camera orientation at two locations along a curve.

Each movie frame is taken at a particular location on the curve based on the number of 
frames. If a curve slopes down, the camera follows the tangent and slopes down as well, 
resulting in the eye looking down at the angle specified by the tangent. The up vector of 
the camera is always the z axis.

Creating a Walk-through Animation
1. Create a curve along which the camera will travel for the movie.

2. Choose Animation>Walk-through. The Message Line reads: Walk-through Anima-
tion: Pick curve for camera eye path. [Shift=Extend]

3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
The QT Walk-through Movie dialog box appears.

4. Choose the settings.
5. Click Save. The Save As dialog box appears.
6. Type in the movie name and navigate to the location where to save the file.
7. Click Save. The Compression Settings dialog box appears. 
8. Specify the settings for the compressor.
9. Click OK. A progress dialog box 

appears providing a preview movie 
window and information on the number 
of frames generated.
The Message Line provides information 
on the pass, time elapsed and time 
remaining to generate the movie.
The operation can be clicked to end 
before it’s complete. The program will 
finish generating the current frame and 
write out the movie at that frame. Once the movie is generated it is not possible to add 
more frames to it. The dialog box disappears when the movie generation is complete.

10. It is possible now to view the movie using QuickTime player.

This field only activates for the Animation, Cinepak, Graphics, 
H.261, H.263, Intel Indeo Video® 4.4 (Windows only), Intel 
Video® R3.2 (Macintosh only), Intel Raw (Macintosh only), 
Sorenson Video, TGA (Windows only) and Video compressor 
types.

OK Click this button to generate the movie.

Cancel Click this button to exit the dialog box without creating a movie.
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Fly-by Animation
This animation command creates a Fly-by movie using a curve to define the camera 
path. The eye point is on the curve. The camera orientation is directed towards the 
reference point specified. The up vector of the camera is always the z axis. The 
reference point never changes. The point can be in space or on an object. The graphics 
illustrate the eye point, camera orientation and reference point at two locations.

Creating a Fly-by Animation
1. Create a curve along which the camera will travel for the movie.

2. Choose Animation>Fly-by. The Message Line reads: Fly-by Animation: Pick curve 
for camera eye path. [Shift=Extend]

3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
The Message Line now reads, Fly-by: Pick location for camera reference point.

4. Pick a reference point location towards which the camera will always be directed.
The QT Fly-by Movie dialog box appears.

5. Choose the settings.
6. Click Save. The Save As dialog box appears.
7. Type in the movie name and navigate to the location where to save the file.
8. Click Save. The Compression Setting dialog box appears.
9. Click OK. A progress dialog box appears providing a preview movie window and 

information on the number of frames generated. 
The Message Line provides information on the pass, time elapsed and time remaining 
to generate the movie.
It is possible to click to end the operation before it’s complete. The program will finish 
generating the current frame and write out the movie at that frame. Once the movie is 
generated it is not possible to add more frames to it. The dialog box disappears when 
the movie generation is complete.

10. It is possible now to view the movie using QuickTime player. 

Path Animation
This animation command creates a path movie using a curve to define the camera path 
and another curve to define the location of the reference point towards which the 
camera is directed. The eye point is on the first curve. The up vector of the camera is 
always the z axis.
Each of the curves are divided according to the number of frames specified for the 
movie. The first frame eye point on the camera path curve corresponds to the first frame 
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reference point on the reference path curve. The graphics illustrate the eye point, 
camera orientation and reference point at two locations.

Creating a Path Animation
1. Create two curves, one to define the camera path and the other to define the refer-

ence point towards which the camera is directed.

2. Choose Animation>Path. The Message Line reads: Paths Animation: Pick curve for 
camera eye path [Shift=Extend].

3. Select the camera path curve. (Hold down the SHIFT key to select more than one 
curve.)
The Message Line now reads, Paths: Pick curve for camera reference path. 
[Shift=Extend]

4. Select the reference point curve.
The QT Paths Movie dialog box appears.

5. Choose the settings.
6. Click Save. The Save document As dialog box appears.
7. Type in the movie name and navigate to the location where to save the file.
8. Click Save. The Compression Setting dialog box appears.
9. Click OK. A progress dialog box appears providing a preview movie window and 

information on the number of frames generated.
The Message Line provides information on the pass, time elapsed and time remaining 
to generate the movie.
It is possible to click to end the operation before it’s complete. The program will finish 
generating the current frame and write out the movie at that frame. Once the movie is 
generated it is not possible to add more frames to it. The dialog box disappears when 
the movie generation is complete.

10. It is possible now to view the movie using QuickTime player.

Backgrounds and Movies
Put in a background for Walk-through, Fly-by and Paths animations if necessary.
1. Create the background image in a graphic software.

2. Place the image file in the Textures folder within the PhotoRender folder.
3. Display the Render Library.
4. Select the Backgrounds library and the Images category.
5. Apply the VS Logo image to the background.
6. Choose PhotoRender>Edit Background.
7. Select image in the Shader Types list.
8. From the Attribute Value pull-down menu, choose the image.
9. Click OK and render the scene.
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Static Animation

QuickTime VR Movies
This Designer Elements program creates two types of VR movies: Object and 
Panoramic.

QuickTime Object Movie
An object movie keeps the observation point fixed as the eye point is moved at a fixed 
distance about the observation point. This gives the visual effect of moving completely 
around an object on the surface of an invisible sphere.
The QuickTime movie options produce an interactive movie that can be viewed with a 
QuickTime player. (A player and browser Plug In can be obtained from the Apple web 
site.) Each movie is composed of many individual scene images rendered from a slightly 
different point of view.

Creating an Object Movie
1. Create the drawing and apply the render materials to the objects.

2. Choose Animation>Object VR.
The QTVR Object Movie dialog box appears.
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The dialog box includes these additional options:

The asterisk (*) next to the field indicates the ability to specify locations by clicking in 
the drawing area. The values can be entered manually.

3. Enter the desired values.
4. Click Save to create the movie.

Pan This section contains the fields for setting the pan frames and 
angle, where a zero angle represents the viewer’s eye normal 
to the model as currently displayed on the screen. Since the 
pan angle is based on the viewer’s eye, the current view of the 
model is irrelevant.

The Frames field sets the number of images generated around 
the sphere equator (latitude).

The Angle Min field sets the location of the minimum pan 
angle. A zero in this field means the pan will include the 0° 
location in the pan.

The Max field sets the largest angle to include in the pan with 
360° as the maximum.

The Start field sets the starting angle location for the pan. The 
Start angle must be a value within the range set by the Angle 
Min and Max fields.

Tilt This section contains the fields for setting the tilt frames and 
angle, where zero represents the viewer’s eye normal to the 
model as currently displayed on the screen.

The Frames field sets the number of images generated from 
pole to pole for the movie.

The Angle Min field sets the location of the minimum tilt angle. 
A zero in this field means the pan will include the 0° location. 
The minimum angle must be between -90° (looking straight up) 
and 90° (looking straight down).

The Max field sets the highest tilt angle with a maximum angle 
of 90°.

The Start field sets the starting angle location for the tilt. The 
Start angle must be within the range set by the Angle Min and 
Max fields.

Camera This section contains the FOV (Field of View) angle, the eye 
(Eye X, Y and Z) and reference (Ref X, Y and Z) point 
coordinates for the movie.

The FOV field sets the view angle for the perspective. The 
standard angle is 60°. A greater angle produces greater 
distortion, especially when the eye point is within the scene 
(like a room).

The Eye X, Y and Z fields set the location for the eye point.

The Ref X, Y and Z fields set the location for the reference 
point.
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QuickTime VR Panoramic Movie
A panoramic movie keeps the eye point fixed as the observation point is rotated 360°. 
This gives the visual effect of turning 360° in place.
The QuickTime movie options produce an interactive movie that can be viewed with a 
QuickTime 3.0 player. (A player and browser Plug In can be obtained from the Apple 
web site.) Each movie is composed of many individual scene images rendered from a 
slightly different point of view.

Creating a Panoramic Movie
1. Create the drawing and apply the render materials to the objects.

2. Choose Animation>Panoramic VR.
The QTVR Panoramic Movie dialog box appears.

The dialog box includes these additional options:

The asterisk (*) next to the field indicates the ability to specify locations by clicking in 
the drawing area. The values can be entered manually.

3. Enter the desired description and values.
4. Click Save to create the movie.

Pan The Frames field sets the number images to be want 
generated for the movie. The default number is 32.

Camera This section contains the FOV (Field of View) angle, the eye 
(Eye X, Y and Z) and reference (Ref X, Y and Z) point 
coordinates for the movie.

The FOV field sets the view angle for the perspective. The 
standard angle is 60°. A greater angle produces greater 
distortion, especially when the eye point is within the scene 
(like a room).

The Eye X, Y and Z fields set the location for the eye point.

The Ref X, Y and Z fields set the location for the reference 
point.
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File Management
Whenever either Cobalt, Xenon or Argon is opened or New from the File menu is 
chosen, a new document appears. Multiple files can be opened as desired.
Each file supports the layers feature. This feature adds a great deal of flexibility to the 
documents. Layers display various parts of a document individually or as part of the 
whole. Each document is made up of layers which can be hidden or displayed as 
needed.

Consider file organization early. This is particularly important for sharing files with 
other people.
The following topics are covered in this chapter. 
• Using Documents
• Files and Preferences
• Files and Locking 
• File Size & Deleting
• Uninstalling This Program on Windows

Using Documents
A drawing can be a simple part or a complex assembly. A new document opens as 
Untitled and remains untitled until it is saved. Saving a drawing is explained later in 
this chapter.

File Use and Operating System Short Cuts
Cobalt, Xenon and Argon take advantage of some features of the operating systems 
when working with files. 
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Windows
The program starts and opens files from within the Windows Explorer or other folders. It 
also supports the Drag and Drop functionality.

Windows Explorer and other Folders
Open Designer Elements program files by double-clicking on the file icon in Windows 
Explorer, the Desktop or another folder. If this Designer Elements program is not 
running, the program launches first and then opens the file.
To open multiple files, hold down the CTRL key to select the files. Press the right mouse 
button and select the Open command. Each file opens in a separate drawing. If the 
program is not running, the program launches first, before the files open.

Drag and Drop
Cobalt, Xenon and Argon have the ability to manipulate files by dragging and dropping 
them.
Drag and drop files into this program to open the files.
• By dragging and dropping one or more files into an open drawing, they are merged 

into the drawing.
• By dragging and dropping one or more files into this Designer Elements program 

when no files are open, each opens individually.
• By holding down the SHIFT key before dropping multiple files into the program when 

no files are open, files are merged into a single new drawing.
• By dragging and dropping one or more files onto the program desktop icon and the 

files open individually with the program open.

Macintosh
Double-click on the program file to launch the program and open the file.
• By dragging and dropping one or more files into an open drawing, they are merged 

into the drawing.
• By holding down the SHIFT key before dropping multiple files into this program when 

no files are open, files are merged into a single new drawing.
• By dragging and dropping one or more files onto the Designer Elements program 

desktop icon. The files open individually with the program open.

File Menu Commands
The File menu contains commands to manipulate documents, including, New, Open, 
Close, Save and Revert.

New
CTRL+N (Windows); +N (Macintosh)
This command in the File menu creates a document. The new document has no name 
(the title bar shows Untitled 1), and is set with the default options, such as pen style or 
grid display. 
If more than one new document is opened, the subsequent documents are numbered 
sequentially until they are named by saving.

Referral: Use the File>Import command to use drawings of other format
types, such as DXF, IGES, or SAT. See Importing for more information.
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Open 
CTRL+O (Windows); +O (Macintosh)
This command in the File menu opens an existing Cobalt, Xenon or Argon document. 
Graphite files can also be opened using this command. A progress bar appears as the 
file is opening. This is especially helpful for large files. 
The document appears in the drawing area maintaining the same settings as they are 
saved the last time. 

Tech Note: To open a Cobalt, Xenon or Argon program file in prior versions of
Ashlar-Vellum software, export the file using the appropriate export version.
This Designer Elements program embeds ACIS data in its binary files. Vellum
Solids 99 and 98 use an earlier ACIS version and ACIS is not backward
compatible.

The dialog box specifies the document and changes folders, if necessary.
Windows - If the Open as read only box is checked, the file can be opened and printed 
but not altered. Macintosh - If a file is locked, it can be opened and printed but not 
altered. Unlock a file by selecting the file and choosing Get Info (Macintosh standard).

Opening a Document
1. Choose File>Open. 

The dialog box 
appears.
The current 
folder displays 
with the files and/
or folders it 
contains.

2. Choose the 
appropriate 
folder contain-
ing the docu-
ment to open.

3. Click the File 
name to open in 
the list box.

4. Click OK. 

Recent File List
Another way to access files opened recently is through the Recent File List that appears 
in the File menu after the Exit command (Windows) or Quit command (Macintosh). This 
list contains the names and paths of the most recent files opened in this program.
The number of files displayed depends on the number selected in the Filing page of the 
Preferences dialog box. Up to 20 files can be displayed in this list.
To open a file from the Recent File List, select the file name from the File menu. If the file 
has been moved since it was last used and the path is no longer accurate, this program 
will ask you to locate the file by providing the standard Open dialog box.
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Saving a Drawing
Save a drawing by choosing File>Save or Save As. 
The file is stored on the computer in the specified 
folder.
Attempting to save a file containing links that are 
not resolved, the following warning appears:

Save 
CTRL+S (Windows); +S (Macintosh)

This command in the File menu saves the current document to its original folder. To 
save it to a different folder or with a different name, choose Save As. If Save is chosen 
and the document has not been saved previously, the Save As dialog box appears 
automatically to name the document and specify the folder in which to save it.

Tech Note: When attempting to save a file with the name of a locked file, a
warning message will appear. 
If objects are deleted before saving a file, the data for that information may
still be retained with the file. Perform the delete operation again to guarantee
the data is removed.

If no geometrical changes are made in the file, the Save command is not available. 
Changing an object’s layer is not recognized as a geometrical change. If the document 
have been named and saved before, a brief message appears when Save as chosen. 
The program pauses while it updates the information.
Note: It is necessary to save frequently. It is important to save before performing any 
intricate, multistep procedure. That way, if the result is not exactly what is desired, it is 
possible to abandon the file by closing it without saving.

Save As
This command in the File menu saves the current document. A dialog box appears to 
name the current document, give it a different name, or save it to a different directory. 
Use the Save As command to make a backup of a document.
(Windows) - It is possible to save a file as Read only. Click the check box for that option.

Saving in the Current Directory
1. Choose File>Save As.

The Save document as 
dialog box appears.

2. If necessary, display a 
different folder.

3. Type the name to use 
in the File name box.

4. Click OK.
The appropriate 
filename extension for 
your software is 
automatically appended 
to the filename (.co, .xe 
or .ar).
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Tech Note: Macintosh users: Although the .co, .xe, ar, and .vs extension is
not required for the file name, it is included to ease file transfer between
Macintosh and Windows.

Making a Backup
Make a backup of the work in case there are many changes and it is necessary to go 
back to the original version. Choose File>Save As and save the file with another name. 

Auto Save 
This command is found under File>Preferences>Filing and directs the program to save 
a backup copy of the work periodically. If your computer crashes for any reason, the 
work done up to the last Auto Save will be recoverable.
There is the option to save after a certain number of commands or minutes. It is also 
possible to specify the number of backup files created before reusing a backup file 
name. (See Auto Save for more information on setting up or using the Auto Save 
feature.) For Windows, files opening with the READ ONLY attribute are also autosaved.
Files saved using this feature are placed in the Backup folder within the program folder. 
If Auto Save is set to on in Preferences but geometry is not modified since the last 
autosave, the function does not activate.

Revert 
This command in the File menu deletes all changes 
made in the drawing since the file was last saved. 

1. Choose File>Revert. The following dialog box 
appears.

2. Click OK to return to the original file opened and 
close the dialog box. (Click Cancel to close the 
dialog box without enabling the command.)

Close
CTRL+F4 (Windows); +F4 (Macintosh) 
This command in the File menu closes the current program document. If other program 
documents are open, they remain open when the current document is closed. If changes 
have been made since the file was last saved, a dialog box appears. Close the 
document with or without saving the changes. 
For Windows, close the document by double-clicking the Control menu at the upper left 
corner of the title bar. For Macintosh, click the Close button in the upper left corner.

Exit 
CTRL+Q (Windows); Quit - +Q (Macintosh) 
This command in the File menu closes this Designer Elements program. If there were 
changes since the last saving, a dialog box opens. If more than one document is open, 
an alert message opens to save unsaved documents. 

Files and Preferences 
In the Filing page of the Preferences dialog box, choose settings for this Designer 
Elements’ documents. These include options for saving native picture formats, clearing 
undo, compacting files, read-only network file sharing, recent files and auto save.
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Files and Locking 
Both Windows and Macintosh operating systems provide the ability to lock files. Once 
locked these files can be opened and printed but not altered until unlocked. This feature 
is valuable when working on a network. When one person is working on the file, another 
person can open the file but is unable to make changes. See the User Guide for your 
system for more information.

Tip: If your system crashes with an open file, the file will lock. Unlock the file
according to your system instructions. Or save the file under the same name.
While saving, the system prompts to confirm the overwriting of the locked file.

File Size & Deleting 
When objects in this Designer Elements program are deleted, the object data is still 
retained until a second delete operation is performed. If the file size is large in 
comparison to the amount of geometry in the file, this may be the reason. Perform 
another delete operation (create a line and delete it), save the file and reopen it.

Uninstalling This Program on Windows
When uninstalling this Designer Elements program, there are some folders and files left 
in User domains (e.g. C:\Documents and Settings\/CURRENT_USER/\Application 
Data\Ashlar-Vellum\Modeling V8) and Local domain (e.g. C:\Documents and 
Settings\All Users\Application Data\Ashlar-Vellum\Modeling v8). Those folders do not 
uninstall automatically since they were created after installation.
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Importing & Exporting
There are various reasons to use the import and export functions. It may be necessary 
to bring a document in from another application to work on in this Designer Elements 
program. It may be necessary to save a document in a format other than this Designer 
Elements program format for use with another application. This Designer Elements 
program offers a wide variety of options to accomplish this.
The following topics are covered in this chapter:
• Importing
• Exporting
• Batch Convert Tool

Importing
Cobalt, Xenon or Argon import many different kinds of files. Some types include import 
options specific to the format.
When the Import command is chosen, the following dialog box appears.
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The dialog box contains these options:

Supported Import Formats
This Designer Elements program imports these file formats: Cobalt (including Xenon 
and Argon), Vellum Solids, Graphite/Vellum 3D, DWG, DXF, IGES, STEP, ACIS SAT, 
Parasolid (Windows only), Facet, Truespace COB, 2D Raster Image, Rhino 3DM, STL, 
Adobe Illustrator, 3D Studio, Catia v4, Spline, Text, Grid Surface, PICT (Macintosh only) 
, and ClarisCAD.

Vellum Solids (VS)
Selecting this type imports files created in Vellum Solids. There are no options for this 
import type. In order to read previous versions of Vellum Solids into this Designer 
Elements program, import the file using this format.

Graphite/Vellum (VC6, VLM)
Selecting this type imports files 
created in Graphite/Vellum 2D and 
3D. There are three options: Vellum 
Layers, Auto Heal Bodies and 
Feature Recognition.
This translator imports horizontal, 
vertical, diameter and radial dimensions in addition to geometry.

Import Type Lists the file formats that this Designer Elements program 
imports.

Import Options Includes the options that are available for the selected format.

OK Click this button to close the import dialog box and display the 
standard Open dialog box for locating the file.

Cancel Click this button to close the dialog box and ends the 
operation.

Vellum Layers This section includes check boxes, Create, Create Empty and 
Display All.

Create - When checked, the program creates/imports the 
layers in the Graphite/Vellum file and places geometry on their 
respective layers. If this box is not checked, all geometry is 
placed on the work layer.

Create Empty - When checked, the layers that contain no 
geometry are also created. If this box is not checked, layers 
that contain no geometry are deleted.

Display All - When checked, all objects on all layers are 
displayed. If this box is not checked, the import file determines 
which layers display.

Auto Heal Bodies When checked, auto-healing is applied to imported surfaces. 
Auto-healing attempts to find collections of surfaces that define 
closed volumes and convert them to solids. With this box 
checked, the Feature Recognition check box is enabled.

If this box is not checked, auto-healing is not be performed and 
the Feature Recognition check box is disabled.
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Graphite/Vellum 3D Notations
• The translator does not support the following entities: work plane, fill, bitmap, balloon, 

hatch, sheet and view.
• ACIS does not support skewed ellipses. Only ellipses created with the 2-Point Center 

Ellipse tool and the Opposite-Corner Ellipse tool in Vellum 3D can be imported into 
Cobalt, Xenon or Argon. 

• Cobalt, Xenon and Argon do not support models (model space). When importing a file 
with geometry in different models, each model is placed on its own layer.

• When importing a file it is necessary to surface them to intersect with other objects or 
project curves onto them, use the Cover, Skin or Net Surface tools.

DWG
Selecting this type imports DWG files 
created in AutoCAD or other 
programs that support the DWG file 
format. The translator will read DWG 
files up to and including version 
R2008.
This translator imports horizontal, 
vertical, diameter and radial 
dimensions in addition to geometry.
DWG includes three options: DWG 
Layers, and DWG Units.

DWG Notations
The DXF/DWG translator does not support the following entities: Shape, Ole2frame, 
MLine, Leader, MText, ViewPort, Tolerance, Proxy, Hatch and Image.
Importing a DWG file that contains entities that are not supported, a box appears 
warning that the entities were not read.

Opening Password Protected DWG Files
The password protection in AutoCad files is supported in Cobalt, Xenon and Argon 
under the Windows operating system only. To open a password protected file:
1. Go to File>Import.

2. Choose DWG or DXF formats in the Import dialog box and click OK.
3. Navigate to the place where the file is located with the Open window and click Open 

button.

DWG Layers Includes three check boxes, Create, Create Empty and Display 
All.

Create - When checked, the layers in the DWG file are created/
imported and geometry placed on the respective layers. If this 
box is not checked, all geometry are placed on the work layer.

Create Empty - When checked, layers that contain no 
geometry are created. If this box is not checked, layers that 
contain no geometry are deleted.

Display All - When checked, all objects on all layers are 
displayed. If left unchecked, the import file determines which 
layers display.

DWG File Units This list sets the units for the incoming file. The units include 
inches, feet, mm, cm and meters.
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4. Input the password in the Enter Password Dialog box and click OK.

5. The drawing opens in the Cobalt window. 

DXF
Selecting this imports DXF 
(AutoCAD’s Data eXchange Format) 
files. The translator will read DXF 
files up to and including version 
R2013.
This translator imports horizontal, 
vertical, diameter and radial 
dimensions in addition to geometry.
DXF includes two options: DXF 
Layers, and DXF Units.

DXF Facet Files
In DXF and DWG files created prior to 
AutoCAD Release 13, surfaces were 
represented as a collection of facets. Cobalt, 
Xenon and Argon convert these surfaces to 3-
Point mesh elements. This graphic shows an 
example of a DXF facet file that was imported 
into the program. 

DXF Notations
The DXF translator does not support the following entities: Shape, Ole2frame, MLine, 
Leader, MText, ViewPort, Tolerance, Proxy, Hatch and Image.
Importing a DXF file that contains entities that are not supported, a warning box will 
appear saying that the entities were not read.

DXF Layers This section includes three check boxes: Create, Create Empty 
and Display All.

Create - When checked, the layers in the DXF file are created/
imported and geometry is placed on the respective layers. If 
this box is not checked, all geometry is placed on the work 
layer.

Create Empty - When checked, layers that contain no 
geometry are created. If this box is not checked, layers that 
contain no geometry are deleted.

Display All - When checked, all objects on all layers are 
displayed. If this box is not checked, the import file determines 
which layers display.

DXF File Units This pull-down list sets the units for the incoming file. The units 
include inches, feet, mm, cm and meters.
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Tech Note: There is almost no reason to use an IGES file format for importing
from SolidWorks. Use ACIS SAT, Parasolids  or STEP for 3D, or DXF for 2D.
Use IGES with the SolidWorks flavor only if importing from a SolidWorks
version prior to 2000.  For any version after 2000 use one of the formats
above or, if absolutely necessary, IGES Generic.

IGES
Selecting this imports IGES files 
created by various CAD 
programs. IGES includes three 
options: Flavor, Trim Curve 
Options and Auto Heal Bodies.

Tip: IGES is best known in the industry as "I guess."

This translator also supports importing horizontal, vertical, diameter and radial 
dimensions.

When importing an IGES file, the IGES Import Results box appears.

The box contains the following items:

Flavor This section includes a pull-down menu to choose to import 
three different IGES flavors: Generic, AutoCAD or SolidWorks. 
Use Generic if specific IGES flavor is not listed.

Auto Heal Bodies When checked, auto-healing is applied to imported surfaces. 
Auto-healing attempts to find collections of surfaces that define 
closed volumes and convert them to solids.

Trim Curve Option Is set appropriately for the flavor chosen but can be overridden 
using this option.

Entity Type Lists five entity types: Trimmed/Bounded Surface, Manifold 
Solid (#186), Independent Surface, Independent Curve and 
Independent Point.

Present Displays the number of a particular entity in the file.

Converted Displays the number of entities for the type that converted.

%(Conversion) Lists the percentage conversion of the particular entity.
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ACIS SAT
Selecting this type imports SAT files created by various ACIS-based CAD programs. 
There are no options for this type.

Facet
Selecting this type imports ASCII Facet files created by various CAD programs. There 
are no options for this import type.
The facet file format was created by the 
United States Electromagnetic Code 
Consortium and Lockheed Fort Worth. This 
file format provides an efficient means for 
transferring geometry models to a variety of 
government-sponsored signature predication 
codes. The format includes geometry 
definitions of 3- and 4-sided facets and 
material IDs for each facet. 
The graphic shows a facet file after it was 
imported into this Designer Elements 
program. Each shade represents a material to 
be analyzed by the signature predication code. The canopy and raydome are 
transparent, so they are not included in the signature model.

PICT (Macintosh only)
Selecting this type imports Pict files created by various programs. Pict is the Macintosh 
native file format. There are no options for this import type.

Bitmap Images (2D Raster Images)
Hand sketches, photographs and other 2D images can be imported and displayed in 3D. 
This makes it significantly easier to trace over the sketches to create a 3D model. These 
images can be oriented in any direction and viewed from any perspective regardless of 
the work plane. The bitmap comes in on the current work plane. Use the Trackball to 
view the images from all directions.

Creator Information Contains the name of the person who created the IGES file 
and system information.
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Importing 2D raster images provides the following options:

Adobe Illustrator
Selecting this type imports Adobe 
Illustrator version 5.0 through 8.0 
files. Adobe Illustrator includes 
three options: Group Path 
Segments, Polygon from Fill and 
Join Path Segments.

This translator also supports importing text.

Spline
Selecting this type imports ASCII Spline files created by various CAD programs. There 
are no options for this import type. 

Import Command
This command in the File menu imports a document and places it in the current file.
1. Choose File>Import.

Import the Image 
Center

Sets the center of the target file at the origin of the drawing 
area.

To the Work Plane 
Origin

Imports the image to the work plane origin.

Group Path 
Segments

Determines how paths are imported. When selected, separate 
segments from a multi-span path are grouped.

Polygon from Fill Sets whether fill is imported with curves if the objects contain 
fill. When selected, the fill and curves are imported. When this 
option is not selected, fill is not imported.

Join Path Segments Attempts to merge adjoining path segments into as few 
segments as possible without changing the shape.
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The Import dialog box appears with all the import options.
2. Select the Import type from the list and the options for the type as desired.
3. Click OK. The standard Open dialog box appears.

4. Navigate to the file to import.
(Windows users: If the Open as read-only box is checked, the original file can be 
viewed but changes cannot be saved under the same file name.)

5. Click Open to import the file.
The file appears in the drawing area. To save the file in its original format after editing, 
choose the Export command from the File menu.

Importing Splines
When importing a text file that contains the coordinates of a spline, Cobalt, Xenon or 
Argon will create the spline according to the imported coordinates.
1. Select File>Import.

The Import dialog box appears.
2. Specify the import option Spline.
3. Click OK. This Designer Elements program displays the standard Open dialog box.
4. Select a text file that contains the coordinates for the spline.
5. Click Open to import the file.

The program begins creating the spline.

Importing Tips and Notations
These tips and notations will help to successfully import files.
• Groups - This Designer Elements program can import grouped geometry and groups 

within groups.
• Layers and Color - Be careful importing geometry into a layer with a color override. 

Objects placed on that layer will be displayed in the color of the layer.
• ACIS Data - Surfaces and solids data is written out in DXF only.
• Smart Walls - Cobalt, Xenon and Argon do not support the Smart Walls feature of 

Graphite and prior versions of Vellum 3D. Smart walls imported into this Designer 
Elements program are converted into individual lines.
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• If this Designer Elements program displays geometry that was not in the original 
AutoCAD DXF file, go back to the original file in AutoCAD. Choose the PURGE 
command and purge any unnecessary blocks in the file. Then export the DXF file and 
import it into this Designer Elements program.

• If an error occurs when trying to import a file, Cobalt, Xenon or Argon create a file log 
in the program folder. For example, if a file is imported through the IGES translator 
and an error occurs, the file IGSRead is created.

Exporting
This Designer Elements program exports to many different kinds of files formats. Some 
types include export options specific to the format. When choosing the Export 
command, the dialog box appears.

The dialog box contains these elements:

Formats/Software 
Tabs

Simplify the selection of the correct format for file translation. 
Click the tabs to switch between the lists of formats or 
software. The Formats tab contains a list of specific file types. 
The Software tab allows the program name to be chosen 
instead of a cryptic file extension.

Export Type Lists the file formats that this Designer Elements program 
exports.

Export Options Includes the options that are available for the selected format.

Selected Only When checked, only selected geometry is exported.

MultiFile When checked creates a file for each object in the drawing, 
using the same name as in the Design Explorer. This option is 
useful when exporting files to products that do not handle 
multiple objects within one file such as Pro/E and SolidWorks. 

End of Line Specifies an end of line structure for the exported file. There 
are three options: Mac (LF), PC (CR/LF) and Unix (CR).
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Supported Export Formats
This Designer Elements program exports these file formats: Cobalt (including Xenon 
and Argon), Vellum Solids, Graphite, DWG, DXF, IGES, STEP, ACIS SAT, Parasolid, 
EPS, CGM, Facet, VRML, RAW, STL, Adobe Illustrator, Catia v4, Text, Macrmedia, 
PICT (Macintosh only).

Vellum Solids (VS) 
Selecting this type exports files as a Vellum Solids file. There are 
four options: VS 2000, VS 2000 SP1, VS 99 SP1, VS99 and VS 
98.

Graphite/Vellum 3D (VC6 and VLM) 
Selecting this type exports files as a Vellum 3D file. This translator exports text and 
horizontal, vertical, diameter and radial dimensions in addition to geometry. Angle 
center mark, ordinate and balloon dimensions are exploded into lines and text. There 
are no options for this type.

DWG
Selecting this type exports DWG 
files compatible with AutoCAD and 
other programs that support the 
DWG file format. (DWG is the binary 
version of DXF.) DWG includes 
several options.
This translator exports all dimension 
types: horizontal, vertical, diameter, 
radial, ordinate, angled, center mark 
and balloon dimensions. It also exports groups and bezier and vector splines. Hatching 
is converted into lines.
Warning: Layer names are limited to the following character set: ‘a’ through ‘z’, ‘A’ 
through ‘Z’, ‘0’ through ‘9’, ‘-’ and ‘_’. All other characters in a layer name convert into an 
underscore (_).

Tech Note: For maximum compatibility among DWG versions of 2000 or
later, use the Version 2000 option since no new data was added to the later
file formats and those with different versions will have trouble reading the
file.

OK Click this button to close the Export dialog box and display the 
standard Save As dialog box.

Cancel Click this button to close the dialog box and end the operation.

VS 2000 Exports Vellum Solids 2000 Service Pack 0 files.

VS2000 SP1 Exports Vellum Solids 2000 Service Pack 1 files.

VS 98 Exports the Vellum Solids 2000 file as a Vellum Solids 98 file.

VS 99 Exports Vellum Solids 99 files.

VS 99 SP1 Exports Vellum Solids 99 Service Pack 1 files.
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ACIS data cannot be exported using the 
DWG translator. When attempting to use 
this translator on a file containing ACIS 
data, a warning dialog box appears asking 
if you want to export the file using the DXF 
translator.
Click Yes to create a DXF file or No to end 
the operation.

Choose the DWG option based on the translator version supported by the program into 
which to import the file.

DXF
Selecting this type exports DXF files 
compatible with AutoCAD. DXF 
includes several options.
Choose the end of line structure 
(Mac (LF), PC (CR/LF) or Unix 
(CR)) from the End of Line pull-
down menu.
This translator exports all dimension 
types: horizontal, vertical, diameter, 
radial, ordinate, angled, center mark 
and balloon dimensions. It also exports groups and bezier and vector splines. Hatching 
is converted into lines.

Tech Note: For maximum compatibility among DXF versions of 2000 or
later, use the Version 2000 option since no new data was added to the later
file formats and those with different versions will have trouble reading the
file.

Version 12 Exports the file as an R12 file. This does not support ACIS 
data. Ellipses, conics, splines are converted into polylines. 
ACIS curves are converted into b-splines. Surfaces and solids 
are converted into facets (Face3D).

Version 13 Exports the file as an R13 file. Ellipses, splines and ACIS 
curves are supported. Conics are converted into polylines.

Version 14 Exports the file as an R14 file. Ellipses, splines and ACIS 
curves are supported. Conics are converted into polylines.

Version 2000 Exports the file as an R2000 file. This was the last time the file 
type was extended by Autodesk relevant to Ashlar-Vellum 
products. For maximum compatibility among users with 
Version 2000 and later, use this option.

Versions above 2000 Provided for convenience. This option will prevent users of 
earlier Autodesk products from opening these files. For best 
compatibility use the Version 2000 option.
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Warning: Layer names are limited to the following character set: ‘a’ through ‘z’, ‘A’ 
through ‘Z’, ‘0’ through ‘9’, ‘-’ and ‘_’. All other characters in a layer name convert into an 
underscore (_).

Choose the DXF option based on the translator version supported by the program into 
which it is necessary to import the file and the end of line setting.

IGES
Selecting this type, exports 
various versions of IGES files. 
IGES includes four format 
options: Flavor, Write MSBO 
#186, Write Nurbs #128 and 
Trimming Curve Prefs.
Choose the end of line 
structure (Mac (LF), PC (CR/
LF) or Unix (CR)) from the End 
of Line pull-down menu.
This format also exports 
groups.

Version 12 Exports the file as an R12 file. This does not support ACIS 
data. Ellipses, conics, splines are converted into polylines. 
ACIS curves are converted into b-splines. Surfaces and solids 
are converted into facets (Face3D).

Version 13 Exports the file as an R13 file. Ellipses, splines and ACIS 
curves are supported. Conics are converted into polylines.

ACIS data for surfaces and solids are written out as SAT data 
(Spatial Technologies format). A program that supports these 
versions does not automatically support SAT data. Check your 
program manual or with the manufacturer to determine 
whether it can read SAT data. Geometry exported using these 
versions is considered more accurate than facet 
representation.

Version 14 Exports the file as an R14 file. Ellipses, splines and ACIS 
curves are supported. Conics are converted into polylines.

ACIS data for surfaces and solids are written out as SAT data 
(Spatial Technologies format). A program that supports these 
versions does not automatically support SAT data. Check your 
program manual or with the manufacturer to determine 
whether it can read SAT data. Geometry exported using these 
versions is considered more accurate than facet 
representation.

Version 2000 Exports the file as an R2000 file. This was the last time the file 
type was extended by Autodesk relevant to Ashlar-Vellum 
products. For maximum compatibility among users with 
Version 2000 and later, use this option.

Versions above 2000 Provided for convenience. This option will prevent users of 
earlier Autodesk products from opening these files. For best 
compatibility use the Version 2000 option.
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Tip: IGES is best known in the industry as "I guess."

Tech Note: There is almost no reason to use an IGES file format for
importing from SolidWorks. Use ACIS SAT, Parasolids  or STEP for 3D, or
DXF for 2D. Use IGES with the SolidWorks flavor only if importing from a
SolidWorks version prior to 2000. For any version after 2000 use one of the
formats above or, if absolutely necessary, IGES Generic.

Use Generic if a specific IGES flavor is not listed.

STEP
Selecting this type exports a STEP file. STEP (STandard for the Exchange of Product 
model data) is a neutral file format used to export models among CAD, CAM and CAE 
applications.
It is also possible to choose the end of line structure (Mac (LF), PC (CR/LF) or Unix 
(CR)) for the file from the End of Line pull-down menu. There are no other options for 
this export type.

Flavor Includes a pull-down menu to export different IGES flavors: 
Generic, AutoCAD, SolidWorks, Vellum v3.0, Vellum v2.7, Pro/
E or Alias.

AutoCAD, R13: Certain MSBOs are not supported by 
AutoCAD. This flavor converts the MSBOs so they can be read 
in AutoCAD.

SolidWorks: This flavor does not support IGES Conic Arc 
(#104) which this Designer Elements program uses to write an 
ellipse. Ellipses convert into nurb splines.

Vellum v3.0: All solids convert into surfaces.

Vellum v2.7: All solids and surfaces convert into curves.

Pro/E: Does not include the Trimming Curve Prefs options.

Alias: Includes all the options listed for the Generic flavor.

Write MSBO #186 When checked, exports solids using this IGES5 solid object 
type. (MSBO #186 is a Manifold Solid B-Rep entity.) If this box 
is not checked, only 3D parametric trimming curves for analytic 
surfaces are exported.

Write Nurbs #128 When checked, exports solids using this nurb surface type.

Trimming Curve 
Prefs

Includes two check boxes 2D Parametric and 3D Model Space. 
Choose one option.

2D Parametric - Exports 2D parametric trimming curves for 
analytic surfaces. This option is valuable to programs that can 
read only 2D data and need the 3D data mapped to a 2D 
parametric.

3D Model Space - Exports the actual 3D trim curve in the 
model space.
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SAT

Selecting this type exports SAT files compatible with various versions of ACIS. This 
format includes one option: Version.

This translator supports exporting curves, surfaces, solids and grouped objects. It does 
not support exporting layers.

EPS
Selecting this type exports an EPS (encapsulated postscript) file. There are no options 
for this type.

Tip: This Designer Elements program EPS exports an embedded post script
file. This type is great for printing and embedding in such applications as
Microsoft Word and PowerPoint. This EPS export is different from the EPS
export used in Vellum 3D which exports an Adobe Illustrator version of post
script.

CGM
Selecting this type exports a computer graphics metafile. This format is a 2D data 
exchange format which allows graphical data to be stored and exchanged among 
graphics devices, applications and computer systems. This metafile is not a picture but 
a description of a picture. There are no options for this translator.

PDF
Ashlar-Vellum’s built-in PDF writer has several advantages over printing to PDF. It is 
possible to create multi-sheet vector PDFs drawn from multiple models in the same file 
and embed the source files or translations directly in the PDF.
Everything for an entire project can be emailed, displayed and archived. Use Adobe 
Acrobat to further enhance the file, inserting and replacing pages, commenting and 
marking changes or tracking revisions.

Version The option sets the ACIS export version in the pull-down 
menu.
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Tech Note: PDF page size is controlled by the print layout settings and paper
selection.

Exporting to .pdf,provides the following options:

.

In the PDF Options dialog box it is possible to set the following:

Attach Source File Includes the source file with the PDF.

Open Resulted File Opens the new file automatically after export.

Selected Only Exports only those entities selected. 

Multi File Creates one entity per file for later importing into other types of 
software.

Advanced Brings up the following display:

Page Selects which layers will appear on which pages of the PDF. 
Add and delete pages as necessary. If layers are not 
specifically designated, all visible layers are exported to one 
page of the PDF by default.

+ Adds pages to the target file.

- Deletes pages.

Select All Selects all the layers for the current page.

Clean All Deselects all the layers for the current page.

Invert Inverts the selected or layers on the current page.

Page Size Designates page size. Can be Standard or Custom. 
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When the PDF is opened in a viewer such as Adobe Reader or Acrobat, each page is 
shown as designated.

Facet
Selecting this type exports an ASCII Facet file. There are no options for this type.

STL
The precise, mathematical representation of a solid or surface must often be converted 
into a collection of imprecise planar facets. These facets may be used to export a model 
to the STL format and when changing a solid or surface (Edit>Change Object Type…) 
to a mesh. The amount of error that results from this conversion is controlled by the 
settings in the mesh parameters dialog box.

Standard enables the drop down menu to select one of the 
predefined standard formats.

Custom enables the Width and Height fields for setting the 
custom page size. The allowed PDF size range is from 
0.04167x0.04167 inches, 1.05833x1.05833 millimeters or 3x3 
points up to 200x200 inches, 5080x5080 millimeters or 
14400x14400 points.

Auto Fit Expands the page size so that all entities fit on the page. 

Margins Designates margin settings. For standard and custom page 
sizes the margins are measured inwards from the strictly 
defined page size. Geometry is inscribed within the remaining 
area. 

Apply to All Pages Applies settings designated for current page get applied to all 
pages of the document.

Units Drop down menu for setting the units for the width and height 
of the pages.

Remember Pages 
Settings

Saves the current page, size, and margins settings with the 
Cobalt, Xenon or Argon file for later exporting.

Add Attaches additional files to the PDF. Click Add then navigate to 
the file. 

Add Converted Exports the same file in any other format and attaches it to the 
PDF.

OK Closes the Advanced settings box.
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During the conversion, vertex points are distributed on the surface or solid. These 
vertices are then grouped into 3-sided and 4-sided facets. The conversion is deemed 
acceptable when the generated vertices and facets satisfy the settings. The 5 available 
settings are Surface Deviation, Normal Deviation, Edge Length, Aspect Ratio, and STL 
Facets. These settings are defined in the sections below.
Change the facet settings as needed in the dialog and then click the Update button to 
see the number of facets and vertices generated. Determining the combination of 
settings that will work for a given situation can be a little bit of an art. If one setting 
becomes too tight, the other settings will have no effect. If one setting becomes too 
loose, it will have no effect.
Keep in mind that the settings are used by the faceting algorithms if possible. It is often 
not possible to satisfy all settings simultaneously. In this situation, the algorithm decides 
which settings to “loosen.”
The Mesh Parameters dialog box contains the following options:

VRML
Selecting this type exports virtual reality modeling language files. There are two options 
for VRML, Version 1.0 and Version 2.0.

Surface Deviation Controls the maximum allowed distance between any point on 
the actual surface or solid and the facet representing that 
point. The exaggerated figure below shows the largest 
distance between a patch on the actual surface (yellow) and 
the corresponding planar facet (brown).

Normal Deviation Controls the maximum allowed angular difference between any 
normal on the actual surface or solid and the corresponding 
interpolated normal on the facet.

Edge Length Controls the maximum allowed edge length of any given facet.

Aspect Ratio Controls the maximum allowed aspect ratio of any given facet.

STL Facets Forces the facets generated to be suitable for 
stereolithography usage. This setting is usually used when 
exporting STL files.
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RAW
Selecting this type exports a raw file consisting of 
triangular vertices. These vertices define the x, y 
and z locations of the 3D faces which make up the 
model. There are no options for this type.
After exporting, a dialog box appears displaying 
the number of entities and vertices in the exported 
model.
The raw file can be viewed by opening it in any text editor.

Adobe Illustrator
Selecting this type exports an Illustrator file. This Illustrator file is compatible with Adobe 
Illustrator versions 5.0 through 8.0. This translator supports exporting the Hidden and 
Hidden w/dimmed render options. All dimensions are converted into lines and text. 
There are no options for this type.
Macintosh only: When exporting an Illustrator file, this Designer Elements program 
automatically displays it with an Illustrator icon. Double-click the file to launch Adobe 
Illustrator.

Tip: For best results use the PDF export option for Adobe Illustrator since
Adobe Illustrator natively supports PDF.

Text
Selecting this option will export the text contained in the file along with a list of objects 
contained in the file.

Catia v4 EXP or DLV
Selecting this type exports a CATIA v4 file. There are no options for this type.

Macromedia
Selecting this type exports a Macromedia file. Choose the Geometry Quality and there is 
the option of creation a log file if the box is checked.

Bitmap Images (2D Raster Images)
The dialog box for exporting 2D raster images provides the following options:

PICT (Macintosh only)
Selecting this type exports Pict files, the Macintosh native file format. There are no 
options for this type.

Export Command
This command in the File menu saves a document in the specified format. 
1. Choose File>Export.

The Export dialog box appears.
2. Select the export type and its options. To export only selected objects on the screen, 

rather than the entire document, click Selected Only.

View Area Exports the current view only. If left unchecked the software 
will Zoom All and capture everything visible. 

Ignore Background Tells the software to ignore any background color or gradient.



Exporting

43-19

3. Click OK. The standard Save document as dialog box appears prompting a name 
and location for the exported file.
Windows: The type of file being exported is indicated with the appropriate filename 
extension.

4. Enter the file name and click Save. The exported file is saved with the name and 
location entered.

Exporting Tips and Notations
These tips and notations will help to successfully export files.
• When exporting files from Cobalt, Xenon or Argon for import into another program, 

determine what version of the translator is used by the other program. Choose the 
appropriate translator in this Designer Elements program for the target application. 
Be sure to check whether there are any tips or notations for a successful translation in 
this program or the target application.

• In general, it is best to show all layers before exporting from this Designer Elements 
program or from another program that will be imported into this program, to know 
what is being exported.

• AutoCAD does not like the & symbol in the layers table of the DXF file. Remove the 
symbol from the layer name in this Designer Elements program or AutoCAD will 
generate an error reading in the file.

• If line patterns do not import into AutoCAD accurately from a Designer Elements 
program DXF or DWG file, change the AutoCAD variable LTSCALE to display the 
patterns at an appropriate scale.
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Batch Convert Tool
The Convert command in the File menu converts entire folders of files from one type to 
another by automating the import or export process. To use the command:
1. Create two new computer folders. One will host all of the source files that will be 

converted. The other will receive the converted files.

2. Place all files to be converted in one batch in one of the folders created in step 1.
3. Choose File>Convert.
4. In the Convert dialog box indicate the input and output file types along with any 

options available. Activate the Batch check box and click OK. 

5. In the first dialog box navigate to the new folder containing the files to convert. Click 
OK.

6. In the second dialog box navigate to the destination folder and click OK.



44-1

Drawing Composition for 
Cobalt & Xenon
Cobalt and Xenon quickly create 2D drawings from one or more 
entities. The 2D drawing views are associative in Cobalt and Xenon. Changes made to 
the objects automatically appear in the 2D drawings. In Argon, however, the 2D drawing 
views are snap shots without associativity. Instructions for creating drawings in Argon 
are discussed in the next chapter. The topics covered in this chapter for Cobalt and 
Xenon include:
• Model to Sheet Command
• Drawing Views
• Sheet Tools
• Unfolding Views
• Editing a Drawing View
• Layout Templates
• Printing the Layout

Model to Sheet Command
The Model to Sheet command, 
located in the Layout menu, 
automates the process of creating 
drawings through the use of 
templates. Templates are empty 
drawings with predefined and pre-
arranged drawing views set within 
drawings borders. With this feature, 
this Cobalt or Xenon creates 2D 
geometry from the selected 3D 
wireframe, surface and solid models 
and places them in drawing views on 
a new layer, called Sheet View. The 
original 3D geometry remains.

Tip: Turn on all layers and zoom out, to see the original geometry in the Top
view.
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Warning: Do not use this command with curves or groups.
If the geometry contains objects or drawing border lines using the background color, the 
program automatically changes it to the foreground color. This capability is especially 
helpful when the background color is black. 
See Colors for information on setting the background and foreground colors.
The new sheet view displays in the top view. Drawing views placed on this sheet can 
only be selected when the view orientation is top. The sheet is positioned at the origin 
using the lower left corner as the alignment reference.
Choosing the Model to Sheet command displays the following dialog box.

The dialog box contains these options:

Layouts Sets the layout for displaying the geometry. These layouts are 
predefined and located in the Layout folder within the same 
folder as the application. The layouts contain drawing views 
and may contain title blocks and drawing size boundaries 
depending on the layout selected.

Create or modify any of the templates based on the drawing 
layout preferences. See Layout Templates for more 
information.

Rendering Represents Flat, Gouraud and Phong shading options and 
Photo-rendered, Photo-rendered (no materia) rendering 
options to make the object look photorealistic in the model to 
sheet.

Wireframe Sets how hidden edges display in the final drawing. There are 
Precise Curves (Slower), and Polylines (Faster) settings.

Tech Note: The hidden line settings for Edge
display do not affect the Hidden Line render mode
available in the Render Options dialog box. See
Shade Options for information on the render
modes.
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Below is a sheet with four views

Any number of photo-rendered views can be included in engineering drawings.

Using the Model to Sheet Command
1. Select the models to display on the sheet.

2. Choose Layout>Model To Sheet.
The Model to Sheet dialog box displays.

Use Layout Settings The dialog box has 5 combination boxes that change the pen 
style when doing a Model to Sheet. It is possible to have a 
layout with predefined pen and scale settings for each view 
and retain the values by checking the Use Layout Settings 
check box. When this box is checked, the pen style options are 
grayed out.

Zoom Extents Changes the scale of the drawing view so the objects within it 
fill the drawing view. This command operates similarly to the 
Zoom All command except that it applies to a drawing view.

Scale Sets the scale of the drawing.

Pen Styles Refer to the Draw View Properties section of this chapter for 
details.

OK, Cancel Clicking OK completes the Model to Sheet command and 
displays the geometry based on the specified settings. Clicking 
Cancel, cancels the command and closes the dialog box.
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3. Choose the Layout, Rendering and Wirefrme options from their respective pull-down 
lists.

4. Enter a scale in the Scale field.
5. Click OK.

2D geometry is created from the 3D model, placed in the drawing views of the 
selected layout, and displayed in the top view. A Sheet View layer is also created on 
which the drawing views containing the geometry are placed. 

Referral: Drawing Views are explained later in this chapter.

If a layout is selected with a format A, B, C, D or E, the format is also placed on the 
Sheet View layer. Choose Layout>Layer Manager to see the new layer and the 
number of new 2D objects on that layer.

The Sheet View layer is now the work layer and all other layers are turned off.

Undoing the Model to Sheet Command
If the Model to Sheet command is inadvertently selected or later it is necessary to 
remove the sheet, use the Undo command or the Layer Manager.
• Using Undo: Choose Edit>Undo (CTRL+Z (Windows) or +Z (Macintosh). The Undo 

command can be used more than once depending on the number of operations 
conducted since the Model to Sheet command was chosen.

• Using the Layer Manager: Display the Layer Manager. Choose another layer as the 
work layer. Then select the Sheet View layer and delete it. Click OK to close the 
dialog box. The view is still set to top. Change the view and zoom scale to view the 
geometry.
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Drawing Views
A drawing view is a defined area into which the 
2D geometry is placed when using the Model 
to Sheet command. The drawing view displays 
the geometry in a particular view orientation, 
like top, trimetric, etc. The example here 
shows a drawing view with a trimetric view 
orientation.

Tech Note: Drawing views operate differently from those in Vellum 3D. You
are not looking at a 3D model in a drawing view but rather 2D wireframe
object created from the 3D model. The trackball cannot be used to rotate the
view orientation of a specific drawing view or zoom in the drawing view. Use
the Change View command and Properties command in the Drawing View
menu to make adjustments. See the Drawing View Menu.

Drawing views are created automatically using the Model to Sheet command or by using 
one of the Sheet tools. Drawing views are placed on top of the Sheet View layer rather 
than on the layer. Each drawing view has its own work plane. Any additional objects, text 
or dimensions placed in the view appear only in that view on that work plane, set to top.
The drawing view frame uses the foreground color set in Preferences. If the Show Triad 
command is activated, the triad displays in each drawing view.
Spacing for crosshatching, 
dimensions, text, arrow size and line 
font in drawing views can now be set 
relative to the sheet through the Edit 
Objects dialog box, independent of 
the scale set in the drawing view. This 
sets any scale for the view without 
concerning how the item will appear.
Just double-click the item to display 
the Edit Objects dialog box. On the 
Attributes page, select the Ignore 
Scale option. Click Close or Apply to 
update the selected item.
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Activating Views
Once a drawing is created, activate individual views 
by clicking in the rectangular region surrounding the 
view. When activated, the view boundaries highlight 
in red.
You cannot activate drawing views if the sheet is 
displayed in any view other than top. All geometry in 
the view becomes available for selection when the 
view is activated. The Drafting Assistant recognizes 
all snap points in the view. Click outside the area to 
deactivate the view.

Tech Note: The Drafting Assistant only recognizes geometry within an active
view.

Drawing View Menu
Drawing views have specific 
commands associated with them. 
These are accessible through a pull-
down menu in the drawing view. Click 
the mouse in the upper left region of 
the view.

The view menu displays.
The view menu can also be displayed by clicking the right mouse 
button (Windows) or by holding down the CTRL key and clicking 
the mouse button (Macintosh).
The View menu contains the following commands: Properties, 
Delete, Align, Center, Change View, Frame to Extents and Flatten 
View.

Properties Command
The Properties command accesses to a set of properties that affect a drawing view’s 
display on the screen. When the command is chosen, the following dialog box displays.
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The dialog box contains the following options:

Name Specifies the name that appears in the drawing view when the 
Draw name check box in the dialog box is activated.

Rendering Provides Flat, Gouraud and Phong shading options and Photo-
rendered, Photo-rendered (no materia) rendering options to 
make the object look photorealistic in the model to sheet.

Wireframe Sets the hidden edges display in the final drawing. There are 
Precise Curves (Slower), and Polylines (Faster) settings.

Scale Sets the scale of the drawing.

Dash Length Sets the length of dashes when using either the Dash All 
Hidden (precise) or Dash Only Holes (precise) edge display 
options.

Frame Region Defines the rectangular area of the selected drawing view and 
its location. The field values represent the view edge’s distance 
from the origin (where the sheet is automatically placed).

The Left field sets the distance from the left view edge to the 
origin (0,0,0). The Right field sets the distance from the right 
view edge to the origin (0,0,0). The Top field sets the distance 
from the top view edge to the origin (0,0,0). The Bottom field 
sets the distance from the bottom view edge to the origin 
(0,0,0).

Units are based on those set in Preferences.

Pen Styles Pen styles are used to define edge attributes options within a 
draw view.   Edge options include visible, hidden, holes, 
tangent and outline. A pen style defines the pen weight, pattern 
and color.

One advantage to using a pen style to define an edge attribute 
is the ease at which different pen styles can be explored for all 
the drawn views.   Any change to the master pen style will 
automatically update all edges that use that pen style.

For example, suppose it is necessary the visible lines printed 
in a E size drawing at a heavier weight than an A size drawing. 
In this case just change the Visible pen weight to the desired 
weight and print. 

Note: It is also possible to select "Use Object Color" which 
does not use a pen style but always follows the object color 
used to create the draw view.
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Tech Note: The hidden line settings for Edge display do not affect the Hidden
Line render mode available in the Render Options dialog box. See Shade
Options for information on the render modes.

Visible Applied to edges that are not hidden. This excludes edges that 
are classified as tangent or outline.

Hidden Applied to edges that are occluded. 

Holes The holes edge format is applied to edges that are hidden and 
cylindrical.

Tangent Applied to edges that are shared by two faces that are tangent. 
Fillet edges are examples of tangent curves. 

Outline An edge is classified as an outline if the normal to the face on 
one side of the edge points towards the eye and the normal to 
the face on the other side of edge points away from the eye.
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The following picture gives examples of how changing these parameters affect the 
model.

Transparent View Controls whether the drawing view background is clear or 
opaque. When checked, the background is clear and objects 
located underneath the view are visible through the view.

Remember that drawing views are placed on top of the Sheet 
View layer rather than on the layer. Geometry placed on the 
layer may fall underneath a view.

Frame View Controls the display of the drawing view frame. When selected, 
the view frame is visible.

2D Objects in View Controls the 3D nature of geometry within the drawing view. 
When checked, all geometry is flattened to 2D geometry. For 
example, an arc in a trimetric drawing view becomes an ellipse 
in 2D when this option is checked. When left unchecked, no 
objects are flattened.
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Delete Command
The Delete command in the Drawing View menu removes the drawing view and its 
contents from the drawing. The original model remains.

Align Command
The Align command in the Drawing View menu functions like a tool with the Message 
Line which contains steps for its use. This command aligns an active view with another 
selected view. Use the command on section views, general drawing views and auxiliary 
views. The left graphics here show, the top view of a CAM part with its associated 
auxiliary view. The right graphics show the same two views aligned.

1. Select the view to align.

Draw Name Controls the display of the text in the Name field. When 
selected, the text displays at the lower border of the frame, 
centered between the left and right edges.

Draw Scale Adds a scale to the layout as a text element with the view 
names.

Regen Manually Controls whether the view regenerates or updates 
automatically after making changes to the geometry. This 
control is helpful if a file requires a long regeneration time. With 
this option selected, a series of changes can be made without 
the delay of regeneration. To regenerate one particular drawing 
view, toggle this option between on and off.

This option relates to the Manual View Regeneration tool in 
the Sheet tools palette which regenerates all views on the 
sheet.

Simplify Curves Attempts to simplify splines into lines, arcs, or circles when 
appropriate. This is primarily useful if the objects used in the 
model to sheet consisted of splines instead of the typical 
analytics.

Auto Hatch Controls hatching for a section view. When selected, hatch 
automatically appears within section geometry. This option 
uses the default hatch set in the Cross Hatch dialog box. See 
Fill and Crosshatching.

Area Hatch Only Controls the geometry that appears in the section view. When 
selected, only the geometry cut by the section displays. When 
not selected, the section view shows the section geometry and 
any portion of the geometry lying behind the section cut.
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2. In the Drawing View menu, choose the Align command. The Message Line reads: 
Align View: Pick parent view to align with.

3. Select the parent view. The two views align.

Center Command
The Center command centers the objects within the frame boundaries. This is especially 
helpful if the drawing view is moved or the view orientation of the geometry is changed.

Change View Command
The Change View command changes the 
view orientation of the selected drawing 
view. Change the view to one of the pre-
defined or user-defined views or modify the 
view by specifying the Eye/Reference 
point, Azimuth/Elevation or rotation values.
When this command is chosen, the Change 
Aux View dialog box appears.
The dialog box contains the following options:

View Setting This setting displays the name of the current view and a pull-
down list for selecting a different view. The views include Right 
Side, Left Side, Front, Back, Top, Bottom, Iso (Top Front Left), 
Iso (Top Front Right), Iso (Top Back Left), Iso (Top, Back 
Right), Iso (Bottom, Front Left), Iso (Bottom Front Right), Iso 
(Bottom Back Left), Iso (Bottom Back Right), Trimetric and any 
user-defined views.

Modify View Clicking this button brings up the View Properties dialog box.

Change the Eye/Reference point, Azimuth/Elevation or rotation 
values for the view. It is also possible to name the view. If a 
name entered and to display it in the drawing view, it is 
necessary also to enter the new name in the Draw View 
Properties dialog box. This view is specific to the drawing view 
and not available through the Trackball.

Perspective Enables perspective so that the size of an object's dimensions 
along the line of sight are relatively shorter than dimensions 
across the line of sight.
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Frame to Extents Command
The Frame to Extents command shrinks the frame to the size of the geometry in the 
view.

Flatten View Command
The Flatten View command deletes the drawing view, projects all objects into 2D entities 
and places them on the sheet creating complete 2D geometry. This command destroys 
any associativity between the flattened objects and the 3D model that created them.
The objects are scaled according to the value set in the Properties dialog box for the 
view. If the view contains dimensions, they are flattened also. The dimension value from 
the original view is placed in the flattened view. If the view scale was set to anything 
other than 1.0, the actual measurement of the flattened object will be different than the 
dimension value. For example, if an object is dimensioned in a view that was 1.25 
inches and shown at a scale of 2, the flattened dimension would still read 1.25. The 
actual length, however, is 2.50. 
Important: Be sure to mark the drawings “Not to Scale” if flattening a view with any 
scale other than 1 so that people read the dimension value rather than measuring the 
object.
Since the geometry in the view is scaled, its size on the screen after being flattened, is 
the same as it was in the view. The left graphic here shows a selected view. The right 
graphic shows the same geometry flattened.

If a detail view is flattened, the detail view boundary is converted into a circle with a 
phantom pen pattern and flattened onto the sheet with the geometry.

Zoom Extents Command
The Zoom Extents command changes the scale of the drawing view so the objects 
within it fill the drawing view. This command operates similarly to the Zoom All command 
except that it applies to a drawing view.

Focal Length Sets the convergence or divergence of perspective. The naked 
eye sees at about 50 which gives noticeable perspective. 
Shorter focal lengths increase perspective with a wide-angle 
effect. Longer focal lengths shorten perspective. Focal Length 
is only applicable when Perspective is checked. 

OK Click this button to close the dialog box and the view changes.

Cancel Click this button to close the dialog box without making any 
changes.

Apply Click this button to change the view but keep the dialog box 
open.
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Sheet Tools
After the drawing is created, some changes can be made to the drawing to better 
illustrate certain aspects of the model. Tools are provided to create new views, modify a 
selected view and add auxiliary views, section views and details views to the drawing. 
These tools are available through the Sheet tools palette. The tools include Drawing 
View, Auxiliary View, Section View, Detail View and Manual View Regeneration. 
Choose Window>Sheet Tools to display the palette.

Drawing View Tool

This tool creates empty drawing views. Use this tool to add 
drawing views to the current layout already containing views or 
create customized layouts.

Using the Drawing View Tool
1. Select the Drawing View tool. The Message Line reads: Drawing View: Pick start 

position view frame.

2. Click the starting point position for the frame. The Message Line now reads: Drawing 
View: Pick end position view frame. 
Notice that as the pointer is moved to select the ending position an outline of the 
frame appears.

3. Click the ending point position for the frame.
The new view appears with the frame edges. The view orientation is front. Continue 
placing new views as desired. To activate the view, choose the Selection tool and 
select the frame.

Adding Associative Geometry to Empty Drawing Views
Cobalt or Xenon add geometry (associative to the original 3D geometry) to empty views. 
When changes are made to the geometry all associative geometry updates.
1. Turn on the layers containing the 3D geometry to place in the new view.

2. Select the 3D geometry.
If geometry is selected from an existing drawing view, only 2D wireframe geometry 
would be copied.

3. Choose Edit>Copy.
4. Select the empty drawing view.
5. Choose Edit>Paste.

The geometry pastes into the new view. Use the Drawing View menu to center the 
geometry, change the view, etc.

Auxiliary View Tool

This tool creates auxiliary views from a referenced drawing view. Auxiliary views 
dynamically align to that view and are associative to both the original view and the 
auxiliary dimension. Change the geometry and the auxiliary view automatically updates. 
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Move the dimension location in the original view and again the auxiliary view reflects the 
changes. Auxiliary dimension lines appear in the original view. These dimensions are 
placed on the Sheet View layer. The Auxiliary tool can only be used when a drawing 
view is present.
By default, auxiliary labels are alphabetical. If more than one auxiliary view is placed in 
the drawing, the auxiliary view label automatically increments to the next letter. If the file 
containing auxiliary views is closed and later it is reopened and another auxiliary view is 
added, the label increments to the next letter based on the last auxiliary label in the file. 
Any label text can be entered if desired. The user-defined label text, however does not 
automatically increment.

Tech Note: The font type, size or style of the dimension label cannot be
changed. Use the Text tool to create custom labels.

The left graphic here shows the 
referenced view with auxiliary view 
dimension lines. The right graphic shows 
the auxiliary view.

Using the Auxiliary View Tool
1. Select the Auxiliary View tool. The Mes-

sage Line reads: Auxiliary View: Pick draw-
ing view for auxiliary view.

2. Select the drawing view from which to create the auxiliary view.
The Message Line now reads: Auxiliary View: Pick start and end of folding line.

3. Click the start and endpoint locations that specify the folding line for the view. The 
points do not need to be located on the geometry.
The Message Line reads: Drag window to final position.

4. Drag the view to a new location and click the mouse button. Notice that as the 
pointer is moved, an outline of the frame appears.
The auxiliary view displays with a view label at the specified location. The auxiliary 
view dimension appears in the original view.
To delete the view later, delete both the view and the dimension line in the original 
view. The auxiliary labels may need to be adjusted to accommodate the deletion.

Changing the Direction or Label of the Auxiliary 
View
To change the auxiliary view direction opposite to that 
indicated by the view dimension, select the dimension 
and choose Window>Edit Objects. In the Geometry 
page, check the Flip Direction option and click Apply. 
The direction of the view changes.
The view label can be changed in this dialog box.
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Section View Tools

These tools create horizontal, vertical and 2 point section views. Section view geometry 
is associative to the geometry in the view and the section dimension. Change the 
geometry and the section view automatically updates. Move the dimension location in 
the original view and again the section view reflects the changes. Section view 
dimensions are placed on the Sheet View layer.
The Section tools specify whether to see only the section cut, or both the section cut 
and the geometry lying behind it. This ability is controlled in the Draw View Properties 
dialog box, accessed through the Drawing View menu. See the Drawing View Menu 
section earlier in this chapter.
By default, section labels are alphabetical. If more than one section view is placed in the 
drawing, the section view label automatically increments to the next letter. If the file 
containing section views is closed and later reopened and another section view is 
added, the label increments to the next letter, based on the last section label in the file. 
Any label text can be entered if desired, however, user-defined label text does not 
automatically increment.

Tech Note: The font type, size or style of the dimension label cannot be
changed. Use the Text tool to create own labels.

Section views also support crosshatching. These tools can only be used when a drawing 
view is present. The graphics here show a vertical section view.

Tech Note: Solids cannot be pasted into section views. To add a solid, add it
to the original view.

When the Section View tool is selected, a subpalette appears containing three tools: 
Vertical, Horizontal and 2 Pt.

Vertical Section View Tool

This tool creates a vertical section view.
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Using the Vertical Section View Tool
1. Select the Section View tool.

2. Select the Vertical Section View tool in the Message Line. The Message Line 
reads: Section View: Pick drawing view for section.
If a view is already selected, skip to step 3.

3. Select the drawing view.
The Message Line now reads: Section View: Pick location for vertical section.

4. Click a point on the geometry for the section.
The Message Line reads: Drag window to final position.

5. Drag the view to a new location and click the mouse button. Notice that as the 
pointer is moved, an outline of the frame appears.
The section view displays with the view label shown in the Status Line. To have a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view.
To delete the view later, delete both the view and the dimension line in the original 
view. It may be necessary to adjust the section labels to accommodate the deletion.
The Status Line contains the section view label.

Horizontal Section View Tool

This tool creates a horizontal section view.

Using the Horizontal Section View Tool
1. Select the Section View tool.

2. Select the Horizontal Section View tool in the Message Line. The Message Line 
reads: Section View: Pick drawing view for section.
If a view is already selected, skip to step 3.

3. Select the drawing view.
The Message Line now reads: Section View: Pick location for horizontal section.

4. Click a point on the geometry for the section.
The Message Line reads: Drag window to final position.

5. Drag the view to a new location and click the mouse button. Notice that as the 
pointer is moved, an outline of the frame appears.
The section view displays with the view label shown in the Status Line. To have a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view.
To delete the view later, delete both the view and the dimension line in the original 
view. It may be necessary to adjust the section labels to accommodate the deletion.
The Status Line contains the Section view label.

2 Pt Section View Tool

This tool creates a section view based on the orientation of two user-defined points.
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Using the 2 Pt Section View Tool
1. Select the Section View tool.

1. Select the 2 Pt Section View tool. The Message Line reads: Section View: Pick 
drawing view for section.

If a view is already selected, skip to step 3.
2. Select the drawing view.

The Message Line now reads: Section View: Pick start and end of section orientation.
3. Click two points on the geometry to indicate start and end points for the section cut-

ting line.
The Message Line reads: Drag window to final position.

4. Drag the view to a new location and click the mouse button. Notice that as the 
pointer is moved, an outline of the frame appears.
The section view displays with the view label shown in the Status Line. To have a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view. 
Adjust the section labels to accommodate the deletion.
To delete the view later, delete both the view and the dimension line in the original 
view.
The Status Line contains the Section view label.

Changing the Direction or Label of a Section View
To change the section view direction opposite to 
that indicated by the view dimension, select the 
dimension and choose Window>Edit Objects. 
On the Geometry page, check the Flip Direction 
option and click Apply. The direction of the view 
changes.
It is also possible to change the view label in the 
dialog box.

Sections and Crosshatching
By default, section views automatically contain 
crosshatching. Remove the crosshatching or 
change the hatch pattern for a selected view 
through the Cross Hatch dialog box.

Tech Note: The crosshatching used for geometry in a section view must be
set separately from the material set in the Mass Properties dialog box. See
the Editing Objects chapter for more information on Mass Properties.

It is also possible to set the default hatch pattern through this dialog box. When nothing 
is selected, choose Pen>Cross Hatch. See Fill and Crosshatching chapter for more 
information on the dialog box and the hatches available.
If there is more than one object cut in the section, define separate hatch patterns.
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1. In the section view, select the hatch pattern.

2. Choose Pen>Cross Hatch. The following dialog box displays.
3. Select a category and Cross Hatch pattern from their respective lists.
4. Set the hatch rotation angle and scale.
5. Click Apply to change the selected hatch.

If you are not satisfied with the hatch pattern, choose another. Change the hatch 
patterns of any other section geometry in the view or in other views if necessary.

6. Click the Close button (Windows) or the Close box (Macintosh) to exit the dialog box 
when finished.

Detail View Tool

This tool creates a detail view from a drawing 
view. Detail view geometry is associative to the 
geometry in original view and the detail 
dimension. Change the geometry within the 
area defined by the detail and the detail view 
automatically updates. Move the dimension 
location or the size of the detail in the original 
view and again the detail view reflects the 
changes. Detail view dimensions are placed on the Sheet View layer.
By default, detailed dimensions are alphabetical. If more than one detail view is placed 
in the drawing, the detail view dimension and label automatically increment to the next 
letter. If the file containing detail views is closed and later reopened and another detail 
view is added, the dimension and label increment to the next letter, based on the last 
detail label in the file. Label text can be entered as desired, however, user-defined label 
text does not automatically increment. The graphic above shows a drawing view and an 
associated detail view.

Tech Note: The font type, size or style of the dimension label cannot be
changed. Use the Text tool to create own labels.

Once a detail view is created, the detail view dimension can be moved in the original 
view from its default location, shown as A in the left graphic above. Select the label, 
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choose Edit>Show Points and drag the control point/detail dimension to another 
location. The detail view label, shown as Detail A above, cannot be moved.
This tool can only be used when a drawing view is present.

Tech Note: Solids cannot be pasted into section views. To add a solid, add it
to the original view.

Using the Detail View Tool
1. Select the Detail View tool. The Message 

Line reads: Detail View: Pick drawing view 
for detail view.

If a view is already selected, skip to step 3.
2. Select the drawing view.

The Message Line now reads: Detail View: Pick detail center.
3. Click the center point on the geometry for a detail view.

The Message Line reads: Detail View: Pick detail edge pt.
4. Click the detail edge point.

The Message Line reads: Drag window to final position.
5. Drag the view to a new location and click the mouse button. Notice that as the 

pointer is moved an outline of the frame appears.
The detail view displays with the view label and the scale shown in the Status Line. To 
have a different label or scale, enter the data in the appropriate data field and press 
ENTER (Windows) or RETURN (Macintosh). The detail view dimension appears in 
the original view.
To delete the view later, delete both the view and the dimension line in the original 
view. Adjust the detail labels to accommodate the deletion.

The Status Line contains the detail view label and Scale.

Resizing the Detail View Dimension
It is possible to change the diameter of the detail view 
dimension. Select the detail dimension and choose 
Edit>Show Points. Two control points appear defining the 
center and edge of the dimension.
Select one of the control points and drag it to a new 
location.

Manual View Regeneration Tool

This tool regenerates all drawing views on the sheet. This is useful if the Manually 
Regen option in a Draw View Properties dialog box is selected for one or more views 
and changes are made to them.

Using the Manual View Regeneration Tool
1. Select the Manual View Regeneration tool.
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The Draw Views dialog box appears displaying the number of views that need to be 
regenerated.

2. Click Yes to regenerate all views. 
Click No to close the dialog box without regenerating the views.

Unfolding Views
New views can be quickly created from an existing drawing view by using an unfolding 
operation. The graphic here shows a center view unfolded in four directions.

1. Choose the Selection tool and activate to unfold.

2. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and drag the 
view to the left, right, top or bottom of the view.
A new view is created with the geometry rotated 90° from the selected view.

Editing a Drawing View
Adding Objects to a View
Add objects in an existing or new view by either creating them using a drawing tool or by 
copying and pasting them into a view.

Creating Objects in a View
Once a view is activated, create additional wireframe and solid objects in the view. Since 
the Drafting Assistant functions inside the view, place the objects relative to the other 
objects already present.
Dimensions and text can be placed in the view using the Dimension tools and the Text 
tools. All dimensions are placed on the Sheet View layer rather than the Dimension 
layer for drawing views. Since the drawing view work plane is set to top, all text and 
dimensions appear correctly.
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All entities created in an active view, display only in that view.

Copying and Pasting Objects into a View
Objects copied from another location can be pasted into a selected view. When pasting 
the objects, the contents of the paste buffer is examined and inserted it in the active 
view. The inserted object is associative to the original object. This feature is valuable 
when creating a new drawing view.
If the objects were copied from a 3D model, 
the 2D objects created from them are 
associative to the model. It is possible to 
change the view later and the geometry will 
display correctly. If 2D objects are copied 
from a view (regardless of whether they 
were created from a 3D model), these 
objects do not reference the 3D model. 
Since this 2D geometry is not associative to 
a 3D model, changing the view may not create a complete view. The graphic here shows 
an example of this. The 2D geometry in the trimetric view was pasted into the right side 
view.

Editing Objects in the View
Editing 2D Geometry created from 3D Geometry
It is possible to edit 2D geometry in a number of ways: changing the line characteristics, 
layers or modifying the geometry.

Changing Line Patterns and Layers
Since an object placed in the drawing views are true 2D wireframe, assign a different 
line pattern, color, weight or layer to the entities making up the object. To change a line 
characteristic, select the line in the view. In the Pen menu, choose a new pattern, color 
or weight. Line characteristics can be changed through the Edit Objects dialog box.
To change the layer for the line, choose Edit>Change Layer and select the new layer. 
You can also change the layer through the Edit Objects dialog box.

Modifying 2D Geometry
Because the 2D geometry created from the 3D model is composed of individual curves, 
the length or the location of the curve cannot be modified by dragging a control point like 
in a normal model. If this were possible, the associativity of the model would be 
destroyed. For example, a line in a model may represent the visible edge of a cylinder 
which is not actually present in the 3D model. If this was changed, a cylinder would not 
exist longer.
When attempting to modify the geometry, the program provides the following warning.

Given this, there are two ways to edit geometry, removing the links of the selected 
geometry or editing the 2D geometry by changing the parent 3D geometry using the 
Design Explorer and the Edit Objects dialog box.



Drawing Composition for Cobalt & Xenon

44-22

• Select the object and choose Edit>Remove Links. A warning appears as a reminder 
reminding that this command deletes all associative relationships and that this 
operation cannot be undone. Click OK and the object can now be changed.

• Select the object. Display the Design Explorer and open the history tree to show the 
parent geometry for the selected object. Double-click on that object to display the Edit 
Objects dialog box. Change the desired value and click OK. The 3D model and the 
2D geometry updates. The graphic here shows a selected edge and the Design 
Explorer with the ACIS Solid parent.

Editing View Characteristics
Changing the Scale of a View
There are two methods for changing the scale within a view:
• Choose the Properties command in the Drawing View menu and change the scale 

value within the dialog box.
• Use the Selection Make and the Design Explorer to select the views to modify, then 

change them in the Edit Objects dialog box.

Resizing a Drawing View
There are three methods for resizing a drawing view:
• Dragging the view edge: Select the view and place the 

pointer on a control point of the edge to move. The 
pointer becomes a two-directional arrow. Drag the edge 
to a new location. Place the pointer at a corner control 
point to resize two adjacent edges at the same time. The 
graphic shows the view control points and the directional 
arrow.

• Using the Properties command in the Drawing View menu
• Using the Frame to Extents command in the Drawing View menu
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Dimensions and Drawing Views
If dimensions in the drawing view go outside the bounds of the view so that they can’t be 
seen, choose the Frame to Extent command in the Drawing View menu. The view edge 
can be dragged manually to completely display the dimension. See Dimensions for 
information on the standard dimension tools.
All dimensions placed in drawing views go on the Sheet View layer rather than the 
Dimension layer. This enables turning off all other layers and still prints the sheet with 
views containing dimensions.

Changing or Deleting View
The view orientation, scale and view properties can be changed through the Drawing 
View menu for each view. If the view orientation of a drawing view is changed and all of 
the geometry in the view cannot be seen, choose the Center command or Frame to 
Extents command in the Drawing View menu. See the Drawing Views section earlier in 
this chapter for more information.
It is possible to delete a view through the Drawing View menu. All drawing views can be 
deleted at once by selecting the Drawing view type in the Selection Mask, double-
clicking on the Selection tool and pressing the BACKSPACE key (Windows) or the 
DELETE key (Macintosh).

Moving a Drawing View
There are two methods for moving a drawing view:
• Dragging the View: Select the view. Place the pointer over a 

view edge, not a control point. The pointer becomes the move 
symbol. Select the top or bottom view edge to drag the view 
vertically. Select the left or right view edge to drag the view 
horizontally.

• Using the Properties command in the Drawing View menu

Drawing Views and the Edit Menu
If you notice that the Edit menu name is red while working in a sheet view, the drawing 
contains some unresolved links. This occurs when geometry is moved or any other 
change is made. Choose Edit>Resolve Links. The Edit menu name becomes black 
again.

Layout Templates
A default set of layout templates is displayed for 
each localization setting. The set of templates to 
controlled through the language selection in the 
Preferences section. To change the default set, go 
to File>Preferences>Localization and select the 
desired language set.

Creating User-defined Layout Templates
Create custome templates from scratch or by modifying an existing template.

Modifying an Existing Template
All templates provided are in the Designer Elements program files and can be opened 
like any other file. 
1. Open one of the files in the Layouts folder. 
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2. Make any changes. It is possible to adjust the format, add text to the title block, and 
add or remove drawing views.

3. Save the file under another name in the desired Layouts folder.
Select this template from the Layout pull-down menu in the Model to Sheet dialog box.

Creating a New Template
Create a new template from scratch using a standard program file. 
1. Open a new file.

2. Set the view and plane to Top.
3. Create the title block and border for the layout and add text if desired.
4. Using the Drawing View tool, add drawing views.
5. Save the file in the Layouts folder.

This template can be selected from the Layout pull-down menu in the Model to Sheet 
dialog box.

Tech Note: There are three possible locations for Layouts: 
1 In the Applications folder 
2 In the All Users folder 
3 In the Current Users folder 
See the knowlegebase in the Support Center of www.ashlar.com for
information specific to your operating system and version of the software.

Printing the Layout
To print the layout with the views, turn off all layers other than the Sheet View layer. 
Make sure the Page Setup (Windows) or Print Setup (Macintosh) matches the layout.
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Attributes and Bill of Materials
User Attributes and Bill of 
Materials provide a means to 
apply custom attributes to 
entities and display that data in 
a table or export it to an 
external application such as 
Microsoft Excel.
This tool is located in the 
Window menu 
(Window>Attributes and 
BOM). After selecting this tool 
the following dialog box 
appears:
The Bill of Materials dialog box 
contains a drop down menu of 
predefined attribute templates and five button options.
The predefined templates are:

Area Calculates the surface area of any polygon, surface or solid.

Area 2D Calculates the 2D area and centroid properties for curves.

Mass Properties Calculates the Mass Properties for a solid using the 
Verify>Mass Properties command.

Material Assigns a material to an entity.

Perimeter Calculates the 2D perimeter for curves.

Price Assigns a price to an entity.

Standard Assigns a part number and description to an entity.

Stock Size Assigns part number, stock size and description to an entity.

Vendor No. Assigns a part number, a vendor number and a description to 
an entity.

Volume Calculates the volume of a solid.

Weight Calculates the weight of a solid using the material assigned in 
the Verify>Mass Properties command.



Attributes and Bill of Materials

45-2

The first five attribute templates require the user to supply all of the information 
associated with the attribute. The latter six automatically extract attribute information 
from the entity.
The five buttons on the Attributes/BOM dialog box have the following functions:

Apply To Selected This options applies the current BOM attribute to the selected 
entities.

Create BOM This option creates a Bill of Material Table using the attributes 
defined by the pull down menu. The user is prompted to enter 
text height, column width and item order.

Update BOM This option updates the BOM table and the corresponding 
balloons.

Export BOM This option creates a tab separated text file that can be opened 
with any text editor as well as imported into Microsoft Excell or 
other similar spreadsheet programs. 

Create Balloons This option adds balloon item dimensions to geometry. This 
option requires an item number type to be used with the 
attribute. All of the supplied attribute files have item numbers.

Graphic 2 equals Item Numbers Up
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Tip: The Bill of Materials function does not incorporate the use of Copy/Cut
and Paste.

BOM User Defined Templates
Create user-defined templates by creating an attribute definition file. Attribute definition 
files are located in the BOM folder of the install directory. The first line of the file contains 
the attribute name. This is the name that will appear in the attribute pull-down menu. 
The next lines contain two columns, the first column contains the attribute definition 
string, and the second column the attribute type. Commas separate each column
The following attribute types are supported:

Float User-assigned signed decimal value.

Integer User-assigned signed integer value.

String User-assigned character string.

Area Calculates the entity area and assign.

Perimeter Calculates the entity perimeter and assign.

Volume Calculates the entity volume and assign.

Weight Calculates the entity weight and assign.

Qty Counts the number of occurrences this attribute is used. 

Index Index used to refer to the attribute in the BOM table or balloon 
callout.

Name Extracts the name from the entity.

CG-X Calculates the CG-X value from an entity.

CG-Y Calculates the CG-Y value from an entity.

CG-Z Calculates the CG-Z value from an entity.

Sum Sums the value the previous attribute.

Material Extracts the material type from the entity.
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Page Setup and Printing
The geometry is created using the wireframe, surface and solids tools, then various 
operations are conducted on it such as extruding, sweeping and blending, and finally 
some basic annotation are added to the drawing.
All during the design process it was not necessary to designate a scale or paper size. 
Now to print a hard copy it is necessary to set up the page according to a scale, paper 
format, orientation and the printer specifications.
This Designer Elements program prints and plots on most printers and plotters 
supported by your computer. Follow the manufacturer’s instructions for installing and 
setting up the printer or plotter, and to set up the page size as needed.
The following topics are covered:
• Page Layout Command
• Printing a Drawing
• Print Window

Page Layout Command
The Print Layout command, located in the File 
menu, displays the dialog box to set the page size, 
scale and other options.
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Selecting the command the Print Layout dialog box appears. The graphic here shows 
the Advanced Setup mode.

The Drawing Size dialog box includes the standard buttons: OK, Close and Apply.

The Drawing Size dialog box includes the following sections: Setup Mode, Drawing 
Size, Scale, Preview and Utility Controls.

Setup Mode Section
The Drawing Size dialog box supports four setup modes; Single Page, Height and 
Width, Rows and Columns and Advanced.
For all setup modes, a drawing frame displays in the Preview window. The outer 
drawing frame represents the physical page size. The inner drawing frame represents 
the printable page area. The page settings are obtained from the current printer settings. 
Change the printer settings by choosing File>Print Setup (Windows) or Page Setup 
(Macintosh).

OK Click this button to accept all changes and close the dialog 
box.

Close Click this button to ignore any changes made since the last 
time Apply was clicked and close the dialog box.
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Single Page Mode
The Single Page mode is the simplest printing mode. It is the best mode to use when 
printing to a large format plotter or for a quick single page plot. As the printer settings 
are changed, the drawing frame updates to conform to the new settings. Selecting this 
mode displays the most basic Drawing Size dialog box.

Set the plot scale by making a selection from the Scale drop down list or by changing 
the value in the Scale data field.
Use the Fit to Area button to automatically compute the scale that will fit the drawing 
objects to the printable area.

Height and Width Mode
The Height and Width mode is used to generate large standard or user defined plot 
sizes when using small format print devices (e.g. 8.5 x 11 laser or inkjet printer). 
Selecting this mode displays the format area of the Drawing Size section.
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For drawing sizes larger than what the printing device allows, the drawing is tiled and 
can later be assembled into the large format plot. The Preview window displays the 
page tile edges within the drawing frame automatically.
Specify a standard drawing size or a custom drawing size. Set the scale in the Scale 
section or automatically compute the scale using the Fit to Area button.

Rows and Columns Mode
The Rows and Columns mode is used to force whole pages to be used for tiled plots. 
Unlike the Height and Width mode, this mode will use all the printable area available for 
the plot, however, the plot will not be a standard size. Selecting this mode displays the 
Tile area of the Drawing Size section.

Specify the tile rows and columns by changing the values in the Rows and Cols data 
fields. The Overlap data field controls how tile pages will overlap. The overlap region 
helps align the pages when assembling the final plot.
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Advanced Mode
The Advanced mode provides access to all height, width, row and column plot settings. 
This mode permits complete control over all aspects of tiling. Selecting this mode 
displays the entire Drawing Size section.

Specify any of the listed elements.

Drawing Size Section
This section contains the drawing format sizes available and the height and width of the 
selected format size.

The format size field includes a pull-down menu listing all of 
the formats and their sizes.
Choose any of the predefined sizes, A, B, C, D, E, F, G, H, J 
and K. Each format size includes a listing for portrait and 
landscape orientation.

Tech Note: When choosing a drawing format size, be sure to set the page
orientation for the printer to the same orientation selected in the Drawing Size
dialog box. Choose File>Print Setup or Page Setup to display the Printer
dialog box to check the current page orientation.
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The units (inches or mm) are determined by the preference setting. When selecting one 
of these predefined formats, the size is displayed in the Width and Height fields.
It is also possible to set the drawing size by selecting the User Defined option in the list. 
Choosing this option, enter the size in the Width and Height fields.
The drawing sizes displayed in the pull-down list are contained in the DrawSize.ini file in 
the Environ folder within the program folder. This file can be edited but keep in mind it 
may change or be overwritten by future installations (updates) to the program. Before 
editing the file, save the original version under another name in order to have a copy in 
case it is necessary to return to the default sizes.
If the page size is larger than the size supported by the printer, values are automatically 
entered in the Tile area to accommodate the drawing and appears as such in the 
Preview window. (Choosing the Advanced mode shows the tiling specifics.) See the 
next section for more information on tiling.
Before choosing the size, determine what formats the printer or plotter supports.
Drawing size and page tiling are synchronized based on the scale. Values entered in the 
drawing size fields affect those in the page tiling and vice versa. Height affects Rows 
and Width affects Cols. The last field in which values are entered controls the drawing 
dimension, represented by the activated field name. The associated field name is 
unavailable.

Setting the Format Size
1. Choose File>Print Layout.

2. Choose the Height and Width mode from the pull-down menu.
3. Display the pull-down menu for the drawing format size.
4. Select the desired size. 

The size is displayed in the Width and Height fields. 
If the User Defined format size is selected, enter the size in the Width and Height 
fields.

Page Tiling
The Tile area of the Drawing Size section sets up the file so a larger drawing can be 
printed in tiled sheets.

This area includes these elements:

Rows Represent the number used to print the file, based on the size 
supported by the printer driver and the drawing scale. A value 
automatically appears in this field when a drawing size larger 
than that which the printer supports is selected.

If the exact drawing size is unimportant, just specify the 
number of rows. Since the number is synchronized with the 
Height, entering a different value changes the height of the 
drawing.

Cols Represent the number of columns used to print the file, based 
on the size supported by the printer driver and the height of the 
drawing. A value is automatically entered in this field when a 
drawing size is selected. 



Page Layout Command

46-7

This graphic shows an example of tiling with three rows and four columns.

Tiling operates independently of the page orientation.

Setting the Page Tiling
1. Choose File>Print Layout.

2. Choose the Rows and Columns mode from the pull-down menu.
3. Enter the desired values in the Rows and Cols fields. The drawing size fields adjust 

accordingly.
4. Specify the overlap for the tiled pages. The units are determined by the preferences 

setting.

Scale
This section specifies the scale of the drawing. Select a 
standard scale from the pull-down list or set the scale in 
the data field.

Scale Options
The pull-down list provides these scaling options: User Defined, 5:1, 4:1, 3:1, 2:1, 1:1, 
1:2, 1:3, 1:4 and 1:5.
Choosing one of the standard scales enters a value in the data field. A 5:1 scale, enters 
5.0 in the field. A 1:5 scale enters a 0.20 in the field.
To specify your own scale, enter the value in the data field. The scale name changes to 
User Defined, regardless of the scale entered.

If the exact drawing size is unimportant, just specify a number 
of columns. Since the number of columns is synchronized with 
the Width, entering a different value changes the width of the 
drawing.

Overlap When tiling, specify a page overlap (between 0 and .75 inch or 
20 mm). The overlap determines how much of the geometry 
repeats on the right and top area of each tile page. The overlap 
region is used to align the tiles when joining the pages.
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The drawing scales displayed in the pull-down list are contained in the DrawSize.ini file 
in the Environ folder within the program folder. This file can be edited, but keep in mind 
it may change or be overwritten by future installations (updates) to the program. Before 
editing the file, save the original version under another name in order to have a copy in 
case it is necessary to return to the default scales.

Setting the Scale
1. Choose File>Print Layout.

2. Display the pull-down list for the scale.
3. Select the desired scale. The scale appears in the edit field.

If the User Defined scale option is selected, enter the scale in the data field.
The left graphic below shows the Preview window of a rectangle at a scale of 2:1. The 
right graphic shows the Preview window of an rectangle at a scale of 1:2.

Scaling does not change the actual dimensions of the part. Verify this by selecting an 
object and choosing Window>Edit Objects.

Preview Section
To assist in choosing the correct format size for the drawing, the program includes the 
Preview section containing the Preview window and two check boxes, Overlay Drawing 
and Print Selected. 

Preview Window
A preview of the drawing appears in this section of 
the Drawing Size dialog box.
The outer drawing frame represents the physical 
page size. The inner drawing frame represents the 
printable page area. The page settings are 
obtained from the current printer settings. If the 
drawing size is changed, the Preview window still 
displays the last drawing size selected until Apply 
is clicked.
Only objects or part of objects that lie within the 
page bounds are printed.
The Preview window displays a rectangle, 
representing the drawing or the actual geometry. 
This display is determined by the Overlay Drawing setting. See the next section for more 
details.
The Axis displays in the Preview window only if it's displayed in the drawing area. The 
Axis does not print.

Overlay Drawing
This check box determines how the geometry appears in the Preview window. When the 
box is not checked, a red rectangle displays, representing the drawing area used by the 
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objects (the graphic on the left below). When the box is checked, the actual geometry 
displays (the right graphic).

Print Selected
This check box specifies which objects within the 
drawing bounds get printed. When the check box is 
empty, all geometry within the page bounds print. When 
the box is checked, only selected geometry within the 
page bounds prints and the view window zooms in on 
that area. In the graphic here, only the square prints.
In the graphic, all of the geometry displays. If the 
Overlay Drawing check box is deactivated, only the 
selected rectangle displays in the Preview window.
This check box only becomes available when geometry 
is selected.

Preview Section Example
An example of using the option in this area might clarify how the Preview window and 
check boxes interrelate.
1. Draw some geometry.

2. Choose File>Print Layout. The Drawing Size dialog 
box displays. The Preview window shows a red rectan-
gle representing the object area.

3. Check the Overlay Drawing box to display the actual 
geometry.

4. Click OK in the dialog box to close it.
5. Select an object within the page bounds.
6. Choose File>Print Layout to display the dialog box 

again.
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7. Check the Print Selected box. The Preview window 
zooms in on selected object.

8. Click the Overlay Drawing check box to remove the 
check mark. Only the selected geometry displays.

Utility Controls
The Drawing Size dialog box contains utility controls for setting up the drawing. These 
include the Show Page Breaks in Drawing Window check box, the Fit to Scale button 
and the Fit to Area button.

Show Page Breaks in Drawing Window
This check box specifies whether to display the page breaks/boundaries in the drawing 
area. When this box is checked, the page bounds display.

When OK is clicked and the dialog box is closed, the page boundaries can be 
moved. Place the cursor over the marker at the lower left corner of the page 
boundaries. The cursor becomes the move symbol (shown to the right). Drag the 
page boundaries to the new location. See the Moving the Print Boundaries section at 
the end of this chapter for more information.
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Fit to Scale
Clicking this button uses the current scale value and automatically changes the height, 
width and page boundaries to fit the geometry.

This button only displays with the Advanced mode.

Fit to Area
Clicking this button automatically computes the scale and page boundaries to fit the 
geometry to the entire tiled plot's printable area.

For a single page to print, set both Rows and Cols to 1 and press the Fit to Area button.
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Drawing Size and Short Cut Key
A new short cut key, Single Page, is in the Drawing Size category in the Short Cut 
Manager.

Using this key automatically chooses the Single Page mode, activates the Fit to Area 
function and Shows Page Breaks. This short cut may be assigned to any key.

Printing a Drawing
After setting up the page it is ready to be printed. Choose File>Print Setup (Windows) 
or File>Page Setup (Macintosh).

Print Setup (Windows); Page Setup (Macintosh)
Choosing this command in the File menu displays the printer setup window.

Choose the necessary settings for paper size and page orientation to agree with the 
settings in the Drawing Size dialog box. Click OK to save settings. See the printer 
manual for information about setting the printer options.
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Print Command
CTRL+P (Windows); +P (Macintosh)
This command in the File menu prints or plots the current document as specified in the 
Drawing Size dialog box.
The area printed or plotted is the portion that fits on the page size specified in the 
Drawing Size dialog box. Choose File>Print Layout to scale the drawing to the 
appropriate size and reposition the print/plot region.
It is possible to specify tiling (printing on several pages to be pasted together) by 
choosing File>Print Layout>Advanced. 

Print to a File
It is also possible to print to a file rather than to a plotter or printer. This way, a plotter 
does not need to be attached to the computer. Someone else can plot the drawing 
without having Cobalt, Xenon or Argon on the plotter’s computer. The type of plotter 
chosen when setting up the page determines the format of the plot file.
If a PostScript printer is chosen, the file format is Encapsulated PostScript. Use the 
HPGL language when selecting Hewlett Packard plotters. The computer that finally plots 
the file must have an application compatible with the file format of the printer or plotter.

Plotter Font
When using a plotter, specify the Plotter font for the text and dimensions on the drawing. 
It is also possible to generate special characters and accents as described in “Appendix 
B: Special Characters” on page 1.

Printing/Plotting Region
When File>Print is chosen, only the geometry within the page boundaries prints. View 
those boundaries by choosing File>Print Layout. If the printer does not support the 
size, gray boundary lines are displayed in the window, representing the boundaries and 
the tiling feature activates. For all printers and plotters, the plotting region is smaller than 
the actual page size because most printers and plotters cannot plot to the edge of the 
paper, allowing room for the margins.

The size of this region is based on the paper size and the printer or plotter driver 
currently selected.

Moving the Print Boundaries
If the geometry is not contained within the page boundaries the page boundaries can be 
moved. 
1. Choose File>Print Layout.

2. Select the Show Page Breaks in Drawing Window check box.
3. Click OK. The dialog box closes and the page boundaries are displayed in the draw-

ing.

Paper Size

Printing/Plotting Region

Vellum displays the Printing/Plotting region
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4. Place the cursor over the 
marker at the lower left cor-
ner. It becomes the Move 
symbol.

5. Drag the boundaries to the 
new location.

Printing and Rendering
Cobalt, Xenon and Argon print both wireframe and rendered geometry. To print rendered 
geometry, set the Static Render option in the Render Options dialog box to the desired 
mode.
If the printer supports color, Static Render must be set to Flat or Gouraud.

Print Window
The Print Window command in the File menu copies 
the image within the drawing screen and sends it to 
the printer.
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Dimensionally Constrained 
Parametrics  

Cobalt supports 2D profile dimensionally constrained parametrics. This feature provides 
a mechanism for dimensioning entities to define distances and angles in order to 
establish geometric constraints between curves.
To access the Constraint tools and enter a 2D sketch mode go to the Window menu 
and choose Constraints.

Sketch Mode
To enter the 2D sketch mode to use dimensionally constrained parametrics, first 
choose the Sketch tool.
Clicking on this tool expands the tool palette, showing the tools available while in 
sketch mode.

By entering the sketch mode, the application knows to adjust the user interface in such 
a manner that creating 2D sketches is intuitive. The sketch mode does the following 
automatically when creating a new sketch or modifying an existing sketch:
1. Hides tool palettes such as surface and solid modeling which have no meaning in 

the 2D sketch environment.

2. Adjusts the Drafting Assistant to always snap into the sketch plane and see only 
snaps in the sketch plane. This is accomplished by turning on the "Work Plane" and 
"Plane Only" options in the Snaps dialog box.

3. Turns on Auto Constraints. Auto Constraints will automatically create geometric 
relationships (coincident, tangent, concentric, perpendicular) as geometry is created 
and modified. It can be turned off in sketch mode through the popup menu activated 
with a right mouse click (Windows) or CTRL + mouse click (Macintosh).

4. Creates a set of layers for the sketch that includes the container layer, "Sketch 1" 
and sub layers that include construction, profile, constraints, and dimensions. Note 
the geometry in the construction layer is ignored if the sketch is used in profile-
based operations such as skinning, sweeping, lathing, or extruding. 

5. Turn on Dimming. This feature is useful when working on faces of solids where 
edges not in the sketch plane are dimmed.  In addition, if a sketch on the face of a 
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solid is modified, the part is rolled back to the point where the sketch was originally 
created.

Reference Edges
When in sketch mode, edges of geometry that are not on the sketch plane can be 
projected onto the plane. In sketch mode, simply select the Explode Edge tool:

Then click on the surface or solid edge to project onto the sketch plane, and the 
exploded curve will appear on the sketch plane in the Fixed Constraint color. This color 
means that the object is associatively tied to another piece of geometry.  Keep in mind 
that if the original geometry is moved, the exploded curve will move as well.

Projecting a Curve into a Sketch
This is similar to exploding the edge of a surface or solid and projecting it onto the 
sketch plane, except that it will work for wireframe geometry. The procedure is the same 
as for Reference Edges. When in sketch mode, simply select the Explode Edge tool 
and choose the wireframe geometry to project to the sketch plane.  Once again, this 
geometry is associatively tied to the original curve, and is displayed in the Fixed 
Constraint color.

Exiting Sketch Mode
Exiting the sketch will return Cobalt to the settings before the sketch was entered. One 
other advantage of the sketch mode is that it temporarily suspends the regeneration of a 
dependent feature.  This means that while in sketch mode it is possible to perform a 
series of operations such as adding and removing curves to the sketch that would 
otherwise invalidate downstream operations. When exiting the sketch mode, however, it 
is necessary to resolve a valid profile so that dependent features can then be updated.

Sketch Mode Tools
The tools available in sketch mode are listed below.

Sketch Tool

The Sketch tool creates or modifies an existing sketch.

Auto Constraints Tool

The Auto Constraint tool automatically applies constraints to curves and dimensions 
selected by the user.
This tool is particularly useful when working with data created outside the sketch tool. 
The Auto Constraints tool will add the following constraints to the selected geometry: 
Horizontal, Vertical, Tangent, Concentric and Coincident.
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Horizontal Constraint Tool

This tool adds a horizontal constraint to a line. Select one or more curves to apply a 
horizontal constraint. Horizontal is defined by the work plane x-axis. The two chosen 
points will have the same x value when completed.
Pick the tool. The Message Line reads: Horizontal Constraint: Pick line for horizontal 
constraint [Ctrl = Share X position (Windows) or Option = Share X position (Macintosh)] 
[Shift = Extend]. 
When applying a horizontal constraint, pressing the CTRL key (Windows) or OPTION 
key (Mac) aligns the geometry horizontally to a specific point on another line. The two 
chosen points will have the same x value.

Vertical Constraint Tool

This tool adds a vertical constraint to a line. 
Select one or more curves to apply a vertical constraint. Vertical is defined by the work 
plane y-axis.
Pick the tool. The Message Line reads: Vertical Constraint: Pick line for vertical constraint 
[Ctrl = Share Y position (Windows) or Option = Share Y position (Macintosh)] [Shift = 
Extend]

When applying a vertical constraint, pressing the CTRL key (Windows) or OPTION key 
(Mac) aligns the geometry vertically to a specific point on another line. The two chosen 
points will have the same y value when completed.

Coincident Constraint Tool

This tool adds a coincident constraint between two object positions.   
Objects that are recognized for coincident constraints include lines, arcs, circles, 
ellipses, splines, points, and edges of solids. The point of coincidence to the object is 
automatically determined by use of the Drafting Assistant. 
Referencing end points, midpoints, vertex, centers, and point on are preserved.   In the 
case of point on (point along curve) the coincidence constraint may be anywhere along 
the curve. All others are fixed to specific locations. The floating coincident constraint is 
represented by a small triangle symbol and a fixed constraint is shown as a small 
rectangle about the two shared points.
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Some examples of coincident constraints:

The Coincident Constraint tool provides several methods for attaching relationships.  
The first method is to follow the Message Line prompts:
1. Pick the first curve for coincident constraint. 

2. Pick the position along the first curve using the Drafting Assistant.
3. Pick the second curve for the coincident constraint.
4. Pick the position along the second curve using the Drafting Assistant.
The second method for creating coincident constraints is to draw a selection box around 
two or more curves at the first prompt.  In this case all curve end points that lie within 
0.001 inches will be applied a coincident constraint.

In addition, the Coincident Constraint tool allows for pre-selections.  If any curves are 
pre-selected before clicking the tool palette icon, coincident relations are automatically 
applied to the selected objects.
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Tangent Constraint Tool
This tool creates a tangent constraint between two or more curves. 

To use the Tangent Constraint tool simply select the curves to apply a tangent 
constraint. When selecting more than two curves, the tangent constraint tool only 
applies a constraint between curves that are already tangent within 1 degree.  This 
constraint draws a circle to represent the existence of a tangent constraint.

Parallel Constraint Tool
The Parallel Constraint tool adds a parallel constraint between two lines.
Only lines can be used in this tool; arcs, circles, ellipses, splines are ignored.  
The constraint symbology is two small parallel lines.

Note: The solver determines which line to move based on a set of rules involving the 
curve type, other curve relations and minimization of geometry movement.  Therefore 
the order in which the curves are picked is irrelevant as to which curve is actually 
moved.

 Perpendicular Constraint Tool
The Perpendicular Constraint tool creates a 90° angle between a line and 
another curve. 
In the example below a coincident constraint is needed to attach the line to the 

circle.  As in other constraints the entity that moves is independent of selection order.
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Fixed Constraint Tool

The Fixed Constraint tool locks the entity from being moved by the constraint solver.
It is possible to move the entity with the Move or Transform tools. A fixed object uses 
the fixed display color which is by default gray and whose symbol consists of a 
collection of slanted lines.

Note: Attempting to dimension a fixed entity will result in the display of the dimension 
error dialog box.

This error message implies that the position, direction, and length are fixed due to the fix 
constraint previously applied.

Concentric Constraint Tool

The Concentric Constraint tool creates a constraint that forces circles to share the 
same center point. 

This concentric tool recognizes circles and points as valid selectable entities.
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Symmetric Constraint Tool

This tool creates a symmetric constraint between entities of asimilar type and symmetry 
line.

Note:  Use the mirror tool in the transformation tool palette while in the sketch mode to 
automaticaly apply mirror constraints at the time the mirror operation is performed.

Equal Constraint Tool 

The Equal Constraint tool applies an equal distant or radius constraint between two 
entities.

This tool works only with lines or circles.  When selecting two lines, the lengths are 
forced to be the same for the two entities.  In the case of circles, the same radius value 
is applied between the selected circles.  As with many constraints, this operation is 
independent of which curve is selected first due to the method in which the solver finds 
solutions.

Colinear Constraint Tool

The Colinear Constraint makes two lines colinear.

Colinear implies that the two resulting lines have the same direction and lie within the 
same line. It does not imply anything regarding their lengths.
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Offset Constraint Tool

This tool adds an offset constraint between two lines or two circles.

The offset distance is specified through the status line. In addition, use the edit objects 
dialog to change an existing offset value. Click on the constraint symbol to display this 
edit page.

Dimension-driven Geometry

Dimensions created in the sketch mode are by default driving dimensions. This means 
that changing the dimensional value will force curves associated with the dimension to 
be updated to the new dimensional value. A dimension that is driven by the curve is 
called a reference dimension. Outside of the sketch mode, dimensions created are 
reference dimensions. To change a dimension from dimension-driving to dimension-
driven, right click over the dimension. 

Constraint Animation Tool

The Animation tool will animate a sketch by modifying a dimension value through a 
range of values. To use the tool, select a dimension that was used within a sketch and 
then choose the Constraint Animation tool.
This tool is always visible in Constraint palette and can be accessed either within 
sketch mode or from outside. See the next section on Dimensionally Constrained 
Animation Controller for more details on this tool.
Note:  If a sketch is animated while in sketch mode, only the sketch is updated.  If a 
sketch is animated outside of the sketch mode, dependent surfaces and solids update 
accordingly.

Dimensional Constraint Animation Controller
Dimensional Constraint Animation Settings
The Dimensional Constraint Animations Settings dialog box is used to control the 
behavior of a sketch dimension animation. The available animation settings are Start, 
End, Steps, Delay, Loop, and Rebound.
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The dialog contains the following options:

Running the Animation
Once the settings are made, select the dimension to animate. The animation will start 
automatically. Control the execution of the animation using the VCR style buttons in the 
dialog box.

Deleting Constraints
To delete any constraint, simply select the constraint symbol and press the DELETE key 
or use Cut from the Edit menu.

Verifying Constraint Relations
To confirm the entities used in a constraint relationship, simply move the cursor over the 
constraint symbol and pause for several seconds.  After several seconds the entities 
involved in the constraint relationship will highlight in red.

Constraint Preferences
The 
Preferences 
dialog box 
under the File 
menu contains 
a category for 
DCM 
(Dimension 
and Constraint 
Management). 
The DCM 
Preference 
Settings 
includes 
options for 
setting:

Start  Specifies the starting dimension value.

End  Specifies the ending dimension value.

Steps Controls the number of intermediate steps to use when 
transitioning from the dimension start value to the end value. 
For example, if start is 1.0, end is 4.0, and the steps are 6, the 
dimension will animate with the values of 1.0, 1.5, 2.0, 2.5, 3.0, 
3.5, and 4.0. The delta value is computed by:  

(End - Start) / Steps.

Delay Controls the number of seconds to wait between sketch 
dimension animation “frames.”

Loop If checked, the animation will continue to play indefinitely until 
stopped.

Rebound If checked, the dimension value will transit from start to end in 
the specified number of steps, and then continue by 
“rebounding” from End to Start in the same number of steps.
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Note: Avoid using the select color as a constraint color to minimize confusion between a 
constraint color and when an entity is selected.

Exiting Sketch Mode
Once a sketch is created and constrained, to exit Sketch Mode simply click the blue Exit 
icon in the lower right-hand corner of the drawing window:

Over-Defined 
Constraint Color

Any entity in a sketch that has too many constraints or creates 
an ambiguity for the solver will display in the Over-defined 
Constraint color.  It is best to resolve any over-defined sketch 
entities before exiting a sketch.

Under-Defined 
Constraint Color

Entities that still have degrees of freedom remaining are 
displayed in the under-defined constraint color.

Fully Defined 
Constraint Color

Any entity whose position and size is fully defined is displayed 
in the fully defined constraint color.

Fixed Constraint 
Color

Entities that have a fixed constraint associated with their 
definition are displayed in this color. 

Show Constraint 
Layer

When the Show Constraint Layer check box is enabled, new 
sketches will automatically turn on the sketch layer.  
Sometimes complex sketches get visually complicated when 
all the constraint symbology is displayed.
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Variables and Equations 
Cobalt supports assigning variables and equations to dimensions 
applied while in the constraints sketch mode. Having geometry that has 
been constrained using equations is an easy way to manipulate the 
geometry, see the examples below.

Using Equations & Variables
Once the parametrically constrained part is completed, edit the dimensions applied to 
the part. This can be done using the equations dialog box or through the Edit Objects 
box. Both methods are described below. To edit dimensions or change the names in 
either dialog box, or through the Edit Objects box. Both methods are described below. 
To edit dimensions or change the names in either dialog box, click on the field and type 
in the new value.
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Using the Variables/Equations Dialog Box
To open the Equations dialog box go to the Window menu and choose Equations.
The Variables/Equations dialog box supports all kinds of mathematical expressions. To 
use one dimension as a reference to another be sure to use its name from the name 
field as in the previous example. For a list of mathematical operators that can be used 
see Appendix A: Mathematical Operators.

The Variables/Equations dialog contains the following options:

Highlighting Dimensions in the Sketch
Use the following steps to highlight the dimension on the screen.
1. Move the cursor to the Dimension Value field to be highlighted.

2. Click and hold down the mouse button.
3. The dimension highlights.

All Sketches This pull down menu contains the list of every sketch within the 
file.

Filter Sorts by the type of dimensions shown in the dialog box.

Name Displays the name of the dimension. 

Value Shows the current value for each dimension. 

Equation Displays the mathematical expression that will define the 
dimension.
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Using the Edit Objects Box for Variables & Equations
Variables and equations can be referenced within Cobalt in the Edit Object box and in 
the Status Line. 

Defining Equations
Using mathematical expression or operators, change or resolve the size of the part.
1. Click in the equation field of the dimension to be changed.

2. Add a mathematical expression, such as D1*2/3.
3. Click Apply for the changes to take place.

Note: The Undo command (CTRL+Z (Windows) or COMMAND + Z (Macintosh)) cannot 
be used for expressions applied in the equations dialog box. Repeat the steps above to 
change the dimension.

Nested Equations
Equations can reference other equations within Cobalt for more robust equation-driven 
parametrics. The results of one equation can be used in other equations.
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Conditional Equations
Cobalt’s parametrics contain equations for more complex and intelligent geometric 
constraints. This enables adding if-then-else statements to the parametric constraints 
bounding the upper and lower limits of geometry.
For example, a sketch has the dimensions: D2+D1x3. 
If the maximum constraint of these dimensions is 20 and the minimum constraint is 1, 
then a conditional equation could be written: 

If (D1x3>=20;20; If (D1x3<=1;1;D1x3)) 
This bounds the dimension at 1 and 20.

Syntax
Conditional equations include:

IF (condition; exp1; exp2)
This means that if [condition] is true (is not equal to zero) then expression exp1 will be 
used, else exp2.

Logical Operations
Logical operations include AND, OR, NOT, <, >, <=, >=, and =. 
Results of logical operations are 1.0 or 0.0.

Priority of Operations
1.( ) 
2.NOT, unary +, unary -
3.^ (power)
4.*, /, %
5.+, -
6.<, >, <=, >=
7.=
8.AND
9.OR
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Preference Settings
All designers develop a particular style when creating their models and parts. This style 
includes specific standards that unify their work and may include such things as 
measurement units, line color, drawing layout, shortcut keys and more. It also unifies 
work within companies and industries. Preferences set in the Preferences dialog box 
relating to object display and creation affect only the entities created after the 
preferences are set.

Default versus Selected Object Settings
When no object is selected, any setting changes made to Selectable Points, Grid, Axis, 
Triad, Show Points, Construction Lines, User-defined plane, Pen, Text, Dimension, tool 
palettes and Render become the default for all open files and the current Designer 
Elements program session. When an object is selected, any change made will only 
affect the object.
This chapter covers the following topics:
• Preferences
• 3Dconnexion SpaceMouse Information
• Pen and Dimension Preferences
• Shortcuts
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Preferences
Cobalt, Xenon and Argon all save preferences for a particular session. The programs, 
however, do not support saving preferences with a specific file.
When more than one file is open during a particular program session, menu settings like 
pen pattern, Hide/Show Axis and the status and location of palettes are the same for all 
open files. Commands dealing with the view orientation and work plane are file specific.

To save preferences, choose File>Preferences to display the dialog box. Preferences 
are saved in prefs.ini.
The Preferences dialog box contains a Category list of Preference groups, the Settings 
section and a series of operation buttons. The buttons include:

The Category list includes:
• Colors
• Dimensional Constraint Manager (DCM) (Cobalt Only)
• Display
•
• File Associations
• Filing
• General
• Grid
• Localization
• Drag/Move

OK Saves preference settings specified in this session and closes 
the Preferences dialog box.

Cancel Closes the dialog box without saving all changes.

Apply Applies the change instantly and leaves the dialog box upon 
for further selections.

Revert Page Undoes changes made to the current preference group.

Revert All Undoes changes made to any preference group.

Factory Resets the program to the actual factory defaults for all 
Preferences, not just the current Preference pane.
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• Paths
• Select
• Skins
• SpaceMouse
• Units
Selecting an item from the Category list displays its preference options in the Settings 
section.

Colors
Choosing the Color category displays the Color preferences page. This page controls 
the foreground and background color of the drawing area. The current (or proposed) 
settings are indicated by the color rectangle, color name and the Preview section. Press 
the appropriate New button to display the color selection dialog box and change the 
color.

Background
This sets the background color for the drawing area. The current colors are displayed in 
the window. The standard color names or the color values display to the right of the view 
window. To change the background: 
1. Click New. The color palette is displayed.

2. Choose the background colors.
3. For a solid color background uncheck the Gradient box.
4. To use an image as a background, check the Image box and select the desired one 

from the drop down list or browse to select it from the system. Click OK. 

Foreground
This option sets the foreground color for the drawing area (specifically the location 
indicator and the indicator separator lines). The current color is displayed in the window. 
The standard color names or the color values display to the right of the view window. To 
change the foreground: 
1. Click New. The color palette is displayed.

2. Choose the foreground color.
3. Click OK. The new foreground displays in the view window with the color name. 
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Preview
The Preview window displays the background and foreground choices.

Dimensional Constraint Manager (DCM) (Cobalt Only)
This option controls how the Dimensional Constraints Manager gives feed back to the 
user.

Over-defined Constraint Color
Set this field to the desired color for over-defined constraints.

Under-defined Constraint Color
Set the field to the desired color for under-defined constraints.

Fully-defined Constraint Color
Set this field to the desired color for a sketch that is fully defined.

Fixed Constraint Color
Set this field to the desired color for fixed constraints.

Show Constraint Layer
This check box tells the program whether or not to show constraints as they are being 
applied. If the box is not checked, constraints will be visible on the active work layer 
even though the constraints are being applied.
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Display
This option controls the individual default display parameters for curve, surface and 
solid object types.

Object Type
This sets the appearance of curves, surfaces and 
solids. Each object type offers different display 
options.

Display
Choose an option for each object type (curve, surface and solid). Display options vary 
according to the object type and may include: Resolution, Iso Lines, Silhouette and 
Edge Color.

Resolution (Available for all object types.) Controls how accurately an 
object’s curves appear. It is possible to set the curve resolution 
to Coarse, Medium, Fine, Very Fine and Super Fine. An object 
with a Coarse resolution draws quickly but may be visually less 
appealing. An object with a Fine resolution draws more slowly 
but may be visually more appealing.

Iso Lines (Available for Surface and Solid object types.) Iso (isopram) 
Lines control the number of U and V lines displayed for a 
surface or solid object. Iso Lines are constant parameter 
curves that lie on an object. U and V are letters used to define 
these lines (and their coordinates) in parameter space where U 
is for horizontal and V is for vertical. These are standard for the 
industry. A zero (0) in both fields turns off Iso Lines. U/V values 
may enhance the visual appearance of a surface or solid at the 
expense of drawing speed.
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Tech Note: Parameter space is where objects are defined in a 2D
coordinate system. Typically, a surface is mathematically defined in
parameter space. Each surface has a mathematical function that maps 2D
parameter space into 3D model space. A U/V coordinate of U=0.5 and
V=0.25 in parameter space maps to X=100, Y=300, Z=255 in 3D model
space.

The left graphic below shows a surface with both U and V Iso 
lines set to five (5).

Silhouette (Available for Surface and Solid object types.) This controls the 
silhouette edge draw mode. There are three options: Off, On 
and Smart. Silhouette edges are view-dependent and can 
cause a significant reduction in drawing speed. If the Smart 
mode is selected, silhouettes will be dynamically drawn based 
on performance considerations.

Edge Color (Available for Surface and Solid object types.) This option sets 
the edge color of rendered mesh objects separate from the 
entity itself.

Select one of four options from the pull-down menu, 
Foreground, Background, Entity and User Defined. To specify 
a User Defined color, click on New, choose a color in the 
palette and click OK. The new color is displayed in the Edge 
Color window with its RGB values.
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Drafting Assistant
This category controls the low level snapping behavior of the Drafting Assistant. The 
settings include the Hit Radius, Alignment Angles, Creation Angles and % Point.

Hit Radius Determines the detection distance in pixels. When the pointer 
is within the specified Hit Radius, the Drafting Assistant 
notations display and the object is selected when the mouse is 
clicked.

Alignment Angles Define angles for the Drafting Assistant's dynamic construction 
lines. Change the specifications to change the orientation of 
the drawing. For example, in a 2D drawing, these angles can 
be set to 30°, 90° and 15° for isometric drawing. The defaults 
are 0° (horizontal) and 90° (vertical). Separate values by 
semicolons.

To automatically display a dynamic construction line through a 
point, move the pointer to the point to activate it. (A diamond 
appears.) Up to eight points are active. When the ninth point is 
activated, the first one deactivates.

Creation Angles These define angles for the Drafting Assistant’s dynamic 
construction lines, displayed while creating geometry. (These 
lines are not part of the list of lines generated from the eight 
active points.) The defaults are +45° and -45°. Separate values 
by semicolons.

% Point Controls the Drafting Assistant's notations for divisions of a 
curve. For example, entering 25 instructs the Drafting Assistant 
to indicate when the pointer is 25% of the distance along a line.
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Drag/Move
CTRL+Drag or OPTION+Drag
This dialogue box controls what happens when selecting a part and copying it by 
dragging while holding the CTRL key on Windows or the OPTION key on Mac.
In the Object Type pul-down it is possible to designate different behaviors for both 
surfaces and solids. 

 

Distance Detection
Check this to display a notice if an object is being moved more than the range specified.

Create ACIS Entity 
Copies

This creates copies of the original without any history.

Creates Instances of 
the Original

These share the original part's history. Any changes made to 
the original, flow through to the instance part.
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File Associations
(Windows only.) This re-establishes the association between this application and these 
file types.

Filing
This category controls the filing behavior of your Designer Elements program. Settings 
include Save Native Picture Formats Only, Compact Files, Read-only Network File 
Sharing, Recent Files and Auto Save.

Save Native Picture Formats Only
Activating this option disables multiple platform picture support. Saving only the native 
format will reduce file size.
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Clear Undo on Save
Activating this option flushes the undo stack after a file has been saved. If the box is not 
checked, the undo stack is maintained after saving, increasing the file size.

Compact Files
If this option is checked, files compact when saved. Display facets are not written out 
when this option is selected. This file size reduction is especially noticeable on files 
containing solid models with many creation parts.

Read-only Network File Sharing
If this option is checked, the file can only be edited by the current user. No one else will 
be able to edit the file until the first person closes the file.

ACIS Check on Open
Check this for the application to check every entity containing ACIS data upon opening. 
If errors, such as unresolved links, are found, the program attempts to fix them, taking 
longer to open. For faster open times, uncheck this box and forgo the ACIS data checks.

Recent Files
This option sets the number of recent files that display in the File menu. Selecting a file 
from the menu immediately opens the file and bypasses the Open File dialog box.

Auto Save
Checking this box enables the automatic file saving 
options and directs the Designer Elements program 
to save a backup of your work periodically. If this 
box is not checked, automatic file saving does not 
occur. 
If auto save is triggered, a backup file is created in the Backup folder within the program 
folder. Backup files are numbered sequentially. If the file is not yet saved, the backup will 
be named untitled.
If auto save is on but no geometry has been modified in the drawing since the period 
that the last auto save operation occurred, auto save does not activate.
There are three auto save options:

Maximum Menu 
Items

The drop down list specifies 0 to 20 file names. The default 
number is five.

Show Full Paths in 
Menu

Checking this box displays the full path along with the recently 
used file name in the File menu.

Save after “N” 
Commands

Entering a value in this field specifies the number of drawing 
modifications (creations, edits or deletions) that occur before 
an auto save triggers.

Save after “M” 
Minutes

Entering a value in this field specifies the number of minutes 
that must pass after the first drawing modification before an 
auto save triggers.

Using a Max of Temp 
Files

Entering a value in this field specifies the number of backup 
files to be created before reusing a backup file name. A large 
value will consume more disk space. The default value is five.
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General
This category controls the general user interface behavior, view definitions and arrow 
nudge distance.

User Interface
This section provides the following check boxes for choosing interface options:

Enable Tool Tips Enables the floating tool tip help windows.

Enable Shortcut Keys Enables setting the keyboard short cut keys through 
File>Shortcuts.

Enable Tool Cursors Enables the display of tool-specific icons when using the tool. 
Without this enabled, the cursor appears as crosshairs when 
moved into the drawing area.

Enable Auto Resolve Enables the automatic regeneration of child objects when 
parent objects are modified (Cobalt and Xenon only).

Save Dialog 
Positions

Saves the location of dialog boxes. The next time the dialog 
box displays, it is positioned at its most recent location.

Show Axis at Startup Shows the coordinate axis when the program launches.

Show Triad at Startup Shows the coordinate triad when the program launches.

Save Tool’s Last 
Options

For the tools with multiple options, the last option chosen 
saves as the default.

Save Palette 
Positions

Saves the tool palette positions and displays its status when 
exiting. The next time the program launches, the palettes 
display in their previous positions. 

Save Now Immediately saves tool palette positions, pen color, fill color, 
dialog box locations and display status.

Restore Palettes Returns all palettes back to their factory default position. If 
palettes are out of the drawing area, use Windows>Organize 
Palettes to show them in the drawing area.
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View Definitions
Cobalt, Xenon and Argon all support two different common view definitions, Default and 
Aerospace. Select the Default option to use view definitions commonly used for 
mechanical drafting. Select the Aerospace option to use view definitions commonly 
used for aerospace lofting.

Arrow Key Nudge Distance
The Arrow Key Nudge distance specifies how far the drawing will scroll when a 
keyboard arrow key is pressed in the Selection tool. The units for this option are based 
on the units chosen on the Units page of this dialog box.

Grid
This category controls the grid display and snapping behavior. The options include grid 
spacing, appearance, startup preference and color. 

Spacing
The dX and dY values set the grid spacing. Units are based on those set on the Units 
page of the dialog box.

Sub-spacing
X Divs and Y Divs specify the number divisions for the grid to which geometry snaps in 
the drawing when the Snap to Grid command is activated.

Display As
The grid can be displayed as either dots or lines. Check either the Grid Dots or Grid 
Lines option.
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Grid Size
Enter a value in these fields to set the grid size. The values represent the number of grid 
sections that appear in the positive and negative X and Y directions. A value of three 
entered into each field results in six grid sections in the X direction and six grid sections 
in the Y direction. The graphic here is an example of this.

The grid also follows the current work plane the created in any plane. For example, by 
changing the plane from the Top plane to a user-defined plane, the grid displays as it did 
in the Top plane.

Display Grid at Startup
Check this box to display the grid at startup of this Designer Elements program.

Snap to Grid at Startup
Check this box to activate the snapping function at program startup.

Grid Color
Select any color for the grid. The current color displays in the window. 
1. Click New to display the color palette.

2. Select a color from the palette.
3. Click OK to accept the color and return to the Grid page. The new color now dis-

plays in the grid view window with the color name. For colors other than the stan-
dard colors, the color values display to the right of the view window.
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Localization
This category controls the use of language and decimals versus commas in this 
Designer Elements program.

Use Commas as Decimal
Checking the Use Comma as Decimal option allows international users to display 
numbers according to their numerical standards.

Language
The drop down menu provides the list of languages to choose. There is an Auto 
command which chooses the language of the preferences of your computer.

Mouse
Invert Zoom of your mouse by checking the InvertZoom option on this page of the 
Preferences Dialogue box.

Paths
This page is used mostly by system administrators and Ashlar-Vellum tech support 
specialists. 
It is useful for workgroups to set up a custom network folder for the PhotoRender, BOM 
and Layout libraries. 
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It is also a useful tool for allowing others in the group to have access to common data. 
For example, if a user creates a new material or adds a texture, this can be exported to 
the Custom Network Folder for use by others without copying it to each local machine. 

Tech Note: Write-permission is required for destination directories.

The Application Installation Folder, Default Network Folder (if used by default by the 
operating system), All Users Folder, and Current User Folder show the automatically 
generated paths. Custom Network Folder is created by the system administrator and 
can be used by all the users of the local network.

Select

This category controls object selection behavior, including Pick Box Size, Ambiguity 
Popup, Selection Color and the Selection Fence mode.
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Pick Box Size
When an object is selected, place the cursor on the object and click the mouse. The 
Pick Box is the area around the cursor in which an object must be located to be 
selected. To specify the area use the pull-down menu (ranges from 2 through 16, even 
numbers only). The Pick Box does not display.

Ambiguity Popup 
The Ambiguity Popup displays when there are multiple objects near the vicinity of the 
selection and offers choices of which object to choose.
A check mark in the box enables the popup. This is the default setting.

Selected Entities Color
This option sets the selection color. The current color displays in the window. To change 
the color:
1. Click New to display the color palette.

2. Select a color from the palette.
3. Click OK to accept the color and be returned to the Select page. The new color now 

displays in the view window with the color name. For colors other than the standard 
colors, the color values display to the right of the view window.

Wire Weight
Select a curve and the line weight of that curve is increased according to the setting in 
the drop down box. The weight is specified in pixels. Choose between zero, which does 
not increase the weight when selected, and four, which increases the selected line 
weight by four pixels.

Transparency
Select a surface or solid object and the surface or solid becomes transparent. The 
Transparency slider controls how transparent the object becomes. A value of zero 
means no transparency is added to the selected object. A value of 100 means the 
selected object becomes fully transparent, showing only the edges.

Selected Points
When a point is selected the entire curve will highlight, however, the edits will only affect 
the selected point.

Select Fence Mode
The program supports two modes when dragging to select one or more objects, Entire 
Object Extents or Partial Object Extents. Selecting the Entire Object Extents option 
allows only the selection of objects that fall completely within the selection fence. 
Selecting the Partial Object Extents option allows the selection of any object that has a 
portion within the selection fence.
Note: Be aware that control points will affect what is selected when using the Partial 
Objects Extents option. For example, with this option selected, if the selection fence 
covers a control point for a circle, only the center point is selected rather than the entire 
circle.
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Skins 
Choose the look of the user interface using the Skins page of the Preference settings.

SpaceMouse
The SpaceMouse Preferences control the interaction for all 3Dconnexion motion control 
devices including the SpaceMouse, SpacePilot, SpaceBall and Space Traveler. The 
intuitive reaction of individual users to the controller's operation varies widely, so 
optional settings are provided.

Color Skin Select the color theme desired.

Icons Select the icon style. The default is Modern.

Pressing Effect Check this box for the selected icon to appear as a pressed 
button.

Enable SpaceMouse Check this box to enable interaction between Ashlar-Vellum 
programs and the SpaceMouse.
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3Dconnexion SpaceMouse Information

Working with the Motion Controller in 3D Applications

Invert Rotation Check this box to invert the SpaceMouse rotation vector, 
altering the default rotation behavior of the scene with respect 
to the SpaceMouse motion controller. 

Invert Zoom Check here to invert the SpaceMouse zoom vector, changing 
the behavior of the motion controller with respect to the scene.

Invert X Pan When set, the behavior of the SpaceMouse X motion 
component vector is inverted with respect to the scene.

Invert Y Pan When checked, the behavior of the SpaceMouse Y motion 
component vector is inverted with respect to the scene.

Orbital Sensitivity The Orbital Sensitivity slider adjusts the sensitivity of the 
programs to the orbital input from the SpaceMouse motion 
controller. Zero disables the orbital input. Selecting a larger 
value increases sensitivity, requiring less physical motion on 
the motion controller to achieve scene changes.

Pan Sensitivity The Pan Sensitivity slider determines how sensitive the 
program is to the pan input from the SpaceMouse motion 
controller. Zero disables the pan input (X and Y). A larger value 
increases sensitivity, requiring less physical motion on the 
SpaceMouse to achieve scene changes.

Zoom Sensitivity The Zoom Sensitivity slider lets you set how sensitive the 
program is to the zoom input from the SpaceMouse motion 
controller. Zero disables the zoom input. Selecting a larger 
value increases sensitivity for physical motion of the 
SpaceMouse to achieve scene changes.

Pan Pull up and push down to move the model vertically.

Move left and right, keeping the 
controller head parallel with the work 
surface.
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Units
This category controls the units and the number of decimal points displayed for the 
geometry.

Tech Note: The decimal places entered here only affect the Status Line and
Location Indicator. They do not affect the decimal places used for
dimensions. These must be set in the Dimension menu.

Rotate Tilt the controller head left and right or 
forward and backward to rotate 
accordingly (X-Z axis).

Zoom Push forward or pull backwards 
keeping the controller head parallel 
with the work surface.

Rotate Twist clockwise and counterclockwise 
to rotate the model accordingly (Y 
axis).
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Units can be set to inches, feet, feet/inches, millimeters, centimeters and meters.

Tech Note: If feet/inches are chosen for units, it is fine to enter a
combination of feet and units in the Status Line and Edit Objects dialog box.
These values, however, will convert to decimals after they are applied to the
geometry. For example: A value of 1”3” converts to 1.25 feet.

In the Display Decimal Digits data field, enter the needed number of decimal places 
(between 1 and 8). Three decimal places is the default.

Alchemy
This page of the Preferences dialogue box allows registering your Alchemy license.

Changing the Preference Settings with the Preferences Command
1. Choose File>Preferences.

2. Select the desired category to set.
3. Make desired changes.
4. Select another category or click OK to close the dialog box.

Changing the Preference Settings Manually
1. Quit the program.

2. Open the Preferences file, prefs.ini, in a text editor. 
3. Make the desired change to the characteristics.
4. Save and close the file.

The file must be stored in the original folder.
5. Relaunch the program.
The preferences are set.
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Tech Note: The location of the prefs.ini file varies with the program, the
version, the platform and the version of the operating system. It can be
found under User, Workgroup, System (Mac only) and/or Program. For
specific information on your version try the knowledgebase in the Support
Center on the website at www.ashlar.com.

Preferences and Object Creation
When any of the preference settings are changed, the changes are only reflected for 
new objects.

Pen and Dimension Preferences
When Cobalt, Xenon or Argon are launched, the default pen, text and dimension 
characteristics can be set. Without anything selected, specify the settings. It is not 
necessary to save any file to save these preferences. Simply, exit the program and the 
pen, text and dimension settings are saved to the preferences .ini file.

Shortcuts
The Shortcuts command in the File menu creates keyboard combinations, providing 
alternative ways to invoke commands. It is possible to create shortcuts for activating 
tools and commands, setting the work plane, changing layers, switching between 
wireframe and render modes and more. If a shortcut to a tool is assigned, the short cut 
displays with the tool tip when the pointer is moved over the tool.
Shortcuts are organized by the Shortcut Manager.

The Shortcut Manager dialog box includes the following elements:

Category Contains all available operations in this Designer Elements 
program.
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The buttons in the Shortcut Manager include:

Command Displays the commands assigned to the selected operation in 
the category list.

Shortcut key Displays the key combination for the selected operation. To 
use the function keys, type F and the number (F3 for example) 
rather than pressing the function key itself.

Description Describes the action that results from the selected command.

OK Saves the new Shortcuts and closes the Shortcut Manager.

Cancel Closes the Shortcut Manager without saving any changes.

Print Prints a hard copy of the current shortcut key assignments. 
The factory default Shortcuts are included in Appendix C: 
ShortCuts.

Assigned If this box is checked, when printing the Shortcut list, only 
assigned keys are included.

Assign Key Assigns the Shortcut key combination for future use. 

If the shortcut key is already assigned, a warning box displays 
asking to confirm its reassignment.

Click Yes to accept the reassignment or No to be returned to 
the Shortcut Manager to enter another key combination.

Remove Key Removes the key combination from the selected command.

Revert Undoes any changes made to any groups.

Factory Resets all groups to the factory settings.
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Creating a New Shortcut
1. Choose File>Shortcuts.

2. Select the desired category and command in the 
appropriate sections.

3. Enter the key combination into the Shortcut key 
data field.

4. Click Assign. The key combination displays next 
to the selected command.

5. Continue entering all key combinations as 
desired.

6. Click OK to save the new shortcut keys and 
close the dialog box.
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Appendix A: Mathematical Operators
The data fields in Cobalt, Xenon and Argon accept the following mathematical 
operators:

Addition x+y

Subtraction x-y

Multiplication x*y

Division x/y

x%y - modulo division which returns the remainder of x/y. The 
resulting value will always be from 0 to y-1.

Angles are accepted in any of the following forms: 45d30m30s, 
45d30"30', 45d30', 30"30', 30m30s, 30"30s and 45°30"30

Absolute Value abs(x) - absolute value of x

Arc tangent atan (degrees)

Arc sine asin(degrees)

Arc cosine acos(degrees)

Cosine cos(degrees)

Sine sin(degrees)

Tangent tan(degrees)

Trigonometry trig functions

Smallest Larger 
Integer

ceiling(x), or ceil(x) - returns a value representing the smallest 
integer that is greater than or equal to x.

Largest Smaller 
Integer

floor(x) - returns a value representing the largest integer that is 
less than or equal to x.

Degrees to radians dtor(degrees)

Radians to degrees rtod(radians)

Factorials factorial(x), or fact(x) - factorial of x. (e.g. fact(4) = 4*3*2*1)

Logorithms log(x)

ln(x) - base 10 log of x, natural ln of x
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Exponentials exp(x) - e to the power of x where ln(exp(x)) = x.

x^y - exponentiation (x to the power of y)

Negatives neg(x) - negative of x

p pi

Round round(x) - rounds to the nearest whole value. For example, 
round(1.49) = 1.0, and round(1.51) = 2.0.

Random numbers rnd - random value between 0.0 and 1.0

Square root sqrt(x) - square root of x

Remove Fractional 
Part

truncate(x)

trunc(x) - truncates to the whole value. For example, 
trunc(1.01)= 1.0, and trunc(1.99) = 1.0.
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Appendix B: Special Characters
It is possible to use special characters and accents which are available with the 
operating system and region keyboard for the computer. Usually these characters are 
described in an appendix of the operating system's user manual. Many symbols and 
characters are from the keyboard. 

Windows:
Unlock the keypad with the NUM LOCK key and then hold down the ALT key and enter 
the numeric code for the necessary character.
The character appears in the current font (including the DE Plotter font). The following 
list includes common symbols which are available in all fonts:

Macintosh:
To access international and mathematical symbols on the Mac, activate the Keyboard 
Viewer and Character Palette under the Apple System Preferences/International. A flag 
icon appears in the menu bar. Click it for a menu with options to show and hide these 
two tools.

Tech Note: Numeric values must be entered with an enhanced 101
keyboard using the separate number pad.

In addition, the OPTION key can be used to generate international accents in the 
current font, including the Plotter font.

Accent Key Combination

° ALT 0176

ø ALT 0216

± ALT 0177

Accent Key Combination

é OPTION+e then letter to be accented

è OPTION+` then letter to be accented

ñ OPTION+n then letter to be accented

ü OPTION+u then letter to be accented
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The following list includes common symbols which are available in all fonts.

Accent Key Combination

° OPTION+ SHIFT 8

ø OPTION+ O (letter)

± OPTION+SHIFT =
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Appendix C: ShortCuts
These are the short cut keys currently programmed in this Cobalt, Xenon and Argon. 
There are many short cuts which can be programed with specific keys. Choose 
File>Short Cuts to display the Short Cut Manager. See Preference Settings for 
information on how to program the keys.

Short Cut Key Action
Layout:Dec Display { Makes the previous layer visible and turns off all 

other layers except the work layer.

Layout:Inc Display } Makes the next layer visible and turns off all other 
layers except the work layer.

Layout:Isolate Layer i Brings up the Isolate Layer dialog box for setting the 
work layer.

Line:HorzConst H Creates a moveable horizontal construction line at 
the pointer tip. Move the pointer to the desired 
location and click to place the construction line.

Line:VertConst V Creates a moveable vertical construction line at the 
pointer tip. Move the pointer to the desired location 
and click to place the construction line.

Snap Alignments A Toggles the Drafting Assistant alignment snaps, like 
align x, y and z, between on and off.

Snap Centers C Snaps to the center of an object.

Snap:Edges E Snaps to the edges of an object.

Snap:Faces F Snaps to the faces of a solid.

Snap:Intersections I Snaps to the intersections of objects.

SnapOnOff Q Toggles all Drafting Assistant snaps between on and 
off.

View:Front View s Changes the view to Front.

View:ISO View f Changes the view to Isometric.

View:Redraw Screen r Redraws the screen.

View:Side View a Changes the view to Side.
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View:Top View d Changes the view to Top.

View:TRI View g Changes the view to Trimetric.

View:Zoom All e Activates the Zoom All command.

View:Zoom In ] Activates the Zoom In command.

View:Zoom Out [ Activates the Zoom Out command.

View:Zoom Window w Activates the Zoom Window command to drag a 
selection fence to specify the zoom area.
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Appendix D: Spline Text Files
It is possible to create text files for importing spline data into Cobalt, Xenon or Argon.

Creating a Text File for Importing a Spline
1. Use a text editor, a word processor or a spreadsheet to create a text file.

2. Input X, Y and Z values for the spline coordinates.
The text file should be tab or space separated. Each line ends with a return. Line 
feeds after each return should have no effect.
The text file should conform to the following columnar format:

Specifing decimal coordinates are allowed as well:

Press ENTER (Windows) or RETURN (Macintosh) after the last coordinate. If not, 
Cobalt, Xenon or Argon will not import the coordinates specified in the last line.

3. Save the file as Text only and import into Cobalt, Xenon or Argon using the Spline 
Import format to create the spline.

1 1 0

2 2 0

1.33 1.1 0

2.4 2.5 3.5678
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Appendix E: 
Photo-realism Fundamentals
Photo-realistic rendering borrows terminology and technology from many disciplines. 
From photography to painting, there is often more going on behind the scene than the 
viewer realizes. To make an interesting composition, Cobalt, Xenon and Argon provide 
an extensive library of materials, lights and decals for use in a scene, but making that 
scene come to life will require some fundamental techniques.
In this lesson are some general guidelines to help make your renderings look real. 
These include:
Creating the Environment
• Modeling Tips for More Realism
• Creating Floor Surfaces and Backdrops
• How to View the Scene
• Composition: Arranging Objects in the Scene
• Making Reflective Objects Look Real
Lighting the Environment
• The 3-point Light Setup
• Specific Lighting Situations
• Lighting Color
• Shadows
Adding Realistic Materials
• Basics of Materials
• Types of Plastic
• How to Make Metal
• How to Make Clear Materials
• Image-based Textures
• Practice Makes Perfect
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Creating the Environment
Modeling Tips for More Realism
Round off Edges
In the real world, there are almost no sharp edges. Putting tiny blends on all edges can 
add subtle realism to a rendering.

Set Object Resolution to Super Fine
Choose Edit>Change Resolution... and select Super Fine from the window, or right 
mouse click an object, choose Resolution>Super Fine from the flyout menu.
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Use Surfaces for More Texturing Control
Sometimes different materials need to be applied to the same object. To obtain this do 
one of the following:
1. Use the Deep Select tool to select one face of a solid and apply necessary material 

to it. 

2. Choose Edit>Change Object Type... and change the object to surfaces. This 
allows you to place different materials on each different surface. 

Model as Much Detail as Possible
Nothing in the real world is as perfect as a computer can make it. It’s the subtle 
imperfections in things that make us know they’re real. Model the smallest details like 
the piece of apple skin hanging off the edge of the bite area or the ink in the tip of the 
pen below.
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Creating Floor Surfaces and Backdrops
Placing objects in a scene or on a simple backdrop can add dimension and scale to an 
otherwise flat rendering. Whether it’s a simple floor or a detailed room, objects will seem 
more realistic if they are placed in a suitable environment.

Simple Floor
A simple floor is a nice way to add a shadow to an object. The human eye is used to 
seeing shadows. Including them in a rendering adds realism.

Curved Surface
A curved surface under objects more accurately simulates a photographic studio’s 
technique of putting a large roll of paper under an object. This gives a smooth 
background with no seam between the floor and the rear wall.

Floor and Wall
Sometimes a distinct separation between the floor and the wall is needed. Two or more 
surfaces can be used to simulate this.
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Background Image vs. Sky Dome Sphere
Cobalt, Xenon and Argon allow you to place an image in the Photo Render>Texture 
folder, then from the PhotoRender>Edit Background... place an image using the 
Image Shader Type. This will work for most situations, but the image is always placed to 
the back of the current view as if shown from a projector. Therefore, reflections in 
mirrored or glass objects will not reflect as they would in the real world.

To achieve a realistic reflection, the image needs to wrap around the scene. This Sky 
Dome is created by placing a solid primitive sphere around the scene. Highlight the 
sphere, go to Edit>Change Object Type... and change the object to surfaces. Then 
place the backdrop as a decal or a wrapped image onto the sphere surface.

Detailed Room 
Build a detailed room around the objects to make them appear as they would in the real 
world. Notice the reflections show all of the walls in the room. 
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How to View the Scene
View Angles - Wide Angle vs. Close-up
Choosing a wide angle will allow the viewer to get a feel for the environment in which the 
object resides. If you don’t have a lot of detail in the wide angle view, this can detract 
from the object you are showing. A close-up view will show more detail in the objects.

View Angles - High Angle vs. Low Angle
Viewing the objects from a high angle will give a viewer the feeling of looking down into 
objects. This will also give the perception that the objects may be small. Viewing down 
low, however, will give the feeling that the objects are large or it can also give a grand 
feeling to a scene.

Which Side of the Object to Light
Which side of your object do you want to be lit, or conversely, which side of the object do 
you want the shadow to be on?
Placing the key light toward the wrong face of an object can hide the most important 
features. Make sure you place your objects and lighting so the most important feature is 
prevalent in your scene and that the shadow falls in a manner so as to give the object 
depth and realism.



Creating the Environment

E-7

What’s the Focal Point?
Adding secondary objects to the scene can help to enhance the realism of the main 
object. It can be smaller objects that make the main object look bigger, or a floor with 
tiles to give a sense of scale. Make sure that the main object is what a viewer 
concentrates on when looking at your rendering. Too many additional objects can 
become distracting and lure the focus away from the subject.

Composition: Arranging Objects in the Scene
The Rule of Thirds
A general guideline when setting up a scene is to 
imagine the frame being divided up into thirds. Placing 
the subject along one of the vertical lines will give your 
scene a sense of motion. It will make the image a little 
more interesting to the viewer.

Compositional Balance
While the Rule of Thirds is often very helpful in making a scene interesting, it can often 
make a scene feel unbalanced. Adding an object to a scene that is subdued in color and 
does not draw your attention away from the subject can be just what’s needed to bring a 
scene together.

Perspective: High-Angle vs. Low-Angle
Perspective angle combined with the view-angle is what gives a feeling of scale. A high-
angle perspective with a narrow field of view will show objects close to their natural look. 
A low-angle view with a wide field of view will exaggerate the size of a model. It also 
help so move in real close. 
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Perspective: Inside vs. Outside
The field of view can be changed to simulate whether you are inside or outside of a 
room. The field of view is how wide the viewing angle is.
Change the perspective focal length by using View>View Properites or clicking the 
Perspective icon in the View palette..

Making Reflective Objects Look Real
Floor and Additional Objects
Metal or glass objects are reflective by nature. In order to look realistic they require 
something to reflect. If you have a simple object and apply a chrome material to it, then 
render the scene, it won’t look like chrome at all. 
In the following images we see the original object with a chrome material applied. When 
rendered, it only reflects the black background, therefore it doesn’t look like chrome. In 
the second image, a white floor has been added. The chrome looks a little better, but 
you still don’t get the feeling that it’s chrome. Finally, some additional objects have been 
added to the scene. It becomes obvious now that the object is a chrome part.

Off-screen Objects
Adding objects to the scene that will only be seen in the reflections can further enhance 
the realism. Shown below is a scene where some additional surfaced have been added 
outside the view. They have been given a white material so they will show in the 
reflective surfaces of the subject pieces.



Lighting the Environment

E-9

Texturing
Adding a textured surface to the floor and walls can also enhance the look of reflective 
objects. 

Lighting the Environment
The 3-point Light Setup
One of the most popular lighting setups in both photography and 3D rendering is the 3-
point lighting setup. Three-point lighting is favorable in most scenes because it adds 
depth to the subject matter and offers more control with less lights in the scene.

The Key Light
This light is the main light in a scene. It is responsible for the majority of the light on the 
subject and for defining the main shadow.

The Fill Light
The Fill light, as it’s name implies, serves to fill in the darker area of the object not 
lighted by the Key light. This light helps to soften the bold shadow created by the Key 
light.

The Back Light or Rim Light
This light is used to help separate the object from the background. It will add a rim of 
light to the edge of the object. It is most often placed behind the object.
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Specific Lighting Situations
Lighting Creates 3D Form and Depth
Lighting a scene properly can add depth indicating to the viewer the true shape of the 
objects. Proper light placement will highlight edges and cast shadows to show the true 
form in the scene.

Lighting can Draw Attention and Create Interest
Making the background darker will draw attention to the objects in the foreground. 
Again, proper light placement and light intensity is the key to drawing the viewers 
interest where you want it.

Real Light Decreases Intensity with Distance
Computer generated lights are often set so the intensity does not diminish based on the 
light’s distance from the subject. It is possible to adjust this setting in Cobalt, Xenon or 
Argon to be more realistic if necessary. When placing a light, with it still selected, use 
the Attenuation pulldown in the Edit Objects dialog box. There will be five options: None, 
Clamped Linear, Clamped Quadratic, Unclamped Linear and Unclamped Quadratic.

Light

Light

Light
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Lighting Color
Lighting has Color
Create a mood with the color of the lights. You can make a scene appear as though it’s 
shot in the warm summer sun or in the midst of a cold winter day. You can also simulate 
different light types with color. For instance, use a light that produces the color of a 
candle flame, an incandescent light or a fluorescent light.

Color Temperature
Light color is often described as its color temperature, which is measured in degrees 
Kelvin. The following is a general guideline for common light sources and their 
respective RGB values for use in Cobalt, Xenon and Argon.

Shadows
Shadows - Hard vs. Soft
When a light is selected in a scene, its shadow type can be changed in the Edit Objects 
Dialog box. A hard shadow will make the scene look like a bright, sunny day. A blurry 
shadow may simulate an overcast day. Bear in mind that this technique will also 
increase the rendering time.
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Transparent Shadows
If you have a transparent object in the scene, have the software render a transparent 
shadow. To do this, open PhotoRender>Advanced Settings... and click the Use 
Transparent Shadows check box. When rendering, the shadows will appear as if the 
light was traveling through the object. If the object is colored, the shadow will retain the 
color.

Shadows with Gel Images
It is possible to have the light cast an image to 
simulate light shining through a tree, bouncing off 
water or even through a stained glass window. This 
only works on a Spot light, not the Point or Distant 
light.
Place a spot light, then open the Edit Objects Dialog 
box. Enable the Slide checkbox then choose an 
image. The image will be projected just like a slide 
in a slide projector.
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Adding Realistic Materials
Cobalt, Xenon and Argon provide a wealth of pre-defined render materials. Sometimes 
though, you’ll need to edit these materials or perhaps start from scratch to create your 
own. To edit a material, use the Render Material Settings dialogue box. Bring up this box 
by right mouse clicking an object that has a material applied and choosing Edit Material 
or by selecting the object, opening the Edit Object Dialog box, choosing the Material tab 
and cicking the Advanced button.

Basics of Materials
Material Categories Like Additive Layers
Each material may have several different layers that make it look real. A shiny wooden 
floor will consist of a layer that contains the image of the wood, a layer that makes the 
wood look rough and a layer that makes it shiny. Each of these layers, or shader 
classes, has it’s own area in the Render Material Settings Shader Class pull-down box.
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The Reflectance Category and What It Does
The Reflectance category designates a material as matte or shiny, reflective or dull. 
Here are some images that show the different categories.

Combined Reflectance Attributes 
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Types of Plastic
Smooth Plastic and Rough Plastic
Note the Reflectance and Displacement Shader Class settings to make plastic smooth 
or rough.

Reflective Plastic
In the Reflectance Shader Class, switch the Shader Type to conductor and experiment 
with the mirror factor Attribute setting. Note an extremely high value will become mirror-
like, reflecting the objects environment.
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How to Make Metal
Basic Metal
Some basic settings for making Aluminum, Gold or Brass appear in the Reflectance 
Shader Class Conductor Shader Type.

Raw or Anodized
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Chrome

How to Make Clear Materials
Glass
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Clear Plastic

Image-based Textures
Brushed Metal
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Wood.

Marble and Stone

Practice Makes Perfect
Since computer-based rendering is based in so many disciplines, including 
photography, cinematography, illustration and painting, it’s not something that’s easy to 
master. There are many books on these subjects that will apply to your rendering efforts. 
Remember to experiment with settings and note the changes. Practice with little test 
scenes. If you see something interesting in your environment, or a picture that you are 
fond of, try to simulate it in Cobalt, Xenon and Argon. The tools are there, now it’s up to 
you to master the craft.
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Appendix F: Shader Attribute Definitions
This appendix defines shader attributes for all shader types. Although these terms may 
be used elsewhere in this Designer Elements program, these definitions only apply to 
the shader attributes.
Some shader attributes share a common base word like base color and decal color. In 
these instances, only the base word is listed and defined here. In this example 
mentioned, color is defined.
Information for these definitions was taken from LightWorks 5.0 Online Reference.

Color Class Attributes
amplitude Sets the magnitude of an attribute relative to another.

axis Sets the location of the axis for the attribute.

axis direction Sets the direction for the axis when applying the simple wood 
shader.

bands Sets the total number of bands around the evaluation cylinder 
when analyzing a surface.

brick height Sets the brick height.

center Sets the center of an attribute.

color Sets the color of the attribute.

color array Sets the colors used for curvature divisions.

coverage Sets the ratio of the area covered by the bands to the area not 
covered for a surface evaluation.

curvature Sets the degree of curvature to be mapped.

curvature division Sets the number of color divisions used for a curvature 
evaluation. 

curvature type Sets the type used in a geometric curvature evaluation. There 
are three types: gaussian, mean and absolute.

decal texture space Sets the texture space for the attributes. Checking the Edit 
button displays a copy of the Render Material Settings dialog 
box from which the space can be set.

decal transparency Sets the transparency from clear to opaque.
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detail Sets the complexity of the texture where a value of 1.0 results 
in a simple pattern and higher values result in a finer pattern.

draft angle Sets the draft angle required to pull the object out of a mold.

file name Sets the file name containing the image used for the shader.

fuzz Sets the band sharpness.

gnarl Sets the random roughness of the regular rings inside the 
trunk.

grain Sets the intensity of the random grain effect where 0 (zero) 
equals no grain.

max cut off Set the maximum curvature value for evaluating an object.

min angle Sets the angle of the normal along the cylinder axis that 
defines the cylinder length and thus the reflection on the 
surface being evaluated. Smaller values create longer 
cylinders.

min cut off Sets the minimum curvature value for evaluating an object.

mix Sets the mix ratio of attributes.

mortar size Sets the mortar size.

noise Sets the visibility of the tree rings for the simple wood shader.

offset Sets relative displacement of odd and even rows of the wood 
pattern.

plank length Sets the plank length of the wood shader.

plank variation Sets the brightness variation between wood planks.

plank width Sets the plank width for a wood shader.

point on axis Sets the point on the axis of the tree from which the wood is 
taken.

pull direction Sets the direction the object will be pulled from the mold.

radius Sets the radius of the attribute.

replication type Sets the pattern of the wrapped image.

ring fuzz grain Sets the intensity of the high frequency random roughness for 
the ring edges.

ring fuzz in Sets the sharpness of the inner ring edges near the trunk 
center.

ring fuzz out Sets the sharpness of the outer ring edge.

scale Sets the scale of the attribute.

separation Sets the distance between centers of adjacent spheres for the 
solid polka shader.

size Sets the attribute size.

amplitude Sets the magnitude of an attribute relative to another.
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Displacement Class Attributes

softness Sets the softness of the feature used to define the shading.

strips Sets the count of the rectangle wood planks.

tolerance angle Sets the degree tolerance added to the draft angle that allows 
the object to be pulled from a mold but with difficulty.

trunk direction Determines the direction of the trunk axis.

trunk center Specifies the center of the trunk.

vector Sets the direction of the attribute calculated in determining the 
appearance of a particular shader.

vein contrast Sets the color contrast of the marble veins where larger values 
produce a greater contrast.

width Sets the attribute width.

amplitude Sets the magnitude of one attribute relative to another.

blend Sets the size of the blend between the sphere and the surface 
for the shader.

center depth Sets the depth of the spheres used for the dimple shader.

dented threshold Sets the relative contributions made by the displacements and 
indentations for the casting shader.

detail Sets the complexity of the texture where a value of 1 results in 
a simple pattern and higher values result in a finer pattern.

file name Sets the file name containing the image used for the shader.

frequency Sets the wavy or curving quality of edges.

irregularity Sets the pattern shape from a square to an irregular convex 
shape.

radius Sets the radius of the attribute.

scale Sets the scale of the attribute.

separation Sets the distance between the centers of adjacent spheres for 
the wrapped dimple shader.

sharpness Sets the sharpness of surface irregularities.

smooth max Sets the maximum smoothness of the edges when using the 
leather shader.

smooth min Sets the minimum smoothness of the edges when using the 
leather shader.

softness Sets the softness of the feature used to define the shading.

amplitude Sets the magnitude of an attribute relative to another.
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Reflectance Class Attributes
absorption Sets the amount of light absorbed.

ambient factor Sets the amount of ambient light reflected.

amplitude Sets the magnitude of one attribute relative to another.

bias Sets the contribution of the two thread directions for the 
wrapped woven anisotropic shader. A bias of 0.0 causes all 
reflectance to be provided by threads along one axis. A bias of 
1.0 causes all reflectance to be provided by threads along the 
other axis.

chrome factor Sets the amount of chrome light reflected.

color Sets the color of the attribute.

cylinder distance Sets the distance between cylinders for the wrapped 
anisotropic shader. The distance determines the degree of 
anisotropy of the surface. A distance of 0.0 results in an 
isotropic (normal) reflection. A distance of 2.0 results in the 
maximum anisotropy.

decal texture space Sets the texture space for the attributes. Clicking the Edit 
button displays a copy of the Render Material Settings dialog 
box from which the space can be set.

diffuse factor Sets the amount of diffuse light reflected.

exponent Sets the sharpness of the specular reflection highlights.

file name Sets the file name containing the image used for the shader.

floor height Sets the height of the floor across the cylinders used for the 
wrapped anisotropic (grooved) shader. A value of 0.0 gives 
equals no floor. A value of 1.0 creates a flat, isotropic surface.

height Sets the height of the attribute.

metallic layer factor Sets the contribution of the metallic layer to the reflectance of 
the multilayer paint shader.

metallic flakes Sets the metal for the metal flakes in the paint shader.

mirror factor Sets the contribution made by light reflected in the mirror 
direction.

reflectance Sets the reflectance of the shader.

refraction Sets the amount of light refracted.

roughness Sets the sharpness of the reflectance. Smaller values, such as 
0.1, produce a sharper reflection.

scale Sets the scale of the attribute.

selector Sets the shader used to calculate the decal reflectance with 
respect to the base object. Clicking the Edit button displays a 
copy of the Render Material Settings dialog box from which the 
shader can be set.

shader Sets the shader.
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Transparency Class Attributes

sharpness Sets the sharpness of the surface.

softness Sets the softness of the feature used to define the shading.

specular factor Sets the amount of specular light reflected.

translucency factor Sets the degree of translucency.

transmission factor Sets the amount of light that passes though the shader.

transparency Sets the transparency of the shader.

width Sets the width of the attribute.

coverage Sets the degree that an attribute covers the object with the 
associated shader.

color Sets the color of the attribute.

detail Sets the complexity of the attribute.

edge falloff Sets the transparency edge falloff rate.

file name Sets the file name containing the image used for the shader.

fuzz Sets the degree of fuzziness for the edges.

grid size Sets the size of the grid for the wrapped grid shader.

height Sets the height of the attribute.

noise density Sets the density of the roughness or irregularities.

scale Sets the scale of the attribute.

s fuzz Sets the softness of the s edge of the square for the wrapped 
square shader. The letter “s” is an identifier used to refer to one 
side of the square.

size Sets the size of the attribute.

s max Sets the maximum s dimension of the square for the wrapped 
square shader. The letter “s” is an identifier used to refer to one 
side of the square.

s min Sets the minimum s dimension of the square for the wrapped 
square shader. The letter “s” is an identifier used to refer to one 
side of the square.

softness Sets the softness of the feature used to define the shading.

t fuzz Sets the softness of the t edge of the square for the wrapped 
square shader. The letter “t” is an identifier used to refer to one 
side of the square.

t max Sets the maximum t dimension of the square for the wrapped 
square shader. The letter “t” is an identifier used to refer to one 
side of the square.

absorption Sets the amount of light absorbed.
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Texture Space Class Attributes

Background Class Attributes

t min Sets the minimum t dimension of the square for the wrapped 
square shader. The letter “t” is an identifier used to refer to one 
side of the square.

transparency Sets the transparency of the shader.

width Sets the width of the attribute. 

zero angle Sets the angle between surface normal and view direction.

aspect ratio Sets the ratio of the texture space which is defined as one unit 
of its height divided by one unit of its width.

axis direction Sets the direction of the axis.

center point Sets the center point of the cylinder used for mapping a texture 
space.

origin Sets the origin point of the texture.

scale Sets the scale of the attribute.

scale along axis Sets the factor that an image is scaled along the axis.

scale around axis Sets the factor that an image is scaled around the axis.

vector Sets the direction of the attribute.

angle Sets the angle (radians) over which the environment map is 
sampled for each background pixel allowing blurring. A 0 
(zero) angle (default) means that the pixel’s center point 
determines the color.

color Sets the color of the attribute.

detail Sets the complexity of the attribute.

distance Sets the distance that the infinite planes are in front and back 
of the eye point. The two background images are placed on 
these infinite planes.

extrapolation Sets how the background will cover the background area. 
There are three options: none, smear and tile.

file name Sets the file name containing the image used for the shader.

intensity Sets the brilliance of the reflection to be altered. The color is 
calculated for each background pixel by multiplying it with the 
intensity.

keep aspect Sets the use of the pixel aspect ratio for the image. Images are 
automatically scaled to fit the viewport. Selecting True 
preserves the pixel aspect ratio.

coverage Sets the degree that an attribute covers the object with the 
associated shader.
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Foreground Class Attributes

keep texture Sets the use of the texture for the image. Selecting True results 
in the image and file name attributes being referenced when no 
texture has been created yet.

missing ratio Sets the ratio for mixing two shaders.

rotation Sets the angle the image is rotated. The value must be either 
+/-90°, +/-180°, or +/-270°. Positive angles rotate the image 
clockwise. Negative angles rotate the image counter-
clockwise.

scale Sets the scale of attribute.

shader Sets the shader.

softness Sets the softness used to define the shading.

AA level Sets the depth used for determining the number of samples. A 
value of zero results in no oversampling. A value of one results 
in two times the number of samples as the maximum.

AA threshold Sets the limit value used to determine whether additional 
sampling calculations are performed to determine the light 
effect. If the scattered light at two sample points differ more 
than the threshold value, additional sampling occurs.

amplitude Sets the magnitude of one attribute relative to another.

bounds Sets the use of light scattering boundaries for calculating the 
effect when unable to determine where the light source 
contribution is negligible. Selecting False results in no bounds.

bounds on Sets the use of light scattering boundaries for calculating the 
effect when unable to determine where the light source 
contribution is negligible. Selecting False results in no bounds.

bounds volume Sets the volume of the boundary sphere used to calculate the 
scattering effect when unable to determine where the light 
source contribution is negligible.

color Sets the color of the attribute.

density Sets the density of the attribute.

distance Sets the distance used in calculating the closeness of the fog 
to the viewer.

eccentricity Sets the ellipse eccentricity used when calculating the light 
scattering effect for the Henyey-Greenstein scattering model. It 
has no effect on any other light scattering model. A zero 
eccentricity results in an isotropic scattering. A positive 
eccentricity results in a forward scattering. A negative 
eccentricity results in a backward scattering.

angle Sets the angle (radians) over which the environment map is 
sampled for each background pixel allowing blurring. A 0 
(zero) angle (default) means that the pixel’s center point 
determines the color.
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error bound Sets the limit for using the max lod attribute when calculating 
the detail effect using the scattering medium shader. The 
calculation time can become excessive depending on the 
detail level. This value determines the trade off point between 
calculation time and accuracy. The suggested range is 
between 0.0 and 1.0.

falloff threshold Sets the spherical area of influence of the light sources. 
Beyond a certain area the light contribution would be 
negligible, making a large number of samples unnecessary. 
The default threshold is 0.001. The value’s effect depends on 
the size of the scene and light source intensity. Thresholds that 
are too high result in spotlight clipping.

far Sets the maximum distance for the foreground shader. 
Distances greater than the far value display the full 
background color.

flake size Sets the size of the flake for the snow shader.

fog height Sets the sets fog decrease rate.

ground normal Sets the normal for the ground fog shader.

ground point Sets the ground point for the ground fog shader.

ignore background Sets whether the fog effect is applied to the background. 
Selecting True results in no background fog effect.

max depth Sets the maximum distance used in calculating the light 
scattering effect. A smaller depth, near 0.0, results in an image 
lacking any volumetric effects. The default depth is 1000. The 
value’s effect depends on the size of the scene.

max lod Sets the maximum detail level for calculating scattered light 
using the scattering medium shader.

medium ambient Sets a uniform light scattering through the medium.

medium attenuation Sets the attenuation within the medium or how it absorbs light 
along the way.

medium density Sets the density of the medium through which scattering 
occurs.

medium shadows Sets whether the medium received shadows.

min lod Sets the minimal detail level for calculating scattered light 
using the scattering medium shader.

near Sets the minimum distance that a background color appears. 
Distances less than the near value will not display the color.

noise gain Sets the contrast in the noise. High values result in sharp 
transitions while low values result in smooth transitions.

AA level Sets the depth used for determining the number of samples. A 
value of zero results in no oversampling. A value of one results 
in two times the number of samples as the maximum.
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noise octaves Sets the number of octaves (frequencies/scales) used to 
determine the detail of the noise in the light scattering.

samples Sets the number of samples taken to calculate the atmospheric 
scattering of light. A higher number results in greater accuracy 
but requires more calculation time.

scale Sets the scale of attribute.

scattering model Sets the model used for scattering the light. You have five 
options: isotropic, Rayleigh, Mie hazy, Mie murky and Henyey-
Greenstein. Choosing Mie murky results in strong anisotropic 
forward scattering as would appear when looking directly at 
light sources.

source attenuation Sets the falloff value for the attribute. Small changes in the 
attenuation value greatly affect the light scattering effect. 
Values are typically between 0.1 and 0.5.

AA level Sets the depth used for determining the number of samples. A 
value of zero results in no oversampling. A value of one results 
in two times the number of samples as the maximum.
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Glossary
Accelerators Keyboard Equivalents that invoke commands rather than using 

the mouse to choose from menus.

Align These commands align objects, including: text along the left 
sides, right sides, tops, bottoms, centers horizontal, centers 
vertical, to grid and equally spaced vertically.

ACIS This Designer Elements program is based on this kernel, 
developed by Spatial Technologies.

Ambient Light This light source provides equal illumination on all sides 
independent of the light source normal.

Annotation Text on drawings, including notes, crosshatching and 
dimensions.

Alignment Angle The angle of the Drafting Assistant’s automatic construction 
lines. The specification is set in the Window>Snaps submenu.

Ambiguity Popup This popup menu appears when attempting to select one 
object among objects so the desired object can be chosen.

Anchor This point defines the direction when placing a distant light 
source in the drawing.

Anti-Alias Feature 
Following

This feature performs a ray trace operation to bring out small 
geometric details and produce smoother images.

Arrange This command in the Layout menu changes the display of 
overlapping objects in the drawing.

Arrow Tool Used for selecting objects to be operated on with subsequent 
commands. Also used to move selected geometry.

ASCII An acronym for American Standard Code for Information 
Interchange.

Aspect Ratio Refers to a mesh surface and specifies the maximum ratio 
between triangle edges.
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Associativity A link between an object and its dimensions or parent/child 
objects. In the case of dimensions, if the object is changed, the 
dimensions automatically change to match. In the case of 
parent/child objects, if the parent is changed the child also 
changes.

Attenuation The reduction of light intensity with the distance from the 
source.

Attributes The data fields associated with a particular object that define 
that object. This includes such as Layer Name, Pen Style, 
Color, X-Y-Z Coordinates. This is also a page in the Edit 
Objects dialog box.

Auto Heal Bodies This function finds collections of surfaces that define closed 
volumes and convert them into solids. This occurs when 
importing Vellum 3D and IGES files into this Designer 
Elements program.

Auxiliary View A view created from its parent view at the geometry location 
that the user specifies.

Axis Displays the current view orientation of the X, Y and Z axis in 
the center of the screen. 

Bezier Curve A free form curve. NURB splines are a superset of Bezier 
curves.

Blend This is the filleting and rounding of solid edges.

Boolean Tools These tools add, subtract and intersect solids.

Border A frame showing the boundary of a view.

Boss This is a cylinder extending from a solid and filleted at the 
intersection of the two.

Boundary The geometry that defines the limits for operations such as 
trimming and relimiting.

CAD An acronym for Computer-Aided Design.

CADD An acronym for Computer-Aided Design and Drafting.

CADD.LIN All line patterns are stored in this file in the Environ folder.

CAE An acronym for Computer-Aided Engineering.

CAM An acronym for Computer-Aided Manufacturing.

Case This refers to the text case options in this Designer Elements 
program and includes lower case, UPPER CASE and Title 
Caps.

Center Mark A center-line dimension for circles and arcs.

Chamfer A beveled or sloping edges between two objects.

Characteristics See Attributes.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Child An object created from another object or an operation 
performed on an object.

Circumference The distance around a circle along its edge =2 Pi r

Circumscribed Enclosing a circle. In circumscribed polygons, the midpoint of 
each side of the polygon touches an imaginary circle (i.e. the 
polygon exactly surrounds the circle).

Clamped Linear Light intensity that diminishes according to the following 
formula, Intensity/(distance+1).

Clamped Quadratic Light intensity that diminishes according to the following 
formula, Intensity/(distance2+1).

Click To press and release the mouse button. To click an object, 
move the pointer to the object and press and release the 
button.

Clipboard The memory buffer where selections are stored when the Cut 
or Copy command is used.

Conic These objects are used in aerospace design field and create 
curves defined by start point, end point, shoulder and slope 
control points.

Construction Lines Lines, displayed as dotted or gray lines, that are used for exact 
alignment. The Drafting Assistant creates dynamic, temporary 
construction lines. It is also possible to create permanent 
construction lines, which can be used in the geometry or used 
for alignment and then deleted.

Control Point The endpoint or midpoint of an object or “knot” point defining a 
spline. The Drafting Assistant indicates these positions when 
the pointer is moved near them.

Coon Patch A nurb surface with three or four sides.

Coordinates Positions on axes that specify the point locations. Two-
dimensional objects have x,y coordinates; three-dimensional 
objects have x,y,z coordinates.

Coplanar This refers to objects that lie in the same two dimensional 
plane.

Copy The command that places a duplicate of the selected geometry 
on the Clipboard. See the descriptions for the Polar Duplicate 
and Linear Duplicate tools and Transformation tools for 
additional copying methods.

Cover Surface A surface created from a profile.

Counter Bore A hole created from a hole and a bore where the bore is a 
straight sided cylinder with a diameter larger than the hole. The 
hole extends from the end of the bore into the solid to complete 
the counter bore.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Counter Sink A hole created from a hole and a sink. The sink is an angled 
hole with a diameter larger than the straight sided hole. The 
hole extends from the end of the sink into the solid to complete 
the counter sink.

Crayon Picker This is a Macintosh color display to chose a color from the 
crayon box.

Custom Colors (Windows only) This button in the color display defines 16 
additional colors to show in the partial color display.

Cursor The I-beam position indicator in the text tool and boxes which 
use text. Elsewhere, the position indicator is called a pointer. 

Curvature This command in the Verify menu displays a porcupine plot of 
selected curves or surfaces representing the direction and 
order of magnitude of the curvature.

Curvature Plot This analysis displays geometry in a Gaussian Curvature plot 
which is the product (K1 - K2) of the principle curvatures at a 
point on a surface.

Curve A line, circle, arc, ellipse, or spline.

Cut The command to delete selected entities. The selection is 
placed on the Clipboard and can be pasted into the same or 
different documents or into documents created by other 
applications.

Cutout A profile that has been extruded through a solid and removes 
all intersecting material.

CYMK Picker This is a standard color wheel for the Macintosh with the option 
to specify CYMK values.

Dashed A line pattern made up of dashes.

Default Built-in settings that are used by the system if othere value or 
choice is not specified.

Defining Points The X, Y and Z coordinates for the specified points of splines, 
mesh and slab primitives.

Deformable Faces These are solid faces whose shapes can be modified by 
applying a gain pressure.

Degenerative An object such as a surface or chamfer where the length at the 
beginning and/or ending is equal to zero.

Delete The command to erase selected geometry. The selection is not 
placed on the Clipboard; however, it can be retrieved within the 
limits of the Undo command.

Delta A change, usually in position.

Design Explorer This command displays a dialog box with the history tree of the 
selected object. It includes its own submenu of editing 
commands.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Detail View An enlarged view of a specific area of the geometry displayed 
in a drawing view.

Dialog Box A specification box that appears in response to certain 
commands. A dialog box provides information that qualifies the 
execution of those commands.

Diameter The distance across an arc or circle, passing through the 
center.

Differential Scaling Refers to the ability to use different scaling values for along 
different axes of a curve.

Dimension A graphic object that displays the distance between two points. 
A measurement of an object. 

Direction This command in the Verify menu displays the direction of the 
normals of an object. 

Distant Light This light source emits parallel rays of light, as if from a very 
distance source.

Divide To segment a line or curve into equal parts. This is also one of 
the Trim tools.

Double-click To press and release the mouse button twice, quickly. 

Drafting Assistant A unique feature which displays feedback notations and 
construction lines to aid with snap, alignment and constraint 
operations. The Drafting Assistant facilitates exact construction 
without requiring to be exact. When the pointer is close enough 
to display feedback, the Drafting Assistant locks onto the exact 
location.

Drag To press and hold the mouse button, move the pointer to a new 
location, and release the button.

Draft A taper or a specific angle applied to a solid.

Draft Angle The subtraction or addition of material at a specific angle along 
a solid. Draft angles are used to facilitate the placement or 
removal of a part from a mold. Positive draft angles add 
material. Negative draft angles remove material.

DXF An acronym for Data Exchange Format-a format of AutoCAD 
files.

Drawing A drafted, 2-dimensional drawing of a model. Usually a 
drawing including an orthogonal view.

Drawing View A view containing 2D geometry created from a 3D model after 
choosing the Model to Sheet command. 

Dynamic Render The feature that displays the geometry in the selected render 
mode as it is rotated.

DWG AutoCAD's native file format.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Endpoint The first and last point of a line or curve. The Drafting Assistant 
indicates these positions when the pointer is moved near the 
endpoint of an object.

EPS Encapsulated PostScript format for printing to a PostScript 
printer and for importing into compatible applications.

Estimate Count Refers to a button in the Mesh Parameter dialog box which 
calculates the approximate number of facets based on 
specified parameters. The dialog box appears when using the 
Change Object Type command and convert a surface or solid 
to mesh.

Export To save a document in a file format that can be used by a 
different application program.

Extrude Creates a 3D object out of a 2D profile.

Expression Parsing Mathematical, trigonometric and exponential operators that 
can be used in the Status Line.

Face A surface of a solid.

Facet A way of representing surfaces in DXF and DWG files prior to 
release 13.

Falloff Angle The angle that controls the sharpness of a spot light’s edge.

Falloff Rate This light distribution for a spot light from the center of the spot 
light cone to the outer edge.

Feature A set of operations that may add material to or subtract 
material from the solid including blending, chamfering, creating 
holes, bosses, cutout and protrusions.

Field of View The view angle for a perspective.

File An individual document.

Fill Color The color applied to a selected pattern for a smart polygon.

Fill Pattern The pattern applied to a smart polygon.

Fillet An arc of a specified radius tangent to entities. 

First Blind An option for the hole tools which will extend a hole to the first 
open face. 

Flatten View This command in the Drawing View menu flattens 2D geometry 
within a view onto the Sheet View layer. This operation breaks 
the 2D geometry’s associativity to the 3D model.

Flat Shading Renders the object with a painter's algorithm using constant 
shading techniques.

Flavor The types of IGES files this Designer Elements program can 
import and export.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Flip Normal When this option is checked in the Render Options dialog box, 
the normals of an object are flipped. If light normals are pointed 
away from the view when rendered, the object will appear dark.

Font The assortment of type used in text.

Gain Pressure applied to a solid face to deform it.

Geometry The objects used to construct parts.

Geometric 
Characteristics

Characteristics that make up the geometry of an object like, 
length, radius, Defining Points and Rho.

Gouraud Shading Renders the geometry based on calculated light intensities at 
each vertex. It shades more quickly but with a lower quality 
than Phong shading. This rendering method uses Open GL 
(Windows) or QuickDraw 3D (Macintosh).

Gouraud w/Edges 
Shading

Renders the geometry based on calculated light intensities at 
each vertex and displays the face edge boundaries in a 
specific color.

Gregory Surface A Nurb surface with more than four sides.

Grid The rectangular array of lines that facilitates measurement and 
alignment. The grid display can be turned on or off, and the 
spacing can be specified through the Layout menu.

Group To specify several entities as one unit that will be treated as a 
single object.

Helix A spiral curve.

Hidden A line pattern used to draw lines that would not be visible in a 
solid part. Drafters traditionally use hidden lines for geometry 
that is behind other geometry.

Hidden Shading Renders the geometry such that only visible edges are 
displayed.

Hidden w/Dimmed Renders the geometry such that the visible edges are 
displayed and the hidden edges are dimmed.

Hot Spot The point on the wireframe and dimension tool cursors that 
indicates the next point to click. The hot spot is represented by 
a dot with crosshairs on the cursor.

Histogram A bar graph representing the frequency of a curvature 
smoothness (change in a curve over the change in curvature) 
using the color spectrum. The length of the bar represents the 
frequency.

Hit Radius The distance, in pixels, detectable by the Drafting Assistant 
between the object and the pointer.

HSL Picker This is a standard color wheel for the Macintosh with the option 
to specify Hue, Saturation and Lightness.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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HSV Picker This is a standard color display for the Macintosh with the 
option to specify Hue, Saturation and Value.

IGES An acronym for Initial Graphics Exchange Specification. The 
U.S. Department of Commerce, National Bureau of Standards 
issues IGES as the industry standard among CAD/CAM 
systems for data exchange in a neutral file format. 

Import To load or read in a non-Designer Elements program file.

Infinite Plane A two dimensional surface with no defining boundaries.

Inflection A change in slope along a spline.

Influence The degree of impact a control point has on a spline.

Inscribed Within a circle. For polygons, all vertices touch the (imaginary) 
circle.

Instance Refers to an object that's moved to or placed in a different 
location after performing an operation on it. Creating a solid, 
add a blend and move it, the solid is now an instance. The 
original is still located in the previous position although it is not 
displayed. If a master symbol is created, an instance occurs 
when the symbol is placed in the drawing. An instance is 
associative to the original geometry. Any change made to the 
original is reflected in the instance. If the object is copied and 
pasted, the associativity is broken.

Intensity The lighting level for a light source set in the Edit Objects 
dialog box.

Interference The shared volume created by two or more intersecting 
objects.

Intersection The position where two lines or curves meet. The curves may 
actually touch or only intersect when they are extended. The 
Drafting Assistant indicates only actual intersections.

ISO Lines Control the isopram lines drawn for a surface. These Iso 
(isopram) lines are constant parameter curves that lie on a 
surface, typically defined in parameter space. The parameter 
space coordinate system uses U and V coordinates. A 0 (zero) 
in both fields turns off Iso lines. The appropriate U/V values 
may enhance the visual appearance of the surface at the 
expense of drawing speed. The letters, U and V are industry 
standard space coordinate identifiers 

(U = horizontal, V = 
vertical).

Isopram The full name for ISO Lines.

Knot Points The points defining a spline, indicated as vertex points by the 
Drafting Assistant.

Lathe Revolve an object a certain angle.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Layer Analogous to transparent media used in conventional manual 
drafting. Parts can be constructed on several layers which can 
be made visible or invisible.

Line Pattern Manager Through this dialog box, modify the scale of all available line 
patterns.

Linear Duplicate A feature that duplicates an object and places the copies in a 
line or in an array of multiple lines.

Links This is the associative relationship that exists between parent/
child objects in which a modification to the parent also modifies 
the child.

Local Face Modeling The ability to perform various operations on a specific face of a 
model including: drafts, move, offset, remove replace and 
match.

Lock The command to render a selection unchangeable.

Loft A surface that references another surface making it tangent to 
the referenced surface. Any surface can be used to create the 
surface.

MxN Curves The number of curves that define a net surface in two 
perpendicular directions.

Mask To select entities as a group, masking out all others.

Masking The method used for applying a decal to an object, either 
stencil or factor.

Mate This operation matches the planar face of one object to the 
planar face of another object.

Math Operator The mathematical, trigonometric, or exponential expression 
used to indicate values. All value entry boxes in this Designer 
Elements program accept the math operators listed in 
Appendix A.

Max Edge Refers to a conversion of an object type to mesh. This sets the 
maximum acceptable length of facets.

Message Line The top line of the drawing area. It names the current tool and 
provides instructions for using it.

Memory Indicator The indicator at the bottom left corner of the Designer 
Elements program window that displays how much RAM is 
allocated to this Designer Elements program.

Mesh Planar elements defined by nodes or 3D vertices that can be 
used to represent surfaces but are not surfaces themselves.

META The file format used by the Windows Clipboard.

Mnemonics The key sequence which invokes a command from a menu.

Model The model is the geometry.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Model Point The point that can be specified in the View Rotation Options 
dialog box about which to rotate a view.

N# Sections The number (n) of cross sections used to define a skin surface.

Net Surface A surface defined by M (number) of rows and N (number) of 
columns. 

Non-planar Surfaces or points that do not lie in a two dimensional plane.

Normal A perpendicular to a tangent of a curve, surface or solid face.

Normal Deviation Refers to a conversion of an object type to mesh. This sets the 
maximum angular deviation between adjacent facets.

NURB Non-Uniform Rational B-splines—the type of splines this 
Designer Elements program creates. NURB splines are a 
superset of Bezier curves. NURB splines provide designers 
with two interrelated functions.

First, curvature continuity remains intact even when the curve 
is changed, so kinks won’t develop as the spline is altered. 
Second, localized control of a complex curve is provided. 

Object An individual piece of geometry, such as a line, arc, circle, 
surface or solid.

Object Extents The area defined by an object.

Object Type This refers to a specific kind of geometry and includes curves, 
surfaces and solids.

Offset The distance a curve or surface is placed from the original 
location.

Origin The 0,0,0 location on the drawing area. When a new document 
is opened, 0,0,0 is located in the middle of the screen. The 
coordinate symbol displays at the origin when the grid is turned 
on. The origin can be changed at any time.

Pan A horizontal camera movement used when creating movies.

Palette A group of tools. The general tool palette is always displayed 
to the left of the drawing area.

Parent An object from which other objects are created or operations 
are performed.

Param The percentage point that a variable blend radius is placed 
along a solid edge.

Parent/Child The relationship created between an original object and 
subsequent objects such that any modifications done on the 
parent affects the child.

Part A collection of entities representing an object or structure.

Parting Line A curve used with the Parting Line tool to divide a solid for 
applying a draft.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Paste To place the contents of the Clipboard in the current document.

Perpendicular At a 90° angle. The Drafting Assistant displays a notation when 
the current construction is at a 90° angle to an object. 

Perspective Viewing 3D geometry on a two dimensional surface as seen by 
normal binocular vision.

Phong Shading Renders the geometry based on calculated light intensities at 
each pixel location.

Phong w/Edges 
Shading

Renders the geometry based on calculated light intensities at 
each pixel location and displays the face edge boundaries in a 
specific color.

Photorealistic Images resembling photography in the rendering quality.

Pick Box The pixel area defined in Preferences that selects an object.

Pick Objects This is the dialog box with the Ambiguity Popup menu.

PICT The Macintosh graphics file format which uses object-oriented 
bitmaps or resolution-independent graphics.

Pick To select a location or object by clicking it.

Pipe Solid A solid created by with an inside and outside diameter using 
the Pipe Solid tool.

Pitch The distance between helix peaks.

Planar Surfaces or points that lie in a two dimensional plane.

Plot To draw a part on paper using a plotter.

Plotter A computerized drawing device for hardcopy output.

Point A location for constructing geometry.

Point Light This light emits rays in all directions, like a candle or table 
lamp.

Pointer The position locator similar to a cursor. When a tool is in effect, 
the pointer takes on a representative shape while in the 
drawing area.

Polar Duplicate A feature that duplicates an object and rotates the copes 
around a reference point.

Press To press and hold down the mouse button. This action is most 
commonly used to view the contents of a menu.

Primitive A basic solid shape defined by linear or quadratic geometry 
like: block, cylinder, cone, etc.

Profile A closed curve or collection of curves connected end to end.

Protruded Feature Material projections from a solid.

Pull-direction The direction a part ejects from a mold.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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QuickTime Object 
Movie

A Quick Time movie that keeps the observation point fixed as 
the eye point is moved at a fixed distance about the 
observation point.

QuickTime VR 
Panoramic Movie

A QuickTime movie that keeps the eye point fixed as the 
observation point is rotated 360°.

Radius Half the distance across an arc, starting from the center.

Rail A curve used to define a sweep direction and distance for a 
surface.

RAW This translator creates a file containing triangular vertices that 
define the x, y and z locations of the 3D faces.

Raytrace The function that determines the visibility of objects in a scene 
by tracing rays from the eye to the objects. The raytrace 
function calculates the visibility by breaking the scene into 
smaller pixel areas, producing a photorealistic rendered 
images.

Redo The command that reverses the action of the Undo command. 

Redraw To refresh the screen, recreating all objects.

Reflectivity The ratio of the amount of light falling on a material to the light 
reflected off it.

Relative Position A location specified as a certain distance from another 
location. It is often called the delta position.

Relimit Lengthen or shorten lines to the specified object.

Render The command that shades the geometry in a specified mode.

Render Now The render option activated when the Render command is 
chosen. Set the mode in the Render Options dialog box.

Render Options The dialog box that sets the shading mode for the geometry.

Resolution The appearance of surfaces and solids when rendered. There 
are five options: Super Fine,Very Fine, Fine, Medium and 
Coarse.

Rho Used in defining a conic object, it is the ratio of the center point 
- shoulder point distance and the center point - slope control 
point.

Right-hand rule 1. A memory aid for the relative directions of the positive axes. 
With your right palm upturned, the thumb (X) points right, the 
index finger (Y) points straight ahead and the middle finger (Z) 
points up. If you move your hand to indicate the X and Y axes, 
you can easily see the direction of the Z axis.

2. A memory aid in which the thumb of the right hand points in 
the direction of the positive axis of rotation. The fingers curve 
in the direction of rotation.

SAT A file format for ACIS based programs.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Section View A view created by making a section cut through the geometry 
displayed in a drawing view.

Selection Fence A bounding box that temporarily appears as the Selection tool 
cursor is dragged around an area in the drawing.

Setback The distance that a blend extends from three or more 
intersecting edges.

Short Cuts Key combinations for performing Designer Elements program 
operations to customize the program.

Shelled Solid A hollowed out solid object.

Shoulder control 
point

A point used in defining a conic.

Silhouette A view of the object from the visible edges only. Silhouette 
edges are view dependent and can cause a significant 
reduction in drawing speed.

Simplify This option available in the Stitched Solid tool asks Designer 
Elements program to determine whether the solid can be 
defined by analytic surfaces, for which ACIS is optimized, 
rather than nurb surfaces.

Skin Surface Nurb patches fitted over a collection of curve cross-sections.

Slab A solid primitive created from three or more points, a height 
and draft angle.

Slope The change of x relative to y between two points on a line. In a 
spline, slope defines the vector of a line tangent to the spline at 
a particular knot point.

Slope control point A point used in defining a conic.

Smart Polygon A true polygon that is one object with length and width. This 
can be contrasted with a single line polygon composed of 
individual lines.

Smart Silhouette A silhouette that displays only if it does not degrade the 
performance of this Designer Elements program.

Snap The command sets the specifications for the Drafting Assistant.

Sphere Trackball The standard trackball that rotates the view by dragging the 
cursor on the sphere.

Spline A smooth, free-form curve passing through specified points.

Spot Light This light emits a cone of light from a local source.

Static Render This render option defines how the geometry will display when 
the view is stationary.

Status Line The line at the bottom of the drawing area in which the 
specifications for the geometry being created can be entered.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Stencil An image that defines the regions through which artwork 
projects onto an object.

Step Trackball The trackball that rotates the view by clicking on a directional 
arrow.

Stitched Solid This is a solid created from joining surfaces together.

STL The file format creates stereolithography files.

Subtract Solid This solid is subtracted from another to create a final solid.

Sweep Refers to the extrusion of a profile to a surface or solid.

Surface Non Uniform Rational B-Splines created for specified 
boundaries.

Surface Deviation Referring to the conversion of a surface or solid to a mesh, this 
sets the maximum acceptable distance between the facet and 
the surface represented by the mesh.

Symbol Objects that are created in the Symbol Manager are Master 
Symbols and can be instanced into the drawing at multiple 
locations.

Tangent The point where a line or curve touches a curve without 
intersecting it. The Drafting Assistant displays the tangent 
notation of a curve when the pointer nears it.

Taper Solid This is a solid created with draft angles or tapers.

Termination Type This defines the protrusion type used to create a feature on a 
solid.

3DMF The file format of QuickDraw 3D.

Tiling Breaks up a drawing into a multiple pages to print large 
drawings.

Tilt A vertical camera movement used when creating movies.

Torus A solid primitive generated by the revolution of a conic section, 
like a circle.

Transparency The amount that light can pass through a material.

Triad This illustrates the orientation of the x, y and z axis and the 
current work plane.

Toggle To switch between two conditions, for example, Hide Grid/
Show Grid.

Transformation The tools to move, rotate, expand, shrink, or mirror an object or 
group of entities.

Trim To shorten or remove a portion of a line.

Tube Surface A surface created in the shape of a tube.

Twist Angle The angle of twisting a solid when sweeping a profile to a solid.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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Unclamped Linear Light intensity that diminishes according to the following 
formula, Intensity/distance.

Unclamped 
Quadratic

Light intensity that diminishes according to the following 
formula, Intensity/distance2.

Undo The command that reverses the last editing or creation action. 
An infinite number of actions can be undone in a specific 
Designer Elements program session.

Uniform Scaling Scales an object equally in all directions.

Units Measures used for construction (U.S. or metric).

Vector Splines The slope, shape, control points and control point influence 
can be modified for splines of this type.

Verify A menu listing commands for determining properties of 
selected objects.

Vertex The point at which the sides of an angle intersect or a knot 
point of a spline.

View Rotation 
Options

This dialog box to specify trackball rotation parameters.

VRML A file format for exporting virtual reality modeling language 
files.

Wrap The mode that artwork projects onto an object, planar, 
cylindrical or spherical when applying a decal.

Wireframe A 3-dimensional representation showing boundary lines, edges 
and intersections, but not surfaces.

World plane The work plane used at the beginning of the construction of a 
model. Also known as the world coordinate system. 

Work plane The x,y plane used for 2D objects which has an origin of 0,0,0 
for all data input. Sometimes referred to as the user or work 
coordinate system.

Zoom The tool or command that magnifies or reduces an image.

Accelerators Keyboard Equivalents that invoke commands rather than using 
the mouse to choose from menus.
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I-1

Index
Symbols
% point 3-6, 49-7
Numerics
1 point

block primitive 23-4
cone primitive 23-8
cylinder primitive 23-6
prism primitive 23-12
pyramid primitive 23-14
rotate 8-3
sphere primitive 23-2
symbol 34-4
torus primitive 23-10

2 points
block primitive 23-5
center ellipse 12-2
cone primitive 23-9
conic 12-5
cylinder primitive 23-7
mirror 8-8
prism primitive 23-13
pyramid primitive 23-15
section view 44-16
sphere primitive 23-2
symbol 34-4
torus primitive 23-11

2-entity
chamfer 15-3
fillet 15-2

3 points
arc 11-2
center ellipse 12-3
circle 11-5
conic 12-6
mirror 8-9
rotate 8-4
work plane command 37-6

3-Corner Ellipse tool 12-4
3-Entity Fillet tool 15-2
3-point light setup E-9
4-Point Conic tool 12-7
A
ACIS SAT

export 43-14
import 43-6

add
boolean surface 20-9
union solid 26-2

Add Spline Control Point tool 14-7
Adobe Illustrator

export 43-18
import 43-7

align 5-9
assembly 28-3
drawing view 44-10

Align Objects tool 8-21
alignment angles 3-6, 49-7
along curve

Bend solid 25-33
ambient lighting 38-14
ambiguity popup 4-6, 49-16
analysis

surface 29-9
analysis (surface) 29-10, 29-22
Angle 3 Pts command 29-1
angles (construction line) 3-9
angular

chamfer 15-3
dimension 32-11

Angular Dimension tool 32-16
animation 41-1

Fly By 41-5
Paths 41-5
VR Object 41-7
VR Panoramic 41-9
Walk Through 41-4

ANSI dimension standard 32-23, 32-24
anti-alias 40-8
Apply button 2-19
Arbitrary Polygon tool 13-7

show frame 13-7
Arc tools 11-1

3-Point 11-2
Center-Point 11-1
Tangent-Point 11-3

Architecture dimension standard 32-23,
32-24
Area command 29-2
area render 40-10
arrange

command 5-8
icons 35-18

arrays. See duplicate
arrow key (nudge distance) 49-12
arrowheads

dimension 32-21
pen 10-8

aspect ratio (mesh) 5-16, 5-18
Assembly Modeling tools 28-1

align 28-3
Connect 28-1
Insert 28-4
Mate 28-2
palette 28-1

associativity
dimension 32-1
features 25-1
parent/child 1-3
solid 22-5
surfaces 16-4

asterisks 2-19
Attenuation E-10
attribute (shader) 39-19
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Attributes and Bill of Materials 45-1
Apply To Selected 45-2
Area 45-1
Area 2D 45-1
Create Balloons 45-2
Create BOM 45-2
Export BOM 45-2
Material 45-1
Perimeter 45-1
Price 45-1
Standard 45-1
Stock Size 45-1
Update BOM 45-2
User Defined Templates 45-3
Vendor No. 45-1
Volume 45-1
Weight 45-1

auto
decal wrap 39-10
hatch 44-10
heal bodies 43-2
layers 20-2
save 49-10

Auxiliary View tool 44-13
Axis

Bend solid 25-31
axis 2-2, 2-14

show/hide 6-10
azimuth (view) 35-13
B
backdrop E-4
backgrounds

applying 39-13
drawing window color 49-3
editing 39-24
library 39-2, 39-12
settings 39-25
types 39-25

backup files 42-5
Balloon Dimension tools 32-12
base line dimension

horizontal 32-6
vertical 32-7

bend (deform face) 27-15
Bend Solid Tool 25-31
Bend Solid tool

Along Axis 25-31
Along Curve 25-33
Center 25-33

Bezier Spline tool 14-4
blend (constant)

disjoint 25-9
edge to face roll 25-11
elliptical 25-6
mitered 25-8
multi-radius 25-8
radial 25-5
vertex 25-7, 25-9

blend (variable)
by position 25-12
fixed width 25-14
hold line 25-15
law curve 25-13
linear 25-12

blend options (advanced)
chain select edges 25-3
cross section 25-4
feature interaction 25-3

Blend tools
Constant 25-5, 25-16
param 25-13, 25-24
Variable 25-12

Block Primitive tools 23-4
1 Point 23-4
2 Point 23-5
Diagonals 23-5

BOM User Defined Templates 45-3
Area 45-3
CG-X 45-3
CG-Y 45-3
CG-Z 45-3
Float 45-3
Index 45-3
Integer 45-3
Material 45-3
Name 45-3
Perimeter 45-3
Qty 45-3
String 45-3
Sum 45-3
Volume 45-3
Weight 45-3

Boolean Solid tools 26-2
Intersect 26-3
Subtract 26-2
union 26-2

Boolean Surface tools
add 20-9
Intersect 20-9
Subtract 20-9

Boss Feature tool 25-29
direction 25-29

branch (Design Explorer)
collapse 5-34
expand 5-34

bulge factor (lofted solid) 26-8
by position blend 25-12
by position variable chamfer 25-24
C
C2 continuous splines 14-4
camera (movie) 41-2, 41-8, 41-9
case (text) 31-5
Catia v4

export 43-18
Center

Bend solid 25-33
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center
center mark dimension 32-11
Drafting Assistant snap 3-2
Drawing View command 44-11

center of gravity 29-4
Center/Axis Rectangle tool 13-3
Center/Corner Rectangle tool 13-2
center-point

arc 11-1
circle 11-4

CGM 43-14
chain (selection) 4-11
chain dimension

horizontal 32-6
vertical 32-7

chain select edges blend
option 25-3

chain select edges chamfer 25-17
chamfer (constant)

length 25-18
length angle 25-19
mitered 25-21
two lengths 25-19
vertex 25-20

chamfer (variable)
by position 25-24
fixed width 25-24
four lengths 25-22
lengths 25-22
lengths angles 25-23

Chamfer Edge tools
Variable 25-21

chamfer options (advanced)
chain select edges 25-17
feature interaction 25-17

Chamfer tools 15-1
2-Entity 15-3
Angular 15-3

change
curves to lines 5-13
curves to splines 5-13, 5-14
dimension to lines 5-19
direction 5-11
drawing view 44-11
layer 5-6
object type 5-12
preferences 49-20
resolution 5-4
solid to curves 5-17
solid to mesh 5-17
solid to surfaces 5-17
solids to solids 5-19
surface to curves 5-14
surface to mesh 5-15
surface to surfaces 5-15
text to curves 5-14

Change Object Type E-3
check box 2-18

Check Object command 29-7
Circle tools 11-3

3-Point 11-5
Center-Point 11-4
Opposite-Point 11-5
Tangent-Point 11-6

Circumscribed Polygon tool 13-5
scribe type 13-6
show frame 13-6

Clear Materials E-17
clipboard 5-3
Close 24-17
close file 42-5
collapse (Design Explorer)

branch 5-34
item 5-34

color
ambient light 38-14
background 49-3
current pen 10-3
default dimension 49-21
default pen 49-21
define 10-3
dimension 32-19
fill 25-1, 25-4
foreground 49-3
grid 49-13
layer 36-3, 36-8
lighting 38-15
name 10-4
palette 10-3
pen 10-2
preferences 49-3
selection 4-3
shader class 39-21
texture shader 39-21

Color Temperature E-11
compact files 49-10
Compositional Balance E-7
compressor (movie) 41-3
Cone Primitive tools 23-8

1 Point 23-8
2 Point 23-9
Diagonal 23-9

Conic tools 12-5
2-Point 12-5
3-Point 12-6
4-Point 12-7
rho 12-5
shoulder point 12-5
slope control point 12-5

Connect Assembly tool 28-1
Connect Curve tool

Join 15-8
move curve point 15-8

Connect Surface tool 20-10
Connected Lines tool 11-3
constant blend
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disjoint 25-9
edge to face roll 25-11
elliptical 25-6
extrapolation 25-11
mitered 25-8
multi-radius 25-8
one edge vertex 25-9
radial 25-5
two edge vertex 25-9
vertex 25-7
with cutouts 25-11

Constant Blend tool 25-5, 25-16
constant chamfer

length 25-18
length angle 25-19
mitered 25-21
two lengths 25-19
vertex 25-20

construction geometry 3-10
construction line

angles 3-8, 3-9
construction command 3-9
delete 3-11
Drafting Assistant 3-6
offset 3-9
parallel 3-10
pattern 10-8
permanent 3-8

control points
adding to spline 14-7
remove from spline 14-7
selecting 4-8
show 4-7
slope 12-5
spline 14-2, 14-3

control vertex modification 16-5
insert knot 21-6

convert
files (see export)
objects (see change object type)
text to curves 5-14

coordinate system 2-2
choosing 6-6
global 6-5
user-defined 6-5

Coordinate System Axis 2-14
copy

along path 8-9
bitmap 5-2
command 5-2
object characteristics 4-14
objects 8-23
objects/layer 36-9
pict 5-2
Status Line entries 2-13, 6-3

Corner Trim tool 15-7
count (layer objects) 36-3
Counter Bore tool 25-28

Counter Sink tool 25-28
Cover Surface tool 18-9

n-sided 18-9
cross section (blend) 25-4
crosshatching 25-4

auto hatch 44-10
command 25-6
DIN patterns 25-6
edit 25-7
ISO patterns 25-5
patterns 25-4
section cuts 25-7
section views 44-17

curvature plot 29-13
curve check

protruded feature 24-13
solid profiles 24-17

Curve Utility tools 15-9
Explode Edge 15-16
Extrude Curve 15-16
Offset Curve 15-9
Project Curve 15-13
Revolve Curve 15-12

Curve/Surface Intersection tool 20-7
Curve/Surface Projection tool 20-4
cut

command 5-1
solids 22-7
surface 16-4

Cutout Feature tool 24-11
Cylinder Primitive tools 23-6

1 Point 23-6
2 Point 23-7
Diagonals 23-7

cylindrical wrap (decals) 39-8
D
dcm

fixed constraint
preferences 49-4

fully defined constraint
preferences 49-4

over defined
preferences 49-4

over defined constraint
preferences 49-4

preferences 49-4
under defined constraint

preferences 49-4
DCM Animation Settings 47-8

Delay 47-9
End 47-9
Loop 47-9
Rebound 47-9
Running the Animation 47-9
Start 47-9
Steps 47-9

decals 39-2, 39-7
applying 39-9
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auto wrap 39-10
creating 39-14
cylindrical wrap 39-8
images 39-12, 39-14
lock normal 39-10
masking 39-10
planar wrap 39-8
reflectance 39-23
rotation 39-9
shader 39-21
spherical wrap 39-8
stencil 39-11
user-defined 39-14

decimal places 2-13
decrement layer 36-7
default layers 36-4
define

color 10-3
defining spline point 14-3
work plane 37-3

definitions G-1
Deform Face tool

bend 27-15
boundary tangents 27-15
gain 27-12
resolution 27-15
stretch 27-14
to curve 27-14
to point 27-13

degree (elevate surface) 16-5
delete

construction lines 3-11
drawing view 44-10
geometry 5-3
layer 36-3, 36-5
lighting 38-16
view 35-15
work plane 37-4

deselecting 4-11
Design Explorer 5-26

change item name 5-30
close window 5-34
collapse branch 5-34
collapse item 5-34
edit parameter 5-34
expand branch 5-34
expand item 5-34
move feature 5-33
remove feature 5-34
reorder feature 5-33
suppress feature 5-32
unsuppress feature 5-30, 5-32

Designer Elements window 2-1
axis 2-2, 2-14
coordinate system axis 2-2, 2-14
drawing area 2-2, 2-15
location indicator 2-2, 2-12
menu bar 2-2, 2-15

Message Line 2-2, 2-12, 6-6
pointer 2-2
scroll bars 2-2, 2-15
Status Line 2-2, 2-12, 6-2
title bar 2-2
tool palette 2-2
tool tip 2-2
Triad 2-2, 2-14
work layer indicator 2-2, 2-15

Detail View tool 44-18
diagonal primitive

block 23-5
cone 23-9
cylinder 23-7
prism 23-13
pyramid 23-15
sphere 23-2
torus 23-11

Diagonal Rectangle tool 13-2
dialog box 2-18

Apply button 2-19
asterisks 2-19
check box 2-18
list/entry box 2-19
Option button 2-18

Diameter Arrow Dimension tool
In 32-10
Out 32-10

dimension
angular appearance 32-17
arrowheads 32-21
associative 32-1
color 32-19
default settings 49-21
drawing view 32-25, 44-5
edit objects 32-4
font 32-18
layer 32-4, 32-20
linear appearance 32-15
menu 2-16, 32-1, 32-25
move 32-3
offset 32-23
palette 32-2
size 32-18
standards 32-22
style 32-19
text 32-17
tolerances 32-16
units 32-4
weight 32-20
witness lines 32-22
work plane 32-2

dimension standard
ANSI 32-23, 32-24
Architecture 32-23, 32-24
choosing 32-25
creating 32-25
DIN 32-23, 32-24



Index

I-6

Dual side 32-23, 32-24
Dual stacked 32-23, 32-24
ISO 32-23, 32-24
JIS 32-23, 32-24
Stacked fraction 32-23, 32-24

Dimension tools
Angular 32-11, 32-16
Balloon 32-12
Center Mark 32-11
Diameter 32-10
Horizontal 32-5, 32-16
Oblique 32-8, 32-16
Radial 32-9
Smart 32-16
Vertical 32-6, 32-16

DIN crosshatching 25-6
DIN dimension standard 32-23, 32-24
direction

change 5-11
disjoint blend 25-9

edge to face 25-10
face to face 25-10

displacement
see also roughness
shader 39-22
wrapped 39-22

display
edit objects 5-21
isolines 49-5
preferences 49-5
resolution 49-5
silhouette 49-6

Display Last Image command 40-12
Distance Pt-Pt command 29-2
Divide at Location tool 15-7
Divide tool 15-6
documentation 1-1

margin notes 1-1
style conventions 1-2

Draft 27-1
draft angle

extrude solid 24-7
lathed solid 24-2

draft angle analysis 29-19
draft angle evaluation

advanced rendering 29-26
Verify menu 29-24

draft face
local face modeling 27-1

Draft Surface tool 19-4
draft. See also taper
Drafting Assistant 3-1

% point 3-6, 49-7
alignment angles 3-6, 49-7
axis locking 3-3
construction lines 3-6
creation angles 3-6, 49-7
customizing 3-4

hit radius 3-5, 49-7
permanent construction lines 3-8
preferences 3-5, 49-6
Snap command 3-4
snap options 3-4
snap points 3-2
snapping to geometry 3-1
solid 22-3

drawing
area 2-2, 2-15
Drafting Assistant 3-1
full scale 6-11
object creation methods 6-1
Status Line 6-2
techniques 6-1

drawing composition 44-1
drawing view 44-5
Model to Sheet command 44-1
Sheet tools 44-23
unfold views 44-20, 44-23

drawing size
format 46-6
page breaks 46-10
page tiling 46-6
scale 46-7
short cut 46-12

drawing view 44-5
activating 44-6
align 44-10
center 44-11
change 44-11
delete 44-10
dimension 32-25
edit objects 44-20
edit view 44-22
flatten view 44-12
frame to extents 44-12
menu 44-6
properties 44-6
right mouse button 2-11
scale 5-22, 44-5
tool 44-13

Dual side dimension standard 32-23, 32-24
Dual stacked dimension standard 32-23,
32-24
duplicate

linear 8-10
polar 8-13

DWG
export 43-10
import 43-3

DXF
export 43-11
facet files 43-4
import 43-4

dynamic
Pan tool 35-9
render 35-3
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Rotate tool 35-16
Zoom tool 35-9

E
edge

color 49-6
tolerant (stitched solid) 26-6

edge to face blend 25-10
edge to face roll blend 25-11
edit

background shader 39-24
crosshatching 25-7
drawing view 44-22
drawing view objects 44-20
foreground shader 39-24
lights 38-15
menu 2-15
parameter 5-34
pattern 10-7
render material 39-17
symbols 34-3, 34-7
text 31-5

edit a material E-13
edit objects

attributes 5-22
command 5-19
dimension 32-4
display 5-21
entering values 5-20
geometry 5-20
selecting 4-5

editing commands 5-1
Editing tools

Chamfer 15-1
Divide at Location 15-7
general 15-1
Join 15-8
solid 22-3
surface 20-1
trim 15-4

Elevate Curve tool 14-10
elevate degree (surface) 16-5
elevation (view) 35-13
Ellipse tools 12-1

2-Point Center 12-2
3-Corner 12-4
3-Point Center 12-3
modify ellipse 12-5
Opposite-Corner 12-3

Ellipsoid Primitive tool 23-16
1 Point 23-16
2 Point 23-16
By diagonals 23-17

elliptical blend 25-6
endpoint 3-2
entire object extents (selection) 4-3
Entity Color 49-16
EPS export 43-14
erase geometry 5-3

escape key 6-12
evaluation

surface 29-9, 29-10, 29-22
exit 42-5
expand (Design Explorer)

branch 5-34
item 5-34

Expand/Shrink tool
differential 8-5
uniform 8-5

Explode Edge tool 15-16
export 43-9

ACIS SAT 43-14
Adobe Illustrator 43-18
Catia v4 43-18
CGM 43-14
command 43-18
DWG 43-10
DXF 43-11
end of line 43-9
EPS 43-14
Facet 43-16
Graphite/Vellum 3D 43-10
IGES 43-14
Macromedia 43-18
options 43-9
pict 43-18
ProE/Granite 43-18
Raw 43-18
solids 22-7
STL 43-16
surfaces 16-4
tips 43-19
type 43-9
Vellum Draft 43-10
Vellum Solids 43-10
VRML 43-17

expression parsing 2-13
extrude

curve 15-16
mesh 30-4
solid 24-4

Eye Dropper tool 4-14
F
face

draft 27-1
match 27-3
move 27-4
offset 27-6
remove 27-7
replace 27-8
solids 22-1

face to face blend 25-10
facet

export 43-16
import 43-6

Fair Spline tool 14-11
feature
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move 5-33
remove 5-34
reorder 5-33
suppress 5-32
unsuppress 5-30, 5-32

feature interaction
blend 25-3
chamfer 25-17

Feature tools 22-3
associative 25-1
Blends 25-2
Boss 25-29
Cutout 24-11
Holes 25-25
Protruded 24-12

file 43-7
auto save 42-5, 49-10
backup 42-5
close 42-5
compact 49-10
exit 42-5
lock 42-6
management 42-1
name 42-3
native picture formats 49-9
new 42-2
open 42-3
preferences 42-5, 49-9
recent list 42-3, 49-10
revert 42-5
save 42-4
short cuts 42-1
size 42-6

fill
color 25-1, 25-4
holes 25-3
overlapping objects 25-3
pattern 25-1

Fillet Surface tool 19-5
Fillet tools

2-Entity 15-2
3-Entity 15-2

fixed width
variable blend 25-14
variable chamfer 25-24

flat render 35-3
flatten view 44-12
Fly By animation 41-5
Focal Point E-7
font 31-3

dimension 32-18
plotter 46-13

font (default) 49-21
foregrounds

applying 39-13
color 49-3
editing 39-24
library 39-2, 39-13

settings 39-25
types 39-25

format
drawing size 46-6

four lengths variable chamfer 25-22
Frame to Extents command 44-12
front view 35-11
full scale 6-11
G
G1 surface 21-2
G2 surface 21-3
gain (deform face) 27-12, 27-14
Gaussian plot 29-15
global

coordinate system 6-5
work plane 6-6

Glossary G-1
Gouraud render 35-3
Graphite/Vellum 3D

export 43-10
grid

color 49-13
preferences 49-12
Show command 2-15
Snap command 2-15, 6-11
spacing 49-12

group
command 5-7
objects 5-7
selection 5-7

H
Hatch command 25-7
Helix Curve

creating a helix 14-6
Helix Curve Tool 14-3
Helix Curve tool 14-6

pitch 14-6
hidden

lines 44-2, 44-7
render 35-4

hide
axis 6-10
command 35-17
layer 36-5
points 6-11
Triad 6-10
work plane 6-11

histogram 29-14
hit radius 3-5, 49-7
hold line blend 25-15
Hole Feature tools 25-25

Counter Bore 25-28
Counter Sink 25-28
direction 25-27
Simple 25-27
Through Types 25-26

Horizontal Dimension tools 32-5
Base Line 32-6
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Chain 32-6
Horizontal 32-16
Ordinate 32-8

Horizontal Section View tool 44-16
Horizontal Text tool 31-1
hot spot 2-11
HPGL 46-13
I
IGES

export 43-14
import 43-5

image (shader) 39-21, 39-22, 39-23
Image Based Textures E-18
import 43-1

ACIS SAT 43-6
Adobe Illustrator 43-7
auto heal bodies 43-2
command 43-7
DWG 43-3
DXF 43-4
facet 43-6
IGES 43-5
options 43-2
pict 43-6
spline points 43-7
symbols 34-7
tips 43-8
type 43-2
Vellum 3D 43-2
Vellum Solids 43-2

increment layer 36-7
inertia (moment of) 29-4
Infinite Plane tool 17-1

3 Pts In Plane 17-2
Along Curve 17-2
Clipping Planes 17-4
Normal Location 17-2
X, Y, Z Station 17-2

influence (spline) 14-4
Inscribed Polygon tool 13-4

scribe type 13-5
show frame 13-5

insert knot 21-6
Insert tool (assembly) 28-4
instance 1-2

solid 22-5
intensity (lighting) 38-3
Interference command 29-4
intersect

curve/solid 20-8
curve/surface 20-8
plane/curve 20-3
plane/solid 20-4
plane/surface 20-3
solids 26-3
surface/solid 20-7
surface/surface 20-7
surfaces 20-9

Invert command 35-18
ISO crosshatching 25-5
ISO dimension standard 32-23, 32-24
isolines 5-5, 49-5
isometric view 35-11
isopram lines 5-5, 49-5
item (Design Explorer)

collapse 5-34
expand 5-34

J
JIS dimension standard 32-23, 32-24
Join tool 15-8
K
key

arrow nudge distance 49-12
escape 6-12
short cut 49-21, 49-23

L
Lathed Solid tool 24-2
law curve blend 25-13
layer 36-1

auto 20-2
change 5-6
color 36-3, 36-8
copying/pasting 36-9
creating 36-4
decrement 36-7
default 36-4
delete 36-3, 36-5
dimension 32-4, 32-20
hide 36-5
increment 36-7
isolate 36-5, 36-7
lock 36-3, 36-6
manager 36-2
new 36-3
rename 36-4, 36-5
show 36-6
unlock 36-6
work 36-2, 36-7

layout 44-2
creating 44-23
lighting 38-16
menu 2-16
modify 44-23
printing 44-24
templates 44-23

length angle constant chamfer 25-19
Length command 29-2
lengths angles variable chamfer 25-23
library

Backgrounds 39-2, 39-12
Decals 39-2, 39-7
Foregrounds 39-2, 39-13
Materials 39-2
Render 39-1

Light tools
Point 38-5
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Spot 38-3
light’s distance E-10
lighting 38-1

ambient 38-14
attenuation 38-4
color 38-14, 38-15
delete 38-16
directional 38-1
edit 38-15
enable 38-3
intensity 38-3
layouts 38-16
modify 38-14
move 38-14
palette 38-1
render 35-8, 38-19
shadows 38-3, 38-4, 38-6, 38-8, 38-

10, 38-11, 38-13
Line Pattern manager 10-6
Line tools 11-1

Connected Lines 11-3
Parallel Line 11-4
Point 11-5
Single Line 11-1

linear blend 25-12
linear duplicate 8-10
lines (modifying) 11-6
links 5-25

remove 5-26
list/entry box 2-19
Local Face Modeling tool

draft 27-1
match face 27-3
Modifying Taper 27-6
move face 27-4
offset face 27-6
remove face 27-7
replace face 27-8

Local Face Modeling tools 27-1
Local Surface Tools

elevate degree 16-5
insert knot 21-6
untrim 16-5

Local Surface tools 21-1, 29-1
Match Surface 21-1
Rebuild Surface 21-4

localization (preferences) 49-14
location indicator 2-2, 2-12
lock

files 42-6
layer 36-3, 36-6
normal (decals) 39-10
objects 5-8

Lofted 19-2
Lofted Solid tool 26-8

bulge factor 26-8
error 26-8

Lofted Surface tool 19-2

Lop Solid tool 26-11
M
Macintosh

page setup 46-12
Macromedia

export 43-18
margin notes 1-1
masking (decals) 39-10
match face 27-3
Match Surface tool 21-1

G1 slope 21-2
G2 slope 21-3

Mate tool (assembly) 28-2
material

crosshatching 25-5
Properties command 29-3
Render library 39-2
user-defined 39-14

material Categories E-13
material editing 39-17
mathematical operators A-1
menu 1-1

choosing commands 1-1, 2-16
dimension 2-16
displaying 2-16
drawing view 44-6
Edit 2-15
Layout 2-16
Pen 2-16
PhotoRender 2-16
Planes 2-16
submenu 2-17
Text 2-16
toggling commands 2-19
Trackball 6-9
Verify 2-16
View 2-16
Window 2-16

menu bar 2-2
mesh

aspect ratio 5-16, 5-18
count 5-16, 5-18
normal deviation 5-16, 5-18
smoothing 5-18
surface deviation 5-16, 5-18

Mesh tools
3 Pts 30-2
4 Pts 30-2
Curve 30-3
extrude 30-4
rendering 30-5
spacing 30-3

Message Line 2-2, 2-12, 6-6
Metal E-16
midpoint 3-2
Minimum Distance command 29-2
Mirror tool 8-7

2 Pts 8-8
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3 Pts 8-9
XY plane 8-8
ZX plane 8-9
ZY plane 8-8

mitered blend 25-8
mitered constant chamfer 25-21
Model to Sheet command 44-1

layouts 44-2
undoing 44-4

modeling
solid 22-1
surface 16-1
wireframe 7-1

Modify Slope tool 14-8
explicit 14-8
free 14-8
reference 14-8
reverse 14-8

modifying
ellipses 12-5
layout 44-23
lighting 38-14
lines 11-6
parting line solid 27-11
tapered solid 27-6
view 35-14

moment of inertia 29-4
mouse 1-3

arrow pointer 1-3
click 1-3
double-click 1-3
drag 1-3
pointer 1-3
right button 2-5
selection arrow 1-3
smart pointer 2-11

Move 27-5
move

dimension 32-3
face 27-4
feature 5-33
light 38-14
objects 8-21
origin 37-7
text 31-5
tools 8-2

movie
Fly By 41-5
Paths 41-5
VR Object 41-7
VR Panoramic 41-9
Walk Through 41-4

multi-radius blend 25-8
N
n# sections 18-5
normal deviation (mesh) 5-16, 5-18
normals plot 29-20
n-sided 18-9

nurb splines 14-1
O
Object Counts command 29-7
object resolution E-2
object type (preferences) 49-5
objects 35-18

align 5-9
area 29-2
arrange 5-8
change type 5-12
check 29-7
copy 8-23
count 29-7, 36-3
crosshatching 25-7
dimensions 32-3
direction 5-11
drawing view 44-20
edit 5-19
group 5-7
hide 35-17
interference 29-4
length 29-2
lock 5-8
move 8-21
properties 29-3
selecting 4-1
show 35-17
show All 35-17
sizing 8-24
transparency 40-8
ungroup 5-8
unlock 5-8
volume 29-3

Oblique Dimension tool 32-8, 32-16
Off Screen Objects E-8
offset

construction lines 3-9
curve 15-9
dimension 32-23
linear duplicate 8-11
solid face 27-6
Surface tool 19-1
work plane 37-8

Offset Curve tool
by point 15-11
to value 15-10

one edge vertex blend 25-9
open file 42-3
Opposite-Corner Ellipse tool 12-3
Opposite-Point Circle tool 11-5
Option button 2-18
ordinate dimension

horizontal 32-8
orientation (blend) 25-4
origin

move 37-7
set 37-7
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P
page breaks (drawing) 46-10
page setup 45-1
page tiling 46-6
palette 2-2

Assembly Modeling 28-1
Color 10-3
Dimension 32-1
floating 2-3
Lighting 38-1
Render library 39-2
selecting a tool 2-3
Sheet tools 44-23
Solid 22-2
subpalette 2-4
Surface 16-2
Symbols 34-1
tear away 2-5
Wireframe 2-4

pan
view 35-11

pan (movie) 41-8, 41-9
Parallel Dimension tool

see Oblique Dimension tool
Parallel Line tool 11-4
param (blend) 25-13
param (chamfer) 25-24
Parametric Constraints 47-1

Sketch Mode 47-1
Sketch Mode Exiting 47-2

parent/child 1-3
partial objects extents (selection) 4-3
Parting Line Solid tool 27-9

modifying 27-11
pull-direction 27-9
taper (draft) 27-10

paste
command 5-2
objects/layer 36-9
solids 22-7
Status Line entries 2-13, 6-3
surfaces 16-4

Paths animation 41-5
pattern

choosing pen 10-8
construction line 10-8
creating 10-6
crosshatching 25-4
DIN crosshatching 25-6
editing 10-7
fill 25-1
ISO crosshatching 25-5
manager 10-6
new 10-6
pen 10-5

pen
arrowheads 10-8
characteristics 10-1

color 10-2
default settings 49-21
menu 2-16
pattern 10-5
pattern manager 10-6
settings 10-1
style 10-1
weight 10-4

permanent construction lines 3-8
perpendicular 3-3
photorealistic E-1

commands 40-9
rendering 40-7
settings 40-7

pick box 4-2, 49-16
Pick Objects command (plane) 37-6
pict

export 43-18
import 43-6

pitch (helix) 14-6
pixels (pen weight) 10-4
planar wrap (decals) 39-8
plane 37-1

3 Pt 37-6
pick objects 37-6
views 35-19
work 37-2

plane (work) 6-6
Plane/Surface Intersection tool 17-3, 20-1
Planes menu 2-16
Plotter fonts 46-13
point operations

selectable points 4-9
selecting 4-7
show/hide 4-7, 6-11

Point tools 11-5
Along a Curve 11-5
Along a Surface 11-6
At XYZ Location 11-5
Light 38-5
marker 11-5

pointer 1-3, 2-2
location indicator 2-12
smart 2-11
solids 20-1

polar duplicate 8-13
Polygon from Curves tool 13-8

show frame 13-8
Polygon tools

Arbitrary 13-7
Circumscribed 13-5
Inscribed 13-4
Polygon from Curves 13-8
Rectangle 13-2
Single Line 13-1
Smart Polygon 13-1

PostScript 46-13
pre-defined views 35-11
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preferences 49-2
changing settings 49-20
color 49-3
command 49-20
dcm 49-4

fixed constraint 49-4
fully defined constraint 49-4
over defined 49-4
over defined constraint 49-4
under defined constraint 49-4

display 49-5
Drafting Assistant 3-5, 49-6
file 42-5
filing 49-9
general 49-11
grid 49-12
localization 49-14
object type 49-5
resolution 49-5
selection 4-2, 49-15
short cut 49-21
units 49-19
user interface 49-11
view definitions 49-12

preview sample (shader) 39-19
primitive (ellipsoid) 23-16
Primitive tools 22-2

Block 23-4
Cone 23-8
Cylinder 23-6
Prism 23-12
Pyramid 23-14
Slab 23-3
Sphere 23-1
Torus 23-10

print 46-1
boundaries 46-13
command 46-13
layout 44-24
region 46-13
render 46-14
setup 46-12
to file 46-13
Window command 46-14

Print Layout Command 46-1
Prism Primitive tools 23-12

1 Point 23-12
2 Point 23-13
Diagonals 23-13

ProE/Granite
export 43-18

Profile Solid tools
curve checks 24-17
extrude 24-4
Lathed 24-2
Skinned 24-14
Swept 24-9

Profile tools 22-2

project
curve 15-13
curve/solid 20-6
curve/surface 20-6

Project Curve tool
plane options 15-14
projection options 15-15

Properties command 29-3
center of gravity 29-4
density 29-4
material 29-3
moment of inertia 29-4
volume 29-4
weight 29-4

Properties command (planes) 37-4
Protruded Feature tool 24-12

curve check 24-13
termination types 24-12

pull-direction (parting line solid) 27-9
Pyramid Primitive tools 23-14

1 Point 23-14
2 Point 23-15
diagonals 23-15

Q
QuickTime movie

compressor 41-3
Fly By 41-5
Paths 41-5
VR Object 41-7
VR Panoramic 41-9
Walk Through 41-4
with camera movement 41-1

R
Radial Arrow Dimension tool

In 32-9
Out 32-9

radial blend 25-5
ratio (elliptical blend) 25-6
Raw export 43-18
ray cube (background) 39-25
ray trace

commands 35-3, 40-10
reflections 40-8
shader 39-22

Rebuild Surface tool 21-4
recent file list 42-3, 49-10
Rectangle tools 13-2

Center/Axis 13-3
Center/Corner 13-2
Diagonal 13-2

redo 5-3
redraw screen 35-17
reflectance shader 39-22

decals 39-23
ray trace 39-22
wrapped 39-23

Reflective Objects E-8
reflectivity 5-23, 39-17
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Relimit tool 15-5
remove

control point (spline) 14-7
face 27-7
feature 5-34
links 5-26

rename
rename (Design Explorer) 5-30

render
anti-alias 40-8
applying materials 39-5
Backgrounds library 39-2, 39-12
copying characteristics 4-14
Decals library 39-2
display last image 40-12
Eye Dropper tool 4-14
Foregrounds library 39-2, 39-13
image files 40-12
library 39-1
lighting 35-8, 38-1, 38-19
Materials library 39-2
menu 2-16
mesh 30-5
photorealistic 40-7, 40-9
print 46-14
ray trace 40-8
reflectivity 5-23, 39-17
roughness 5-23, 39-18
shade options 35-2
shader 39-19
shadows 5-23, 39-18
textures 5-23, 39-18
to file 40-11
transparency 5-23, 39-17, 40-8

render area 40-10
render options

dynamic 35-3
flat 35-3
Gouraud 35-3
hidden 35-4
static 35-3
view rotations 35-7

reorder feature 5-33
replace face 27-8
resolution

change 5-4
deform face 27-15
isolines 5-5
preferences 49-5
silhouettes 5-5
solid 22-4
surface 16-3
wireframe 7-3

revert file 42-5
Revolve Curve tool 15-12
Revolved Surface tool

About a Curve 18-11
About Two Points 18-11

rho (conic) 12-5
Rib Solid tool 26-9
right mouse button 2-5

color 2-8
copy as instance 2-10
copy part history 2-10
drawing view 2-11
edit objects 2-9
hide all 2-7
hide/show only 2-8
layer 2-9
object characteristics 2-10
object name 2-9
over an object 2-8
over no object 2-6
planes 2-6
resolution 2-8
select all 2-6
show all 2-7
transparency 2-10
view 2-6

right-hand rule 2-14
rotate

decals 39-9
dynamic (view) 35-16
view 35-13, 35-16

Rotate tools 8-3
1 Pt 8-3
3 Pts 8-4

roughness
Edit Objects 5-23, 39-18
see also displacement

Rule of Thirds E-7
rules

Design Explorer 5-35
grouping 5-7
local face modeling 27-1
relimit 15-5
right-hand rule 2-14
sweep surface 18-15

S
SAT

export 43-14
import 43-6

save 42-4
auto 42-5, 49-10
save as 42-4

scale
differential 8-5
drawing size 46-7
drawing view 44-5
full 6-11
ignore 5-22
ignore (drawing view) 44-5
material 5-23, 39-18
sheet 44-5
uniform 8-5

screen horizontal
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text 31-5
scribe type

circumscribed polygon 13-6
inscribed polygon 13-5

scroll bars 2-2, 2-15
Section 1

Create the Environment E-2, E-9
Section 2

Lighting the Environment E-9
Section 3, Make the Environment Come
Alive E-13
Section View tools 44-15

2 Pts 44-16
crosshatching 25-7, 44-17
Horizontal 44-16
Vertical 44-15

Segment tool 15-7
selected points 49-16
selection

ambiguity popup 4-6, 49-16
chain 4-11
color 4-3
control point 4-8
deselecting 4-11
edit objects 4-5
entity color 49-16
fence 4-2, 49-16
Group command 5-7
hollow arrow 20-1
objects 4-1, 4-4, 4-9
pick box 4-2
points 4-7
preferences 4-2, 49-15
select all 4-9
selected points 49-16
selection mask 4-9
tool 2-3, 4-4
transparency 4-4, 49-16
wire weight 4-3, 49-16

selection transparency 49-16
set origin 37-7
shade now 35-2

command
render

shade now 35-2
Shade Options 35-2
shader

attribute value 39-19
attributes 39-19, F-1
backgrounds 39-25
class 39-19
foregrounds 39-25
preview sample 39-19
texture projection 39-23
types 39-19

shader class 39-19
color 39-21
displacement 39-22

reflectance 39-22
texture space 39-23
transparency 39-23

shader types 39-19
shadow casting (lighting) 38-3, 38-4, 38-6,
38-8, 38-10, 38-11, 38-13
Shadows E-11
Shadows with Gel Images E-12
Sheet tools 44-23

Auxiliary View 44-13
Detail View 44-18
drawing view 44-13
Model to Sheet command 44-1
Section View 44-15

short cut
creating 49-23
file 42-1
list C-1
preferences 49-21
view rotation 6-10

short cut (tool tip) 49-21
shoulder point (conic) 12-5
show

axis 6-10
command 35-17
control point 4-7
Dimension palette 32-2
layers 36-6
points 6-11
Show All command 35-17
Show Only command 35-18
silhouettes 5-5
Triad 6-10
work plane 6-11, 37-2

show frame
arbitrary polygon 13-7
circumscribed polygon 13-6
inscribed polygon 13-5
polygon from curves 13-8

show work plane 37-4
side view 35-11
silhouettes 5-5, 49-6
Simple Hole tool 25-27
Simple Trim tool 15-4
Simplify object

change 5-19
edit 5-19

simplify object
command 5-19

simplify surfaces (stitched solid) 26-5
Single Line tool 11-1
size

dimension 32-18
objects 8-24
text 31-4

Sketch Mode 47-1
Animating Dimensions Tool 47-8
Auto Constraints Tool 47-2
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Coincident Constraint Tool 47-3
Colinear Constraint Tool 47-7
Concentric Constraint Tool 47-6
Constraint Preferences 47-9
Deleting Constraints 47-9
Equal Constraint Tool 47-7
Exiting 47-2
Fixed Constraint Tool 47-6
Horizontal Constraint Tool 47-3
Offset Constraint Tool 47-8
Parallel Constraint Tool 47-5
Perpendicular Constraint Tool 47-5
Sketch Tool 47-2
Symmetric Constraint Tool 47-7
Tangent Constraint Tool 47-5
Verifying Constraint Relations 47-9
Vertical Constraint Tool 47-3

sketch spline
creating a spline 14-5

Sketch Spline tool 14-5
Skin Solid tool

guides 24-17
Skin Surface tool

basic 18-6
closed skin 18-6
guides 18-7
n# sections 18-5
standard 18-5

Skinned Solid tool 24-14
basic 24-16

Slab Primitive tool 23-3
slope (conic) 12-5
smart

hot spot (pointer) 2-11
pointer 2-11
polygon 13-1

Smart Dimension tool 32-16
Snap command 3-4
solid

associativity 22-5
cutting/pasting 22-7
display edges 22-4
Drafting Assistant 22-3
exporting 22-7
instances 22-5
modeling 22-1
resolution 22-4
tools 22-2

Solid Editing tools
Assembly Modeling 28-1
Boolean 26-2
Chamfer Edge 25-16
Features 22-3

solid modeling
Ellipsoid Primitive tool 23-16
error messages 22-7

Solid Utility tools 26-1
Intersect Solid 26-3

Lip Solid 26-11
Local Face Modeling Tools 27-1
Lofted Solid 26-8
Parting Line Solid 27-9
Rib Solid 26-9
Split Solid 26-5
Stitched 26-5
Subtract Solid 26-2
Thicken Solid 26-6
Union Solid 26-2

Solids Creation tools
Primitives 22-2
Profiles 22-2

special characters B-1
Sphere Primitive tools 23-1

1 Point 23-2
2 Point 23-2
Diagonals 23-2

spherical wrap (decals) 39-8
spline

control point 14-2, 14-3
creating text files D-1
import points 43-7

Spline tools 14-1
Add Control Point 14-7
Bezier 14-4
Elevate Curve 14-10
Fair Spline 14-11
Helix Curve 14-6
influence 14-4
Modify Slope 14-8
nurbs 14-1
Remove Control Point 14-7
Sketch Spline 14-5
Through-Points B-Spline 14-2
Vector 14-3

Split Solid tool 26-5
Spot Light tool 38-3

cone angle 38-5
falloff angle 38-5
falloff rate 38-5

Stacked fraction dimension standard 32-
23, 32-24
static render 35-3
Status Line 2-2, 2-12, 6-2

copying/pasting entries 2-13, 6-3
expression parsing 2-13
units 6-3
world coordinate system 2-13

stencil (decal) 39-11
Stitched Solid tool 26-5

gap size 26-5
options 26-5
simplify surfaces 26-5
tolerant edges 26-6

STL export 43-16
stretch (deform face) 27-14
stroke construction lines 3-8
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stroke zoom 35-10
style

dimension 32-19
pen 10-1
text 31-4

submenu 1-1, 2-17
subtract

solid 26-2
surface 20-9

suppress feature 5-32
surface

associativity 16-4
cutting/pasting 16-4
Editing tools 20-1
evaluation 29-9
exporting 16-4
Mesh tools 30-1
modeling 16-1
resolution 16-3
tools 16-2

surface analysis
advanced rendering 29-22
curvature plot 29-13
draft angle 29-19, 29-24
Gaussian 29-15
histogram 29-14
normals plot 29-20
Verify menu 29-10
zebra plot 29-21

Surface Creation tools
Cover Surface 18-9
Draft Surface 19-4
Fillet Surface 19-5
Infinite Plane 17-1
Lofted Surface 19-2
Offset Surface 19-1
Sweep Surface 18-12
Tube Surface 18-15

surface deviation (mesh) 5-16, 5-18
Surface Editing tools

Boolean Surface 20-8
Connect Surface 20-10
Curve/Surface Intersection 20-7
Curve/Surface Projection 20-4
Plane/Surface Intersection 20-1
Split Surface 20-10
surface evaluation 29-9
Surface/Surface Intersection 20-7
untrim 16-5

Surface From Curves Tools 18-1
Net Surface Tool 18-1
Surface Tools 17-10, 18-1

Surface from Curves Tools
Net Surface 18-1

Surface/Surface Intersection tool 20-7
Sweep Surface tool

Along 1 Rail 18-13
Along 2 Rails 18-14

Sweep Surface tool Along 2 Points 18-12
Swept Solid tool 24-9
symbol 34-1

1 Point tool 34-4
2 Point tool 34-4
creating 34-3
edit 34-3, 34-7
files 34-7
importing 34-7
manager 34-2
palette 34-1
transforming 34-6

T
tangent 3-3
Tangent Surface tool

bulge factor 19-3
tangent-point

arc 11-3
circle 11-6

taper
parting line solid 27-10

text
case 31-5
convert to curves 5-14
default settings 49-21
dimension font 32-18
dimension size 32-18
dimension style 32-19
dimension text 32-17
drawing view 44-5
editing 31-5
font 31-3
menu 2-16
move 31-5
screen horizontal 31-5
size 31-4
style 31-4

Text tools 31-1
Along a curve 31-2
At an angle 31-2
box 31-3
Horizontal 31-1

texture (shader) 39-21
texture projection shader 39-23
texture space shader 39-23
textures 5-23, 39-18
Thicken Solid tool 26-6
Through-Points B-Spline tool 14-2
tile

page 46-6
tilt (movie) 41-8
tips

exporting 43-19
import 43-8
tool 2-2

title bar 2-2
toggling commands 2-19
tolerances (dimension) 32-16
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tool tip 2-2
short cut 49-21

tools
Arc 11-1
Circle 11-1
Conic 12-1
Ellipse 12-1
Line 11-1
Mesh 30-1
Polygon 13-1
Rectangle 13-2
Selection 4-4
solid modeling 22-2
Solid Utility 22-3
surface modeling 16-2
wireframe 7-2

top view 35-11
Torus Primitive tools 23-10

1 Point 23-10
2 Point 23-11
Diagonals 23-11

Trackball 6-6
Axis Locking 6-6
rotation options 6-7, 6-8
save view 35-14
Sphere 6-7
Step 6-7
view menu 6-9

Transformation tools 8-1
Align 8-21
Copy Along Path 8-9
Linear Duplicate 8-10
Mirror 8-7
Move 8-2
Polar Duplicate 8-13
Rotate 8-3

transparency
Edit Objects 5-23, 39-17
selection 4-4
shader 39-23
shadows 40-8
wrapped 39-23

Transparent Shadows E-12
Triad 2-2, 2-14

show/hide 6-10
trim operations

surface/curve 20-11
surface/solid 20-11
surface/surface 20-11

Trim Solid Tool 26-3
Trim tools 15-4

Corner 15-7
Divide 15-6
Divide at Location 15-7
Relimit 15-5
Segment 15-7
Simple Trim 15-4
Surface 20-10

untrim surface 16-5
trimetric view 35-12
Tube Surface tool 18-15
turbulent (shader) 39-21
twist angle (swept solid) 24-9
two edge vertex blend 25-9
two lengths constant chamfer 25-19
U
u/v lines 5-5, 49-5
undo 5-3
unfold view 44-20, 44-23
ungroup 5-8
uninstalling 42-6
units

mixed 32-4
pen weight 10-4
precision 2-13
preferences 49-19
setting 32-4
Status Line 6-3

unlock
layers 36-6
objects 5-8

unsuppress feature 5-30, 5-32
untrim surface 16-5
Use View command (plane) 37-5
user interface 49-11
user-defined

coordinate system 6-5
standard 32-25
work plane 37-3

user-defined views 35-12
Utility tools (solid) 22-3
uv shader 39-23
V
variable blend

by position 25-12
fixed width 25-14
hold line 25-15
law curve 25-13
linear 25-12

Variable Blend tool 25-12
variable chamfer

by position 25-24
fixed width 25-24
four lengths 25-22
lengths 25-22
lengths angles 25-23

Variable Chamfer Edge tool 25-21
variable lengths chamfer 25-22
Variables and Equations 48-1

Adding Equations 48-3
Highlighting Dimensions in the Sketch

48-2
Using Equations 48-1

Vector Spline tool 14-3
Vellum 3D

import 43-2
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Vellum Draft export 43-10
Vellum Solids

export 43-10
import 43-2

Verify commands
Angle 3 Pts 29-1
Area 29-2
Check Object 29-7
Distance Pt-Pt 29-2
Interference 29-4
Length 29-2
Minimum Distance 29-2
Object Counts 29-7
Properties 29-3
Volume 29-3
X,Y,Z 29-1

Verify menu 2-16, 29-1
vertex blend 25-7
vertex chamfer 25-20
Vertical Dimension tools 32-7

Base Line 32-7
Chain 32-7
Vertical 32-16

Vertical Section View tool 44-15
view

azimuth 35-13
delete 35-15
drawing 44-5
dynamic rotate 35-16
elevation 35-13
menu 2-16
Modify command 35-14
New View command 35-12
pan 35-11
planes 35-19
pre-defined 35-11
preferences 49-12
redraw screen 35-17
rotate 35-13, 35-16
rotation short cut 6-10
show/hide 35-17
Trackball 35-14
Trackball rotation 6-7, 6-8
unfold 44-20, 44-23
user-defined 35-12
view the plane 35-17
work plane 37-8
zoom 35-10, 35-19

View Angles E-6
Views pop-up menu 6-10
Volume command 29-3
VR Object movie 41-7
VR Panoramic movie 41-9
VRML export 43-17
W
Walk Through animation 41-4
weight

dimension 32-20

pen 10-4
Window menu 2-16
Windows

print setup 46-12
uninstalling 42-6

wire weight 49-16
selection 4-3

wireframe
Drafting Assistant 7-3
modeling 7-1
resolution 7-3
tools 7-2

witness lines 32-22
work layer 36-2, 36-7

indicator 2-2, 2-15, 36-5, 36-7
work plane 37-2

3 Pts 37-6
define 37-3
delete 37-4
dimensions 32-2
dimming 37-7
global 6-6
new 37-3
offset 37-8
origin 37-7
pick objects 37-6
properties 37-4
save current 37-4
setting 37-5
show 37-2, 37-4
show/hide 6-11
snapping 37-6
use view 37-5
user-defined 37-3
view the plane 37-8
views 37-8
world coordinate system 37-8

world coordinate system
Status Line 2-13
work plane 37-8

wrap (decal)
auto 39-10
cylindrical 39-8
planar 39-8
spherical 39-8

wrapped
displacement 39-22
image 39-21, 39-22, 39-23
reflectance 39-23
texture 39-21
transparency 39-23

X
X,Y,Z command 29-1
Z
zebra plot 29-21
zoom

all 35-8
commands 35-8
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dynamic 35-9
home 35-8
in 35-8

out 35-9
out 35-8
previous 35-8
ratio 35-9
stroke 35-10
tools 35-9
views 35-10, 35-19
window 35-8
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	First Look
	Parts of the Designer Elements Window
	Tool Palette
	1. Position the arrow pointer on the icon of the tool.
	2. Click the mouse button.
	1. Position the arrow pointer on the tool.
	2. Press the mouse button.
	3. Drag the pointer to highlight the desired tool.
	4. Release the mouse button.

	Right Mouse Button
	Selected Drawing View
	Smart Pointer & Wireframe Tools
	Location Indicator
	Message Line
	Status Line
	Coordinate System Axis
	Axis
	Triad
	Drawing Area
	Scroll Bars
	Work Layer Indicator

	Menu Bar
	1. Pull down the menu.
	2. Click on a command followed by an arrow symbol.
	3. Click on the submenu.
	4. Click the desired command.

	Update Installer
	Automated Support Ticket Preparation
	1. Tell us exactly what the difficulty is.
	2. Attach any files or screen captures to help us understand the issue.
	3. Include ALL contact information including an alternate email address, your cell phone and desk phone. Our support team does not have regular access to your sales file.
	4. Include a subject line descriptive of the problem.
	5. Make sure that you use your actual mail client.


	The Drafting Assistant
	Snapping onto Geometry
	Customizing the Drafting Assistant

	Drafting Assistant Construction Lines
	Using the Drafting Assistant’s Construction Lines
	1. Click a point to begin new geometry.
	2. Move the pointer away from the point horizontally, vertically, or at a 45° angle.
	3. While the construction line is visible and the Drafting Assistant displays on, click the next point.
	1. On selected geometry, without pressing the mouse button, move the pointer over an existing point.
	2. Move the pointer horizontally or vertically.
	3. While the construction line is visible and the Drafting Assistant displays on, click the desired point in the construction.


	Permanent Stroke Construction Lines
	1. Hold down the SHIFT+CTRL keys (Windows) or the z key (Macintosh). The pointer becomes the stroke pointer (z).
	2. Move the pointer near the center of the circle.
	3. Drag the mouse vertically or horizontally away from the midpoint.
	The Construction Command
	1. Click the Angle field.
	2. Drag a vector in the drawing area.
	1. Click the Offset field.
	2. Drag the offset distance in the drawing area.
	1. Click the X field.
	2. Enter new coordinates

	Creating Construction Geometry
	1. In the Layout menu, choose Layer Manager. (The dialog box will say Design Explorer because two boxes [Design Explorer and Layer Manager] are combined.)
	2. Click in the work layer column just to the left of Construction. (Move the pencil to that layer.)
	3. Click the Close button in the upper right corner of the window. The Layer Manager closes and the Construction layer is now the work layer. The Work Layer Indicator at the bottom left of the screen shows the current layer.
	4. Create the geometry for construction.
	5. When the construction geometry is complete, make another layer the work layer by changing the layer in the Layer Manager or the Work Layer Indicator.
	6. Continue the work.

	Removing Construction Lines

	Drafting Assistant and Display

	Selecting Objects
	1. Select the tool.
	2. Select the object to be modified.
	1. Select the object.
	2. Specify the action for the selected object.
	Objects
	Indicating Selection & Preferences
	Pick Box
	Select Fence
	Selection Color

	Selection Process
	Selecting Objects with the Selection Tool
	1. Click the Selection tool in the tool palette. The Message Line reads: Selection: Select [Shift=Extend, Ctrl (Windows) or Option (Macintosh) = Copy].
	2. Move the pointer to an object and click. The object is selected, and any previously selected objects are deselected.
	1. Choose the Selection tool in the tool palette.
	2. Move the pointer to an object and click.
	3. Press down the SHIFT key.
	4. While holding down the SHIFT key, click other objects to be selected.
	5. Release the SHIFT key.
	1. Click the Selection tool in the tool palette.
	2. Drag a selection fence around the objects to select.

	Selecting Points
	1. Select the geometry.
	2. Choose Edit>Show/Hide Points to toggle the display of points on and off.
	1. Chose the Selection tool.
	2. Drag a selection fence around the location of the point.

	Selecting Objects Using Other Tools
	Selecting Objects with Commands
	1. Choose Window>Selection Mask.
	2. Click the items to select so they are highlighted.
	1. Select the beginning of a curve as shown by the arrow in the left graphic below.
	2. Choose Edit>Select Chain.
	3. All objects connected to the start or end are selected, as in the right graphic below.

	Deselecting

	Deep Select Tool
	Using the Deep Select Tool to Apply a Color
	1. Select the Deep Select tool from the Selection tools palette. The Message Line reads: Deep Select: Pick solid faces [Shift = Extend].
	2. Select the face to be changed.
	3. Go to Pen>Color and choose the color desired.
	1. Select Deep Select tool, from the Selection tools palette. The Message Line reads: Deep Select: Pick solid faces [Shift = Extend].
	2. Choose the face and designate the material from the Window>Render Library menu.
	3. Right-click on the material and choose Apply to Solid Face(s).
	4. Alternatively, choose the material from the Render Library menu, right-click it and select Apply to Solid Face(s) from the context menu. Then choose the face of the solid. The material is applied.
	5. Render the object to see the changes.


	Eye Dropper Tool
	Using the Eye Dropper Tool
	1. Select the Eye Dropper tool from the Selection tools palette. The Message Line reads: Eye Dropper: Select objects to copy from. [Ctrl = Filter (Windows) or Option = Filter (Macintosh)].
	2. Select the object with the characteristics to be copied.
	3. If you do not want all object characteristics copied, press the CTRL (Windows) or OPTION (Macintosh) key to display the Eye Dropper Filter dialog box. Otherwise, skip to step 5.
	4. Deselect those items in the dialog box that do not need to be copied.
	5. Select the objects to receive the characteristics.



	Editing Objects
	Basic Editing Commands
	Cut
	1. Select the object to cut.
	2. Choose Edit>Cut.
	1. Select the object(s) to move.
	2. Choose Edit>Cut.
	3. Display the location where the selection will appear in the drawing area, scrolling if necessary.
	4. Choose Edit>Paste.

	Copy
	1. Select the object(s) to be copied.
	2. Choose Edit>Copy.

	Copy Pict/Copy Bitmap
	Paste
	1. If the object was cut or copied from a Designer Elements program document, when it is pasted into another Designer Elements program document it goes on the work layer regardless of the layer from which it was cut or copied. A pasted selection reta...
	2. Objects cut or copied from non-Ashlar-Vellum documents are pasted onto the work layer.

	The Clipboard
	Erasing/Deleting Geometry
	Undo
	Redo

	Advanced Editing Commands
	Change Resolution
	1. Select the object to change resolution.
	2. Choose Edit>Change Resolution. The Object Resolution dialog box appears.
	3. Select the desired resolution.
	4. Click OK to save the resolution and close the dialog box.
	1. Select the object to change resolution.
	2. Right-click the object. Choose Resolution option from the context menu.
	3. Select the desired resolution.

	Change Layer
	1. Select the object to move to a different layer.
	2. Choose Edit>Change Layer. The following Change Layer dialog box appears:

	Grouping Objects
	1. Select the objects to be grouped.
	2. Select Layout>Group>Group.
	1. Select the group.
	2. Choose Layout>Group>Ungroup. The geometry is ungrouped and the individual objects remain selected.
	3. Hold down the SHIFT key and select the geometry to add to the group.
	4. Choose Layout>Group>Group.
	1. Select the group.
	2. Choose Layout>Group>Ungroup.
	1. Select the objects to lock.
	2. Choose Layout>Group>Lock.
	1. Choose Edit>Select All.
	2. Choose Layout>Group>Lock.
	1. Choose Layout>Group>Unlock.
	2. Select the locked object by clicking on the object or dragging a selection fence around it. The locked object is unlocked and selected.

	Arrange Command
	Align Command
	1. Select the objects to align.
	2. Choose the alignment tool from the Transformation tool palette. Select the alignment option from the message line. The Message Line reads: Enter Alignment Point.
	3. Choose the point at which the objects will align.


	Object Commands
	Change Direction
	1. Select the object to change its direction.
	2. Click Edit>Change Direction.

	Change Object Type
	1. Create text using one of the Text tools.
	2. Choose Edit>Change Object Type.
	3. In the Change Type dialog box choose curves.
	4. Click OK.

	Simplify Object
	Edit Objects
	1. Select an object to edit.
	2. Choose Window>Edit Objects and the dialog box appears.
	3. Click on the tab containing the desired information.
	4. Change the information in an entry box by double-clicking the entry data field and typing a new entry. Do not press ENTER (Windows) or RETURN (Macintosh). Many data fields have pop-up menus for selection. Press the down arrow and then drag to the ...
	5. Make changes in other entry fields as required.
	6. Click Apply and the changes automatically occur on the selected geometry.
	7. Click Close to close the Edit Objects dialog box.
	1. Select the object(s) to be moved.
	2. Choose Window>Edit Objects.
	3. Click the arrow for the Layer entry field.
	4. Pick the layer from the list.
	5. Choose Apply.

	Links
	Design Explorer
	1. Select the model which contains the feature to suppress.
	2. Choose Window>Design Explorer to display the history tree.
	3. Expand the tree to display the desired feature by clicking on the plus (+) sign to the left of the part name.
	4. Select the desired feature.
	5. Click the right mouse button on a two-button mouse or press the CTRL key with a one-button mouse to display the Design Explorer menu.
	6. Choose the Suppress Feature command.
	1. In the Design Explorer select the suppressed feature.
	2. Click the right mouse button (Windows) or press the CTRL key with a one-button mouse to display the Design Explorer menu.
	3. Choose the Unsuppress Feature command.
	1. Select the part.
	2. Open the Design Explorer and display the tree to expose the feature to reorder.
	3. In the Design Explorer menu select the Reorder Feature command.
	4. Click on the operation below to move the selected operation.
	1. Select the feature in the Design Explorer to move. The feature is selected in the drawing area.
	2. Display the Design Explorer menu by clicking the right mouse button on a two-button mouse or pressing the CTRL key with a one-button mouse.
	3. Select the Move command. The Message Line appears guiding the appropriate steps.
	4. Click a new center on the solid. The feature is repositioned.



	Drawing Techniques
	Object Creation Methods
	Creating a Line by Clicking
	1. Click the Single Line tool in the main tool palette. The Message Line reads: Single Line: Pick beginning point [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].
	2. Move the pointer to the drawing area and click to set the starting point of the line.
	3. Move or drag the mouse to the desired location for the endpoint of the line. When doing so, a rubberband image of the line appears.
	4. Release the mouse button or click to set the endpoint.


	Status Line
	Using the Status Line
	Status Line Entries and Tool Operations
	Using the Status Line with Drawing Tools
	1. Select the Single Line tool. The Message Line reads: Single Line: Pick beginning point [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].
	2. Click two locations in the drawing area. The length (L) field automatically highlights in the Status Line.
	3. Type 3. The 3 is entered directly in the L field.
	4. Press the TAB key to select the next status field. The angle (A) field now highlights.
	5. Enter 15.
	6. Press ENTER (Windows) or RETURN (Macintosh).
	1. With the Single Line tool still selected from the previous example, click two more points.
	2. Type 4.
	3. Press the TAB key and type 25 in the Angle field.
	4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.
	1. Choose the Selection tool so the Status Line clears.
	2. Click the Single Line tool again.
	3. Type 0.
	4. Press the TAB key. The Y data field highlights.
	5. Type 0.
	6. Press the TAB key. The Z data field highlights.
	7. Type 0.
	8. Press the TAB key.
	9. Type 2.
	10. Press the TAB key. The dY data field highlights.
	11. Type 2.
	12. Press the TAB key. The dZ data field highlights.
	13. Type 0.
	14. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.

	Creating Geometry Offset from a Point
	1. Select the tool to be used.
	2. Move the pointer over the control point from which the offset is desired.
	3. Click once to lock onto that point.
	4. Finish creating the geometry.
	5. With the geometry still selected, click in the appropriate X, Y, or Z data field in the Status Line, placing the text cursor at the end of the entry.
	6. Type the offset (such as + 3) and press ENTER (Windows) or RETURN (Macintosh).
	7. Continue with the construction.


	Coordinate System Axis
	Choosing a Coordinate System
	1. Choose the coordinate system by clicking on the coordinate system axis icon at the far left of the Status Line.
	2. Choose the Global Work Plane or any user-defined work plane.
	3. Continue designing.


	Message Line
	Trackball
	Sphere Trackball
	1. Choose Window>Trackball.
	2. Drag the pointer on the Trackball to rotate the view.

	Step Trackball
	1. Choose Window>Trackball.
	2. Click on the arrow button on the right side of the Trackball title bar to change the display to the Step Trackball.
	3. Click one of the directional arrows. The model rotates a specified number of degrees. Or...

	Trackball View Menu
	1. Move the pointer to the current view name displayed at the bottom of the Trackball window.
	2. Press the mouse button.
	3. Choose the view orientation to be displayed in the current window.

	View Rotation Short Cut

	Drawing Display Commands
	Show/Hide Triad
	Show/Hide Axis
	Show/Hide Work Plane
	Show/Hide Points
	Grid

	Drawing at Full Scale
	1. Draw a line, specifying 83' for the length.
	2. Choose View>Zoom All.

	Default versus Selected Object Settings
	Escape Key

	Introduction to Wireframe Modeling
	Wireframe Tools
	Wireframes and the Drafting Assistant
	Wireframes, Selection and Display
	Changing an Object's Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.


	Objects Characteristics and Edit Objects

	Transforming Geometry
	Transformation Tools
	Geometric Characteristics
	Item vs. Faces
	1. Select the appropriate transformation tool.
	2. Click the Faces button in the Message Line.
	3. Select the face or faces to transform. To copy press CTRL.
	4. Select the beginning and ending reference points as directed by the Message Line.

	Move Tool
	1. Select the Move tool.
	2. Click the Item or Face icon in the Message Line. The Message Line reads: Move: Select objects to move. [Shift = Extend]
	3. Select the object(s) to be moved.
	4. If necessary, use SHIFT-click to select more objects, and then pick a beginning point. The Message Line now reads, Move: Pick ending reference point. [Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	5. Click an ending reference point or drag the selected object(s) to a new location.

	Rotate Tools
	1. Select the Rotate tool.
	2. Click the Item or Face icon in the Message Line.
	3. Select the Rotate by Angle tool in the Message Line. The Message Line reads: Rotate: Select items [or feature faces] to rotate. [Shift = Extend].
	4. Select the objects to rotate.
	5. Use SHIFT-click to select more objects.
	6. Select the rotation axis from the pull-down menu.
	7. Specify the center of rotation.
	1. Select the Rotate tool.
	2. Click the Item or Face icon in the Message Line.
	3. Select the Rotate 3 Points tool in the Message Line. The Message Line reads: Rotate: Select items [or feature faces] to rotate. [Shift = Extend]
	4. Select the objects to rotate.
	5. Click the rotation point.
	6. Click the first reference point.
	7. Click the second reference point.

	Resize/Scale Tool
	1. Select the Resize and Scale tool. In The Message Line reads: Resize and Scale: Select items [or feature faces] to scale [Shift = Extend].
	2. Click the Item or Face icon in the Message Line.
	3. Select the object(s) to scale. The option pull-down menu appears.
	4. Select the Uniform option from the menu. When moving the pointer into the drawing area the pointer becomes the expand/shrink icon, shown here.
	5. Click the anchor point on the geometry. This point remains fixed in the stretch. Use the SHIFT key to select more objects to stretch for this operation.
	6. Click the beginning reference point.
	7. Click the ending reference point. The scale factor is calculated based on the beginning reference point and this point.
	1. Select the Resize/Scale tool. The Message Line reads: Resize/Scale: Pick items [or feature faces] to scale. [Shift = Extend]
	2. Click the Item or Face icon in the Message Line.
	3. Select the object(s) to scale.
	4. Select the Differential option from the menu. When moving the pointer into the drawing area the pointer becomes the scale icon, shown here:
	5. Enter the X, Y and Z Scale values in the Status Line.
	6. Click a point about which the object will be scaled.

	Mirror Tool
	1. Select the Mirror tool. The Message Line reads: Mirror: Pick items [or feature faces] to mirror [Shift = Extend].
	2. Click the Face or the Item icon in the Message Line.
	3. Select the object(s) to be mirrored.
	4. Select the 2 Points option in the pull-down menu. The Message Line reads: Mirror: Pick beginning of reference line. [Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	5. Click a location to set the beginning of the reference line around which the object mirrors. The Message Line now reads, Mirror: Pick end of reference line. [Ctrl = Copy (Windows) or Option = Copy (Macintosh)]
	6. Click to locate the end of the reference line.
	1. Select the Mirror tool.
	2. Click the Item or Face icon. The Message Line reads: Mirror: Pick items [or feature faces] to mirror. [Shift = Extend]
	3. Select the object(s) to be mirrored.
	4. Select the XY Plane option in the pull-down menu. The Message Line reads: Mirror 1 Point: Enter 1 point for mirror origin. [Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	5. Click a point in the XY plane to specify a reference point for the mirror.
	1. Select the Mirror tool.
	2. Click the Item or Face icon. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	3. Select the object(s) to be mirrored. An option pull-down menu appears.
	4. Select the ZY Plane option in the pull-down menu. The Message Line reads: Mirror 1 Pt: Enter 1 point for mirror origin [Shift= Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)].
	5. Click a point in the ZY plane to specify a reference point for the mirror.
	1. Select the Mirror tool.
	2. Click the Item or Face icon. The Message Line reads: Mirror: Pick items [or feature faces] to mirror. [Shift = Extend]
	3. Select the object(s) to be mirrored. An option pull-down menu appears.
	4. Select the ZX Plane option in the pull-down menu. The Message Line reads: Mirror 1 Point: Enter 1 point for mirror origin. [Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	5. Click a point in the ZX plane to specify a reference point for the mirror.
	1. Select the Mirror tool.
	2. Click the Item or Face icon. The Message Line reads: Mirror: Pick items [or feature faces] to mirror. [Shift = Extend]
	3. Select the object(s) to be mirrored.
	4. Select the 3 Points option in the pull-down menu. The Message Line reads: Mirror 3 Points: Enter 3 points for mirror plane. [Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	5. Click three points to specify a reference plane for the mirror.

	Copy along Path Tool
	1. Select the Copy along Path tool.
	2. Select the Item or Face icon in the Message Line. The Message Line reads: Copy Along Path: Select items [or feature faces] to duplicate. [Shift = Extend]
	3. Select the objects to copy.
	4. Enter the number of objects to copy in the Qty (Quantity) field of the Status Line.
	5. Click the path curve. The Message Line reads: Copy Along Path: Enter copy origin.
	6. Click the point where the copy should begin. The Message Line reads: Copy: along Path: Enter two points for alignment axis.
	7. Pick two points on the screen to show where to align the object(s).

	Linear Duplicate Tool
	1. Select the Linear Duplicate tool.
	2. Select the Items or Faces icon in the Message Line.
	3. The Message Line reads: Linear Duplicate: Select objects for linear duplicate. [Shift = Extend]
	4. Select the object(s) to be duplicated. The dialog box appears.
	5. Enter the number of columns in the Number per row data field.
	6. Select offset option, either Total or Step.
	7. If the Offset X* field is not selected, click in the field.
	8. Move the pointer to the drawing area and drag to indicate the offset for the row of copies. Values automatically appear in the X*, Y* and Z* data fields.
	9. Select the spacing option, either Total or Step.
	10. If the Spacing* field is not selected, click in the field.
	11. Move the pointer to the drawing area and drag to indicate the spacing for the spacing for the rows.
	12. Click OK to close the dialog box and create the duplicates.

	Polar Duplicate Tool
	1. Select the Polar Duplicate tool
	2. Select the Items or Faces icon in the Message Line. The Message Line reads: Polar Duplicate: Select items [or feature faces] to polar duplicate. [Shift = Extend]
	3. Select the object to be duplicated. The dialog box appears.
	4. Enter the number of objects in the circular array.
	5. If the Center X* data field is not selected, click in the field.
	6. Move the pointer to the drawing area and click the center point of the array in the drawing area. Values automatically appear in the X*, Y* and Z* data fields.
	7. To make objects to be upright in the same orientation as to the selected objects, select the Translate Duplicates option.
	8. If Translate Duplicates is specified, click a location for the reference point in the drawing area.
	9. Select the angle option, Total or Step.
	10. Enter the angle of rotation in the Angle field or drag in the drawing area along the desired angle using the Draft Assistant.
	11. Click OK.

	Spherical Duplicate Tool
	1. Select the Spherical Duplicate tool.
	2. Select Item or Faces from the Message Line.
	3. The Message Line reads: Spherical Duplicate: Select Feature Faces [or Items] to spherically duplicate.
	4. Select the item or faces to duplicate. The dialog box appears.
	5. Enter the values for axes location or click them with the pointer in the drawing area and the values will appear in the appropriate field.
	6. Specify the number of features/items to be duplicated in vertical and horizontal directions and the angle for which the feature/item to be duplicated on the sphere's surface.
	7. Click OK.

	Cylindrical Duplicate Tool
	1. Select the Cylindrical Duplicate tool.
	2. Select Item or Faces from the Message Line.
	3. The Message Line reads: Cylindrical Duplicate: Select items/[or feature faces] to cylindrically duplicate.
	4. Select the item or faces to duplicate. The dialog box appears.
	5. Enter the values for the center of the cylinder duplicate and number of the items/ faces in a ring of the cylinder duplicate. It is possible to click in the drawing area to specify the center.
	6. Fill in the Rotation and Rings along Axis fields as desired.
	7. Click OK.

	Align Objects Tool
	1. Select the Align tool.
	2. Select the alignment type from the pull down menu in the Message Line.
	3. Hold down the SHIFT key and select the text and geometry to align.
	4. Click in the drawing area to pick an alignment point.


	Transforming Techniques
	Moving Objects with Tools
	1. Select the Move tool.
	2. Select the square to be moved.
	3. Click one corner of the square when the endpoint notation is displayed.
	4. Enter 2 in the dX entry field on the Status Line and -1 in the dY entry field. A positive or negative value entered in the Status Line determines the direction along the X or Y axis. A negative value moves the object to the left or down on the scr...
	5. Press the ENTER (Windows) or RETURN (Macintosh) key. The square is moved.

	Moving Objects to Another Layer
	1. Choose Window>Edit Objects.
	2. In the Layer field, scroll down to the layer on which the object will be relocated.
	3. Click OK. The object is now located on the new layer.

	Copying Objects with Tools
	1. Choose the Selection tool.
	2. Select the object(s) to copy.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Drag a copy of the selection to a new location. The copy is placed on the current work layer.
	1. Construct the geometry to copy.
	2. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	3. Click a new location. The click determines the location of the first point specified during the construction of the original geometry (the center of a Center-Point Circle, for example).
	1. Select one of the transformation tools.
	2. Select the object to copy and transform.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Perform the transformation according to the directions in the Message Line.
	1. In the Edit menu, be certain that Selectable Points is set.
	2. Click the Selection tool.
	3. Drag a selection fence around the control points that represent the area to stretch.
	4. Drag the points to a new location.
	1. In the Edit menu, be sure that Selectable Points is set.
	2. Click the Selection tool.
	3. Drag a selection fence around the lower right corner of the rectangle.
	4. Select the Move tool.
	5. Enter +1 in the dX data field, a -1 in the dY field and a 0 in the dZ field.



	Architectural Features
	Wall Tool
	Using the Wall Tool
	1. Select the Single Wall tool.
	2. Choose one of the
	3. The Message Line reads: Single Wall: Pick the first wall point.
	4.


	Door Tool
	Window Tool

	Pen Settings
	Default versus Selected Object Settings
	Changing the Pen Characteristics of an Object
	1. Select the object.
	2. Choose Pen>Color, Weight or Pattern and select any one for the selected object.

	Changing the Default Pen Characteristics

	Style
	Creating a New Pen Style
	Deleting a Pen Style
	Modifying a Pen Style

	Color
	Displaying the Color Palette
	1. Choose Pen>Color>More.
	2. Display 8, 16, 144 or the full 256 color palette. The default color palette displays 256 colors. Click the button in the upper right corner of the title bar.

	Specifying the Color of the Current Pen
	1. Choose Pen>Color. The submenu appears.
	2. Choose the color desired.

	Defining Colors
	1. To define a new color, choose Pen>Color>More. The color palette displays.
	2. Double-click on one of the definable colors.
	3. Once the color is selected, click OK, the color display closes and returns to color palette.
	4. Double-click on the color name field, where the old name currently displays. The following dialog box appears.
	5. Enter the new name for the color and click OK.
	6. Repeat this process to define up to 239 colors.


	Weight
	Units
	Pixels
	More
	1. Choose Pen>Weight. The submenu appears.
	2. Drag to the desired weight.


	Pattern
	Line Pattern Manager
	New Patterns
	1. Quit your Designer Elements program, if it is running.
	2. Open the Cadd.lin file in an ASCII text editor.
	3. After the last line pattern, enter the name of the new pattern. Give it a name not already used.
	4. In the same line, enter a descriptor string. This string is simply a visual representation of the pattern that will display in the Line Pattern Manager next to the name. (See the other patterns for an example). Use the periods, dashes and the spac...
	5. Begin the second line with a capital “A” followed by the length of the attributes. Each attribute should be followed by a comma and contain no spaces.
	6. Save the file.
	7. Restart your Designer Elements program.
	1. Quit the Designer Elements program, if it is running.
	2. Open the Cadd.lin file, in an ASCII text editor.
	3. Make the desired changes to the patterns. If a default pattern, name or descriptor is changed, it will be reflected in the Pattern submenu.
	4. Save the file.
	5. Restart the Designer Elements program.
	1. Choose Pen>Pattern>More. The Line Pattern Manager displays.
	2. Select the pattern to modify.
	3. Enter a value in the Scale field.
	4. Click OK to accept the changes or Cancel to close the Line Pattern Manager.
	1. Choose Pen>Pattern. The submenu appears.
	2. Drag to the desired pattern. The pen takes on the new pattern, selected in the submenu.
	1. Select the object.
	2. Choose Pen>Pattern.
	3. Drag to the desired pattern. The pen takes on the new pattern, selected in the submenu.

	Construction Line Pattern

	Arrowheads
	Arrowhead Types


	Line Tools
	Single Line Tool
	Using the Single Line Tool
	1. Select the tool. The Message Line reads: Single Line: Pick the beginning point. [Ctrl = Copy Previous] (Windows) or [Option = Copy Previous (Macintosh)].
	2. Click to place the first endpoint of the line.
	3. Move the cursor to a new location. A rubberband image appears that previews the construction.
	4. Click to place the last point of the line.

	Drawing a Line Perpendicular to Another Object
	1. Construct the object.
	2. Move the pointer to the object until a Drafting Assistant on notation appears (endpoint, midpoint, quadrant etc., will not work, only “on”).
	3. Drag straight away from the object in a perpendicular direction. A perpendicular line will appear attached to the object. Notice that the line stays perpendicular but slides along the object.
	4. Drag to the desired length.

	Drawing a Line Tangent or Perpendicular to an Arc, Circle or Ellipse
	1. Construct an arc, circle, spline or ellipse.
	2. Choose the Single Line tool.
	3. Move the pointer to the arc until a Drafting Assistant on notation appears (endpoint, midpoint, quadrant etc., will not work, only “on”).
	4. Drag in the appropriate direction (straight out for perpendicular or at an angle for tangent) until the Drafting Assistant perpendicular or tangent notation appears.
	5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line around the arc to the desired location and extend the line to the desired length.

	Geometric Characteristics

	Mid-point Line Tool
	Using the Mid-point Line Tool
	1. Select the Mid-point Line tool from Line tool palette. The Message Line reads: Mid- point Line: Pick center point [Ctrl = Copy previous] (Windows) or [Option = Copy Previous] (Macintosh).
	2. Pick the center point. The Message Line reads: Mid-point Line: Pick end point.
	3. Pick the end point of the line.

	Geometric Characteristics

	Connected Lines Tool
	Using the Connected Lines Tool
	1. Select the tool. The Message Line reads: Connected Lines: Pick the beginning point.
	2. Click to indicate the endpoints of the line segments.
	3. Indicate the last point by double-clicking, hitting the ESC key or by choosing another tool.

	Geometric Characteristics

	Parallel Line Tool
	Using the Parallel Line Tool
	1. Select the tool. The Message Line reads: Parallel Line: Drag new line off existing line.
	2. Drag off the desired line and release to indicate the position for the new parallel line. A rubberband line moves with the pointer. The distance field is active in the Status Line and displays the distance from the original line that was dragged.

	Geometric Characteristics

	Point Tool
	Using the Point at an XYZ Location Tool
	1. Select the Point tool from the palette.
	2. Select the Point at an XYZ Location tool in the Message Line. The Message Line reads: Point: Enter point. [Ctrl = Markers (Windows) or Option = Markers (Macintosh)].
	3. Click a point in the drawing area.

	Using the Points on a Curve Tool
	1. Select the Point tool from the palette.
	2. Select the Point on a Curve tool in the Message Line. The Message Line reads: Point on Curve: Select curves to distribute points on. [Ctrl = Markers (Windows) or Option = Markers (Macintosh), Shift = Extend].
	3. Enter the number of points that need to be distributed along the curve in the #Pts data field of the Status Line.
	4. Select the curve. To select more than one curve, hold down the SHIFT key before selecting the first curve and while selecting succeeding curves.

	Using the Points on a Surface Tool
	1. Select the Point tool from the palette.
	2. Select the Points on a Surface tool in the Message Line. The Message Line reads: Point on Surface: Select surface(s) to distribute points on. [Ctrl = Markers (Windows) or Option = Markers (Macintosh), Shift = Extend].
	3. Enter the number of points to distribute along the surface in two perpendicular directions in the #U and #V data fields of the Status Line. U and V represent perpendicular coordinate directions along the surface. (The letters U and V are standard ...
	4. Select the surface. To select more than one surface, hold down the SHIFT key before selecting the first surface and while selecting succeeding surfaces.

	Geometric Characteristics

	Modifying Lines

	Arc & Circle Tools
	Arc Tools
	Center-point Arc Tool
	1. Select the tool. The Message Line reads: Center-point Arc: Pick Center.
	2. Click the center point of the arc. The Message Line now indicates the next step in using the tool.
	3. Click the beginning point of the arc which will also define the radius.
	4. Moving the cursor to place the final point, a rubberband arc appears. Click the final point.

	3-point Arc Tool
	1. Select the tool. The Message Line reads: 3-point Arc: Pick first point. [Ctrl = Tangent to object (Windows) or Option = Tangent to object (Macintosh)].
	2. Click the first endpoint of the arc.
	3. Click the second point of the arc. A rubberband arc appears as the cursor is moved to a third position.
	4. Click the last point of the arc. The arc is created.

	Tangent-point Arc Tool
	1. Select the tool. The Message Line reads: Tangent-point Arc: Pick beginning point of arc (tangent line).
	2. Click the starting point. This is both the starting point of the arc and the starting point of the temporary tangent line.
	3. Click the endpoint of the tangent line.
	4. Click the endpoint of the arc. The arc is drawn between the first and last clicked points, tangent to the line between the first and second points.


	Circle Tools
	Center-point Circle Tool
	1. Select the tool. The Message Line reads: Center-point Circle: Pick center. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click the center of the circle. A rubberband circle appears guiding the construction as the cursor is moved.
	3. Click the second point which determines the circle's radius.

	Opposite-Point Circle Tool
	1. Select the tool. The Message Line reads: Opposite-point Circle: Pick first point on circle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click two locations to indicate the diameter. After the first point is clicked, a rubberband circle appears to guide in the construction.

	3-point Circle Tool
	1. Select the tool. The Message Line reads: 3-point Circle: Pick first point. [Ctrl = Tangent to object (Windows) or Option = Tangent to object (Macintosh)].
	2. Click the first point on the circle.
	3. Click the second and third points. After the second point a rubberband circle appears guiding the construction.
	1. Select the tool. The Message Line reads: Tangent Circle: Enter diameter then pick first tangent object.
	2. A diameter for the circle can be entered in the Status Line data field.
	3. Click the objects to which the circle is to be tangent.



	Ellipse & Conic Tools
	Ellipse Tools
	2-point Center Ellipse Tool
	1. Select the tool. The Message Line reads: 2-point Center Ellipse: Pick center of ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click to establish the center of the ellipse.
	3. Click to establish the corner of the rectangle defining the ellipse.

	Opposite-corner Ellipse Tool
	1. Select the tool. The Message Line reads: Opposite-corner Ellipse: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click to establish one corner of the rectangle defining the ellipse.
	3. Click to establish the opposite corner of the defining rectangle.

	3-point Center Ellipse Tool
	1. Select the tool. The Message Line reads: 3-point Center Ellipse: Pick center of the ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Click to establish the center of the ellipse.
	3. Click to establish the midpoint of the side of the control parallelogram defining the ellipse.
	4. Click to establish the corner of the control parallelogram defining the ellipse.

	3-corner Ellipse Tool
	1. Select the tool. The Message Line reads: 3-corner Ellipse: Pick first corner of control parallelogram. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Click to establish one corner of the parallelogram defining the ellipse.
	3. Click to establish another corner of the defining parallelogram.
	4. Click to establish the final corner of the defining parallelogram.

	Modifying Ellipses

	Conic Tools
	2-point Conic Tool
	1. Select the tool. The Message Line reads: 2-point Conic: Pick start point. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Pick the start point of the conic. As the cursor is moved to place the second point, a rubberband image appears.
	3. Pick the end point to complete the conic.

	3-point Conic Tool
	1. Select the tool. The Message Line reads: 3-point Conic: Pick start point. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Pick the start point of the conic.
	3. Pick the end point of the conic. Once this third point is placed, a rubberband image appears.
	4. Pick the shoulder point to complete the conic.

	4-point Conic Tool
	1. Select the tool. The Message Line reads: 4-point Conic: Pick start point. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Pick the start point of the conic.
	3. Pick the end point of the conic.
	4. Pick the slope control point of the conic. Once this third point is placed, a rubberband image appears.
	5. Pick the shoulder point to complete the conic.



	Polygon Tools
	Rectangle Tool
	Center/Corner Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Center/Corner Rectangle tool in the Message Line. The Message Line reads: Rectangle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	3. Pick the center point of the rectangle. As the cursor is moved, a rubberband image appears.
	4. Pick rectangle corner.

	Diagonal Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Diagonal Rectangle tool in the Message Line. The Message Line reads: Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	3. Click one corner of the rectangle. As the cursor is moved a rubberband image appears.
	4. Click the opposite corner of the rectangle.

	Center/Axis Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Center/Axis tool in the Message Line. The Message Line reads: Rectangle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	3. Click the center point of the rectangle.
	4. Click the midpoint of the rectangle side. As the cursor is moved a rubberband image appears.
	5. Click the opposite side of the rectangle.

	Corner/Axis Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Corner/Axis Rectangle tool in the Message Line. The Message Line reads: Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	3. Click the first corner of the rectangle.
	4. Click the second corner of the rectangle. As the cursor is moved, a rubberband image appears.
	5. Click the opposite point.

	Geometric Characteristics

	Inscribed Polygon Tool
	Using the Inscribed Polygon Tool
	1. Select the tool. The Message Line reads: Inscribed Polygon: Pick center of polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click the center of the polygon. The Message Line reads: Inscribed Polygon: Pick vertex of polygon. As the cursor is moved, a rubberband polygon appears guiding the construction.
	3. Pick a point on the circumference of the circumscribing circle to complete the polygon.

	Geometric Characteristics

	Circumscribed Polygon Tool
	Using the Circumscribed Polygon Tool
	1. Select the tool. The Message Line reads: Circumscribed Polygon: Pick center of polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click the center of the polygon and the midpoint of one of the sides, as directed by the Message Line.

	Geometric Characteristics

	Star Polygon Tool
	Using the Star Polygon Tool
	1. Select the Star Polygon tool from Polygon Tools palette. The Message Line reads: Star Polygon: Pick center of star polygon. [Ctrl = Copy previous] (Windows) or [Option = Copy Previous] (Macintosh).
	2. Pick the center point. The Message Line reads: Star Polygon: Pick outside vertex of star polygon.
	3. Pick the outside vertex. The Message Line reads: Star Polygon: Pick inside vertex of star polygon. [Shift = Deform star].
	4. Pick the inside vertex. Press the SHIFT key to create a non-symmetric star polygon.
	5. The Status Line contains the Vertices field. Enter the desired number for the star polygon.

	Geometric Characteristics

	Arbitrary Polygon Tool
	1. Select the tool. The Message Line reads: Arbitrary Polygon: Pick first point. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click the next point as directed by the Message Line.
	3. Continue clicking points to complete the desired polygon. Single click the last point to close the polygon at its starting point.
	Geometric Characteristics

	Polygon from Curves Tool
	1. Select the tool. The Message Line reads: Polygon from Curves: Select a collection of curves [Shift = Extend].
	2. Select all the desired curves. If the curves are selected individually, hold down the SHIFT key before beginning the selection.
	Geometric Characteristics


	Spline Tools
	Through-point B-spline Tool
	Using the Through-Points B-Spline Tool
	1. Select the tool. The Message Line reads: Through-points B-spline: Pick control points. (End = ESC, Double-click).
	2. Click the points for the vectors of the spline.
	3. Double-click the last point or hit the ESC key.

	Geometric Characteristics

	Vector Spline Tool
	Using the Vector Spline Tool
	1. Select the tool. The Message Line reads: Vector Spline: Pick control points (End = ESC, Double click).
	2. Click the points for the vectors of the spline.
	3. Double click the last point.

	Geometric Characteristics

	Bezier Spline Tool
	Using the Bezier Spline Tool
	1. Select the tool. The Message Line reads: Bezier Spline: Pick control points (End = ESC, Double click).
	2. Click the points of the spline.
	3. Double click the last point.

	Geometric Characteristics

	Freehand Spline on Surface Tool
	Using the Freehand Spline Tool
	1. Select the tool. The Message Line reads: Freehand Spline: Press and drag mouse. [Ctrl = AutoClose (Windows) Option = AutoClose (Macintosh)]
	2. Click and drag the mouse on the screen.
	3. Release the mouse button to create the freehand spline.

	Using the Freehand Spline on a Surface Tool
	1. Select the tool. The Message Line reads: Freehand Spline on Surface: Select surface or face. [Ctrl = AutoClose (Windows) Option = AutoClose (Macintosh)]
	2. Select the surface or solid on which to draw.
	3. Click and drag the mouse over the selected surface, keeping the points on the surface.
	4. Release the mouse button to complete the spline.


	Helix Curve Tool
	Using the Helix Curve Tool
	1. Select the Helix Curve tool. The Message Line reads: Helix Curve: Pick start and end of helix [Ctrl (Windows) or Option (Macintosh) = Left-handed helix].
	2. The Status Line contains the Pitch, Diameter, Length and Draft Angle data fields.
	3. Pick the start and end point of the helix. A right-handed helix is created.

	Geometric Characteristics

	Add Control Point Tool
	Using the Add Spline Control Point Tool
	1. Select the tool. The Message Line reads: Add Control Point: Select the spline to add point to (Shift = Extend).
	2. Click on the spline to add a point.
	3. Pick the desired location(s) for the new control point(s).


	Remove Control Point Tool
	Using the Remove Control Point Tool
	1. Select the tool. The Message Line reads: Remove Control Point: Select the spline point to remove (Shift = Extend).
	2. If the control points of the spline are not displayed, select the spline and choose Edit>Show Points.
	3. Pick the control point to be removed.


	Modify Slope Tool
	Using the Modify Slope Tool - Release Slopes Option
	1. Select the tool.
	2. Choose the Release Slope option in the pull-down menu of the Message Line. The Message Line reads: Modify Slope: Select spline slope(s) to release.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show Points.
	4. Pick the spline slope control endpoint to be freed.

	Using the Modify Slope Tool - Reference Option
	1. Select the tool.
	2. Choose the Reference option in the pull-down menu of the Message Line. The Message Line reads: Modify Slope: Select the spline end to set slope.
	3. If the control points of the spline that need to be modified are not displayed, select the spline and choose Edit>Show Points.
	4. Pick the spline to modify. In the graphic here, it's the spline displaying points.
	5. Pick the curve, surface or solids whose slope is to be referenced.
	6. Click on the endpoint of the curve to be modified, (The curve and the reference object do not have to connect.) The curve slope adjusts.

	Using the Modify Slope Tool - Reverse Option
	1. Select the tool.
	2. Choose the Reverse option in the pull-down menu of the Message Line. The Message Line reads: Modify Slope: Select spline slope point to reverse.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show Points.
	4. Pick the spline slope control endpoint to be reversed, as in the left graphic below. The slope control endpoint reverses 180° (right graphic).

	Using the Modify Slope Tool - Explicit Option
	1. Select the tool.
	2. Choose the Explicit option in the pull-down menu of the Message Line. The Message Line reads: Modify Slope: Select spline slope point for explicit set.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show Points.
	4. Pick the spline control endpoint to be set. An Input String dialog box appears.
	5. Enter the Angle for the slope in the data field and click OK. The dialog box closes and the slope of the spline is adjusted. (Click Cancel to close the dialog box without changing the angle value.)

	Using the Modify Slope Tool - Release Magnitudes Option
	1. Select the tool.
	2. Choose the Free Magnitudes option in the pull down menu. The Message Line reads: Modify Slope: Select spline magnitude to release.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show Points.
	4. Select the bezier curve slope or control point to be released.


	Elevate Curve Tool
	Using the Elevate Curve Tool
	1. Select the Elevate Curve tool. The Message Line reads: Elevate Curve: Pick curve to elevate.
	2. Select the curve to elevate.


	Fair Curve Tool
	Using the Fair Spline Tool
	1. Select the tool.
	2. The Message Line reads: Fair Spline: Select curve to fair.
	3. Click on the spline to fair.



	Wireframe Editing Tools
	Fillet and Chamfer Tools
	2-entity Fillet Tool
	1. Select the 2-entity Fillet tool. The Message Line reads: 2-entity Fillet: Pick first entity. [Shift=Corner, Ctrl=No trim (Windows) or Option=No Trim (Macintosh)].
	2. Enter the arc radius in the Status Line. The default radius is .50 inch.
	3. Click the first curve. The Message Line reads: 2-entity Fillet: Pick second entity. [Ctrl=No trim] (Windows) or [Option=No Trim (Macintosh)].

	3-entity Fillet Tool
	1. Select the 3-entity Fillet tool. The Message Line reads: 3-entity Fillet: Pick three entities [Ctrl=No Trim (Windows) or Option=No Trim (Macintosh)].
	2. Click the three objects to fillet.

	2-entity Chamfer Tool
	1. Select the 2-entity Chamfer tool.
	2. In the Status Line specify the chamfer's distance from the corner. (The default distance is .50 inch.)
	3. Click the first curve. The Message Line reads: 2-entity Chamfer: Pick second entity. [Shift = Corner, Ctrl = No trim (Windows) or Shift = Corner, Option = No trim (Macintosh)].

	Angular Chamfer Tool
	1. Select the Angular Chamfer tool. The Message Line reads: Angular Chamfer: Pick first entity [Ctrl = No trim (Windows), Option = No trim (Macintosh)].
	2. In the Status Line, enter the length for the intersection of the chamfer and the second line of the corner. The default length is .50 inch.
	3. In the Status Line also enter the angle between the chamfer and the second side. The default Angle is 45°.
	4. Click the first curve. The Message Line reads: Angular Chamfer: Pick second entity. [Ctrl=No trim (Windows) or Option=No Trim (Macintosh)].


	Trim Tools
	Simple Trim Tool
	1. Select the Simple Trim tool. The Message Line reads: Simple Trim: Select boundaries for simple trim. [Shift = Extend]
	2. Select the object that limits the trim.
	3. Click the section of the object to be discarded.

	Relimit Tool
	1. Select the Relimit tool. The Message Line reads: Relimit: Select boundaries for relimit [Shift = Extend].
	2. Select the object that limits the change.
	3. Click the section of the object to retain.

	Segment Tool
	1. Select the Segment tool. The Message Line reads: Segment: Select boundaries for segment [Shift = Extend].
	2. Select the objects that limit the segmentation.
	3. Click the object to be segmented.

	Divide Tool
	1. Select the Divide tool. The Message Line reads: Divide: Pick curve to divide. [Shift=Extend]
	2. Set the No. of Segments value in the Status Line.
	3. Select the object to divide.

	Corner Trim Tool
	1. Select the Corner Trim tool. The Message Line reads: Corner Trim: Pick portion of first entity to retain. [Shift=Corner].
	2. Select the first curve.
	3. Select the second object.

	Divide at Location Tool
	1. Select the Divide at Location tool. The Message Line reads: Divide at Location: Pick curve to divide at location: [Shift=Extend].
	2. Select the curve. The Message Line reads: Divide at Location: Pick divide point.
	3. Choose the point on the curve where the division will be made.

	Connect Curve Tool
	1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select two curves to connect end points [Ctrl=Join (Windows) or Option=Join (Macintosh)].
	2. Select the first curve near the endpoint where it will connect the curve.
	3. Select the second curve near the endpoint that needs moving.
	1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select two curves to connect end points [Ctrl=Join (Windows) or Option=Join (Macintosh)].
	2. If desired, specify a tolerance distance in the Status Line to which the resulting curves will fit.
	3. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and select the two curves.


	Curve Utility Tools
	Offset Curve Tool
	1. Select the Offset Curve tool.
	2. Select the Offset to Value tool in the Message Line. The Message Line reads: Offset Curve: Pick curves to offset distance. [Ctrl=Extend Corner (Windows) or Option=Extend Corner (Macintosh)] [Shift=Extend]
	3. Enter an offset distance in the Offset data field of the Status Line.
	4. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter offset direction.
	5. Pick a point on either side of the curve or edge to specify the offset direction. The offset direction must be parallel to the curve or edge. The program offsets the curve by the distance set in the data field.
	1. Select the Offset Curve tool.
	2. Select the Offset to Value tool in the Message Line. The Message Line reads: Offset Curve: Pick curves to offset distance [Ctrl=Extend Corner (Windows) or Option=Extend Corner (Macintosh)] [Shift=Extend]
	3. Enter an offset distance in the Offset data field of the Status Line.
	4. Select the curves or edges to offset. The Message Line reads: Offset Curve: Enter offset direction.
	5. Select the type of offset.
	1. Select the Offset Curve tool.
	2. Select the Offset by Point tool in the Message Line. The Message Line reads: Offset Curve: Pick curves to point [Ctrl=Extend Corner (Windows) or Option=Extend Corner (Macintosh)] [Shift=Extend]
	3. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter offset point.
	4. Pick the desired point for the offset. The Designer Elements program offsets the curve to that point. The offset value is displayed in the Offset data field in the Status Line.
	1. Select the Offset Curve tool.
	2. Select the Offset by Point tool in the Message Line. The Message Line reads: Offset Curve: Pick curves to point [Ctrl=Extend Corner (Windows) or Option=Extend Corner (Macintosh)] [Shift=Extend]
	3. Select the curves to offset. The Message Line reads: Offset Curve: Enter offset point.
	4. Select the type of offset.
	5. Pick the desired point for the offset. The Designer Elements program offsets the curve to that point. The offset value is displayed in the Offset data field in the Status Line.

	Extrude Curve Tool
	1. Click the Extrude Curve tool. The Message Line reads: Extrude Curve: Pick curves to extrude [Shift=Extend].
	2. Select the curve(s) to extrude. The Message Line reads: Extrude Curve: Specify two points for extrusion direction.
	3. Click two points to indicate where the new extruded curve will be placed. The direction of the extrusion is specified by the order in which the points are picked. This Designer Elements program applies the specified distance and direction.

	Revolve Curve Tool
	1. Select the Revolve Curve tool. The Message Line reads: Revolve Curve: Pick curves to revolve. [Shift=Extend]
	2. Select the curve(s) to revolve. The Message Line reads: Revolve Curve: Specify two points for the revolution axis.
	3. Click two points to indicate the axis of revolution. The direction of the revolution is specified by the order the points are picked. The program rotates the curve about the axis by the number of steps and through the angle set in the data fields ...

	Project Curve Tool
	1. Select the Project Curve tool. The Message Line reads: Project Curve: Pick curves to project. [Ctrl=Copy (Windows) or Option=Copy (Macintosh)] [Shift=Extend]
	2. From the pull-down menu in the Status Line choose the projection plane.
	3. Select the curves to project. Hold down the SHIFT key or drag a selection fence to select multiple lines. The Message Line now reads, Project Curve: Specify point in projection plane. [Ctrl=Copy (Windows) or Option=Copy (Macintosh)]
	4. Pick the point on the projection plane where the curves should be projected. The selected lines are replaced with lines projected on the selected plane.

	Explode Edge Tool
	1. Select the Explode Edge tool. The Message Line reads: Explode Edge: Pick edges to explode. [Shift=Extend]
	2. Select the surface or solid edge or Iso line from which to create a curve.



	Introduction to Surface Modeling
	Surface Modeling Tools
	Surface Primitive Tools
	Surface From Curves Tools
	Feature Surface Tools
	Surface Utilites Tools
	Local Surface Tools

	Surfaces, Selection and Display
	Changing an Object's Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.
	3. Enter the desired number of Iso lines. Check the Show Silhouettes box.
	4. Click OK to close the dialog box and save the new settings.


	Surface Associativity
	Cutting and Pasting Surfaces
	Exporting Surfaces
	Objects Types and Edit Objects
	Surface Control Vertex Modification
	Performing a Control Vertex Modification
	1. Select the surface you want to modify.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Using the Selection tool, drag the control points as desired.



	Surface Primitive Tools
	Infinite Plane Tool
	Using the X-, Y- and Z-Station Planes Option
	1. Select the Infinite Plane tool.
	2. Pick X-, Y- or Z-Station from the drop down list on the Message Line. The Message Line reads: Infinite Plane: Pick location for plane.
	3. Click the point on the screen where the plane will be. An icon for the plane appears at that location.

	Using the Normal and Location Plane Option
	1. Select the Infinite Plane tool.
	2. Pick Normal Loc from the drop down list on the Message Line. The Message Line reads: Infinite Plane: Enter 3 points (1-Normal End, 2-Normal Start, 3-Loc).
	3. Click the point where the plane's normal will end, the point where the plane's normal will start, and the point where the plane will be placed.

	Using the Infinite Plane Tool to Create a Three Point Plane
	1. Select the Infinite Plane tool.
	2. Pick 3 Pts In Plane option from the drop down list on the Message Line. The Message Line reads: Infinite Plane: Enter 3 points in the plane.
	3. Click three points. The plane icon appears at the specified location.
	1. Select the Infinite Plane tool.
	2. Pick Along Curve from the drop down list on the Message Line. The Message Line reads: Infinite Plane: Pick curve to distribute planes along [Shift=Extend].
	3. Click a curve on the screen. The Input String dialog box appears.
	1. Select the Infinite Plane tool and select the Along Curve option.
	2. Create the planes along a curve adjacent to the solid model.
	3. Choose the Plane/Surface Intersection tool and pick the planes on the curve with which to cut the solid. The graphic here shows one example.
	4. Select the solid. The Plane/Surface Intersection tool projects the planes through the solid. The Designer Elements program puts each projected plane on a separate layer after clicking the AutoLayers box on the Message Line before creating them.
	5. The intersections display.
	1. Select the Infinite Plane tool. The Message Line reads: Infinite Plane: Pick location for plane.
	2. Place the infinite plane in the drawing.
	3. Right-Click on the infinite plane and select the Use a Clip Plane menu option.
	4. All objects are visually clipped and sectioned. The perpendicular arrow represents the normal, which indicates the direction of the clipped part of the unit.
	5. Adjust the plane visually using the handles on the plane indicator. There are 3D handles on the corners, midpoints and center of the clip plane. Midpoint markers rotate the clip plane. Hold the SHIFT key to rotate in 45-degree steps.
	6. Edit the plane properties with the Edit Object dialog box. Double click the plane to open the Edit Objects. Use the Scale option to size the plane.
	7. Modify the color of the clip plane cut with the Section drop down menu.
	8. Set the transparency of the clip plane in the View>Shade Options dialog.
	9. The geometry tab of the Edit Object dialog box provides the following options:

	Geometric Characteristics

	Sphere Surface Tool
	1. Select the Sphere Surface Primitive tool. The Message Line reads: Sphere Primitive: Enter center and radius point for sphere.
	2. In the drawing area click the center point and radius point.

	Block Surface Tool
	1. Select the Block Surface Primitive tool. The Message Line reads: Block Primitive: Enter center and length points.
	2. In the drawing area click the center and length points for the block.

	Cylinder Surface Tool
	1. Select the Cylinder Surface Primitive tool. The Message Line reads: Cylinder Primitive: Enter start and end points for cylinder.
	2. In the drawing area click the start and end points for the cylinder.

	Pyramid Surface Tool
	1. Select the Pyramid Surface Primitive tool. The Message Line reads: Pyramid Primitive: Enter start and end points for pyramid.
	2. In the drawing area click the start and end points for the pyramid.


	Surface From Curves Tools.
	Net Surface Tool
	Using the Net Surface Tool
	1. Select the Net Surface tool. The Message Line reads: Net Surface: Pick (M) curves defining surface [Shift=Extend].
	2. Hold down the SHIFT key and pick two or more curves along one direction. The objects appear selected as in the graphic here (Curves 1 and 2).
	3. Hold down the SHIFT key once again, and pick two or more curves to complete the boundary for the surface.

	Geometric Characteristics

	Ruled Surface Tool
	1. Select the Ruled Surface tool. The Message Line reads: Ruled Surface: Pick curves for defining surface. [Shift=Extend]
	2. If there are more than two curves being used for the ruled surface hold down the SHIFT key and select all the curves. When the SHIFT key is released the surface is created
	Geometric Characteristics

	Skin Surface Tools
	Standard Skin Surface
	Closed Skin Surface
	Skin Curve Surface Tool
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the same direction, adjust them so that they do.
	2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) Shift=Extend].
	3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
	4. Select the curves in the order that the surface is to be skinned. To select more than two curves hold down the SHIFT key. A selection fence can not be used to select the curves.
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the same direction, adjust them so that they do.
	2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining surface [Ctrl = Closed (Windows) or Option (Macintosh) Shift=Extend].
	3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
	4. (Windows) Select the curves in the order that the surface is to be skinned. To select more than two curves hold down the SHIFT key. (The selection fence can not be used to select the curves.) After selecting the last curve and while still holding ...

	Skin with Curve Guides Surface Tool
	1. Check curve directions of the profile curves by choosing Verify>Direction. If all of the curves do not run in the same direction, adjust them so that they do.
	2. Create one or more guide curves.
	3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) Shift=Extend].
	4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message Line.
	5. Select the curves in the order that the surface is to be skinned. To select more than two curves, hold down the SHIFT key. A selection fence can not be used to select the curves.
	6. Select the guide curves.
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the same direction, adjust them so that they do.
	2. Create one or more guide curves.
	3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) Shift=Extend].
	4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message Line.
	5. (Windows) Select the curves in the order that the surface is to be skinned. To select more than two curves hold down the SHIFT key. (The selection fence can not be used to select the curves.) After the last curve is selected and while still holdin...
	6. Select the guide curves.

	Geometric Characteristics

	Cover Surface Tool
	Using the Cover Surface Tool
	1. Select the Cover Surface tool. The Message Line reads: Cover Surface: Pick curves for cover surface [Shift=Extend].
	2. To select more than one curve hold down the SHIFT key before selecting the first curve.
	3. Select the curves. Do not worry about the order in which they are selected.

	Geometric Characteristics

	Revolved Surface Tool
	Revolved Surface about Two Points Tools
	1. Select the Revolved Surface tool.
	2. Select the Resolve Surface About Two Points tool in the Message Line. The Message Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].
	3. Enter the angle through which to revolve the curve in the Angle data field of the Status Line.
	4. Select the curve or curves to revolve.
	5. Click two points to define the Axis of Revolution.

	Revolved Surface about a Curve Tool
	1. Select the Revolved Surface tool.
	2. Select the Resolve Surface About Curve tool in the Message Line. The Message Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].
	3. Enter the angle through which to revolve the curve in the Angle data field on the Status Line.
	4. Select the curve or curves to revolve.
	5. Select the curve to use as the Axis of Revolution. If the Axis of Revolution crosses any of the profile curves and error message appears. Choose another curve or adjust the curve as required.

	Geometric Characteristics

	Sweep Surface Tool - Along 2 Points
	1. Select the Sweep Surface Along 2 Points tool. The Message Line reads: Pick curve(s) to sweep [Shift=Extend].
	2. Select the curve to sweep. The Message Line reads: Sweep 2 Pts Surface: Enter two points for sweep direction.
	3. Click two points to define the vector. The order the points are clicked specifies the direction of the sweep.
	Sweep Surface Tool - Along 1 Rail
	1. Select the Sweep Surface Along 1 Rail tool. The Message Line reads: Sweep 1 Rail Surface: Pick curve to sweep [Shift=Extend].
	2. Click the sweep curve. The Message Line reads: Sweep 1 Rail Surface: Pick sweep axis [Shift=Extend].
	3. Click the rail curve. The surface is created.

	Sweep Surface Tool - Along 2 Rails
	1. Select the Sweep Surface tool.
	2. Select the Sweep Surface Along 2 Rails tool in the Message Line. The Message Line reads: Sweep 2 Rail Surface: Pick curves or group to sweep. [Ctrl or Option = Maintain Height][Shift = Extend]
	3. Click the profile to sweep and then choose the two rails for the sweep path.

	Sweep Rules

	Tube Surface Tool
	Using the Tube Surface Tool
	1. Create a curve that would act as the center line for the tube.
	2. Select the Tube Surface tool. The Message Line reads: Tube Surface: Pick tube center line [Shift=Extend].
	3. Click the curve for the tube's center line.
	4. Enter a new tube radius in the data field on the Status Line, if required. Press ENTER (Windows) or RETURN (Macintosh) and the radius of the tube will change accordingly.

	Geometric Characteristics


	Derived Surface Tools
	Offset Surface Tool
	Using the Offset Surface Tool
	1. Select the Offset Surface tool. The Message Line reads: Offset Surface: Pick surfaces to offset [Shift=Extend].
	2. Enter an Offset distance in the data field of the Status Line.
	3. Click the parent surface. A duplicate surface appears at the offset distance.


	Lofted Surface Tool
	Using the Lofted Surface Tool
	1. Select the Lofted Surface tool. The Message Line reads: Lofted Surface: Pick edges for lofted surface.[Shift=Extend].
	2. Enter a new bulge factor in the Bulge data field in the Status Line, if desired. The bulge factor controls the magnitude of the slope of the surface edges.
	3. Click an edge on each surface to be joined by the tangent surface. When a tangent surface is created, the screen shows only one connecting line. Choose View>Shade Now to see the tangent surface. If Shade Now is set to anything other than wireframe...


	Draft Surface Tool
	Using the Draft Surface Tool
	1. Select the Draft Surface tool. The Message Line reads: Draft Surface: Select curve on surface [Ctrl=Align Curve].
	2. Enter a new angle and/or length in the data fields in the Status Line, if necessary.
	3. Click a curve (edge) on the surface to draft or extend the surface. When the edge is seleced, the whole surface is highlighted until this Designer Elements program creates the draft.


	Fillet Surface Tool
	Using the Fillet Surface Tool
	1. Select the Fillet Surface tool. The Message Line reads: Fillet Surface: Pick two surfaces to blend [Shift=Extend].
	2. Select the two intersecting or connected surfaces that share an edge


	Tangent Cover Tool
	1. Select the Tangent Cover Surface tool. The Message Line reads: Tangent Cover Surface: Pick four edges/curves for cover surface.
	2. Select the surface edges and or curves. Select them inhead to tail fashion. The tangent cover surface is created.


	Surface Utility Tools
	Surface Editing Tools
	Plane/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick the planes to slice objects with. [Ctrl = Auto Layers] [Shift = Extend]
	2. Click the plane to use for intersecting the curve. Hold down the SHIFT key to pick more than one plane. The Message Line reads: Plane/Surface Intersection: Pick objects to intersect with plane. [Shift=Extend]
	3. Click the curves to intersect with the plane.
	1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick planes to slice objects with. [Ctrl = Auto Layers] [Shift=Extend]
	2. Click the plane to use to intersect the surface. Hold down the SHIFT key to pick more than one plane. The Message Line reads: Plane/Surface Intersection: Pick objects to intersect with plane. [Shift=Extend]
	3. Click the surface to intersect with the plane.
	1. Click the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick planes to slice objects with. [Ctrl = auto Layers] [Shift=Extend].
	2. Click the plane to use to intersect the solid. Hold down the SHIFT key to pick more than one plane. The Message Line reads: Plane/Surface Intersection: Pick objects to intersect with plane. [Shift=Extend]
	3. Click the solid to intersect with the plane.

	Curve/Surface Projection Tool
	1. Select the tool in the tool palette. Choose the necessary option in the Message Line. The Message Line reads: Curve/Surface Projection: Pick curves to project onto surface. [Ctrl = Imprint] [Shift=Extend]
	2. Click the curve to project onto the surface (it does not highlight). Hold down the SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface Projection: Pick ONE surface or solid for curve projections. [Shift=Extend]
	3. Click the surface or solid onto which to project the curve.
	4. Enter two points for the projection vector.
	1. Click the tool in the tool palette. Select the necessary option in the Message Line. The Message Line reads: Curve/Surface Projection: Pick curves to project onto surface. [Ctrl = Imprint] [Shift=Extend].
	2. Click the curve to project onto the solid (it does not highlight). Hold down the SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface Projection: Pick ONE surface or solid for curve projections. [Shift=Extend]
	3. Click the solid onto which to project the curve.
	4. Enter two points for the projection vector.

	Surface/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Surface/Surface Intersection: Pick two surfaces or solids for intersection.
	2. Click on the two surfaces. An intersection curve displays.
	1. Click the tool in the tool palette. The Message Line reads: Surface/Surface Intersection: Pick two surfaces or solids for intersection.
	2. Click the two surfaces. An intersection curve displays.

	Curve/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersection: Select curves to intersect surface/solids. [Shift=Extend]
	2. Click the curve to intersect the surface. Hold down the SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface Intersection: Select surfaces or solids to intersect with curve. [Shift=Extend]
	3. Click the surface to intersect with the curve. The intersection points display.
	1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersection: Select curves to intersect surface/solids. [Shift=Extend]
	2. Click the curve to intersect the solid. Hold down the SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface Intersection: Select surfaces or solids to intersect with curve. [Shift=Extend]
	3. Click the solid to intersect with the curve. The intersection points display.

	Boolean Surface Tools
	1. Select the Boolean Surface tool.
	2. Select the Add Boolean Surface tool in the Message Line. The Message Line reads: Boolean Surface: Pick planar surface to add to. [Shift=Extend]
	3. Select the surface to which another will be added. The Message Line reads: Boolean Surface: Pick planar surface to add. [Shift=Extend]
	4. Select the surface to be added.
	1. Select the Boolean Surface tool.
	2. Select the Subtract Boolean Surface tool in the Message Line. The Message Line reads: Boolean Surface: Pick planar surface to subtract from. [Shift=Extend]
	3. Select the surface from which you will subtract another. The Message Line reads: Boolean Surface: Pick planar surface to subtract. [Shift=Extend]
	4. Select the surface to be subtracted. One surface is subtracted from the other.
	1. Select the Boolean Surface tool.
	2. Select the Intersect Boolean Surface tool in the Message Line. The Message Line reads: Boolean Surface: Pick planar surface to intersect with. [Shift=Extend]
	3. Select the surface with to intersect another. The Message Line reads: Boolean Surface: Pick planar surface to intersect. [Shift=Extend]
	4. Select the surface to be intersected. The intersecting portion of the surfaces is displayed.

	Connect Surface Tool
	1. Click the Connect Surface tool in the tool palette. The Message Line reads: Connect Surface: Pick two surfaces to connect. [CTRL = Advanced (Windows) or OPTION = Advanced (Macintosh)] [Shift=Extend].
	2. For advanced settings tap the CTRL key (Windows) or the OPTION key (Macintosh) to display the Stitching Options dialog box to enter the maximum stitch and heal gap sizes, simplify spline surfaces or use tolerant edges.
	3. Click the two surfaces to connect. The surfaces become one surface but retain their individual mathematical definitions.

	Split Surface Tool
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick surface to split.
	2. Select the surface to split. The Message Line reads: Split Surface: Pick curves, surface, or solid to split with.
	3. Select the entity that defines the trim area. The program splits the surface at the intersection of the two entities. The objects won't appear differently on the screen. Delete any unnecessary portions.
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick surface to split.
	2. Select the surface to trim. The Message Line reads: Split Surface: Pick curves, surface, or solid to split with. [Shift=Extend]
	3. Select the entity that defines the trim area. The program splits the surface at the intersection of the surface and curve. The objects won't appear differently on the screen. Delete any unnecessary portions.
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick surface to split.
	2. Select the surface to split. The Message Line reads: Split Surface: Pick curves, surface, or solid to split with.
	3. Select the entity that defines the split area. The program splits the surface at the intersection of the surface and the solid. The objects won't appear differently on the screen. Delete any unnecessary portions.

	Silhouette Curves Tool
	1. Select the Silhouette Curves tool, The Message Line reads: Silhouette Curves: Pick surface/solids for silhouettes. [Shift = Extend]
	2. Select the objects on which silhouette curves are necessary. The message line now reads, Silhouette Curves: Specify two points for view direction.



	Surface Modification Tools
	Match Surface Tool
	Rules and Notations for using the Match Surface Tool and Options
	Match G1 Slope Option
	1. Select the Match Surface tool.
	2. From the pull-down menu in the Message Line, select Match G1 Slope. The Message Line reads: Match Surface: Pick surface edge to modify tangency.
	3. Click on the edge of the surface to modify.
	4. Click on the surface edge to which the first surface is being matched.

	Match G2 Slope Option
	1. Select the Match Surface tool.
	2. From the pull-down menu in the Message Line, select Match G2 Slope. The Message Line reads: Match Surface: Pick surface edge to modify tangency.
	3. Click on the edge of the surface to modify.
	4. Click on the surface edge to which the first surface is being matched.


	Rebuild Surface Tool
	Using the Rebuild Surface Tool
	1. Select the Rebuild surface tool. The Message Line reads: Rebulid Surface: Pick surface to rebuild.
	2. Click the surface to rebuild.


	Untrim Surface Tool
	Using the Untrim Surface Option
	1. Select the Untrim Surface tool.
	2. From the pull-down menu in the Message Line, select Untrim Surface. The Message Line reads: Untrim Surface: Pick surface to untrim.


	Elevate Surface Tool
	1. Select the surface for which to add control points.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Select the Elevate Surface tool.
	7. From the pull-down menu in the Message Line select: Elevate Degree. The Message Line reads: Elevate Surface: Pick surface to elevate.
	8. Select the surface.

	Insert Knot Tool
	Using the Insert Knot Tool - At Location Option
	1. Select the surface to which control points are being added.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Select the Insert Knot tool.
	7. From the pull-down menu in the Message Line select At Location. The Message Line reads: Insert Knot: Pick surface to insert a new knot.
	8. Select the surface. The Message Line now reads: Insert Knot: Specify location for new knot.
	9. Select a location along an edge of the surface for the new row or column of knots.

	Using the Insert Knot Tool - Across Surface Option
	1. Select the surface to which control points are being added.
	2. Choose Window>Edit Objects to verify that the surface is a surface face. If it is, continue on with step 5.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Select the Insert Knot tool.
	7. From the pull-down menu in the Message Line select Across Surface.
	8. In the Status Line enter the number of rows and columns of knots to be inserted across the surface in both directions.
	9. The Message Line reads: Insert Knot: Pick surface to insert a new knot. [SHIFT = Extend]



	Introduction to Solid Modeling
	Solid Modeling Tools
	Primitives
	Profiles
	Features
	Solid Utility Tools
	Local Solid Face Tools

	Drafting Assistant and Solids
	Solids, Selection and Display
	Displaying Solid Edges
	Object Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.
	3. Enter the desired number of Iso lines. Check the Show Silhouettes box if desired.
	4. Click OK to close the dialog box and save the new settings.


	Solid Associativity
	Solids and Instances
	Instances and Moving Solids
	Instances, Copying Solids and Associativity

	Cutting and Pasting Solids
	Cutting and Pasting on the Macintosh

	Exporting Solids
	1. When exporting to an application that supports ACIS, generate a SAT file. SAT files contain precise geometry and topology, so the other application can import the solid's data as it was created in Cobalt, Xenon or Argon.
	2. Convert the solid into polylines or meshes with the Change Object Type command in the Edit menu. After converting the model, use the DXF export command to create an ASCII DXF file.
	3. Export solids through the IGES translator as solid entities or as a collection of trimmed surfaces.

	Object Types and Edit Objects
	Error Messages

	Solids Primitive Tools
	Sphere Primitive Tool
	Sphere 1 Point Option
	1. Select the Sphere Primitive tool.
	2. Select the Sphere 1 Point option in the Message Line. The Message Line reads: Sphere Primitive: Enter center point for sphere.
	3. Click a point in the drawing area.

	Sphere 2 Point Option
	1. Select the Sphere Primitive tool.
	2. Select the Sphere 2 Point option in the Message Line. The Message Line reads: Sphere Primitive: Enter center and radius point for sphere.
	3. Click the center point and the radius point in the drawing area.

	Sphere by Diagonals Option
	1. Select the Sphere Primitive tool.
	2. Select the Sphere by Diagonals option in the Message Line. The Message Line reads: Sphere Primitive: Enter diagonal corners for sphere.
	3. Click two points in the drawing area.The sphere is created.


	Slab Primitive Tool
	Using the Slab Tool
	1. Select the Slab Primitive tool. The Message Line reads: Slab Primitive: Enter 3 or more points for slab. (Double-click last point).
	2. Click the three or more points to describe the slab. (Be careful that the points are not overlapping.)


	Block Primitive Tool
	Block 1 Point Option
	1. Select the Block Primitive tool.
	2. Select the Block 1 Point option in the Message Line. The Message Line reads: Block Primitive: Enter center point for block base.
	3. Click a point in the drawing area.

	Block 2 Point Option
	1. Select the Block Primitive tool.
	2. Select the Block 2 Point option in the Message Line. The Message Line reads: Block Primitive: Enter centerline points for block.
	3. Click two points in the drawing area.

	Block by Diagonals Option
	1. Select the Block Primitive tool.
	2. Select the Block by Diagonals option in the Message Line. The Message Line reads: Block Primitive: Enter start diagonal point. [Shift=Square]
	3. Click two points in the drawing area to specify two diagonal corners of the block’s base.
	4. After the first two points are placed The Message Line reads: Block Primitive: Enter height.
	5. Drag to set the height of the block.


	Cylinder Primitive Tool
	Cylinder 1 Point Options
	Using the Cylinder 1 Point Option
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder 1 Point option in the Message Line. The Message Line reads: Cylinder Primitive: Enter center point for cylinder.
	3. Click a point in the drawing area.

	Cylinder 2 Point Option
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder Two Point option in the Message Line. The Message Line reads: Cylinder Primitive: Enter start and end points for cylinder.
	3. Click two points in the drawing area.

	Cylinder by Diagonals Option
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder by Diagonals option in the Message Line. The Message Line reads: Cylinder Primitive: Enter start diagonal point. [Shift=Square]
	3. Click two points in the drawing area to specify two diagonal corners of the cylinder base’s bounding box.
	4. The Message Line reads: Cylinder Primitive: Enter height.
	5. Drag to set the height of the cylinder.


	Cone Primitive Tool
	Cone 1 Point Option
	1. Select the Cone Primitive tool.
	2. Select the Cone 1 Point option in the Message Line. The Message Line reads: Cone Primitive: Enter center point for cone.
	3. Click a point in the drawing area.

	Cone 2 Point Option
	1. Select the Cone Primitive tool.
	2. Select the Cone 2 Point option in the Message Line. The Message Line reads: Cone Primitive: Enter start and end points for cone.
	3. Click in the drawing area to set the start (center) point and the end (tip) point of the cone.

	Cone by Diagonals Option
	1. Select the Cone Primitive tool.
	2. Select the Cone by Diagonals option in the Message Line. The Message Line reads: Cone Primitive: Enter start diagonal point. [Shift=Square]
	3. Click two points in the drawing area to specify two diagonal corners of the cone base’s bounding box.
	4. Drag to set the height of the cone.


	Torus Primitive Tool
	Torus 1 Point Option
	1. Select the Torus Primitive tool.
	2. Select the Torus 1 Point option in the Message Line. The Message Line reads: Torus Primitive: Enter center point for torus.
	3. Click in the drawing area to set the center.

	Torus 2 Point Option
	1. Select the Torus Primitive tool.
	2. Select the Torus 2 Point option in the Message Line. The Message Line reads: Torus Primitive: Enter center and radius point for torus.
	3. Click the center point and the radius point in the drawing area.

	Torus by Diagonals Option
	1. Select the Torus Primitive tool.
	2. Select the Torus by Diagonals option in the Message Line. The Message Line reads: Torus Primitive: Enter start diagonal point. [Shift=Square]
	3. Click twice to specify two diagonal corners of the torus’ bounding box.
	4. The Message Line reads: Torus Primitive: Enter height.
	5. Drag to set the height of the torus.


	Prism Primitive Tool
	Prism 1 Point Option
	1. Select the Prism Primitive tool.
	2. Select the Prism 1 Point option in the Message Line. The Message Line reads: Prism Primitive: Enter center point for prism.
	3. Click in the drawing area to set the base's center point.

	Prism 2 Point Option
	1. Select the Prism Primitive tool.
	2. Select the Prism 2 Point option in the Message Line. The Message Line reads: Prism Primitive: Enter start and end points for prism.
	3. Click in the drawing area to set the start point (center) and the end point (height).

	Prism by Diagonals Option
	1. Select the Prism Primitive tool.
	2. Select the Prism by Diagonals option in the Message Line. The Message Line reads: Prism Primitive: Enter start diagonal point. [Shift=Square]
	3. Click two points in the drawing area to specify two diagonal corners of the prism base’s bounding box.
	4. The Message Line reads: Prism Primitive: Enter height.
	5. Drag to set the height of the prism.


	Pyramid Primitive Tool
	Pyramid 1 Point Option
	Using the 1 Point Pyramid Tool
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid 1 Point option in the Message Line. The Message Line reads: Pyramid Primitive: Enter center point for pyramid.
	3. Click in the drawing area to set the center.

	Pyramid 2 Point Option
	Using the 2 Point Pyramid option
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid Two Point option in the Message Line. The Message Line reads: Pyramid Primitive: Enter start and end points for pyramid.
	3. Click two points in the drawing area.

	Pyramid by Diagonals Option
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid by Diagonals option in the Message Line. The Message Line reads: Pyramid Primitive: Enter start diagonal point. [Shift=Square]
	3. Click two points in the drawing area to specify two diagonal corners of the pyramid base’s bounding box.
	4. The Message Line reads: Pyramid Primitive: Enter height.
	5. Drag to set the height of the pyramid.


	Ellipsoid Primitive Tool
	Ellipsoid 1 Point Options
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid 1 Point option in the Message Line. The Message Line reads: Ellipsoid Primitive: Enter center point for ellipsoid.
	3. Click a point in the drawing area.

	Ellipsoid 2 Point Option
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid 2 Point option in the Message Line. The Message Line reads: Ellipsoid Primitive: Enter center and radius point for ellipsoid.
	3. Click the center point and radius point in the drawing area.

	Ellipsoid by Diagonals Option
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid by Diagonals option in the Message Line. The Message Line reads: Ellipsoid Primitive: Enter start diagonal point. [Shift = Square]
	3. Click two points in the drawing area to specify two diagonal corners of the ellipsoid’s bounding box.
	4. The Message Line reads: Ellipsoid Primitive: Enter height.
	5. Drag to set the height of the ellipsoid.



	Solids from Curves Tools
	Creating Associative Profiles in Cobalt & Xenon
	Creating Solids from Profiles
	Lathed Solid Tool
	Using the Lathed Solid Tool
	1. Click the Lathe Solid tool. The Message Line reads: Lathed Solid: Select objects to lathe. [Shift=Extend]
	2. The Status Line contains the Degree and Draft Angle fields. Enter the desired values for the lathed solid. Tab between data fields.
	3. Pick a curve or curves to lathe. If selecting more than one curve, hold down the SHIFT key before selecting the first curve.
	4. Pick the line around which to rotate the curves and make the solid object.

	Geometric Characteristics

	Extrude Solid Tool
	Using the Extrude Solid Tool
	1. Click the Extrude Profile tool. The Message Line reads: Extrude Solid: Select close objects to extrude by vector. [Shift=Extend]
	2. The Status Line contains the dX, dY and dZ values, the Distance of the extrusion vector and the Draft Angle. Enter the desired Distance and the Draft Angle for the extruded solid. Tab between data fields.
	3. Pick one or more curves to extrude. As the Message Line indicates, they must be closed. If they are not, two messages appear. The first one says, "Gaps detected in profile. Would you like to examine gaps?" Click No to ignore the gaps and continue.
	4. Pick two points on the screen. The extruded solid is created.

	Geometric Characteristics

	Swept Solid Tool
	Using the Swept Solid Tool
	1. Click the Swept Solid tool. The Message Line reads: Swept Solid: Select closed profile to sweep. [Shift=Extend]
	2. The Status Line contains the Twist Angle and Draft Angle data fields. Enter the twist angle through which the solid will twist from beginning to end, and a draft angle, if desired.
	3. Pick one or more curves for the profile. As the Message Line indicates, they must be closed. If they are not, two messages appear. The first one says, "Gaps detected in profile. Would you like to examine gaps?" Click No to ignore the gaps and cont...
	4. Pick the point on the screen where the sweep will begin.
	5. Pick the curve or curves along which to sweep the profile.

	Geometric Characteristics

	Sweep 2 Rail (Paths) Solid
	Using the Sweep 2 Rail Solid Tool
	1. Select the Sweep 2 Rail Solid tool. The Message Line reads: Sweep 2 Rail Solid: Pick curves or group to sweep. [Ctrl = Maintain Height] [Shift = Extend]
	2. Pick the curves or group that defines the profile to sweep.
	3. Choose the first rail that the profile will be swept along.
	4. Choose the second rail that the profile will be swept along.

	Geometric Characteristics

	Cutout Feature Tool
	Using the Cutout Feature Tool
	1. Create a 2D profile with a curve or polygon tool and place it on or in the solid where the cutout will begin.
	2. Select the Cutout Feature tool. The Message Line reads: Cutout Feature: Pick solid for cutout.
	3. Select the solid to be cut. The Message Line now reads: Cutout Feature: Pick closed curves or polygon for cutting. [Shift=Extend]
	4. Select the profile previously created.
	5. Specify two points to indicate the direction and length of the cutout.

	Geometric Characteristics

	Protruded Feature Tool
	Using the Protruded Feature Tool - Vector Option
	1. Create a 2D profile where the protrusion will begin.
	2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: Pick solid for protrusion.
	3. Select the Vector Termination Type from the pull-down menu in the Message Line.
	4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or polygon for adding. [Shift=Extend]
	5. Select the profile previously created.
	6. Specify two points for protrusion direction and length.

	Using the Protruded Feature Tool - Face Option
	1. Create a 2D profile where the protrusion will begin. (It need not be on the solid.)
	2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: Pick solid for protrusion.
	3. Select the To Face Termination Type from the pull-down menu in the Message Line.
	4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or polygon for adding. [Shift=Extend]
	5. Select the profile previously created.
	6. Select the face on the solid where the protrusion will end.
	7. Specify two points for the protrusion direction. By specifying the direction, not the length, it is not necessary to reference the curve or the solid.

	Geometric Characteristics

	Cutout and Protruded Curve Checks
	Curve Gap Check
	Planar Curves Check

	Skinned Solid Tool
	Basic Skinned Solid Option
	1. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed curves or polygons for solid from sections. [Shift = Extend]
	2. Select the Basic Skinned Solid option in the Message Line.
	3. Hold down the SHIFT key and select the closed curves.

	Skinned Solid with Guide Curves Option
	1. Create the section curves and guide curve.
	2. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed curves or polygons for solid from sections. [Shift = Extend]
	3. Select the Skinned Solid with Guide Curves options in the Message Line.
	4. Hold down the SHIFT key and select the closed curves for all of the sections.
	5. Select the guide curves.

	Geometric Characteristics

	Solids from Profiles Curve Checks
	Closed Curves Check

	Pipe Solid Tool
	Using the Pipe Solid Tool
	1. Click the Pipe Solid tool. The Message Line reads: Pipe Solid: Select curve for pipe path. [Shift=Extend]
	2. Enter values in the Status Line data fields.
	3. Select the curve. To select more than one curve, hold down the SHIFT key before selecting the first curve.

	Geometric Characteristics


	Solid Feature Tools
	Blend Tools
	Advanced Blend Capabilities
	1. Create a curve along the z-axis.
	2. Select the Blend tool.
	3. In the Message Line select the Constant Blend tool and the Radial option for the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	4. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced Blend Options dialog box.
	5. Select the Specify Cross Section Orientation option and click OK to close the dialog box.
	6. Select the edge(s) for the blend.
	7. Select the curve.

	Constant Blend Tool
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend subtool and the Radial option from the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	3. To create a setback, enter the value in the Status Line data field.
	4. Select the edge(s) and/or face(s) for the blend.
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend tool and the Elliptical option from the pull-down menu. The Message Line reads: Elliptical Blend: Pick edges to blend, [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	3. Enter radius values for the ellipse, R1 and R2, in the Status Line data field. R1 is the major axis radius and R2 is the minor axis radius.
	4. Select the edge(s) for the blend.
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend tool and the Vertex Blend option from the pull-down menu. The Message Line reads: Vertex Fillet: Select vertex to blend. [SHIFT = Extend]
	3. Enter a radius in the Status Line data field.
	4. Select the vertex for the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	3. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced Blend Options dialog box.
	4. Turn off the Automatic Chain-select of Shared Edges option and click OK.
	5. Enter the desired radius in the Status Line.
	6. Select each of the edges individually to create a mitered intersection. (If the SHIFT key is held down, a smooth vertex blend will be created rather than a mitered blend.)
	1. Select the object.
	2. Choose Window>Design Explorer.
	3. Expand the history tree to display the fillet blend. (Cobalt and Xenon only)
	4. Double-click on the fillet blend to display the Edit Objects dialog box.
	5. Select the edge with the radius to change. The radius value appears in the data field. Enter a new radius.
	6. Click Apply to accept the changes and the geometry updates.
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	3. Hold the SHIFT key down and select the objects. The Message Line now reads: Constant Blend: Specify help position.
	4. Click the help position location. (If the help position does not create the blend try another location in the same quadrant.)
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down menu. The Message Line reads: Radial Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend]
	3. Enter the radius in the Status Line.
	4. Select the edge to blend.

	Variable Blend Tool
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Linear option from the pull-down menu. The Message Line reads: Linear Blend: Pick edge to linearly blend. [Pick edge near R1]
	3. Select the edge along which to make the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the By Position option from the pull-down menu. The Message Line reads: Position Blend: Pick edge(s) for variable radius blend. [End=ESC,Dbl Click] [Ctrl=Advanced (Windows) or Option=Advanced...
	3. Select the edge along which to make the blend. The Message Line reads: Position Blend: Specify location for radius value [End=ESC, Dbl Click].
	4. Enter a radius in the R field of the Status Line.
	5. Specify the location(s) along the selected edge for the radius.
	6. Enter a new radius in the R field.
	7. Specify the location for this radius along the edge.
	1. Create the curve that will be referenced for the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Radius Curve option from the pull-down menu. The Message Line reads: Radius Curve Blend: Pick edge for variable radius blend.
	3. Select the solid edge. The Message Line now reads: Radius Curve Blend: Pick radius curve (in positive xy plane).
	4. Select the radius curve.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Fixed Width option from the pull-down menu. The Message Line reads: Fixed Width Blend: Pick edges/ faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh)], [Shift=Extend]
	3. Enter the fixed width for the blend in the Status Line.
	4. Select the edge for the blend.
	1. Create a hold line curve.
	2. Select the Blend tool.
	3. In the Message Line, select the Variable Blend tool and the Hold Line option from the pull-down menu. The Message Line reads: Hold Line Blend: Pick edges/faces to blend. [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh)], [Shift=Extend]
	4. Select the edge for the blend. The Message Line now reads, Hold Line Blend: Pick curve for hold line. [Shift = Extend]
	5. Select the hold line curve.


	Chamfer Edge Tools
	Advanced Chamfer Capabilities
	Constant Length Chamfer Tool
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length option from the pull-down menu. The Message Line reads: Chamfer Edge: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] [Shif...
	3. Enter a setback value in the Setback data field of the Status Line, if desired, for three or more intersecting edges.
	4. Select the edges or faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face if necessary.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Two Lengths option from the pull-down menu. The Message Line reads: Chamfer Edge: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] ...
	3. Enter L1 and L2 values in the Status Line.
	4. Select the edges or faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face If necessary.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length and Angle option from the pull-down menu. The Message Line reads: Chamfer Length Angle: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced ...
	3. Enter an L1 and angle in the Status Line data fields.
	4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face when performing the operation.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Constant Length Chamfer tool and the Vertex Chamfer option from the pull-down menu. The Message Line reads: Vertex Chamfer: Select vertex to chamfer. [SHIFT = Extend].
	3. Enter an L1 value in the Status Line data field.
	4. Select the vertex to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length option from the pull-down menu. The Message Line reads: Chamfer Edge: Pick solid edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] [Shif...
	3. Enter a setback value in the Setback data field.
	4. Hold down the SHIFT key and select the edges to chamfer them.
	5. Using the Design Explorer, double- click on the chamfer to display the Edit Object dialog box.
	6. In the edge list select an edge. It’s associated L1 value appears in the length data field.
	7. Enter a new value in the field.
	8. Click apply and the chamfer updates.

	Variable Chamfer Edge Tool
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the Lengths option from the pull-down menu. The Message Line reads: Linear Chamfer: Pick edges/faces to linearly chamfer. (Pick edge near L1) [Ctrl = Advanced (Windows) or Option = A...
	3. Enter the L1 (the beginning setback length of the chamfer) and L2 (the ending setback length of the chamfer) values in the Status Line data fields.
	4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face when performing the operation.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Variable Length Chamfer tool and the Four Lengths option from the pull-down menu. In the Message Line select the Linear Chamfer tool. The Message Line reads: Chamfer Length: Pick solid edges to chamfer. [Ctrl = Advan...
	3. Enter the L1 and L2 values for the beginning setback lengths of the chamfer and L3 and L4 values for the ending setback lengths of the chamfer in the Status Line data fields.
	4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face when performing the operation.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the Lengths and Angles option from the pull-down menu. The Message Line reads: Chamfer Length Angle: Pick solid edges/faces to chamfer [Ctrl = Advanced (Windows) or Option = Advanced...
	3. Enter an L1 and A1 (angle) for the beginning of the chamfer and L2 and A2 (angle) for the end of the chamfer in the Status Line data fields.
	4. Select the edges or the faces of a part to chamfer. Use the Ambiguity box to specify the edge or a face when performing the operation.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the By Position option from the pull-down menu. The Message Line reads: Position Chamfer: Pick edges for variable position chamfer. [End = ESC, Double Click] [Ctrl = Advanced (Window...
	3. Select the edge along which to make the chamfer. The Message Line reads: Position Chamfer: Specify location for length value [End=ESC, Dbl Click].
	4. Enter a setback length in the Length field of the Status Line.
	5. Specify the location(s) along the selected edge for the chamfer.
	6. Enter a new length in the Length field.
	7. Specify the location for this length along the edge.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Variable Length Chamfer tool and the Fixed Width option from the pull-down menu. The Message Line reads: Fixed Width Chamfer: Pick edges/faces to chamfer. [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] ...
	3. Enter a width in the W data field of the Status Line.
	4. Pick the edge(s) for the chamfer.


	Hole Feature Tools
	Hole Direction
	Simple Hole Tool
	1. Select the Hole tool.
	2. In the Message Line select the Simple Hole tool. The Message Line reads: Simple Hole: Pick solid face to place hole.
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message line.
	4. Select the face where to locate the hole.
	5. Select the location for the center of the hole.
	6. If the 2-Pts direction is selected, click two points to specify the direction.

	Counter Bore Tool
	1. Select the Hole tool.
	2. In the Message Line select the Counter Bore Hole tool. The Message Line reads: Counter Bore: Pick solid face to place counterbore.
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message Line.
	4. Select the face to place the counter bore.
	5. Specify the location for the center of the counterbore hole.
	6. If the 2-Pts direction is selected, click two points to specify the direction.

	Counter Sink Tool
	1. Select the Hole tool.
	2. In the Message Line select the Counter Sink Hole tool. The Message Line reads: Counter Sink Hole: Pick solid face to place countersink.
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message line.
	4. Select the face where to locate the hole.
	5. Select the location for the center of the hole.
	6. If the 2-Pts direction is selected, click two points to specify the direction.


	Boss Feature Tool
	Boss Direction
	Using the Boss Feature Tool
	1. Select the Boss Feature tool. The Message Line reads: Boss Feature: Pick solid face to place boss.
	2. Select the boss direction from the pull-down menu.
	3. Select the face to locate the boss.
	4. Specify a location for the boss center.
	5. If the 2-Pts direction is selected, click two points to specify the direction.

	Geometric Characteristics

	Shell Solid Tool
	Using the Shell Solid Tool
	1. Select the Shell Solid tool. The Message Line reads: Shell Solid: Pick solid to shell [Ctrl = Keep Core (Windows) or Option = Keep Core (Macintosh)]
	2. In the Status Line, enter the desired offset or thickness of the shell.
	3. Select the solid. The Message Line reads: Shell Solid: Pick open faces [Shift=Extend].
	4. Select the face or faces that will be open. The object shells.

	Geometric Characteristics

	Bend Tool
	1. Click the Bend Solid tool. Select the Bend One End tool in the Message Line. The Message Line reads: Bend One End: Pick Solid to Bend.
	2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired values for the bend solid. Tab between data fields.
	3. Pick the solid to bend.
	4. The message line now reads, Bend One End: Enter two points for bend axis. Specify two points for the bend axis. The two points represent the inner tangent line for the bend solid. After clicking the two points, the solid is bent about the axis.
	5. The Message Line now reads: Bend One End: Pick Solid to Bend [Option = Flip Material]. Press the CTRL (Windows) or OPTION (Mac) key to flip the end that is bent.
	Using Bend Center
	1. Click the Bend Solid tool. Select the Bend Center subtool in the Message Line. The Message Line reads: Bend Center: Pick Solid to Bend.
	2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired values for the bend solid. Tab between data fields.
	3. Pick the solid to bend.
	4. The message line now reads, Bend Center: Enter two points for bend axis. Specify two points for the bend axis. The two points represent the inner tangent line for the bend. After clicking the two points, the solid is bent about the axis.
	5. The Message Line now reads: Bend Center: Pick Solid to Bend [Ctrl = Flip Material (Windows) or Option = Keep Material (Macintosh)]. Press the CTRL (WIndows) or OPTION (Mac) key to flip the side of the material that was bent.
	1. Click the Bend Solid tool. Select the Bend Along Path subtool the Message Line. The Message Line reads: Bend Along Path: Pick Solid to Bend.
	2. Pick the solid to bend.
	3. The message line now reads, Bend Along Path: Pick curve to bend solid to. Choose the curve.
	4. The Message Line now reads, Bend Solid: Enter two points for bend height axis. Specify two points for the bend axis. The two points represent the point at which the bend will start.
	5. The Message Line now reads, Bend Solid: Enter two points for alignment axis. Choose the points on the solid to aligned with the curve.

	Geometric Characteristics

	Twist Solid Tool
	Using the Twist Solid Tool
	1. Select the Twist tool from Solid Utility tool palette. The Message Line reads: Twist Solid: Pick solid to twist.
	2. The Status Line contains the Start Angle and End Angle fields. Enter the desired values for the twist. Tab between data fields.
	3. Pick the solid object to twist. The Message Line reads: Twist Solid: Enter two points for twist axis.
	4. Specify the start point for the region to twist.
	5. Specify the end point for the region to twist.

	Geometric Characteristics


	Solid Utility Tools
	Union Solid Tool
	Using the Union Solid Tool
	1. Select the Union Solid tool. The Message Line reads: Union Solid: Pick solid to add to.
	2. Select the initial solid.
	3. Select the solid(s) to add to the first solid. Hold down the SHIFT key before selecting the first solid to select multiple solids.


	Subtract Solid Tool
	Using the Subtract Solid Tool
	1. Select the Subtract Solid tool. The Message Line reads: Subtract Solid: Pick solid to subtract from.
	2. Select the initial solid.
	3. Select the solid(s) from which to subtract the first solid. Hold down the SHIFT key before selecting the first solid to select multiple solids Hold the CTRL key (Windows) or OPTION key (Mac) to retain the items subtracted.


	Intersect Solid Tool
	Using the Intersect Solid Tool
	1. Select the Intersect Solid tool. The Message Line reads: Intersect Solid: Pick two solids to intersect.
	2. Select the two solids to form the intersect solid.


	Trim Solid Tool
	1. Click the Trim Solid tool. The Message Line reads: Trim Solid: Pick curve or surface to trim solid.
	2. The Message Line now reads: Trim Solid: Pick solid to trim. [CRTL (Windows) or OPTION (Macintosh) = Flip direction to remove]
	3. The solid is trimmed to the curve, removing the solid in the direction of the arrows.
	4. Press the Control or Option key to change the material that is kept.

	Split Solid Tool
	1. Select the Split Solid tool. The Message Line reads: Split Solid: Pick solid to split.
	2. Select the solid. The Message Line reads: Split Solid: Pick surface for splitting solid.
	3. Select the infinite plane or surface to split the solid.

	Stitched Solid Tool
	1. Select the Stitched Solid tool. The Message Line reads: Stitched Solid: Pick surfaces to create solid from. [Ctrl=Advanced] (Windows) or Option=Advanced (Macintosh) [Shift=Extend]
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Stitching Options dialog box.
	3. Specify the settings and click OK. Click Cancel to close the dialog box.
	4. Hold down the SHIFT key and select the surfaces or drag a selection fence around them.

	Thicken Solid Tool
	Using the Thicken Solid Tool
	1. Select the Thicken Solid tool. The Message Line reads: Thicken Solid: Pick surface or solid to thicken. [CTRL or OPTION = Flip thickness side].
	2. Type the desired thickness in the Thickness data field in the Status Line.
	3. Select the surface or solid object to be thickened. The program thickens the selected object.


	Lofted Solid Tool
	Using the Lofted Solid Tool
	1. Select the Lofted Solid tool. The Message Line reads: Lofted Solid: Pick two faces for lofted solid.
	2. Enter a value in the Bulge data field.
	3. Select a solid face.
	4. Select a face on the other solid.


	Rib Solid Tool
	Using the Rib Solid Tool
	1. Select the Rib Solid tool.
	2. Specify the necessary option in the Message Line.
	3. The Message Line reads: Rib Feature: Pick solid for rib.
	4. Select the solid to which to add the rib. The Message Line reads: Rib Feature: Pick rib profile. [Shift = Extend]
	5. Once the rib profile is selected, the Message Line reads: Rib Feature: Specify 2 points for rib direction.


	Lip Solid Tool
	Using the Lip Solid Add Feature Tool
	1. Select the Lip Solid tool. The Message Line reads: Lip Feature Add: Pick curves for lip profile. [Shift = Extend]
	2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify profile origin.
	3. The Message Line reads: Lip Feature Add: Pick edges for profile to sweep. [Shift = Extend]
	4. Pick the edges of the solid to which to add the lip feature. In the example above, the edges of the green block were chosen.

	Using the Lip Solid Remove Feature Tool
	1. Select the Lip Solid tool. The Message Line reads: Lip Feature Remove: Pick curves for lip profile. [Shift = Extend]
	2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify profile origin.
	3. The Message Line reads: Lip Feature Remove: Pick edges for profile to sweep. [Shift = Extend]
	4. Pick the edges of the solid from which the lip feature profile will be removed. In the example below, the edges of the green block were chosen.



	Solid Face Modification Tools
	Draft Face Tool
	Rules
	1. Select the Draft Solid tool. The Message Line reads: Draft Solid: Pick reference face or edge for draft (click nothing for work plane].
	2. Select the reference face, edge or work plane. This tells the program the pull direction of the normal for the taper.
	3. Select a face or hold down the SHIFT key to select more than one face. The Message Line now reads, Draft Solid: Specify taper neutral position.
	4. Click a point on the screen to serve as the neutral position. The neutral position will remain constant.


	Match Face Tool
	Planar Example
	Elliptical Example
	Using the Match Face Tool
	1. Select the Match Face tool. The Message Line reads: Match Face: Pick face to modify.
	2. Select the face of the solid to modify or match to another face. To select more than one face be sure to hold down the SHIFT key before selecting the first face.
	3. Select the face of the solid that the selected face will match.

	Geometric Characteristics

	Move Solid Element Tool
	Using the Move Solid Element Tool
	1. Select the Move Solid Element tool.
	2. Select the desired option to move a vertex, edge or face. The Message Line reflects the option chosen. For Move Face it reads: Move Face: Pick faces of a solid to move [Shift=Extend].
	3. Select the face, vertex or edge of the solid to move. To select more than one, hold down the SHIFT key before selecting the first one.
	4. Select the two points to specify dX, dY, dZ values for the move. The order the points are selected determines whether the value is positive or negative.


	Offset Face Tool
	Using the Offset Face Tool
	1. Select the Offset Face Modeling tool.
	2. The Message Line reads: Offset Face: Pick faces of a solid to offset [Shift=Extend].
	3. In the Status Line enter a value in the data field. A positive value enlarges the object and a negative value reduces the object.
	4. Select the face of the solid to offset. To select more than one face be sure to hold down the SHIFT key before selecting the first face.

	Geometric Characteristics

	Remove Face Tool
	Using the Remove Face Tool
	1. Select the Remove Face tool.
	2. The Message Line reads: Remove Face: Pick faces of a solid to remove. [Shift=Extend]
	3. Select the face of the solid to remove. To select more than one face be sure to hold down the SHIFT key before selecting the first face.


	Replace Face Tool
	Using the Replace Face Tool
	1. Select the Replace Face tool.
	2. The Message Line reads: Replace Face: Pick face to replace.
	3. Select the face of the solid to replace. To select more than one face be sure to hold down the SHIFT key before selecting the first face.
	4. Select the replacement face.

	Replace Face Example
	1. Select the Rectangle tool and trace over the top face of the block.
	2. Select the Through Point B-Spline tool and create a three point spline from the midpoint of one edge to the midpoint of the opposite edge.
	3. Using the Selection tool, select the center control point of the spline and drag it up along the z axis some distance.
	4. Select the Skin tool.
	5. Select the Guide Curves option from the Message Line.
	6. Select the skin curves consisting of the right edge curves, (curves 1, 2 and 3 in the graphic).
	7. Select the guide curves consisting of the top and bottom curves (curves 1 and 2 in the graphic) to complete the skin surface.
	8. Select the Replace Face tool.
	9. Select the top face of the block to replace.
	10. Select the just created net surface to replace the face.

	Geometric Characteristics

	Parting Line Solid Tool
	Rules
	Using the Parting Line Solid Tool
	1. Select the Parting Line tool. The Message Line reads: Parting Line Solid: Pick solid for parting line.
	2. Select the solid to part. The Message Line reads: Parting Line Solid: Pick curves for parting line.
	3. Select the parting line curves. To select more than one curve be sure to hold down the SHIFT key before selecting the first curve.

	Modifying Parting Line Solids
	Geometric Characteristics

	Deform Face Tool
	Deform Face with Gain Option
	1. Select the Deform Face tool.
	2. Select the Deform Face with Gain option in the Message Line. The Message Line reads: Deform Face: Pick face to deform with pressure.
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the face or surface to deform.

	Deform Face to Point Option
	1. Select the Deform Face tool.
	2. Select the Deform Face to Point tool in the Message Line. The Message Line reads: Deform Face: Pick face to deform.
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the surface or face to deform.
	5. Click a location on the selected surface/face to set the point from which the face deforms.
	6. Click the final location for the face point where the deformation begins.

	Deform Face to Curve Option
	1. Select the Deform Face tool.
	2. Select the Deform Face to Curve option in the Message Line. The Message Line reads: Deform Face: Pick face to deform to curve.
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the surface or face to deform.
	5. Select the curve.


	Stretch Solid Tool
	Using the Stretch Tool
	1. Select the Stretch tool from Solid Utility tool palette. The Message Line reads: Stretch Solid: Pick solid to stretch.
	2. Pick the solid object to stretch. The Message Line reads: Stretch Solid: Enter two points for stretch region.
	3. The Status Line contains the Distance field. Enter the desired value for the stretch.
	4. Specify the starting point for the region to stretch.
	5. Specify the end point.



	Assembly Modeling Tools
	Assembly Connect Tool
	1. Select the Assembly Connect tool. The Message Line reads: Assembly Connect: Pick solid to move.
	2. Select the solid.
	3. Using the Drafting Assistant select the connection point on the solid to be moved.
	4. Select a different solid to which the first solid will be moved.
	5. Using the Drafting Assistant select the connection point on the stationary solid where the first solid will be connected.

	Assembly Mate Tool
	1. Select the Assembly Mate tool. The Message Line reads: Assembly Mate: Pick solid face to mate.
	2. Select the solid face to mate.
	3. Select the face of a different solid with which to mate the first.
	4. To offset the first solid a certain distance from the second, enter a value in the Status Line data field and press ENTER (Windows) or RETURN (Macintosh).

	Assembly Align Tool
	1. Select the Assembly Align tool. The Message Line reads: Assembly Align: Pick solid face to align.
	2. Select the solid face to align.
	3. Select the face of a different solid with which to align.

	Assembly Insert Tool
	1. Select the Assembly Insert tool. The Message Line reads: Assembly Insert: Pick solid face to align.
	2. Select the solid face to align.
	3. Select the face of a different solid with which to align the first.
	4. Select the solid face to mate.
	5. Select the face of a different solid with which to align the first.
	6. To offset the first solid a certain distance from the second, enter a value in the Status Line data field and press ENTER (Windows) or RETURN (Macintosh).


	Object Properties & Verification
	Geometric Properties
	X, Y, Z Command
	Angle 3 Points Command
	Distance Point-to-Point Command
	Minimum Distance Command
	Length Command
	Area Command
	Volume Command
	Properties Command
	Interference Command
	1. Display the model as a wireframe.
	2. Select the solids on which to perform the check.
	3. Choose Verify>Interference.
	4. To retain these interference solids in the model, check the Keep Intersection Solids box.
	5. Click Save or Print to save or print the log of the interference solids.
	6. Click Done to close the dialog box.


	Object Counts Command
	Check Object Command
	Surface Evaluation
	Evaluation Through the Verify Menu and Edit Object Window
	1. Select an object for examination.
	2. Activate the Surface Analysis icon in the View palette.
	3. Choose Verify>Surface Analysis>Environment Map or check the Environment Map option in the Edit Objects dialogue box on the Display tab. To edit the environment map, press the Edit button. The Environment Map Settings dialog box opens.
	4. Choose any Shader Type and the corresponding attributes and values, then click OK.
	5. When an object in the drawing area is selected and the Real-time Environment Map icon is clicked, one of the following Shader Types appear:
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Curvature Settings or double click the object to open the Edit Object window, click on the Display tab and press the Edit button.
	3. Select a Plot Style if the desired style is not already selected.
	4. To display a certain analysis/color area, place the pointer at the location over the color spectrum and click the mouse.
	5. To remove the triangular indicator, click in the dialog box outside of the color spectrum bar.
	6. Change the histogram values in the data fields and press the Recalculate button to update the surface curvature analyses for the plot style selected, or press the Recalculate All button to update the surface curvature analyses for all the plot sty...
	1. Select the object.
	2. Choose Verify>Surface Analysis>Draft Angle or check the option on the Display page of the Edit Object dialog box and click the Edit button.
	3. To display a certain analysis/color area place the pointer at the location over the color spectrum and click the mouse.
	4. To remove the triangular indicator click in the dialog box outside of the color spectrum bar.
	5. Change the histogram values in the data fields and the histogram and analysis automatically recalculates.
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Normals.
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Zebra.

	Surface Evaluation Through the Advanced Rendering Feature
	1. Select the surface.
	2. Double-click on the surface to display the Edit Objects dialog box.
	3. On the Material page of Edit Objects dialog box, click the Advanced button.
	4. From the Color class choose the surface evaluation type. The following window displays:
	5. Specify the value for each attribute.
	6. Click the Update button to preview the surface evaluation in the preview window.
	7. Click OK to save the changes and close the dialog box.
	8. Render the scene using one of the photorealistic commands in the PhotoRender menu.


	Draft Evaluation
	Draft Evaluation Through the Verify Menu or Edit Object Window
	1. Select the object.
	2. Choose Verify>Surface Analysis>Draft Angle or double click the object to open the Edit Object dialog box, check the option on the Display page and click the Edit button.
	3. To display a certain analysis/color area, place the pointer at the location over the color spectrum and click the mouse.
	4. To remove the triangular indicator click in the dialog box outside of the color spectrum bar.
	5. Change the histogram values in the data fields and the histogram and analysis automatically recalculates.

	Draft Evaluation Through Advanced Rendering
	1. Double click on the object to be evaluated to display the Edit Objects dialog box.
	2. Click the Advanced button to display the Render Material Settings dialog box.
	3. Select draft angle evaluation from the Shader Types list.
	4. Specify the settings for the attributes.
	5. Click OK to close the dialog box and save the settings.
	6. Render the object using one of the photo-realistic commands.



	Mesh Creation Tools
	3-point Mesh Tool
	Using the 3-point Mesh Tool
	1. Select the tool. The Message Line reads: 3-point Mesh: Enter 3 locations for mesh.
	2. Click three points to define the mesh boundary.

	Geometric Characteristics

	4-point Mesh Tool
	Using the 4-point Mesh Tool
	1. Select the tool. The Message Line reads: 4-point Mesh: Enter 4 locations for mesh.
	2. Click four points to define the mesh boundary.

	Geometric Characteristics

	Ruled Mesh Tool
	Using the Mesh Curve Tool
	1. Select the tool. The Message Line reads: Ruled Mesh: Select curves in order of meshing [Shift=Extend].
	2. Select a mesh spacing option from the pull-down menu.
	3. The Status Line displays the N data field which represents the number of mesh segments lines that will be distributed across the mesh.
	4. Click two or more curves to define the mesh boundary. These curves should not be connected. To select more than two curves, hold down the SHIFT key before selecting the first curve.

	Geometric Characteristics

	Extrude Mesh Tool
	Using the Extrude Mesh Tool
	1. Select the tool. The Message Line reads: Extrude Mesh: Select objects to extrude [Shift=Extend].
	2. The Status Line displays data fields to enter the delta values for the extrusion and the number of N segments for the mesh.
	3. Click one or more curves to sweep. To select more than one curve, hold down the SHIFT key before selecting the first curve.
	4. To enter a different value for the N segments than currently listed, select the field and type the new value. After the curves are selected, The Message Line reads: Extrude Mesh: Enter two points to extrude.
	5. Click two points to set the direction and the distance of the extrusion. The points do not have to be on the selected curves.

	Geometric Characteristics

	Mesh and Rendering
	Mesh Notations

	Text
	Text Tools
	Horizontal Text Tool
	1. Select the Horizontal Text tool from the main tool palette. The Message Line reads: Enter location for text. [Press Mouse to End]
	2. Place the cursor at the beginning location for the text and click. The cursor becomes a text cursor.
	3. Enter the desired text. Press ENTER (Windows) or RETURN (Macintosh), to begin a new and separate line of text that is aligned left with the previous line.

	Text Along a Curve Tool
	1. Create the curve along which the text will appear, placing the points in the order that the text will be placed. For a horizontal line created left to right, the text appears left to right. For a vertical line created top to bottom, the text appea...
	2. Select the Text Along a Curve tool from the main tool palette. The Message Line reads: Select path for text. [Shift=Extend]
	3. Select the just created curve. The cursor becomes a text cursor placed at the start point of the curve.
	4. Enter the desired text. It displays horizontally.
	5. Press ENTER (Windows) or RETURN (Macintosh) and the text line molds to the curve.

	Text at an Angle Tool
	1. Select the Text at an Angle tool from the main tool palette. The Message Line reads: Enter location for text.
	2. In the Status Line, enter the angle for the text in the Angle data field. Press ENTER (Windows) or RETURN (Macintosh) to register the value.
	3. Place the cursor at the beginning location for the text and click. The cursor becomes a text cursor.
	4. Enter the desired text. The text displays horizontally.
	5. Press ENTER (Windows) or RETURN (Macintosh) and the text angle changes.

	Geometric Characteristics
	Bounded Box Text Tool

	Text Commands
	Font
	Size
	1. Choose Text>Size>User.
	2. Select the size option, either Points or Units by clicking in the appropriate radio button.
	3. Enter the size.
	4. Click OK to accept the change and close the dialog box. Click Cancel to close the dialog box without accepting the changes.

	Style
	Case
	1. Select a text line.
	2. Choose Text>lower case, UPPER CASE or Title Caps.


	Text Handling
	Editing Text
	Moving Text
	Screen Horizontal Text
	Convert Text into Lines, Curves, Poligons.
	1. After the text is typed, choose Select tool.
	2. Right click on the text and choose the Change Object Type option from the context menu.
	3. Choose the type to which to convert the text.
	4. Uncheck the Delete Originals to leave the original text. In the picture below, the example on the left shows the result where original text was deleted, in the right example, the text was left. When the original text is not deleted, both the text ...
	5. Uncheck Use Work Layer box to be able to save the new object on any layer except the work layer.



	Dimensions
	Dimension Menu
	Dynamic Dimensions
	Dimension Tools
	Dimensions and the Work Plane
	Dimension Smart Pointer
	Dimensioning Objects and Placement
	1. Select the appropriate dimension tool.
	2. Click the points to measure.
	3. Move the dimension to a new location if it is not in the necessary location.

	Moving the Dimension
	1. Choose the Selection tool.
	2. Place the Selection tool over the dimension text and it becomes the Move symbol.
	3. Drag the dimension to the desired location.

	Dimension Status Line Fields
	Automatically Placing Dimensions on a Separate Layer
	Dimensions and Edit Objects
	Dimensioning Surfaces and Solids
	Smart Dimension Tool
	Using the Smart Dimension Option
	1. Select the tool from the Dimension tool palette. The Message Line reads: Smart Dimension: Pick curve to dimension.
	2. Select the curve.


	Horizontal Dimension Tools
	Horizontal Dimension Option
	1. Select the Horizontal Dimension option. Choose the Horizontal Dimension tool from the Message Line. The Message Line reads: Horizontal: Pick first dimension point.
	2. Click the left point of the geometry.
	3. Click the right point.

	Horizontal Base Line Dimension Option
	1. Select the Horizontal Dimension tools. Choose the Horizontal Base Line Dimension option. The Message Line reads: Horizontal Base Line: Pick first dimension point.
	2. Click the base point of the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears above the first measured from the base point. Continue clicking the points to dimension. Each dimension can dragged to a new location. Dimension and extension lines automatically redraw.

	Horizontal Chain Dimension Option
	1. Select the Horizontal Dimension tools. Choose the Horizontal Chain Dimension option. The Message Line reads: Horizontal Chain: Pick first dimension point.
	2. Click the first point on the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears measured from the last point clicked. Continue clicking all the points to be dimensioned. Each dimension can be dragged to a new location. Dimension and extension lines automatically r...


	Vertical Dimension Tools
	Vertical Dimension Tools
	1. Select the Vertical Dimension tool. The Message Line reads: Vertical: Pick first dimension point.
	2. Click the top point of the geometry first.
	3. Click the bottom point.

	Vertical Base Line Dimension Option
	1. Select the Vertical Dimension tools. Choose the Vertical Base Line Dimension tool. The Message Line reads: Vertical Base Line: Pick first dimension point.
	2. Click the base point of the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears to the right of the first measured from the base point. Continue clicking all the points to be dimensioned. Each dimension can be dragged to a new location. Dimension and extension lin...

	Vertical Chain Dimension Option
	1. Select the Vertical Dimension tools. Choose the Vertical Chain Dimension tool. The Message Line reads: Vertical Chain: Pick first dimension point.
	2. Click the first point on the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears measured from the last point clicked. Continue clicking all the points to be dimensioned. Each dimension can be dragged to a new location. Dimension and extension lines automatically r...


	Oblique Dimension Tool
	Using the Oblique Dimension Tool
	1. Select the Oblique Dimension tool. The Message Line reads: Oblique: Pick first dimension point.
	2. Click the left point of the geometry first.
	3. Click the right point.


	Ordinate Dimension Tools
	Horizontal Ordinate Dimension Option
	1. Select the Horizontal Ordinate Dimension option from the Message Line. The Message Line reads: Horizontal Ordinate: Pick first dimension point.
	2. Click the base point of the geometry.
	3. Click the next point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. Continue clicking all the points to be dimensioned. To display a dimension at the base point, click the base point after dimensioning all other points.

	Vertical Ordinate Dimension Option
	1. Select the Horizontal Ordinate Dimension option. The Message Line reads: Vertical Ordinate: Pick first dimension point.
	2. Click the base point of the geometry.
	3. Click the next point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. Continue clicking all the points to be dimensioned. To display a dimension at the base point, click the base point after dimensioning all other points.


	Radial Arrow Out Dimension Tool
	Using the Radial Arrow Out Dimension Tool
	1. Select the Radial Arrow Out Dimension tool. The Message Line reads: Radial Arrow Out: Select arc/circle.
	2. Click near the circle, arc or fillet to be to dimensioned.


	Radial Arrow In Dimension Tool
	Using the Radial Arrow In Dimension Tool
	1. Select the Radial Arrow In Dimension tool. The Message Line reads: Radial Arrow In: Select arc/circle.
	2. Click near the circle, arc or fillet to be dimensioned.


	Diameter Arrow In Dimension Tool
	Using the Diameter Arrow In Dimension Tool
	1. Select the Diameter Arrow In Dimension tool. The Message Line reads: Diameter Arrow In: Select arc/circle.
	2. Click near the circle or arc to dimension.


	Diameter Arrow Out Dimension Tool
	Using the Diameter Arrow Out Dimension Tool
	1. Select the Diameter Arrow Out Dimension tool. The Message Line reads: Diameter Arrow Out: Select arc/circle.
	2. Click near the circle or arc to dimension.


	Angular Dimension Tool
	Using the Angular Dimension Tool
	1. Select the Angular Dimension tool. The Message Line reads: Angular: Pick first line.
	2. Click on the first line near the endpoint from which the angle will be measured.
	3. Click on the second line.


	Center Mark Dimension Tool
	Using the Center Mark Dimension Tool
	1. Select the Center Mark Dimension tool. The Message Line reads: Center Mark: Select circle for center mark [Shift = Extend].
	2. Select the circle or arc to dimension. Hold down the SHIFT key if to dimension more than one object at the same time.


	Balloon Dimension Tools
	Using a Balloon Dimension Tools
	1. Select the Balloon Dimension tools.
	2. Select the desired balloon shape. The Message Line reads: Balloon: Enter 2 points for balloon dimension.
	3. Click the point on the geometry for the dimension arrow.
	4. Click the second point to specify the location of the symbol.
	5. Enter the text and frame width in the Status Line data fields. Press ENTER (Windows) or RETURN (Macintosh) to update the dimension.


	Length Along Curve Dimension Tool
	Using the Length Along Curve Dimension Tool
	1. Select the Length Along Curve Dimension tool. The Message Line reads: Length Dimension: Specify two points along curve.
	2. Click the first point along the curve.
	3. Click the second point along the curve.


	GD&T Feature Control Tool
	Using the Datum Feature Option
	1. Select the GD&T icon.
	2. Choose the Datum Feature option from the Message Line. The Message Line reads: Datum Feature: Input 2 Points (Arrow and Shoulder).
	3. Click the point on the geometry for the dimension arrow.
	4. Click the second point to specify the location of the symbol.
	5. Enter the text in the Status Line data fields. Press ENTER (Windows) or RETURN (Macintosh) to update the dimension.
	6. Move the dimension by choosing the Selection tool, selecting the dimension, placing the pointer over the end of the leader line, and when the pointer becomes the Move symbol, dragging the text to a new location.
	7. Enter specific text in the dimension, as necessary.
	8. The Status Line contains Text data fields.

	Using the Datum Target Option
	1. Select the GD&T icon.
	2. Choose the Datum Target option from the Message Line. The Message Line reads: Datum Target: Input 2 Points (Arrow and Shoulder).
	3. Click the point on the geometry for the dimension arrow.
	4. Click the second point to specify the location of the symbol.
	5. The datum target appears.
	6. Enter data for the upper and lower section in the Status Line data fields. Press ENTER (Windows) or RETURN (Macintosh) to update the dimension.
	7. Move the dimension by choosing the Selection tool, selecting the dimension, placing the pointer over the end of the leader line, and when the pointer becomes the Move symbol, dragging the text to a new location.
	8. Enter specific text in the dimension, as necessary.
	9. The Status Line contains Upper and Lower data fields.

	Using the Feature Control Frame
	1. Select the GD&T tool icon.
	2. Choose the Feature Control Frame from the Message Line. The Message Line reads: Feature Control Frame: Input 2 Leader Points (Arrow and Shoulder).
	3. Click the point on the geometry for the dimension arrow.
	4. Click the second point to specify the location of the symbol. The Feature Control dialog box appears. Fill in the dialog box using the parameters below.


	Dimension Appearance
	Linear
	Linear Tolerance
	Angular
	Text
	Font
	Size
	Style
	Color
	Weight
	Layer
	Arrowheads
	Arrow Size Command
	Witness Lines
	Dimension Standards
	1. Choose Dimension>Standards.
	2. In the Standards submenu, choose one of the listed standards.
	3. Click OK to accept the standard as the default and close the dialog box.
	1. Choose Dimension>Standards Settings.
	2. Enter values in the desired fields.
	3. Click Save As.
	4. Enter a new name in the data field.
	5. Click OK to close the dialog box and save the new standard.


	Dimensions and Drawing Views

	Fill and Crosshatching
	Fill Pattern and Fill Color
	Fill Pattern
	1. Choose the Selection tool.
	2. Select the polygon to display with a fill pattern. Hold down the SHIFT key to select more than one polygon.
	3. Choose Pen>Fill Pattern and one of the fill patterns.
	1. Select the existing polygon with the Selection tool.
	2. In the Pen menu, choose a new pattern from the Fill Pattern submenu.
	1. Select the existing polygon with the Selection tool.
	2. In the Pen menu, choose None from the Fill Pattern submenu.

	Fill Color
	1. Choose the Selection tool.
	2. Select the polygon to fill.
	3. Select the fill color. The color displays.
	1. Select the existing polygon by clicking it with the Selection tool.
	2. In the Pen menu, choose a new color from the Fill Color submenu.


	Crosshatching
	Cross Hatch Patterns
	Crosshatch Command
	1. Choose Pen>Cross Hatch. The Default Cross Hatch dialog box appears.
	2. Choose the crosshatch standard from the pull-down menu.
	3. Choose the category and the crosshatch pattern. The pattern appears in the pattern window.
	4. Specify a rotation angle and scale.
	5. Click Set Default. The default crosshatch pattern is set.
	6. Click the Close button (Windows) or the Close box (Macintosh) to close the dialog box.
	1. Select the object to crosshatch.
	2. To apply the default crosshatch, choose Pen>Hatch and the object is crosshatched.
	3. Choose the crosshatch standard from the pull-down menu.
	4. Choose the category and the crosshatch pattern. The pattern appears in the pattern window.
	5. Specify a rotation angle and scale.
	6. Click Apply. The pattern is applied to the selected object.
	7. Click the Close button to close the dialog box.

	Hatch Command
	1. Select the object to crosshatch.
	2. Choose Pen>Hatch.

	Editing Hatching
	Crosshatching and Section Cuts


	Symbols
	Symbol Palette
	Symbol Manager
	Creating Symbols
	1. Select a symbol tool.
	2. Press CTRL (Windows) or OPTION (Macintosh) to display the Symbol Manager.
	3. Click the New button. The Symbol Edit screen displays.
	4. Create the symbol geometry using any of the tools and commands in the program.
	5. When completing the symbol geometry, click the EXIT Edit Symbol button to return to the standard drawing area.

	Symbol Tools
	Symbol 1 Point Tool
	1. Select the Symbol 1 Point tool. The Message Line reads: Symbol 1 Point: Enter location for symbol [Ctrl (Windows) or Option (Macintosh) = Symbol Manager].
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol to place in the drawing.
	4. Click OK to close the Symbol Manager dialog box.
	5. Click in the drawing area to set the symbol's origin (as defined by the master).

	Symbol 2 Points Tool
	1. Select the Symbol 2 Points tool. The Message Line reads: Symbol 2 Points: Enter symbol origin and lever point [Ctrl (Windows) or Option (Macintosh) = Symbol Manager].
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol to place in the drawing.
	4. Click OK to close the Symbol Manager dialog box.
	5. Click the location for the symbol origin. The location is the symbol origin defined by the master symbol.
	6. Click the lever point. The symbol is placed in the drawing.


	Symbol Example
	1. Open a new file.
	2. Choose Window>Symbols to display the Symbol tools palette, if it is not already displayed.
	3. Select the Symbol 2 Points tool.
	4. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager.
	5. Click on the New button. The Symbol Edit screen appears.
	6. Create an object similar to the graphic here.
	7. Once the symbol is completed, select the Symbol 2 Point tool and then click the EXIT Edit Symbol button in the lower right corner.
	8. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager.
	9. In the Rename field, which is already highlighted, type BoomBox. As it is typed, the name is replaced in the Symbol Name list.
	10. Click OK to accept the name and close the Symbol Manager.
	11. In the drawing click to place the origin point.
	12. Move the cursor to the right horizontally using the Drafting Assistant and click to place the lever point.
	13. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager. The # Used field shows that the symbol was instanced once in the drawing.

	Transforming a Symbol
	Editing a Symbol
	1. Select a symbol tool.
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol to edit.
	4. Click on the Edit button.
	5. Make the changes.
	6. Click the EXIT Edit Symbol button.

	Symbols and Rendering
	Symbols and Files
	Using Symbols in Other Files
	Importing


	Viewing Geometry
	The View Palette
	Shade Options
	Shade Now
	Shade Options
	1. Choose View>Shade Options. The dialog box displays.
	2. Select the render options if necessary.
	3. Click OK and the options are accepted. (Click Cancel to close the dialog box without saving the settings.)
	1. Create some geometry.
	2. In the Shade Options dialog box, set Render Now to Hidden w/Dimmed and Static Render to Wireframe.
	3. Click OK to save the setting and close the dialog box.
	4. Choose View>Shade Now and the geometry is displayed in Hidden w/Dimmed view mode.
	5. Rotate the view. The geometry is now displayed as wireframe because of the Static Render setting.

	Lights & Facets

	Zooming
	Zoom Commands
	Zoom, Pan and Rotate Tools
	1. Choose the Zoom In tool. The Message Line reads: Zoom In: Pick area to enlarge. [Ctrl (Windows) or Option (Macintosh) = Zoom Out]
	2. Click in the drawing area; that position is displayed in the center of the screen and the drawing is enlarged or reduced by a factor of two. It is possible to drag a selection fence around an area so only that area is displayed.

	Using the Dynamic Pan Tool
	1. Select the Dynamic Pan tool. The Message Line reads: Dynamic Pan: Drag mouse to translate view.
	2. Place the pointer over the section of the screen to move and drag.

	Dynamic Zoom Tool
	1. Choose the Dynamic Zoom tool. The Message Line reads: Dynamic Zoom: Drag mouse to zoom view. Move right zooms out.
	2. Move the cursor to the drawing area. The cursor becomes the dynamic zoom icon.
	3. Drag the mouse to the right to zoom out or to the left to zoom in. The view scale changes according to the stroke.

	Stroke Zoom
	Zooming and Views

	Panning a View
	View Displays
	Pre-defined Views
	User-defined Views
	1. Choose View>New View.
	2. Enter the new name for the view.
	3. Select one of the Create By methods for defining the view. Enter the appropriate values according to the Create By option chosen.
	4. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close the dialog box without saving the view.)
	1. Display the Trackball.
	2. Rotate the view as desired.
	3. Click the view name on the Trackball to display the pull-down menu.
	4. Select Save Current View and release the mouse. The new view saves.

	Modifying a View
	1. Choose View>View Properties and select the view to change. The Modify View dialog box displays.
	2. Make all of the desired changes in the appropriate fields. (See the New View section earlier in this chapter for an explanation of the data fields.)
	3. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close the dialog box without saving the view.)

	Deleting a View

	View Rotation
	Choosing a Predefined View
	Choosing a User-defined View
	Choosing an Undefined View
	Dynamic Rotate Tool
	1. Select the Dynamic Rotate tool. The Message Line reads: Dynamic Rotate: Drag mouse to rotate view.
	2. Drag the cursor to change the view.

	Using the Shift and Arrow keys

	View Commands
	Redraw Screen
	View the Plane
	Show/Hide
	1. Select the Hide command. The Message Line reads: Select entities to hide. [Shift = Extend]
	2. Select an object. The object hides from view.
	1. Select the Show command. The Message Line reads: Select entities to show. [Shift = Extend]
	2. Select an object by clicking on the approximate location of the object or using a selection fence. The object shows on the screen.
	1. Select the Show Only command. The Message Line reads: Select entities to show only. [Shift = Extend]
	2. Select the object to display. Hold down the SHIFT key to select more than one object.

	Tile
	Arrange Icons (Windows only)
	Open File Windows

	Views and Planes
	Views and Zoom Scale

	Layers
	Layer Manager
	1. Open the Design Explorer (Window>Design Explorer).
	2. Choose Layout>Layer Manager:
	3. Click on the Work Layer Indicator to display the pop-up menu and choose the Layer Manager command.
	Default Layers

	Creating New Layers
	Using the Layer Manager
	1. Display the Layer Manager dialog box.
	2. Click the new layer button. A new layer is added to the layer list.
	3. The new layer is added.

	Using the Work Layer Indicator
	1. Click on the Work Layer Indicator to display the pop-up menu.
	2. Choose the New Layer command.

	Using the Isolate Layer Command
	1. Choose Layout>Isolate Layer.
	2. Click Create New Layer.
	3. Click OK to close the dialog box and save the new layer. The layer is now the active work layer and all other layers are hidden.


	Renaming Layers
	1. Display the Layer Manager dialog box.
	2. Click twice on the layer to rename, once to select the layer and the second time to rename it.

	Deleting Layers
	1. Display the Layer Manager dialog box.
	2. Select the name of the layer from the list box.
	3. Click on the trash can in the lower right corner of the dialog box. The layer is deleted.
	4. If the layer contains any geometry on it a warning appears.

	Hiding Layers
	Hiding One Layer
	1. Display the Layer Manager dialog box.
	2. Click on the show icon (the eye) to the right of the layer name to turn hide.

	Hiding all Layers
	1. Display the Layer Manager dialog box.
	2. Right click on a layer name and choose Hide All.
	3. Close the Layer Manager dialog box.


	Showing Layers
	Showing One Layer
	1. Display the Layer Manager dialog box.
	2. Click the box to the left of the layer name to turn on Show.

	Showing all Layers
	1. Display the Layer Manager dialog box.
	2. Right click on a layer name and choose Show All.


	Locking Layers
	1. Display the Layer Manager dialog box.
	2. Click in the Lock Layer column next to the desired layer and the lock icon appears.

	Unlocking Layers
	1. Display the Layer Manager dialog box.
	2. Click on the lock icon in Lock Layer column next of the desired layer. The lock icon disappears and the layer unlocks.

	Making a Layer the Active Work Layer
	Using the Layer Manager
	1. Display the Layer Manager dialog box if it is not already displayed.
	2. Click in the Work Layer column to the left of the desired layer.
	3. Close the dialog box and save the change.

	Using the Work Layer Indicator
	1. Click on the Work Layer Indicator to display the menu.
	2. Select the layer to make the active work layer.

	Using the Isolate Layer Command
	1. Choose Layout>Isolate Layer.
	2. Click on the arrow in the Layer entry field to display all available layers.
	3. Select the desired layer.
	4. Click OK to save this layer as the work layer and close the dialog box. All other layers are hidden.

	Increment Layer
	Decrement Layer

	Layers and Pen Color
	Using the Layer Color Override
	1. Display the Layer Manager tab of the Design Explorer dialog box if it is not already displayed.
	2. Click in the Layer Color column next to the desired layer. A color patch appears displaying the first color available, white.
	3. Click on the color patch to advance to the next patch color.
	4. For a list of available colors, to designate a custom color, or to remove colors right click (or CTRL+click on a single button mouse) on the column to display the color menu.
	5. Click OK to close the dialog box and save the change.

	Layer Color Warning

	Layers and Pen Style
	Using the Pen Style Override
	1. Display the Layer Manager tab of the Design Explorer dialog box if it is not already displayed.
	2. Click on the layer to activate. Right click on the layer to modify the line style.
	3. Choose the Independent Pen Defaults option from the context menu. All layers that are overridden appear in italics in the Design Explorer.
	4. Go to Pen>Style and choose one of the patterns available.
	5. The Independent Pen Defaults option becomes checked in the right click menu and the style name is indicated below in the parentheses.


	Layers and Copying/Pasting Objects

	Planes
	Work Plane
	Show Work Plane Command
	Work Plane
	1. From the work plane manager menu, choose New.
	2. Enter the values for the origin, right and up arms of the work plane. The locations can also be specified by clicking in the drawing area.
	3. Enter in name for the work plane in the Name data field.
	4. Click OK to save the new plane.
	5. Display the work plane manager menu again.
	1. Select the user-defined work plane to delete.
	2. Choose the Delete command. A warning box appears explaining that the operation cannot be reversed and asking for confirmation.
	3. Click Yes to delete the plane.
	1. Choose a user-defined work plane.
	2. Choose the Properties command. The Define Work Plane dialog box appears displaying the name and the X, Y, Z coordinates of the work plane.
	3. Change any value and click OK to close the dialog box and save the changes.

	Setting the Work Plane
	1. Click or drag on the Plane menu to display the submenu.
	2. Select one of the predefined planes.
	1. Choose Plane>3 Pts. The Message Line reads: Work Plane: Enter three points for work plane (1 origin, 2 x-axis, 3 y-axis).
	2. Click in the drawing area to indicate the origin point for the new work plane.
	3. Click a point to define the positive x-axis.
	4. Click a point to define the positive y-axis.
	1. Choose Planes>Pick Objects. The Message Line reads: Work Plane: Select objects to set Work Plane [Shift = Select].
	2. Select a curve or curves located in the plane set as the work plane.
	1. Click on the work plane icon at the left of the Status Line.
	2. From the menu select a work plane. (This menu displays the global work plane and any user-defined work planes.)

	Work Plane Snapping
	Work Plane Dimming
	Moving the Origin
	1. Choose Planes>Set Origin.
	2. Click in the drawing area to indicate the location for the new origin.

	Offsetting the Work Plane
	1. Display the work plane icon. (This is not required but it will help to visualize the offset.)
	2. Choose Planes>Offset.
	3. Enter the distance to offset (negative or positive) the work plane in the data field. The units for the distance are based on the Units page of Preferences.
	4. Click OK to accept the value and close the dialog box.


	Work Plane and Views
	Standard Views
	View the Plane

	Work Plane and World Coordinates

	Lighting
	Directional Lighting
	Light Palette
	1. Select the Distant Light tool. The Message Line reads: Distant Light: Enter location and direction positions.
	2. Click a point to set the location of the light.
	3. Click the next point to establish the direction of the light.
	1. Select the Spot Light tool. The Message Line reads: Spot Light: Enter location and direction positions.
	2. Click the first point to set the location of the light.
	3. Click the next point to establish the direction of the light.
	1. Select the Point Light tool. The Message Line reads: Point Light: Enter location.
	2. Click to set the source location of the light.
	1. Select the Linear Tube Light tool.
	2. Activate the Create Solid Body option in the Message Line to create a pipe body that presents source of light. When the light is visualised it looks like on the right picture above.
	3. Following the prompts in the Message Line, pick two points to specify the beginning and the end of the tube.
	4. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.
	5. Render the scene.
	1. Using the Tube Light From Curve
	1. Create a curve such as an arc, circle or spline, along which to create a light source.
	2. Choose Tube Light from Curve in the Lights tool palette.
	3. Activate the Create Solid Body option in the Message Line to create a pipe body that presents source of light. When the light is visualised it looks like on the right picture above.
	4. Following the prompts in the Message Line, pick the curve created.
	5. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.
	6. Render the scene.
	1. Select Rectangular Area Light tool from Lights palette in the Window menu.
	2. Following the prompts in the Message Line, click three points to build the rectangular area to be the light source.
	3. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.
	4. Render the scene.
	1. Create any surface object.
	2. Choose Area Light from Selected Surface in the Lights tool palette.
	3. Following the prompts in the Message Line, pick the surface.
	4. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.
	5. Render the scene.


	Ambient Lighting
	Modifying the Lights

	Default Lighting
	User-defined Lighting Layouts
	1. Select all the light sources by selecting each individually or using the Selection Mask.
	2. Choose File>Export.
	3. Select the Designer Elements program format.
	4. Choose the Selected Only option.
	5. Click OK and save the file as desired.

	Photo-realistic Sunlight for Stills and Animations
	1. Select PhotoRender>Edit Sunlight. The Sunlight Settings dialog box appears.
	2. Enter a city from the list for the longitude and latitude to show automatically, or click Add to include a custom location using longitude and latitude, and the time zone plus or minus from Greenwich Mean Time.
	3. Click Orientation and in the Sunlight Orientation box set the position of the sunlight by North and East vectors.
	4. Enter the desired date and time. This specifies the intensity of the sunlight automatically.

	Lights & Facets

	Display Materials, Decals & Environments
	Render Library
	Render Library Items
	Using the Materials Library
	1. Choose Window>Render Library to display the dialog box.
	2. Select the materials library and desired category in their respective menus.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the drawing, the pointer becomes the material application symbol.
	4. Continue dragging to the object to which to apply the image. The object highlights. Release the mouse button.
	5. Apply more images to the objects as desired. Then render the drawing using one of the commands in the Render menu.
	1. Select Deep Select tool, choose the face and designate the material from the Window>Render Library menu.
	2. Right-click on the material and choose Apply to Solid Face(s).
	3. Alternatively, choose the material from the Render Library menu, right-click it and select Apply to Solid Face(s) from the context menu. Then choose the face of the solid. The material is applied. Render the object to see the changes.

	Using the Decals Library
	1. Choose Window>Render Library to display the dialog box.
	2. Select the desired library and category in their respective menus.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the drawing, the pointer becomes the decal symbol.
	4. Continue dragging the decal to the object to which it is to be applied. Use the axes included with the symbol for alignment. Release the mouse button.

	Using the Backgrounds and Foregrounds Libraries
	1. Choose Window>Render Library to display the dialog box.
	2. Select the desired foreground or background library.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the drawing, the pointer becomes the application symbol.
	4. Drag to the drawing area and release the mouse button.

	User-defined Images
	1. Create the shape of the stencil.
	2. Color the stencil using a percentage of red depending on the desired stencil affect.
	1. Create own bitmaps images.
	2. Place them in the Textures folder located within the PhotoRender folder stored with the program.
	3. Apply a Designer Elements program supplied texture to the object.
	4. Double-click on the object to display the Edit Objects dialog box.
	5. From the Texture file menu select the image created.
	6. Click Apply and render the scene. Your own material is displayed on the object.
	1. Create your own bitmap images, both the decal stencil and the decal artwork.
	2. Place the stencils and image in the Textures folder located within the PhotoRender folder stored with the program.
	3. Double-click on the decal to display the Edit Objects dialog box.
	4. From the Stencil menu in Edit Objects select the stencil image created.
	5. In the Logo menu choose the Image option.
	6. From the Image menu, select the artwork image created.
	7. Click Apply and render the scene.
	1. Go to Window>Render Library.
	2. Right-click in the gray space of the Render Library dialog box to bring up the context menu and choose the Create New option. The Add Decal dialog box appears.
	3. Fill in the Name and Category fields or choose the Category from the drop down menu on the right.
	4. Choose Image from the Masking drop down menu.
	5. Specify the image file name from the Image drop down menu or browse the system.
	6. The custom decal is created with the desired file. The newly created decal can be used in the same way as all the other decals from the library.


	Editing the Rendered Scene
	Material Editing
	1. Double click on the object being modified to open the Edit Objects dialog box.
	2. Select the Material page.
	3. Click the Advanced button to display the Render Material Settings dialog box.
	4. Select the desired settings for each shader class, as desired.
	5. Preview the object using the Update button or the Auto option.
	6. Click OK, when the settings are satisfactory, to close the dialog box and save the settings.
	7. Render the scene with one of the photorealistic commands. The objects now appear based on the settings specified for each object.

	Background and Foreground Editing

	Photo-realistic Environment Maps for Stills and Animations
	Using a Photo-realistic Environment Map
	1. Go to Window>Render Library and select Environment Map from the drop down menu of the Render Library dialogue box. Then specify the type of the environment map.
	2. The system queries whether or not to apply an environment background.
	3. Choose Yes for the environment box to appear around the object that reflects it.
	4. Check the Use Environment Map option in the PhotoRender Menu.
	5. Apply the environment map by choosing one of the first nine options from the PhotoRender Menu.
	1. Use the PhotoRender>Edit Photorender Environment Map command. The dialogue box appears.
	2. Choose the type of the environment map from the drop down menu.
	3. Select the image(s) for the environment map.
	4. Click the Add to Render Library button to apply. Specify the name of the map to add to the render library and click OK.



	Photo-realistic Images
	Advanced Rendering Settings
	Custom Render Presets

	Interleaved Wireframe Geometry
	1. Check the Use Interleave Wireframe Geometry option in the PhotoRender menu or in the Photorealistic Render Settings window.
	2. Select the Edit Interleaved Wireframe Geometry Settings option in the PhotoRender menu or press the Edit button next to the Interleave Wireframe Geometry option in the Photo-realistic Render Settings dialog.
	3. The Interleave Wireframe Settings dialog box appears.

	Raytrace Rendering
	Photo-realistic Rendering Settings
	Photo-realistic Rendering Commands
	1. Apply materials to the objects in the scene.
	2. Choose PhotoRender> and the command.
	1. Apply materials to objects in the scene.
	2. Hold down the CTRL (Windows) or OPTION (Macintosh) key and from the PhotoRender menu, select one of the photorealistic commands.
	3. While still holding down the CTRL (Windows) or OPTION (Macintosh) key, drag a selection fence to define the rendering area.
	4. Release the CTRL (Windows) or OPTION (Macintosh) key and the mouse button.

	Render to File
	1. Create the drawing and apply the render materials to the objects.
	2. Choose PhotoRender>Render to File.
	3. Choose the render mode from the pull-down menu. Phong and Gouraud shading options can be used when rendering to a file.
	4. Choose the image file format.
	5. Enter the desired width and height values. If the Match Width/Height to Drawing Window Aspect box is checked, only enter a value in one field.
	6. Check Open Resulted File if necessary to view it at once.
	7. Click Save to create the file.

	Display Last Image Command
	Rendering and Multi-processors


	Animation
	QuickTime Movies with Camera Movement
	1. Create a curve along which the camera will travel for the movie.
	2. Choose Animation>Walk-through. The Message Line reads: Walk-through Animation: Pick curve for camera eye path. [Shift=Extend]
	3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
	4. Choose the settings.
	5. Click Save. The Save As dialog box appears.
	6. Type in the movie name and navigate to the location where to save the file.
	7. Click Save. The Compression Settings dialog box appears.
	8. Specify the settings for the compressor.
	9. Click OK. A progress dialog box appears providing a preview movie window and information on the number of frames generated.
	10. It is possible now to view the movie using QuickTime player.
	1. Create a curve along which the camera will travel for the movie.
	2. Choose Animation>Fly-by. The Message Line reads: Fly-by Animation: Pick curve for camera eye path. [Shift=Extend]
	3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
	4. Pick a reference point location towards which the camera will always be directed.
	5. Choose the settings.
	6. Click Save. The Save As dialog box appears.
	7. Type in the movie name and navigate to the location where to save the file.
	8. Click Save. The Compression Setting dialog box appears.
	9. Click OK. A progress dialog box appears providing a preview movie window and information on the number of frames generated.
	10. It is possible now to view the movie using QuickTime player.
	1. Create two curves, one to define the camera path and the other to define the reference point towards which the camera is directed.
	2. Choose Animation>Path. The Message Line reads: Paths Animation: Pick curve for camera eye path [Shift=Extend].
	3. Select the camera path curve. (Hold down the SHIFT key to select more than one curve.)
	4. Select the reference point curve.
	5. Choose the settings.
	6. Click Save. The Save document As dialog box appears.
	7. Type in the movie name and navigate to the location where to save the file.
	8. Click Save. The Compression Setting dialog box appears.
	9. Click OK. A progress dialog box appears providing a preview movie window and information on the number of frames generated.
	10. It is possible now to view the movie using QuickTime player.
	1. Create the background image in a graphic software.
	2. Place the image file in the Textures folder within the PhotoRender folder.
	3. Display the Render Library.
	4. Select the Backgrounds library and the Images category.
	5. Apply the VS Logo image to the background.
	6. Choose PhotoRender>Edit Background.
	7. Select image in the Shader Types list.
	8. From the Attribute Value pull-down menu, choose the image.
	9. Click OK and render the scene.

	QuickTime VR Movies
	1. Create the drawing and apply the render materials to the objects.
	2. Choose Animation>Object VR.
	3. Enter the desired values.
	4. Click Save to create the movie.
	1. Create the drawing and apply the render materials to the objects.
	2. Choose Animation>Panoramic VR.
	3. Enter the desired description and values.
	4. Click Save to create the movie.


	File Management
	Using Documents
	File Use and Operating System Short Cuts
	File Menu Commands
	1. Choose File>Open.
	2. Choose the appropriate folder containing the document to open.
	3. Click the File name to open in the list box.
	4. Click OK.
	1. Choose File>Save As.
	2. If necessary, display a different folder.
	3. Type the name to use in the File name box.
	4. Click OK.
	1. Choose File>Revert. The following dialog box appears.
	2. Click OK to return to the original file opened and close the dialog box. (Click Cancel to close the dialog box without enabling the command.)


	Files and Preferences
	Files and Locking
	File Size & Deleting
	Uninstalling This Program on Windows

	Importing & Exporting
	Importing
	Supported Import Formats
	1. Go to File>Import.
	2. Choose DWG or DXF formats in the Import dialog box and click OK.
	3. Navigate to the place where the file is located with the Open window and click Open button.
	4. Input the password in the Enter Password Dialog box and click OK.
	5. The drawing opens in the Cobalt window.

	Import Command
	1. Choose File>Import.
	2. Select the Import type from the list and the options for the type as desired.
	3. Click OK. The standard Open dialog box appears.
	4. Navigate to the file to import.
	5. Click Open to import the file.
	1. Select File>Import.
	2. Specify the import option Spline.
	3. Click OK. This Designer Elements program displays the standard Open dialog box.
	4. Select a text file that contains the coordinates for the spline.
	5. Click Open to import the file.

	Importing Tips and Notations

	Exporting
	Supported Export Formats
	Export Command
	1. Choose File>Export.
	2. Select the export type and its options. To export only selected objects on the screen, rather than the entire document, click Selected Only.
	3. Click OK. The standard Save document as dialog box appears prompting a name and location for the exported file.
	4. Enter the file name and click Save. The exported file is saved with the name and location entered.

	Exporting Tips and Notations

	Batch Convert Tool
	1. Create two new computer folders. One will host all of the source files that will be converted. The other will receive the converted files.
	2. Place all files to be converted in one batch in one of the folders created in step 1.
	3. Choose File>Convert.
	4. In the Convert dialog box indicate the input and output file types along with any options available. Activate the Batch check box and click OK.
	5. In the first dialog box navigate to the new folder containing the files to convert. Click OK.
	6. In the second dialog box navigate to the destination folder and click OK.


	Drawing Composition for Cobalt & Xenon
	Model to Sheet Command
	Using the Model to Sheet Command
	1. Select the models to display on the sheet.
	2. Choose Layout>Model To Sheet.
	3. Choose the Layout, Rendering and Wirefrme options from their respective pull-down lists.
	4. Enter a scale in the Scale field.
	5. Click OK.

	Undoing the Model to Sheet Command

	Drawing Views
	Activating Views
	Drawing View Menu
	1. Select the view to align.
	2. In the Drawing View menu, choose the Align command. The Message Line reads: Align View: Pick parent view to align with.
	3. Select the parent view. The two views align.


	Sheet Tools
	Drawing View Tool
	1. Select the Drawing View tool. The Message Line reads: Drawing View: Pick start position view frame.
	2. Click the starting point position for the frame. The Message Line now reads: Drawing View: Pick end position view frame.
	3. Click the ending point position for the frame.
	1. Turn on the layers containing the 3D geometry to place in the new view.
	2. Select the 3D geometry.
	3. Choose Edit>Copy.
	4. Select the empty drawing view.
	5. Choose Edit>Paste.

	Auxiliary View Tool
	1. Select the Auxiliary View tool. The Message Line reads: Auxiliary View: Pick drawing view for auxiliary view.
	2. Select the drawing view from which to create the auxiliary view.
	3. Click the start and endpoint locations that specify the folding line for the view. The points do not need to be located on the geometry.
	4. Drag the view to a new location and click the mouse button. Notice that as the pointer is moved, an outline of the frame appears.

	Section View Tools
	1. Select the Section View tool.
	2. Select the Vertical Section View tool in the Message Line. The Message Line reads: Section View: Pick drawing view for section.
	3. Select the drawing view.
	4. Click a point on the geometry for the section.
	5. Drag the view to a new location and click the mouse button. Notice that as the pointer is moved, an outline of the frame appears.
	1. Select the Section View tool.
	2. Select the Horizontal Section View tool in the Message Line. The Message Line reads: Section View: Pick drawing view for section.
	3. Select the drawing view.
	4. Click a point on the geometry for the section.
	5. Drag the view to a new location and click the mouse button. Notice that as the pointer is moved, an outline of the frame appears.
	1. Select the Section View tool.
	1. Select the 2 Pt Section View tool. The Message Line reads: Section View: Pick drawing view for section.
	2. Select the drawing view.
	3. Click two points on the geometry to indicate start and end points for the section cutting line.
	4. Drag the view to a new location and click the mouse button. Notice that as the pointer is moved, an outline of the frame appears.
	1. In the section view, select the hatch pattern.
	2. Choose Pen>Cross Hatch. The following dialog box displays.
	3. Select a category and Cross Hatch pattern from their respective lists.
	4. Set the hatch rotation angle and scale.
	5. Click Apply to change the selected hatch.
	6. Click the Close button (Windows) or the Close box (Macintosh) to exit the dialog box when finished.

	Detail View Tool
	1. Select the Detail View tool. The Message Line reads: Detail View: Pick drawing view for detail view.
	2. Select the drawing view.
	3. Click the center point on the geometry for a detail view.
	4. Click the detail edge point.
	5. Drag the view to a new location and click the mouse button. Notice that as the pointer is moved an outline of the frame appears.

	Manual View Regeneration Tool
	1. Select the Manual View Regeneration tool.
	2. Click Yes to regenerate all views.


	Unfolding Views
	1. Choose the Selection tool and activate to unfold.
	2. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and drag the view to the left, right, top or bottom of the view.

	Editing a Drawing View
	Adding Objects to a View
	Editing Objects in the View
	Editing View Characteristics

	Layout Templates
	1. Open one of the files in the Layouts folder.
	2. Make any changes. It is possible to adjust the format, add text to the title block, and add or remove drawing views.
	3. Save the file under another name in the desired Layouts folder.
	1. Open a new file.
	2. Set the view and plane to Top.
	3. Create the title block and border for the layout and add text if desired.
	4. Using the Drawing View tool, add drawing views.
	5. Save the file in the Layouts folder.

	Printing the Layout

	Attributes and Bill of Materials
	BOM User Defined Templates

	Page Setup and Printing
	Page Layout Command
	Setup Mode Section
	Drawing Size Section
	1. Choose File>Print Layout.
	2. Choose the Height and Width mode from the pull-down menu.
	3. Display the pull-down menu for the drawing format size.
	4. Select the desired size.
	1. Choose File>Print Layout.
	2. Choose the Rows and Columns mode from the pull-down menu.
	3. Enter the desired values in the Rows and Cols fields. The drawing size fields adjust accordingly.
	4. Specify the overlap for the tiled pages. The units are determined by the preferences setting.
	1. Choose File>Print Layout.
	2. Display the pull-down list for the scale.
	3. Select the desired scale. The scale appears in the edit field.
	1. Draw some geometry.
	2. Choose File>Print Layout. The Drawing Size dialog box displays. The Preview window shows a red rectangle representing the object area.
	3. Check the Overlay Drawing box to display the actual geometry.
	4. Click OK in the dialog box to close it.
	5. Select an object within the page bounds.
	6. Choose File>Print Layout to display the dialog box again.
	7. Check the Print Selected box. The Preview window zooms in on selected object.
	8. Click the Overlay Drawing check box to remove the check mark. Only the selected geometry displays.

	Drawing Size and Short Cut Key

	Printing a Drawing
	Print Setup (Windows); Page Setup (Macintosh)
	Print Command
	Printing/Plotting Region
	Moving the Print Boundaries
	1. Choose File>Print Layout.
	2. Select the Show Page Breaks in Drawing Window check box.
	3. Click OK. The dialog box closes and the page boundaries are displayed in the drawing.
	4. Place the cursor over the marker at the lower left corner. It becomes the Move symbol.
	5. Drag the boundaries to the new location.

	Printing and Rendering

	Print Window

	Dimensionally Constrained Parametrics
	Sketch Mode
	1. Hides tool palettes such as surface and solid modeling which have no meaning in the 2D sketch environment.
	2. Adjusts the Drafting Assistant to always snap into the sketch plane and see only snaps in the sketch plane. This is accomplished by turning on the "Work Plane" and "Plane Only" options in the Snaps dialog box.
	3. Turns on Auto Constraints. Auto Constraints will automatically create geometric relationships (coincident, tangent, concentric, perpendicular) as geometry is created and modified. It can be turned off in sketch mode through the popup menu activate...
	4. Creates a set of layers for the sketch that includes the container layer, "Sketch 1" and sub layers that include construction, profile, constraints, and dimensions. Note the geometry in the construction layer is ignored if the sketch is used in pr...
	5. Turn on Dimming. This feature is useful when working on faces of solids where edges not in the sketch plane are dimmed. In addition, if a sketch on the face of a solid is modified, the part is rolled back to the point where the sketch was original...
	Reference Edges
	Exiting Sketch Mode

	Sketch Mode Tools
	Sketch Tool
	Auto Constraints Tool
	Horizontal Constraint Tool
	Vertical Constraint Tool
	Coincident Constraint Tool
	1. Pick the first curve for coincident constraint.
	2. Pick the position along the first curve using the Drafting Assistant.
	3. Pick the second curve for the coincident constraint.
	4. Pick the position along the second curve using the Drafting Assistant.

	Tangent Constraint Tool
	Parallel Constraint Tool
	Perpendicular Constraint Tool
	Fixed Constraint Tool
	Concentric Constraint Tool
	Symmetric Constraint Tool
	Equal Constraint Tool
	Colinear Constraint Tool
	Offset Constraint Tool
	Dimension-driven Geometry
	Constraint Animation Tool

	Dimensional Constraint Animation Controller
	Dimensional Constraint Animation Settings
	Running the Animation

	Deleting Constraints
	Verifying Constraint Relations
	Constraint Preferences

	Variables and Equations
	Using Equations & Variables
	Using the Variables/Equations Dialog Box
	1. Move the cursor to the Dimension Value field to be highlighted.
	2. Click and hold down the mouse button.
	3. The dimension highlights.

	Using the Edit Objects Box for Variables & Equations

	Defining Equations
	1. Click in the equation field of the dimension to be changed.
	2. Add a mathematical expression, such as D1*2/3.
	3. Click Apply for the changes to take place.
	Nested Equations
	Conditional Equations


	Preference Settings
	Default versus Selected Object Settings
	Preferences
	Colors
	1. Click New. The color palette is displayed.
	2. Choose the background colors.
	3. For a solid color background uncheck the Gradient box.
	4. To use an image as a background, check the Image box and select the desired one from the drop down list or browse to select it from the system. Click OK.
	1. Click New. The color palette is displayed.
	2. Choose the foreground color.
	3. Click OK. The new foreground displays in the view window with the color name.

	Dimensional Constraint Manager (DCM) (Cobalt Only)
	Display
	Drafting Assistant
	File Associations
	Filing
	General
	Grid
	1. Click New to display the color palette.
	2. Select a color from the palette.
	3. Click OK to accept the color and return to the Grid page. The new color now displays in the grid view window with the color name. For colors other than the standard colors, the color values display to the right of the view window.

	Localization
	Mouse
	Paths
	Select
	1. Click New to display the color palette.
	2. Select a color from the palette.
	3. Click OK to accept the color and be returned to the Select page. The new color now displays in the view window with the color name. For colors other than the standard colors, the color values display to the right of the view window.

	Skins
	SpaceMouse
	Units
	Alchemy
	Changing the Preference Settings with the Preferences Command
	1. Choose File>Preferences.
	2. Select the desired category to set.
	3. Make desired changes.
	4. Select another category or click OK to close the dialog box.

	Changing the Preference Settings Manually
	1. Quit the program.
	2. Open the Preferences file, prefs.ini, in a text editor.
	3. Make the desired change to the characteristics.
	4. Save and close the file.
	5. Relaunch the program.

	Preferences and Object Creation

	Pen and Dimension Preferences
	Shortcuts
	Creating a New Shortcut
	1. Choose File>Shortcuts.
	2. Select the desired category and command in the appropriate sections.
	3. Enter the key combination into the Shortcut key data field.
	4. Click Assign. The key combination displays next to the selected command.
	5. Continue entering all key combinations as desired.
	6. Click OK to save the new shortcut keys and close the dialog box.



	Appendix A: Mathematical Operators
	Appendix B: Special Characters
	Windows:
	Macintosh:

	Appendix C: ShortCuts
	Short Cut
	Key
	Action

	Appendix D: Spline Text Files
	1. Use a text editor, a word processor or a spreadsheet to create a text file.
	2. Input X, Y and Z values for the spline coordinates.
	3. Save the file as Text only and import into Cobalt, Xenon or Argon using the Spline Import format to create the spline.

	Appendix E: Photo-realism Fundamentals
	Creating the Environment
	Modeling Tips for More Realism
	1. Use the Deep Select tool to select one face of a solid and apply necessary material to it.
	2. Choose Edit>Change Object Type... and change the object to surfaces. This allows you to place different materials on each different surface.
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	How to View the Scene
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	Practice Makes Perfect
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