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User Guide Documentation
This User Guide is written for both Windows and Mac OS X platforms of Graphite. 
Before using this manual it is necessary to install Graphite using the instructions 
contained in the Getting Started Guide that came with the software. After 
installation continue with the tutorial exercises included in that book to familiarize 
yourself with the tools, features and commands of Graphite, and to maximize your 
productivity in the shortest amount of time.

Chapter Layout
The chapters are arranged in the order of the design process starting with the 
basics. It then provides explanations of each tool, editing procedures, adding 
details and printing. Each chapter contains subheadings indicating the different 
sections and within those are further subdivisions as needed.

Windows and Macintosh Notations
Throughout the manual, notations are included to perform tasks using either 
platform. Steps are identical except for specific keyboard commands. In cases 
where the steps vary, each are listed. 

Menus and Submenus

Choosing Commands
In the example exercises, you are directed to choose commands contained in 
submenus of other menus. For example, if asked to select Define in the Color 
submenu of the Pen menu, it appears as Pen>Color>Define.
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Tip:

Tips, referrals to other 
chapters, and alternative 
ways to accomplish a task 
are displayed in the 
margin throughout the 
manual.
Margin Notes
Graphite includes margin notes that provide information that may help you use the 
software. There are three types of margin notes: Tips, Tech Notes and Referrals. 
These notes have been given a special treatment so that you can instantly 
recognize their significance and locate them for future reference.

Tip
A tip provides instructions for getting the most out of Graphite. Tips may show you 
how to speed up an operation or how to perform some timesaving drawing 
technique.

Tech Note
A technical note provides additional technical information, not necessary for using 
Graphite but useful in understanding how it works.

Referral
A referral directs you to related information contained somewhere else in the 
manual for the particular topic being addressed.

Style Conventions
This manual uses various style conventions which highlight certain terms or 
phrases. The list below includes an explanation and an example in parentheses. 
The conventions are as follows:

Bold Tool palette names (Light palette); Tool name 
(Single Line tool); Keyboard-entered text; 
Definition terms (as shown in these style 
conventions).

Italic Terms used for the first time in a chapter; 
(Parametrics); Drafting Assistant notations 
(midpoint); tool and dialog box options (Angle 
data field); book references (User Guide); 
Message Line directions (Single Line:Pick the 
beginning point.); margin note headings (Tip); 
menu commands (Extrude); filenames 
(Graphite.ini); stand alone extensions (.dwg); 
directory names; drawing names.

Bold and Italic Command series (Pen>ColorDefine).

ALL CAPITALS Key names on the keyboard (ENTER, RETURN).
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Referral:

Specific page information 
on a particular tool or 
command can be found 
in the index.
Title Capitalization Dialog box names (Edit Objects); menu names 
(Pen menu); special Graphite phrases (the 
Drafting Assistant).

all lower case File names (graphite.ini); stand-alone file 
extensions (.dwg).

User Guide Chapter Breakdown
The chapters are grouped into sections dealing with a specific area.

Sections

1. Overview Contains chapters that provide information on the 
documentation layout, basic elements of Graphite 
and the Drafting Assistant.

2. Setting the Contains information on setting the drawing 
environment.

3. Creating Geometry Contains information on creating geometry using 
the tools of Graphite.

4. Editing Contains information on using the tools and 
commands to edit your geometry.

5. Document Detailing Contains information on adding text and 
dimensions to your drawing.

6. Viewing Your Designs Contains information on viewing your geometry.

7. Documents Contains information on opening, saving, 
importing and exporting files.

8. Parametrics and Contains information on using parametrics and 
placing symbols.

9. Geometric Analysis Contains information on performing a 2D analysis 
on your geometry.

Environment

Symbols
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Appendices
Operators and Units Describes all operators and units which are 

accepted by all Graphite data fields.

Special Characters Lists all special characters not directly available 
from the keyboard and symbols that are used in 
Graphite.

Program Settings & Files Contains all of the default settings for Graphite 
following installation. It also includes a list of all 
the folders and files that come with the program.

Other
Glossary Defines terminology used in Computer Aided 

Design and Drafting (CADD) and Graphite.

Index Lists features, tools and actions in Graphite and 
their associated page number location in the 
manual.

Graphics
Most of the graphics in the manuals apply to both platforms of Graphite. In those 
instances that require a platform and software reference, a Graphite Windows 
graphic is used. When necessary, both Windows and Macintosh graphics are 
included.
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New Update Installer
In the Graphite Help menu is an item called Check 
Web For Update. Click it and Graphite links to the 
Ashlar-Vellum website to see if a new build of the 
software is available as a free update. This update 
will be a small file, not the entire program, which 
can be downloaded without disturbing your 
Preference file or your registration codes. 

Tool Description Option
The Help option in the Help menu opens the 
manual in your default browser to the description of 
the selected tool. Activate the Help>Help menu 
option then click on the desired tool. Your web 
browser opens showing the description of that tool.
1-5
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Graphite Overview
Graphite Overview
As mentioned in the Getting Started section of this manual, Graphite is a powerful 
program that is quick to learn and use due to its technology. Graphite helps you 
get the job done within your timeframe.

This chapter provides a brief overview of the following concepts:

• chapter 2 Wireframe Drafting

• chapter 2 The Models

• chapter 2 The Drafting Assistant

• chapter 2 The Design Process (including Drawing at Full Scale and Drawing 
Formats)

Wireframe Drafting
In Graphite you create wireframe models. A wireframe model consists of 
the geometry that makes up the edges of the object.

A wireframe model is often used in place of a prototype so that simulations and 
tests are accomplished on the computer rather than in the laboratory. Models are 
used for checking the visual specification, measuring distances between points 
within the model and observing the visual and real intersections of lines.

3D wireframe models are most useful for showing multiple views and doing 2D 
dimensioning and drafting on those views. This lets you design in 3D, and then 
produce 2D working drawings from that 3D model.
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Referral:

The definition of models is 
also discussed in 
Chapter 14.
The Models
Models exist in 3D space in the computer’s memory, whether the geometry is two 
or three dimensional. A model is any combination of geometry, such as lines, arcs, 
circles, dimensions, text, etc. Models are created in an infinitely large three-
dimensional area. (In the following graphics each model has its own imaginary 3D 
model space). Models are not created directly on the sheet. What you see on the 
sheet is only a projected view of the model.

A sheet in Graphite is an infinite 2D planar area (always aligned parallel to the 
screen) that displays an image of one or more models. View the model as if 
looking through a camera while it moves around the model. The image of a model 
is picked up by either a sheet camera or a detail view camera. The sheet camera 
projects the image directly onto the sheet (called a Sheet View). The detail view 
camera projects the image into a view window (called a Detail View) which rests 
on the sheet. Sheets do not actually contain any geometry, only images of 
geometry.

Your computer screen 
displays all the views on the 
current sheet. In the graphic 
on the right a Top view of the 
model is picked up by the 
sheet camera and projected 
onto the current sheet. In the 
Top view the sheet camera is 
aligned parallel to the sheet.

Opening a document, you are 
looking down on top of the x, y 
plane and you cannot see 
anything in the z-direction, 
which is coming toward you, 
away from the screen. 
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Graphite 3D Models
Rotate the image to see what you are drawing in the z-direction. 

The on-screen Trackball rotates the sheet camera around the 3D model. This 
changes your orientation, it does not rotate the model. The three-dimensional 
object geometry (the model) stays fixed, even if the opposite impression is 
displayed on the screen.
2-3
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In the following graphic the sheet camera is rotated to the Trimetric view.

When rotating the image with the on-screen 
Trackball, it is as though the movement of the 
pointer on the Trackball corresponds to a fulcrum; 
the location where you press the mouse button 
becomes the fulcrum and the movement of the 
mouse rotates the model around that fulcrum point. 
What you see on the screen responds to the view of 
the sheet camera.

Graphite 3D
When creating view windows, either detail views, drafting layouts, or design 
layouts, each view window looks at the same model. When a change is made in 
any view window, the model changes; therefore, the model in every view changes. 

For more information on models, see chapter 14 Advanced Viewing Techniques.
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The Drafting Assistant
The Drafting Assistant is unique to Ashlar-Vellum software and makes Graphite 
easy to use because it thinks like a designer. The Drafting Assistant guides a 
designer in the creation of geometry. It displays temporary construction lines, 
provides information about existing geometry, and gives notations of the 
relationship between new and existing geometry in all three dimensions.

Move the pointer near an existing geometric construction and the Drafting 
Assistant’s snap point locks onto individual geometry, displaying an on notation. 
The Drafting Assistant also displays information about geometric landmarks, such 
as endpoints and centers, and temporary automatic construction lines, such as 
alignment and tangents. 

The following examples illustrate the alignment notations for the x, y and z axes.

align:z The z-direction is 
perpendicular to the work 
plane.

align:x The x-direction is parallel 
to the work plane.

align:y The y-direction is parallel 
to the work plane.

 

For more information on the Drafting Assistant, see 
chapter 4 The Drafting Assistant

align:z

on

align:x

on

align:y

on
2-5



2-6

Graphite Overview Ashlar-Vellum
The Design Process
The computer revolutionized the design process. Graphite has contributed to this 
by allowing you to quickly design a model that previously existed only in your 
mind's eye. 

Graphite
Using Graphite it is possible to start designing immediately in 3D or begin in 2D and 
continue later in 3D.

For example, you can choose to begin designing in the Trimetric view orientation 
so that you see all three directions at once. Display other view windows with the 
Front, Right, and Top view orientations at quarter scale to observe the 
construction from other angles. While drawing, you can zoom in and out to enlarge 
and reduce areas as needed.

Rotate, move the origin, and change the work plane to take advantage of the 3D 
modeling environment. 

Drawing at Full Scale
In the paper world, a model design begins by deciding what scale to use so that 
the model fits on a particular size sheet of paper. With Graphite, scaling is 
postponed until after the model is drawn at full scale. Scale the geometry to fit on 
a standard drawing format provided by Graphite and then scale the whole drawing 
to fit the size of paper needed.

Constructing a 3D Model
There are several different methods to create a model. The following steps are an 
example of a process for a 3D model:

• Begin the construction by opening a new document.

• Set the preferences you prefer, such as the pen style, grid, and selection 
modes.

For more information, see chapter 5 Basic Environment Settings

• Display the Triad symbol using the Show Triad command. This illustrates the 
work plane orientation that acts as a point of reference when drawing in 3D.

• Display the Trackball.

• In the view menu of the Trackball, choose Trimetric. The sheet rotates so that 
the construction is seen from the Trimetric view.

• Create the 3D model using the tool palette and Graphite commands.
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• To observe multiple view orientations 
while modeling, choose Sheet Into View 
from the Views menu, and then specify 
the Views Design 4 layout. View windows 
displaying the Top, Front, and Right view 
orientations are displayed at quarter 
scale along the right side of the screen.

For more information on Sheet into 
Views, see chapter 14 Advanced Viewing 
Techniques

Drawing Formats
When the model is complete (or to be submitted for review), you might want a 
drafting version incorporating several views in a drawing format with dimensions 
and annotations. To create this, import a drawing format and make adjustments to 
the views as necessary or use a premade layout with format in Sheet Into View. 
This example shows a premade layout with four views.

• Flatten any view that contains geometry to be edited independently. For more 
information on flattening a view, see chapter 14 Advanced Viewing Techniques

• Crosshatch, dimension, annotate, and perform any view editing needed.

• Fine-tune the model if necessary.

• Specify the paper size from the Print Setup (Windows) or Page Setup 
(Macintosh) command in the File menu.

Vellum
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• Set the scale for the drawing format to fit on the plotter paper. If an exact scale 
is not necessary, click Fit in the Drawing Size dialog box and the geometry and 
format will be scaled appropriately for the paper size specified.

• Plot the finished drawing. For more information on plotting, printing and related 
activities, see chapter 15 Graphite Documents
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Tips:

If you are left-handed and 
your mouse has more 
than one button, you can 
change the functionality to 
the right mouse button. 
Make this change in the 
Control Panel of 
Windows.

Tip:

If holding down the middle 
button does not pan, then 
the button has been 
defined as something else 
by the operating system 
and can be changed in the 
Control Panel or System 
Preferences.
The Basics
This chapter describes the basic components of Graphite. This brief overview of 
useful features may be all you need to know if you are familiar with CAD software. 
The following topics are covered:

• Using a Mouse

• Parts of the Graphite Window

• Menu Bar, including the Dialog Boxes

• Preferences

For more information about standard elements such as menus, scroll bars, File 
menu commands, and dialog boxes, refer to the Windows or Macintosh User’s 
Guide that came with your computer.

Using a Mouse
The mouse is your communication device to tell the computer what to do. Use the 
mouse to indicate locations, choose commands, select tools, and construct 
objects.

If your mouse has more than one button, use the right button to popup a menu 
that contains a variety of commands and functions. By default the right mouse 
button provides shortcuts to the most popularly used commands.

To set up the right mouse button options, right click in the drawing area to activate 
the menu. Choose RightMouse. When the dialog box appears, check the boxes 
to activate or deactivate items displayed in the popup menu. If your mouse has 
three buttons or a scroll wheel, click and hold the button or wheel to pan. Move the 
scroll wheel forward and back to zoom in and out.
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This manual uses the following terms for mouse activities:

Pointer An arrow or any other graphic symbol that allows 
selection or creation of an object. Move the 
pointer to point to a command or an object on the 
screen. Depending on its location, the pointer is 
an arrow or looks like the current tool.

  

To move the pointer, move the mouse on the 
mouse pad. Several different mouse actions are 
used with Graphite. 

Point Move the mouse until the pointer is over the 
desired item.

Press Press and hold down the mouse button.

Click Quickly press and release the mouse button 
once.

Double-click Click the mouse button twice, quickly in 
succession.

Drag Press and hold down the mouse button, move the 
mouse, then release the mouse button.

Arrow Pointer Selection Arrow Center-Point Circle
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Parts of the Graphite Window
Upon starting Graphite, the following window appears. 

Title Bar Includes the title of the active document and 
buttons for controlling the window including boxes 
for zooming and closing the program.   

Menu Bar Contains the Graphite menus of commands and 
settings. Make choices from the menus using the 
mouse or special key combinations.

Tool Palette Contains the drawing and editing tool icons used 
for constructing, editing and annotating geometry.

Pointer Shows the active position on the screen. If the 
pointer is in the drawing area, its shape 
represents the current tool.

Title Bar Message Line Menu Bar

Drawing Area

Tool Palette

Scroll BarsStatus LinePointer Locator

Layer Indicator

Pointer
3-3
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Pointer Locator Shows the x, y coordinates of the pointer location. 

Message Line Displays the name of the current tool and step-by-
step instructions for using the tool.

Drawing Area Consists of multiple layers where geometry is 
constructed and annotated.

Status Line Shows the coordinate location and other 
geometric parameters of the current construction.

Scroll Bars Move around a drawing so that different sections 
of it are seen through the Graphite window. The 
scroll buttons move one line at a time.

Work Layer Indicator Displays the name of the current layer and 
provides a menu for changing the work layer.

Title Bar
The Title Bar includes the name of the current document, and the Control Menu, 
Minimize and Maximize/Restore buttons (Windows), or the Close and Zoom boxes 
(Macintosh).

Windows

Control Menu Button Closes, moves, and changes the size of the 
window. This button is available on all windows 
and many dialog boxes.

Double-clicking this button closes the window 
without displaying the menu. To choose a different 
option from the Control menu, click the button 
once to display the menu and then make the 
selection.
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Minimize Button Reduces the Graphite window to an icon near the 
lower-left corner of the screen. This action does 
not close or save the document, it only shrinks the 
window to an icon for performing some other 
Windows-related task. To redisplay the window, 
double-click the icon.

Maximize/Restore Displays the window, full or partial screen. Once 
the window appears full screen, click the button 
again to restore it to its previous size.

Macintosh

Close Button Closes the window when clicked. If you attempt to 
close the window without saving your work, 
Graphite displays a message with the option to 
save or not.

Zoom Button Toggles the window size between the previous 
size and full size.
3-5
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Tool Palette
A tool palette is a group of tool icons along the left side of the screen. The icons 
represent the tools for drawing, editing, and annotating geometry. 

Orbit and Miscellaneous Tools

View Control Tools

Transformation Tools

Trim Tools

Fillet and Chapter Tools

Dimension Tools

Text Tools

Spline Tools

Polygon Tools

Ellipse Tools

Circle Tools

Arc Tools

Line Tools

Selection Tools
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Selecting a Tool from the Tool Palette
1. Position the arrow pointer on the icon of the desired tool.

2. Click the mouse button.

The icon highlights to indicate its selection. The Single Line tool 
is selected here.

Tool Subpalettes
Most of the tools in the tool palette contain a subpalette with related functions. The 
arrow in the lower-right corner of the tool icon indicates the presence of a 
subpalette.

Viewing and selecting from a subpalette are similar to choosing a command from 
a menu.

Selecting a Tool from a Subpalette
1. Position the arrow pointer on the tool.

2. Press the mouse button.

The subpalette appears to 
the right of the tool.

3. Drag the pointer to highlight 
the desired tool.

4. Release the mouse button.

The selected tool replaces the previous tool in the tool palette. The 
highlighted icon in the tool palette shows that the selection from the 
subpalette is the active or current tool. 

The new tool is visible in the tool palette until another tool is selected from 
the same subpalette. The tools in the subpalette remain in the same 
order; only the tool displayed on the tool palette changes.
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Once a tool is selected, additional information appears to help with the 
construction. The Pointer, Pointer Locator, Message Line, and Status Line all 
provide feedback about the active tool.

To select a tool that is already displayed in the tool palette just click it. It is 
unnecessary to select it from the subpalette.

Tear Off Palettes
All tool palettes containing subpalettes are capable of tearing away from 
the parent palette. To tear away the subpalette from the parent tool 
palette click the small button in the upper right corner of the subpalette.

Move the subpalette anywhere in the drawing area. To save the palette in 
this location choose Layout>Preferences>Save Palette. Close the palette by 
double clicking on the left button in its title bar.

Smart Pointer
When selecting a tool and moving the pointer in the drawing area, the pointer 
shape represents the selected tool. 

Some of the pointers, like the single line pointer, are simple cross-hairs. Others, 
such as the Opposite-Point Circle pointer, resemble the tool itself.

The pointer, called a smart pointer, 
displays indicators for multi-step 
procedures. Each smart pointer has 
a dot, the hot spot, showing the next 
point to specify. The dot changes 
position on the pointer during each 
step of the construction. 

For example, the Opposite-
Point Circle pointer illustrated 
above shows that the first click 
of the mouse places a point on 
one edge of the circle being 
created. After clicking a 
location, the hot spot moves to 
the other side of the pointer, 
showing that the next click 
places a point on the opposite edge of the circle. (See the graphic above).

Hot Spot

The smart pointer shows you where to click next.

Your first click

The hot spot moves to the other side of the 
smart pointer to indicate the next step.
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Tech Note:

The number of decimal 
places displayed in the 
locator field is determined 
by the Precision setting in 
the Units dialog box 
(choose 
Layout>Preferences>
Units).

The location indicator 
tracks the pointer position 
of any tool other than the 
Selection tool.
After clicking the second location, the circle appears. The 
hot spot moves back to its original position on the pointer 
so that another circle can be created.

Pointer Locator
The Pointer Locator is two numbers to the left of the 
horizontal scroll buttons at the bottom of the drawing area.

This locator continuously tracks the pointer location when the pointer is in the 
drawing area, displaying the X,Y coordinates of the current location relative to the 
origin. The origin (0,0,0) is in the center of the screen when a new document is 
opened. When making the grid visible by choosing Layout>Show Grid, a symbol 
appears at the origin (0,0).

Message Line
The Message Line across the top of the drawing area provides concise 
instructions for the use of the selected tool.

For example, after selecting the Center-Point Circle tool, the Message Line 
appears as illustrated below:

The instructions in the Message Line for some tools also indicate optional 
activities. For example, by holding down the CTRL (Windows) or OPTION 
(Macintosh) key while using the Center-Point Circle tool, the next mouse click 
creates a copy of the last circle with the center placed where the mouse was 
clicked.

Layer1
1.53 1 0 .87 .87 0 1.22dZZ dX dYYX

0-1.872.4
L
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Tip:

Objects can be also 
changed with the Edit 
Objects command.
Status Line
The Status Line provides measurements, angles, X,Y coordinates and delta 
values for the current construction. The current tool determines the number of 
status data fields and which of the status data fields is highlighted after the 
construction. For example, if the Center-Point Circle tool is selected, the Status 
Line shows the X,Y coordinates for the center of the circle and the length of the 
diameter.

When the last point of the circle is clicked, the diameter (D) data field highlights in 
the Status Line to indicate that it is active. It shows the diameter of the circle just 
created. If a new number is typed, and the ENTER (Windows) or RETURN 
(Macintosh) key is pressed, the diameter of the circle updates reflecting the 
change.

Entries can be changed in the Status Line, until the ENTER (Windows) or 
RETURN (Macintosh) is pressed.

The number of decimal places displayed in the status data fields is determined by 
the Precision setting in the Units dialog box (choose Layout>Preferences>Units).

Moving Between Status Data Fields
Use the TAB key to move to the right, highlighting the next field. When pressing 
ENTER (Windows) or RETURN (Macintosh), the construction redraws according 
to the new specifications in the Status Line. The mouse is also used to activate a 
Status Line data field.

Use the Status Line arrows to scroll if any of the status data fields are off screen.

Drawing Area
Use the drawing area for all construction, editing, and annotation of geometry. 
Think of the drawing area as a sheet of paper of unlimited size that is used to 
construct full-size unscaled drawings. Use the scroll bars to move the sheet so 
that the desired portion is visible in the window.
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Tip:

Normally, it is not 
necessarily to display the 
Grid, since the Drafting 
Assistant offers a more 
elegant support than the 
grid.
Displaying the Grid
To work with a grid in the drawing area, 
choose Layout>Show Grid.

When the grid is visible, constructions 
snap to the grid, meaning that any 
geometry point clicked snaps onto the 
closest grid point. The coordinate 
symbol appears at the origin when the 
grid is visible.

Scroll Bars
The scroll bars move the sheet up and down or right and left. Display different 
parts of the drawing sheet by dragging the slider of a scroll bar to the approximate 
location. For example, the right, center, or left position in the horizontal scroll bar 
displays the right side, middle, or left side of the drawing, respectively. 

Click the arrows at the end of the scroll bars to move the sheet one line at a time. 
Click in the scroll bar to move the sheet one window at a time.

Work Layer Indicator
The work layer indicator in the lower-left corner of the screen shows which layer is 
the current work layer. New geometry goes on the work layer. For the construction 
to be on a specific layer, first make that the current layer. 

To select a work layer, position the pointer over the 
work layer indicator, then press the mouse button. 
All available layers are then displayed in a pull-
down menu from which a different layer can be 
selected as the current work layer. 

Drag to the layer and release the mouse button. 
The selected layer becomes the work layer and all 
geometry being created will be placed onto that layer.

0,0  Origin
Coordinate Symbol
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Menu Bar
The Graphite menus contain related commands and settings.

File Commands that affect entire documents (files).

Edit Commands to select and manipulate objects.

Layout Commands and settings that specify the drawing 
area and provide program features and 
functionality, such as construction lines and 2D 
analysis.

Arrange Commands for zooming (to change the area 
displayed in the window) and setting 
specifications for objects.

Pen Commands to specify pen characteristics (style, 
color, weight, and pattern), crosshatching, fill and 
arrows.

Text Commands to set the font, size, style, alignment, 
and indentation of text and also to create text 
blocks and forms (title blocks).

Dimension Commands that specify dimensions and their 
format and tolerance.

Views Commands to control multi-page documents, 
including sheet manipulation and View mode. The 
menu also contains Define View, View the Plane, 
Unfold View, Flatten View and Show Trackball.

3D Commands relating to the creation of geometry in 
three dimensions including planes and object 
rotation, as well as extruding and revolving of 
construction.

Utilities Commands to add new functionality and to create 
and invoke macros.

Window Commands to open the main tools palette, 
Dimensions palette, Pen Styles palette, Navigator 
palette, General palette.

Help Commands that provide access to Graphite's 
PDF documentation and Ashlar-Vellum's Support 
Center.
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Displaying a Graphite Menu
1. Point to the menu name.

2. Click on the name.

The menu appears. To dismiss the menu without mak-
ing a choice, click outside the menu.

Choosing a Command from a Menu
1. Point to the menu name.

2. Click on the name.

The menu appears. 

3. Click on the command.

The command executes, or the setting, such as 
Selectable Points, toggles on or off.

Mouse versus Keyboard
Graphite’s menu items are chosen with the mouse or with 
a combination of keys on the keyboard. For example, 
various methods are used for displaying the Edit menu.

Windows and Macintosh:

• Click on Edit in the menu bar.

Windows only:

• Press the ALT key and then type E.

• Press the ALT key and then press the RIGHT ARROW key until Edit is 
highlighted in the menu bar; then press ENTER.

There are also various methods for choosing commands with the keyboard. For 
example, use any of the following methods to choose Layout>Show Grid.

Windows:

• Press ALT and L and then type G.

• Press ALT and then use the RIGHT ARROW key to highlight Layout and press 
ENTER. Then press the DOWN ARROW key to move the highlighted area to 
Show Grid and press ENTER.

• Hold down the CTRL key and type G.

The first method is the mnemonic method. Press the ALT key with the appropri-
ate letters for the menu and command as indicated by the underlined character 
in the names.
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Macintosh:

• Hold down the  COMMAND key and type G.

The third method for Windows, and the only one available for Macintosh, is a 
keyboard accelerator. When available it is denoted by the key sequence listed on 
the menu.

While keyboard functionality is always available, this manual generally describes 
making choices with the mouse.

Submenus
Commands followed by an arrow have submenus which display when the 
command is highlighted.

1. Pull down the menu.

2. Click on a command with an (arrow) on the end.

The submenu displays.

3. Click on the submenu.

4. Click the desired command.
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Dialog Boxes
When choosing a command followed by an 
ellipsis (…), such as Edit Objects in the Edit 
menu, a dialog box appears.

Dialog boxes qualify the command chosen 
by adding information. For example, in the 
Edit Objects dialog box on the right, the 
specifications of the selected object are 
changed.

If a dialog box obscures the view of the 
drawing area, move it to a new location by 
dragging it with the pointer on the Title bar.
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Tip:

Windows: An alternative is 
to hold down the ALT key 
and type a letter to select 
the first item that begins 
with that letter, then use 
the arrow keys to move to 
the desired selection. 
Once it is highlighted, 
press ENTER.
Option Buttons
Option buttons indicate mutually exclusive choices; select only one option at a 
time. Click the desired option and the button turns black, as shown by the inches 
option below.

Check Boxes
Check boxes, as shown above, provide options to switch on and off and which are 
not mutually exclusive. A check shows the option set.

List/Entry Boxes
Some dialog boxes contain lists of options, 
displaying an arrow to provide access to the list.

If the entry includes an arrow, it displays a menu 
which works like a submenu on the menu bar 
displaying the selected item in the box.

Some list boxes also allow an entry to be typed. 
For example, type a value in the Scale data field 
in the Drawing Size dialog box or choose from the 
pop-up menu. See the graphic below.

To type an entry, select the current entry (if it isn’t 
already selected), then type a new entry. In most 
cases, clicking on the OK button, saves the 
changes.

Selected Option

Option Buttons

Check Boxes

Drawing Scale 1:1
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Asterisks
When an item in the dialog box displays an asterisk (*), 
a value can be specified by clicking or dragging in the 
drawing area. This feature is particularly useful for 
specifying location because knowing the x, y 
coordinates is not necessary. 

Apply Buttons
Some dialog boxes have an Apply button so that the 
specification can be activated and left open for setting 
further specifications.

For example, crosshatch a part then leave the 
Crosshatch dialog box open to crosshatch other objects.

Closing a Dialog Box
If a dialog box contains an OK or Cancel button or an action button such as Open, 
the dialog box closes after clicking the button. Otherwise, to dismiss the dialog 
box manually double-click the Control Menu (Windows) or click the Close Button 
(Macintosh) in the upper-left corner of the box. If the dialog box has an Apply 
button, such as the Crosshatch dialog box above, you must dismiss it manually. 
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Toggling Commands
Commands that set a condition (such as Selectable Points and Arrow At Start) 
display a check mark in the menu to indicate that they are active. To turn a 
command off, choose it and the check mark disappears.

In the case of pen styles and text characteristics, the check shows the current 
setting.

Other commands, Show Grid, Show Points, Show Palette, Show Trackball and 
Show Triad toggle to Hide (Grid, Points, Palette, Trackball or Triad) when the 
component is visible.
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Preferences
All files are saved with their settings when choosing File>Save. The 
characteristics used for new files (the default settings) are contained in the 
preferences file. The preferences filename is prefs.vc6 (Windows) or Graphite 
prefs (Macintosh). Change the default settings so that every new document opens 
with the desired settings. The following specifications are set in the preferences 
file:

• Pen styles

• Text characteristics

• Preference settings (snap, grid, units, selection color indicator, visualization, 
palette status and palette location)

• Grid display

• Layer and sheet specifications

• Work layer

• Dimension and tolerance formats

• Arrowhead type and display

• Drawing size and scale

• Zoom scale

• Fillet radius

• Chamfer angle and length

• Resolve values

The default value of any setting that can be changed on a menu or in a dialog box 
can be set in the preferences file.

Changing the Default Settings Manually
1. Open the preferences file (it’s in the same folder as the Graphite application).

2. Change the characteristics and, if needed, create the layers and sheets.

3. Save and close the file.

The file must be stored in the same folder as the Graphite application.

The preferences are set for subsequent new documents. 

The settings will not take effect until the next time you launch Graphite.
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Changing the Default Settings with Save Preferences
1. Open a new Graphite file.

2. Set the preferences as needed.

3. Choose Layout>Preferences>Save Preferences.

The preferences are set for this file. The settings for future files take effect the 
next time you launch Graphite.

Important: It is advisable to use Save Preferences only before starting to draw. 
Otherwise, undesired data may be saved in new files. For example, if Save 
Preferences is chosen on a file with a detail view and multiple models, all new files 
will contain a detail view window and multiple models.

Changing the Icon Style
The icon style has been updated. The new style is set by default. To use the 
Classic or Modern icon style instead choose 
Layout>Preferences>Style>Classic.



The Drafting Assistant
The Drafting Assistant
The Drafting Assistant makes Graphite unique among design and drafting 
software products. The Drafting Assistant thinks like a drafter; it automatically 
knows where construction lines are typically wanted and temporarily displays 
them when needed. 

The Drafting Assistant also makes it easy to select existing points for construction 
by displaying information about the pointer’s location in the drawing area. If a 
Drafting Assistant notation displays when clicking, the construction snaps onto the 
geometry precisely, without requiring finely tuned eye-hand coordination or 
tedious selection of special modifiers, modes, or other specialized construction 
tools.

The following topics are covered in this chapter:

• Snapping to Geometry

• Drafting Assistant Construction Lines

• Permanent Construction Lines
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Snapping to Geometry
When the pointer is in the drawing area, it has a snap point function. The snap 
point locks onto specific points on existing objects as the pointer moves near 
them. 

The Drafting Assistant tells when the snap point is on an object.

It displays information about the location of the snap point. This information 
appears either beside the pointer or next to the object itself. 

The Drafting Assistant tells when the snap point has locked onto the points of an 
object as follows:

The Drafting Assistant snapping onto a circle

on

The Drafting Assistant displaying the relationship
between the circle and the line that is being constructed.

tangent
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The center of an arc or circle. Move the pointer 
across the arc or circle to display on for the arc 
or circle, then move the pointer near the center to 
display the center point notation.

The endpoint of lines, arcs, circles, ellipses 
and splines. 

The midpoint of lines, arcs, circles, ellipses 
and splines.

The intersection of two curves or lines, including 
permanent lines and the Drafting Assistant’s 
dynamic construction lines.

Quadrant points on an arc or circle displayed at 
3 o’clock, 6 o’clock, 9 o’clock and 12 o’clock. 

The vertices of an ellipse, spline, or dimension 
point.

center

endpoint

midpoint

intersection

quadrant

vertex

midpoint

intersection

quadrant

vertex

center

endpoint
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Using Tangents and Perpendiculars
By clicking a point on an arc or circle and dragging the pointer away at about a 45º 
angle, the Drafting Assistant locks onto the tangent. If you drag away at a 90º 
angle the Drafting Assistant locks onto a perpendicular.

Continue holding the mouse button, and the line remains tangent or perpendicular 
while dragging the ending point around the object. 

This is a useful feature if, for example, it is 
necessary to create a line from and 
tangent to an existing circle to the tangent 
point of another circle.

Once a line is tangent to the circle, it can 
be dragged to the tangent point on the 
other circle, with the tangency maintained 
at both ends.

The Drafting Assistant locks onto a tangent 
or perpendicular only when the Drafting 
Assistant starts from the on notation. It is possible to begin a tangent or 
perpendicular line from a specific point, such as endpoint, quadrant or vertex.

tangent

perpendicular

tangent

tangent

tangent

Perpendicular

Tangent
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Tech Note:

Another way to create 
geometry from an exact 
location relative to another 
object is to reduce the Hit 
Radius of the Drafting 
Assistant with a lower 
number of pixels or to 
zoom in on the drawing to 
separate the construction 
points visually.
Keyboard Snap Points
It is possible to direct the Drafting Assistant to snap onto an object. For example, 
to start a new line from the exact center of a circle. Hold down the mouse button 
and press the C key on the keyboard. The Drafting Assistant finds the center of 
the circle when moving the pointer near the center.

Using the Drafting Assistant for Snapping onto Geometry
The following table lists the keys for finding specific points. The desired point must 
be within the Hit Radius (defined later in this chapter) of the pointer. Press the 
mouse button first and then press one of the following keys on the keyboard. 

Keyboard snap points only work when there are multiple snap points within the Hit 
Radius of the pointer.

Letter Snaps To (Align)

c center

e endpoint

g grid

i intersection

m midpoint

n no point

o on

p perpendicular

q quadrant

t tangent
v vertex
% the percentage point set in the Snap dialog box

Pressing the SPACEBAR or clicking the mouse releases all snap restrictions. 

Keyboard snap points act as a filter. For example, to place the end of a line at the 
center of a circle where the intersection of two other objects lies near the center 
(within the specified Hit Radius), the Drafting Assistant does not know which 
point—the center or the intersection—to snap to. By pressing the C on the 
keyboard while dragging the line, the Drafting Assistant knows to snap to center 
and to disregard the intersection (or any other snap point that falls within the Hit 
Radius).
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DAssistant Command
This command, found 
in 
Layout>Preferences, 
turns the Drafting 
Assistant on or off. 
When the Drafting 
Assistant is not 
checked in the menu, 
the Drafting Assistant 
is off.

Snap Basic Command
This Snap command, found in Layout>Preferences, sets specifications for the 
Drafting Assistant.
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Hit Radius This setting determines the detection distance in 
pixels. When the pointer is within the specified Hit 
Radius, the Drafting Assistant notations display 
and the object is selected when the mouse is 
clicked. The default Hit Radius is 12 pixels.

If specifying locations becomes difficult because 
they are close together and the Drafting Assistant 
snaps to an existing control point, do any of the 
following:

• Decrease the Hit Radius. 

• Zoom in so more pixels separate the existing 
point and the point to select.

• Lock on a point by pressing the mouse button 
and then typing the letter that represents the 
point (m for midpoint, for example). 

If the Hit Radius is set to zero, it disables 
the single click selection of the Selection tool. 
Dragging a selection fence and double-clicking to 
select all objects still works). Instead, consider 
using the Selection Mask in the Edit menu to 
specify that some objects cannot be selected.

Alignment Angles These angles define the dynamic construction 
lines that the Drafting Assistant automatically 
uses. To change the orientation of the drawing, 
change these specifications. For example, set 
these angles to 30°, 90° and 150° for an isometric 
drawing. The defaults are 0° (horizontal) and 90° 
(vertical). Use a semicolon to separate the values. 
Up to 16 angle values can be set in the Alignment 
Angles field.

To display a temporary construction line through 
a point, activate the point by moving the pointer to 
it. A diamond appears when you move your 
mouse away from the point. Construction lines 
automatically display through the active point. Up 
to eight points are active at one time. When the 
ninth point is activated, the first one in the series 
deactivates.
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Additional Creation Angles These lines are used by the Drafting Assistant 
only when creating geometry and they are not 
part of the list of lines generated from the eight 
active points. The defaults are 45° and -45°. Use 
a semicolon to separate the values. 

% Point These are the divisions of a line for Drafting 
Assistant notations.To divide the line into 
quarters, use a 25 specification. The default is 
50, which shows the midpoint of lines.

For example, entering 60 instructs the Drafting 
Assistant to tell when the pointer is 60% of 
the distance along a line as shown below.

Snap Mode Command
The Snap command is available by going to Edit>Snaps Filter. This command 
activates and deactivates the different snap modes of the Drafting Assistant. This 
command is different from the Snap command, chosen through the 
Layout>Preferences menu, that sets basic specifications of the Drafting 
Assistant.

Choosing Edit>Snaps Filter displays the following dialog box: 

All snap modes are activated by default. To deactivate a snap 
mode click the related check box. 

%point
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Drafting Assistant Construction Lines
In addition to snapping to geometry, the Drafting Assistant also displays dynamic 
construction lines. Three types of construction lines are used most frequently: 
vertical, horizontal, and 45° angle lines. These display automatically during 
construction. Construction lines appear temporarily to help align geometry. Once a 
point is set, the Drafting Assistant construction line disappears so that the drawing 
is not cluttered with extraneous lines.

Dynamic construction lines extend automatically from the last point created. To 
activate other points so the Drafting Assistant displays construction lines relative 
to them, simply move the pointer over the geometry to activate or “wake-up” its 
control points, then move away horizontally or vertically.

Of course, there is the option of creating permanent construction lines and other 
shapes, as described later in this chapter.

Using the Drafting Assistant’s Construction Lines 
Indicate the first endpoint of a line and move the pointer horizontally, vertically, or 
in a 45° direction, the dynamic construction lines appear. The figure here 
illustrates a 45° construction line relative to the endpoint of an existing line.

Displaying Dynamic Construction Lines while Constructing Geometry
1. Click a point to begin new geometry.

2. Move the pointer away from the point horizontally, vertically, or at a 45° angle. 

3. While the construction line is visible and the Drafting Assistant displays on, 
click the next point.

The point is placed exactly on the construction line, even though the pointer 
wasn’t exactly on that line when clicked. The dynamic construction line 
disappears.

align:45

on
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Tech Note:

Up to eight active points 
are available. Activating 
the ninth point in a series 
deactivates the first point.
Displaying Dynamic Construction Lines with Existing Geometry 
1. Without pressing the mouse button, move the pointer over an existing point.

The point notation (endpoint or midpoint, for example) shows that the point is 
active.

2. Move the pointer horizontally or vertically.

A construction line appears through the point.

3. While the construction line is visible and the Drafting Assistant displays on, 
click the desired point in the construction.

The point is placed exactly on the construction line, even though the pointer 
wasn’t exactly on that line when clicked. The dynamic construction line 
disappears.

The figure here illustrates intersecting construction lines drawn through two 
existing, active points.

Once familiar with the Drafting Assistant, Graphite will streamline design and 
drafting tasks.

Setting New Drafting Assistant Construction Angles
Add to or change the angles that the Drafting Assistant uses for dynamic 
construction lines by choosing Layout>Preferences>Snap. Enter the construction 
line angles, separated by semicolons, in the appropriate data field.

align

perpendicular

intersect
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Referral:

For using the 
Construction Line tool 
see “Construction Lines 
Tool” on page 7-13

Referral:

More information on 
Layers is found in Viewing 
Geometry

Tip:

Use strokes to create 
construction lines while 
you are in the process of 
using another tool.
Permanent Construction Lines
In addition to the Drafting Assistant’s dynamic construction lines, it is possible to 
create construction lines that display until hidden or removed. There are three 
methods for creating permanent construction lines: strokes, with the Construction 
Line tool and the Construction command in the Layout menu. Construction lines 
automatically appear on the construction layer, not the work layer of the drawing. 
Hide the construction layer to view or print the drawing without construction lines.

To remove all construction lines, choose Layout>Delete Constructions. 
Everything on the construction layer deletes, regardless of the object's pen style.

Stroke Construction Lines
Stroke construction lines are lines that are created with the mouse. Hold down the 
CTRL+SHIFT keys (Windows) or the  key (Macintosh) and drag the mouse 
horizontally or vertically. The Drafting Assistant helps to place the stroke precisely. 

Holding down the CTRL+SHIFT keys (Windows) or the  key (Macintosh) 
changes the mouse pointer to the Stroke point ().

Drag Result

Vertically A vertical construction line through the first point 
of the stroke.

Horizontally A horizontal construction line through the first 
point of the stroke. 

Drag the pointer
horizontally or vertically

center
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Tech Note:

Graphite automatically 
places construction lines 
on the construction layer. 
When choosing 
Layout>Delete 
Constructions, 
everything on the 
construction layer is 
deleted, regardless of the 
object’s pen style.
Using Stroke Construction Lines
Construction lines are as long as the dimensions of the viewing area of the screen 
or the plot region (as designated in Drawing Size dialog box in the Layout menu), 
whichever is larger. 

For example, if using the Connected Lines tool to create a construction line that 
extends through the center of a circle: 

1. Hold down the CTRL+SHIFT keys (Windows) or the  key (Macintosh). The 

pointer becomes the Stroke pointer ().

2. Move the pointer near the center of the circle.

The Drafting Assistant snaps onto the center point.

3. Drag the mouse vertically or horizontally away from the midpoint.

The construction line appears through the center while still in the process of 
creating connected lines. Releasing the CTRL+SHIFT keys (Windows) or the  
key (Macintosh) and continue working. 

The Construction Command
Stroke construction lines are useful for creating lines through existing points. To 
create a construction line at a location other than an existing point or at a 
particular angle, use the Construction command.

Using the Command CTRL+K (Windows) +K (Macintosh)
This command in the Layout menu creates a 
construction line on the construction layer of the 
document.

Specify the angle of the construction line or the offset 
from a reference point defined by the X, Y coordinates. 
The asterisk shows that the values are specified by 
clicking or dragging the mouse. Values are also typed 
into the data fields.

The distance dragged is always entered in the Offset 
data field as a positive value, regardless of the 
direction dragged.

Any geometry placed on the Construction layer will not have a Midpoint snap. This 
is by design so that construction data will not confuse the user’s work area. It is 
not advisable to create a drawing on the Construction layer because there is no 
Midpoint snap and because the Layout>Delete Construction will delete all 
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geometry on this layer. The Construction layer is really used for Graphite to store 
construction line data and should not be used for regular geometry.

Specifying the Construction Line Angle with the Mouse
1. Click the Angle data field.

2. Drag a vector in the drawing area. 

The angle of the vector line appears in the Angle data field.

Specifying the Construction Line Offset with the Mouse
1.Click the Offset data field.

2.Drag the offset distance in the drawing area. 

The distance dragged appears in the Offset data field. 
The offset is determined by the angle of the 
construction line as shown.

Specifying X,Y Coordinates with the Mouse
The coordinates of the last point specified appear in 
the X and Y data fields. To change them, do the 

following:

1. Click the X data field.

2. Enter new coordinates, or

 In the drawing area, click the location of the point through which the 
construction line will pass. The coordinates are entered automatically for the X 
and Y data fields.

Creating Multiple Construction Lines
Create multiple construction lines through the same point by entering the angles 
separated by semicolons.

Creating Parallel Construction Lines
Create parallel construction lines by specifying a single angle value with different 
offsets separated by semicolons. It is also possible to create parallel lines by 
creating one construction line using this data field, then creating new lines with the 
Parallel Lines tool.

90
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+
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+

-
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Tip:

Select construction lines 
in the usual manner from 
any layer. The 
construction layer doesn’t 
have to be the work layer.
Creating Construction Geometry
Non-construction geometry is placed on the work layer. Create temporary 
construction geometry, such as arcs or circles, by making the construction layer 
the work layer, creating the construction geometry and then switching to another 
layer to continue working.

Use the Construction pen style if desired, but it’s not essential.

Lines made with the Construction pen do not go on the construction layer unless 
that layer is the work layer. 

Creating Construction Geometry
1. Choose Layout>Layers.

2. Click Construction in the list box.

3. Click Set Layer.

4. Create the geometry for construction. Use the Construction pen style if 
desired. 

5. When the construction geometry is complete, make another layer the work 
layer.

6. Close the dialog box.

7. Continue to work. 

Once the construction geometry is no longer needed, choose Layout>Delete 
Constructions to remove all geometry on the construction layer. 
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Removing Construction Lines
To delete only one or two construction lines among many, select the lines to 
remove, and then choose Edit>Delete or press the BACKSPACE (Windows) or 
DELETE (Macintosh) key. To remove all the construction lines created, choose 
Layout>Delete Constructions.

Delete Constructions
This command in the Layout menu deletes all construction lines and any geometry 
on the construction layer. The Drafting Assistant’s dynamic construction lines 
appear only temporarily and are not affected by this command. Any geometry on 
the construction layer (regardless of the pen style used) is deleted by this 
command.

Retrieving the deleted construction geometry is possible with the Undo command.
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Basic Environment Settings
Basic Environment Settings
This chapter describes the options for adapting Graphite to your needs. The 
following topics are covered:

• Pen Styles

• Pen Characteristics, including the Color Palette

• Setting Units

• The Grid

• Drawing at Full Scale

• The Drafting Process

• OS Settings

• Saving Preferences

• Save Palettes

Pen Styles
The pen style determines the appearance of lines on the screen and during 
plotting. Using a monochrome monitor or printer, all lines are black but the weight 
and pattern are visible. Any line thickness of less than .016 inch appears one pixel 
wide on the screen. When printing or plotting such lines, you will see that the 
different weights are observed.
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The default pen style is Outline—solid, black lines, .01 inch wide. Change to a 
different pen style or change an individual characteristic of the current pen.   

Choose from nine different pen styles in the Pen menu. The characteristics are 
listed below.

Pen Pattern Weight Color

Outline Solid 0.010 Black

Visible Solid 0.020 Black

Hidden Hidden 0.016 Red

Dash Dashed 0.016 Yellow

Center Center 0.010 Green

Phantom Phantom 0.010 Cyan

Dimension Solid 0.002 Blue

Balloon Solid 0.005 Green

Construction Dotted 0.002 Magenta

To change pens, choose among four options:

• Choose Pen>Style from the menu and select a different pen style from the list. 
The current pen style is checked.

• Choose a pen from the Pen Style palette accessed under Windows>Show Pen 
Styles Palette.

• Choose different characteristics for the current pen from the pen characteristics 
listed in the Pen menu (Color, Weight and Patterns) 

• Use Pen>Style>Edit Style to permanently alter the characteristic of the pen.
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Changing the Pen Characteristics of an Object
1. Select the object.

2. Choose Pen>Style and select the pen style to change the characteristics of 
the selected object. To change one characteristic rather than the entire pen 
style, choose the characteristic from the pen characteristics listed in the Pen 
menu.

When changing this, the current pen also changes, thus affecting future 
constructions.

To change the pen characteristics of an object without changing the current pen, 
select the object, then choose Edit>Edit Objects and change the characteristics 
in the dialog box. 

Pen Characteristics
The following characteristics are available from the submenus in the Pen menu. 
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Color
There are 234 color options including 170 user definable colors and 64 predefined 
colors. This Color palette displays the 64 predefined colors in 
Pen>Color>Palette.

Each definable color can be independently assigned from the 16.7 million colors 
available.

This Color command specifies the color of the current pen and any other selected 
geometry without changing any other pen characteristics.

Specifying the Color of the Current Pen
1. Choose Pen>Color. The submenu appears.

2. Choose the color.

The pen takes on the new color as selected in the submenu.

3. Deselect any geometry to see the chosen color.
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Defining Colors
As many as 234 colors may be defined. By choosing Layout>Preferences>Save 
Preferences following their definition, they are available each time a new file is 
opened.

Because the color displays are different for Windows and Macintosh machines, 
the process for defining a color vary slightly. See your Windows or Mac 
documentation for information on how to define custom colors on your platform. 

1. To define a new color, choose Pen>Color>Define.
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Tech Note:

The 64 predefined colors 
that came with Graphite 
cannot be redefined or 
edited.
2. The Edit Colors dialog box appears.

3. In the dialog box window, scroll down and select one of the undefined color 
numbers, like <User65> (the first definable color available).

4. Enter the color name in the Color Name data field and click Rename. The 
name entered replaces User <65> in the colors list, as displayed here.

5. Click Define. The color display appears on the screen.

Follow the directions in your Windows or Mac operating system documentation on to 
create custom colors.

6. When you have finished creating any custom colors, save these colors as 
default color settings for all new files by choosing Layout>Preferences>Save 
Preferences.

Editing User-defined Colors
Edit the previously defined colors using a procedure similar to that for defining 
colors.

1. Choose Pen>Color>Define.

2. The Define Colors dialog box appears.

3. In the dialog box window, scroll down and select one of the defined colors.

4. Click Define. The color display appears.

Edit the color. 

5. Click OK to save the changes.
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Saving Colors 
Choose Layout>Preferences>Save Preferences to save the colors defined. 
Colors created for a specific file are saved with the file if they have not been saved 
using Save Preferences.

Customizing the Color Palette 
This feature designates which colors display in the Palette when choosing 
Pen>Color>Palette.

Displaying a Color in the Palette
1. Choose Pen>Color>Define.

2. Select the color to display.

3. Click Use. An eye icon appears next to the color name.

Click in the blank space to the left of the name to display the icon.

Choose Pen>Color>Palette to see that the color patch has been added to the 
palette.

Removing a Color from the Palette
1. Choose Pen>Color>Define.

2. Select the color to remove.

3. Click No Use. The eye icon next to the color name is removed.

Click on the eye icon to remove it.

When choosing 
Pen>Color>Palette, the color 
patch has been replaced by a 
patch with an X in it.
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Weight
This command in the Pen menu sets the pen 
width of the current pen and selected lines 
without changing any other pen characteristics.

The line weights shown in this submenu 
depend on the units selected in the 
Preferences submenu. If metric units are 
selected, the line weight is shown in millimeters 
instead of inches.

Note: Any line thickness that converts of less 
than .016 inch in your resolution appears one 
pixel wide on the screen. When printing or 
plotting such lines, the different weights are 
seen.

Specifying a New Weight for the Current Pen
1. Choose Pen>Weight. The submenu appears.

2. Drag to the desired weight. 

The pen takes on the new weight, as selected in the submenu.

Edit Weight Command
This command from the Weight submenu in the Pen menu sets the line weights. 
Graphite comes with eight default line weights ranging from .002” (.05mm) to .050” 
(1.27mm). Objects drawn in Graphite are drawn in one of the eight available pen 
weights. Choose Pen>Weight>Edit Weight to change the weight of one of the 
pens to any value between .001” (.0254mm) to .050” (1.27mm).

There cannot be more than eight different pen weights in a drawing, so changing a 
pen weight in the Edit Pen Weights dialog box changes the weight of every object 
drawn with that pen’s previous weight. 
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Editing Pen Weights
1. Choose Pen>Weight>Edit Weight. The Edit Pen Weight dialog box appears.

2. Select the pen weight to change by clicking on the pen number. That pen’s 
data field is selected.

3. Change the pen weight by typing a new value into the data field. If no units are 
given with the entry, Graphite applies the unit specified in the Units dialog box 
from Preferences.

If the entry does not fall with in the valid range from 0.0001" (.00254mm) to 5" 
(127 mm), Graphite prompts with an Alert box similar to the one here.

Note: While Graphite will accept any entry between these values, most 
printers will not print a line over 0.5" (1.27mm), nor will the screen display 
anything less than 1 pixel.

Clicking OK in the Alert box returns to the Edit Pen Weights dialog box to 
make the necessary changes.
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Tech Note:

Remember that all pen 
weights thinner than .015” 
appear on the screen as one 
pixel thick. It is possible to 
see the difference in pen 
weights on the prints and 
plots.
4. Click OK in the Edit Pen Weights dialog box. All existing lines drawn in the pen 
weight that was edited change to reflect the new weight, as will all future lines 
drawn in that pen weight.

Clicking Cancel ignores all changes made to any pen weights and closes the 
Edit Pen Weights dialog box.

Undoing a Pen Weight Edit
Do not undo editing a pen weight with the Undo command. To return a pen to 
Graphite’s default, enter the original value in the Edit Pen Weight dialog box, 
following the steps described above.

The default weights are: Pen 1 - .002", Pen 2 - .005", Pen 3 - .010", Pen 4 - .016", 
Pen 5 - .020", Pen 6 - .032", Pen 7 - .040", Pen 8 - .050".

Edited pen weights affect only the pen weights in the current file. To save the 
edited pen weights so that they are available in all future files, choose 
Layout>Preferences>Save Preferences.
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Pattern
Graphite provides eleven standard line patterns and the ability to create nineteen 
additional line patterns. Using the Pattern command, set the pattern of the current 
pen and any selected lines without changing any other pen characteristics. Define 
new patterns and edit all line patterns currently available.

Specifying a New Pattern for the Current Pen
Choose a standard line pattern or a user-defined pattern. When selecting a 
pattern, regardless of whether an object is selected, the pattern becomes the 
current pen. If a particular pen style had been previously chosen, notice that style 
is no longer checked in the pen style submenu.

Setting a Standard Pattern

1. Choose Pen>Pattern. The submenu appears.

2. Select a pattern.

The pen takes on the new pattern.
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Setting a User-defined Pattern
1. Choose Pen>Pattern>More. The Line fonts dialog box appears.

2. Scroll down to the desired pattern and select it.

3. Click Current.

The pen takes on the new pattern.

Defining and Editing Pen Patterns
Edit the standard patterns included with Graphite or create up to nineteen patterns 
of your own.
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Define Pattern Command
This command, found by choosing Pen>Pattern>Define Pattern, defines up to 
nineteen line patterns.

Graphite considers each line segment and each space between line segments 
separate dashes. Each dash has a handle, represented by a box attached to the 
vertical line extending from the end of each dash. 

One complete element of the line pattern appears in the pattern window. The 
default visible length is two inches. To create patterns with dashes or elements 
larger than two inches, change the value in the Visible Length data field to an 
appropriate number. The Pattern Window scales the pattern element accordingly.

Graphite automatically scales line patterns by the inverse of the scale factor set in 
the Drawing Size dialog box or Sheet Into View dialog box so that the pattern 
spacing is appropriate for the viewing and drawing scale of the geometry. Set the 
pattern spacing independently of the viewing or drawing scale, or change the 
pattern altogether. The Edit Pattern dialog box controls the pattern spacing for 
nine of Graphite’s eleven different line patterns. Solid and dotted patterns cannot 
be edited.

These patterns are saved as default patterns by choosing 
Layout>Preferences>Save Preferences.To save these patterns with the file only 
and not as default patterns, just save the file.
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Defining a Pen Pattern
1. Choose Pen>Pattern>Define Pattern. The Define patterns dialog box 

appears.

2. Click New.

The User1 default name is added to the bottom of the patterns window and 
appears in the Pattern Name field.

3. Click Edit. The Edit Pattern dialog box appears with the default name User1 in 
the Edit Pattern field.

By default there are two dashes, a solid line segment and a blank segment.



Graphite User Guide Pen Characteristics
4. Create the pattern by modifying the length of these segments and/or adding 
dashes.

Clicking the dash handle (to the right of the dash) activates the handle for the 
pattern segment. The dash’s current length appears in the Dash Length data 
field. There are two ways to change the length of a dash:

Enter a new value in the Dash Length data field and change the length of the 
selected dash. 

Drag the handle. While dragging, the dash’s length updates in the Dash 
Length data field. Release the mouse button when the dash is of desired 
length.

To add a new dash, click Add. A blank, solid dash is added with a length of 
zero. The solid dash handle is activated. Change the length of the new dashes 
by dragging their handles or by typing in a value in the Dash Length data field. 
If a handle is selected before clicking Add, the new dashes are placed in front 
of the selected dash. 

To remove a dash, select its handle and click Remove. The dash is removed 
from the pattern element.

Note: Pattern elements start with solid dashes, and then switch to blank 
dashes, and then, if necessary, back to solid, and so on. Adding or removing 
dashes may change existing dashes from solid to blank or from blank to solid.

5. When the pattern element is properly defined, click OK. The new pattern is 
created and the program returns to the Define patterns dialog box.

Click Cancel to close the Edit Pattern dialog box without retaining the pattern 
settings.

6. Select the Pattern Name field and enter a new name for the pattern.

7. Click Rename.

8. Click Current to set the pen to the new pattern.

9. Click the Close button in the title bar to close the dialog box.
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Edit Pattern Command
This command, found by choosing Pen>Pattern>Edit Pattern, edits all line 
patterns but Solid and Dotted. 

To edit a pattern already used in geometry within the drawing, the geometry 
automatically updates to the revised pattern. For example, if the Phantom line 
pattern is edited, every line in the existing document drawn in the Phantom line 
pattern changes to reflect the revision.

Edited line patterns also scale by the inverse of the viewing and drawing scales, 
but editing the pattern controls how the patterns appear on the screen and on 
paper.

Editing a Pen Pattern
1. Choose Pen>Pattern>Edit Pattern.

The Edit Pattern dialog box appears.

2. Select the line pattern to change from the Edit Pattern list.

3. Modify the line pattern by changing the lengths of existing dashes or by 
adding or removing dashes to or from the element.

4. When the pattern element is properly defined, click OK and the dialog box 
closes. All existing lines drawn in the edited line pattern change to reflect the 
new pattern element, as will all future lines drawn in the line pattern. 

Click Cancel to ignore all the changes made to any pattern elements and 
close the Edit Pattern dialog box.
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Undoing a Pattern Edit
Do not undo a pattern edit with the Undo command. To return to the standard 
patterns that came with the program, click Revert in the Edit Pattern dialog box. 
Revert changes the line patterns back to their defaults, not just the pattern 
selected from the Edit Pattern list. A warning message is presented using Revert.

Clicking Yes changes the patterns back to Graphite’s original settings. Clicking No 
returns to the Edit Pattern dialog box without returning changing the current 
settings.

To undo changes made to user-defined patterns, previously saved as a 
preference, save the file (if necessary), close and relaunch the program, and then 
open the file. All user-defined patterns return to their previously defined settings. 
Edited Patterns affect only the patterns in the current file. To save the edited 
pattern so that it is available in all future files, choose Layout>Preferences>Save 
Preferences.
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Pen Styles
Pen styles help simplify the design process by defining the color, weight and 
pattern type for each style. Then rather than having to set each pen characteristic 
each time a specific type of line is desired, choose one of the predefined styles. 
Nine pen styles are provided.

The following are the default settings for the styles in the Pen menu:   

Outline

Solid, .01 inch, black lines - the default 
pen setting. 

Solid, .02 inch, black lines. 

Hidden           

Hidden pattern, .016 inch, red lines. Hidden 
lines are actually visible on the screen and 
in the drawing; they represent lines that would 
be hidden in a solid object.

Dashed, .016 inch, yellow lines. 

Center, .01 inch, green lines. 

Phantom

Phantom, .01 inch, cyan lines. 

Dimension

Solid, .002 inch, blue lines. (These lines are .002 
inch thick, regardless of the weight you specify.)

Visible

Dash

Center
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Balloon

Solid, .005 inch, green lines. 

Construction

Dotted, .002 inch, magenta lines. This does not 
create construction lines but uses construction 
line characteristics. True construction lines are 
placed on the construction layer and are deleted 
while choosing Layout>Delete Constructions.

Modifying Pen Styles
Modify a pen style as needed. Change one characteristic of the style by choosing 
it in the Pen menu or change the style for the duration of the work session by 
choosing Pen>Style>Edit Style. 

Changing One Characteristic of a Pen Style
1. Choose the pen to modify.

2. In the Pen menu, choose a characteristic: Color, Weight, or Pattern.

To return a standard pen to its original specifications, choose a different pen style 
from the menu and then choose the modified pen again. Change all of the 
specifications for a standard pen by redefining it with the Edit Style command by 
choosing Pen>Style>Edit Style.
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Edit Style Command
This command from the Style submenu of the Pen menu sets the characteristics 
for the pen styles. 

Redefining the Specification of a Pen Style
1. Choose Pen>Style>Edit Style. 

The dialog box appears.

2. Select the pen style to change by pressing 
the Style data field. 

When the list of pen styles appears, choose 
the style to change.

3. Specify the characteristics (Color, Weight, 
and Pattern) for that style. 

4. Click OK to set the specifications and close 
the dialog box, or click Apply to put the 
specifications into effect for a single pen 
style and leave the dialog box open to make changes to another pen style.

When editing a style, set new specifications for future uses of that pen. The 
specifications remain in effect for the document in which they are set until 
changed again with the Edit Style command. Change the default setting of any 
pen style by saving changes in the preferences file. See the “Saving Preferences” 
section at the end of this chapter.

Although style characteristics can be changed, style names cannot. Keep this in 
mind changing the pen pattern. Otherwise, the style name may not reflect the 
pattern and cause confusion if the changes are saved as a preference.
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Setting Units
Graphite is set to measure geometry in inches. When opening a new drawing, set 
the precision, units, and fractional or decimal specifications as needed.

Units Command
This command is found by choosing Layout>Preferences>Units. A dialog box 
displays. 

Precision Sets the number of decimal places in all data 
fields within Graphite (in Edit Objects, the Status 
Line and all dialog boxes). The default is 0.001.

When choosing a fractional precision, 
measurements appear as fractions rather than 
decimals. Set the format for fractions by choosing 
Dimension>Linear.

When Graphite rounds off values it stores the 
number, accurate to 16 decimal places; therefore, 
it is possible to change the precision displayed at 
any time and maintain the desired accuracy.

 Altering the decimal or fractional precision does 
not affect any dimensions. The precision of 
dimensions is selected by going to the Dimension 
menu and choosing the setting in the Linear and 
Angular submenus. A fractional precision is 
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required with fractional dimensions. The same is 
true for decimal dimensions.

Inches, feet Displays measurements in English units. 
Measurements less than 1 foot appear in inches 
and those greater than 1 foot appear in feet and 
inches.

mm, cm, meters Displays measurements in metric units.

Leading 0's Determines whether or not the zero to the left of 
the decimal point appears.

Trailing 0’s Determines whether or not zeros to the right of 
the decimal point are displayed. If set, the 
precision determines the number of trailing zeros.

All geometry reflects the new unit measurement, converting automatically 
between English and metric. When changing the units, existing dimensions 
update to reflect the change.

Using the Status Line to Specify the Unit of Measure
Use the Status Line to specify a unit of measure other than the one in effect for the 
document. If the units are set to inches for drawing a line, use different units of 
measure such as inches ("), feet ('), feet and inches (x'y”), millimeters (mm), 
centimeters (cm) and meters (m). Mix the units in the mathematical expression if 
they are labeled properly. For example: 10" + 25.4 cm.

In the following example, if the units are set to inches, enter 23' in the Length data 
field as shown below.

When ENTER (Windows) or RETURN (Macintosh) is pressed, a line 23 feet long 
is drawn. Graphite converts the length to inches and the Status Line displays the 
length in inches because of the Units setting.

In addition, it is permissible to use mathematical, exponential, and trigonometric 
expressions in the Status Line. Appendix A provides examples of the valid 
operators.
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Tech Note:

To change the Hit Radius, 
choose 
Layout>Preferences>
Snap.
The Grid
When the Grid is visible, objects snap to the grid spacing. To place an object 
between the grid marks, either turn off the grid, change the grid spacing, or zoom 
in so that the spacing is larger than the Hit Radius. The grid spacing automatically 
reflects the units set in the Units dialog box. When the units are changed, the 
appearance of the grid spacing remains the same, and the values listed in this 
dialog box change automatically.

Grid Command
This command, found in Layout>Preferences, sets the spacing of the grid lines. 
Specify the number of ticks (subdivisions) per unit (spacing). Change the default 
setting by saving changes in the preferences file.

Show Grid 

CTRL+G (Windows);+G (Macintosh)

This command in the Layout menu controls the display of the grid. The grid is 
made up of horizontal and vertical lines of dots. The spacing of the grid lines and 
the number of tick marks between the intersections are set in the Grid dialog box 
by choosing Layout>Preferences>Grid. When the grid is visible, the Drafting 
Assistant snaps to the grid spacing. In other words, if the grid is set to .25 inch 
spacing, constructing an object cannot be done closer than .25 inch to another 
object. 

The coordinate symbol appears at the origin location (X=0, Y=0) when the grid is 
visible.

0,0  Origin
Coordinate Symbol
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Changing the Grid Spacing and Subdivision
1. Choose Layout>Preferences>Grid.

The Grid dialog box displays.

2. Enter the desired values for Grid Spacing and/or # of subdivisions.

3. Select the grid color from the drop down menu.

4. Click OK and the changes are saved.

Click Cancel to prevent saving the changes.
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Drawing at Full Scale
Whether designing or drafting a highly detailed blueprint, create the geometry at 
its actual size. In Graphite it is possible to construct the part using full-scale 
specifications and then set the visual scale of the drawing. In this way, the part 
dimensions to its true-to-life measurements. Drawing at full scale has the following 
advantages:

• Scaling mistakes are eliminated.

• Dimensions are automatic (dimension manually if drawing is not at full scale).

• Associative dimensions update when the object is edited (manual dimensions 
do not).

• The size relationship of imported parts is compatible.

• Calculations for 2D analysis are accurate.

Once the project is drawn, dimension it, scale it visually and size it to fit into a 
standard drawing format, if necessary. The actual size of the geometry remains 
constant unless edited. 

When opening a new Graphite document, the drawing area is a sheet that is 
infinitely large so that anything can be designed at full size. For a simplistic 
example, here's how to draw and view a line 83 feet long:

1. Draw a line, specifying 83' for the length. 

The line extends off the screen. 

2. Choose Arrange>Zoom All.

The entire 83 foot line is visible on the screen.

Using the draw to scale/Zoom All method, create accurate full-scale drawings 
which are displayed at the magnification chosen. The actual size of an object is 
not affected by zoom magnification or reduction. 

Zoom All magnifies or reduces all objects on the drawing to fill the screen 
regardless of the size of the objects.
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The Drafting Process
The drafting process may or may not include using a standard drawing format. 

Since the geometry is created at full scale, the basic difference in the two drafting 
processes is how the visual scale of the geometry is set so that it fits on the paper 
or in a drawing format. Most steps are discussed in the following two drafting 
procedures. They are also discussed in greater detail in later chapters.

Vellum

2.174

2.174

Ø 327

Ø 530

Ø 274

2.174

2.174

Ø 327

Ø 530

Ø 274



Graphite User Guide The Drafting Process
Drafting without a Drawing Format
1. Start Graphite and display an Untitled document.

2. If necessary, set the Units of measure to use by choosing 
Layout>Preferences>Units.

3. Construct the geometry at full size, saving the construction while working. Use 
the Zoom commands and tools to display the part at an appropriate 
magnification in order to see what is done.

4. Choose File>Print Setup (Windows) or Page Setup (Macintosh) command to 
set the paper size for plotting or printing.

5. Choose Layout>Drawing Size to set the drafting scale for plotting or printing.

Specify the drafting scale for the drawing, such as 1:120 or 1":10' for 1 inch to 
represent 10 feet. If the scale is not of concern and the final geometry only 
needs to fit on the selected paper size, specify Fit to adjust the geometry 
automatically to the paper size.

6. Dimension the part and add text.

When specifying the visual scale for the drawing with the Drawing Size 
command, Graphite scales text, dimensions, hatches and line patterns 
inversely with the same scale factor so that all text and dimensions added 
after scaling have exactly the size specified in the Size submenu in the Text 
menu. That means if the text size is set for text and dimensions to 0.25 inches 
it plots at a size of 0.25 inches on the paper.

7. Make final adjustments.

8. Choose File>Print.
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Tech Note:

If text and dimensions are 
added before scaling the 
drawing with the Drawing 
Size command, all text and 
dimensions must be selected 
with the Selection Mask to set 
the text size again to the 
desired value, for plotting on 
the paper. See Scaling Text 
and Dimensions in Graphite 
Documents.
Drafting with a Drawing Format
1. Start Graphite and display an Untitled document.

2. If necessary, set the Units of measure by choosing 
Layout>Preferences>Units.

3. Construct the geometry at full size, saving the construction in the process. 
Use the Zoom commands and tools to display the part at an appropriate 
magnification in order to see what is done.

4. Use the Sheet Into View command from the Views menu to set the visual 
scale so that the part fits into the size of the drawing format selected in the 
pop-up menu in the Sheet Into View dialog box.

5. Dimension the part and add text.

When you specify the visual scale for the drawing with the Sheet Into View 
command, Graphite scales text, dimensions, hatches and line patterns 
inversely with the same scale factor so that all text and dimensions added 
after scaling have exactly the size specified in the Size submenu of the Text 
menu. That means, if the text size is set for text and dimensions to 0.25 
inches, it plots at a size of 0.25 inches on the paper.

6. Make any final adjustments.

7. Choose File>Print to print or plot the drawing.
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Referral:

For more information about 
using the Recent File List, 
consult the discussion of the 
Recent File List in Graphite 
Documents.
OS Settings

Windows Settings

Graphite.ini
The Graphite.ini file is an ASCII text file that can be opened and edited in any text 
editor, including NotePad. This file contains setting for the number of fonts that 
appear in the Font submenu, the size of the screen when Graphite is launched, 
and the number of files that appear in the Recent File List.

To make changes to the Graphite.ini file, open it in any text editor and make the 
desired edits. Save the file as a text file. The next time Graphite is launched, it will 
account for the new setting in the Graphite.ini file.

MaxFont
This option sets the number of fonts that appear in the Font submenu from the 
Text and Dimension menus. Graphite takes the fonts in alphabetical order, up to 
the number that is specified in the Graphite.ini file. Fonts that do not show up in 
the menu are accessed by choosing Text>Font>Other. By default this value is left 
blank, so Graphite displays all the fonts.

Screen
This option sets the size of the screen when Graphite opens. There are two 
options. Screen=FULL opens to a maximized window. Screen=Standard opens to 
the standard size, which is almost maximized but with room for icons at the 
bottom. If no value is specified, the screen opens to the standard size.

Recent File List
This option determines the number of files that appear in the Recent File List from 
the File menu. Specify the number of files that are to appear in the File menu after 
Files=. The names and paths of recently opened files are saved in the list that 
follows the Files= line. File1= is always the most recent file opened. As new files 
are opened, the file list gets shifted down, so the old File1 becomes File2, and so 
on. The default number of files is four. The maximum number is eight.
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Macintosh Settings

Fonts
All of your system fonts are available when choosing Text>Fonts.

Recent File List
Specify the number of files that should appear in the Recent File List of the File 
menu. A file named recent.lst can be found in the Scripts folder. This file is an 
ASCII text file that can be opened and edited in any text editor. The following is a 
sample of the contents of the recent.lst file:

/aRecentFiles
4            % Number of recent files remembered (8 maximum)
store
/aRecentFileList [
(MacHD:Graphite 3D 3.0:Samples 3D:YF-22)
(MacHD:Graphite 3D 3.0:Samples 3D:Chair 3D)
(MacHD:Graphite 3D 3.0:Samples 3D:Question Mark)
()
] store

Before % Number of recent files enter a number to specify the number of files that 
are to appear in the File menu. The names and paths of recently opened files are 
saved in the list that follows the /aRecentFileList [ line. The first file in the list—YF-
22 in the example above—is always the most recent file opened. As new files are 
opened, the file list gets shifted down. The default number of files is four. The 
maximum number is eight.

Saving Preferences
All files save with the settings set for the file. The characteristics used for new files 
(the default settings) appear in the preferences file.

Preferences Command
This command in the Layout menu displays a submenu for setting various 
specifications. Descriptions of the items in the submenu appear individually in this 
reference section. Change the default setting by saving changes in the 
preferences file, prefs.vc6 (Windows) or Graphite prefs (Macintosh).
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Snap This box sets the alignment angles, hit radius and 
other Drafting Assistant settings. This is different 
from the Snap command explained in Chapter 4.

Grid This dialog box specifies the spacing of the grid 
lines. Choose Layout>Show/Hide Grid to turn 
the display of the grid on and off.

Units This dialog box specifies the units and precision 
for the current Graphite document.

Selection Use this dialog box to set the color or blinking 
which shows that an object is selected. 

Undos Sets the number of last actions to reverse.

Nudge Specifies the distance selected geometry can be 
nudged within Graphite using the arrow keys on 
the keyboard.

Invert This option inverts the screen from white to black.

DAssistant This is a toggle switch for turning the Drafting 
Assistant on or off. A check mark in front marks 
the on status.

AutoSave Sets the time interval for the program to save files 
(if they were modified). 

Directory Specifies the file location for symbols and for 
opening, saving, importing, exporting files.

Language Sets the language of the interface.

Icon Style Sets the icon style for the user interface.

Dimensions Palette Sets the orientation of the Dimension palette.
Orientation
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Save Preferences If the desired characteristics such as units, pen 
style and dimension format are set, it is possible 
to make those settings the default settings. 
Choose Layout>Preferences>
Save Preferences. Geometry cannot be saved 
this way.To save the geometry, open the 
preferences file, create the geometry and save 
the file.

Save Palettes This saves the status (visible/hidden) and the 
location of the Dimension, Symbol and Function 
palettes. 

Saving Preferences Information and Characteristics
The preferences filename is prefs.vc6 (Windows) or Graphite prefs (Macintosh). 

To use different settings for your work, change the default settings, and then every 
new document opens with the settings selected. The following specifications are 
set in the preferences file:

• Pen styles

• Text characteristics

• Preferences settings (snap, grid, units, selection color indicator, and 
visualization settings) 

• Grid display

• Layer and sheet specifications

• Work layer

• Dimension and tolerance formats

• Arrowhead type and display

• Drawing size and scale

• Zoom scale

• Fillet radius

• Chamfer angle and length

• Resolve values

• User defined colors
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Changing the Default Settings
1. Create a file which has the desired preferences.

2. Choose Layout>Preferences>Save Preferences.

The preferences are set for subsequent new documents after restarting 
Graphite.

Be careful choosing Save Preferences when working in a file with multiple sheets, 
models, details views, or layers. Even though the geometry is not saved, all other 
data is. All new files opened subsequently will contain items that are not desired.   
Check the Preferences file for the items mentioned on a regular basis. The original 
default setting for the file includes one sheet, one model, three layers 
(Construction, Dimension, and Layer 1) and no detail views.

Save Palettes
In the Preferences submenu find the Save Palettes command. When selecting 
this command the Status (visible/hidden) and the Location of all palettes are 
saved to preferences. When restarting Graphite, all palettes that were displayed 
while closing Graphite are automatically reopened.

Location and Status for the following palettes are saved with this command:

• Dimension palette

• Symbol palette

• Function palette

• Tool palettes

• Tear-off palettes

The Trackball does not save with this command.

For Windows, the Location and Status of these palettes are saved in the 
Graphite.ini file, under the section Palettes.
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Advanced Environment Settings
Advanced Environment Settings
This chapter describes the various advanced options that for adapting Graphite to 
your needs. The following topics are covered:

• Add Command

• Macros

• File Organization

• 3D Viewing
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Add Command

This utility adds custom functionality to the Graphite Utilities menu. Utility scripts are 
available in the Support Center of the Ashlar-Vellum website, can be developed by 
you in Ashlar-Vellum’ s FE language (similar to Postscript), or may be custom 
developed for you by the Ashlar-Vellum technical team. From the Utilities menu, 
choose Add Command and navigate to the location on your system where the script 
is saved. Select the file and click the Open button to place the script in the correct 
folder. As alert message notifies you that the new functionality will be available after 
restarting the software.
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Macros
It is possible to create macros within Graphite and access them through menu 
commands, stroke commands, or key combinations, providing an alternative way to 
invoke these commands.

A macro automates a repetitive task by executing a group of simple commands. 
Define a macro by pointing and clicking. 

Macro Command
Choose Utilities>Macro, and the following dialog box displays:

The Macro dialog box is modeless in the sense that there are no Start Recording or 
Stop Recording buttons. Whatever actions are performed (selecting menu items or 
defining strokes) are recorded automatically in the related list boxes as long as the 
Macro dialog box is open.

The Macro dialog box contains the following buttons:

New This adds a macro named Macro1 to the Names list 
box. Rename the macro in the Rename data field 
by overwriting Macro1 with a new name and then 
clicking the Rename button.
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Rename This overwrites the selected macro name in the 
Names list box with the name entered in the 
Rename data field. (For Windows, macro names 
may only contain alpha-numeric characters. No 
spaces or other characters are allowed.)

Remove Click this to remove any selected entry from one of 
the three list boxes.

Save The Save button writes all currently defined 
macros to files in the Scripts folder in the Graphite 
installation folder. The file names are generated 
directly from the macro names. The files are 
output in such a way that when Graphite is 
subsequently started, the macros activate 
automatically. Macro files can be moved to other 
locations, or to other machines for use in other 
licenses of Graphite.

Run The Run button exe the macro currently selected 
in the Names list box. Macros can call other 
macros if they are in the Utilities menu. This is 
done by clicking on the relevant entry in the 
Utilities menu, like any other menu item. If a macro 
calls another macro, which in turn calls the original 
macro an infinite loop is created. These infinite 
loops are checked when an attempt is made to 
include a macro, and if detected, an alert box is 
posted resulting in the macro not being included.

Help Opens the text file with the instructions on using 
the macros.

Names list box The names of all defined macros are alphabetically 
displayed in the names list box. When one of the 
items is selected, the Strokes and the Commands 
list boxes, as well as the Key and In Utilities Menu 
fields are automatically filled in with the relevant 
data that defines the selected macro.

Strokes list box This box shows a group of stroke commands, if 
any, that can run the selected macro. The names 
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in this list box relate to the encoding of the shape 
of the stroke and you need not be concerned 
about them. It is optional to associate a stroke 
with a defined macro.

Commands list box The Commands list box shows the set of menu 
commands that define this macro. They are 
shown in this form: MenuName; EntryName

Key This assigns the key combinations for a macro by 
clicking in the Key edit box and entering the key 
combination or typing it directly in the Key entry 
field. For example, enter CTRL+SHIFT (by 
pressing the CTRL key first, keeping it depressed 
and pressing the SHIFT key) and then the key P. 
The Key edit box displays CTRL+SHIFT P. 

Windows users: While creating a macro, if the 
CTRL key combination designated is already in 
use, the macro cannot be executed. Macintosh 
users: While creating a macro, if the designated  
key combination is already in use, Graphite 
prompts for a different key combination to be 
assigned.

In Utilities If this is checked, the macro name is included as a 
menu item in the Utilities menu to access the 
macro directly.

Creating a Macro
1. Choose Utilities>Macro. The Macro dialog box displays.

2. Click New.

The name Macro1 displays in the Rename field.

3. Overwrite the name if desired. (Use alpha-numeric characters with no 
spaces.)

4. Select menu commands in the order the new macros will execute.

The selected commands are automatically filled in the Commands list box.

If a stroke command is not desired for the macro, go to step 6.
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5. Define a Stroke command on the drawing area.

Press CTRL+SHIFT (Windows) or the  key (Macintosh) and drag a symbol on 
the drawing area to be associated with the new macro.

Use letters or a figure like a circle. Do not use Graphite’s standard stroke 
commands like Zoom or Construction strokes, since they are executed 
immediately. A letter and number combination describing the executed stroke 
displays in the Stroke list box automatically. When defining a stroke, repeat it 
several times to define all variations of the stroke, so that all possible variations 
are covered and can be recognized by Graphite.

6. Check the In Utilities Menu option to include the new macro in the Utilities 
menu.

7. Enter a Key short cut in the Key entry field.

Click in the Key data field and enter the key combination or type it directly in the 
Key data field. 

8. Close the Macro dialog box by double-clicking the Control menu (Windows) or 
the Close button (Macintosh) in the upper left corner of the dialog box.

Editing a Macro
1. Display the Macro dialog box.

2. Select a macro in the Names list box.

3. Rename the macro in the Rename data field and click the Rename button.

4. Redefine the macro by executing menu items and assigning a new stroke 
equivalent to the macro.

5. Alter the Macro key combination in the Key data field.

6. Close the Macro dialog box by double-clicking the Control menu (Windows) or 
the Close box (Macintosh) in the upper left corner of the dialog box.

Removing a Macro
1. Display the Macro dialog box.

2. Select a macro in the Names list box.

3. Click Remove.
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Running a Macro
Each macro has a unique name and is run in one of four ways:

• Invoked with a key combination. Subsequent typing of that key combination 
causes the associated macro to run.

• Invoked by a family of stroke commands defined in the Macro dialog box.

• Selected the Utilities menu if the In Utilities Menu option was checked in the 
Macro dialog box.

• Executed by selecting it from the Names list in the Macro dialog box and clicking 
Run.

Executing a macro with the Run button is useful for testing a macro. Should it not 
work properly, highlight any dialog box entry and remove it by pressing the 
Remove button. Modify the macro as needed then test it again by pressing the 
Run button. Continue this process until the macro runs properly.

Macro Limitations

Macros are not general programs. There are limitations as to what is encoded in a 
macro. The following rules apply:

• Only menu items and tools are included in a macro.

• A menu item might cause a dialog box to appear, but the macro cannot fill in the 
required entries.

• There are no conditionals (like if or ifelse) or loops (like while).

• Subroutines are allowed so that one macro can call another macro, provided 
the called macro is in the Utilities menu and therefore a menu item. If a macro 
calls a nested macro which ends in an infinite loop, an alert box appears and 
the macro aborts.

• Macro names are limited to alpha-numeric characters with no spaces.
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File Organization
Graphite enables you to organize your files. The Directory command in 
Preferences specifies the file location for symbols and for opening, saving, 
importing, exporting files. See Chapter 15 for more information.

3D Viewing
Although the transition between 2D and 3D drawing in Graphite is seamless, there 
are a few settings and features that are unique to 3D. When opening a new 
document an empty work area displays. This work area, a sheet, is an infinitely 
large drawing space for creating a model of any size. The new sheet displays the 
Top view by default on the x, y plane of the model space picked up by the sheet 
camera. When constructing geometry in 3D, rotate the sheet camera to a 3D view. 

It is also possible to start drafting in 2D and then continue drafting in 3D simply by 
changing the view.
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Tip:

The Trackball can be 
changed to the Trackcube 
by clicking the button in 
the lower left corner of the 
Trackball window.
Once the sheet camera is rotated, it is as though the model rotates so that all the 
x-, y-, and z-directions can be seen while drawing. 

There are several options for this rotation:

• Manually rotate with the on-screen Trackball.

• Select a view from the pop-up menu in the Trackball window.

• Choose a view from the Views submenu in the Views menu.

Show/Hide Trackball/Trackcube
This command toggles the display of the Trackball/Trackcube window. Use the 
Trackball/Trackcube to rotate the view orientation in the active detail view window 
or the sheet view, as long as no view windows have been created. Drag the 
Trackball window around the screen. For more information on detail views and 
sheet views, see Chapter 13, “Viewing Geometry.” To rotate between the Trackball 
and the Trackcube, click on the box in the lower left corner.
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z

y

x
Tip:

To see the Triad at the 
origin (0,0,0), set the grid 
spacing to 0 in the 
Preferences submenu in 
the Layout menu.
Rotating the Sheet View or Active View
1. Choose Views>Show Trackball.

2. Drag the pointer on the Trackball to 
rotate the view.

The model rotates as you drag. The 
model rotates around the center of the 
active view or sheet.

Using the Trackball View Menu
The Trackball/Trackcube has a pull-down menu for specifying the view of 
the current view window or the sheet view, if there are no view windows.

1. Move the pointer to the current view name displayed at the bottom of the 
Trackball/Trackcube window.

2. Press the mouse button. The Views menu 
displays.

3. Choose the view orientation to display in the 
current window.

The view orientation changes to the 
specification in the view window.

Trackball Locking
This feature locks the Trackball/Trackcube along 
two screen axes so that the view of the geometry 
is rotated around the third screen axis. The 
screen axes are different from the axes of the 
geometry unless the top view is set.

Example:
It is possible to rotate the view of this block around the x-,y- or z-axes 
of the geometry or the screen.
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Rotate View around an Axis of the Geometry
To rotate the view around an axis of the geometry, 
change the view to Top, either from the Trackball 
menu or choosing Views>Views>Top. This makes 
the screen axes the same as the axes of the block.

Rotate View around the X-axis

To rotate around the x-axis, place the cursor on the 
Trackball, hold down the SHIFT key and drag the 
cursor up or down. The geometry rotates around the x-
axis.

Holding down the SHIFT key locks both the y- and z-
axes.

Rotate View around the Y-axis

To rotate around the y-axis, place the cursor on the 
Trackball, hold down the CTRL key (Windows) or the 
OPTION key (Macintosh) and drag the cursor to the 
left or right. The geometry rotates around the y-axis.

Holding down the CTRL key (Windows) or the 
OPTION key (Macintosh) locks both the x- and z-
axes.

Rotate View around the Z-axis
To rotate around the z-axis, place the cursor on the 
Trackball, hold down the CTRL+SHIFT keys 
(Windows) or the  key (Macintosh) and drag the 
cursor in a circular motion. The geometry rotates 
around the z-axis.

Holding down the CTRL+SHIFT keys (Windows) or 
the  key (Macintosh) locks both the x- and y-axes.

Top
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Rotate View around the Screen Axis
With the same block displayed in any view, simply use the key combinations listed 
previously to rotate around the desired axis.

If the geometry is displayed in the trimetric view and 
it needs to be rotated around the screen's z-axis, 
place the cursor on the Trackball, hold down the 
CTRL+SHIFT keys (Windows) or the  key 
(Macintosh) and drag the cursor in a circular 
motion. The geometry rotates around the screen's 
z-axis.

Show/Hide Triad
This command toggles the display of the Triad symbol in the upper-left corner of 
the view windows. The Triad illustrates the orientation of the x, y, z axis and the 
work plane. This symbol also temporarily displays at the origin and rotates as the 
view orientation is rotated manually with the Trackball.

If a detail view is not created, the Triad symbol displays in the upper-left corner of 
the sheet. Once a view window is created, the sheet camera cannot be rotated 
any more. It remains stationary at the world orientation. For more information on 
detail views and sheet views, see Chapter 13.

Top Isometric

Trimetric

Front Right
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The Triad represents the principle of 
the right-hand rule—a memory aid for 
the relative directions of the positive 
axes. With your right palm upturned, 
the thumb (x) points right, the index 
finger (y) points straight ahead, and 
the middle finger (z) points up. If you 
move your hand to indicate the x and 
y-axes, you can easily see the 
direction of the z-axis.

Views Command

This command displays the view 
orientation submenu to set the 
orientation of the sheet view or active 
view window. 

The standard views, Front, Isometric, 
Right, Top and Trimetric, are always 
displayed in this menu. Create new 
views with the Define View command 
and those views are listed in this menu. 
Views are also selected from the 
Trackball menu. (See Chapter 14 for 
more information on Define View.)

The selected view orientation affects 
the active area, including the sheet 
view or the active view window. 

X

Y

Z

The Right Hand Rule
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Drawing Tools

Referral:

For more information 
about the Drafting 
Assistant, see Chapter 4.
Drawing Tools
This chapter describes how to create geometric objects that are the building blocks 
for the designs created with Graphite's drawing tools. It also describes how the 
Drafting Assistant makes design faster and easier. The following topics are 
contained in this chapter:

• Drawing Techniques

• The Status Line

• The Message Line

• Drawing Tools - Description and Use

Drawing begins with the tool palette, located at the left of the Ashlar-Vellum 
Graphite drawing area shown below:

The tool palette has seven subpalettes of tools used to create and select geometric 
objects. These seven tools are the drawing tools.
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Selection Tools

Spline Tools

Polygon Tools

Ellipse Tools

Circle Tools

Arc Tools

Line Tools
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Drawing Techniques
Most drawing tools offer two methods for creating an object: clicking and dragging. 

Clicking This creates objects by clicking points with the 
mouse. The benefit of this technique is in 
performing unrelated activities, such as zooming, 
while creating the geometry.

Dragging This method indicates two points by dragging 
from one to the other. Press and hold mouse 
button to set the first point. Next, drag the mouse 
to the location for the next point and release the 
mouse button. The benefit of this technique is that 
a rubberband image appears during the 
construction to show how the object will appear 
once the mouse is released.

Both methods are available in most tools.

To make object creation easier, Graphite's tools contain a feature called Smart 
Pointers. While working with a tool, the tool icon shows the points that must be 
indicated to create an object with the tool. 

Each dot on the icon, such as the Single Line tool icon shown here, represents a 
point to place either by clicking or by dragging. The smart pointer indicates the order 
for designating points while drawing the geometry.
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Tech Note:

Notice that there is no 
rubberband guide line 
when using the clicking 
method.
Creating a Line by Clicking
1. Select the Single Line tool from the tool palette.

2. Move the pointer to the drawing area and click to set the starting point of the 
line.

3. Move the pointer to the desired location for the endpoint of the line and click. 

The line is drawn between the two points.

Immediately after construction, changes can be made in the Status Line at the 
bottom of the drawing area to alter the length or position of the line. If the 
geometry isn’t satisfactory, just press the BACKSPACE (Windows) or the 
DELETE (Macintosh) key.

Click at the beginning point of the line

Click at the endpoint of the line
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Tip:

Notice that when dragging 
between points, a 
rubberband line acts as a 
guide. When using the 
clicking method, unrelated 
activities, such as 
zooming can be 
performed between clicks.
Creating a Line by Dragging
1. Click the Single Line tool in the tool palette.

2. Move the pointer into the drawing area.

3. Press and hold the mouse at the desired location for the starting point of the 
line.

4. With the mouse button still held, move the mouse to the desired location for 
the endpoint of the line.

5. Release the mouse button to set the endpoint.

Immediately after construction, changes can be made in the Status Line at the 
bottom of the drawing area to alter the length or position of the line. If the 
geometry is not satisfactory, just press the BACKSPACE (Windows) or the 
DELETE (Macintosh) key.

Press and hold the mouse button
at the starting point of the line.

Drag the mouse until the line is the desired length. 
Release the mouse button. 
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Tip:

Notice how each method 
affects the selection of the 
contents of the status 
field. Clicking once inside 
the field places the cursor 
where clicked. If double-
clicking inside the field, 
the entire entry is 
selected for editing.
The Status Line
Whenever a tool from the tool palette is selected, the Status Line appears along the 
bottom of the drawing area. It contains fields that provide information about the 
current construction. For example, when the Single Line tool or Connected Lines 
tool is the current tool, the Status Line contains fields for the X and Y coordinates of 
the beginning point and the change of X and Y values for the endpoint of the line. 
It also contains the value of the length and angle of the line.

Use the Status Line in three ways:

• To create an object with keyboard entries only.

• To edit an object that was just created and is still selected.

• To create an additional object using the current tool.

When constructing an object, the status field contains selected specifications that 
can be changed (the field is highlighted). For example, when drawing a line with the 
Single Line tool, the Length data field is highlighted to enter a value for the length. 
Just type a value. Press ENTER (Windows) or RETURN (Macintosh) and the line is 
redrawn at the new length.

Set the number of decimal places for the Status data field entries or fractional round 
off by going to Layout>Preferences>Units. In the Units dialog box set the 
precision.

Using the Status Line Fields
To make an entry in a different status field, use one of four selection methods:

• Press the Tab key to cycle the selection highlight through the status fields from 
left to right.   

• Click inside the status field and the pointer becomes an I-beam text cursor.

• Double-click inside the status field to select the entire contents of the field. 

• Click the field label to select the entire contents of the field.
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Using the Status Line with Drawing Tools
After an object is drawn, specifications, such as the length, angle and location can 
be adjusted in the Status Line. It is possible to make these changes immediately, 
before constructing another object, selecting a different tool, or choosing another 
command. 

Make only one series of changes in the Status Line (in as many fields as 
necessary). After pressing ENTER (Windows) or RETURN (Macintosh) Graphite 
redraws the object to the specifications. Once ENTER (Windows) or RETURN 
(Macintosh) is pressed, make subsequent changes with the Edit Objects command 
in the Edit menu.

Note: When working in English units, values in the Status Line can be entered as a 
combination of feet and inches. Enter them as x'y" and not x'-y". The dash reads as 
a minus sign and x'-y" is calculated as an equation. See Appendix A for operators 
and units.

Try the following exercises to create and change a single line with the Status Line.

Altering Geometry in Progress with Status Fields
1. Select the Single Line tool.

2. Click two locations in the drawing area. The length (L) field automatically 
highlights in the Status Line.

3. Type 3. The 3 is entered directly in the L field.

4. Press the Tab key to select the next status field. The angle (A) field now 
highlights.

5. Enter 15.

6. Press ENTER (Windows) or RETURN (Macintosh).

Pressing ENTER (Windows) or RETURN (Macintosh) completes the data entry 
for this object. The line redraws 3 units long and at a 15° angle.

Remember that by pressing ENTER (Windows) or RETURN (Macintosh), Graphite 
constructs the object based on the specifications in the status fields. Pressing 
ENTER (Windows) or RETURN (Macintosh) a second time in the above example 
creates a second line with the same values. Since the lines have the same values, 
the second line overlays the first line, obscuring it from view.
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Creating Additional Geometry with Status Fields
1. With the Single Line tool still selected from the previous example, click two 

more points. 

2. Type 4.

3. Press the Tab key and type 25.

4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.

Creating New Geometry with Status Fields
1. Choose the Selection tool so the Single Line status field clears.

2. Click the Single Line tool again.

With the X status field is active, enter a value for the X coordinate of the 
beginning point of the line.

3. Type 0.

Note: Do not press ENTER (Windows) or RETURN (Macintosh) until step #10.

4. Press the Tab key. The Y field highlights.

5. Type 0.

6. Press the Tab key again.

The dX field highlights. The dX value is the delta X, the numeric difference 
between the beginning and ending X coordinate.

7. Type 2.

8. Press the Tab key. The dY field highlights. 

9. Type 2.

10. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.
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Creating Geometry Offset from a Point
To create geometry that is offset from an existing point, use the Status Line to 
specify the offset.

1. Select the tool.

2. Move the pointer over the control point from which you want the offset.

3. Click once to lock onto that point.

4. Click in the appropriate X or Y field in the Status Line, placing the text cursor 
at the end of the entry.

5. Type the offset (such as + 3") and press ENTER (Windows) or RETURN 
(Macintosh).

6. Continue the construction.

The Message Line
The Message Line is an important feature when drawing. Upon selection of a 
drawing tool, the line displays the tool selected and the first step in its use. Following 
each step, the line displays the next one until the steps are completed. The 
Message Line may also display additional commands to use with the tool. See the 
example below.

Selected point 
from which 
geometry will 
be offset

Offset reference on 
new geometry 
(location appropriate 
to selected tool)

X Offset

Y 
O

ffs
et
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Drawing Tools - Description and Use
This section describes the drawing tools found in the tool palette. For a description 
of the selection tools see Chapter 9.

Line Tools

The Line tools in the Line tool palette create line segments, connected lines, lines 
parallel to existing lines and smart walls. While creating a line, the coordinate 
locations, line length and angle from horizontal appear in the Status Line. Dragging 
creates a rubberband smart wall, so that it is seen before it is drawn. The line is also 
drawn with the current pen specifications for color, weight and pattern. 

Single Line Tool

This tool, in the second subpalette of the main tool palette, draws a line between two 
points. Click or drag to draw a line.

Using the Single Line Tool
1. Select the tool. The Message Line reads, Single Line: Pick the beginning point. 

[Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Click two endpoints of the line, 

or

Drag to indicate the endpoints of the line; press at the beginning and release at 
the end of the line. While dragging, a rubberband line previews the construction.

To copy the line just created, as the Message Line indicates, hold down the CTRL 
(Windows) or OPTION (Macintosh) key and click once in the drawing area. A line 
appears that is identical to the one just drawn. The location of the click designates 
the location of the first endpoint.

The Status Line specifies the X,Y coordinates of the beginning, the relative location 
of the end (delta X and delta Y), the line length, and the angle from horizontal. Once 
a line is drawn, the line Length is the selected status field.
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Drawing a Line Perpendicular to Another Object
1. Construct the object.

2. Move the pointer to the object until a Drafting Assistant on notation appears. 
The Drafting Assistant notation must be on rather than endpoint, quadrant, or 
midpoint.

3. Drag straight away from the object in a perpendicular direction. A 
perpendicular line appears attached to the object. Keep holding the mouse 
down and move the cursor. Notice that the line stays perpendicular but slides 
along the object.

4. Drag to the desired length for the perpendicular line.

Drawing a Line Tangent to or Perpendicular to a Curve
1. Construct an arc, circle, or ellipse.

2. Choose the Single Line tool. 

3. Move the pointer to the arc until a Drafting Assistant on notation appears. The 
Drafting Assistant notation must be on rather than endpoint, quadrant, or 
midpoint.

4. Drag in the appropriate direction (straight for perpendicular or at an angle for 
tangent) until the Drafting Assistant perpendicular or tangent notation appears. 

5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line 
around the arc to the desired location and extend the line to the necessary 
length.

Creating a Point
Create a point by creating a line and setting its length to zero. Set the starting point 
of the line with the mouse, then type 0 in the Length entry field of the Status Line 
and press ENTER (Windows) or RETURN (Macintosh). The line (“point”) displays a 
+ to indicate its location. A 0 length line can also be created by clicking the Single 
Line tool twice in the same spot.
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Mid-Point Line Tool

This tool, in the second subpalette of the main tool palette, creates a line that starts 
from the center and dynamically draws in both directions until the endpoint is 
clicked. 

Using the Mid-point Line Tool
1. Select the tool. The Message Line reads, Mid-Point Line: Pick center point. 

The message guides each successive step.

2. Click to indicate where the mid-point of the line will be.

3. Indicate one end point and the line grows symmetrically in the opposite 
direction.

Connected Lines Tool

This tool, in the second subpalette of the main tool palette, draws lines in which the 
endpoint of one line segment is the beginning point of the next. 

Using the Connected Lines Tool
1. Select the tool. The Message Line reads, Connected Lines: Pick the beginning 

point. The Message Line guides each successive step.

2. Indicate the endpoints of the line segments.   

If you click a point and then change your mind, press the ESC key, or choose 
Undo to remove the last line. Pressing the BACKSPACE (Windows) or DELETE 
(Macintosh) key removes all connected lines in the current construction.

3. Indicate the last point by double-clicking or by choosing another tool.

After completing at least one segment with the Connected Lines tool, it is possible 
to create a tangent arc off of the last line by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key (the pointer temporarily changes to an “arc” icon) and 
clicking or dragging to the next point. The Message Line notes this added feature. 
Several tangent arcs can be strung together by continuing to hold down the CTRL 
(Windows) or OPTION (Macintosh) key. (Note: The radius of these arcs cannot be 
edited with this method.) 



Graphite User Guide Drawing Tools - Description and Use

Referral:

For more information on 
construction lines see 
also “Permanent 
Construction Lines” on 
page 4-11
The Status Line specifies the X,Y coordinates of the beginning, the relative location 
of the end (delta X and delta Y), the line length and the angle from horizontal. Once 
the line segment is created, line Length is the selected status field. By entering 
successive sets of data and hitting ENTER (Windows) or RETURN (Macintosh) 
after each set, a continuous string of connected lines can be entered from the 
keyboard.

Construction Lines Tool

This tool, in the second subpalette of the main tool palette, constructs lines that help 
while drawing. Use the following methods for creating construction lines:

Using the Construction Lines Tool

1. Select the tool. The Message Line reads, Construction Line: Pick beginning 
point. The Message Line guides each successive step.

2. Click in the drawing area to specify the point through which the construction 
line should go.

3. Click once again with the mouse button indication the another point through 
which the construction line must go.

The Status Line has the fields with the coordinates of the last construction line 
drawn. You can change the data in the Status Line fields and the line 
coordinates will change accordingly.
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Parallel Lines Tool

This tool, in the second subpalette of the main tool palette, constructs lines parallel 
to existing lines. Use one of the following methods for creating parallel lines:

Using the Parallel Lines Tool
1. Select the tool. The Message Line reads, Parallel Lines: Drag new line off 

existing line. The Message Line guides each successive step.

2. Indicate the line to duplicate then drag to the new position. Enter the delta 
distance in the Status Line and press ENTER (Windows) or RETURN 
(Macintosh).

or

Click the line to duplicate then enter a delta distance in the Status Line and then 
press ENTER (Windows) or RETURN (Macintosh). (This method does not allow 
control of which side of the original line the new line is drawn.)

The status field specifies the distance between the original line and the new parallel 
line.
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Tip:

To use the Smart Wall 
feature for single lines, 
create the lines with the 
Smart Wall tool and enter 
0 for the thickness of the 
wall.
Smart Wall Tool

The Smart Wall tool, in the second 
subpalette of the main tool palette, 
constructs a double line like those 
used in architectural drawings. 
Please note: this tool functions 
correctly only in the Top view. 
Results are not accurate if drawn in 
any other view.

This tool works in much the same 
way as the Single Line tool except 
that it draws double lines or walls. 
Walls created on the same layer 
automatically trim to where they 
touch or intersect. Automatic trimming of smart walls occurs only when the walls 
are on the same layer. Dragging creates a rubberband smart wall, so that it is seen 
before it is drawn.

When dragging the mouse, the defining side of the wall falls on the construction line 
dragged along. The other side of the wall automatically fills in at the thickness 
specified in the Status Line. The position of the automatic wall depends on the last 
activity. If the second wall is on the wrong side of the construction line, press the 
SHIFT key to flip it. Notice the Message Line reads “Shift = Flip” as a reminder of 
this feature.

To fillet or chamfer or otherwise alter a Smart Wall layout, first ungroup them with 
the Ungroup command in the Arrange menu. The result is that the selected Smart 
Walls turn into separate line segments and the “smarts” are stripped out. This 
cannot be undone. Regrouping the pieces will not make them Smart Walls again. It 
is recommended to place all symbols before ungrouping and filleting/chamfering the 
walls.

Overlapping lines are 
automatically trimmed at 
the intersections.

Shift key
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Using the Smart Wall Tool
1. Select the tool. The Message Line reads, Double Line: Pick start point. [Shift = 

Flip]. The Message Line guides each successive step.

2. In the Status Line, specify the thickness (T) of the wall.

3. Indicate the ends of the wall segment.

Press the SHIFT key to flip the wall to the opposite side.

4. Continue specifying both endpoints for wall segments, as needed.

After deleting a merged segment, the remaining walls redraw. 

The Status Line specifies the thickness of the wall, the X,Y coordinates of the 
beginning point, the wall length and the angle from horizontal. Once the wall 
segment is created, wall Length is the selected status field.

Wall Symbols
Parametric symbols (like door and window symbols) can be constructed in a way 
that automatically cuts an opening in the Smart Wall on which they are placed. 
Examples of this are included with Graphite in the Architect library within the 
Symbols folder. When moving the symbol along the wall to another position, the wall 
automatically closes at the old position and the opening appears at the 
new position.

1. The symbol must contain a Smart Wall piece that is thicker than the wall 
segment on which it will be placed.

2. Set the pen pattern of the smart wall piece to dotted. (Any geometry in a 
symbol that is of the dotted pen pattern is placed on the drawing, but it is 
invisible.) This results in an invisible Smart Wall piece that cuts the Smart 
Walls on the drawing.

Parametrics works with Smart Wall configurations, but it can be tricky. While using 
parametrics, turn on the point display (Layout>Show Points) and hook dimension 
objects right to the displayed points rather than to the lines. Keep in mind that 
double walls obscure the fact that smart walls are actually single lines.

For more information on parametrics, see Chapter 16.
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Arc Tools
Use the Arc tools to create an arc by any of three methods:

• Center-Point

• 3-Point

• Tangent Point

When creating each arc, the Status Line displays entries such as coordinate 
locations, radius, angle from horizontal and delta angle. Dragging creates a 
rubberband ellipse, so the ellipse is seen before it is drawn.

The arc is drawn with the current pen specifications for color, weight and pattern.

Center-Point Arc Tool
This tool, in the third subpalette of the main tool palette, draws an arc from 
three points: the center point, arc beginning point and arc endpoint.

Using the Center-Point Arc Tool
1. Select the tool. The Message Line reads, Center-Point Arc: Pick center. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)]. The 
Message Line guides each successive step.

2. Indicate the center point of the arc.

3. Indicate the radius and beginning of the arc.

All three points can be clicked, but the rubberhand arc doesn’t appear with this 
method. To construct an arc greater than 180°, drag rather than click, the endpoint.

The Status Line specifies the X,Y coordinates of the center of the arc, the length of 
the radius, the starting angle from horizontal and the delta angle from the start. 
Radius is the selected status field.
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3-Point Arc Tool
This tool, in the third subpalette of the main tool palette, draws an arc 
through the points selected. 

Using the 3-Point Arc Tool
1. Select the tool. The Message Line reads, 3-Point Arc: Pick first point. [Ctrl = 

Tangent to object (Windows) or Option = Tangent to object (Macintosh)].

2. Indicate the first endpoint of the arc. 

3. Indicate the second and third positions. 

The arc is drawn from the first position designated, through the second position, 
and ends at the third position.

Clicking on a separate object while holding down the CTRL (Windows) or OPTION 
(Macintosh) key, the arc is drawn tangent to the specified object rather than through 
the exact click-point. For each of the three clicks that define the arc, if the CTRL 
(Windows) or the OPTION (Macintosh) key is held down and the cursor is placed on 
some other object, Graphite will define the arc to be tangent to that object at the 
nearest tangency point. If the CTRL (Windows) or OPTION (Macintosh) key is not 
held down, then the arc is created directly through that exact point. Each of the three 
points is treated separately.

The Status Line indicates the X,Y coordinates for each of the three points.
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Tangent-Point Arc Tool

This tool, in the third subpalette of the main tool palette, draws an arc beginning at 
the first point specified. The second point specified is the direction vector and the 
third point indicates the endpoint of the arc. Essentially, the Tangent-Point Arc tool 
first creates a line, then creates an arc tangent to the line, then erases the line.

Using the Tangent-Point Arc Tool
1. Select the tool. The Message Line reads, Tangent-Point Arc: Pick beginning 

point of arc (tangent line). The Message Line guides each successive step.

2. Indicate the starting point. This is both the starting point of the arc and the 
starting point of the temporary tangent line.

3. Indicate the endpoint of the tangent line. 

4. Indicate the endpoint of the arc. The arc is drawn between the first and last 
point clicked and tangent to the line between the first and second points.

The Status Line specifies the X,Y coordinates of the endpoints of the arc and the 
angle of the tangent line.

First Click Second Click

Third Click
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Tech Note:

A Circle Center Line tool 
is available for creating 
axis dimensions. For 
more information, see 
Chapter 12.
Circle Tools

The Circle tools on the tool palette construct circles by any of four methods: 

• Center-Point

• Opposite-Point

• 3-Point 

• Tangent

Center-Point uses the center and diameter of the circle. Opposite-Point uses the 
diameter. 3-Point uses three points and can be tangent to existing objects. Tangent-
Point draws a circle tangent to two objects, using the diameter specified. Dragging 
creates a rubberband ellipse, so the ellipse is seen before it is drawn.The circle is 
drawn with the current pen specifications for Color, Weight and Pattern.

Center-Point Circle Tool

This tool, in the fourth subpalette of the main tool palette, draws a circle specified by 
the center point and diameter. 

Using the Center-Point Circle Tool
1. Select the tool. The Message Line reads, Center-Point Circle: Pick center. [Ctrl 

= Copy previous (Windows) or Option = Copy previous (Macintosh)].

2. Indicate two locations; the first click places the center and the second 
determines the radius. 

3. To create a copy of the last circle, hold down the CTRL (Windows) or OPTION 
(Macintosh) key and click once in the center for the new circle.

The Status Line shows the X,Y coordinates of the center and the diameter of the 
circle. Diameter is the selected status field.
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Opposite-Point Circle Tool

This tool, in the fourth subpalette of the main tool palette, draws a circle specified by 
the diameter.

Using the Opposite-Point Circle Tool
1. Select the tool. The Message Line reads, Opposite-Point Circle: Pick first point 

on circle. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides each successive step.

2. Indicate two locations for the diameter, 

Create a copy of the last circle drawn by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking once to place first point of the new circle.

The Status Line specifies the X,Y coordinates representing the endpoints of the 
diameter.
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3-Point Circle Tool 

This tool, in the fourth subpalette of the main tool palette, draws a circle through the 
points selected. 

Using the 3-Point Circle Tool
1. Select the tool. The Message Line reads, 3-Point Circle: Pick first point. [Ctrl = 

Tangent to object (Windows) or Option = Tangent to object (Macintosh)]. The 
Message Line guides each successive step.

2. Indicate the first point on the circle.

3. Indicate the second and third points. 

If any of the three points are placed on an existing object, the circle is drawn through 
that point. By clicking an object while holding down the CTRL (Windows) or OPTION 
(Macintosh) key, the circle is drawn tangent to the object rather than through the 
indicated point. Combine the placement of these points to create a circle through a 
specific point of one object and tangent to another object, or a circle tangent to three 
objects, or any other combination.

The Status Line indicates the X,Y coordinates for each of the three points.

Tangent-Point Circle Tool

This tool, in the fourth subpalette of the main tool palette, draws a circle tangent to 
the two objects indicated. 

Using the Tangent Circle Tool
1. Select the tool. The Message Line reads, Tangent Circle: Enter diameter then 

pick first tangent object. The Message Line guides each successive step.

2. Enter a diameter for the circle in the status field.

3. Click the objects to which the circle is to be tangent.
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Ellipse Tools

The Ellipse tools on the tool palette construct ellipses inscribed within an invisible 
rectangle or parallelogram by any of four methods:

• 2-Point Center

• Opposite-Corner

• 3-Point Center

• 3-Corner

The 2-Point Center Ellipse uses the center point and one corner location of the 
rectangle. The Opposite-Corner Ellipse uses opposite corners of a rectangle. The 3-
Point Center Ellipse uses the center point, the midpoint of a side and the corner of 
the parallelogram. The 3-Corner Ellipse uses three corners on a parallelogram. 
Click or drag to create the ellipse. Dragging creates a rubberband ellipse, so the 
ellipse is seen before it is drawn.

The ellipse is drawn with the current pen specifications for Color, Weight and 
Pattern.

Ellipses do not have center points by design. By drawing lines between opposite 
vertex points on the ellipse, the intersection of the two lines is the center of the 
ellipse. For a 2-Point Center Ellipse (inscribed in a rectangle) the Drafting 
Assistant's horizontal and vertical temporary construction lines will cross at the 
center point once two vertex points are touched.
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2-Point Center Ellipse Tool

This tool, in the fifth subpalette of the main tool palette, constructs an ellipse 
inscribed within the rectangle calculated from the two specified points: the center 
point and one corner of the rectangle.    

Using the 2-Point Center Ellipse Tool
1. Select the tool. The Message Line reads, 2-Point Center Ellipse: Pick center of 

ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides successive steps.

2. Indicate the center of the ellipse.

3. Indicate the corner of the rectangle defining the ellipse.

If the two points are on the vertical or horizontal axis, a straight line is drawn.

To create a copy of the last ellipse, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click in the center of the future ellipse.

The Status Line specifies the X,Y coordinates of the center point and the length and 
angle of the semi-major and semi-minor axes of the ellipse.
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Opposite-Corner Ellipse Tool

This tool, in the fifth subpalette of the main tool palette, draws an ellipse inscribed in 
the rectangle specified by the opposite corners indicated.

Using the Opposite-Corner Ellipse Tool
1. Select the tool. The Message Line reads, Opposite-Corner Ellipse: Pick first 

corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides successive steps.

2. Indicate one corner of the rectangle defining the ellipse.

3. Indicate the opposite corner of the defining rectangle.

If the two points are on the vertical or horizontal axis, a straight line is drawn.

To create a copy of the last ellipse, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click the lower-left point of the future ellipse.

The Status Line allows specifying the X,Y coordinates of the lower-left point and the 
length and angle of the major and minor axes of the ellipse.
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3-Point Center Ellipse Tool

This tool, in the fifth subpalette of the main tool palette, constructs an ellipse 
inscribed within the parallelogram calculated from three specified points: the center 
point, the midpoint of a side and a corner of the parallelogram.

Using the 3-Point Center Ellipse Tool
1. Select the tool. The Message Line reads, 3-Point Center Ellipse: Pick center of 

the ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides successive steps.

2. Indicate the center of the ellipse.

3. Indicate the midpoint of the side of the rectangle defining the ellipse.

4. Indicate the corner of the rectangle defining the ellipse.

If the three points are on the vertical or horizontal axis, a straight line is drawn. 

To create a copy of the last ellipse, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click where the center of the future ellipse.

The Status Line specifies the X,Y coordinates of the center point and the length and 
angle of the sides of the parallelogram.
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3-Corner Ellipse Tool

This tool, in the fifth subpalette of the main tool palette, draws an ellipse inscribed in 
the parallelogram calculated from the three corners specified. 

Using the 3-Corner Ellipse Tool
1. Select the tool. The Message Line reads, 3-Corner Ellipse: Pick first corner of 

control parallelogram. [Ctrl = Copy previous (Windows) or Option = Copy 
previous (Macintosh)]. The Message Line guides through each successive 
step.

2. Indicate one corner of the parallelogram defining the ellipse.

3. Indicate another corner of the defining parallelogram.

4. Indicate the final corner of the defining parallelogram.

If the three points are on the vertical or horizontal axis, a straight line is drawn. 

To create a copy of the last ellipse, hold down the CTRL (Windows) or the OPTION 
(Macintosh) key and click where the lower-left corner of the future parallelogram.

The Status Line specifies the X,Y coordinates of a corner and the length and angle 
of the sides of the parallelogram.

Polygon Tools

These tools on the tool palette draw rectangles, inscribed polygons or circumscribed 
polygons. They create lines which are individual objects. To treat a polygon as a 
single object, select all lines of the polygon and choose the Group command in the 
Arrange menu. 

Dragging to indicate the points of the polygon creates a rubberband image. The 
polygon is drawn with the current pen specifications for Color, Weight and Pattern.
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Rectangle Tool

This tool, in the sixth subpalette of the main tool palette, draws a horizontal or 
vertical rectangle, using the opposite corners specified. 

Using the Rectangle Tool
1. Select the tool. The Message Line reads, Rectangle: Pick first corner of 

rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)].

2. Indicate the opposite corners of the rectangle, 

Create a square by aligning the second point on the 45° construction line. If the two 
points are on the vertical or horizontal axis, a straight line is drawn. To draw a 
square from the center rather than opposite corners, use one of the other polygon 
tools, specifying four sides. It is not possible to create a rectangle from the center.

Changing the Width and the Height of a rectangle in Edit Objects dialog box is not 
possible. Each line must be edited individually because rectangles become four line 
objects after deselecting the rectangle.

Create a copy of the last rectangle by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking where to place the upper-left corner of the 
future rectangle.

A default 1-inch rectangle is drawn if a rectangle has not been previously drawn.

The Status Line specifies the X,Y coordinates of the first point, as well as the width 
and height of the rectangle. Width is the selected status field.

Inscribed Polygon Tool

This tool, in the sixth subpalette of the main tool palette, draws a regular polygon 
where the radius of the circumscribing circle determines the location of the 
polygon’s vertices. 

The default polygon is a hexagon, but specifying the number of sides is possible in 
the Status Line. The Status Line shows a diameter for the circle, the standard way of 
describing a polygon inscribed in a circle.
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Using the Inscribed Polygon Tool
1. Select the tool. The Message Line reads, Inscribed Polygon: Pick center of 

polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides successive steps.

2. Indicate the center of the polygon. 

3. Indicate a point on the circumference of the circumscribing circle.

Create a copy of the last inscribed polygon by holding down the CTRL (Windows) or 
OPTION (Macintosh) key and clicking where you want the center.

The Status Line specifies the X,Y coordinates of the center, the diameter of the 
circle defining the polygon, and the number of sides. Diameter is the default Status 
Line selection, and the default number of sides is six.

Circumscribed Polygon Tool

This tool, in the sixth subpalette of the main tool palette, draws a regular polygon for 
which the radius of the circle determines the midpoint of the sides. The default 
shape is a hexagon, but it is possible to specify the number of sides in the Status 
Line. (Note: The Status Line shows a diameter for the circle, the standard way of 
describing a polygon circumscribed around a circle.)

Using the Circumscribed Polygon Tool
1. Select the tool. The Message Line reads, Circumscribed Polygon: Pick center 

of polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous 
(Macintosh)]. The Message Line guides successive steps.

2. Indicate the center of the polygon and the midpoint of one of the sides 

Create a copy of the last circumscribed polygon by holding down the CTRL 
(Windows) or OPTION (Macintosh) key and clicking where you want the center.

The Status Line specifies the X,Y coordinates of the center, the diameter of the 
circle defining the polygon, and the number of sides. The default number of sides is 
six. Diameter is the default Status Line selection.
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Spline Tools

The spline tools on the tool palette create NURBS (Non-Uniform Rational B-Splines) 
which are a superset of Bezier curves. These splines are curves created by a 
complex mathematical formula. 

NURB splines provide designers with two interrelated functions. First, curvature 
continuity remains intact when the curve is changed. Kinks don't develop as the 
spline is altered. Second, NURB splines provide localized control of a complex 
curve. Isolate an area and make changes without affecting the remainder of the 
spline. 

These properties are essential in aerodynamic designs. Air molecules moving over 
a wing surface must flow smoothly for maximum aero-dynamic lift. If the surface 
does not maintain curvature continuity, the air molecules separate from the wing 
surface and cause a vacuum. Such a vacuum causes an eddy as the molecules try 
to fill it. This disruption of air flow increases the drag, which is not a part of an 
effective design.

The automotive industry needs smooth air flow to improve gas mileage. Complete 
curvature continuity also improves styling. The appearance of a car is one of the 
major sales factors. The potential buyer would not be impressed if the showroom 
lights’ reflection on the car rippled and wavered. It is complete curvature continuity 
that makes a smooth reflection.

Localized control of complex curves allows minor modifications to be made without 
adversely affecting the shape. For example, if a new, bigger engine doesn’t fit under 
a perfectly-designed hood, use a NURB spline to raise the center of the hood 
without changing the basic design.

NURB splines are also valuable for injection mold designs to eliminate the swirl of 
plastic as it is injected into the mold. Such designs provide better surface finishes 
and allow thinner cross-sections in the die.
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Through-Points Spline Tool

The Through-Points Spline tool, in the seventh subpalette of the main tool palette, 
draws a spline through the points placed.

Using the Through-Points Spline Tool
1. Select the tool. The Message Line reads, Through-Points Spline: Pick control 

point (Double-click last point).

2. Indicate the points for the vectors of the spline.

3. Double-click the last point.

The Status Line shows the X,Y, and Z coordinates of each point along the path. 
(Graphite shows only X and Y coordinates.)

If a spline crosses over itself, the Drafting Assistant will not be able to find that 
intersection. This is by design.

Locked
Control Points

Selected Point

Drag 4-way pointer to adjust
area between locked points

vertex
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P

P

Vector Spline Tool

This tool, in the seventh subpalette of the main tool palette, draws a spline using 
vectors determined by the points specified. The Vector Spline tool uses each point 
placed as the vertex of a vector for the spline it creates.

Using the Vector Spline Tool
1. Select the tool. The Message Line reads, Vector Spline: Pick control point 

(Double-click last point).

2. Click the points for the vectors of the spline.

3. Double-click the last point.

Graphite uses these vectors to calculate the control points (two fewer than the 
number of vertices specified). The spline is tangent to the first and last vectors and 
passes through the calculated control points. 

The Status Line shows the X,Y, and Z coordinates of each point along the path. 

oint placed here Point placed here Point placed here

Point placed here

oint placed here

Control point
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Add Spline Control Point Tool

This tool, in the seventh subpalette of the main tool palette, adds another control 
point to an existing spline. 

Using the Add Spline Control Point Tool
1. Select the tool. The Message Line reads, Add Spline Control Point: Pick 

location on spline.

2. Click on the spline at the desired location(s) for the new control point(s). 

Note: To see the new control point(s), as well as the existing control points, first 
select the spline and then choose Layout>Show Points (or use the Edit Objects 
dialog box to specify display points).

To move a point, be sure to lock the adjacent points so you don’t change the slope 
of the rest of the spline.
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Tech Note:

The Lock command in the 
Arrange menu is used to 
prevent changes to 
objects and doesn’t affect 
spline control points.
Lock Spline Control Point Tool

This tool, in the seventh subpalette of the main tool palette, locks specified points on 
an existing spline so that the slope between the points can be changed without 
affecting the rest of the spline.

Using the Lock Spline Control Point Tool
1. Select the spline.

2. Choose Layout>Show Points.

3. Select the tool. The Message Line reads, Lock Spline Control Point: Pick 
control point.

4. Click the vertices to lock.The Lock Spline Control Point tool is used to lock or 
immobilize selected control points on an existing spline. Then adjust the 
curvature of the spline between the locked points without disturbing other 
areas of the spline.

Unlocking Spline Control Points
1. Select the tool and click on the point to unlock it. 

Locking More than One Spline Control Point
1. Lock more than one point by simply clicking each point.

Locked
Control Points

Selected Point

Drag 4-way pointer to adjust
area between locked points

vertex
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Editing Control Points of a Spline
1. Select the spline with the Selection tool.

2. Choose Layout>Show Points. (If the menu says Hide Points, no need to 
choose it.)

3. Click on the drawing area to deselect the spline.

4. If necessary, select the Lock Spline Control Points tool from the Spline tool 
subpalette.

5. If necessary, click the points to lock (the points on either side of the point to be 
changed).

6. Use the Selection tool to select the point to change.

7. Drag the point to the new location.

The dotted lines that appear tangent to the end portions of the spline are tangent 
control arms. They adjust the curvature of the spline leading up to the endpoints 
without moving the endpoints themselves. To do this, select the endpoint of the 
tangent control arm and drag it to another location with the 4-way pointer that 
appears.

Editing the End Slope of a Spline
1. Select the spline with the Selection tool.

2. Choose Layout>Show Points. (If the menu says Hide Points, no need to 
choose it.)

3. Click in the drawing area to deselect the spline.

4. If necessary, select the Lock Spline Control Points tool from the Spline tool 
subpalette.

5. If necessary, select the point to lock but not the endpoint.

6. Use the Selection tool to select the point at the end of the tangent control arm 
that needs to be moved.

7. Drag the point to a new location.

It is not possible to move both endpoints of a spline at the same time. Select and 
move the endpoints individually.
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3D Drawing Tools

Referral:

Work planes are 
discussed later in this 
chapter.
3D Drawing Tools
The process of moving from 2D to 3D geometry creation is relatively seamless. All 
of the tools used to create 2D geometry in Graphite are also used to create 3D 
geometry. However, there are some tools, features and concepts that are specific 
to 3D. The following topics are covered in this chapter:

• Geometry in 3D

• 3D Features and Tools

• Work Plane

Geometry in 3D
Graphite tools behave in predictable ways in 3-dimensional space. Once you 
know the rules, manipulate the tools to construct the necessary geometry. 

In traditional 3D computer-aided design, it is necessary to establish everything on 
work planes. It is as though a piece of glass has been propped on one of the faces 
of the model and you must draw on that plane. To work on a different plane, you 
must figuratively pick up the glass and carry it to the new position. With Graphite, it 
is possible to work freely within the model, using work planes or not as necessary. 
Move around inside the model and draw wherever desired. Generally, the only 
concern is the design, not moving the piece of glass.

The Drafting Assistant keeps tabs on the angles and intersections in all three 
dimensions. If geometry exists, draw relative to it. When it is simpler to use a work 
plane, or no geometry exists which is relative to the necessary plane, simply move 
Graphite's on-demand work plane with the Planes, 3-Point Plane and Define Plane 
commands in the 3D menu.
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For example, to put a circle in the work plane or parallel to the work plane, it is 
possible to use tools which require only two specification points, such as the 
Center-Point Circle tool or the Opposite-Point Circle tool. To put a circle on a 
non-parallel plane, then use three-point specification tools, such as the 3-Point 
Circle tool or Tangent-Point Circle tool.

When a tool creates geometry from two points, the geometry lies on a plane 
parallel to the work plane. If the tool uses three points to define the geometry, the 
geometry will lie on the plane defined by the three points.

If the geometry does not specify three points (or two entities) in the necessary 
plane simply move the work plane.

Reminders:

There are two ways to see geometry in 3D:

• In the Views menu, choose Views and select a view. The default views are 
Isometric, Right, Front, Top and Trimetric.

• In the Views menu, choose Show Trackball. When the Trackball appears select 
a view from its own menu.

Three dimensional geometry is created or viewed using the Triad to display the 
orientation of the work plane on which the drawing is performed. The Show Triad 
command is located in the 3D menu. See Chapter 6 “Advanced Environment 
Settings”  for more information on the Trackball and the Triad.

Rectangle tool
(2-point definition—can draw
only parallel to the work plane)

Opposite-Point Circle  tool
(2-point definition—can draw
only parallel to the work plane)

3-Point Circle tool (3-
Point definition—
can draw in any plane)
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Construction Rules for Tools Used in 3D
Lines Single, connected and parallel lines have no 3D 

restrictions. 

Tangent lines pulled off a curve, circle or spline 
will be tangent if created in the same plane as the 
curve, circle or spline.

Tangent lines that are tangent to only one object 
can be created only with objects on the work 
plane at the origin. Tangent lines tangent to two 
objects can be created on any work plane as long 
as both objects are on the same work plane.

Arcs A center-point arc is drawn parallel to the work 
plane.

A 3-point arc is drawn in the plane designated by 
the three points defining the arc.

A tangent-point arc is drawn in the plane of the 
three defining points.

Circles A center-point circle and opposite-point circle are 
drawn parallel to the work plane.

A 3-point circle is drawn in the plane designated 
by the three points defining the circle.

A tangent circle is drawn in the plane of the two 
defining entities.

Ellipses A 2-point center ellipse and opposite-point ellipse 
are drawn parallel to the work plane.

A 3-point center ellipse and 3-corner ellipse are 
drawn in the plane designated by the three points 
defining the ellipse.

Rectangles All rectangles and polygons are created parallel to 
the work plane.

Splines Splines have no 3D restrictions.
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Fillets/Chamfers Fillets and chamfers are constructed in the plane 
defined by the selected entities.

Tracer This tool does not work with 3D objects.

3D Features and Tools
Graphite provides tools and features specific to the 3D environment.

Extrude Command
This command, in the 3D menu, takes 2D geometry and makes it 3D through a 
simple extrusion process. There is also the option to extrude as a surface. 

When you begin thinking about using this command, consider the following points:

• Which face shows the most detail?

• Will the extrusion be uniform or do some portions of the part have different 
dimensions?

For example, the top view of a bracket 
provides the most detail. Draw it with the 
Connected Lines tool on the tool 
palette.

Once the basic shape is drawn, use the 
Extrude command from the 3D menu to 
create the depth of the bracket.

Once extruded, add some circles and 
extrude them to create holes in the 
bracket.
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Using the Extrude Command
1. Draw the geometry to be extruded. 

2. Select the geometry if it is not already selected.

3. Choose 3D>Extrude.

4. Enter the distance and direction or drag to specify the extrusion. Positive or 
negative values indicate the direction.

Use the Tab key to move between the x, y, and z coordinate data fields.

5. Click OK and the geometry is extruded.

Notes: 

• X and Y are on the current work plane and Z is perpendicular to that plane. This 
is not necessarily relative to the original x, y, z axes that were used when the 
geometry was constructed. 

• If the object was drawn in the x,y plane, the extrusion should be in the z-
direction. Therefore enter a z-value in the dialog box. Think of the screen as the 
0 coordinate with positive values extending toward you and negative values 
away from you. 

• Manipulate the work plane to determine the direction of an extrusion.
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Revolve Command
The Revolve command, in the 3D menu, creates a model as though it were turned 
on a lathe. It copies and revolves a 2D object into a 3D object. There is the option 
to surface the geometry at the same time it is revolved.

Begin by drawing half of the model on an axis for revolving. 

Then use the Revolve command to revolve the image 
a specified number of steps and angles.

Finally, show the Trimetric view to see more detail of 
the wireframe.
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Tip:

Use the Tab key to move 
through the data fields.

Tip:

To establish the axis of 
revolution, click the 
startpoint and the 
endpoint.
Using the Revolve Command
1. Draw the geometry to be rotated. 

2. Select the geometry if it is not already selected.

3. Choose 3D>Revolve. The Revolve dialog box displays.

4. Specify the number of degrees in the Sweep Angle for the revolution.

5. Specify the number of Steps (copies or divisions).

6. Tab to the Origin data field in the dialog box.

7. Place the target cursor at the startpoint of the axis of revolution.

8. Drag along the axis from the startpoint to the endpoint. The six data fields are 
automatically filled in.

9. Click OK and the selected geometry is now revolved around the axis as 
specified, according to the right hand rule of revolution.

Right-hand Rule of Revolution
The direction of revolution is determined by the right-
hand rule of revolution which states that if the thumb 
is pointed toward the positive axis of revolution, the 
revolution is in the same direction in which the 
fingers are curled.

Note: When revolving a circle that is eventually 
surfaced, the Axis of Revolution should be on an 
endpoint not a quadrant.

Direction of
Revolution

 Axis of Revolution
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Object Rotation Command
The Object Rotation command in the 3D menu, rotates geometry around any 
specified axis.

1. Select the geometry to rotate.

2. Choose 3D>Object Rotation.

3. In the Rotate Angle field, enter the angle to rotate the geometry.

4. Tab to the Origin Data field. The cursor becomes a crosshair.

5. Click a point on the geometry to specify the Axis of Rotation around which to 
rotate the geometry. 

6. Place the target cursor along the desired axis. Think of it as pointing to the top 
of a hinge.
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Tech Note:

If a work plane is named 
Temp Plane, it was 
created with the 3-Point 
Plane command and will 
exist only for the duration 
of the current Graphite 
session. Rename the 
TempPlane work plane 
with the Define Plane 
command to make it a 
permanent plane for that 
file.

Also, there can only be 
one plane called Temp 
Plane in a document. If 
another plane is created 
using the 3-Point Plane 
command, without 
changing the name of the 
first, the new Temp Plane 
replaces the old one.
7. Drag along the desired axis, as if dragging along the length of the hinge. Don’t 
worry about whether the z-axis is pointed in the right direction. The six data 
fields are automatically completed.

8. Click OK. The object rotates. Change the view as necessary to observe the 
change in rotation.

Work Plane 
The Work Plane is the plane on which the geometry is created. It is an x, y plane 
with an origin of 0, 0, 0 for all data input. Move the work plane as desired by 
creating your own or choosing one of the standard work planes available in 
Graphite.

While learning to use Graphite, try to use the Drafting Assistant without moving 
the work plane. Even though the Drafting Assistant does a lot of the work, the 
work plane is still an essential element of 3D modeling.

The Z-Drafting Assistant assumes that geometry is being created in the current 
work plane unless it snaps to an align:z or to a logical snap point that is not in the 
current work plane.

Creating the geometry that is not parallel to the current work plane and that does 
not snap to one of the Drafting Assistant’s constraints like endpoint or midpoint, 
and when using a tool that requires only two points for creation, such as the 
Center-Point Circle, Rectangle, or 2-Point Ellipse, use a work plane to place the 
geometry properly. Also, tools which use three points for specification can be 
drawn non-parallel to the work plane. 

Planes
This command, in the 3D menu, displays the Planes submenu to set the current 
work plane. The standard work planes—Front, Right, Top and World—are always 
displayed, as well as any temporary plane generated (TempPlane) and any planes 
created with the Define Plane command. See margin notes.
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Setting the Work Plane
1. Choose 3D>Planes.

The Planes submenu displays.

2. Drag down the submenu until the plane highlights.

3. Release the mouse button.

The work plane in the sheet view or active view window rotates as specified, 
and the work plane name is checked in the submenu.

Since only the plane is changed, the appearance of the geometry and its view 
orientation, remains unchanged. Therefore, it is possible to set the view to match 
the current work plane.

To move both the origin and change the orientation of the work plane, use either 
the 3-Point Plane command or the Define Plane command.
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Specifying the Position of the Work Plane
In conventional CAD-programs it is necessary to specify both the orientation of the 
work plane and its exact location along the z-axis. In Graphite only the orientation 
of the work plane is specified. Once that is done, then all planes parallel to that 
orientation act equally as the current work plane, e.g. the Drafting Assistant 
identifies the location of the work plane automatically.

Another way to explain the relationship presented in the graphics above, is to 
remember the role of the Drafting Assistant. For new geometry to be placed on the 
same plane as another piece of geometry, brush over that existing geometry to 
wake up one of its control points like midpoint or endpoint. Graphite will then retain 
this plane information while creating the new geometry.

If no object exists or no geometry is referenced for plane information, Graphite 
places the new object geometry onto the work plane at the origin.

Z

X

Y

Z

Y

X

X
Y

Z

X

Y

By identifying on point of an        
object with the Drafting Assistant... 

...the new object geometry   is created on 
the plane of that object .

If an existing object is not identified wit h the new object, the new  
geometry is placed on  the work plane of the origin.

Grid
Origin

Work plane

midpoint

Grid
Origin

Parallel current work plane

align:y on

Grid
Origin

Work plane
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The Origin and the Work Plane
Occasionally, when working on a model, it may be necessary to move the origin of 
the work plane. This is especially useful for measuring distances. For example, 
open a document and start drawing without regard to the location of the origin, 
then move the origin to a convenient location for future reference.

Choose Layout>Show Grid to display the origin.

Set Origin Command
This command, in the 3D menu, sets a new origin in the current work plane.

1. Choose 3D>Set Origin.

2. Click in the drawing area to indicate the location for the new origin.

The origin of the current work plane is moved while the orientation of x,y,z 
remains the same.

To move the origin and change the orientation of the work plane, use either the 3-
Point Plane command or the Define Plane command.

The origin might be 
here to begin with...

...but you can move it here for
more convenient measurements.
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Setting a New Work Plane
It is possible to define a work plane other than the standard planes. For example, 
to work on an angled face, reorient the work plane.

Define a new plane using two commands on the 3D menu, 3-Point Plane and 
Define Plane. To define a new work plane specify the origin and indicate the 
horizontal and vertical directions. Use 3-Point Plane to set the work plane, and 
then use Define Plane to name and save the plane. 

3-Point Plane Command
This command, in the 3D menu, sets a temporary work plane from the three points 
specified. Follow the directions in the Message Line.

1. Choose 3D>3-Point Plane.

2. Click in the drawing area to indicate the point for the origin of the new work 
plane.

3. Click a point to define the positive x-axis.

4. Click a point to define the positive y-axis.

A temporary work plane is created and named TempPlane. The work plane 
moves, but the view does not change. 

Rename this plane by going to the 3D menu and choosing Define Plane. There is 
an option to Rename in the dialog box. See a later section for more information. If 
the new plane is not renamed, it is replaced by the next specified 3-Point Plane 
and removed from the list when exiting Graphite.

Y

X
1

2

3To work  
on this face... 

Origin

...click  
on points 1, 2, 3 
(3-point plane).
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Define Plane Command
This command, in the 3D menu, defines a new work plane, names a temporary 
plane or changes a standard plane. The standard planes cannot be changed 
unless the lock icon is clicked off. Their default configurations are defined as 
follows:

Front The x,z plane. 

Right The y,z plane. 

Top The x,y plane. 

World The origin and plane of the original geometry 
when it was created. This plane cannot be 
changed. 

When changing any of the standard planes, always revert to the world plane to 
return to the original orientation.

Having used other CAD applications, you may be familiar with the terms World 
Coordinate System and User Coordinate System. The World Coordinate System 
is equivalent to Graphite’s world work plane and the User Coordinate System is 
equivalent to the current work plane.
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Specifying a New Work Plane
1. Choose 3D>Define Plane.

The Define Plane dialog box displays.

2. Click New.

The Redefine Plane dialog box displays and the Origin data field highlights.

The new work plane is named Plane 1 by default.

3. On the drawing area, click the location for the new origin.

The Right data field is selected.

4. Click a location on the positive x-axis.

The Up data field is selected.

5. Click a location on the positive y-axis.

6. Click OK.
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The definition box goes away and the new plane is defined. The new work plane 
is named Plane 1 by default. If this plane is not renamed, the next plane created 
will be Plane 2.

7. Select Plane 1, the new plane just created. 

8. Click Set Work.

The current plane changes to the new specification. 

9. Rename this work plane if desire. 

10. Dismiss the dialog box if it is no longer needed to define other work planes.

Be aware that simply changing the work plane does not mean that work done is 
on the visible face. The view orientation must be adjusted accordingly.

Renaming a Plane
1. Choose 3D>Define Plane.

2. If necessary, click the lock icon to unlock the plane, then click the plane to be 
renamed in the list box.

3. Type a new name.

4. Click Rename.

The plane is renamed. If the renamed plane was a temporary plane, it becomes 
permanent. The name is added to the Planes submenu and the list in the Define 
Plane dialog box.

The World plane cannot be renamed.
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Deleting a Plane
1. Choose 3D>Define Plane.

2. If necessary, click the lock icon to unlock the plane and then click the plane to 
be deleted from the plane list.

3. Click Delete.

A plane cannot be deleted if it is set as the current work plane. First make 
another plane the current work plane and then it can be deleted.

To delete a standard plane (Front, Right, or Top), unlock it. World plane cannot be 
deleted. To delete a standard plane, do not choose Save Preferences. In this case, 
the plane must be recreated for use in future files.

Redefining a Plane
Use Define Plane to change the origin or orientation of the axes of any plane, 
except the World plane. 

1. Choose 3D>Define Plane.

2. Click the lock icon on the plane to be changed.

3. Click the name of the plane to change it. 

4. Click Redefine.

The Redefine Plane dialog box displays the settings as they appear on the 
screen with the origin selected.

5. On the drawing area, click the location for the new origin.

The Right data field is selected.

6. Click a location on the positive x-axis.

The Up data field is selected.

7. Click a location for the positive y-axis.

8. Click OK.

The plane is redefined.

The standard work planes—Front, Right, and Top— cannot be redefined without 
unlocking them. The World plane, which was established from the original 
orientation of the model, cannot be redefined.
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Set Plane to Screen
This command, in the 3D menu, sets the work plane to be coincident with the 
screen, where the origin is in the center of the screen; the x-axis is coincident with 
the width of the screen and the y-axis is coincident with the height of the screen.

This sets the plane to match the screen in all views which is particularly useful 
when moving from view to view while drafting.

To name this work plane, use the Define Plane command.
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Selecting Objects
Once objects have been constructed, they can be changed. One of the basic rules 
of Graphite says that an object should be selected before editing. Just as 
selecting a drawing tool from the tool palette before starting to draw, an object 
must first be selected before a function can be applied.

Modifying an object is always a two-step process:

1. Select the object.

2. Specify the action for the selected object. 

For example, select a circle and then change the pen style to Center to indicate a 
bolt-hole circle. 

The following topics are covered in this chapter:

• Objects

• Indicating Selection

• Selection Process
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Referral:

Selecting points is 
described in a later 
section of this chapter.
Objects
A single piece of geometry is an object. 

Several objects that have been grouped with the Group command are also an 
object.

For example, the four lines of a rectangle are four objects. By grouping them, 
Graphite treats them as a single object.

A point is an object, too. Every type of geometry contains two or more points, 
sometimes called control points. A line has two control points, one at the 
beginning and one at the end of the line. By selecting an object and choosing 
Layout>Show Points, the points are visible on the selected object.

Keep in mind, that an object must be selected first, followed by the command to 
execute a function.

By selecting a point without selecting the geometry it defines, Graphite treats the 
point as an object. 

A line is an object

Single
Object

A rectangle is 4
lines—4 objects

Ungrouped
Objects

A grouped rectangle
is a single object

Grouped
Objects

A line without points displayed

Unselected point

A line with points displayed

Selected point
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Indicating Selection
Upon selecting an object, its appearance on the screen shows that it is selected. It 
is a specific color (such as red), it blinks, or both. It is possible to change the color 
and turn blinking on and off for the selection indicator. 

Selection Command
This command, found under Layout>Preferences, determines the appearance of 
selected objects.

To choose a color, move the pointer to the color box and click on the color name to 
display the color list. Drag to the desired color and release or click the color. Once 
the selection color is changed, all current and future selected items appear in the 
new color.

Do not use black for indicating selection because many of the standard pens use 
black lines. 
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Selection Process 
Selecting an object does not affect the properties of the object. A selected object 
highlights, but this highlighting goes away once the object is deselected. While 
points and objects are selected in a similar way, point selection is controlled by the 
Selectable Points setting in the Edit menu. For this reason, selecting objects and 
selecting points are discussed separately.

Graphite provides Selection tools and commands for selecting the objects.

Selecting Tools
There are five selection tools: Selection, Tracer, Select by Line, Select by 
Polygon and Eyedropper.

Selection Tool

The Selection tool, in the first subpalette of the main tool palette, selects one or 
more objects or points in the drawing area.

Selecting a Single Object
1. Click the Selection tool in the tool palette. The Message Line reads, Select: 

Select [Shift = Extend, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

2. Move the pointer to an object and click. The object is selected, and any 
previously selected objects are deselected.

Selecting Multiple Objects Using the SHIFT key
1. Click the Selection tool in the tool palette.

2. Move the pointer to an object and click.

3. Press down the SHIFT key.

4. While holding down the SHIFT key, click other objects to be selected.

The objects clicked on are selected. Clicking one of the selected objects 
deselects it.

5. Release the SHIFT key.
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Tip:

Specify that only certain 
objects, layers, or colors 
are selected by setting a 
selection mask with the 
Selection Mask command. 
Select All is useful to 
make a global change in a 
drawing, such as 
changing the width of all 
lines.
Selecting Multiple Objects by Dragging
To select more than one object, drag a selection fence around the objects. 

1. Click the Selection tool in the tool palette.

2. Drag a selection fence around the objects to select it.

All objects that lie completely inside the selection fence are selected. If a portion 
of an object is outside the region being dragged on, that geometry is not 
selected but the control points of the geometry which lie inside the selection 
fence are selected.

To select most of the objects within an area, drag a selection fence to select all the 
objects, and then deselect the objects by holding down the SHIFT key and clicking 
them.

Selecting All Objects
Select all objects by double-clicking on the Selection tool.

Select by Line Tool

This tool, in the first subpalette of the main tool palette, selects one or more 
objects along a straight line path when dragging a line over the desired objects.

1. Choose the Select by Line tool in the Selection tool palette. The Message 
Line reads, Select By Line: Draw line [Shift = Extend, Ctrl = Copy (Windows) 
or Option = Copy (Macintosh)].

2. In the drawing area, drag across the 
objects you want to select, as shown in the 
graphic below.

The objects intersected by the line are 
selected, as shown below in gray, and any 
previously selected objects are deselected.
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Tip:

The Tracer tool is most 
useful for selecting 
boundaries for 
Crosshatching, Fills and 
for 2D Analysis because it 
eliminates the need to 
Tracer Tool

This Tracer tool, in the first subpalette of the main tool palette, selects boundaries 
and uses coincident endpoints and line intersections to trace the perimeter of the 
geometry.

1. In the Selection tool subpalette, select the Tracer tool. The Message Line 
reads, Tracer: Pick curve to start trace. [Shift = Extend].

2. Click on a boundary line.

The Tracer moves from one line to another making its selection. 

With two overlapping objects as shown here, the Tracer tool 
selects the perimeter of the objects, depending on where the 
object is clicked. 

Clicking on the outside of the perimeter line, the Tracer tool 
selects the outer most perimeter.

The crosshatching of the figures below shows the 
boundaries selected when clicking the Tracer tool at the 
cursor locations shown.

Clicking on the inside of the line, the tracer selects the inner most perimeter.

The Tracer tool does not select actual geometry, but rather creates temporary 
geometry that Graphite uses for operations like Fills, Crosshatching and 
2D Analysis.

The Tracer tool does not work on a 3D model.
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Select by Polygon Tool

This tool, in the first subpalette of the main tool palette, selects one or more 
objects when a polygon is drawn around them. Each object must be completely 
enclosed by the selection polygon for the object to be selected. This tool functions 
similarly to the Connected Lines tool.

1. Choose the Select by Polygon tool in the Selection tool palette. The 
Message Line reads, Select By Polygon: draw polyline [Shift = Extend].

2. Click or drag to indicate the endpoints of the line segments that will make up 
this selection polygon. The selection polygon appears as line segments in the 
designated selection color.

Press the ESC key or choose Undo to remove the last line. Pressing the 
BACKSPACE key (Windows) or the DELETE key (Macintosh) removes the 
entire selection polygon. 

3. Indicate the last point by double-clicking or choosing another tool.

Completely enclose the object or objects to be selected. Objects not completely 
within the selection polygon are not selected. The graphic below shows the 
selected objects in gray.
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Eye Dropper Tool

The Eyedropper tool copies properties from a selected entity to another entity, 
including lines, fonts, layers or dimensions. For text the properties include font, 
size and color. For dimensions it includes text location, font, size, style, colors, line 
weight, layers and arrow head on/off.

1. Select the Eye Dropper tool from the Selection tools palette. The Message 
Line reads, Eye Dropper: Select objects to copy from [Shift=Extend].

2. Select or deselect multiple characteristics to be extracted for the Eye Dropper 
dialog box that automatically appears.

Click the Save button for the selections to be saved in Preferences and 
remembered each time the tool is selected.

3. Select the object with the characteristics to be copied.

4. Select the objects to receive characteristics. Apply the properties to multiple 
objects before clicking anywhere in open space to deactivate the tool. 

Each object's characteristics change to those of the referenced object.

You can also select the object before you select the tool. If you do this, you only 
select the reference entity and the object automatically changes. 

There are no Status Line entries.
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Tip:

The Selection Mask is 
useful to change particular 
groups of objects in a 
complex drawing. Use this 
feature to export some but 
not all geometry. Also use 
the Selection Mask to 
change all dimensions 
from parametric variables 
to real values as 
described in the Chapter 
16 “Parametrics.’ .
Deselecting
To deselect an object, click anywhere in the drawing area where there is no object, 
or click any of the creation tools in the tool palette.

To deselect an object that was selected in a multiple selection operation. Hold 
down the SHIFT key and click the objects to deselect.

Selection Commands
Graphite provides various selection commands for selecting objects.

Select All 

CTRL+A (Windows); +A (Macintosh)

This command in the Edit menu selects all objects except those on a hidden layer 
or excluded by the Selection Mask. Double-click the Selection tool to select all 
objects. By choosing Select All while using the Text tool, all characters in the 
current text area are selected. 

Selection Mask
This command in the Edit menu limits selection by object type, layer and color. 
Only objects that are highlighted in the dialog box can be selected. 

For example, if circles are not highlighted, when you choose Select All from the 
Edit menu, everything but the circles is selected. In this way, it is possible to select 
such combinations as only blue splines or only red objects on a particular layer.
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Using the Selection Mask
1. Choose Edit>Selection Mask.

The Selection Mask dialog box appears.

The highlighted items respond to all selection methods and are detected by the 
Drafting Assistant.

2. Designate the items allowed to be selected so they are highlighted.

While the dialog box is visible, it is possible to select, create and edit geometry. 
Move the dialog box if it covers geometry. The Selection Mask remains in effect 
after closing the dialog box until a tool is selected. 

When an item in the dialog box is not highlighted, the Drafting Assistant and all the 
tools cannot detect it, even though it is visible on the screen.

Selecting or Deselecting Listed Items
• To select one item, simply click on the item and the rest of the list will be 

deselected.

• To deselect a list quickly, click one item in the list.

• To select a contiguous group of items, click on the item at the top or bottom of 
the desired group list, then hold down the SHIFT key and click or drag up or 
down to select the other items in the group.

• To select or deselect non-contiguous items, hold down the CTRL (Windows) or 
the  key (Macintosh) and click on the items.

The Selection Mask includes objects like lines, arcs/circles, text, etc. Most of the 
objects are self-explanatory except for those mentioned below.

Chain This object is created when using Flatten View in 
the Views menu. For more information see 
Chapter 14 “Advanced Viewing Techniques.’ 
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Selecting Points
Selecting points differs from selecting objects because points are not always 
visible. 

Being able to select points is useful in two situations: stretching selected geometry 
(described later in this chapter) and control point selection for transformations.

When drawing a selection fence around objects, all geometry that is completely 
within the fence is selected. If geometry is partially within the fence, only the 
control points inside the fence are selected, and the geometry is not selected. 

Show Points
This command in the Layout menu toggles the display of the control points 
(endpoints, midpoints, center points, and knot points) for selected objects. When 
points are displayed, select a point by clicking it. If points are not displayed (but 
Selectable Points is set in the Edit menu), select a point by dragging a selection 
fence around the location of the point. 

To show points for an individual selection, in the Edit menu, use the Edit Objects 
command.

By selecting and dragging an entire line, the line and the endpoints move. By 
selecting and dragging only an endpoint of the line, the endpoint moves and the 
line length changes while the other endpoint of the line remains fixed.

Displaying Points
1. Select the geometry.

2. Choose Layout>Show/Hide Points to toggle the display of points on and off.

To turn off the point display once the points of an object are showing, select the 
object again and choose either Layout>Hide Points or the Control Points option 
in the Edit Objects dialog box.

A line without points displayed

Unselected point

A line with points displayed

Selected point
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Showing and Hiding Points with Stroke
When holding down the CTRL+SHIFT keys (Windows) or the Command () key 
(Macintosh) and clicking an object, the display of the object’s points toggles on or 
off. If the points are hidden when clicking the object, the points are displayed.

Selecting Points
A control point can be selected whether the points are visible or not, however, 
Selectable Points in the Edit menu must be on, displaying a check mark in the 
menu. To select points if points are not visible:

1. Click the Selection tool.

2. Drag a selection fence around the location of the point.

The selected point displays as a square.

To select points if they are visible:

1. Click the Selection tool.

2. Click the point.

The selected point displays as a square. 

Unselected point Selected point
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Selectable Points
This command in the Edit menu selects points that aren’t displayed. When 
Selectable Points are not set, selecting points by dragging a fence is not possible. 
If points are displayed, simply click the point to select it. If points are not displayed, 
select a point by dragging a selection fence around it. The following example 
illustrates the use of Selectable Points. 

The line's
control point is
selected with
the rectangle.

The line's control
point is not
selected with the
rectangle.

With Selectable Points  turned on,
the Move tool moves the lower
rectangle and the line endpoint.

With Selectable Points turned off,
the Move tool moves the lower
rectangle but not the line endpoint.
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Editing Objects
Editing Objects
Once an object is created, alter it by selecting it and choosing a command or a tool 
to edit it. This chapter describes the common editing activities to perform on a 
selected object and compares different methods for performing the same action.

The specific topics covered are:

• Editing Tools

• Moving Objects with Tools

• Copying Objects with Tools

• Sizing Objects with Tools

• Editing Commands

• Erasing Geometry

• Changing the Characteristics of Objects

• Arranging Geometry
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Fillet and C

Transform and D
Editing Tools

These tools are used to change an object physically, either by altering the geometry, 
changing the size, changing the location, or modifying orientation of the selected 
object. Three subpalettes on the tool palette provide these editing capabilities.

Fillet and Chamfer The Fillet tools round the corners of non-parallel 
lines. The Chamfer tools cut them at straight 
angles. 

Trim The Trim tools cut off or extend a line to the 
boundary limit specified. They also segment a line 
at an intersection, and create corners from 
intersecting lines. 

Transform and Duplicate The Transform tools move, rotate, expand or 
shrink, and mirror objects. The Duplicate tools 
copy and arrange objects in particular patterns.

Fillet and Chamfer Tools

These tools construct fillets and chamfers from corners formed by nonparallel lines 
or curves. The fillets and chamfers are automatically trimmed, unless the CTRL 
(Windows) or the OPTION (Macintosh) key is held down while selecting the objects.

2-Entity Fillet Tool

The 2-Entity Fillet tool constructs an arc tangent to the two objects clicked. Fillets 
use the smallest arc between the selected geometry.

hamfer Tools

Trim Tools

uplicate Tools
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Using the 2-Entity Fillet Tool
1. Click the 2-Entity Fillet tool. The Message Line reads, 2-Entity Fillet: Pick first 

entity [Shift = Corner, Ctrl = No trim (Windows) or Option = No trim 
(Macintosh)]. The Message Line guides each successive step.

2. Enter the arc radius in the Status Line. The default radius is .25 inch.

3. Select the first entity. 

4. Select the second entity. The fillet is created.

Another method is to hold down the SHIFT key and click once inside the desired 
corner to be filleted. By holding down the CTRL (Windows) or OPTION (Macintosh) 
key while selecting the objects to fillet, the objects are not trimmed. These options 
are noted in the Message Line.

The Status Line specifies the Radius of the fillet either before or after creating the 
fillet.

3-Entity Fillet Tool

The 3-Entity Fillet tool constructs a fillet tangent to the three objects chosen.

Using the 3-Entity Fillet Tool
1. Click the 3-Entity Fillet tool. The Message Line reads, 3-Entity Fillet: Pick first 

entity [Ctrl = No trim (Windows) or Option = No trim (Macintosh)]. The 
Message Line guides each successive step.

2. Click the three objects to fillet.

By holding down the CTRL (Windows) or OPTION (Macintosh) key while selecting 
the objects to fillet, the objects are not trimmed.

There are no Status Line entries.
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2-Entity Chamfer Tool

The 2-Entity Chamfer tool creates a chamfer across a corner at the specified 
distance from the intersection of two lines.

Using the 2-Entity Chamfer Tool
1. Click the 2-Entity Chamfer tool. The Message Line reads, 2-Entity Chamfer: 

Pick first entity chamfer [Shift = Corner, Ctrl = No trim (Windows) or Option = 
No trim (Macintosh)]. The Message Line guides each successive step.

2. In the Status Line, enter the distance of the chamfer from the corner. (The 
default distance is .25 inch.)

3. Click each line making up the corner to be chamfered. Another way is to hold 
down the SHIFT key and click once inside the corner to chamfer. 

The lines are automatically trimmed or extended, unless the CTRL (Windows) or the 
OPTION (Macintosh) key is held down while selecting the objects. 

These options are noted in the Message Line.

The Status Line specifies the distance (length) from the chamfer to the intersection 
of the corner lines.

Angular Chamfer

The Angular Chamfer tool creates a chamfer at the specified angle and distance 
from the corner. The specified angle is that between the chamfer and the second 
line of the corner. The specified length is the distance between the corner and the 
intersection of the chamfer and the second line of the corner. (The second line of the 
corner refers to the second line chosen when creating the chamfer).



Graphite User Guide Editing Tools
Using the Angular Chamfer
1. Click the Angular Chamfer tool. The Message Line reads, Angular Chamfer: 

Pick first entity to chamfer [Ctrl = No trim (Windows) or Option = No trim 
(Macintosh)]. The Message Line guides each successive step.

2. In the Status Line, enter the length of the intersection of the chamfer and the 
second line of the corner from the corner. The default length is .25 inch. 

3. Enter the angle between the chamfer and the second side. The default is 45°.

4. Click each line making up the corner to be chamfered.

The lines are automatically trimmed or extended, unless the CTRL (Windows) 
or the OPTION (Macintosh) key is held down while selecting the objects.

The Status Line sets the distance (length) from the intersection as well as the angle.

Trim Tools

The Trim tools on the tool palette lengthen or shorten lines and curves. In general, 
select the limiting object(s) before selecting the tool. If you forget to select 
everything needed, however, hold down the SHIFT key and the Trim tool 
temporarily becomes the Selection tool so that additional objects can be selected. 

Simple Trim Tool

The Simple Trim tool shortens a line to the specified boundary. By holding down the 
CTRL (Windows) or the OPTION (Macintosh) key while using this tool, it becomes 
the Relimit tool.

Rule: Point to what is to be removed.
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Using the Simple Trim Tool
1. Select the object that limits the trim.

2. Select the Trim tool. The Message Line reads, Simple Trim: Pick section to 
trim [Shift = Select boundary, Ctrl = Relimit (Windows) or Option = Relimit 
(Macintosh)].

If necessary, use SHIFT-Click to select more boundary objects.

3. Click the section of the object to be discarded.

There are no Status Line entries.

Relimit Tool

This tool lengthens or shortens a line to the specified boundary. By holding down the 
CTRL (Windows) or the OPTION (Macintosh) key while using this tool, it becomes 
the Trim tool.

Rule: Point to what is to be kept.

Using the Relimit Tool
1. Select the object that limits the change.

2. Select the Relimit tool. The Message Line reads, Relimit: Pick section to 
retain [Shift = Select boundary, Ctrl = Trim (Windows) or Option = Trim 
(Macintosh)].

If necessary, use SHIFT-Click to select more boundary objects. 

3. Click the section of the object to remain.

There are no Status Line entries.

Segment Tool

The Segment tool divides a line or curve at intersections with other lines or curves.
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Using the Segment Tool
1. Select the objects that limit the segmentation.

2. Select the Segment tool. The Message Line reads, Segment: Pick entity [Shift 
= Select boundary, Ctrl = Current pen (Windows) or Option = Current pen 
(Macintosh)].

If necessary, use SHIFT-Click to select more boundary objects.

3. Click the object to be segmented.

The selected object segments at the boundary objects. Even though the 
segmentation cannot be seen on the screen, parts of the segmented line may 
be selected by clicking.

There are no Status Line entries.

In order to see the segmentation on the screen, first select the boundaries and the 
object to segment and then choose Layout>Show Points. After the segmentation, 
the endpoints of the segmented parts are displayed.

By holding down the CTRL (Windows) or OPTION (Macintosh) key while selecting 
the line to be segmented, the new segment appears in the characteristics of the 
current pen style.

Corner Trim Tool

The Corner Trim tool creates a corner from two specified objects. Lines are 
extended or shortened to create the corner. 

Using the Corner Trim Tool
1. Click the Corner Trim tool. The Message Line reads, Corner Trim: Pick first 

entity to trim [Shift = Corner, Ctrl = No Trim (Windows) or Option = No Trim 
(Macintosh)]. The Message Line guides each successive step.

2. Click each object.

Another way is to press and hold the SHIFT key and click inside the about-to-
be-created corner.

There are no Status Line entries.

Extending Lines to a Theoretical Intersection
To extend a line to its theoretical intersection with another line, first click the line to 
be extended, then hold down the CTRL (Windows) or OPTION (Macintosh) key and 
click the line that is not to be trimmed.
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Referral:

Enlarging or shrinking an 
object with the Move tool 
is described under “Sizing 
Objects with Tools” in this 
chapter.

Tip:

Geometry can be nudged 
a specified distance 
within Graphite using the 
arrow keys on the 
keyboard. More 
information on nudging 
geometry is available 
further ahead in this 
chapter.
Transformation Tools

The first part of the Transform & Duplicate palette has the Transformation tools. 
These tools move, rotate, expand or shrink, stretch, vector-defined and mirror 
objects. Select the object to transform before selecting a Transformation tool. 

It is possible to copy while transforming objects by holding down the CTRL 
(Windows) or the OPTION (Macintosh) key while specifying the transformation.

By pressing the SHIFT key, additional objects may be selected after Transformation 
tool is chosen, the tool temporarily becomes the Selection tool so that as soon as 
the SHIFT key is released the Transformation tool is active again.

Move Tool
The Move tool relocates the selected objects in a new position. Copy the 
selection by holding down the CTRL (Windows) or OPTION (Macintosh) 
key while selecting the objects. Select more than one object and they 
remain in the same position relative to each other.

Using the Move Tool
1. Select the object(s) to be moved. 

2. Select the Move tool. The Message Line reads, Move: Pick beginning 
reference point [Shift = Select, Ctrl = Copy (Windows) or Option = Copy 
(Macintosh)].

If necessary, use SHIFT-Click to select more objects.

3. Drag the selected object to a new location, clicking to set a reference point, 
and releasing to indicate the new location.

Another way is to click a reference point, then click a destination point to move the 
selected object to the new location. It is not necessary for the reference and 
destination points to be on the object being moved. The move is performed relative 
to the specified points.

The Status Line specifies the distance for the selection is to be moved in a particular 
direction.

A positive or negative value entered in a data field of the Status Line determines the 
direction along the axis. A negative value moves the object to the left or down on the 
screen. A positive value to the right or up.
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Tip:

Using the beginning and 
ending reference point for 
the Expand/Shrink tool is 
particularly useful to 
change the size of an 
object relative to the size 
of another object.
Rotate Tool

The Rotate tool rotates one or more objects around a specified point. Copy the 
selection by holding down the CTRL (Windows) or OPTION (Macintosh) key while 
selecting the objects. When selecting more than one object, they remain in the 
same position relative to each other.

Keep in mind that objects are always rotated about the Z-axis with this tool.

Using the Rotate Tool
1. Select the object(s) to be rotated.

2. Select the Rotate tool. The Message Line reads, Rotate: Pick center of 
rotation [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

If necessary, use SHIFT-Click to select more objects.

3. Select the center of rotation.

4. Drag the objects or enter an Angle in the Status Line to specify the rotation. 

The Status Line specifies the angle of rotation. 

Another way is to click the reference point and then click the destination point. It is 
not necessary for the reference and destination points to be on the object being 
moved. If they are not, the rotation is performed relative to the specified points.

This tool rotates the selected geometry around an axis through the origin specified 
and parallel to the z-axis of the work plane. The Object Rotation command rotates 
around any axis specified.

Expand/Shrink Tool

The Expand/Shrink tool resizes objects while maintaining the proportions. Copy the 
selection by holding the CTRL (Windows) or OPTION (Macintosh) key when 
selecting the objects. If more than one object is selected, they remain in the same 
position relative to each other.
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Using the Expand/Shrink Tool
1. Select the object(s) to be expanded or shrunk.

2. Select the Expand/Shrink tool. The Message Line reads, Expand/Shrink: Pick 
anchor point [Shift = Select, Ctrl = Copy (Windows) or Option = Copy 
(Macintosh)]. The message Line guides each successive step.

If necessary, use SHIFT-Click to select more objects.

3. Click a point on the object to remain stationary.

4. Click the beginning reference point.

5. Click the ending reference point.

The object changes size so the beginning reference point meets the ending 
reference point.

The Status Line specifies the exact scale (Factor).

To expand or shrink geometry in one direction only, use the Stretch tool below.

Stretch Tool
The Stretch tool resizes the geometry along one axis and at a specified 
angle. If more than one object is selected, they remain in the same position 
relative to each other.

Using the Stretch Tool
1. Select the object(s) to be stretched.

2. Select the Stretch tool. The Message Line reads, Click point to remain fixed.

3. Click the point to remain fixed.

4. Click the beginning reference point to define the angle.

5. Click the ending reference point to define the scale.

The object resizes along one axis at a specified angle. The Status Line shows the 
exact scale (Factor) and Angle.
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Mirror Tool
The Mirror tool creates the mirror image of an object or objects on the 
opposite side of a reference line. Copy the selection by holding down the 
CTRL (Windows) or OPTION (Macintosh) key while selecting the objects. If 
more than one object is selected, they remain in the same position relative 

to each other.

Using the Mirror Tool
1. Select the object(s) to be mirrored.

2. Select the Mirror tool. The Message Line reads, Mirror: Pick beginning of 
reference line [Shift = Select, Ctrl = Copy (Windows) or Option = Copy 
(Macintosh)].

If necessary, use SHIFT-Click to select more objects.

3. Specify the reference line by clicking two locations or by dragging. The 
reference line needs not be parallel to the object.

Hold down the CTRL (Windows) or OPTION (Macintosh) key, before specifying 
the reference line to create a mirrored copy.

The Status Line has no entries.

Note: When working in 3D, mirror selected geometry through the axis specified and 
parallel to the work plane.
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Duplication Tools

The second part of the Transform & Duplicate palette has the Duplication tools. 
Using Graphite multiple copies of an object can be created and arranged in an array 
along a straight line, in a circular pattern or copied by path. They can also be offset.

If a duplication is not satisfactory, stop the process by pressing the ESC key, and 
then use Undo to remove the copies from the document. 

Linear Duplicate Tool
The Linear Duplicate tool creates an array of copies along a straight line. 
In addition to the Transform & Duplicate palette, this command is also 
accessed from the Edit menu.

Select the command and the dialog box appears:

The Linear Duplicate dialog box contains the following settings:

Number Per Row This is the total number of objects in each row. Be 
sure to include the selected object itself in this 
total count.

If the number is unknown use math operators to 
determine the number of copies. For example, to 
place studs 16 inches apart on a 17 foot wall, 
enter (17*12)/16. Graphite truncates the result to 
create 12 copies.
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X Length/Y Length The X Length value determines the horizontal 
length of a row. The Y Length value determines 
the vertical rise of the row.

The X Length and Y Length can be set by 
entering values, or by clicking the mouse in the 
drawing area.

Total Lengths The Total Lengths is the distance from the 
selected object to the last copy. 

Step Lengths The Step Lengths is the distance from the 
selected object to the first copy. 

Number of Rows This designates the total Number of Rows.

Total Offset The Total Offset is the perpendicular distance 
between the row containing the selected object 
and the last row.

Step Offset The Step Offset is the perpendicular distance 
between the row containing the selected object 
and the next row.

Offset This is the perpendicular distance setting for the 
Total Offset or Step Offset.

Specify the Offset by entering a value or by 
pressing and dragging the mouse in the drawing 
area.
10-13



10-14

Editing Objects Ashlar-Vellum
Using the Linear Duplicate Tool
1. Select the object to be duplicated.

2. Choose Edit>Linear Duplicate or choose the tool from the Transform and 
Duplicate palette.

A dialog box appears.

An asterisk (*) appearing beside an entry field indicates that the field can be filled 
by dragging the mouse in the drawing area to indicate the length. This is a very 
handy and accurate way to specify this information. 

3. Enter the Number of objects Per Row.

4. Specify Total or Step Lengths by clicking a button.

5. Click the X Length* data field.

6. Move the pointer to the drawing area and drag to indicate the length of the row 
of copies.

Both the X and Y values appear in the data fields.

7. If more than one row is desired, enter the Number of Rows, and click a button to 
specify the type of offset.

8. Enter the offset, if any. A negative number can be used.

Dragging to indicate the offset is particularly useful to equal the distance between 
two objects.

9. Click OK.
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An Example
Suppose it is necessary to illustrate six machine screws. Draw the 
geometry, then use Linear Duplicate to copy the geometry in an array.

1. Create and select the geometry to duplicate.

2. Choose Edit>Linear Duplicate or choose the tool from the 
Transform and Duplicate palette.

3. Enter 6 in the Number Per Row data field.

4. Click the Step Length option.

5. Click in the X Length data field.

6. Move the pointer into the drawing area and drag across the widest point of the 
step.

7. Click at the end of the entry in the X Length data field.

8. Type *2 to multiply the width of the geometry by two.

9. Click OK.

The geometry duplicates in a linear array.
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Referral:

For more information 
about using the Copy 
command in the Edit 
menu, see the section 
Editing Commands later in 
this chapter.
Polar Duplicate Tool

The Polar Duplicate command 
copies and rotates the selected 
geometry. When duplicating an 
object in a circular array, specify 
the number of duplications, the 
center of the array and whether 
the objects are copied in a rotated 
orientation or an upright 
orientation. In addition to the Transform & Duplicate palette, this tools is also 
accessed from the Edit menu.

Select this tool and the dialog box appears.

The Polar Duplicate dialog box contains the following settings:

Number This is the total number of objects to be 
duplicated. Be sure to include the selected object 
itself in this total count.

Center X/Center Y The Center X and Y values determine the center 
of the circular array.

The Center X and Center Y can be set by entering 
values, or by clicking the mouse in the drawing 
area.
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Total Angle The Total Angle is the number of degrees 
between the center of the selected object and the 
center of the last copy.

Step Angle The Step Angle is the number of degrees between 
the center of the selected object and the center of 
the first copy. 

Rotated Objects Copies are rotated relative to the angle between 
the copies. Each single arbitrary point of all 
copies have the same distance to the center of 
the circular array. That means that any point of 
the object can be the reference point.

Upright Objects Copies are upright with respect to the selected 
object. This option requires a reference point.

Ref X/Ref Y This is the reference point for the Upright Objects 
option.

Ref X and Ref Y determine an imaginary point 
duplicated around the center, as specified. The 
selected objects are reproduced in the same position 
relative to each imaginary point that is duplicated. 
With the Rotated Objects option the reference point 
has a constant distance to the center of the circular 
array. Specify the Ref X and Ref Y by entering a value 
or by clicking the mouse in the drawing area. 
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Using the Polar Duplicate Tool
1. Select the object to be duplicated.

2. Choose Edit>Polar Duplicate or choose the tool from the Transformation 
palette

A dialog box appears. 

An asterisk (*) beside an entry field indicates that the data can be filled in the 
field by dragging the mouse in the drawing area to indicate the length. This is a 
very handy and accurate way to specify this information. 

3. Enter the Number of objects in the circular array.

4. Click the Center X* data field.

5. Move the pointer to the drawing area and click to indicate the center for the 
array of copies.

The values for Center X and Center Y appear in the data fields.

6. Specify Upright or Rotated objects by clicking a button. See the next section 
for the definition of these terms.

7. If Upright is specified, click a location for the reference point in the drawing 
area.

8. If the copies do not need to be in a complete circle, click the Total or Step 
Angle option.

9. Enter a value for the specified angle type.

10. Click OK.

To place a selected object three times in a semi-circle, enter 3 for the Number and 
90° for the Step Angle.
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Copy by Path Tool

The Copy by Path tool creates an array of copies along a curve. After selecting the 
object, anchor point and the path, the dialog box appears. 

The Copy Along Path dialog box contains the following settings: 

Number The total number of objects that should be after 
copying by path. 

Step The distance from the selected object to the first 
copy.

Fill the path with step

First to second Sets the distance between first and second point 
by step.

First to last Sets the distance between first and last point by 
step.

Reverse direction Reverses the direction of array.

Turn to normal Turns to normal of copy. 
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Another side This option allow to reside of copy.

Cut in path's end This option allow to cut the number of copies on 
the circle.

Anchor point X*/Y* The values determine place of anchor point.

Complete set Allow to finish working with current array and start 
new array.

Using the Copy by Path Tool
1. Choose the tool from Transformation palette. 

2. Select the object to be duplicated.

3. Pick the anchor point.

4. Select the path (line, spline, circle...). Use SHIFT to choose several objects 
(rectangle, several splines...)

5. A dialog box appears. 

6. Enter the Number of objects in the array.

7. Enter the Step.

8. Pick on the path to set start point.

9. Click the Complete set to continue working with this tool and start new array.
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Offset Tool

The Offset command creates offsets from lines, arcs, circles, ellipses and splines. In 
addition to the Transform & Duplicate palette, this is also accessed through the 
Edit menu.

When selecting this command, the Offset dialog box appears.

The dialog box contains the following settings:

Offset Distance* This is the distance away from the original 
geometry that the new geometry is created. The 
asterisk indicates that the cursor can be used to 
input an offset distance by dragging between any 
two points on the drawing area. The cursor must 
be in the Offset Distance field while dragging. For 
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multiple offsets additional values may be entered 
manually, separated by semicolons.

The X, Y, or Z direction values can be filled in 
manually or indicated by a mouse click on the 
drawing area offset from the object. The point 
clicked determines which side of the object the 
offset should be performed. The offset direction 
(positive or negative value) is also filled in the 
respective entry fields when dragging the offset 
distance since the vector dragged determines the 
Offset direction automatically.

Clicking the Options button displays this dialog box.

The Options dialog box contains the following settings:

Tolerance For spline and ellipse objects the offset distance is 
approximated by a spline. Setting a Tolerance for 
this type of object determines how accurate the 
offset is relative to its theoretical position.

Max Iteration Graphite iterates the number of times specified 
when calculating the offset of spline and ellipse 
objects to improve the approximation. The default 
value is 3. Setting a high value (100, 1000, etc.) 
decreases performance.
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Mitered Joint If this option is marked, the offset object has 
square external corners instead of filleted 
corners. This option is, by default, not selected. 
The radius of the filleted corners is automatically 
set to the offset distance. For instance, a box that 
is offset by .25 has a fillet at each corner with a 
radius of .25.

Grouped If this option is marked, the new offset geometry is 
grouped when created. This option is, by default, 
not selected to produce ungrouped geometry.

Creating an Offset
1. Select the object to offset.

2. Choose Edit>Offset or choose the tool from the Transform and Duplicate 
tool palette.

The Offset dialog box displays.

3. Click into the Offset Distance* field.

4. Input an offset distance by dragging between any two points on the drawing 
area.

5. Click in one of the Ref* entry fields.

6. Enter an offset direction by dragging between any two points on the drawing 
area.

7. Click the Options button.

In the Options dialog box, specify a Tolerance, if needed, and whether or not the 
object will be offset with mitered corners.

The new geometry ungroups, and the original geometry remains selected.

For Graphite, if an offset is created with the work plane not set to match the plane of 
the object being offset, the results may be unpredictable. The Z* value is ignored in 
the Offset dialog box, and the distance is applied in the plane of the object being 
offset.
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Moving Objects 
When an object is selected, move the pointer near the object until the 4-way Move 
symbol appears as shown below, and drag the object to a new location.

Note: If there is difficulty displaying the 4-way Move symbol, it might be because the 
Paste command was just used. When an object is drawn and then immediately 
copied and pasted, the original drawing tool is still in effect. Click the Selection tool 
to access the 4-way Move tool when the cursor is moved near an object.

Using the Drafting Assistant for Moving
When the pointer becomes the 4-way Move symbol, drag the object around to see 
the Drafting Assistant’s notations relative to the object’s location. If the pointer is 
moved over a control point activated by the Drafting Assistant the object can be 
aligned using that point.

on
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Selected Move versus Move Tool
Objects can be moved using either with the Selection tool or the Move tool, or 
nudged with the arrow keys.

Moving with the Selection Tool

The move tool of the Selection palette freely moves a selected object.

To move a circle from one location to another as shown above, use the Selection 
tool and the Drafting Assistant to align the 90° quadrant with the corner of the 
rectangle. The circles do not need to touch the rectangle to be aligned with it.

To move a circle or an arc from its center point, use the Move tool rather than the 
Selection tool.

Nudging Geometry
Geometry can be nudged a specified distance within Graphite using the arrow keys 
on the keyboard.

Setting the Nudge Distance
1. Go to Layout>Preferences>Nudge or Right Mouse Click and choose Nudge.

Moving with Nudge
1. Select an item or items to move or Nudge. 

2. Use the arrow keys to move the selected items in the desired direction. By 
holding down the CONTROL key the nudge distance is doubled.
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Tip:

Use the Move tool to 
move a circle or an arc by 
its center point. The 
Selection tool cannot do 
this.
Moving with the Move Tool

The Move tool relocates the selection with reference to other geometry.

Move a 1-inch square 2 inches in the X direction and 
1 inch in the Y direction. See the following graphic.

1. Select the square to be moved.

2. Select the Move tool.

3. Click one corner of the square when the 
endpoint notation displays.

4. Enter 2 in the X data field on the Status Line and 
-1 in the Y data field.

A positive or negative value entered in the Status 
Line determines the direction along the X or Y axis. A negative value moves the 
object to the left or down on the screen, and a positive value moves the object to 
the right or up.

5. Press the ENTER (Windows) or RETURN (Macintosh) key.

The square moves.

Moving Objects to Another Layer
1. Select the object(s) to move to another layer.

2. Choose Edit>Edit Objects.

3. In the Layer field of the Edit Objects dialog box select to the desired layer.

4. Click OK. The object is now located on the new layer.
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Copying Objects 
Copy selections with the Copy command or by holding down the CTRL (Windows) 
or OPTION (Macintosh) key while using the following tools:

• Selection tool

• Single Line tool

• Center-Point and Opposite-Point Circle tools

• Ellipse tools

• Polygon tools

• Text tool

• Transformation tools

Copying with the Selection Tool
Hold down the CTRL (Windows) or OPTION (Macintosh) key and drag a copy of the 
selection to a new location.

1. Click the Selection tool.

2. Select the object(s) to copy.

3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.

4. Drag a copy of the selection to a new location. 

5. Release the CTRL (Windows) or OPTION (Macintosh) key.
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Copying with the Geometry Tools
Make copies with the following drawing tools:

• Single Line tool

• Center-Point and Opposite-Point Circle tools

• Ellipse tools

• Polygon tools

• Text tool

1. Construct the geometry to copy.

2. With the drawing tool still activated, hold down the CTRL (Windows) or 
OPTION (Macintosh) key.

3. Click a new location. The click determines the location of the first point original 
geometry construction (the center of a center-point circle, for example).

4. Release the CTRL (Windows) or OPTION (Macintosh) key.

Copying with the Transformation Tools
Hold down the CTRL (Windows) or OPTION (Macintosh) key while using a 
Transformation tool to make a copy of the selected geometry.

1. Select the object to copy and transform.

2. Select one of the four Transformation tools.

3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.

4. Perform the transformation according to the directions in the Message Line.

5. Release the CTRL (Windows) or OPTION (Macintosh) key.

A copy transforms and the original remains unchanged.

Copy Command versus CTRL (Windows) or 
OPTION (Macintosh) 
Usually, using the copy option of a geometry tool is faster than using the Copy and 
Paste commands in the Edit menu. The Copy command is very useful for copying to 
a different document or application.
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Referral:

Sizing with the Expand/
Shrink tool is described in 
an earlier section.
Sizing Objects with Tools
Normally an object is sized with the Selection tool or the Expand/Shrink tool. In 
some cases it is possible to use the Move tool for sizing objects. Stretch objects by 
selecting a point and dragging it to a new location.

Sizing an Object with the Selection Tool
Stretch objects by selecting a point and dragging it to a new location.

1. In the Edit menu, be certain that Selectable Points is checked.

2. Click the Selection tool.

3. Drag a selection fence around the control points that represent the area to 
stretch.

4. Drag the points to a new location.

Intersecting lines can be dragged
to new lengths.

A line can be dragged to a new
length.
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Sizing an Object with the Move Tool
Size an object with the Move tool. Using the Move tool allows the distance that 
selected point(s) should be moved to be specified by particular values along the X 
and Y direction in the Status Line.

To move the corner of the rectangle in the next graphic with the Move tool:

1. In the Edit menu, be certain that Selectable Points is checked.

2. Click the Selection tool.

3. Drag a selection fence around the lower right corner of 
the rectangle, selecting only the point.

4. Click the Move tool.

5. Enter +1 in the X data field and -1 in the Y data field 
in the Status Line.

6. Press ENTER (Windows) or RETURN (Macintosh).

The corner of the rectangle moves the distance 
specified in the Status Line.

Use the Move tool for sizing objects only once since the 
next values entered in the Status Line do not refer to the 
new position of the moved point(s), but always to the 
original one. That means if (in our example) –1 is entered in the X data field and +1 
in the Y data field, the point is not moved back to its original position, but in the 
opposite direction referring to its original position.
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Selected Sizing Versus Expand/Shrink Tool
Dragging a control point of a selected object changes the size of the object, but it 
also distorts the object, changing the proportion between height and width. 

The Expand/Shrink tool on the Transformation subpalette resizes geometry while 
maintaining its proportions. 

In addition, specify proportions by clicking points on other geometry. For example, 
resize an object to fit within another object by clicking the boundary into which the 
resized object must fit.

Use the Expand/Shrink tool to enlarge
or shrink a shape proportionally
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Tech Note:

The difference between 
the Cut and Copy 
commands is that cutting 
a selection removes it 
from the drawing area 
while a copied selection 
remains in the drawing 
area.

Tip:

To move an object from 
one layer to another, 
choose the Edit>Edit 
Objects.
Editing Commands
Commands in the Edit menu select and manipulate objects. Two important 
commands in this menu are Undo and Redo which reverse an action or reinstate it. 
Four other commands in the Edit menu change objects without changing the 
physical geometry. Using them it is possible to copy or move objects within the 
same document, either on the same sheet or to other sheets. They are also used to 
copy or move objects to other documents, even to other applications. 

The Cut, Copy and Paste commands do not alter the object’s attributes, such as the 
layer and pen style (color, weight, and pattern). To change the attributes of an 
object, choose Edit>Edit Objects. The Cut and Copy commands place a copy of 
the selected object on the Clipboard. The Clipboard is a buffer, a temporary storage 
place that holds the last cut or copied selection. The contents of the Clipboard are 
objects, not bitmaps or picts.

Cut 
CTRL+X (Windows); +X (Macintosh)

The Cut command in the Edit menu removes the selected objects and places them 
on the Clipboard. Each selection cut or copied to the Clipboard replaces the 
previous Clipboard contents.

Cutting Objects
1. Select the object to be cut.

2. Choose Edit>Cut.

Once a selection is cut, it can be pasted. Use Cut and Paste to move geometry or 
text around the document, from one sheet to another, or from one document to 
another. Paste the cut selection onto a document in a different application. 

Moving Geometry with the Cut Command
1. Select the objects to move.

2. Choose Edit>Cut.

3. Display the location for the selection to appear in the drawing area, scrolling if 
necessary.

4. Choose Edit>Paste. 

The object appears in the center of the drawing area on the original layer on which it 
was created or onto the work layer if it’s from a different application. The object 
is selected so it can be moved. 
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Tip:

It is also possible to create 
a copy of an object or text 
box with the Selection 
tool. First select the object, 
then hold down the CTRL 
(Windows) or the OPTION 
(Macintosh) key and drag 
a copy of the object to a 
new location.

Copy an object using any 
of the Transformation 
tools by holding down the 
CTRL (Windows) or the 
OPTION (Macintosh) key 
while using the tool.
Copy
CTRL+C (Windows); +C (Macintosh)

This command in the Edit menu places a copy of the selection onto the Clipboard 
without deleting the original selection. Paste the copy elsewhere in the current 
document or into a different document. Or even paste the copied selection into a 
document created with a different application.

Copying Objects
1. Select the objects to be copied.

2. Choose Edit>Copy.

The selection goes on the Clipboard, and it remains in the current document.

Paste 
CTRL+V (Windows); +V (Macintosh)

The Paste command in the Edit menu pastes a copy of the Clipboard contents onto 
the center of the drawing area. The Clipboard contents are not changed when using 
the Paste command. 

It is also possible to paste the selection into another Graphite document or into 
a document created with another application. To create an even distribution of 
geometry, in the Edit menu, use Linear Duplicate or Polar Duplicate.

Rules:
1. If the object was cut or copied from a Graphite document, when it is pasted 

into another Graphite document it goes on the layer with the same name from 
which it was cut or copied. A pasted selection retains its original attributes. 

Any geometry on a layer that is not in the new Graphite document is placed on 
the current work layer. So, make sure that the new document has all the layers 
of the pasted geometry by creating those corresponding layers in the new 
document before pasting the geometry.

2. Objects cut or copied from non-Graphite documents are pasted onto the work 
layer.
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Delete 
The Delete command in the Edit menu removes a selection without placing it onto 
the Clipboard. It is possible to Undo this deletion, but not Paste what is deleted. In 
addition to this command, use the DELETE (Windows and Macintosh) or 
BACKSPACE (Windows only) key to delete a selection. (Retrieve what was deleted 
with the Undo command).

Undo 
CTRL+Z (Windows); +Z (Macintosh)

This command in the Edit menu reverses the last action. For example, if an object is 
deleted, choose Undo to restore it. Then use Redo to return to the deleted version.

Undo affects actions that create and edit geometry and text, but not on actions that 
do not change the contents of the drawing, such as resizing the window or quitting.

When using a tool which involves a multi-step process, such as constructing with 
Connected Lines or creating a 3-Entity Fillet, choosing Undo reverts to the 
beginning of the process. Some other activities can be stopped by pressing the ESC 
key. The number of Undo commands is specified using 
Layout>Preferences>Undos.

Redo 
CTRL+SHIFT+Z (Windows); No Key Command (Macintosh)

The Redo command in the Edit menu reinstates the last action reversed by Undo. 
Use Undo and Redo an unlimited number of times depending upon what is specified 
in the Preferences.

Erasing Geometry
There are use several methods to erase objects: 

• Select the object(s), then press the BACKSPACE (Windows) or DELETE 
(Macintosh) key. (Retrieve what was deleted with the Undo command).

• Select the object(s), then choose the Delete command from the Edit menu. 
(Retrieve what was deleted with the Undo command).

• Select the object(s), then choose Edit>Cut. (Retrieve what was cut by using the 
Paste command, as long as nothing else has been cut or copied. 
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Tip:

It is often faster to change 
a single geometric 
characteristic of an object 
by simply clicking the 
object and changing the 
geometry in the Status 
Line. But when changing 
several characteristics or 
attributes, it is better to 
use the Edit Objects 
dialog box.
Changing the Characteristics of Objects
Edit selected objects either by changing individual characteristics, such as weight or 
color, from the menu, or by changing the specifications in the Edit Objects dialog 
box. 

The Edit Objects dialog box also provides information about the selected object in 
addition to allowing making changes.

Edit Objects Command 
CTRL+I (Windows); +I (Macintosh)

The Edit Objects command in the Edit menu 
changes the individual characteristics of 
selected objects, such as weight, layer, or 
pen style, or other specifications. Changes 
made through this dialog box are reversed 
with the Undo and Redo commands.

Editing Objects
1. Select the object to be edited.

2. Choose Edit>Edit Objects.

The dialog box appears.

3. Change the information in the data 
fields.

Click the data field, type a new entry and 
press ENTER (Windows) or RETURN 
(Macintosh). The object is modified 
instantly.

Many data fields have pop-up menus for 
selection. Press the down arrow and then 
drag to the selection desired. Once you 
click the option from the pop-up menu, 
the object is modified.

4. Click the Close button to close the Edit 
Objects dialog box. 

Use Undo and Redo to reverse changes made through this dialog box.
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Tip:

Use the Expand/Shrink 
tool as well as the Edit 
Objects command to edit 
the measurements of 
existing objects. This 
dialog box is a fast, easy 
way to make several 
changes at once.

Tech Note:

Use mathematical 
operators in the Edit 
Objects dialog box. A list 
of all allowed operators is 
in Appendix A.

Tech Note:

Use different units in each 
data field like inch (“), 
feet(‘), feet/inches (x’y”), 
centimeter (cm), 
millimeter (mm), or meter 
(m). It is possible to mix 
English and metric units 
as long as they are 
labeled correctly like 10” + 
25.4 cm.
The specifications shown in the dialogue box depend on the type of object selected, 
and include at least the following: 

• Number (or type) of objects

• Lock status

• Current layer

• Current color

• Current pattern

• Current weight

• Absolute coordinates for the starting point and ending point of the object

The measurements reflect the settings of the Units option in the Preferences 
submenu. To prevent changes to an object, specify locked in this dialog box, or 
select the object and choose Lock from the Arrange menu.

When doing a lot of editing, leave the Edit Objects dialog box displayed. That way it 
is possible to select the object, make the changes in the dialog box, click Apply, 
and then go on to the next object. 

If more than one object is selected when Edit Objects is chosen, only the common 
information is displayed. Entries are blank when the information isn’t common. For 
example, if selecting two concentric circles, the center displays in the Edit Objects 
box but the diameter box is blank.

If several objects are selected and then Edit Objects is chosen, all of the objects 
reflect the changes made in the dialog box. For example, if all dimensions are 
selected and the text entry in the Edit Objects dialog box is changed to 2, all the 
dimensions display a 2.

Moving an Object to a Different Layer
1. Select the object(s) to be moved.

2. Choose Edit>Edit Objects.

3. Click the arrow for the Layer data field.

4. Click the layer from the list.

5. Choose Apply.
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Arranging Geometry
The Arrange menu contains commands that subdivide geometry, group geometry 
so it behaves like a unit, and lock geometry to prevent changes. This menu also 
contains a command to refresh the screen after geometry have been changed.

Divide Command
This command in the Arrange menu subdivides the selected geometry into the 
specified number of equal parts. 

1. Select the object to be divided.

2. Choose Arrange>Divide.

The dialog box appears.

3. Enter the number of equal parts to divide the selection.

4. Click OK.

The divisions can be seen when displaying the points by clicking Show Points in 
this dialog box or choosing Layout>Show Points.
10-37



10-38

Editing Objects Ashlar-Vellum
Group Command 
CTRL+Y (Windows); +Y (Macintosh)

The Group command in the Arrange menu combines selected objects to function as 
a single object. 

1. Select the objects to be grouped.

2. Select Arrange>Group.

Once geometry is grouped, the individual objects within the group can’t be edited 
unless ungrouped.

If the group is moved, all components move together. If the size of a group is 
changed, the individual objects change proportionally. 

It is also possible to combine groups. For hierarchical groupings, Graphite ungroups 
each group in the order in which they were combined.

To create temporary groups, which are useful when moving multiple objects, drag a 
selection fence around several objects to treat them as a single unit while they are 
selected. 

Changing the Members of a Group without Adding a Hierarchical Level
To add new geometry to an existing group, select the group and the new geometry 
and choose the Group command. This method creates a group within a group. To 
make a single group, follow these directions:

1. Select the group.

2. Choose Arrange>Ungroup. The geometry ungroups with the individual 
objects selected.

3. Hold down the SHIFT key and select the geometry to be added to the group.

4. Choose Arrange>Group.

Follow a similar procedure to remove members of a group.

Ungroup Command
The Ungroup command in the Arrange menu separates grouped objects into their 
individual components. 

1. Select the group.

2. Choose Arrange>Ungroup.

The group becomes individual objects once again.
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Lock Command
The Lock command in the Arrange menu prohibits editing or movement of selected 
geometry. 

Preventing Accidental Changes to One or More Objects
1. Select the objects to be locked.

2. Choose Arrange>Lock.

Although moving or changing a locked object is not allowed, it is possible to copy, 
group, and select it.

Selected objects can also be locked or unlocked by clicking the locked box in the 
Edit Objects dialog box.

Preventing Changes to an Entire Document
1. Choose Edit>Select All.

2. Choose Arrange>Lock.

Selected objects can also be locked or unlocked by clicking the Locked box in the 
Edit Objects dialog box.

Unlock Command
The Unlock command in the Arrange menu removes the lock in the selection. 
Change and move the unlocked objects.

1. Select the locked object(s).

2. Choose Arrange>Unlock.

Selected objects can also be locked and unlocked by clicking the Locked box in the 
Edit Objects dialog box.

Redraw Screen Command
CTRL+R (Windows); +R (Macintosh)

The Redraw Screen command in the Arrange menu refreshes the screen. When 
changes are made to the constructions, the geometry may not be redrawn cleanly in 
the drawing area.

Redrawing the Screen
To redraw all of the geometry and remove extraneous artifacts, choose the Redraw 
Screen command from the Arrange menu.
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Stopping a Screen Refresh 
Windows: Press the ESC or BREAK key to stop the redrawing of the screen. For 
interrupting long operations such as redraw, or linear or polar duplicate, use the 
BREAK key. If the operation was initiated by a control key command (such as 
CRTL+R for redraw) the ESC key is read by MS-Windows and it brings up a task list 
at the end of the operation.

Macintosh: Press ESC or the Command () key to stop the screen from redrawing.



Adding Details
Adding Details
Once the basic geometry is created, add notations or highlight certain portions of 
the geometry. This chapter discusses a few ways to do so. The topics covered 
include:

• Text

• Crosshatching and Solid Fills

• Arrowheads

Text
When the drawing needs to be annotated, use the Text tool to create a text box for 
entering characters from the keyboard. Create, import and edit text on the screen, 
using the Text menu to set the characteristics, such as font, text size, style, 
alignment, line spacing and indent.

There are nine text handles for each text object. These help move and/or align the 
text as necessary.

The specifications list is included
on a separate sheet.

1.
vertex

vertex

vertex

vertex

Tolerances are specified as noted
—see attached sheet.

2.

midpoint

midpointmidpoint

midpoint

center
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Tech Note:

An ASCII text file is 
usually created by word 
processing software and 
saved as plain text. It 
usually contains only 
standard keyboard 
characters—letters, 
numbers, punctuation, 
and spaces—without the 
formatting typically found 
in word processing 
documents.
Text Tool

The Text tool, creates and edits text on screen. The text entered has the 
characteristics set in the Text menu.

Using the Text Tool
1. Select the Text tool from the tool palette. The Message Line reads, Text: Pick 

opposite corners of text entry box [Ctrl = Copy Previous (Windows) or Option 
= Copy Previous (Macintosh)].

2. Create a text box by dragging or by clicking two locations to place the opposite 
corners of the text area. 

The text box is as tall as a single line of text and as wide as indicated. The text 
cursor appears in the box, ready for the typing.

3. Enter the desired text from the keyboard. 

Pressing the BASKSPACE (Windows) or the DELETE (Macintosh) key erases 
characters to the left of the cursor. 

The text entered automatically word wraps to the next line when it reaches the 
right side of the text box created in step #2. If the text box is resized, the words 
rewrap automatically.

The Status Line specifies the X and Y location of the first text box corner, the text 
box width and height.

Importing Text 
Small portions of text may be copied and pasted into a text box from other sources 
such as a word processing document. 

It is also possible to import an ASCII file that contains text into the drawing. For 
example, place specifications written with a word processor on the drawing 
without retyping them. The entire file imports, so to use only part of the document, 
create a new file that contains only the information to be entered on the drawing. 
To import a file:

1. Select the Text tool from the tool palette.

2. Create a text box by dragging or clicking twice to place the opposite corners of 
the text area. 

3. Choose File>Import. 
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Tip:

To change characteristics 
for the entire text entry, 
use the Selection tool to 
select the text block.

Tip:

To change the 
characteristics of a word 
or portion of a text block, 
use the Text tool to select 
what to change.
A dialog box appears.

4. Select the text file to import.

When the Import dialog box appears, specify the Text as the file type.

5. Click OK. 

The text file appears in the text box created.

Editing Text
1. Select the Text tool from the tool palette.

2. Move the pointer directly over the text to be edited. The pointer turns into an I-
beam text cursor when it is over text. (This only occurs when the Text tool is 
active.)

3. Use the text cursor to select text.

Drag either direction to select characters, double-click on an individual word to 
select it, or click to place the text cursor within the existing text to add or change 
it.

4. Modify the selected text by choosing the appropriate commands from the Text 
menu.

Changing the Characteristics of a Block of Text
Change the font, text size, style, spacing and indentation of a block of text.

1. Use the Selection tool to select the block of text to be changed.

2. Select the new characteristic from the Text menu.

The selection shows the new characteristic.

Changing the Size of the Text Box
1. Click the Selection tool.

2. Drag a selection fence around the right side of the text box. 

The dotted lines shown in the following graphic do not appear on the screen.

Note: For single lines of text, if it is not possible to select the control points on 
the right side of the text box, it may be that the original text box extends further 
than the edge of the text. With the Selection tool, first select the text by clicking 
on it. When the text box appears, drag a selection fence around the right side.

The control points mark the boundaries of the text box when it is first created.

3. Drag the control points to the right as shown below or to the left to make the 
text box smaller.
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The area changes size and the text rewraps automatically.

In the Edit menu, Selectable Points must be active for selecting the control points 
of the text box.

Moving Text

1. Choose the Selection tool.

2. Select the text object to move.

3. Move the cursor over the text object. The cursor becomes a 4-way Move 
symbol.

4. Place the 4-way Move symbol at the desired handle location using the 
Drafting Assistant notations as a guide.

5. Drag the text object to the new location.

Spell Check
To spell check any text item in a drawing:

1. Select the text to check.

2. Access the spell check function using one of the following:

• Choose Text>Spell Check.

• Right click the mouse and choose Spell Check from the context menu that 
appears.

• Choose Spell Check tool from the Text palette.

3. The Spell Check dialog box operates like any 
spelling checker. It is necessary to have the 
required files in the directory named “Spell” of the Graphite application folder. 
The user requested additions are compiled in the userdic.tlx file.

The right and left margins
of the text are controlled by
the size of the text box.

The right and left margins of the text are
controlled by the size of the text box.

 box to make it larger or smaller.
Drag a control point on the box 
to make it larger or smaller. 

Control points

Drag a control point on the
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Text Menu
The Text menu contains commands for changing the text 
font, size, and style, as well as the justification, spacing 
and indentation.

Font
The Font command in the Text menu changes the font for 
selected text or future text entries.

The fonts listed in the menu are 
those installed on the computer and 
include Ashlar-Vellum’s Plotter fonts. 
Use a Plotter font whenever creating 
text for a drawing that is intended to 
be sent to a plotter, since plotting 
Postscript or TrueType fonts take 
much more time to plot or may be 
substituted.

The selected font stays in effect for 
the current document until another 
font is chosen.

Note: The fonts used for dimensions 
are the same set of fonts as those 
used for the text, however, they are 
set in the Dimension menu.

Special characters and accents 
are available as described in 
Appendix B.
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Tech Note:

Macintosh users: All fonts 
available in the system 
are displayed in the fonts 
list so there is no 
Extended font selection 
process.
Extended Font Selection (Windows)
The Font submenu displays up to 20 fonts. If more than 20 fonts are installed, 
select More in the Font submenu of the Text menu for more available fonts.

Choosing More brings up a dialog box for specifying the font, text size and text 
style. The text size is measured as a point size. To specify the size in the units set 
for the drawing, type the exact unit such as " for inch or mm for millimeter after the 
value. 

1. Choose Text>Font>More.

The Character Format dialog box displays:

2. Select the character format. 

3. Click Apply. 

Leave this dialog box open to assign other character formats. To close this dialog 
box, double click the Control pull-down menu in the upper left corner of the dialog 
box. 

The character format specified stays in effect until another character format is 
chosen.

Rotating Text
Text, including Postscript and TrueType fonts, can be rotated with the Rotate tool 
like any other object in the drawing. Text that is neither horizontal nor vertical may 
appear jagged on the screen, but it should print at the system’s highest quality.

Font Sizes and ANSI Standards
A typical system font specified for .156 inches may produce a character that is 
only .125 inches. The variation depends on the proportional spacing of the font. To 
set a font to exact specifications, use a Plotter font, which conforms to ANSI 
standards.
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Size
The Size command in the Text menu sets 
the font size for the selected text or for 
future text entries in the current document. 
This can be specified as either points (12 
pt) or units (.156 inches) as defined in the 
Units dialog box within 
Layout>Preferences>Units. If no unit is 
specified, Graphite picks the default unit.

Specifying a Non-standard Text Size
Choosing Other from the Size submenu 
brings up a dialog box to enter the exact 
text size in point size, inches or metric 
units. If a unit is not specified the default 
unit for the drawing is used.

1. Choose Text>Size>Other.

2. Enter the size. The size is measured 
in the current units as set in the Preferences 
submenu. To specify a point size, include pt with 
the numeric entry.

3. Click OK.

The size specified stays in effect until another size is 
chosen.

Text Size and Scaling
Making changes to the scale in the Drawing Size dialog box in the Layout menu, 
changes the text size inversely. For example, if the drawing is scaled 1:4, multiply 
the text size by 4 for it to display properly on the drawing. Also use the Keep Text 
Size and Keep Dimension Text Size options from the Drawing Size dialog box 
when changing the Drawing Scale to change the size of the text relative to the size 
of the other objects. 

If it looks right on the screen, the scaling is appropriate. See the chapter on 
Graphite Documents for more information on scaling.
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Style
The Style command in the Text menu sets the 
style (such as Bold or Underline) for selected 
text or future text entries.

The style specified stays in effect until another 
style is chosen. A check mark indicates the 
current style. Change the default setting by 
saving the changes in the preferences file 
(prefs.vc6 - Windows, or Graphite prefs - 
Macintosh). Choose 
Layout>Preferences>Save Preferences.

Text Alignment
The four commands in the second section of 
the Text menu align the text within the text 
box. The text can be aligned on the left, the 
right, centered in the middle, or it can be fully 
justified so that it is aligned with both left and 
right margins of the text box.

If the Text tool is active, both the selected text and future text are aligned as 
specified, but existing text is not aligned. If another tool is active when any of these 
commands are chosen, only future text entries are aligned. If a text entry is 
selected when any of these commands are chosen, the selection and future text 
entries are aligned as specified. 

Align Left
Align Left in the Text menu aligns 
the selected and future text at the 
left margin of the text area. 

Align Middle
Align Middle centers the selected 
and future text in the text area. 

Text alignment is controlled
from the Text menu. You can
align text with the left or the
right margins, with both
margins, or centered between
the margins.

Text alignment is controlled
from the Text menu. You can
align text with the left or the

right margins, with both
margins, or centered between

the margins.
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Align Right
Align Right aligns the selected and future text 
at the right margin of the text area. 

Justified
Justified aligns both the left and right margins 
of the selected and future text in the text 
area. 

Text Spacing
The Text menu has commands for 
single, space-and-a-half, or double 
spacing between the lines of the text.

The check mark in the Text menu 
indicates the current line spacing. 
Change the default setting by saving 
changes in the Preferences file.

Single Space
Single Space sets the spacing of 
selected and future lines of text so each line occupies one space in the text area.

1-1/2 Space
This command changes the spacing of selected and future text so each line 
occupies one and a half spaces in the text area. 

Double Space

This command sets the spacing of selected and future text so each line occupies 
two spaces in the text area. 

Text alignment is controlled 
from the Text menu. You can 
align text with the left or the 

right margins, with both 
margins, or centered between 

the margins.

 

 

The text alignment is 
controlled from the text menu. 
You can align text with the left 
or the right margins, with both 
margins, or centered between 
the margins

Text spacing is controlled from the Text 
menu.

Text can be single spaced like the first 
paragraph or set at one and a half 
spaces, as in this paragraph. 

Text can also be double-spaced like in 
this paragraph.
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Indenting Text
To indent the text on the right or left side of the text box, or to have the first line 
indented, choose Text>Indentation.

Indentation Command
The indentation command in the Text menu sets the indentation of paragraphs for 
the selected text area as defined by the units set in the Preferences submenu.

1. Choose Text>Indentation.

The dialog box appears.

2. Specify the indentation. Use point values if 
pt is included in the entry.

3. Click OK.

Specify the number of units for any or all the 
choices:

First Line Sets the number 
of units for the 
indentation of the first line of each paragraph. 

Left Indent Sets the number of units for the indentation on the 
second and following lines of the left margin of 
each paragraph.

Right Indent Sets the number of units for the indentation of the 
right margin of each paragraph.

        This is an example
of a paragraph with the
first line indented.

2.    This is an example
       of a paragraph with
       a left indent.

This is an example
 of a paragraph with
 a right indentation.
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Plotter Fonts
All TrueType and PostScript fonts installed on the computer are available in 
Graphite. (SHX fonts are not supported on the Macintosh platform.)

In addition, Graphite offers the following Plotter fonts.
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Tech Note:

Crosshatching appears 
parallel to the work plane 
and only in the view in 
which it was created. In 
other words, it is drawn 
correctly when viewed 
along the z-axis of the 
work plane.
Crosshatching and Solid Fills
Graphite can crosshatch and fill any enclosed area in the drawing and then 
automatically update the crosshatching or fill when changing the dimensions of 
the enclosed area. If a closed area with a hole or other cutout in it is specified, 
Graphite accurately excludes the hole area from the crosshatching.

In the Pen menu are two fill commands: Solid Fill and Fill, and two crosshatch 
commands: Crosshatch and Hatch. Fill creates a solid fill for a selection with the 
current pen color. Hatch crosshatches the selection with the default pattern or the 
last pattern selected. Solid Fill sets the tolerance for the fill. To change the hatch 
patterns, choose Crosshatch and specify the pattern to use. To change the default 
hatch pattern, make changes to the preferences file as described in Chapter 5, 
Basic Environment Settings.

Choose the Fill command from the keyboard with CTRL+B (Windows) or +B 
(Macintosh) and the Hatch command from the keyboard with CTRL+H (Windows) 
or +H (Macintosh).

Crosshatch Patterns
A wide variety of Crosshatch patterns are available in both ISO or DIN styles. 
Crosshatching appears parallel to the work plane, and only in the view in which it 
is created. In other words, it is drawn correctly when viewed along the z-axis of the 
work plane.
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The following ISO crosshatching options are available.

The following DIN crosshatching options are available.

Iron Titanium Grass

Steel Electric Fabric

Bronze
Copper

Marble
Glass Insulation

Zinc Thread Mud

Aluminum Brick Concrete

Rubber
Plastic

Earth
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Tech Note:

To crosshatch Smart Walls 
containing smart symbols, 
first segment the walls to 
create hatch boundaries. 
Since smart symbols 
cover only wall segments, 
they can’t be used as 
hatch boundaries.

Tip;

To crosshatch a figure that 
is not a closed figure, add 
lines or segment lines to 
make a closed figure. In 
this way, crosshatch 
individual sections of the 
geometry. See 
“Crosshatching” in the 
“Advanced Features” 
section of the Getting 
Started manual for a step-
by-step example.
Specifying the Fill or Crosshatch Area
The selected objects must completely enclose the area that needs to be 
crosshatched or filled. For example, to crosshatch or fill the object below; select all 
of the lines making up the part, including the holes.

The exterior lines define the boundary for the 
crosshatching or solid fill. The two holes tell 
Graphite that those enclosed areas within the 
original area should not be crosshatched or 
filled.Once the lines and holes are selected, in the 
Pen menu, choose the Hatch, Fill, Crosshatch, or 
the Solid Fill command and specify the pattern to 
use.
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Tip:

Use the Tracer tool to 
select the boundary.
It is important not to select extra objects when specifying the crosshatch or fill area 
because Graphite does not know how to treat the extra objects.

Crosshatch Command
The Crosshatch command in the Pen menu crosshatches the selection with one of 
the industry standard crosshatching patterns. Change the default pattern by 
saving changes in the preferences file. See Chapter 5, “Basic Environment 
Settings.”

To crosshatch
a rectangle

Select only the
boundaries

Do not select
extraneous lines
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Adding Crosshatching
1. Select the objects which represent a closed boundary. The closed boundary 

may include cutout areas such as a hole. Select both the outside boundary 
and the hole.

2. Choose Pen>Crosshatch.

The dialog box appears displaying DIN crosshatching options.

3. To display ISO crosshatching options, click the ISO radio button in the dialog 
box. 

Using ISO Crosshatching
1. Click the ISO radio button to display the ISO patterns. The dialog box 

displays.

2. Select the pattern from the menu.

The pattern selected appears in the Pattern display area as it will appear on the 
drawing.

3. Change the spacing and angle, if desired.

When making changes to the angle or spacing, the pattern box shows the 
revised pattern exactly as it is when the specified object is crosshatched.

4. Click Apply.
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Using DIN Crosshatching
1. Select the pattern from the menu. Those patterns that have an ellipsis (...) 

following their name have their own submenu. Double-click on one of those 
names to display the submenu.

To return to the main menu, double-click on the ellipsis at the top of the 
submenu.

The pattern selected appears in the Pattern display area as it  appears on the 
drawing.

2. Change the spacing and angle, if desired.

When making changes to the angle or spacing, the pattern box shows the 
revised pattern exactly as it is when the specified object is crosshatched.

3. Click Apply.

Editing an Existing Crosshatch Pattern
1. Select the existing crosshatching by clicking it with the Selection tool. 

2. Choose Pen>Crosshatch.

3. Make the changes in the Crosshatch dialog box.

4. Click Apply.

The crosshatching changes as specified.

Note: The line style of any specific crosshatch pattern is not editable. Only the 
space and angle can be adjusted.

Hatch Command

CTRL+H (Windows); +H (Macintosh)

The hatch command, located in the Pen menu, crosshatches the selected objects 
using the current crosshatch pattern. To change the crosshatch pattern, choose 
Crosshatch and make the selection from the dialog box.

The best way to select a hatch boundary is with the Tracer tool. 

Crosshatching with the Current Pattern
1. Select the object to crosshatch.

2. Choose Pen>Hatch.

The selected area is crosshatched with the current pattern.
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Solid Fill Command
The Solid Fill command in the Pen menu fills the selection with the current pen 
color. 

A solid filled object covers its background only if it is the last entity drawn. To make 
a solid filled object cover its background, select it again before printing or saving to 
bring it on top.

Creating a Solid Fill
1. Select the objects which represent a closed boundary. The closed boundary 

may include cutout areas like a hole. Select both the outside boundary and the 
hole.

2. Choose Pen>Solid Fill. The Fill dialog box appears.

3. Enter a Tolerance for the fill.

The tolerance controls how smooth the 
linearization is for fills in circles, arcs, 
ellipses and closed splines. Increasing 
the value of Tolerance makes the fill 
smoother. The default value is 0.01 (A 
value of 0.001 produces smoother 
edges than .01. This is also affected by Drawing Scale.)

4. Click Apply.

The selected object fills with the current pen color.

Changing the Color of an Existing Solid Fill
1. Select the existing solid fill by clicking it with the Selection tool.

2. In the Pen menu, choose a new color from the Color submenu.

The Fill color changes as specified and is visible as soon as the solid fill is 
deselected. 

Changing the Tolerance of an Existing Solid Fill
1. Select the existing solid fill by clicking it with the Selection tool.

2. Choose Pen>Solid Fill.

3. Change the Tolerance and press Apply.

The Tolerance may also be changed using the Edit Objects dialog box.
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Tech Note:

Arrowheads for 
dimensions are controlled 
with commands from the 
Dimensions menu.

Tech Note:

The size of the dimension 
arrowheads is set using 
the Arrow Size command 
from the Dimensions 
menu.
Fill Command 

CTRL+B (Windows); +B (Macintosh)

This command is located in the Pen menu and fills the selected objects using the 
current pen color. To change the fill color, in the Pen menu, change the color from 
the Color submenu.

Fill with the Current Pen Color
1. Select the object to fill.

2. Choose Pen>Fill.

The selected area fills with the current pen color.

Arrowheads
To use arrowheads on lines or circular arcs that are not a part of dimensions, 
specify the placement of arrowheads in the Pen menu. An arrowhead may appear 
at the beginning or end of a line or circular arc, or at both the beginning and end.

Width of Arrowhead
The width of the arrowhead is based on the text size.

Arrowhead Types
Use the Arrowheads submenu to set one of eight arrowheads for arrow lines.
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Tip:

Add or remove arrows to 
or from lines and arcs 
using the Edit Objects 
dialogue box.
Arrow at Start Command
This command in the Pen menu places an arrowhead at the beginning of any 
selected and subsequent lines and circular arcs. Choose the type of arrowhead 
from the Pen menu. A check mark indicates the current arrowhead setting. 
Change the default setting by saving changes in the preferences file.

Arrow at End Command
This command in the Pen menu places an arrowhead at the end of selected and 
subsequent lines and circular arcs. Choose the type of arrowhead from the Pen 
menu. A check mark indicates the current arrowhead setting. Change the default 
setting by saving changes in the preferences file.

The start and end of a line and an arc are determined by the point that was 
created first.

No Arrow At Start No Arrow At End

Arrow  At Start No Arrow At End

No Arrow At Start Arrow At End

Arrow At Start Arrow At End
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Dimensions
This chapter explains how to use the Dimension tools in Graphite. The topics 
covered include:

• Associative Dimensions

• Dimensioning Overview

• The Dimension Tools

• Dimension Appearance

• Parametric Dimensions
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Associative Dimensions
Graphite’s geometric dimensions are associative. This means that when a change 
is made to the geometry, the dimension changes also. This is not true if a manual 
dimension was entered in order to use parametrics, such as a value for the # in 
the dimension text data field).

This associativity is a tremendous time saver because dimensions automatically 
update whenever a change in the geometry is made. Change the units from 
English to metric, using the Preferences submenu in the Layout menu, and every 
dimension on the drawing reflects the change.

When extending a line by selecting the endpoint of the line and dragging it to a 
new position, the dimension changes also, because the dimension has a control 
point at the same position of the line endpoint. So when selecting the endpoint of 
the line is selected, the dimension control point must be selected also.

Dimensions are associative relative to the points they measure. When changing 
the length of a line using the Edit Objects dialog box, the dimension will not update 
because the point was not changed. To correct the dimension, select the 
dimension’s vertex point and drag it to the new endpoint of the line.

40Endpoints

Line
endpoint

Dimension control point
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Dimensioning Overview

Dimension Tool Palette
Graphite’s individual Dimensioning tools are in the main tool bar of the main 
Graphite palette. 

These tools are used to measure either an object or the area between objects. 

Once an object (or space) is dimensioned, the dimensions update when the 
changes are made to the geometry.

Like all palettes in Graphite, the Dimension palette can be torn off and positioned 
anywhere in the drawing area by clicking on the tear-off icon at the end of the fly-
out palette and moving it as desired. Change the orientation of the palette by 
choosing either Vertical or Horizontal option in Layout>Preferences>Dimensions 
Palette Orientation.
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Four tools on the Dimension palette have subpalettes for base line, chain, and 
ordinate style dimensions. To access these subpalettes it is necessary to tear off 
the Dimensions palette.

Some of the Dimensioning tools, such as the Horizontal and Vertical tools, 
require that two points be selected. Others, such as the Radial and Diametral, 
require only one point.

Save the location and the status (on/off) of the Dimension palette by choosing 
Layout>Preferences>Save Palettes.
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Dimension Menu
The Dimension menu contains commands for setting the format and tolerance limits 
for dimensions. These commands are discussed in detail further on in this chapter 
under Dimension Appearance.

Dimensioning and the Work Plane
Dimensions appear in the current work plane of the active view. Set the work 
plane to correspond to the view before adding text or dimensions in a view. 

For example, if the current work plane is the top plane, then the dimensions will 
appear parallel to the work plane regardless of the view. See the graphic on the 
next page. 

All point to point dimensions are also placed parallel to the work plane. Working in 
the front plane and using the Horizontal Dimension tool, the dimension is placed 
parallel to the front plane.

1.500
1.434

1.624
2.000
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Tech Note:

Steps #4 and #5 must be 
done in order. If the entry in 
the text box is changed and 
then ENTER (Windows) or 
RETURN (Macintosh) is 
pressed, the dimension 
cannot be moved, because it 
is no longer selected. To 
move a dimension, select it 
and drag it to the desired 
location.
Dimensioning Objects and Placement
1. If necessary, display the Dimension palette.

2. Select the appropriate dimension tool.

The dimension pointer is a smart pointer with a hot spot. The dot shows which 
side of the object to select first. Select as indicated by the position of the dot for 
the text to appear above or to the right of the leader. If selected in the opposite 
order, the text appears below or to the left of the leader.

3. Click the points to measure.

Dimensions automatically use the dimension pen style and current dimension 
text characteristics. To change the dimension pen color or weight, use the 
Dimension menu. The dimension pattern is changed in the Edit Object dialog 
box for dimensions that are selected.

4. Move the dimension to a new location as desired. (See the margin note.) 

5. When using the dimension with parametrics, change the entry in the text data 
field on the Status Line.
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Moving the Dimension
When the dimension text appears, it is selected so that it can be moved to a new 
location. Move the pointer to the dimension text. When the pointer changes to the 
4-way Move symbol (the picture bellow), drag the dimension to its new location.

To move a dimension later, use the Selection tool. Click the dimension once, then 
drag it to the new location. 

Also drag to select the 
dimension text or to select the 
entire dimension or several 
dimensions at once.

Using the Dimension Status Line Fields
The status fields shown below appear when a dimensioning tool is selected.

Text The # symbol in the text data field indicates that 
the dimension is the actual value of the object’s 
measurement. If this symbol is deleted, the 
dimension is no longer associative (it doesn’t 
update if the geometry is changed).

When using parametrics, delete the # symbol and 
enter values, algebraic expressions, or variables 
in the text data field. Parametrics are described in 
Chapter 16.

Some of the dimensioning tools, such as the 
Radial tools, add a letter in the text status data 
field which appears in the dimension itself. Add 
text before or after the # symbol and to enter 
parentheses to enclose the resulting dimension in 
parentheses. When the # symbol is included, 
Graphite uses the measurement of the geometry 
as well as the text added.

Tolerance The Upper and Lower fields appear if a tolerance 
format is specified (in the Linear or Angular 
submenu of the Dimension menu). Enter the limits 
for the tolerance in these fields.

1.524 1.524

# .001 -.001Text Upper Lower
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Automatically Placing Dimensions on a Separate Layer
Graphite automatically creates a dimension layer unless it is removed from the 
prefs.vc6 (Windows) or the Graphite prefs (Macintosh) file. To create a dimension 
layer, do the following:

1. Create a layer named Dimension. (This name must be spelled correctly.) The 
dimension layer does not need to be the work layer. 

2. Dimension as usual. Subsequent dimensions automatically go on the 
dimension layer rather than the work layer.

Adding Tolerance and Limits
1. From the Dimension menu, choose the desired style, either Linear or Angular.

2. Create the dimension.

3. Enter the values in the Status Line for upper and lower tolerance limits and 
press ENTER (Windows) or RETURN (Macintosh).

Using Fixed Dimensions
Delete the # symbol in the text data field (on the Status Line for a newly-created 
dimension or in the Edit Objects dialog box) and replace it with other text. The 
entry in the text data field is now fixed. It does not update if the units or the size of 
the geometry is changed. 

Adding Special Symbols to Dimension Text
It is possible to add special symbols to the dimension text. To add a special 
symbol:

1. Select the desired dimension.

2. Open the Edit Objects dialog box. Next to the Text entry field there is  
button. Click the button and a drop down list of symbols appears. Choose the 
necessary symbol.

3. Click ENTER. The symbol appears in the dimension text.
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The Dimension Tools

Automatic Dimensions
Auto Dimensioning is a convenient way to add dimensions to drawings quickly and 
easily. If more control over the dimension is desired, such as the style or tolerances, 
use the individual dimensioning tools.

Automatic Dimensioning Tool

This tool automatically dimensions lines (independently 
from their angle), circles, ellipses and arcs.

Using the Automatic Dimensioning Tool.
1. Choose the Automatic Dimensioning tool. The Message Line reads, 

Automatic Dimensioning: Select object for Auto dimensioning.

2. Click at each object with the Automatic Dimensioning tool.

All lines are dimensioned correctly. All circles, arcs and ellipses are dimensioned 
with a radial dimension.
12-9
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Horizontal Dimension Tools
These tools measure horizontal spaces or the distance between linear 
objects. To access this subpalette, tear off the Dimension palette from 
the main tool bar.

Horizontal Dimension Tool

This tool dimensions an object or space horizontally.

Using the Horizontal Dimension Tool
1. Select the Horizontal Dimension tool. The Message 

Line reads, Horizontal: Pick first dimension point. The 
Message Line guides each successive step.

2. Click the left point of the geometry. 

3. Click the right point. 

The dimension appears. Drag it to a new location. Dimension and extension 
lines automatically redraw.

Click the points in the opposite order to display the dimension below the objects.

When the dimension text appears, drag it to a new location. Release the mouse 
button and the dimension and extension lines are redrawn.

.797
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Tip

To access the subpalette, tear 
off the Dimension palette 
from the main tool bar.
Horizontal Base Line Dimension Tool

This tool dimensions objects or spaces 
horizontally from a base point.

Using the Horizontal Base Line Dimension Tool
1. Select the Horizontal Base Line Dimension 

tool. The Message Line reads, Horizontal 
Base Line: Pick first dimension point. The 
Message Line guides each successive step.

2. Click the base point of the geometry. 

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears above the first, 
measured from the base point. Continue clicking the points to be 
dimensioned. Drag each dimension to a new location. Dimension and 
extension lines automatically redraw.

Click the points in the opposite order to display the dimension below the objects.

Horizontal Chain Dimension Tool

This tool dimensions objects or spaces 
from end-to-end, horizontally.

Using the Horizontal Chain Dimension Tool
1. Select the Horizontal Chain Dimension tool. The Message Line reads, 

Horizontal Chain: Pick first dimension point. The Message Line guides each 
successive step.

2. Click the first point on the geometry. 

3. Click the second point. The dimension appears.

4. Click the next place for the dimension. This dimension appears, measured 
from the last point clicked. Continue clicking all the points to be dimensioned. 
Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Click the points in the opposite order to display the dimension below the objects.
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2.470

.802 1.106 .653
12-11



12-12

Dimensions Ashlar-Vellum
Horizontal Ordinate Dimension Tool

This tool dimensions objects or spaces 
horizontally from a base point.

Using the Horizontal Ordinate Dimension Tool
1. Select the Horizontal Ordinate Dimension 

tool. The Message Line reads, Horizontal 
Ordinate: Pick first dimension point. The 
Message Line guides each successive step.

2. Click the base point of the geometry. 

3. Click the second point. The dimension appears, measured from the base 
point.

4. Click the next point for the dimension. This dimension appears measured from 
the base point. Continue clicking all the points to be dimensioned. To display a 
dimension at the base point, click the base point after having dimensioned all 
other points.

Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Reminder: To display the dimension number of the base point, click it at both the 
first and the last dimension points.
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Vertical Dimension Tools
These tools measure vertical space or the distance between vertical 
objects. To access this subpalette, tear off the Dimension palette from 
the main tool bar.

Vertical Dimension Tool

This tool dimensions an object or space vertically. Click the top 
point first, then click the bottom.

Using the Vertical Dimension Tool
1. Select the Vertical Dimension tool. The Message Line reads, 

Vertical: Pick first dimension point. The Message Line guides 
each successive step.

2. Click the top point of the geometry first.

3. Click the bottom point. 

The dimension appears. Drag it to a new location. Dimension and extension 
lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

4.000
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Vertical Base Line Dimension Tool

This tool dimensions objects or space vertically 
from a base point.

Using the Vertical Base Line Dimension Tool
1. Select the Vertical Base Line Dimension 

tool. The Message Line reads, Vertical Base 
Line: Pick first dimension point. The 
Message Line guides each successive step.

2. Click the base point of the geometry. 

3. Click the second point. The dimension appears.

4. Click the next place for the dimension. This dimension appears to the right of 
the first, measured from the base point. Continue clicking all the points to be 
dimensioned. Drag each dimension to a new location. Dimension and 
extension lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

.424
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Tip

To access the subpalette, 
tear off the Dimension 
palette from the main tool bar.
Vertical Chain Dimension Tool

This tool dimensions objects or space from 
end-to-end, vertically.

Using Vertical Chain Dimension Tool
1. Select the Vertical Chain Dimension tool. 

The Message Line reads, Vertical Chain: Pick 
first dimension point. The Message Line 
guides each successive step.

2. Click the first point on the geometry. 

3. Click the second point. The dimension 
appears.

4. Click the place for the dimension. This dimension appears, measured from the 
last point clicked. Continue clicking all the points to be dimensioned. Drag 
each dimension to a new location. Dimension and extension lines 
automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

.313

1.096
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Vertical Ordinate Dimension Tool

This tool dimensions objects or space vertically from a 
base point.

Using the Vertical Ordinate Dimension Tool
1. Select the Vertical Ordinate Dimension tool. The 

Message Line reads, Vertical Ordinate: Pick first 
dimension point. The Message Line guides each 
successive step.

2. Click the base point of the geometry. 

3. Click the second point. The dimension appears, measured from the base 
point.

4. Click the next point for the dimension. This dimension appears measured from 
the base point. Continue clicking all the points to be dimensioned. To display a 
dimension at the base point, click the base point after having dimensioned all 
other points.

Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Reminder: To display the dimension number of the base point, click it twice at both 
the first and the last dimension points.
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Oblique Dimension Tools
These tools measure space or objects, obliquely or point to point. To 
access this subpalette, tear off the Dimension palette from the main tool 
bar.

Oblique Dimension Tool

This tool dimensions an object or space from point 
to point or obliquely.

Using the Oblique Dimension Tool
1. Select the Oblique Dimension tool. The 

Message Line reads, Oblique: Pick first 
dimension point. The Message Line guides each 
successive step.

2. Click the left point first. 

3. Click the right point. The dimension appears. Drag it to a new location. 
Dimension and extension lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

1.134
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Oblique Base Line Dimension Tool

This tool dimensions objects and spaces 
point-to-point or obliquely from a base point. The 
results shown reflect colinear dimension points.

Using the Oblique Base Line Dimension Tool
1. Select the Oblique Base Line Dimension 

tool. The Message Line reads, Oblique Base 
Line: Pick first dimension point. The Message 
Line guides each successive step.

2. Click the base point of the geometry.

3. Click the second point. The dimension appears.

4. Click the next place for the dimension. This dimension appears to the right of 
the first, measured from the base point. Continue clicking all the points to be 
dimensioned. Drag each dimension to a new location. Dimension and 
extension lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

1.934
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Tip

To access the subpalette, 
tear off the Dimension 
palette from the main tool bar.
Oblique Chain Dimension Tool

This tool dimensions objects and spaces point-
to-point, end-to-end.   The results shown reflect 
colinear dimension points.

Using Oblique Chain Dimension Tool
1. Select the Oblique Chain Dimension tool. 

The Message Line reads, Oblique Chain: 
Pick first dimension point. The Message Line 
guides each successive step.

2. Click the first point on the geometry. 

3. Click the second point. The dimension appears.

4. Click the next place for the dimension. This dimension appears, measured 
from the last point clicked. Continue clicking all the points to be dimensioned. 
Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Click the points in the opposite order for the dimension to display on the other 
side of the objects.

4.243

4.243

4.243
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Tip

To access the subpalette, 
tear off the Dimension 
palette from the main tool 
bar.
Perpendicular Dimension Tools
These tools measure an object or space perpendicular to another line. If 
most of the dimensions start from a line edge, use this tool to generate 
both horizontal and vertical dimensions.

For 3D geometry, perpendicular dimensions are created in the plane of 
the baseline. To access this subpalette, tear off the Dimension palette 
from the main tool bar.

Perpendicular Dimension Tool

This tool dimensions an object or space perpendicular to a 
line.

Using the Perpendicular Dimension Tool
1. Select the Perpendicular Dimension tool. The 

Message Line reads, Perpendicular: Pick first 
dimension point. The Message Line guides each 
successive step.

2. Click the base line. Be certain to click on the base line, not on the endpoint of 
the base line. 

3. Click the object or location.

The dimension appears. Drag it to a new location. Dimension and extension 
lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

6.549
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Perpendicular Base Line Dimension Tool

This tool dimensions between a point or object 
perpendicular to an existing base line.

Using the Perpendicular Base Line 
Dimension Tool
1. Select the Perpendicular Base Line 

Dimension tool. The Message Line reads, 
Perpendicular Base Line: Pick first 
dimension point. The Message Line guides each successive step.

2. Click the base point of the geometry. 

3. Click the second point. The dimension appears.

4. Click the next place for the dimension. This dimension appears above the first, 
measured from the base point. Continue clicking the points to be 
dimensioned. Drag each dimension to a new location. Dimension and 
extension lines automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

6.549

9.019
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Perpendicular Chain Dimension Tool

This tool dimensions between points or 
objects perpendicular to an existing baseline.

Using the Perpendicular Chain Dimension 
Tool
1. Select the Perpendicular Chain 

Dimension tool. The Message Line 
reads, Perpendicular Chain: Pick first 
dimension point. The Message Line guides each successive step.

2. Click the first point on the geometry. 

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears, measured 
from the last point clicked. Continue clicking all the points to be dimensioned. 
Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Click the points in the opposite order to display the dimension on the other side 
of the objects.

2.470

6.549
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Perpendicular Ordinate Dimension Tool

This tool dimensions between a point or object 
perpendicular to an existing base line.

Using the Perpendicular Ordinate Dimension 
Tool
1. Select the Perpendicular Ordinate 

Dimension tool. The Message Line reads, 
Perpendicular Ordinate: Pick first dimension 
point. The Message Line guides each successive step.

2. Click the base point of the geometry. 

3. Click the next point. The dimension appears, measured from the base point.

4. Click the next point for the dimension. This dimension appears measured from 
the base point. Continue clicking all the points to be dimensioned. To display a 
dimension at the base point, click the base point after having dimensioned all 
other points.

Drag each dimension to a new location. Dimension and extension lines 
automatically redraw.

Reminder: To display the dimension number of the base point click both the first 
and last dimension points.

4.243

4.243

4.243
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Radial & Diametral Arrow Dimension Tools 
These tools measure the radial or diameter, placing the arrow inside or outside the 
object as designated by the appropriate tool name. 

Radial Arrow Out Dimension Tool

This tool measures the radius of a circle, 
arc, or fillet.

Using the Radial Arrow Out Dimension Tool
1. Select the Radial Arrow Out Dimension tool. The Message Line reads, 

Radial Arrow Out: Select arc/circle. The Message Line guides each successive 
step.

2. Click near the circle, arc or fillet to be dimensioned. Click inside or outside the 
object depending on where the dimension should appear.

The dimension is placed for the selected object. When the dimension appears 
the leader line is placed at the nearest 15° increment from the location clicked. 
Drag the text to a new location.

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. 

R 2.741

R 2.741
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Radial Arrow In Dimension Tool

This tool measures the radius of a 
circle, arc, or fillet with the arrow 
inside the geometry.

Using the Radial Arrow In Dimension Tool
1. Select the Radial Arrow In Dimension tool. The Message Line reads, Radial 

Arrow In: Select arc/circle.

2. Click near the circle, arc or fillet to dimension. Click inside or outside the object 
depending on where the dimension should appear. Either way the arrow line 
starts from the arc center.

The dimension text appears for the object. The arrow line starts from the arc 
center. When the dimension appears, the leader line is placed at the nearest 
15° increment from the location clicked. Drag the text to a new location.

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. 

Diametral Arrow Out Dimension Tool

This tool measures the diameter of a circle. 

Using the Diametral Arrow Out Dimension Tool
1. Select the Diametral Arrow Out Dimension tool. The Message Line reads, 

Diametral Arrow Out: Select arc/circle.

2. Click near the circle or arc to be dimensioned. Click inside or outside the 
object depending on where the dimension should appear.

The dimension appears for the object. When the dimension appears, the leader 
line is placed at the nearest 15° increment from the location clicked. Drag the 
text to a new location. Change the position of the arrow by dragging a selection 
fence around the control point at the tip of the arrow, and then dragging the 
arrow to a new location.

For 3D geometry, diametral dimensions are created in the plane of the circle.

R 2.385

R 2.385

Ø .838

Ø .838
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Diametral Arrow In Dimension Tool

This tool measures the diameter of a 
circle.

Using the Diameter Arrow In Dimension Tool
1. Select the Diametral Arrow In Dimension tool. The Message Line reads, 

Diametral Arrow In: Select arc/circle.

2. Click near the circle or arc to be dimensioned. Click inside or outside the 
object depending on where the dimension should appear.

The dimension appears for the object (depending on the circle and font size). 
When the dimension appears, the leader line is placed at the nearest 15° 
increment from the location clicked. Drag the text to a new location.

For 3D geometry, diametral dimensions are created in the plane of the circle.

Ø.838 Ø.838
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Additional Dimension Tools

Angular Dimension Tool

This tool measures the angle between two lines.

Using the Angular Dimension Tool
1. Select the Angular Dimension tool. The Message Line reads, Angular: Pick 

first line. The Message Line guides each successive step.

2. Click on the first line near the endpoint from which the angle is measured.

3. Click near the endpoint of the second line.

The inside angle is measured between the lines. The smaller angle is used.

The angle between the endpoints of the lines is measured so that it is necessary to 
only click near the end points, not exactly on them. Graphite interprets all mouse 
clicks left of the line midpoint as the left endpoint and all mouse clicks right of the 
line midpoint as the right endpoint.

When dimensioning intersecting lines it 
is important to not confuse the 
intersection with the midpoint of the 
lines.

left endpoint

Clicking here means left
endpoint

Clicking here means
right endpoint

midpoint

right endpoint

midpoints

intersection

To dimension this angle...

...you have to click here
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If the lines don’t meet, the angle is measured from the invisible extension of the 
lines. The extension appears as part of the dimension. 

When the dimension text appears, drag it to a new location. When releasing the 
mouse button, the dimension and extension lines are redrawn.

Angular dimension displays all angles properly if the angles are larger than 3 
degrees. For smaller than that, build the dimensions manually using lines and text 
objects.

The Angular Dimension tool does not dimension angles over 180°.

For 3D geometry, Angular dimensions are created in the plane of the two lines.

45

135

45

135

Click here Click here

Click here Click here
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Arc Length Dimension Tool

This tool measures the length of an arc.

Using the Arc Length Dimension Tool
1. Select the Arc Length Dimension tool. The 

Message Line reads, Arc Length: Pick start 
point on the arc. The Message Line guides each 
successive step.

2. Select the start point. 

3. Select a point on the arc. 

4. Select the opposite end of the arc. 

Drag the text to the desired position. 

The Arc Length Dimension tool does not put witness lines perpendicular to the 
arc for angles less than 180 degrees.

Circle Center Line Dimension Tool

This tool creates a center line for any circle being created. It 
also optionally displays a thread symbol with the center line.

Using the Circle Center Line Dimension Tool
1. Choose the Circle Center Line tool. The Message Line 

reads, Circle Center Line: Select circle.

2. Click on the circle with the tool.

Pressing the CTRL (Windows) or the OPTION (Macintosh) key while clicking on 
the circle adds a thread symbol.

3. In the Axis overlap data field of the Status Line, enter the desired axis overlap.

4. Press the ENTER (Windows) or the RETURN (Macintosh) key.

A circle center line with an optional thread symbol is added to the circle with the 
specified overlap.

The Status Line sets the Axis 
overlap.

Axis Overlap
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Balloon Dimension Tool
This tool attaches a balloon symbol to geometry 
in the location clicked.

Using a Balloon Dimension Tool
1. Select the Balloon Dimension tool. The 

Message Line reads, Balloon: Pick geometry to point to. The 
Message Line guides each successive step.

2. Click the point on the geometry for the dimension arrow. 

3. Click the second point to specify the location of the balloon.

The balloon symbol appears. 

4. Enter the text and frame width in the Status Line data fields. Press 
ENTER (Windows) or RETURN (Macintosh) to update the 
dimension.

Move the dimension by dragging the text to a new location.

Balloon dimension text does not increment while placing additional 
balloons. Enter specific text in the balloon dimension, if necessary.

The Status Line contains Text and Width data fields.2

B
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Tip:

To change from decimal to 
fractional dimensions use 
Layout>Preferences>
Units.
Dimension Appearance
Graphite automatically creates dimensions according to 
ANSI Y14.5, DIN, ISO or JIS standards. Many companies 
and individuals, however, have developed their own 
standards. The commands in the Dimension menu control 
virtually every aspect of the dimension appearance, without 
having to construct dimensions manually and while retaining 
the associativity of Graphite’s smart dimensions.

Settings made in the Dimension menu affect the currently 
selected dimension and all future dimensions.

Linear Dimensions

Fractional Display or Decimal Display
To change the current linear appearance of the dimensions, 
first change the precision setting in the Units dialog box.

Choose Layout>Preferences>Units. In the Units dialog 
box, change the Precision to a decimal or fractional option 
by holding down the mouse button on the arrow to the right 
of the data field and scrolling to the desired precision. That 
precision is now displayed in the Status Line data fields. 

Graphite still calculates out to sixteen decimal places, however, the Status Line 
displays the nearest fraction or decimal to the calculated value based on the 
precision selected.
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Linear
This command in the Dimension menu sets the precision of the dimension’s 
nominal value, and the format of its tolerance and limits. Dimensions may be 
shown as either decimals or factions, as designated in the Preferences settings. 
The default is decimals with three decimal places (or x/16 if set to fractions) with 
no tolerance or limits.
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Dimension Tolerance
The following graphic shows the appearance of each tolerance format, the limits 
shown in the Status Line bellow are entered.

Dual Dimensioning
Dual dimensioning displays the dimensions in 
both inches and millimeters by selecting the 
inches/mm under Dimensions>Linear.

1.391

1.391?.003

1.391+.003
-.001

1.394
1.390

1.394

1.391

1.391

-   1.390

xxx

xxx?tol

xxx+upper/-lower

xxx/yyy [limits]

yyy-xxx
[limits]

[xxx] [basic]

_xxx_ (not to
scale)

Upper Lower.003 -.001

inches/mm

1.391
35.331
12-33



12-34

Dimensions Ashlar-Vellum
Linear Tolerance
The Linear Tolerance command in the 
Dimension menu sets the precision of a 
linear dimension's tolerance values.

Angular Dimensions

Angular
The Angular command in the 
Dimension menu sets the format for 
Angular dimensions. 

It is possible to set degrees, minutes 
and seconds as well as the tolerance 
and limits for these dimensions.
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Tech Note:

Use the [xxx] (basic) format 
to create dimensions for 
GD&T symbols.
The default format is degrees with no minutes or seconds and no tolerance or 
limits. The graphic here shows the appearance of each tolerance format as if 
entered with the limits shown in the Status Line.

Angular Tolerance
The Angular Tolerance command in the 
Dimension menu sets the precision of an 
angular dimension’s tolerance values.
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Text Characteristics 
Characteristics set here affect dimensions only. To change the style of text within 
text boxes, use the Text menu.

Text
The Text command in the Dimension menu 
specifies the position and orientation for 
dimension text.

The default is Horizontal text. The Break-in, 
Over and Under options produce text that is 
aligned with dimension leader lines. Over and 
Under display text above or below leader lines, 
while Break-in places the text between leader 
lines.
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Tech Note:

The Font command only 
affects dimensions. To 
change the font of other text 
objects, choose Text>Font.

The Font submenu in the Text 
menu has no effect on 
dimensions. Use the Font 
command from the 
Dimension menu to specify 
the font for dimension text.

Tech Note:

The Size command only 
affects dimensions. To 
change the size of other text 
objects, use Edit Objects or 
the Size submenu from the 
Text menu.

The size submenu from the 
Text menu has no effect on 
dimensions.
Font
The Font command in the 
Dimension menu picks the font 
for dimension text. The fonts in 
this list are the same as those 
available in the Font submenu 
from the Text menu. 

Windows: additional fonts are 
accessed by choosing the More 
command.

Size
The Size command in the Dimension menu 
picks the size of dimension text only. The 
sizes in this list are the same as those 
available in the Size submenu from the 
Text menu.

Selecting the Other option specifies a non-
standard font size for dimension text.
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Tech Note:

The Style command only 
affects dimensions. To 
change the style of other text 
objects, use the Style 
submenu from the Text 
menu.

The Style submenu from the 
Text menu has no effect on 
dimensions. 

Tech Note:

The Color command only 
affects dimensions. To 
change the color of other 
objects, use Edit Objects or 
the Color submenu from the 
Pen menu.

The Color submenu from the 
Pen menu has no effect on 
dimensions.
Style
The Style command in the Dimension menu 
designates the style of dimension text. The 
styles in this list are the same as those 
available in the Style submenu from the Text 
menu, however, the settings here do not affect 
those in the Text menu.

Other Characteristics

Color
The Color command in the Dimension menu 
sets the color of the dimension. 

The default color is blue.
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Tech Note:

The Weight command only 
affects dimensions. To 
change the weight of other 
objects, use Edit Objects or 
the Weight submenu from the 
Pen menu.

The Weight submenu from 
the Pen menu has no effect 
on dimensions. 

The values shown in the 
Weight submenu may be 
different if the available line 
weights have been changed 
using the Pen Weight Editor.
Weight
The Weight command in the Dimension menu specifies the weight of dimension 
lines. Dimension lines are typically drawn in the thinnest weight available. For 
Graphite, that is 0.002" or 0.05mm.

The default weight is 0.002" or 0.05mm.
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Tech Note:

The layers in the list will be 
different than the ones shown 
here if layers have been 
added or any of the default 
layers have been deleted.
Layer
The Layer command in the Dimension menu specifies the layer on which 
dimensions are placed. Dimensions can be placed on any visible layer.

The default layer is the Dimension layer. If the layer on which dimensions are to be 
placed is hidden or deleted, future dimensions will be placed on the current work 
layer.
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Tech Note:

The Arrowheads command 
only affects dimensions. To 
select the arrowhead type for 
lines or arcs, use the 
Arrowheads submenu from 
the Pen menu.

The Arrowheads submenu 
from the Pen menu has no 
effect on dimensions.
Arrowheads 
The Arrowheads command in the Dimension menu sets the type of arrowhead 
used for dimensions.
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Arrow Size Command
The Arrow Size command in the Dimension menu specifies the size of the 
arrowhead that has been selected.

Dot Size: Describes the diameter of circular and slash 
arrowheads. The value displayed is in the current 
units specified in the Units dialog box from the 
Preferences command.

Length: Describes the length of the arrowhead as the 
horizontal distance from its tip to the furthest 
extension of its base.

Height: Describes the height of the arrowhead as the 
vertical distance from its base.

Side: Describes the length of the edge of the 
arrowhead.

Angle: Describes the angle of the tip of the arrowhead.

By changing any value in the Length, Height, Side, or Angle entry data fields, 
Graphite changes the values in the other entry data fields accordingly.
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Tip:

Witness Lines for existing 
linear dimensions can also be 
toggled on or off in Edit 
Objects.
Witness Lines
The Witness Lines command in the Dimension menu designates which sides of 
the linear dimension should have witness lines. A check mark indicates that a 
witness line is placed at the specified location. This option is useful for plotting a 
drawing that contains baseline or chain dimensions. By turning off one or more of 
the overlapping witness lines, the plotter is prevented from drawing multiple 
witness lines when only one is needed.

The Start of a dimension is the first point clicked. The End of a dimension is the 
last point clicked. The default settings have witness lines at both the start and end 
of a dimension.

This command affects only linear dimensions. Radial and diametral dimensions 
are not affected by the settings made in the Witness Lines command.
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Dimension Standards
The Dimension Preferences dialog box is opened by choosing 
Dimension>Standards. This dialog box sets the standard that the dimensions will 
follow, as well as defines the characteristics for the standard. Most changes made 
in the Dimensions Standards dialog box affect currently selected dimensions and 
newly created ones. Changes made to the First Offset and the Next Offset affect 
only newly created dimensions.

Changing the standard also changes the Dimension menu settings. Setting 
dimension standards saves the values in the Dimension Standards dialog box as 
well as the settings in the Dimension menu, except for the Witness Lines 
command.
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Standard Designates the standard the dimensions will 
follow. Graphite provides settings for ANSI, DIN, 
ISO and JIS standards. The Other setting in the 
pull down list creates custom settings or enables 
changes to one of the supplied standard settings.

The Set button maps the current settings to the 
standard that appears in the pull-down list. It also 
saves all of the settings from the Dimension 
menu.

The Default button reverts to the factory settings 
of the selected standard.

Text Offset Sets the distance from the base of the dimension 
text to the leader lines. A positive entry places the 
text above the leader lines, and a negative value 
places it below the leader lines. A zero value 
places the text on the leader lines.

Gap Provides the distance between the dimension 
point and the witness line.

Extension Sets the distance the witness lines extend beyond 
the leader lines.

Arrow Leader Sets the distance the leader lines extend beyond 
the witness lines when the arrow lines appear 
outside of the witness lines.

First Offset Designates the perpendicular distance between 
object being dimensioned and the leader line and 
dimension text.

Changes to this value only affect newly created 
dimensions.

Next Offset Sets the perpendicular distance between 
subsequent leader lines created in a base line 
dimensioning.

Changes to this value only affect newly created 
dimensions.

Leading 0’s Determines whether Dimension or Tolerance 
values display leading or trailing zeros. Neither 
option is selected by default. 

&Trailing 0’s
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Selecting Leading 0's places a 0 before all 
dimensions that are less than 1. 

Selecting Trailing 0's places 0's after the decimal 
point. This option is affected by the precision set 
in Layout>Preferences>Units. Example: If the 
precision is set at .001, a measurement of three 
inches is displayed as 3.000.

These options do not apply to dimensions 
displayed in fractions.

Solid Leader Determines whether the leader lines that appear 
outside of the witness lines are connected with 
another line. The default value does not place this 
line.

Tolerance Text Size % Specifies the size of the tolerance text as a 
percentage of the nominal value. The default 
value is 100%, the same size as the nominal 
value.

Clicking OK accepts the changes made and closes the Dimension Standards 
dialog box. Clicking Apply affects any changes made in the Dimension Standards 
dialog box to any currently selected dimensions without closing the dialog box. 
Clicking Cancel ignores any changes and closes the Dimension Standards dialog 
box.

GD&T 

See Chapter 20 for information about the U.S. government standard called 
Geometric Dimensioning and Tolerancing.
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Parametric Dimensions
Objects must be dimensioned in order to use the parametrics feature. Specify 
values, variables, or expressions for each dimension. Parametrics are discussed 
in detail in Chapter 16.

Creating a Parametric Dimension
1. Create the dimension as usual.

The Status Line displays a # symbol in the text data field. 

2. Enter a value (variable or algebraic expression) in the text data field.

The dimension reflects the value or variable entered, regardless of the actual 
value of the geometry just dimensioned. 

3. Continue dimensioning as needed to define the part completely.

4. Use the parametric feature as described in Chapter 16.

Converting Parametric Dimensions to Associative 
Dimensions
When bringing in a parameterized part with the Import command, the geometry is 
drawn as specified, but the dimensions display the variables and expressions 
which defined them as symbols. It is possible to change the dimensions to be 
associative so that they reflect the actual measurements of the geometry, even if 
the geometry is changed.

1. Select the dimensions. 

2. Choose Edit>Edit Objects.

3. Enter a # in the text data field.

4. Click Apply and close the dialog box. 

The parametric variable changes to reflect the geometry’s actual measurement.
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Viewing Geometry
Viewing Geometry
This chapter describes several Graphite features for viewing geometry in the 
drawing in different ways. The following topics are covered:

• Zooming and Panning

• Layers

• View Displays and Detail Views

• Light Settings

• Perspective

• Views Menu
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Tip:

Use the Zoom tools or Stroke 
zoom to zoom to a particular 
location.
Zooming and Panning
Graphite offers several ways to change the magnification of the drawing by 
zooming in and out using commands, zoom tools, and strokes.

Zoom Commands
Zoom In, Zoom Out, or Zoom All from the Arrange menu all change the view 
magnification of the geometry. The Zoom Previous command returns to the last 
magnification. To zoom on a particular area, use the Stroke feature or the Zoom In 
tool. Strokes are described later in this chapter.

Zoom All 

CTRL+F (Windows); +F (Macintosh)
The Zoom All command in the Arrange menu zooms in or out to make all objects 
on the drawing fill the screen, regardless of how big or small the objects are. 

Zoom In 

CTRL+] (Windows); +] (Macintosh)
The Zoom In command in the Arrange menu zooms in on the center of the screen 
by a factor of two. A particular area cannot be specified for enlargement. 

Zoom Out 

CTRL+[ (Windows); +[ (Macintosh)
The Zoom Out command in the Arrange menu zooms out from the center of the 
screen by a factor of two. The area of reduction can not be specified. 

Zoom Previous
The Zoom Previous command in the Arrange menu zooms to the previous 
magnification, up to five times.
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View Control Tools

Select the appropriate zoom tool from the View Control tool palette.

Using a Magnifying Glass Tool
With the Zoom tools, drag a box around an area on the screen, so only that area 
magnifies on the screen.

1. Select a Zoom tool from the tool palette.

2. With the mouse button pressed, drag a box around an area on the screen to 
magnify or reduce.

3. Release the mouse button.

The content of the dragged box is made visible on the screen.

Zoom In Tool

The Zoom In tool, zooms in by the specified factor. The default factor is two. This 
is a visual rather than a physical change.

Click in the drawing area and that position redisplays in the center of the screen 
with the drawing enlarged by a factor of two.

It is also possible to drag a box around an area, so only that area magnifies.

The Status Line shows the current zoom scale. Enter a different scale and press 
ENTER (Windows) or RETURN (Macintosh) for the new scale to take effect.

Pressing the CTRL (Windows) or the OPTION (Macintosh) key while using this 
tool causes it to change to the Zoom Out tool. 
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Tip:

Toggle between Zoom In and 
Zoom Out using the CTRL 
(Windows) or the OPTION 
(Macintosh) key.
Zoom Out Tool

The Zoom Out tool zooms out by the specified factor. The default factor is one 
half. This is a visual rather than a physical change.

Click in the drawing area and that position displays in the center of the screen with 
the drawing reduced by one half.

The Status Line shows the current zoom scale. Enter a different scale and press 
ENTER (Windows) or RETURN (Macintosh) for the new scale to take effect. 

Pressing the CTRL (Windows) or the OPTION (Macintosh) key while using this 
tool causes it to change to the Zoom In tool. 

Detail View Tool

The Detail View tool is discussed further in this chapter under View Displays.
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Stroke Zoom 
Use stroke commands to zoom in or out on the drawing. Stroke commands are 
useful because they don’t require getting out of the current tool in order to zoom. 
Hold down the SHIFT+CTRL keys (Windows) or the  key (Macintosh) and drag 
the pointer diagonally across the screen as described below. The pointer takes on 
the  shape when holding down the SHIFT+CTRL (Windows) or the  key 
(Macintosh) keys.

Using Stroke Zoom

Drag Diagonally Result

Upper left to lower right Zoom-in enlargement centered over the stroked 
area.

Lower right to upper left Reverses Zoom In stroke to the previous 
magnification. 

Upper right to lower left Zoom-out reduction of the current screen to the 
size of the area defined by the stroke. 

Lower left to upper right Reverses Zoom Out stroke to previous 
magnification.

Note: For Zoom In and Zoom Out, the size and location of the stroke rectangle is 
important for determining the result of the Zoom operation. For Zoom Previous, 
the size and location of the stroke rectangle is irrelevant. All cases just give the 
previous magnification.
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Mouse Scroll Wheel Zoom
The mouse scroll wheel zooms in and out of a Graphite drawing using the cursor 
as the anchor point.

Using the Mouse Scroll Wheel to Zoom
To zoom in:

1. Place the cursor at the desired area to anchor the zoom.

2. Scroll the mouse button backwards.

The drawing zooms closer keeping the cursor in the same position.

To zoom out:

1. Place the cursor at the desired anchor point.

2. Scroll the mouse wheel forwards.

The drawing zooms out keeping the cursor in the same position.     

Miscellaneous Tools

The Orbit tool rotates the sheet camera around the 3D model. The 3D objects are 
fixed even if it gives the impression that they are moving. The Pan tool moves the 
sheet camera in the x and y directions. Panning past the document edges 
automatically scrolls the view in that direction. The Measuring tool displays the 
distance between two points.

Using the Orbit Tool
1. Select the Orbit tool from the tool palette.

2. Drag across the screen in the desired direction to move around the geometry.

The camera moves in increments of about 90 degrees with each stroke.

Using the Pan Tool
1. Select the Pan tool from the tool palette.

2. Drag across the geometry in the desired direction.

3. Hold the cursor at the edge of the window for the geometry to continue 
scrolling in that direction. 

4. Hold the cursor on the edge of the opposite window to move it back.
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Using the Measuring Tool
1. Select the measuring tool from the tool palette.

2. Click the first point from which to begin the measure.

3. Click the end point.

The distance displays in the status box at the bottom of the screen.

Spacebar Pan
Use the spacebar to activate the dynamic pan tool while within any 
operation except text.

1. Place the cursor over the portion of the drawing to move.

2. Hold down the spacebar. The cursor changes to the hand.

3. Move the cursor in the drawing area in any direction.

The drawing dynamically moves at the same zoom level.

Layers
Layers are like pages, some transparent and some invisible. Use layers to show 
and hide various components of the drawing. They are particularly useful in 
helping to view and plot complex drawings. For example, when dimensioning a 
part, the dimensions can be placed on a separate layer which can be displayed or 
not, as required. Layers allow plotting different versions of the same document for 
quick and easy specialized blueprints. Some examples of their usefulness: 

• Hide the dimension layer to exhibit the idea of a design to a planning team and 
show the dimensions when presenting the drawing to engineers. 

• Hide some drawing components when printing or plotting. For example, hide 
the construction layer so that construction lines and geometry don’t print or 
plot, but they remain in the drawing ready for use with design revisions. Think 
of visible layers as transparent pages and hidden layers as invisible pages. 
Although objects on hidden layers cannot be seen, they do exist. The layer 
must be visible for objects on it to be selected. Nor can those objects be 
deleted using Select All unless the layer is visible.

• Construct different layouts using one layer as the basis. For example, use a 
floor plan and then construct the electrical and plumbing plans on different 
layers. Then, turn off one layer (the electrical plan, for instance) and print the 
other (the plumbing plan) with the floor plan.

Graphite provides up to 255 visible or hidden layers in the drawing.
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Tip:

Layers facilitate color specific 
wiring diagrams or electrical 
and plumbing blueprints.
Using Colors with Layers 
Many CAD drawings show different components in different colors. When 
specifying a different color for a layer, the layer remembers the color so that if 
geometry is added to a layer later, the new geometry appears in the same color as 
the last geometry constructed on that layer. In this way, the Visible pen in red can 
be used on one layer, green on another layer and so on.

1. Choose Layout>Layers.

2. Create a new layer and rename it Outline green, indicating that the pen style 
Outline with a green color will be used on this layer.

3. Make the layer, Outline green, current.

4. Select Pen>Style>Outline.

5. Change the pen color from Black to Green by selecting Pen>Color>Green.

6. Draw a circle. The circle is created with the green color.

7. Select the Single Line tool.

8. Make Layer 1 current.

9. Draw a line. The line is created in black (the default color for the Outline pen 
style).

10. Select the Rectangle tool.

11. Make the layer, Outline green, current and draw a rectangle. 

The rectangle is created in green.

Notes: 

• Layers can be saved as Preferences with specified colors.

• Layers do not have an orientation or origin in Graphite.
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Layers Command 
CTRL+L (Windows); +L (Macintosh)
The Layers command in the Layout menu creates, deletes, hides, shows and 
renames layers, as well as sets layer specifications. The work layer is the active 
layer, the layer on which the current construction is created.

It is not possible to hide or delete a layer that is the current (active) work layer.

It is possible to change the position of any layer in the list by drag and drop.

The visible layers are indicated in the list box by an Eye icon, while a check mark 
indicates the work layer. 

When opening a new drawing, the default layers include Construction, Dimension 
and Layer 1.

Construction This layer automatically accepts all construction 
lines created with stroke commands or with the 
Construction dialog box. All lines of the 
“construction” line type go on the current work 
layer, not this construction layer.

Dimension This layer automatically accepts all dimensions 
created with the Dimensioning tool unless another 
layer has been designated using 
Dimension>Layer>(Layer Name). Generally, the 
Dimension layer should be reserved for 
dimensions.
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Tip:

It is also possible to type a 
name, then click New.
Layer 1 This is the current work layer when opening a new 
file. If the file only contains the default layers, all 
geometry is normally placed on Layer 1.

Edit any geometry or text that is visible, regardless of its layer. To make some 
geometry unselectable but still visible, use the Selection Mask. The selectability of 
entire layers can also be specified with the Selection Mask.

Creating a New Layer
1. Click New in the Layer dialog box to create another layer. 

2. Name the layer by typing the name in the Rename Layer data field. 

3. Click Rename. 

There can be as many as 255 layers.

Renaming a Layer
1. Select the name of the layer from the list box. 

2. Type the new name.

3. Click Rename.

Deleting a Layer
1. Select the name of the layer to delete from the list box.

2. Click Delete.

The layer and everything on that layer is deleted; 

Note: It is not possible to delete the current work layer.
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Hiding a Layer
1. Click the layer(s) in the list to be hidden.

2. Click Hide. The Eye icon beside the layer name disappears. 

Notes:

• The current work layer cannot be hidden.

• If a layer is hidden then choosing Select All and deleting, the objects on the 
hidden layer are not deleted.

Displaying a Hidden Layer
1. Click the layer(s) to make visible in the list.

2. Click Show. 

An Eye icon appears next to the layer’s name in the list indicating the layers are 
visible.

Making a Layer the Current Work Layer in the Layers Dialog Box
1. Select the layer name from the list.

2. Click Set Layer.

The layer must be visible before making it the work layer.

Relocating a Layer
1. Click the layer you want to relocate.

2. Drag it to a new position and drop it.

Changing the Work Layer with the Work Layer Indicator Box
Use the Work Layer Indicator pop-up box at the lower left of the drawing area to 
specify a different layer as the work layer. 

1. Press the mouse button on the box and the 
menu displays.

2. Drag to the layer to make it the work layer and 
release the mouse button.

The layer selected is now the work layer.
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Tech Note:

Select a contiguous group of 
items in the Selection Mask 
by clicking on the first or last 
item in the desired group, 
then holding down the SHIFT 
key and either clicking on the 
items or dragging up or down 
to the other end of the 
desired list.

To select or deselect 
noncontiguous items, hold 
down the CTRL (Windows) or 
the  (Macintosh) key and 
click the items.
Determining How Many Objects are on a Layer
1. Choose Edit>Selection Mask.

2. Select the desired layer from those listed in the center box.

3. Choose Edit>Select All.

4. Choose Edit>Edit Objects. The number of objects is listed at the top of the 
Edit Objects dialog box.

5. Close the Selection Mask and Edit Objects dialog boxes.

Layer Examples
Layers are like transparent sheets that can be turned on and off. This feature is 
particularly useful for designs with several variations of a component or to reveal 
as much or as little detail as needed for the design. Here are two such uses.

Floor Plans
A common use of layers is for different floor, plumbing and wiring plans for a 
building. The following examples show simplified drawings using layers.

Layers can be used to display different

floor plans of the same building.

Layer 3: Second Floor

Bath Dressing
Room

Master BedroomStudy

Layer 2: First Floor

Bedroom Bath Kitchen

Dining Area

Living RoomBedroom

Layer 1:  The foundation
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In order to print or plot the layers, simply use the Layers dialog box to turn on the 
layers to print and turn off all other layers using the Hide or Show button. When 
the desired geometry is displayed on the screen, choose File>Print.

Using Smart Walls with Layers
In these examples it is also possible to observe how smart walls function. The 
interior walls on Layers 2 and 3 overlay the exterior walls of the foundation.

Smart walls merge only on the same layer; therefore, the interior walls are not 
merged with the exterior walls and walls on Layer 2 are not merged with walls on 
Layer 3. 

Assembly
Layers can also be used to create interlocking parts of an assembly. Create one 
part on Layer 1 and copy the common geometry onto Layer 2. Then create the 
remainder of the interlocking part on Layer 2.

Then, turn the display of the layers on and off to present the parts appropriately. 

Layer Groups
Layer Groups are particularly useful for viewing and plotting different layers of a 
complex drawing. For example, the document described in the Layers section that 
shows the floor plan of a house might have several layers illustrating the plumbing 
layout and several layers illustrating the electrical plan. The plumbing layers can 
be shown in the Plumbing Layer Group but hidden in the Electrical Layer Group. 
Similarly, the electrical layers are shown in the Electrical Layer Group but hidden 
in the Plumbing Layer group. To create a print to go to the electrical contractor, 
simply make the Electrical Layer Group be the work group. This will show the 
layout of the house with the electrical plan contained on various electrical layers 
but not the plumbing information which is on the hidden plumbing layers. Rather 
than having to Show or Hide numerous individual layers, you only have to select a 
single Layer Group to get the format that is desired.

Layer 1 and Layer 2 Layer 2Layer 1
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Layer Groups Command
The Layer Groups command in the Layout menu extends the functionality of 
layers by creating Layer Groups. A Layer Group records, stores and displays layer 
settings, such as which layers are shown and which layers are hidden, as well as 
which layer is the work layer. This shows and hides different layers quickly by 
selecting a single Layer Group rather than setting the attributes of numerous 
individual layers.

The Layer Groups dialog box lists the layer groups on the left and the individual 
layers on the right. Visible layers for the selected (highlighted) Layer Group are 
indicated in the Layer list by the Eye icon, just as they are in the Layers dialog 
box. Visibility can be toggled by clicking the Eye icon, or at the location where the 
Eye icon should be for hidden layers. The work layer of the selected group is set 
by double-clicking on the desired layer from the Layer list. Layers that are created 
after a Layer Group has been defined are included in the group but are not visible.

The current set of visible layers and the work layer need not correspond to any 
layer group; thus, it is not necessary that a Layer Group be designated as the 
“work” group. Setting a work group simply changes the model’s current layer 
settings to those of the specified Layer Group. Also, if a Layer Group is 
designated the work group and layer attributes are subsequently modified, either 
by the Layer dialog box or by changing the work layer in the Layer Indicator pull-
down list, the Layer Group loses its “work” status.

There must be at least one Layer Group created before using any of the buttons 
other than New, or changing any settings for any layers.
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New Creates a new Layer Group, called Group1, 
Group2, Group3, etc., by default. Use the 
Rename button to rename the Layer Group with 
an appropriate name. It is possible to have up to 
255 Layer Groups in a single file.

Delete Deletes the selected (highlighted) Layer Group. 
This does not delete the layers in the group.

Set Group Sets the currently selected (highlighted) group as 
the work group. This changes the layer settings 
for the current model to those specified by the 
layer group.

Rename Renames the currently selected (highlighted) 
group with the name in the Layer Group data field.

A check mark by a Layer Group indicates that the model’s current layer settings 
match those of the indicated Layer Group.

Creating a Layer Group
1. Click New. 

A new Layer Group appears in the group list and is selected. It records the 
current layer settings and displays these settings in the Layers list. 
The Layers list contains all the layers present in a file.

2. Choose the layer settings. 

Visible layers are indicated by the Eye icon and are hidden by clicking on the 
symbol. Hidden layers are made visible by clicking the location where the Eye 
symbol would be. The work layer is indicated by the check mark and is set by 
double-clicking on the desired layer.

3. Close the dialog box and the settings are retained. 

To have more layer groups, repeat steps #1 and #2 before closing the dialog 
box.
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Renaming a Layer Group
1. Select the desired Layer Group from the group list.

2. Enter a new name in the Layer Group data field.

3. Click Rename.

Deleting a Layer Group
1. Select the desired Layer Group from the group list.

2. Click Delete.

Deleting the work group, which is indicated by a check mark, deletes the group 
from the list, but the layer settings remain in effect until they are changed.

Making a Layer Group the Work Group
1. Select the desired Layer Group from the group list.

2. Click Set Group. This changes the layer settings for the current model to those 
specified by the layer group. These settings are shown in the layers list.

A check mark by a Layer Group indicates that the model’s current layer settings 
match those of the indicated Layer Group.

Changing the Layer Setting of a Layer Group
1. Select the desired Layer Group from the group list.

2. Change the layer settings as desired. Visible layers are indicated by the Eye 
icon and are hidden by clicking on the symbol. Hidden layers are displayed in 
the layer group by clicking in the location where the Eye icon should be. The 
work layer is indicated by the check mark and is set by double-clicking on the 
desired layer. The new settings automatically replace the old settings.

Layers, Sheets, and Models
All Models and Sheets share the same set of layers in a file. For more information 
about Models and Sheets, see Chapter 14.



Graphite User Guide View Displays

Referral:

More about sheets and views 
is in the chapter 14 Advanced 
Viewing Techniques in this 
manual.

Referral:

See the next section for 
information on associativity.
View Displays
This section explains various ways to enlarge or reduce all or part of the geometry 
for both viewing and printing. This visual change of the view does not affect the 
actual measurement of the geometry in the model. This is different from the view 
orientation of the geometry that is set using the Trackball or the View commands 
in the Views menu. See Chapter 6, “Advanced Environment Settings.” There are 
two types of views in Graphite: the sheet view and the detail view. 

Sheet Views
The sheet view shows all of the geometric construction on the sheet outside of 
any existing view windows, at the scale specified. The sheet view is the default 
view when starting Graphite.

The sheet view is picked up by the Sheet Camera and projected on the current 
sheet. The sheet view is infinite in size, having no boundaries. In other words, 
when drawing on a sheet, create geometry as large as desired.

Note: When selecting File>New, Sheet 1 of the untitled file is displayed. It is the 
only sheet available until more are added. See Chapter 14 for more information 
about sheets and the Sheet Camera.

Detail Views
In drafting, detail views are used to provide more information about a specific area 
of the drawing. They are typically shown at a larger scale than the original 
geometry. Graphite provides a tool that automatically creates detail views in order 
not to have to redraw the geometry.

A detail view is like a window which looks at some geometry in the drawing from a 
particular camera angle and displays it at a specified scale. A detail view can be 
created in Graphite in two different ways: with the Detail View tool or the Sheet 
Into View command in the Views menu. The Sheet Into View command is an 
automated way of creating arrangements of detail views in specific layouts. The 
detail views in each case behave in the same way.

Detail views are always placed in a view window and are associative so that when 
modifying geometry in any view, all views of that geometry reflect the change. 
There are three deliberate exceptions to this associativity, in line with standard 
drafting practice: dimensions, crosshatching, and text appear only in the view in 
which they were created.
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Graphite can create detail 
views of the drawing in which 
some part of the geometry is 
scaled and placed in a view 
window. In the illustration here, 
the detail view shows a 2 : 1 
enlargement of the side notch.

Use more than one view window with 
different view orientations to show the 
various faces of the geometry. Detail view 
windows are useful for observing the 
geometry while working. They are also 
essential for creating finished drawings. 
The following graphic displays another 
model in four different detail views.

Vellum
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Tip:

It is also possible to create 
the view window rectangle by 
clicking to place the 
diagonally-opposite corners.

Referral:

Find more about Models and 
Views in the Chapter 14, 
“Advanced Viewing 
Techniques.”
Detail View Tool

The Detail View tool creates a detail of the designated area of the drawing. 

Creating an Associative Detail View
An associative detail view is one in which a change will appear in the view if a 
change is made to geometry in another view.

1. In the View Control subpalette, select the Detail View 
tool. The Message Line reads, Detail View: Enter view 
scale then pick first corner of viewing frame. 

2. Enter a scale for the detail view in the Status Line. 

3. Use the pointer to drag a rectangle around the area of the drawing that is to be 
placed in the detail view. This rectangle becomes the window frame. 

It is also possible to click the first corner and the opposite corner to define the 
view.

4. Position the pointer in the center of the detail view window frame and drag the 
window to a clear area on the drawing.

Creating a Non-associative Detail View
To have a detail view that is not associative; that is, when making changes to the 
original geometry, the geometry in the view does not change:

1. Create a detail view on an open space. 

2. Use the Selection tool to click inside the view and make it active.

3. Drag a selection fence around all of the geometry inside the original view.

The geometry inside the view is selected.

4. Choose Edit>Copy.

5. Choose Views>Models.

6. Click New to create a new model (by default, model 2).

7. Click Current to make the new model the current model in the new view. The 
geometry in the view disappears.

8. Choose Edit>Paste.

The geometry is pasted into the new detail view, but it is no longer associative, 
since it is part of a different model.
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Rotating the Viewing Area and Detail Views
It is only possible to change the view orientation within a view window. The sheet 
view is rigidly fixed to the sheet itself and aligned parallel to the sheet in the Top 
view. 
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Tech Note:

When clicking the detail view, 
the view becomes active and 
the view window with a title 
bar appears.
Active View
The detail view window 
displays a title bar only when it 
is the current or active view. 

Click inside the detail view 
window when the view is 
inactive, as in the left graphic 
here. The detail view window 
becomes active, displaying a 
title bar and control button for 
its pull-down menu, as in the right graphic. 

The sheet view is made active by clicking in the drawing area away from all detail 
views. In other words, all the detail views look inactive. Activate the sheet to 
construct geometry that is outside of a view.

A view must be active to work in it. Either a detail view is active or the sheet view 
is active, but only one can be active at a time.

Inactive view Active view

7.23

4.12

2.95

1.35

2.253
2.249

1.204

1.25

Dimensions and hatch pattern only on the sheet
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Tech Note:

In the Graphite View window, 
the Control Menu in the upper 
left corner does not contain 
the standard control 
commands but special view 
window commands.

Tech Note:

Using Cut or Copy within the 
Detail View does not cut or 
copy the geometry inside, but 
rather cuts or copies the 
detail view itself. To cut or 
copy just the geometry, use 
these commands from the 
Edit menu.
View Window
The view window includes a title bar, size box 
and Control pull-down menu only when the 
detail view is active.

Drag the view around by the title bar and 
resize the window by dragging the size box.

Control Pull-down Menu
The Control pull down menu provides options for manipulating the view.

Properties Names the detail view, changes the view scale 
(entering 2 zooms into the area by a factor of 2), 
and defines the locations of its corners relative to 
the origin.

Cut Removes the Detail View from the sheet and 
places it on the Clipboard. This is useful for 
placing the view on a different sheet. Choose the 
Edit>Paste to paste the cut view window. This 
command does not cut the geometry. To cut the 
geometry, choose Edit>Cut.

Pull down menu
Title bar

Size box
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Copy Places a copy of the view window on the 
Clipboard. This is useful for pasting multiple 
identical views onto one or more sheets. Choose 
the Edit>Paste to paste a copy of the view 
window. This command does not copy the 
geometry. To copy the geometry, choose 
Edit>Copy.

Delete Removes the active window and makes the sheet 
active. It does not delete geometry.

Pan Moves the geometry inside the view window. 
A hand icon appears which is used to drag the 
contents of the window.

When the mouse button is released the Pan 
function ends.

Resize Drags a new view window. This function differs 
from dragging the window borders. With the 
Resize command, it is not necessary to change 
each border individually since a new window is 
defined that is substituted for the original one.

If the content of the view window is not seen after 
applying the Resize command, choose 
Arrange>Zoom All with the SHIFT (Windows) or 
CONTROL (Macintosh) key pressed. This ”fits“ all 
the geometry of that model into that view window 
at the necessary view scale.
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Tip:

Scroll within a view by holding 
down the SHIFT (Windows) 
or the CONTROL (Macintosh) 
key while moving the 
scrollbars.
Changing the View Scale
When fitting a view or group of views in a drawing format, it may be necessary to 
scale a view. 

1. In the detail view's Control menu, choose Properties.

2. Specify the scale and click OK.

Copying a View Window
Use the view window menu to make another view window to add to or change the 
arrangement selected with Sheet Into View.

1. Click inside the window to make it active.

2. Choose Copy from the view window control menu.

3. Choose Edit>Paste.

The copy of the window appears slightly offset from the original window. Drag it 
to a new location.

Panning the Geometry in a View Window
1. Click inside the window to make it active.

2. Choose Pan from the view window menu. 

The pointer changes to a hand icon.

3. Drag the geometry to the desired location.

Zooming within a View
1. Click inside the view to make it active. 

2. Hold down the SHIFT (Windows) or the CONTROL (Macintosh) key.

3. Choose Arrange>Zoom (In, Out, Previous, or All) 

or

Choose one of the Zoom tools in the tool palette.

The geometry inside the view is zoomed.

All commands from the Arrange menu work inside the view when holding down 
the SHIFT (Windows) or the CONTROL (Macintosh) key while choosing from the 
menu.

The keyboard Zoom commands are not designed to work within a view window.
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Views Menu
The view control commands in the Views menu control the active view. When 
there are overlapping views, think of them as a stack where only the top view is 
active. If the Auto Front command is turned on, clicking a view moves it to the top 
of the stack for work. This may cause some problems when an object is clicked on 
in the top view to select it, but an underlying view activates instead.

To remedy this situation, turn off the Auto Front command. Select the view to work 
in and choose Views>Bring To Front. The objects in the view brought to the front 
remain on top, even when clicking a different view visible in the top view’s space.

Auto Front Command
The Auto Front command in the Views menu overrides the Bring To Front or Send 
To Back settings. When this setting is in effect, simply click on a view to bring it to 
the front and make it active. When this setting is not active, it is not possible to 
inadvertently bring a view to the front when working on another view. This 
command only works for views.
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Bring To Front Command
This command in the Views menu brings the specified view to the front of the 
stack of views. 

1. Select the view.

2. Choose Views>Bring To Front.

This command counteracts the Auto Front command, so a click selects objects in 
the view rather than activating another view. 

Send To Back Command
This command in the Views menu sends the specified view to the back of the 
stack of views. 

1. Select the view.

2. Choose Views>Send To Back.

This counteracts the Auto Front command, so a click activates another view rather 
than selecting objects.

Draw View Boundaries Command
This command in the Views menu shows the boundaries of all inactive views. This 
boundary is printed if left displayed while choosing the Print command.

To print the view without boundaries, in the Views menu, deactivate Draw View 
Boundaries.

Windows
This submenu on the Views menu shows the names of all the open Graphite 
documents. To bring a different document to the top window, choose it from the 
submenu.
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Navigator Palette
The Navigator Palette easily moves through sheets and layers in a 
circular file fashion. It displays the active documents and isolated layers.

To display the Navigator palette, choose Utilities>Show Navigator. 

Sheet Navigation

Click on the S>  button to move forward through the visible 

sheets. Click on the S<  button to move backward. Only one 

sheet at a time can be shown.

Layer Navigation

Click on the L>  button to move forward through the visible 

layers. Click on the L<  button to move backwards.

Click on the L+  to show all layers. Clicking L^  pops up a list of 

available layers. Choosing one of the layers makes it the active layer and all other 
layers are visibly turned off. Restore full visibility to all layers by clicking on the 

L+ button or choosing Layout>Layers and setting the visibility individually.

Window Navigation

Click on the W  button to display a popup menu of open Graphite 

documents. Choosing one of the documents makes it the active document.
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Advanced Viewing Techniques
Sheets, views and models are features in Graphite that add a great amount of 
flexibility to the design process. This chapter explains each of them and how they 
interact with each other. The following topics are included:

• Sheets

• Models

• Views, including Sheet into View and View Layouts

• Combining Sheets, Views and Models

Sheets
A sheet is an infinite planar area. Graphite 
allows multiple opaque sheets within a 
drawing. A drawing can be a simple part or a 
complex assembly, with related geometry 
organized on as many sheets as the scope of 
the project demand. 

There can be many sheets but only one sheet 
is active, and therefore, visible at a time. To 
activate a sheet use the Current command in 
the Sheets dialog box in the Views menu. In 
Graphite one sheet is always the active sheet 
which cannot be deleted.

Having multiple sheets, imagine them arranged 
as a stack of sheets behind the computer screen. To make a sheet current bring it 
to the front. That is why only one sheet, the current sheet, can be seen at a time.
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Using Sheets
Every document contains Sheet 1. Use the Sheets command in the Views menu to 
create new sheets, delete, rename, or set the current work sheet. Give the sheets 
distinctive names, rather than their default numbers, because it is much easier to 
know what’s on a sheet if it's named, for instance, Detail View, rather than Sheet 
2. 

Sheets are Graphite’s equivalent to pieces of paper, with the added function that 
Sheet 2 can display geometry associated with Sheet 1. When using detail views, 
layers won’t serve your needs for printing or plotting. This is because when the 
layer containing the geometry that the detail view is associated with is hidden, the 
geometry is also no longer visible in the detail view. 

Use sheets to display and print multiple pages of complex drawings. The following 
example explains the process:

• When opening a new document, Sheet 1 displays in the drawing area.

• Create a complex assembly and a detail view on Sheet 1.

• When it is time to plot the project, the assembly is found to fill all of the plotting 
area and there is no room for the detail view on the page. 

• Select the detail view and choose Cut from the active View window menu (not 
from the Edit menu in the menu bar).

• Choose Views>Sheets and click New to create another sheet (Sheet 2). 

• Click Current to make Sheet 2 the current sheet.

A blank sheet displays.

• Choose Edit>Paste to paste the detail view on Sheet 2.

The detail view displays on Sheet 2.

Use Zoom All in order to see the detail view.
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Tip:

To print a part related to one 
project separately, create a 
new sheet.
Finally, check to see that the detail view is still associated with the original 
assembly:

• Make Sheet 1 current and make a change to the area of the assembly that is in 
the detail view. (Remember: Crosshatching, Text, and Dimensions are not 
associated in a detail view.)

• Look at Sheet 2 and see that the change appears in the detail view on Sheet 2 
and, of course, changes made in the detail view are also be reflected in the 
Sheet 1 view.

Sheets Command
The Sheet command in the Views menu facilitates creating and naming sheets, 
and setting the work sheet. The check mark in the list of sheets indicates the 
current work sheet. The title bar for the document also indicates the active sheet 
(Document Name: Sheet Number). The name of the sheet only displays in the 
Title Bar if more than one sheet exists.

Use several sheets to create related components and associated detail views. 
Using a new sheet in Graphite is like using a fresh sheet of paper on a drafting 
board to create a component related to the larger project.
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Tip:

It is also possible to create a 
new sheet by typing a sheet 
name and then clicking New.
Creating a New Sheet
Click New to create another sheet. Name the sheet by typing the name in the 
Rename data field and clicking the Rename button.

Note: Graphite automatically creates a new model when creating a new sheet. 
See a later section for more information on models.

Renaming a Sheet
1. Select the name of the sheet from the list box. 

2. Type the new name.

3. Click Rename.

Deleting a Sheet
1. Select the name of the sheet from the list box.

2. Click Delete.

Graphite handles Models and Sheets separately. The geometry created is the 
model. What you see on the sheet is only an image (view) of that model. So when 
the sheet is deleted only the Sheet View or Detail View of the model is deleted, but 
not the geometry (model) itself. 

Note: The current sheet cannot be deleted.

Selecting the Current Sheet
1. Select the name from the list.

2. Click Current.
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Tip:

Any combination of geometry 
such as lines, arcs, circles, 
dimensions, text, etc. created 
using the tools in Graphite is 
a model.

Tech Note:

The Sheet Into View 
command also creates a new 
model for the sheet view. The 
existing model is placed in the 
detail view window. See a 
later section of this chapter 
for more information.
Models
Models are composed of the geometry you create. Even if it looks like the 
geometry is created directly on the sheet, it is not. What is seen on the sheet is 
only an image of that model. The model itself is created in an infinite three-
dimensional area we call Model space.

Projected Model Image
The image on the sheet is the 
projected sheet view of the model 
picked up by the sheet camera 
which is aligned parallel to the 
sheet and looking from a top view, 
at the model.

When the Zoom commands in the 
Arrange menu or the Zoom tools 
from the tool palette are used, it 
changes the view scale of the 
model by zooming the sheet 
camera like a video camera.

Multiple Models
There are two different ways to 
create models:

• Using the Sheets command in 
the Views menu.

• With the Model command in the Views menu.

When creating a new sheet, Graphite automatically creates a new blank model 
where geometry can be created.
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Creating a New Model with the Sheets Command
This task assumes that any additional models and sheets are not created.

1. Select Views>Sheets.

The Sheets dialog box displays.

2. Select Views>Models.

The Models dialog box displays. 

3. Since the Model dialog box is placed at the same location on the screen, 
move it to another location to see both dialog boxes. 

A new drawing in Graphite has one Sheet and one Model by default. The check 
mark in each dialog box shows that Sheet 1 and Model 1 are current.

4. Display the Sheets dialog box and click New to create a new sheet. A new 
model automatically appears in the Models dialog box (Model 2).

5. Make Sheet 2 current by highlighting it and clicking Current.

Any geometry on Sheet 1 disappears and a blank screen comes up. Also, the 
check mark moves from Sheet 1 to Sheet 2 and the check mark also moves 
automatically from Model 1 to Model 2.

Model 2 automatically becomes current because Sheet 2 is related to Model 2. 
So if you make Sheet 2 current on the screen, then Model 2 has to be current as 
well.

Sheet 2, now displayed on the monitor, is blank because nothing has yet been 
added to Model 2. As soon as the drawing is begun, all geometry automatically 
adds to Model 2 since Model 2 is the current model space.



Graphite User Guide Models

Tip:

It is also possible to create a 
new model by typing a model 
name and then clicking New.
Relationship between Sheets and Models
When a new model is created with the Model command, it is created without 
creating a new sheet. So it is possible to have more models than there are sheets. 
It is only possible to look at one model at a time in any view (sheet view or detail 
view) if the geometry is contained in different model spaces (i.e. Model 1 or Model 
2). Think of models as a spatial area where geometry is located. Two spatial areas 
cannot be viewed through one window at the same time.

It is possible to create more 
models than there are view 
windows. It is also possible to have 
a model that is not displayed in 
any view. And a single model can 
be displayed in many views at the 
same time.

Making a model current in a sheet 
view is like moving the sheet 
camera moved to the new model. 
Making a sheet current, is like 
moving the sheet camera to the 
related model whose image is 
projected on that sheet.

Models Command
The Models command in the Views 
menu specifies models and 
switches between models, projecting them on the current sheet. It is possible to 
display a single model on more than one sheet, but only one model can be viewed 
at a time on each sheet without using detail views.

Creating a New Model
Click New to create another model. Name the model by typing the name in the 
Rename data field and clicking Rename. 
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Renaming a Model
1. Select the name of the model from the list box. 

2. Type the new name.

3. Click Rename.

Deleting a Model
1. Select the name of the model from the list box.

2. Click Delete.

When deleting a model, all of the geometry making up that model is deleted.

Note: The current model cannot be deleted. A model which is still associated with 
a sheet cannot be deleted. As long as it is related to a sheet the Delete button in 
the Models dialog box is not available.

Making a Model the Current Model
1. Activate the view (sheet view or detail view) by clicking on it.

2. Select the name from the list in the Models dialog box.

3. Click Current. A check mark shows the current model for the current view.
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Multiple Sheets and Models
Generally, a model is created on a single sheet. When it is time to create drafting 
views of the model, it may be necessary to have several sheets because the 
model is so large or so detailed that it requires more than one sheet of paper 
for the finished drawing.

For example, designing a dental workstation, place the view on one page showing 
the chair, work tray, x-ray and drill arms. 

Then on subsequent pages, add the detail views of the x-ray arm and drill setup. 
In addition to this, the first sheet would use a particular format and the following 
sheets would use a different, less detailed drawing format.

Vellum

Vellum

First pag e — Sheet 2
particular format   

Second page — Sheet 2    
less detailed format
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Using Multiple Sheets 
The key to using more than one 
sheet of paper is to use 
Graphite’s model and sheet 
functions. In the example below, 
start with the front view of a 
model (Model 1) on a drawing 
format (Model 2) on Sheet 1. 
Then open Sheet 2 and display 
all four views of Model 1 on it. 

1. Create the part.

Model 1 contains the part 
and its Top view is picked up 
by the sheet camera and 
displayed on Sheet 1.

2. In the Views menu, use the 
Sheet Into View command 
to set up four views in the 
appropriate sized drawing 
format.

The sheet camera aligns 
parallel to the current sheet 
and displays the Top view 
of Model 2 (the drawing 
format) on Sheet 1. Four 
detail view cameras display 4 
views of Model 1 on Sheet 1 
within the drawing format. 

3. Use the Cut command in the 
view window menu to remove 
all the view windows, except 
the Front view.

y

-z

x

3D-Model space
Sheet
camera

Sheet 1

Top

Models

Model 1

Sheets

Sheet 1

Vellum

Vellum

Model 2 (Drawing Format)

4 detail views of
Model 1 (detail
cameras not
illustrated)

Sheet 1

Sheet
camera

Models

Model 1

Sheets

Sheet 1

Model 2

Trimetric
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4. Resize the remaining Front view window so that it fills the drawing format. 

5. Choose Views>Sheets.

The Sheets dialog box displays.

6. Click New.

Sheet 2 displays in the Rename box.

7. Click Current.

Vellum

Vellum

Sheet 1

Sheet
camera

Model 2 (Drawing Format)

Front view of
Model 1 (detail
camera not
illustrated)

Models

Model 1

Sheets

Sheet 1

Model 2

Front

Vellum
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Sheet 2 with the blank Model 3 displays in the drawing area.

8. Choose Views>Models.

The Models dialog box displays. The blank Model 3 is the current model 
automatically created with Sheet 2, picked up by the sheet camera and 
displayed on Sheet 2.

9. Click Model 1 and click Current.

Vellum

Vellum

Sheet 1
Sheet 2

Model 2 (Drawing Format) 
         placed on Sheet 1 

Front view of
Model 1 on 
Sheet 1 with
drawing format
(not visible).
Detail camera is
not illustrated

Model space 3 

Sheet
camera

Models

Model 1

Sheets

Sheet 2

Model 2
Model 3

Sheet 1

Front
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Model 1 is picked up by the sheet camera and displayed on the second sheet.

10. (Optional) Delete Model 3 since it is no longer needed. Model 3 was 
automatically created with Sheet 2.

Another possibility is to leave Model 3 active and paste the views of Model 1, 
which were removed with the Cut command at the beginning of this exercise, on 
Sheet 2.
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11. Choose Views>Sheet Into View and select the appropriate format and views.

With the Sheet Into View command, place views from the current Model 1 on 
the current Sheet 2. The sheet camera moves to Model 3, which was 
automatically created with Sheet Into View and displays the appropriate drawing 
format on Sheet 2. Sheet 1 with the front view of Model 1 lies behind Sheet 2 
and is not visible.

Note: The sheet camera is moved to Model 4 if Model 3 was not deleted in Step 
10.

When Sheet 1 is made current, Sheet 1 
moves forward and the sheet camera 
moves to Model 2 (drawing format) and 
displays the Front view of Model 1 within 
the drawing format, because Model 2 
(drawing format) rests on Sheet 2.

12. Arrange the views on the sheet.

Vellum

Vellum

Vellum

Vellum

Front

Models

Model 3
Model 2
Model 1

Sheets

Sheet 2
Sheet 1

Sheet 1
Sheet 2

Sheet
camera

Model 4 (Drawing Format)

3 views of
Model 1 on

Sheet 2. . Detail
cameras
are not illu-
strated

Model 2 (Drawing Format)  
         placed on Sheet 1 

Front view of
Model 1 on
Sheet 1 with
drawing format
(not visible).
Detail camera is
not illustrated

Vellum

Vellum
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Tech Note:

Regardless of the method 
used to create a View 
Window, they all behave the 
same way. They all have a 
border which can be turned 
on and off in the Views menu 
with the Show/Hide View 
Boundaries command. The 
active view is displayed in a 
view window which has a title 
bar.

Tip:

To move a view window to 
another sheet, cut the view 
window with the Cut 
command in the View 
Windows’s control menu, 
make the other sheet active 
and place the view window 
with the Paste command in 
the Edit menu on the current 
sheet.
Views
In the previous chapter, the concepts of sheet views and detail views were 
discussed.

These two different views are easy to identify on the screen:

• Each item displayed inside a view window is a detail view.

• The area outside (and underneath) all detail view windows is the sheet view.

This section goes into greater detail on views and models, including Sheet into 
View. 

More about Associative Detail Views
When creating a detail view with the Detail View tool on the tool palette or the 
Sheet Into View command in the Views menu, the same model is viewed through 
a second camera—the detail view camera.

The detail view camera behaves like the sheet camera except it displays its view 
of the model in a view window on the sheet.

Sheet 1

Sheet
camera

Model with one additional detail view camera projecting its  
view in its active  view window.  

Models

Model 1

Sheets

Sheet 1

Model

Detail View Camera

Detail View Projector
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Tip:

This procedure is very useful 
to identify models and sheets 
for renaming.

Tip:

Change the scale of a detail 
view with the Properties 
command in the view 
window’s Control menu.
All views displaying the same model are associative. For example, when changing 
the geometry on the sheet, the geometry in the view window changes, and vice 
versa. 

Having several views displaying the same model they have to be associative, 
because no matter which view is active—the sheet view or any detail view— the 
same model is being edited.

Activating Views
To make a view active click on it. When clicking on the sheet, the sheet view 
becomes active. When clicking in a view window, the detail view becomes active.

Identifying Models
When it is uncertain which view displays which model, open the Models dialog 
box. When clicking on the drawing area, the check mark moves to the model 
displayed on the sheet. Click in a view window and the check mark moves to the 
model displayed in the detail view.

Scaling Views
Zooming affects the sheet view and the detail view differently. Zooming in a detail 
view with the SHIFT (Windows) or the CONTROL (Macintosh) key pressed, 
changes the view scale property of that view only. With the Zoom or Stroke-Zoom 
commands, it is possible to change only the screen display scale of the sheet and 
all detail views projected on that sheet, but not the size of the geometry itself. 

Text, Dimensions, Crosshatching, Fills and Detail Views
While it is important that changes made to geometry in one view be reflected in 
the other views, the same is not true for text, dimensions, crosshatching and fills. 
The views become very cluttered and are rendered useless if all notations made in 
one view appear in the others. For that reason, Ashlar-Vellum designed these 
elements so that they would not be associative, in line with standard drafting 
practice.
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Tip:

Documents are more 
manageable if all existing 
view windows are deleted 
before using the Sheet Into 
View command.

Tip:

Use the Sheet Into View 
command when importing a 
drawing format which is a 
different scale from the 
geometry.
Sheet Into View Command
The Sheet Into View command places all the geometry on a sheet, including 
dimensions, text, crosshatching, and fills, into one view window (the front).

The view window created with the Sheet Into View command behaves like any 
view window created with the Detail View tool. Although both view windows 
behave the same, the Sheet Into View command includes three automatic steps 
which are not performed when a view window is created with the Detail View tool. 

The Sheet Into View command:

• Creates an additional model (blank or containing a standard drawing format if 
selected).

• Moves the sheet camera to that model (blank or with the drawing format) to 
display it on the current sheet.

• Puts all geometry, including text, dimensions, crosshatching, and fills on the 
current sheet into a view window and displays it in the scale specified within the 
selected drawing format.

Sheet 1

Sheet
camera

Model with one additional detail view camera projecting its  
view in its active  view window.  

Models

Model 1

Sheets

Sheet 1

Model

Detail View Camera

Detail View Projector
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Tip:

Add your own formats to this 
list as described in chapter 15 
Graphite Documents, or 
modify the layouts provided 
to meet your needs.
Placing Geometry into a View Using Sheet into View
1. Draw the geometry.

2. Choose Views>Sheet Into View.

3. Choose the layout 
from the Layout menu. 
It is possible to 
choose from a view 
with no drawing format 
or a view in a standard 
drawing format.

4. Enter the scaling 
value in the Scale box 
if you need a certain value, or just check the Zoom Extents option to make the 
drawing fit into the view window. Factors greater than one enlarge the model 
in the view(s) and factors less than one reduce the model. 

5. Click OK.

6. Choose Arrange>Zoom All.

The geometry scales and the views appear as specified. By specifying a 
drawing format, it imports into the view and scales appropriately for the 
specified drawing size.

Adding Formats to the Sheet Into View Dialog Box List 
To create the drawing formats and add them to the list in the Sheet into View 
dialog box do the following:

1. Start a new document.

2. Select the Detail View tool and create a view window. 

3. Display the Models dialog box and create a new model.

4. Click on the sheet and make Model 2 the current model in the Model dialog 
box.

5. Click in the view window and make Model 1 the current model in the Models 
dialog box.

6. Click on the sheet to activate Model 2.
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Tip:

It is also possible to open one 
of the layouts in the Layouts 
folder of Graphite and change 
it. But be sure to save that 
layout under a different name 
before modifying it.
7. Create the drawing format at a scale 1:1 or import one of Ashlar-Vellum 
formats and modify it.

8. Save the drawing with a proper name in the Layouts folder of Graphite.

The Filename is listed on the Layout menu.

See chapter 15 Graphite Documents, for more information on formats and 
customizing.

Erroneous Sheet into View
Having mistakenly invoked the Sheet Into View command, use Undo to recover. If 
this is not done immediately, use the following method to manually back out.

Recovering from an Erroneous Sheet Into View
1. Delete all view windows on the current sheet by choosing Delete from the 

view window’s Control menu of each view.

2. Make Model 1 in the Model dialog box the current model for the Sheet View.

3. Delete Model 2.

View Orientation
There are many options for changing the view orientation within the view window.

• Rotate the view with the Trackball.

• Choose 3D>Views and select a view.

• Select a view from the pull-down menu on the Trackball.

• Set a view with the Define View command.

• Unfold a view with the Unfold View command.

• Set the view to the current work plane with the View the Plane command.
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Define View Command
The Define View command in the Views menu defines an auxiliary view orientation 
or changes the standard view orientations. The standard views cannot be 
changed unless the locked check box is clicked off. The default configurations are 
defined as follows:

Front The view of the x,z plane. 

Isometric The view of the axes rotates as shown.

Right The view of the y,z plane. 

Top The view of the x,y plane. 

Trimetric The view of the axes rotates as shown. 
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Specifying a New View
Follow these directions to specify a new view orientation.

1. Choose Views>Define View.

The Define View dialog box displays.

2. Click New.

The new work view is named View 1. 

The Redefine View dialog box displays 
the locations for the current view. If that 
view is the desired view, click OK. 
Otherwise, proceed with the 
specification. The Normal (line of sight) 
specification highlights in the dialog box.

3. Drag a line in the active view window to indicate the Normal (line of sight) 
vector.

The Up data field becomes selected.

4. Drag a line in the active view window indicating the Up direction.

5. Click OK.

The dialog box closes and the new view is defined.

6. Click Set View.

The active view displays the new orientation. 

7. Rename this view to give it a more distinctive name. 

8. Close the Define View dialog box if there is no other need to define additional 
work views.

Be aware that simply rotating the view does not alter the orientation of the work 
plane in 3D space.
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Deleting a View Orientation
Select the view orientation to be deleted from the View list and click the Delete 
button.

Redefining a View Orientation
There are two methods to change the orientation of the axes of a view.

By Example
1. Manipulate the view orientation manually with the Trackball. 

2. Choose Views>Define View.

3. Select the view to redefine.

4. Click Redefine. 

5. Click OK.

The Redefine View dialog box closes.

6. Dismiss the Define View dialog box if there is no other need for it.

By Definition
1. Choose Views>Define View.

2. Select the view to redefine.

3. Click Redefine. 

The Redefine View dialog box displays the settings as they appear on the 
screen with Normal (line of sight) selected.

4. In the active view window, drag the Normal (line of sight).

The Up data field becomes selected.

5. Drag the direction for up.

When dragging the normal vector with the mouse, know that the vector, from the 
beginning point, points directly at you, not away from you. So when this new 
view is made current, the normal vector points out of the screen, not into it.

6. Click OK. 

The Redefine View dialog box closes.

7. Dismiss the Define View dialog box if it is not needed.
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Renaming a View Orientation
1. Click the view orientation to be renamed.

2. Type a new name.

3. Click Rename. 

Renaming a Standard View Orientation
1. Click the standard view name in the list box.

2. Click the Locked box to toggle it off.

3. Type a new name.

4. Click Rename.

Unfold View Command
The Unfold View command in the Views menu creates a view orientation from the 
active view window by specifying a line from which to unfold the new view 
orientation.

Unfolding this view 
along this line...

...creates this view window
and view orientation 
14-23



14-24

Advanced Viewing Techniques Ashlar-Vellum
By specifying a line a 90°-plane along that line, which is coming towards you away 
from the screen. This plane is folded by 90° and creates the new view orientation 
from the active view.

Note: Use this command only in a view orientation aligned parallel to an object 
face. When using it in a differently aligned view (where object face is not parallel to 
the screen) this command may work correctly, but the result is unpredictable in 
most cases.

Unfolding a View
1. Choose Views>Unfold View.

2. Click the endpoints of the line on which to unfold.

An actual line is not necessary, just indicate a vector.

The active view window shows the view unfolded 90° from the line specified.

Setting the Screen to the Work Plane
Change the point of view to look directly at the work plane. Choose Views>View 
the Plane to do this.

90°

90°

Folding Line

Screen

90-plane

Folding line

Before Unfolding After Unfolding

Unfolded View

Screen

90°-plane

Screen
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View the Plane Command
This command in the Views menu rotates the view orientation in the active view 
window to match the work plane. The view changes so the work plane becomes 
horizontal on the screen. The y-direction of the work plane becomes vertical, and 
the z-direction of the work plane becomes the line of sight, coming directly out of 
the screen.

To leave this view orientation, select a view from the Trackball pull-down menu or 
the Views submenu, or use the Trackball for free rotation.

Editing a View Without Editing the Model
The geometry within view windows is associative. Making a change in one 
window, the change affects the model and therefore the geometry in all views. In 
the drafting phase of the design process, it is possible to edit the geometry in 
one view window without making the same changes to the model. For example, it 
might be necessary to clarify the view by removing a line or adding an arc visually, 
but not unnecessary make the actual change in the model. 

Accomplished this by using the Flatten View command on the Views menu. When 
flattening a view, the geometry is taken out of the view and placed back on the 
sheet, where it is no longer associated with the model. In this way, it is possible to 
make changes to the geometry without changing the model or other views. 

A typical situation for flattening a view is when a view should display fillets but the 
fillets do not need to be displayed in the model.

Trimming such intersecting fillets in 3D is a difficult problem that was addressed in 
the Getting Started Guide, but Graphite makes this problem very easy to solve.
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Flatten View Command
The Flatten View command in the Views menu places a projection of the visible 
geometry in the active view window onto the sheet at full scale. When the view 
is flattened, all overlapping lines of equal length and all lines parallel to the line of 
sight are removed. The geometry is no longer associated with the model. If 
changes are made to the flattened geometry, those changes do not affect the 
model. If changes are made to the model, the flattened geometry is not changed.

1. Select a view window to make it the active view.

2. Choose Views>Flatten View.

A dialog box displays a warning message. Since flattening disassociates the 
current view from the model, be certain that this is not only the correct view to 
flatten, but also that it really should be flattened. All dimensions in the view are 
deleted because the 3D dimensions are not correct in 2D geometry. 

3. Click OK. The geometry is placed on the sheet at full scale.

Important:

• The geometry is flattened at the scale being viewed. This scale is listed in the 
Control menu of the detail view.

• Text and crosshatching are treated like geometry by this command.

• Dimensions no longer update if a change is made to the 3D model since the 
flattened geometry is disassociated, but they change if the flattened geometry 
is altered. Also if the geometry is dimensioned after it is flattened, the desired 
values must be entered manually because Graphite simply reads the length of 
the projected flat lines. To keep the dimensions, copy the view and flatten the 
copy, or group the geometry with the dimensions, then flatten the view.

• If the following message appears, The current view and the draft view have the 
same model, it is necessary to change the model on the sheet. Click the sheet, 
outside all views, then choose Views>Models. Click New and then click 
Current. Repeat the above steps to flatten the view.
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View Layouts
Included with Graphite are layouts set up with various views that can be chosen 
using the Sheet Into View command in the Views menu. It is also possible to 
create your own view layouts. In all but the Design.vc6, each view has the same 
scale. In the Design.vc6 layout, the Trimetric view is scaled as specified in the 
Sheet Into View dialog box and the other three views are scaled to 25% of the 
Trimetric view.

The default layouts available from the Sheet Into View command are as follows:

View Top
This layout shows the Top view of geometry, just as it is seen in 2D.

2.0

4.0

1.0

1.0
14-27



14-28

Advanced Viewing Techniques Ashlar-Vellum
Views with Standard Drawing Formats
A Landscape 4 VIEW.vc6 (Windows & Macintosh); =
4 views for an A size sheet

B Landscape 4 VIEW.vc6 (Windows & Macintosh); =
4 views for a B size sheet

C Landscape 4 VIEW.vc6 (Windows & Macintosh); = 
4 views for a C size sheet

D Landscape 4 VIEW.vc6 (Windows & Macintosh); =
4 views for a D size sheet

Vellum
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Design.vc6 (Windows); Views Design 4 (Macintosh)
This layout creates a Trimetric view at full scale and Top, Front, and Right views at 
1/4 scale.

The design layout is primarily for viewing the model while designing it. When 
choosing this layout it may be desirable to change the scale and rearrange the 
smaller views to prepare for plotting.

Draft.vc6 (Windows); Views Draft 4 (Macintosh)
This layout creates four full-scale views: Top, Front, Right, and Trimetric.

Sheet 1

Sheet
camera

Model with one additional detail view camera projecting its  
view in its active  view window.  

Models

Model 1

Sheets

Sheet 1

Model

Detail View Camera

Detail View Projector
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Trimtric.vc6 (Windows); View 
Trimetric (Macintosh)
This layout is a single Trimetric 
view at full scale.

Frntrit.vc6 (Windows); Views 
Front and Right (Macintosh)
This layout displays two full-scale views, the Front and Right.

Frnttop.vc6 (Windows); Views Top and 
Front (Macintosh)
This layout displays two full-scale views, the Top 
and Front.
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Tip:

Look at one of the files in the 
Layouts folder to see how it is 
set up. Be sure not to make 
any unwanted changes to 
these layout files.
Creating Custom View Layouts
The specifications for the view layouts available from the Sheet Into View dialog 
box are in individual Graphite drawing files stored in the Layouts folder in the 
Graphite folder. To create your own layout or a customized drawing format, simply 
edit one of the existing drawings in the Layouts folder, or create a new drawing 
and save it in the Layouts folder. The filename will then appear in the pull-down 
menu in the Sheet Into View dialog box.

Method 1
1. Choose File>Open and open a Layout file in the Layout folder.

2. Save the file under a different name in the Layout folder by choosing 
File>Save As before doing any changes.

3. Customize the layout as needed.

4. Save the file.

5. Select Views>Sheet Into View.

6. The new layout appears in the pull-down menu in the Sheet Into View dialog 
box. 

Method 2
Another way to create own layout is to design it in a new document.

1. Open a new document by choosing File>New.

2. Create a view window with the Detail View function.

3. Make the current sheet active by clicking anywhere outside the view window 
on the sheet.

4. Choose Views>Model and create Model 2.

5. Make Model 2 the current model in the Models dialog box.

6. Duplicate the view window as often as needed.

Duplicating or copying a view was discussed in Chapter 13.

7. Set each view window to the desired view orientation with the on-screen 
Trackball pull-down menu or the Views submenu in the Views menu.

8. Select Properties in the detail view window’s control menu to scale each view 
window.

9. Save the new layout under a proper name in the Layout folder of the Graphite 
folder.
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Drafting Methods with Views and View Layouts
Two different methods exist for creating 3D wireframe models:

• Start the model creation on the drawing sheet and add views later for editing 
and viewing the model from different angles.

• Use a view layout from the beginning and create the model in different view 
windows simultaneously.

Method 1
Open a document and create the geometry on an empty sheet. With the on-screen 
Trackball and the view commands in the View submenu, rotate the model and edit 
it from different angles as long as any detail view windows have not been created.

To view the geometry from different angles simultaneously, create detail view 
windows with the Detail View tool and place them on the sheet. The sheet view 
then shows an image of the model in the Top view on the sheet. In the view 
windows, display different view orientations of the geometry, like front, top, 
trimetric, etc.

As soon as a view window is 
created, the sheet view of the 
geometry remains fixed in the Top 
view parallel aligned and rigidly 
fixed to the sheet. As a result the 
view angle can only be changed in 
the detail view windows.

The view orientation of a sheet 
with a detail view cannot be 
rotated with the Trackball.
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The sheet view of the geometry may overlap the view windows on the sheet as 
shown in the upper graphic. Create a new sheet with the Sheets dialog box in the 
View menu and Cut and Paste the view window from Sheet 1 onto Sheet 2 to get 
a clear view on the view windows.

Something similar, but more elegant, is done by the Sheet Into View command in 
the Views menu. Sheet Into View puts Model 1 into one or more views and puts 
Model 2 on the current sheet.
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Method 2
With this method choose a view layout with the Sheet Into View command. The 
views provide a vantage point of the model. It places all geometry into one of the 
view layouts. It is possible to customize the view layouts.

Sheet into View puts Model 1 into one or more views as specified by the choice 
from the dialog box and creates Model 2 and projects it onto the current sheet.
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• By choosing one of the layouts that contain a title block and a border format, 
that format becomes Model 2 and is projected by the Sheet camera in the Top 
view on the current sheet.
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Combining Sheets, Views and Models
In general, a powerful CAD program is necessary for two tasks:

• The creation of the designs. 

• The generation of 2D engineering drawings, or blueprints, in order to get the 
designs built. 

The design phase is effortless and very productive with the help of Graphite's 
Drafting Assistant, integrated parametrics (Chapter 16), and the intuitive user 
interface itself.

For the second of these two tasks, very powerful and flexible drafting functions are 
desired, since there are so many possible types of drawings that might need to be 
created. One of the specific features in Graphite that handles this so well is the 
combined power of sheets, views and models.

For most daily work, it is not necessary to know anything about the relationship 
between sheets, views and models. But for some tasks it is helpful to understand 
this relationship since it offers elegant solutions that were not possible without the 
combined power of the features in Graphite.

The relationship between sheets, views and models makes it easy to:

• Place part views in different scales, such as 1:50, in a standard drawing format 
with a title block and borders that must be plotted at a scale of 1:1.

• Create detail views if an object that are not associative to the original model.

• Create customized drafting layouts.

• Recover from an erroneous Sheet into View command.

The first section of this chapter explained the use of sheets, views and models. 
Each is a simple and straight forward operation. In the graphics are shown the 
environment, and how sheets, views, and models are set up in Graphite. It is 
necessary to know the exact definition of all engaged components and the rules 
that describe how they interact.
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Components
The environment in Graphite for handling all geometry created can be described 
by five components—sheets, models, views, cameras, and projectors.

First, all geometry created is not created directly on the sheet on the computer 
screen but somewhere outside of the sheet in an infinitely large three-dimensional 
work space (Model space). All geometry is placed here as separate models. Only 
images or views of these models display on the sheet.

Sheets
A sheet is an infinite 2D planar area that displays an image of one or more 
models. The image of a model is picked up either by the Sheet camera and 
projected onto the sheet (the Sheet View) or by a Detail View camera and 
projected into a view window which is resting on the sheet (the Detail View).

• Sheets are arranged 
behind each other so only 
one at a time can be seen.

• Create as many sheets as 
desired, but with each 
sheet a blank model is 
automatically created, 
similar to the drafting board 
when starting with a clean 
sheet.

• Independent of how many 
models exist, it is possible 
to delete all sheets but 
one—the current sheet—
since Graphite needs at 
least one sheet to display 
the models even if they are blank.

• When deleting a sheet, all Detail Views resting on that sheet are deleted.

• Display as many Detail Views on one sheet as needed but only one sheet 
(Sheet View) at a time.

• When changing the current sheet, the related model is always activated. 
Change this relation only by assigning another model to that sheet.
14-37



14-38

Advanced Viewing Techniques Ashlar-Vellum
Models
A model is a collection of geometry, dimensions, text, fills and hatching. Models 
are placed in an infinite three-dimensional area. A model can be blank (then we 
call it Model space) just as it is when launching Graphite and looking at a blank 
sheet. Images of models are picked up by either the Sheet camera or by Detail 
View cameras and projected on the sheet. The view of the Sheet camera is called 
a Sheet View and the views of the detail cameras are called Detail Views.

• Create and delete as many models as desired.

• When changing the current model, move the related camera. The camera you 
move depends on what is active—the sheet or the detail view. If the sheet is 
active, the Sheet camera moves to the current model. If the detail view is active 
then the related Detail view camera moves.
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Tech Note:

The Drawing Size command 
changes only the plot scale 
but not the scale factor of the 
Sheet view. Even if the view 
is scaled to fit the paper 
format the scale factor 
remains 1:1 since the real 
size of the geometry is not 
affected.
Views
Views are the images picked up by cameras and projected on sheets. Graphite 
has two types of views—the Detail View and the Sheet View.

Detail Views
• Detail Views are picked up by Detail View cameras and always displayed in a 

view window which rests on the sheet. They have boundaries and display only 
a limited view of the model. 

Create as many views as necessary and move or copy and paste them to differ-
ent sheets. 

When deleting a detail view, the Detail View Camera deletes. When deleting a 
sheet which contains a detail view, the detail view deletes also since the detail 
view rests on the sheet.

• Place views from different models on one sheet, but each view can display only 
one model at a time.

• Once a detail view is created, the sheet camera remains stationary in the 
original x,y (world) orientation. The view of the sheet can not be changed.

Sheet View
• There is only one sheet view for each sheet. The sheet view is an infinite view 

picked up by the Sheet camera and displays everything on the sheet outside of 
all view windows. 

The sheet view cannot be deleted and needs at least one sheet to display its 
view. 

Since the sheet view, like the detail view, can display only one model at a time, 
use detail views to show more than one model on a sheet. 

• To activate a detail view click in the view window; to activate the sheet view 
click on the sheet outside of all detail views. If the Models dialog box is 
displayed, the related model is highlighted.

• The view orientation of a sheet becomes fixed when a detail view is created. 
The sheet camera remains stationary in the original x,y (world) orientation. The 
view of the sheet cannot be changed.
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Tech Note:

When changing the sheet, 
the Sheet camera is moved 
to the selected sheet and 
automatically displays it at 
the view scale which was 
current when the sheet was 
last changed.
Cameras and Projectors
There are two type of cameras—one Sheet camera and as many Detail View 
cameras as detail views created.

• The Sheet camera is permanently installed as default and displays its view via 
the sheet projector on the sheet. 

To move the Sheet camera perform a model change either by the Models com-
mand or by the Sheets command in which the Sheet camera moves automatically 
to the related model.

• Detail View cameras display their views via Detail View projectors in view 
windows which rest on the sheet.

Install as many Detail cameras as desired even if each one is looking at one 
model. Install Detail cameras by creating Detail views either by the Detail View 
tool from the tool palette or with the Sheet Into View command.

Move Detail View cameras to another model by performing a model change when 
the view window is active.

• Both cameras, the Sheet camera and a Detail View camera, can look at only 
one model at a time.

Using Sheets, Views and Models
We listed many rules in the sections above and they all describe the same fact 
that Graphite administers geometry (models), views and sheets separately. That 
has a lot of advantages. The most impressive example is if you delete a 
sheet displaying geometry. The geometry is not lost since the related model is not 
deleted. 

Practice the following examples and implement them in daily work. Using Models, 
Sheets and Views will become second nature and you will never want to work 
without them.
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Recovering from Deleting a Sheet Displaying Geometry
To restore the geometry displayed on a sheet deleted unintentionally, proceed as 
follows:

1. Select Views>Sheets.

2. Click New to create a new sheet.

3. Click Current to activate the new sheet and draw some geometry.

4. Make another sheet active by highlighting a different sheet in the Sheets 
dialog box and click Current.

5. Close the Sheets dialog box and select Views>Models.

6. Search for the before-displayed geometry by activating each Model followed 
by a Zoom All command until the previous geometry displays on the new 
sheet.

Displaying Three Components on One Sheet
Sheets, Views and Models are very helpful to display several components of a 
part created by different drafters on one sheet. The following simple example 
shows how to perform this task:

1. Open a new document.

2. Draw an ellipse.

3. Save the drawing as ellipse.vc6.

4. Open a new document and draw a rectangle.

5. Select Views>Sheet Into View.
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6. In that dialog box, choose the 
ViewTop layout, set the Scale to 1 
and click OK.

Now one Sheet is with one view 
window showing the Rectangle 
(Model 1). The Sheet camera aligns 
to Model 2 (created with the Sheet 
Into View command) displaying a 
blank model space on the sheet.

7. Make the sheet active by clicking 
on it and draw a circle.

8. Select Sheet Into View (the sheet 
still active) and choose Top view 
again with the Scale factor 1.

Now one Sheet has two view windows, one displaying the rectangle (Model 1) 
and one displaying the circle which became Model 2. The Sheet camera moves 
to the new Model 3 and an empty model space is displayed on the sheet.

9. Activate the sheet by clicking on it and select File>Import.

10. Select the file ellipse.vc6 and click OK.
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Tech Note:

In order to select overlapping 
view windows, Auto Front 
must be deactivated, as 
described in Chapter 13, 
“Viewing Geometry.”
The ellipse imports onto the current sheet and is added to Model 3 which was 
active when the Import command was performed.

11. Arrange the two view windows around the ellipse and rearrange the rectangle 
and the circle with the Zoom commands in the Arrange menu like in the 
following graphic.

12. Activate the sheet and in the Views menu deactivate the Show View 
Boundaries command.
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Graphite Documents
A document is a Graphite file. Whenever opening Graphite or choosing New from 
the File menu, a new document appears in the Graphite window. 

The sheets and layers features add a great deal 
of flexibility to the documents. They show various 
parts of a document individually or as part of the 
whole. Each document has one or more sheets, 
like the sheets of paper in a set of blueprints, and 
each sheet is made up of layers which are hidden 
or displayed as needed.

New users are sometimes too busy learning about 
Graphite to think about how to organize the 
drawings. Consider organization early, however, 
since eventually there will be a large number of 
drawings. Organization is particularly important for sharing files with other people.

The following topics are covered in this chapter. 

• Using Documents, including Opening, Recent File List and Saving

• Importing/Exporting

• Drawing at Full Scale

• Drawing Scale and Paper Size

• Drawing Formats

• Forms 

• Printing and Plotting
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Tech Note:

Use the Import command to 
bring in drawings of other 
format types, such as DXF, 
IGES, or ASCII text.
Using Documents
A drawing can be a simple part or a complex assembly. A new document opens as 
Untitled and remains untitled until it is saved. Saving a drawing is explained later 
in this chapter. 

The commands used to manipulate documents are in the File menu and in the 
Window>General palette.

New 
CTRL+N (Windows); +N (Macintosh)

This command in the File menu, or in the 
Window>General palette, creates a new 
Graphite document.

The new document has no name (the title bar 
shows Untitled 1), and is set with the default options, such as pen style or 
grid display. 

Opening more than one new document, the subsequent documents are numbered 
sequentially until named upon saving.

Opening Files
Open files using the Open command in the File menu or in the Window>General 
palette in the program or by double-clicking on the file to launch the program and 
the file.

Open Command 

CTRL+O (Windows); +O (Macintosh)

The Open command in the File menu, or in the 
Window>General palette, opens an existing 
Graphite document. The document appears in 
the drawing area maintaining the same settings 
as the last time it was saved.

The dialog box specifies the document name and folder as necessary.
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Tech Note:

The number of files contained 
in this list can be set in the 
Graphite.ini file (Windows) or 
the recent list file in the 
User’s Scripts folder 
(Macintosh). For more 
information, consult Chapter 
5 "Basic Environment 
Settings.".
Opening a Document
1. Choose File>Open or click the Open (second) icon in the 

Window>General palette.

The dialog box appears.

The current folder displays the files and/or folders contained within.

2. Display the appropriate folder containing the document to open.

 The Vellum Graphite file extension is .vc6, where v is for Vellum and c6 is the 
chemical abbreviation for Graphite.

3. Click the file name to open in the list box.

4. Click OK. 

Opening a File when Graphite is not Running
Open a file and launch Graphite at the same time by double-clicking on the file. 
The program launches automatically and the file opens. By using this technique, 
no untitled file opens.

Recent File List
Another way to access files that were opened recently is through the Recent File 
List that appears at the end of the File menu. This list contains the names and 
paths of recently opened Graphite files.

To open a file from the Recent File List, simply select the file from the File menu. If 
the file has been moved since it was last used and the path is no longer accurate, 
Graphite provides the standard Open dialog box to locate the file.

Saving a Drawing
Save a drawing by choosing File>Save, or Save As, or clicking 
the corresponding icons in the Window>General palette. The 
file is stored on the computer in the folder specified.
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Tip:

Use AutoSave so that 
Graphite automatically saves 
the work. Choose 
Layout>Preferences>
AutoSave.
Save Command 

CTRL+S (Windows); +S (Macintosh)

The Save command in the File menu, or icon in 
the Window>General palette, saves the current 
Graphite document to its original folder. To save 
it to a different folder or with a different name, 
choose Save As. If the document has not been saved previously, the Save As tool 
dialog box appears automatically, requesting the name and the folder in which to 
save it.

If the document was named and saved before, a brief message appears when 
choosing Save, and the program pauses while it updates the information.

Save frequently. Even though the drawing appears on the screen, it is not stored 
on the disk until saved. Hours of work can be lost because of a power failure. It is 
also important to save before performing any intricate, multistep maneuver. In that 
way, if the result is not exactly what it is hoped, abandon the file by closing it 
without saving.

Save As Command
The Save as command in the File menu, or in the 
Window>General palette, saves the current 
document. A dialog box appears in order to name 
the current document, give it a different name, or 
save it to a different directory.

Saving in the Current Directory
1. Choose File>Save As or click the Save As (forth) icon in the 

Window>General palette.

The Save Drawing As dialog box appears.

2. If necessary, display a different folder.

3. Type the name to use in the File name data field.

4. Either press ENTER (Windows), RETURN (Macintosh) or click OK.

The Vellum Graphite file extension is .vc6, where v is for Vellum and c6 is the 
chemical abbreviation for Graphite.

Use the Save As command to make a backup of a document.
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Making a Backup 
It is always a good idea to make a backup of the file in case you want to return to 
the original version after making many changes. Choose File>Save As and save 
the file with another name. It’s possible that periodic backups are made of the 
directories by you or your IT department, and you can go back to a previous 
version that way.

AutoSave Command
This command is found under Layout>Preferences and directs Graphite to save a 
backup copy of the work periodically. If the computer crashes for any reason, the 
work done up to the last AutoSave is recoverable.

In the AutoSave dialog box turns 
AutoSave On or Off, and specifies 
the time interval (in minutes) 
between AutoSaves. At the specified 
interval, Graphite creates an 
AutoSave file with the base of the 
original file name and the .SAV 
extension. AutoSave prompts for a 
file name before creating an 
AutoSave file of untitled documents 
(created by using the New command from the File menu). If a file name is 
supplied, this file name is associated with the document and the AutoSave file. If 
Cancel is clicked, AutoSave skips that document, but the prompt appears again at 
the next AutoSave interval.
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Setting up AutoSave
1. Choose Layout>Preferences>AutoSave. The AutoSave dialog appears.

2. Switch AutoSave On or Off. The default setting is off.

3. Specify the time interval for AutoSaving in minutes in the AutoSave Interval 
data field. The interval can be from 1 to 60 minutes; the default setting is 15 
minutes. An interval of 0 or less is equivalent to turning AutoSave off.

4. Click OK.

If AutoSave is on the work is automatically saved for the specified time 
interval. To save these settings permanently, choose 
Layout>Preferences>Save Preferences. Close any open untitled files before 
saving the preferences, otherwise, with AutoSave On, the Save As command 
continually appears.

Close Command
CTRL+F4 (Windows); +W (Macintosh)

The Close command in the File menu closes the current Graphite document (the 
one displayed in the top window). If other Graphite documents are open, they 
remain open when closing the current document. If any changes were prompts for 
each made since the last time the current document was saved, a dialog box 
displays in order to save the changes. Close the document with or without saving 
the changes.

For Windows, close the document by double clicking the Control menu at the 
upper left corner of the title bar. For Macintosh, click the Close button once at the 
upper left corner.

Exit Command (Windows) or Quit Command (Macintosh)
CTRL+Q (Windows); +Q (Macintosh)

The Exit or Quit commands in the File menu closes Graphite. If changes were 
made since the file was last saved, a dialog box displays in order to save the 
changes. If more than one document is open, an alert message displays in order 
to save unsaved documents.
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File Organization
Graphite automatically organizes files using the Directory function in Preferences. 
When opening, saving, importing and exporting files, Graphite goes to the 
directory or folder specified.

1. Choose Layout>Preferences>Directory.

The Directory Selection dialog box appears with four fields for specifying the 
directory location.
15-7



15-8

Graphite Documents Ashlar-Vellum
2. Enter the directory path in each data field. Either type the path or browse the 
computer for the folder and have the path entered automatically.

To browse, click on the Browse button and locate the desired folder. 

Click OK.

The path appears in the selected data field of the Directory Selection dialog box.

3. Repeat step #2 for all of the directories specified.

4. Click Apply to save the settings and close the dialog box.
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Importing and Exporting
Before beginning a file translation for Graphite, establish a clear purpose for any 
particular translation. Consider if the translated data must be edited or just viewed 

and/or printed. If it is to be viewed or printed, use the Graphite ShareTM utility 
available FREE on the Ashlar-Vellum web site. Graphite Share opens, views, 
prints and exports Graphite and older Vellum 2D/3D files. Send Graphite Share to 
a client or manufacturer free of charge along with a Graphite file. Share allows 
them to export the file themselves, experimenting with the file format that works 
best for their needs.

On the other hand, if the translated data must be manipulated and saved, consider 
if the target application that can handle the data being translated to it properly, 
such as multiple sheets in one file.

Remember that re-importing a file successfully into the original format neither 
proves nor disproves its translation accuracy. 

Older versions of Vellum had difficulties with metric-to-English conversions. These 
were addressed in Graphite v6, but be aware of the issues if any archive files 
need to be converted.

Use Zip or Stuff-It to compress files before emailing. Using an email program’s 
built-in compression has unreliable results on graphics, often converting them to 
text files. This is especially true if emailing a file from a Mac to a Windows-based 
system.

The reasons to use the import and export features of Graphite are:

• Bringing a document in from another application to work on in Graphite. 

• Saving a document in a format other than Graphite for use with another 
application. 

• Importing or exporting text to or from a Graphite document that's an ASCII text 
file. 

Graphite offers a wide variety of options to accomplish this.
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Tip:

When importing into Graphite, 
choose Arrange>Zoom All to 
see the imported geometry.
Import Command
This command in the File menu imports a document and places it in the current 
model. The names of documents in a format Graphite can read are displayed in a 
dialog box that works like the Open dialog box.

1. Choose File>Import.

A dialog box appears similar to the Open dialog box.

2. Windows Select the file type to import from the Files of Type list box. The list 
box shows all files of the selected type available in that folder.

Macintosh Skip to the next step.

3. Double-click the File name to import.
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The Import dialog box appears.

4. Specify import options. 

5. Click OK.

The file appears in the drawing area. To save the file in its original format after 
editing, choose the File>Export.

The file formats Graphite imports are listed below:

Graphite and Vellum Ashlar-Vellum’s native file formats for current and 
previous versions.

Text ASCII text file.

Claris CAD Claris CAD native file format

DXF AutoCAD’s Data eXchange Format. R14 and 
ACAD2007 files can be imported. 

DWG AutoCAD’s native file format. R14 and ACAD2007 
files can be imported.

IGES IGES version 4.0 Initial Graphics Exchange 
Specification. The translator also supports IGES 
entity 128 and 144 NURB surfaces and importing 
an unlimited number of entities.

EPS Encapsulated PostScript format for printing to a 
postscript printer.

Spline Text file, which Graphite converts to a spline.

MetaFiles (Windows only) Windows Metafile Format
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Tip:

To ungroup the imported 
geometry choose Arrange> 
Ungroup.
Bitmaps (Windows only) Windows BitMaP Format

Pict (Macintosh only) Macintosh native file format.

BMI CADAM BMI’s file format.

Using the Import command, Graphite detects the format of the document and 
displays a dialog box showing the format and asking how to bring the geometry 
into Graphite. 

Grouped Brings the geometry into Graphite grouped so it is 
a single unit in the Graphite document. 

Geometry Only Brings in only the geometry, leaving any text, 
dimensions and crosshatching behind. 

Onto Work Layer The imported geometry is placed on the work 
layer rather than on the layer on which it was 
originally created.

Unscaled When checked, uses the drawing scale to resize 
the part (i.e. a 12” line becomes six inches with a 
2:1 drawing scale).
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Importing DXF Files
While Graphite offers high visual fidelity for dimensions and text in DXF format, if 
the goal is to import or export archive drawings, preserving the text and 
dimensions, use a free copy of Ashlar-Vellum Share or buy Adobe Acrobat 
instead.

DXF files do not always specify units. Be sure to set Graphite to match the source 
file prior to importing it. Also, because individual users customize their systems, 
there is often difficulty in translating fonts, line weights and patterns, dimensioning 
styles, hatch patterns and custom symbols. Be sure these are also present on the 
destination system.

When importing a DXF file, the geometry is constructed according to the units set 
in Preferences when choosing the Import command. Be sure to set the 
appropriate units before importing DXF geometry.

Importing ASCII Text from Another Document
1. Choose File>Import.

The Import dialog box appears.

2. Select the filename to import. 

3. If Text is not selected, click the Text button.

4. Click OK. 

The text appears in a text box in the drawing.

Importing Splines
Importing a text file that contains the coordinates of a spline, Graphite creates the 
spline according to the imported coordinates.

1. Select File>Import.

Graphite displays the standard Open dialog box.

2. Select a text file that contains the coordinates for the spline.

The Import dialog box displays.

3. Specify the import option Spline.

4. Click OK. 

Graphite begins creating the Spline.
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Creating a Text File for Importing a Spline
1. Use a text editor, a word processor or a spreadsheet to create a text file.

2. Input X, Y and Z values for the spline coordinates. 

The text file should be tab or space separated. Each line ends with a return. 
Line feeds after each return should have no effect.

The text file should conform to the following columnar format:

1 1 0

2 2 0

Specify decimal coordinates as well:

1.33 1.1 0

2.4 2.5 3.5678

Be sure to press ENTER (Windows) or RETURN (Macintosh) after the last 
coordinate, if Graphite will not import the coordinates specified in the last line.

3. Save the file as Text only and import into Graphite to create the spline.

How Importing Affects Some Objects
It is difficult to exchange data between different graphic programs because each 
program defines geometric objects differently. All entities created in one program 
may not translate accurately or at all depending on what the program supports. 
The following lists are specifics about entities for two translators.

DXF/DWG Graphite

Blocks Convert into groups.

Center Mark Convert into lines.

Crosshatch Convert to grouped lines.

Donuts Convert to grouped Three Point arcs.

Double lines Convert to lines.

Points Convert into Points.

Polygons Convert into grouped lines.

Polylines Polylines and 3D polylines convert into lines.
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3D Face Converts into lines that define the polygonal 
boundary of the face.

View Ports Not supported.

EPS Graphite

Line All shapes and attributes are maintained.

Curve Curves convert into splines. All shapes and 
attributes are maintained.

Fill All shapes and attributes are maintained.

Fill/line All shapes and attributes are maintained.

Non-fill/Non-line Not supported.

Text Not supported.

Weight Converts to the current weight.

Color (white/black) Converts to the nearest of the first seven colors.

Process color Convert to the nearest of the first seven colors.

Custom color Converts to the nearest of the first seven colors.

Pattern Converts to black fill.

Layer Layer name and elements are retained. Layers 
that contain no elements are not retained.
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Export Command
The Export command in the File menu saves a document in the format specified.

1. Choose File>Export.

The Export dialog box appears.

2. Click the desired file type. To export only selected objects on the screen, rather 
than the entire document, click Only Selected.

3. Click OK. The Export file dialog box appears. 

The Export dialog box is identical in both appearance and function to the Save 
As dialog box. For Windows, filename extension indicates the type of export 
file.

Types of Files

The following file types can be exported:

Graphite and Vellum Ashlar-Vellum’s native file format for current and 
previous versions.

DXF AutoCAD’s Data eXchange Format. R14 and 
ACAD2007 files can be exported. 
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DWG AutoCAD’s native file format. R14 and ACAD2007 
files can be exported. 

IGES Initial Graphics Exchange Specification, version 4, 
the National Bureau of Standards format to 
standardize the exchange of graphics. The 
translator also includes the support of IGES entity 
128 and 144 NURB surfaces and exporting an 
unlimited number of entities.

TEXT ASCII characters. This option is available only if 
the Text tool is the active tool.

Bill of Materials A listing of assigned attributes in an ASCII

PDF Adobe’s Portable Document Format

META (Windows only) The format used by the Windows 
clipboard, is an interchange format specifically 
used for graphics commands. A document saved 
in this manner contains only the routines to 
reproduce the drawing as it appears on the 
screen. 

Bitmaps (Windows only) Microsoft Windows Bitmap file 
format. 

BMI CADAM BMI’s file format.

Pict (Macintosh only) Macintosh's Pict file format 
which uses object-oriented bitmaps or resolution 
independent graphics.

EPS Encapsulated PostScript format for printing to a 
Postscript printer and for importing into 
compatible applications.

By specifying Only Selected, only the selected objects in the drawing are saved in 
the export format. If Only Selected is not specified, all objects are saved for 
export.
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PDF

CAD files do not archive or email well and PDF files don’t allow for further CAD 
editing or machining. It is possible, however, to create multi-sheet PDFs directly 
from within Graphite and embed .dxf and .vc6 files directly in the file.

PDFs email easily and they accurately reproduce fonts, line styles and patterns, 
but allow no access to manipulate the source data for editing, printing or 
manufacturing.

Graphite’s built in PDF writer has several advantages over the PDF maker built 
into the operating system. In Graphite it is possible to create multi-sheet PDFs 
drawn from multiple models in the same file. Optionally embed a Graphite file or a 
DXF export file directly in the file. Everything for an entire project can be emailed, 
displayed and archived.

Use Adobe Acrobat to further enhance the file, inserting and replacing pages, 
commenting and marking changes or tracking revisions.
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Creating a PDF in Graphite
1. Chose File>Export.

2. Select PDF from the Export dialogue box and click OK.

3. The Save File As dialogue box appears. Enter the name and location to save 
the PDF.

4. The PDF attachment box appears. Select which file to include and click OK.

How Exporting Affects Some Objects
It is difficult to exchange data between different graphic programs because each 
program defines geometric objects differently. Even though the DXF and IGES 
formats standardize this exchange, some objects do not transfer exactly. For 
example, crosshatching is no longer associative although it does appear in 
exported files. The following table tells what to expect when exporting Graphite 
objects.

Graphite DXF

Crosshatching Supported.

Detail views The view is lost, but the dimensions and text are 
retained.

Diameter dimension The leader style may change.

GD&T symbol The feature control frame converts to non-GD&T 
symbol representation.

Layers Layers are maintained.

Lines with arrows Lines with arrowheads at the start and/or end are 
converted into lines and solids.

Locked geometry The geometry is retained, but it is no longer 
locked.

Line Weight AutoCad 2000 and higher only.

Multiple sheets Each sheet must be exported individually.

NURB splines Convert to splines.

Radial dimensions The leader style may change.

Smart Walls The double lines convert to 
symbol representation.

Solid Fills Convert into solids.
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Symbols Convert into blocks.

Tolerances The tolerance is lost, but the dimension remains.

Graphite IGES

Crosshatching Converts to symbol representation.

Detail views The view is lost but the dimensions and text are 
retained.

Diameter dimension The leader style may change.

Fonts Fonts are not maintained.

GD&T symbol The feature control frame converts to a group of 
non-GD&T geometry.

Grouped geometry The geometry is retained but it is no longer 
grouped.

Layers The layers are lost but the geometry is retained.

Locked geometry The geometry is retained but it is no longer 
locked.

Multiple sheets Each sheet must be exported individually.

Radial dimensions The leader style may change.

Smart Walls The double lines convert to 
symbol representation.

Text A multiple line note becomes many single lines.

Graphite EPS

Line All shapes and attributes are maintained.

Circle Converts to a spline. All shapes and attributes are 
maintained.

Arc Converts to plural connected paths (a maximum 
of 8 paths and 45 degrees). All shapes and 
attributes are maintained.

Ellipse Converts to plural connected paths (a maximum 
of 8 paths). All shapes and attributes are 
maintained.

Spline All shapes and attributes are maintained.
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Fill All shapes and attributes are maintained.

Hatch Patterns are not maintained.

Wall Line.

Dimension Not supported.

Text Not supported.

Picts Not supported.

Groups Group attributes do not convert.

Layer Layer names, shapes, attributes and elements 
are retained. Layers that contain no elements are 
not retained.

Color Converts to the nearest of the first seven colors.

Weight Line weight converts to one point.

Line patterns Not supported. All lines are converted into solid 
lines.

All geometry is exported as individual elements, except in the following 
circumstances:

• Fill geometry

• Grouped geometry

EPS Translator 
This translator shares data between Graphite and other EPS applications. It was 
optimized for Adobe Illustrator 5.0J but works with other applications that support 
the EPS file format. This translator imports a postscript file into Graphite (text is 
not translated) and exports drawing data.
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Translator Notations
In postscript's expression, drawing data is described as a “path.” 2D drawing data 
is expressed by the values given for the path from the startpoint to the endpoint. 
Straight lines and Bezier curves create such paths.

For example, a circle contains the following components:

• 4 connected Bezier curves (in Adobe Illustrator the path is structured by anchor 
points (startpoint, centerpoint and endpoint) and segments). If the circle is 
created using one tool, then the anchor points are connected.

• Path width: user-defined units or points (1pt=0.35 mm)

• Path Color: user-defined

• Fill inside Startpoint~Endpoint: user-defined

• Fill Color: user-defined

CADAM BMI Translator
The CADAM BMI translator shares data between Graphite and CADAM. The 
translator converts this data, using the BMI format, into a neutral file format of 
CADAM.

All recognizable entities will be converted with their attributes. For unrecognizable 
entities, only the shapes will be converted.

The translator works according to the graphic below.

The VelBmi.ini file is the Control Parameter file. This parameter file is used in the 
translation of the geometric entities in the drawing.
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Tips for the Best Possible Translation
In general, it is recommended to show all the layers before exporting from 
Graphite or any other CAD package to know what objects are exporting.

• Graphite was designed to export only the current model. If there are Detail 
Views in the file, flatten them with the Flatten View command found in the Views 
menu. If dimensions already appear in the detail view and the view scale is set 
to 1, group the dimensions and geometry together before flattening the view. 
This brings the dimensions across to the current model for Export.

• Graphite supports 256 layers. If a DXF file contains more than 256 layers, the 
geometry that is on the additional layers is automatically placed on the current 
work layer in Graphite. If this is not desirable, reduce the number of layers to 
maximum of 256 in the application where DXF file is being created. 

• Attributes in an AutoCAD file do not come into Graphite as text because 
Graphite does not support that entity type. To bring the attributes into Graphite 
via DXF, convert those attributes to Text before Exporting from AutoCAD.

• If, when translating to AutoCAD, the line patterns do not seem to come across 
or are distorted (too big or too small), change the AutoCAD variable LTSCALE 
to a smaller number to display the line patterns at an appropriate scale.

• With some angular dimensions, the arrow may be displayed in AutoCAD in the 
wrong direction (pointing towards the text rather than towards the extension 
lines). If this happens, execute the DIM command in AutoCAD, select the 
affected dimensions, and use the UPDATE command to display the arrow 
correctly.

• To export from Graphite to Illustrator, use the EPS format. Be aware that 
dimensions, text, and .pict and .bmp images are not supported by EPS in this 
process. Remember that EPS does not support 3D data. It will translate all data 
to the top view, unless the 3D data is flattened before exporting as EPS. If text 
and dimensions are needed for Illustrator, export using the DXF format or print 
to Post Script. Usually the easiest way to get simple data into Illustrator is to 
highlight it in Graphite, then copy it to the clipboard and paste it into Illustrator.

• We recommend using DWG for translating data between Graphite and Pro/E.

• DWG is the preferred method of translation between Graphite and SolidWorks.
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Convert Command
This command in the File menu starts the Convert batch translator importing and 
exporting multiple files in an unattended mode. It imports all files of the same type 
from one folder and saves these files in the selected format into a destination 
folder.

Converting Multiple Files
1. Create two folders.

One folder is used to store the 
original files (the FilesIn folder), 
the other folder stores the 
converted files (the FilesOut 
folder).

2. Copy all files to convert into the 
FilesIn folder.

3. Select the File>Convert. 

The Multiple File Translation 
dialog box appears.

4. Select the file type being 
translated from the Input File 
Format column.

5. Select the file type being 
translated from the Output File 
Format column.

6. Check the Draw each file option, 
if desired.

Mark this option to see each file 
during the conversion process. If 
this option is not selected, 
Graphite opens a blank drawing 
window, performs the 
conversion, closes the blank 
window and repeats the process 
for each file in the folder.
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For large drawings or large quantities of drawings turning off Draw each file 
speeds up the operation.

7. Click OK.

The Open file dialog box displays.

8. Open the folder (FilesIn) that contains the files to convert.

9. Select a single file and click Open.

The selected file must be of the same type as was selected for Input File 
format or Graphite generates an error message.

10. Select a destination folder (FilesOut) for the translated files or create a new 
one.

Specify a new extension to identify the converted files (it is reasonable to use 
the standard file type extension like .dxf for DXF files or .igs for IGES files. 
This is not necessary for the Macintosh but may help in file organization.

Graphite will convert every file from the Input folder that is of the same type.

Select a Graphite file in the Input folder, and requested convert to DXF, Graphite 
converts every Graphite file in that folder to DXF, and places those DXF files in the 
Output folder selected. If the folder also contains IGES files, they are not 
translated.

Specify DXF as the Output file format, Graphite asks once to convert thick lines to 
be Polylines. Whatever is specified is valid for all DXF Files in that folder.
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Tech Note:

Zoom All magnifies or 
reduces all objects on a 
drawing to fill the screen—
regardless of how big or small 
the objects are.
Drawing at Full Scale
Whether designing or drafting a highly detailed blueprint, create the geometry at 
its actual size. Graphite enables constructing the part using full-scale 
specifications and then setting the visual scale of the drawing. In this way, the part 
dimensions to its true-to-life measurements. Drawing at full scale has the following 
advantages:

• Scaling mistakes are eliminated.

• Dimensions are automatic (dimension manually if not drawing at full scale).

• Associative dimensions update when the object is edited (manual dimensions 
do not).

• The size relationship of imported parts is compatible.

• Calculations for 2D analysis are accurate. (See Chapter 18 for more 
information.)

Once the project is drawn, it can be dimensioned, scaled it visually, and sized to fit 
into a standard drawing format, if needed. The actual size of the geometry 
remains constant unless edited. 

When opening a new Graphite document, the drawing area is a sheet that is 
infinitely large to design anything at full size. For a simplistic example, here's how 
to draw and view a line 83 feet long:

1. Draw a line, specifying 83' for the length. 

The line extends off the screen. 

2. Choose Arrange>Zoom All. The entire 83 foot line is visible on the screen.

Using the draw to scale/Zoom All method, create accurate full-scale drawings 
which are displayed at the magnification chosen. 

Reminder: The actual size of an object is not affected by zoom magnification or 
reduction. 

Scaling Line Patterns and Crosshatch Patterns
If the unscaled construction is very large or very small compared to the size of 
added text and dimensions, line patterns and crosshatch patterns are 
inappropriately sized. By setting the scale for the drawing with the Drawing Size or 
Sheet Into View command, line patterns and crosshatch patterns are automatically 
scaled with the inverse scale factor specified. The patterns appear at the 
appropriate size for the view scale of the geometry.
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Tech Note:

When scaling smaller, 
multiply the text size by the 
scale factor. If scaling larger, 
divide the text size by the 
scale factor.
Scaling Text and Dimensions
If drawing objects that are scaled visually, text, dimensions, line patterns and 
crosshatch patterns behave, when scaled, differently than the geometry created. 
While geometry always scales with the specified scale factor, text and dimensions 
scale with the inverse scale factor set with the Drawing Size or Sheet Into View 
command.

While the inverse scale factor applies immediately to line patterns and crosshatch 
patterns as described in the section above, the inverse scale factor applies only to 
future text and dimensions added after scaling. Existing text and dimensions scale 
with the same scale factor as the object geometry. A 12 pt. text that was created at 
a 1:1 drawing scale is 24 pt. on a page printed at a 2:1 scale. The size of the text 
does not change relative to the other geometry in the file.

To keep the text size specified before scaling, choose the Keep Text Size and 
Keep Dimension Text Size options in the Drawing Size dialog box. This changes 
the size of the text relative to other geometry in the file. For example, 12 pt. text 
that was created at a 1:1 drawing scale is still 12 pt. on a page printed at a 2:1 
scale. The size of the text is half as small as before changing the drawing scale, 
relative to other geometry.

Another method of controlling text size and dimensions while scaling is to 
calculate the needed text size manually as shown in the following example.

When calculating the text size for scaling manually the rule is: set the text size to 
the inverse of the scaling factor. (The text size affects both text and dimensions.) 
In that way, the text elements of the drawing are proportional with the size of 
the geometry.

For example, if an assembly is 83 feet wide, scale that assembly 1:100 (a scale 
factor of .01) to place it in a drawing format. This requires using text that is equally 
large to read it visually when scaling the drawing. The final text to be .156 inch in 
height, specify 100 x .156 for the text size in the drawing. With the manual 
calculation make this specification before beginning dimensioning or annotating.
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Tech Note:

The relationship between the 
object and the text should 
appear normal when zoomed. 
If it looks right, it is right.
Scaling Text and Dimensions Manually
1. Choose Text>Size>Other.

The dialog box displays the measurement of the text.

The Font Size is set to .156 inch.

2. Click after the entry in the data field.

The text cursor blinks in the data field.

3. Enter *100 and click OK.

Subsequent text and dimensions are one hundred times the original size, or 
15.6 inches. When adding dimensions, the text size is appropriate for the part.

Drawing Scale and Paper Size
When the design is ready to be detailed with line patterns and dimensions, or to 
print or plot the design, scale the view of the drawing to fit the paper used.

Specify a printer or plotter, the paper format and orientation, and then the drawing 
size for the specified format.

Print to PDF
Graphite’s built in PDF writer has several advantages over the PDF maker 
included into the operating system, such as embedding source and other target 
export files. It also supports multiple sheet drawing.
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Print Setup (Windows); Page Setup (Macintosh)
The Print Setup or Page Setup command in the File menu sets the page size, 
orientation and other options. 

Setting up the Page
1. Select the plotter or printer.

2. In the Paper Size menu, select 
the paper size.

3. Specify the orientation. 

Drawing Size Command
The Drawing Size command in the Layout menu shows the size of the maximum 
plotting/printing area relative to the drawing. It also specifies the scaling of the 
drawing so it fits the paper size and orientation set by the Print Setup (Windows) 
or Page Setup (Macintosh) command. The Drawing Size window has two tabs: 
Printing and PDF Exporting.
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Tip:

When scaling the drawing, 
text and dimensions behave 
differently from the geometry 
created as described under 
the “Scaling Text and 
Dimensions” section earlier in 
this chapter.
Setting Up the Drawing Size for Printing to Paper
If the geometry is larger than a standard piece of paper, or so small that it would 
be impossible to use it at full scale, set the Drawing Size. In many cases, it may be 
desirable to use a standard drawing scale (such as 1/4 inch = 1 foot) for the 
drafting project.

1. Choose Layout>Drawing Size. A dialog box appears.

2. Select Printing from the list.

3. Specify the scale, using one of three methods below as necessary:

• Click the Drawing Scale data field and enter a scale ratio (Plotted Size: Actual 
Size). Enter real values, such as 0.25'' : 1', which Graphite converts to 1:48. 
Click Apply to see the effect of the scaling. 

• Or press the arrow beside the Drawing Scale data field and choose one of the 
standard ratios from the menu. Click Apply to see the specified scaling.

• Or click the Scale Font from PDF button to copy the text scale from the PDF 
Exporting tab if preferred. Make sure that the Keep Text Size option is 
checked to enable this functionality. Click Apply to see the result of scaling.

The Cancel button on the Drawing Size dialog box doesn’t abort changes if Fit 
or Apply were chosen first.
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Note: 

This is NOT the same as 
Print to PDF. You may still 
Print to PDF by configuring 
PDF printer software from 
an appropriate supplier.
If a specific scale is not needed, click Fit to scale the drawing to fit the paper. 

With any of these methods, the geometry itself does not change scale on the 
display; it only changes visually, not physically.

4. When printing multiple sheets and taping them together, follow the directions 
for “Tiled Printing” on page 15-34 later in this chapter. 

5. Click OK. 

Setting Up the Drawing Size for Exporting to PDF 
PDF is basically electronic or virtual paper with some of the same issues as actual 
paper. There are separate settings for Exporting to PDF because sometimes you’d 
like to use a different paper size than is supported by your printer. 

1. Choose Layout>Drawing Size. A dialog box appears.

2. Choose the PDF Exporting tab.
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Tip:

When scaling the drawing, 
text and dimensions behave 
differently from the geometry 
created as described under 
the “Scaling Text and 
Dimensions” section earlier in 
this chapter.

Referral:

An exact description of the 
Sheet Into View command is 
in the Chapter 15 "Tiled 
Printing."
3. Specify the width and height in the W and H data fields or click the down arrow in 
the data field on the right to choose one of the predefined sizes. Set the margins 
for the left, top, right and bottom edges of the page in the L, T, R, B data entry 
fields.

• Click the Drawing Scale data field and enter a scale ratio (Plotted Size: Actual 
Size). Enter real values, such as 0.25'' : 1', which Graphite converts to 1:48. 
Click Apply to see the effect of the scaling. 

• Or press the arrow beside the Drawing Scale data field and choose one of the 
standard ratios from the menu. Click Apply to see the specified scaling.

• Or click the Scale Font from Printer button to copy the text scale from the 
Printing tab if preferred. Make sure that the Keep Text Size option is checked to 
enable this functionality. Click Apply to see the result of scaling.

The Cancel button on the Drawing Size dialog box doesn’t abort changes if Fit or 
Apply were chosen first.

If a specific scale is not needed, click Fit to scale the drawing to fit the paper. 

With any of these methods, the geometry itself does not change scale just the 
display; it only changes visually, not physically.

4. When printing multiple sheets and taping them together, follow the directions for 
“Tiled Printing” on page 15-34 later in this chapter. 

5. Click OK. 

Setting the Visual Scale with the Sheet Into View Command
Once a full-scale part has been drawn and dimensioned, then create a visually-
scaled view of that part. The Sheet Into View command performs the details of this 
operation automatically.

1. Choose Arrange>Zoom All.

All objects are displayed on the screen.

2. Choose the Views>Sheet Into View.

3. Enter the scaling value in the Scale data field of the Sheet Into View dialog box. 
Figuring this value is similar to drafting on paper, determining which scale to use 
so that the finished part fits on the paper size.

4. Click OK. 

The part is now in an independent view, scaled as specified. 
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Tech Note:

The location of the Layout file 
for the drawing formats varies 
with the version of Graphite, 
the platform and the version 
of the operating system. It 
can be found under User, 
Workgroup, System (Mac 
only) and/or Program. For 
specific information on your 
version try the 
knowledgebase in the 
Support Center on the 
website at www.ashlar.com.

Tech Note:

It is only possible to pan when 
the Drawing Size dialog box is 
open. Once closed it is no 
longer possible to adjust the 
boundaries through panning.
Scaling does not change the actual dimensions of the part. Verify this by selecting 
an object and then looking at the specifications of that object in the Edit Objects 
dialog box.

Printing/Plotting Region
Select Layout>Drawing Size and then click Always Display Page Bounds. A gray 
rectangle appears in the drawing area. This rectangle represents the printing/
plotting region of the page to show how the drawing fits the paper. The plotting 
region is smaller than the actual page size because most printers and plotters 
cannot plot to the edge of the paper. For the plottable outline not to show all the 
time, uncheck Always Display Page Bounds.

The size of this region is based on the 
paper size and the printer or plotter drive 
currently selected.

When the boundary of the printing/
plotting region appears, drag the 
boundary rectangle around the drawing 
area with the Hand pointer, as shown 
above. The cursor becomes the Hand 
pointer when the cursor is moved outside 
of the dialog box.

To change the paper orientation while the 
Drawing Size dialog box is visible, 
choose File>Print Setup (Windows) or 
Page Setup (Macintosh) and enter the 
specifications. The new specifications 
appear in the drawing area.
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Tiled Printing
When using a printer rather than a plotter, it is possible to tape pages together to 
get a larger drawing than laser printers allow. Specify the layout for those pages 
by choosing Layout>Drawing Size.

1. Choose Layout>Drawing Size.

2. Specify the number of pages Across for the final drawing.

3. Specify the number of pages Down for the final drawing.

4. Specify the order for printing the pages (Across then Down or Down then 
Across). 

5. Click Fit.   

6. Click OK.

The drawing scales to fit the number of pages and layout as specified.

Preview Layout
The Preview Layout command in the File menu shows the size and orientation of 
the printing area specified in Print Setup (Windows) or Page Setup (Macintosh) by 
displaying a black border. If a printing/plotting size is not specified, the default size 
is used. To remove the page border display, select the command again or simply 
select a tool from the tool palette.

If the drawing does not fit the paper size, choose Layout>Drawing Size.
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Tech Note:

The location of the Layout file 
for the drawing formats 
varies with the version of 
Graphite, the platform and 
the version of the operating 
system. It can be found under 
User, Workgroup, System 
(Mac only) and/or Program. 
For specific information on 
your version try the 
knowledgebase in the 
Support Center on the 
website at www.ashlar.com.
Drawing Formats
When a part is complete and ready to be placed in a formatted border, Graphite 
provides many options. Not only can all drawing formats be modified in the Layout 
folder, but it is also possible to create your own drawing formats and design 
layouts as well.

Graphite distinguishes between Drawing Formats and Design Layouts. Drawing 
formats contain the border line of the drawing, the cutting line and a Title block for 
entries such as name and scale of the drawing. Design layouts contain a border 
and detail views.

• Drawing formats have to be created for each paper format such as A, B, C or D 
and for both paper orientations Portrait and Landscape.

• All drawing formats found in the Layout folder are designed for Plotter devices, 
where the cutting lines correspond exactly with the dimensions of the selected 
paper format (for example 30 x 40 inch for the D Format) and the Border line is 
offset inside by a half inch according to the ANSI standard.

• When using these plotter formats for a laser printer it is necessary to adjust 
them to the printing area of the printer, since they often differ from printer to 
printer.

• Design layouts contain, in addition to the drawing format, one or more detail 
views that may display with the Sheet Into View command the content of a 
drawing at different view angles and scale factor.
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Tech Note:

The location of the Layout file 
for the drawing formats 
varies with the version of 
Graphite, the platform and 
the version of the operating 
system. It can be found under 
User, Workgroup, System 
(Mac only) and/or Program. 
For specific information on 
your version try the 
knowledgebase in the 
Support Center on the 
website at www.ashlar.com.
Placing Drawing Formats 
Graphite places Standard Drawing Formats using two different commands: 

• The Import command in the File menu.

• the Sheet Into View command in the Views menu. 

Using the Import Command
If a part is placed in a detail view and visually scaled, it is possible to import a 
standard drawing format (either one of those supplied by Ashlar-Vellum or a 
custom format) in preparation for printing or plotting. Since the format should be 
full scale, it must be imported onto the sheet outside the view because the detail 
view is scaled and the sheet is not.

1. Choose Layout>Drawing Size to scale the drawing.

The Drawing Size dialog box displays.

2. Mark the Always Display Page Bounds option to compare the true size of the 
drawing with the displayed printing area of the drawing format.

3. Choose the File>Import.

The Import dialog box displays.

4. Mark the unscaled option.

5. Select a desired drawing format under your language in the Layout Folder on 
your system. See the Tech Note on locating the Layout Folder. For example:

ViewB.vc6 (Windows) or a Format B & View (Macintosh) where 1View stands 
for one detail view and B for the paper format.

Important: Ignore the number of detail views since they are only important 
when using the Sheet Into View command.

6. Click OK.



Graphite User Guide Drawing Formats
Using the Sheet into View Command
With the Sheet Into View command, Graphite imports not only a drawing format 
but also displays the drawing at the specified scale in one or several detail views, 
depending on the selected design layout.

1. Choose the Sheet Into View command in the Views menu.

The Sheet Into View dialog box displays.

2. Select the desired drawing format from the Layout list box, such as: 

B Landscape 4 Views.vc6

where B Landscape stands for the paper size and orientation, and 4 Views 
designates the number of detail views.

3. Enter the desired scale factor in the Scale data field.

4. Click OK.

The drawing format is placed at a scale of 1:1 (at it’s true size) onto the 
drawing area and the complete geometry of the drawing displays in one or 
several detail views at the specified scale factor. The number of detail views 
and the view angle (Top, Isometric, etc.) depends on the selected design 
layout. 

Modifying Drawing Formats 
All drawing formats included with Graphite in the Layout folder can be modified. To 
create custom drawing formats it is recommended to modify existing formats and 
save them under a new name.
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Tech Note:

The location of the Layout file 
for the drawing formats varies 
with the version of Graphite, 
the platform and the version 
of the operating system. It 
can be found under User, 
Workgroup, System (Mac 
only) and/or Program. For 
specific information on your 
version try the 
knowledgebase in the 
Support Center on the 
website at www.ashlar.com. 
Creating Drawing Formats and Design Layouts for Laser Printers
1. From the Layout folder the drawing format:

B Landscape 1 View.vc6

where B Landscape is the paper size and orientation and 1 is the number of 
detail views.

2. Save the drawing under a new name.

3. Choose Layout>Drawing Size.

The Drawing Size dialog box displays.

4. Mark the Always Display Page Bounds option.

The Printing area of the active printer displays as a gray rectangle.

5. Click OK.

The Drawing Size dialog box closes.

6. Select the grouped drawing format on the drawing area and ungroup the 
format by choosing Arrange>Ungroup.

7. Adjust the border lines of the drawing format until they are placed exactly on 
top of the displayed gray rectangle for the printing area of the printer.

8. Delete all cutting lines since they are not required for printing.

9. Hide the Forms layer.

All Text Entries are hidden. See the next section for information about title 
blocks and text entries.

10. Select the complete drawing format by choosing Edit>Select All and group 
the format by choosing Arrange>Group.

Important: Text entries with an @ character in front must not be grouped since 
then the Forms command cannot identify these entries as title entries (see a 
later section, “Creating Forms”).

11. Activate the Forms layer.

12. Save your work.
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Forms 
Use Text>Forms Text to display the Forms dialog box. Fill in text or values for the 
title blocks of all standard drawing formats that are saved in the Layout folder. 
Customized drawing formats can be used with the Forms command. This is 
described in a later section of this chapter.

As long as no standard drawing format is placed in a drawing, the Forms 
command is not available. It can be selected only if a drawing format with a title 
block is placed in the File menu using the Import command or the Sheet into View 
command in the Views menu. 

Creating Forms
Before using the Forms command in the Forms Text submenu to fill in customized 
drawing formats, the title blocks of these formats must be prepared.

To enable Graphite to identify the title blocks, define fields in the drawing format. 
To define a field, create a regular text block, and type an @ character in front of 
the text. Any text following an @ character then becomes a field. For example, to 
create an entry field for Scale create a text block and type “@Scale” in the box. 
For a label in front of the field, create another text block without an @ character. 
The following illustration shows two text blocks. One is the label (a standard text 
block), one is the field (a text block beginning with @).

Note: All field and label text blocks have to be placed on the Forms layer. (Create 
this layer using the Layers command as discussed in Chapter 13.)
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Preparing Title Blocks with the Forms Command
1. Open one of the drawing formats in the Layout folder.

2. If no layer with the name Forms exists, create this layer by choosing 
Layout>Layers and make it the current layer.

3. Select the Text command from the function palette.

4. Create text blocks. Any text block beginning with an @ character will become 
a field, all others will become labels.

5. Assign to all of the text blocks the desired font, style and size using the 
Selection tool from the tool palette.

6. Save the drawing format.

Using Forms 
With a format already placed in the drawing, selecting the Forms command in the 
Forms Text submenu brings up the Forms dialog box. This dialog box is similar to 
the Resolve dialog box in that it prompts the user for values for each previously 
defined field. Graphite replaces the field text blocks with whatever values are 
entered. Text attributes, such as font, assigned in the saved format are applied to 
the new values.

Filling in a Form
1. Place a Standard drawing format (use the Import or Sheet into View 

command). The form appears with all of the field labels as they were originally 
created. 

2. Choose the Text>Forms Text>Forms. 

The Forms dialog box containing all entry fields of the title block displays.

3. Type in the desired parameters. All entry fields need not be filled. 

4. Click OK.

The Forms dialog box closes and all entry fields of the selected title block are 
filled in according to your specifications. 
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Editing Title Blocks
1. Select the fields containing values to update (or choose Edit>Select All).

2. Select the Text>Forms Text>Forms. 

The Forms dialog box displays again.

3. Modify the entries of the title block.

4. Click OK.

The Forms dialog box closes and the selected title block is modified 
accordingly. 

Printing or Plotting a Drawing
Graphite prints and plots on most printers and plotters. Follow the manufacturer’s 
instructions for installing and setting up the printer or plotter, then size the drawing 
for the paper.

Setting the Printer or Plotter and Paper Specifications
In the File menu, use the Print Setup (Windows) or Page Setup (Macintosh) to 
specify the printer or plotter, the paper size, orientation, number of copies and 
other options.

Once the page setup is specified, set the visual scale of the geometry so that it fits 
the paper size.

Follow the instructions found earlier in this chapter to scale the geometry visually 
to fit the paper specified in Print Setup (Windows) or Page Setup (Macintosh).
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Print Command 
CTRL+P (Windows); +P (Macintosh)

The Print command in the File menu, or the last 
icon in the Window>General palette, prints or 
plots the current document as specified in Print 
Setup (Windows) or Page Setup (Macintosh).

The area printed or plotted is the portion that fits on the page size specified in Print 
Setup (Windows) or Page Setup (Macintosh) when the origin (0,0) is placed in the 
center of the page. Choose Layout>Drawing Size to scale the drawing to the 
appropriate size and reposition the print/plot region.
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Specify tiling (printing on several pages to be pasted together) through the 
Drawing Size command. If there is more than one sheet or tiling is specified, it is 
possible to designate which page(s) to print/plot. Pages are numbered 
sequentially for tiling, then for additional sheets.

Plotting to a File
It is also possible to plot to a file rather than to a plotter or printer. In that way, a 
plotter does not need to be attached to the computer. Someone else can plot the 
drawing without having a copy of Graphite on the plotter’s computer.

The type of plotter chosen when setting up the page determines the format of the 
plot file.

By choosing a PostScript printer, the file format will be Encapsulated PostScript; 
and the HPGL language is used when Hewlett Packard plotters are selected. The 
computer that finally plots the file must have an application compatible with the file 
format of the printer or plotter.

Plotter Fonts
When you are using a plotter, specify the Plotter font for the text and dimensions 
on the drawing. It is also possible to specify different text styles (such as italic or 
bold) in the Text menu and generate special characters and accents as described 
in Appendix B.
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Parametrics
Parametrics
Graphite’s integrated parametrics feature creates geometry without regard to its 
actual measurements. When the geometry is resolved parametrically, values are 
specified for the dimensions and Graphite redraws the geometry to the 
specifications provided. One example of parts that are well-suited to parametric 
definition are containers that vary in size according to the needs of a product line. 
Another might be hydraulic pistons that vary in size because of the duty loads. Still 
another might be valves that vary according to the diameter of the pipes to which 
they are attached.

This parametric feature is the basis for creating symbols to be used in drafting on 
a regular basis. See the next chapter for more detailed information.

The following topics cover the parametrics feature:

• Introduction to Parametrics

• Using Parametrics

• Parametric Drafting

• Parametric Problems

• Complex Parametric Drafting

• Parametrics and Grouped Objects
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Tip:

The Graphite folder contains 
a folder of symbols that use 
parametrics. You might 
retrieve a few of the symbols 
by going to the File menu to 
the Symbols submenu and 
choosing the Insert command 
to become familiar with how 
parametrics works. See the 
next chapter for more 
information on symbols.
Introduction to Parametrics
In its simplest form, parametrics allow the creation of a shape and then the 
specification the exact measurements. Take, for example, the basic activity of 
constructing triangles using parametric geometry.

1. Create the geometry.

2. Dimension the geometry using variables, constant values, and expressions. 
As many as 253 parametric dimensions can be used.

3. Resolve the parametric geometry.

Using this method, it is 
possible to quickly draw a 
triangle to exact 
specifications.

Of course, parametrics can 
be much more complex 
when using variables, as 
seen later in this chapter. While creating geometry is straightforward, when a part 
becomes complex, parametric dimensioning requires some skill and 
comprehension of how Graphite treats geometry.

Using Parametrics
The parametric mechanism is point-driven. It locates the points and then connects 
them with the appropriate geometry, much like the childhood activity of connect-
the-dots. It is not unlike drawing with a compass, triangle, and T-square. 

To begin, determine where the endpoints are and then draw lines to connect the 
points. Or figure out where the center of an arc should be, where the arc begins 
and ends, and use a compass to connect the points. 
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Basic Rules
1. Define the geometry completely. 

Each object must relate to another object.

Dimensions must define every aspect of the geometry. (The geometry may be 
over dimensioned according to standard drafting practice.)

Do not include extraneous text as part of a dimension. (A single # is acceptable. 
The parametric mechanism recognizes R # to mean a radius, measuring the 
real value of the geometry.) 

2. Keep it simple. If the part is complex, construct small segments, resolving as 
you go, solving any parametric problem before proceeding.

3. Return to the original part between tests. Use the Undo command to revert to 
the original state of the parametric part between tests. In this way, an 
unwanted constraint won’t be introduced.

4. Consider the following assumptions made by the parametric mechanism:

• Horizontal and vertical lines maintain their orientation.

• Connected lines remain connected.

• Lines tangent to arcs remain tangent (if there is an endpoint at the tangency 
point).

• Colinear lines remain colinear if they overlap or share endpoints.

• Concentric arcs remain concentric.

• A point of an object on a horizontal or vertical line will remain on that line.

5. Be aware of the relationships that the parametric mechanism cannot 
recognize:

• Parallel lines may not remain parallel.

• Perpendicular lines may not remain perpendicular.

• Symmetrical geometry may not remain symmetrical.

Creating Geometry
When approaching the problem of resolving geometry, evaluate it as if drawing it 
on paper. Remember the assumptions and requirements for geometric 
relationships as outlined in the previous Basic Rules section. 
16-3



16-4

Parametrics Ashlar-Vellum
Parametric Dimensions
The essence of parametrics is in the dimensions. The dimensions may be the 
actual value (gotten by default), a constant which is not the actual value, a single 
variable, or an algebraic expression involving constants, variables, mathematical 
operators, functions, and conditional operators. 

Constants are specific numeric values, such as specifying a radius as .25 (inch). 
Variable expressions may be as simple as a single letter such as L (for length), or 
a mathematical expression such as 2 * Dia (where Dia may be the diameter). The 
arithmetic operators are addition (+), subtraction (-), multiplication (*), division (/), 
mod (the remainder after division—%), and exponentiation (**). See Appendix A 
for a list of functions and conditional operators.

In whatever way the dimensions are specified, they must define all geometry and 
any relationships that exist between different parts of the geometry. 

Creating Parametric Dimensions
1. Construct the geometry.

2. Display the dimension palette and choose the appropriate dimensioning tool.

The Status Line displays a # symbol in the text data field to show that the 
dimensions are entered as actual measurements.

3. Click the geometry to dimension as usual.

The Text data field in the Status Line highlights. 

4. Type whatever expression, variable, or constant to be used for the dimension, 
and press the ENTER (Windows) or the RETURN (Macintosh) key. To use the 
actual value, do not overwrite the # symbol in the text data field.

Variables are case sensitive: D is not the same as d.

The expression typed replaces the # symbol.
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Examples of Parametric Dimensions
and Conditional Expressions
Use the conditional operators as parametric 
dimensions. Create the dimension as usual and 
enter the conditional expression as text in the 
Status Line.

The example here shows a conditional 
ifelse expression.

When the above ifelse statement resolves, 
the rectangle with the larger value (L1 or 
L2) touches the L3 rectangle.

The length represented by the ifelse 
expression equals L1 because L1 is 
greater than L2. 

The length represented by the ifelse 
expression equals L2 because L2 is 
not less than L1.
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Tech Note:

Example: Use a 
mathematical expression with 
a fastener symbol. For a 
numbered fastener (#2, #4, 
#6, etc.,) use the following 
formula for the thread size: 
(N*13+60)/1000 where N is 
fastener number. For a #6 
screw, the thread size equals 
6*13+60/1000 or .138
Resolving the Parameters
Once the geometry is constructed and parametric dimensions are added, use the 
Resolve command to specify the values for the variables and redraw the 
geometry.

Resolve Command
The Resolve command in the Edit menu redraws geometry automatically to fit 
specified dimensions. This parametric feature draws a geometric shape without 
regard to measurements and then Graphite redraws the same shape to the values 
specified.

Using the Resolve Command with Parametrics
1. Create the geometry.

2. Dimension all geometry by using variables, constant values and expressions. 
(Dimension the essential, related geometry so Graphite can reconstruct the 
geometry. Graphite cannot identify parallel or colinear lines.)

• Select the appropriate dimensioning tool.

• Click the geometry to be dimensioned.

• Enter an expression (such as 1.5, x, x+3*y) in the text data field in the Status 
Line.

• Press the ENTER (Windows) or the RETURN (Macintosh) key.

3. Select the geometry and dimensions to be resolved.

4. Choose Edit>Resolve.

5. If necessary, enter the values to assign to the variables.

Enter mathematical expressions, fractions, and decimals in the data fields of the 
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Tech Note:

To use a spreadsheet like 
Microsoft Excel for creating 
the text file, type in each cell 
the variable name and the 
value separated by a white 
space and export it as a text 
file.

Tech Note:

If text file contains more 
variables and values than it is 
necessary to resolve the 
geometry, Graphite 
automatically imports only the 
needed variables and values.
Resolve dialog box. A mix of different units may be used as long as they are 
specific, for example 2’6”.

6. Optional step: to anchor a point on the geometry at a particular location, click 
the point. The point remains in the same location after resolving the geometry. 
An example appears later in this section.

7. Click OK.

 If the parametric dimensions defined the geometry properly, the geometry 
redraws as specified. The dimensions remain as variable expressions. 

If Graphite cannot resolve the parametrics, a message box displays information 
about the problem. The “Parametric Problems” section, later in this chapter, 
describes typical problems that may be encountered. If all of the dimensions 
required to draw the geometry are not provided, the geometry divides into 
unrelated groups. The missing information determines how the groups relate to 
one another. 

An alert box shows how many groups exist. To see each group, click Next. 
Examine the groups shown to determine why the position of each group is not 
related to any other. A group consisting of a single point is particularly telling. (This 
investigation can require some clever thought because the solution may not be 
obvious.)

The Resolve command cannot resolve ellipses and splines, unless the ellipse or 
spline is contained in a group. See the section on Parametrics and Grouped 
Objects.

Specifying Parametric Variables in a Text File
When using parametrics which contain many variables, create a text file to specify 
the variables and avoid entering them in the Resolve dialog box each time the 
parametrics are resolved.

Create a text file which alternates the variables and the values, using white space 
(SPACEBAR, TAB, or ENTER (Windows), RETURN (Macintosh)) between entries. 
Graphite assumes the first entry is a variable and the second is the value for that 
variable. The text file might look like the examples shown here or any other 
arrangements).
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Using a Text File for Parametric Variables
1. Create the text file using any word processor or spreadsheet and saving it as 

Text only.

2. In Graphite select the geometry and parametric dimensions.

3. Choose Edit>Resolve.

The Resolve dialog box displays.

4. Click File to specify the values for the variables automatically.

5. Select the text filename.

The variables and values are read from the file.

6. Specify an anchor point, if necessary. 

7. Click OK.

The geometry resolves accordingly. 

Anchoring the Geometry
Anchor the geometry by clicking 
the anchor point when the Resolve 
dialog box appears. For example, 
in a tutorial exercise in the Getting 
Started manual, parametrics were 
used to create the side view.

Using this side view as parametric 
geometry, it is possible to anchor the upper-right corner so that it remains aligned 
with the front view after resolution.
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Changing the Dimensions to Actual Measurements
Once parametric geometry is resolved, the dimension notations continue to show 
variables and constants. To make the geometry reflect the actual measurements, 
edit the dimensions. Follow these steps to change a resolved parametric 
dimension to a real value:

1. Choose Edit>Selection Mask.

2. Highlight the four dimension types in the box on the left. 

Only dimensions are selectable.

3. Choose Edit>Select All.

All dimensions are selected.

4. Choose Edit>Edit Objects.

5. Change the entry in the text data field to a # symbol.

6. Click Apply.

7. Close the Edit Objects and Selection Mask dialog boxes.

8. Click the Selection tool to cancel the effect of the Selection Mask.

If different types of dimensions need to be in different formats, select each type 
separately.

Parametric Drafting
This section describes how to modify standard drafting practices to accommodate 
parametrics. It describes three examples with three topics to illustrate how to 
define parametric geometry completely.

Reminder:

• Define the geometry completely.

• Dimension all geometry. 

• Relate all geometry.

• Do not include extraneous text.

• Return to the original part between tests.
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Dimension All Geometry
Center lines require consideration if they are to be resolved properly. 

Problem
Creating the circle shown with two centerlines, parametrics 
can resolve the circle but not the centerlines because the 
endpoints of the lines are not defined.

Solutions

A. Using the Pen Style, Center
Looking at this problem as a connect-the-dots problem, notice that the centerlines 
have no dots to define them.

1. It is possible to construct the centerlines so 
their endpoints are on the circle, as shown 
here.

2. Include dimensions for the centerlines. 
The dimensions should be variables 
based on the diameter of the circle so 
when the diameter of the circle is 
specified, the centerlines are drawn 
relative to the diameter.

B. Using the Circle Center Line Tool
1. Use the Circle Center Line tool to place the center line on the circle.

2. Dimension the diameter of the circle and 
one of the center lines relative to the 
diameter. Dimension the center line from 
endpoint to endpoint or from the center of 
the circle to one endpoint of a center line.
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Relate All Geometry
All parts of the geometry must be related. 

Problem 
Both squares could be drawn by the 
parametric mechanism, but there is no way to 
determine their relative positions. 

Solution
Add a constraint line and dimension between 
the squares to connect the dots.

Additional Tips:

1. The added dimension is an example of 
using a constant value. A variable 
expression such as x+y can be entered for the constraint line. 

2. Constraint lines are ordinary lines usually drawn with the Single Line tool. 
They can be any line style, but they should be different from the lines of the 
regular geometry. The Construction line style is a good choice.

3. Placing the constraint line and dimension on a layer (named Constraints), that 
layer can be hidden when plotting the drawing. 

No Extraneous Text
Dimension all geometry because the parametric mechanism does not understand 
text and cannot detect symmetry.

Problem
By dimensioning the radius of a filleted corner of a 
rectangle as R .25 4 PLCS to indicate four fillets, 
the parametric mechanism doesn’t understand 4 
PLCS and doesn’t know the corners are 
symmetrical.   

Solution
Dimension each fillet.
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Return to the Original Part between Tests
Resolving parametric geometry more than one time, unintentional constraints may 
be introduced that prevent the parametric function from returning to the original 
display of the part. Take the part below, for example.

Problem
Resolving this geometry by specifying 
that R is half the measurement of X 
(R=X/2), the resolved geometry would 
appear as shown in the lower illustration.

Resolve this geometry only with the 
same X value of R * 2 because the 
undimensioned line is vertical, and 
according to the basic rules, vertical 
lines remain vertical.

If a value for R or X is 
used other than the R = X/
2 relationship, the 
parametric mechanism 
would display this problem 
message:

Solution
Use the Undo command 
to return to the original shape. It is also possible to solve this problem by changing 
the geometry.
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Parametric Problems
This section illustrates problems that can be encountered when resolving 
parametric geometry. It provides examples and shows what caused the problem 
and how to solve it.

When resolving parametric 
geometry, problems which 
prevent resolution appear in 
a message box, stating the 
type and number of 
instances of the problems.

When a message appears, 
the problematic geometry 
appears as thick lines and individual dots. The lines indicate the geometry that the 
parametric mechanism can draw. Dots indicate unknown points. Click Next, and 
the next problem is shown. Examining of the relationships between the problems 
helps discern what must be done.

Important: Pay attention to single points. Remember, the parametric mechanism 
connects the dots. Frequently, one constraint or dimension can solve several 
problems at once.

Geometry Overconstrained 
The basic rules say that all geometry must be defined and every object must be 
related to some other geometry within the parametric definition. When geometry is 
overconstrained, it is related in more than one way, so the geometry’s 
specifications could be resolved to more than one answer.
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Problem 
The diameters of the circles indicate the 
relationship between the circles adequately 
because the centerline remains horizontal and the 
circles are tangent to each other. The length 
variable causes the problem because the length 
between the centers of the circles may not 
correspond to the sizes of the connected circles. 
The centerline begins and ends at the centers of the circles.

Solution 
Delete the Length dimension.

Unrelated Groups
If not enough dimensions are provided, 
the parametric mechanism finds two or 
more groups of geometry, each of which 
is well-defined in itself, but not related to 
each other. 

Problem 
A simple example of this problem is 
illustrated on the left, where the short 
vertical line is not related to the rest of 
the geometry. Resolving this geometry, 
an Unrelated Group Problem message 
appears.

The first unrelated group appears in bold 
black lines. Click Next to highlight the 
second group.
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This problem is like the two squares shown earlier. Only one group could be 
drawn. The parametric mechanism does not know how to relate the two groups.

Solution
Decide how to relate the groups. Usually, 
there are many options to accomplish this. 
For this example, adding the dimension W/
3 is one alternative.
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Unrelated Groups where One Group is a Single Point
A single point as an unrelated group is like a neon sign saying: The problem is 
right here!

Problem
The Resolve Problem message may display a single point, such as the point on 
the left hole of this example. That point is the endpoint of the circle. 

Solution
On closer examination, it is seen that the circle is not dimensioned. Therefore, the 
solution is to dimension the circle.
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Another Unrelated Group

Problem 
In this graphic, the height of the right side 
of the part is dimensioned. Assume that 
the height dimension applies to the right 
and left side. The parametric mechanism 
does not make that assumption.

Solutions 
There are three possible solutions to this problem:

1. The height can be dimensioned on 
the left.

2. Draw a constraint line to close the 
opening.

3. Dimension the height from the top of 
the left line to the bottom of the right 
line. While this is not good drafting 
practice, it is very useful for 
parametric symbols.
16-17



16-18

Parametrics Ashlar-Vellum
Assumptions Involving Tangency
The parametric mechanism can identify tangent points but not the tangency of 
geometry. 

Problem 
The endpoints of the lower line that is tangent to and 
ends at the circle can be determined. The upper line, 
however, is tangent to and extends beyond the circle 
and cannot be defined without more information.

Solutions
Here are three possible solutions to the problem:

1. Draw a constraint line from the center of the 
circle to the point of tangency for the line that 
extends beyond the circle, as shown here.

2. Use the Rotate tool on the Transformation 
subpalette to move the endpoint of the circle to 
the tangent point of the line that extends 
beyond the circle.

3. Divide the line into two segments which join at 
the tangent point.
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Relationships Involving Symmetry
Create geometry with a mirrored copy, the parametric mechanism cannot resolve 
and maintain the symmetry without more information.

Problem 
The problem message shows three unrelated groups: 
the trapezoid on the left and the two rightmost 
corners, as shown below.
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If parametrics swings an arc of the radius H1 and H2, it doesn’t 
know where the point is supposed to be on the arc. The point 
has a distance but no direction unless an angle dimension is 
added. 

Solution 
Single points that are considered a group 
provide a clue to the solution. In this 
example, the parametric mechanism does 
not know where those points are, relative to 
the original trapezoid. Solve the problem by 
adding a constraint line and angle 
dimension between that line and the mirror 
line.

Complex Parametric 
Drafting
This section illustrates two complex 
examples of parametric drafting. These 
examples combine the information provided in this chapter to display how to use 
the parametric mechanism.

Example—Departures from Standard Drafting
This example illustrates the parametric drafting 
practices that differ from standard drafting practices. 
The first illustration is the side view of an adapter 
without dimensions so its shape can be seen clearly. 
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Here is the side view with typical 
dimensions added.

The illustration shows the side view with 
added constraint lines.

The next illustration shows the side view 
with numbered constraint lines.

1. The centerline does not extend 
beyond the geometry.

2. Constraint lines define the edges of 
the groove. Parametrics do not 
recognize non-touching colinear 
lines.
16-21



16-22

Parametrics Ashlar-Vellum
3. Constraint lines connect the 
endpoints of the upper and lower 
halves to relate the geometry. 
Parametrics do not recognize non-
touching colinear lines.

4. Four dimensions are added to relate 
the geometry to the centerline. 
Parametrics don’t recognize non-
touching colinear lines.

The illustration below shows the 
completed parametric drawing. 

Additional Tips:

1. Place the additional information on a separate layer to hide the layer when 
plotting the drawing.

2. Using a yellow pen (which is hard to see against a white background) prevents 
confusing the additions with the actual geometry.
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Example—Keep It Simple or Testing as You Go
When there are unconnected multiple views, the parametric mechanism can’t 
determine the relationships between them.

The coin chute example below describes the parametric drafting of three views. 

Dimension these views according to standard drafting practice, as shown.
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Section 1
1. Construct and resolve one section at 

a time. Solve any problems with this 
bracket before moving on.

2. Add a centerline between the holes to 
maintain alignment.

3. Add a line connecting the lower edges 
of the flanges to keep the lines 
colinear. 

If the section below resolves without 
problems, go on to the next section.

Once this view resolves properly, add the side view. 

Since the side view determines height, delete the height (H) dimension and the 
lower thickness (T) dimension after adding the side view.
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Section 2
1. Add constraint lines to connect the 

geometry between sections. 

2. Add a dimension to specify the distance 
between the sections. (See the two box 
problem earlier in this section.)

3. Add extra thickness (T) dimensions since all geometry must be defined.

Section 3
1. Dimension each fillet, as explained 

earlier.
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2. Relate this section to the rest of the 
geometry.

3. Add a dimension to specify the 
distance between the sections.

Three sections are related as shown 
below.

This is the completed parametric drawing. 
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Parametrics and Grouped Objects
It is possible to create many objects. Group them and then treat them as a single 
parameterized object. There must be a framework on which the group sits. 
Dimension between two control points on the framework and then resolve the 
framework. The group changes accordingly, shrinking or expanding 
proportionately to the distance between the control points.

Create a spline and group it.

Then create a framework line between 
the endpoints and dimension the line.

When resolving for the length of the line 
(L), the spline changes accordingly.

Using Parametrics and Grouped 
Geometry
1. Create the geometry to be 

parameterized.

2. Select the geometry.

3. Choose Arrange>Group.

4. Create a framework on which the grouped geometry sits.

5. Dimension between two control points. It is possible to use only one variable 
per group.

6. Select the framework, the dimension and the group.

7. Choose Edit>Resolve.

8. Enter the value for the distance between the control points.

9. Click OK.

Including a dimension as part of the Group, the dimension changes when the 
Group is resolved. It is not used as part of the parametric solver.
16-27



16-28

Parametrics Ashlar-Vellum
Rigid Links
Geometry can be grouped into a rigid body and then attached to the rigid body to 
parametric geometry in at least two points. Resolving the parametric geometry, the 
rigid body undergoes the same geometric transformation.

The following shows an example of using parametrics with grouped objects. Begin 
with a basic shape that resolves properly, as shown in the part below. Then add 
the thread groups. By resolving the part, the threads also resolve.

The next example shows, the 
usual method of parametric 
drafting followed by an example 
of how using parametrics with 
groups simplifies changes to the 
part.
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Parametrics in 3D
The parametric feature works in 3D with some restrictions. Consider its 
functionality as 2  1/2D since it functions properly in all planes parallel to the work 
plane. 

The parametric mechanism has two phases. In the first phase, the parametrics 
ignore the z coordinates of the selected geometry and resolve the geometry as it 
does in 2D. Any dimension that is not completely in a plane parallel to 
the x,y plane is also ignored. In other words, the x and y coordinates are resolved 
and the z coordinates are not changed.

In the second phase, parametrics adjust the z coordinates, as necessary. All linear 
dimensions parallel to the z axis are examined and every point in the selected 
geometry is considered to define a plane parallel to the x,y plane. The dimensions 
in the z direction define the required distances between these planes. Unlike the 
first phase, in the second phase parametrics are very tolerant of missing 
dimensions. If the dimensions do not completely define the distance between any 
two planes, then the distance is not changed.

In phase two, any line or arc that does not lie in a plane parallel to the x,y plane is 
modified appropriately because the defining points are adjusted by the 
parametrics and the line or arc is changed accordingly. This includes all lines 
parallel to the z axis and any oblique lines at any angle to all three axes.

Parametrics deal with all geometry in the current work plane coordinates. 
Consequently, it is a good idea to set up a view that looks down the z axis of the 
work plane onto the x,y plane. In this way, it is possible to see what the first phase 
of the operation “sees.” This is particularly useful to encounter problems resolving 
parametric geometry. Errors in parametrics are shown in bold lines drawn in the 
x,y plane and independent of the z values of the highlighted lines. The easiest 
way to see this is to look down on the x,y plane by choosing Views>View The 
Plane.
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In the drawing below, the first phase of parametrics will deal with only four 
dimensions W, L, L/2 and L/4. In the second phase, the H and H/3 dimensions are 
evaluated.
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Symbols
In Graphite it is possible to place any drawing as a symbol and open any symbol 
as a drawing. Create symbol documents for generic, parameterized parts, and 
then bring them into the drawing, customizing the dimensions with each use. 
Symbols are particularly useful for creating a library of standard designs common 
to your work. For example, create libraries of windows, screws, nuts or bolts.

Graphite distinguishes between: 

• Simple symbols, which have neither parametric dimensions nor underlying 
value tables

• Parametric symbols, with editable dimensions

• Symbol libraries, that contain parametric symbols with underlying value tables.

All commands used to manipulate symbols are found by choosing 
File>Symbols....

Most of the symbols shipped with Graphite are parametric symbols. Parametric 
means that the symbol's final measurements can be specified just before placing 
them into a drawing. This feature uses one symbol in countless variations.

The following topics are covered in this chapter:

• Using Symbols

• Placing Symbols

• Smart Symbols

• Symbol Libraries

• Creating Symbol Libraries
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Using Symbols
The installation procedure copied the parameterized symbols in to the Symbols 
folder of the Graphite folder. Look at some of those symbols to get an idea of the 
type of symbols to be created with Graphite.

When a symbol is brought into a drawing, it is necessary to indicate its location 
and orientation. In order for this to work properly, a control point must be at the 
Origin (0,0) in the original symbol file.

As a special feature for use with parametrics, lines in the Construction pen style 
do not appear with the symbol when it comes into a document. Use this feature to 
define your own smart windows and smart doors, as well as other symbols.

Creating a Symbol Document
1. Construct the geometry, using the Construction pen style for any lines that 

should not appear in the symbol when it comes into a drawing. Be sure to 
place one control point at (0,0) to specify the location of the symbol when 
bringing it into a drawing.

2. Dimension all aspects of the part by entering a variable in the text data field in 
the status line of each dimension.

3. Choose Edit>Resolve to check the accuracy of the parametric dimensions.

4. Choose File>Save As.

5. Name the document. 
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Tech Note:

Click the small resize box in 
the lower right corner of the 
Symbol Panel to drag and 
resize the symbol. Shift click 
to minimize the panel (for use 
on nonparametric symbols, 
such as nuts, bolts, valves, 
etc.)
Placing Symbols
It is a very easy process to place symbols into the drawing. Using File>Symbol..., 
place either newly created symbols or those that came with the program.

Symbol Commands
When selecting Symbol in the File menu, an open file dialog box appears. Use the 
dialog box to navigate and select a symbol directory. All the symbols in that 
directory are loaded into the Symbol Panel and their file names display along the 
left side of the Symbol Panel.

Insert
Choose File>Symbol... and a standard open file dialog box displays. Once a 
symbol is selected, the Symbol Panel appears.

The dialog box displays a preview of the symbol and lists the file names of all 
other symbols stored in that directory. The Symbol Panel is resizeable.

For parametric symbols, entry fields for all variables defining the symbol are 
displayed.
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Tech Note:

Use a text file to fill in 
parametric dimensions of a 
symbol. Create a text file with 
value pairings for each 
variable and its value. Then 
load the symbol and click on 
File in the Symbol Panel. The 
file automatically fills in the 
values specified for each 
dimension.
To place the symbol in the drawing, click or drag a vector on the drawing area. 
Click and the symbol inserts at the clicked location, in its original orientation. Drag 
and the starting point of the drag specifies the insertion point for the symbol and 
the direction of the drag indicates the orientation.

Bringing a Symbol into the Current Document
1. Choose File>Symbol....

The Open dialog box appears.

2. Select the symbol file to be used and click Open.

The Symbol dialog box appears displaying a preview of the currently selected 
symbol. All symbol files in that directory appear in the symbols list on the left 
side of the Symbol Panel.

3. Enter a value for each of the parametric dimensions.

4. Specify the location and orientation for the symbol.

In the dialog box, a triangle appears on the geometry to indicate the origin or 
the point being located. Click, the symbol inserts at the clicked location, in its 
original orientation.

 Drag and the starting point of the drag specifies the insertion point for the 
symbol and the direction of the drag indicates the orientation.

If a location is not specified, scroll as necessary to see the symbol. 

5. Click OK.

The geometry resolves and appears in the current drawing at the location 
clicked, sized as specified. 

The symbol geometry is selected so it can be moved to a new location. 

6. Add regular dimensions if desired.

To see an enlargement of any part of the symbol within the viewing window, move 
the pointer to the area of interest and press the mouse button. The enlargement 
reduces when the mouse button is released.
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Browsing a Directory of Symbols
1. Choose File>Symbol....

The Open dialog box appears.

2. Select a symbol file from the directory to be browsed and click Open.

The Symbol dialog box appears displaying a preview of the currently selected 
symbol. All symbol files in that directory appear in the symbols list on the left 
side of the Symbol Panel. (To change the selected symbol, click on a file name 
from the list along the left side of the Symbol Panel. The preview pane 
updates to display the currently selected symbol.)

3. Click New to load a different directory of symbols.

Importing a Symbol
Use the Import command from the File menu to bring in the geometry and 
dimensions of a symbol. When importing a symbol, it comes into the current 
drawing at the size it was drawn. Specify new measurements by choosing 
Edit>Edit Objects or choose Edit>Select All and then choose Edit>Resolve to 
change the size.

Editing Parametric Symbols
Using the Edit Objects command it is possible to edit parametric symbols placed in 
a drawing. After selecting the symbol, choose Edit>Edit Objects, then edit the 
dimension of the symbol.
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Smart Symbols
The Architect folder of the Symbols folder contains smart symbols for doors and 
windows. Smart window and door symbols are smart because they contain a 
smart wall segment. Adding one of these symbols to a smart wall breaks it into the 
wall in the specified location. 

When creating custom smart symbols, draw smart walls with the Construction pen 
style. (Geometry created with the Construction pen does not appear when it is 
brought into a drawing.) The invisible geometry is still functional in that existing 
smart walls in the drawing detect the invisible wall of the symbol. 

Draw a thick wall in line with or overlapping a thinner wall, so it hides the thinner 
wall. Therefore, to get a symbol to mask part of a wall, include a single wall that 
overlays the target wall. To see an example, open one of the smart symbols in the 
Architect folder that was installed with Graphite.

Creating a Smart Symbol
1. Choose Pen>Style>Construction.

2. Draw a smart wall thicker than the maximum thickness expected to be used 
and only as long as the final symbol is.

3. Change pen styles to any style other than Construction.

4. Draw the symbol.

5. Choose File>Save As and save as usual.

Using Symbols for Smart Windows and Doors
The Symbols/Architect folder that was installed with Graphite contains symbols for 
smart windows and smart doors. These symbols work like regular Graphite 
symbols in that they are parameterized and can be placed and oriented on a 
drawing. In addition, they break into any smart wall they touch and the cut area of 
the smart wall fills in if the smart symbols are moved or deleted.
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2D Analysis
The 2D Analysis provides sectional properties for the selected geometry, a feature 
that is useful for many calculations related to design and drafting. Architects use 
the perimeter and area values for calculating material requirements; engineers 
use the moments of inertia for stress analysis; manufacturers use the centroid for 
balancing parts for turning. The following topics are covered in this section:

• 2D Analysis

• Calculations
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Tech Note:

The closed figure is an area 
that could be crosshatched. If 
in doubt about the area, 
simply crosshatch the 
geometry to see if it 
represents the area that 
needs to be analyzed.

Tech Note:

Once the area is 
crosshatched and the 
selection is correct, choose 
Undo to remove the 
crosshatching and still 
maintain the selection.

Tech Note:

This tolerance value has no 
effect on the precision of the 
resultant values. The 
precision of the result is set 
by choosing 
Layout>Preferences>Units. 
2D Analysis Command
The 2D Analysis command in the Layout menu displays the statistics on the 
selection, including the length of the perimeter, the enclosed area, the center of 
gravity (centroid), and moments of inertia. The selection must be a closed figure.

Performing 2D Analysis
1. Select the geometry that defines a closed boundary. Use the Tracer tool to 

select the perimeter.

2. Choose Layout>2D Analysis.

The analysis is performed and the values appear in the dialog box.

3. If necessary, enter changes for the tolerance and weight per area values.

4. Click CALCULATE. 

The analysis recalculates and the new values appear in the dialog box.

The following items are included in the dialog box:

Tolerance Determines the accuracy of calculations for 
curved objects. The smaller the tolerance, the 
higher the accuracy. The default value is 0.01. 
Change the value by entering a new number. 

The 2D analysis mechanism analyzes arcs, 
circles, ellipses and splines as straight line 
segments that deviate from the true curve by no 
more than the stated tolerance value. The smaller 
the number, the greater the accuracy, however, 
the greater the accuracy, the longer the 
calculation time.
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Weight Per Area A multiplier used to determine the actual weight of 
a part of constant thickness defined by a selected 
boundary. The weight of the part is the product of 
the Area multiplied by the Weight Per Area. 

The default entry is 1. Change the value by 
entering a new number. Find the proper number 
for this entry in a handbook published by most 
material vendors, particularly for sheet steel and 
aluminum. Enter the weight for the thickness of 
the proposed material and click CALCULATE.

For example, to analyze a square as if it were a 
cube three inches thick, enter 3 *  the material's 
density in the weight per area box.

Perimeter The length of all segments which define the 
selected boundary. This is the only value that 
appears if the boundary is not closed.

For circles, arcs and other curves, the accuracy 
depends on the tolerance setting. 

Area The surface area enclosed by the selected 
boundary.

For circles, arcs and other curves, the accuracy 
depends on the tolerance setting. 
18-3



18-4

2D Analysis Ashlar-Vellum
Weight The product of the Area multiplied by the Weight 
Per Area.

Centroid X The X coordinate of the center of mass defined by 
the selected boundary.

Centroid Y The Y coordinate of the center of mass defined by 
the selected boundary.

Inertia IXX The moment of inertia about the central X-X axis 
which is parallel to the X-axis. 

IXX = ½(y-Yc)2dA

Inertia IYY The moment of inertia about the central Y-Y axis 
which is parallel to the Y-axis.

IYY = ½(x-Xc)2dA

Inertia IXY The product of inertia about the centroid.

IXY = ½(x-Xc)(y-Yc)dA
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Calculations
Graphite calculates the values for 2D Analysis before the dialog box appears. To 
make a change in the Tolerance or the Weight Per Area, click CALCULATE to 
recalculate the statistics.

The 2D Analysis mechanism evaluates the boundary in the same way the 
crosshatching mechanism does. For example, Graphite considers a circle inside a 
bounded area to be a hole. Crosshatching does not fill the hole and 2D Analysis 
does not include the area of the circle in the area calculation.

Displaying the Centroid
1. Select the geometry defining the part.

2. Choose Layout>2D Analysis.

The 2D Analysis dialog box appears.

3. Choose Layout>Construction.

The Construction dialog box appears.

4. In the Angle field in the Construction dialog box, enter 0;90. (Be certain to 
separate the numbers with a semicolon.)

5. Enter the value for Centroid X in the X field of the Construction dialog box.

6. Enter the value for Centroid Y in the Y field of the Construction dialog box.

7. Press ENTER (Windows) or RETURN (Macintosh).

Construction lines display, intersecting at the centroid of the selected part.
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Bill of Materials
Bill of Materials is an important extension to CAD programs for tracking and listing 
parts all the way through the product design and manufacturing process. In the 
product manufacturing industry every part produced has some type of 
distinguishing mark—typically the part number—either stamped, etched, 
embossed, or silk screened onto the part. The manufacturer also needs to 
document the design and track the characteristics of each part like material, cost 
of manufacturing, and outside vendor code during the product development 
process.

The following topics are covered:

• Introduction

• Attributes

• Item Numbers

• Bill of Materials Table
19-1



19-2

Bill of Materials Ashlar-Vellum
Introduction
Graphite’s Bill of Materials Extraction 
utility attaches characteristics 
(attributes) to the parts being 
designed. From these attributes, Bill of 
Materials table is extracted. This Bill of 
Materials table can be printed 
separately or with the drawing.

In addition, it is possible to export the 
Bill of Materials to other applications.

The Bill of Materials Extraction utility is 
completely integrated in Graphite and 
combines powerful functionality with 
an easy to use interface.

Generating a Bill of Materials is a two 
step process:

• Defining and assigning attributes to 
object geometry in drawings.

• Extracting user-defined and 
predefined attributes in the form of 
lists or ASCII-files for export purposes.

When using the Bill of Materials Extraction utility for the first time, start by 
interviewing all the groups within your organization to determine which 
characteristics need to be tracked. The next step is to assign these characteristics 
to an existing catalog of parts, typically Graphite symbol files. These parts can 
then be used to create an assembly or installation drawing. These attributes can 
then be extracted into a Bill of Materials table or exported for use in other 
applications.

The Bill of Material distinguishes between two kinds of attributes:

User-defined Attributes Define and assign attributes to object geometry 
after creating it.

Predefined Attributes These are numerical attributes like the perimeter 
or area of a circle which are automatically defined 
by creating the geometry.

Non-numerical attributes like line color and line style are not recognized by the Bill 
of Materials.
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Attributes and Objects
Each object created in Graphite automatically has different kinds of attributes: 
numerical attributes like the perimeter and the area of a circle, and non-numerical 
attributes like the line color and the line style.

With the Bill of Materials Extraction utility, assign User-defined Attributes to 
objects, like a Part Name or Part Number.

Defining Attributes
Before assigning attributes to objects, they must first be defined. To define 
attributes choose Text>Bill of Materials>Define Attributes.
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Attributes Command
This command defines, deletes, redefines and activates attributes. Active 
attributes (attributes which can be assigned) are indicated by an eye icon in front 
of the attribute name. Locked attributes (their values cannot be changed during 
assignment) are indicated by a lock icon in front of the check mark.

The Define Attributes command displays the dialog box on the right.

Attributes are defined in the Define Attributes dialog box by three parameters:

Attribute Name Specifies a general name for the attribute like 
name, material, serial number, etc.

Default Value Assigns a specific value to the attribute. For 
example, the value of steel can be assigned to the 
attribute of material. The value of an attribute can 
be changed in the Status Line before assigning it 
to object geometry or in the Edit Objects dialog 
box after it has been assigned.

Format (Text, Number, Qty.) Select a format for the attribute value in this pop-
up menu. Choose between three attribute 
formats: Text, Number and Qty.

Text is the default format and is the choice for all 
alpha-numeric values (Text entries) like Name, 
Material, etc.

Number is the choice for all values which are 
expressed by numbers used for further 
calculations. A part number like S3456 or 252-49 
would be formatted as Text, since this value would 
never be used for any kind of calculation. To use 
hyphens or dashes in the Part Number, use the 
Text format, not Number.
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Qty. causes the Bill of Material to calculate the 
number of identical objects in a drawing. 

The Define Attributes dialog box contains the following buttons:

New Clicking New creates a new attribute like Attribute 
1, 2, 3, etc. Rename the attribute by typing the 
name in the Attribute Name entry field and 
clicking Redefine.

Delete Clicking Delete deletes the selected attribute from 
the attribute list.

Redefine Clicking Redefine does three things: First, it 
renames a selected attribute with the name 
specified in the Attribute Name entry field; 
second, it assigns a value to the attribute which 
may be entered in the Default Value entry field; 
and third, it assigns the format for the attribute 
selected from the Format pop-up list.

Defining Attributes
1. Click New to create a new attribute.

In the Attribute Name entry field Attribute 1 displays.

2. Rename the attribute by typing a name in the Attribute Name entry field, like 
COST.

3. Specify a value for the attribute in the Default Value entry field. 

The value can be changed in the Status Line during assignment, like 2.50. The 
format must be Text, not Number if the $sign is used.

4. Select a format for the new attribute. In the examples given above, the format 
is Number.

Click the Format pop-up menu and select.

5. Click Redefine. 

The new attribute name appears in the attributes list, and the specified value 
and format is assigned to the attribute.

6. Close the Define Attributes dialog box.
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Show or Hide Attributes
Only visible attributes (indicated by an eye icon beside the attribute name) are 
displayed during assignment. Hidden attributes cannot be edited.

1. Select an attribute to show or hide from the list box. The eye icon beside the 
attribute name indicates that an attribute is visible.

Locking and Unlocking Attributes
To lock or unlock an attribute simply click in front of the attribute's name. The lock 
icon in front of the name appears or disappears.

The values of locked attributes cannot be changed during assignment.

Changing the Characteristics of an Attribute
Choose the Text>Bill of Materials>Define Attributes to open the Define 
Attributes dialog box.

1. Select the attribute whose name, value or format needs to be changed.

2. Type a new name or value, or choose a new attribute format.

3. Click Redefine.

The new attribute name appears in the attributes list and the new value and 
format are assigned to the attribute.

4. Close the Define Attributes dialog box by clicking Close.

Deleting Defined Attributes
Choose Text>Bill of Materials>Define Attributes to open the Define Attributes 
dialog box.

1. Select the name of the attribute from the list box.

2. Click Delete. The selected attribute deletes.
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Saving Attributes
With the Redefine button, rename an attribute or assign a new value or format to 
the attribute.

To save all attribute definitions permanently, choose Layout>Preferences>Save 
Preferences. Close Graphite and relaunch it for the new preferences to take 
affect.

Predefined Attributes (Graphite Attributes)
Predefined Attributes are attributes that Graphite defines. These attributes are 
calculated and displayed using 2D Analysis (see Chapter 18). Choose the ones 
from the list by double clicking.

• Perimeter

• Area

• Weight

• Centroid X

• Centroid Y

• Inertia IXX

• Inertia IYY

• Inertia IXY

For predefined attributes enter the attribute's name only, since their values and 
formats are predefined. These attributes are displayed in the Status Line but 
cannot be changed, since Graphite calculates the values automatically.

Assigning Attributes
Assign attributes using the BOM tools. Activate BOM tools like any other tool in 
the Graphite tool palette. 

An object's attributes are inaccessible if the object is grouped, so that the group 
itself can have attributes. The object's attributes are made accessible by 
ungrouping the group. Ungrouping a group with attributes removes the group's 
attributes.

BOM Tools
Graphite’s BOM tools are on a separate palette which can be dragged around the 
drawing area. The palette displays by choosing Text>Bill of Materials>Show 
Palette.
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Show Palette/Hide Palette
Choose Text>Bill of Materials>Show Palette or Hide Palette, to display or hide 
the BOM palette.

Remove the tool palette using the button at the top of the palette.

Attribute Tools

With the attribute tools, assign attributes to object geometry or mark an object as a 
symbol. By selecting one of these tools all attributes of the current BOM layout 
display in the Status Line. Hidden attributes do not display in the Status Line.

The attribute values shown in the Status Line can be entered or modified if they 
are not locked. If they are locked, the attribute’s value is grayed out.

Attribute Selection Tool

Symbol Attributes Tool

Item Number Tool

BOM Tool
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Tip:

To assign attributes to an 
object made up of several 
individual objects, like a 
rectangle, made up of four 
single lines, group the object 
before assigning attributes. 
Otherwise, the attributes will 
be assigned to each 
individual object selected.
Attribute Selection Tool

Assign attributes of the current layout to a selected object with this tool.

Assigning Attributes
1. Choose Text>Bill of Materials>Define Layouts.

The Define Layouts dialog box displays.

For more information about the Define Layouts dialog box, see the “Bill of 
Materials Layouts” section later in this chapter.

2. Select a BOM Layout.

3. Close the Define Layouts dialog box by clicking Close.

4. Select Text>Bill of Materials>Define Attributes.

The Define Attribute dialog box displays.

5. Hide all attributes which needn't be assigned to object geometry in the current 
drawing by deselecting the eye icon next to that attribute.

6. Close the Define Attributes dialog box.

7. In the BOM tool palette, select the Attribute Selection tool. The Message Line 
reads, User Attribute Tool: Select Geometry...[Return = Append Attribute, 
Ctrl+Return = Remove Attribute {Windows} or Option+Return = Remove 
Attribute {Macintosh}].

8. Select the object to which attributes will be assigned.

9. Enter the desired values in the entry field in the Status Line.

Locked attribute values cannot be edited in the Status Line. 

10. Press the ENTER (Windows) or RETURN (Macintosh) key.

Important: The attributes are assigned only after pressing ENTER (Windows) 
or RETURN (Macintosh).
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Symbol Attributes Tool

This tool marks a symbol with assigned attributes.

Graphite doesn't recognize any difference between drawings and symbols. They 
are only opened by different commands:

• Drawings are opened by choosing File>Open.

• Symbols are inserted by choosing File>Symbol>Insert.

Symbol attribute tables cannot be edited. They must be deleted and reinserted.

Marking an Object as a Symbol
With the Symbol Attributes tool, mark an object with a small table containing all 
assigned attributes. This table is interpreted when the object is placed as a 
symbol.

When this object is inserted with the Symbol command all attributes contained in 
this table are listed in the Symbol dialog box. Values of unlocked attributes can be 
edited before the symbol is placed—without the attributes table—in the drawing 
area.

Symbol Attributes do not attach to the objects in the symbol file like object 
attributes. Instead, Symbol Attributes attach to the symbol when the symbol is 
inserted into a drawing.

When opening a marked symbol by choosing File>Open the attributes table 
appears in the drawing area with the symbol.

1. In the BOM tool palette, choose the Symbol Attributes tool. The Message 
Line reads, BOM Symbol Attribute Tool: Select Insertion Point.

2. Enter the values for the attributes in the Status Line.
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3. Click to place the Symbol Attributes table in an empty spot in the drawing 
area.

A table with all assigned attributes appears with the values entered in the 
Status Line. 

4. Save the object with the Symbol Attributes table.

The attributes in this table attach to the symbol when it is placed using the 
Symbol command, and the assigned values can be changed in the Symbol 
dialog box. There should be only one symbol table per file.

If a symbol holding object attributes are placed in the drawing, but no Symbol 
Attributes table is included, the object attributes do not display in the Symbol 
dialog box and do not get attached to the symbol when it is placed in the new 
drawing. To access the object attributes, the symbol must first be ungrouped.

An object can have both object attributes and symbol attributes, and their values 
do not have to be the same.

Editing Attributes
Assigned attributes display in the Status Line, where the default values are edited.

Showing Attributes
1. In the BOM tool palette, select the Attribute Selection tool.

2. Move the mouse pointer over the drawing area. As soon as the pointer comes 
near an object with assigned attributes, these attributes and their respective 
values automatically display in the Status Line.

Important: Attributes must be visible (eye icon displaying) and the proper 
layout must be active, as indicated in the Define Attributes dialog box and in 
the Define Layouts dialog box in order to display assigned attributes in the 
Status Line.
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Tip:

Values of attributes can also 
be edited in the Edit Objects 
dialog box. To do so, select 
the object, choose Edit>Edit 
Objects, change the value in 
the Edit Objects dialog box 
and click Apply.
Changing the Values of Attributes
1. In the BOM tool palette, select the Attribute Selection tool.

2. Move the mouse pointer near an object with assigned attributes.

The attributes and their respective values display in the Status Line.

3. Select the object with the Attribute Selection tool. 

4. Change the respective values in the Status Line. To remove an attribute value, 
delete the value in the entry field.

5. Press the ENTER (Windows) or RETURN (Macintosh) key.

The changed values are assigned to the selected attribute.

Removing Attributes
1. In the BOM tool palette select the Attribute Selection tool.

2. Move the mouse pointer near an object with assigned attributes.

The attributes and their respective values display in the Status Line.

3. Select the object with the Attribute Selection tool.

4. Press the CTRL+ENTER keys (Windows) or the OPTION+RETURN key 
(Macintosh) simultaneously. All visible and unlocked attributes are removed.

Item Numbers
The BOM tool palette assigns item numbers to objects which will be automatically 
included in the Bill of Materials table.
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Assigning Item Numbers
Item numbers are assigned with the Item Number tool in the BOM tool palette.

Do not use Graphite's Balloon tool from Graphite's Dimension palette to assign 
Item Numbers for objects to be listed in the Bill of Materials. Item Numbers 
created with the Balloon tool are not recognized by Graphite's Bill of Materials 
Extraction utility.

Item Number Tool

With this tool in the BOM tool palette, assign Item Numbers to objects. These Item 
Numbers will automatically be included in the Bill of Materials.

Using the Item Number Tool
1. In the BOM tool palette, select the Item Number tool. The Message Line 

reads, Item Number Tool: Pick BOM geometry to point to... [Ctrl = Renumber].

2. Three entry fields display in the Status Line: Item, Width and Size.

3. Enter the starting item number for the selected object into the Item field.

Item Numbers can also contain alpha characters—A, B, C, etc.

4. Click the Item Number tool near the object to be labeled.

5. Click with the Item Number tool in the drawing area to indicate the position of 
the Item Number balloon.

The Item Numbers are placed at the clicked location.

When placing additional position balloons the Item Number automatically 
increases. The default Item Number always increments from the last Item Number 
used.

If an Item Number is assigned to an object already assigned to another object, the 
item numbers adjust as follows:

• If the new Item Number is lower than the highest Item Number already 
assigned, all higher Item Numbers increase.

• If the new Item Number is higher than the highest assigned Item Number, the 
existing Item Numbers remain unchanged.

More than one Item Number cannot be assigned to an object. If so, the original 
Item Number balloon deletes. To get the original Item Number back, do an Undo.
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Tip:

An Item Number’s font is 
specified in the Font 
submenu of the Dimension 
menu. 

Tip:

The shape of the Item 
Number balloon can also be 
changed in Edit Objects. If 
existing Item Numbers are 
renumbered, all Item Number 
balloons revert to the default 
circle balloon.
Adjusting Item Number Balloon and Text Size
The following procedure describes how to adjust the Item Number balloon and 
Text size before assigning any Item Numbers.

1. In the BOM tool palette, select the Item Number tool.

The entry fields, Item, Width and Size, display in the Status Line.

2. Press the TAB key twice and enter the desired width for the Item Number 
balloon. The units for the indicated width are based on the unit specified in the 
Units dialog box from the Layout>Preferences>Units.

3. Enter the desired size.

4. Select the desired text size.

The text size of the Item Number balloon is now set.

5. Press the ENTER (Windows) or RETURN (Macintosh) key.

The size of the Item Number balloon is now set.

Editing Item Numbers
Item Number, Text Size and the Size of the Item Number balloon can be changed.

Editing the Size of an Existing Item Number Balloon
1. Select the desired Item Number balloon.

2. Choose Item Number Tool.

3. In the Status Line, enter the new diameter in the width field.

4. Press the ENTER (Windows) or RETURN (Macintosh) key.

The diameter of the selected Item Number balloon updates accordingly.

Editing the Text Size
1. Select the respective Item Number balloon.

2. Choose Edit>Edit Objects.

3. In the Status Line, enter the new Text Size in the size field.

4. Press the ENTER (Windows) or RETURN (Macintosh) key.

The text size of the selected Item Number balloon update accordingly.

Item Number text size can be changed dynamically by selecting the Item Number 
balloon and changing the size in the Dimension menu.
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Deleting Item Numbers
1. Select the desired Item Number balloon.

2. Select Edit>Delete or press the BACKSPACE (Windows) or DELETE 
(Macintosh) key.

The selected Item Number will be deleted.

Renumbering Existing Item Numbers
1. In the BOM tool palette, select the Item Number tool.

The entry fields, Item, Width and Size, display in the Status Line.

2. Enter in the Item field the new starting number for the Item Number, press the 
ENTER (Windows) or RETURN (Macintosh) key.

3. Press the CTRL (Windows) or OPTION (Macintosh) key and keep it pressed.

4. Click the Item Number balloons in the desired order.

The Item Number balloon will split. The upper half of the symbol shows the old 
Item Number and the lower half of the symbol the new Item Number.

5. Release the CTRL (Windows) or OPTION (Macintosh) key.

All Item Numbers renumber.

Item Numbers and Object Copies
The Item Number tool automatically recognizes if an object is a copy of an object 
to which an Item Number is already assigned, as long as the original object has an 
attribute of the Quantity. The Item Number tool automatically assigns the identical 
Item Number of the original object to the object copy. 

Bill of Materials
After assigning attributes to objects, 
create a Bill of Materials. The Bill of 
Materials will contain all Item 
Numbers and their associated 
attributes.

The Bill of Materials is placed on the current sheet. Move it to another location, 
copy it to another sheet or export it into an ASCII file to use it in other programs 
like spread sheets or text editors.

In order to create a Bill of Materials, first define a layout.
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Bill of Materials Layouts
The Layouts command defines different layouts for the Bill of Materials and is 
used in conjunction with the Define Attributes dialog box. To define layouts, 
choose Text>Bill of Materials>Define Layouts.

Layouts Command
The Layouts command, in the BOM submenu of the Text menu, displays the 
following dialog box:
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Layouts differ only by the attributes to which they relate. A layout contains all the 
visible attributes listed in the Define Attributes dialog box. (Visible attributes are 
indicated by a check mark.) Therefore, the Define Attributes dialog box should be 
displayed when defining a layout.

Defining a New Layout
1. Choose Text>Bill of Materials>Define Layouts.

The Define Layouts dialog box appears.

2. Click New.

3. Rename the layout in the Layout Name entry field.

4. Click Rename.

5. Double click to activate/set.

6. Select the Text>Bill of Materials>Define Attributes.

The Define Attributes dialog box displays.

7. Define all the attributes to be used in different layouts.

8. Make all the attributes visible to be saved under one layout name.

All active attributes in the Define Attribute dialog box are automatically saved 
under the current layout name for the current Graphite session.To save layouts 
permanently, choose Layout>Preferences>Save Preferences.
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Editing Layouts
1. Choose Text>Bill of Materials>Define Layouts.

The Define Layout dialog box displays.

2. Double click to activate/select.

3. Click Current.

4. Select the Text>Bill of Materials>Define Attributes.

The Define Attribute dialog box displays.

5. Show or Hide the attributes as desired.

All changes made in the Define Attribute dialog box are automatically saved under 
the current layout name. To save the changes permanently, choose Layout> 
Preferences>Save Preferences.

Layout Options
For all BOM layouts defined, some of the preferences can be set globally.

Select the Text>Bill of Materials>Options and this dialog box displays.
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Ballooned Only Places only BOM items in the table that have an 
associated BOM Balloon in the file.

Export Headline Draws the header line in the table.

Show Item Number Header Creates an Item column as the first column.

Item Number Header Names the Item column.

Table Margin Designates the margin between the text and the 
vertical column guides.

Headline Color Designates a color for the title text.

To choose a color, click into the pop-up menu and 
drag to the desired color. As soon as the mouse is 
released the selected color displays in the pop-up 
menu.

Sort by Selects the attribute by which the Bill of Materials 
should be sorted. Click into the pop-up menu with 
the left mouse button pressed and drag to the 
desired attribute. When released, the selected 
attribute displays in the pop-up menu.

User Widths Activates the Edit button. Clicking Edit displays a 
dialog box to define the column width of the Bill of 
Materials table.

Draw Table Selects whether the Bill of Materials is drawn from 
the Top Down or from the Bottom Up.
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Tip:

Macintosh users: drag the 
attribute names in the 
Attribute List in the Define 
Attributes dialog box to 
change the order.
User Widths
Specifies the width of the BOM columns individually.

The Edit button activates. Clicking Edit displays the following dialog box:

In this dialog box all attributes of the actual layout appear. For each attribute the 
respective column width displays. The displayed values for the column widths are 
calculated by the word length of each attribute and the indicated margin. Change 
the width for each column individually. All specified values are based on the units 
set in the Units dialog box (Layout>Preferences>Units).

Attribute Order
The order by which the attributes displays in the Bill of Materials is determined by 
the order the attributes were defined in the Define Attribute dialog box and cannot 
be changed in this box.

Creating A Bill of Materials
A Bill of Materials contains all the Item Numbers and their associated attributes. 
The generated Bill of Materials is an object in Graphite like any other object 
geometry. That means it can be moved, copied, deleted and edited. Create a Bill 
of Materials with the Bill of Materials tool in the BOM tool palette.

BOM Tool

This tool, in the BOM tool palette, generates a Bill of Materials of the current 
model and places it on the current sheet. Its insertion point is based on the Draw 
Table setting in the Options dialog box.
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Creating a Bill of Materials for the Entire Drawing
1. Choose Text>Bill of Materials>Show Palette.

The BOM palette displays.

2. Select the BOM tool. The Message Line reads, BOM Tool: Pick 
Insertion Point [Ctrl = Selection Only {Windows}, OPTION = 
Selection Only {Macintosh}].

3. Click in the drawing area to indicate the location to display the Bill of 
Materials.

The Bill of Materials of the current layout appears at the selected 
location. The Bill of Materials uses the font currently selected in the 
Text menu. It can be moved, copied or deleted like any other object 
in Graphite.

Creating a Bill of Materials of Selected Objects
1. Select all objects to display in a Bill of Materials.

2. Choose Text>Bill of Materials>Show Palette.

The BOM palette displays.

3. Select the BOM tool.

4. With the CTRL (Windows) or OPTION (Macintosh) key pressed, click in the 
drawing area to indicate where to place the Bill of Materials.

A Bill of Materials containing the selected objects is created and placed at the 
location indicated with the last mouse click.

Editing a Bill of Materials
1. Select the Bill of Materials with the Selection tool.

2. Choose Arrange>Ungroup.

The Bill of Materials ungroups into text and line objects that can be edited.
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Exporting a Bill of Materials
Attributes assigned to objects in a drawing can be exported into an ASCII file for 
use in other programs like text editors or spread sheets.

To export a Bill of Materials, select the File>Export. The displayed Export dialog 
box contains the export option Bill of Materials.

Exporting a Bill of Materials
1. Select File>Export.

The Export dialog box displays.

2. Mark the Bill of Materials option.

3. Select the Only Selected option to export attributes only from selected objects 
and not from the entire drawing.

4. Click OK and provide a file name and location.

The Item Numbers and attributes of the entire drawing or of the selected objects 
only export into an ASCII file.
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GD&T
GD&T stands for Geometric Dimensioning and Tolerancing, a U.S. government 
standard. This GD&T capability is compliant with ANSI Y14.5 (1985), DIN, ISO 
and JIS standards.

Since this annotation may be new to you, this section includes an overview of 
GD&T standards and a brief explanation of the components of a GD&T label, 
using the true position of holes as an example. The topics covered include:

• Background

• Alignment Information

• Bonus Tolerance

• Basic Dimensions

• GD&T Feature Control Frame

• Geometric Characteristics

• The GD&T Label
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Background
Before World War II, a single vendor did most military manufacturing for a 
particular part of product. During the war, however, it became a matter of national 
security to diversify weapons manufacturing so a single plant was not the only 
source of a vital part. When more than one manufacturer interpreted specifications 
and blueprints, difficulties arose.

When several companies manufacture the same part, each must drill holes within 
the same tolerance for the parts to be interchangeable. Even though 
manufacturers thought they were following the tolerance specifications, the parts 
were not interchangeable. The problem arose from the order in which 
measurements were made. 

Alignment Information
A part was usually laid on a flat surface (A) 
and aligned first with one straight edge (B), 
then with another (C). 

If one manufacturer aligned with edge B, then 
edge C, but another aligned with edge C, then edge B, the resulting 
measurements would probably be different. The GD&T standards tell a 
manufacturer the order of alignment.
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Bonus Tolerance
In addition to the alignment information, a manufacturer gets a bonus from GD&T 
tolerances. In conventional drafting, the tolerance for hole drilling results in a 
square target area. For example, examine the plate on the left below. The 
positional tolerance for the hole is ±.001. The target area (magnified and shown 
on the right) is from .001 left of the perfect center to .001 right of the perfect 
center, and .001 above the perfect center to .001 below the perfect center.

GD&T provides a circular target area for the hole. First 
measure from the center in one direction by the distance of 
the tolerance; then measure the same distance 
perpendicular to that point. 

Then use the distance from the endpoint of the second line 
to the perfect center as the radius of a circle to create a 
circular target—the bonus tolerance. 

In that way, the target area for the hole’s center is the area circumscribing the 
square of standard dimensions.
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The standard information (basic dimensions) about the target area appears in a 
box with a GD&T feature control frame.

Basic Dimension
Since the tolerance for a dimension is in the feature control frame, GD&T 
dimensions are also basic dimensions and appear in a box. The value defines the 
theoretically perfect location and implies that the tolerance is in the feature control 
frame.

To specify the basic dimension format, in the Dimension menu, go to the Linear 
and Angular submenus, and choose [xxx] (basic).
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GD&T Feature Control Frame
This section discusses the GD&T labeling of the left hole in the plate below.

Typically, the GD&T feature control frame appears as shown below:

Geometric Characteristics
The first section of the feature control frame contains the geometric characteristic 
symbol. The feature control frame on the previous page describes True Position—
how to locate the circular target area for the hole. The possible characteristics are 
as follows: 

Straightness The axis of an item of revolution or element of a 
surface is a straight line.
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Flatness All elements of a surface in one plane.

Roundness All points of a surface of revolution equidistant 
from an axis that is intersected by a plane 
perpendicular to that axis.

Cylindricity All points of a surface of revolution equidistant 
from a common axis.

Profile of Line A 3D element projected to a plane.

Angularity An axis or planar surface at a specified angle from 
another axis or datum plane.
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Perpendicularity An axis or planar surface at a right angle to a 

datum axis or datum plane.

Parallelism An axis or planar surface equidistant along its 

length to a datum axis or datum plane.

 True Position A zone of tolerance for a center axis or center 

plane.

Concentricity The axes of all elements in a cross-section share 
a common datum axis.

Symmetry The location of a feature relative to a center 
plane.
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Tip:

If the diameter symbol is 
appropriate for the geometry, 
it should be displayed. It is 
usually not used with 
flatness, roundness, 
cylindricity, profile of line or 
surface, angularity, circular or 
total runout.
Circular Runout Circular elements of a surface of revolution 

associated with a datum axis.

Total Runout All elements of a surface of revolution associated 

with a datum axis.

Diameter
The second section of the feature control frame specifies whether the tolerance 
applies to a circular zone. If it does, specify the diameter symbol (Ø) from the pop-
up menu. 

Position Tolerance
The third section of the feature control frame defines the tolerance allowed under 
the stated conditions.

Material Condition
The fourth section of the feature control frame provides the material condition for 
limiting the tolerance. Use any of three material conditions: Maximum, Least and 
Regardless of Feature Size.
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Tip:

Maximum Material Condition 
is the most commonly used 
symbol for parts.

Tip:

Least Material Condition is 
most frequently used to 
control wall thicknesses of 
parts, as well as for tool 
fixtures and inspection 
gauging.
Maximum Material Condition
Maximum Material Condition (MMC) indicates that a feature contains the 
maximum amount of material within the specified tolerance limit. For drilling holes, 
MMC means that the drill bit is accurate—it drills the smallest hole. For shafts, 
MMC results in the largest dimension. 

In the example above, this material condition symbol means that the tolerance in 
the feature control frame (.002) applies to the location of the smallest hole (.310 in 
this case). As the hole size nears its upper limit (.315), the location of the hole 
increases from .002 to .007 (the tolerance for the location, .002, plus the tolerance 
for size, .005).

Least Material Condition
Least Material Condition (LMC) indicates that a feature contains the minimum 
amount of material within its specified tolerance limit. For holes, the swept area is 
the largest and the drill bit drills the largest hole. For shafts, the tolerance is the 
smallest allowable dimension.

In the example above, this material condition symbol means that the tolerance 
(.002) applies to the location of the largest hole (.315). As the hole size nears its 
lower limit (.310), the tolerance for the location of the hole increases from .002 to 
.007 (the tolerance for the location, .002, plus the tolerance for size, .005). 
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Regardless of Feature Size
The Regardless of Feature Size (RFS) material condition means the tolerance 
applies regardless of the size of the feature (within the specified tolerance limit). 
For holes, the location tolerance is the same regardless of whether the hole is the 
smallest or largest allowable size. For shafts, the roundness tolerance is the same 
regardless of the shaft diameter.

In the example above, this material condition symbol in the feature control frame 
(.002) applies to the location of the hole whether the hole is at its smallest (.310) 
or largest (.315). This material condition would control an axis in space, so you 
probably wouldn’t use Regardless of Feature for this hole.

Datum
The last three sections of the frame show the alignment order to position the part. 
This is easier to see in a part which does not have perpendicular sides. A typical 
engineering drawing might appear as shown below:

For proper drilling alignment and measurement, this part would lie on a flat surface 
(Surface A), with Side B pushed against the first straight edge, and then Side C 
pushed against the other straight edge.



Graphite User Guide Geometric Characteristics
GD&T tells a manufacturer which surface to align first. If the part is aligned with 
Side C before Side B, the holes do not line up in the same way as they would if 
Side B was aligned before Side C.

The rule for points of contact per surface is as follows:

Datum Material Condition
When showing a datum in a feature control frame, there is also the option of 
indicating a material condition. Such a modifier should only be specified for a 
datum that is an axis or centerplane of a feature, such as a hole or boss. Material 
Condition modifiers do not apply to planes such as the straight side or flat bottom 
of a part.

Composite GD&T Symbols
A composite symbol uses more than one line of the feature control frame to 
specify more than one tolerance for the same feature. 

The first line of the feature control frame means that the hole must be straight 
throughout within a cylindrical tolerance of .003 diameter for the total of its length, 
3.00 inches. The second line of the frame means that the hole must be straight for 
any 1.00 inch portion within a cylindrical tolerance of .001 diameter. Graphite 
creates the composite frame automatically if the same symbol is in Line 1 and 
Line 2 of the dialog box.

Surface Point of Contact 
(minimum)

1st 3

2nd 2

3rd 1
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Projected Tolerance Zone
This entry box of the feature control frame specifies an area above the actual part 
where the tolerance of a feature should still apply if the feature were extended or 
projected into the area. For example, if an outboard motor has a hole in the 
housing, the hole has to be straight not only through the housing, but also down 
into the propeller assembly, so that the drive shaft aligns properly.

In the motor example, the tolerance for the hole should be checked 24 inches from 
the actual hole.
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The GD&T Label

GD&T Command
The GD&T command in the Dimension menu creates a label, a feature control 
frame for showing dimensions, alignment, and tolerances. The dialog box looks 
like a complex GD&T symbol into which the information can be entered. 

The GD&T label uses Plotter fonts so the font size corresponds to ANSI 
standards, since the sizes of other fonts are not always consistent with ANSI 
standards. If the size of the dimensions needs to be the same as the font in a 
GD&T label, select the dimensions and change the font size or choose the plotter 
font.

The GD&T dialog box resembles a GD&T label. For 3D geometry, GD&T labels 
are created parallel to the work plane. 

The square boxes are pop-up menus from which symbols are selected. Use a 
single entry, a line, or a combination of lines as needed to specify the GD&T 
dimensions for the part.

Geometric Characteristics

Diameter Symbol

Tolerance Value

Material Condition

Dimension Label
Material C

Datum Tex

Datum

Tolerance Projection Zone

Datum Text

Material Condition

Material Cond

Datum Text
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P

Creating a GD&T Label

1. Choose Dimension>GD&T. The GD&T dialog box appears. 

2. Click a button (Stand Alone, Arrow Line, or Witness Line) to indicate the way 
the GD&T symbol is connected to the geometry being labeling.

3. Enter the appropriate data to create the GD&T label. Make two types of 
entries in this dialog box:

• Select symbols from pop-up menus that appear when pressing the square 
buttons. 

• Enter text in the rectangular fields by clicking to place a text cursor, and then 
typing the entry. 

4. Indicate the location of the label. The Message Line guides each successive 
step.

• For a Stand Alone label, click the location for the upper-left corner of the 
GD&T label. 

• To connect a label with an Arrow Line or Witness Line, click on the geometry 
to be labeled, and then click on the drawing area to indicate the position for 
the upper-left corner of the label.

Entry Boxesop-up Menu Boxes
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Editing a GD&T Label
Once a GD&T label is created, it is possible to make changes.

1. Select the GD&T label to be edited.

2. Choose Dimension>GD&T.

The GD&T dialog box appears, displaying the current GD&T information.

3. Make the changes in the GD&T dialog box.

4. Click Edit.

The GD&T label changes.

Using an Editing Shortcut with GD&T
When editing a GD&T label or creating a second label, every entry in Line 1 or 
Line 2 can be removed. 

1. Press the first field to display the Geometric Characteristic menu.

2. Drag to the X symbol. 

All entries in the line disappear.
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Appendix A: Operators and Units
This appendix describes mathematical and conditional operators.

Mathematical Operators
Entry boxes that accept numbers also accept mathematical, trigonometric and 
exponential operators in the form:

funcName (arg1; arg2; . . . ; argN)

Operator Example Operator Example

Addition 3+.450 Arctangent atan(1;1)

Subtraction 3-.500 Log (Base 10) log(7.25)

Multiplication 3*.725 Natural Log ln(8.5)
(Base e)

Division 3/5.25 Remove truncate(6.125)
Fractional Part

Square Root sqrt(8.75) Absolute Value abs(-47+16)

Parenthetical 3/(5*2/4) Smallest Larger ceiling(5.25)
Integer

Scientific 4e-3 Largest Smaller floor(12.75)
Notation Integer

Exponentiation exp(2;7) Negative Value neg(11.12)

Sine of Angle sin(15) Round round(11.12)

Cosine of cos(30) Random # in rand()

Angle range 0 to 231

Math operators are case-sensitive so be sure to type them in lower case when 
using them. Use these operators to edit objects, make entries in the Status Line 
and specify values in dialog boxes.

Conditional Expressions
Conditional expressions are particularly useful with parametrics when an 
expression depends on a condition. For example, a flange might depend on the 
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diameter of a pipe but should never be smaller than some minimum size. Use two 
function forms of conditional expressions, ifelse and RNG (range).

ifelse (condition; expression1; expression2)

Condition The result of a boolean expression:

== equals

!= not equals

> greater than

>= greater than or equals

< less than

<= less than or equals

&& logical and

|| logical or

! logical not

expression1 The value of the ifelse function if the condition is true.

expression2 The value of the ifelse function if the condition is false.

The following examples show boolean expressions and an ifelse statement:

Length > 5 The length is greater than 5

(L <3) || (W >=2) Either the length is less than 3 or the width 
is greater than or equal to 2.

3*ifelse (A>B; A; B) Evaluate three times the maximum of the 
variables A and B, returning 3*A if A is larger than 
B and 3*B if B is larger than A.

The range function is a more general form of conditional expression.

RNG (T; V1; N1; V2; N2; V3; N3 ... Vi; Ni; Vi + 1)

In this function, the first argument (T) is tested against every N value in the other 
arguments and returns the value (V) that lies between the two N values that 
bracket T. Each of the test N values must be greater than the preceding N.

For example, the expression 



RNG (A; -1; 10; 0; 20; 1) returns -1 if A is less than 10 
0 if 10 <= A <201
1 if A >= 20

Units of Measure
Use different units of measure such as inches ("), feet ('), inches and feet (x'y"), 
millimeters (mm), centimeters (cm) and meters (m). It is possible to mix the units 
in the mathematical expression as long as the units are labeled properly, for 
example, 10" + 25.4 cm.

Nanoseconds
Graphite is well-suited for computer hardware design, such as diagrams of timing 
devices. For example, draw in nanoseconds (a billionth of a second). Designs 
which include nanoseconds typically consist of wave forms made of horizontal and 
vertical lines which mimic the functions of a timing device.

The concept for using nanoseconds is to relate time with distance.

1. Specify millimeters as the unit of measure by choosing 
Layout>Preferences>Units.

2. Choose Layout>Preferences>Grid.

3. Set the grid spacing to 34 and the number of subdivisions to 2. 

A megahertz is approximately 34 nanoseconds and this becomes the base 
cycle, with two tick marks for drawing half cycles.

4. Turn on the grid.

5. Use the Connected Lines tool to draw the wave form of the desired 
specifications.

6. Use the Expand/Shrink tool to stretch the wave form to half and full cycles. 
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Tip:

It is possible to place the 
constraint lines on another 
layer and hide them.
Using Parametrics for Wave Forms
Use parametrics to speed up this process, as shown below. The dotted lines are 
constraint lines.

Decimal Indicators
International numeric keypads have a comma in place of the period because 
Europeans use commas in decimal expressions. 

Graphite can handle both American and European decimal entries in the Status 
Line (24,5 or 24.5), however, the display is controlled by the Numbers Control 
Panel.

Keyboards and Command Keys
Since keyboards vary from country to country, the Graphite command keys may 
not respond as described with a non-American keyboard.



Tech Note:

Numeric values must be 
entered with an enhanced 
101 keyboard using the 
separate number pad.
Appendix B: Special Characters
It is possible to use special characters and accents which are available with the 
computer. Usually these characters are described in an appendix of the 
computer’s user manual. Many symbols and characters are accessed from the 
keyboard. 

Windows
If necessary, unlock the keypad with the NUM LOCK key, and then hold down the 
ALT key and enter the numeric code for the necessary character.

The character appears in the current font (including Graphite's Plotter fonts). The 
following list includes common symbols which are available in all fonts:

Accent Key Combination

° ALT 0176

ø ALT 0216

± ALT 0177
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Macintosh
The following list includes common symbols which are available in all fonts.

Accent Key Combination

° OPTION+ SHIFT 8

ø OPTION+SHIFT O (letter)

± OPTION+SHIFT =

Adding Special Symbols to the Dimensions Text
1. Select the dimension you need to add special symbols to.

2. Open the Edit Objects window. Next to the Text entry field there is  button. 
Click the button and the drop down list of symbols appears. Choose the one 
you need.

3. Click ENTER. The symbol appears in the dimension text.



Appendix C: Program Settings & Files
For your convenience, this appendix includes the default settings present for first 
installing the program. It also includes a list of all the folders and files that come 
with the program.

Default Settings
The default settings are contained in the Prefs.VC6 (Windows) or Graphite Prefs 
(Macintosh). Change these setting by opening this file, making the changes and 
then saving the file. See Chapter 5, Basic Environment Settings for more informa-
tion.

Once new preferences are saved, the previous default settings are no longer 
available. The following are the default settings that came with the program 
according to the pull down menus:

Edit menu

Selection Mask All Selected
Selectable Points On
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Layout menu

Preferences Submenu
Units

Precision 0.001
Inches
* All others off

Selection Color Red
Invert White
DA On
Autosave Off 15 min.

Layers Construction, Dimension, Layer1, Constraint

Arrange menu

Divide
# of pieces 2
Show Points On

Pen menu

Style Outline
Color Black
Weight 0.010
Pattern Solid
Arrowheads Standard
Arrow at Start Off
Arrow at End Off

Text menu

Font Plotter (Windows); Geneva (Macintosh)
Size 12 pt
Style Normal
Align Left On
Single Space On



Dimension menu

Linear .xxx
xxx

Linear Tol .xxx
Angular xx.xx° (Windows); Whole Degrees (Macintosh)

xxx
Angular Tol xx.xx° (Windows); xx.x° (Macintosh)
Text Horizontal
Font Plotter
Size 9 pt
Style Normal
Color Blue
Weight .002
Layer dimension
Arrowhead Standard

Arrow Size
Dot Size .125
Length .25
Height .125
Side .258

Angle: 28° 4' 21"
Witness Lines Line at Start, On

Line at End, On

Views menu

Sheets Sheet 1
Models Model 1
Views Top
View the Plane Off
Draw View Boundaries On
Show Trackball Off

WindowsUntitled

3D menu

Planes Top
Show Triad Off

Utilities menu

Macros Empty
Navigator Unchecked
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Glossary
Glossary
Accelerators Keyboard equivalents that invoke commands 

rather than using the mouse to choose from 
menus.

Annotation Text on drawings, including notes, crosshatching 
and dimensions.

Apple HSL Display A standard color wheel for the Macintosh with the 
option to specify Hue, Saturation and Lightness.

Apple RGB Display A standard color display for the Macintosh with 
the option to specify Red, Green and Blue 
percentages.

Alignment 1. The justification of text with either or both 
margins even or text centered within the 
designated text space. Alignment is set in the Text 
menu.

2. The spatial relationship of different sets of 
geometry to each other along a common line.

Alignment Angle The angle of the Drafting Assistant’s automatic 
construction lines. The specification is set by 
choosing Layout>Preferences>Snap.

Arc Tool Draws a part of a circle.
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ASCII An acronym for American Standard Code for 
Information Interchange. This is the format for text 
characters to be imported into Graphite. Most 
word processors save text in ASCII format.

Arrow Tool Used for selecting objects to be operated on with 
subsequent commands. Also used to move 
selected geometry.

Associativity A link between an object and its dimensions or 
between views. If the object is changed, the 
dimensions automatically change to match. In 
associative views, such as a detail view, when 
geometry is changed in one view, all views of the 
same geometry are changed accordingly. 

Attributes The data fields associated with a particular object 
that completely define that object. This includes 
layer name, pen style, color, x-y-z coordinates 
and even data for a BOM, such as cost, item-
name, quantity, description, etc.

Automatic Dimensions This tool automatically places dimensions on 
lines, circles, ellipses and arcs with one mouse 
click on the geometry.

Bezier Curve A free form curve. NURB splines are a superset of 
Bezier curves.

Border A frame showing the boundary of a view.

Boundary The geometry that defines the limits for operations 
such as trimming, relimiting, crosshatching, 2D 
analysis, or fill.

CAD An acronym for Computer-Aided Design.

CADD An acronym for Computer-Aided Design and 
Drafting.

CAE An acronym for Computer-Aided Engineering.

CAM An acronym for Computer-Aided Manufacturing.
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Chamfer Tool The tool that constructs beveled or sloping edges 
or a surface between two objects.

Chain This entity is created when flattening a surfaced 
object using the Flatten View command. Once an 
object is flattened these chain entities can be 
edited.

Characteristics See Attributes.

Circle Tool Draws circles specified by the radius, the 
diameter, or tangency to other entities.

Circle Center Line This tool places a center line on circles. 

Circumference The distance around a circle along its edge =

Circumscribed Enclosing a circle. In circumscribed polygons, the 
midpoint of each side of the polygon touches an 
imaginary circle (i.e. the polygon exactly 
surrounds the circle).

Click To press and release the mouse button. To click 
an object, move the pointer to the object and 
press and release the mouse button.

Clipboard The memory buffer where selections are stored 
when the Cut or Copy command is used.

Construction Lines Lines, displayed as dotted or gray lines, used for 
exact alignment. The Drafting Assistant creates 
dynamic, temporary construction lines. 
Permanent construction lines can also be created 
then deleted.

Control Point The endpoint or midpoint of an object or “knot” 
point defining a spline. The Drafting Assistant 
indicates these positions when the pointer is 
moved near them.

Coordinates Positions on axes that specify the locations of a 
point. Two-dimensional graphics have x,y 
coordinates; three-dimensional graphics have 
x,y,z coordinates.

2r
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Copy The command that places a duplicate of the 
selected geometry on the Clipboard. See the 
descriptions for the Polar Duplicate and Linear 
Duplicate commands and Transformation tools 
for additional copying methods.

Corner Tool An editing tool that trims lines extending past their 
intersection or extends lines to form a corner.

Crosshatching The filling of closed geometry with a line pattern.

Cursor The I-beam position indicator in the text tool and 
boxes which use text. Elsewhere, the position 
indicator is called a pointer. 

Curve A circle, arc, ellipse, or spline.

Cut The command to delete selected entities. The 
selection is placed on the Clipboard and can be 
pasted into the same or different documents or 
into documents created by other applications.

Custom Colors (Windows only) The button in the color display 
that defines 16 additional colors to show in the 
partial color display.

Dash A pen style or line pattern made up of dashes.

Default Built-in settings that are used by the system if a 
value or choice is not specified by the user.

Delete The command to erase selected geometry. The 
selection is not placed on the Clipboard. It can, 
however, be retrieved within the limits of the Undo 
command.

Delta A change, usually in position.

Detail View Tool The tool that creates a separate view of the 
indicated geometry, at the specified scale.

Dialog Box A specification box that appears in response to 
certain commands. A dialog box provides 
information that qualifies the execution of those 
commands.

Diameter The distance across an arc or circle, passing 
through the center.
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Dimension A graphical object that displays the distance 
between two points, a measurement of an object 
and also a pen style.

Divide To segment a line or curve into equal parts.

Double-click To press and release the mouse button twice 
in rapid succession. 

Drafting Assistant A unique Graphite feature which displays 
feedback notations and construction lines to aid 
with snap, alignment and constraint operations. 
The Drafting Assistant facilitates exact 
construction without requiring manual precision. 
When the pointer is close enough to display 
feedback, the Drafting Assistant locks onto the 
exact location.

Drag To press and hold the mouse button, move the 
pointer to a new location, and release the mouse 
button.

DXF An acronym for Data Exchange Format, a format 
of AutoCAD files.

Drawing A 2-dimensional line art representation, 
usually including an orthogonal view and 
dimensions.

DWG AutoCAD's native file format.

Ellipse Tool The tool for drawing ellipses from rectangle or 
parallelogram specifications.

Endpoint The first or last point of a line or curve. The 
Drafting Assistant indicates these positions when 
the pointer is moved near the endpoint of an 
object.

Export To save a document in a file format that can be 
used by a different application program.

EPS Encapsulated PostScript format for printing to a 
PostScript printer and for importing into 
compatible applications.
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Eye Dropper The Eyedropper tool copies properties from a 
selected entity to another entity, including lines, 
fonts, layers or dimensions. For text the 
properties include font, size and color. For 
dimensions it includes text location, font, size, 
style, colors, line weight, layers and arrow head 
on/off.

File An individual document.

Fillet Tool A tool that creates an arc of a specified 
radius tangent to entities. 

Flatten To convert a view of a 3D model into a 2D plane. 
Flattening disassociates a view from a model, 
allowing independent editing. 

Font The assortment of type used in text.

Forms The command to create standardized title blocks.

GD&T Drafting notations for Geometric Dimensioning 
and Tolerancing.

Geometry The objects used to construct parts.

Grid The rectangular array of lines that facilitates 
measurement and alignment. The grid display can 
be turned on or off, and the spacing can be 
specified through the Layout menu.

Group To specify several entities as one unit that will be 
treated as a single object.

Hidden A line pattern or pen style used to draw lines that 
would not be visible in a solid part. Drafters 
traditionally use hidden lines for geometry that is 
behind other geometry.

Hit Radius The distance, in pixels, that is detectable by the 
Drafting Assistant between the object and the 
pointer.



Glossary
IGES An acronym for Initial Graphics Exchange 
Specification. The U.S. Department of Commerce, 
National Bureau of Standards issues IGES, which 
is intended to be the industry standard among 
CAD/CAM systems for data exchange in a neutral 
file format. Ashlar-Vellum Graphite supports IGES 
Version 4.0.

Import To load a non-Graphite file.

Inscribed Within a circle. For polygons, all vertices touch 
the (imaginary) circle.

Intersection The position where two lines or curves meet. The 
curves may actually touch or only intersect when 
they are extended. 

Isometric A top, front and right view in which the X-axis is at 
-30° from the screen horizontal, the Y-axis is 30° 
from the screen horizontal and the Z-axis is 
vertical.

Knot Points The points defining a spline, indicated as vertex 
points by the Drafting Assistant.

Layer Analogous to transparent media used in 
conventional manual drafting. Parts can be 
constructed on several layers which can be made 
visible or invisible.

Line Tool The tool that draws single, connected, parallel 
lines, or smart walls.

Linear Duplicate The command that copies an object in a line or in 
an array of multiple lines.

Lock The command to render a selection 
unchangeable.

Mask To select entities as a group, masking out all 
others. 

Math Operator The mathematical, trigonometric, or exponential 
expression used to indicate values. All value entry 
boxes in Graphite accept the math operators 
listed in Appendix A.
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Message Line The top line of the drawing area. It names the 
current tool and provides instructions for using it.

META The file format used by the Windows Clipboard.

Mnemonics The key sequence which invokes a command 
from a menu.

Model The geometry that is incorporated into a view. The 
model is the geometry that a view sees.

Non-planar Surfaces or points that do not lie in a two 
dimensional plane.

NURB Non-Uniform Rational B-splines—the type of 
splines Graphite creates. NURB splines are a 
superset of Bezier curves. NURB splines provide 
designers with two interrelated functions. 

First, curvature continuity remains intact even 
when the curve is changed, so kinks won’t 
develop as the spline is altered. Second, localized 
control of a complex curve is provided, so an area 
can be isolated for changes without affecting the 
remainder of the spline. 

Object An individual piece of geometry, such as a line, 
arc, or circle.

Object Rotation The command that rotates geometry around any 
axis.

Origin The 0,0,0 location on the drawing area. When a 
new document is opened, 0,0,0 is located in the 
middle of the screen. The coordinate symbol 
displays at the origin when the grid is turned on. 
The origin can be changed at any time.

Orthogonal A 2D view of a 3D model which does not show 
perspective, usually the top, front and right view 
of the model.

Palette A group of tools. The general tool palette is 
always displayed to the left of the drawing area. 
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Parametrics Integrated parametrics is available through the 
Resolve and Symbol commands. Once geometry 
is created, add dimensions as variables or real 
values. Choose Resolve, to enter specific 
dimensions for the variables, and the object is 
drawn to the specifications.

Part A solid with or without associative history.

Paste To place the contents of the Clipboard in the 
current document.

Perpendicular At a 90° angle. 

PICT The Macintosh graphics file format which uses 
object-oriented bitmaps or resolution-independent 
graphics.

Pick To select a location or object by clicking it.

Planar Surfaces or points that lie in one two-dimensional 
plane.

Plot To print on paper using a plotter.

Plotter A vector drawing device for hardcopy output.

Point A location for constructing geometry.

Pointer The position locator similar to a cursor. When a 
tool is in effect, the pointer takes on a 
representative shape while in the drawing area.

Polar Duplicate To copy a selection and rotate it around a 
reference point.

Polygon Tool The tool that draws regular polygons, that is, 
objects with equal sides. Specify rectangles and 
inscribed or circumscribed polygons. 

Press To press and hold down the mouse button. This 
action is most commonly used to view the 
contents of a menu.

Redo The command that reverses the action of the 
Undo command. 

Redraw To refresh the screen, recreating all objects.
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Relative Position A location specified as a certain distance from 
another location. It is often called the delta 
position.

Relimit A trim tool that lengthens or shortens lines to the 
specified object.

Resolve The command that draws geometry according to 
the specific indicated measurements. See 
Parametrics.

Right-hand rule 1. A memory aid for the relative directions of the 
positive axes. With your right palm upturned, 
the thumb (X) points right, the index finger (Y) 
points straight ahead and the middle finger (Z) 
points up.If you move your hand to indicate the 
X and Y axes, you can easily see the direction 
of the Z axis.

2. A memory aid in which the thumb of the right 
hand points in the direction of the positive axis 
of rotation. The fingers curve in the direction of 
rotation.

Segment Tool The tool used to divide a line or curve at specific 
boundaries.

Selection Tool The tool that selects objects. Usually, subsequent 
actions affect only the selection. Also used to 
move selected geometry.

Sheet An unbounded region for drawing. Think of a 
sheet as one page in a set of blueprints.

Slope The change of x relative to y between two points 
on a line. In a spline, slope defines the vector of a 
line tangent to the spline at a particular knot point.

Smart Symbol A symbol created with the Smart Wall tool which 
is automatically incorporated into a smart wall.

Smart Wall A tool to create special double walls 
automatically, trimming overlapping intersections.

Snap The Preferences command that sets the 
specifications for the Drafting Assistant.
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Snap Command Activates or deactivates different snap modes of 
the Drafting Assistant.

Spline A smooth, free-form curve passing through 
specified points.

Status Line The line at the bottom of the drawing area to enter 
the specifications for the geometry being created.

Stretch Tool Used to stretch the geometry along one axis and 
at a specified angle.

Symbol Libraries Groups of symbols of the same type. These were 
either included with Graphite or created by you.

Symbol The command that retrieves a predefined 
drawing. This command may use Graphite’s 
integrated parametric feature.

Tangent The point where a line or curve touches a curve 
without intersecting it. The Drafting Assistant 
displays the tangent notation of a curve when the 
pointer nears it.

Textblocks This command creates a standard text block for 
multiple use.

Text Tool The tool for drawing annotation. Specifies a text 
box (the area where text is displayed) for entering 
the text.

Text Lines Tool Used to place text within a geometrically created 
horizontal line.

Toggle To switch between two conditions, for example, 
Hide Grid/Show Grid.

Transformation The tools to move, rotate, expand or shrink, or 
mirror an object or group of entities.

Trim To shorten or remove a portion of a line.

Trimetric A top, front and right view in which the Z-axis is 
vertical, the X-axis is at -30° from the screen 
horizontal and the Y-axis is at 15° from the screen 
horizontal. 

Undo The command that reverses the last editing or 
creation action. 
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Unfold To open a model 90° along an axis.

Units Measures used for display of geometry.

Vertex The point at which the sides of an angle intersect, 
or a knot point of a spline.

View-dependent Geometry that appears only in the view in which it 
was created. Crosshatching, text, GD&T symbols 
and dimensions in a detail view are view-
dependent.

Visible A pen style.

Wireframe A 3-dimensional representation showing 
boundary lines, edges and intersections, but not 
surfaces.

World Plane The work plane used at the beginning of the 
construction of a model. Also known as the world 
coordinate system. 

Work Plane The x,y plane used for 2D objects which has an 
origin of 0,0,0 for all data input. Sometimes 
referred to as the user or work coordinate system.

Zoom The tool or command that magnifies or reduces 
an image. 



Index
Index
Symbols
% Point 4-8
Numerics
2D analysis

Command 18-2
Displaying the Centroid 18-5

2D analysis calculation 18-1, 18-5
Area 18-3
Centroid 18-4
Inertia 18-4
Perimeter 18-3
Tolerance 18-2
Weight 18-4
Weight Per Area 18-3

2-Entity
Chamfer 10-4
Fillet 10-2

2-Point Center Ellipse tool 7-24
3-Corner Ellipse tool 7-27
3D

Drawing tools 8-1
Extrude 8-4
Features/tools 8-4
Geometry 8-1
Revolve 8-6
Tracer tool 8-4
Work plane 8-9

3D construction rules 8-3
3D geometry

Arcs 8-3
Circles 8-3
Ellipses 8-3
Fillets 8-4
Lines 8-3
Rectangles 8-3
Splines 8-3

3D viewing 6-8
3-Entity Fillet tool 10-3
3-Point Center Ellipse tool 7-26

3-Point plane command 8-9, 8-13
3-Point tools

Arc 7-18
Circle 7-22

A
Absolute value A-1
Active view 13-21
Add Spline Control Point tool 7-33
Addition A-1
Align axis

x 2-5
y 2-5
z 2-5

Alignment
Angles 4-7
Drafting Assistant 2-5
GD&T 20-2
Text 11-8

Anchors (parametrics) 16-8
Angles

Alignment 4-7
Construction 4-10, 4-13
Creation 4-8

Angular Chamfer tool 10-4
Angular dimension command 12-34
Angular dimension settings 12-34
Angular Dimension tool 12-27
Angularity, GD&T 20-6
ANSI

Font 11-6
GD&T 20-1, 20-13

Arc Length Dimension tool 12-29
Arc tools 7-17

3D 8-3
3-Point 7-18
Center-Point Arc 7-17
Tangent objects 7-18
Tangent-Point 7-19

Arctangent A-1
Area 18-3, 19-7
Arrange menu 3-12
I-1
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I-2
Arrow pointer 3-2
Arrowhead

Arrow at end 11-20
Arrow at start 11-20
Dimension 12-41

Arrowhead appearance
Pen 11-19
Size 11-19
Type 11-19

ASCII 15-11, 15-13
Associative

Detail view 13-19, 14-15
Dimensions 12-2

Asterisks 3-17
Attribute operation

Assigning 19-7, 19-9, 19-12
Command 19-4
Defining 19-3
Deleting 19-6
Editing 19-6, 19-11
Hide 19-7
Lock/Unlock 19-6
Removing 19-12
Save 19-7
Show 19-7, 19-11

Attribute tools
Selection 19-9
Symbol Attributes 19-10

Attribute type
Predefined 19-2, 19-7
User-defined 19-2
Vellum attributes 19-7

Attributes
Active 19-4
Order 19-20

Auto Front command 13-25
Automatic Dimensioning tool 12-9
AutoSave

Command 15-5
Preference 5-31

B
Backup 15-5
Balloon

Dimension tool 12-30
Item number 19-14
Pen style 5-2, 5-19

Base Line dimension
Horizontal 12-11
Oblique 12-18
Perpendicular 12-21
Vertical 12-14

Bill of Materials 19-1
Attributes 19-2, 19-3
Introduction 19-2
Layout options 19-18
Layouts 19-16
Palette 19-8
User format 19-20

Bill of Materials operation
Creating 19-20
Defining layout 19-17
Editing 19-21
Exporting 19-22

Bitmap
Export 15-17
Import 15-12

Blinking selection 9-3
BMI

Import 15-11
BOM tools 19-7

Attribute Selection 19-9
BOM 19-20
Item Number 19-13
Symbol Attributes 19-10

Bring to Front command 13-26
C
Calculation, 2D analysis 18-1, 18-5
Camera

Detail view 14-37
Sheet view 2-2, 14-37
View/Sheet 14-40
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Center pen style 5-2, 5-18
Center, Drafting Assistant 4-3
Center-Point tools

Arc 7-17
Circle 7-20

Centimeters 5-22, A-3
Centroid 18-4

Attributes 19-7
Displaying 18-5

Chain dimension
Horizontal 12-11
Oblique 12-19
Perpendicular 12-22
Vertical 12-15

Chain object 9-10
Chamfer tools 10-2

2-Entity 10-4
Angular 10-4

Chamfer, Smart wall 7-15
Check boxes 3-16
Circle Center Line Dimension tool 12-
29
Circle tools 7-20

3D 8-3
3-Point 7-22
Center-Point 7-20
Opposite-Point Circle tool 7-21
Tangent-Point 7-22

Circular runout, GD&T 20-8
Circumscribed Polygon tool 7-29
Click 7-3
Close command 15-6
Color

Define 5-5
Dimension 12-38
Editing 5-6
Layer 13-8
Pen 5-4
Saving 5-7

Color palette
Customizing 5-7
Displaying a color 5-7

Removing a color 5-7
Commands

Choosing 1-1
Concentricity, GD&T 20-7
Conditional expressions A-1
Connected Lines tool 7-12
Construction 4-11

Angles 4-10, 4-13
Command 4-12
Geometry 4-14
Offset 4-13
Pen style 5-2, 5-19
X,Y coordinates 4-13

Construction line type
Dynamic 4-9
Permanent 4-11
Stroke 4-11

Construction lines 2-5, 4-9
Command 4-12
Creating multiple 4-13
Creating parallel 4-13
Delete 4-15
Layer 4-11
Using 4-9

Control point 7-33, 9-2
Spline 7-35

Convert Command 15-24
Convert command 15-16
Copy 10-33

Detail view 13-23
Objects 10-27, 10-33

Corner Trim tool 10-7
Cosine of angle A-1
Counting objects 13-12
Creation angles 4-8
Crosshatch 2-7, 11-12

Command 11-15
Detail view 14-16
Edit 11-17
Patterns 11-12

Crosshatch type
DIN 11-13, 11-17
I-3
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I-4
ISO 11-13, 11-16
Cut

Command 10-32
Detail view 13-22

Cylindricity, GD&T 20-6
D
Dash handle 5-15
Dash pen style 5-2, 5-18
DAssistant

Command 4-5
Preference 5-31

Datum, GD&T 20-10
Decimals A-4

# of places 3-10
Status Line 7-6

Default settings
Preferences 5-33

Define
Attributes 19-3
BOM layout 19-17
Color 5-5
Pen pattern 5-13
Plane 8-9, 8-14
View 14-20

Delete
Attributes 19-6
Command 10-34
Construction lines 4-15
Detail view 13-23
Item numbers 19-15
Layer 13-10
Layer group 13-16
Model 14-8
Plane 8-17
Sheet 14-4
View orientation 14-22

Deselection 9-9
Detail view 2-2, 13-17, 14-32, 14-39

Active 13-21
Associative 13-19, 14-15
Crosshatching 14-16

Delete 13-23
Dimensions 14-16
Fills 14-16
Menu 13-22
Non-associative 13-19
Scale 13-24
Text 14-16
Tool 13-19
Window 13-22

Detail view camera 14-15, 14-37
Detail view operation

Copy 13-23
Cut 13-22
Pan 13-23
Rotating area 13-20
Zoom 13-24

Diagrams A-3
Dialog boxes, using 3-14
Diameter, GD&T 20-8
Diametral Arrow Dimension tool

In 12-26
Out 12-25

Dimension 15-27
Arrowhead 12-41
Associative 12-2
Circle center line 7-20
Detail view 14-16
Dual 12-33
GD&T 20-4
Layer 12-8, 12-40
Menu 3-12
Move 12-7
Objects 12-6
Parametrics 12-47, 16-4
Tools 12-3
Work plane 12-5

Dimension appearance 12-31
Color 12-38
Font 12-37
Fractions 12-34
Pen style 5-2, 5-18
Size 12-37



Index
Style 12-38
Text 12-36
Weight 12-39
Witness lines 12-43

Dimension setting
Angular 12-34
Angular tolerance 12-35
Limits 12-8
Linear 12-32
Linear tolerance 12-34
Standards 12-44
Tolerance 12-8, 12-33

Dimension tools
Angular 12-27
Arc Length 12-29
Automatic Dimensioning 12-9
Balloon 12-30
Circle Center Line 12-29
Diametral Arrow In 12-26
Diametral Arrow Out 12-25
Horizontal 12-10
Oblique 12-17
Perpendicular 12-20
Radial Arrow In 12-25
Radial Arrow Out 12-24
Vertical 12-13

DIN crosshatching 11-13, 11-17
Divide command 10-37
Division A-1
Document

New 15-2
Organizing 15-1
Windows 13-26

Drafting
Drafting Assistant 2-5, 4-1
Full scale 5-25
Parametrics 16-9
Process 5-26
Wireframe 2-1
With format 5-28
Without format 5-27

Drafting Assistant 2-5, 4-1

% Point 4-8
Alignment 2-5
Alignment angles 4-7
Construction angles 4-10
Construction lines 2-5, 4-9
Creation angles 4-8
DAssistant command 4-6
Snap command 4-8
Snap point 2-5, 4-2, 4-5
Z direction 8-9

Drafting Assistant notation
Center 4-3
Endpoint 4-3
Intersect 4-3
Midpoint 4-3
Perpendicular 4-4
Quadrant 4-3
Tangent 4-4
Vertex 4-3

Drag, using mouse 7-3
Draw View Boundaries command 13-
26
Drawing

Formats 2-7
Print 15-41
Techniques 7-3
Tools 7-1

Drawing area
Graphite 3-4, 3-10
Scroll bars 3-11

Drawing at full scale 2-6
Drawing size command

Page bounds 15-33
Preview layout 15-34
Printing 15-33
Scale 3-16
Tiled printing 15-34
Using 15-29

Drawing tools
3D 8-1
Arc 7-17
Circle 7-20
I-5
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I-6
Ellipse 7-23
Line 7-10
Polygon 7-27
Spline 7-30

Dual dimensions 12-33
Duplicate commands

Linear 10-12
Polar 10-16

DWG
Import 15-11, 15-17

DXF
Configuration files 15-23
Export effects 15-19
Import 15-11, 15-13, 15-16
Import effects 15-14

Dynamic construction lines
Constructing geometry 4-9
Existing geometry 4-10

E
Edit

Attributes 19-11
Bill of Materials 19-21
BOM layout 19-18
Color 5-6
Crosshatching 11-17
Item numbers 19-14
Macros 6-6
Menu 3-12
Objects 10-1, 10-35
Pattern 5-16
Pen style 5-20
Symbol 17-5
Text 11-3
View 14-25

Editing commands
Copy 10-33
Cut 10-32
Delete 10-34
Paste 10-33
Redo 10-34
Undo 10-34

Editing tools
Chamfer 10-2
Fillet 10-2
Transformation 10-2, 10-8
Trim 10-2

Ellipse tools 7-23
2-Point Center 7-24
3-Corner 7-27
3D 8-3
3-Point Center 7-26
Opposite-Corner 7-25

Endpoint 4-3
Environment settings

Advanced 6-1
Basic 5-1

EPS 15-21
Export 15-17
Export effects 15-20
Import 15-11

Equals A-2
Erasing geometry 10-34
Exit command 15-6
Exponentiation A-1
Export

Bill of Materials 19-22
Command 15-16
Convert 15-16
Tips 15-23

Export type
Bitmap 15-17
EPS 15-17
IGES 15-17
MetaFiles 15-17
Pict 15-17
Text 15-17

Extrude
Command 8-4

Eye Dropper G-6
Eye Dropper Tool 9-8



Index
F
Feature control frame 20-5

Diameter 20-8
Feet A-3
File 15-10

Backup 15-5
Menu 3-12
Organization 15-7
Plotting to a file 15-43
Program files C-1
Program settings C-1
Recent file list 15-3

File command
Close 15-6
Exit 15-6
Export 15-9
Import 15-9
Open 15-2
Save 15-3

Filename 15-3
Fill

Command 11-19
Detail view 14-16
Solid 11-12, 11-18

Fillet
3D 8-4
Smart wall 7-15

Fillet tools 10-2
2-Entity 10-2
Fillet 10-3

Flatness, GD&T 20-6
Flatten view 2-7, 14-26
Font

ANSI 11-6
Dimension 12-37
Plotter 11-11, 15-43
Text 11-5
Text size 11-7

Format
Creating 15-38
Drafting with 5-28

Drafting without 5-27
Drawing 2-7, 15-35
Importing 15-36
Modifying 15-37
Placing 15-36
Sheet into view 14-18, 15-37
Views 14-28

Forms
Command 15-39
Creating 15-39

Fractions, dimensions 12-34
Front view 14-20
G
GD&T 20-1

ANSI 20-1, 20-13
Background 20-2
Command 20-13
Dimension 20-4
Geometric characteristic 20-5
Label 20-13
Material condition 20-8
Symbols 20-11

GD&T setting
Alignment 20-2
Bonus tolerance 20-3
Datum 20-10
Feature control frame 20-5
Tolerance 20-8, 20-12

Geometric characteristic
Angularity 20-6
Circular runout 20-8
Concentricity 20-7
Cylindricity 20-6
Flatness 20-6
Parallelism 20-7
Perpendicularity 20-7
Profile of Line 20-6
Roundness 20-6
I-7
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I-8
Straightness 20-5
Symmetry 20-7
Total runout 20-8
True position 20-7

Graphite
Constructing a model 2-6

graphite prefs 3-19
Graphite Window

Drawing area 3-4, 3-10
Menu Bar 3-3, 3-12
Message Line 3-4, 3-9
Pointer 3-3
Pointer Locator 3-4
Scroll Bars 3-4, 3-11
Status Line 3-4, 3-10
Title Bar 3-3, 3-4
Tool palette 3-3, 3-6
Work Layer Indicator 3-4, 3-11

graphite.ini 5-29
Grid 5-23

Command 5-23
Drawing area 3-11
Show 3-11, 5-23

Grid setting
Origin 5-23
Preferences 5-31
Spacing 5-24
Subdivision 5-24

Group
Command 9-2, 10-38
Parametrics 16-27

H
Hatch 11-17
Hidden pen style 5-2, 5-18
Hide

Attributes 19-7
BOM palette 19-8
Layer 13-11

Hide points 9-12
Hit radius 4-7
Horizontal Dimension tools

Base Line 12-11
Chain 12-11
Horizontal 12-10
Ordinate 12-12

Hot spot 3-8
HPGL 15-43
I
ifelse A-2
IGES 15-17

Export 15-17
Export effects 15-20
Import 15-11

Import
Command 15-10
Formats 15-36
Symbol 17-5
Text 11-2

Import type
ASCII 15-11, 15-13
Bitmap 15-12
BMI 15-11
DWG 15-11, 15-17
DXF 15-11, 15-13, 15-16
EPS 15-11
IGES 15-11
MetaFiles 15-11
Pict 15-12
Spline 15-11, 15-13
Text 15-11, 15-13

Inches 5-22, A-3
Indenting text 11-10
Inertia 18-4
Inscribed Polygon tool 7-28
Intersect, Drafting Assistant 4-3
Invert preference 5-31
ISO crosshatching 11-13, 11-16
Isometric view 14-20
Item number

Balloon 19-14
Text 19-14
Tool 19-13



Index
Item number operation
Assigning 19-13
Delete 19-15
Editing 19-14
Object copies 19-15
Renumber 19-15

K
Keyboard

Versus mouse 3-13
L
Layer 4-11, 13-7

Color 13-8
Command 13-9
Construction 4-11
Dimension 12-8, 12-40
Sheet/Models 13-16
Smart wall 13-13
Work 13-11

Layer groups
Command 13-14
Creating 13-15
Delete 13-16
Renaming 13-16

Layer operation
Counting objects 13-12
Creating 13-10
Delete 13-10
Displaying 13-11
Group 13-13
Hide 13-11
Move objects 10-26, 10-36
Renaming 13-10

Layout
Bill of Materials 19-16
BOM edit 19-18
BOM Layouts command 19-16
BOM options 19-18
Custom view 14-31
Defining BOM layout 19-17
Menu 3-12
Preview 15-34

See also Formats
Sheet into view 14-18
View 14-27

Leading 0s 5-22
Limits, dimension 12-8
Line creation

Click 7-4
Drag 7-5

Line tools 7-10
3D 8-3
Connected 7-12
Parallel 7-14
Single 7-10
Smart Wall 7-15

Linear dimension settings 12-32
Linear duplicate 10-12
Linear tolerance 12-34
Location Indicator 3-9
Lock

Command 10-39
Splines 7-34
Trackball 6-10

Lock Spline Control Point tool 7-34
Log (Base 10) A-1
M
Macintosh

Fonts 5-30
graphite prefs 3-19, 5-30
OS settings 5-30
Page setup 15-29
Recent file list 5-30

Macros 6-3
Command 6-3
Creating 6-5
Editing 6-6
Limitations 6-7
Removing 6-6
Running 6-7

Magnifying glass tool 13-3
I-9
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I-10
Margin notes
Referral 1-2
Tech note 1-2
Tip 1-2

Material condition, GD&T 20-8
Math operators A-1
Megahertz A-3
Menu

Arrange 3-12
Dimension 3-12
Edit 3-12
File 3-12
Layout 3-12
Modules 3-13
Pen 3-12
Submenus 3-14
Text 3-12, 11-5
Trackball view menu 6-10
Utilities 3-12
Views 3-12

Menu Bar 3-3
Menu, using

Choosing a command 1-1, 3-13
Displaying 3-13
Toggling commands 3-18

Message Line 3-4, 3-9, 7-9
MetaFiles

Export 15-17
Import 15-11

Meters 5-22, A-3
Midpoint, Drafting Assistant 4-3
Millimeters 5-22, A-3
Mirror tool 10-11
Model 14-5, 14-38

3D construction 2-6
Command 14-7
Model space 2-2, 14-38
Multiple 14-5
Sheets 14-7, 14-9
Sheets/Views 14-36

Model operation
Creating 14-7

Delete 14-8
Identifying 14-16
Make current 14-8
New 14-6
Renaming 14-8

Models 2-2
Modules menu 3-13
Moment of inertia 18-4
Mouse

Arrow pointer 3-2
Clicking 3-2, 7-3
Double-click 3-2
Dragging 3-2, 7-3
Pointer 3-2
Selection arrow 3-2
Smart pointer 3-8
Using 3-1
Versus keyboard 3-13

Move
Dimension 12-7
Objects 10-24
Objects to layer 10-26, 10-36
Text 11-4

Move tool 10-8
Multiplication A-1
N
Nanoseconds A-3
Natural log (Base e) A-1
Navigator Palette

View 13-27
Negative value A-1
Nudge Tool 10-9
NURBS 7-30
O
Objects

# on layer 13-12
Changing characteristics 10-35
Copy 10-27, 10-33
Cut 10-32
Deselecting 9-9
Dimension 12-6
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Edit 10-1, 10-35
Expand/Shrink 10-10
Group 10-38
Lock 10-39
Mirroring 10-11
Move 10-8, 10-24
Relimit 10-6
Rotating 10-9
Segment 10-7
Selecting 9-2, 9-4
Size 10-29
Trimming 10-6
Ungroup 10-38
Unlock 10-39

Oblique Dimension tools
Base Line 12-18
Chain 12-19
Oblique 12-17

Offset
Command 10-21
Construction lines 4-13
Creating point offset geometry 7-9
Distance 10-21

On-Line help (Windows) 1-5
Open command 15-2
Operators A-1

Absolute value A-1
Addition A-1
Arctangent A-1
Cosine of angle A-1
Division A-1
Equals A-2
Exponentiation A-1
ifelse A-2
Log (Base 10) A-1
Multiplication A-1
Natural log (Base e) A-1
Negative value A-1
Parenthetical A-1
Random A-1
RNG A-2
Round A-1

Scientific notation A-1
Sine of angle A-1
Square root A-1
Subtraction A-1

Opposite-Corner Ellipse tool 7-25
Ordinate dimension

Horizontal 12-12
Perpendicular 12-23
Vertical 12-16

Origin 8-7
Setting 8-12
Work plane 8-12

OS settings
Macintosh 5-30
Windows 5-29

Outline pen style 5-2, 5-18
P
Page setup 15-29
Palette

Bill of Materials 19-8
Color 5-7
Main palette 3-6
Save 5-32, 5-33

Pan, detail view 13-23
Parallel construction lines 4-13
Parallel Lines tool

Using 7-14
Parallelism, GD&T 20-7
Parametrics 16-1

3D 16-29
Anchoring geometry 16-8
Complex drafting 16-20
Dimension 12-47, 16-4
Drafting 16-9
Grouped objects 16-27
Insertion point of symbols 17-2
Problems 16-13
Resolve 16-6
Rules 16-3
I-11
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I-12
Symmetry 16-19
Text file 16-7
Wave forms A-4

Parenthetical A-1
Paste 10-33
Pattern

Crosshatch 11-12
Dash handle 5-15
Define pen 5-13
Edit pen command 5-16
Pen 5-11
Scale 15-26
Standard pen 5-11
Undoing pen edit 5-17
User-defined pen 5-12
Visible pen length 5-13

Pen
Arrowheads 11-19
Characteristics 5-3
Color 5-4
Menu 3-12
Pattern 5-11
Style 5-18, 5-19
Styles 5-1
Weight 5-8

Percentage point, DA 4-8
Perimeter 18-3, 19-7
Permanent construction lines 4-11
Perpendicular Dimension tools

Base Line 12-21
Chain 12-22
Ordinate 12-23
Perpendicular 12-20

Perpendicular lines 7-11
Perpendicular, Drafting Assistant 4-4
Perpendicularity, GD&T 20-7
Phantom pen style 5-2, 5-18
Pict

Export 15-17
Import 15-12

Plane
Define 8-9, 8-14

Delete 8-17
Redefine 8-17
Rename 8-16
Set to screen 8-18
Standard 8-9
Temp 8-9
View 14-25
Work 8-9

Plot
Drawing 15-33
Scale 15-30, 15-32

Plotter fonts 11-11, 15-43
Point

Control 7-33, 9-2
Creating 7-11
Hide 9-12
Selectable point command 9-13
Selecting 9-11, 9-12
Show 9-11

Pointer 3-2, 3-3
Locator 3-9
Smart 3-8, 7-3

Pointer Locator 3-4, 3-9
Polar duplicate 10-16
Polygon tools 7-27

Circumscribed 7-29
Inscribed 7-28
Rectangle 7-28

PostScript 15-43
Precision

Setting 3-10, 5-21
Status Line 7-6

pref.vlm 5-32
Preferences 3-19

AutoSave 5-31
Command 5-30
DAssistant 5-31
Default 5-33
Default setting 3-19
Grid 5-31
Invert 5-31
Save 5-32



Index
Saving 3-20, 5-30
Selection 5-31
Snap 5-31
Units 5-31
Visualization 5-32

prefs.vlm 3-19
Preview layout 15-34
Print 15-33

Command 15-42
Drawing 15-41
Tiled 15-34

Print scale 15-30, 15-32
Print setup 15-29
Printing 15-43
Profile of line, GD&T 20-6
Q
Quadrant, Drafting Assistant 4-3
R
Radial Arrow Dimension tool

In 12-25
Out 12-24

Random A-1
Recent file list 15-3

Macintosh 5-30
Windows 5-29

Rectangle tool 7-28
3D 8-3

Redo 10-34
Redraw screen 10-39
Referral 1-2
Relimit tool 10-6
Remove

Macros 6-6
Resolve

Command 16-6
Parametrics 16-6

Revolve
# of steps 8-7
Command 8-6
Origin 8-7
Sweep Angle 8-7

Right view 14-20
Right-hand rule 6-13
RNG A-2
Rotate

Active view 6-10
Sheet view 6-10
Text 11-6

Rotate tool 10-9
Rotate view

Geometry axis 6-11
Screen axis 6-12
X-axis 6-11
Y-axis 6-11
Z-axis 6-11

Round A-1
Roundness, GD&T 20-6
Rules

3D construction 8-3
Parametrics 16-3
Right-hand 6-13, 8-7

S
Save

Attributes 19-7
AutoSave 15-5
Color 5-7
Palette 5-32, 5-33
Preferences 3-20, 5-30, 5-32
Save As 15-4
Save command 15-4

Scale 3-16, 15-27
Detail view 13-24
Dimensions 15-27
Drawing at full scale 15-26
Full scale drawing 2-6, 5-25
Lines/crosshatches 15-26
Paper size 15-28
Patterns 15-26
Text 11-7, 15-27
Views 14-16

Scaling views 14-16
Scientific notation A-1
Screen display scale 14-16
I-13
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I-14
Scroll Bars 3-4
Segment tool 10-6
Selectable Points

Command 9-4
Selection 9-3

Arrow 3-2
Command 9-3
Deselecting 9-9
Indicating 9-3
Objects 9-2, 9-4
of points 9-12
Points 9-4, 9-11, 9-12
Select All 9-5, 9-9
Selectable points 9-13
Selecting a tool 3-7
Selection Mask 9-5, 9-9

Selection setting
Blinking 9-3
Preferences 5-31

Selection tools
Select by Line 9-5
Select by Polygon 9-7
Selection 9-4
Tracer 9-6

Send to Back command 13-26
Sheet 2-2, 6-8, 14-1, 14-37

Command 14-3
Creating 14-4
Delete 14-4
Making current 14-4
Models/Views 14-36
Renaming 14-4
Sheet into view 2-7
Using 14-2
View 13-17, 14-39

Sheet camera
Model 2-2, 14-5, 14-37

Sheet into view 2-7, 5-28, 14-17
Erroneous 14-19
Format 14-18, 15-37
Layouts 14-18
Visual scale 15-32

Sheet view
Command 13-17
Model 2-2, 14-5
Rotate 6-10

Show
Attributes 19-7, 19-11
BOM palette 19-8
Dimension palette 12-3
Grid 5-23
Points 9-11
Trackball 6-9, 8-2
TrackCube 6-9
Triad 6-12, 8-2

Simple Trim tool 10-5
Sine of angle A-1
Single Line tool 7-10

Perpendicular 7-11
Perpendicular lines 7-11
Point 7-11
Tangent 7-11

Size
Dimension 12-37
Objects 10-29

Slope, splines 7-35
Smart 17-6

Pointer 3-8, 7-3
Symbol 17-6
Wall 7-15

Smart wall
Layer 13-13

Smart Wall tool 7-15
Architecture 7-15
Chamfer 7-15
Fillet 7-15
Symbols 7-16

Snap command
% Point 4-8
Alignment Angles 4-7
Basic 4-6
Creation angles 4-8
Hit radius 4-7
Mode 4-8



Index
Snap point
Drafting Assistant 2-5, 4-2, 4-5
Preference 5-31

Solid fill 11-18, 11-19
Spacing, text 11-9
Special Characters B-1
Spell Check 11-4
Spline

Creating a text file 15-14
Import 15-11, 15-13

Spline tools 7-30
3D 8-3
Add Spline Control Point 7-33
Control point 7-33
Lock Spline Control Point 7-34
NURBS 7-30
Slope 7-35
Through-Points 7-31
Unlocking 7-34
Vector 7-32
Vertex 7-32

Square root A-1
Standard views 6-13
Status Line 3-4, 3-10, 7-6

Altering geometry 7-7
Creating additional geometry 7-8
Creating new geometry 7-8
Drawing tools 7-7
Fields 7-6
I-beam 7-6
Moving between fields 3-10
Precision 7-6
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	Using a Mouse
	Parts of the Graphite Window
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	1. Position the arrow pointer on the icon of the desired tool.
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	1. Position the arrow pointer on the tool.
	2. Press the mouse button.
	3. Drag the pointer to highlight the desired tool.
	4. Release the mouse button.
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	1. Point to the menu name.
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	3. Click on the command.
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	2. Click on a command with an (arrow) on the end.
	3. Click on the submenu.
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	1. Without pressing the mouse button, move the pointer over an existing point.
	2. Move the pointer horizontally or vertically.
	3. While the construction line is visible and the Drafting Assistant displays on, click the desired point in the construction.
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	Stroke Construction Lines
	1. Hold down the CTRL+SHIFT keys (Windows) or the z key (Macintosh). The pointer becomes the Stroke pointer (z).
	2. Move the pointer near the center of the circle.
	3. Drag the mouse vertically or horizontally away from the midpoint.

	The Construction Command
	1. Click the Angle data field.
	2. Drag a vector in the drawing area.
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	2. Drag the offset distance in the drawing area.
	1. Click the X data field.
	2. Enter new coordinates, or

	Creating Construction Geometry
	1. Choose Layout>Layers.
	2. Click Construction in the list box.
	3. Click Set Layer.
	4. Create the geometry for construction. Use the Construction pen style if desired.
	5. When the construction geometry is complete, make another layer the work layer.
	6. Close the dialog box.
	7. Continue to work.

	Removing Construction Lines
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	1. Select the object.
	2. Choose Pen>Style and select the pen style to change the characteristics of the selected object. To change one characteristic rather than the entire pen style, choose the characteristic from the pen characteristics listed in the Pen menu.
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	Color
	1. Choose Pen>Color. The submenu appears.
	2. Choose the color.
	3. Deselect any geometry to see the chosen color.
	1. To define a new color, choose Pen>Color>Define.
	2. The Edit Colors dialog box appears.
	3. In the dialog box window, scroll down and select one of the undefined color numbers, like <User65> (the first definable color available).
	4. Enter the color name in the Color Name data field and click Rename. The name entered replaces User <65> in the colors list, as displayed here.
	5. Click Define. The color display appears on the screen.
	6. When you have finished creating any custom colors, save these colors as default color settings for all new files by choosing Layout>Preferences>Save Preferences.

	Editing User-defined Colors
	1. Choose Pen>Color>Define.
	2. The Define Colors dialog box appears.
	3. In the dialog box window, scroll down and select one of the defined colors.
	4. Click Define. The color display appears.
	5. Click OK to save the changes.

	Saving Colors
	Customizing the Color Palette
	1. Choose Pen>Color>Define.
	2. Select the color to display.
	3. Click Use. An eye icon appears next to the color name.
	1. Choose Pen>Color>Define.
	2. Select the color to remove.
	3. Click No Use. The eye icon next to the color name is removed.

	Weight
	1. Choose Pen>Weight. The submenu appears.
	2. Drag to the desired weight.
	1. Choose Pen>Weight>Edit Weight. The Edit Pen Weight dialog box appears.
	2. Select the pen weight to change by clicking on the pen number. That pen’s data field is selected.
	3. Change the pen weight by typing a new value into the data field. If no units are given with the entry, Graphite applies the unit specified in the Units dialog box from Preferences.
	4. Click OK in the Edit Pen Weights dialog box. All existing lines drawn in the pen weight that was edited change to reflect the new weight, as will all future lines drawn in that pen weight.

	Pattern
	1. Choose Pen>Pattern. The submenu appears.
	2. Select a pattern.
	1. Choose Pen>Pattern>More. The Line fonts dialog box appears.
	2. Scroll down to the desired pattern and select it.
	3. Click Current.
	1. Choose Pen>Pattern>Define Pattern. The Define patterns dialog box appears.
	2. Click New.
	3. Click Edit. The Edit Pattern dialog box appears with the default name User1 in the Edit Pattern field.
	4. Create the pattern by modifying the length of these segments and/or adding dashes.
	5. When the pattern element is properly defined, click OK. The new pattern is created and the program returns to the Define patterns dialog box.
	6. Select the Pattern Name field and enter a new name for the pattern.
	7. Click Rename.
	8. Click Current to set the pen to the new pattern.
	9. Click the Close button in the title bar to close the dialog box.
	1. Choose Pen>Pattern>Edit Pattern.
	2. Select the line pattern to change from the Edit Pattern list.
	3. Modify the line pattern by changing the lengths of existing dashes or by adding or removing dashes to or from the element.
	4. When the pattern element is properly defined, click OK and the dialog box closes. All existing lines drawn in the edited line pattern change to reflect the new pattern element, as will all future lines drawn in the line pattern.

	Pen Styles
	1. Choose the pen to modify.
	2. In the Pen menu, choose a characteristic: Color, Weight, or Pattern.
	1. Choose Pen>Style>Edit Style.
	2. Select the pen style to change by pressing the Style data field.
	3. Specify the characteristics (Color, Weight, and Pattern) for that style.
	4. Click OK to set the specifications and close the dialog box, or click Apply to put the specifications into effect for a single pen style and leave the dialog box open to make changes to another pen style.


	Setting Units
	Units Command

	The Grid
	Grid Command
	1. Choose Layout>Preferences>Grid.
	2. Enter the desired values for Grid Spacing and/or # of subdivisions.
	3. Select the grid color from the drop down menu.
	4. Click OK and the changes are saved.


	Drawing at Full Scale
	1. Draw a line, specifying 83' for the length.
	2. Choose Arrange>Zoom All.

	The Drafting Process
	1. Start Graphite and display an Untitled document.
	2. If necessary, set the Units of measure to use by choosing Layout>Preferences>Units.
	3. Construct the geometry at full size, saving the construction while working. Use the Zoom commands and tools to display the part at an appropriate magnification in order to see what is done.
	4. Choose File>Print Setup (Windows) or Page Setup (Macintosh) command to set the paper size for plotting or printing.
	5. Choose Layout>Drawing Size to set the drafting scale for plotting or printing.
	6. Dimension the part and add text.
	7. Make final adjustments.
	8. Choose File>Print.
	1. Start Graphite and display an Untitled document.
	2. If necessary, set the Units of measure by choosing Layout>Preferences>Units.
	3. Construct the geometry at full size, saving the construction in the process. Use the Zoom commands and tools to display the part at an appropriate magnification in order to see what is done.
	4. Use the Sheet Into View command from the Views menu to set the visual scale so that the part fits into the size of the drawing format selected in the pop-up menu in the Sheet Into View dialog box.
	5. Dimension the part and add text.
	6. Make any final adjustments.
	7. Choose File>Print to print or plot the drawing.

	OS Settings
	Windows Settings
	Macintosh Settings

	Saving Preferences
	Preferences Command
	1. Create a file which has the desired preferences.
	2. Choose Layout>Preferences>Save Preferences.


	Save Palettes

	Advanced Environment Settings
	Add Command
	Macros
	Macro Command
	1. Choose Utilities>Macro. The Macro dialog box displays.
	2. Click New.
	3. Overwrite the name if desired. (Use alpha-numeric characters with no spaces.)
	4. Select menu commands in the order the new macros will execute.
	5. Define a Stroke command on the drawing area.
	6. Check the In Utilities Menu option to include the new macro in the Utilities menu.
	7. Enter a Key short cut in the Key entry field.
	8. Close the Macro dialog box by double-clicking the Control menu (Windows) or the Close button (Macintosh) in the upper left corner of the dialog box.
	1. Display the Macro dialog box.
	2. Select a macro in the Names list box.
	3. Rename the macro in the Rename data field and click the Rename button.
	4. Redefine the macro by executing menu items and assigning a new stroke equivalent to the macro.
	5. Alter the Macro key combination in the Key data field.
	6. Close the Macro dialog box by double-clicking the Control menu (Windows) or the Close box (Macintosh) in the upper left corner of the dialog box.
	1. Display the Macro dialog box.
	2. Select a macro in the Names list box.
	3. Click Remove.


	File Organization
	3D Viewing
	Show/Hide Trackball/Trackcube
	1. Choose Views>Show Trackball.
	2. Drag the pointer on the Trackball to rotate the view.
	1. Move the pointer to the current view name displayed at the bottom of the Trackball/Trackcube window.
	2. Press the mouse button. The Views menu displays.
	3. Choose the view orientation to display in the current window.

	Trackball Locking
	Show/Hide Triad
	Views Command


	Drawing Tools
	Drawing Techniques
	Creating a Line by Clicking
	1. Select the Single Line tool from the tool palette.
	2. Move the pointer to the drawing area and click to set the starting point of the line.
	3. Move the pointer to the desired location for the endpoint of the line and click.

	Creating a Line by Dragging
	1. Click the Single Line tool in the tool palette.
	2. Move the pointer into the drawing area.
	3. Press and hold the mouse at the desired location for the starting point of the line.
	4. With the mouse button still held, move the mouse to the desired location for the endpoint of the line.
	5. Release the mouse button to set the endpoint.


	The Status Line
	Using the Status Line Fields
	Using the Status Line with Drawing Tools
	1. Select the Single Line tool.
	2. Click two locations in the drawing area. The length (L) field automatically highlights in the Status Line.
	3. Type 3. The 3 is entered directly in the L field.
	4. Press the Tab key to select the next status field. The angle (A) field now highlights.
	5. Enter 15.
	6. Press ENTER (Windows) or RETURN (Macintosh).
	1. With the Single Line tool still selected from the previous example, click two more points.
	2. Type 4.
	3. Press the Tab key and type 25.
	4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.
	1. Choose the Selection tool so the Single Line status field clears.
	2. Click the Single Line tool again.
	3. Type 0.
	4. Press the Tab key. The Y field highlights.
	5. Type 0.
	6. Press the Tab key again.
	7. Type 2.
	8. Press the Tab key. The dY field highlights.
	9. Type 2.
	10. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.
	1. Select the tool.
	2. Move the pointer over the control point from which you want the offset.
	3. Click once to lock onto that point.
	4. Click in the appropriate X or Y field in the Status Line, placing the text cursor at the end of the entry.
	5. Type the offset (such as + 3") and press ENTER (Windows) or RETURN (Macintosh).
	6. Continue the construction.


	The Message Line
	Drawing Tools - Description and Use
	Line Tools
	1. Select the tool. The Message Line reads, Single Line: Pick the beginning point. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Click two endpoints of the line,
	1. Construct the object.
	2. Move the pointer to the object until a Drafting Assistant on notation appears. The Drafting Assistant notation must be on rather than endpoint, quadrant, or midpoint.
	3. Drag straight away from the object in a perpendicular direction. A perpendicular line appears attached to the object. Keep holding the mouse down and move the cursor. Notice that the line stays perpendicular but slides along the object.
	4. Drag to the desired length for the perpendicular line.
	1. Construct an arc, circle, or ellipse.
	2. Choose the Single Line tool.
	3. Move the pointer to the arc until a Drafting Assistant on notation appears. The Drafting Assistant notation must be on rather than endpoint, quadrant, or midpoint.
	4. Drag in the appropriate direction (straight for perpendicular or at an angle for tangent) until the Drafting Assistant perpendicular or tangent notation appears.
	5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line around the arc to the desired location and extend the line to the necessary length.
	1. Select the tool. The Message Line reads, Mid-Point Line: Pick center point. The message guides each successive step.
	2. Click to indicate where the mid-point of the line will be.
	3. Indicate one end point and the line grows symmetrically in the opposite direction.
	1. Select the tool. The Message Line reads, Connected Lines: Pick the beginning point. The Message Line guides each successive step.
	2. Indicate the endpoints of the line segments.
	3. Indicate the last point by double-clicking or by choosing another tool.
	1. Select the tool. The Message Line reads, Construction Line: Pick beginning point. The Message Line guides each successive step.
	2. Click in the drawing area to specify the point through which the construction line should go.
	3. Click once again with the mouse button indication the another point through which the construction line must go.
	1. Select the tool. The Message Line reads, Parallel Lines: Drag new line off existing line. The Message Line guides each successive step.
	2. Indicate the line to duplicate then drag to the new position. Enter the delta distance in the Status Line and press ENTER (Windows) or RETURN (Macintosh).
	1. Select the tool. The Message Line reads, Double Line: Pick start point. [Shift = Flip]. The Message Line guides each successive step.
	2. In the Status Line, specify the thickness (T) of the wall.
	3. Indicate the ends of the wall segment.
	4. Continue specifying both endpoints for wall segments, as needed.
	1. The symbol must contain a Smart Wall piece that is thicker than the wall segment on which it will be placed.
	2. Set the pen pattern of the smart wall piece to dotted. (Any geometry in a symbol that is of the dotted pen pattern is placed on the drawing, but it is invisible.) This results in an invisible Smart Wall piece that cuts the Smart Walls on the drawing.

	Arc Tools
	1. Select the tool. The Message Line reads, Center-Point Arc: Pick center. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Indicate the center point of the arc.
	3. Indicate the radius and beginning of the arc.
	1. Select the tool. The Message Line reads, 3-Point Arc: Pick first point. [Ctrl = Tangent to object (Windows) or Option = Tangent to object (Macintosh)].
	2. Indicate the first endpoint of the arc.
	3. Indicate the second and third positions.
	1. Select the tool. The Message Line reads, Tangent-Point Arc: Pick beginning point of arc (tangent line). The Message Line guides each successive step.
	2. Indicate the starting point. This is both the starting point of the arc and the starting point of the temporary tangent line.
	3. Indicate the endpoint of the tangent line.
	4. Indicate the endpoint of the arc. The arc is drawn between the first and last point clicked and tangent to the line between the first and second points.

	Circle Tools
	1. Select the tool. The Message Line reads, Center-Point Circle: Pick center. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Indicate two locations; the first click places the center and the second determines the radius.
	3. To create a copy of the last circle, hold down the CTRL (Windows) or OPTION (Macintosh) key and click once in the center for the new circle.
	1. Select the tool. The Message Line reads, Opposite-Point Circle: Pick first point on circle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides each successive step.
	2. Indicate two locations for the diameter,
	1. Select the tool. The Message Line reads, 3-Point Circle: Pick first point. [Ctrl = Tangent to object (Windows) or Option = Tangent to object (Macintosh)]. The Message Line guides each successive step.
	2. Indicate the first point on the circle.
	3. Indicate the second and third points.
	1. Select the tool. The Message Line reads, Tangent Circle: Enter diameter then pick first tangent object. The Message Line guides each successive step.
	2. Enter a diameter for the circle in the status field.
	3. Click the objects to which the circle is to be tangent.

	Ellipse Tools
	1. Select the tool. The Message Line reads, 2-Point Center Ellipse: Pick center of ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides successive steps.
	2. Indicate the center of the ellipse.
	3. Indicate the corner of the rectangle defining the ellipse.
	1. Select the tool. The Message Line reads, Opposite-Corner Ellipse: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides successive steps.
	2. Indicate one corner of the rectangle defining the ellipse.
	3. Indicate the opposite corner of the defining rectangle.
	1. Select the tool. The Message Line reads, 3-Point Center Ellipse: Pick center of the ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides successive steps.
	2. Indicate the center of the ellipse.
	3. Indicate the midpoint of the side of the rectangle defining the ellipse.
	4. Indicate the corner of the rectangle defining the ellipse.
	1. Select the tool. The Message Line reads, 3-Corner Ellipse: Pick first corner of control parallelogram. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides through each successive step.
	2. Indicate one corner of the parallelogram defining the ellipse.
	3. Indicate another corner of the defining parallelogram.
	4. Indicate the final corner of the defining parallelogram.

	Polygon Tools
	1. Select the tool. The Message Line reads, Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)].
	2. Indicate the opposite corners of the rectangle,
	1. Select the tool. The Message Line reads, Inscribed Polygon: Pick center of polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides successive steps.
	2. Indicate the center of the polygon.
	3. Indicate a point on the circumference of the circumscribing circle.
	1. Select the tool. The Message Line reads, Circumscribed Polygon: Pick center of polygon. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message Line guides successive steps.
	2. Indicate the center of the polygon and the midpoint of one of the sides

	Spline Tools
	1. Select the tool. The Message Line reads, Through-Points Spline: Pick control point (Double-click last point).
	2. Indicate the points for the vectors of the spline.
	3. Double-click the last point.
	1. Select the tool. The Message Line reads, Vector Spline: Pick control point (Double-click last point).
	2. Click the points for the vectors of the spline.
	3. Double-click the last point.
	1. Select the tool. The Message Line reads, Add Spline Control Point: Pick location on spline.
	2. Click on the spline at the desired location(s) for the new control point(s).
	1. Select the spline.
	2. Choose Layout>Show Points.
	3. Select the tool. The Message Line reads, Lock Spline Control Point: Pick control point.
	4. Click the vertices to lock.The Lock Spline Control Point tool is used to lock or immobilize selected control points on an existing spline. Then adjust the curvature of the spline between the locked points without disturbing other areas of the spline.
	1. Select the tool and click on the point to unlock it.
	1. Lock more than one point by simply clicking each point.
	1. Select the spline with the Selection tool.
	2. Choose Layout>Show Points. (If the menu says Hide Points, no need to choose it.)
	3. Click on the drawing area to deselect the spline.
	4. If necessary, select the Lock Spline Control Points tool from the Spline tool subpalette.
	5. If necessary, click the points to lock (the points on either side of the point to be changed).
	6. Use the Selection tool to select the point to change.
	7. Drag the point to the new location.
	1. Select the spline with the Selection tool.
	2. Choose Layout>Show Points. (If the menu says Hide Points, no need to choose it.)
	3. Click in the drawing area to deselect the spline.
	4. If necessary, select the Lock Spline Control Points tool from the Spline tool subpalette.
	5. If necessary, select the point to lock but not the endpoint.
	6. Use the Selection tool to select the point at the end of the tangent control arm that needs to be moved.
	7. Drag the point to a new location.



	3D Drawing Tools
	Geometry in 3D
	Construction Rules for Tools Used in 3D

	3D Features and Tools
	Extrude Command
	1. Draw the geometry to be extruded.
	2. Select the geometry if it is not already selected.
	3. Choose 3D>Extrude.
	4. Enter the distance and direction or drag to specify the extrusion. Positive or negative values indicate the direction.
	5. Click OK and the geometry is extruded.

	Revolve Command
	1. Draw the geometry to be rotated.
	2. Select the geometry if it is not already selected.
	3. Choose 3D>Revolve. The Revolve dialog box displays.
	4. Specify the number of degrees in the Sweep Angle for the revolution.
	5. Specify the number of Steps (copies or divisions).
	6. Tab to the Origin data field in the dialog box.
	7. Place the target cursor at the startpoint of the axis of revolution.
	8. Drag along the axis from the startpoint to the endpoint. The six data fields are automatically filled in.
	9. Click OK and the selected geometry is now revolved around the axis as specified, according to the right hand rule of revolution.

	Object Rotation Command
	1. Select the geometry to rotate.
	2. Choose 3D>Object Rotation.
	3. In the Rotate Angle field, enter the angle to rotate the geometry.
	4. Tab to the Origin Data field. The cursor becomes a crosshair.
	5. Click a point on the geometry to specify the Axis of Rotation around which to rotate the geometry.
	6. Place the target cursor along the desired axis. Think of it as pointing to the top of a hinge.
	7. Drag along the desired axis, as if dragging along the length of the hinge. Don’t worry about whether the z-axis is pointed in the right direction. The six data fields are automatically completed.
	8. Click OK. The object rotates. Change the view as necessary to observe the change in rotation.


	Work Plane
	Planes
	1. Choose 3D>Planes.
	2. Drag down the submenu until the plane highlights.
	3. Release the mouse button.

	Set Origin Command
	1. Choose 3D>Set Origin.
	2. Click in the drawing area to indicate the location for the new origin.

	Setting a New Work Plane
	1. Choose 3D>3-Point Plane.
	2. Click in the drawing area to indicate the point for the origin of the new work plane.
	3. Click a point to define the positive x-axis.
	4. Click a point to define the positive y-axis.
	1. Choose 3D>Define Plane.
	2. Click New.
	3. On the drawing area, click the location for the new origin.
	4. Click a location on the positive x-axis.
	5. Click a location on the positive y-axis.
	6. Click OK.
	7. Select Plane 1, the new plane just created.
	8. Click Set Work.
	9. Rename this work plane if desire.
	10. Dismiss the dialog box if it is no longer needed to define other work planes.

	Renaming a Plane
	1. Choose 3D>Define Plane.
	2. If necessary, click the lock icon to unlock the plane, then click the plane to be renamed in the list box.
	3. Type a new name.
	4. Click Rename.

	Deleting a Plane
	1. Choose 3D>Define Plane.
	2. If necessary, click the lock icon to unlock the plane and then click the plane to be deleted from the plane list.
	3. Click Delete.

	Redefining a Plane
	1. Choose 3D>Define Plane.
	2. Click the lock icon on the plane to be changed.
	3. Click the name of the plane to change it.
	4. Click Redefine.
	5. On the drawing area, click the location for the new origin.
	6. Click a location on the positive x-axis.
	7. Click a location for the positive y-axis.
	8. Click OK.

	Set Plane to Screen


	Selecting Objects
	1. Select the object.
	2. Specify the action for the selected object.
	Objects
	Indicating Selection
	Selection Command

	Selection Process
	Selecting Tools
	1. Click the Selection tool in the tool palette. The Message Line reads, Select: Select [Shift = Extend, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].
	2. Move the pointer to an object and click. The object is selected, and any previously selected objects are deselected.
	1. Click the Selection tool in the tool palette.
	2. Move the pointer to an object and click.
	3. Press down the SHIFT key.
	4. While holding down the SHIFT key, click other objects to be selected.
	5. Release the SHIFT key.
	1. Click the Selection tool in the tool palette.
	2. Drag a selection fence around the objects to select it.
	1. Choose the Select by Line tool in the Selection tool palette. The Message Line reads, Select By Line: Draw line [Shift = Extend, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].
	2. In the drawing area, drag across the objects you want to select, as shown in the graphic below.
	1. In the Selection tool subpalette, select the Tracer tool. The Message Line reads, Tracer: Pick curve to start trace. [Shift = Extend].
	2. Click on a boundary line.
	1. Choose the Select by Polygon tool in the Selection tool palette. The Message Line reads, Select By Polygon: draw polyline [Shift = Extend].
	2. Click or drag to indicate the endpoints of the line segments that will make up this selection polygon. The selection polygon appears as line segments in the designated selection color.
	3. Indicate the last point by double-clicking or choosing another tool.
	1. Select the Eye Dropper tool from the Selection tools palette. The Message Line reads, Eye Dropper: Select objects to copy from [Shift=Extend].
	2. Select or deselect multiple characteristics to be extracted for the Eye Dropper dialog box that automatically appears.
	3. Select the object with the characteristics to be copied.
	4. Select the objects to receive characteristics. Apply the properties to multiple objects before clicking anywhere in open space to deactivate the tool.

	Deselecting
	Selection Commands
	1. Choose Edit>Selection Mask.
	2. Designate the items allowed to be selected so they are highlighted.

	Selecting Points
	1. Select the geometry.
	2. Choose Layout>Show/Hide Points to toggle the display of points on and off.
	1. Click the Selection tool.
	2. Drag a selection fence around the location of the point.
	1. Click the Selection tool.
	2. Click the point.



	Editing Objects
	Editing Tools
	Fillet and Chamfer Tools
	1. Click the 2-Entity Fillet tool. The Message Line reads, 2-Entity Fillet: Pick first entity [Shift = Corner, Ctrl = No trim (Windows) or Option = No trim (Macintosh)]. The Message Line guides each successive step.
	2. Enter the arc radius in the Status Line. The default radius is .25 inch.
	3. Select the first entity.
	4. Select the second entity. The fillet is created.
	1. Click the 3-Entity Fillet tool. The Message Line reads, 3-Entity Fillet: Pick first entity [Ctrl = No trim (Windows) or Option = No trim (Macintosh)]. The Message Line guides each successive step.
	2. Click the three objects to fillet.
	1. Click the 2-Entity Chamfer tool. The Message Line reads, 2-Entity Chamfer: Pick first entity chamfer [Shift = Corner, Ctrl = No trim (Windows) or Option = No trim (Macintosh)]. The Message Line guides each successive step.
	2. In the Status Line, enter the distance of the chamfer from the corner. (The default distance is .25 inch.)
	3. Click each line making up the corner to be chamfered. Another way is to hold down the SHIFT key and click once inside the corner to chamfer.
	1. Click the Angular Chamfer tool. The Message Line reads, Angular Chamfer: Pick first entity to chamfer [Ctrl = No trim (Windows) or Option = No trim (Macintosh)]. The Message Line guides each successive step.
	2. In the Status Line, enter the length of the intersection of the chamfer and the second line of the corner from the corner. The default length is .25 inch.
	3. Enter the angle between the chamfer and the second side. The default is 45°.
	4. Click each line making up the corner to be chamfered.

	Trim Tools
	1. Select the object that limits the trim.
	2. Select the Trim tool. The Message Line reads, Simple Trim: Pick section to trim [Shift = Select boundary, Ctrl = Relimit (Windows) or Option = Relimit (Macintosh)].
	3. Click the section of the object to be discarded.
	1. Select the object that limits the change.
	2. Select the Relimit tool. The Message Line reads, Relimit: Pick section to retain [Shift = Select boundary, Ctrl = Trim (Windows) or Option = Trim (Macintosh)].
	3. Click the section of the object to remain.
	1. Select the objects that limit the segmentation.
	2. Select the Segment tool. The Message Line reads, Segment: Pick entity [Shift = Select boundary, Ctrl = Current pen (Windows) or Option = Current pen (Macintosh)].
	3. Click the object to be segmented.
	1. Click the Corner Trim tool. The Message Line reads, Corner Trim: Pick first entity to trim [Shift = Corner, Ctrl = No Trim (Windows) or Option = No Trim (Macintosh)]. The Message Line guides each successive step.
	2. Click each object.

	Transformation Tools
	1. Select the object(s) to be moved.
	2. Select the Move tool. The Message Line reads, Move: Pick beginning reference point [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].
	3. Drag the selected object to a new location, clicking to set a reference point, and releasing to indicate the new location.
	1. Select the object(s) to be rotated.
	2. Select the Rotate tool. The Message Line reads, Rotate: Pick center of rotation [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].
	3. Select the center of rotation.
	4. Drag the objects or enter an Angle in the Status Line to specify the rotation.
	1. Select the object(s) to be expanded or shrunk.
	2. Select the Expand/Shrink tool. The Message Line reads, Expand/Shrink: Pick anchor point [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)]. The message Line guides each successive step.
	3. Click a point on the object to remain stationary.
	4. Click the beginning reference point.
	5. Click the ending reference point.
	1. Select the object(s) to be stretched.
	2. Select the Stretch tool. The Message Line reads, Click point to remain fixed.
	3. Click the point to remain fixed.
	4. Click the beginning reference point to define the angle.
	5. Click the ending reference point to define the scale.
	1. Select the object(s) to be mirrored.
	2. Select the Mirror tool. The Message Line reads, Mirror: Pick beginning of reference line [Shift = Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].
	3. Specify the reference line by clicking two locations or by dragging. The reference line needs not be parallel to the object.

	Duplication Tools
	1. Select the object to be duplicated.
	2. Choose Edit>Linear Duplicate or choose the tool from the Transform and Duplicate palette.
	3. Enter the Number of objects Per Row.
	4. Specify Total or Step Lengths by clicking a button.
	5. Click the X Length* data field.
	6. Move the pointer to the drawing area and drag to indicate the length of the row of copies.
	7. If more than one row is desired, enter the Number of Rows, and click a button to specify the type of offset.
	8. Enter the offset, if any. A negative number can be used.
	9. Click OK.
	1. Create and select the geometry to duplicate.
	2. Choose Edit>Linear Duplicate or choose the tool from the Transform and Duplicate palette.
	3. Enter 6 in the Number Per Row data field.
	4. Click the Step Length option.
	5. Click in the X Length data field.
	6. Move the pointer into the drawing area and drag across the widest point of the step.
	7. Click at the end of the entry in the X Length data field.
	8. Type *2 to multiply the width of the geometry by two.
	9. Click OK.
	1. Select the object to be duplicated.
	2. Choose Edit>Polar Duplicate or choose the tool from the Transformation palette
	3. Enter the Number of objects in the circular array.
	4. Click the Center X* data field.
	5. Move the pointer to the drawing area and click to indicate the center for the array of copies.
	6. Specify Upright or Rotated objects by clicking a button. See the next section for the definition of these terms.
	7. If Upright is specified, click a location for the reference point in the drawing area.
	8. If the copies do not need to be in a complete circle, click the Total or Step Angle option.
	9. Enter a value for the specified angle type.
	10. Click OK.

	Copy by Path Tool
	1. Choose the tool from Transformation palette.
	2. Select the object to be duplicated.
	3. Pick the anchor point.
	4. Select the path (line, spline, circle...). Use SHIFT to choose several objects (rectangle, several splines...)
	5. A dialog box appears.
	6. Enter the Number of objects in the array.
	7. Enter the Step.
	8. Pick on the path to set start point.
	9. Click the Complete set to continue working with this tool and start new array.

	Offset Tool
	1. Select the object to offset.
	2. Choose Edit>Offset or choose the tool from the Transform and Duplicate tool palette.
	3. Click into the Offset Distance* field.
	4. Input an offset distance by dragging between any two points on the drawing area.
	5. Click in one of the Ref* entry fields.
	6. Enter an offset direction by dragging between any two points on the drawing area.
	7. Click the Options button.


	Moving Objects
	Using the Drafting Assistant for Moving
	Selected Move versus Move Tool
	1. Go to Layout>Preferences>Nudge or Right Mouse Click and choose Nudge.
	1. Select an item or items to move or Nudge.
	2. Use the arrow keys to move the selected items in the desired direction. By holding down the CONTROL key the nudge distance is doubled.
	1. Select the square to be moved.
	2. Select the Move tool.
	3. Click one corner of the square when the endpoint notation displays.
	4. Enter 2 in the X data field on the Status Line and -1 in the Y data field.
	5. Press the ENTER (Windows) or RETURN (Macintosh) key.

	Moving Objects to Another Layer
	1. Select the object(s) to move to another layer.
	2. Choose Edit>Edit Objects.
	3. In the Layer field of the Edit Objects dialog box select to the desired layer.
	4. Click OK. The object is now located on the new layer.


	Copying Objects
	Copying with the Selection Tool
	1. Click the Selection tool.
	2. Select the object(s) to copy.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Drag a copy of the selection to a new location.
	5. Release the CTRL (Windows) or OPTION (Macintosh) key.

	Copying with the Geometry Tools
	1. Construct the geometry to copy.
	2. With the drawing tool still activated, hold down the CTRL (Windows) or OPTION (Macintosh) key.
	3. Click a new location. The click determines the location of the first point original geometry construction (the center of a center-point circle, for example).
	4. Release the CTRL (Windows) or OPTION (Macintosh) key.

	Copying with the Transformation Tools
	1. Select the object to copy and transform.
	2. Select one of the four Transformation tools.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Perform the transformation according to the directions in the Message Line.
	5. Release the CTRL (Windows) or OPTION (Macintosh) key.

	Copy Command versus CTRL (Windows) or OPTION (Macintosh)

	Sizing Objects with Tools
	Sizing an Object with the Selection Tool
	1. In the Edit menu, be certain that Selectable Points is checked.
	2. Click the Selection tool.
	3. Drag a selection fence around the control points that represent the area to stretch.
	4. Drag the points to a new location.

	Sizing an Object with the Move Tool
	1. In the Edit menu, be certain that Selectable Points is checked.
	2. Click the Selection tool.
	3. Drag a selection fence around the lower right corner of the rectangle, selecting only the point.
	4. Click the Move tool.
	5. Enter +1 in the X data field and -1 in the Y data field in the Status Line.
	6. Press ENTER (Windows) or RETURN (Macintosh).

	Selected Sizing Versus Expand/Shrink Tool

	Editing Commands
	Cut
	1. Select the object to be cut.
	2. Choose Edit>Cut.
	1. Select the objects to move.
	2. Choose Edit>Cut.
	3. Display the location for the selection to appear in the drawing area, scrolling if necessary.
	4. Choose Edit>Paste.

	Copy
	1. Select the objects to be copied.
	2. Choose Edit>Copy.

	Paste
	1. If the object was cut or copied from a Graphite document, when it is pasted into another Graphite document it goes on the layer with the same name from which it was cut or copied. A pasted selection retains its original attributes.
	2. Objects cut or copied from non-Graphite documents are pasted onto the work layer.

	Delete
	Undo
	Redo

	Erasing Geometry
	Changing the Characteristics of Objects
	Edit Objects Command
	1. Select the object to be edited.
	2. Choose Edit>Edit Objects.
	3. Change the information in the data fields.
	4. Click the Close button to close the Edit Objects dialog box.
	1. Select the object(s) to be moved.
	2. Choose Edit>Edit Objects.
	3. Click the arrow for the Layer data field.
	4. Click the layer from the list.
	5. Choose Apply.


	Arranging Geometry
	Divide Command
	1. Select the object to be divided.
	2. Choose Arrange>Divide.
	3. Enter the number of equal parts to divide the selection.
	4. Click OK.

	Group Command
	1. Select the objects to be grouped.
	2. Select Arrange>Group.
	1. Select the group.
	2. Choose Arrange>Ungroup. The geometry ungroups with the individual objects selected.
	3. Hold down the SHIFT key and select the geometry to be added to the group.
	4. Choose Arrange>Group.

	Ungroup Command
	1. Select the group.
	2. Choose Arrange>Ungroup.

	Lock Command
	1. Select the objects to be locked.
	2. Choose Arrange>Lock.
	1. Choose Edit>Select All.
	2. Choose Arrange>Lock.

	Unlock Command
	1. Select the locked object(s).
	2. Choose Arrange>Unlock.

	Redraw Screen Command


	Adding Details
	Text
	Text Tool
	1. Select the Text tool from the tool palette. The Message Line reads, Text: Pick opposite corners of text entry box [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].
	2. Create a text box by dragging or by clicking two locations to place the opposite corners of the text area.
	3. Enter the desired text from the keyboard.
	1. Select the Text tool from the tool palette.
	2. Create a text box by dragging or clicking twice to place the opposite corners of the text area.
	3. Choose File>Import.
	4. Select the text file to import.
	5. Click OK.
	1. Select the Text tool from the tool palette.
	2. Move the pointer directly over the text to be edited. The pointer turns into an I- beam text cursor when it is over text. (This only occurs when the Text tool is active.)
	3. Use the text cursor to select text.
	4. Modify the selected text by choosing the appropriate commands from the Text menu.
	1. Use the Selection tool to select the block of text to be changed.
	2. Select the new characteristic from the Text menu.
	1. Click the Selection tool.
	2. Drag a selection fence around the right side of the text box.
	3. Drag the control points to the right as shown below or to the left to make the text box smaller.
	1. Choose the Selection tool.
	2. Select the text object to move.
	3. Move the cursor over the text object. The cursor becomes a 4-way Move symbol.
	4. Place the 4-way Move symbol at the desired handle location using the Drafting Assistant notations as a guide.
	5. Drag the text object to the new location.

	Spell Check
	1. Select the text to check.
	2. Access the spell check function using one of the following:
	3. The Spell Check dialog box operates like any spelling checker. It is necessary to have the required files in the directory named “Spell” of the Graphite application folder. The user requested additions are compiled in the userdic.tlx file.

	Text Menu
	1. Choose Text>Font>More.
	2. Select the character format.
	3. Click Apply.
	1. Choose Text>Size>Other.
	2. Enter the size. The size is measured in the current units as set in the Preferences submenu. To specify a point size, include pt with the numeric entry.
	3. Click OK.

	Text Alignment
	Text Spacing
	Indenting Text
	1. Choose Text>Indentation.
	2. Specify the indentation. Use point values if pt is included in the entry.
	3. Click OK.

	Plotter Fonts

	Crosshatching and Solid Fills
	Crosshatch Patterns
	1. Select the objects which represent a closed boundary. The closed boundary may include cutout areas such as a hole. Select both the outside boundary and the hole.
	2. Choose Pen>Crosshatch.
	3. To display ISO crosshatching options, click the ISO radio button in the dialog box.
	1. Click the ISO radio button to display the ISO patterns. The dialog box displays.
	2. Select the pattern from the menu.
	3. Change the spacing and angle, if desired.
	4. Click Apply.
	1. Select the pattern from the menu. Those patterns that have an ellipsis (...) following their name have their own submenu. Double-click on one of those names to display the submenu.
	2. Change the spacing and angle, if desired.
	3. Click Apply.
	1. Select the existing crosshatching by clicking it with the Selection tool.
	2. Choose Pen>Crosshatch.
	3. Make the changes in the Crosshatch dialog box.
	4. Click Apply.
	1. Select the object to crosshatch.
	2. Choose Pen>Hatch.
	1. Select the objects which represent a closed boundary. The closed boundary may include cutout areas like a hole. Select both the outside boundary and the hole.
	2. Choose Pen>Solid Fill. The Fill dialog box appears.
	3. Enter a Tolerance for the fill.
	4. Click Apply.
	1. Select the existing solid fill by clicking it with the Selection tool.
	2. In the Pen menu, choose a new color from the Color submenu.
	1. Select the existing solid fill by clicking it with the Selection tool.
	2. Choose Pen>Solid Fill.
	3. Change the Tolerance and press Apply.
	1. Select the object to fill.
	2. Choose Pen>Fill.


	Arrowheads
	Width of Arrowhead


	Dimensions
	Associative Dimensions
	Dimensioning Overview
	Dimension Tool Palette
	Dimension Menu
	Dimensioning and the Work Plane
	Dimensioning Objects and Placement
	1. If necessary, display the Dimension palette.
	2. Select the appropriate dimension tool.
	3. Click the points to measure.
	4. Move the dimension to a new location as desired. (See the margin note.)
	5. When using the dimension with parametrics, change the entry in the text data field on the Status Line.

	Moving the Dimension
	Using the Dimension Status Line Fields
	Automatically Placing Dimensions on a Separate Layer
	1. Create a layer named Dimension. (This name must be spelled correctly.) The dimension layer does not need to be the work layer.
	2. Dimension as usual. Subsequent dimensions automatically go on the dimension layer rather than the work layer.

	Adding Tolerance and Limits
	1. From the Dimension menu, choose the desired style, either Linear or Angular.
	2. Create the dimension.
	3. Enter the values in the Status Line for upper and lower tolerance limits and press ENTER (Windows) or RETURN (Macintosh).

	Using Fixed Dimensions
	Adding Special Symbols to Dimension Text
	1. Select the desired dimension.
	2. Open the Edit Objects dialog box. Next to the Text entry field there is button. Click the button and a drop down list of symbols appears. Choose the necessary symbol.
	3. Click ENTER. The symbol appears in the dimension text.


	The Dimension Tools
	Automatic Dimensions
	1. Choose the Automatic Dimensioning tool. The Message Line reads, Automatic Dimensioning: Select object for Auto dimensioning.
	2. Click at each object with the Automatic Dimensioning tool.

	Horizontal Dimension Tools
	1. Select the Horizontal Dimension tool. The Message Line reads, Horizontal: Pick first dimension point. The Message Line guides each successive step.
	2. Click the left point of the geometry.
	3. Click the right point.
	1. Select the Horizontal Base Line Dimension tool. The Message Line reads, Horizontal Base Line: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears above the first, measured from the base point. Continue clicking the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.
	1. Select the Horizontal Chain Dimension tool. The Message Line reads, Horizontal Chain: Pick first dimension point. The Message Line guides each successive step.
	2. Click the first point on the geometry.
	3. Click the second point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears, measured from the last point clicked. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.
	1. Select the Horizontal Ordinate Dimension tool. The Message Line reads, Horizontal Ordinate: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the second point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. Continue clicking all the points to be dimensioned. To display a dimension at the base point, click the base point after having dimensioned all other points.

	Vertical Dimension Tools
	1. Select the Vertical Dimension tool. The Message Line reads, Vertical: Pick first dimension point. The Message Line guides each successive step.
	2. Click the top point of the geometry first.
	3. Click the bottom point.
	1. Select the Vertical Base Line Dimension tool. The Message Line reads, Vertical Base Line: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the second point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears to the right of the first, measured from the base point. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automa...
	1. Select the Vertical Chain Dimension tool. The Message Line reads, Vertical Chain: Pick first dimension point. The Message Line guides each successive step.
	2. Click the first point on the geometry.
	3. Click the second point. The dimension appears.
	4. Click the place for the dimension. This dimension appears, measured from the last point clicked. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.
	1. Select the Vertical Ordinate Dimension tool. The Message Line reads, Vertical Ordinate: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the second point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. Continue clicking all the points to be dimensioned. To display a dimension at the base point, click the base point after having dimensioned all other points.

	Oblique Dimension Tools
	1. Select the Oblique Dimension tool. The Message Line reads, Oblique: Pick first dimension point. The Message Line guides each successive step.
	2. Click the left point first.
	3. Click the right point. The dimension appears. Drag it to a new location. Dimension and extension lines automatically redraw.
	1. Select the Oblique Base Line Dimension tool. The Message Line reads, Oblique Base Line: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the second point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears to the right of the first, measured from the base point. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automa...
	1. Select the Oblique Chain Dimension tool. The Message Line reads, Oblique Chain: Pick first dimension point. The Message Line guides each successive step.
	2. Click the first point on the geometry.
	3. Click the second point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears, measured from the last point clicked. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.

	Perpendicular Dimension Tools
	1. Select the Perpendicular Dimension tool. The Message Line reads, Perpendicular: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base line. Be certain to click on the base line, not on the endpoint of the base line.
	3. Click the object or location.
	1. Select the Perpendicular Base Line Dimension tool. The Message Line reads, Perpendicular Base Line: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the second point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears above the first, measured from the base point. Continue clicking the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.
	1. Select the Perpendicular Chain Dimension tool. The Message Line reads, Perpendicular Chain: Pick first dimension point. The Message Line guides each successive step.
	2. Click the first point on the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears, measured from the last point clicked. Continue clicking all the points to be dimensioned. Drag each dimension to a new location. Dimension and extension lines automatically redraw.
	1. Select the Perpendicular Ordinate Dimension tool. The Message Line reads, Perpendicular Ordinate: Pick first dimension point. The Message Line guides each successive step.
	2. Click the base point of the geometry.
	3. Click the next point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. Continue clicking all the points to be dimensioned. To display a dimension at the base point, click the base point after having dimensioned all other points.

	Radial & Diametral Arrow Dimension Tools
	1. Select the Radial Arrow Out Dimension tool. The Message Line reads, Radial Arrow Out: Select arc/circle. The Message Line guides each successive step.
	2. Click near the circle, arc or fillet to be dimensioned. Click inside or outside the object depending on where the dimension should appear.
	1. Select the Radial Arrow In Dimension tool. The Message Line reads, Radial Arrow In: Select arc/circle.
	2. Click near the circle, arc or fillet to dimension. Click inside or outside the object depending on where the dimension should appear. Either way the arrow line starts from the arc center.
	1. Select the Diametral Arrow Out Dimension tool. The Message Line reads, Diametral Arrow Out: Select arc/circle.
	2. Click near the circle or arc to be dimensioned. Click inside or outside the object depending on where the dimension should appear.
	1. Select the Diametral Arrow In Dimension tool. The Message Line reads, Diametral Arrow In: Select arc/circle.
	2. Click near the circle or arc to be dimensioned. Click inside or outside the object depending on where the dimension should appear.

	Additional Dimension Tools
	1. Select the Angular Dimension tool. The Message Line reads, Angular: Pick first line. The Message Line guides each successive step.
	2. Click on the first line near the endpoint from which the angle is measured.
	3. Click near the endpoint of the second line.
	1. Select the Arc Length Dimension tool. The Message Line reads, Arc Length: Pick start point on the arc. The Message Line guides each successive step.
	2. Select the start point.
	3. Select a point on the arc.
	4. Select the opposite end of the arc.
	1. Choose the Circle Center Line tool. The Message Line reads, Circle Center Line: Select circle.
	2. Click on the circle with the tool.
	3. In the Axis overlap data field of the Status Line, enter the desired axis overlap.
	4. Press the ENTER (Windows) or the RETURN (Macintosh) key.
	1. Select the Balloon Dimension tool. The Message Line reads, Balloon: Pick geometry to point to. The Message Line guides each successive step.
	2. Click the point on the geometry for the dimension arrow.
	3. Click the second point to specify the location of the balloon.
	4. Enter the text and frame width in the Status Line data fields. Press ENTER (Windows) or RETURN (Macintosh) to update the dimension.


	Dimension Appearance
	Linear Dimensions
	Angular Dimensions
	Text Characteristics
	Other Characteristics
	Dimension Standards

	Parametric Dimensions
	Creating a Parametric Dimension
	1. Create the dimension as usual.
	2. Enter a value (variable or algebraic expression) in the text data field.
	3. Continue dimensioning as needed to define the part completely.
	4. Use the parametric feature as described in Chapter 16.

	Converting Parametric Dimensions to Associative Dimensions
	1. Select the dimensions.
	2. Choose Edit>Edit Objects.
	3. Enter a # in the text data field.
	4. Click Apply and close the dialog box.



	Viewing Geometry
	Zooming and Panning
	Zoom Commands
	View Control Tools
	1. Select a Zoom tool from the tool palette.
	2. With the mouse button pressed, drag a box around an area on the screen to magnify or reduce.
	3. Release the mouse button.

	Stroke Zoom
	Mouse Scroll Wheel Zoom
	1. Place the cursor at the desired area to anchor the zoom.
	2. Scroll the mouse button backwards.
	1. Place the cursor at the desired anchor point.
	2. Scroll the mouse wheel forwards.

	Miscellaneous Tools
	1. Select the Orbit tool from the tool palette.
	2. Drag across the screen in the desired direction to move around the geometry.
	1. Select the Pan tool from the tool palette.
	2. Drag across the geometry in the desired direction.
	3. Hold the cursor at the edge of the window for the geometry to continue scrolling in that direction.
	4. Hold the cursor on the edge of the opposite window to move it back.
	1. Select the measuring tool from the tool palette.
	2. Click the first point from which to begin the measure.
	3. Click the end point.

	Spacebar Pan
	1. Place the cursor over the portion of the drawing to move.
	2. Hold down the spacebar. The cursor changes to the hand.
	3. Move the cursor in the drawing area in any direction.


	Layers
	1. Choose Layout>Layers.
	2. Create a new layer and rename it Outline green, indicating that the pen style Outline with a green color will be used on this layer.
	3. Make the layer, Outline green, current.
	4. Select Pen>Style>Outline.
	5. Change the pen color from Black to Green by selecting Pen>Color>Green.
	6. Draw a circle. The circle is created with the green color.
	7. Select the Single Line tool.
	8. Make Layer 1 current.
	9. Draw a line. The line is created in black (the default color for the Outline pen style).
	10. Select the Rectangle tool.
	11. Make the layer, Outline green, current and draw a rectangle.
	Layers Command
	1. Click New in the Layer dialog box to create another layer.
	2. Name the layer by typing the name in the Rename Layer data field.
	3. Click Rename.
	1. Select the name of the layer from the list box.
	2. Type the new name.
	3. Click Rename.
	1. Select the name of the layer to delete from the list box.
	2. Click Delete.
	1. Click the layer(s) in the list to be hidden.
	2. Click Hide. The Eye icon beside the layer name disappears.
	1. Click the layer(s) to make visible in the list.
	2. Click Show.
	1. Select the layer name from the list.
	2. Click Set Layer.
	1. Click the layer you want to relocate.
	2. Drag it to a new position and drop it.
	1. Press the mouse button on the box and the menu displays.
	2. Drag to the layer to make it the work layer and release the mouse button.
	1. Choose Edit>Selection Mask.
	2. Select the desired layer from those listed in the center box.
	3. Choose Edit>Select All.
	4. Choose Edit>Edit Objects. The number of objects is listed at the top of the Edit Objects dialog box.
	5. Close the Selection Mask and Edit Objects dialog boxes.

	Layer Examples
	Layer Groups
	1. Click New.
	2. Choose the layer settings.
	3. Close the dialog box and the settings are retained.
	1. Select the desired Layer Group from the group list.
	2. Enter a new name in the Layer Group data field.
	3. Click Rename.
	1. Select the desired Layer Group from the group list.
	2. Click Delete.
	1. Select the desired Layer Group from the group list.
	2. Click Set Group. This changes the layer settings for the current model to those specified by the layer group. These settings are shown in the layers list.
	1. Select the desired Layer Group from the group list.
	2. Change the layer settings as desired. Visible layers are indicated by the Eye icon and are hidden by clicking on the symbol. Hidden layers are displayed in the layer group by clicking in the location where the Eye icon should be. The work layer is...

	Layers, Sheets, and Models

	View Displays
	Sheet Views
	Detail Views
	1. In the View Control subpalette, select the Detail View tool. The Message Line reads, Detail View: Enter view scale then pick first corner of viewing frame.
	2. Enter a scale for the detail view in the Status Line.
	3. Use the pointer to drag a rectangle around the area of the drawing that is to be placed in the detail view. This rectangle becomes the window frame.
	4. Position the pointer in the center of the detail view window frame and drag the window to a clear area on the drawing.
	1. Create a detail view on an open space.
	2. Use the Selection tool to click inside the view and make it active.
	3. Drag a selection fence around all of the geometry inside the original view.
	4. Choose Edit>Copy.
	5. Choose Views>Models.
	6. Click New to create a new model (by default, model 2).
	7. Click Current to make the new model the current model in the new view. The geometry in the view disappears.
	8. Choose Edit>Paste.

	Rotating the Viewing Area and Detail Views
	Active View
	View Window
	1. In the detail view's Control menu, choose Properties.
	2. Specify the scale and click OK.
	1. Click inside the window to make it active.
	2. Choose Copy from the view window control menu.
	3. Choose Edit>Paste.
	1. Click inside the window to make it active.
	2. Choose Pan from the view window menu.
	3. Drag the geometry to the desired location.
	1. Click inside the view to make it active.
	2. Hold down the SHIFT (Windows) or the CONTROL (Macintosh) key.
	3. Choose Arrange>Zoom (In, Out, Previous, or All)


	Views Menu
	1. Select the view.
	2. Choose Views>Bring To Front.
	1. Select the view.
	2. Choose Views>Send To Back.
	Navigator Palette


	Advanced Viewing Techniques
	Sheets
	Using Sheets
	1. Select the name of the sheet from the list box.
	2. Type the new name.
	3. Click Rename.
	1. Select the name of the sheet from the list box.
	2. Click Delete.
	1. Select the name from the list.
	2. Click Current.


	Models
	Projected Model Image
	Multiple Models
	1. Select Views>Sheets.
	2. Select Views>Models.
	3. Since the Model dialog box is placed at the same location on the screen, move it to another location to see both dialog boxes.
	4. Display the Sheets dialog box and click New to create a new sheet. A new model automatically appears in the Models dialog box (Model 2).
	5. Make Sheet 2 current by highlighting it and clicking Current.

	Relationship between Sheets and Models
	1. Select the name of the model from the list box.
	2. Type the new name.
	3. Click Rename.
	1. Select the name of the model from the list box.
	2. Click Delete.
	1. Activate the view (sheet view or detail view) by clicking on it.
	2. Select the name from the list in the Models dialog box.
	3. Click Current. A check mark shows the current model for the current view.
	1. Create the part.
	2. In the Views menu, use the Sheet Into View command to set up four views in the appropriate sized drawing format.
	3. Use the Cut command in the view window menu to remove all the view windows, except the Front view.
	4. Resize the remaining Front view window so that it fills the drawing format.
	5. Choose Views>Sheets.
	6. Click New.
	7. Click Current.
	8. Choose Views>Models.
	9. Click Model 1 and click Current.
	10. (Optional) Delete Model 3 since it is no longer needed. Model 3 was automatically created with Sheet 2.
	11. Choose Views>Sheet Into View and select the appropriate format and views.
	12. Arrange the views on the sheet.


	Views
	More about Associative Detail Views
	1. Draw the geometry.
	2. Choose Views>Sheet Into View.
	3. Choose the layout from the Layout menu. It is possible to choose from a view with no drawing format or a view in a standard drawing format.
	4. Enter the scaling value in the Scale box if you need a certain value, or just check the Zoom Extents option to make the drawing fit into the view window. Factors greater than one enlarge the model in the view(s) and factors less than one reduce th...
	5. Click OK.
	6. Choose Arrange>Zoom All.
	1. Start a new document.
	2. Select the Detail View tool and create a view window.
	3. Display the Models dialog box and create a new model.
	4. Click on the sheet and make Model 2 the current model in the Model dialog box.
	5. Click in the view window and make Model 1 the current model in the Models dialog box.
	6. Click on the sheet to activate Model 2.
	7. Create the drawing format at a scale 1:1 or import one of Ashlar-Vellum formats and modify it.
	8. Save the drawing with a proper name in the Layouts folder of Graphite.
	1. Delete all view windows on the current sheet by choosing Delete from the view window’s Control menu of each view.
	2. Make Model 1 in the Model dialog box the current model for the Sheet View.
	3. Delete Model 2.

	View Orientation
	1. Choose Views>Define View.
	2. Click New.
	3. Drag a line in the active view window to indicate the Normal (line of sight) vector.
	4. Drag a line in the active view window indicating the Up direction.
	5. Click OK.
	6. Click Set View.
	7. Rename this view to give it a more distinctive name.
	8. Close the Define View dialog box if there is no other need to define additional work views.
	1. Manipulate the view orientation manually with the Trackball.
	2. Choose Views>Define View.
	3. Select the view to redefine.
	4. Click Redefine.
	5. Click OK.
	6. Dismiss the Define View dialog box if there is no other need for it.
	1. Choose Views>Define View.
	2. Select the view to redefine.
	3. Click Redefine.
	4. In the active view window, drag the Normal (line of sight).
	5. Drag the direction for up.
	6. Click OK.
	7. Dismiss the Define View dialog box if it is not needed.
	1. Click the view orientation to be renamed.
	2. Type a new name.
	3. Click Rename.
	1. Click the standard view name in the list box.
	2. Click the Locked box to toggle it off.
	3. Type a new name.
	4. Click Rename.
	1. Choose Views>Unfold View.
	2. Click the endpoints of the line on which to unfold.

	Editing a View Without Editing the Model
	1. Select a view window to make it the active view.
	2. Choose Views>Flatten View.
	3. Click OK. The geometry is placed on the sheet at full scale.

	View Layouts
	1. Choose File>Open and open a Layout file in the Layout folder.
	2. Save the file under a different name in the Layout folder by choosing File>Save As before doing any changes.
	3. Customize the layout as needed.
	4. Save the file.
	5. Select Views>Sheet Into View.
	6. The new layout appears in the pull-down menu in the Sheet Into View dialog box.
	1. Open a new document by choosing File>New.
	2. Create a view window with the Detail View function.
	3. Make the current sheet active by clicking anywhere outside the view window on the sheet.
	4. Choose Views>Model and create Model 2.
	5. Make Model 2 the current model in the Models dialog box.
	6. Duplicate the view window as often as needed.
	7. Set each view window to the desired view orientation with the on-screen Trackball pull-down menu or the Views submenu in the Views menu.
	8. Select Properties in the detail view window’s control menu to scale each view window.
	9. Save the new layout under a proper name in the Layout folder of the Graphite folder.

	Drafting Methods with Views and View Layouts

	Combining Sheets, Views and Models
	Components
	Sheets
	Models
	Views
	Using Sheets, Views and Models
	1. Select Views>Sheets.
	2. Click New to create a new sheet.
	3. Click Current to activate the new sheet and draw some geometry.
	4. Make another sheet active by highlighting a different sheet in the Sheets dialog box and click Current.
	5. Close the Sheets dialog box and select Views>Models.
	6. Search for the before-displayed geometry by activating each Model followed by a Zoom All command until the previous geometry displays on the new sheet.
	1. Open a new document.
	2. Draw an ellipse.
	3. Save the drawing as ellipse.vc6.
	4. Open a new document and draw a rectangle.
	5. Select Views>Sheet Into View.
	6. In that dialog box, choose the ViewTop layout, set the Scale to 1 and click OK.
	7. Make the sheet active by clicking on it and draw a circle.
	8. Select Sheet Into View (the sheet still active) and choose Top view again with the Scale factor 1.
	9. Activate the sheet by clicking on it and select File>Import.
	10. Select the file ellipse.vc6 and click OK.
	11. Arrange the two view windows around the ellipse and rearrange the rectangle and the circle with the Zoom commands in the Arrange menu like in the following graphic.
	12. Activate the sheet and in the Views menu deactivate the Show View Boundaries command.



	Graphite Documents
	Using Documents
	New
	Opening Files
	1. Choose File>Open or click the Open (second) icon in the Window>General palette.
	2. Display the appropriate folder containing the document to open.
	3. Click the file name to open in the list box.
	4. Click OK.

	Recent File List
	Saving a Drawing
	1. Choose File>Save As or click the Save As (forth) icon in the Window>General palette.
	2. If necessary, display a different folder.
	3. Type the name to use in the File name data field.
	4. Either press ENTER (Windows), RETURN (Macintosh) or click OK.
	1. Choose Layout>Preferences>AutoSave. The AutoSave dialog appears.
	2. Switch AutoSave On or Off. The default setting is off.
	3. Specify the time interval for AutoSaving in minutes in the AutoSave Interval data field. The interval can be from 1 to 60 minutes; the default setting is 15 minutes. An interval of 0 or less is equivalent to turning AutoSave off.
	4. Click OK.

	Close Command
	Exit Command (Windows) or Quit Command (Macintosh)
	File Organization
	1. Choose Layout>Preferences>Directory.
	2. Enter the directory path in each data field. Either type the path or browse the computer for the folder and have the path entered automatically.
	3. Repeat step #2 for all of the directories specified.
	4. Click Apply to save the settings and close the dialog box.


	Importing and Exporting
	Import Command
	1. Choose File>Import.
	2. Windows Select the file type to import from the Files of Type list box. The list box shows all files of the selected type available in that folder.
	3. Double-click the File name to import.
	4. Specify import options.
	5. Click OK.
	1. Choose File>Import.
	2. Select the filename to import.
	3. If Text is not selected, click the Text button.
	4. Click OK.
	1. Select File>Import.
	2. Select a text file that contains the coordinates for the spline.
	3. Specify the import option Spline.
	4. Click OK.
	1. Use a text editor, a word processor or a spreadsheet to create a text file.
	2. Input X, Y and Z values for the spline coordinates.
	3. Save the file as Text only and import into Graphite to create the spline.

	Export Command
	1. Choose File>Export.
	2. Click the desired file type. To export only selected objects on the screen, rather than the entire document, click Only Selected.
	3. Click OK. The Export file dialog box appears.
	1. Chose File>Export.
	2. Select PDF from the Export dialogue box and click OK.
	3. The Save File As dialogue box appears. Enter the name and location to save the PDF.
	4. The PDF attachment box appears. Select which file to include and click OK.
	1. Create two folders.
	2. Copy all files to convert into the FilesIn folder.
	3. Select the File>Convert.
	4. Select the file type being translated from the Input File Format column.
	5. Select the file type being translated from the Output File Format column.
	6. Check the Draw each file option, if desired.
	7. Click OK.
	8. Open the folder (FilesIn) that contains the files to convert.
	9. Select a single file and click Open.
	10. Select a destination folder (FilesOut) for the translated files or create a new one.


	Drawing at Full Scale
	1. Draw a line, specifying 83' for the length.
	2. Choose Arrange>Zoom All. The entire 83 foot line is visible on the screen.
	Scaling Line Patterns and Crosshatch Patterns
	Scaling Text and Dimensions
	1. Choose Text>Size>Other.
	2. Click after the entry in the data field.
	3. Enter *100 and click OK.


	Drawing Scale and Paper Size
	Print to PDF
	Print Setup (Windows); Page Setup (Macintosh)
	1. Select the plotter or printer.
	2. In the Paper Size menu, select the paper size.
	3. Specify the orientation.

	Drawing Size Command
	1. Choose Layout>Drawing Size. A dialog box appears.
	2. Select Printing from the list.
	3. Specify the scale, using one of three methods below as necessary:
	4. When printing multiple sheets and taping them together, follow the directions for “Tiled Printing” on page 15-34 later in this chapter.
	5. Click OK.
	1. Choose Layout>Drawing Size. A dialog box appears.
	2. Choose the PDF Exporting tab.
	3. Specify the width and height in the W and H data fields or click the down arrow in the data field on the right to choose one of the predefined sizes. Set the margins for the left, top, right and bottom edges of the page in the L, T, R, B data entr...
	4. When printing multiple sheets and taping them together, follow the directions for “Tiled Printing” on page 15-34 later in this chapter.
	5. Click OK.
	1. Choose Arrange>Zoom All.
	2. Choose the Views>Sheet Into View.
	3. Enter the scaling value in the Scale data field of the Sheet Into View dialog box. Figuring this value is similar to drafting on paper, determining which scale to use so that the finished part fits on the paper size.
	4. Click OK.

	Printing/Plotting Region
	Tiled Printing
	1. Choose Layout>Drawing Size.
	2. Specify the number of pages Across for the final drawing.
	3. Specify the number of pages Down for the final drawing.
	4. Specify the order for printing the pages (Across then Down or Down then Across).
	5. Click Fit.
	6. Click OK.


	Drawing Formats
	Placing Drawing Formats
	1. Choose Layout>Drawing Size to scale the drawing.
	2. Mark the Always Display Page Bounds option to compare the true size of the drawing with the displayed printing area of the drawing format.
	3. Choose the File>Import.
	4. Mark the unscaled option.
	5. Select a desired drawing format under your language in the Layout Folder on your system. See the Tech Note on locating the Layout Folder. For example:
	6. Click OK.
	1. Choose the Sheet Into View command in the Views menu.
	2. Select the desired drawing format from the Layout list box, such as:
	3. Enter the desired scale factor in the Scale data field.
	4. Click OK.

	Modifying Drawing Formats
	1. From the Layout folder the drawing format:
	2. Save the drawing under a new name.
	3. Choose Layout>Drawing Size.
	4. Mark the Always Display Page Bounds option.
	5. Click OK.
	6. Select the grouped drawing format on the drawing area and ungroup the format by choosing Arrange>Ungroup.
	7. Adjust the border lines of the drawing format until they are placed exactly on top of the displayed gray rectangle for the printing area of the printer.
	8. Delete all cutting lines since they are not required for printing.
	9. Hide the Forms layer.
	10. Select the complete drawing format by choosing Edit>Select All and group the format by choosing Arrange>Group.
	11. Activate the Forms layer.
	12. Save your work.


	Forms
	Creating Forms
	1. Open one of the drawing formats in the Layout folder.
	2. If no layer with the name Forms exists, create this layer by choosing Layout>Layers and make it the current layer.
	3. Select the Text command from the function palette.
	4. Create text blocks. Any text block beginning with an @ character will become a field, all others will become labels.
	5. Assign to all of the text blocks the desired font, style and size using the Selection tool from the tool palette.
	6. Save the drawing format.

	Using Forms
	1. Place a Standard drawing format (use the Import or Sheet into View command). The form appears with all of the field labels as they were originally created.
	2. Choose the Text>Forms Text>Forms.
	3. Type in the desired parameters. All entry fields need not be filled.
	4. Click OK.
	1. Select the fields containing values to update (or choose Edit>Select All).
	2. Select the Text>Forms Text>Forms.
	3. Modify the entries of the title block.
	4. Click OK.


	Printing or Plotting a Drawing
	Print Command


	Parametrics
	Introduction to Parametrics
	1. Create the geometry.
	2. Dimension the geometry using variables, constant values, and expressions. As many as 253 parametric dimensions can be used.
	3. Resolve the parametric geometry.

	Using Parametrics
	Basic Rules
	1. Define the geometry completely.
	2. Keep it simple. If the part is complex, construct small segments, resolving as you go, solving any parametric problem before proceeding.
	3. Return to the original part between tests. Use the Undo command to revert to the original state of the parametric part between tests. In this way, an unwanted constraint won’t be introduced.
	4. Consider the following assumptions made by the parametric mechanism:
	5. Be aware of the relationships that the parametric mechanism cannot recognize:

	Creating Geometry
	Parametric Dimensions
	1. Construct the geometry.
	2. Display the dimension palette and choose the appropriate dimensioning tool.
	3. Click the geometry to dimension as usual.
	4. Type whatever expression, variable, or constant to be used for the dimension, and press the ENTER (Windows) or the RETURN (Macintosh) key. To use the actual value, do not overwrite the # symbol in the text data field.

	Resolving the Parameters
	1. Create the geometry.
	2. Dimension all geometry by using variables, constant values and expressions. (Dimension the essential, related geometry so Graphite can reconstruct the geometry. Graphite cannot identify parallel or colinear lines.)
	3. Select the geometry and dimensions to be resolved.
	4. Choose Edit>Resolve.
	5. If necessary, enter the values to assign to the variables.
	6. Optional step: to anchor a point on the geometry at a particular location, click the point. The point remains in the same location after resolving the geometry. An example appears later in this section.
	7. Click OK.

	Specifying Parametric Variables in a Text File
	1. Create the text file using any word processor or spreadsheet and saving it as Text only.
	2. In Graphite select the geometry and parametric dimensions.
	3. Choose Edit>Resolve.
	4. Click File to specify the values for the variables automatically.
	5. Select the text filename.
	6. Specify an anchor point, if necessary.
	7. Click OK.

	Anchoring the Geometry
	Changing the Dimensions to Actual Measurements
	1. Choose Edit>Selection Mask.
	2. Highlight the four dimension types in the box on the left.
	3. Choose Edit>Select All.
	4. Choose Edit>Edit Objects.
	5. Change the entry in the text data field to a # symbol.
	6. Click Apply.
	7. Close the Edit Objects and Selection Mask dialog boxes.
	8. Click the Selection tool to cancel the effect of the Selection Mask.


	Parametric Drafting
	Dimension All Geometry
	1. It is possible to construct the centerlines so their endpoints are on the circle, as shown here.
	2. Include dimensions for the centerlines. The dimensions should be variables based on the diameter of the circle so when the diameter of the circle is specified, the centerlines are drawn relative to the diameter.
	1. Use the Circle Center Line tool to place the center line on the circle.
	2. Dimension the diameter of the circle and one of the center lines relative to the diameter. Dimension the center line from endpoint to endpoint or from the center of the circle to one endpoint of a center line.

	Relate All Geometry
	1. The added dimension is an example of using a constant value. A variable expression such as x+y can be entered for the constraint line.
	2. Constraint lines are ordinary lines usually drawn with the Single Line tool. They can be any line style, but they should be different from the lines of the regular geometry. The Construction line style is a good choice.
	3. Placing the constraint line and dimension on a layer (named Constraints), that layer can be hidden when plotting the drawing.

	No Extraneous Text
	Return to the Original Part between Tests

	Parametric Problems
	Geometry Overconstrained
	Unrelated Groups
	Unrelated Groups where One Group is a Single Point
	Another Unrelated Group
	1. The height can be dimensioned on the left.
	2. Draw a constraint line to close the opening.
	3. Dimension the height from the top of the left line to the bottom of the right line. While this is not good drafting practice, it is very useful for parametric symbols.

	Assumptions Involving Tangency
	1. Draw a constraint line from the center of the circle to the point of tangency for the line that extends beyond the circle, as shown here.
	2. Use the Rotate tool on the Transformation subpalette to move the endpoint of the circle to the tangent point of the line that extends beyond the circle.
	3. Divide the line into two segments which join at the tangent point.

	Relationships Involving Symmetry

	Complex Parametric Drafting
	Example—Departures from Standard Drafting
	1. The centerline does not extend beyond the geometry.
	2. Constraint lines define the edges of the groove. Parametrics do not recognize non-touching colinear lines.
	3. Constraint lines connect the endpoints of the upper and lower halves to relate the geometry. Parametrics do not recognize non- touching colinear lines.
	4. Four dimensions are added to relate the geometry to the centerline. Parametrics don’t recognize non- touching colinear lines.
	1. Place the additional information on a separate layer to hide the layer when plotting the drawing.
	2. Using a yellow pen (which is hard to see against a white background) prevents confusing the additions with the actual geometry.

	Example—Keep It Simple or Testing as You Go
	1. Construct and resolve one section at a time. Solve any problems with this bracket before moving on.
	2. Add a centerline between the holes to maintain alignment.
	3. Add a line connecting the lower edges of the flanges to keep the lines colinear.
	1. Add constraint lines to connect the geometry between sections.
	2. Add a dimension to specify the distance between the sections. (See the two box problem earlier in this section.)
	3. Add extra thickness (T) dimensions since all geometry must be defined.
	1. Dimension each fillet, as explained earlier.
	2. Relate this section to the rest of the geometry.
	3. Add a dimension to specify the distance between the sections.


	Parametrics and Grouped Objects
	Using Parametrics and Grouped Geometry
	1. Create the geometry to be parameterized.
	2. Select the geometry.
	3. Choose Arrange>Group.
	4. Create a framework on which the grouped geometry sits.
	5. Dimension between two control points. It is possible to use only one variable per group.
	6. Select the framework, the dimension and the group.
	7. Choose Edit>Resolve.
	8. Enter the value for the distance between the control points.
	9. Click OK.

	Rigid Links
	Parametrics in 3D


	Symbols
	Using Symbols
	1. Construct the geometry, using the Construction pen style for any lines that should not appear in the symbol when it comes into a drawing. Be sure to place one control point at (0,0) to specify the location of the symbol when bringing it into a dra...
	2. Dimension all aspects of the part by entering a variable in the text data field in the status line of each dimension.
	3. Choose Edit>Resolve to check the accuracy of the parametric dimensions.
	4. Choose File>Save As.
	5. Name the document.

	Placing Symbols
	Symbol Commands
	1. Choose File>Symbol....
	2. Select the symbol file to be used and click Open.
	3. Enter a value for each of the parametric dimensions.
	4. Specify the location and orientation for the symbol.
	5. Click OK.
	6. Add regular dimensions if desired.
	1. Choose File>Symbol....
	2. Select a symbol file from the directory to be browsed and click Open.
	3. Click New to load a different directory of symbols.


	Smart Symbols
	Creating a Smart Symbol
	1. Choose Pen>Style>Construction.
	2. Draw a smart wall thicker than the maximum thickness expected to be used and only as long as the final symbol is.
	3. Change pen styles to any style other than Construction.
	4. Draw the symbol.
	5. Choose File>Save As and save as usual.



	2D Analysis
	2D Analysis Command
	Performing 2D Analysis
	1. Select the geometry that defines a closed boundary. Use the Tracer tool to select the perimeter.
	2. Choose Layout>2D Analysis.
	3. If necessary, enter changes for the tolerance and weight per area values.
	4. Click CALCULATE.


	Calculations
	Displaying the Centroid
	1. Select the geometry defining the part.
	2. Choose Layout>2D Analysis.
	3. Choose Layout>Construction.
	4. In the Angle field in the Construction dialog box, enter 0;90. (Be certain to separate the numbers with a semicolon.)
	5. Enter the value for Centroid X in the X field of the Construction dialog box.
	6. Enter the value for Centroid Y in the Y field of the Construction dialog box.
	7. Press ENTER (Windows) or RETURN (Macintosh).



	Bill of Materials
	Introduction
	Attributes and Objects
	Defining Attributes
	1. Click New to create a new attribute.
	2. Rename the attribute by typing a name in the Attribute Name entry field, like COST.
	3. Specify a value for the attribute in the Default Value entry field.
	4. Select a format for the new attribute. In the examples given above, the format is Number.
	5. Click Redefine.
	6. Close the Define Attributes dialog box.
	1. Select an attribute to show or hide from the list box. The eye icon beside the attribute name indicates that an attribute is visible.
	1. Select the attribute whose name, value or format needs to be changed.
	2. Type a new name or value, or choose a new attribute format.
	3. Click Redefine.
	4. Close the Define Attributes dialog box by clicking Close.
	1. Select the name of the attribute from the list box.
	2. Click Delete. The selected attribute deletes.

	Predefined Attributes (Graphite Attributes)

	Assigning Attributes
	BOM Tools
	Attribute Tools
	1. Choose Text>Bill of Materials>Define Layouts.
	1. In the BOM tool palette, choose the Symbol Attributes tool. The Message Line reads, BOM Symbol Attribute Tool: Select Insertion Point.
	2. Enter the values for the attributes in the Status Line.
	3. Click to place the Symbol Attributes table in an empty spot in the drawing area.
	4. Save the object with the Symbol Attributes table.


	Editing Attributes
	Showing Attributes
	1. In the BOM tool palette, select the Attribute Selection tool.
	2. Move the mouse pointer over the drawing area. As soon as the pointer comes near an object with assigned attributes, these attributes and their respective values automatically display in the Status Line.

	Changing the Values of Attributes
	1. In the BOM tool palette, select the Attribute Selection tool.
	2. Move the mouse pointer near an object with assigned attributes.
	3. Select the object with the Attribute Selection tool.
	4. Change the respective values in the Status Line. To remove an attribute value, delete the value in the entry field.
	5. Press the ENTER (Windows) or RETURN (Macintosh) key.

	Removing Attributes
	1. In the BOM tool palette select the Attribute Selection tool.
	2. Move the mouse pointer near an object with assigned attributes.
	3. Select the object with the Attribute Selection tool.
	4. Press the CTRL+ENTER keys (Windows) or the OPTION+RETURN key (Macintosh) simultaneously. All visible and unlocked attributes are removed.


	Item Numbers
	Assigning Item Numbers
	1. In the BOM tool palette, select the Item Number tool. The Message Line reads, Item Number Tool: Pick BOM geometry to point to... [Ctrl = Renumber].
	2. Three entry fields display in the Status Line: Item, Width and Size.
	3. Enter the starting item number for the selected object into the Item field.
	4. Click the Item Number tool near the object to be labeled.
	5. Click with the Item Number tool in the drawing area to indicate the position of the Item Number balloon.
	1. In the BOM tool palette, select the Item Number tool.
	2. Press the TAB key twice and enter the desired width for the Item Number balloon. The units for the indicated width are based on the unit specified in the Units dialog box from the Layout>Preferences>Units.
	3. Enter the desired size.
	4. Select the desired text size.
	5. Press the ENTER (Windows) or RETURN (Macintosh) key.

	Editing Item Numbers
	1. Select the desired Item Number balloon.
	2. Choose Item Number Tool.
	3. In the Status Line, enter the new diameter in the width field.
	4. Press the ENTER (Windows) or RETURN (Macintosh) key.
	1. Select the respective Item Number balloon.
	2. Choose Edit>Edit Objects.
	3. In the Status Line, enter the new Text Size in the size field.
	4. Press the ENTER (Windows) or RETURN (Macintosh) key.
	1. Select the desired Item Number balloon.
	2. Select Edit>Delete or press the BACKSPACE (Windows) or DELETE (Macintosh) key.
	1. In the BOM tool palette, select the Item Number tool.
	2. Enter in the Item field the new starting number for the Item Number, press the ENTER (Windows) or RETURN (Macintosh) key.
	3. Press the CTRL (Windows) or OPTION (Macintosh) key and keep it pressed.
	4. Click the Item Number balloons in the desired order.
	5. Release the CTRL (Windows) or OPTION (Macintosh) key.

	Item Numbers and Object Copies

	Bill of Materials
	Bill of Materials Layouts
	1. Choose Text>Bill of Materials>Define Layouts.
	2. Click New.
	3. Rename the layout in the Layout Name entry field.
	4. Click Rename.
	5. Double click to activate/set.
	6. Select the Text>Bill of Materials>Define Attributes.
	7. Define all the attributes to be used in different layouts.
	8. Make all the attributes visible to be saved under one layout name.
	1. Choose Text>Bill of Materials>Define Layouts.
	2. Double click to activate/select.
	3. Click Current.
	4. Select the Text>Bill of Materials>Define Attributes.
	5. Show or Hide the attributes as desired.

	Layout Options
	Creating A Bill of Materials
	1. Choose Text>Bill of Materials>Show Palette.
	2. Select the BOM tool. The Message Line reads, BOM Tool: Pick Insertion Point [Ctrl = Selection Only {Windows}, OPTION = Selection Only {Macintosh}].
	3. Click in the drawing area to indicate the location to display the Bill of Materials.
	1. Select all objects to display in a Bill of Materials.
	2. Choose Text>Bill of Materials>Show Palette.
	3. Select the BOM tool.
	4. With the CTRL (Windows) or OPTION (Macintosh) key pressed, click in the drawing area to indicate where to place the Bill of Materials.
	1. Select the Bill of Materials with the Selection tool.
	2. Choose Arrange>Ungroup.

	Exporting a Bill of Materials
	1. Select File>Export.
	2. Mark the Bill of Materials option.
	3. Select the Only Selected option to export attributes only from selected objects and not from the entire drawing.
	4. Click OK and provide a file name and location.



	GD&T
	Background
	Alignment Information
	Bonus Tolerance
	Basic Dimension
	GD&T Feature Control Frame
	Geometric Characteristics
	Diameter
	Position Tolerance
	Material Condition
	Datum
	Datum Material Condition
	Composite GD&T Symbols
	Projected Tolerance Zone

	The GD&T Label
	GD&T Command
	1. Choose Dimension>GD&T. The GD&T dialog box appears.
	2. Click a button (Stand Alone, Arrow Line, or Witness Line) to indicate the way the GD&T symbol is connected to the geometry being labeling.
	3. Enter the appropriate data to create the GD&T label. Make two types of entries in this dialog box:
	4. Indicate the location of the label. The Message Line guides each successive step.
	1. Select the GD&T label to be edited.
	2. Choose Dimension>GD&T.
	3. Make the changes in the GD&T dialog box.
	4. Click Edit.
	1. Press the first field to display the Geometric Characteristic menu.
	2. Drag to the X symbol.



	Appendix A: Operators and Units
	Mathematical Operators
	Conditional Expressions
	Units of Measure
	1. Specify millimeters as the unit of measure by choosing Layout>Preferences>Units.
	2. Choose Layout>Preferences>Grid.
	3. Set the grid spacing to 34 and the number of subdivisions to 2.
	4. Turn on the grid.
	5. Use the Connected Lines tool to draw the wave form of the desired specifications.
	6. Use the Expand/Shrink tool to stretch the wave form to half and full cycles.

	Decimal Indicators

	Appendix B: Special Characters
	Windows
	Macintosh
	Adding Special Symbols to the Dimensions Text
	1. Select the dimension you need to add special symbols to.
	2. Open the Edit Objects window. Next to the Text entry field there is button. Click the button and the drop down list of symbols appears. Choose the one you need.
	3. Click ENTER. The symbol appears in the dimension text.
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