Designer Elements
v7 + v8 Addendum
Cobalt, Xenon and Argon Version 7 & 8

August 2009

In December 2008 selected assets of Ashlar Incorporated were transferred to Vellum Investment Partners, LLC pursuant to the 2005 agreements between the companies. Eventually, all assets and selected liabilities of Ashlar Incorporated will be transferred to Vellum Investment Partners. As part of this process, specific copyrights and trademarks will be transferred and re-registered as appropriate in various countries worldwide.

Therefore, for the purposes of this copyright and trademark notice, Ashlar Incorporated and Vellum Investment Partners LLC shall be collectively, jointly, individually, and separately known as Ashlar-Vellum. All references to Ashlar-Vellum that follow shall apply as appropriate at the time of receipt or reading, in the country of the publisher, distributor, recipient or reader to one or both of Ashlar Incorporated and Vellum Investment Partners LLC.

The word Ashlar is a registered trademark in the United States of Ashlar-Vellum. The word Ashlar and logo Ashlar with Bricks are registered trademarks in the United States and Benelux of Ashlar-Vellum. The word Vellum is a registered trademark in the United States, Japan, Benelux and France of Ashlar-Vellum. Where not registered, Ashlar (word), Ashlar with Bricks (word & logo), Vellum (word) and Ashlar-Vellum (words) are trademarks of Ashlar-Vellum. Graphite (word), Graphite C-Hex (logo), Cobalt (word), Cobalt C-spiral (logo), Xenon (word), Xenon X-graphic (logo), Argon (word), Argon A-loop (logo), Chromium (word), Chromium Cr-graphic (logo), Iridium (word), Iridium Ir-graphic (logo), Ashlar-Vellum (words), Ashlar Bricks alone (logo), Creative Intuition Powered by Vellum (words), The Ultimate Product Design and Development Tool (words) and Software that works the way you think (words), Ashlar-Vellum Software that works the way you think with Bricks (words & logo), Ashlar-Vellum Software that works the way you think with Bricks and Swoosh (words & logo), Vellum:environments (words & logo), Vellum:tracks (words & logo), Vellum:decals (words & logo), Vellum:materials (words & logo), Graphite Tips & Tricks (words & logo) are all trademarks of Ashlar-Vellum.

Other marks (if any) are property of their respective owners.

All rights reserved. No part of this document may be reproduced, photocopied or transmitted in any form without the expressed permission of Ashlar-Vellum. The software described in this document is provided under a license and may be used or copied only in accordance with the terms of such license.

Limit of Liability/Disclaimer of Warranty: The information provided in the document is distributed, as is, without warranty. While every precaution has been taken in the preparation of this document, Ashlar-Vellum, Ashlar-Vellum employees, contractors, sub-contractors, and suppliers shall have no liability to any person or entity with respect to liability, loss or damage caused directly or indirectly by the instructions contained in this document or by the software described herein.

Copyright © 2009 Ashlar-Vellum. All rights reserved.

3Dv7+8A0909

Ashlar-Vellum
+1 800 877 2745
www.ashlar-vellum.com
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table of Contents</td>
<td>I-I</td>
</tr>
<tr>
<td>Welcome</td>
<td>1</td>
</tr>
<tr>
<td>Technology Updates</td>
<td>2</td>
</tr>
<tr>
<td>ACIS R12.0.X</td>
<td>2</td>
</tr>
<tr>
<td>Ease-of-use Improvements</td>
<td>2</td>
</tr>
<tr>
<td>OpenNurbs Initiative Rhino v3</td>
<td>2</td>
</tr>
<tr>
<td>ACIS R16</td>
<td>3</td>
</tr>
<tr>
<td>Import DWG\DXF 2007/2008 Files</td>
<td>3</td>
</tr>
<tr>
<td>Escape Key Enhancement</td>
<td>4</td>
</tr>
<tr>
<td>Design Explorer</td>
<td>5</td>
</tr>
<tr>
<td>Feature Tree</td>
<td>5</td>
</tr>
<tr>
<td>In/Out/History Links</td>
<td>5</td>
</tr>
<tr>
<td>All Operations Listed</td>
<td>6</td>
</tr>
<tr>
<td>Right-click Menu</td>
<td>6</td>
</tr>
<tr>
<td>Appearance of Tolerances for Linear Dimensions</td>
<td>8</td>
</tr>
<tr>
<td>Edit Window</td>
<td>9</td>
</tr>
<tr>
<td>Customize Surface Analyses Options via Edit Object</td>
<td>9</td>
</tr>
<tr>
<td>Real-Time Environment Maps</td>
<td>9</td>
</tr>
<tr>
<td>Curvature</td>
<td>13</td>
</tr>
<tr>
<td>Draft Angle</td>
<td>14</td>
</tr>
<tr>
<td>Enhanced Clipping Plane</td>
<td>15</td>
</tr>
<tr>
<td>Using the Clip Plane</td>
<td>15</td>
</tr>
<tr>
<td>Color per Face</td>
<td>22</td>
</tr>
<tr>
<td>New Options for Shade + Shortcut</td>
<td>23</td>
</tr>
<tr>
<td>Right-click Popup Menu</td>
<td>24</td>
</tr>
<tr>
<td>Right Mouse Click on Surfaces</td>
<td>24</td>
</tr>
<tr>
<td>Save Entity As Symbol</td>
<td>25</td>
</tr>
<tr>
<td>Editing Common Properties on Multiple Objects</td>
<td>25</td>
</tr>
<tr>
<td>New Right-click Menu Options</td>
<td>25</td>
</tr>
<tr>
<td>User Pen Styles</td>
<td>26</td>
</tr>
<tr>
<td>Specifying Pen Weight Units</td>
<td>27</td>
</tr>
<tr>
<td>Assigning Pen Properties to Layers</td>
<td>27</td>
</tr>
<tr>
<td>Tangent Circle Tool Enhancement</td>
<td>29</td>
</tr>
<tr>
<td>General Transform Tools</td>
<td>30</td>
</tr>
<tr>
<td>Item vs. Faces</td>
<td>30</td>
</tr>
</tbody>
</table>
Table of Contents

Enhanced Polar Duplicate Tool .............................................................. 31
Spherical Duplicate Tool ......................................................................... 33
  Using the Spherical Duplicate Tool ...................................................... 35
Cylindrical Duplicate Tool ................................................................. 37
  Using the Cylindrical Duplicate Tool .................................................... 38

**Wireframe Creation Tools** ................................................................ 41
Mid-point Line ......................................................................................... 41
  Using the Mid-point Line Tool ............................................................ 41
Star Polygon ............................................................................................. 42
  Using the Star Polygon Tool ............................................................... 42

**Surface Editing Tools** ...................................................................... 43
Enhancements to the Curve/Surface Projection Tool ............................. 43
  Parametric Sketch ................................................................................ 43
  New To Entity/Face Option ................................................................. 43

**Solid Tools** ...................................................................................... 46
Selecting Faces for Chamfer Tools ........................................................ 46
Flip Direction Option in Chamfer Tools ................................................ 47
Twist Solid Tool ....................................................................................... 48
  Using the Twist Solid Tool: ................................................................. 49
Stretch Solid Tool .................................................................................... 50
  Using the Stretch Tool.......................................................................... 51
Extrude, Cutout, Lathe, Protrude Nonplanar Profiles ............................. 52
Gaps Detected Enhancement ................................................................ 53
Enhanced Rib Tool .................................................................................. 54
Vertex and Edge Options in the Local Move Tool ................................. 55
  Move Edge Option.................................................................................. 55
  Move Vertex Option.............................................................................. 56
Enhanced Skinned Solid Tool ............................................................... 56
Profile Enhancement ................................................................................ 57

**Model to Sheet Enhancements** ....................................................... 59
  Use Layout Settings for Model to Sheet ................................................ 59
  Renderings and Wireframe Handled Separately in Model to Sheet Views. 60
  Optional Automatic View Scale Indicator ............................................. 63
  Pan Tool for Drawing Views .................................................................. 64

**Photo-realistic Rendering** ............................................................... 65
  New Advanced Photo-realistic Rendering Options................................. 65
  Custom Render Presets .......................................................................... 68
  Photo-realistic Environment Maps for Stills and Animations .................. 69
    Using a Photo-realistic Environment Map ............................................. 71
Photo-realistic Tube and Area Lights for Stills and Animations .......... 73
  Linear Tube Light ............................................................................................... 74
  Tube Light From Curve .................................................................................. 75
  Rectangular Area Light .................................................................................. 76
  Area Light from Selected Surface ....................................................................... 77
Photo-realistic Sunlight for Stills and Animations ......................................... 78
Interleaved Wireframe Geometry ........................................................................ 81
Custom Decals From Alpha Images ...................................................................... 83
Decal Material Options .................................................................................... 85
Material per Face ............................................................................................. 87
Accelerated Phong and Gouraud Shading Options ........................................ 89
  Fast Shading with Render to File ....................................................................... 89
  Fast Shading with Animations .......................................................................... 90
Real Time Photo-realistic Material Changes Displayed in the Edit Window ........ 91
Constrained Parametric Sketches ....................................................................... 92
Status Line and Edit Object Variables ........................................................... 92
Nested Equations ............................................................................................. 93
Conditional Equations ....................................................................................... 93
  Logical Operations ............................................................................................ 93
  Conditional Equations ..................................................................................... 94
  Priority of Operations ...................................................................................... 94
Export and Import ............................................................................................. 95
New Format and Software Tabs ......................................................................... 95
Batch Convert Tool ............................................................................................ 96
Creating a Multi-sheet PDF from within the Software ...................................... 97
New Real-time Display of 2D Images in 3 Dimensions ....................................... 100
Enhanced Support for Bitmap Images .............................................................. 101
  Import Options ................................................................................................ 101
  Export Options ................................................................................................ 101
Opening Password Protected DWG Files .......................................................... 102
Preference Setting Enhancements ..................................................................... 103
Factory Setting .................................................................................................. 103
Gradient Color of Background .......................................................................... 104
Copy as Instance ............................................................................................... 105
File Open Times ............................................................................................... 106
Select .................................................................................................................. 107
  Wire Weight .................................................................................................... 107
  Transparency .................................................................................................. 107
SpaceMouse (Windows Only) .............................................................................. 108
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable SpaceMouse</td>
<td>108</td>
</tr>
<tr>
<td>3Dconnexion SpaceMouse Information</td>
<td>110</td>
</tr>
<tr>
<td>Working with the Motion Controller in 3D Applications</td>
<td>110</td>
</tr>
<tr>
<td>User-definable Interface Skins</td>
<td>111</td>
</tr>
<tr>
<td>Restore Default Palettes</td>
<td>112</td>
</tr>
<tr>
<td>File Paths</td>
<td>113</td>
</tr>
<tr>
<td>New Update Installer</td>
<td>114</td>
</tr>
<tr>
<td>Automated Support Ticket Preparation</td>
<td>115</td>
</tr>
<tr>
<td>Items Removed in v7</td>
<td>116</td>
</tr>
<tr>
<td>Pro/E Granite Translator (Windows Only)</td>
<td>116</td>
</tr>
<tr>
<td>Viewpoint Media</td>
<td>116</td>
</tr>
<tr>
<td>Memory Readout (Macintosh Only)</td>
<td>116</td>
</tr>
</tbody>
</table>
Welcome

Ashlar-Vellum is proud to bring you this combined addendum featuring the enhanced features of both version 7 and version 8 of Cobalt, Xenon and Argon in our Designer Elements product line.

The information on the following pages is intended to supplement that found in the user documentation originally created for previous versions. Included is information on the following:

- Technology Updates
- Escape Key Enhancement
- Design Explorer
- Appearance of Tolerances for Linear Dimensions
- Edit Window
- Right-click Popup Menu
- User Pen Styles
- Tangent Circle Tool Enhancement
- General Transform Tools
- Wireframe Creation Tools
- Surface Editing Tools
- Solid Tools
- Model to Sheet Enhancements
- Photo-realistic Rendering
- Constrained Parametric Sketches
- Export and Import
- Preference Setting Enhancements
- New Update Installer
- Automated Support Ticket Preparation
- Items Removed in v7
Technology Updates

Versions 7 and 8 of Ashlar-Vellum's Cobalt, Xenon and Argon 3D modeling programs include updates from some of our many technology partners.

**ACIS R12.0.X**

The technology added by Spatial ACIS R12.0.1 includes more than 200 kernel improvements that impact blending, shelling, local operations, Booleans, and faceting. It includes integration of Spatial's interoperability translators for IGES, STEP, and CATIA V4.

**Ease-of-use Improvements**

Cobalt, Xenon and Argon have been updated to include:

- Enhanced control over model units and scaling, particularly when importing and exporting models. Models are automatically scaled whenever necessary.
- Improved progress monitoring and abort mechanisms, providing progress metrics during data translation and optionally allowing interruption of the translation process.
- Improved error logging for enhanced feedback when problems are encountered during data translation.

**OpenNurbs Initiative Rhino v3**

The Rhino 3dm import is updated through the OpenNurbs source code. Now you have the ability to import versions 1, 2 or 3 of Rhino files.
**ACIS R16**

The technology added by Spatial ACIS R16 improves interoperability among other design software through the export of ACIS SAT version 16 file format. It provides enhancements to booleans, blends and move face features. This also includes updates to the IGES, STEP, PRO/E, and CATIA v4 translators.

**Import DWG\DXF 2007/2008 Files**

Cobalt, Xenon and Argon v8 SP0 support the import of AutoCAD DWG\DXF 2007 files through the Import dialogue window in the **File>Import**. DWG/DXF 2008 is included in v8 SP1. If DWG/DXF 2008 is not available in the Import dialog box, use **Help>Check Web for Update** to download the latest build.

---

**v8**

Tech Tip:

Using the AutoCAD 2000 export in Cobalt, Xenon and Argon exports all information necessary for AutoCAD 2002-2008 to properly open the file.
Escape Key Enhancement

The escape key functionality is enhanced to deselect both an object and a tool and objects.

Tap the Escape key the first time to deselect an object, such as this line.

Tap it the second time to deselect the current tool returning to the Select tool.
Design Explorer

Feature Tree

The Design Explorer Feature Tree displays the most recent items at the top of the list. Think of stacking new items or features on top of old ones.

In/Out/History Links

Notice the numbers in brackets [ ] after each feature in the tree such as:

LINE_43 [0/1/0]

These numbers represent links that go into and out of the feature, or that form a separate history. Out Links are always above In Links.
All Operations Listed
Every operation performed is now listed in the Feature Tree. Previously, commands such as Explode Edge or Offset Face were not listed in the part's history.

The material of a part is no longer considered a child link. It is now an In Link and therefore is listed at the top of the History Tree.

Right-click Menu
An option has been added to the Right-click Menu.

Open, listed at the top of the menu, accesses that history link as a top-level feature, as shown in the picture below.
When the opened link is selected, its place in the Feature Tree is also highlighted.
Appearance of Tolerances for Linear Dimensions

For greater ease of use, another option has been added to the linear dimension toolset and an existing option clarified. Now under Dimensions>Linear these options enable the tolerances to appear as follows:

The Edit Objects box was enhanced to override the + or - for either of these as needed.
Edit Window

Customize Surface Analyses Options via Edit Object

Real-Time Environment Maps

Cobalt, Xenon and Argon now feature real-time environment mapping in the Edit Objects window.

Environment maps provide interactive feedback on surface aesthetics. They are used to interactively evaluate curved surfaces in real-time. A real-time environment map is a way to simulate the reflections seen while examining a reflective model.

To use this feature:
1. Select an object for examination.
2. Activate the **Surface Analysis** icon in the **View** palette.


4. Choose any Shader Type and the corresponding attributes and values, then click OK.

5. When an object in the drawing area is selected and the Real-time Environment Map icon is clicked, one of the following Shader Types appear:
Wrapped Image

The graphic on the right appears without an environment. The graphic on the left uses the real-time environment map to mirror an applied surrounding environment of a sun room.
Plain

Applies a plain color to the object. Choose the color from the drop down menu and use the sliders to modify the color.

Zebra

Choose the Zebra thickness value and stripe orientation in the Attribute and Attribute Value fields. To make it easier to visualize the surface flow and transition between surfaces of tangent planes, use the Surface Match tool. After matching the planes the surfaces flow smoothly.
Curvature

To customize the curvature, check the option in the Edit Object dialog box and click the Edit button.

The Curvature Plot Dialog appears. Set the plot style, color and check whether or not to apply the settings only to selected objects. Press Recalculate to update the surface curvature analyses for the plot style selected. To update the surface curvature analyses for all the plot styles, press the Recalculate All button.
Draft Angle

To edit the draft angle, check the option in the Edit Objects window and click the Edit button.

The Draft Angle dialog box appears. Select the color and check whether or not to apply the settings only to the selected objects. Click the Recalculate or Recalculate All button.
**Enhanced Clipping Plane**
Clipping planes are enhanced with interactive visual clipping and sectioning.

**Using the Clip Plane**
1. To activate the enhanced clip plane, locate the cursor on the infinite plane and right-click to bring up the Context menu. Select *Use as Clip Plane*. Modify the settings as described in the following steps, then click Apply to activate them.
2. All objects are visually clipped and sectioned. The perpendicular arrow represents the normal, which indicates the direction of the clipped part of the unit.

3. Adjust the plane visually using the handles on the plane indicator. There are 3D handles on the corners, midpoints and center of the clip plane. Midpoint markers rotate the clip plane. Hold the SHIFT key to rotate with 45-degree steps.
Corner markers pan the plane along the normal. The central marker moves the clip plane to any location.

4. Edit the plane properties with the Edit Object dialog box. Double click the plane to open the Edit Objects. Use the Scale option to size the plane.

**Auto**

The diagonal of the clip plane is equal to the length of the diagonal of an imaginary bounding box of all the objects to be clipped.
5. Modify the color of the clip plane cut with the Section drop down menu.
Object Color  
Makes the section the same color as the object, thus the clipped part looks like the solid object as in the picture below.

Plane Color  
None  
Makes the section the same color as the plane. The section area will be transparent.
6. Set the transparency of the clip plane in the **View>Shade options** dialog.
7. The geometry tab of the Edit Object dialog box provides the following options:

Location
Sets the location of the plane origin.

Normal
Sets the direction of the normal.

Angle 1
Sets the turn angle along the X axis.

Angle 2
Sets the turn angle along the Y axis.

Apply
Activates edited settings.

Set the options and click the Apply button to activate the settings.
**Color per Face**

It is possible to apply different colors to each face of an object with the new Deep Select tool.

To apply a color to a face, use the Deep Select tool from the Selection tool palette, choose the face and designate the color from the Pen menu.

The Edit Object window shows only the color of the overall object without the changes made by the Deep Select.
Some materials adopt the color of the object faces if the Use Object Color check box is checked in the Render Material Settings dialog box.

**Picture 1:** An object has different colors on the faces.

**Pictures 2 and 3:** Materials adopt the color of the object faces with the Object Color option checked.

**New Options for Shade + Shortcut**

All six of the photo-realistic rendering preset styles plus any user-defined custom rendering styles are now added to the Shade Now Shortcut.

These are the same settings available in the Shade Options box accessed through **View>Shade Options**.

![Shade Options dialog box]

After designating the desired settings in the Shade Options box, quickly apply them to the model by using the **View>Shade Now** command or the **CTRL+T** (Windows) or **OPTION+T** (Mac) shortcut keys.
Right-click Popup Menu

The right-click pop-up menu features new options for object editing.

**Right Mouse Click on Surfaces**
Click the right mouse button on surfaces to copy the surfaces' history. This option was previously available for solids only.

Click the right mouse on a surface and select Copy History Tree from the pop-up menu. This places a historically accurate duplicate of the surface in the same location as the original.

Clicking the surface brings up the Ambiguity box, revealing two surfaces in the same location. The higher numbered surface is the new one.
**Save Entity As Symbol**
Any entity can be saved as a symbol using the right-click menu. The original (parent) object is not affected. The new symbol is added to the Layer Manager.

**Editing Common Properties on Multiple Objects**
The common properties of multiple objects can be modified via the right-click menu. The ambiguity dialog box appears if more than one item is clicked. Choose the All Selected option from the Pick Object dialog and the properties modified in the right-click pop-up menu apply to all the selected objects.

**New Right-click Menu Options**
The right-click menu now includes style, weight, color and pattern for easy access.
User Pen Styles

User Pen Styles are now available globally and not just per drawing. New pen styles are automatically saved in a PenStyles.ini file so they are available for all drawings once a new style is created.
**Specifying Pen Weight Units**

To specify a custom pen weight, go to **Pen>Weight>More**. In the enhanced dialog box enter the size and select the units of measure from the drop down menu.

![Object Pen Weight dialog box]

**Assigning Pen Properties to Layers**

Line styles can now be assigned to layers.

1. Click on the layer to activate. Right click on the layer to modify the line style.
2. Choose the **Allow Overrides** option from the context menu. All layers that are set to allow override appear in italics in the Design Explorer.
3. Go to **Pen>Style** and choose one of the patterns available.

![Design Explorer dialog box]

**Tip:**

Even if the preference settings are set to one type of unit, such as inches, in this dialog box the pen units can be set to a different unit of measure, such as millimeters, if desired.
4. The Allow Override option becomes checked in the right click menu and the style name is indicated below in the brackets.

The selected pen style will be the new default for that layer when active, for all future geometry, until another style is selected. A different pen style can be set for each layer as desired. It can be used only when the layer is active.
Tangent Circle Tool Enhancement

A new option added to the Tangent Circle tool flips the position of the circle once it is placed.

If there are alternative positions possible for the circle's placement, the program cycles through them by tapping the Ctrl (Windows) or Option (Mac) key.
General Transform Tools

Item vs. Faces

All of the Transformation tools, with the exception of the Alignment tool, now support the movement of individual faces in addition to entire items.

When one of these tools is selected, the Item/Faces buttons appear in the Message Line and the Message Line changes accordingly.

To transform or copy only certain faces of an object:

1. Select the appropriate transformation tool.
2. Click the Faces button in the Message Line.
3. Select the face or faces to transform. To copy press CTRL.
4. Select the beginning and ending reference points as directed by the Message Line.

After completing the action, while the object is still selected, enter new values in the Status Line fields to modify the face transformation. Press ENTER (Windows) or RETURN (Macintosh) to accept the new values.
**Enhanced Polar Duplicate Tool**

The **Polar Duplicate** tool has been enhanced to automatically duplicate multiple rings of objects saving time when creating patterns.

Three new options have been added to the Polar Duplicate dialog box to facilitate concentric rings.

- **Grid**
  - Fills the area of the pattern with the maximum amount of the features.

- **Rings**
  - Designates the number of concentric rings in a pattern.

- **Spacing**
  - Designates the spacing between the rings.
The data in the dialog box produces the result below with the Grid box checked. The result on the left has a rotation angle of 360°, where the result on the right changes the rotation angle to 120°.

The reference point has a significant meaning. Duplicates are created along the imaginary reference line, the line between the center of duplication origin and the reference point. The picture on the left shows the reference point in the center of the original object. The picture on the right shows the reference point specified on the top quadrant point of the original object.
**Spherical Duplicate Tool**

The **Transformation** tools palette now includes a **Spherical Duplicate** tool for items and faces. The **Spherical Duplicate** tool copies a selection of either items or faces in a sphere around a central point.

The number and location of duplicates are controlled through the Spherical Duplicate dialog box.

The dialog box contains the following options:

**Center X*, Y*, Z***  
Sets the X, Y and Z location for the center of the spherical array. Enter these values or click the location in the drawing area for the center.

**Axis Direction X*, Y*, Z***  
Sets the direction of the axis from which all the parallels will be calculated.
### General Transform Tools

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em><em>Prim Meridian X</em>, Y</em>, Z***</td>
<td>Sets the principal meridian which is the beginning point of calculating of location of all the other meridians.</td>
</tr>
<tr>
<td><strong>Vertical Number</strong></td>
<td>Sets the total number of faces or items in the plane, going through the axis of the sphere. Be sure to include the selected one in this total count.</td>
</tr>
<tr>
<td><strong>Vertical Angle</strong></td>
<td>Sets the angle between objects in the plane that goes through the axis of the sphere.</td>
</tr>
<tr>
<td><strong>Horizontal Number</strong></td>
<td>Sets the number of repetitions of the item or face in the horizontal plane along the specified axis of the sphere.</td>
</tr>
<tr>
<td><strong>Horizontal Angle</strong></td>
<td>Designates the angle by which the objects, specified in the Vertical Number and Vertical Angle, are twisted.</td>
</tr>
<tr>
<td><strong>Total Angle</strong></td>
<td>Defines the angle to which the duplication will be spread. A 360 degree angle spreads the features or items all along the sphere.</td>
</tr>
<tr>
<td><strong>Step Angle</strong></td>
<td>Sets the angle of the single step for which the feature/item will be duplicated.</td>
</tr>
<tr>
<td><strong>Associative Duplicates</strong></td>
<td>Creates each duplicate as an instance of the original.</td>
</tr>
</tbody>
</table>

The asterisk (*) indicates that the value is automatically filled in when dragging the pointer in the drawing area to indicate the offset or spacing.
Using the Spherical Duplicate Tool

1. Select the **Spherical Duplicate** tool.

2. Select Item or Faces from the Message Line.


4. Select the item or faces to duplicate. The dialog box appears.

5. Enter the values for axes location or click them with the pointer in the drawing area and the values will appear in the appropriate field.

6. Specify the number of features/items to be duplicated in vertical and horizontal directions and the angle for which the feature/item to be duplicated on the sphere's surface.

7. Click OK.

The face/item duplicates according to the specified values.

To modify the duplication, use Status Line entry fields, the Feature Tree, or double click the object to open Edit Object dialog box.
The **Spherical Duplicate** tool duplicates a face in accordance with the data set in the Spherical Duplicate dialogue box.
**Cylindrical Duplicate Tool**

The Transformation tools palette now includes a Cylindrical Duplicate tool for items and faces. The Cylindrical Duplicate tool copies a selection of either items or faces in a cylinder around a central axis.

The Cylindrical Duplicate tool has options found in the Message Line when the tool is selected:

These options set the axis of the cylinder.

The number and location of duplicates are controlled through the Cylindrical Duplicate dialog box.
The dialog box contains the following options:

- **Number**
  Sets the number of items/faces in the ring.

- **Center X*, Y*, Z***
  Sets the X, Y and Z location for the center of the cylindrical array. Enter these values or click the location in the drawing area for the center.

- **Rotation Angle***
  Designates the area which used for the duplication, measured in degrees.

- **Rings**
  Sets the number of circles of items/faces in the cylinder array.

- **Spacing**
  Specifies the distance between the rings.

- **Turn Angle**
  Designates the shift of the following ring relative to the previous around the axis.

- **Hexagon**
  Designates that each ring of the items/faces is located one-half twist relative to the previous one.

- **Associative Duplicates**
  Creates each duplicate as an instance of the original.

The asterisk (*) indicates that the value is automatically filled in when dragging the pointer in the drawing area to indicate the offset or spacing.

**Using the Cylindrical Duplicate Tool**

1. Select the **Cylindrical Duplicate** tool.

2. Select Item or Faces from the Message Line.

3. The Message Line reads: *Cylindrical Duplicate: Select items/faces to cylindrically duplicate.*

4. Select the item or faces to duplicate. The dialog box appears.

5. Enter the values for the center of the cylinder duplicate and number of the items/faces in a ring of the cylinder duplicate. It is possible to click in the drawing area to specify the center.

6. Fill in the Rotation and Rings along Axis fields as desired.

7. Click OK.

The duplication is performed reflecting the values specified in the Cylindrical Duplicate dialog box.
To modify the feature duplication, use the Status Line entry fields, the Feature Tree, or double click the feature to open Edit Object dialog box.

This graphic shows an object with a face to be duplicated with the **Cylinder Duplicate** tool.
The settings in the dialog box duplicate the features as in this picture.

This graphic shows the same features duplicated with the Hexagon option checked.
Wireframe Creation Tools

**Mid-point Line**

New **Mid-point Line** tool is added to **Lines** tool palette.

This tool creates the line object by line midpoint and line endpoint.

**Using the Mid-point Line Tool**

1. Select the **Mid-point Line** tool from **Line** tool palette. The Message Line reads: *Mid Point Line: Pick center point [Ctrl = Copy previous] (Windows) or [Option = Copy Previous] (Macintosh).*


3. Pick the end point of the line.

To copy this just-created line, hold down the CTRL (Windows) or the OPTION (Macintosh) key and click once in the drawing area to set the starting point. An identical line appears beginning at the point clicked on the current work plane.

The Status Line contains the X, Y, and Z coordinates of the beginning, the relative location of the end (delta X, delta Y and delta Z), the line length, and the angle from horizontal. Once a line is drawn, the Length field is active in the Status Line. Specify the end point for the region to stretch.

**Mid-point Line** object has two end control points and a mid control point. Move the end control point to change line length or/and angle from the horizontal.
The new Star Polygon tool is added to Polygon Tools palette. It creates stars as a set of lines and as a polygon.

This tool creates the Star Polygon object by star center, inside and outside vertexes.

Using the Star Polygon Tool

1. Select the Star Polygon tool from Polygon Tools palette. The Message Line reads: Star Polygon: Pick center of star polygon. [Ctrl = Copy previous] (Windows) or [Option = Copy Previous] (Macintosh).

2. The Status Line contains the Vertices field. Enter the desired number for the star polygon.


5. Pick the inside vertex. Press the SHIFT key to create a non-symmetric star polygon.

The Status Line contains the X, Y, and Z coordinates of the star center, inside and outside diameters of the star (D1 and D2), star vertices number.
Surface Editing Tools

Enhancements to the Curve/Surface Projection Tool

Two enhancements have been made to the Curve/Surface Projection tool.

Parametric Sketch

In addition to curves, a parametric sketch can now be directly selected for projection and imprinting onto a surface or solid.

Press the CTRL key while using the Curve/Surface Projection tool to imprint a sketch.

New To Entity/Face Option

The Curve/Surface Projection tool now supports projecting curves onto surfaces and solids. Select the Curve/Surface Projection tool from the Surface Utilities tool palette and these options appear in the Message Line:
Through

Projects a curve on a surface that intersects the entire object.

To Entity

Projects a curve where it first touches the object.
To Face

Projects a curve only on the specified face.

v8
The face of a part, rather than just the edges, may now be selected for a chamfer. Use the Ambiguity box to specify the edge or face when performing the operation.
**Flip Direction Option in Chamfer Tools**

A Flip Direction option is added to some of the chamfer tools. Swap chamfer values by tapping the Ctrl (Windows) or Option (Mac) key.

For example, using the Two Lengths Chamfer tool with values of 0.5 and 1.5 for Length 1 and Length 2 respectively, apply a chamfer to one edge of this cube.

Tap the Ctrl or Option key, and the values are reversed as they are applied to the cube.
**Twist Solid Tool**

The new **Twist Solid** tool is added to **Solids Editing** tool palette.

This tool adds angular twisting to a solid, surface or curved object.
Using the Twist Solid Tool:

1. Select the **Twist** tool from **Solids Editing** tool palette. The Message Line reads: *Twist Solid: Pick solid to twist.*

2. The Status Line contains the Start Angle and End Angle fields. Enter the desired values for the twist. Tab between data fields.

3. Pick the solid object to twist. The Message Line reads: *Twist Solid: Enter two points for twist axis.*

4. Specify the start point for the region to twist.

5. Specify the end point for the region to twist.

Two planes set perpendicular to the twisting axis through the specified points define the twist region. The Start Angle and End Angle values define the angle of rotation of relative to the initial state.

The Message Line contains a pull-down menu to specify a type of geometric continuity between twisted area of the object and non-twisted area. There are three options: G0 Slope, G1 Slope and G2 Slope.

The following images demonstrate the difference between G0, G1 and G2 modes.
**Stretch Solid Tool**

The **Stretch Solid** tool stretches a solid along an axis. When selecting the **Stretch Solid** tool, a drop down menu appears in the Message Line containing two options: **Match G0 Slope** and **Match G1 Slope**. These options specify the translations of the non-stretched portions of the body.

- **Match G0 Slope**
  Indicates that the portion of the body below the stretch's starting region retains its position.

- **Match G1 Slope**
  The entire body is translated along the stretch axis by the given distance before the stretch is performed.

Following images show the difference between G0 and G1 modes.
Using the Stretch Tool

1. Select the **Stretch** tool from **Solid Utility** tool palette. The Message Line reads: *Stretch Solid: Pick solid to stretch.*

2. Pick the solid object to stretch. The Message Line reads: *Stretch Solid: Enter two points for stretch region.*

3. The Status Line contains the Distance field. Enter the desired value for the stretch.

4. Specify the starting point for the region to stretch.

5. Specify the end point.

Two planes perpendicular to the stretch axis through the specified points define the region to stretch.

The Message Line contains a pull-down menu to specify the geometric continuity between the stretched area of the object and non-stretched area. There are two options: G0 Slope and G1 Slope.
Extrude, Cutout, Lathe, Protrude
Nonplanar Profiles
Profiles can now be extruded, cutout, lathed, protruded even when they are not on one plane.
Gaps Detected Enhancement

In v7SP1, new functionality has been added to assist in finding gaps in extruded profiles and fixing them. If gaps are detected, two warning messages appear. The first one says, "Gaps detected in profile. Would you like to examine gaps?"

Click No to ignore the gaps and continue.

Click Yes, and another message appears, stating "Gaps in profile are shown with red indicators. Use Undo to remove indicators. Hint: gaps can also be caused by duplicate or overlapping geometry in the profile."

Click OK to remove the message and view the profile with red Xs where gaps are detected. After noting the gaps, use Edit>Undo to clear the indicators or drag a selection box around them and press Delete. The indicators are created as geometric points, adding geometry to the drawing.
Enhanced Rib Tool

Cobalt’s Rib Solid tool has been enhanced to include several options. Previously, the Mid Line was the only extrusion available. Now when the Rib tool is selected from the Solids tool palette these options appear in the Message line.

One Side
Extrudes from one side or the other of the profile line using a negative or positive number to control both the thickness and the side.

Two Sides
Extrudes the distances specified for both directions from the profile line.

Mid Line
Extrudes an equal distance in both directions from the profile line.

Extend Rib Profiles
Automatically extends the rib to meet the corresponding faces of the related solid when the box is checked. If left unchecked the rib will only be as long as the profile line.
Vertex and Edge Options in the Local Move Tool

Two new options have been added to the Move Face tool allowing single edges or vertices to be moved in addition to whole faces. This is now called the Local Move tool.

To directly move an edge or vertex of a solid to a specified place, select the Local Move tool from the Local Face tool palette and then choose the option from the drop down menu in the Message Line.

Move Edge Option

To move a selected edge of a solid body to the desired position:

1. Choose the Edge option from the drop down menu of the Message Line.
2. Pick an edge of a solid to move.
3. Click two reference points.
4. The selected edge moves in accordance with the reference points specified.
Move Vertex Option

To move a vertex:

1. Choose the **Vertex** option from the drop down menu of the Message Line.
2. Pick a vertex to move and two reference points.
3. The vertex moves along the reference points.
4. The vertex moves as specified.

Enhanced Skinned Solid Tool

The Advanced Skin Options dialog box is now available by pressing CTRL while using the **Skinned Solid** tool. These options used to be available for surfaces only. (See the User Guide for details).
Profile Enhancement
Using the Context Menu it is now possible to add, remove or replace profiles or elements of a profile for the Extrude, Skin, Lathe, Cutout, Protrude, Boss and Hole tools.

In the picture below an element is added.
The element is replaced in the picture below.
Model to Sheet Enhancements

Use Layout Settings for Model to Sheet

The Model to Sheet command has an added option called Use layout setting. The dialog box has 5 combination boxes that change the pen style when doing a Model to Sheet. Now it is possible to have a layout with predefined pen and scale settings for each view and retain the values by checking the Use layout settings checkbox. When this box is checked, the pen style options are grayed out.
Renderings and WireframeHandled Separately inModel to Sheet Views

The Model to Sheet and the Drawing View Properties dialogue boxes handle rendered and wireframe views separately. During Model To Sheet creation and editing, properties in the Rendering drop down menu include these options:

- Flat
- Gouraud
- Phong
- Photo-rendered
- Photo-rendered (no Materials)

The Wireframe drop down menu includes:

- Precise Curves (Slower)
- PolyLines (Faster)

The Wireframe menu designates how hidden edges display in the final drawing.

When the Model to Sheet first displays, all views appear in the method selected. To change the display method for each view as desired (Cobalt and Xenon only):

1. Click on the view.
2. In the upper left corner of the view frame right click on the box and select Properties. The Draw View Properties dialog box appears.
3. In the drop down menus change the method as desired.
Below is a sheet with four views

Any number of photo-rendered views can be included in engineering drawings.
Optional Automatic View Scale Indicator

This new feature optionally adds a scale to the layout as a text element with the view names to reduce confusion and errors among different scaled views.

To automatically add a scale to a view:

1. Select the view.
2. Right click the box in the upper left of the view and select Properties.
3. Check the Draw Name and Draw Scale options from the Draw View Properties dialog box. Then click OK.

The sheet below shows two views noting the view type and scale rate. The name and scale are included by default for Auxiliary, Section and Detail Views.
Pan Tool for Drawing Views
To pan the view, activate the view, click the wheel button on the mouse or press the space button on the keyboard and left mouse button. The pan symbol appears and the drawing within the active view can be moved.
Photo-realistic Rendering

New Advanced Photo-realistic Rendering Options

The photo-realistic rendering features of Cobalt, Xenon and Argon are enhanced in v8 to include a number of new setting: Advanced Control of Antialiasing for Objects, Edges, Shadows and Reflections; Independent Control of Reflections and Refractions; and Custom Render Presets.

Use PhotoRender>Advanced Settings to bring up the Photo-realistic Render Settings dialog box to designate custom settings. User Settings are used only when selecting Render (User Settings) from the PhotoRender menu. Common Settings and Sunlight settings influence rendering when any other option from the PhotoRender menu is chosen.
Advanced settings include:

**Allow Shadows**
Enables or disables shadows.

**Anti-aliasing**
Enables or disables all forms of anti-aliasing. Checking this box accesses the advanced anti-aliasing settings including those for edges, shadows, reflections and texture quality. The default value is unchecked, meaning that no anti-aliasing is performed.

**Anti-aliasing of Edges**
Anti-aliases the edges of geometry when rendered. The default is unchecked. Note that if the overall Anti-aliasing box is not checked, then checking this will have no effect.

**Anti-aliasing of Shadows**
Anti-aliases the edges of shadows when rendered. Setting this provides the most complete form of anti-aliasing, including the edges of reflected or refracted geometry. Note that checking this will override all other anti-aliasing settings (except the overall Anti-aliasing control).

**Anti-aliasing of Reflections**
Anti-aliases reflected and refracted textures when rendered. The default value is unchecked. Note that if the overall Anti-aliasing box is unchecked, then modifying this will have no effect.

**Texture Quality**
When set to high, anti-aliasing is enabled for textures and material shaders which support anti-aliasing. The default setting is low, which means that no texture anti-aliasing takes place.

**Oversampling Level**
Sets the Oversampling Level which applies very simple anti-aliasing to the rendering if required. Setting a value greater than 1 results in oversampling of each pixel. The color of each pixel is sampled many times and then an average color calculated. There is a noticeable effect on rendering speed if this value is increased. The valid range is 1 to 16, the default being 1 with no oversampling performed. Note that if the Anti-aliasing box is unchecked, then modifying this value will have no effect. Also if Anti-alias Shadows is on, it overrides this setting.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transparency</td>
<td>Enables or disables transparency.</td>
</tr>
<tr>
<td>Reflections</td>
<td>Enables or disables ray-traced reflections.</td>
</tr>
<tr>
<td>Max Ray Bounces</td>
<td>Controls the number of ray trace bounces used during rendering. The smaller the number the faster ray tracing will be for complex scenes. If the value is set to be too low then effects, such as multiple reflections, may not be rendered correctly. Ashlar-Vellum recommends starting with the default setting of 6 and adjusting it from there.</td>
</tr>
<tr>
<td>Min Ray Contribution</td>
<td>Controls the minimum contribution made by a secondary ray (reflected, refracted or alpha ray) before it is ignored. A value of 5 means that if the traced ray would contribute less than 5 percent to the total illumination at the pixel of interest then its contribution is ignored.</td>
</tr>
<tr>
<td>Override Global Bounces</td>
<td>Enables or disables the following two controls. If checked it allows control of maximum reflections and refractions. If left unchecked then all ray depths are the same as Max Ray Bounces.</td>
</tr>
<tr>
<td>Max Reflections</td>
<td>Controls how many levels of reflection are considered during renders. The lower the number of reflections, the faster ray tracing will be for complex scenes. If the value is set to be too low then any multiple reflections may not be rendered correctly.</td>
</tr>
<tr>
<td>Max Refractions</td>
<td>Is the same as Max Reflections, but applies to refracted or alpha rays.</td>
</tr>
</tbody>
</table>

**Tech Note:**
The pre-set options accessed from the PhotoRender menu use a value of 10 for ray bounces, reflections and refractions.
**Custom Render Presets**

Advanced Settings can be changed as necessary. Go to *PhotoRender*\>**Advanced Settings**. In the Advanced Settings dialog box modify settings as desired, press the Save button, then type in a new name for this group of settings.

The new settings will be available in the Preset drop down menu of the Photo-realistic Render Settings dialog and also in the Shade Now option in the Shade Options dialog. The objects can be rendered only in the Render [User Settings] mode of the PhotoRender menu.
**Photo-realistic Environment Maps for Stills and Animations**

A shiny object in a real world scene will exhibit reflections on its surface. These relate to a phenomenon called specular reflection, which occurs when light energy on the surface is reflected immediately, without being absorbed by the material. There are two categories of specular reflections. The first is known as incoherent reflection and manifests itself as highlights. Highlights are specular reflections of light sources and appear as bright regions when they are reflected in a surface. The second category is known as coherent reflection, and appear as mirror-like reflections of other objects within the scene. An extreme example of this is a wall mirror, but the same property is exhibited by many types of surfaces, such as machined metals, chrome, and polished floors and tables.

In computer graphics, reflection mapping is an efficient method of simulating a complex mirroring surface using a predefined texture image. The texture is used to store the image of the environment surrounding the rendered object. There are several ways of storing the surrounding environment. The most common ones store a single texture containing the image of the surrounding as reflected on a mirrored ball.

Environment mapping is a method of quickly calculating reflections. It is similar to ray tracing, however, ray tracing is much more accurate since everything in the room must be modeled. Environment mapping, on the other hand, substitutes a picture so that items are reflected on the model for visual effect. Photo-realistic environment maps are a handy tool when the details of the reflection are less important.

*Referral:*
Real-time environment maps, as opposed to photo-realistic ones, are also available for surface analysis of objects. See page 9 for details.
Seven photo-realistic environment map styles are included in Cobalt, Xenon and Argon. They include:

**Cube**

A cubic environment map at infinite distance with six independent images.

**Fixed Cube**

A cubic environment map at a fixed distance and location from the model, composed of six images.

**Cross**

A cubic environment map at infinite distance using one composite image assembled in a photo editing program.

**Fixed Cross**

A cubic environment map at fixed distance and location using one composed image.

**Spherical**

A spherical environment map at infinite distance using one fisheye image of 180°.
Latlong

A panoramic environment map at infinite distance using a 360° panoramic image.

Using a Photo-realistic Environment Map

There are two ways to apply a photo-realistic environment map.

To apply a reflection map to a rendering:

1. Go to **Window>Render Library** and select Environment Map from the drop down menu of the Render Library dialogue box. Then specify the type of the environment map.
2. The system queries whether or not to apply an environment background.
3. Choose Yes for the environment box to appear around the object that reflects it.
   Choose No for the object to reflect the surrounding environment while the environment stays invisible.
4. Check the Use Environment Map option in the PhotoRender Menu.
5. Apply the environment map by choosing one of the first nine options from the PhotoRender Menu.

Alternatively:
1. Use the **PhotoRender>Edit Photorender Environment Map** command. The dialogue box appears.

2. Choose the type of the environment map from the drop down menu.
3. Select the image(s) for the environment map.
   For most environment map types only one image can be specified.
   If Cube is chosen, all the six image drop downs can be specified. Use the Browse option in the drop down menu to locate your own image.
   If Fixed Cube is chosen, all the six images, plus the center point and size of the environment map can be specified. Check Auto to let the program set the environment map parameters.

4. Click the Add to Render Library button to apply. Specify the name of the map to add to the render library and click OK.

5. After designating environment map settings click OK.

*Photo-realistic Tube and Area Lights for Stills and Animations*

Cobalt, Xenon and Argon v8 feature new photorealistic light settings for both tube and area lighting with the proper geometric pattern and color temperatures. These are accessed through the *Lights* palette in the Windows menu and include:

- Linear Tube Light
- Tube Light from Curve
- Rectangular Area Light
- Area Light from Selected Surface
Linear Tube Light

Use linear tube lights for fluorescent lighting effects. To create a tube light:

1. Use Window>Lights, choose the Linear Tube Light tool.

2. Activate the Create Solid Body option in the Message Line to be able to edit the source of light through the Edit Object dialog box.

3. Following the prompts in the Message Line, pick two points to specify the beginning and the end of the tube.

4. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.

The solid body of the light appears as a pipe in the Design Explorer and can be edited on the Geometry tab of the Edit Object dialog box.

The linear tube light symbol appears on the screen.
**Tube Light From Curve**

Use curved tube lights for neon lighting effects, specifying a light source along a curve.

1. Create a curve such as an arc, circle or spline, along which to create a light source.

2. Choose **Tube Light from Curve** in the **Lights** tool palette.

3. Activate the **Create Solid Body** option in the Message Line to edit the source of light through the Edit Object dialog box.

4. Following the prompts in the Message Line, pick the curve created.

5. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.

The symbol for this light source appears on the screen.
Rectangular Area Light

Area lights create a lovely diffused light. Simply create a rectangle and have it glow as a light source. Use these lights in stills and animations for improved realism for photo-realistic renderings.

To illuminate the object with the rectangular area light:

1. Select **Rectangular Area Light** tool from **Lights** palette in the Window menu.
2. Following the prompts in the Message Line, click three points to build the rectangular area to be the light source.
3. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.

   The rectangular light symbol appears on the screen.
Area Light from Selected Surface

This kind of light emanates from a glowing surface achieving a perfect photo-realistic effect for stills and animations.

1. Create any surface object.
2. Choose **Area Light from Selected Surface** in the **Lights** tool palette.
3. Following the prompts in the Message Line, pick the surface.
4. In the Edit Objects dialog box, check the Visualize Light option to show the light source while rendering.
   The area light source symbol appears.
Photo-realistic Sunlight for Stills and Animations

Cobalt, Xenon and Argon v8 feature photo-realistic sunlight settings for stills and animations using location, date and time. This makes it easy to do light and shadow studies for architectural designs.

1. Select **PhotoRender>Edit Sunlight**. The Sunlight Settings dialog box appears.

2. Enter a city from the list for the longitude and latitude to show automatically, or click Add to include a custom location using longitude and latitude, and the time zone plus or minus from Greenwich Mean Time.
3. Click Orientation and in the Sunlight Orientation box set the position of the sunlight by North and East vectors.

4. Enter the desired date and time. This specifies the intensity of the sunlight automatically.

When set to automatic mode, the sunlight color is determined by the coordinates and the date and time. In the Custom mode, it is possible to set any plain color. In the By Temperature mode, the sunlight color is determined by the color temperature. The temperature rate can be varied within 150 K and 20,000 K.

Intensity Settings specify the exact amount of the sunlight that illuminates the square unit of the area. Auto uses the parameters specified in the Coordinates, Date/Time, and Sun Color. The Custom option provides the Intensity Units drop down menu with Lux, Kilolux and Footcandle options where Lux = Lumen/m², Kilolux = 1000 Lux, Footcandle = Lumen/in².
Sky Type Settings designate the Sky Parameters which also influence the sunlight intensity.

**Cloudiness**
Is set between 0 and 0.999. Either use the slider or input field to specify the level of cloudiness between Clear, Intermediate and Overcast. The greater the value the more overcast the sky.

**Pressure**
Set it to Low, Normal or High with the slider or input the value between 0 and 2500 in the field.

**Alpha**
Specifies the type of the locality. Use the slider to choose between Mountain, Rural and Maritime locality or set the value between 0 and 2 in the input field.

**AOD**
Specifies the type of the atmosphere. Use the slider to choose between No Aerosol, Clear and Dusty atmosphere or enter the value between 0 and 1 in the input field.

The rendering results will reflect the correct position of the sun at that time and season of the year.

If the Draw Compass option is checked, the compass symbol appears in the left bottom corner of the screen. The compass symbol sets the orientation of the scene.
Interleaved Wireframe Geometry

It is possible to interleave 3D wireframe geometry in photo-renderings including all types of edges, curves, dimensions and text.

To enable interleaved wireframe geometry:

1. Check the Interleave Wireframe Geometry option in the PhotoRender command menu or in the Photorealistic Render Settings window.
2. Select the Interleave Wireframe Settings option in the PhotoRender command menu or press the Edit button next to the Interleave Wireframe Geometry option in the Photo-realistic Render Settings dialog.

3. The Interleave Wireframe Settings dialog box appears.

4. In this window separately turn On/Off rendering for wireframe geometry and object edges (Render Wireframe and Render Edges check-boxes). Also set color and weight properties for wireframe rendering. If the Use Common Line Weight option is checked then PhotoRender uses the selected weight for all wireframe objects rendering. Otherwise PhotoRender uses object weight for rendering. This box also sets rendering color options by checking the Use Common Line Color check-box and specifying a color.
**Custom Decals From Alpha Images**

It is possible to create custom decals. To accomplish this:

1. Go to *Window>Render Library*.

2. Right-click in the gray space of the Render Library dialog box to bring up the context menu and choose the Create New option. The Add Decal dialog box appears.
3. Fill in the Name and Category fields or choose the Category from the drop down menu on the right.

4. Choose Image from the Masking drop down menu.

5. Specify the image file name from the Image drop down menu or browse the system.
   
   To browse the image, navigate to the file location in the Open window, select the file and press Open. The system confirms that the file has been successfully copied. Click OK in the window. Also click OK in the Add Decal dialog.

6. The custom decal is created with the desired file. The newly created decal can be used in the same way as all the other decals from the library.
Decal Material Options

Materials can be applied to decals as well as to the objects. The picture shows a label on a bottle, which was applied as a decal, and a material was applied to the decal. So the decal has its own material options.

To edit the decal material, right click on the Material in the Design Explorer's Feature Tree.
Displacement and Reflectance options are available for decal materials in the Render Material Settings.
**Material per Face**
Different materials may be applied to each face using the *Deep Select* tool.

To apply a material to a face:
1. Select *Deep Select* tool, choose the face and designate the material from the *Window>Render Library* menu.
2. Right-click on the material and choose Apply to Solid Face(s).
3. Alternatively, choose the material from the Render Library menu, right-click it and select Apply to Solid Face(s) from the context menu. Then choose the face of the solid. The material is applied. Render the object to see the changes.
The material for each face appears in the Design Explorer as a ball and can be edited.

Materials per Face are also editable through the Edit Objects box. Turn on or off the material under the Material Faces tab.
Accelerated Phong and Gouraud Shading Options

Faster rendering options using Phone and Gouraud shading are now available for animations when photo-realism is not required. This is a great way to quickly verify camera paths and check other details before committing to a long photo-realistic rendering session. These quick shading options support render to file, fly-by, walk-through and path animations.

Fast Shading with Render to File

To use these shading options when rendering to a file, go to PhotoRender>Render to File and select one from Render Mode dropdown.
Fast Shading with Animations

To use these options when creating a walk-through, fly-by or path animation, choose the desired animation type from the appropriate Animation menu. After picking the curve for the camera eye path and reference point, a dialogue box appears providing a place to specify the mode in the drop-down menu.
**Real Time Photo-realistic Material Changes Displayed in the Edit Window**

Check the Scene Preview box in the Render Material Settings dialogue box to view material setting changes in real time.
Variables and equations are now referenced within Cobalt in the Edit Object box and in the Status Line. The Variables/Equations dialog box is accessed by Window>Equations.
Nested Equations

Equations can now reference other equations within Cobalt for more robust equation-driven parametrics. The results of one equation can be used in other equations.

Conditional Equations

Cobalt’s parametrics now contain equations for more complex and intelligent geometric constraints. This enables adding if-then-else statements to the parametric constraints bounding the upper and lower limits of geometry.

For example, a sketch has the dimensions: D2+D1x3.

If the maximum constraint of these dimensions is 20 and the minimum constraint is 1, then a conditional equation could be written:

If (D1x3>=20;20; If (D1x3<=1;1;D1x3))

This bounds the dimension at 1 and 20.

Logical Operations

Logical operations include AND, OR, NOT, <, >, <=, >=, and =.

Results of logical operations are 1.0 or 0.0.
Conditional Equations

Conditional equations include:

\[
\text{IF (condition; exp1; exp2)}
\]

This means that if [condition] is true (is not equal to zero) then expression exp1 will be used, else exp2.

Priority of Operations

1. ( )
2. NOT, unary +, unary -
3. \(^\text{power}\)
4. *, /, %
5. +, -
6. <, >, <=, >=
7. =
8. \(\text{AND}\)
9. \(\text{OR}\)
Export and Import

**New Format and Software Tabs**

New tabs have been added to the Import and Export dialog boxes making it easier to select the correct format for file translation. Click the tabs to switch between the lists of formats or software.

The Formats tab contains a list of specific file types.

The Software tab allows the program name to be chosen instead of a cryptic file extension.
Batch Convert Tool

The new Convert command in the File menu converts entire folders of files from one type to another by automating the import or export process. To use the command:

1. Create two new folders on your computer. One will host all of the source files that will be converted. The other will receive the converted files.

2. Place all files to be converted in one batch in one of the folders created in step 1.


4. In the Convert dialog box indicate the input and output file types along with any options available. Activate the Batch check box and click OK.

5. In the first dialog box navigate to the new folder containing the files to convert. Click OK.

6. In the second dialog box navigate to the destination folder and click OK.

Tech Note:
For a complete discussion on file translation options refer to the chapter on Importing & Exporting of the Designer Elements 3D Modeling User Guide
Creating a Multi-sheet PDF from within the Software

Ashlar-Vellum’s built-in PDF writer has several advantages over printing to PDF. From within Cobalt, Xenon and Argon v8 it is possible to create multi-sheet vector PDFs drawn from multiple models in the same file and embed the source files or translations directly in the PDF.

Everything for an entire project can be emailed, displayed and archived. Use Adobe Acrobat to further enhance the file, inserting and replacing pages, commenting and marking changes or tracking revisions.

The create a PDF of an open Cobalt, Xenon or Argon file from within the software:

1. Choose File>Export.
2. Under the Formats tab, select PDF from the Export Type list.
3. Click Check Attach Source file to include the source file with the PDF.
4. Click Selected Only to export only those entities selected. Also choose Multi File if one entity per file is necessary for later importing into other types of software.

Tech Note:
PDF page size is controlled by the print layout settings and paper selection.
5. Click the Advanced button for the PDF options box to display.

6. Select which layers will appear on which pages of the PDF. Add and delete pages as necessary. If layers are not specifically designated, all visible layers are exported to one page of the PDF by default.

7. Designate page size and margin settings. For standard and custom page sizes the margins are measured inwards from the strictly defined page size. Geometry is inscribed within the remaining area. Using Auto Fit, the page size expands so that all entities fit on the page.

8. To attach additional files to the PDF, click Add then navigate to the file. Click OK to close the Advanced settings box.

9. Click Add Converted to export the same file in any other format and to attach it to the PDF.
10. Click OK again to open the Save As dialog box and enter the name and location to save the PDF. When the PDF is opened in a viewer such as Adobe Reader or Acrobat, each page is shown as designated.
**New Real-time Display of 2D Images in 3 Dimensions**

Hand sketches, photographs and other 2D images can be imported and displayed in 3D. This makes it significantly easier to trace over the sketches to create a 3D model. These images can be oriented in any direction and viewed from any perspective regardless of the work plane.

Use *File>Import* or simply paste the image. The bitmap comes in on the current work plane. Use the Trackball to view the images from all directions.
**Enhanced Support for Bitmap Images**

It is now easier to import and export bitmapped images in Cobalt, Xenon and Argon.

1. Simply use **File>Export** or **File>Import** as necessary.

2. In the appropriate dialog box, select the Formats tab and click on file type to translate, or select Software and click on the appropriate program.

3. Specify necessary options.

**Import Options**

- **Import the Image Center**
  - The center of the target file is set in the origin of the drawing area.

- **To the Work Plane Origin**
  - Imports the image to the work plane origin.

**Export Options**

- **View Area**
  - Check this box to export the current view only. If left unchecked the software will Zoom All and capture everything visible.

- **Ignore Background**
  - Tells the software to ignore any background color or gradient.

4. Click OK and the file is saved in the location and in the format specified.
Opening Password Protected DWG Files

The password protection in AutoCad files is supported in Cobalt, Xenon and Argon under the Windows operating system only. To open a password protected file:

1. Go to File>Import.
2. Choose DWG or DXF formats in the Import dialog box and click OK.
3. Navigate to the place where the file is located with the Open window and click Open button.
4. Input the password in the Enter Password Dialog box and click OK.

5. The drawing opens in the Cobalt window.
Preference Setting Enhancements

Several new settings have been added to Preferences. The following paragraphs discuss the advanced control options added to version 7.

**Factory Setting**

Clicking the Factory button in Preferences resets the program to the actual factory defaults for all Preferences, not just the current Preference pane.
Gradient Color of Background

Upon opening v7 SP1 the gradient color of the drawing screen appears as default. To turn it off choose *File* > *Preferences*, then select the *Colors* category.

There are two color choices for background and a checkmark labeled Gradient. Change background color here or uncheck the gradient checkbox to have the background look like it did in previous versions.
Copy as Instance

A new category called Copying is available in Preference. This dialogue box controls what happens when selecting a part and copying it by dragging and holding the Ctrl key on Windows or the Option key on Mac. Optionally, choose to create ACIS entity copies, which create copies of the original without any history, or choose to create instances of the original, which share the original part's history. Any changes made to the original, flow through to the instance part. Under the Object Type pull down option, designate different behaviors for surfaces and solids.
**File Open Times**

The Filing category now has a selection for ACIS Check on Open. Unselected, Cobalt opens files as it did in v6 without checking ACIS data within the file resulting in faster opening times. When selected, the application checks every entity containing ACIS data and if errors are found, such as unresolved links, attempts to fix those errors, thus taking more time to open.
**Select**

Two options are added to the Select category box. These settings control the way an object appears when it is selected.

**Wire Weight**

Select a curve and the line weight of that curve is increased according to the setting in the drop down box. The weight is specified in pixels. Choose between zero, which does not increase the weight when selected, and four, which increases the selected line weight by four pixels.

**Transparency**

Select a surface or solid object and the surface or solid becomes transparent. The Transparency slider controls how transparent the object becomes. A value of zero means no transparency is added to the selected object. A value of 100 means the selected object becomes fully transparent, showing only the edges.
The SpaceMouse Preferences control the interaction for all 3Dconnexion motion control devices including the SpaceMouse, SpacePilot, SpaceBall and Space Traveler. The intuitive reaction of individual users to the controller's operation varies widely, so optional settings are provided.

**Enable SpaceMouse**
Check this box to enable interaction between Ashlar-Vellum programs and the SpaceMouse.

**Invert Rotation**
Check this box to invert the SpaceMouse rotation vector, altering the default rotation behavior of the scene with respect to the SpaceMouse motion controller.

**Invert Zoom**
Check here to invert the SpaceMouse zoom vector, changing the behavior of the motion controller with respect to the scene.

**Invert X Pan**
When set, the behavior of the SpaceMouse X motion component vector is inverted with respect to the scene.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invert Y Pan</td>
<td>When checked, the behavior of the SpaceMouse Y motion component vector is inverted with respect to the scene.</td>
</tr>
<tr>
<td>Orbital Sensitivity</td>
<td>The Orbital Sensitivity slider allows you to select the sensitivity of the Ashlar-Vellum programs to the orbital input from the SpaceMouse motion controller. Zero disables the orbital input. Selecting a larger value increases sensitivity, requiring less physical motion on the motion controller to achieve scene changes.</td>
</tr>
<tr>
<td>Pan Sensitivity</td>
<td>The Pan Sensitivity slider determines how sensitive the Ashlar-Vellum programs are to the pan input from the SpaceMouse motion controller. Zero disables the pan input (X and Y). A larger value increases sensitivity, requiring less physical motion on the SpaceMouse to achieve scene changes.</td>
</tr>
<tr>
<td>Zoom Sensitivity</td>
<td>The Zoom Sensitivity slider lets you set how sensitive the Ashlar-Vellum programs are to the zoom input from the SpaceMouse motion controller. Zero disables the zoom input. Selecting a larger value increases sensitivity for physical motion of the SpaceMouse to achieve scene changes.</td>
</tr>
</tbody>
</table>
**3Dconnexion SpaceMouse Information**

**Working with the Motion Controller in 3D Applications**

**Pan**
Pull up and push down to move the model vertically.
Move left and right, keeping the controller head parallel with the work surface.

**Rotate**
Tilt the controller head left and right or forward and backward to rotate accordingly (X-Z axis).

**Zoom**
Push forward or pull backwards keeping the controller head parallel with the work surface.

**Rotate**
Twist clockwise and counterclockwise to rotate the model accordingly (Y axis).

Several new settings have been added to Preferences. The following paragraphs discuss the advanced control options added to version 8.
**User-definable Interface Skins**

Choose the look of the user interface using the Skins page of the Preference settings.

![Preferences settings](image)

**Skin:** Select the color theme desired.

**Icons:** Select the icon style.

<table>
<thead>
<tr>
<th></th>
<th>Classic</th>
<th>Modern</th>
</tr>
</thead>
<tbody>
<tr>
<td>Classic</td>
<td><img src="image" alt="Classic Classic" /></td>
<td><img src="image" alt="Classic Modern" /></td>
</tr>
<tr>
<td>Mac</td>
<td><img src="image" alt="Mac Classic" /></td>
<td><img src="image" alt="Mac Modern" /></td>
</tr>
<tr>
<td>Metallic</td>
<td><img src="image" alt="Metallic Classic" /></td>
<td><img src="image" alt="Metallic Modern" /></td>
</tr>
<tr>
<td>Win</td>
<td><img src="image" alt="Win Classic" /></td>
<td><img src="image" alt="Win Modern" /></td>
</tr>
</tbody>
</table>

**Pressing Effect:** Check this box for the selected icon to appear as a pressed button.
**Restore Default Palettes**

Clicking the Restore Palettes button on the General page of the Preferences dialog box is a fast way of moving all palettes back to their factory default position no matter what their position on the screen.

If palettes are out of the drawing area, go *Windows>Organize Palettes* to show them in the drawing area.
File Paths

The Paths page is added to the Preferences dialog box. This page is used mostly by system administrators and Ashlar-Vellum tech support specialists.

It is useful for workgroups to set up a custom network folder for the PhotoRender, BOM and Layout libraries.

It is also a useful tool for allowing others in the group to have access to common data. For example, if a user creates a new material or adds a texture, this can be exported to the Custom Network Folder for use by others without copying it to each local machine.

The Application Installation Folder, Default Network Folder (if used by default by the operating system), All Users Folder, and Current User Folder show the automatically generated paths. Custom Network Folder is created by the system administrator and can be used by all the users of the local network.

Tech Note:
Write-permission is required for destination directories.
Cobalt, Xenon and Argon feature a new installation program to quickly check the website for newly available updates. Using this feature under Help>Check Web for Updates... downloads and installs just the update, not the entire program.

This method keeps in place:
- Designated Preference settings.
- Current registration codes.
- User serial numbers.

It is recommended that this feature be used at least once a month with current software to be sure that the latest build of the major version number is being used.
Automated Support Ticket Preparation

To receive the assistance from our technical support experts, submit a ticket via email directly from your system. The email will automatically capture your product and system information, but you MUST include the following within the body of the email:

1. Tell us exactly what the difficulty is.
2. Attach any files or screen captures to help us understand the issue.
3. Include ALL contact information including an alternate email address, your cell phone and desk phone. Our support team does not have regular access to your sales file.
4. Include a subject line descriptive of the problem.
5. Make sure that you use your actual mail client.
Items Removed in v7

Several items were removed in the v7 sp0 upgrade.

**Pro/E Granite Translator (Windows Only)**

The Granite option has been removed from the File Import and Export dialogs because all Wildfire versions of Pro/E contain SAT file support, the preferred method for translating files between Pro/E and the Designer Elements 3D modeling programs.

**Viewpoint Media**

The 3D Web Publish choice has been removed from the File menu, as well as the Viewpoint Media option from the File Export dialog because it was discovered that the Viewpoint Toolbar (installed when the Viewpoint Reader was installed) contained spyware.

**Memory Readout (Macintosh Only)**

The Memory Readout was removed from the Macintosh versions due to lack of accuracy in providing a true memory usage picture.