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User Guide Documentation
This User Guide section of the manual is written for both Windows 98/NT/2000/Me/
Xp and Power Macintosh platforms. Before using this User Guide section, however, 
you will need to install your Designer Elements 3D modeling program (Cobalt™, 
Xenon™ and Argon™). Instructions and System Requirements are contained in the 
Getting Started manual. This manual is divided into sections which group chapters 
according to the topic. Each chapter provides information about tools, commands 
and other features.

Menus and Submenus
As is standard for all programs, Ashlar’s Designer Elements 3D modeling programs 
provide menus and submenus for choosing commands and performing other oper-
ations.

Choosing Commands
As you proceed through the manual, you will be directed to choose commands 
contained in submenus of other menus, like the pull down menu. For example, you 
might be asked to select Lock in the Group submenu of the Layout menu. That 
appears in this manual as Layout>Group>Lock.

Margin Notes
Your Designer Elements 3D program includes margin notes that provide you with 
information that may help you use this program. There are three types of margin 
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notes: Tip, Tech Note and Referral. These notes are given special treatment so that 
you can instantly recognize their significance and locate them for future reference.

Tip
A tip provides instructions for getting the most out of this Designer Elements pro-
gram. Tips may show you how to speed up an operation or how to perform some 
timesaving drawing technique.

Tech Note
A technical note provides additional technical information that may help when 
using a tool.

Referral
A referral directs you to related information contained somewhere else in the man-
ual for the particular topic being addressed.

Style Conventions
This manual uses various style conventions which highlight certain terms or 
phrases. The list below includes and explanation and an example in parentheses. 
The conventions are as follows:

Bold Tool palette names (Light palette); Tool names 
(Single Line tool); Keyboard-entered text; Defini-
tion terms (as shown in these style conventions)

Italic Terms used for the first time in a chapter; (Iso 
Lines); Drafting Assistant notations (midpoint); tool 
and dialog box options (Angle box); book refer-
ences (User Guide); Message Line directions (Single 
Line: Pick the beginning point.); margin note head-
ings (Tip); menu commands (Zoom Previous); file-
names (prefs.ini); stand alone extensions (.dwg); 
directory names; drawing names

Bold and Italic Command series (Layout>Group>Lock)

ALL CAPITALS Key names on the keyboard (ENTER, RETURN)

Title Capitalization Dialog box names (Edit Objects); menu names 
(Pen menu); special Vellum phrases (the Drafting 
Assistant)
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all lower case File names (prefs.ini); stand-alone file extensions 
(.dwg)

Terminology
For those of you new to surface and solids modeling, there are many terms or 
phrases that might be unfamiliar to you or used differently from your experience. 
These terms are defined the first time they are used in the manual as well as in the 
Glossary.

Some important terms include:

Curves   Refer to all lines, arcs, ellipses, conics, circles, 
splines and polygons created using one of the 
wireframe tools.

Instance Refers to an object that's moved to or placed in a 
different location after performing an operation on 
it. If you create a solid, add a blend and move it, 
the solid is now an instance. The original is still 
located in the previous position although it is not 
displayed. If you create a master symbol, an 
instance occurs when you place the symbol in 
your drawing. An instance is associative to the 
original geometry. Any change made to the origi-
nal is reflected in the instance (Cobalt™ and 
Xenon™ only). If you copy and pasted the object, 
the associativity is broken.

Parent/child Refers to objects that are related to each other in 
such a way that changing one (the parent) affects 
the other (the child). This is an important feature 
in Cobalt™ and Xenon™, Argon™ does not have 
this functionality. This associativity works much 
the same way Vellum 3D or Vellum Solids worked 
with dimensioning objects and editing. When you 
change an object in Vellum, the dimension 
changes. Cobalt™ and Xenon™ have taken this 
idea to a higher level involving geometry. After 
creating a curve, extruding and then filleting it, 
you can go back to the first curve and edit it and 
the entire object adjusts. Cobalt™ and Xenon™ 
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Referral:

Specific page information 
on a particular tool or com-
mand can be found in the 
index.
have the intelligence to remember the relationship 
between the parent curve and all other operations 
performed on the resulting object.

Using the Mouse
The mouse is your communication device; you use it to tell the computer what you 
want to do. Use the mouse to indicate locations, choose commands, select tools 
and construct objects.

This manual uses the following terms for mouse activities:

Pointer An arrow or any other graphic symbol that allows 
selection or creation of an object. Move the pointer 
to point to a command or an object on the screen. 
Depending on its location, the pointer is an arrow 
or may look like the current tool.

  

To move the pointer, move the mouse on the 
mouse pad. 

Point Move the mouse until the pointer is over the item 
you want.

Press Press and hold down the mouse button.

Click Quickly press and release the mouse button once.

Double-click Click the mouse button twice, quickly in succes-
sion.

Drag Press and hold down the mouse button, move the 
mouse, then release the mouse button.

Chapter Breakdown
The chapters are grouped into nine sections dealing with a specific area.

Sections
1. Overview Contains chapters that introduce you to some basic 

features of your Designer Elements 3D modeling 

Arrow Pointer Selection Arrow Center-Point Circle
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program, including the program Window, the 
Drafting Assistant and information on selecting 
objects.

2. Setting the Environment Contains chapters on pen and preference settings 
and drawing techniques.

3. Wireframe Modeling This section contains chapters on using such curve 
tools as lines, arcs, circles, splines, polygons, etc.

4.Surface Modeling Contains an introduction to surface modeling and 
information about surface modeling tools such as 3 
Point Mesh, Mesh Curve, Infinite Plane, Skin, Net, 
Tube, Tangent, etc.

5. Solids Modeling Contains an introduction to solids modeling and 
information on such solids modeling tools as the 
Sphere Primitive, Block Primitive, Cylinder Primi-
tive, Lathe Solid, Pipe Solid, Blend Solid, Hole, 
Boss, Protruded Feature, etc.

6. Editing Contains tools and commands for editing curves, 
surfaces and solids, including such tools as 2 Entity 
Fillet, Simple Trim, Connect Curve, Plane Surface 
Intersection, Boolean Surface, Subtract Solid, Shell 
Solid, Taper Solid, Deform Face, etc.

7. Adding Details This section includes information on text, dimen-
sions, patterns and fills, crosshatching and sym-
bols.

8. Drawing Display Contains information on viewing your geometry, 
layers, planes and rendering.

9. Documents Contains information on file management, import-
ing, exporting, page setup and producing produc-
tion drawings.

Appendices
Operators Describes all operators accepted by the data fields.
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Chapter Breakdown
Special Characters Lists all special characters not directly available 
from the keyboard and symbols that you can use 
in this Designer Elements program.

DXF/DWG Translator Includes notes to help the user in successful .dxf/
.dwg translation.

IGES Translator Includes notes to help the user in successful .igs 
translation.

Short Cuts Contains a list of the default Short Cuts

Spline Text Files Provides instructions for creating spline text files to 
import.

Shader Attribute Definitions Contains the definitions of shader attributes used 
when using the advanced shader rendering capa-
bilities.

Other
Glossary Defines terminology used in CAD drafting and in 

this Designer Elements program.

Index List this Designer Elements program tools, features 
and actions and their page location.

Tips Contains additional tips for using this Designer Ele-
ments program.

Graphics
Most of the graphics in the manuals apply to both platforms. In those instances that 
require a platform and software reference, a Windows graphic is used. When neces-
sary, both Windows and Macintosh graphics are included.

On-Line Help
Designer Elements program Help (Windows only) provides a complete description 
of the program’s many features, commands, and tools. The Help index is organized 
by menus and tools. The Macintosh Help uses the UserGuide PDF file that was 
installed when you installed the application.



     
First Look
This chapter describes the “first look” components of your Designer Elements pro-
gram. A brief overview of useful features may be all you need to know if you are 
familiar with CAD software. The following topics are covered:

• Parts of the your Designer Elements program Window

• Menu Bar, including the dialog boxes

For more information about standard elements such as menus, scroll bars, File 
menu commands, and dialog boxes, refer to the Windows or Macintosh User’s 
Guide that came with your computer.

Parts of the Designer Elements Window
When you start your Designer Elements program, the following window appears. 
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Title Bar Includes the title of the active document and but-
tons for controlling the window including boxes 
for zooming and closing the program.   

Menu Bar Contains the Designer Elements program menus of 
commands and settings. You can make choices 
from the menus with the mouse or by using spe-
cial key combinations.

Tool Palette Contains drawing and editing tool icons you will 
use for constructing, editing and annotating geom-
etry. This is the most basic tool palette. The Sur-
face tool palette and Solids tool palette are not 
automatically displayed on start up, unless speci-
fied as such through Preferences. See Chapter 6.

Tool Tip As you hold your cursor over one of the tools, a 
brief description of the tool is displayed. The Tool 
Tips function can be activated or deactivated by 
choosing File>Preferences>General. If you 
assign a short cut to a tool, the short cut displays 
with the tip.

Pointer Shows the active position on the screen. For wire-
frame tools, when the pointer is in the drawing 
area, its shape represents the current tool.

Axis Displays the current view orientation of the x, y 
and z axis in the center of your screen.

Triad Displays the current view orientation of the x, y 
and z axis with a representation of the current 
work plane.

Location Indicator Shows the x, y and z coordinates of the pointer 
location at the top of your drawing area.

Message Line Displays the name of the current tool and step-by-
step instructions for using the tool. For some tools, 
the Message Line includes an additional subpalette.

Drawing Area Consists of multiple layers where you construct 
and annotate geometry. 
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Status Line Shows the coordinate location and other geometric 
characteristics of the current construction based on 
the World coordinate system.

Coordinate System Axis Shows the current coordinate system. You can 
choose between the default global or world coor-
dinate system and a user-defined coordinate sys-
tem.

Scroll Bars Allow you to move around a drawing so you can 
see different sections of it through the Designer 
Elements program window. The scroll buttons 
allow you to move one line at a time.

Work Layer Indicator Displays the name of the current layer and pro-
vides a menu for changing the work layer, creating 
a new layer and accessing the Layer Manager.

Memory Indicator Displays two numbers. The first is the RAM avail-
able on your system and the second is the amount 
of virtual memory available (RAM plus swap).

Title Bar
The Title Bar includes the name of the current document, the Control Menu, Mini-
mize and Maximize/Restore buttons (Windows) or the Close and Zoom boxes (Mac-
intosh).

Windows

Control Menu Button Allows you to close, move, and change the size of 
the window. This button is available on all win-
dows and many dialog boxes.

Double-clicking this button closes the window 
without displaying the menu. If you want to 
choose a different option from the Control menu, 

Control Menu Button

Close Button
Maximize Button

Minimize Button
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click the button once to display the menu and then 
make your choice.

Minimize Button Reduces the Vellum window to a task bar near the 
lower-left corner of the screen. This action does 
not close or save the document, it only shrinks the 
window to a task bar so you can perform some 
other Windows-related task. To display the win-
dow again, click once on the same button.

Maximize/Restore Displays the window, full or partial screen. Once 
the window appears full screen, click the button 
again to restore it to its previous size.

Macintosh

WindowShade This WindowShade contains the Close Box and 
Zoom Box. You can set your computer to allow 
you to reduce your file to just the WindowShade. 
See the User Guide that came with your computer.

Close Box Closes the window when you click on it. If you 
attempt to close the window without saving your 
work, your Designer Elements program displays a 
message so you can decide whether to save or not.

Zoom Box Toggles the window size between the previous 
size and full size.

Zoom BoxClose Box WindowShade
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Tech Note:

Macintosh only: If you are 
using more than one monitor 
with your computer, you can 
save your palettes to the 
other monitor.
Tool Palette
A tool palette is a group of tool icons that represent tools 
for drawing, editing and annotating geometry. This graphic 
here is the main tool palette.

Selecting a Tool from the Tool Palette
1. Position the arrow pointer on the icon of the tool you 

want to use.

2. Click the mouse button.

The icon appears highlighted to indicate its selection.

Floating Tool Palettes
All tool palettes in your Designer Elements program are floating tool palettes. Once 
a palette is displayed, you can move it to any location in your drawing area simply 
by dragging the palette by its title bar. You can save your palette to that location for 
future files by choosing File>Preferences>General and click the Save Now button.

Tool Subpalettes
Most of the tools in tool palettes con-
tain a subpalette of tools with related functions. The (arrow) in the lower-right cor-
ner of the tool icon represents the presence of a subpalette which contains related 
tools. The next graphic shows the Wireframe tool palette.
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Viewing and selecting from a subpalette are similar to choosing a command from a 
menu.

Selecting a Tool from a Subpalette
1. Position the arrow pointer on the tool.

2. Press the mouse button.

The subpalette appears to the right of the tool. 

3. Drag the pointer to highlight the desired tool.

4. Release the mouse button.

The selected tool replaces the previous tool in the tool palette. The 
highlighted icon in the tool palette shows that your selection from the 
subpalette is the active or current tool.

The new tool is visible in the tool palette until you select another tool 
from the same subpalette. The tools in the subpalette remain in the same order; 
only the tool displayed in the tool palette changes.

Once you select a tool, additional information appears to help with your construc-
tion. The Pointer, Pointer Locator, Message Line, and Status Line all provide feed-
back about the active tool.

If you want to select a tool already displayed in the tool palette, you only need to 
click it; you don’t need to select it from the subpalette.

Tear Away Palettes
All tool palettes containing subpalettes are capable of “tearing away” from the par-
ent palette located anywhere in your drawing area. The graphic here is the Ellipse/
Conic tool palette.

When you drag the mouse to the right across the subpalette beyond the last tool, 
the subpalette “tears away” from the parent tool palette. You can save the palette in 
this location by choosing File>Preferences>General and click on the Save Now 
button. Close the palette by clicking on the close button in its title bar.



Parts of the Designer Elements Window
When you tear away multiple tool 
palettes and drag them near each 
other they snap to a left alignment.

Smart Pointer & Wireframe Tools
When you select a tool and move the pointer into the drawing area, the pointer 
shape represents the tool.

Some of the pointers, like the Single Line pointer, are simple cross-hairs. Others, 
such as the Opposite-Point Circle pointer, resemble the tool.

The pointer, called a smart pointer, dis-
plays indicators for multi-step proce-
dures. Each smart pointer has a dot, the 
hot spot, showing the next point you 
should specify. The dot changes position 
on the pointer during each step of the 
construction. 

For example, the Opposite-Point Circle pointer, illustrated above, shows that the 
first click of the mouse places a point on one edge of the circle you’re creating. 
After you click a location, the hot spot moves to the other side of the pointer, show-
ing that the next click places a point on the opposite edge of the circle. See the 
graphic below.

After you click the second location, the cir-
cle appears. The hot spot moves back to 
its original position on the pointer so that 
you can create another circle.

Hot Spot

The smart pointer shows you where to click next.

Your first click

The hot spot moves to the other side of the 
smart pointer to indicate the next step.
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Tech Note:

The number of decimal 
places displayed in the Sta-
tus Line fields is determined 
by the decimal setting in the 
Units page of Preferences.
Location Indicator
The Location Indicator is located next to the Layer indicator at the bottom of the 
drawing area.

This indicator continuously tracks the pointer location when the pointer is in the 
drawing area, displaying the X, Y and Z coordinates of the current location relative 
to the origin. The origin (0,0,0) appears in the center of the screen when you open 
a new document. If you are displaying the Axis, the origin is at the intersection of 
the x, y and z axes.

Message Line
The Message Line across the 
top of the drawing area pro-
vides concise instructions for 
the use of the current tool.

For example, after selecting the Center-Point Circle tool, the Message Line appears 
as illustrated here.

The instructions in the Message Line for some tools also indicate optional activities. 
For example, if you hold down the CTRL (Windows) or OPTION (Macintosh) key 
while using the Center-Point Circle tool, the next mouse click creates a copy of 
the last circle with the center placed where you clicked.

Status Line
The Status Line provides measurements, angles, X, Y and Z coordinates and delta 
values for the current construction. The current tool determines the number of sta-
tus fields and which of the status fields highlights after the construction. For exam-
ple, if you select the Center-Point Circle tool, the Status Line shows the X,Y and Z 
coordinates for the center of the circle and the length of the diameter.

When you click the last point of the circle, the diameter (D) entry field highlights in 
the Status Line to indicate that it is active. It shows the diameter of the circle you 
just created. If you type a new number, and press the ENTER (Windows) or 
RETURN (Macintosh) key, the diameter of the circle you just created changes.
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Tip:

You can also change objects 
with the Edit Objects com-
mand or double-clicking on 
the object to display the Edit 
Objects dialog box.
You can change any or all entries in the Status Line. If you change the entry before 
the tool operation, the values automatically register when you click in the drawing 
area for the particular operation. If you enter a value after the geometry is created 
and then press ENTER (Windows) or RETURN (Macintosh), the changes are made 
to the geometry and you can’t make any more changes in the Status Line.

The number of decimal places displayed in the data fields is determined by the Pre-
cision setting in the Units page of Preferences.

The Status Line uses the World coordinate system for all values entered in the data 
fields. Values can be entered in inches, feet, millimeters, centimeters, meters and 
mathematical expressions (ex. 10”+2.54 cm).

When the units in Preferences are set to feet and inches, it’s important to be aware 
of the following rules:

• All numbers are assumed to be feet unless accompanied by the unit symbol, like 
“ for inches. Entering a 1.5 in the field is read as 1.5 feet. If you want 1.5 inches, 
enter 1.5”, 1.5i, 1.5in, 1.5 inch, etc.

• If you want to enter fractions of inches, each entry must include the unit symbol. 
For example, 5 feet 6 5/8 inches must be entered 5’ 6” 5/8”. Internally this is con-
verted as 5’ + 6” + 5/8”. If the inch symbol is not included with the fraction, 5/8 
will be interpreted as a fraction of a foot.

Copying and Pasting Status Line Entries
You can copy and paste Status Line text for use in another data field.

For Windows, hold down the right mouse button and use the Copy and Paste com-
mands available in the menu. You cannot use the Copy and Paste commands in the 
Edit menu.

For Macintosh, use z +C to copy and z +V to paste text. You cannot use the Copy 
and Paste commands in the Edit menu. These function only for your Designer Ele-
ments program data.

Moving between Status Fields
You can use the TAB key to move to the right, highlighting the next field. When 
you press ENTER (Windows) or RETURN (Macintosh), the entry either changes or 
the construction redraws according to the new specifications in the Status Line. You 
can also use your mouse to activate a Status Line field.

Use the Status Line arrows to scroll if any of the fields are off screen.
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Expression Parsing
The status line entry fields also accept mathematical, trigonometric, and exponential 
operators. Position the cursor in the text field and type in the additional operation. 
See Appendix A for the list of supported operators.

Coordinate System Axis
The coordinate system axis, at the left of the Status Line, dis-
plays the coordinate system currently set for the file. You can 
choose either the Global (world coordinate system) or a user-
defined coordinate system. Clicking on the axis displays a 
menu from which you set the coordinate system.

The default system is the Global coordinate system. See Chapter 7 for more infor-
mation.

Axis
The Axis displays the current view orientation of the x, y 
and z axis in the center of your screen. When you change 
views, the axis will adjust accordingly. You can turn off 
the display by choosing View>Show Axis. If you do not 
want the Axis to display at start up, choose File>Prefer-
ences>General and deselect the Axis option.

Triad
The Triad displays in the 
upper-left corner of your 
drawing area to illustrate the 
orientation of the x, y, z axis 
and the work plane. The 
example below uses the 
default view definitions.

y

z

x

Top Isometric

Trimetric

Front Side



Parts of the Designer Elements Window
The Triad represents the principle of the right-
hand rule—a memory aid for the relative direc-
tions of the positive axes. With your right palm 
upturned, the thumb (x) points right, the index 
finger (y) points straight ahead, and the middle 
finger (z) points up. If you move your hand to 
indicate the x and y-axes, you can easily see the 
direction of the z-axis.

You can turn off the Triad by choosing, 
Planes>Show Triad. If you do not want the 
Triad to display at start up, choose File>Prefer-
ences>General and deselect the Triad option.

Drawing Area
You use the drawing area for all construction, editing and annotation of geometry. 
Think of the drawing area as a sheet of paper of unlimited size that you use to con-
struct full-size unscaled drawings. You use the scroll bars to move the sheet so the 
portion you want to work on is visible in the window.

Displaying the Grid
If you wish to work with a grid in the 
drawing area, choose Planes>Show 
Grid.

If you choose Window>Snap, the Snap 
Options dialog box appears. Choose To 
Grid and your constructions snap to the 
grid, meaning that any geometry point 
that you click snaps onto the closest grid 
point.

Scroll Bars
The scroll bars allow you to move the sheet up and down or right and left. You can 
display different parts of the drawing sheet by dragging the slider of a scroll bar to 
the approximate location. For example, the right, center, or left position in the hor-
izontal scroll bar displays the right side, middle, or left side of the drawing, respec-
tively. 

X

Y

Z

The Right Hand Rule
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You can also click the arrows at the end of the scroll bars to move the sheet one 
line at a time.

Work Layer Indicator
The Work Layer Indicator in the lower-left corner of the screen shows which layer 
is the current work layer. New geometry goes on the work layer. If you want your 
construction to go on a specific layer, first make it the current layer.

You can select the work layer in two ways:

• Click on the arrow to the left or right of the layer name and the layer will move 
backward or forward to another layer.

• Position the pointer over the Work 
Layer Indicator, then press the mouse 
button. All available layers are then 
displayed in a pop-up menu from 
which you can select a different layer 
to be the current work layer. Drag to 
the new work layer. All new geometry will be placed on that layer. You can also 
create a new layer and display the Layer Manager from the Work Layer Indicator.

Memory Indicator
The Memory Indicator field displays two numbers, the amount of RAM available on 
your system and the amount of virtual RAM (RAM plus swap). For Macintosh users, 
when the value reaches 5 MB use extreme caution because your Designer Elements 
program may crash. You are advised to save your files, close the program and then 
restart it.

Remember that the minimum required RAM for your Designer Elements program is 
256 MB. The recommended RAM is 512 MB.

Menu Bar
Your Designer Elements program menus contain related commands and settings.

File Contains commands that affect entire documents 
(files), including opening and closing files, setting 



Menu Bar
preferences and defining your Print Setup (Win-
dows) or Page Setup (Macintosh).

Edit Contains commands to select and manipulate 
objects. These include such things as copying and 
pasting as well as changing an object’s direction, 
resolution, layer and type.

Layout Contains commands and settings that specify the 
drawing area and provide program features and 
functionality such as the Grid, Layer Manager, 
Group and Align.

View Contains commands for displaying your document 
and includes choosing and setting views and zoom 
options.

Planes Contains commands for choosing and defining the 
work plane.

Pen Contains commands to specify pen characteristics 
(color, weight, and pattern), polygon patterns, 
polygon fill, crosshatching and arrows.

Text Contains commands to set the font, size, style and 
case of your text (lower, upper and title capitals).

Dimension Contains commands that specify dimensions, their 
format and tolerance.

Verify Contains commands to obtain information about 
your file and specific objects in your file. These 
include properties of an object, direction, curva-
ture and object counts.

Window Contains commands for displaying tool palettes, 
the Design Explorer, Trackball, etc.

PhotoRender Contains commands for rendering your geometry, 
setting options for rendering and placing lights.

Animation Contains commands for generating Quicktime mov-
ies.
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Help Contains commands to access the on-line help file 
(Windows only).

Displaying a Designer Elements program Menu
1. Point to the menu name.

2. Click on the name.

The menu appears. If you want to dismiss the 
menu without making a choice, click outside 
the menu.

Choosing a Command from a Menu
1. Point to the menu name.

2. Click on the name.

The menu appears. 

3. Click on the command.

The command executes, or the setting, such as 
Snap To Grid, toggles on or off.

Mouse versus Keyboard
Designer Elements program menu items can be chosen with the mouse or with a 
combination of keys on the keyboard. For example, you can use various methods 
for displaying the Edit menu.

Windows and Macintosh:

• Click on Edit in the menu bar.

Windows only:

• Press the ALT key and then type E.



Menu Bar
• Press the ALT key and then press the RIGHT ARROW key until Edit 
is highlighted in the menu bar; then press ENTER.

You also have various methods for choosing commands with the keyboard. For 
example, you can use any of the following methods to choose Planes>Show Grid.

Windows:

• Press ALT and L and then type G.

• Press ALT and then use the RIGHT ARROW key to highlight Layout and press 
ENTER. Then press the DOWN ARROW key to move the highlighted area to 
Show Grid and press ENTER.

• Hold down the CTRL key and type G.

The first method is the mnemonic method. Press the ALT key with the appropriate 
letters for the menu and command as indicated by the underlined character in the 
names.

Macintosh:

• Hold down the z  (command) key and type G.

The third method for Windows and the only one available for Macintosh is a key-
board accelerator. When available it is denoted by the key sequence listed on the 
menu.

While keyboard functionality is always available, this manual generally describes 
making choices with the mouse. 
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Tip:

Windows only: You can also 
hold down the ALT key and 
type a letter to select the first 
item that begins with that 
letter, then use the arrow 
keys to move to the selec-
tion you want. Once your 
choice is highlighted, press 
the ENTER key.

Tech Note:

Windows only: Designer 
Elements program dialog 
boxes do not support using 
the large font setting in the 
Setting page of the Display 
Properties dialog box for 
your Operating System.

Tech Note:

If you want to copy and 
paste data between data 
fields in dialog boxes, you 
cannot use the Copy and 
Paste commands. For Win-
dows, press the right mouse 
button and use the com-
mands in the menu. For 
Macintosh, use ctrl+C to 
copy and ctrl+V to paste.
Submenus
Commands followed by an arrow symbol have 
submenus which display when the command 
is highlighted.

1. Pull down the menu.

2. Click on a command followed by an 
arrow symbol.

The submenu displays.

3. Click on the submenu.

4. Click the desired command.

Dialog Boxes
When you choose a command followed by an ellip-
sis (…), such as Edit Objects in the Window menu, a 
dialog box appears.

Dialog boxes allow you to qualify the command you 
chose by adding information. For example, in the 
Edit Objects dialog box here, you can change the 
specifications of the selected object.

If a dialog box obscures your view of the drawing 
area, you can move it to a new location by dragging 
it with the pointer on the Title bar. 



Menu Bar
Option Buttons
Option buttons indicate mutually exclusive choices; you can select only one option 
at a time. Click the option you want and the button turns black, as shown by the 
inches option below.

Check Boxes
Check boxes, as shown above, provide options you can switch on and off and 
which are not mutually exclusive. A check mark shows the option that is set.

List/Entry Fields
Some dialog boxes contain lists of options, display-
ing an arrow to provide access to the list.

If the entry includes an arrow, you can display a 
menu which works like a submenu on the menu 
bar but the item you specify appears in the field 
once you select it.

Some list fields also allow you to type an entry. For 
example, you can type a value in the Scale entry 
field in the Drawing Size dialog box or choose from 
the pull-down menu, indicated by the arrow. See 
the graphic here.

To type an entry, select the current entry (if it isn’t already selected), then type a 
new entry. In most cases, clicking OK, saves the changes.
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Asterisks
When an item in the dialog box dis-
plays an asterisk (*), you can specify a 
value by clicking or dragging in the 
drawing area. This feature is particu-
larly useful for specifying location 
because you don’t need to know any x, 
y and z coordinates. 

Apply Buttons
Some dialog boxes have an Apply button that allows you to apply the specification 
you just set. You can leave the dialog box open to set other specifications.

For example, once you make a change to an object in the Edit Objects dialog box, 
you can click apply and leave the dialog box open for future changes.

Closing a Dialog Box
If a dialog box contains an OK or Cancel button or an action button such as Open, 
the dialog box closes when you click the button. Otherwise, you dismiss the dialog 
box manually by double-clicking the Control Menu (Windows) or clicking the Close 
Box (Macintosh) in the upper-left corner of the box.

Toggling Commands
Commands that set a condition (such as Snap To Grid and Arrow At Start) display a 
check mark in the menu to indicate that they are active. To turn a command off, 
choose it and the check mark will disappear.

In the case of pen patterns and text characteristics, the check shows the current set-
ting.



The Drafting Assistant
The Drafting Assistant is the feature that makes your Designer Elements program 
unique among design and drafting software products. The Drafting Assistant thinks 
like a drafter; it automatically knows where you typically want construction lines 
and displays them temporarily when you need them. 

The Drafting Assistant also makes it easy to select existing points for construction 
by displaying information about the pointer’s location in the drawing area. If a 
Drafting Assistant notation displays when you click, the construction snaps onto the 
geometry precisely, without requiring finely tuned eye-hand coordination or 
tedious selection of special modifiers, modes, or other specialized construction 
tools.

The following topics are covered in this chapter:

• Snapping onto Geometry

• Drafting Assistant Construction Lines

• Permanent Construction Lines

• Drafting Assistant and Display
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Snapping onto Geometry
When the pointer is in the drawing area, it has a 
snap point function. The snap point locks onto 
specific points on existing objects as you move 
the pointer near them.

The Drafting Assistant tells you when the snap 
point is on an object.

The Drafting Assistant displays information 
about the location of the snap point. This 
information appears either beside the pointer 
or next to the object itself. 

The Drafting Assistant tells you when a snap point locks onto object points.

center

The center of an arc or circle. Move the pointer 
across the arc or circle to display on for the arc 
or circle, then move the pointer near the center to 
display the center point notation.

endpoint

The endpoint of lines, arcs, circles, ellipses 
and splines. 

midpoint

The midpoint of lines, arcs, circles, ellipses 
and splines.

The Drafting Assistant snapping onto a circle

on

The Drafting Assistant displaying the relationship
between the circle and the line that is being constructed.

tangent

center

endpoint

midpoint
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intersection

The intersection of two curves (permanent and the 
Drafting Assistant’s dynamic construction lines).

quadrant

Quadrant points on an arc or circle displayed at 
3 o’clock, 6 o’clock, 9 o’clock and 12 o’clock. 

vertex

The vertices of an ellipse, spline, or dimension 
point.

Using Tangents and Perpendiculars
If you click a point on an arc or circle and drag the pointer away at about a 45° 
angle, the Drafting Assistant locks onto the tangent. If you drag away at a 90° angle 
the Drafting Assistant locks onto a perpendicular.

Tangent

Perpendicular

If you continue holding down the mouse button, the line remains tangent or per-
pendicular while you drag the ending point around the object. 

This is a useful feature if, for example, 
you want to create a line from and tan-
gent to an existing circle to the tangent 
point of another circle.

intersection

quadrant

vertex

tangent

perpendicular

tangent
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Once a line is tangent to the circle, you 
can drag it to the tangent point on the 
other circle, with the tangency main-
tained at both ends.

The Drafting Assistant locks onto a tan-
gent or perpendicular only when the Drafting Assistant starts from the on notation. 
You cannot begin from a specific point, such as endpoint, quadrant or vertex.

Drafting Assistant Axis Locking
The Drafting Assitant support locking to the X, Y or Z axis. To lock to one of these 
axis hold down the corresponding key on your keyboard (X, Y or Z). The Drafting 
Assistant will only show alignment points in that axis.

Customizing the Drafting Assistant
When you first start your Designer Elements program, the Drafting Assistant auto-
matically activates. You can customize the Drafting Assistant in a few different ways 
by using the Snaps command or changing your preferences in the Snap page of the 
Preferences dialog box.

Snap Command
This command, found in the Window menu, displays the Snap 
option dialog box and allows you to activate and deactivate the 
different snaps modes of the Drafting Assistant.

When an option activates the Drafting Assistant operates in the 
following manner as a pointer moves across geometry:

Snaps Enabled The Drafting Assistant is enabled. 
Snaps that are checked display. 
(De-selecting this option is the 
same as turning the DA off.)

Endpoints Object endpoints display.

Midpoints Object midpoints display.

Curve Intersections Intersections between objects display.

Curve On The point nearest to the pointer displays with an 
on notation.

XYZ Align Alignments along the x, y and z axes display.

tangent

tangent
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Tangents/Perpendiculars Tangents and perpendiculars for your geometry 
displays.

Face On A face notation displays for solid objects. 

Edge On All notations normally associated with curves, such 
as endpoint, midpoint, and vertex display for solid 
objects.

Work Plane This snap option allows you to create a curve 
using referencing points on 3D objects but con-
fined to your current 2D work plane. This snap 
works best when you are viewing your current 
work plane. See the example here for clarification.

Example: You have three 
objects from which you want to 
reference points. Display the 
Work Plane icon for the Front 
plane.

Change the view to front and 
draw a curve using the points 
from the objects with the help 
of the Drafting Assistant.

Change the view and you can 
see the curve aligned with the 
current work plane. The dotted 
lines show that the curve aligns 
with the object points.

To Grid When using the grid, this option snaps to grid 
alignment points.

Plane Only Snap points are given for objects only on the cur-
rent work plane.

Each of these snap options have Short cut equivalents. See the “Short Cuts” section 
in Chapter 6 for more information on using Short cuts.

To turn off an option, click the check box to remove the mark next to the option 
name. By default, Solid Face Projections, Project to Work Plane, To Grid and Plane 
Only are turned off.
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Drafting Assistant Preferences
When you choose, File>Preferences>Drafting Assistant, the following dialog 
box appears.

The Drafting Assistant page of Preferences includes the following options:

Hit Radius This setting determines the detection distance in 
pixels. When the pointer is within the specified Hit 
Radius, the Drafting Assistant notations are dis-
played and the object is selected when you click 
the mouse. The default Hit Radius is 12 pixels.

If you can’t specify locations that are close 
together because the Drafting Assistant snaps to an 
existing control point, you can do any of the fol-
lowing:

• Decrease the Hit Radius. 

• Zoom in so more pixels separate the existing 
point and the point you want to select.

• Lock on a point by pressing the mouse button 
and typing the letter that represents the point (m 
for midpoint, for example). 

If you set the Hit Radius to zero, you disable 
the single click selection of the Selection tool 
(dragging a selection fence and double-clicking to 
select all objects will still work). Instead, you 



Drafting Assistant Construction Lines
might consider using the Select Mask 
in the Window menu to specify that some objects 
cannot be selected.

Alignment Angles These angles define the dynamic construction lines 
that the Drafting Assistant automatically uses. If 
you want to change the orientation of your draw-
ing, you can change these specifications. 
For example, you could set these angles to 30°, 90° 
and 150° for an isometric drawing. The defaults are 
0° (horizontal) and 90° (vertical). Use a semicolon 
to separate the values.

To display a dynamic construction line through 
a point, move the pointer to the point to activate 
it (a diamond appears); construction lines automat-
ically display through the active point. You can 
have as many as eight active points. When you 
activate the ninth point, the first one in the series 
deactivates.

Creation Angles These lines are used by the Drafting Assistant only 
when you are creating geometry and they are not 
part of the list of lines generated from the eight 
active points. The defaults are 45° and -45°. Use a 
semicolon to separate the values. 

% Point The divisions of a line for Drafting Assistant nota-
tions. If you want to divide the line into quarters, 
use a 25 specification. The default is 0.0.

For example, entering 25 instructs the Drafting 
Assistant to tell you when the pointer is 25% of 
the distance along a line.

Drafting Assistant Construction Lines
In addition to snapping onto geometry, the Drafting Assistant displays dynamic 
construction lines. The three types of construction lines you use most frequently—

%point
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Tech Note:

You can have as many as 
eight active points; activat-
ing the ninth point in a series 
deactivates the first point.
vertical, horizontal and 45° angle lines—display automatically during construction. 
These construction lines appear temporarily to help you align geometry. Once 
you’ve set a point, the Drafting Assistant construction line disappears—your draw-
ing is not cluttered with extraneous lines.

Dynamic construction lines extend automatically from the last point you created. 
You may want to activate other points so the Drafting Assistant displays construc-
tion lines relative to them. Simply move the pointer over the geometry to activate or 
“wake-up” its control points, then move away horizontally or vertically.

Of course, you also have the option to create permanent construction lines and 
other shapes, as described later in this chapter.

Using the Drafting Assistant’s Construction Lines 
After you’ve indicated the first endpoint of 
a line, move the pointer horizontally, ver-
tically, or in a 45° direction, the dynamic 
construction line appears. The figure here 
illustrates a 45° construction line relative 
to the endpoint of an existing line.

Displaying Dynamic Construction Lines 
while Constructing Geometry
1. Click a point to begin new geometry.

2. Move the pointer away from the point horizontally, vertically, or at a 45° angle. 

3. While the construction line is visible and the Drafting Assistant displays on, 
click the next point. 

The point is placed exactly on the construction line, even though the pointer wasn’t 
exactly on that line when you clicked. The dynamic construction line disappears. 

Displaying Dynamic Construction Lines with Existing Geometry 
1. On selected geometry, without pressing the mouse button, move the pointer 

over an existing point. 

The point notation (endpoint or midpoint, for example) shows that the point is 
active. 

2. Move the pointer horizontally or vertically. 

A construction line appears through the point. 

align:45°

on
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3. While the construction line is visible and the Drafting Assistant displays on, 
click the desired point in the construction.

The point is placed exactly on the construction line, even though the pointer 
wasn’t exactly on that line when you clicked. The dynamic construction line dis-
appears.

The figure here illustrates intersecting construction lines drawn through two exist-
ing, active points.

Once you are familiar with the Drafting Assistant, you’ll see how much your 
Designer Elements program streamlines design and drafting tasks!

Setting New Drafting Assistant Construction Angles
You can add to or change the angles that the Drafting Assistant uses for dynamic 
construction lines by choosing File>Preferences>Drafting Assistant. Enter the 
new construction line angles, separated by semicolons, in the Alignment and Cre-
ation Angles fields.

Locking the Drafting Assistant to Work Plane
By holding down the Shift key, the Drafting Assistant locks to the x, y and z axes of 
the work plane. Only align:x, align:y and align:z construction lines appear.

Permanent Stroke Construction Lines
In addition to the Drafting Assistant’s dynamic construction lines, you may want to 
create construction lines that display until you hide or remove them. 

Stroke construction lines are lines that you create with the mouse. Hold down the 
SHIFT+CTRL keys (Windows) or the z  key (Macintosh) and drag the mouse hori-
zontally or vertically. Since you are working in the drawing area, the Drafting Assis-
tant helps you place the stroke precisely.

align

perpendicular

intersect
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Tip:

You can use strokes to create 
construction lines while you 
are in the process of using a 
tool.

Windows users: When both 
the CTRL and SHIFT keys 
are used by a tool, Stroke 
construction lines cannot be 
created while in the tool.
Construction lines automatically appear on the Construction layer, not the work 
layer of your drawing. If you have inadvertently deleted the Construction layer, it 
recreates the next time you create a construction line. 

You can hide the construction layer to view or print the drawing without construc-
tion lines. You also can select construction lines in the usual manner from any layer; 
the Construction layer doesn’t have to be the work layer. (More information on lay-
ers can be found in Chapter 31). 

When you want to get rid of all construction lines, choose Layout>Delete Con-
structions. Everything on the construction layer deletes and not just the construc-
tion lines.

Holding down the SHIFT+CTRL keys (Windows) or the 
z  key (Macintosh) changes the mouse pointer to the 
Stroke pointer (z ). 

Drag Result

Vertically A vertical construction 
line appears through 
the first point of the 
stroke.

Horizontally A horizontal construction line appears through the 
first point of the stroke. 

Using Stroke Construction Lines
Construction lines are as long as the dimensions of the viewing area of the screen 
or the printing region (as designated in Print Setup (Windows) or Page Setup (Mac-
intosh) in the File menu), whichever is larger.

For example, if you are using the Connected Lines tool, you can create a construc-
tion line that extends through the center of a circle:

1. Hold down the SHIFT+CTRL keys (Windows) or the z  key (Macintosh). The 
pointer becomes the stroke pointer (z ).

2. Move the pointer near the center of the circle.

The Drafting Assistant snaps onto the center point.

3. Drag the mouse vertically or horizontally away from the midpoint.

The construction line appears through the center and you are still in the process 
of creating connected lines after releasing the SHIFT+CTRL keys (Windows) or 

Drag the pointer
horizontally or vertically

center



Permanent Stroke Construction Lines

Tip:

Vellum 3D Users: You can-
not enter multiple angles or 
offsets to create multiple 
construction lines.
the z  key (Macintosh). 

The Construction Command
Stroke construction lines are useful for creating lines through existing points. If you 
want to create a construction line at a location other than an existing point or at a 
particular angle, you can use the Construction command.

Using the Construction Command - CTRL+K (Windows); z +K (Macintosh)
This command in the Layout menu creates a construc-
tion line on the construction layer of the current docu-
ment. 

You can specify the angle of the construction line or the 
offset from a reference point defined by the X, Y coordi-
nates. The asterisk shows that the values can be speci-
fied by clicking or dragging the mouse; values can also 
be typed into the fields.

The distance dragged will always be entered in the Offset data field as a positive 
value, regardless of the direction dragged.

You can only enter one set of values for a new construction line at a time. You can-
not enter multiple angles to create multiple construction lines.

Specifying the Construction Line Angle with the Mouse
1. Click the Angle field.

2. Drag a vector in the drawing area. 

The angle of the vector line appears in the Angle field.

Specifying the Construction Line Offset with the Mouse
1. Click the Offset field.

2. Drag the offset distance in the drawing area. 

The distance you drag appears in the Offset field. Be aware 
that the offset is determined by the angle of the construc-
tion line as shown.

Specifying X, Y Coordinates with the Mouse
The coordinates of the last point you specified appear in the X and Y fields, but you 
can change them by doing the following:

90°

45°

0°

+ -

+

-

+

-
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Tech Note:

If you create construction 
geometry on the construction 
layer, be sure you change 
layers before creating your 
actual geometry. When you 
choose Layout>Delete Con-
structions, everything on the 
construction layer is deleted 
and not just construction 
lines. Choose Undo to 
restore your geometry and 
move it to another layer
1. Click the X field.

2. Enter new coordinates

or

In the drawing area, click the location of the point through which the construc-
tion line should pass. The coordinates are entered automatically for both the X 
and Y fields.

Creating Parallel Construction Lines
You can create parallel construction lines by creating one construction line using 
this field, then creating new lines with the Parallel Line tool.

Creating Construction Geometry
Non-construction geometry is placed on the work layer. You can create temporary 
construction geometry, such as arcs or circles, by making the construction layer the 
work layer, creating the geometry and switching to another layer to continue your 
work. 

Creating Construction Geometry 
1. In the Layout menu, choose Layer Manager. (The dialog box will say Design 

Explorer because to two boxes [Design Explorer and Layer Manager] are com-
bined.)

2. Click in the work layer column 
just to the left of Construction. 
(Move the pencil to that layer.)

3. Click OK. The Layer Manager 
closes and the Construction 
layer is now the work layer. 
You will note this in the Work 
Layer Indicator at the bottom 
left of your screen.

4. Create the geometry you will 
use for construction. 



Drafting Assistant and Display
5. When the construction geometry is complete, make another layer the work 
layer by changing the layer in the Layer Manager or the Work Layer Indicator.

6. Continue your work. 

Once you no longer need the construction geometry, choose Layout>Delete Con-
structions to remove all geometry on the construction layer. 

Removing Construction Lines
If you have many construction lines and you want to delete only one or two of 
them, select the lines you want to remove, and then choose the BACKSPACE (Win-
dows) or DELETE (Macintosh) key. You can remove all the construction lines that 
you’ve created by choosing Layout>Delete Constructions.

Delete Constructions
This command in the Layout menu deletes all construction lines and any geometry 
on the construction layer. The Drafting Assistant’s dynamic construction lines 
appear only temporarily and are not affected by this command. Any geometry on 
the construction layer (regardless of the pen style used) deletes by this command.

You can retrieve deleted construction geometry with the Undo command.

Drafting Assistant and Display
The Drafting Assistant enables you to accurately create and place objects. When 
you create an object that shares a common control point with another object, both 
control points are in the same X, Y, Z location.

If you zoom in on that specific control point, depending on the resolution capabili-
ties of your monitor, it may appear that the objects are not connected at the control 
point. This is a limitation of your hardware. The Drafting Assistant has correctly 
located your geometry.
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Selecting Objects
Once you’ve constructed objects, you may want to make changes. To do so, you 
will have to select the desired object. In your Designer Elements program, the step 
at which you select the object depends on the operation you want to perform. In 
both cases it, modifying an object is always a two-step process.

Modifying with a Tool
1. Select the tool.

2. Select the object to be modified.

For example, use the Divide tool to divide a curve into multiple pieces.

Modifying with a Menu Command
1. Select the object.

2. Specify the action for the selected object. 

For example, you could select a circle and then change the pen pattern to Center to 
indicate a bolt-hole circle. 

The following topics are covered: 

• Objects 

• Indicating Selection Preferences 

• Selection Process

• Eye Dropper tool
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Referral:

Selecting points is described 
later in this chapter.
Objects
A single piece of geometry is an object. 

Several objects that have been grouped with the Group command are also an object 
and are selected when you click on any member in that group.

A point is an 
object, too. Every 
type of geometry 
contains one or 
more points, some-
times called control points. A line has two control points, one at the beginning and 
one at the end of the line. If you select an object and choose Edit>Show Points, 
the points are visible on the selected object. If you select a point without selecting 
the geometry it defines, Your Designer Elements program treats the point as an 
object. 

Indicating Selection & Preferences 
When you select an object, its appearance on the screen shows that it is selected in 
a specific color. The default color chosen is red for your Designer Elements pro-
gram. You can choose you own color as well as choose other settings for selecting 
objects by choosing File>Preferences>Select. The following selection page is dis-
played.

A line is an object

Single
Object

A line without points displayed

Unselected point

A line with points displayed

Selected point



Indicating Selection & Preferences
Pick Box
The pick box is an invisible box centered 
about the pointer tip. The default size of the 
box is 8 x 8 pixels. The pick box requires you 
to move the pointer over the desired object 
and click the mouse button. Objects that are 
within the bounds of the pick box are 
selected. See the graphic below.

Select Fence
The selection fence is a rubber banding selection window. You can choose 
between one of two settings, Entire Object Extents or Partial Object Extents.

Entire Object Extents Only objects that lie completely within the pick 
window are selected. In the graphic below, only 
the circle is selected.

Partial Object Extents Any object that lies within the selection fence win-
dow is selected. In the graphic above, both the cir-
cle and the spline are selected.

Selection Color
You can choose any color for the selection color. In the Selected Entities Color sec-
tion, click New and your standard color display appears. Choose the color, click OK 
and you are returned to the Select page of the Preferences display. Once the selec-
tion color changes, all current and future selected items appear in the new color.

Invisible Pick Box

To another and release.

Drag the mouse from one point...
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Tip:

Having trouble selecting 
objects when displaying 
many objects? Try using the 
Selection Mask, a selection 
fence, or rotate the view 
slightly and try again.
Do not use black for indicating selection because black is the default color for all 
curves.

Selection Process
Selecting an object does not affect the properties of the object. A selected object 
highlights, but this highlighting goes away once the object is deselected. You can 
select an object by using either the Selection tool or by the hollow selection tool 
that appears temporarily when using one of the editing tools.

You can use the Selection tool to select both objects and points. While the selec-
tion process for objects and points are quite similar, there is enough difference to 
merit separate attention.

Selecting Objects with the Selection Tool
To select an object, begin by clicking the Selection tool in the main tool palette. 
You can select one object, SHIFT-click more than one object, or drag a selection 
fence around a group of objects. 

Selection Tool

The Selection tool in the main tool palette 
selects one or more objects (curves, solid 
edges, faces, etc.) or points in the drawing 
area. The graphic here shows the selection 
of a solid face.

You can use the Selection tool to edit previ-
ously created geometry. Click on the object 
to be edited and use the Status Line to edit 
the parameters of the object.



Selection Process

Referral:

The Pick Objects command 
in the Planes menu is for set-
ting the work plane not for 
selecting objects on which to 
perform an operation. See 
Chapter 32, “Planes” for 
more information.
Selecting a Single Object
1. Click the Selection tool in the tool palette. The Message Line reads: Selection: 

Select [Shift=Extend, Ctrl (Windows) or Option (Macintosh) = Copy].

2. Move the pointer to an object and click. The object is selected, and any previ-
ously selected objects are deselected.

Double-selecting a Single Object
Double-click on an object to display an 
Object’s characteristics. This will bring up 
the Edit objects dialog box. You can also 
make changes to the object through this 
box. See Chapter 24 for more information.

Selecting Multiple Objects by SHIFT-clicking
1. Choose the Selection tool in the tool palette.

2. Move the pointer to an object and click.

3. Press down the SHIFT key.

4. While holding down the SHIFT key, click other objects to be selected.

The objects you clicked are selected. If you then click one of the selected objects, 
it is deselected.

5. Release the SHIFT key.

Selecting Multiple Objects by Dragging
If you want to select more than one object, you can drag a selection fence around 
the objects.

1. Click the Selection tool in the tool palette.

2. Drag a selection fence around the objects you want to select.
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Tip:

You can specify that only 
certain objects, layers, or 
colors are selected by setting 
a selection mask with the 
Select Mask command. 
Select All is useful if you 
want to make a global 
change in a drawing, such as 
changing the width of all 
lines.
If you want to select most of the objects within an area, you can drag a selection 
fence to select all the objects, and then deselect the objects you do not want by 
holding down the SHIFT key and clicking them.

Selecting One or More Objects when they Overlap (Ambiguity Popup box)
Often times with more complex drawings, geometry overlaps to such an extent that 
it's difficult to select one object without zooming very close to it. This Designer Ele-
ments program has made this easier with the Ambiguity Popup box. When you 
attempt to select one object among many objects close together, the popup menu 
appears.

As you move the pointer over an object name in the popup, the object it represents 
highlights in the selection color but is not yet selected. Click on the object name in 
the popup to accept that choice. If you move the pointer beyond the extents of the 
popup window, the window will automatically move, enabling you to see what is 
underneath the window.

The Ambiguity Popup box lists faces for such tools that require the selection of a 
face (draft, shell, fillet and extrude).

You can select only one object at a time in the popup box.

You have two options for closing the Ambiguity box without selecting an object:

• Click the Close button or box in the title bar

• Click outside the popup box

Selecting All Objects
There are two ways to select everything in the your Designer Elements program 
document.



Selection Process
• Select the Selection tool and choose Edit>Select All (CTRL+A (Windows) or 
z +A (Macintosh).

• Double-click the Selection tool.

Copying with the Selection Tool
The Selection tool can be used to copy wireframe, surface and solid objects. Be 
careful when copying surfaces and solids. By holding down the CTRL (Windows) or 
OPTION (Macintosh) key and dragging a surface or solid you create an instance of 
the original object. All changes made to the original object are automatically 
reflected in the instance (Cobalt™ and Xenon™ only). If you do not want to create 
an instance, select the original object, choose Edit>Copy and then Edit>Paste. 

Selecting Points 
Selecting points differs from selecting objects because points are not always visible. 

Being able to select points is useful in two situations: stretching selected geometry 
(described later in this chapter) and control point selection for transformations.

Show/Hide Points Command
This command in the Edit menu toggles the display of the control points (endpoints, 
midpoints, center points and vertex points) for selected objects. When points are 
displayed, you can select a point by clicking it. If points are not displayed, you can 
select a point by dragging a selection fence around the location of the point. 

To show points for an individual selection, choose Window>Edit Objects and 
change the control points setting from Hidden to Visible.

If you select and drag a line, the line and the endpoints move. If you select and 
drag only an endpoint of the line, the endpoint moves and the line length changes 
while the other endpoint of the line remains fixed.

The appearance of a selected point is not affected by the zoom scale or the line 
width of your geometry.

A line without points displayed

Unselected point

A line with points displayed

Selected point
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Displaying Points
1. Select the geometry.

2. Choose Edit>Show/
Hide Points to toggle 
the display of points on 
and off.

To turn off the point display 
once the points of an object 
are showing, you must 
select the object again and 
choose either Edit> Hide 
Points or the Control Points option in the Edit Objects dialog box. The graphic 
illustrates some curves with their associated points.

Showing and Hiding Points with Stroke
When you hold down the SHIFT+CTRL keys (Windows) or the z  key (Macintosh) 
and click an object, the display of the object’s points toggles on or off. If the points 
are hidden when you click the object, the points display.

Selecting Points
You can select a control point whether the points are visible or not. To select 
points:

1. Chose the Selection tool.

2. Drag a selection fence around the 
location of the point.

The selected point displays as a square.

Selectable Points Command
This command in the Edit menu gives you the ability to select points that aren't dis-
played. When Selectable Points is not set, you cannot select points by dragging a 
fence.

Two Point CircleLine

Conic Spline

Unselected point Selected point



Selection Process
If points are displayed, 
click the point to 
select it. If points are 
not displayed, you can 
select a point by drag-
ging a selection fence 
around it. The follow-
ing example illus-
trates the use of 
Selectable Points.

Selecting Objects using Other Tools
With the editing tools, you will be asked to select the objects for performing an 
operation. As was mentioned earlier in the chapter, you select the tool first and then 
the objects.

When you select the tool and move the pointer into the drawing area, it 
becomes a hollow selection arrow.

When you finish selecting, the pointer becomes a general tool cursor.

This outline arrow must not be confused with the Selection tool.

Selecting Objects with Commands
Your Designer Elements program provides you with three selection commands, 
Select All, Selection Mask and Select Chain.

Select All - CTRL+A (Windows); z +A (Macintosh)
When the Selection tool is chosen, this command in the Edit menu selects all 
objects except those on a hidden layer or excluded by the Selection Mask. You can 
also double-click the Selection tool to select all objects.

The line's
control point is
selected with
the rectangle

The line's control
point is not
selected with the
rectangle

With Selectable Points turned on,
the Move tool moves the lower
rectangle and the line endpoint

With Selectable Points turned off,
the Move tool moves the lower
rectangle but not the line endpoint
4-9



Tech Note:

Vellum 3D Users: In Vellum 
3D when you closed the 
Selection Mask, the setting 
remained in effect until you 
selected another creation 
tool.
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Selection Process
Select Mask Command
This command in the Window menu allows you to limit selection by object type, 
layer and color. You can only select objects that are highlighted in the dialog box. 
The object type list includes such things as points, lines, splines, mesh, surfaces, 
solids, text, dimensions, images, symbols, groups, lights, decals, draw view, cross 
hatch, etc.

For example, if circles are not highlighted, when you choose Select All, everything 
but the circles is selected. In this way, you can select such combinations as only 
blue splines or only red objects on a particular layer. 

Using the Selection Mask
1. Choose Window>Select Mask.

The Selection Mask dialog box appears.

The highlighted items respond to all selection methods and can be detected by 
the Drafting Assistant.

2. Click the items you want to be able to select so they are highlighted. 

While the dialog box is visible, you can select, create and edit geometry. You can 
move the dialog box if it covers geometry you want to work on. The Selection Mask 
resets itself to the default setting of Select All after you close the box. 

When an item in the dialog box is not highlighted, the Drafting Assistant and all the 
tools cannot detect it, even though it is visible to you on the screen.

The Selection Mask is useful when you have created a complex drawing and want 
to change particular groups of objects. You can use this feature to export some but 
not all geometry.

If layers are added when the Selection Mask dialog box is displayed, the Selection 
Mask dialog box automatically updates.



Eye Dropper Tool
Selecting or Deselecting Listed Items
• To select one item - Windows: With all items selected, click on the item and the 

rest of the list will be deselected. Macintosh: Press the Clear All button and click 
on the desired item.

• To deselect a list quickly, press the Clear All button.

• To select a contiguous group of items, click on the item at the top or bottom of 
the desired group list and drag up or down to select the other items in the group.

• To select or deselect non-contiguous items, hold down the CTRL (Windows) or 
the z  key (Macintosh) and click on the items.

Select Chain Command
This command selects curves that are connected to the selected object. To use the 
Select Chain command:

1. Select the beginning of a curve as shown by the arrow in the left graphic 
below.

2. Choose Edit>Select Chain.

3. All objects connected to the start or end are selected, as in the right graphic 
below.

Deselecting
To deselect an object, click anywhere in the drawing area where there is no object, 
or click any of the creation tools in the tool palette.

You can deselect an object that was selected in a multiple selection operation. 
While the objects are still selected, hold down the SHIFT key and click the objects 
you want deselected.

Eye Dropper Tool

This tool allows you to copy object characteristics such as line font, color, pattern, 
arrow at start and end and render materials from one object to another.
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You can specify which object characteristic you want to 
copy through the Eye Dropper Filter dialog box. To dis-
play this box, press the CTRL (Windows) or OPTION 
(Macintosh) key.

The listed characteristics include: line font, color, layer 
and render material.

This tool does not affect the resolution, dimensions, iso lines or the size and shape 
of the object. In the graphic below, the left block characteristics were applied the 
cylinder with no material applied to it (middle graphic). The right graphic shows 
the cylinder with the same render material as the block after using this tool.

Using the Eye Dropper Tool
1. Select the Eye Dropper tool from the Selection tools palette. The Message 

Line reads: Eye Dropper: Select objects to modify [Shift=Extend].

2. Select the objects whose characteristics you want to change.

The Message Line now reads, Eye Dropper: Select object to copy from 
[Shift=Extend, Ctrl (Windows) or Option (Macintosh) = Filter].

3. If you do not want all object characteristics copied, press the CTRL (Windows) 
or OPTION (Macintosh) key to display the Eye Dropper Filter dialog box. Oth-
erwise, skip to next step 5.

4. Deselect those items in the dialog box that you do not want copied.

5. Select the object whose characteristics you want to copy.



Eye Dropper Tool
The object’s characteristics change to those of the referenced object.

You can also select the object before you select the tool. If you do this, you only 
select the reference entity and the object automatically changes. If the change 
involves applying a material, render your drawing to confirm the change.

There are no Status Line entries.
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Pen Settings
This chapter describes various options for adapting your Designer Elements program to 
your needs.

Default versus Selected Object Settings
When no object is selected, any changes made to the settings become the default for all 
open files. When an object is selected, any change made will only affect the object.

The following topics are covered:

• Style

• Color

• Weight

• Pattern
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• Arrowheads

You have three options for setting pen characteristics, pen color, 
weight and pattern.

You can change the pen characteristics for selected objects or 
choose one or more of these characteristics as the default setting 
for your file.

Changing the Pen Characteristics of an Object
1. Select the object.

2. Choose Pen>Color, Weight or Pattern and select the one you want for the selected 
object. 

This change only affects the selected objects. It does not affect the default setting for 
future objects created.

Changing the Default Pen Characteristics
If you want to change a pen characteristic so that all future objects will have that charac-
teristic, choose the characteristic without having any object selected.

Style
The Pen>Style menu contains commands for creat-
ing and modifying pen styles. A pen style is a collec-
tion of pen attributes such as color, weight and 
pattern.

Pen Styles are associative. This means that after you 
create and assign pen styles to a drawing you can go 
back and modify the pen style and have all objects 
using that pen style update.

The first three menu option provide tools to create, 
delete and modify user defined pen styles. The next 
nine pen styles are hard coded into the program and 
therefore not modifiable.



Style
Creating a new Pen Style
To create a new pen style choose Pen>Style>New from the 
drop down menu. Specify the name, color, weight, pattern and 
scale, clicking “Ok” creates the new style. All pen styles that 
you create are listed below the non modifiable pen styles.

Deleting a Pen Style
To delete a pen style choose Pen>Style>Delete from the drop 
down menu and choose one of the styles you created. The non 
modifiable pen styles cannot be deleted.

Modifying a Pen Style
To modify a pen style choose Pen>Style>Modify from the drop 
down menu. This provides you the means to change one of the 
pen styles you created. Hit “Apply” for your changes to take 
effect.
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Tip:

The fill color for polygons is 
set in the Pen Color. See 
Chapter 28.
Color
There are 256 color options including 239 user definable 
colors and 17 predefined colors. Each definable color can be 
assigned independently from the 16.7 million colors avail-
able.

The color submenu displays eight of the defined colors by 
name, including black, white, red, yellow, green, cyan, blue 
and magenta. The submenu also includes the option, More 
which displays a color palette with more color options.

Displaying the Color Palette
1. Choose Pen>Color>More.

The Color palette appears.

2. You can choose to display 8, 16, 144 or the full 256 color 
palette. The default color palette displays 256 colors. Click 
the button in the upper right corner of the title bar.

You can cycle through the number of colors displayed by con-
tinuing to click the same button.

Specifying the Color of the Current Pen
1. Choose Pen>Color. The submenu appears.

2. Choose the color you want.

The pen takes on the new color, selected in the submenu.

This Color command specifies the color of the current pen and any other selected geome-
try without changing any other pen characteristics.

Defining Colors
You can define as many as 239 colors. When you define a color, you are defining it both 
for the file and for your Designer Elements program.

Because the color displays are different for Windows and Macintosh machines, the pro-
cess for defining a color varies slightly.

Windows:
1. To define a new color, choose Pen>Color>More. The color palette displays.



Color
2. Double-click on one of the definable colors.

The first 17 are not definable. If you attempt to 
redefine one of those you receive the following 
error message.

If the color is definable, the following color dis-
play appears.

3. Click the Define Custom Colors button to display the 
full color display.

The color display contains the following elements:

Basic Colors This section displays the 64 default colors available in 
the palette.

Custom Colors You can display 16 more user-defined colors in this 
area for a particular file. These will be saved with the 
particular file but will not save as a default setting.

Add to Custom Colors Use this button to place a color in the Custom colors 
section.

Color Palette Select your color by using this palette.

Color Palette Solid Once you select a color, it appears in this swatch.

Hue, Saturation, Luminance These fields automatically fill in when you select a 
color. You can also enter values into these fields.

Define Custom Colors Click on this button when you see a partial color dis-
play to show the full color display.
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Red, Green, Blue These fields automatically fill in when you select a 
color. You can also enter values into these fields.

Cancel, OK Click Cancel to close the color display without saving 
the color selection. Click OK to accept the color selec-
tion.

4. In the color palette on the right, place the pointer within the target cursor and drag to 
the color desired. The color displays in the Color/Solid area below the palette.

You can also adjust the Hue, Saturation, Luminance, and the percentage of Red, Green 
and Blue by entering your own values. The % of black can be adjusted by moving the 
cursor over the arrow in the scroll bar to the right of the color palette and drag up or 
down to the desired location. All the values in the Luminance, Red, Green and Blue data 
fields change as well. Hue and Saturation do not change.

5. Once you have chosen the color, click OK, the color display closes and you are 
returned to color palette.

6. Double-click on the color name field, where 
the old name currently displays. The follow-
ing dialog box appears.

7. Enter the new name for the color and click 
OK.

You are returned to the color palette with the 
new color name shown.

8. Repeat this process to define up to 239 colors.

These colors save with the file and the program for future use.



Color
Macintosh:
1. To define a new color, choose Pen>Color>More. The 

color palette displays.

2. Double-click on one of the definable colors.

The first 17 are not definable. If you attempt to redefine one of 
those you receive the following error message.

If you click a definable color, one of six color displays appears: HLS Picker, HSV 
Picker, CYMK Picker, Crayon Picker, HTML Picker or the RGB Picker. You have a 
choice for the default display.

HLS Picker HSV Picker

CYMK Picker Crayon Picker
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The HLS Picker, HSV Picker, CYMK Picker, Crayon Picker, HTML Picker and RGB 
Picker contain the following elements:

Color Wheel (HLS & HSV) Contains the color spectrum from which you choose a 
color. Click or drag within the wheel to select the 
color. The color values appear in the Hue and Satura-
tion data fields.

Lightness Slide Bar (HLS & HSV)Allows you to set the lightness for a particular color. 
Place the cursor over the slide and drag to the desired 
lightness. The lightness value appears in the data field.

Hue Angle, Saturation Values can be entered into these fields to select a color.

Color Slide Bar (RGB) There are three bars; Red, Green and Blue. Place the 
cursor over the slide and drag it to adjust the color 
value for each bar. Values are entered in the data field.

Red, Green and Blue (RGB) Values can be entered into these fields to select a color.

Name (Crayon) The color name displays when you choose a crayon 
color.

Crayon Box (Crayon) Displays the colors available for selecting.

More Choices/Fewer Choices This toggles between the two options. Choosing More 
Choices displays two icons for the HLS Picker, HSV 
Picker, CYMK Picker or Crayon Picker displays. 
Choosing Fewer Options turns off the icon display.

Original/New fields Original displays the current color setting for the color 
you are defining. When you define a new color, the 

HTML Picker

Lightness fields (HLS & HSV)

RGB Picker



Color
swatch is gray. New displays the new color you have 
selected.

Cancel, OK Click Cancel to close the color display without saving 
the color selection. Click OK to close the dialog box 
and save the new settings.

3. Choose a color from the color display.

4. Once you have chosen the color, click OK, the color display closes and you are 
returned to the color palette.

5. Double-click on the color name field, where the old name currently displays. The fol-
lowing dialog box appears.

6. Enter the new name for the color and click OK.

You are returned to the color palette with the new color name shown.

7. Repeat this process to define up to 239 colors.

These colors save with the file and the program for future use.

Add to Custom Colors (Windows only)
This feature is standard for the Windows platform and allows the user to save 16 user-
defined colors for a particular file and display in the Custom colors section of the Color 
display when you first double-click on a definable color.

1. Repeat steps 1 and 2 in the previous section, “Defining Colors,” to show the partial 
color display.

2. Place the pointer over one of the available 
boxes in the Custom colors area and click. A 
dotted line appears around that box to show 
that it is selected.

3. Click Define Custom Colors and the full color 
display appears.

Note in the display that the Color/Solid area is black and the target icon in the palette 
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above it is at the bottom edge.

4. Move the pointer to the color palette and place 
it within the target area. Drag this to the color 
you desire. You can also adjust the % of black 
in the color by dragging the arrow, in the scroll 
bar to the right, to the desired location.

5. Click Add to Custom Colors. The color appears in the Custom colors patch.

6. To fill in the others boxes, go through the same process.

Weight
This command in the Pen menu sets the pen width of the 
current pen pattern and selected lines without changing any 
other pen characteristics.

You also have the option of setting a line weight based on 
units, pixel thickness and through the More option by the 
point size or model space.

Units
The line weights shown depend on the units selected in the 
Preferences dialog box. If you have selected metric units, 
the line weight shows in millimeters instead of inches.

Pixels
The pixel weight depends on the screen resolution and so 
remains constant from zoom to zoom.

More
When you choose More, the Pen Weight dialog box appears.

By selecting the Points, you can enter a value in the size field of 
the point size you want for the current pen weight. By selecting 
the Model, you can enter a thickness value based on the units of 
your model set in the Preferences dialog box. A one inch value 
entered in the field, prints one inch thick, for a drawing scale of 
1:1. After you choose your setting, click OK to accept the pen weight or Cancel to close 
the More dialog box.

Note: Any line thickness of less than .016 inch appears one pixel wide on the screen. When 
you print or plot such lines, you can see the different weights.



Pattern
Specifying a New Weight for the Current Pen
1. Choose Pen>Weight. The submenu appears.

2. Drag to the weight you want. 

The pen takes on the new weight, selected in the submenu.

Pattern
The pen pattern determines the appearance of lines on the screen and during plotting. Any 
line thickness of less than .016 inch appears one pixel wide on the screen. When you print 
or plot such lines, you can see the different weights.

The default pen pattern is Solid. The default color for all patterns is black. The default 
weight for all patterns is 1 pixel.

There are nine default pen patterns in the Pattern submenu of the Pen menu.

You can also create your own pen patterns and access them through the Line Pattern dia-
log box by choosing Pen>Pattern>More.
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Pattern
Line Pattern Manager
The Line Pattern manager appears 

when you choose Pen>Pattern> 
More. If nothing is selected the dialog 
box is called Default Line Pattern and 
the pattern becomes the default pattern 
for the drawing. If an object is selected 
the dialog box is called Object Line 
Pattern and the pattern selected only 
applies to the selected object. Both 
dialog boxes display the pen patterns 
that are available to you for creating 
and editing geometry. You can perform 
some basic editing on these patterns 
using the options provided.

The Line Pattern manager contains the 
following items:

Patterns This section contains all the patterns available.

Scale This field contains the value by which the pattern 
dashes and spaces are multiplied to obtain the same 
pattern at a different size. You can either enter a spe-
cific value or use the slide to set the scale. The graphic 
below is an example of the phantom line with scale 
values of 1, 2 and 3.

(Scale 1) ___ _ _ ___ _ _ ___ _ _ ___ _ _ ___ _ _ 

(Scale 2) ______ __ __ ______ __ __ ______ __ __ 

(Scale 3) ____________ ____ ____ ____________



Pattern
New Patterns
Each line pattern displays according to two description lines of the Cadd.lin file in the 
Environ folder.

You can add new patterns to your Designer Elements program by opening the file in an 
ASCII text editor and creating two new description lines per pattern.

The first line contains the pattern line name plus a descriptor string. The second line con-
tains the length attribute for dashes, spaces and dots. A zero (0) value indicates a dot and a 
negative value indicates a blank space.

Creating a New Pattern
1. Quit your Designer Elements program, if it is running.

2. Open the Cadd.lin file from the Environ folder in an ASCII text editor.

3. After the last line pattern, enter the name of your new pattern. Give it a name not 
already used.

4. In the same line, enter a descriptor string. This string is simply a visual representation 
of the pattern that will display in the Line Pattern Manager next to the name. (See the 
other patterns for an example). Use the periods, dashes and the space key on your key-
board to create the descriptor.

5. Begin the second line with a capital “A” followed by the length of the attributes. Each 
attribute should be followed by a comma and contain no spaces.

6. Save the file.

7. Restart your Designer Elements program.

Editing Patterns
You can edit any pattern in two ways:

• Make changes to the Cadd.lin file in an ASCII editor.
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Tip:

If you want to make 
changes to the default pat-
terns, copy the original file 
to another location or 
rename it and keep it in 
the same location before 
making changes. Then, if 
you want to return to the 
original factory settings, 
you simply have to replace 
the Cadd.lin file with this 
• Choose settings in the Line Pattern Manager.

Making Changes in the Cadd.lin file
1. Quit your Designer Elements program, if it is running.

2. Open the Cadd.lin file, from the Environ folder, in an ASCII text editor.

3. Make the desired changes to the patterns. If you have changed a default pattern, name 
or descriptor, it will be reflected in the Pattern submenu.

4. Save the file.

5. Restart your Designer Elements program.

Choosing Settings in the Line Pattern Manager
1. Choose Pen>Pattern>More. The Line Pattern Manager displays.

2. Select the pattern you want to modify.

3. Enter a value in the Scale field.

4. Click OK to accept the changes or Cancel to close the Line Pattern Manager. All 
selected will reflect the changes. 

If any objects are selected, they will reflect the changes. The current pen pattern will not 
be affected unless it's the pattern you changed.

If no objects are selected, clicking OK will change the current pen pattern to the edited 
pattern.

Important: Changes made here affect all open files.

Specifying a New Pattern for the Current Pen
1. Choose Pen>Pattern. The submenu appears.

2. Drag to the pattern you want. The pen takes on the new pattern, selected in the sub-
menu.

Specifying a New Pattern for a Selected Object
1. Select the object.

2. Choose Pen>Pattern.

3. Drag to the pattern you want. The pen takes on the new pattern, selected in the sub-
menu.



Arrowheads
Construction Line Pattern
A construction line uses a dotted line pattern. It cannot be modified and is not affected by 
changes to the dot pattern. The default color is magenta. If you want to create construction 
geometry on the construction layer, you can use the dotted line pattern.

Arrowheads
When you want to use arrowheads on lines or circular 
arcs that are not a part of dimensions, specify the place-
ment of arrowheads in the Pen menu. You can have an 
arrowhead at the beginning or end of a line or circular 
arc, or at both the beginning and end.

Arrowheads Type
The Arrowheads submenu allows you to choose one of eight 
arrowheads for arrow lines. Select the style that you prefer.

Arrow Size Command
This command in the Dimension menu lets you specify the size of the arrowhead that you 
have selected.
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Diameter/Length This value is the diameter or length of circular and 
length of all slash or standard arrow styles. The value 
here affects all Length, Side and Angle fields. The 
value displays in the current units specified in the 
Units page of the Preferences dialog box.

Length This value is the length of the arrowhead as the hori-
zontal distance from its tip to the furthest extension of 
its base.

Height This value is the height of the arrowhead as the vertical 
distance of its base.

Side This value is the length of the edge of the arrowhead.

Angle This value is the angle of the tip of the arrowhead.

If you change any value in the Length, Height, Side, or Angle entry fields, this Designer 
Elements program changes the values in the other entry fields accordingly.

Arrow At Start
This command in the Pen menu places an arrowhead at the beginning of selected and sub-
sequent lines and circular arcs. You can choose the type of arrowhead from the Pen menu. 
A check indicates the current arrowhead setting. You can change the default setting by 
saving changes in the preferences file.

Arrow At End
This command in the Pen menu places an arrowhead at the end of selected and subsequent 
lines and circular arcs. You can choose the type of arrowhead from the Pen menu. A check 
indicates the current arrowhead setting. You can change the default setting by saving 
changes in the preferences file.

The start and end of a line and an arc are determined by the point that was created first.

No Arrow At Start No Arrow At End

Arrow At Start No Arrow At End

No Arrow At Start Arrow At End

Arrow At Start Arrow At End



Preference Settings
All designers develop a particular style when creating their models and parts. This 
style includes specific standards that unify their work and may include such things 
as measurement units, line color, drawing layout, short cut keys and more. It also 
unifies work within companies and industries. Preferences set in the Preferences 
dialog box relating to object display and creation affect only the entities created 
after the preference is set.

Default versus Selected Object Settings
When no object is selected, any setting changes made to Selectable Points, Grid, 
Axis, Triad, Show Points, Construction Lines, User-defined plane, Pen, Text, Dimen-
sion, tool palettes and Render become the default for all open files and the current 
Designer Elements program session. When an object is selected, any change made 
will only affect the object.

This chapter covers the following topics:

• Preferences

• Short Cuts

Preferences
Your Designer Elements program allows you to save preferences for a particular 
session. However our program do not support saving preferences with a specific 
file.
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When you have more than one 
file open during a particular 
Designer Elements program 
session, menu settings like pen 
pattern, Hide/Show Axis and 
the status and location of pal-
ettes are the same for all open 
files. Commands dealing with 
the view orientation and work 
plane are file specific.

To save preferences, choose 
File>Preferences to display the dialog box. Preferences are saved in prefs.ini.

The Preferences dialog box contains a Category list of Preference groups, the Set-
tings section and a series of operation buttons. The buttons include:

OK Saves preference settings you have specified in this 
session and closes the Preferences dialog box.

Cancel Closes the dialog box without saving all changes.

Apply Applies the change instantly.

Revert Page Undoes changes made to the current preference 
group.

Revert All Undoes changes made to any preference group.

Factory Resets all preference groups to the factory settings.

The Category list includes:

• Colors

• DCM

• Display

• Drafting Assistant

• Filing

• General

• Grid

• Localization



Preferences
• Select

• Units

Selecting an item from the Category list displays its preference options in the Set-
tings section.

Colors
Choosing the Color category 
displays the Color preferences 
page. This page controls the 
foreground and background 
color of the drawing area. The 
current (or proposed) settings 
are indicated by the color rect-
angle, color name and the Pre-
view section. Press the 
appropriate New button to dis-
play the color selection dialog box and change the color.

Background
This setting allows you to set the background color for your drawing area. The cur-
rent color is displayed in the window.

1. Click New. The color palette is displayed.

2. Choose the background color.

3. Click OK. The new background displays in the view window with the color 
name. For colors other than the standard colors, the color values display to the 
right of the view window.

Foreground
This setting allows you to set the foreground color for your drawing area (specifi-
cally the location indicator and the indicator separator lines). The current color is 
displayed in the window.

1. Click New. The color palette is displayed.

2. Choose the foreground color.
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3. Click OK. The new foreground displays in the view window with the color 
name. For colors other than the standard colors, the color values display to the 
right of the view window.

Preview
The Preview window displays your background and foreground choices.

Dimensional Constraint Manager (DCM) (Cobalt™ Only)
This option controls how the 
Dimensional Constraints Manager 
gives feed back to the user.

Over-Defined Constraint Color
You have the ability to set the color of an over-defined sketch. Set this field to the 
desired color.

Under-Defined Constraint Color
You have the ability to set the color or an under-defined sketch. Set the field to the 
desired color.

Fully-Defined Constraint Color
You have the ability to set the color of a sketch that is fully defined. Set this field to 
the desired color.

Fixed Constraint Color
You have the ability to set the color of fixed constraints. Set this field to the desired 
color.



Preferences
Show Constraint Layer
This check box tells the program whether or not to show constraints as they are 
being applied. If the box is not checked, constraints will be visible on the active 
work layer even though the constraints are being applied.

Display
This option controls the individ-
ual default display parameters for 
curve, surface and solid object 
types.

Object Type
You have the ability to set the appearance of 
Curves, Surfaces and Solids. Each object type 
offers different display options.

Display
For each object type (curve surface and solid), you can choose a display option. 
Display options vary according to the object type and may include: Resolution, Iso 
Lines, Silhouette and Edge Color.

Resolution (Available for all object types) Controls how accu-
rately an object’s curves appear. You can set the 
curve resolution to Coarse, Medium, Fine, Very 
Fine and Super Fine. An object with a Coarse reso-
lution draws quickly but may be visually less 
appealing. An object with a Fine resolution draws 
more slowly but may be visually more appealing.
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Tech Note:

Parameter space is where 
objects are defined in a 2D 
coordinate system. Typically, a 
surface is mathematically 
defined in parameter space. 
Each surface has a mathemat-
ical function that maps 2D 
parameter space into 3D 
model space. A U/V coordi-
nate of U=0.5 and V=0.25 in 
parameter space maps to 
X=100, Y=300, Z=255 in 3D 
model space.
Iso Lines (Available for Surface and Solid object types) Iso 
(isopram) Lines control the number of U and V 
lines displayed for a surface or solid object. Iso 
Lines are constant parameter curves that lie on an 
object. U and V are letters used to define these 
lines (and their coordinates) in parameter space 
where U is for horizontal and V is for vertical. 
These are standard for the industry. A zero (0) in 
both fields turns off Iso Lines. U/V values may 
enhance the visual appearance of a surface or solid 
at the expense of drawing speed.

The left graphic below shows a surface with both 
U and V Iso lines set to five (5).

Silhouette (Available for Surface and Solid object types) Con-
trols the silhouette edge draw mode. There are 
three options, Off, On and Smart. Silhouette edges 
are view dependent and can cause a significant 
reduction in drawing speed. If the Smart mode is 
selected, silhouettes will be dynamically drawn 
based on performance considerations.



Preferences
Edge Color (Available for Surface and Solid object types) This 
option allows you to set the edge color of ren-
dered mesh objects separate from the entity itself.

You can select one of four options from the pull-
down menu, Foreground, Background, Entity and 
User Defined. To specify a User Defined color, 
click on New, choose a color in the palette and 
click OK. The new color is displayed in the Edge 
Color window with its RGB values.

Drafting Assistant
This category controls the low level snapping behavior of the Drafting Assistant. 
The settings include the Hit Radius, Alignment Angles, Creation Angles and % 
Point.

Hit Radius Determines the detection distance in pixels. When 
the pointer is within the specified Hit Radius, the 
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Drafting Assistant notations display and the object 
is selected when you click the mouse.

Alignment Angles Define angles for the Drafting Assistant's dynamic 
construction lines. If you want to change the orien-
tation of your drawing, you can change these spec-
ifications. For example, in a 2D drawing, you 
could set these angles to 30°, 90° and 15° for iso-
metric drawing. The defaults are 0° (horizontal) 
and 90° (vertical). Values should be separated by 
semicolons.

To display a dynamic construction line through a 
point, move the pointer to the point to activate it 
(a diamond appears); construction lines automati-
cally display through the active point. You can 
have as many as eight active points. When you 
activate the ninth point, the first one in the series 
deactivates.

Creation Angles Define angles for Draft Assistant dynamic construc-
tion lines displayed when you are creating geome-
try. (These lines are not part of the list of lines 
generated from the eight active points.) The 
defaults are +45° and -45°. Values should be sepa-
rated by semicolons.

% Point Controls the Drafting Assistant's notations for divi-
sions of a curve. For example, entering 25 instructs 
the Drafting Assistant to tell you when the pointer 
is 25% of the distance along a line.



Preferences
Filing
This category controls the filing behavior of your Designer Elements program. Set-
tings include Save Native Picture Formats Only, Compact Files, Read-only Network 
File Sharing, Recent Files and Auto Save.

Save Native Picture Formats Only
Activating this option allows you to disable multiple platform picture support. Sav-
ing only the native format will reduce file size.

Clear Undo on Save
Activating this option allows you to flush the undo stack after a file has been saved. 
If the box is not checked, the undo stack is maintained after saving, increasing the 
file size.

Compact Files
If this option is checked, files compact when saved. Display facets are not written 
out when this option is selected. This file size reduction is especially noticeable on 
files containing solid models with many creation parts.

Read-only Network File Sharing

If this option is checked, the file can only be edited by the current user. No one 
else will be able to edit the file until the first person closes the file.
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Recent Files
This option allows you to set the number of recent files that display in the File 
menu. Selecting a file from the menu immediately opens the file and bypasses the 
Open File dialog box.

Max Files in Menu The drop down list allows you to specify 0 to 20 
file names. The default number is five.

Show Paths in Menu Checking this box displays the full path along with 
the recently used file name in the File menu.

Auto Save
Checking this box enables the automatic file 
saving options and directs your Designer Ele-
ments program to save a backup of your work 
periodically. If this box is not checked, auto-
matic file saving does not occur. 

If auto save is triggered, a backup file is created in the Backup folder within the 
Designer Elements program folder. Backup files are numbered sequentially. If you 
have not yet saved your file, the backup will be named untitled.

If auto save is on but you have not modified any geometry in your drawing since 
the period that the last auto save operation occurred, auto save does not activate.

There are three auto save options:

Save after “N” Commands Entering a value in this field specifies the number 
of drawing modifications (creations, edits or dele-
tions) that must occur before an auto save triggers.

Save after “M” Minutes Entering a value in this field specifies the number 
of minutes that must pass after the first drawing 
modification before an auto save triggers.

Using a Max of Temp Files Entering a value in this field specifies the number 
of backup files to be created before reusing a 
backup file name. A large value will consume 
more disk space. The default value is five.



Preferences
General
This category controls the general user interface behavior, view definitions and 
arrow nudge distance.

User Interface
This section provides the following check boxes for choosing interface options:

Enable Tool Tips Enables the floating tool tip help windows.

Enable Short Cut Keys Enables setting the keyboard short cut keys 
through File>Short Cuts.

Enable Tool Cursors Enables the display of tool specific icons when 
using the tool. Without this enabled, the cursor 
appears as crosshairs when moved into the draw-
ing area.

Enable Auto Regen Enables the automatic regeneration of child objects 
when parent objects are modified (Cobalt™ and 
Xenon™ only).

Save Dialog Positions Saves the location of dialog boxes. The next time 
the dialog box displays, it is positioned at its most 
recent location.

Save Palette Positions Saves the tool palette positions and displays its sta-
tus when exiting. The next time your Designer Ele-
ments program launches, the palettes display in 
their previous positions. Click the Save Now but-
ton to immediately save tool palette positions, pen 
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color, fill color, dialog box locations and display 
status.

Show Axis at Startup Shows the coordinate axis when your Designer 
Elements program launches.

Show Triad at Startup Shows the coordinate triad when your Designer 
Elements program launches.

View Definitions
Your Designer Elements program supports two different common view definitions, 
Default and Aerospace. Select the Default option to use view definitions commonly 
used for mechanical drafting. Select the Aerospace option to use view definitions 
commonly used for aerospace lofting.

Arrow Key Nudge Distance
The Arrow Key Nudge distance specifies how far the drawing will scroll when a 
keyboard arrow key is pressed in the Selection tool. The units for this option are 
based on the units chosen on the Units page of this dialog box.

Grid
This category controls the grid display and snapping behavior. The options include 
grid spacing, appearance, start up preference and color. 

Spacing
The DX and DY values set the grid spacing. Units are based on those set on the 
Units page of the dialog box.



Preferences
Sub-spacing
X Divs and Y Divs specify the number divisions for the grid to which geometry 
snaps in your drawing when the Snap to Grid command is activated.

Display As
The grid can be displayed as either dots or lines. Check either the Grid Dots or Grid 
Lines option.

Grid Size
Enter a value in these fields to set the grid size. The values represent the number of 
grid sections that appear in the positive and negative X and Y directions. A value of 
three entered into each field results in six grid sections in the X direction and six 
grid sections in the Y direction. The graphic here is an example of this.

The grid also follows the current work plane allowing you to use it when creating 
objects in any plane. For example, if you change the plane from the Top plane to a 
user-defined plane, the grid displays as it did in the Top plane.

Display Grid at Startup
Check this box to display the grid when you first launch your Designer Elements 
program.

Snap to Grid at Startup
Check this box to activate the snapping function when you first launch your 
Designer Elements program.
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Preferences
Grid Color
You can select any color for the grid. The current color displays in the window. 

1. Click New to display the color palette.

2. Select a color from the palette.

3. Click OK to accept the color and return to the Grid page. The new color now 
displays in the grid view window with the color name. For colors other than the 
standard colors, the color values display to the right of the view window.

Localization
This category controls the usage of decimals versus commas in your Designer Ele-
ments program.

Use Commas as Decimal
Checking the Use Comma as Decimal option allows international users to display 
numbers according to their numerical standards.



Preferences
Select
This category controls object 
selection behavior, including 
Pick Box Size, Ambiguity Popup, 
Selection Color and the Selection 
Fence mode.

Pick Box Size
When you select an object, you place the cursor on the object and click the mouse. 
The Pick Box is the area around the cursor in which an object must be located to be 
selected. You can specify the area using the pull-down menu (ranges from 2 
through 16, even numbers only). The Pick Box does not display.

Ambiguity Popup 
The Ambiguity Popup displays when there are multiple objects near the vicinity of 
your selection and offers choices of which object to choose.

A check mark in the box enables the popup. This is the default setting.

Selected Entities Color
This option allows you to set the selection color. The current color displays in the 
window. To change the color:

1. Click New to display the color palette.

2. Select a color from the palette.

3. Click OK to accept the color and be returned to the Select page. The new color 
now displays in the view window with the color name. For colors other than 
the standard colors, the color values display to the right of the view window.

Select Fence Mode
Your Designer Elements program supports two mode when dragging to select one 
or more objects, Entire Object Extents or Partial Object Extents. Selecting the Entire 
Object Extents option allows only the selection of objects that fall completely within 
the selection fence. Selecting the Partial Object Extents option allows the selection 
of any object that has a portion within the selection fence.
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Tech Note:

The decimal places entered 
here only affect the Status 
Line and Location Indicator. 
They do not affect the deci-
mal places used for dimen-
sions. These must be set in 
the Dimension menu.

Tech Note:

If you choose feet/inches for 
units, you can enter the com-
bination of feet and units in 
the Status Line and Edit 
Objects dialog box. However, 
these values will convert to 
decimals after they are applied 
to your geometry. For exam-
ple: A value of 1”3” converts 
to 1.25 feet.
Note: Be aware that control points will affect what is selected when using the Par-
tial Objects Extents option. For example: With this option selected, if your selection 
fence covers a control point for a circle, only the center point is selected rather than 
the entire circle.

Units
This category controls the units and the number of decimal points displayed for 
your geometry.

Units can be set to inches, feet, feet/inches, millimeters, centimeters and meters.

In the Display Decimal Digits data field, enter the number of decimal places 
(between 1 and 8) you want to display. Three decimal places is the default.

Changing the Preference Settings with the Preferences Com-
mand
1. Choose File>Preferences.

2. Select the category you want to set.

3. Make your desired changes.

4. Select another category or click OK to close the dialog box.

Changing the Preference Settings Manually
1. Quit your Designer Elements program.

2. Open the Preferences file, prefs.ini, in a text editor. The file is located in the 
Environ folder - the same folder as the executable file for your Designer Ele-
ments program.



Pen and Dimension Preferences
3. Change the characteristics you want.

4. Save and close the file.

The file must be stored in the original folder.

5. Relaunch your Designer Elements program.

The preferences are set.

Preferences and Object Creation
When you change any of the preference settings, the changes are only reflected for 
new objects.

Pen and Dimension Preferences
When you launch your Designer Elements program, you can set the default pen, 
text and dimension characteristics. Without anything selected, specify the settings. 
You do not have to save any file to save these preferences. Simply, exit the program 
and the pen, text and dimension settings are saved to the preferences .ini file.

Short Cuts
The Short Cuts command in your Designer Elements program allows you to create 
keyboard combinations, providing alternative ways to invoke commands. You can 
create short cuts for activating tools and commands, setting the work plane, chang-
ing layers, switching between wireframe and render modes and more. If you assign 
a short cut to a tool, the short cut displays with the tool tip when you move the 
pointer over the tool.

Short Cuts are organized by the Short Cut Manager.
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The Short Cut Manager dialog box includes the following elements:

Category Contains all available operations in your Designer 
Elements program.

Command Displays the commands assigned to the selected 
operation in the category list.

Shortcut key Displays the key combination for the selected 
operation. If you want to use the function keys, 
type F and the number (F3 for example) rather 
than pressing the function key itself.

Description Describes the action that results from the selected 
command.

The buttons in the Short Cut Manager include:

OK Saves the new Short Cuts and closes the Short Cut 
Manager.

Cancel Closes the Short Cut Manager without saving any 
changes.

Print Prints a hard copy of the current short cut key 
assignments. The factory default Short Cuts are 
included in Appendix E.

Assigned If this box is checked, when you print the Short 
Cut list, only assigned keys are included.

Assign Key Assigns the Short Cut key combination for future 
use. 

If the short cut key is already assigned, a warning 
box displays asking if you want to remove the 
command assignment already using that key com-
bination.



Short Cuts
Click Yes to accept the reassignment or No to be 
returned to the Short Cut Manager to enter another 
key combination.

Remove Key Removes the key combination from the selected 
command.

Revert Undoes any changes made to any groups.

Factory Resets all groups to the factory settings.

Creating a New Short Cut
1. Choose File>Short Cuts.

2. Select the desired category and command 
in the appropriate sections.

3. Enter the key combination into the Shortcut 
key data field.

4. Click Assign Key. The key combination dis-
plays next to the selected command.

5. Continue entering all key combinations as 
desired.

6. Click OK to save the new short cut keys 
and close the dialog box.
6-19



Preference Settings

6-20



Tech Note:

Rubberband images only 
appear when geometry is 
displayed in the Wireframe 
rendering mode.
Drawing Techniques
This chapter provides techniques for creating geometry and setting up your draw-
ing area. The following topics are covered:

• Object Creation Methods

• Status Line

• Message Line

• Coordinate System

• Trackball

• Drawing Display Commands

• Drawing at Full Scale

• Default versus Selected Object Settings

• Escape Key

• Progress Bar

• Right Mouse Button

Object Creation Methods
In Vellum 3D and Vellum Draft, you had two methods for creating objects, clicking 
and dragging. In your Desiger Elements program, objects are created by clicking 
only. 
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As you create geometry, a rubberband image of the geometry appears showing you 
how the object will look when you click the last point.

To make object creation easier, your Desiger Elements program’s wireframe tools 
contain a feature we call Smart Pointers. As you work with a tool, the cursor icon 
shows you the points you must indicate to create an object with the tool. 

Each dot on the icon represents a point you must place by clicking. The smart 
pointer indicates the order for designating points.

Creating a Line by Clicking
1.Click the Single Line tool in the main tool palette. The Message 
Line reads: Single Line: Pick beginning point [Ctrl = Copy Previous 
(Windows) or Option = Copy Previous (Macintosh)].

2.Move the pointer to the drawing area and click to set the starting 
point of the line. 

3. Move the mouse to the desired location for the endpoint of the line. As you do 
so, a rubberband image of the line appears. 

4. Click to set the endpoint. 

Immediately after construction, you can make changes in the Status Line at the bot-
tom of the drawing area to alter the length or position of the line. If the geometry is 
not satisfactory, just press the BACKSPACE (Windows) or the DELETE (Macintosh) 
key

Status Line
Whenever you select a tool from a tool palette, the Status Line appears along the 
bottom of the drawing area. It contains data fields that provide information about 
the current construction. For example, when the Single Line or Connected Lines 

Click to place the starting point of
the line.

Click to place the ending point of
the line.



Status Line
tool is active, the Status Line contains data fields for the X, Y and Z coordinates of 
the beginning point and the change of X, Y and Z values. It also contains the value 
of the length and angle of the line.

You can use the Status Line in three ways:

• To create an object with keyboard entries only.

• To edit an object that was just created and is still selected.

• To create additional wireframe objects using the current tool.

Whenever you construct an object, the status data field containing the specification 
that you are most likely to change is active (the data field is highlighted). For exam-
ple, when you draw a line with the Single Line tool, the Length data field is high-
lighted so you can enter a value for the length. Just type a value. When you press 
ENTER (Windows) or RETURN (Macintosh), the line is redrawn at the new length.

You can set the number of decimal places for Status data field entries to display by 
going to File>Preferences>Units.

Using the Status Line
If you want to make an entry in a different status data field, you can use one of four 
selection methods:

• Press the TAB key to cycle the selection highlight through the status data fields 
from left to right.   

• Click inside the status data field and the pointer becomes an I-beam text cursor.

• Double-click inside the status data field to select the entire contents of the data 
field. 

• Click the data field label to select the entire contents of the data field.

Units and the Status Line
Values can be entered in inches, feet, feet and inches, millimeters, centimeters, 
meters and mathematical expressions (ex. 10”+2.54 cm).

When the units in Preferences are set to feet and inches, it’s important to be aware 
of the following rules:
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Tech Note:

There are two methods for 
making Status Line entries in 
Your Desiger Elements pro-
gram. The first is Select a tool, 
create the object, type the 
new values and press ENTER 
(Windows) or RETURN 
(Macintosh). The selected 
geometry changes. In the sec-
ond method, you select the 
tool, type the desired values 
in the Status Line and press 
ENTER (Windows) or 
RETURN (Macintosh). The 
values are now registered. 
Then you create the geome-
try with the tool.
• All numbers are assumed to be feet unless accompanied by the unit symbol, like 
“ for inches. Entering a 1.5 in the field is read as 1.5 feet. If you want 1.5 inches, 
enter 1.5”, 1.5i, 1.5in, 1.5 inch, etc.

• If you want to enter fractions of inches, each entry must include the unit symbol. 
For example, 5 feet 6 5/8 inches must be entered 5’ 6 5/8”. Internally this is con-
verted as 5’ + 6” + 5/8”. If the inch symbol is not included with the fraction, 5/8 
will be interpreted as a fraction of a foot.

Copying and Pasting Status Line Entries
You can copy and paste Status Line text for use in another data field.

For Windows, select the Status Line text, hold down the right mouse button and use 
the Copy and Paste commands available in the menu that appears. You cannot use 
the Copy and Paste commands in the Edit menu.

For Macintosh, use z +C to copy and z +V to paste text. You cannot use the Copy 
and Paste commands in the Edit menu. These function only for your Desiger Ele-
ments program data.

Status Line Entries and Tool Operations
Information entered in the Status Line is registered in two different ways in your 
Desiger Elements program depending on what step you are on in creating your 
geometry.

• After you select a tool, you can immediately enter values in the Status Line data 
fields. When you perform the tool operation, those values will be used to create 
your object.

• After you create your object with a tool and the object is still selected, you can 
enter new values in the Status Line data fields. To move from field to field you 
use the TAB key. When you press ENTER (Windows) or RETURN (Macintosh), 
you object changes to reflect those values. Once you hit ENTER (Windows) or 
RETURN (Macintosh), future changes can only be made to the object through the 
Edit Objects dialog box.

• When entering values in the Status Line, the accuracy of your geometry depends 
on the number of decimal places you enter.

• The Status Line references the current coordinate system current work plane. All 
values in the Status Line are based on the current coordinate/work plane system.



Status Line

Tip:

Vellum 3D Users: If you 
pressed ENTER (Windows) 
or RETURN (Macintosh) a 
second time after creating a 
line in Vellum 3D, you would 
create an identical object in 
the same location. This is not 
the case with your Desiger 
Elements program.
Using the Status Line with Drawing Tools
Once you have drawn an object, you can adjust the specifications —the length, 
angle and location—in the Status Line. You can make these changes immediately 
before you construct another object, select a different tool or choose a command 
however it is not necessary.

You can make only one series of changes in the Status Line (in as many fields as 
necessary); after you press ENTER (Windows) or RETURN (Macintosh) your Desiger 
Elements program redraws the object to your specifications. After this, you must 
make subsequent changes using the Edit Objects command in the Edit menu.

Try the following exercises to create and change a single line with the Status Line.

Altering Geometry in Progress with Status Line
1. Select the Single Line tool. The Message Line reads: Single Line: Pick beginning 

point [Ctrl = Copy Previous (Windows) or Option = Copy Previous (Macintosh)].

2. Click two locations in the drawing area. The length (L) field automatically high-
lights in the Status Line.

3. Type 3. The 3 is entered directly in the L field.

4. Press the TAB key to select the next status field. The angle (A) field now high-
lights. (If your monitor does not display the Angle field, click on the scroll 
arrow at the right to display it and then press the Tab key to highlight the data 
field.)

5. Enter 15.

6. Press ENTER (Windows) or RETURN (Macintosh).

Pressing ENTER (Windows) or RETURN (Macintosh) completes the data entry for 
this object. The line is redrawn 3 units long and at a 15° angle.

Remember that when you press ENTER (Windows) or RETURN (Macintosh), your 
Desiger Elements program constructs the object based on the specifications in the 
Status Line.

Creating Additional Geometry with the Status Line
1. With the Single Line tool still selected from the previous example, click 2 more 

points. 

2. Type 4.

3. Press the TAB key and type 25 in the Angle field.
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4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.

Creating New Geometry with the Status Line
1. Choose the Selection tool so the Status Line clears.

2. Click the Single Line tool again.

The X status field is active, showing that you can enter a value for the X coordi-
nate of the line's beginning point.

Do not press ENTER (Windows) or RETURN (Macintosh) until you reach step #14.

3. Type 0.

4. Press the TAB key. The Y data field highlights. 

5. Type 0.

6. Press the TAB key. The Z data field highlights.

7. Type 0.

8. Press the TAB key.

The dX data field highlights. The dX value is the delta X, the numeric difference 
between the beginning and ending X coordinate.

9. Type 2.

10. Press the TAB key. The dY data field highlights. 

11. Type 2.

12. Press the TAB key. The dZ data field highlights.

13. Type 0.

14. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.

Creating Geometry Offset from a Point
If you want to create geometry offset from an existing point, you can use the Status 
Line to specify the offset.

Creating Geometry Offset from a Point
1. Select the tool you want to use.

2. Move the pointer over the control point from which you want the offset.

3. Click once to lock onto that point.

4. Finish creating the geometry.



Coordinate System Axis
5. With the geometry still selected, click in the appropriate X, Y, or Z data field in 
the Status Line, placing the text cursor at the end of the entry.

6. Type the offset (such as + 3) and press ENTER (Windows) or RETURN (Macin-
tosh).

7. Continue with your construction.

Coordinate System Axis
The coordinate system axis, at the left of the Status Line, 
displays the coordinate system currently set for the file. You 
can choose either the Global (world coordinate system) or 
a user-defined coordinate system. The graphic below repre-
sents the global coordinate system. The default system is the Global coordinate sys-
tem.

The Global System aligns with the X, Y and Z axes (X = 1, 0, 0; Y = 0, 1, 0; Z = 0, 0, 
1). The user-defined coordinate system is set by you. Planes labeled as DynWork-
Plane or UserWorkPlane# are part of the user-defined coordinate system. See Chap-
ter 32 for information on the Work Plane Manager and defining your own work 
planes.

Choosing a Coordinate System
1. Choose the coordinate system by clicking on the coordinate system axis icon at 

the far left of the Status Line.

Selected point 
from which 
geometry will 
be offset

Offset reference on 
new geometry 
(location appropriate 
to selected tool)

X Offset

Y
 O

ffs
et
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Referral:

See Chapter 32 for informa-
tion on defining a work 
plane.
A menu displays.

2. Choose the GlobalWorkPlane, DynWorkPlane or any 
user-defined work plane.

The work plane and coordinate system are now set.

3. Continue designing.

Message Line
The Message Line is an important fea-
ture when drawing. After selecting a 
tool, the line displays the tool name 
and the first step in its use.

Some tools display a subpalette and a pull-down option list. As you finish each 
step, the next step displays until all steps are completed. The Message Line may 
also display additional commands that can be used with the tool.

Trackball
The Trackball gives you the ability to rotate the view orienta-
tion of your geometry in the drawing area. You can also rotate 
the view around an object by selecting it before using the 
Trackball. The objects include features such as holes. You have 
to select the hole through the Design Explorer to do the rota-
tion. (Selecting a hole results in a view rotation around the 
hole center by referencing the faces and edges introduced by 
the hole.)

To display the Trackball, choose Window>Trackball. When 
the Trackball displays a check mark appears in front of the 
command in the Windows menu. You can drag the Trackball to 
any location in your drawing area.

You can toggle the Trackball between two display types, the 
sphere display and the step display. Both displays include a views pull-down menu.

Axis Locking
The Trackball will lock rotations to an X, Y or Z axis. Hold down the X, Y or Z key 
on your keyboard while using the mouse in the Trackball window and the Track-
ball will rotate only in the direction of the key being pressed.



Trackball
Sphere Trackball
The Sphere Trackball gives the ability to drag your view to the 
desired rotation. You can drag beyond the boundary of the 
trackball and continue the rotation. The sphere trackball is the 
default display.

Using the Sphere Trackball
1. Choose Window>Trackball.

2. Drag the pointer on the Trackball to rotate the view.

The model rotates as you drag. See a later section for setting view rotation 
options. The model continues rotating if you drag the pointer past the edge of 
the trackball display and until you release the mouse button.

Setting View Rotation Options
You can to set view rotation options for the 
Sphere Trackball in the View Rotation Options 
dialog box.

To display the dialog box, double-click on the 
gray area of the Sphere Trackball.

The View Rotation Options dialog box appears 
containing the following:

Type Allows you to set the rotation type, Model or 
Screen. 

The Model option rotates the view around the x, y 
and z axis as displayed by the Axis icon. 

The Screen option rotates the view around the 
screen axis with the x axis oriented horizontally, 
the y axis oriented vertically and the z axis ori-
ented normal to the screen.

Origin Allows you to set the origin at either the Model 
Point or the Object Center.

The Model Point option gives you the ability to 
determine the rotational point yourself. You can 
either enter the values in the x, y and z data fields 
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or click on your geometry to set the location (val-
ues are entered automatically).

The Object Center option gives you the ability to 
rotate your geometry around the center of the 
objects in your drawing. This center is calculated 
by your Desiger Elements program. When you 
select this option, the x, y, and z data fields are 
unavailable.

You can choose only one of the four rotational options, Model Type, Screen Type, 
Model Point Origin or Object Center Origin.

Click OK to accept your settings and close the dialog box or Cancel to close the 
dialog box without accepting the changes.

Step Trackball
The Step Trackball gives you have ability to rotate your view in 
regular angle increments or in a continuous movement and 
provides you with addition options in the View Rotation 
Options dialog box.

Change the Sphere Trackball to the Step Trackball by clicking 
the arrow button on the right side of the Trackball title bar.

The Step Trackball includes the following icons:

Directional Arrows These arrows allow you to rotate your view in a 
specific direction. Clicking the vertical arrows 
rotates your geometry about the x axis. Clicking 
the horizontal arrows rotates your geometry about 
the y axis. Clicking the angled arrows rotates your 
geometry about the z axis. (In the View Rotation 
Options dialog box, you can choose either the 
model or screen axis to reference the rotation 
when using these arrows. See a later section, “Set-
ting View Options,” for more information.)

Step Rotation This display, represented by the stair icon, 
toggles with Continuous Rotation. With the 
step icon displayed, rotation moves 



Trackball
through stepped increments in the direction you 
select.

You can set the degree increment for the steps in 
the View Rotation Options dialog box. See a later 
section, “Setting View Options,” for more informa-
tion.

Continuous Rotation This display, represented by the circular 
arrow, toggles with Step Rotation. With this 
icon displayed, rotation is a continuous 

motion in the direction you select. 

You can temporarily halt the rotation by placing 
the cursor over the arrow and pressing. When you 
release the mouse, the rotation continues. To stop 
the continuous rotation, click the circular arrow 
icon.

Using the Step Trackball
1. Choose Window>Trackball.

2. Click on the arrow button on the right side of the Trackball title bar to change 
the display to the Step Trackball.

3. Click one of the directional arrows. The model rotates a specified number of 
degrees. Or...

Click on the Step Rotation icon to toggle the display to the Continuous Rotation 
icon and click one of the directional arrows. Click on the circular arrow icon to 
stop the rotation.

Setting View Rotation Options
Your Desiger Elements program allows you to 
set view rotation options for the Step Trackball 
in the View Rotation Options dialog box.

To display the dialog box, double-click on the 
black area of the Step Trackball. View Rotation 
Options containing these options:

Type This option sets the rotation type, Model or Screen. 
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The Model option rotates the view around the x, y 
and z axis as displayed by the Axis icon. The 
option allows you to rotate the model around one 
stationary axis. See the graphic here.

The Screen option rotates the view around the 
screen axis with the x axis oriented horizontally, 
the y axis oriented vertically and the z axis ori-
ented normal to the screen.

Step Angle Allows you to set the rotation angle for the Step 
Trackball.

Origin Allows you to set the origin at either the Model 
Point or the Object Center.

The Model Point option gives you the ability to 
determine the rotational point yourself. You can 
either enter the values in the x, y and z data fields 
or click on your geometry to set the location (val-
ues are entered automatically.

The Object Center option gives you the ability to 
rotate your geometry around the center of the 
objects in your drawing. This center is calculated 
by your Desiger Elements program. When you 
select this option, the x, y, and z data fields are 
grayed out.

You can choose only one of the four rotational options, Model Type, Screen Type, 
Model Point Origin or Object Center Origin.
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Click OK to accept your settings and close the dialog box or Cancel to close the 
dialog box without accepting the changes.

Trackball View Menu
The Trackball has a pull-down menu for specifying the view or saving the current 
view. The views available in this menu include the default views and any user-
defined views.

Using the Trackball View Menu
1. Move the pointer to the current view name dis-

played at the bottom of the Trackball window.

2. Press the mouse button.

The Trackball views menu displays.

3. Choose the view orientation you want to dis-
play in the current window.

The view orientation changes to your specifica-
tion in the view window. A check mark appears 
next to the selected view, as shown here.

View Rotation Short Cut
You can rotate your view by holding down the SHIFT key and pressing one of the 
keyboard arrows. This rotates the view a specified number of degrees.

You can also change your view with the following keyboard short cuts: a - Side 
View, s - Front View, d - Top View, f- Isometric View and g - Trimetric View.

Drawing Display Commands
There are a number of commands that display features that may assist you in creat-
ing geometry. These include: Show/Hide Triad, Show/Hide Axis, Show/Hide Work 
Plane, Show/Hide Points and the Grid commands.
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Show/Hide Triad
This command in the Planes menu toggles the display of the Triad 
symbol in the upper-left corner of the view windows. The Triad 
illustrates the orientation of the x, y, z axes and the work plane. See 
Chapter 3 for more information on the Triad.

Show/Hide Axis
This command in the View menu toggles the display of the Axis 
symbol at the drawing origin. The Axis establishes the direction 
of the x, y and z axes. The Axis can clarify the geometry location 
when rotating the view.

Show/Hide Work Plane
This command in the Planes menu toggles the display of 
the Work Plane icon on your geometry. The graphic below 
shows the work plane set to the Top plane.

Show/Hide Points
This command in the Edit menu toggles the display of the control points for 
selected objects. See Chapter 4, “Selecting Objects,” for more information.

Grid
The grid overlays your drawing and can help you create and align geometry. The 
grid is made up of horizontal and vertical lines of dots. The grid commands, Show/
Hide Grid and Snap to Grid are found in the Planes menu. Set your Grid prefer-
ences (spacing, the number of divisions, display appearance and startup options by 
choosing File>Preferences>Grid.

Show/Hide Grid Command
This command in the Planes menu toggles the display of the grid. The grid is 
always aligned with the work plane's x and y axis. You can display the grid when 
viewing any plane.

Snap to Grid Command
This command in the Window>Snaps menu toggles on and off and is normally 
used with the grid. However, this command does not require that the grid is dis-
played.

Top

y

z

x



Drawing at Full Scale

Tip:

If you notice a gray rectangle 
in your drawing area when 
you first start your Desiger 
Elements program, choose 
File>Page Setup. The 
option, Show Page Breaks in 
Drawing Windows may be 
selected. The gray rectangle is 
the page bounds.
When Snap to Grid is on (a check mark appears next to the name), the Drafting 
Assistant snaps all geometry to the grid. In other words, if the grid is set to .25 inch 
spacing, you can't construct an object closer than .25 inch to another object.

Drawing at Full Scale
Whether you are designing or drafting a highly detailed blueprint, you should cre-
ate the geometry at its actual size. Your Desiger Elements program allows you to 
construct the part using full-scale specifications and then set the visual scale of the 
drawing. In this way, the part dimensions to its true-to-life measurements. Drawing 
at full scale has the following advantages:

• Scaling mistakes are eliminated

• Dimensions are automatic (you must dimension manually if you do not draw at 
full scale)

• Associative dimensions update when the object is edited (manual dimensions do 
not)

• The size relationship of imported parts is compatible.

Once your project is drawn, you can dimension it and scale it visually to fit into a 
standard drawing size, if you wish with the Print Setup command (Windows) or 
Page Setup command (Macintosh) in the File menu. Regardless of how you set up 
your drawing, the actual size of the geometry remains constant unless you edit it.

If you want to create ensure that your geometry is contained within a specified 
page bounds at a 1:1 scale, you can display the page bounds. See Chapter 37 for 
more information.

When you open a new Desiger Elements program document, the drawing area is an 
infinitely large sheet so that you can design anything at full size. For a simplistic 
example, here's how to draw and view a line 83 feet long:

1. Draw a line, specifying 83' for the length. 

The line extends off the screen. 

2. Choose View>Zoom All.

The entire 83 foot line is visible on the screen.

Using the draw to scale/Zoom All method, you can create accurate full-scale draw-
ings which are displayed at the magnification you choose. The actual size of an 
object is not affected by zoom magnification or reduction. 
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Zoom All magnifies or reduces all objects on your drawing to fill the screen— 
regardless of the size of the objects.

Default versus Selected Object Settings
When no object is selected, any setting changes made with respect to Selectable 
Points, Grid, Axis, Triad, Show Points, Construction Lines, User-defined plane, Pen, 
Text, Dimension, tool palettes (choice, status and location) and Render become the 
default for all open files and the current Desiger Elements program session. When 
an object is selected, any change made will only affect the object.

Escape Key
When geometry becomes quite complex, the time required for operations to com-
plete will inevitably lengthen. You can interrupt the command by pressing the ESC 
key.

Progress Bar
The progress bar provides you with feedback when opening files, importing or 
exporting files or performing complex operations. The bar provides you with feed-
back about the status of the operation.

Right Mouse Button
Your Desiger Elements program gives you access to commands though the right 
mouse button. If you are a Macintosh user and do not have a right mouse button, 
these same commands are available by holding down the CONTROL key and press-
ing the mouse button.

Different sets of commands display depending on whether the button is pressed 
while on or off an object or when a drawing view is activated.



Right Mouse Button
Over No Object
When you click the right mouse button (Windows) or Con-
trol + mouse button (Macintosh), the following popup 
menu appears:

The menu includes the following commands:

Zoom All, Zoom Window, These commands are the same as those in the 
View menu.

Dynamic Pan, Dynamic Zoom, These commands perform the same function as the 
Dynamic Pan, Dynamic Zoom and Dynamic 
Rotate tools in the View tool palette. When you 
select one of these commands, the pointer icon 
becomes that of the tool. You can perform the 
operation once and then the icon reverts back to 
the selected tool.

If you want to perform multiple operations, hold 
down the Shift key before selecting the command. 
When you release the Shift key, the icon reverts 
back to the selected tool.

View This command displays all default views and any 
user-defined views.

Zoom In, Zoom Out

Dynamic Rotate
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Planes This command displays the same commands as 
those in the Planes menu, with the exception of 
the Show Work Pln command.

Show All This command is enabled when objects are hidden 
in the drawing and is the same as the Show ALL 
command in the Show-Hide dialog box.

Over An Object
When you select an object. place the pointer over the 
selected object and click the right mouse button (Win-
dows) or Control + mouse button (Macintosh), the fol-
lowing popup menu appears:

The menu includes the following: 

Hide, Show Only These commands are 
the same as those in 
the Show-Hide dia-
log box allowing you 
to hide or show the 
object.

Resolution This command dis-
plays a menu allowing you to change the object’s 
resolution to Super Fine, Very Fine, Fine Medium 
or Coarse.

Color This command displays the color menu allowing 
you to change the color or the object. These are 



Right Mouse Button
the same color options available when choosing 
Pen>Color.

Layer This command allows you to change the object’s 
layer to any layers in the file, whether or not a 
layer is hidden. It also includes The More com-
mand. Selecting More displays the following dialog 
box:

Click on the Create New Layer button and then 
click OK to move the object to the new layer. The 
new layer is titled with a default name (for exam-
ple, Layer3). You can change the name through 
the Layer Manager (Layout>Layer Manager).

Edit Objects This command displays the Edit Objects dialog 
box.

Object Name The name of the object appears in the menu. You 
can change the object’s name by clicking on the 
name. The following dialog box appears: 

Type a new name and click OK to make the 
change.
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Object Characteristics For a wireframe object, the menu also provides its 
geometric characteristics. For example, an ellipse 
displays the major radius, the minor radius and cir-
cumference.

Selected Drawing View
When a drawing view is selected and you click the right 
mouse button (Windows) or Control + mouse button 
(Macintosh), the following popup menu appears:

These commands are identical to those in the Drawing 
View pull-down menu. See Chapter 36 for information on 
these commands.



Introduction to Wireframe Modeling
In your Desiger Elements program you have the ability to create wireframe, surface 
and solid models. The most basic model is the wireframe model. A wireframe con-
sists of the geometry that makes up the edges of the object. The word “wireframe” 
relates to the idea of a wire that is bent to follow an object's edges. A wireframe 
model is the simplest mathematical representation of an object.

Wireframes in your Desiger Elements program consist of points, lines, arcs, circles, 
ellipses, conics, splines or a combination of any of these. These particular wire-
frames are also collectively referred to as curves. Although wireframes are limited in 
the amount of model content they represent, they are powerful building blocks for 
creating more complex models composed of surfaces and solids.

A wireframe model can often be used in place of a prototype (to run simulations 
and tests on the computer rather than in the laboratory). Models can be used for 
checking visual specification, measuring distances between points within the model 
and observing the visual and real intersections of lines.
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The topics discussed in this chapter include:

• Wireframe tools

• Wireframes and the Drafting Assistant

• Wireframes, Selection and Display

• Object Types and Edit Objects

Wireframe Tools
These chapters in this section describe how to create wireframe geometry with your 
Desiger Elements program tools. They also provide information on how the Draft-
ing Assistant helps you design faster and easier.

Wireframe tools are contained in the main tool palette, 
located at the left side of the Desiger Elements program draw-
ing area.

You can change the default status (open or closed) and loca-
tion of the main tool palette by choosing your status and 
location and quitting your Desiger Elements program. The 
next time you launch the program, the palette will retain the 
status and location you chose.

Each icon in the palette is the first in the subpalette of tools 
grouped together by purpose, as shown here. 



Wireframes and the Drafting Assistant
Information on using each tool is contained in the chapters that follow.

Wireframes and the Drafting Assistant
The Drafting Assistant recognizes several useful snap locations associated with 
wireframe objects. These dynamic snap locations include:

• Endpoints

• Midpoints

• Intersections

• Projections

• Centers

• Vertices

• Tangencies

The Drafting Assistant recognizes such points in all three dimensions, making 3D 
drafting much easier.

Wireframes, Selection and Display
Wireframes are selected when they are within the selection fence or the boundaries 
of a single pick box as defined in Preferences (see Chapter 6, “Preference Set-
tings”). Conics, ellipses, splines and circles have resolution attributes that impact 
the screen display and printer output. You can change the resolution of the selected 
object by choosing Edit>Change Resolution.
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Changing an Object's Resolu-
tion
1. Select the object.

2. Choose Edit>Change Resolution.

The Object Resolution dialog box 
appears.

You have five resolution options: 
Super Fine, Very Fine, Fine, Medium and Coarse. Medium is the default option.

.

Objects Characteristics and Edit Objects

All wireframe objects you create with a Desiger Elements program tool are defined 
by their own geometric, display and attribute characteristics. The Edit Objects dia-
log box provides information for these three categories. Where the display and 
attribute characteristics are identical for wireframe objects, the geometric character-
istics differ according to a particular object.

For example: A line created by the Single Line tool includes the following geomet-
ric categories: Length, Angle, End 1 (X, Y and Z values) and End 2 (X, Y and Z val-
ues).

Chapters 8 through 13 introduce you to the wireframe tools. With every tool 
description there is a list of the geometric characteristics displayed in the Edit 
Objects dialog box. For information on using the Edit Objects command and the 
dialog box, see Chapter 24.



Tech Note:

Vellum 3D Users: your 
Designer Elements program, 
unlike Vellum 3D, will not 
create a second entity if you 
hit ENTER (Windows) or 
RETURN (Macintosh) while 
still in a tool.
Line Tools

The Line tools in the Line tool palette create line segments, connected lines, lines 
parallel to existing lines and points. As you create a line, the coordinate locations, 
line length and angle from horizontal appear in the Status Line. All geometry 
appears in the current pen specifications for color, weight and pattern.

For each tool you can enter values in the Status Line to define a line, either before 
or after you create it. If you enter the values after you select the tool but before you 
create the line, your first click in the drawing area automatically registers all Status 
Line values. If you enter values in the selected Status Line data field after creating 
the line and while the line is still selected, pressing ENTER (Windows) or RETURN 
(Macintosh) updates the line to reflect the new values.

The topics explained here include

• Single Line Tool

• Connected Lines Tool

• Parallel Line Tool

• Point Tool

• Modifying Lines

Your Designer Elements program does not support Smart Wall entities. All imported 
Smart Walls are converted into individual curves.
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Single Line Tool

This tool draws a line between two points. You can click points to draw a line.

Using the Single Line Tool
1. Select the tool. The Message Line reads: Single Line: Pick the beginning point. 

[Ctrl = Copy Previous] (Windows) or [Option = Copy Previous (Macintosh)].

2. Click to place the first endpoint of the line.

3. Move the cursor to a new location. As you do, a rubberband image appears that 
previews your construction.

4. Click to place the last point of the line.

To copy the line just created, as the Message Line indicates, hold down the CTRL 
(Windows) or the OPTION (Macintosh) key and click once in the drawing area to 
set the beginning point. An identical line appears beginning where you clicked and 
on the current work plane.

The Status Line contains the X, Y, and Z coordinates of the beginning, the relative 
location of the end (delta X, delta Y and delta Z), the line length, and the angle 
from horizontal. (If any of the fields do not display, click the arrow at the right end 
of the Status Line). Once a line is drawn, the Length field is active in the Status Line.

Drawing a Line Perpendicular to Another Object
1. Construct the object.

2. Move the pointer to the object until a Drafting Assistant on notation appears 
(endpoint, midpoint, quadrant etc., will not work, only “on”).

3. Drag straight away from the object in a perpendicular direction. A perpendicu-
lar line will appear attached to the object. Notice that the line stays perpendic-
ular but slides along the object.

Point 2

Point 1



Connected Lines Tool
4. Drag to the desired length.

Drawing a Line Tangent or Perpendicular to an Arc, Circle or 
Ellipse
1. Construct an arc, circle, or ellipse.

2. Choose the Single Line tool. 

3. Move the pointer to the arc until a Drafting Assistant on notation appears (end-
point, midpoint, quadrant etc., will not work, only “on”).

4. Drag in the appropriate direction (straight out for perpendicular or at an angle 
for tangent) until the Drafting Assistant perpendicular or tangent notation 
appears. 

5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line 
around the arc to the desired location and extend the line to the desired length.

Geometric Characteristics
A single line is created by clicking two points and is made up of the following char-
acteristics: Length, Angle, End 1 (X, Y and Z values) and End 2 for X, Y and Z val-
ues). This information is listed in the Edit Objects dialog box under the Geometry 
tab. To display the dialog box, select the line and choose Window>Edit Objects or 
double-click on the line.

Connected Lines Tool

This tool draws lines in which the endpoint of one line segment is the beginning 
point of the next. 

Using the Connected Lines Tool
1. Select the tool. The Message Line reads: Connected Lines: Pick the beginning 

point.
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2. Click to indicate the endpoints of the line segments. 

If you click a point and then change your mind, press the ESC key, or choose 
Undo to remove the last segment.

After the beginning point is set, the Message Line changes to reflect the next step.

3. Indicate the last point by double-clicking, hitting the ESC key or by choosing 
another tool.

After completing at least one seg-
ment with the Connected Lines 
tool, you can create a tangent arc 
off of the last line by holding down 
the CTRL (Windows) or the OPTION 
(Macintosh) key (the pointer tempo-
rarily changes to an “arc” icon) and 
clicking or dragging to the next 
point. The Message Line notes this 
added feature. Several tangent arcs can be strung together by continuing to hold 
down the CTRL (Windows) or OPTION (Macintosh) key.

The radius of arcs created with this method cannot be edited in the Status Line.) 

The Status Line contains the X, Y and Z coordinates of the beginning, the relative 
location of the end (delta X, delta Y and delta Z), the line length and the angle from 
horizontal. Once a line segment is drawn, the Length field is active in the Status 
Line.

Geometric Characteristics
A connected line is multiple single lines connected at their endpoints. Lines are 
made up of the following characteristics: Length, Angle, End 1 (X, Y and Z values) 
and End 2 (X, Y and Z values). This information is listed in the Edit Objects dialog 
box under the Geometry tab. To display the dialog box, select the line and choose 
Window>Edit Objects or double-click on the line.



Parallel Line Tool
Parallel Line Tool

This tool constructs a line parallel to an existing line 
in the current work plane.

Using the Parallel Line Tool
1. Select the tool. The Message Line reads: Parallel 

Line: Drag new line off existing line.

2. Drag off the desired line and release to indicate 
the position for the new parallel line. A rubber-
band line moves with the pointer. The distance 
field is active in the Status Line and displays dis-
tance from the original line that you dragged. 

If you type in your own value and hit ENTER (Windows) or RETURN (Macintosh), 
the parallel line will move the offset distance specified.

The Status Line contains the Offset data field.

Geometric Characteristics
A parallel line is a duplicate of a line created by the Single Line tool or the Con-
nected Lines tool. The line is made up of the following characteristics: Length, 
Angle, End 1 (X, Y and Z values) and End 2 (X, Y and Z values). This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog 
box, select the line and choose Window>Edit Objects or double-click on the line.

Point Tool

When you select the Point tool, a subpalette appears in the Message Line, with 
three Point tools, Point at an XYZ Location, Points on a Curve and Points on 
Surface.
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You can choose the appearance of the points using any 
of these tools. Press the CTRL (Windows) or the 
OPTION (Macintosh) key to display the Point Markers 
dialog box.

Click the radio button for the desired marker (crosshairs 
plus, crosshairs x, empty diamond or empty square) 
and click OK to close the dialog box. When you click to 
place the point in the drawing area, the point is repre-
sented by the new marker. The Point Marker style can-
not be saved as a preference.

Using the Point at an XYZ Location Tool

You create individual points in your drawing area with this tool.

1. Select the Point tool from the palette.

2. Select the Point at an XYZ Location tool in the Message Line. The Message 
Line reads: Point: Enter point. [Ctrl = Marker (Windows) or Option = Marker 
(Macintosh)].

3. Click a point in the drawing area.

The Status Line contains the X, Y and Z location of the point.

Using the Points on a Curve Tool

This tool places a series of points distributed 
equally along a curve (remember that curves include lines, circles, ellipses, arcs and 



Point Tool
splines). You cannot use this tool on polygons created using one of the Polygon 
tools.

1. Select the Point tool from the palette.

2. Select the Point on a Curve tool in the Message Line. The Message Line reads: 
Point on Curve: Select curves to distribute points on. [Ctrl = Marker (Windows) 
or Option = Marker (Macintosh), Shift = Extend].

3. Enter the number of points you want distributed along the curve in the #Pts 
data field of the Status Line.

4. Select the curve. If you want to select more than one curve, hold down the 
SHIFT key before selecting the first curve and while selecting succeeding 
curves.

Points are equally distributed along the curve. For closed curves, the start and 
endpoint are the same.

The Status Line contains the number of points to distribute along a selected curve.

Using the Points on a Surface Tool

This tool places a series of points distributed equally 
along a surface.

1. Select the Point tool from the palette.
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2. Select the Points on a Surface tool in the Message Line. The Message Line 
reads: Point on Surface: Select surface(s) to distribute points on. [Ctrl = Marker 
(Windows) or Option = Marker (Macintosh), Shift = Extend].

3. Enter the number of points you want distributed along the surface in two per-
pendicular directions in the #U and #V data fields of the Status Line. U and V 
represent perpendicular coordinate directions along the surface. (The letters U 
and V are standard identifiers for surface coordinates.)

4. Select the surface.   If you want to select more than one surface, hold down the 
SHIFT key before selecting the first surface and while selecting succeeding sur-
faces.

Points are equally distributed in a grid like pattern across the surface.

The Status Line contains the number of points to distribute in the U and V direction 
for the surface.

Geometric Characteristics
A Point is created by a single click placed in one or more locations depending on 
the tool used. Points are made up of the following characteristics: X, Y and Z coor-
dinates and the Display Style of the Point (crosshair plus, crosshair x, empty dia-
mond, empty square). This information is listed in the Edit Objects dialog box 
under the Geometry tab. To display the dialog box, select the point and choose 
Window>Edit Objects or double-click on the point.

Modifying Lines
You can modify a line in a number of ways. See Chapter 21 for information on the 
Editing tools. After creating a line, you can change any value including length if the 
line is still selected.

For example, you can type a new length, press ENTER (Windows) or RETURN 
(Macintosh) and the length will change. If you decide that the length is not correct, 
you can choose Edit>Undo and the line will return to the previous length. If you 
decide to change the length of the line again you may either select the line with the 
selection tool and edit information in any of the status line boxes or you may dou-
ble click on the line to bring up the Edit Objects dialog box and edit all aspects of 
the line there.



Arc & Circle Tools
This chapter contains information on the Arc and Circle tools available in your 
Designer Elements program. As you create an arc or circle, the coordinate locations 
and radius/diameter appear in the Status Line. The arc or circle is also drawn with 
the current pen specifications for color, weight and pattern.

For each tool you can enter values in the Status Line to define an object, either 
before or after you create the object. If you enter the values after you select the tool 
but before you create the object, your first click in the drawing area automatically 
registers all Status Line values. If you enter values in the selected Status Line data 
field after creating the object and while the object is still selected, pressing ENTER 
(Windows) or RETURN (Macintosh) updates the object to reflect the new values.

The tools explained here include:

• Center-Point Arc

• 3-Point Arc

• Tangent-Point Arc

• Center-Point Circle

• Opposite-Point Circle

• 3-Point Circle

• Tangent Circle
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Arc Tools

Your Designer Elements program features three arc tools: Center-Point Arc, 3-
Point Arc and Tangent Point Arc.

Center-Point Arc Tool

This tool draws an arc based on three points: the 
center point, the beginning point and the end-
point of the arc.

Using the Center-Point Arc Tool
1. Select the tool. The Message Line reads: Center-Point Arc: Pick Center.

2. Click the center point of the arc. The Message Line now tells you the 
next step in using the tool.

3. Click the beginning point of the arc which will also define the radius.

4. As you move the cursor to place the final point, a rubberband arc 
appears. Click the final point.

To construct an arc greater than 180°, you must create one of 180° or less, double-
click the arc to bring up the Edit Objects dialog box and enter the desired degrees.

The Status Line contains the X, Y and Z coordinates of the center of the arc, the 
Radius, the starting angle from horizontal, A, and the delta angle from the start, dA. 
The Radius field is active in the Status Line.

Geometric Characteristics
The center-point arc is created from a center point and two arc points. Arcs are 
made up of the following characteristics: Diameter, Start Angle, End Angle, Start (X, 
Y and Z values) and End (X, Y and Z values). This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the 
arc and choose Window>Edit Objects or double-click on the arc.



Arc Tools
The Start and End Angles refer to the angles tangent to the arc point relative to the 
work plane.

3-Point Arc Tool

This tool draws an arc through the points you select. 

Using the 3-Point Arc Tool
1. Select the tool. The Message Line reads: 3-Point Arc: 

Pick first point. [Ctrl = Tangent to object (Windows) or 
Option = Tangent to object (Macintosh)].

2. Click the first endpoint of the arc.

Notice that the Message Line tells you the next step for 
using the tool.

3. Click the second point of the arc. A rubberband arc appears as you move the 
cursor to a third position.

4. Click the last point of the arc. The arc is created.

The arc is drawn from the first position that you indicate, through the second posi-
tion and ends at the third position. For each of the three clicks that define the arc, if 
the CTRL (Windows) or the OPTION (Macintosh) key is held down and you click 
on some other object, your Designer Elements program will define the arc to 
be tangent to that object at the nearest tangency point.

The Status Line contains the X, Y and Z coordinates for each of the three points.

Geometric Characteristics
A 3-point arcs is created by placing three points and are made up of the following 
characteristics: Diameter, Start Angle, End Angle, Start (X, Y and Z values) and End 
(X, Y and Z values). This information is listed in the Edit Objects dialog box under 
the Geometry tab. To display the dialog box, select the arc and choose Win-
dow>Edit Objects or double-click on the arc.
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Tangent-Point Arc Tool

This tool draws an arc beginning at 
the first point you specify. The second point you specify is the direction vector and 
the third point you specify indicates the endpoint of the arc. Essentially, the Tan-
gent-Point Arc tool first creates a line then creates an arc tangent to the line and 
erases the line.

Using the Tangent-Point Arc Tool
1. Select the tool. The Message Line reads: Tangent-Point 

Arc: Pick beginning point of arc (tangent line).

2. Click the starting point. This is both the starting point of 
the arc and the starting point of the temporary tangent 
line.

The Message Line displays the next step for using the tool.

3. Click the endpoint of the tangent line. 

4. Click the endpoint of the arc. The arc is drawn between the first and last point 
you click, tangent to the line between the first and second points.

The Status Line contains the X, Y and Z coordinates of the endpoints of the arc and 
the angle of the tangent line.

Geometric Characteristics
A tangent-points arc is created by clicking points for the tangent line and the arc 
and are made up of the following characteristics: Diameter, Start Angle, End Angle, 
Start (X,Y and Z values) and End (X, Y and Z values). This information is listed in 
the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the arc and choose Window>Edit Objects or double-click on the arc.

First Click Second Click

Third Click



Circle Tools
Circle Tools

The Circle tools include the Center-Point Circle, Opposite-Point Circle, 3-Point 
Circle and Tangent Circle.

The Center-Point tool uses the center and diameter of the circle. The 3-Point tool 
uses three points and can be tangent to existing objects. The Tangent-Point tool 
draws a circle tangent to two objects, using the diameter specified by the user.

The circle is drawn with the current pen specifications for color, weight and pat-
tern.

Center-Point Circle Tool

This tool draws a circle specified by the center point 
and diameter.

Using the Center-Point Circle Tool
1. Select the tool. The Message Line reads: Center-

Point Circle: Pick center. [Ctrl = Copy previous (Windows) or Option = 
Copy previous (Macintosh)].

2. Click the center of the circle. A rubberband circle appears guiding 
your construction as you move the cursor.

3. Click the second point which determines the circle's radius.

You can create a copy of the last circle by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking once in the drawing area to set the cen-
ter point. An identical circle appears center at the point you clicked on the current 
work layer.

The Status Line contains the X, Y and Z coordinates of the center and the diameter 
of the circle. Diameter is the active status field.
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Tip:

You can select the center 
point of an opposite point 
circle if you display its control 
points using the Show Points 
command in the Layout 
menu.
Geometric Characteristics
A center-point circle is created by clicking the center point and a point on the cir-
cle. Circles are made up of the following characteristics: Diameter and Center (X, Y 
and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the circle and choose Win-
dow>Edit Objects or double-click on the circle.

Opposite-Point Circle Tool

This tool draws a circle specified by the 
diameter. 

Using the Opposite-Point Circle Tool
1. Select the tool. The Message Line reads: Opposite-

Point Circle: Pick first point on circle. [Ctrl = Copy 
previous (Windows) or Option = Copy previous 
(Macintosh)].

2. Click two locations to indicate the diameter. After you click the first point, a 
rubberband circle appears to guide you in the construction.

You can create a copy of the last circle by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking once to place the center point of the new 
circle. An identical circle appears center at that point on the current work layer.

The Status Line allows you to specify the X, Y and Z coordinates representing the 
endpoints of the diameter.

Geometric Characteristics
An opposite-point circle is created by clicking two points to establish the diameter. 
Circles are made up of the following characteristics: Diameter and Center (X, Y and 
Z values). This information is listed in the Edit Objects dialog box under the Geom-
etry tab. To display the dialog box, select the circle and choose Window>Edit 
Objects or double-click on the circle.



Circle Tools
3-Point Circle Tool

This tool draws a circle through the points you 
select. 

Using the 3-Point Circle Tool
1. Select the tool. The Message Line reads: 3-Point Circle: Pick first point. [Ctrl = 

Tangent to object (Windows) or Option = Tangent to object (Macintosh)].

2. Click the first point on the circle.

Notice that the Message Line displays the next step for using the tool.

3. Click the second and third points. After the second point a rubberband circle 
appears guiding your construction.

If you place any of the three points on an existing object, the circle is drawn 
through that point. If you click an object while holding down the CTRL (Windows) 
or OPTION (Macintosh) key, the circle is drawn tangent to the object rather than 
through the indicated point. You may combine the placement of these points to cre-
ate a circle through a specific point of one object and tangent to another object, or 
tangent to three objects, etc.

The Status Line contains the X, Y and Z coordinates for each of the three points.

Geometric Characteristics
A 3-point circle is created by clicking three points to set the boundary of the circle. 
Circles are made up of the following characteristics: Diameter and Center (X, Y and 
Z values). This information is listed in the Edit Objects dialog box under the Geom-
etry tab. To display the dialog box, select the circle and choose Window>Edit 
Objects or double-click on the circle.

Tangent-Point Circle Tool

This tool draws a circle tangent to two 
objects.
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Using the Tangent-Point Circle Tool
1. Select the tool. The Message Line reads: Tangent Circle: Enter diameter then 

pick first tangent object.

2. You can enter a diameter for the circle in the Status Line data field.

3. Click the objects to which the circle is to be tangent.

Geometric Characteristics
A tangent-point circle is created by entering the circle diameter and clicking on 
objects to establish tangency. Circles are made up of the following characteristics: 
Diameter and Center (X, Y and Z values). This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the 
circle and choose Window>Edit Objects or double-click on the circle.
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Ellipse & Conic Tools

This chapter contains information on using the Ellipse tools and Conic tools. As 
you create an ellipse, the coordinate locations, lengths of the control rectangle and 
angles appear in the Status Line. As you create a conic, the rho value appears in the 
Status Line. These objects are also drawn with the current pen specifications for 
color, weight and pattern.

For each tool you can enter values in the Status Line to define an object, either 
before or after you create the object. If you enter the values after you select the tool 
but before you create the object, your first click in the drawing area automatically 
registers all Status Line values. If you enter values in the selected Status Line data 
field after creating the object and while the object is still selected, pressing ENTER 
(Windows) or RETURN (Macintosh) updates the object to reflect the new values.

The tools explained here include:

• 2-Point Center Ellipse 

• Opposite Corner Ellipse

• 3-Point Center Ellipse

• 3-Corner Ellipse

• 2-Point Conic

• 3-Point Conic

R
T
n
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Tip:

Vellum 3D Users: Ellipses 
are enhanced in your 
Designer Elements program 
and are now defined by cen-
ters.
• 4-Point Conic

Ellipse Tools

You can create ellipses with four tools: 2-Point Center, Opposite-Corner, 3-Point 
Center and 3-Corner. These tools in the main tool palette construct ellipses 
inscribed within an invisible rectangle or parallelogram. The 2-Point Center Ellipse 
tool uses the center point and one corner location of the rectangle. The Opposite-
Corner Ellipse tool uses opposite corners of a rectangle. The 3-Point Center 
Ellipse tool uses the center point, the midpoint of a side and the corner of the par-
allelogram. The 3-Corner Ellipse tool uses three corners of a parallelogram.

Ellipses are defined by their Major and Minor Diameters, the Start and End Angles 
and their centers. The Start and End Angles specify the start and end location of the 
ellipse measured from the major axis.

The graphic here shows an ellipse with a Start and End 
Angle of 90° and 180°.

The ellipse is drawn with the current pen specifications for 
color, weight and pattern.

2-Point Center Ellipse Tool 

This tool constructs an ellipse inscribed 
within a rectangle defined by two specified 
points: the center point and one corner of 
the rectangle.

Using the 2-Point Center Ellipse Tool
1. Select the tool. The Message Line reads: 2-Point Center Ellipse: Pick 

center of ellipse. [Ctrl = Copy previous (Windows) or Option = Copy pre-
vious (Macintosh)].

2. Indicate the center of the ellipse.

Notice that the Message Line displays the next step for using the tool.

Y

X
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3. Indicate the corner of the rectangle defining the ellipse.

If the two points are on the vertical or horizontal axis, a straight line is drawn.

You can create a copy of the last ellipse by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking where you want the center. The copy is 
placed on the current work layer.

The Status Line allows you to specify the X, Y and Z coordinates of the center point 
and the length and angle of the semi-major and semi-minor axes of the ellipse. 

Geometric Characteristics
A 2-point center ellipse is created by placing the center point and corner of the 
control rectangle. It is made up of the following characteristics: Major Diameter, 
Minor Diameter, Start Angle, End Angle, and Center (X, Y and Z values). This infor-
mation is listed in the Edit Objects dialog box under the Geometry tab. To display 
the dialog box, select the ellipse and choose Window>Edit Objects or double-click 
on the ellipse.

Opposite-Corner Ellipse Tool

This tool draws an ellipse inscribed in a 
rectangle specified by opposite corners.

Using the Opposite-Corner Ellipse Tool
1.Select the tool. The Message Line reads: Opposite-Corner Ellipse: 
Pick first corner of rectangle. [Ctrl = Copy previous (Windows) or 
Option = Copy previous (Macintosh)].

2.Indicate one corner of the rectangle defining the ellipse.

Notice that the Message Line displays the next step for using the tool.

3. Indicate the opposite corner of the defining rectangle.

If the two points are on the vertical or horizontal axis, a straight line is drawn.
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You can create a copy of the last ellipse by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking to place the lower-left point. The copy is 
placed on the current work layer.

The Status Line allows you to specify the X, Y and Z coordinates of the lower-left 
point, the length of the major and minor axes, L1 and L2 and angle of the major and 
minor axes, A1 and A2 of the ellipse. 

Geometric Characteristics
An opposite-corner ellipse is created by placing two points that represent the cor-
ners of the control rectangle and is made up of the following characteristics: Major 
Diameter, Minor Diameter, Start Angle, End Angle and Center (X, Y and Z values). 
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the ellipse and choose Window>Edit Objects or dou-
ble-click on the ellipse.

3-Point Center Ellipse Tool

This tool constructs an ellipse inscribed within a 
parallelogram calculated from three specified 
points: a center point, a midpoint of a side and a 
corner of the parallelogram.

Using the 3-Point Center Ellipse Tool
1. Select the tool. The Message Line reads: 3-Point Center Ellipse: Pick center of the 

ellipse. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macintosh)]. 
The Message Line will guide you through each successive step.

2. Pick the center of the ellipse.



Ellipse Tools
3. Pick the midpoint of the side of the control parallelogram defining the ellipse.

4. Pick the corner of the control parallelogram defining the ellipse.

If the three points are on the vertical or horizontal axis, a straight line is drawn. You 
can create a copy of the last ellipse by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking where you want the center. The copy is 
placed on the current work layer.

The Status Line allows you to specify the X, Y and Z coordinates of the center point 
and the length and angle of the sides of the parallelogram. 

Geometric Characteristics
A 3-point center ellipse is created by placing the center point, midpoint of the side 
and the corner of the control parallelogram. It is made up of the following charac-
teristics: Major Diameter, Minor Diameter, Start Angle, End Angle and Center (X, Y 
and Z values). This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the ellipse and choose Win-
dow>Edit Objects or double-click on the ellipse.

3-Corner Ellipse Tool

This tool draws an ellipse inscribed in a parallelo-
gram defined by three corners. 

Using the 3-Corner Ellipse Tool
1. Select the tool. The Message Line reads: 3-

Corner Ellipse: Pick first corner of control par-
allelogram. [Ctrl = Copy previous (Windows) or Option = Copy previous (Macin-
tosh)]. The Message Line will guide you through each successive step.

2. Pick one corner of the parallelogram defining the ellipse.

3. Pick another corner of the defining parallelogram.
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4. Pick the final corner of the defining parallelogram.

If the three points are on the vertical or horizontal axis, a straight line is drawn. You 
can create a copy of the last ellipse by holding down the CTRL (Windows) or the 
OPTION (Macintosh) key and clicking to place the lower-left corner of the parallel-
ogram. The copy is placed on the current work layer.

The Status Line allows you to specify the X, Y and Z coordinates of a corner and 
the length and angle of the sides of the parallelogram. 

Geometric Characteristics
A 3-corner ellipse is created by placing the three points that represent the corners 
of the control rectangle and is made up of the following characteristics: Major 
Diameter, Minor Diameter, Start Angle, End Angle and Center (X, Y and Z values). 
This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the ellipse and choose Window>Edit Objects or dou-
ble-click on the ellipse.

Modifying Ellipses
You can modify any ellipse in a number of ways:

• After it’s created and while it’s still selected by entering new values in the Status 
Line

• Using the Transformation tools (see Chapter 25)

• Using Edit Objects

• Select a control point and dragging it to a new location. The number of control 
points available to edit is based on the tool used to create the ellipse. A 2-Point 
Center ellipse has 2 control points.

Conic Tools

You can create conics with three tools: 2-Point Conic, 3-Point Conic and 4-Point 
Conic. The 2-Point Conic tool uses the start point and end point to define the 
conic. The 3-Point Conic tool uses the start point, end point and slope control 
point to define the conic. The 4-Point Conic tool uses the start point, end points, 



Conic Tools
slope control point and shoulder point to define the conic. The rho value is the 
dimension ratio of the distance from the center point to the shoulder point and the 
center point and the slope control point. The graphic below illustrates the defini-
tions of the conic characteristics.

When using a conic tool a rubberband image appears after you place all but the last 
point. This allows you to see the ellipse before it is drawn. The conic is drawn with 
the current pen specifications for color, weight and pattern.

2-Point Conic Tool

This tool constructs a conic calculated from three specified 
points: the start point, end point and slope control point.

Using the 2-Point Conic Tool
1. Select the tool. The Message Line reads: 2-Point Conic: Pick start point. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message 
Line will guide you through each successive step.

2. Pick the start point of the conic. As you move the cursor to place the second 
point, a rubberband image appears.

3. Pick the end point to complete the conic.

You can modify the Rho value in the Status Line and press ENTER (Windows) or 
RETURN (Macintosh) to accept the new rho value. Rho values must be between 
.501 and .999. A rho value of .501 will create a straight line. A rho value of .999 
will create a conic with a 90° angle.

Slope Control Point

Shoulder Point
Start Point

A
B

End Point

Rho = A
B

Start Point

End Point
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You can create a copy of the last conic by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking to indicate the start point. The copy is 
placed on the current work layer.

The Status Line allows you to specify the Rho value of the conic.

Geometric Characteristics
A 2-point conic is created by placing two points; the start point and end point and 
is made up of the following characteristics: Rho, End 1 (X, Y and Z values) and End 
(X, Y and Z values). This information is listed in the Edit Objects dialog box under 
the Geometry tab. To display the dialog box, select the conic and choose Win-
dow>Edit Objects or double-click on the conic.

3-Point Conic Tool

This tool constructs a conic calculated from 
three specified points: the start point, end 
point and slope control point.

Using the 3-Point Conic Tool
1. Select the tool. The Message Line reads: 3-Point Conic: Pick start point. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message 
Line will guide you through each successive step.

2. Pick the start point of the conic.

3. Pick the end point of the conic. Once you place this third point, a rubberband 
image appears.

4. Pick the shoulder point to complete the conic.

You can modify the Rho value in the Status Line and press ENTER (Windows) or 
RETURN (Macintosh) to accept the new rho value. Rho values must be between 
.501 and .999. A rho value of .501 will create a straight line. A rho value of .999 

Slope Control Point
Start Point

End Point
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will create a conic with a 90° angle.

You can create a copy of the last conic by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking to indicate the start point. The copy is 
placed on the current work layer.

The Status Line allows you to specify the Rho value of the conic.

Geometric Characteristics
A 3-point conic is created by placing three points; the start point, end point and 
slope control point and is made up of the following characteristics: Rho, End 1 (X, 
Y and Z values) and End 2 (X, Y and Z values). This information is listed in the Edit 
Objects dialog box under the Geometry tab. To display the dialog box, select the 
conic and choose Window>Edit Objects or double-click on the conic.

4-Point Conic Tool

This tool constructs a conic calculated from 
four specified points: the start point, end 
point, slope control point and shoulder point.

Using the 4-Point Conic Tool
1. Select the tool. The Message Line reads: 4-Point Conic: Pick start point. [Ctrl = 

Copy previous (Windows) or Option = Copy previous (Macintosh)]. The Message 
Line will guide you through each successive step.

2. Pick the start point of the conic.

3. Pick the end point of the conic.

4. Pick the slope control point of the conic. Once you place this third point, a rub-
berband image appears.

5. Pick the shoulder point to complete the conic.

Slope Control Point

Shoulder Point
Start Point

End Point
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You can modify the rho value in the Status Line and press ENTER (Windows) or 
RETURN (Macintosh) to accept the new rho value. Rho values must be between 
.501 and .999. A rho value of .501 will create a straight line. A rho value of .999 will 
create a conic with a 90° angle.

You can create a copy of the last conic by holding down the CTRL (Windows) or 
the OPTION (Macintosh) key and clicking to indicate the start point. The copy is 
placed on the current work layer.

The Status Line allows you to specify the Rho value of the conic.

Geometric Characteristics
A 4-point conic is created by placing four points; the start point, end point, slope 
control point and shoulder point and is made up of the following characteristics: 
Rho, End 1 (X, Y and Z values) and End 2 (X, Y and Z values). This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog 
box, select the conic and choose Window>Edit Objects or double-click on the 
conic.



Polygon Tools

These tools draw rectangles, inscribed polygons, circumscribed polygons, arbitrary 
polygons and polygons from curves. The polygon is drawn with the current pen 
specifications for color, weight and pattern.

For each tool you can enter values in the Status Line to define a polygon, either 
before or after you create the polygon. If you enter the values after you select the 
tool but before you create the polygon, your first click in the drawing area automat-
ically registers all Status Line values. If you enter values in the selected Status Line 
data field after creating the polygon and while the polygon is still selected, pressing 
ENTER (Windows) or RETURN (Macintosh) updates the polygon to reflect the new 
values.

Every polygon tool but the Polygon from Curves tool, pro-
vides two options for creating polygons, Single Line and 
Smart Polygon. These options are available through a pull-
down menu in the Message Line.

Polygons created with the Single Line option, are composed of individual lines that 
can be modified independently. These polygons can be filleted/chamfered, 
extruded, revolved, offset or relimited.

Polygons created with the Smart Polygon option are true polygons, whose width 
and height can be modified. These objects cannot be filleted/chamfered, extruded, 
revolved, offset, or relimited with the 2D wireframe tools however you can perform 
3D operations such as extrudes, blends and revolutions on these entities. To per-
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form these operations on a smart polygon with 2D wireframe tools convert it into 
individual lines by choosing Edit>Change Object Type and select the line option. 
See Chapter 24, “Editing Commands,” for more information.

The tools explained here include:

• Rectangle

• Inscribed Polygon

• Circumscribed Polygon 

• Arbitrary Polygon

• Polygon from Curves

Rectangle Tool 

When you select the Rectangle tool, a subpalette appears in the Message Line con-
taining four tools for creating rectangles, Polygon by center & point, Polygon by 
diagonals, Polygon by center & axis and Polygon by major & minor axes

The rectangle tools create rectangles from the selected points as directed by the 
specific tool.

Center/Corner Rectangle Tool 

This tool draws a rectangle, using the center and corner you specify.

Using the Center/Corner Rectangle Tool
1. Select the Rectangle tool from the palette.

Corner

MidpointCenter

CornerCorner



Rectangle Tool
2. Select the Center/Corner Rectangle tool in the Message Line. The Message 
Line reads: Rectangle: Pick center point of rectangle. [Ctrl = Copy previous (Win-
dows) or Option = Copy previous (Macintosh)].

3. Pick the center point of the rectangle. As you move the cursor, a rubberband 
image appears.

4. Pick rectangle corner.

With the rectangle still selected, you can change the width and height of the rectan-
gle by entering the values in the Status Line fields and pressing ENTER (Windows) 
or RETURN (Macintosh). You can also change the width and the height of a rectan-
gle in the Edit Objects dialog box.

You can create a copy of the last rectangle by holding down the CTRL (Windows) 
or the OPTION (Macintosh) key and clicking where you want the upper-left corner.

The Status Line allows you to specify the X, Y and Z coordinates of the first point, 
as well as the width and height of the rectangle. Width is the active status field.

Diagonal Rectangle Tool

This tool draws a rectangle based on two corners along a diagonal.

Using the Diagonal Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Diagonal Rectangle tool in the Message Line. The Message Line 
reads: Rectangle: Pick first corner of rectangle. [Ctrl = Copy previous (Windows) 
or Option = Copy previous (Macintosh)].

3. Click one corner of the rectangle. As you move the cursor a rubberband image 
appears.

4. Click the opposite corner of the rectangle.

With the rectangle still selected, you can change the width and height of the rectan-
gle by entering the values in the Status Line fields and pressing ENTER (Windows) 
or RETURN (Macintosh).You can also change the width and the height of a rectan-
gle in the Edit Objects dialog box.
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You can create a copy of the last rectangle by holding down the CTRL (Windows) 
or the OPTION (Macintosh) key and clicking where you want the upper-left corner.

The Status Line allows you to specify the X, Y and Z coordinates of the first point, 
and the rectangle’s width and height. Width is the active field.

You can create a square by aligning the second point on the 45° construction line. 
If the two points are on the vertical or horizontal axis, a straight line is drawn. If 
you want to draw a square from the center rather than opposite corners, use one of 
the other polygon tools, specifying four sides. You can’t create a rectangle from the 
center.

Center/Axis Rectangle Tool

This tool draws a rectangle using the center, midpoint and corner.

Using the Center/Axis Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Center/Axis tool in the Message Line. The Message Line reads: Rect-
angle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or Option 
= Copy previous (Macintosh)].

3. Click the center point of the rectangle.

4. Click the midpoint of the rectangle side. As you move the cursor a rubberband 
image appears.

5. Click the corner of the rectangle.

With the rectangle still selected, you can change the width and height of the rectan-
gle by entering the values in the Status Line fields and pressing ENTER (Windows) 
or RETURN (Macintosh).

You can also change the width and the height of a rectangle in the Edit Objects dia-
log box.

You can create a copy of the last rectangle by holding down the CTRL (Windows) 
or the OPTION (Macintosh) key and clicking where you want the upper-left corner.



Rectangle Tool
The Status Line allows you to specify the X, Y and Z coordinates of the first point, 
as well as the width and height of the rectangle. Width is the active status field.

Major/Minor Axis Rectangle Tool

This tool draws a rectangle using the corners you specify.

Using the Major/Minor Rectangle Tool
1. Select the Rectangle tool from the palette.

2. Select the Major/Minor Axis tool in the Message Line. The Message Line reads: 
Rectangle: Pick center point of rectangle. [Ctrl = Copy previous (Windows) or 
Option = Copy previous (Macintosh)].

3. Click the first corner of the rectangle.

4. Click the second corner of the rectangle. As you move the cursor, a rubberband 
image appears.

5. Click the third corner of the rectangle.

With the rectangle still selected, you can change the width and height of the rectan-
gle by entering the values in the Status Line fields and pressing ENTER (Windows) 
or RETURN (Macintosh).

You can also change the width and the height of a rectangle in the in Edit Objects 
dialog box.

You can create a copy of the last rectangle by holding down the CTRL (Windows) 
or the OPTION (Macintosh) key and clicking where you want the upper-left corner.

The Status Line allows you to specify the X, Y and Z coordinates of the first point, 
as well as the width and height of the rectangle. Width is the active status field.

Geometric Characteristics
A rectangle polygon is created by picking the appropriate points as directed by the 
selected tool in the rectangle subpalette. A rectangle is made up of the following 
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characteristics according to the Edit Objects dialog box: Length and Width and 
includes the option to Show Frame and Show Fill. 

Show Frame refers to the display of the polygon. Show Fill refers to the placement 
of a fill within the polygon. Setting Show Frame to No, turns off the wireframe dis-
play. (If the wireframe is not displayed and does not contain a fill, your geometry 
will become invisible when your click Apply.) Setting Show Fill to Yes, places a fill 
within the polygon, based on the default pattern and fill currently selected in the 
Pen menu. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the polygon and choose Win-
dow>Edit Objects or double-click on the polygon.

Inscribed Polygon Tool

This tool creates a polygon where the radius of the cir-
cumscribing circle determines the location of the poly-
gon’s vertices. 

The default polygon is a hexagon, but you can specify the 
number of sides in the Status Line. The Status Line shows 
a diameter for the circle, the standard way of describing a 
polygon inscribed in a circle.

Using the Inscribed Polygon Tool
1. Select the tool. The Message Line reads: Inscribed 

Polygon: Pick center of polygon. [Ctrl = Copy previ-
ous (Windows) or Option = Copy previous (Macintosh)].

2. Click the center of the polygon. The Message Line reads: Inscribed Polygon: 
Pick vertex of polygon. As you move your cursor a rubberband polygon appears 
guiding your construction. 

3. Pick a point on the circumference of the circumscribing circle to complete the 
polygon.

You can create a copy of the last inscribed polygon by holding down the CTRL 
(Windows) or OPTION (Macintosh) key and clicking where you want the center.



Circumscribed Polygon Tool
The Status Line allows you to specify the X, Y and Z coordinates of the center, the 
diameter of the circle defining the polygon, and the number of sides. Diameter is 
the active Status Line selection, and the default number of sides is six.

Geometric Characteristics
An inscribed polygon is created by picking the center and the vertex of the poly-
gon. It is made up of the following characteristics according to the Edit Objects dia-
log box: Diameter, Sides, Scribe Type and includes the option to Show Frame and 
Show Fill.

Scribe Type refers to circle type used to define the polygon. Choosing Circle Out-
side places the polygon within the circle, defining an inscribed polygon. Choosing 
Circle Inside places the polygon on the outside of the circle, defining a circum-
scribed polygon. 

Show Frame refers to the display of the polygon. Show Fill refers to the placement 
of a fill within the polygon. Setting Show Frame to No, turns off the wireframe dis-
play. (If the wireframe is not displayed and does not contain a fill, your geometry 
will become invisible when your click Apply.) Setting Show Fill to Yes, places a fill 
within the polygon, based on the default pattern and fill currently selected in the 
Pen menu. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the polygon and choose Win-
dow>Edit Objects or double-click on the polygon.

Circumscribed Polygon Tool

This tool draws a polygon in which the radius/diameter 
of the circle determines the midpoint of the sides. The 
default shape is a hexagon but you can specify the 
number of sides in the Status Line. Notice that the Sta-
tus Line shows a diameter for the circle, the standard 
way of describing a polygon circumscribed around a 
circle.
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Using the Circumscribed Polygon Tool
1. Select the tool. The Message Line reads: Circum-

scribed Polygon: Pick center of polygon. [Ctrl = Copy 
previous (Windows) or Option = Copy previous 
(Macintosh)].

2. Click the center of the polygon and the midpoint of one of the sides (as 
directed by the Message Line).

After you place the first point, a rubberband polygon appears guiding construc-
tion.

You can create a copy of the last circumscribed polygon by holding down the CTRL 
(Windows) or OPTION (Macintosh) key and clicking where you want the center.

The Status Line allows you to specify the X, Y and Z coordinates of the center, the 
diameter of the circle defining the polygon, and the number of sides. The default 
number of sides is six. Diameter is the default Status Line selection.

Geometric Characteristics
A circumscribed polygon is created by picking the center and the midpoint of the 
polygon side. It is made up of the following characteristics according to the Edit 
Objects dialog box: Diameter, Sides, Scribe Type and includes the option to Show 
Fill and Show Frame. 

Scribe Type refers to circle type used to define the polygon. Choosing Circle Out-
side places the polygon within the circle, defining an inscribed polygon. Choosing 
Circle Inside places the polygon on the outside of the circle, defining a circum-
scribed polygon. 

Show Frame refers to the display of the polygon. Show Fill refers to the placement 
of a fill within the polygon. Setting Show Frame to No, turns off the wireframe dis-
play. (If the wireframe is not displayed and does not contain a fill, your geometry 
will become invisible when your click Apply.) Setting Show Fill to Yes, places a fill 
within the polygon, based on the default pattern and fill currently selected in the 
Pen menu. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the line and choose Window>Edit 
Objects or double-click on the polygon.



Arbitrary Polygon Tool
Arbitrary Polygon Tool

This tool draws a polygon with the number of sides deter-
mined by the points you choose.

Using the Arbitrary Polygon Tool
1. Select the tool. The Message Line reads: Arbitrary 

Polygon: Pick first point. [Ctrl = Copy previous (Win-
dows) or Option = Copy previous (Macintosh)].

2. Click the next point (as directed by the Message Line).

3. Continue clicking points to complete the desired polygon. Single click the last 
point to close the polygon at its starting point. (If you try to double-click at this 
point you will receive an error message.)

You can also double-click to place the last point (that is not the starting point of 
the polygon and your Designer Elements program will close the polygon auto-
matically.

You can create a copy of the polygon by holding down the CTRL (Windows) or 
OPTION (Macintosh) key and clicking where you want the center.

The Status Line allows you to specify the X, Y and Z coordinates of the first point. X 
is the default Status Line selection.

Geometric Characteristics
An arbitrary polygon is created by placing the desired points for the polygon. It is 
made up of the following characteristics according to the Edit Objects dialog box: 
Defining Point and the options to Show Fill and Show Frame. 

Defining Point refers to the chosen’s point X, Y and Z location. The section below 
Defining Points lists the points with the X, Y and Z location. The selected point is 
displayed in the Defining Point fields. Each point can be edited individually.

Show Frame refers to the display of the polygon. Show Fill refers to the placement 
of a fill within the polygon. Setting Show Frame to No, turns off the wireframe dis-
play. (If the wireframe is not displayed and does not contain a fill, your geometry 
will become invisible when your click Apply.) Setting Show Fill to Yes, places a fill 
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within the polygon, based on the default pattern and fill currently selected in the 
Pen menu. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the polygon and choose Win-
dow>Edit Objects or double-click on the polygon.

Polygon from Curves Tool

This tool creates a polygon from the curves you choose. The curves do not have to 
be connected to create a polygon. If these curves are not connected, the tool adds 
curves to complete the polygon. The polygon created when a curve is missing 
depends on the order of the curve selection. 

Once the polygon is created a parent/child relationship has been established 
between the original curves and the polygon. The original curves selected are still 
available for editing and any change made will affect the polygon. Due to this same 
parent/child relationship, in order to move the polygon and retain the relationship, 
you must select the curves and the polygon. You can break the relationship by 
selecting them and choosing Edit>Remove Links. See Chapter 24, “Editing Com-
mands” for more information.

The graphic below on the left represents five different curves. The graphic on the 
right is the one polygon created after using the tool.

Using the Polygon from Curves Tool
1. Select the tool. The Message Line reads: Polygon 

from Curves: Select a collection of curves [Shift = 
Extend].

2. Select all the desired curves. If you are selecting the curves individually, hold 
down the SHIFT key before beginning your selection.

A polygon is created from those curves.

There are no entries in the Status Line.



Polygon from Curves Tool
Geometric Characteristics
Using this tool a polygon is created by selecting specific curves. No new geometry 
is created. The following characteristics are listed in the Edit Objects dialog box: 
Show Fill and Show Frame.

Show Frame refers to the display of the polygon. Show Fill refers to the placement 
of a fill within the polygon. Setting Show Frame to No, turns off the wireframe dis-
play. (If the wireframe is not displayed and does not contain a fill, your geometry 
will become invisible when your click Apply.) Setting Show Fill to Yes, places a fill 
within the polygon, based on the default pattern and fill currently selected in the 
Pen menu. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the polygon and choose Win-
dow>Edit Objects or double-click on the polygon.
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Tech Note:

Your Designer Elements pro-
gram creates B-Splines of the 
third and fourth order.
Spline Tools

The spline tools in the main tool palette create NURBS (Non-Uniform Rational B-
Splines). These NURB splines are smooth curves created by a complex mathemati-
cal formula.

NURB splines provide designers with two interrelated functions. First, curvature 
continuity remains intact when the curve is changed. Kinks don't develop as the 
spline is altered. Second, NURB splines provide localized control of a complex 
curve by changing the control points.

These properties are essential in aerodynamic designs. Air molecules moving over a 
wing surface must flow smoothly for maximum aero-dynamic lift. If the surface 
does not maintain curvature continuity, the air molecules separate from the wing 
surface and cause a vacuum. Such a vacuum causes an eddy as the molecules try to 
fill it. This disruption of air flow increases the drag, which is not a part of an effec-
tive design.

Complete curvature continuity also improves styling. The appearance of a car is 
one of the major sales factors. The potential buyer would not be impressed if the 
showroom lights’ reflection on the car rippled and wavered. It is complete curva-
ture continuity that makes a smooth reflection.

Localized control of complex curves allows you to make minor modifications with-
out adversely affecting the shape. For example, if a new, bigger engine wouldn’t fit 
under a perfectly-designed hood, you could use a NURB spline to raise the center 
of the hood without changing the basic design. NURB splines are also valuable for 
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injection mold designs to eliminate the swirl of plastic as it is injected into the mold. 
Such designs provide better surface finishes and allow thinner cross-sections in the 
die.

The spline creation tools are the Through-Points B-Spline tool, Vector Spline 
tool, Bezier Spline tool and Sketch Spline tool. At the most basic level these splines 
are the same. For the Through-Points B-Spline and the Bezier Spline, your Designer 
Elements program has the additional step of interpolating the points to calculate a 
control polygon which is hidden from you. For the Vector Spline the interpolation 
step is eliminated because you define the control polygon to which you have 
access.

Spline control points automatically lock after placement. You can select one point 
and move it without affecting the other control points.

You can enter values in the Status Line to define a spline either before or after you 
create the spline. If you enter the values after you select the tool but before you 
create the spline, your first click in the drawing area automatically registers all Sta-
tus Line values. If you enter values in the selected Status Line data field after creat-
ing the spline and while the spline is still selected, pressing ENTER (Windows) or 
RETURN (Macintosh) updates the spline to reflect the new values. The tools 
explained here include:

• Through-Points B-Spline

• Vector Spline

• Bezier Spline

• Sketch Spline

• Helix Curve

• Add Control Point 

• Remove Control Point 

• Modify Slope

• Elevate Curve

• Fair Curve Spline



Through-Points B-Spline Tool
Through-Points B-Spline Tool

The Through-Points B-Spline tool draws a spline through your specified points. 
Use this tool when you want the B-Spline to interpolate a collection of points. The 
interpolation algorithm is based on predefined B-Spline blending functions, control 
point locations and imposing curvature continuity across the curve length. This 
results in a smooth spline created through your points.

Using the Through-Points B-Spline Tool
1. Select the tool. The Message Line reads: Through-Points B-Spline: Pick 

control points. (End = ESC, Double-click).

2. Click the points for the vectors of the spline.

3. Double-click the last point or hit the ESC key.

The Status Line shows the X, Y and Z coordinates for each point as it is 
placed.

If you create a spline that crosses over itself, the Drafting Assistant will not be able 
to find that intersection. This is by design.

Spline is drawn through points
placed with mouse clicks
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Tip:

: With the Vector Spline 
tool all original points used to 
create the spline will display 
when the spline is selected.
Geometric Characteristics
A Through-Points B-Spline is created by picking the desired points. A spline is 
made up of the following characteristics according to the Edit Objects dialog box: 
Start and End Angles (relative to work plane) and Defining Point.

Angles refer to the degrees of the tangent relative to the work plane for the spline. 
You can change the Start and End Angles by clicking within the check box and 
entering the angle.

Defining Point refers to the X, Y and Z location of the active point. X, Y and Z val-
ues for each point can be edited individually using these fields.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the spline and choose Window>Edit Objects or dou-
ble-click on the spline.

Vector Spline Tool 

This tool draws a spline using vectors determined by the points you specify. The 
Vector Spline tool uses each point that you place as the vertex of a vector for the 
spline it creates. Vector splines are smooth curvature, continuous B-Splines created 
from a control polygon that you define. The polygon influences the shape (position 
and tangencies) of the spline. Except for the start and end points, the control poly-
gon does not necessarily lie on the spline.

Choosing Edit>Show Points will display all the control points used to define the 
spline and can be selected to edit the spline. This provides the additional benefit of 
being able to smooth your spline to eliminate inflections. To determine whether or 



Vector Spline Tool
not your spline has inflections, choose Verify>Curvature. An inflection is located 
where the curvature changes from one side of the spline to the other.

Using the Vector Spline Tool
1. Select the tool. 

The Message Line 
reads: Vector 
Spline: Pick con-
trol points (End = 
ESC, Double-click).

2. Click the points for the vectors of the spline.

3. Double-click the last point.

This Designer Elements program uses these vectors to calculate the control points 
(two fewer than the number of vertices you specify). The spline is tangent to the 
first and last vectors and passes through the calculated control points.

The Status Line shows the X, Y and Z coordinates of each point as they are placed.

Geometric Characteristics
A vector spline is created by picking control points and is made up of the one char-
acteristic according to the Edit Objects dialog box: the Defining Point (X, Y and Z 
location). Defining Point refers to the active point’s X, Y and Z location.   Each 
point can be edited using the X, Y, Z fields. This information is listed in the Edit 

Point placed here Point placed here Point placed here

Point placed here

Point placed here

Control point
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Objects dialog box under the Geometry tab. To display the dialog box, select the 
spline and choose Window>Edit Objects or double-click on the spline.

Bezier Spline Tool

This tool creates curvature continuous (C2) 
splines through a collection of user defined 
points. At each control point, you can control 
the direction and the magnitude of the tangent. After creating a spline with this 
tool, you can move the control points, change the slope (direction) and the influ-
ence of a control point using the spline vector.

The influence of a control point is determined by the length of the control point’s 
vector. The longer the vector, the greater the influence a control point has on the 
spline. You can adjust the length of control point vector but maintain the slope. The 
left graphic here shows a Bezier spline, a selected control point and the direction it 
will be moved to change the influence but maintain the slope. The right graphic 
shows the spline with a longer vector.

You can also use the Add Control Point, Remove Control Point and Modify 
Slope tools to change the spline.

Using the Bezier Spline Tool
1. Select the tool. The Message Line 

reads: Bezier Spline: Pick control 
points (End = ESC, Double-click).

2. Click the points of the spline.

3. Double-click the last point.



Sketch Spline Tool
The Status Line shows the X, Y and Z coordinates of each point as they are placed.

Geometric Characteristics
A Bezier spline is created by picking control points and is made up of the following 
characteristics according to the Edit Objects dialog box: the Defining Point (X, Y 
and Z location) and the points list. This list includes the spline control points and 
the slope points (if displayed). Display the slope points by selecting the spline and 
choosing Edit>Show Points. Defining Point refers to the active point’s X, Y and Z 
location.   Each point can be edited using the X, Y, Z fields. This information is 
listed in the Edit Objects dialog box under the Geometry tab. To display the dialog 
box, select the spline and choose Window>Edit Objects or double-click on the 
spline.

Sketch Spline Tool

The Sketch Spline tool samples points as the cursor moves and creates a smooth 
spline throught the sampled data. Once selected this tool has two options located in 
the Message Line, Sketch Spline tool and Sketch on a Surface tool.

Using the Sketch Spline Tool

1. Select the tool. The Message Line reads: Sketch Spline: Press and drag mouse 
(Option=AutoClose).

2. Click and drag the mouse on the screen.

3. Release the mouse button to create the sketch spline.
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Tech Note:

If you want to sweep a sur-
face on a helix, the helix must 
be created using this tool. See 
Chapter 16 for information 
on using the Sweep Sur-
face tool.
Using the Sketch on a Surface Tool

1. Select the tool. The Message Line reads: Sketch on Surface: Select surface or 
solid to sketch on (Option=AutoClose).

2. Select the surface or solid to sketch on.

3. Click and drag the mouse over the selected surface, keeping the points on the 
surface.

4. Release the mouse button to complete the sketch.

Helix Curve Tool

The Helix Curve tool draws a curve based on its start point, end point, Pitch, diam-
eter, length and draft angle. The endpoint defines the length and orientation of the 
helix. Pitch is the distance between helix peaks (two adjacent turns of the helix). 
The number of turns in the helix is equal to the length of the helix divided by the 
pitch. The draft angle must be a value less than 90°.

You can create a standard helix (left graphic below), a spiral (middle graphic 
below) by entering zero for the helix length, or a swept solid using a helix with a 
draft as the sweep path (right graphic below). 

Using the Helix Curve Tool
1. Select the Helix Curve tool. The 

Message Line reads: Helix Curve: 
Pick start and end of helix [Ctrl 
(Windows) or Option (Macintosh) = 
Left handed helix].



Add Control Point Tool
2. The Status Line contains the Pitch, Diameter, Length and Draft Angle data fields.

Enter the desired values in the appropriate fields. Tab between fields.

3. Pick the start and end point of the helix. A right handed helix is created.

While the helix is still selected you can change the Status Line values. Type the new 
values and press ENTER (Windows) or RETURN (Macintosh) and the helix updates.

Geometric Characteristics
A helix is created by picking the start and end point and specifying the pitch and 
diameter. A helix is made up of the following characteristics according to the Edit 
Objects dialog box: the Diameter, Pitch, Length and Draft Angle.

You also have a check box to change the helix direction. By default, using this tool 
creates a right-handed helix. You can change the helix to a left-handed helix by 
deselecting the Right handed helix option and clicking Apply or Close. If you 
already created a left-handed helix, the box is not checked.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the helix and choose Window>Edit Objects or dou-
ble-click on the helix.

Add Control Point Tool 

This tool allows you to add another control point to an existing spline both within 
the spline and outside of the spline to extend it.
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Using the Add Spline Control Point Tool
1. Select the tool. The Message Line 

reads: Add Control Point: Select 
the spline to add point to (Shift = 
Extend).

2. Click on the spline to which you 
want to add a point.

3. Pick the desired location(s) for the new control point(s).

Note: To see the new control point(s), as well as the existing control points, you 
must first select the spline and then choose Edit>Show Points (or use the Edit 
Objects dialog box to specify whether the Control points are visible or hidden).

There are no Status Line entries for this tool.

Remove Control Point Tool 

This tool allows you to remove a control 
point from an existing spline. A spline must 
have more than two control points to use this 
tool.

Using the Remove Control Point Tool
1. Select the tool. The Message Line 

reads: Remove Control Point: 
Select the spline point to remove 
(Shift = Extend).

2. If the control points of the spline are not displayed, select the spline and 
choose Edit>Show Points.

3. Pick the control point you want to remove.

There are no Status Line entries for this tool.



Modify Slope Tool
Modify Slope Tool 

This tool allows you change the endpoint slope of an existing spline created using 
the Through-Points B-Spline tool. You have four options for changing the slope: 
Free, Reference, Reverse and Explicit.

Free Frees the spline slope and returns it the original 
slope as defined by this Designer Elements pro-
gram for the chosen slope control point. This is 
helpful if you’ve adjusted the slope of a spline in 
numerous locations along the spline and want to 
return to the spline that was originally created.

Reference Uses the slope of other curves or surfaces as a ref-
erence to make the selected curves tangent.

Reverse Reverses a curve 180°.

Explicit Allows you to set the exact slope of the curve rela-
tive to the work plane (between 0° and 360°). A 
slope of 0° will make the curve tangent to the 
plane. Choose Planes>Show Work Plane when 
using this option to assist you.

Using the Modify Slope Tool - Free Option
1. Select the tool. The Message Line reads: Modify Slope: Select spline slope(s) to 

free (Shift = Extend).

2. Choose the Free option in the pull-down menu of the Message Line.

3. If the control points of the spline are not displayed, select the spline and 
choose Edit>Show Points.

4. Pick the spline slope control endpoint you want to free.

The slope control endpoint returns to its original position.

There are no Status Line entries for this tool.
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Using the Modify Slope Tool - Reference Option
1. Select the tool. The Message Line reads: Modify Slope: Select the spline end to set 

slope at (Shift = Extend).

2. Choose the Reference option in the pull-down menu of the Message Line.

3. If the control points of the spline that you want modified are not displayed, 
select the spline and choose Edit>Show Points.

4. Pick the spline want to modify. In the 
graphic here, it's the spline displaying 
points.

5. Pick the curve, surface or solids whose 
slope you want to reference.

The icon now becomes a target icon.

6. Click on the endpoint of the curve 
you want to modify, (The curve and 
the reference object do not have to 
connect.) The curve slope adjusts.

There are no Status Line entries for this 
tool.

Using the Remove Control Point Tool - Reverse Option
1. Select the tool. The Message Line reads: Modify Slope: Select spline slope point to 

reverse (Shift = Extend).

2. Choose the Reverse option in the pull-down menu of the Message Line.



Modify Slope Tool
3. If the control points of the spline are not displayed, select the spline and 
choose Edit>Show Points.

4. Pick the spline slope control endpoint you want to reverse, as in the left 
graphic below. The slope control endpoint reverses 180° (right graphic).

There are no Status Line entries for this tool.

Using the Modify Slope Tool - Explicit Option
1. Select the tool. The Message Line reads: Modify Slope: Select spline slope point 

for explicit set (Shift = Extend).

2. Choose the Explicit option in the pull-down menu of the Message Line.

3. If the control points of the spline are not displayed, select the spline and 
choose Edit>Show Points.

4. Pick the spline control endpoint you want to set. 
An Input String dialog box appears.

5. Enter the Angle for the slope in the data field and 
click OK. The dialog box closes and the slope of 
the spline is adjusted. (Click Cancel if you want to 
close the dialog box without changing the angle 
value.)

There are no Status Line entries for this tool.
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Using the Modify Slope Tool - Free Magnitudes Option
1. Select the tool. Choose the Free Magnitudes option in the pull down menu. The 

Message reads: Modify Slope: Select Spline Magnitude to free (Shift=Extend).

2. If the control points of the spline are not diplayed, select the spline and choose 
Edit>Show Points.

3. Select the bezier curve control point you want to free.

The Bezier slope resets to an optimally calculated slope.

Elevate Curve Tool

This tool elevates the degree of a curve, introducing more control points. These 
control points can be used to modify the curve.

Curves are defined by NURB polynomial equations. The most basic question possi-
ble is used to define the curve. Shapes defined by higher degree polynomials have 
more control points than those defined by lesser degree polynomials. This tool-
raises the degree level for a shape, providing more control points for curve manip-
ulation. Curves can be elevated up to the 22nd degree. However, it is 
recommended that you never elevate a curve highter than 9 degrees. The left side 
of the graphic below shows the original ellipse. The right side of the graphic below 
shows the ellipse elevated one degree.



Modify Slope Tool
Using the Elevate Curve Tool
1. Select the Elevate Curve 

tool. The Message Line 
reads: Elevate Curve: Pick 
curve to elevate [Shift=Extend].

2. Select the curve to elevate.

The curve elevates one degree.

There are no entries in the Status Line.

Fair Spline Tool

The Fair Spline command provides a tool to globally smooth a curve. Fairing a 
spline optimally moves control vertices to locations that minimize large curvature 
variations. Curves eligible for fairing are limited to vector splines. It’s helpful to 
watch the control vertices move as you fair the spline with the Edit>Show Points 
command. You can also use the Verify>Curvature tool to visually inspect the cur-
vature graph of a curve.

Using the Fair Spline Tool
1. Select the tool. The Message Line reads: Fair Spline: Select curve to fair.

2. Click on the spline which you want to fair.

The status line displays a move tolerance value for the tool. 
The move tolerance is the maximum distance a spline con-
trol vertex will be allowed to move towards its optimal 
position.
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Introduction to Surface Modeling
A surface/mesh model is a more complete and less ambiguous representation than 
a wireframe model. Surface models take the representation of an object one step 
beyond wireframe models by defining the area between selected boundaries with 
smooth equations. Mesh models also go beyond wireframe models but are defined 
by nodes or vertices. Consequently, surface and mesh modeling provides a means 
for the designer to create complex shapes such as cars, ships and aircraft.

Your Designer Elements program surfaces are based on Spatial Technology’s ACIS 
Geometry Engine. ACIS surfaces are composed of Non Uniform Rational B-Splines 
(NURBs). NURBs provide a highly precise yet flexible mathematical definition for 
modeling even the most demanding free form shapes. Surfaces generated with your 
Designer Elements program are suitable for precise geometric analysis and can be 
passed to computer aided manufacturing applications that support SAT or IGES file 
formats.
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The topics discussed in this chapter include:

• Surface Modeling tools

• Surfaces, Selection and Display

• Surfaces and Instances

• Cutting and Pasting Surfaces

• Exporting Surfaces

• Object Types and Edit Objects

Surface Modeling Tools
The surface modeling tools are accessible from the Sur-
faces tool palette. The Surfaces tool palette automati-
cally displays when you first launch your Designer 
Elements Program. If you close the palette and need to 
display the palette again, choose Window>Surfaces.

The palette will appear under the main tool palette on 
the left side of your screen.

You can save the open status of the palette and its loca-
tion, simply by quitting your Designer Elements pro-
gram. The next time you launch the program, the palette 
will be open and placed in the last location.

Each icon in the palette is the first in a subpalette of tools grouped together with a 
similar purpose. From top to bottom they include:

• Surface Primitive tools

• Surface From Curves tools



Surface Modeling Tools
• Feature Surface tools

• Surface Utility tools

• Local Surface tools

Surface Primitive Tools

The Surface Primitives tool palette provides tools for quickly creating surfaces from 
simple shapes and parameters. This tool palette provides a means to create Infinite 
Planes, Speheres, Blocks, Cylinders and Pyramids. (For more information on 
these tools see chapter 16.)

Surface From Curves Tools

Use the Surfaces From Curves tools to construct surfaces built upon curves. This 
tool palette is home to the Net, Ruled, Skin, Cover, Revolution (lathe), 
Extruded, Swept, Swept 2 rail and Pipe surface tools.(For more information on 
these tools see chapter 16.)

Feature Surface Tools

The Feature Surface tool palette constructs surfaces built upon other surfaces. The 
tools in this palette include Offset, Loft, Draft, Fillet and Tangent Cover Surface. 
(For more information on these tools see chapter 16.)
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Surface Utilites Tools

After you’ve constructed or imported surfaces into your model, you may need to 
refine or combine the surfaes with other entities. Your Designer Elements program 
provides several tools which make these tasks easy to complete. The Surface Utili-
ties palette is home to tools such as Entity Intersections, Projections, Joining, 
Trimming and Silhouette Curves commands. (For more information on these 
tools see chapter 21.)

Local Surface Tools

This tool palette provides commands to modify the internal shape or definition of a 
surface. Example tools located in this palette include, Surface Slope Matching, 
Rebuilding, Untrimming, Degree Elevation and Knot Insertion. (For more 
information on these tools see chapter 21.)

Surfaces, Selection and Display
You can select a surface by clicking anywhere within its boundary. However, your 
Designer Elements program will find the surface fastest if you select the surface's 
edge. A surface is displayed by its boundary edges and any existing interior holes. 
You can increase a surface's edge resolution with the Change Resolution command 
in the Edit menu.

Changing an Object's Resolution
1. Select the object.

2. Choose Edit>Change Reso-
lution.

The following Object Resolu-
tion dialog box appears.



Surface Associativity
You can choose one of five resolutions, Super 
Fine, Very Fine, Fine, Medium and Coarse. Select 
the desired resolution and click OK to close the 
dialog box. The object changes accordingly. The 
graphic illustrates each option.

3. Enter the desired number of Iso lines. Check 
the Show Silhouettes box if desired.

The # Iso Lines allow you to control the isopram 
lines drawn for a surface. These Iso (isopram) 
lines are constant parameter curves that lie on a 
surface, typically defined in parameter space. 
The parameter space coordinate system uses U and V coordinates. A 0 (zero) in 
both fields turns off Iso lines. The appropriate U/V values may enhance the visual 
appearance of the surface at the expense of drawing speed. The letters, U and V 
are space coordinate identifiers (U = horizontal, V = vertical) that are the industry 
standard. The Force U=V check box automatically sets equal number of U and 
V lines. Entering a new value in one automatically changes the other isoline 
value.

The Silhouette check box controls the silhouette edges of objects. Silhouette 
edges are view dependent and can cause a significant reduction in drawing 
speed. A check in the box turns the silhouette on.

4. Click OK to close the dialog box and save the new settings.

Surface Associativity
Surfaces are associative to the original curves used to create them. Changing the 
curve automatically changes the dependent surface. For example, if you create a 
skin surface from three arcs and change the radius of one of the arcs, the skin sur-
face automatically updates to reflect the change. Use the Edit>Remove Links com-
mand to remove all associativity with the surface if you do not want curve changes 
to affect the surface. Another important issue to remember with the curve/surface 
associativity is that if the curve is deleted, the surface deletes as well. Since it is 
defined by the curve, it is no longer valid.

Cutting and Pasting Surfaces
When you cut a surface into the paste buffer, two sets of data get stored. The first 
set of data is a Designer Elements program object that will precisely paste into the 
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current file or into another Designer Elements program drawing. The second set of 
data is a collection of display vectors in the bitmap format. You can paste this data 
into other Windows or Macintosh programs that support the clipboard.

Exporting Surfaces
Your Designer Elements program provides several methods for exporting surfaces 
into other applications. Our primary goal is for you to preserve as much data a pos-
sible during the export. Use the following export option order when exporting sur-
faces:

• ASIS (.SAT)

• Parasolids (.x_t) (Windows only)

• ProE (.g)(Windows only)

• STEP

• DXF with imbedded .sat

• IGES

• StereoLithography (.stl)(Mesh surfaces only)

Objects Types and Edit Objects
Every surface or mesh object you create with a Designer Elements program tool is 
defined by its own characteristics, and include geometric characteristics and 
attributes. These are displayed in the Edit Objects dialog box. While the characteris-
tics listed in the Attributes tab are identical, the characteristics listed in the Geome-
try tab vary with each object.

Chapters 15 and 16 introduce you to the surface tools of your Designer Elements 
program. Included with every tool description is a list of the characteristics dis-
played for the object when Edit Objects is chosen. For information on using the Edit 
Objects command and the dialog box, see Chapter 24.



Mesh Creation Tools - 

A mesh is a collection of planar elements typically with three or four sides. It is 
equivalent to the 3D Mesh element found in DXF files.

You can use meshes to model bodies that span areas and for calculating wetted 
areas and volume attributes. Although less accurate than surface modeling, mesh 
modeling uses less memory, and still provides considerable flexibility for those who 
prefer to design only with cross sections. 

Unlike a surface, a mesh object is not defined by a mathematical formula but by 
nodes and 3D vertices. The resolution or precision of a mesh is determined by the 
number of vertices.

A mesh object can be used to create output to rapid prototyping machines and for 
compatibility with AutoCAD R12 files. A mesh object is helpful to people who want 
to control the exact number of facets created for each model.

Of the mesh tools available in your Designer Elements program, the Mesh Curve 
tool is the most powerful. With this tool, you can create sections and “skin” them 
together to obtain areas. Skins can be combined into bodies to calculate body area 
curves. Calculations of the area underneath the curve also yield the body’s volume.

For each tool you can enter values in the Status Line to define a mesh, either before 
or after you create the mesh. If you enter the values after you select the tool but 
before you create the mesh, your first click in the drawing area automatically regis-
ters all Status Line values. If you enter values in the selected Status Line data field 
15-1



Mesh Creation Tools -

15-2

Tech Note:

To select a mesh object 
immediately after you create 
it, choose the Selection 
tool. Otherwise, you will 
continue to create new mesh 
objects.
after creating the mesh and while the mesh is still selected, pressing ENTER (Win-
dows) or RETURN (Macintosh) updates the mesh to reflect the new values.

Your Designer Elements program supports four tools for creating mesh objects, 
Mesh 3 Pts, Mesh 4 Pts, Mesh Curve and Mesh Extrude. The topics explained in 
this chapter include: 

• Mesh 3 Pts tool

• Mesh 4 Pts tool

• Mesh Curve tool

• Mesh Extrude tool

• Mesh and Rendering

• Mesh Notations

To access the Mesh tools go to Window>Mesh.

Mesh 3 Pts Tool

The Mesh 3 Pts tool creates a flat plate triangular 
object from three points that you select.

Using the Mesh 3 Pts Tool
1. Select the tool. The Message Line reads: Mesh 3 Pts: Enter 3 locations for mesh.

If you would like to create the mesh in a plane different than the one currently 
set, change the plane before moving on to the next step.

2. Click three points to define the mesh boundary.

The mesh is created.

There are no entries in the Status Line.

Geometric Characteristics
A 3 points mesh is created by picking the three desired points. A mesh is made up 
of the following characteristic according to the Edit Objects dialog box: the Defin-
ing Point for the X, Y and Z location.



Mesh 4 Pts Tool
Defining Point refers to the X, Y and Z location of the chosen point. The section 
below Defining Points lists the points with the X, Y and Z location. The selected 
point is displayed in the Defining Point fields. Each point can be edited individually 
using these fields.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or dou-
ble-click on the mesh.

Mesh 4 Pts Tool

The Mesh 4 Pts tool creates a flat plate rectangular 
object from four points that you select.

Using the Mesh 4 Pts Tool
1. Select the tool. The Message Line reads: Mesh 4 Pts: Enter 4 locations for mesh.

If you would like to create the mesh in a plane different than the one currently 
set, change the plane before moving on to the next step.

2. Click four points to define the mesh boundary. 

The mesh is created.

There are no entries in the Status Line.

Geometric Characteristics
A 4 points mesh is created by picking the four desired points. A mesh is made up of 
the following characteristics according to the Edit Objects dialog box: the Defining 
Point for the X, Y and Z location.

Defining Point refers to the X, Y and Z location of the chosen point. The section 
below Defining Points lists the points with the X, Y and Z location. The selected 
point is displayed in the Defining Point fields. Each point can be edited individually 
using these fields.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or dou-
ble-click on the mesh.
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Mesh Curve Tool

The Mesh Curve tool creates an M by N mesh from a 
collection of curves. M is the number of curves you 
select to define the mesh boundary. The mesh is cre-
ated from the order in which you select them. N is number of segment lines you 
want displayed on the mesh. The graphic above shows a mesh curve with M = 4 
(curves) and N = 20 (grid lines).

The Mesh Curve tool provides several options that 
control mesh spacing. You can pick them from the 
drop down list in the Message Line. The options 
include:

Equal Distance Mesh points are spaced equally.

Half Cosine (Fwd) Mesh points are spaced more closely at the for-
ward end of the mesh, according to a half cosine.

Half Cosine (Aft) Mesh points are spaced more closely at the back 
end of the mesh, according to a half cosine.

Full Cosine Mesh points are spaced more closely at both ends 
of the mesh, according to a full cosine.

Using the Mesh Curve Tool
1. Select the tool. The Message Line reads: Mesh Curve: Select curves in order of 

meshing [Shift=Extend].

2. Select a mesh spacing option from the pull-down menu.

3. The Status Line displays the N data field which represents the number of mesh 
segments lines that will be distributed across the mesh.

If you want a different number of segments, enter the new value in the data field. 
The default value is 25.



Mesh Extrude Tool
4. Click two or more curves to define the mesh boundary. These curves should 
not be connected. If you need to select more than two curves, hold down the 
SHIFT key before you select the first curve. 

Select the curves in the order that you want the mesh created.

Geometric Characteristics
A mesh curve is created by selecting the desired curves. A mesh curve is made up 
of the following characteristics according to the Edit Objects dialog box: the Distri-
bution setting (Equal, Half Cosine (Forward), Half Cosine (Aft) or Full Cosine) and 
Segments (N) which make up the mesh.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the mesh and choose Window>Edit Objects or dou-
ble-click on the mesh.

Mesh Extrude Tool

The Mesh Extrude tool sweeps a collection of curves 
along a vector, creating N mesh segments.

Using the Mesh Extrude Tool
1. Select the tool. The Message Line reads: Mesh Extrude: Select objects to extrude 

[Shift=Extend].

2. The Status Line displays data fields allowing you to enter the delta values for 
the extrusion and the number of N segments for the mesh.

3. Click one or more curves to sweep. If you need to select more than one curve, 
hold down the SHIFT key before you select the first curve.

4. If you want a different value for the N segments than currently listed, select the 
field and type the new value. After you selected the curves, The Message Line 
reads: Mesh Extrude: Enter two points to extrude.

5. Click two points to set the direction and the distance of the extrusion. The 
points do not have to be on the selected curves.

The mesh is created.
15-5



Mesh Creation Tools

15-6
If you want to modify the mesh while it's still selected, type the value in the appro-
priate field tabbing between fields as necessary. Press ENTER (Windows) or 
RETURN (Macintosh) and the mesh curve will be modified.

Geometric Characteristics
An extruded mesh is created by selecting the desired curves and the extrusion val-
ues that define the distance and direction. An extruded mesh is made up of the fol-
lowing characteristics according to the Edit Objects dialog box: Vertex Count, Facet 
Count and Segments. This information is listed in the Edit Objects dialog box under 
the Geometry tab. To display the dialog box, select the mesh and choose Win-
dow>Edit Objects or double-click on the mesh.

Mesh and Rendering
Mesh is displayed according to the Static Render setting in the Rendering Option 
dialog box. You can display the mesh as Wireframe, Flat, Gouraud, Gouraud w/
Edges, Phong, Phong w/Edges, Hidden and Hidden with Dimmed. See Chapter 33, 
“Rendering,” for an explanation of these options.

Mesh Notations
The following notations will be helpful as you begin creating mesh objects.

• Mesh objects are not surfaces. They are defined by nodes or 3D vertices.

• Since mesh objects are not surfaces, you cannot use the Surface Editing tools 
contained in the third set of tools within the Surface tool palette.

• You can convert surfaces and solids into meshes and convert a closed mesh back 
into a solid.



Surface Creation Tools

Your Designer Elements program has 11 tools for creating surfaces. Every tool but 
the Infinite Plane tool can display a surface with Iso Lines. Iso (or isopram) lines 
are constant parameter curves that lie on a surface (defined mathematically in 
parameter space). U/V Iso lines refer to parameter space coordinates where U and 
V are letter identifiers. U Iso lines run perpendicularly to V Iso lines on a surface.

For each tool you can enter values in the Status Line to define a surface, either 
before or after you create the surface. If you enter the values after you select the 
tool but before you create the surface, your first click in the drawing area automat-
ically registers all Status Line values. If you enter values in the selected Status Line 
data field after creating the surface and while the surface is still selected, pressing 
ENTER (Windows) or RETURN (Macintosh) updates the surface to reflect the new 
values. 

Many of the tools use a two step process. The first step after choosing the tool may 
be to select one or more objects. The second step is to perform the editing opera-
tion. Once you the complete the first step (which may involve holding down the 
SHIFT key to select multiple objects), you cannot select more objects to include in 
the same operation. To select additional objects, reset the tool and start again.
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The tools are explained in the order of the palettes and include:

• Infinite Plane 

• Sphere Primitive

• Block Primitive

• Cylinder Primitive

• Pyramid Primitive

• Net Surface

• Ruled Surface

• Skin Surface 

• Cover Surface 

• Revolved Surface 

• Sweep 2pts Surface

• Sweep 1 Rail Surface

• Sweep 2 Rail Surface

• Tube Surface 

• Offset Surface

• Lofted Surface

• Draft Surface

• Fillet Surface

• Tangent Surface 

Infinite Plane Tool

The Infinite Plane is the simplest surface supported by your Designer Elements pro-
gram. An infinite plane is defined by a location and a normal. The plane surface is 
useful for generating cross-sections through meshes, surfaces, or solids.



Tip:

You can determine the dis-
tance between two infinite 
planes by selecting the 
planes and choosing Ver-
ify>Minimum Distance.
The infinite plane has six creation methods listed in the pull-down menu of the 
Message Line.

X-Station Creates a plane with normal X=1, Y=0, Z=0.

Y-Station Creates a plane with normal X=0, Y=1, Z=0.

Z-Station Creates a plane with normal X=0, Y=0, Z=1.

Normal Location Creates an arbitrary plane by specifying the loca-
tion and normal.

3 Pts in Plane Specifies a plane by three points. The normal is 
calculated from the three points.

Along Curve Lays an evenly spaced series of planes along a 
selected curve. The plane’s normals lie parallel to 
the curve.

The choices above are accessed from the Message Line, in the pull down pictured 
below.

After creating an infinite plane, it is represented on the screen by the following 
icon:

Using the Infinite Plane Tool for X-, Y- and Z-Station Planes
1. Select the Infinite Plane tool.

2. Pick X-, Y- or Z-Station from the drop down list on the Message Line. The Mes-
sage Line reads: Infinite Plane: Pick location for plane.

If you would like to create the surface in a plane different from the one currently 
set, change the plane before moving on to the next step.
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3. Click the point on the screen where you want the plane. An icon for the plane 
appears at that location.

The Status Line displays the X, Y and Z location for the plane.

You can modify the location by typing new values in the appropriate fields. Tab to 
move from field to field. Pressing ENTER (Windows) or RETURN (Macintosh) and 
the plane location changes to reflect those values. All future changes must be made 
in the Edit Objects dialog box.

Using the Infinite Plane Tool to create a Normal 
and Location Plane
1. Select the Infinite Plane tool.

2. Pick Normal Loc from the drop down list on the message line. The Message 
Line reads: Infinite Plane: Enter 3 points (1-Normal End, 2-Normal Start, 3-Loc).

If you would like to create the surface in a plane different from the one currently 
set, change the plane before moving on to the next step.

3. Click the point where you want the plane's normal to end, the point where you 
want the plane's normal to start, and the point where you want the plane to be 
placed.

There are no entries in the Status Line.

Using the Infinite Plane Tool to create a Three Point Plane
1. Select the Infinite Plane tool.

2. Pick 3 Pts In Plane option from the drop down list on the Message Line. The 
Message Line reads: Infinite Plane: Enter 3 points in the plane.

If you would like to create the surface in a plane different from the one currently 
set, change the plane before moving on to the next step.

3. Click three points. The plane icon at the specified location.

There are no entries in the Status Line.

Using the Infinite Plane Tool to create a Plane along a Curve
1. Select the Infinite Plane tool.



Referral:

See Chapter 22, “Surface 
Editing Tools,” for information 
on using the Plane/Surface 
Intersection tool.
2. Pick Along Curve from the drop down list on the Message Line. The Message 
Line reads: Infinite Plane: Pick curve to distribute planes along [Shift=Extend].

3. Click a curve on the screen. The Input String dialog 
box appears.

Enter the number of planes to place along the curve. 
Click OK to accept the change and close the dialog 
box. Click Cancel to close the dialog box without 
accepting the changes.

The planes are created along a curve. The example 
here shows 5 planes along a curve.

If you select the curve, the Input String dialog box reappears allowing you to 
change the number of planes placed along the curve.

There are no entries in the Status Line.

Infinite Plane Tool - Along the Curve Option and the Plane/Sur-
face 
Intersection Tool
You can use the Along Curve option of the Infinite Plane tool with the Plane/Sur-
face Intersection tool to quickly create cross sections through solid models. 

1. Select the Infinite Plane tool and select the Along Curve option. 

2. Create the planes along a curve adjacent to the solid model. 

3. Choose the Plane/Surface Intersection tool and 
pick the planes on the curve with which you 
want to cut the solid. The graphic here shows 
one example.

4. Select the solid. The Plane/Surface Intersection 
tool projects the planes through the solid. Your 
Designer Elements program puts each projected 
plane on a separate layer if you click the AutoLayers box on the Message Line 
before you create them.
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5. The intersections displays.

There are no entries in the Status Line.

Clipping Planes
Dynamic display clipping planes provide a means to 
slice through the model and hide the display to either 
side of the plane.

In order to use an Infinite Plane as a Clipping Plane you must bring up the 
Shade Options dialog box located in the View Menu and select the “Use Clip 
Planes” option.

Using an Infinite Plane as a Clipping Plane
1. Select the Infinite Plane tool. The Message Line reads: Infinite Plane: Pick loca-

tion for plane.

2. Place the Infinite Plane in your drawing.

3. Right-Click on the infinite plane and select the “Use a Clip Plane” menu option.



4. Use the Selection tool to dynamically drag the clip plane through the model.

5. To change the direction that the plane clips choose Edit>Change Direction.

This is also referred to as changing the surface normal or flipping normals.
To turn off the clipping plane option go to the View>Shade Options menu and 
deselect the Use Clip Plane option. By default this option is off.

Geometric Characteristics
An infinite plane is created by choosing points or curves as directed by the Message 
Line. An infinite plane is a surface made up of the following characteristics accord-
ing to the Edit Objects dialog box: the Location for the X, Y and Z location and the 
Normal for the DX, DY and DZ location.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the plane and choose Window>Edit Objects or dou-
ble-click on the plane.

Sphere Primitive

This tool creates a sphere surface using a center and radius point.

Using the Sphere Primitive Surface tool
1. Select the Sphere Primitive tool. The Message Line reads: Sphere Primitive: 

Enter center and radius point for sphere.

2. In the drawing area click the center point and radius point.

The Status Line contains X,Y and Z data fields for the sphere center point and dX, 
dY and dZ fields to reference distance and direction of the radius.

Block Primitive

The Block Surface Primitive creates a cubic or rectangular shaped object.

Using the Surface Block Primitive
1. Select the Block Primitive tool. The Message Line reads: Block Primitive: Enter 

center and length points.
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2. In the drawing area click the center and length points for the block.

The first point you click is the center point. This is the bottom center of the result-
ing block. The second point you click controls not only length, but orientation of 
the block.

The Status Line contains X, Y and Z data fields for the block base center point plus 
dX, dY and dZ for the height. In addition, you can specify L and W for the length 
and width of the block.

Cylinder Primitive

This tool creats a cylindrical surface primitive.

Using the Surface Cylinder Primitive
1. Select the Cylinder Primitive tool. The Message Line reads: Cylinder Primitive: 

Enter start and end points for cylinder.

2. In the drawing area click the start and end points for the cylinder.

The first point you click is the cylinder base center point. The second point you 
click controls not only length, but orientation of the cylinder.

The Status Line contains X, Y and Z data fields for the cylinder base center point 
plus dX, dY and dZ for the height. In addition, you can specify D for the diameter 
of the cylinder.

Pyramid Primitive

This tool creates a pyramid surface.

Using the Surface Pyramid Primitive
1. Select the Surface Pyramid Primitive tool. The Message Line reads: Pyramid 

Primitive: Enter start and end points for pyramid.

2. In the drawing area click the start and end points for the pyramid.

The first point you click is the pyramid base center point. The second point you 
click controls the length and orientation of the pyramid.



Surface From Curves Tools.

Tech Note:

A net surface is not the same 
as a mesh. Net surfaces are 
nurb surfaces. A mesh is 
defined by nodes or 3D ver-
tices.
The Status Line contains X, Y and Z data fields for the pyramid base center point 
plus dX, dY and dZ for the height. In addition, you can specify D for the pyramid 
base diameter and the #Sides for the number of sides

Surface From Curves Tools.

Net Surface Tool

The Net Surface tool creates a surface defined by a grid of M rows and N columns, 
where M and N are letter identifiers referring to the number of rows or columns. 
Curves suitable as boundaries for net surfaces include arcs, circles, lines, splines, 
ellipses and conics. These curves cannot be grouped.

The curves may be in different planes. If the curves lie in the same plane, our 
Designer Elements program creates a simple planar surface within the curve bound-
ary. If the curves lie out of plane, our Designer Elements program fits a curved net 
surface similar to a Coons patch mesh to the boundary curves. A Coons patch is a 
three or four sided nurb surface. The left graphic below shows four curves. The 
right graphic shows the resulting net surface with the referenced curves in gray.

You can also specify a point entity for the start or 
end of the net surface, creating a degenerative 
surface.
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Using the Net Surface Tool 
1. Select the Net Surface tool. The Message Line reads: Net Surface: Pick (M) 

curves defining surface [Shift=Extend].

2. Hold down the SHIFT key and pick two 
or more curves along one direction. The 
objects appear selected as in the graphic 
here (Curves 1 and 2).

When you release the SHIFT key, the 
objects are deselected. The Message Line 
now reads, Net Surface: Pick (N) curves 
defining surface [Shift=Extend].

3. Hold down the SHIFT key once again, 
and pick two or more curves to com-
plete the boundary for the surface.

When you release the mouse button the 
net surface is created. The graphic here 
shows the net surface from the example 
above.

As the example shows here, the curves defining the surface do not have to be con-
nected. Our Designer Elements program calculates the intersecting area of the 
selected curves and creates the net surface from that area.

There are no entries in the Status Line.

Geometric Characteristics
A net surface is created by choosing curves as directed by the Message Line. A net 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.



Surface From Curves Tools.
Ruled Surface Tool

The ruled surface tool is used to create surfaces that are linear between the selected 
spans.   Ruled surfaces are developable surfaces.  Developable surfaces can be 
unrolled into flat patterns without stretching or shrinking.

Using the Ruled Surface Tool
1. Select the Ruled Surface tool. The Message Line reads: Ruled Surface: Pick 

curves for defining surface. [Shift=Extend]

2. If there are more than two curves being used for the ruled surface hold down 
the SHIFT key and select all of your curves. When you release the SHIFT key 
the surface is created

As the example shows, the curves defining the surface do not have to be con-
nected. Our Designer Elements program calculates the intersecting area of the 
selected curves and creates the ruled surface

Geometric Characteristics
A ruled surface is created by choosing curves as directed by the Message Line. A 
ruled surface has no specific geometry characteristics according to the Edit Objects 
dialog box. There are tabs for both Display and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.
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Tech Note:

Do not confuse the Skin Sur-
face tool with the Cover Sur-
face tool. The curves you 
select for this tool are used 
as cross-sections. They can-
not be connected or inter-
secting. A warning message 
will appear if you choose 
invalid curves for the opera-
tion. To surface curves that 
are connected or closed use 
the Cover Surface tool.
Skin Surface Tools

A skin surface fits a network of NURB patches to 
a collection of curves that act as cross-sections 
for the final surface. The curves that are skinned 
can be open, closed or grouped. Curves suitable 
for skinning include lines, arcs, circles, ellipses, 
conics and splines. You can create a standard 
skin surface or closed (tangent) skin surface. You 
can also specify a point entity for the start or end of the surface, creating a degener-
ative surface.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when creating a skin surface.

There are two tools in the Message Line, Skin Curve and Skin with Guide Curves.

There is also an Advanced Skin Options dialog box that gives you more control of 
how your object looks when skinned.

It contains the following options:



Skin Surface Tools
Close Last Section with First The close option may be used when the user 
needs to construct a body closed in one direction 
(v direction). The default is an open (not closed) 
body.  The surface is continuous at each profile.  If 
the user provides a set of closed profiles, the face 
normals of the skin or loft body point outside, 
away from the body material. When the user pro-
vides a set of open profiles, the surface normals of 
the skin surface  is oriented along the surface nor-
mals and no attempt is made to change the surface 
normal orientation.  When using this option you 
do not provide profiles in the same position.

Simplify Surface The simplify option simplifies the created surface 
to a conical surface, if applicable. If all of the cross 
sections lie on a conical surface (plane, cylinder, 
cone, sphere or torus), the conical surface is cre-
ated instead. The value of 0.000001 is used to 
determine whether or not the cross section lies on 
an analytical surface (planar, conical, spherical or 
toroidal). The default is not simplified.

Auto-Align Sections The align sections option may be used to allow the 
skinning algorithm to align the direction of the 
curves  in the selection list.  Closed loops of wires 
can also be aligned. The default is aligned.

Arc Length Parameterization The arc length option is used to choose arc length 
or isoparametric parameterization of the skinning  
surfaces. In isoparametric parameterization the sur-
face parameter in the v direction follows the cross 
section curves. In arc length parameterization the 
surface parameter follows lines of constant length. 
The default is arc length parameterization.

Minimize Twist The twist option may be used to minimize the 
twist of the surface produced. Twist minimization 
aligns closed curves such that the start of the sec-
ond curve is aligned to the start of the first curve. 
Even if a body’s shape is unaffected by twisting, a 
surface with a twist could produce unexpected 
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results when faceting and rendering.  By default, 
twist minimization is on. Twist minimization is also 
an involved calculation that some users may not 
want to have carried out.

Perpendicular Skin The take–off vector is a tangent vector going out of 
the starting edge or surface and into the skinned 
surface. The perpendicular option is used to spec-
ify the direction of the take–off vector, perpendicu-
lar to the edge.  The default is in the loft direction 
because a perpendicular take–off vector can cause 
self–intersections to the surface.

Draft Angle Skinning with draft angles provides the ability to 
control the take–off vectors of the two outer skin-
ning profiles. The “draft” angle is defined as an 
angle off the plane of the wire at every point along 
the skinning profile. In addition to the user supply-
ing the angle itself, one may also supply a magni-
tude for the take–off vector.  The draft angle and 
magnitude is constant for the entire profile. How-
ever, one may apply different draft angles to the 
two outer profiles. In addition skinning with draft 
angles supports open and closed profiles and skin-
ning to a point. When skinning to a point the algo-
rithm constructs its own normal vector. The outer 
profiles must be planar when not degenerate.  Use 
the Edit Object dialog box to access the skin mag-
nitude.

Standard Skin Surface
An open skin surface is a surface that has open ended in all directions. You select 
the curves in the order that you want them skinned. When you select the successive 
curves (or n# sections), you create a surface between the curves. You are not sur-
facing the individual curves. If you want to surface curves connected end to end 
use the Cover Surface tool. See a later section in this chapter.



Skin Surface Tools

Tech Note:

The term, N# sections, refers 
to the curve sections you 
select to create a surface. The 
letter N is the generic identi-
fier.
The curves must have the same direction. 
If the curves have different directions the 
resulting surface will twist from section 
to section, as shown here.

To avoid creating twisted surfaces, check 
the curves' directions by choosing Ver-
ify>Direction. If the curves do run in dif-
ferent directions you can adjust or redraw 
them before creating the surface. The 
graphic here shows curves with the same 
direction and the resulting surface.

This tool also provides an option for creating closed tangents.

Closed Skin Surface
A closed or tangent skin surface is continuous end to end. 
When you use this option, your Designer Elements program 
automatically closes the skin such that the first section equals 
the last section making the slopes along the edge tangent 
continuous. The graphic here shows spline curves used to 
create a closed skin surface with the Skin with Guide 
Curves tool.

When these splines are skinned normally, the left model here results. When 
skinned using the closed skin option, the right model results.
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Skin Curve Surface Tool

This tool creates a skin surface between two or more 
curves. The surface edges are defined by the limits 
of the selected curves. You can create a standard skin surface or a closed skin sur-
face. The figure here shows a open skin surface created from three curves.

Creating a Standard Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do 

not run in the same direction, adjust them so that they do.

2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

3. Select the Skin Curve Surface tool (the left tool) in the Message Line.

4. Select the curves in the order that the surface is to be skinned. To select more 
than two curves hold down the SHIFT key. You cannot use a selection fence to 
select the curves.

There are no entries in the Status Line.

Creating an Closed Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do 

not run in the same direction, adjust them so that they do.

2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Closed (Windows) or Option (Macintosh) 
Shift=Extend].

3. Select the Skin Curve Surface tool (the left tool) in the Message Line.

4. (Windows) Select the curves in the order that the surface is to be skinned. To 
select more than two curves hold down the SHIFT key. (You cannot use the 
selection fence to select the curves.) After you select the last curve and while 
still holding down the SHIFT key, hold down the CTRL key. Release the SHIFT 
key and then the CTRL key.

(Macintosh) Hold down the OPTION key and select the curves in the order that 



Skin Surface Tools
the surface is to be skinned. To select more than two curves hold down the 
SHIFT+OPTION keys. You cannot use the selection fence to select the curves. 

The tangent surface is created.

There are no entries in the Status Line.

Skin with Curve Guides Surface Tool

This tool creates a skin surface between two or more curves using curves as guides 
to define the edges. Guide curves give you control over the skin surface. You can 
use one or more guide curves to influence the surface.

In the left graphic below, the profile curves are black and the guide curves are gray. 
The right graphic shows the skinned surface.

Guide Curve Rules
• Curves can go in any direction and need not be consistent with the others.

• Curves cannot loop and must be “well-behaved.” 

• The curves must connect with each profile that you want to use for surface cre-
ation.

Note: Guide curves only affect the geometry of the surface created between the 
profiles to which the guide curves are attached. Also, if the guide curve passes 
through vertices, the two adjoining surfaces follow the curve profile.

You can create a standard skin surface or a closed skin surface.

Creating a Standard Skin Surface
1. Check curve directions of the profile curves by choosing Verify>Direction. If 

all of the curves do not run in the same direction, adjust them so that they do.

2. Create one or more guide curves.
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3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message 
Line.

5. Select the curves in the order that the surface is to be skinned. To select more 
than two curves, hold down the SHIFT key. You cannot use a selection fence to 
select the curves.

The Message Line now reads, Skin Surface: Pick guide curves [Shift = Extend].

6. Select the guide curves.

The skin surface is created.

There are no entries in the Status Line.

Creating a Closed Skin Surface
1. Check curve directions by choosing Verify>Direction. If all of the curves do 

not run in the same direction, adjust them so that they do.

2. Create one or more guide curves.

3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves 
for defining surface [Ctrl = Advanced (Windows) or Option (Macintosh) 
Shift=Extend].

4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message 
Line.

5. (Windows) Select the curves in the order that the surface is to be skinned. To 
select more than two curves hold down the SHIFT key. (You cannot use the 
selection fence to select the curves.) After you select the last curve and while 
still holding down the SHIFT key, hold down the CTRL key. Release the SHIFT 
key and then the CTRL key.

(Macintosh) Hold down the OPTION key and select the curves in the order that 
the surface is to be skinned. To select more than two curves hold down the 
SHIFT+OPTION keys. You cannot use the selection fence to select the curves. 

The Message Line now reads, Skin Surface: Pick guide curves [Shift = Extend].

6. Select the guide curves.



Cover Surface Tool
The tangent surface is created.

There are no entries in the Status Line.

Geometric Characteristics
A skin surface is created by choosing curves as directed by the Message Line. A skin 
surface has no specific geometry characteristics according to the Edit Objects dialog 
box. There are tabs for both Display and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Cover Surface Tool

The Cover Surface tool creates a surface from curves connected end to end. The 
tool tip calls these curves n-sided. Curves suitable as boundaries for covered sur-
faces include arcs, circles, lines, splines, ellipses, conics and grouped curves. 

The curves may be in different planes. If the 
curves lie in the same plane our Designer Ele-
ments program creates a simple planar surface 
within the curve boundary. If the curves lie out 
of plane, our Designer Elements program fits a 
Gregory surface to the boundary curves. A Gre-
gory surface is a nurb surface with five or more 
sides.

Using the Cover Surface Tool 
1. Select the Cover Surface tool. The Message Line reads: Cover Surface: Pick 

curves for cover surface [Shift=Extend].

2. If you want to select more than one curve hold down the SHIFT key before 
selecting the first curve.

3. Select the curves. Do not worry about the order you select them. 

The cover surface is created.
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If not all of the curves that you select connect end to end, as shown in the figure 
below, our Designer Elements program warns you with a Cover Gap dialog box 
and marks the gaps in the selected curves.

Either move the endpoints together or redraw the curves so that they connect.

There are no entries in the Status Line.

Geometric Characteristics
A cover surface is created by choosing curves as directed by the Message Line. A 
cover surface has no specific geometry characteristics according to the Edit Objects 
dialog box. There are tabs for both Display and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On

Revolved Surface Tool

The Revolve Surface tool allows you can create a surface by revolving a set of 
curves (called the profile) around a central axis.

In the Message Line, you have a subpalette displaying two tools for revolving pro-
files: Revolved Surface about Two Points and Revolved Surface about a Curve.

If you revolve curves connected at their endpoints the resulting revolution creates 
one surface.



Revolved Surface Tool
Revolved Surface about Two Points Tools

This tool allows you to revolve a curve 
about two points that you choose. The 
direction of the Angle of Revolution is 
determined by the order in which you 
pick the points that define the axis. Use 
the Right Hand Rule to determine the 
direction that the surface will revolve. 

See Chapter 2 for more information on the Right Hand Rule.

Using the Surface of Revolution Tool - About Two Points
1. Select the Revolved Surface tool.

2. Select the Resolve Surface About Two Points tool in the Message Line. The 
Message Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].

3. Enter the angle through which to revolve the curve in the Angle data field of 
the Status Line.

4. Select the curve or curves to revolve. 

The Message Line directs you to enter two points for lathe (or revolution) axis. 

5. Click two points to define the Axis of Revolution. 

If the Axis of Revolution crosses any of the pro-
file curves this error message appears:

Pick a new non-intersecting axis to complete the 
surface of revolution.

The surface is created.

You can change the Angle while the surface is still 
selected by highlighting the Angle field, entering a new value and pressing ENTER 
(Windows) or RETURN (Macintosh). The surface adjusts accordingly. Any future 
modification to angle must be made through the Edit Objects dialog box.
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Revolved Surface about a Curve Tool

This tool allows you to revolve a 
curve about an existing curve that 
you choose. The direction of the 
angle of revolution is determined by 
the direction in which the axis of rev-
olution curve was drawn. Use the Right Hand rule to determine the direction for the 
revolution. See Chapter 2 for more information about the Right Hand Rule.

Using the Revolved Surface Tool: About a Curve
1. Select the Revolved Surface tool.

2. Select the Resolve Surface About Curve tool in the Message Line. The Message 
Line reads: Revolved Surface: Pick surface to revolve [Shift=Extend].

3. Enter the angle through which to revolve the curve in the Angle data field on 
the Status Line.

4. Select the curve or curves to revolve.

5. Select the curve to use as the Axis of Revolution. If the Axis of Revolution 
crosses any of the profile curves and error message appears. Choose another 
curve or adjust the curve as required.

The surface is created.

You can change the Angle while the surface is still selected by highlighting the 
Angle field, entering a new value and pressing ENTER (Windows) or RETURN (Mac-
intosh). The surface will adjust accordingly. Any future modification to angle must 
be made through the Edit Objects dialog box.

Geometric Characteristics
A revolved surface is created by choosing a curve to revolve and the axis of revolu-
tion. A revolved surface has the following geometry characteristics according to the 
Edit Objects dialog box: Rot. Angle, End 1 (X, Y and Z values) and End 2 (X, Y and 
Z values).

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 



Sweep Surface Tool - Along 2 Points

Tip:

To sweep a curve at an angle 
not perpendicular to the 
curve, change the view to 
specify the sweep points. 
Example: If you draw a rect-
angle in the top plane, 
change the view to front and 
specify the points at the 
desired angle.
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Sweep Surface Tool - Along 2 Points

The Sweep Surface tool sweeps a curve along a path defined by the user. The path 
chosen depends on the Sweep Surface tool used. This Designer Elements program 
automatically aligns, orders and sets the direction of your curves for the sweep 
path.

This tool sweeps a curve along a two 
point vector. The sweep surface starts 
from the curve and moves in the direc-
tion and distance indicated by two 
points that you choose. The resulting 
surface is associative to the original 
sweep curve. Change the curve and the 
surface automatically updates.

You can check information on the sweep using commands in the Verify menu. You 
can sweep grouped curves with this tool.

Using the Sweep Surface Tool: Along 2 Points
1. Select the Sweep Surface Along 2 Points tool. The Message Line reads: Pick 

curve(s) to sweep [Shift=Extend].

2. Select the curve that you want to sweep. The Message Line reads: Sweep 2 Pts 
Surface: Enter two points for sweep direction.

3. Click two points to define the vector. The order you click the points specifies 
the direction of the sweep. 

The vector cannot run in the same direction 
as the curve. If you define a vector in that 
direction this message appears:

Select the curve again and click two other 
points to define the vector.

The sweep surface is created.
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You can change the values in these data fields while the surface is still selected by 
highlighting the desired field and entering in a new value. Use the Tab key to move 
from field to field. Press ENTER (Windows) or RETURN (Macintosh) and the surface 
will adjust accordingly. Any changes you want to make after this must be made in 
the Edit Object dialog box.

The Status Line displays delta values for the X, Y and Z coordinates of the vector 
and the distance of the sweep.

Geometric Characteristics
A swept surface is created by choosing a curve to sweep and the points for the two 
points defining the vector. A swept surface along two points has the following 
geometry characteristics according to the Edit Objects dialog box: Distance and Vec-
tor (dX, dY and dZ values).

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Sweep Surface Tool - Along 1Rail

This tool creates a surface by sweeping an open, closed or grouped curve along 
another curve. The resulting surface is associative to both the path and the sweep 
curve.

Modifying either automatically updates 
the associative sweep surface. You can 
only sweep one curve at a time.

Using the Sweep Surface Tool: Along 1 Rail
1. Select the Sweep Surface Along 1 Rail tool. The Message Line reads: Sweep 1 

Rail Surface: Pick curve to sweep [Shift=Extend].



Sweep Surface Tool - Along 2 Points
2. Click the sweep curve. The Message Line reads: Sweep 1 Rail Surface: Pick 
sweep axis [Shift=Extend].

3. Click the rail curve. The surface is created.

There are no entries in the Status Line.

Geometric Characteristics
A swept surface is created by choosing a curve to sweep and a curve that acts as 
the rail for the sweep. A swept surface along one rail has no specific geometry 
characteristics according to the Edit Objects dialog box. There are tabs for both Dis-
play and Attributes.

Display contains settings for Iso lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Sweep Surface Tool - Along 2 Rails

The sweep along two rails method creates a swept surface by sweeping an open, 
closed or grouped profile between two rail curves. A rail can also be closed, back 
tracking over itself like a circle. This tool supports the maintaining of the profile 
height along the rail by holding down the CONTROL (Windows) or OPTION (Mac-
intosh) key. This tool does not support multiple or grouped curves for the rails. A 
simple two rail sweep is shown in the graphic here.
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As mentioned, you can also use closed curves or curves that backtrack as the rails. 
In the left graphic below, the top circle and bottom ellipse are the rails and the 
spline is the curve being swept. The right graphic shows the swept surface.

The rail curves define the orientation and scale of the swept surface as it moves 
between them. The resulting surface is associative to both rails and the sweep 
curve. Modifying any of the three will automatically update the associative sweep 
surface.

Using the Sweep Surface Tool: Along 2 Rails
1. Select the Sweep Surface tool.

2. Select the Sweep Surface Along 2 Rails tool in the Message Line. The Message 
Line reads: Sweep 2 Rail Surface: Pick curves or group to sweep. [Ctrl or Option = 
Maintain Height][Shift = Extend]

3. Click the profile you want to sweep and then choose the two rails for the 
sweep path.

A swept surface is created.

Hold down the Ctrl or Option key if you want the profile height to be maintained.

There are no entries in the Status Line.

Geometric Characteristics
A swept surface is created by choosing curves or grouped profiles that act as the 
rails for the sweep. A swept surface along two rails has no specific geometry char-
acteristics according to the Edit Objects dialog box. There are tabs for both Display 
and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.



Tube Surface Tool
Sweep Rules
• You must double-click the surface to display the Edit Objects dialog box. If you 

pick the surface and the original sweep curve with Edit>Select All, or by drag-
ging a selection fence, the Edit Objects dialog box will list only the attributes of 
the two entities and will omit the sweep surface's geometry information. There-
fore, always select the surface by double-clicking it. With the second click, the 
Edit Objects dialog box appears automatically.

• If you want to perform a helical sweep, the helix must originate in this Designer 
Elements program. Imported helix curves do not follow the helix curve law and 
the sweep operation requires this for a proper sweep.

• If you sweep curves connected at their endpoints, the resulting sweep creates 
one surface.

Tube Surface Tool

With the Tube Surface tool you can quickly and efficiently create a tube or pipe 
along a reference curve. This tool support grouped curves. You must specify a 
radius small enough to prevent a self-intersecting surface.

Using the Tube Surface Tool
1. Create a curve that would act as the center line for the tube.

2. Select the Tube Surface tool. The Message Line reads: Tube Surface: Pick tube 
center line [Shift=Extend].

3. Click the curve for the tube's center line.

4. Enter a new tube radius in the data field on the Status Line, if required. Press 
ENTER (Windows) or RETURN (Macintosh) and the radius of the tube will 
change accordingly.
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If you want to specify a tube radius before the tube is created, type the value in the 
Radius data field and then select the curve and the tube surface will be created with 
the specified radius.

Geometric Characteristics
A tube surface is created by choosing a curve that will act as the center line for the 
tube. A tube surface has the following geometry characteristic according to the Edit 
Objects dialog box: Diameter of the tube.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Feature Surface Tools

Offset Surface Tool

With the Offset Surface tool you can make a new surface based on an existing or 
parent surface, offset by an amount that you choose. You can also offset an infinite 
plane.

The offset surface is created by first selecting the parent surface and specifying the 
offset surface. Offset surfaces maintain a constant distance normal to the parent sur-
face. The direction of the offset is the surface normal direction. You can specify 
negative offsets. Do not offset a surface a distance greater than the smallest radius 
of curvature or you can create a degenerate surface.



Feature Surface Tools
If you specify a zero offset, this Designer Elements program creates an associative 
copy of the selected surface at the same location.

You can also offset solids faces. 
You may single select a particu-
lar face or box select the entire 
solid to offset all of its faces. A 
positive offset for a solid, creates 
a surface outside the solid. A 
negative offset creates a surface 
towards the inside of the solid.

Using the Offset Surface Tool
1. Select the Offset Surface tool. The Message Line reads: Offset Surface: Pick sur-

faces to offset [Shift=Extend].

2. Enter an Offset distance in the data field of the Status Line.

3. Click the parent surface. A duplicate surface appears at the offset distance.

Geometric Characteristics
An offset surface is created by choosing the parent surface and specifying an offset 
distance. An offset surface is composed of the offset value according to the Edit 
Objects dialog box. There are tabs for both Display and Attributes.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.
16-29



Surface Creation Tools

16-30
Lofted Surface Tool

The Lofted Surface tool creates a smooth, transitional surface between surfaces 
edges and any number of interior non-surface edges. To create a tangent surface 
select the edge of the start surface and the edge of the end surface. 

Using the Lofted Surface Tool
1. Select the Lofted Surface tool. The Message Line reads: Lofted Surface: Pick 

edges for lofted surface.[Shift=Extend].

2. Enter a new bulge factor in the Bulge data field in the Status Line, if desired. 
The bulge factor controls the magnitude of the slope of the surface edges.

3. Click an edge on each surface to be joined by the tangent surface. When you 
create a tangent surface, the screen shows only one connecting line. Choose 
View>Shade Now to see the tangent surface. If Shade Now is set to anything 
other than wireframe in the Shade Options dialog box, your lofted surface 
appears in the chosen mode.

Once created, the lofted surface can be modified in the Edit Objects dialog box 
accessed through the Design Explorer. The start bulge factor controls the magni-
tude of the slope from the starting edge, whereas the end controls the slope at the 



Lofted Surface Tool
end curve. The reverse Edge Direction options are provided to fix twisting of the 
Tangent surface resulting from different edge directions. 

The figure shows two bulb surfaces joined with a tangent surface using different 
bulge factors. The left figure uses a 0.25 bulge factor; the center figure uses a 10.0 
bulge factor; the right figure uses a 3.0 start bulge factor and a 0.5 end bulge factor.

A bulge factor of .25 is 
used at both ends.

A bulge factor of 10 is 
used at both ends.

A bulge factor of 3 is 
used at the top end 

and 0.50 factor at the 
bottom end.
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Geometric Characteristics
A lofted surface is created by choosing the two connecting surfaces. You may edit 
the bulge factor for the lofted surface edges in the Edit Objects dialog box. Tangent 
Edge 1 controls the first edge chosen and Tangent Edge 2 controls the last edge 
chosen.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.

Draft Surface Tool

The Draft Surface tool extends a surface to create a new 
surface attached to the end of the original surface. This 
Designer Elements program provides data fields for angle 
and length that give you control over how the surface is 
generated. Entering 0° in the Angle data field extends the 
surface tangent to the original. Entering 90° extends the surface perpendicularly.

You have two options to set the new surface tangency; Default and Align Curve. 
The default option is automatic when using this tool. It creates a draft surface 
aligned with the original surface derivatives, based on the product of the surface 
tangent and normal. The graphic below shows the original geometry and the result-
ing draft surface.

By holding down the CTRL key (Windows) or OPTION key (Macintosh) you choose 
the Align Curve option listed in the Message Line. When you use this option a draft 
surface is created based on the product of the alignment curve tangent and the sur-



Draft Surface Tool
face normal. The graphic below shows the original geometry and the resulting draft 
surface.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when creating a draft surface.

Using the Draft Surface Tool
1. Select the Draft Surface tool. The Message Line reads: Draft Surface: Select 

curve on surface [Ctrl=Align Curve].

2. Enter a new angle and/or length in the data fields in the Status Line, if you so 
desire.

3. Click a curve (edge) on the surface to draft or extend the surface. When you 
select the edge, the whole surface is highlighted until this Designer Elements 
program creates the draft.

You can change both the angle and the length of the Draft by entering new values 
in the data field while the geometry is still selected. Pressing ENTER (Windows) or 
RETURN (Macintosh) will make the change. Any other changes must be made in 
the Edit Objects dialog box.

Geometric Characteristics
A draft surface is created by choosing a curve to draft and entering the desired 
angle and length of the draft. A draft surface has the following geometry character-
istics according to the Edit Objects dialog box: Angle and Length.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines on 
your surface by entering the value in the U and V data fields and clicking Apply. A 
grid of U and V lines will display on your surface. You have options for the Silhou-
ette setting, Smart, Off or On.
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Fillet Surface Tool

The Fillet Surface tool blends two surfaces that share an edge or intersection. This 
tool does not extend surfaces.

When filleting two intersecting surfaces, there are four places where the fillet can 
be placed. The fillet is created where the surface directions are positive for both 
surfaces. The surface direction can be determined by selecting and choosing Ver-
ify>Direction. You can change the direction by choosing Edit>Change Direction. 
The left graphic here shows two intersecting surfaces. The right graphic shows the 
surfaces blended.

Using the Fillet Surface Tool
1. Select the Fillet Surface tool. The Message Line reads: Fillet Surface: Pick two 

surfaces to blend [Shift=Extend].

2. Select the two intersecting or connected surfaces that share an edge

The surfaces are filleted.

If you want to change the fillet radius, type the value in the Radius data field in the 
Status Line and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the Radius for the blend.



Fillet Surface Tool
Geometric Characteristics
A fillet surface has the following geometric characteristic according to the Edit 
Objects dialog box: Radius of the fillet.

The Display page of Edit Objects contains settings for Iso Lines and Silhouette. You 
can display Iso Lines on your surface by entering the value in the U and V data 
fields and clicking Apply. A grid of U and V lines will display on your surface. You 
have options for the Silhouette setting, Smart, Off or On.

Tangent Cover Surface Tool

The Tangent Cover surfaced creates a surface that is tangent to four neighboring 
surfaces. The surfaces must form a closure. You may also select curves for some of 
the boundaries however if you have a choice, use surface edges for the boundary 
of the tangent cover surface.

Using the Tangent Cover Surface Tool
1. Select the Tangent Cover Surface tool. The Message Line reads: Tangent Cover 

Surface: Pick four edges/curves for cover surface.

2. Select the surface edges and or curves. Select them inhead to tail fashion. The 
tangent cover surface is created.
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Note: The first surface selected is the driving surface. Changing the order of the sur-
face selection can change the final results.



Introduction to Solid Modeling
A solid model is an unambiguous 3D representation of an object, composed of selectable 
faces. A solid model is unambiguous because their mathematical descriptions completely 
define the inside and outside of a 3D object. 

Unlike wireframes and surfaces which define lengths and areas, solids accurately provide 
volume, mass, moments of inertia, centroids and interference information. Solids also 
generate stereolithography models useful for demonstrating prototype concepts or for cre-
ating forms for molds or castings.

Our Designer Elements program is based on Spatial Technologies’ ACIS Geometry 
Engine. ACIS provides a precise boundary representation of solids suitable for design 
projects sensitive to accuracy. In ACIS, linear and quadric geometry is exactly represented 
analytically while free-form geometry is represented as Non Uniform Rational B-Splines 
(NURBs). Unlike faceted solid modelers, ACIS maintains a high level of accuracy as you 
perform boolean operations or add features. Because the ACIS engine is so accurate, parts 
modeled with it are suitable for applications that demand precision, like numerical con-
trol. Our Designer Elements program provides several sets of tools with which to create or 
modify solids: Primitives, Profiles, Features and Editing.

The topics explained here include:

• Solid Modeling tools

• Drafting Assistant and Solids

• Solids, Selection and Display

• Solid Associativity
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• Solids and Instances

• Cutting and Pasting Solids

• Exporting Solids

• Object Types and Edit Objects

Solid Modeling Tools
The solid modeling tools are accessible from the Solids tool pal-
ette. The Solids tool palette displays automatically when you first 
launch your Designer Elements program. To display the palette, 
choose Window>Solids. Selecting the Solids option again from 
the Window menu or the close box in the its palette's title bar, 
closes the palette.

The palette will appear under the main tool palette on the left side 
of your screen.

The five solid modeling subpalettes contain groups of tools for creating primitives, pro-
filed solids, features and editing solids.



Solid Modeling Tools
Primitives
A primitive is a simple shape such as a sphere, slab, block, cylinder, etc. 

The Primitives subpalette contains the following tools: Sphere, Slab, Block, Cylinder, 
Cone, Torus, Prism, Pyramid and Ellipsoid. Chapter 18 explains these tools.

Profiles
A profile is a curve or collection of curves that enclose an area. You can create a solid from 
a profile by revolving, extruding, or sweeping a curve or pipe profile along a path. 

The Profiles subpalette's contains the following tools: Lathed, Extrude, Sweep, Cutout, 
Protruded Feature, Skinned Solid and Pipe Solid. Chapter 19 explains these tools.

Features
A feature simplifies building or modifying a solid by constructing common design ele-
ments with a single command.

The Features subpalette's contains the following tools: Blends (constant, linear, variable), 
Chamfer (constant, angle, linear) Holes (simple hole, counter bore, counter sink), Boss, 
Shell and Bend. Chapter 22 explains these tools.

Solid Utility Tools
As you create your geometry you may want to perform various operations on them such as 
splitting a solid or placing a draft. The Solid Utility tools provide you with various ways of 
editing solid objects.

The Solid Editing tool subpalette contains the following tools: Boolean (Union, Subtract, 
Intersect), Trim, Split, Stitched, Thicken, Lofted, Rib Feature and Lip Feature (Remove and 
Add). Chapter 23 explains these tools. 
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Local Solid Face Tools
As you create or import geometry you may want to perform various operations on it. The 
Local Solid Face Tools provide a means to modify individual faces of your solid geometry.

The Local Solid Face subpalette contains the following tools: Draft Solid, Match Face, 
Move Face, Offset Face, Remove Face, Replace Face, Parting Line and Deform Face (by 
disatance, to a point or to a curve). Chapter 23 explains these tools.

Drafting Assistant and Solids
The Drafting Assistant recognizes a variety of intelligent snap locations for solids includ-
ing all hard vertices, user supplied points (grips), hole centers, cylinder centers, align-
ments, alignment intersections and fillet centers. The Drafting Assistant works the same 
for a solid as it does for a curve.

Solids, Selection and Display
You can select a solid by clicking on an edge or within a face. Selecting the solid on its 
edge is considerably faster than selecting within a face (our Designer Elements program 
has to cast a ray to see if it pierces the solid).

Displaying Solid Edges
Solids display three types of edges, Hard, Silhouette and Smart Silhouette. Hard edges are 
permanent edges and are present in all views. A Silhouette edge is a temporary edge that 
displays when the surface normal makes a 90 degree angle with the view normal. Smart 
Silhouettes display a silhouette only if it does not degrade the display performance.

You can set one of these as the default by choosing File>Preferences>Display and 
selecting the option.



Solids, Selection and Display
Object Resolution
You can increase a solid's edge resolution with the Change Resolution command in the 
Edit menu.

You can choose one of five resolution settings, Super Fine, Very Fine, Fine, Medium or 
Coarse. Click a radio button next and then click OK to close the dialog box. The object 
will change accordingly.

Changing an Object's Resolution
1. Select the object.

2. Choose Edit>Change Resolution.

The Object Resolution dialog box appears.

3. Enter the desired number of Iso lines. Check the Show Silhouettes box if desired.

The # Iso Lines allow you to control the isopram lines drawn for a solid face. These Iso 
(isopram) lines are constant parameter curves that lie on a surface, typically defined in 
parameter space. The parameter space coordinate system uses U and V coordinates. A 0 
(zero) in both fields turns off Iso lines. The appropriate U/V values may enhance the 
visual appearance of the face at the expense of drawing speed. The letters, U and V are 
space coordinate identifiers (U = horizontal, V = vertical) that are the industry standard. 
The Force U=V check box automatically sets equal number of U and V lines. Entering 
a new value in one automatically changes the other isoline value.

The Silhouette check box controls the silhouette edges of objects. Silhouette edges are 
view dependent and can cause a significant reduction in drawing speed. A check in the 
box turns the silhouette on.
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4. Click OK to close the dialog box and save the new settings.

See Chapter 24 for more information on resolution.

Solid Associativity
Solid objects are associative to the original curves used to create them. Changing the curve 
automatically changes the dependent solid. For example, if you create a lathed solid from 
four curves and change the length of one of them, the lathed solid automatically updates to 
reflect the change. Use the Edit>Remove Links command to remove all associativity 
with the solid if you do not want curve changes to affect the solid. Another important issue 
to remember with the curve/solid associativity is that if the curve is deleted, the solid 
deletes as well. Since it is defined by the curve, it is no longer valid.

Solids and Instances
When you perform an operation on a solid and move it to another location or copy a solid 
you create an instance of the original. When you display the Edit Objects dialog box, the 
object is referred to as an instance.

Instances and Moving Solids
When you create an instance by moving the modi-
fied solid to another location, the information 
appears as an instance operation in the Design 
Explorer. The original object is still located in pre-
vious position, although it is not displayed. 

When you select the Instance Translate item in the 
Design Explorer and open the Edit Objects dialog 
box the only geometry characteristics provided the 
offset distance from the original solid.

Silhouette On Silhouette Off



Solids and Instances
Instances, Copying Solids and Associativity
Holding down the CTRL (Windows) or OPTION (Macintosh) key while moving the 
object with the Selection tool creates an instance copy of the original solid. If you display 
the history tree in the Design Explorer, you see two instance operations. The first, called 
Instance, is the copying operation. The second, called Instance:Translate is the translation 
operation moving the copied solid to a different location. 

Displaying the Edit Objects dialog box for the Instance item shows there are no unique 
geometric characteristics. If you open the history tree further you expose the original solid 
and can view its characteristics through the Edit Objects dialog box.

When you copy a solid, creating an instance, this instance is associative to the original 
solid. All changes made to the original solid will automatically be made on all instances 
created from the original. For example, if you added a hole to the original after creating 
the instance, the hole is also added to all instances. You may need to choose 
Edit>Resolve Links for this to occur. 

If an operation you perform on the original after creating an instance conflicts with an 
operation already performed on that instance, you receive two successive errors, a Reorder 
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Error and a Resolve Links error (shown below). Choose Edit>Undo to return to part to the 
original state. 

When you perform operations on an instance, they are listed in the Design Explorer and do 
not affect the original. If you break the link between the original and the instance, changes 
made to the original do affect the instance.

Be aware when you are creating multiple instances whether you are instancing the original 
part or another instance. This is important if you later decide to break the link between the 
original and an instance. If there are any instances created from that instance, you are 
breaking their associativity to the original as well. So, if you only want to break the link 
between one instance and the original, all other instances should be created from the orig-
inal solid.

If you do not want to create an instance, select the original solid, choose Edit>Copy and 
then Edit>Paste. You can also select the instance and choose Edit>Remove Links. 
However, the object geometry cannot be edited using the technique.

Cutting and Pasting Solids
When you cut and paste a solid all associativity relationships are lost. After cutting and 
pasting a part, you will not be able to edit any of its features. Cutting and pasting a solid 



Exporting Solids
does, however, provide an easy way to remove a part's history tree, thereby minimizing 
the amount of memory it consumes.

Cutting and Pasting on the Macintosh
When you cut and paste a solid object into our Designer Elements program on a Macin-
tosh computer, the object is represented in both PICT2 and VS Object form. When both 
forms are present, you can cut and paste a representation of the solid into other applica-
tions and cut and paste a true solid back into our Designer Elements program drawing.

Exporting Solids
If you want to export a solid model created in our Designer Elements program to another 
application, you must convert the model to a standard format. Our Designer Elements pro-
gram supports three formats:

1. You can convert the solid into polylines or meshes with the Change Object Type com-
mand in the Edit menu. After converting the model, use the DXF export command to 
create an ASCII DXF file.

2. If you are exporting to an application that supports ACIS, you can generate a SAT file. 
SAT files contain precise geometry and topology, so the other application can import 
the solid's data as it was created in our Designer Elements program.

3. You can export solids through the IGES translator as solid entities or as a collection of 
trimmed surfaces.

Object Types and Edit Objects
Every solid object you create with our Designer Elements program tools are defined by 
their own characteristics and include geometric characteristics and attributes. These are 
displayed in the Edit Objects dialog box. While the categories listed in the Attributes tab 
are identical, the categories listed in the Geometry tab vary with each object.

For example: A line created by the Single Line tool includes the following categories: 
Length, Angle, End 1 for X, Y, and Z, and End 2 for X, Y and Z.

Chapters 18 and 19 introduce you to the solids tools of our Designer Elements program 
that create the objects. Included with every tool description is a list of the categories dis-
played for the object when Edit Objects is chosen. For information on using the Edit 
Objects command and the dialog box, see Chapter 24.
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Error Messages
Error Messages provide more feedback when trying to perform operations such as shell-
ing, local face modeling and so on. Our Designer Elements program tries to determine 
why the operation failed and provides a hint to the feature that may have caused the prob-
lem.



Solids Creation Tools - Primitives

Primitives are simple solid shapes. You can create primitives by picking one point, 
two points or diagonals. Each Designer Elements program primitive is defined by a 
unique set of characteristics which you can edit.

For each tool you can enter values in the Status Line to define a solid either before 
or after you create the solid. If you enter the values after you select the tool but 
before you create the solid, your first click in the drawing area automatically regis-
ters all Status Line values. If you enter values in the selected Status Line data field 
after creating the solid and while the solid is still selected, pressing ENTER (Win-
dows) or RETURN (Macintosh) updates the solid to reflect the new values.

The Primitive tools are explained in the order of the palette and include:

• Sphere

• Slab

• Block

• Cylinder

• Cone

• Torus

• Prism

• Pyramid
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• Ellipsoid

Sphere Primitive Tool

Our Designer Elements program creates a sphere from a center point and radius or 
from two diagonal points on a bounding box. When you select the Sphere Primi-
tive tool, a subpalette appears in the Message Line containing three tools for creat-
ing spheres: Sphere 1 Point, Sphere 2 Point and Sphere by Diagonals.

The Drafting Assistant recognizes the points that you pick to define the sphere.

Sphere 1 Point Tool

This tool draws a sphere using the center 
point that you specify and the radius 
entered in the Status Line.

Using the Sphere 1 Point Tool
1. Select the Sphere Primitive tool.

2. Select the Sphere 1 Point tool in the Message Line. The Message Line reads: 
Sphere Primitive: Enter center point for sphere.

3. Click a point in the drawing area.

The sphere is created in the specified location.

While the sphere is still selected, change the X, Y, Z location of the center point and 
the radius, if desired. Press ENTER (Windows) or RETURN (Macintosh) to accept 
the new values.
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The Status Line contains X, Y and Z data fields for the sphere center point and the 
Radius data field. 

Our Designer Elements program creates one point spheres independently of the 
construction plane’s orientation.

Sphere 2 Point Tool

This tool draws a sphere from the center point and radius that 
you specify.

Using the Sphere 2 Point Tool
1. Select the Sphere Primitive tool.

2. Select the Sphere 2 Point tool in the Message Line. The Message Line reads: 
Sphere Primitive: Enter center and radius point for sphere.

3. Click the center point and the radius point in the drawing area.

The sphere is created.

While the sphere is still selected you can change the X, Y, Z location of the center 
point and dX, dY and dZ values for the radius, if desired. Press ENTER (Windows) 
or RETURN (Macintosh) to accept the new values.

The Status Line contains X, Y and Z data fields for the sphere center point and dX, 
dY and dZ fields to reference distance and direction to the radius.

Sphere by Diagonals Tool

This tool draws a sphere based on the two corners of the 
sphere’s bounding box that you specify.
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Using the Sphere By Diagonals Tool
1. Select the Sphere Primitive tool.

2. Select the Sphere by Diagonals tool in the Message Line. The Message Line 
reads: Sphere Primitive: Enter diagonal corners for sphere.

3. Click two points in the drawing area.The sphere is created. 

This Designer Elements program places the sphere’s center midway between the 
two points and calculates the radius from the smallest length of the enclosing 
box.

While the sphere is still selected you can change the X, Y, Z location of the first cor-
ner point and dX, dY and dZ values to the second corner, if desired. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the new values.

The Status Line contains X, Y and Z data fields for the first point and the dX, dY and 
dZ fields for the distance and direction to the second point.

Geometric Characteristics
A sphere primitive is created by picking one or two points to specify the sphere’s 
center point, radius or bounding box corners, and is made up of the following char-
acteristics: Center (X, Y, and Z values) and Diameter. This information appears in 
the Edit Objects dialog box under the Geometry tab. To display the dialog box, 
select the sphere and choose Window>Edit Objects or double-click on the sphere.

Slab Primitive Tool

You create a solid slab primitive by extruding a series of closed planar points. If the 
points do not close, our Designer Elements program automatically closes them. Our 
Designer Elements program also checks for invalid or overlapping slab points. If 
one or more are detected, no slab is created.

Our Designer Elements program determines the extrusion direction from the order 
in which you enter the points. Our Designer Elements program constructs the slab 
in the direction of the right hand rule (see Chapter 2 for information on the right 
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hand rule). Although the slab’s points must be coplanar, they do not have to be in 
the current construction plane. You can also specify a draft angle for the slab.

Using the Slab Tool
1. Select the Slab Primitive tool. The Message Line reads: Slab Primitive: Enter 3 

or more points for slab. (Double-click last point).

2. Click the three or more points to describe the slab. (Be careful that the points 
are not overlapping.)

The slab is created with the height and draft angle listed in the Status Line.

While the slab is still selected you can change the height and draft angle in the Sta-
tus Line, if desired. Press ENTER (Windows) or RETURN (Macintosh) to adjust the 
slab to the new values.

The Status Line contains the Height and Draft Angle data fields.

Geometric Characteristics
A solid slab primitive is created by picking three or more points for the slab’s cor-
ners and is made up of the following characteristics: the Height and Draft Angle, 
and the Defining Points (X, Y, and Z values) of the slab’s corner points. This infor-
mation is listed in the Edit Objects dialog box under the Geometry tab. The section 
below Defining Points displays the selected point. Each point can be edited individ-
ually using the X, Y and Z fields. To display the dialog box, select the slab and 
choose Window>Edit Objects or double-click the slab.
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Block Primitive Tool

The block primitive is a cubic or rectangular solid. When you select the Block 
Primitive tool a subpalette appears in the Message Line containing three block 
tools: Block 1 Point, Block 2 Point and Block by Diagonals.

Block 1 Point Tool

This tool draws a block using the center 
point that you specify and the Height 
entered in the Status Line.

Using the 1 Point Block Tool
1. Select the Block Primitive tool.

2. Select the Block 1 Point tool in the Message Line. The Message Line reads: 
Block Primitive: Enter center point for block.

3. Click a point in the drawing area.

The block is created with its base centered at the point you chose. The block’s 
orientation is determined by its length, width, and height along the x, y, and z 
axes of the work plane.

While the block is still selected you can change the X, Y, Z location of the base cen-
ter point and length, width and height of the block, if desired. Press ENTER (Win-
dows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z location of the block base center point and 
Length, Width and Height of the block.
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Block 2 Point Tool

This tool draws a block from the center 
point and radius.

Using the 2 Point Block Tool
1. Select the Block Primitive tool.

2. Select the Block 2 Point tool in the Message Line. The Message Line reads: 
Block Primitive: Enter center and length points for block.

3. Click two points in the drawing area.

The block is created centered on the point chosen with a height equal to the dis-
tance between the two points that you chose.

While the block is still selected you can change the X, Y, Z location of the base cen-
ter point, the dX, dY and dZ to the second point for defining the width and height 
of the block and the length, if desired. Press ENTER (Windows) or RETURN (Macin-
tosh) to accept the new values.

The Status Line contains the X, Y and Z location of the block base center point, the 
dX, dY and dZ to the second point for defining the width, height and length of the 
block.

Block by Diagonals Tool

This tool draws a block based on the two 
base corners and the height that you spec-
ify.
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Using the Block by Diagonals Tool
1. Select the Block Primitive tool.

2. Select the Block by Diagonals tool in the Message Line. The Message Line 
reads: Block Primitive: Enter start diagonal point [Shift=Square].

3. Click two points in the drawing area to specify two diagonal corners of the 
block’s base. 

Hold down the SHIFT key to draw a square. After you click your first point, while 
holding down the key, The Message Line reads: locking.... These two points set 
the block’s width and length.

4. After the first two points are placed The Message Line reads: Block Primitive: 
Enter height.

5. Drag to set the height of the block.

The block is created. If you are working in the top, front or side view, pick a 
point, and our Designer Elements program will make the block’s height equal to 
its width. If you are working in 3D view, you can select the point to set the 
desired height.

While the block is still selected you can change the X, Y, Z location of the first cor-
ner or the length, width and height of the block, if desired. Press ENTER (Windows) 
or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the first corner that you chose 
and the solid’s Length, Width and Height.

Geometric Characteristics
A solid block primitive is created by picking one or two points to specify the center 
point of the block’s base, the block’s height, or the locations of two of the block’s 
corners. The block is made up of the following characteristics: Length, Width and 
Height. This information is listed in the Edit Objects dialog box under the Geometry 
tab. To display the dialog box, select the block and choose Window>Edit Objects 
or double-click the block.



Cylinder Primitive Tool
Cylinder Primitive Tool

With our Designer Elements program, you can make 
circular and elliptical cylinder primitives. The cylin-
der is defined by a base radius ratio and a height. 
The base radius ratio defines the ratio between the 
major radius (R1) and minor radius (R2). A circular 
cylinder’s base ratio equals one. Any other value 
yields an elliptical cylinder. The graphic gives you a 
visual representation of these definitions.

When you select the Cylinder Primitive tool, a subpalette appears in the Message 
Line containing three cylinder tools: Cylinder 1 Point, Cylinder 2 Point and Cyl-
inder by Diagonals.

Cylinder 1 Point Tool

This tool draws a cylinder using the center point that you specify 
and the radius and height entered in the Status Line.

Using the Cylinder 1 Point Tool
1. Select the Cylinder Primitive tool.

2. Select the Cylinder 1 Point tool in the Message Line. The Message Line reads: 
Cylinder Primitive: Enter center point for cylinder.

3. Click a point in the drawing area. 

The cylinder is created with its base centered at the point you chose. The cylinder 
extends along the z axis of the current construction plane.
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While the cylinder is still selected you can change the X, Y, Z location of the base 
center point and radius and height of the cylinder, if desired. Press ENTER (Win-
dows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the cylinder’s base center point 
and its Radius and Height.

Cylinder 2 Point Tool

This tool draws a cylinder from the cen-
ter point of the base, the second point for 
the height and radius.

Using the Cylinder 2 Point Tool
1. Select the Cylinder Primitive tool.

2. Select the Cylinder Two Point tool in the Message Line. The Message Line 
reads: Cylinder Primitive: Enter start and end points for cylinder.

3. Click two points in the drawing area.

The cylinder is created with its height is equal to the distance between the two 
points that you chose and with its top and bottom centered on those points.

While the cylinder is still selected you can change the X, Y, Z location of the base 
center point, the dX, dY and dZ to the second point for defining the distance and 
direction of the cylinder and the radius, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the base center point, the dX, dY 
and dZ values for the distance and direction to the second point, and the Radius.
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Cylinder by Diagonals Tool

This tool draws a cylinder based on the 
two base corners and the height.

Using the Cylinder by Diagonals Tool
1. Select the Cylinder Primitive tool.

2. Select the Cylinder by Diagonals tool in the Message Line. The Message Line 
reads: Cylinder Primitive: Enter start diagonal point [Shift=Square].

3. Click two points in the drawing area to specify two diagonal corners of the cyl-
inder base’s bounding box. 

Hold down the SHIFT key to draw a circular base. After you click your first point, 
The Message Line reads: locking.... The distance between the two points are used 
to calculate the cylinder’s diameter.

4. The Message Line reads: Cylinder Primitive: Enter height.

5. Drag to set the height of the cylinder.

The cylinder is created. If you are working in the top, front or side view, pick a 
point and our Designer Elements program will make the cylinder’s height equal 
to that of the last cylinder you drew (or equal to one inch if this is the first cylin-
der you draw). If you are working in a 3D view you can select the point to set 
the desired height.

While the cylinder is still selected you can change the X, Y, Z location of the cylin-
der’s base center point, the dX, dY, and dZ values for the distance and direction to 
the second point, and the cylinder’s height, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the cylinder’s base center point, 
the dX, dY and dZ values for the distance and direction to the second point and the 
Height.

Geometric Characteristics
A cylinder primitive is created by picking one point to specify the center point of 
the cylinder’s base, two points for the center point and height, or three points for 
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the corners of the bounding box and the cylinder’s height. It is made up of the fol-
lowing characteristics: Height, Diameter (Major axis) and Diameter Ratio (D1/D2 or 
R1/R2). This information is listed in the Edit Objects dialog box under the Geometry 
tab. To display the dialog box, select the cylinder once and choose Window>Edit 
Objects or double-click the cylinder.

Cone Primitive Tool

The cone primitive has an elliptical base at one end and a point at the other. Like 
the cylinder, the cone is defined by a base radius ratio and a height. 

The ratio defines the relationship between the 
major radius (R1) and minor radius (R2). A cir-
cular cone’s base ratio equals one. Any other 
value yields an elliptical cone.

When you select the Cone Primitive tool a 
subpalette appears in the Message Line containing three cone tools: Cone 1 Point, 
Cone 2 Point and Cone by Diagonals.

Cone 1 Point Tool

This tool draws a cone using the center point that you specify 
and the radius and height entered in the Status Line.

Using the Cone 1 Point Tool
1. Select the Cone Primitive tool.

2. Select the Cone 1 Point tool in the Message Line. The Message Line reads: 
Cone Primitive: Enter center point for cone.

3. Click a point in the drawing area.
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The cone is created with its base centered at the point you chose. The cone 
extends along the z axis of the current work plane.

While the cone is still selected you can change the X, Y, Z location of the base cen-
ter point and radius and height of the cone, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the cone’s base center point and 
its Radius and Height.

Cone 2 Point Tool

This tool draws a cone from the center point of the base at the 
height and radius you specify.

Using the Cone 2 Point Tool
1. Select the Cone Primitive tool.

2. Select the Cone 2 Point tool in the Message Line. The Message Line reads: 
Cone Primitive: Enter start and end points for cone.

3. Click in the drawing area to set the start (center) point and the end (tip) point 
of the cone.

The cone is created with its height equal to the distance between the two points 
that you chose and with its top and bottom centered on those points.

While the cone is still selected you can change the X, Y, Z location of the base cen-
ter point, the dX, dY and dZ to the second point for defining the distance and direc-
tion of the cone and the radius, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the base center point, the dX, dY, 
dZ values for the distance and direction to the second point (tip) and the Radius.
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Cone by Diagonals Tool

This tool draws a cone based on the two base corners and 
the height that you specify.

Using the Cone by Diagonals Tool
1. Select the Cone Primitive tool.

2. Select the Cone by Diagonals tool in the Message Line. The Message Line 
reads: Cone Primitive: Enter start diagonal point [Shift=Square].

3. Click two points in the drawing area to specify two diagonal corners of the 
cone base’s bounding box.

Hold down the SHIFT key to draw a circular base. After you click your first point, 
while holding down the key, The Message Line reads: locking....” The distance 
between the two points are used to calculate the cone’s diameter.

After doing this step, The Message Line reads: Cone Primitive: Enter height.

4. Drag to set the height of the cone.

The cone is created. If you are working in the top, front or side view, pick a 
point, and our Designer Elements program will make the cone’s height equal to 
that of the last cone you drew (or equal to one, if this is the first cone you drew). 
If you are working in a 3D view, you can select the point to set the desired 
height.

While the cone is still selected you can change the X, Y, Z location of the cone’s 
base center point, the dX, dY, and dZ values for the distance and direction to the 
second point (tip), and the cone’s height, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the cone’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point, and the 
Height.

Geometric Characteristics
A cone primitive is created by picking one point to specify the center point of the 
cone’s base, two points for the center point and height, or three points for the cor-
ners of the bounding box and the cone’s height. It is made up of the following 
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characteristics: Height, Top Diameter, Diameter Ratio (D1/D2 or R1/R2) and Bottom 
Diameter. This information is listed in the Edit Objects dialog box under the Geom-
etry tab. To display the dialog box, select the cone once and choose Window>Edit 
Objects or double-click the cone.

Torus Primitive Tool

The torus primitive looks like a doughnut. It is generated by sweeping a circle 
around another implied circle. The torus is defined by a center point, the diameter 
of the torus, called the Major Diameter, and the tube’s diameter, called the Minor 
Diameter. The graphics below illustrate these dimensions.

When you select the Torus Primitive tool, a subpalette appears in the Message 
Line with three cone tools: Torus 1 Point, Torus 2 Point and Torus by Diagonals.

Torus 1 Point Tool

This tool draws a torus using the center point you specify and the 
Major Diameter (D1) and the Minor Diameter (d2) of the Status 
Line.
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Using the Torus 1 Point Tool
1. Select the Torus Primitive tool.

2. Select the Torus 1 Point tool in the Message Line. The Message Line reads: 
Torus Primitive: Enter center point for torus.

3. Click in the drawing area to set the center.

A torus is created with its center at the point you chose. The torus lies perpendic-
ular to the z axis of the current work plane.

While the torus is selected you can change the X, Y, Z location of the base center 
point, the Major diameter (D1) and the Minor diameter (d2), if desired. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the torus’ center point, D1 (Major 
diameter) and d2 (Minor diameter).

Torus 2 Point Tool

This tool draws a torus from the center point and radius.

Using the 2 Point Torus Tool
1. Select the Torus Primitive tool.

2. Select the Torus 2 Point tool in the Message Line. The Message Line reads: 
Torus Primitive: Enter center and radius point for torus.

3. Click the center point and the radius point in the drawing area.

A torus is created with a center point at the first point and the major diameter at 
the second point.

While the torus is still selected you can change the X, Y, Z location of the base cen-
ter point, the dX, dY and dZ to the second point for defining the distance and direc-
tion, the Major Diameter (D1) and Minor Diameter (d2), if desired. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the values.
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The Status Line contains the X, Y and Z values for the torus’s center point, the dX, 
dY and dZ values for the distance and direction to the second point, the D1 (Major 
Diameter) and d2 (Minor diameter).

Torus by Diagonals Tool

This tool draws a torus from the center point, 
major radius and minor radius.

Using the Torus by Diagonals Tool
1. Select the Torus Primitive tool.

2. Select the Torus by Diagonals tool in the Message Line. The Message Line 
reads: Torus Primitive: Enter start diagonal point [Shift=Square].

3. Click twice to specify two diagonal corners of the torus’ bounding box.

Hold down the SHIFT key to draw a square bounding box. After you click your 
first point The Message Line reads: locking.... The distance between the two 
points are used to calculate the torus’ diameter.

4. The Message Line reads: Torus Primitive: Enter height.

5. Drag to set the height of the torus.

If you are working in the top, front or side view, pick a point. Our Designer Ele-
ments program will calculate the torus’s Minor Diameter based on the location of 
that point. If you are working in a 3D view, you can select the point to set the 
Minor Diameter.

While the torus is still selected you can change the X, Y, Z location of the torus’ 
center point, the dX, dY, and dZ values for the distance and direction to the second 
point (Major Diameter), and the torus’ Minor Diameter, if desired. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the torus center point, the dX, dY 
and dZ values for the distance and direction to the second point D1 (Major Diame-
ter) and the d2 (Minor Diameter).
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Geometric Characteristics
A torus primitive is created by picking one point to specify the center point of the 
torus, two points for the center point and Major Diameter, or three points for the 
corners of the bounding box and the torus’ Minor Diameter. It is made up of the 
following characteristics: Major Diameter, Minor Diameter, and Center (X, Y, and Z 
values). This information is listed in the Edit Objects dialog box under the Geome-
try tab. To display the dialog box, select the torus and choose Window>Edit 
Objects or double-click the torus.

Prism Primitive Tool

The prism primitive is composed of three 
or more sides, all perpendicular to the 
solid’s base.

When you select the Prism Primitive tool a subpalette appears in the Message Line 
containing three prism tools: Prism 1 Point, Prism 2 Point and Prism by Diago-
nals.

Prism 1 Point Tool

This tool draws a prism using the center 
point that you specify and the radius, 
height and number of sides listed of the 
Status Line.

Using the Prism 1 Point Tool
1. Select the Prism Primitive tool.



Prism Primitive Tool
2. Select the Prism 1 Point tool in the Message Line. The Message Line reads: 
Prism Primitive: Enter center point for prism.

3. Click in the drawing area to set the base's center point.

A prism is created with its base centered at the point you chose. The prism 
extends along the z axis of the current work plane.

While the prism is still selected you can change the X, Y, Z location of the base cen-
ter point, the radius, height and number of sides, if desired. Press ENTER (Win-
dows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the prism’s base center point and 
its Radius, Height, and # of sides.

Prism 2 Point Tool

This tool draws a prism from the center 
point and at the height you specify. 

Using the 2 Point Prism Tool
1. Select the Prism Primitive tool.

2. Select the Prism 2 Point tool in the Message Line. The Message Line reads: 
Prism Primitive: Enter start and end points for prism.

3. Click in the drawing area to set the start point (center) and the end point 
(height).

A prism is created with its height equal to the distance between two points of 
your chosing and its top and bottom centered on those points.

While the prism is still selected you can change the X, Y, Z location of the base cen-
ter point, the dX, dY and dZ to the second point for defining the distance and direc-
tion, the radius and the number of sides, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the prism’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point and the 
prism’s Radius and # of sides. 
18-19



Solids Creation Tools - Primitives

18-20
Prism by Diagonals Tool

This tool draws a torus from two corner 
points, representing the prism’s bounding 
box and a third point for the height.

Using the Prism by Diagonals Tool
1. Select the Prism Primitive tool.

2. Select the Prism by Diagonals tool in the Message Line. The Message Line 
reads: Prism Primitive: Enter start diagonal point [Shift=Square].

3. Click two points in the drawing area to specify two diagonal corners of the 
prism base’s bounding box.

Hold down the SHIFT key to draw a square bounding box. After you click your 
first point, The Message Line reads: locking.... The distance between the two 
points are used to calculate the prism’s diameter.

4. The Message Line reads: Prism Primitive: Enter height.

5. Drag to set the height of the prism.

If you are working in the top, front or side view, pick a point, and our Designer 
Elements program will make the prism’s height equal to that of the last prism you 
drew (or equal to one inch if this is the first prism you draw). If you are working 
in 3D view you can select the point to set the desired height.

While the prism is still selected you can change the X, Y, Z location of the prism’s 
base center point, the dX, dY, and dZ values for the distance and direction to the 
second point and the prism’s height, if desired. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the prism’s base center point, the 
dX, dY and dZ values for the distance and direction to the second point and the 
prism’s Height.

Geometric Characteristics
A prism primitive is created by picking one point to specify the center point of the 
prism’s base, two points for the center point and height, or three points for the cor-
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ners of the bounding box and the prism’s height. It is made up of the following 
characteristics: Height, Diameter, Diameter Ratio (D2/D1 or R2/R1) and Sides. This 
information is listed in the Edit Objects dialog box under the Geometry tab. To dis-
play the dialog box, select the prism and choose Window>Edit Objects or double-
click the prism.

Pyramid Primitive Tool

A pyramid contains three or more flat 
faces which converge to a common vertex 
at the tip. 

A pyramid is created by defining the diameter of the base, the height and the num-
ber of sides. 

When you select the Pyramid Primitive tool a subpalette appears in the Message 
Line containing three pyramid tools: Pyramid 1 Point, Pyramid 2 Point and Pyra-
mid by Diagonals.

Pyramid 1 Point Tool

This tool draws a pyramid using the center point that you specify 
and the radius, height and number of sides listed of the Status 
Line.

Using the 1 Point Pyramid Tool
1. Select the Pyramid Primitive tool.

2. Select the Pyramid 1 Point tool in the Message Line. The Message Line reads: 
Pyramid Primitive: Enter center point for pyramid.

3. Click in the drawing area to set the center.
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A pyramid is created with its base centered at the point you chose. The pyramid 
extends along the z axis of the current work plane.

While the pyramid is still selected you can change the X, Y, Z location of the base 
center point, the radius, height and number of sides, if desired. Press ENTER (Win-
dows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the pyramid’s base center point 
and its radius, height and # of sides.

Pyramid 2 Point Tool

This tool draws a pyramid from the base center point and the 
height.

Using the 2 Point Pyramid Tool
1. Select the Pyramid Primitive tool.

2. Select the Pyramid Two Point tool in the Message Line. The Message Line 
reads: Pyramid Primitive: Enter start and end points for pyramid.

3. Click two points in the drawing area.

A pyramid is created whose height is equal to the distance between the two 
points that you chose and whose top and bottom are centered on those points.

While the pyramid is still selected you can change the X, Y, Z location of the base 
center point, the radius, height and number of sides, if desired. Press ENTER (Win-
dows) or RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the pyramid’s base center point, 
the dX, dY and dZ characteristics for the distance and direction to the second point 
and the pyramid’s radius and # of sides.
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Pyramid by Diagonals Tool

This tool draws a pyramid from the corner of the pyramid’s 
bounding box and the height that you specify.

Using the Pyramid By Diagonals Tool
1. Select the Pyramid Primitive tool.

2. Select the Pyramid by Diagonals tool in the Message Line. The Message Line 
reads: Pyramid Primitive: Enter start diagonal point [Shift=Square].

3. Click two points in the drawing area to specify two diagonal corners of the pyr-
amid base’s bounding box.

Hold down the SHIFT key to draw a square bounding box. After you click your 
first point, The Message Line reads: locking.... The distance between the two 
points are used to calculate the pyramid’s diameter.

4. The Message Line reads: Pyramid Primitive: Enter height. 

5. Drag to set the height of the pyramid.

If you are working in the top, front or side view, pick a point, and a pyramid is 
created with a height equal to that of the last pyramid you drew (or equal to one 
inch if this is the first pyramid you draw). If you are working in a 3D view you 
can select the point to set the desired height.

While the pyramid is still selected you can change the X, Y, Z location of the pyra-
mid’s base center point, the dX, dY, and dZ values for the distance and direction to 
the second point and the pyramid’s height, if desired. Press ENTER (Windows) or 
RETURN (Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the pyramid’s base center point, 
the dX, dY and dZ values for the distance and direction to the second point and the 
pyramid’s Height.

Geometric Characteristics
A pyramid primitive is created by picking one point to specify the center point of 
the pyramid’s base, two points for the center point and height, or three points for 
the corners of the bounding box and the pyramid’s height. It is made up of the fol-
lowing characteristics: Height, Top Diameter, Diameter Ratio (D2/D1 or R2/R1), 
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Bottom Diameter and Sides. This information is listed in the Edit Objects dialog box 
under the Geometry tab. To display the dialog box, select the pyramid and choose 
Window>Edit Objects or double-click the pyramid.

Ellipsoid Primitive Tool

An ellipsoid primitive is created from a center point, center point and radius, or two 
diagonal points on a bounding box.

When you select the Ellipsoid Primitive tool a subpalette appears in the Message 
Line containing three tools for creating ellipsoids: Ellipsoid 1 Point, Ellipsoid 2 
Point and Ellipsoid by Diagonals.

Ellipsoid 1 Point Tool

This tool creates an ellipsoid using the center point that 
you specify and the X, Y and Z diameters entered in the Status Line. The Drafting 
Assistant displays a vertex notation at the center point. 

Using the Ellipsoid 1 Point Tool
1. Select the Ellipsoid Primitive tool.

2. Select the Ellipsoid 1 Point tool in the Message Line. The Message Line reads: 
Ellipsoid Primitive: Enter center point for ellipsoid.

3. Click a point in the drawing area.

The ellipsoid appears.

While the ellipsoid is still selected you can change the X, Y and Z location of the 
center point and the diameters. Press ENTER (Windows) or RETURN (Macintosh) to 
accept the new values.



Ellipsoid Primitive Tool
The Status Line contains the X, Y and Z values for the center point and DiamX, 
DiamY and DiamZ for the ellipsoid diameters. 

Ellipsoid 2 Point Tool

This tool creates an ellipsoid using the center point and the 
radius you specify. The Drafting Assistant displays vertex notations at the center 
point and radius.

Using the Ellipsoid 2 Point Tool
1. Select the Ellipsoid Primitive tool.

2. Select the Ellipsoid 2 Point tool in the Message Line. The Message Line reads: 
Ellipsoid Primitive: Enter center and radius point for ellipsoid.

3. Click the center point and radius point in the drawing area.

The ellipsoid appears.

While the ellipsoid is still selected you can change the X, Y and Z location of the 
center point, the dX, dY and dZ values for the first radius and the two radii not 
specified in the operation (R1 and R2). Press ENTER (Windows) or RETURN (Macin-
tosh) to accept the new values.

T
h

e Status Line contains the X, Y and Z values for the center point, the dX, dY, dZ, R1 
and R2 values.

Ellipsoid by Diagonals Tool

This tool creates an ellipsoid based on two corners of the 
ellipsoid’s bounding box and the height you specify. The 
Drafting Assistant displays vertex notations at the bound-
ing box corners.

Using the Ellipsoid by Diagonals Tool
1. Select the Ellipsoid Primitive tool.
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2. Select the Ellipsoid by Diagonals tool in the Message Line. The Message Line 
reads: Ellipsoid Primitive: Enter diagonal corners for ellipsoid. Enter start diago-
nal point [Shift = Square].

3. Click two points in the drawing area to specify two diagonal corners of the 
ellipsoid’s bounding box. 

Hold down the SHIFT key to draw a rectangular base. After you click your first 
point The Message Line reads: locking... The distance between the two points 
are used to calculate the ellipsoid’s diameter.

4. The Message Line reads: Ellipsoid Primitive: Enter height.

5. Drag to set the height of the ellipsoid.

The ellipsoid appears. If you are working in the top, front or side view, pick a 
point, and our Designer Elements program will make the ellipsoid’s height 
equal to that of the last ellipsoid you drew (or equal to one inch if this is the 
first ellipsoid you draw). If you are working in a 3D view you can select the 
point to set the desired height.

While the ellipsoid is still selected you can change the X, Y, Z location of the ellip-
soid’s base center point, the dX, dY, and dZ values for the distance and direction to 
the second point, and the ellipsoid’s height. Press ENTER (Windows) or RETURN 
(Macintosh) to accept the new values.

The Status Line contains the X, Y and Z values for the cylinder’s base center point, 
the dX, dY and dZ values for the distance and direction to the second point. 

Geometric Characteristics
An ellipsoid primitive is created by picking one point to specify the center of the 
primitive’s base, two points for the center point and height, or three points for the 
corners of the bounding box and the ellipsoid’s height. It is made up of the follow-
ing characteristics: Center X, Y and Z and Diameter 1, Diameter 2 and Diameter 3.

For ellipsoids created using the Ellipsoid 1 Point tool, DiamX, DiamY and DiamZ 
correspond to Diameter1, Diameter2 and Diameter3. For ellipsoids created with the 
Ellipsoid 2 Point tool, the dX, dY, dZ values are used to determine the Diameter 1 
value. R1 corresponds to Diameter 2 and R2 corresponds to Diameter 3.

This information is listed in the Edit Objects dialog box under the Geometry tab. To 
display the dialog box, select the cylinder and choose Window>Edit Objects or 
double-click on the cylinder.



Tech Note:

The ASIC kernal has been 
improved such that you 
may now use grouped 
profiles as well as 
grouped curves for pro-
files..
Solids Creation Tools - Profiles

A profile is a closed section created from curves, polygons or surfaces (planar and 
non-planar). You can lathe, extrude, or sweep a profile to create a solid.

When you make a solid 
from a profile, our 
Designer Elements pro-
gram creates a parent/child 
relationship (Cobalt™ and 
Xenon™ only) between 
the profile (the parent) and 
the solid (the child). If you 
change the parent, our 
Designer Elements pro-
gram automatically regen-
erates the child (Cobalt™ and Xenon™ only). For example, if you lathe a 
rounded rectangle polygon, you can change the polygon's radius and the solid will 
update to the new size (Cobalt™ and Xenon™ only). The graphic here shows 
how you can use the same 2D profile to create three different objects.

Our Designer Elements program supports five tools for creating solids from profiles. 
For each tool you can enter values in the Status Line to define a solid, either before 
or after you create the solid. If you enter the values after you select the tool but 
before you create the solid, your first click in the drawing area automatically regis-
ters all Status Line values. If you enter values in the selected Status Line data field 
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Tech Note:

These tools do not support 
using the Select Chain com-
mand to select multiple 
grouped profiles. However 
can can extrude multiple 
grouped profiles at one time.
after creating the solid and while the solid is still selected, pressing ENTER (Win-
dows) or RETURN (Macintosh) updates the solid to reflect the new values.

The topics explained include the following:

• Lathed Solid tool

• Extrude Solid tool

• Swept Solid tool

• Swept Solid 2 Rail tool

• Cutout Feature tool

• Protruded Feature tool

• Skinned Solid tool

• Pipe Solid tool

• Solids from Profile Curve Checks

Lathed Solid Tool

The Lathed Profile tool creates a solid by revolving a profile around an axis line. 
You can lathe profiles composed of individual, grouped or nested group curves. 
You cannot lathe a profile that intersects itself, as can happen with splines and 
polygons.

Using the Lathed Solid Tool
Before you can use this tool you must first create a profile and a curve for lathe 
axis.

1. Click the Lathe Solid tool. The Message Line reads: Lathed Solid: Select objects to 
lathe [Shift=Extend].

2. The Status Line contains the Degree and Draft Angle fields. Enter the desired 
values for your lathed solid. Tab between data fields.

When the draft angle is zero, the sides of the solid lie parallel to the profile nor-
mal. If the draft angle is positive, the sides will be forced outward from the nor-



Lathed Solid Tool
mal. Negative draft angles force the sides inward towards the normal.

3. Pick a curve or curves to lathe. If you are selecting more than one curve, hold 
down the SHIFT key before selecting the first curve. 

The curves making up the profile must be 
closed. If they are not, this message 
appears:

Our Designer Elements program places 
markers at the gap locations so you can 
easily find and close them.

The Message Line now reads, Lathed Solid: Pick line for lathe axis [Shift=Extend]. 

4. Pick the line around which to rotate the curves and make the solid object.

Our Designer Elements program determines the direction of revolution from the 
direction in which the line was drawn. The left graphic shows a view of a profile 
and a line drawn in the direction of the arrow. The right graphic shows the pro-
file lathed 90°.

After you click the line, the object is lathed.

While the object is still selected you can edit the number of degrees in the revolu-
tion angle and the draft angle for the entire solid. Enter the new values and press 
ENTER (Windows) or RETURN (Macintosh) and the solid updates.

Geometric Characteristics
A lathed profile solid is created by picking one or more curves from which to con-
struct the solid and a line about which to rotate the curves. The lathed solids is 
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made up of the following characteristics: Lathe Angle and Draft Angle. This infor-
mation is listed in the Edit Objects dialog box under the Geometry tab. To display 
the dialog box, select the lathed solid and choose Window>Edit Objects or dou-
ble-click the lathed solid.

Extrude Solid Tool

The Extrude Solid tool extends the selected profile along a vector. You can extrude 
profiles composed of lines, circles, ellipses, closed splines, polygons, grouped 
curves (including nested groups) and surfaces. 

Be careful when selecting circles for 
extrusion. If one of them is actually 
a sphere you will receive the follow-
ing error message:

This tool does not support extruding 
a non-planar surface with a non-
zero draft angle. This message dis-
plays if you attempt to do so.

In our Designer Elements program, this tool uses the plane of the selected profile 
for the extrusion rather than the work plane normal, providing greater flexibility.

In the Message Line there are five extrusion options:



Extrude Solid Tool
Distance Extrudes normal to the plane of the profile a spec-
ified distance. The distance can be positive or neg-
ative.

Vector Extrudes a profile along a vector whose distance is 
defined by the user supplied points.

Mid Plane Extrudes a profile in both directions using the 
plane of the profile.

To Entity Extrudes along a vector terminating at a surface or 
solid. The terminating body is not unioned with 
the extruded body.

Thin Extrudes an open or closed profile by a vector and 
thickness.

Below are examples of each type of extrusion

Extrude by Distance
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Extrude by Vector¬

Extrude by Mid Plane

Extrude to Entity



Extrude Solid Tool
Thin Extrude

Note: The Thin Extrude tool has a toggle key that changes the location of the 
extrude. Use the CRTL key (Windows) or the OPTION key (Macintosh) to toggle 
the extrusion between the right side, left side or offset (mid plane) directions. 
Examples of the toggle directions are below.

Offset/Mid Plane Right Side Extrude Left Side Extrude
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Tech Note:

Some draft angles and extru-
sion heights will cause the 
solid to self intersect. If this 
happens you must reduce the 
draft angle or increase the 
extrusion height.

If you select multiple profiles 
and one of them is not planar, 
a warning will appear. You 
must correct this or you will 
receive an ACIS error.
You have access to these toggle directions in the Edit Objects dialog box. However 
you must access the Edit Objects box through the Design Explorer in order to 
change these directions.

Using the Extrude Solid Tool
Before you can use this tool you must first create a profile to extrude.

1. Click the Extrude Profile tool. The Message Line reads: Extrude Solid: Select close 
objects to extrude by vector [Shift=Extend].

2. The Status Line contains the dX, dY and dZ values, the Distance of the extru-
sion vector and the Draft Angle. Enter the desired Distance and the Draft Angle 
for your extruded solid. Tab between data fields.

When the draft angle is zero, the sides of the solid lie parallel to the profile nor-
mal. If the draft angle is positive, the sides will be forced outward from the nor-
mal. Negative draft angles force the sides inward towards the normal.



Extrude Solid Tool

Tech Note:

You must enter the extrusion 
distance for each new profile 
recreated even if the dis-
tance is the same as the pre-
vious extrusion.
3. Pick one or more curves to extrude. As the Message Line indicates, they must 
be closed. If they are not, this message appears:

Our Designer Elements program places 
markers at the gap locations so you can 
easily find and close them.

The Message Line now reads, Extrude 
Solid: Specify two points for extrusion 
direction and length.

4. Pick two points on the screen. The extruded solid is created.

If the extrusion vector defined by is points travels in a positive direction, the 
extrusion lies along the profile's normal. If the extrusion vector is negative, the 
extrusion direction lies opposite the profile's normal.

The following error message appears if you choose points that are tangential to 
the profile:

While the object is still selected you can edit the dX, dY, and dZ values for the 
extrusion vector's of the extrusion vector's distance and the draft angle for the 
entire solid. Enter the new values and press ENTER (Windows) or RETURN (Macin-
tosh) and the solid updates.

Geometric Characteristics
An extruded profile solid is created by picking one or more curves from which to 
construct the solid, and then picking two points to indicate the extrusion's distance 
and direction. It is made up of the following characteristics: Distance, Draft Angle, 
and the Direction of the vector (DX, DY and DZ). This information is listed in the 
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Edit Objects dialog box under the Geometry tab. To display the dialog box, select 
the extruded solid and choose Window>Edit Objects or double-click the extruded 
solid.

Swept Solid Tool

The Swept Solid tool creates a solid by sweeping the 
profile along a curve. You can extrude profiles com-
posed of lines circles, ellipses, closed splines, polygons, 
grouped (including nested groups) curves and surfaces.

Important: Be careful that there are no gaps or overlapping curves in the profile.

The Swept Solid tool has two pull down options in the Message Line. The first pull 
down controls how the profile orientation as it is swept along the path. This pull 
down has three options:

• Sweep In Place - The profile is not translated or aligned to the path.

• Sweep Perp - The profile is translated and aligned perpendicular to the path

• Sweep Rigid - The profile orientation is maintained regardless of path tangency.

The second pull down controls how the profile is terminated. This pull down has 
three options:

• Curve Extents - The profile is swept across the entire curve extents.

• To Body - The profile is terminated at a surface or solid.

• Between Points - The user specifies two points on the path.

Note: Sweep Perpendicular was the default sweep behaviour in previous version of 
Cobalt and Vellum Solids.

Using the Swept Solid Tool
Before you use this tool you must first create a profile and a curve for the sweep.

1. Click the Swept Solid tool. The Message Line reads: Swept Solid: Select closed 
profile to sweep [Shift=Extend].



Swept Solid Tool
2. The Status Line contains the Twist Angle and Draft Angle data fields. Enter the 
twist angle through which you want your solid to twist from beginning to end 
and a draft angle if desired.

3. Pick one or more curves for the profile. 
As the Message Line indicates, they 
must be closed. If they are not, this 
message appears:

Our Designer Elements program places 
markers at the gap locations so you can easily find and 
close them.

The Message Line now reads, Swept Solid: Enter loca-
tion for sweep profile origin. 

4. Pick the point on the screen where you want the sweep to begin.

The Message Line now reads, Swept Solid: Pick curve(s) for sweep path 
[Shift=Extend]. 

5. Pick the curve or curves along which to sweep the profile.

The swept solid is created.

While the object is still selected you can edit the twist and draft angles. Enter the 
new values and press ENTER (Windows) or RETURN (Macintosh) and the solid is 
adjusted.

Geometric Characteristics
A swept profile solid is created by picking one or more curves from which to con-
struct the solid, picking the point where the sweep will start, and then picking the 
curve along which the profile will sweep. It has two characteristics, Twist Angle 
and Draft Angle. This information is listed in the Edit Objects dialog box under the 
Geometry tab. To display the dialog box, select the swept solid once and choose 
Window>Edit Objects or double-click the swept solid.
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Sweep 2 Rail (Paths) Solid 

The Sweep 2 Rail Solid tool creates a solid by sweeping the profile along two curve. 
You can extrude profiles composed of lines circles, ellipses, closed splines, poly-
gons, grouped curves (including nested groups) and surfaces.

Important: Be careful that there are no gaps or overlapping curves in the profile.

Using the Sweep 2 Rail Solid Tool
Before you use this tool you must first create a profile and a curve for the sweep.

1. Select the Sweep 2 Rail Solid tool. The Message Line reads: Sweep 2 Rail Solid: 
Pick curves or group to sweep. [Ctrl = Maintain Height][Shift = Extend]

2. Pick the curves or group that defines the profile you want to sweep.

3. Choose the first rail that your profile will be swept along.

4. Choose the second rail that your profile will be swept along.

There are not status line entries for this tool.

Geometric Characteristics
A swept 2 rail profile solid is created by picking closed curves or a group from 
which to construct a solid. Picking the two rails (curves) along which the profile 
will be swept. There are only to tabs in the Edit Objects dialog box for this tool, 
Display and Attributes.



Cutout Feature Tool
Cutout Feature Tool

This tool subtracts material from a solid. The cutout is formed from a 2D profile. 
This profile can be located on or in the solid and composed of grouped curves. You 
can specify a Draft Angle in the Status Line.

Using the Cutout Feature Tool
1. Create a 2D profile with a curve or polygon tool and place it on or in the solid 

where the cutout will begin.

2. Select the Cutout Feature tool. The Mes-
sage Line reads: Cutout Feature: Pick 
solid for cutout.

3. Select the solid to be cut. The Message Line now reads, Cutout Feature: Pick 
closed curves or polygon for cutting [Shift=Extend].

4. Select the profile previously created.

5. Specify two points in the drawing area to indicate the direction and length of 
the cutout.

While the solid is still selected you can change the distance, draft angle and direc-
tion of the cutout in the Status Line. Type the desired values in the data fields and 
press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the extrusion dX, dY and dZ values, the extrusion Distance 
and the Draft Angle.
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Geometric Characteristics
A cutout is created by selecting a profile, the solid through which to cut and the dis-
tance and direction of the cut. It is made up of these characteristics according to 
Edit Objects: Distance, Draft Angle and Direction (DX, DY, DZ values). To modify 
the hole characteristics, select the hole using the Design Explorer and choose Win-
dow>Edit Objects or double-click on the cutout name. See Chapter 24 for more 
information on the Design Explorer.

Protruded Feature Tool

The tool adds a piece to an existing solid. The protrusion is formed from a 2D pro-
file. The profile does not need to be attached to the original solid and can be 
grouped curves.

Termination Types
The Message Line also contains a pull-down menu 
allowing you to choose where the protrusion will 
end. You have two options: Vector and To Face.

Vector Defined by two 
points that you choose the vector determines the 
length and direction of the protrusion.

To Face Extends the protrusion to a face on the solid.

Using the Protruded Feature Tool - Vector Option
1. Create a 2D profile where the protrusion will begin.

2. Select the Protruded Feature tool. The 
Message Line reads: Protruded Feature: 
Pick solid for protrusion.



Protruded Feature Tool
3. Select the Vector Termination Type from the pull-down menu in the Message 
Line. 

4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or 
polygon for adding [Shift=Extend].

5. Select the profile previously created.

6. Specify two points for protrusion direction and length.

While the solid is still selected, you can change the direction and distance of the 
protrusion and the draft angle in the Status Line. Type the desired values in the data 
fields and press ENTER (Windows) or RETURN (Macintosh).

Using the Protruded Feature Tool - Face Option
1. Create a 2D profile where the protrusion will begin. (It need not be on the 

solid.)

2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: 
Pick solid for protrusion.

3. Select the To Face Termination Type from the pull-down menu in the Message 
Line.

4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or 
polygon for adding [Shift=Extend].

5. Select the profile previously created.

6. Select the face on the solid where you want the protrusion to end. 

7. Specify two points for the protrusion direction. Since you are specifying the 
direction, not the length, you do not need to reference the curve or the solid.

While the solid is still selected you can change the direction and distance of the 
protrusion and the draft angle in the Status Line. Type the desired values in the data 
fields and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the protrusion dX, dY and dZ values, the protrusion's Dis-
tance and Draft Angle.

Geometric Characteristics
A protrusion is created by selecting a profile, the solid from which you want to 
extend the profile and the distance and direction of the protrusion. It is made up of 
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these characteristics according to Edit Objects: Distance, Draft Angle and Direction 
(DX, DY, DZ values). It also contains the Offset Both Directions check box. To 
modify the protrusion characteristics, select the protrusion using the Design 
Explorer and choose Window>Edit Objects or double-click on the protrusion 
name. See Chapter 24 for more information on the Design Explorer.

Cutout and Protruded Curve Checks
To assist you in performing cutout and protrude operations, this Designer Elements 
program provides you with two curve checks: gaps and planar.

Curve Gap Check
The gap check warns you when the curves for the cutout or protrusion are not 
closed.

Planar Curves Check
The planar check warns you if the selected curves for the cutout or protrusion are 
not planar.



Skinned Solid Tool
Skinned Solid Tool

The Skinned Solid tool creates a solid from a collection of closed profiles. You can 
create skin solids using profiles composed of individual curves (such as circles or 
ellipses) or grouped curves. A profile composed of individual curves does not have 
to be grouped for use with this tool.

There are two tools in the Message Line: Skin Curve and Skin with Guide Curves.

Skin Curve Solid Tool

This tool creates a skin solid between two or 
more curves. The solid edges are defined by the 
limits of the select curves. The figure here 
shows a skin solid created from three curves.

Using the Skin Curve Solid Tool
1. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick 

closed curve(s) or polygons for solid from sections [Shift = Extend].

2. Select the Skin Curve Solid tool in the Message Line.

3. Hold down the SHIFT key and select the closed curves.

The solid is created.

There are no entries in the Status Line.
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Skin with Guide Curves Solid Tool

This tool creates a skinned solid between two 
or more curves using curves as guides to 
define the edges. Guide curves give you con-
trol over the skinned solid. You can use one or 
more guide curves to influence the solid. In the 
graphic the circles are skinned using the spline 
as a guide.

Guide Curve Rules

• Curves can go in any direction and need not be consistent with the others.

• Curves cannot loop and must be “well-behaved.” 

• The curves must connect with each profile that you want to use for the solid cre-
ation.

Using the Skin with Guide Curves Solid Tool
1. Create the profile curves and curve guides.

2. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick 
closed curve(s) or polygons for solid from sections [Shift = Extend].

3. Select the Skin with Guide Curves Solid tool (the right tool) in the Message Line.

4. Hold down the SHIFT key and select the closed curves.

The Message Line now reads, Skinned Solid: Pick guide path for skinned solid 
[Shift = Extend].

5. Select the guide curves.

The solid is created.

There are no entries in the Status Line.

Geometric Characteristics
A skinned solid object is a solid created from profiles and is made up of the same 
characteristics as any solid object.



Solids from Profiles Curve Checks
Solids from Profiles Curve Checks
In order to create objects using the Lathed Solid, Extrude Solid and Swept Solid 
tools, the profiles must be closed and planar.

Close Curves Check
The closed curves check warns 
you if your profile contains gaps.

Pipe Solid Tool

The Pipe Solid tool provides a quick and easy way to create pipes and tubes.You 
select a curve for the pipe's center line and specify the pipe's inner and outer diam-
eter values. You can create a pipe by selecting curves connected end to end. You 
cannot create more than one pipe at a time with this tool.

When you make a pipe solid, this Designer Elements program creates an intelligent 
link between the solid and its parent center line. When you move or modify the 
center line, the pipe updates automatically. A pipe with an inner diameter of zero is 
a solid cylinder.

This tool does not support grouped curves for creating a pipe solid.
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Using the Pipe Solid Tool
Before you can use this tool you must first create a curve for the pipe.

1. Click the Pipe Solid tool. The Message Line reads: Pipe Solid: Select curve for 
pipe path [Shift=Extend].

The Status Line contains the Outside Diameter and Inside Diameter data fields.

2. Enter values in the Status Line data fields. 

An Inside Diameter of zero creates a cylinder. Tab between the fields.

3. Select the curve. If you want to select more than one curve, hold down the 
SHIFT key before selecting the first curve.

A pipe is drawn.

While the object is still selected you can edit the Outside Diameter and the Inside 
Diameter. Enter the new values and press ENTER (Windows) or RETURN (Macin-
tosh) and the solid is adjusted.

Geometric Characteristics
A pipe solid is created by selecting one or more curves and entering specifying the 
inner and outer diameters. A pipe solid is made up of the following characteristics: 
Outer Diameter, Inner Diameter and Wall Thickness. This information is listed in the 
Edit Objects dialog box under the Geometry tab. To display the dialog box, select 
the extruded solid and choose Window>Edit Objects or double-click the pipe.



Tech Note:

These editing tools cannot 
be performed on grouped 
objects, only curves.
General Editing Tools
Once you create an object you can select and alter it by choosing a command or 
using a tool to edit it. This chapter describes common editing activities and com-
pares different methods for performing the same action. You can use the editing 
tools to change an object’s geometry, size, location or orientation. They are col-
lected in three subpalettes in the main tool palette.

For each tool you can enter values in the Status Line to perform the editing opera-
tion before or after the operation is complete. If you enter the values after you 
select the tool but before you perform the operation, your first click in the drawing 
area automatically registers all Status Line values. If you enter values after perform-
ing the operation and while the curve is still selected, pressing ENTER (Windows) 
or RETURN (Macintosh) updates the curve to reflect the new values.

Many of the editing tools require a two step process for their usage. The first step 
after choosing the tool may be to select one or more objects. The second step per-
forms the editing operation. Once you the complete the first step you cannot select 
more objects to include in the same operation. To select additional objects reset the 
tool and start again.

There are no unique geometric characteristics listed in the Edit Objects dialog box 
for an object after using these tools. For example, a fillet between two lines creates 
an arc. Edit Objects lists the parameters for an arc.

The following topics are explained:

• Fillet/Chamfer tools

• Trim tools
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• Curve Extras tools

Fillet and Chamfer Tools

These tools on the main tool palette construct fillets and chamfers from corners 
formed by nonparallel lines or curves. This Designer Elements program automati-
cally trims fillets and chamfers by default. If you do not want them trimmed hold 
down the CTRL (Windows) or the OPTION (Macintosh) key while you are selecting 
the objects to fillet or chamfer.

All curves that you want to fillet must be in the same plane.

2-Entity Fillet Tool

This tool constructs an arc tangent to the two objects you specify.

Using the 2-Entity Fillet Tool
1. Select the 2-Entity Fillet tool. The Message Line reads: 2-Entity Fillet: 

Pick first entity. [Shift=Corner, Ctrl=No trim (Windows) or Option=No 
Trim (Macintosh)].

2. Enter the arc radius you want in the Status Line. The default radius is 
.50 inch. 

3. Click the first curve. The Message Line reads: 2-Entity Fillet: Pick second entity. 
[Ctrl=No trim] (Windows) or [Option=No Trim (Macintosh)].

You can also hold down the SHIFT key and click once inside the corner you want 
to fillet. (See the Message Line at the top of your drawing area for a reference to 
this feature.) If you hold down the CTRL (Windows) or OPTION (Macintosh) key 
while you select the objects to fillet the objects are not trimmed. (See the Message 
Line). Fillets create the smallest possible arc between the selected geometry.
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The Status Line contains the Radius of the fillet.

3-Entity Fillet Tool 

This tool constructs a fillet tangent to the three objects you choose.

Using the 3-Entity Fillet Tool
1. Select the 3-Entity Fillet tool. The Message Line reads: 3-Entity Fillet: Pick three 

entities [Ctrl=No Trim (Windows) or Option=No Trim (Macintosh)].

2. Click the three objects you want to fillet.

If you hold down the CTRL (Windows) or OPTION (Macintosh) key while you 
select the objects to fillet the objects are not trimmed (see the Message Line).

There are no Status Line entries.

2-Entity Chamfer Tool

This tool creates a chamfer across a corner at the specified distance from the inter-
section of two lines.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when creating a chamfer with this tool.
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Using the 2-Entity Chamfer Tool
1. Select the 2-Entity Chamfer tool.

2. In the Status Line specify the chamfer's distance from the corner. (The default 
distance is .50 inch.)

3. Click the first curve. The Message Line reads: 2-Entity Chamfer: Pick second 
entity. [Ctrl=No trim (Windows) or Option=No Trim (Macintosh)]. 

You can also hold down the SHIFT key and click once inside the corner you want 
to chamfer. (See the Message Line at the top of your drawing area for a reference to 
this feature.)

The lines are automatically trimmed or extended. If you hold down the CTRL (Win-
dows) or the OPTION (Macintosh) key while you select the objects to chamfer, the 
objects are not trimmed (see the Message Line).

The Status Line allows you to specify the distance (Length) from the chamfer to the 
intersection of the corner lines.

Angular Chamfer Tool

This tool creates a chamfer at the speci-
fied angle and distance from the corner. 
The specified angle is the angle between the chamfer and the second line of the 
corner. The specified length is the distance between the “corner and the intersec-
tion of the chamfer” and the “second line of the corner.” (The second line of the cor-
ner refers to the second line chosen when creating the chamfer.)

Using the Angular Chamfer Tool
1. Select the Angular Chamfer tool. The Message Line reads: Angular Chamfer: 

Pick first entity [Ctrl = No trim (Windows), Option = No trim (Macintosh)].



Trim Tools
2. In the Status Line, enter the length for the intersection of the chamfer and the 
second line of the corner from the corner. The default length is .50 inch. 

3. In the Status Line also enter the angle you want between the chamfer and the 
second side. The default Angle is 45°.

4. Click the first curve. The Message Line reads: Angular Chamfer: Pick second 
entity. [Ctrl=No trim (Windows) or Option=No Trim (Macintosh)].

You can also hold down the SHIFT key and click once inside the corner you want 
to chamfer. (See the Message Line at the top of your drawing area for a reference to 
this feature.)

The lines are automatically trimmed or extended by default. If you hold down the 
CTRL (Windows) or the OPTION (Macintosh) key while you select the objects to 
chamfer, the objects are not trimmed. (See the Message Line).

The Status Line allows you to set the distance (Length) from the intersection as well 
as the Angle.

Trim Tools

The Trim tools on the tool palette lengthen or shorten lines, curves and polylines. 
You select the limiting object(s) before or after you select the tool. If you don’t 
select everything you need you can hold down the SHIFT key (the tool becomes a 
temporary Selection tool) and click additional objects after the Trim tool is 
selected (see the Message Line).

When trimming curves using one of these tools the following warning will appear if 
the operation will delete the entire curve.
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Click Yes to proceed with the operation or No to exit the operation.

Simple Trim Tool

This tool shortens a curve to the specified 
boundary. If you hold down the CTRL (Win-
dows) or the OPTION (Macintosh) key while 
using this tool it becomes the Relimit tool.

When you trim a Through Point B-spline or Bezier spline an editable vector spline 
results. You can move its control points and change its shape and slope. In some 
situations trimming a curve results in a spline. This spline is also an editable vector 
spline.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when trimming with this tool.

Rule: Point to what you want to remove.

Using the Simple Trim Tool
1. Select the Simple Trim tool. The Message Line reads: Simple Trim: 

Select boundaries for simple trim [Shift = Extend].

If you already selected the boundaries, proceed to step 3.

2. Select the object that limits the trim.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Simple Trim: Pick section to trim [Shift=Select Boundary, Ctrl=Relimit (Win-
dows) Option=Relimit (Macintosh)].

3. Click the section of the object to be discarded.

There are no Status Line entries.

Relimit Tool

This tool lengthens or shortens a curve to the 
specified boundary. If you hold down the 
CTRL (Windows) or the OPTION (Macintosh) 
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key while using this tool it becomes the Trim tool. The Relimit tool will not relimit 
arcs.

When you relimit a Through Point B-spline or Bezier spline an editable vector 
spline results. You can move its control points and change its shape and slope. In 
some situations relimiting a curve results in a spline. This spline is also an editable 
vector spline.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when relimiting geometry with this tool.

Rule: Point to what you want to keep. 

Using the Relimit Tool

1. Select the Relimit tool. The Message Line reads: Relimit: Select boundaries for 
relimit [Shift = Extend].

If you already selected the boundaries, proceed to step 3.

2. Select the object that limits the change.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Relimit: Pick section to keep [Shift=Select Boundary, Ctrl=Trim (Windows) 
Option=Trim (Macintosh)].

3. Click the section of the object that you want to retain.

There are no Status Line entries.

Segment Tool

This tool divides a curve at intersec-
tions with other lines or curves.

When you segment a Through Point B-spline or Bezier spline an editable vector 
spline results. You can move its control points and change its shape and slope. In 
some situations segmenting a curve results in a spline. This spline is also an edit-
able vector spline.
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Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when segmenting curves with this tool.

Using the Segment Tool
1. Select the Segment tool. The Mes-

sage Line reads: Segment: Select 
boundaries for segment [Shift = Extend].

If you already selected the boundaries, proceed to step 3.

2. Select the objects that limits the segmentation.

If necessary, use SHIFT-click to select more boundary objects. The Message Line 
reads: Segment: Pick Entity [Shift=Select Boundary, Ctrl=Current Pen (Windows) 
or Option=Current Pen (Macintosh)].

3. Click the object to be segmented.

The selected object is segmented at the boundary objects. Even though you cannot 
see the segmentation on the screen, you can select parts of the segmented line by 
choosing it with the Selection tool. In order to see the segmentation on the screen, 
first select the boundaries and the object you want to segment, then choose 
Edit>Show Points. The endpoints of the segmented parts are displayed.

If you hold down the CTRL (Windows) or OPTION (Macintosh) key while selecting 
the line to be segmented the new segment appears in the characteristics of the cur-
rent pen style (see the Message Line).

There are no Status Line entries.

Divide Tool

This tool subdivides a curve into 
a specified number of equal-
length segments. The left graphic above shows a single line. The right graphic 
shows the line divided into four segments with the control points displayed.

When you divide a Through Point B-spline or Bezier spline an editable vector 
spline results. You can move its control points and change its shape and slope. In 
some situations dividing a curve results in a spline. This spline is also an editable 
vector spline.
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Using the Divide Tool
1. Select the Divide tool. The Message 

Line reads: Divide: Pick curve to 
divide [Shift=Extend].

2. Set the #Segs (number of segments) value in the Status Line.

3. Select the object to divide.

The object divides. The individual segments is not indicated unless you turn on 
their control points.

The Status Line allows you to set the #Segs in the curve.

Corner Trim Tool

This tool creates a corner from two objects that 
you specify. Lines are extended or shortened to 
create the corner.

When you conduct a corner trim on a Through Point B-spline or Bezier spline an 
editable vector spline results. You can move its control points and change its shape 
and slope. In some situations trimming a curve results in a spline. This spline is also 
an editable vector spline.

Using the Corner Trim Tool
1. Select the Corner Trim tool. The 

Message Line reads: Corner Trim: 
Pick portion of first entity to retain. 
[Shift=Corner, Ctrl=No trim (Windows) or Option=No trim (Macintosh)].

2. Select the first curve. The Message Line reads: Corner Trim: Pick portion of sec-
ond entity to retain. [Ctrl=No trim (Windows) or Option=No trim (Macintosh)].

3. Select the second object.

As an alternative to picking two entities, you can press and hold the SHIFT key and 
click inside the about-to-be-created corner.

There are no Status Line entries.
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Divide at Location Tool

This tool breaks one curve into two at a point that you 
choose.

When you divide a Through Point B-spline or Bezier 
spline using this tool an editable vector spline results. You can move its control 
points and change its shape and slope. In some situations dividing a curve results in 
a spline. This spline is also an editable vector spline. You can also divide 360° cir-
cles and ellipses.

Using the Divide at Location Tool
1. Select the Divide at Location tool. The Message Line reads: Divide at Location: 

Pick curve to divide at location: [Shift=Extend].

2. Select the curve. The Message Line reads: Divide at Location: Pick divide point. 

3. Choose the point on the curve where you want it divided.

There are no Status Line entries.

Connect Curve Tool

This tool allows you to connect curves. This Designer Elements program provides 
you with two options, Move Curve Point and Join. The Join option also includes the 
ability to set a tolerance. (The tolerance field does not apply to the default Move 
Curve Point option.)

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when connecting curves with this tool.

Using the Connect Curve Tool - Move Curve Point Default
Move Curve Point is the 
default option when using 
the tool. Using this option 
moves the endpoint from 
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the second selected curve to the endpoint of the first selected curve. This option is 
useful for creating closed profiles that you can extrude, revolve, or sweep to create 
solid models.

1. Select the Connect Curve tool. The 
Message Line reads: Connect Curve: 
Select two curves to connect end 
points [Ctrl=Join (Windows) or Option=Join (Macintosh), Shift=Extend].

2. Select the first curve near the endpoint where you want to connect the curve.

3. Select the second curve near the endpoint that you want to move.

The second curve’s endpoint moves to the endpoint of the first curve. The other 
endpoint of the second curve remains fixed.

The Status Line contains a Tolerance data field. This field only applies to the Join 
option.

Using the Connect Curve Tool - Join Option
The Join Curve option replaces 
the two curves you select with a 
new spline curve. The selected 
lines must share a tangent. This tool will also join two polylines within a specified 
tolerance distance. This is helpful when you’ve converted curves into polylines 
using the Change Object command and later want to join them. Select the Join 
Curve option as you pick the two curves.

1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select 
two curves to connect end points [Ctrl=Join (Windows) or Option=Join (Macin-
tosh), Shift=Extend].

2. If desired, specify a tolerance distance in the Status Line to which the resulting 
curves will fit.

3. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and 
select the two curves.

Any discontinuities between the selected lines are eliminated.

The Status Line contains the Tolerance data field.
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Curve Utility Tools

The Curve Utility tool palette contains tools for offsetting and exploding curves.

Offset Curve Tool

The Offset Curve tool offsets curves by a location or a distance that you specify. 
The curves can be part of a wireframe object, surface edge (Offset to Value tool 
only) or solid edge. Groups cannot be offset. The graphic here is an example of an 
offset solid ege.

You can offset one or more curves and supports the following options.

Automatic trimming for 
curves offset inside-

curves.

Curves offset outside of 
curves with the arc cor-

ners for the offset.

Curves offset outside of 
curves with extended cor-

ners for the offset.
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The Offset Curve tool includes a subpalette with two tools, Offset to Value and 
Offset by Point.

When you offset a Through Point B-spline or Bezier spline an editable vector spline 
results. You can move its control points and change its shape and slope. In some 
situations offsetting a curve results in a spline. This spline is also an editable vector 
spline.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when using this tool.

Offset to Value Tool

This tool creates an offset curve at a specified distance from the original curve, sur-
face edge or solid edge. When offsetting surface edges you also have the option of 
placing the offset on the surface. You can offset one curve or edge or connected 
curves or edges.

Using the Offset to Value Tool - One Curve, Surface Edge or Solid Edge
1. Select the Offset Curve tool.

2. Select the Offset to Value tool in the Message Line. The Message Line reads: 
Offset Curve: Pick curves to offset distance [Ctrl=Extend Corner (Windows) or 
Option=Extend Corner (Macintosh), Shift=Extend].

3. Enter an offset distance in the Offset data field of the Status Line.

4. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter 
offset direction. 

If you select a surface edge, the Off-
set dialog box appears asking if you 
want the offset to lie on the surface.

Click Yes to place the offset on sur-
face. Click No and proceed with the 
next step.

5. Pick a point on either side of the 
curve or edge to specify the offset 
20-13



General Editing Tools

20-14
direction. The offset direction must be parallel to the curve or edge. Our 
Designer Elements program offsets the curve by the distance set in the data 
field.

While the offset curve is selected you may enter a new offset distance in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the Offset distance.

Using the Offset to Value Tool - Connect Curves or Solid Edges
For connected curves or edges you have multiple offset options: extending exterior 
offsets so they connect with an arc intersection, extending exterior offsets with a 
corner intersection or trimming intersecting offsets for interior offsets.

1. Select the Offset Curve tool.

2. Select the Offset to Value tool in the Message Line. The Message Line reads: 
Offset Curve: Pick curves to offset distance [Ctrl=Extend Corner (Windows) or 
Option=Extend Corner (Macintosh), Shift=Extend].

3. Enter an offset distance in the Offset data field of the Status Line.

4. Select the curves or edges to offset. The Message Line reads: Offset Curve: Enter 
offset direction.

5. Select the type of offset you desire.

Exterior Offset - Arc intersection: Pick a point on the outside of the curves or 
edges.

Exterior Offset - Corner intersection: Hold down the CTRL key (Windows) or the 
OPTION key (Macintosh) and pick a point on the outside of the curves or edges.

Interior Offset: Pick a point on the inside of the curves or edges.

Our Designer Elements program offsets the curves or edges by the distance set in 
the Status Line data field.

While the offset curves are selected you may enter a new offset distance in the Sta-
tus Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the Offset distance.
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Offset by Point Tool

This tool creates an offset at the point specified. You can offset one curve or solid 
edge or connected curves or solid edges.

Using the Offset by Point Tool - One Curve or Solid Edge
1. Select the Offset Curve tool.

2. Select the Offset by Point tool in the Message Line. The Message Line reads: 
Offset Curve: Pick curves to point [Ctrl=Extend Arc (Windows) or Option=Extend 
Arc (Macintosh), Shift=Extend].

3. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter 
offset point.

4. Pick the desired point for the offset. Our Designer Elements program offsets the 
curve to that point. The offset value is displayed in the Offset data field in the 
Status Line.

While the offset curve is selected you may enter a new offset distance in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the offset distance.

Using the Offset by Point Tool - Connected Curves or Solid Edges
1. Select the Offset Curve tool.

2. Select the Offset by Point tool in the Message Line. The Message Line reads: 
Offset Curve: Pick curves to point [Ctrl=Extend Arc (Windows) or Option=Extend 
Arc (Macintosh), Shift=Extend].

3. Select the curves to offset. The Message Line reads: Offset Curve: Enter offset 
point.

4. Select the type of offset you desire.

Exterior Offset - Arc intersection: Pick a point on the outside of the curves.

Exterior Offset - Corner intersection: Hold down the CTRL key (Windows) or the 
OPTION key (Macintosh) and pick a point on the outside of the curves.

Interior Offset: Pick a point on the inside of the curves.

Our Designer Elements program offsets the curves at that point. The offset value 
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Tip:

To extrude an object you 
must click to define the 
extrusion rather than drag.

To extrude a curve at an 
angle not normal to the 
curve, change the view. 
Example: Create a rectangle 
in the top plane. Change the 
plane to the front plane and 
place the extrude points to 
define an angle and length.
is displayed in the Offset data field in the Status Line.

5. Pick the desired point for the offset. Our Designer Elements program offsets the 
curve to that point. The offset value is displayed in the Offset data field in the 
Status Line.

While the offset curves are selected you may enter a new offset distance in the Sta-
tus Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the offset distance.

Extrude Curve Tool

This tool copies a curve at a distance and in the direction 
that you specify. It connects its endpoints by two lines back 
to the original curve. In the graphic to the right the lower 
curve is extruded to form the polygon.

Using the Extrude Curve Tool

1. Click the Extrude Curve tool. The Message Line reads: Extrude Curve: Pick 

curves to extrude [Shift=Extend].

2. Select the curve(s) to extrude. The Message Line reads: Extrude Curve: Specify 
two points for extrusion direction.

3. Click two points to indicate where the new extruded curve will be placed. The 
direction of the extrusion is specified by the order in which you pick the points. 
This Designer Elements program applies the distance and direction you specify.

While the object is selected you can change the extrusion distance in the Status 
Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the extrusion’s dX, dY and dZ values and the Distance.
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Tech Note:

You cannot revolve a Smart 
Polygon. It must first be con-
verted into single lines using 
the Change Object Type 
command. See Chapter 12 
for more information on 
polygon types.

To define the axis of revolu-
tion you must click the points 
rather than drag.
Revolve Curve Tool

This tool revolves a curve around an axis.

Using the Revolve Curve Tool
1. Select the Revolve Curve tool. The Message Line reads: Revolve Curve: Pick 

curves to revolve [Shift=Extend].

2. Select the curve(s) to revolve. The Message Line reads: Revolve Curve: Specify 
revolution origin.

3. Click a point about which to revolve the curve. The Message Line reads: 
Revolve Curve: Specify revolution axis. 

4. Click two points to indicate the axis of revolution. The direction of the revolu-
tion is specified by the order you pick the points. This Designer Elements pro-
gram rotates the curve about the axis by the number of steps and through the 
angle set in the data fields on the status line.

While the object is still selected you can change the number of steps and the angle 
of revolution in the Status Line. Press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the number of steps and the angle of revolution.

Project Curve Tool

The Project Curve tool projects 3D curves, including solid edges onto a 2D plane. 
Arcs, circles and ellipses maintain their precise shape when you project them nor-
mal to their definition. If you project them otherwise a spline is used with a default 
curve tolerance of 0.001 inches. This spline is an editable vector spline.

When you project a Through Point B-spline or Bezier spline an editable vector 
spline results. You can move its control points and change its shape and slope. In 
some situations projecting a curve results in a spline.
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The select curves are created on the plane 
and replace the original curves the curves 
unless the CTRL key (Windows) or OPTION 
key (Macintosh) is held down. The graphic 
here shows a model projected to XY, XZ and 
YZ planes.

The left graphic below shows a model with 
four solid edges selected (displayed in 
black). The right graphic shows the edges 
projected to the XZ Plane.

Plane Options
The pull-down menu in the Message Line provides five options for choosing the 
plane: XY Plane, XZ Plane, YZ Plane, Work Plane and Pick Infinite Plane.
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The following figures, displayed in the Isometric view, explain the projection 
options. All graphics used for the individual planes are also displayed in the Isomet-
ric view.

XY Plane Choosing this option projects the selected curves 
into the XY plane (Top) where X=0 and Y=0.

XZ Plane Choosing this option projects the selected curves 
into the XZ plane (Front) where X=0 and Z=0.

YZ Plane Choosing this option projects the selected curves 
into the YZ plane (Side) where Y=0 and Z=0.
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Work Plane Choosing this option projects the selected curves 
into the work plane. For this example, the work 
plane was defined using the sloped face of the 
object.

Pick Infinite Plane Choosing this option project the selected curves to 
the specified infinite plane.

Use the Plane commands in the Plane menu to define your own plane. You must 
set the work plane to the desired plane before using this option.

Projection Options
When you project curves this Designer Elements program takes those curves and 
creates new geometry on the specified plane. You have two options, Default and 
Copy (see the Message Line).

Project Curves - Default Option
This option takes the selected geometry. See the 
graphic here. Notice that the selected geometry no 
longer appears on the original part.
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Tech Note:

If you hit ENTER (Windows) 
or RETURN (Macintosh) 
instead of specifying a point, 
the projection is placed at the 
origin.
Project Curves - Copy Option
This option copies the selected geometry. To choose 
this option hold down the CTRL key (Windows) or 
OPTION (Macintosh). See the graphic here.

Projecting & Multiple Curve Selection
After you select the tool you can select multiple lines for projection by holding 
down the SHIFT key and selecting the desired lines, as noted in the Message Line.

You can also select multiple lines or an entire object by dragging 
a selection fence around the entire object. When you project the 
object all curves that are normal to the projection plane are recre-
ated as points in the new curve. The graphic here shows a YZ 
projection. The cross hairs represent the points.

Important: (Windows users) Because the CTRL and SHIFT keys 
are programmed to perform specific operations for this tool, the 
Stroke Zoom function (CTRL+SHIFT keys) is not available when 
projecting curves with this tool.

Using the Project Curve Tool
1. Select the Project Curve tool. The Message Line reads: Project Curve: Pick 

curves to project [Ctrl=Copy (Windows) or Option=Copy (Macintosh), 
Shift=Extend].

2. From the pull-down menu in the Status Line choose the projection plane.

3. Select the curves to project. Hold down the SHIFT key or drag a selection fence 
to select multiple lines. The Message Line now reads, Project Curve: Specify 
point in projection plane [Ctrl=Copy (Windows) or Option=Copy (Macintosh)].

4. Pick the point on the projection plane where the curves should be projected. 
The selected lines are replaced with lines projected on the selected plane.

To project a copy of the lines hold down the CTRL key (Windows) or OPTION 
key (Macintosh) before selecting the point.
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There are no Status Line entries.

Explode Edge Tool

This tool enables you to create a curve from a surface 
or solid edge. For surfaces and solids, you can also 
explode Iso lines when displayed on your geometry. 
This ability is useful when constructing geometry off 
an object.

When you explode a solid edge, solid Iso line, surface edge or surface Iso line the 
new curve is placed on the work layer and assumes its color characteristic. If the 
layer has no specific color characteristic, the curve displays in the color selected in 
the Pen menu. If the exploded edge or Iso line results in a spline, a vector spline 
results. You can move its control points and change its shape and slope.

Using the Explode Edge Tool
1. Select the Explode Edge tool. The Message 

Line reads: Explode Edge: Pick edges to explode 
[Shift=Extend].

2. Select the surface or solid edge or Iso line from which you want to create a 
curve.

The curve is created at the same location as the selected edge.

There are no entries in the Status Line.



Surface Editing Tools and Features

Our Designer Elements program provides several editing tools in the Surface Edit-
ing tool palettes. The tools allow you to perform such operations as intersecting 
existing surfaces and solids with other entities, projecting curves onto surfaces, add-
ing to or subtracting from and intersecting 2D planar surfaces as well as joining or 
trimming surfaces and matching surfaces. Our Designer Elements program also 
includes features for reshaping surfaces through control vertex modification.

The following topics are covered in this chapter:

• Solid Editing tools

• Surface Control Vertex Modification

• Surface Evaluation

Solid Editing Tools
Many of the editing tools require a two step process for their usage. The first step 
after choosing the tool may be to select one or more objects. The second step per-
forms the editing operation. Once you the complete the first step you cannot select 
more objects to include in the same operation. To select additional objects reset the 
tool and start again.

Note: These tools do not support the use of grouped objects.
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Tip:

When the Auto Layers option 
is used with the Increment 
Layer command (ALT+0 - 
Windows, z +0 - Macin-
tosh) and Decrement Layer 
(ALT+9-Windows, z +9-
Macintosh), to change layers, 
you have a convenient way of 
examining every 2D cut of a 
3D model.
The geometric characteristics listed in the Edit Objects dialog box after editing an 
object using these tools are the same as the object's standard characteristics. For 
example, if a curve/surface intersection is performed, the Edit Objects dialog would 
display characteristics of the resulting curve.

Selecting Objects within the Editing Tools
With these editing tools you are asked to select the objects for performing an 
operation. When you select the tool and move the cursor into the drawing 
area it becomes a hollow selection arrow (shown here).

When you finish selecting the pointer becomes a general tool pointer 
(shown here.)

This hollow selection arrow must not be confused with the Selection tool.

Plane/Surface Intersection Tool

The Plane/Surface Intersection tool calculates the intersection of an infinite plane 
with a curve, surface or solid. The resulting cut is automatically associative with the 
plane and the object so that if you modify either entity, the cut will update 
(Cobalt™ and Xenon™ only).

Auto Layers Option
This tool provides an Auto Layer option in the Message Line. When this option is 
enabled, our Designer Elements program puts each section cut on a separate layer 
and names the layer according to the location of the cut. For example, the graphics 
here show a solid block with three intersecting planes.
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With the Auto Layers option enabled each 
section is placed on a separate layer. The 
Layer Manager graphic below shows the 
new layers.

Important: (Windows users) Because the 
CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, 
the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when using this tool.

Intersecting a Plane with a Curve
When you intersect a plane with a curve a 
point intersection results. The left graphic 
here shows a plane and three curves. The 
right graphic displays the intersection points for the plane and the curves.

1. Select the tool in the tool palette. The Message Line reads: Plane/Sur-
face Intersection: Pick the planes to slice objects with [Shift+Extend].

2. Click the plane you want to use to intersect the curve. Hold down the 
SHIFT key to pick more than one plane. The Message Line reads: 
Plane/Surface Intersection: Pick objects to intersect with plane 
[Shift=Extend].

3. Click the curves that you want to intersect with the plane.

The intersection point displays. The point is associative to the plane and curve. 
Modifying either the plane or the curve automatically updates the location of 
the point.

There are no entries in the Status Line.
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Intersecting a Plane with a Surface
When you intersect a plane with a surface a curve intersection results. If the curve 
is a spline, it is a vector spline capable of being edited.

1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Inter-
section: Pick planes to slice objects with [Shift=Extend].

2. Click the plane you want to use to intersect the surface. Hold down the SHIFT 
key to pick more than one plane. The Message Line reads: Plane/Surface Inter-
section: Pick objects to intersect with plane [Shift=Extend].

3. Click the surface that you want to intersect with the plane.

The intersection curve displays. The curve is associative to the plane and sur-
face. Modifying either the plane or the surface automatically updates the loca-
tion of the curve (Cobalt™ and Xenon™ only).

There are no entries in the Status Line.

Intersecting a Plane with a Solid
When you intersect a plane with a solid a curve intersection results. If the curve is a 
spline, it is a vector spline capable of being edited.

1. Click the tool in the tool palette. The Message Line reads: Plane/Surface Inter-
section: Pick planes to slice objects with [Shift=Extend].
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2. Click the plane you want to use to intersect the solid. Hold down the SHIFT 
key to pick more than one plane. The Message Line reads: Plane/Surface Inter-
section: Pick objects to intersect with plane [Shift=Extend].

3. Click the solid that you want to intersect with the plane.

The intersection curve displays. The curve is associative to the plane and solid. 
Modifying either the plane or the solid automatically updates the location of the 
curve (Cobalt™ and Xenon™ only).

There are no entries in the Status Line.

Curve/Surface Projection Tool

The Curve/Surface Projection tool projects a curve along a direction vector onto a 
surface or a solid. You specify the direction vector by clicking two points. The new 
curve is associative to the object. When you modify the object the projected curve 
will automatically update (Cobalt™ and Xenon™ only).

Projecting a Curve to a Surface
With this tool you can project a curve onto a surface. If the curve is a spline, it is a 
vector spline capable of being edited.

1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Pro-
jection: Pick curves to project onto surface [Shift=Extend].

2. Click the curve to project onto the surface (it does not highlight). Hold down 
the SHIFT key to pick more than one curve. The Message Line reads: Curve/
Surface Projection: Pick ONE surface or solid for curve projections 
[Shift=Extend].

3. Click the surface or solid onto which you want to project the curve.

4. Enter 2 points for the projection vector as directed by the Message Line.

The curve projects onto the surface.
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There are no entries in the Status Line.

Projecting a Curve to a Solid
With this tool you can project a curve onto a solid. If the curve is a spline, it is a 
vector spline capable of being edited.

1. Click the tool in the tool palette. The Message Line reads: Curve/Surface Projec-
tion: Pick curves to project onto surface [Shift=Extend].

2. Click the curve to project onto the solid (it does not highlight). Hold down the 
SHIFT key to pick more than one curve. The Message Line reads: Curve/Surface 
Projection: Pick ONE surface or solid for curve projections [Shift=Extend].

3. Click the solid onto which you want to project the curve.

4. Enter 2 points for the projection vector as directed by the Message Line.

The curve projects onto the solid.

There are no entries in the Status Line.

Surface/Surface Intersection Tool

The Surface/Surface Intersection tool calculates the intersection of two existing 
surfaces or a surface and a solid. Select the two objects and the tool creates one or 
more curves. The curves are associative with both objects (Cobalt™ and Xenon™ 
only). When you change either object the intersection curve will update. To 
remove the associative link, use Edit>Remove Links.
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Intersecting a Surface with a Surface 
Use this tool to intersect two surfaces producing a curve intersection. If the curve is 
a spline, it is a vector spline capable of being edited.

1. Select the tool in the tool palette. The Message Line reads: Surface/Surface 
Intersection: Pick two surfaces or solids for intersection.

2. Click on the two surfaces. An intersection curve displays.

There are no entries in the Status Line.

Intersecting a Surface with a Solid
Use this tool to intersect a surface with a solid.

1. Click the tool in the tool palette. The Message Line reads: Surface/Surface Inter-
section: Pick two surfaces or solids for intersection [Shift=Extend].

2. Click the two surfaces. An intersection curve displays.

There are no entries in the Status Line.

Curve/Surface Intersection Tool

The Curve/Surface Intersection tool calculates the intersection of a curve and a 
surface or solid. The tool creates a collection of point objects. The points are asso-
ciative to both the curve and object (Cobalt™ and Xenon™ only).
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Intersecting a Curve with a Surface
You can intersect a curve with a surface with this tool.

1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Inter-
section: Select curves to intersect surface/solids [Shift=Extend].

2. Click the curve to intersect the surface. Hold down the SHIFT key to pick more 
than one curve. The Message Line reads: Curve/Surface Intersection: Select sur-
faces or solids to intersect with curve [Shift=Extend].

3. Click the surface to intersect with the curve. The intersection points display.

There are no entries in the Status Line.

Intersecting a Curve with a Solid
You can intersect a curve with a solid with this tool.

1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Inter-
section: Select curves to intersect surface/solids [Shift=Extend].

2. Click the curve to intersect the solid. Hold down the SHIFT key to pick more 
than one curve. The Message Line reads: Curve/Surface Intersection: Select sur-
faces or solids to intersect with curve [Shift=Extend].

3. Click the solid to intersect with the curve. The intersection points display.

There are no entries in the Status Line.
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Tip:

If you want to get volume, 
density and other properties 
of geometry in your drawing, 
you can combine them with 
this tool whether or not they 
are connected.
Boolean Surface Tools

Our Designer Elements program supports 2D boolean operations on planar surfaces 
created with the cover surface command. With the Boolean Surface tool you can 
add surfaces together, subtract surfaces from one another, and find the intersection 
of two or more surfaces. You can use the new curves created from boolean opera-
tions for 2D property analysis or as profiles for solid extrusions, sweeps and lathe 
operations.

You have three tools for performing boolean operations: 
Add Boolean Surface, Subtract Boolean Surface and 
Intersect Boolean Surface.

For the purposes of explaining these tools the objects to 
the right are used.

Add Boolean Surface Tool

With this tool you add two objects to create a third object.

1. Select the Boolean Surface tool.

2. Select the Add Boolean Surface tool in the Message Line. The Message Line 
reads: Boolean Surface: Pick planar surface to add to [Shift=Extend].

3. Select the surface to which you will add another. The Message Line reads: Bool-
ean Surface: Pick planar surface to add [Shift=Extend].

4. Select the surface to be added.

There are no entries in the Status Line.

Subtract Boolean Surface Tool

With this tool you subtract one surface from another.

1. Select the Boolean Surface tool.
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2. Select the Subtract Boolean Surface tool in the Message Line. The Message 
Line reads: Boolean Surface: Pick planar surface to subtract from 
[Shift=Extend].

3. Select the surface from which you will subtract another. The Message Line 
reads: Boolean Surface: Pick planar surface to subtract [Shift=Extend].

4. Select the surface to be subtracted. One surface is subtracted from the other.

There are no entries in the Status Line.

Intersect Boolean Surfaces Tool

With this tool you retain the intersecting portion of two sur-
faces.

1. Select the Boolean Surface tool.

2. Select the Intersect Boolean Surface tool in the Message Line. The Message 
Line reads: Boolean Surface: Pick planar surface to intersect with [Shift=Extend].

3. Select the surface with which you will intersect another. The Message Line 
reads: Boolean Surface: Pick planar surface to intersect [Shift=Extend].

4. Select the surface to be intersected. The intersecting portion of the surfaces is 
displayed.

There are no entries in the Status Line.

Connect Surface Tool

The Connect Surface tool merges two surfaces into one. The resulting surface 
retains the original surfaces mathematical definitions, but a selection operation 
treats both surfaces as one. Unlike the Add Boolean Surface tool the Connect Sur-
face tool can be used with non-planar surfaces. The left graphic below displays two 
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separate but connecting surfaces. The graphic on the right displays one surface that 
retains the characteristics of the individual surfaces.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when using this tool.

Using the Connect Surface Tool
1. Click the Connect Surface tool in the tool palette. The Message Line reads: 

Connect Surface: Pick two surfaces to connect [Shift=Extend].

2. Click the two surfaces that you want to connect. The surfaces become one sur-
face but retain their individual mathematical definitions.

There are no entries in the Status Line.

Split Surface Tool

Use the Split Surface tool to cut away portions of a surface. You can trim a surface 
to another surface, curve or solid. Unlike the Subtract Boolean Surface tool the 
Split Surface tool can be used with non-planar surfaces.

Using the Tool to Split a Surface with a Surface
You can use this tool to trim a surface to a surface.
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Tech Note:

The Split Surface Tool 
will not work with 
grouped surfaces.
1. Select the Split Surface tool in the tool palette. The Message Line reads: Split 
Surface: Pick surface to split [Shift=Extend].

2. Select the surface that you want to split. The Message Line reads: Split Surface: 
Pick curves, surface, or solid to split with [Shift=Extend].

3. Select the entity that defines the trim area. Our Designer Elements program 
splits the surface at the intersection of the two entities. Your objects won't 
appear differently on your screen. Delete any portions that you don't need.

There are no entries in the Status Line.

Using the Tool to Split the Surface to a Curve
You can use this tool to trim a surface to a curve.

1. Select the Split Surface tool in the tool palette. The Message Line reads: Split 
Surface: Pick surface to split [Shift=Extend].

2. Select the surface that you want to trim. The Message Line reads: Split Surface: 
Pick curves, surface, or solid to split with [Shift=Extend].

3. Select the entity that defines the trim area. Our Designer Elements program 
splits the surface at the intersection of the surface and curve. Your objects won't 
appear differently on your screen. Delete any portions that you don't need.

There are no entries in the Status Line.

Using the Tool to Split a Surface with a Solid
You can use this tool to split a surface to a solid.
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1. Select the Split Surface tool in the tool palette. The Message Line reads: Split 
Surface: Pick surface to split [Shift=Extend].

2. Select the surface that you want to split. The Message Line reads: Split Surface: 
Pick curves, surface, or solid to split with [Shift=Extend].

3. Select the entity that defines the split area. Our Designer Elements program 
splits the surface at the intersection of the surface and the solid. Your objects 
won't appear differently on your screen. Delete any portions that you don't 
need.

There are no entries in the Status Line.

Silhouette Curves Tool

The Silhouette Curves tool creates curves from the bounding edge of an object 
relative to a user-defined projection direction. The curves produced by this tool are, 
in most cases, non-planar. This tool is usefule for producing injection mold draw-
ings.

Using the Silhouette Curves Tool
1. Select the Silhouette Curves tool, The Message Line reads: Silhouette Curves: 

Pick surface/solids for silhouettes. [Shift = Extend]

2. Select the objects on which you want silhouette curves. The message line now 
reads, Silhouette Curves: Specify two points for view direction.

The example below shows the progression of use with the Silhouette Curves tool.
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Local Surface Tools

Match Surface Tool

This tool gives you the ability to impose a smooth transition from one surface to 
another neighboring surface. It also allows you perform greater surface manipula-
tion by inserting a knot and elevating the degree of the surface.

There are five options available for this tool: 
Match G1 Slope, Match G2 Slope, Insert Knot, 
Elevate Degree and Untrim Surface. These 
tools are accessed through the pull-down 
menu in the Message Line.

Rules and Notations for using the Match Surface Tool and Options
• Surfaces can not be trimmed surfaces. (Any surface that has had a relimit or 

another editing operation conducted on it is a trimmed surface.) If you want to 
match untrimmed surfaces, you must first untrim them using the Untrim Surface 
option of this tool before matching them. See a later section about this option.

• Surfaces must share the same edge being within 0.001 inches or 0.0254 mm of 
each other.

• The direction and slope of the surfaces do not matter.

• Matching two surfaces with the G1 Slope or G2 Slope options adjusts the slope of 
the first surface to that of the second. To reduce the influence of the matched 
slope on the surface, elevate its degree using the Elevate Degree option of this 
tool before matching the surfaces. See a later section about this option.

Match G1 Slope Option
Use this option to match two untrimmed surfaces with G1 continuity. G1 matched 
surfaces are tangent continuous at their shared edge. The graphics on the left below 
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Tech Note:

G1 stands for geometric 
continuity matched to the 
first derivative, tangency. G1 
matched surfaces are tangent 
continuous.
are the two original surfaces. The graphics on the right below are the same surfaces 

using the G1 Slope option.

Using the G1 Slope Surface Option
1. Select the Match Surface tool.

2. From the pull-down menu in the Message Line, select Match G1 Slope. The Mes-
sage Line reads: Match Surface: Pick surface edge to modify tangency.

3. Click on the edge of the surface you want to modify.

Be sure to click on the edge and not somewhere on the body of the surface. 
The entire surface highlights. The Message Line now reads, Match Surface: Pick 
surface edge to match.

4. Click on the surface edge to which you are matching the first surface.

The slope of the first surface edge now matches the second surface edge with a 
G1 continuity. You can verify this continuity by using the surface evaluation 
feature. In a surface evaluation plot, stripes represent the slope of the surface.
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Tech Note:

G2 stands for geometric 
continuity matched to the 
first and second derivative 
tangency and curvature con-
tinuous. G1 matched surfaces 
are tangent and curvature 
continuous.
These stripes line up from the first surface to the second surface for G1 contin-
uous surfaces.

See the Surface Evaluation section at the end of this chapter for information.

There are no entries in the Status Line.

Match G2 Slope Option
Use this option to match two untrimmed surfaces with G2 continuity. G2 matched 
surfaces are tangent and curvature continuous at their shared edge. The graphics on 
the left below are the two original surfaces. The graphics on the right below are the 
same surfaces using the G2 Slope option. 

Using the G2 Slope Surface Option
1. Select the Match Surface tool.

2. From the pull-down menu in the Message Line, select Match G2 Slope. The Mes-
sage Line reads: Match Surface: Pick surface edge to modify tangency.

3. Click on the edge of the surface you want to modify.

Be sure to click on the edge and not somewhere on the body of the surface. 
The entire surface highlights. The Message Line now reads, Match Surface: Pick 
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surface edge to match.

4. Click on the surface edge to which you are matching the first surface.

The slope of the first surface edge now matches the second surface edge with a 
G2 continuity. You can verify this continuity by using the surface evaluation 
feature. In a surface evaluation plot, stripes represent the slope of the surface. 
These stripes line up from the first surface to the second surface for G2 contin-
uous surfaces.

See the Surface Evaluation section at the end of this chapter for information.

There are no entries in the Status Line.

Rebuild Surface Tool

The Rebuild Surface tool reconstructs an approximating surface to the surface to 
rebuild.  The tightest tolerance achieved is displayed in a dialog box.  If the toler-
ance achieved is not tight enough use undo to put the surface back in its orginal 
condition.

The Rebuild Surface tool is useful for 
converting analytics to cubic NURBs, 
trimmed surfaces to untrimmed sur-
faces, and repairing surfaces.  The 
rebuild tool is limited to surfaces 
with 3 or 4 sides.

Using the Rebuild Surface Tool
1. Select the Rebuild surface tool.  

The Message Line reads: Rebulid 
Surface:Pick surface to rebuild.

2. Click the surface to rebuild.

There are no status line entries for this command.
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Untrim Surface Tool

Using this option removes all trim boundaries on a surface face type surface. The 
left graphic below shows a trimmed surface. The right graphic shows the surface 
after this option is used.

Using the Untrim Surface Option
1. Select the Untrim Surface tool.

2. From the pull-down menu in the Message Line, select Untrim Surface. The Mes-
sage Line reads: Untrim Surface: Pick surface to untrim.

The surface untrims.

There are no entries in the Status Line.

Elevate Surface Tool

This option elevates the degree of a surface introducing more control points. These 
control points can be used to modify the surface.

NURB surfaces are defined by polynomial equations. The most basic equation pos-
sible is used to define the surface. Where cylindrical and spherical shapes are 
defined by second degree polynomials, skin, cover and net surfaces are defined by 
third degree polynomials due to their complexity. Shapes defined by higher degree 
polynomicals have more control points than those defined by lesser degree polyno-
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mials. This option raises the degree level for a shape providing more control points 
for surface manipulation.

Surfaces can be elevated up to the 22nd degree. However, it is recommended that 
you never elevate a curve higher than 9 degrees. Degree elevation is useful when 
trying to match surfaces and minimize the effect of the match on the surface.

Using the Elevate Surface Tool
1. Select the surface to which you want to add control points.

2. Choose Window>Edit Objects to verify that the surface is a surface face.

If your surface is a surface face continue with step 5.

3. Choose Edit>Change Object Type.

4. Select the Surface option and click OK.

If the surface you selected is 
linked to another object, the 
following warning box appears.

Click Yes to continue conver-
sion.

5. Choose Edit>Show Points to 
display the surface control 
points.

6. Select the Elevate Surface tool. 
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7. From the pull-down menu in the Message Line select: Elevate Degree. The Mes-
sage Line reads: Elevate Surface: Pick surface to elevate.

8. Select the surface.

The surface elevates to the next degree.

There are no entries in the Status Line.

Insert Knot Tool

This tool allows you to add a row or column of control points to a surface. The sur-
face must be untrimmed and the surface face type. Net, skin and cover surfaces 
must be converted into the surface face type using the Change Object Type com-
mand in the Edit menu. You can verify the surface type by double-clicking on the 
surface to display the Edit Objects dialog box.

Knot insertion is valuable when you want to adjust a surface shape at a location 
where there are no control points. Knot insertion is also useful when trying to 
match surfaces and minimize the effect of the match on the surface. The left graphic 
below displays the control points of the original surface. The right graphic shows 
an additional row of control points at the right end of the surface.

After inserting control points using this option, you may notice that other control 
points may have shifted. This is automatically done to preserve the surface shape.

Using the Insert Knot Tool
1. Select the surface to which you want to add control points.

2. Choose Window>Edit Objects to verify that the surface is a surface face.

If it is continue on with step 5.
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3. Choose Edit>Change Object Type.

4. Select the Surface option and click OK.

If the surface you selected is 
linked to another object, the 
following warning box appears.

Click Yes to continue conver-
sion.

5. Choose Edit>Show Points to 
display the surface control 
points.

6. Select the Insert Knot tool.

7. From the pull-down menu in the Message Line select Insert Knot. The Message 
Line reads: Insert Knot: Pick surface to insert a new knot.

8. Select the surface. The Message Line now reads: Insert Knot: Specify location for 
new knot.

9. Select a location along an edge of the surface for the new row or column of 
knots.

A new series of knots are added. If you want to add another row or column of 
knots you must select the surface again.

There are no entries in the Status Line.

Surface Control Vertex Modification
Our Designer Elements program supports the ability to manipulate the control 
points for all surface face type NURB surfaces. All other surfaces like net, skin and 
cover, must be converted into the surface face type using the Change Object Type 
command. Remember that using the Change Object Type command removes all 
links from the surface.

After showing points on the selected surface you can select any point and move it 
to a new location. With this ability you can create such things as creases and other 
surface variations. If surface smoothness is a concern, be sure to use the surface 
evaluation plot available through the Verify menu or the advanced rendering fea-
tures. See the next section. 
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The left graphic below shows a sphere converted into a surface and displaying its 
control points. The right graphic shows the surface after control point modification 
creating a heart shape.

Performing a Control Vertex Modification
1. Select the surface you want to modify.

2. Choose Window>Edit Objects to verify that the surface is a surface face.

If it is continue on with step 5.

3. Choose Edit>Change Object Type.

4. Select the Surface option and click OK.

If the surface you selected is 
linked to another object the fol-
lowing warning box appears:

Click Yes to continue conver-
sion.

5. Choose Edit>Show Points to 
display the surface control 
points.

6. Using the Selection tool, drag 
the control points as desired.

Surface Evaluation
Our Designer Elements program gives you the ability to evaluate the smoothness of 
your surfaces. This is useful for identifying surface irregularities. The curvature eval-
uation is accomplished by placing your surface inside a brightly lit imaginary cylin-
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Refferal Note:

This section is duplicated in 
the Verify Menu section of 
Chapter 24.
der with longitudinal stripes. The cylinder stripes are reflected onto the surface to 
convey the surface smoothness. This can especially important when you match sur-
faces using this Match Surface tool. The graphics here show the surface evaluation 
for two matched surfaces using no surface matching (G0), G1 and G2 surface 
matching. 

Notice how the bands of black differ from graphic to graphic. In the G0 Matched 
Surfaces graphic (no surface match), the right surface bands are parallel. In the G1 
Matched Surfaces graphic, the right surface bands are not as parallel showing that 
the surface was adjusted to match the left surface. In the G2 Matched Surface 
graphic, the right surface bands show how the surface has even further adjusted to 
match the left surface.

You can evaluate your surfaces either through the Verify menu using the Surface 
Analysis commands or through the advanced rendering feature.

Evaluation Through the Verify Menu
The Surface Analysis commands allow you to quickly evaluate the smoothness of 
one or more surfaces. All analysis colors are preset with these commands. If you 
would like to define your own settings use the surface evaluation shader through 
the Advanced Rendering feature. See “Evaluation Through the Advanced Rendering 
Feature” on page 34.

G0 Matched Surfaces G1 Matched Surfaces G2 Matched Surfaces
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You have four surface analysis commands, 
Curvature, Draft Angle, Normals and 
Zebra. When you choose Verify>Surface 
Analysis, a submenu appears containing 
the commands.

Curvature Command

This command creates a curvature plot of your surface. When 
you select the command the Curvature Plot dialog box appears 
containing: Analysis Styles, Histogram, Color Spectrum and 
Histogram Data Fields.

The dialog box contains the following elements:

Plot Style This section contains the 
styles for the analysis and 
include: Gaussian, Mean, Min 
Radius and Max Radius. A 
description and illustration of 
each style is provided in the 
next section.

Histogram Located to the left of the color 
spectrum in the dialog box 
these horizontal bars repre-
sent the frequency of a curvature smoothness 
(change in a curve over the change in curvature) 
using the color spectrum. The length of the bar 
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represents the frequency. Our Designer Elements 
program calculates this histogram and displays it 
so that the entire graph fits into the dialog box 
area.

Color spectrum bar The section displays the color spectrum used to 
create the histogram.

Histogram data fields The data fields display the maximum and mini-
mum values used to calculate the histogram. When 
you initially select the command, our Designer Ele-
ments program scans the surface(s) and sets the 
min and max fields for curvature. If you enter dif-
ferent values in the fields such that a large number 
of curvature values fall outside of the specified 
range, a red line appears at the end(s) where the 
values fall. All values are still calculated even 
though they are not displayed due to the specified 
range. In the graphic here the large number of val-
ues fall outside the maximum value of 0.006.

If you make changes to the values our Designer 
Elements program waits for two seconds of non-
action before recalculating the histogram, giving 
you time to change the values before the image is 
rendered again.
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You can return to the range initially displayed by 
clicking on the selected option again. (The option 
does not deselect when you do this.) Windows 
users can also reset the maximum and minimum 
values by right mouse clicking near the respective 
end of the spectrum.

Plot Styles
You have four curvature plot styles to choose from when you select the Curvature 
command: Gaussian, Mean, Min Radius and Max Radius.

Gaussian
Selecting this option creates a Gaussian curvature plot on your selected surface. 
The plot registers the change in a curve over the change in curvature. Mathemati-
cally, the Gaussian value is the product of the kmin (minimum radius curvature) 
and kmax (maximum radius curvature) of each vertex. (The letter “k” refers to the 
curvature.) Any sharp change in color represents a discontinuity.

Mean
Selecting this option creates a mean curvature plot. Mathematically, the mean value 
is the average of the kmin (minimum radius curvature) and kmax (maximum radius 



Surface Evaluation
curvature) of each vertex. (The letter “k” refers to the curvature.) The graphic here 
is an example.

Min Radius
Selecting this option creates minimum radius curvature plot. Mathematically, the 
plot is the kmin values (minimum radius curvature) of each vertex. (The letter “k” 
refers to the curvature.) The graphic here is an example. 
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Max Radius
Selecting this option creates maximum radius curvature plot. Mathematically, the 
plot is the kmax value (maximum radius curvature) of each vertex. (The letter “k” 
refers to the curvature.) The graphic here is an example. 

Using a Curvature Surface Analysis Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Curvature.

The dialog box displays with the analysis. Your geometry also displays the anal-
ysis.

3. Select a Plot style, if the desired style is not already selected.

A new curvature analysis appears.
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4. To display a certain analysis/color area, place the pointer at the location over 
the color spectrum and click the mouse. 

Notice that a triangular indicator appears at the selected location and the related 
color highlights in the histogram. The same color highlights in black on your 
surface.

5. To remove the triangular indicator click in the dialog box outside of the color 
spectrum bar.

6. Change the histogram values in the data fields and the histogram and analysis 
automatically recalculates.
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Draft Angle
This command evaluates the drafts of an object for molding 
purposes. When you select this command the Draft Angle dia-
log box appears with the draft angle analysis containing the 
histogram with the analysis, the color spectrum and histogram 
data fields.

The dialog box contains the following elements:

Histogram Located to the left of the 
color spectrum in the dialog 
box these horizontal bars rep-
resent the frequency of a 
draft angle using the color 
spectrum. The length of the 
bar represents the frequency.

Our Designer Elements pro-
gram calculates this histogram 
and displays it so that the 
entire graph fits into the dialog box area.

Color spectrum bar The section displays the color spectrum used to 
create the histogram.

Histogram data fields The data fields display the maximum and mini-
mum values used to calculate the histogram. When 
you initially select the command our Designer Ele-
ments program scans the surface(s) and sets the 
min and max fields for the draft angle analysis.

If you enter different values in the fields such that 
a large number of values fall outside of the speci-
fied range a red line appears at the end(s) where 
the values fall. All values are still calculated even 
though they are not displayed due to the specified 
range.

If you make changes to the values our Designer 
Elements program waits for two seconds of non-
action before recalculating the histogram, giving 
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you time to change the values before the image is 
rendered again.

You can return to the range initially displayed by 
clicking on the selected option again. (The option 
does not deselect when you do this.) Windows 
users can also reset the maximum and minimum 
values by right mouse clicking near the respective 
end of the spectrum.

The graphic here is an example of a draft angle analysis.

Using the Draft Angle Command

1. Select the object.

2. Choose Verify>Surface Analysis>Draft Angle.

The dialog box displays with the analysis. Your geometry also displays the anal-
ysis.

3. To display a certain analysis/color area place the pointer at the location over 
the color spectrum and click the mouse. 

A triangular indicator appears at the selected location and the related color 
highlights in the histogram. The same color highlights in black on your surface.

4. To remove the triangular indicator click in the dialog box outside of the color 
spectrum bar.

5. Change the histogram values in the data fields and the histogram and analysis 
automatically recalculates.

Normals
This command creates a normals plot of your sur-
face. When you select the command the Normal 
Plot Settings dialog box appears.
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The dialog box contains the following elements:

Number of Stripes This data field contains the number stripes that 
appear on your surface.

Stripe Direction This section provides three direction options: X-
Axis, Y-Axis and Z-Axis.

Colors This sections contains the Stripe Color option and 
swatch, Background Color option and swatch; the 
color pull-down menu and RGB data fields and 
sliders.

Stripe Color option: When selected you can set the 
stripe color from the color pull-down menu or the 
RGB fields.

Background Color option: When selected you can 
set the surface background color from the color 
pull-down menu or the RGB fields.

This graphic shows an example of a normal surface analysis.

Using the Normal Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Normals.

The dialog box displays with the analysis. Your geometry also displays the anal-
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ysis.

Zebra
This command creates a zebra plot of your 
surface. When you select the command the 
Zebra Plot Settings dialog box appears.

The dialog box contains the following ele-
ments:

Number of Stripes This data field contains the number stripes that 
appear on your surface.

Stripe Direction This section provides three direction options: X-
Axis, Y-Axis and Z-Axis.

Colors This sections contains the Stripe Color option and 
swatch, Background Color option and swatch, the 
color pull-down menu and RGB data fields and 
sliders.

Stripe Color option: When selected you can set the 
stripe color from the color pull-down menu or the 
RGB fields.

Background Color option: When selected you can 
set the surface background color from the color 
pull-down menu or the RGB fields.
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This graphic shows an example of a zebra surface analysis.

Using the Zebra Command
1. Select the surface.

2. Choose Verify>Surface Analysis>Zebra.

The dialog box displays with the analysis. Your geometry also displays the anal-
ysis.

Evaluation Through the Advanced Rendering Feature
Through the advanced rendering feature you can evaluate your surfaces using user-
defined attributes for the evaluation.

1. Select the surface.

The surface must have a material applied to it.

2. Double-click on the surface to display the Edit Objects dialog box.

3. In the Material page of Edit Objects, click the Advanced button.



Surface Evaluation
4. From the Color class choose the surface evaluation type. The following window 
displays:

base color This attribute sets the base color of the cylinder 
used for the evaluation. This color is reflected onto 
your surface. If your surface color is dark and your 
base color is white, you will not notice much 
change to the surface color when rendered.

band color This attribute sets the band or stripe color for the 
cylinder. This color is also reflected onto your sur-
face. Use a color that is clearly visible to create the 
surface evaluation.

center This attribute sets the center of the evaluation cyl-
inder. Click the desired location in your drawing 
and the numbers automatically enter into the X, Y 
and Z data fields.

axis This attribute specifies the cylinder axis (0 = X 
axis, 1 = Y axis, 2 = Z axis).

radius This attribute sets the cylinder radius.

bands This attribute sets the total number of bands 
around the evaluation cylinder.

coverage This attribute sets the ratio of the area covered by 
the bands to the area not covered (displaying the 
21-35



Surface Editing Tools and Features

21-36
base color). Entering a zero displays only the base 
color. Entering a one displays only the band color.

fuzz This attribute controls the fuzziness of the band (0 
= sharp band edges, 1 = fuzzy band edges).

minimum angle This attributes controls the angle of the normal 
along the cylinder axis that defines the length of 
the cylinder and thus the reflection on the surface. 
Smaller values create longer cylinders.

5. Specify the value for each attribute.

6. Click the Update button to preview your surface evaluation in the preview win-
dow.

If you select the Auto option the preview window automatically updates each 
time you make an attribute change.

7. Click OK to save the changes and close the dialog box.

Close the Edit Objects dialog box if you want a clean screen when you render 
your scene.

8. Render your scene using one of the photorealistic commands in the Render 
menu.

The rendered scene shows your surface evaluation.



Solids Editing Tools - Features

After you've created a solid model from a primitive or a profile, you may use any of the 
feature tools to modify it. You cannot use these tools on grouped objects.

For each tool you can enter values in the Status Line either before or after you create the 
feature. If you enter the values after you select the tool but before you create the feature, 
your first click in the drawing area automatically registers all Status Line values. If you 
enter values after creating the feature and while it is still selected, pressing ENTER (Win-
dows) or RETURN (Macintosh) updates the feature to reflect the new values.

Many of the tools have a two step process to use them. The first step after choosing the 
tool may be to select one or more objects. The second step is to perform the editing opera-
tion. Once you the complete the first step (which may involve holding down the SHIFT 
key to select multiple objects), you cannot select more objects to include in the same oper-
ation. To select additional objects reset the tool and start again.

After adding features to your solid you can modify them by selecting them in the Design 
Explorer and choosing Window>Edit Objects or double-click on their names in the 
Design Explorer (Cobalt™ and Xenon™ only).

All features are associative. Any modifications made to the parent will automatically alter 
all child objects that reference it (Cobalt™ and Xenon™ only).

The topics explained here include:

• Blend tools
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Tech Note:

The Blend tools performs a 
similar operation on solids to 
what the fillet tool performs 
on a wireframe.

In the solids world, blend 
refers to both filleting and 
rounding. A filleting opera-
tion adds material to a con-
cave intersection. A rounding 
operation removes material 
from a convex intersection.
• Chamfer Edge tools

• Hole tools

• Boss Feature

• Shell Object tool

• Bend Solid tool

• Feature Editing tools

Blend Tools

The Blend tools create fillets along the edge of a solid. When you select the Blend tool, a 
subpalette appears in the Message Line containing two tools for creating blends: Constant 
Blend and Variable Blend.

Each of these tools includes a pull-down 
menu containing options for creating that 
type of blend. The graphic shown here is the 
Constant Length Blend tool menu. 

Many of these tool options also have advanced capabilities. These include: Constant 
Radial Blend, Constant Elliptical Blend, Variable Linear Blend, Variable By Position 
Blend, Variable Fixed Width Blend and Variable Hold Line Blend. These capabilities are 
indicated in the Message Line by the notation, [Ctrl = Advanced] (Windows) or [Option = 
Advanced] (Macintosh). When you press the CTRL (Windows) or OPTION (Macintosh) 
key, the Advanced Blend Options dialog box appears.
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The dialog box contains the following options:

Automatic Chain-select Checking this box enables you to blend all edges that 
share a tangent with the selected edges. This is the 
default setting. Without this checked only the selected 
edges blend. The left graphic shows three edges 
blended with the Constant Radial Blend tool with this 
option selected. The right graphic shows two edges 
blended with the Constant Radial Blend tool without 
the option selected.

Feature Interaction (Slower) Checking this box allows you to apply a blend that inter-
sects a cutout or protrusion. Without this checked the fea-
ture may be deleted. With this checked the cutout is taken 
into account. The graphics here illustrate this. The left 
graphic is the original part with a hole cutout to half the 
part’s depth. The middle right graphic is the blended part 
without this option selected. The right graphic is the 
blended part with the option selected.

The same thing occurs with a protrusion as shown 
below. As before, the left graphic is the original part; 

of Shared Edges
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the middle graphic is the part without the option 
selected and the right graphic is the part with the 
option selected.

Using this option results in a longer blending time.

Specify Cross Section Checking this box allows you to specify the orientation 
of the cross-section for the blend. This is especially 
valuable if you are blending an edge between faces 
containing a draft and you want to maintain the arc. 
See the next section for instruction on using this 
option.

If your model contains a problem that prevents a successful blending operation, an ACIS 
Error dialog box appears highlighting the location of the problem.

Specifying a Cross Section Orientation for a Blend
By default, this Designer Elements program uses the selected edge to define the orienta-
tion of the cross-section resulting in an arc shape for the blend. However, when you apply 
a blend to an object with a draft or taper, the cross-section of the resulting blend is ellipti-
cal because the blended edge is not perpendicular to the intersecting faces. If you want to 

Orientation
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maintain the arc shape for the cross-section, use the Specify Cross Section Orientation 
option in the Advanced Blend Options dialog box. 

The graphic below shows a tapered object (tapered on the left and front sides) with a 
cross-section blend on the left and a standard blend on the right. If you hold down the right 
mouse button (Windows) or CONTROL and the mouse button (Macintosh), you can ver-
ify the object shape. (In the case of the cross-section blend an acurve object is listed. Use 
one of the Arc tools to trace the shape and verify that the blend shape is an arc.)

The graphic to the right is a top view of 
a similar shape and provides the mea-
surements for the blends.

Before using this option you must create 
a curve along the z axis for specifying 
the cross-section orientation.

Using the Cross Section Orienta-
tion Option
Although the example here uses the 
Radial option of the Constant Blend tool, this option is also available for Constant Ellipti-
cal Blends, Variable Linear Blends, Variable By Position Blends, Variable Fixed Width 
Blends and Variable Hold Line Blends.

1. Create a curve along the z-axis.

2. Select the Blend tool.
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Tip:

If you are having difficulty 
creating a radial blend, try 
creating a variable linear 
blend using the same radius 
for the beginning and the 
end. ACIS uses a different 
algorithm for linear blends.
3. In the Message Line select the Constant Blend tool and the Radial option for 
the pull-down menu. The Message Line reads: Radial Blend: Pick edges 
AND/OR faces to blend [Ctrl=Advanced (Windows) or Option=Advanced 
(Macintosh), Shift=Extend].

4. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced 
Blend Options dialog box.

5. Select the Specify Cross Section Orientation option and click OK to close the dialog 
box.

6. Select the edge(s) for the blend.

The Message Line now reads, Blend Solid: Pick curve to define cross section orienta-
tion.

7. Select the curve.

The blend is created.

Constant Blend Tool

When you select this tool its option pull-down menu 
appears.

You have three constant blend options: Radial, Elliptical and Vertex Blend.

Important: (Windows users) When a constant blend option uses the CTRL and SHIFT keys 
to perform specific operations for the tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when blending.

Using the Radial Option
This option adds a blend with a constant radius along the edges you select and with a 
radius you specify in the Status Line.

If you select three or more edges you can create a smooth vertex blend or a setback blend. 
A setback is the distance that a blend extends back along the object edge from the vertex 
of the intersecting edges. A spherical corner results at the intersection of the three edges. 
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The left graphic below shows a three edge blend with no setback; the middle graphic 
shows the same object with a setback and the right graphic is a setback illustration.

1. Select the Blend tool.

2. In the Message Line select the Constant Blend tool and the Radial option for the pull-
down menu. The Message Line reads: Radial Blend: Pick edges AND/OR faces to 
blend [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend].

Set the advanced blend options by pressing CTRL (Windows) or OPTION (Macintosh), 
if desired.

3. If you want a setback enter the value in the Status Line data field.

4. Select the edge(s) and/or face(s) for the blend.

While the blend is still selected you can change the radius of the blend in the Status Line. 
Type a new value and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the Radius and Setback for the blend.

Geometric Characteristics
A constant radial blend is created by choosing a solid edge and specifying a radius and set-
back, if desired. It is made up of these characteristics according to Edit Objects: Setback, 
Radius and a list of the edges blended with their radii. 

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

Using the Elliptical Option
This option adds a blend with a constant elliptical radius along the edges, based on the 
radii you specify in the Status Line. When using this option the automatic chain select of 
Shared Edges feature does not function. You must either select all intersecting edges 
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before blending or blend each edge separately. The left graphic below shows a basic ellip-
tical blend. The middle graphic shows an elliptical blend with a mitered edge. The right 
graphic illustrates the radius variables.

1. Select the Blend tool.

2. In the Message Line select the Constant Blend tool and the Elliptical option from the 
pull-down menu. The Message Line reads: Elliptical Blend: Pick edges to blend 
[Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), Shift=Extend].

Set the advanced blend options by pressing CTRL (Windows) or OPTION (Macintosh), 
if desired.

3. Enter a radius values for the ellipse, R1 and R2, in the Status Line data field. R1 is the 
major axis radius and R2 is the minor axis radius.

4. Select the edge(s) for the blend.

While the blend is still selected you can change the radius and elliptical ratio of the blend 
in the Status Line. Type a new value and press ENTER (Windows) or RETURN (Macin-
tosh).

The Status Line contains the Radius and Ratio for the blend.

Geometric Characteristics
A constant elliptical blend is created by choosing a solid edge and specifying a radii for 
the major and minor axis of the ellipse. It is made up of these characteristics according to 
Edit Objects: R1, R2 and a list of the edges blended with their radii. 

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

R1

R2
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Using the Vertex Blend Option
This option adds a vertex blend at the intersection of three or more edges based on the 
radius you specify in the Status Line. The left graphic shows an example of a vertex blend. 
The right graphic illustrates the radius variables.

1. Select the Blend tool.

2. In the Message Line select the Constant Blend tool and the Vertex Blend 
option from the pull-down menu. The Message Line reads: Vertex Fillet: 
Select vertex to blend.

3. Enter a radius in the Status Line data field.

4. Select the vertex for the blend.

While the blend is still selected you can change the radius of the blend in the Status Line. 
Type a new value and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the radius (R) for the blend.

Geometric Characteristics
A constant vertex blend is created by choosing three or more solid edges and specifying a 
radius. It is made up of one characteristic according to Edit Objects: Radius.

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

R

R

22-9



Solids Editing Tools - Features

22-10
Additional Examples
The Constant Blend tool enables you to create a variety of blends. Here are some examples 
of advanced blends and the steps to create them.

Mitered Blend
A mitered blend can be created by turning off the Auto-
matic Chain-select of Shared Edges option in the Advanced 
Blend Options dialog box and selecting each edge individ-
ually. A mitered corner results at the intersection of the 
three edges.

Creating a Mitered Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool and the Radial option from the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges AND/OR faces 
to blend [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), 
Shift=Extend].

3. Press CTRL (Windows) or Option (Macintosh) to display the Advanced Blend 
Options dialog box.

4. Turn off the Automatic Chain-select of Shared Edges option and click OK.

5. Enter the desired radius in the Status Line.

6. Select each of the edges individually to create a mitered intersection. (If you hold 
down the SHIFT key a smooth vertex blend will be created rather than a mitered 
blend.)

If you want a different radius for each edge blend enter the new value in the Radius data 
field before selecting the edge.

A mitered blend is created.

Multi-radius Blend without and with a Setback
A multi-radius blend is created after applying a constant radial blend to an object and then 
changing the radius of each edge through the Edit Objects dialog box. You can also add a 
setback to this blend through Edit Objects or when creating the radial blend initially. The 



Blend Tools
left graphic shows a multi-radius blend. The middle graphic shows the same object with a 
setback. The right graphic shows a multi-radius, multi-edge blend with a setback.

1. Select the object.

2. Choose Window>Design Explorer. 

3. Expand the history tree to display the fillet blend.(Cobalt™ and Xenon™ only)

4. Double-click on the fillet blend to display the Edit Objects dialog box.

5. Select the edge with the radius you want to change. The radius value appears in the 
data field. Enter a new radius.

Change the other radii, if desired.

6. Click Apply to accept the changes and your geometry updates.

Chain Select Shared Edges On/Off Blend
Two different kinds of blends are created depending on whether the Automatic Chain-
select of Shared Edges option in the Advanced Blend Options dialog box is selected.

When this option is selected on edges with different radii, an object blends to create tan-
gent continuous edges. In the left graphic the two edges have the same radius. When this 
option is not selected and different radii are used, the edges are capped, as shown in the 
right graphic.
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Two Edge or One Edge Vertex Blend
You can create two and one edge vertex blends by first creating a constant radial blend. 
Using the Design Explorer double-click on the blend to display the Edit Objects dialog 
box. For a two edge vertex blend change the radius of one edge to zero. For a one edge 
vertex blend, change two radii to zero. The left graphic below shows the two edge vertex 
blend and the right graphic a one edge vertex blend.

Disjoint Blend
A disjoint blend is a blend between faces that do not touch or are on two separate bodies. 
To create this blend in the past you had to perform a boolean operation. A disjoint blend is 
created by specifying a radius for the blend, selecting the two faces or objects and specify-
ing a blend help position.

The help position tells this Designer Elements program 
where to begin calculating the blend. Visualize a sphere 
with this help position at its center. This sphere rolls along 
the virtual blend between the two bodies as this Designer 
Elements program calculates the actual blend. The sphere 
diameter equals twice the blend radius. The illustration 
here shows the help sphere and the help position for two 
disjoint bodies and applies to all disjoint blend operations.

The graphics below are two examples of objects before 
and after a disjoint blend is created.
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Tips:

• If a help position does not create the blend try another location in the same quadrant.

• When creating a blend between objects of different colors, the color of the first object 
selected becomes the color of the new blended object.

Creating a Disjoint Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool and the Radial option from the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges AND/OR faces 
to blend [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), 
Shift=Extend].

3. Hold the SHIFT key down and select the objects. The Message Line now reads, Con-
stant Blend: Specify help position.

4. Click the help position location. (If the help position does not create the blend try 
another location in the same quadrant.)

A disjoint blend is created.

Disjoint Edge to Face Blend
A disjoint edge to face blend is created by selecting the edge and face of an object. What 
makes this blend unique is that our Designer Elements program allows you to specify a 
radius for the blend that is greater than the distance from the edge to the face. 

In the graphic here a one inch blend is applied using 
the inside top edge of the object and its inside bottom 
face. The user supplied help position is important in 
this blend. If you choose the wrong location the blend 
will not work. The one inch radius is larger than the 
distance from the edge to the face.

Disjoint Face to Face Remote Blend 
A disjoint face to face remote blend is created when applying a blend to two faces that do 
not share the same edge. In graphic below, a face to face remote blend is applied to the top 
and right face separated by a chamfer. Below are the before (chamfered block) and after 
pictures (Blended top and right face seperated by the chamfer).
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Before.

After

Notice in the Design Explorer, shown above, that the fillet blend does not replace the 
chamfer but follows the chamfer operation in the history tree.
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Edge to Face Roll Blend
An edge to face roll blend is create by specifying a 
radius, selecting an edge and face to blend and choosing 
a help position. The graphic to the right shows the origi-
nal object used for this blend.

The left graphic below shows the edge to face roll blend 
in which the vertical edge and the inside bottom face are 
selected. Using the Drafting Assistant, the help position is located out from the shared 
edge/face corner vertex along the z axis. The right graphic shows the default blend if the 
vertical faces and inside bottom faces were selected.

Blend with Cutouts
A blend with cutouts is created by applying a blend to 
faces that contain cutouts using the Constant Blend tool. 
There are no special steps to create this blend.

Extrapolation Blend
An extrapolation blend is created when you apply a con-
stant radial blend to an edge with a radius that is larger 
than what the intersecting face will accommodate. The 
intersecting face extends to accept the blend. The left 
graphic below is the original object. The right graphic 
shows that the faces were extended to accommodate the 
blend.
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Creating an Extrapolation Blend
1. Select the Blend tool.

2. In the Message Line, select the Constant Blend tool and the Radial option from the 
pull-down menu. The Message Line reads: Radial Blend: Pick edges AND/OR faces 
to blend [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), 
Shift=Extend].

3. Enter the radius in the Status Line.

4. Select the edge to blend.

The blend is created and the intersecting side extends as necessary.

Variable Blend Tool

When you select this tool its option 
pull-down menu appears.

You have five variable blend options: 
Linear, By Position, Radius Curve, 
Fixed Width and Hold Line.

Important: (Windows users) When a variable blend option uses the CTRL and SHIFT keys 
to perform specific operations for the tool, the Stroke Zoom function (CTRL+SHIFT keys) 
is not available when blending.

Using the Linear Option
This option adds a blend with a tapered radius along the edges you select. You specify the 
beginning radius (R1) and the ending radius (R2) in the Status Line.

R1

R1

R2

R2
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1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Linear option 
from the pull-down menu. The Message Line reads: Linear Blend: Pick 
edge to linearly blend. [Pick edge near R1][Ctrl=Advanced (Windows) or 
Option=Advanced (Macintosh)].

3. Select the edge along which to make the blend. 

The solid edge closest to your point of selection becomes R1.

While the blend is still selected you can change the radii (R1 and R2) in the Message Line. 
Type the new values and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains R1 (beginning radius) and R2 (ending radius) for the linear 
blend.

Geometric Characteristics
A variable linear blend is created by choosing a solid edge and specifying a radius for the 
beginning and end of the blend. It is made up of these characteristics according to Edit 
Objects: Radius 1 and Radius 2. 

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

Using the By Position Option
This option adds a blend with a varied radius along the edges 
you select. You specify the various radii in the Status Line.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the 
By Position option from the pull-down menu. The Message Line reads: Position 
Blend: Pick edge(s) for variable radius blend. [End=ESC,Dbl Click] [Ctrl=Advanced 
(Windows) or Option=Advanced (Macintosh)] [Shift=Extend].

3. Select the edge along which to make the blend. The Message Line reads: Position 
Blend: Specify location for radius value [End=ESC, Dbl Click].

4. Enter a radius in the R field of the Status Line.

5. Specify the location(s) along the selected edge for the radius.
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As you apply a radius to a location the value appears 
on the edge.

6. Enter a new radius in the R field.

7. Specify the location for this radius along the edge.

Continue following this procedure until you have 
entered all the desired radii. Double-click the last 
place radius point and the variable by position blend 
is created.

The Status Line contains the Radius for the blend.

Geometric Characteristics
A variable position blend is created by choosing a solid edge and various radii at different 
locations along the edge for the blend. It is made up of these characteristics according to 
Edit Objects: a list of the edges blended with their radii and Param points, Radius and 
Param value. Param is the percentage point location along the edge for the selected item in 
the list. When you select one of the items in the list its Radius displays in the Radius data 
field and its percentage point location displays in the Param field.

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Parameters command from the Design Explorer menu 
displays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

Using the Radius Curve Option
This option adds a blend based on a specified radius curve. Before 
using this option you must create an open curve in the positive xy 
quadrant. This curve cannot cross over itself or backtrack. A circle 
or a loop would not be acceptable curves. The graphic here is an 
example of an acceptable curve.

This curve defines the radius distribution. The 
start point of the curve represents the start point 
of the edge. The y value of the curve represents 
the radius. The x length of the curve is divided 
into percentages. The y value at a particular per-
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centage point on the curve is mapped as the radius to the same percentage point along the 
selected solid edge.

One advantage of this tool is the ability to modify the blend by changing the curve. You 
can also add or remove control points to the radius curve to change the blend. The blend is 
associative to the curve. Changing the curve, automatically changes the blend. If you 
attempt to delete the curve, the following dialog box appears:

Deleting the curve changes the object from a solid block to an ACIS solid.

1. Create the curve that will be referenced for the blend.

To ensure that the curve is in the positive xy quadrant, change the view to Top and draw 
the curve using the Axis as a reference.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Radius Curve option from 
the pull-down menu. The Message Line reads: Radius Curve Blend: Pick edge for 
variable radius blend.

3. Select the solid edge. The Message Line now reads, Radius Curve Blend: Pick radius 
curve (in positive xy plane).

4. Select the radius curve.

The blend is applied to the edge.

There are no Status Line entries.

Geometric Characteristics
A variable radius curve blend is created by choosing a solid edge and a curve in the posi-
tive xy quadrant to specify the radii along the edge. According to Edit Objects, a radius 
curve blend contains no unique geometric characteristics. You can make changes to the 
Display and Attribute settings through the Edit Objects dialog box. You cannot change the 
blend radius through the Edit Objects dialog box. It must be done using the original curve. 
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Select the curve and change the x or y location in Edit Objects or drag the control point on 
the curve to the new positive x, or y location (The z location must remain at zero).

Using the Fixed Width Option
This option adds a blend with a fixed width along the edges you select adjusting the blend 
radius to maintain the width. This is important when placing a blend along the edge of two 
faces where the angle changes. You specify the width in the Status Line. In the graphic, the 
left boss has a constant radial blend with a .5 inch radius and the right graphic a fixed 
width blend with a .5 inch width.

1. Select the Blend tool.

2. In the Message Line, select the Variable Blend tool and the Fixed Width option from 
the pull-down menu. The Message Line reads: Fixed Width Blend: Pick edges AND/
OR faces to blend [Ctrl=Advanced (Windows) or Option=Advanced (Macintosh), 
Shift=Extend].

3. Enter the fixed width for the blend in the Status Line.

4. Select the edge for the blend.

A fixed width blend is created.

The Status Line contains the width (W) of the blend.

Geometric Characteristics
A variable fixed width blend is created by choosing a solid edge and specifying the blend 
width. It is made up of these characteristics according to Edit Objects: Radius and a list of 
edges blended with their associated width.

You can select the blend using the Design Explorer. Double-clicking on the item in the 
Design Explorer or choosing Edit Objects command from the Design Explorer menu dis-

Width

Width
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plays the Edit Objects dialog box. You can make changes to the settings on the Display 
and Attribute pages. See Chapter 24 for more information on the Design Explorer.

Using the Hold Line Option
This option adds a blend to the hold line curve specified adjusting the blend radius as 
needed to fit the line.

Hold Line Rules:

• The hold line curve should be one curve (circle, ellipse or spline). If the curve is not 
closed, a linear blend is applied where there is no hold line using the open ends of the 
curve for the radius values.

• Although the hold line curve does not have to be on the plane of the surface, it should 
be close to it and in the same plane as the surface. Curves not on the surface are pro-
jected to the closest surface to calculate the blend.

• Grouped curves are not supported.

The left graphic shows a part with a spline on the slanted face. The right graphic shows the 
same part using the spline as the hold line for the blend.

1. Create a hold line curve.

2. Select the Blend tool.

3. In the Message Line, select the Variable Blend tool and the Hold Line option 
from the pull-down menu. The Message Line reads: Hold Line Blend: Pick 
edges AND/OR faces to blend [Ctrl=Advanced (Windows) or 
Option=Advanced (Macintosh), Shift=Extend].

4. Select the edge for the blend. The Message Line now reads, Hold Line 
Blend: Pick curve for hold line [Shift = Extend].
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5. Select the hold line curve.

A hold line blend is created.

There are no Status Line entries.

Geometric Characteristics
A variable hold line blend is created by choosing a solid edge and a curve for the hold line. 
According to the Edit Objects, a hold line blend contains no unique geometric characteris-
tics. You can make changes to the Display and Attribute settings through the Edit Objects 
dialog box.

Chamfer Edge Tools

The Chamfer Edge tools create flat surfaces along a specified 
edge. The graphic here shows a chamfered solid along all four 
edges.

When you select the Chamfer Edge tool a subpalette appears 
in the Message Line containing two chamfer edge tools: Con-
stant Length and Variable Length.

Each of these tools includes a pull-
down menu containing options for 
creating that type of chamfer. The 
graphic shown here is the Constant 
Length Chamfer tool menu.

Many of these tool options also have 
advanced capabilities. These include: Constant Length Chamfer, Two Lengths Chamfer, 
Length Angle Chamfer, Variable Lengths Chamfer, Variable Four Lengths Chamfer, Vari-
able Lengths Angle Chamfer and Variable By Position Chamfer. These capabilities are 
indicated in the Message Line by the notation, [Ctrl = Advanced] (Windows) or [Option = 



Chamfer Edge Tools
Advanced] (Macintosh). When you press the CTRL (Windows) or OPTION (Macintosh) 
key, the Advanced Chamfer Options dialog box appears.

The dialog box contains the following options:

Automatic Chain-select Checking this box enables you to chamfer all edges 
that share a tangent with the selected edges. This is the 
default setting. Without this checked only the selected 
edges chamfer. The left graphic shows three edges 
chamfered with the Constant Length Chamfer tool with 
the option selected. The right graphic shows two edges 
chamfered with the Constant Length Chamfer tool 
without the option selected.

Feature Interaction (Slower) Checking this box allows you to apply a chamfer that 
intersects a cutout or protrusion. Without this checked the 
feature may be deleted. With it checked the cutout is 
taken into account. The graphics illustrate this. The left 
graphic is the original part with hole cutout to half the 
part’s depth. The middle graphic is the chamfered part 

of Shared Edges
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without this option selected. The right graphic is the 
chamfered part with the option selected.

Without this checked for a protrusion the chamfer 
takes precedence over the protrusion. The left graphic 
below is the original part. The middle graphic is the 
part without the option selected. The right graphic is 
the part with the option selected.

Using this option results in a longer chamfering time.

Constant Length Chamfer Tool

When you select this tool its option pull-
down menu appears. 

You have four constant length options: 
Length, Two Lengths, Length Angle and 
Vertex Chamfer.
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Using the Length Option
This option adds a 45° chamfer based on the specified length to edge distance along the 
selected edge. The left graphic is an example of an object using this option. The middle 
graphic here shows a .5 inch chamfer with a vertex setback of 1.0. (You create this by 
selecting three or more edges with a setback at the corner vertex.) The right graphic illus-
trates the variables.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant 
Length Chamfer tool and the Length option 
from the pull-down menu. The Message Line reads: Chamfer Edge: Pick solid edges 
to chamfer [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] 
[Shift=Extend].

3. Enter a setback value in the Setback data field of the Status Line, if desired, for three 
or more intersecting edges.

4. Select the edge(s) to chamfer.

The chamfer is created.

While the chamfer is still selected you can change L1 and the setback length in the Status 
Line. Type the desired values in the data field and press ENTER (Windows) or RETURN 
(Macintosh).

The Status Line contains L1 and the Setback.

Geometric Characteristics
A constant length chamfer is created by choosing a solid edge and specifying the length to 
the edge. It is made up of two characteristic according to Edit Objects: Setback and 
Length. The setback is the distance from the shared vertex of three or more edges that the 
chamfer extends.

L1

L1
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It also includes an edge list displaying the edge name and its associate length. To modify 
the chamfer characteristics, select the chamfer using the Design Explorer and choose Win-
dow>Edit Objects or double-click on the chamfer name. See Chapter 24 for more infor-
mation on the Design Explorer.

Using the Two Lengths Option
Using this option adds a chamfer based on the specified length to edge distances along the 
selected edge to create a constant length chamfer.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Chamfer tool and the Two Lengths 
option from the pull-down menu. The Message Line reads: Chamfer Edge: Pick solid 
edges to chamfer [Ctrl = Advanced (Windows) or Option = Advanced (Macintosh)] 
[Shift=Extend].

3. Enter L1 and L2 values in the Status Line.

4. Select the edge(s) to chamfer.

The chamfer is created.

While the chamfer is still selected you can change the L1 and L2 values in the Status Line. 
Type the desired values in the data field and press ENTER (Windows) or RETURN (Mac-
intosh).

The Status Line contains L1 and L2.

Geometric Characteristics
A constant two length chamfer is created by choosing a solid edge and specifying the 
lengths to the edge. It is made up of two characteristics according to Edit Objects: Length 
1 and Length 2. To modify the chamfer characteristics, select the chamfer using the 
Design Explorer and choose Window>Edit Objects or double-click on the chamfer 
name. See Chapter 24 for more information on the Design Explorer.

L1

L2
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Using the Length Angle Option
This option adds a chamfer at an angle and a constant length to the edge that you specify 
in the Status Line. The angle is measured from the tangent of the selected edge to the 
chamfered edge (see the right graphic).

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Chamfer tool and the Length Angle 
option from the pull-down menu. The Message Line reads: Chamfer Angle Edge: Pick 
solid edges to chamfer [Ctrl = Advanced (Windows) or Option = Advanced (Macin-
tosh)] [Shift=Extend].

3. Enter an L1 and angle in the Status Line data fields.

4. Select the edge(s) to chamfer. 

While the chamfer is still selected you can change the length and angle in the Status Line. 
Type the desired values in the data fields and press ENTER (Windows) or RETURN 
(Macintosh).

The Status Line contains L1 and the A chamfer angle) data fields.

Geometric Characteristics
An constant length angle chamfer is created by choosing a solid edge and specifying an 
angle and length. It is made up of these characteristics according to Edit Objects: Setback 
and Angle. The setback is the distance from the shared vertex of three or more edges that 
the chamfer extends.

To modify the chamfer characteristics, select the chamfer using the Design Explorer and 
choose Window>Edit Objects or double-click on the chamfer name. See Chapter 24 for 
more information on the Design Explorer.

L1

Angle
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Using the Vertex Chamfer Option
This option adds a constant vertex chamfer to the intersection of three edges. The length is 
measured from the vertex to the edge as indicated in the right graphic below.

The faces next to the intersecting edges must be planar and 
have the same convexity or concavity. The graphic here shows 
convex and concave vertex chamfers.

1. Select the Chamfer Edge tool.

2. In the Message Line select the Constant Length Chamfer 
tool and the Vertex Chamfer option from the pull-down 
menu. The Message Line reads: Vertex Corner: Select ver-
tex to corner.

3. Enter an L1 value in the Status Line data field.

4. Select the vertex to chamfer. 

While the chamfer is still selected you can change the length in the Status Line. Type the 
desired value in the data field and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains L1 chamfer length.

Geometric Characteristics
An vertex corner chamfer is created by choosing a vertex and specifying a length. It is 
made up of one characteristic according to Edit Objects: Radius 1. To modify the chamfer 
radius select the chamfer using the Design Explorer and choose Window>Edit Objects 
or double-click on the chamfer name. See Chapter 24 for more information on the Design 
Explorer.

L1

L1
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Additional Examples
Here are a few chamfer variations using the constant chamfer tools.

Multi-edge Chamfer with Mitered Corner
This chamfer is created using the Length option of the Con-
stant Length Chamfer tool. In the Advanced Chamfer 
options dialog box turn off the Automatic Chain-select of 
Shared Edges option and then chamfer each edge separately.

Multi-edge Chamfer with Varied Lengths and Setback
This chamfer is created using the Length option of the Con-
stant Length Chamfer tool. 

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Constant Length Chamfer 
tool and the Length option from the pull-down menu. 
The Message Line reads: Chamfer Edge: Pick solid edges to chamfer [Ctrl = 
Advanced (Windows) or Option = Advanced (Macintosh)] [Shift=Extend].

3. Enter a setback value in the Setback data field.

4. Hold down the SHIFT key and select the edges to chamfer them. 

5. Using the Design Explorer, double-
click on the chamfer to display the 
Edit Object dialog box.

6. In the edge list select an edge. It’s 
associated L1 value appears in the 
length data field.

7. Enter a new value in the field.

Change other values as desired.

8. Click apply and the chamfer updates.
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Complex Chamfer
This Designer Elements program supports complex chamfering for 
intersecting objects with or without setbacks. The example here 
includes setbacks.

Variable Chamfer Edge Tool

When you select this tool its option pull-
down menu appears.

You have five variable length options: 
Lengths, Four Lengths, Lengths Angles, 
By Position and Fixed Width.

Using the Lengths Option
This option adds a chamfer tapered lin-
early along the edge from two specified setback lengths, L1 and L2.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Variable Length 
Chamfer tool and the Lengths option from the 
pull-down menu. The Message Line reads: Linear Chamfer: Pick edge to linearly 
chamfer. (Pick edge near L1) [Ctrl = Advanced (Windows) or Option = Advanced 
(Macintosh)].

3. Enter the L1 (the beginning setback length of the chamfer) and L2 (the ending setback 
length of the chamfer) values in the Status Line data fields.

4. Select the edge to chamfer.

L1

L1

L2

L2
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While the chamfer is still selected you can change the setback lengths (L1 and L2) in the 
Status Line. Type the desired values in the data fields and press ENTER (Windows) or 
RETURN (Macintosh).

The Status Line contains the chamfer setback lengths, L1 and L2.

Geometric Characteristics
A variable lengths or linear chamfer is created by choosing a solid edge and specifying a 
length for the beginning and end of the chamfer. It is made up of these characteristics 
according to Edit Objects: L1, L2 and a list of the edges chamfered with their correspond-
ing lengths.

To modify the chamfer characteristics, select the chamfer using the Design Explorer and 
choose Window>Edit Objects or double-click on the chamfer name. See Chapter 24 for 
more information on the Design Explorer.

Using the Four Lengths Option
This option adds a chamfer tapered linearly along the edge using four specified setback 
lengths, L1, L2, L3 and L4.

1. Select the Chamfer Edge tool.

2. In the Message Line select the Variable Length Chamfer tool and the Four Lengths 
option from the pull-down menu. In the Message Line select the Linear Chamfer tool. 
The Message Line reads: Chamfer Edge: Pick solid edges to chamfer. [Ctrl = 
Advanced (Windows) or Option = Advanced (Macintosh)] [Shift=Extend].

3. Enter the L1 and L2 values for the beginning setback lengths of the chamfer and L3 
and L4 values for the ending setback lengths of the chamfer in the Status Line data 
fields.

4. Select the edge(s) to chamfer.

L1

L2

L3

L4
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While the chamfer is still selected you can change the setback lengths in the Status Line. 
Type the desired values in the data fields and press ENTER (Windows) or RETURN (Mac-
intosh).

The Status Line contains the chamfer setback lengths, L1, L2, L3 and L4. 

Geometric Characteristics
A variable four lengths chamfer is created by choosing a solid edge and specifying a 
lengths for the beginning and end of the chamfer. It is made up of these characteristics 
according to Edit Objects: L1, L2, L3, L4 and a list of the edges chamfered with their cor-
responding lengths.

To modify the chamfer characteristics select the chamfer using the Design Explorer and 
choose Window>Edit Objects or double-click on the chamfer name. See Chapter 24 for 
more information on the Design Explorer.

Using the Variable Lengths Angles Option
This option adds a chamfer with the specified lengths and angles for the beginning and end 
of the chamfer along the selected edge. The angles are measured from the tangent of the 
selected edge to the chamfered edge (see the right graphic).

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Variable Length Chamfer tool and the Lengths Angles 
option from the pull-down menu. The Message Line reads: Chamfer Angle Edge: Pick 
solid edges to chamfer [Ctrl = Advanced (Windows) or Option = Advanced (Macin-
tosh)] [Shift=Extend].

3. Enter an L1 and A1 (angle) for the beginning of the chamfer and L2 and A2 (angle) 
for the end of the chamfer in the Status Line data fields.

L1

L2

Angle1

Angle2
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4. Select the edge(s) to chamfer. 

While the chamfer is still selected, you can change the lengths and angles in the Status 
Line. Type the desired values in the data fields and press ENTER (Windows) or RETURN 
(Macintosh).

The Status Line contains L1, A1, L2 and A2 data fields.

Geometric Characteristics
A variable length angle chamfer is created by choosing a solid edge and specifying the 
beginning and end chamfer angles and lengths. It is made up of these characteristics 
according to Edit Objects: L1, Angle 1, L2, Angle 2 and a list of the edges chamfered with 
their corresponding lengths and angles.

To modify the chamfer characteristics, select the chamfer using the Design Explorer and 
choose Window>Edit Objects or double-click on the chamfer name. See Chapter 24 for 
more information on the Design Explorer.

Using the Variable By Position Option
This option adds a chamfer with a varied lengths along the edges you select. You specify 
the lengths in the Status Line. You can also create a degenerative chamfer with this option 
by specifying a zero length at both ends of the edge. The left graphic shows a varied length 
chamfer. The right graphic shows a degenerative chamfer.

1. Select the Chamfer Edge tool.

2. In the Message Line, select the Variable Length Chamfer tool and the By Position 
option from the pull-down menu. The Message Line reads: Position Chamfer: Pick 
edges for variable position chamfer [End = ESC, Dbl Click] [Ctrl = Advanced (Win-
dows) or Option = Advanced (Macintosh)] [Shift=Extend].
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3. Select the edge along which to make the chamfer. The Message Line reads: Position 
Chamfer: Specify location for length value [End=ESC, Dbl Click].

4. Enter a setback length in the Length field of the Status Line.

5. Specify the location(s) along the selected edge for the chamfer.

As you specify the location the length appears in red at 
that point and all additional locations. The values 
remain until you double-click to specify the last cham-
fer point and the chamfer is created. The graphic illus-
trates this.

6. Enter a new length in the Length field.

7. Specify the location for this length along the edge.

Continue following this procedure until you have 
entered all the desired lengths. Double-click the last 
place chamfer point and the variable by position 
chamfer is created.

The Status Line contains the Length for the chamfer setback.

Geometric Characteristics
A variable by position chamfer is created by choosing a solid edge and various setback 
lengths at different locations along the edge for the chamfer. It is made up of these charac-
teristics according to Edit Objects: a list of the edges chamfered with their widths and 
Param points, Width (which corresponds to the Status Line length) and Param value. 
Param is the percentage point location along the edge for the selected item in the list. 
When you select one of the items in the list its Length displays in the Width data field and 
its percentage point location displays in the Param field.

To modify the chamfer characteristics select the chamfer using the Design Explorer and 
choose Window>Edit Objects. See Chapter 24 for more information on the Design 
Explorer.

Using the Fixed Width Option
This option adds a chamfer with a fixed width along the edges you select adjusting the 
chamfer length to maintain the width. This is important when placing a chamfer along of 
the edge of two faces where the angle changes. You specify the width in the Status Line. 
The left graphic shows a sloped block with two bosses where the left boss has at constant 
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length chamfer and the right boss has a variable fixed width chamfer. The right graphic 
illustrates the fixed width characteristic.

1. Select the Chamfer Edge tool.

2. In the Message Line select the Variable Length Chamfer tool and the Fixed Width 
option from the pull-down menu. The Message Line reads: Fixed Width Chamfer: 
Pick edges AND/OR faces to chamfer [Ctrl = Advanced (Windows) or Option = 
Advanced (Macintosh)] [Shift=Extend].

3. Enter a width in the W data field of the Status Line.

4. Pick the edge(s) for the chamfer.

While the chamfer is still selected you can change the width in the Status Line. Type the 
desired values in the data fields and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the width for the chamfer.

Geometric Characteristics
A variable fixed width chamfer is created by setting a chamfer width and selecting the 
edge for the chamfer. It is made up of these characteristics according to Edit Objects: 
Width and a list of the edges chamfered with their width. When you select one of the items 
in the list its width displays in the Width data field.

To modify the chamfer characteristics select the chamfer using the Design Explorer and 
choose Window>Edit Objects. See Chapter 24 for more information on the Design 
Explorer.

Width

Width
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Tech Note:

If you want to place a hole 
through an object that will 
intersect a blend, use the 
Depth option rather than the 
To Face option. If To Face is 
used, when the hole inter-
sects the blend, a face 
change occurs and the hole 
ends.
Hole Feature Tools

With the Hole Feature tools you can model bolt holes found frequently in mechanical 
design parts. This Designer Elements program holes are predefined features that remove 
cylindrical shapes from objects. Holes can be placed through models, along face edges at 
corner vertices and on planar and non-planar faces. The graphic below is an example of a 
simple hole.

Holes, like other features in this Designer Elements program, are associative. You can 
modify them at any point in your design process. When you select the Hole Feature tools a 
subpalette appears containing three tools for creating holes: Simple, Counter Bore and 
Counter Sink.

Through Types
The Message Line also contains a pull-down menu 
allowing you to choose a Through Type for your hole. 
You have four options: Depth, Through, First Blind and 
To Face.

Depth Extends the depth of 
the hole to the value 
specified in the Status Line.
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Through Extends a hole through the selected solid.

First Blind Extends a hole to the first open face.

To Face Extends a hole to the selected face.

Hole Direction
The Message Line contains a pull-down menu allowing 
you to specify a boss direction. You have five options: 
Normal, X-Axis, Y-Axis, Z-Axis and 2-Pts.

Normal Creates a hole perpen-
dicular to the solid 
face.

X-Axis Creates a hole along the X-axis.

Y-Axis Creates a hole along the Y-axis.

Z-Axis Creates a hole along the Z-axis.

2-Pts Creates a hole in the direction specified by two user 
defined points.
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Simple Hole Tool

This tool creates straight, cylindrical holes through the selected solid. 
You can specify the X, Y and Z center location, depth, diameter and 
draft angle of the hole in the Status Line.

Using the Simple Hole Tool
1. Select the Hole tool.

2. In the Message Line select the Simple Hole 
tool. The Message Line reads: Simple Hole: Pick solid face to place hole.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message line. 

4. Select the face where you want to locate the hole.

5. Select the location for the center of the hole.

6. If you selected the 2-Pts direction click two points to specify the direction.

The hole is created.

While the solid is still selected you can change the hole depth in the Status Line. Type the 
desired value in the data field and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the hole's X, Y and Z center location, Diameter and Draft Angle.

Geometric Characteristics
A simple hole is created by choosing the solid face and the location of the hole. It is made 
up of these characteristics according to Edit Objects: Hole Type, Thru Type, Hole Depth, 
Diameter and Draft Angle. To modify the hole characteristics, select the hole using the 
Design Explorer and choose Window>Edit Objects or double-click on the hole name. 
See Chapter 24 for more information on the Design Explorer.
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Counter Bore Tool

This tool creates a counter bore hole based on the values you specify in 
the Status Line. A counter bore consists of the bore and the hole. The 
bore is a straight-sided cylinder with a diameter larger than the hole. 
The hole extends from the end of the bore and completes the counter 
bore. See the graphic here.

Using the Counter Bore Hole Tool
1. Select the Hole tool.

2. In the Message Line select the Counter Bore Hole tool. The Message Line reads: 
Counter Bore: Pick solid face to place counterbore.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message Line. 

4. Select the face to place the counter bore.

5. Specify the location for the center of the counterbore hole.

6. If you selected the 2-Pts direction click two points to specify the direction.

The bore is created.

While the solid is still selected you can change the depth, diameter and draft angle of the 
hole and the bore depth and radius in the Status Line. Type the desired values in the data 
fields and press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the counter bore's Depth, Diameter, Draft Angle, Bore Depth and 
Bore Diameter.

Geometric Characteristics
A counter bore is created by choosing the solid face and the location of the hole. It is made 
up of these characteristics according to Edit Objects: Hole Type, Thru Type, Hole Depth, 
Diameter, Draft Angle, Counter Bore Diameter and Depth. To modify the hole characteris-
tics, select the hole using the Design Explorer and choose Window>Edit Objects or 
double-click on the hole name. See Chapter 24 for more information on the Design 
Explorer.
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Counter Sink Tool

This tool creates a hole with angled sides, called the sink and a hole 
that extends from the sink. A counter sink hole can be contrasted with a 
counter bore hole where the bore has straight sides.

Using the Counter Sink Hole Tool
1. Select the Hole tool.

2. In the Message Line select the Counter Sink Hole tool. The Message Line reads: 
Counter Sink Hole: Pick solid face to place countersink.

3. Select a Through Type and Hole Direction from their respective pull-down menus in 
the Message line.

4. Select the face where you want to locate the hole.

5. Select the location for the center of the hole.

6. If you selected the 2-Pts direction click two points to specify the direction.

The hole is created.

While the solid is still selected you can change the depth, diameter and draft angle, sink 
radius and sink angle in the Status Line. Type the desired values in the data fields and 
press ENTER (Windows) or RETURN (Macintosh).

The Status Line contains the countersink's Depth, Diameter, Draft Angle, Sink Diameter 
and Sink Angle.

Geometric Characteristics
A counter sink hole is created by choosing the solid face and the location of the hole. It is 
made up of these characteristics according to Edit Objects: Hole Type, Thru Type, Hole 
Depth, Diameter, Draft Angle, Counter Sink Diameter and Angle. To modify the hole 
characteristics, select the hole using the Design Explorer and choose Window>Edit 
Objects or double-click on the hole name. See Chapter 24 for more information on the 
Design Explorer.



Boss Feature Tool
Boss Feature Tool

This tool creates a boss by adding a cylinder of a specified size to another solid and fillet-
ing the intersection of the two. A boss can be placed on planar and non-planar surfaces. 
You specify the height, diameter and fillet radius in the Status Line.

Boss Direction
The Message Line contains a pull-down menu allowing 
you to specify a boss direction. You have five options: 
Normal, X-Axis, Y-Axis, Z-Axis and 2-Pts.

Normal Creates a boss perpen-
dicular to the solid 
face.

X-Axis Creates a boss along the X-axis.

Y-Axis Creates a boss along the Y-axis.

Z-Axis Creates a boss along the Z-axis.

2-Pts Creates a boss in the direction specified by two user 
defined points.

Using the Boss Feature Tool
1. Select the Boss Feature tool. The Message Line reads: Boss Feature: Pick solid face to 

place boss.

2. Select the boss direction from the pull-down menu.
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3. Select the face to locate the boss.

4. Specify a location for the boss center.

5. If you selected the 2-Pts direction click two points to specify the direction.

The boss is created.

While the solid is still selected you can change the height, diameter and fillet radius of the 
boss in the Status Line. Type the desired values in the data fields and press ENTER (Win-
dows) or RETURN (Macintosh).

The Status Line contains the boss’ Height, Radius and Fillet Radius.

If the solid face selected in incompatible 
with the axis direction the following ACIS 
Error appears.

Geometric Characteristics
A boss is created by choosing the solid 
face and specifying the values for the cylinder. It is made up of these characteristics 
according to Edit Objects: Height, Diameter and Fillet Radius. To modify the boss charac-
teristics, select the boss using the Design Explorer and choose Window>Edit Objects or 
double-click on the boss name. See Chapter 24 for more information on the Design 
Explorer.

Feature Editing
One of this Designer Elements program’ more powerful features is the transparent parent/
child associativity it creates for solid objects. As you add features to your part this 
Designer Elements program automatically establishes relationships between them. When 
you modify or change a parent, this Designer Elements program updates and regenerates 
all the children. For example, consider the following procedure:

1. Create a block primitive.

2. Fillet the block's edges.

3. Place a boss at the block's center.
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4. Place a countersink hole at the boss' top center.

Now try these modifications:

5. Select a face or edge from the original block. Choose Window>Edit Objects and 
change the block's length, width, and height. The fillets, boss and countersink hole 
automatically regenerate based on the new length, width, and height.

6. Select the block. Choose Window>Design Explorer. Click on the + sign to display 
the history tree of the block. Double-click on the fillet name in the Design Explorer. 
The Edit Objects dialog box appears. Change the fillet's radius. Note that the boss and 
hole automatically regenerate.

7. In the Design Explorer select one of the boss' face names. The Edit Object dialog box 
now displays the boss information. Change the boss to 100000 (or any outrageous 
value). In this case this Designer Elements program cannot regenerate the solid and 
returns it to the previously valid state.

Shell Solid Tool

The Shell Solid tool hollows out a solid with a thick-
ness you set.

This tool also includes an error detection routine. If 
your model contains a problem that prevents the completion of the local face modeling 
operation, an ACIS error dialog box appears with the problem location highlighted.

After shelling you can edit the face thickness in the Edit Objects dialog box.
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Tech Note:

Like all tools, you can set the 
thickness of the shell after the 
operation using the Status 
Line. When working with 
small objects, you may need 
to change the default thick-
ness first to shell successfully.
This tool also gives you the option 
of keeping the core of the shelled 
object. Notice the Messages Line:

Using the Shell Solid Tool
1. Select the Shell Solid tool. The Message Line reads: Shell Solid: Pick solid to shell.

2. In the Status Line, enter the desired offset or thickness of the shell.

3. Select the solid. The Message Line reads: Shell Solid: Pick open faces 
[Shift=Extend]. 

4. Select the face or faces that will be open. The object shells.

If you click in an area with no faces, the object will be hollowed out with no open faces.

While the solid is still selected you can enter a new value in the offset field. Press ENTER 
(Windows) or RETURN (Macintosh) to accept the change.

The Status Line contains the offset or shell thickness.

Modifying a Shelled Solid
After you shell a solid you can modify the shelling operation through the Edit Objects dia-
log box.

1. Select the shelled solid.

2. Choose Window>Design Explorer.

3. Open the history tree for the solid by clicking on the + (plus sign).

4. Select the shell operation.
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5. Choose Window>Edit Objects.

Edit Objects includes the Offset data 
field, Face list and a Selection button 
which toggles between three opera-
tions, Select Open, Select Closed and 
Select All.

Offset This field displays the offset when a shell face is 
selected from the face list.

Face list This list specifies the faces contained in the solid, a 
Designer Elements identifier number and the offset for 
the face. If the face was removed in place of an offset 
value appears the word open. If you suppress a face, 
suppressed is displayed instead of an offset value.

Select Open This selection operation displays when all faces are 
selected. Click this button to select all open faces.

Select Closed This selection operation displays when an open face or 
no faces are selected. Click this button to select all 
closed faces.
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Select All This selection operation displays when all closed faces 
are selected. Click this button to select all faces.

If you select one or more faces manually the buttons will not toggle automatically. You 
can also change the more than one face by holding down the SHIFT key when selecting 
or dragging to select multiple faces.

6. Select the desired face. (As you move through the list of faces, the selected face is 
highlighted on your object.)

7. Make any desired modifications.

You can suppress a face or change the offset for each face to another value. An offset of 
0 removes the face.

8. Click Apply to accept the changes.

Geometric Characteristics
A shelled solid is created by choosing a solid, specifying an offset and the face(s) you 
want open. It is made up of these characteristics according to Edit Objects: Offset thick-
ness, Suppress Face check box and a list of the solid faces with the respective offset dis-
tance. This list is only available if you select the operation in the Design Explorer first and 
then display the Edit Object dialog box. See Chapter 24 for more information on the 
Design Explorer.

Bend Solid Tool

The Bend Solid tool creates a solid by bending a solid about an axis through a given 
radius.

There are three options in the Message Line; Bend, Center Bend and Bend Along Curve.
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Using the Bend Axis Option
1. Click the Bend Solid tool.  Select the first tool in the Message Line. The Message Line 

reads: Bend Solid: Pick Solid to Bend.

2. The Status Line contains the Bend Radius and Bend Angle fields.  Enter the desired 
values for your bend solid. Tab between data fields.

3. Pick the solid that you wish to bend

4. The message line now reads, Bend Solid: Enter two points for bend axis.  Specify two 
points for the bend axis.  The two points represent the inner tangent line for the bend 
solid.   After you click the two points, the solid is bent about the axis.

5. The Message Line now reads, Bend Solid: Pick Solid to Bend [Option = Flip Mate-
rial].  Hit the option key to flip the side of the material that was bent.
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While the object is still selected, you can edit the bend radius and bend angle. Enter the 
new values and press ENTER (Windows) or RETURN (Macintosh) and the solid updates

Using the Center Bend Option

1. Click the Bend Solid tool.  Select the first tool in the Message Line. The Message Line 
reads: Center Bend Solid: Pick Solid to Bend.

2. The Status Line contains the Bend Radius and Bend Angle fields.  Enter the desired 
values for your bend solid. Tab between data fields.

3. Pick the solid that you wish to bend

4. The message line now reads, Bend Solid: Enter two points for bend axis.  Specify two 
points for the bend axis.  The two points represent the inner tangent line for the bend.   
After you click the two points, the solid is bent about the axis.

5. The Message Line now reads, Center Bend Solid: Pick Solid to Bend [Ctrl or Option 
= Flip Material].  Hit the option key to flip the side of the material that was bent.

Bend Axis Resulting BendSolid to Bend
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Using the Bend Along Curve Option

1. Click the Bend Solid tool.  Select the first tool in the Message Line. The Message Line 
reads: Bend Solid Along Path: Pick Solid to Bend..

2. Pick the solid that you wish to bend

3. The message line now reads, Bend Solid Along Path: Pick curve to bend solid to. 
Choose your curve.

4. The Message Line now reads, Bend Solid: Enter two points for bend height axis. 
Specify two points for the bend axis.  The two points represent thepoint at which the 
bend will start.

Flipped Material
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5. The Message Line now reads, Bend Solid: Enter two points for alignment axis. 
Choose the points on the solid you want aligned with the curve.



Solid Utilities and Features
After you've created a solid model you may need to modify it. This Designer Ele-
ments program provides several advanced editing tools to accomplish this. Use 
Boolean routines to add solids to each other, subtract them or create a new solid 
from their intersections. With the other tools you can split a solid in two, stitch sev-
eral surfaces together to form a solid, hollow out a solid to create a shell, change a 
solid face's draft angle or collectively change the draft angles of a set of upper and 
lower surfaces. You can also evaluate drafts placed on solid objects using the Draft 
Evaluation feature.

This Designer Elements program also provides you with assembly modeling tools 
for connecting, mating, aligning and inserts solids.

For each tool you can enter values in the Status Line to perform the editing opera-
tion either before or after the operation is complete. If you enter the values after 
you select the tool but before you perform the operation, your first click in the 
drawing area automatically registers all Status Line values. If you enter values after 
performing the operation and while the solid is still selected, pressing ENTER (Win-
dows) or RETURN (Macintosh) updates the solid to reflect the new values.

After using one of these tools to modify your solid you can make further changes to 
them by selecting the tool operation in the Design Explorer and choosing Win-
dow>Edit Objects.

All editing operations conducted on a solid are associative. Any modifications made 
to the parent will automatically alter all child objects that reference it (Cobalt™ and 
Xenon™ only).
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Tech Note:

The add, subtract and inter-
sect tool replace the two 
original solids with a new 
composite solid. The only way 
to recover the original solids 
after this boolean operation 
is to undo the command. A 
technique for retaining the 
originals is to copy them to 
another layer before using a 
Boolean tool.
The topics covered in this chapter include:

• Solid Editing tools

• Draft Evaluation feature

• Assembly Modeling tools

Solid Utility Tools
This Designer Elements program provides you with advanced editing or utilities 
tools located in the last subpalette of the Solids tool palette. The tools include: Bool-
ean, Split Solid, Stitched Solid, Shell Solid, Parting Line Solid, Local Face Modeling, 
Thicken Solid and Deform Face.

Boolean Tools

Your Designer Elements programs Boolean tools allow you to perform boolean 
operations on solid objects. You can add solids together, subtract one solid from 
another or intersect a solid with others. 

Union Solid Tool

The Union Solid tool combines two or more solids into one. In the left graphic 
below Solid A and Solid B are individual solids. The right graphic is a single solid.

Using the Union Solid Tool
1. Select the Boolean tool. 
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2. In the Message Line select the Union Solid tool. The Message Line reads: Union 
Solid: Pick solid to add to and solid(s) to add [Shift=Extend].

3. Select the solid to which you want to add.

4. Select the solid(s) that you want to add to the first solid. Hold down the SHIFT 
key before you select the first solid to select multiple solids.

There are no Status Line entries.

Subtract Solid Tool

The Subtract Solid tool subtracts one or more solids from another. In the right 
graphic Solid B is subtracted from Solid A.

Using the Subtract Solid Tool
1. Select the Boolean tool.

2. In the Message Line select the Subtract Solid tool. The Message Line reads: Sub-
tract Solid: Pick solid to subtract from and solid(s) to subtract out [Shift=Extend].

3. Select the solid from which you want to subtract.

4. Select the solid(s) that you want to subtract from the first solid. Hold down the 
SHIFT key before you select the first solid to select multiple solids.

There are no Status Line entries.
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Intersect Solid Tool

The Intersect Solid tool creates a new solid from the common volume of two inter-
secting solids. The right graphic below is the intersection of Solid A and Solid B.

Using the Intersect Solid Tool
1. Select the Boolean tool.

2. In the Message Line select the Intersect Solid tool. The Message Line reads: 
Intersect Solid: Pick two solids to intersect [Shift=Extend].

3. Select the two solids to form the intersect solid.

There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a boolean solid.

Trim Solid Tool

The Trim Solid tool trims a solid with a curve, surface, or solid. The trim tool is use-
ful for removing material from a base solid.  In addition to trimming to surfaces or 
another solid, the trim solid tool has the unique ability to allow trimming a solid to 
a curve.  In the case of a curve, an internal surface is built that sweeps into the 
screen or sweeps by user defined vector.  Use the pull down menu to specify your 
preference.
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In the case of trimming a solid to a surface or other solid, the pull down option has 
no bearing on the results.

Using the Trim Solid Tool
1. Click the Trim Solid tool.  The Message Line reads: Trim Solid: Pick curve, sur-

face or solid to trim to.

Trim Solid to Curve. Trim Solid to Surface.

Trim Solid to Solid.
23-5



Solid Utilities and Features

23-6
2. The Message Line now reads, Trim Solid: Pick solid to trim [Crtl (Windows) or 
Option (Macintosh) = Flip Direction to Remove]

3. The solid is trimmed to the curve, removing the solid in the direction of the 
arrows.

4. Press the Control or Option key if you want to change the material that is kept.

Note: Press the Control or Option key to change the direction of the material to be 
removed after the trim is completed. Do not hold the Control or Option keys dur-
ing the trimming process.

When trimming a solid to another solid the portion that is kept is the portion that 
was selected by the user.

There is no Status Line for the trim solid tool.
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Split Solid Tool

The Split Solid tool divides a solid into 
two parts. This Designer Elements pro-
gram uses an infinite plane, surface, or 
solid as the splitting entity so you must 
construct the splitting object before you 
can make the split.

Using the Split Solid Tool
1. Select the Split Solid tool. The Message Line reads: Split Solid: Pick solid to split.

2. Select the solid. The Message Line reads: Split Solid: Pick surface for splitting 
solid. 

3. Select the infinite plane or surface to split the solid.

There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a split solid.

Stitched Solid Tool

The Stitched Solid tool creates a closed solid 
from a collection of surfaces. The color and reso-
lution of the first surface selected are used for 
the stitched solid.
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The tool uses healing technology to repair any 
small gaps in the model. and creates a solid 
only if the selected surfaces create a closed 
body. This tool also provides you with three 
stitching options. Press the CTRL key (Win-
dows) or OPTION key (Macintosh) to display 
the Stitching Options dialog box.

The dialog box contains the following options:

Maximum Heal Gap Size This field set the maximum size that Vellum will 
attempt to stitch to objects. Enter a value between 
0 and 1.

Example: If the gap size is .1 but the object has a 
gap of .2, the surfaces won’t stitch.

Simplify Spline Surfaces This option sets whether spline surfaces are simpli-
fied when they are stitched. Solids use surfaces as 
their underlying geometry. These surfaces can be 
either Analytic surfaces or B-Spline Nurb surfaces. 
Analytic surfaces are used to create cylinders, 
cones and spheres. B-Splines surfaces are used to 
create a variety of shapes. ACIS is “turbocharged” 
for analytic surfaces.

When selected, this Designer Elements program 
attempts to simplify your spline surfaces. If your 
surfaces create a standard shape such as a cylinder, 
they convert into analytic surfaces. This conversion 
speeds up the calculation process for the solid and 
for your file. By default, this option is not selected.

Use Tolerant Edges This option determines whether tolerant edges will 
be used if a model can’t stitch because of a gap. 
When selected and an edge can’t stitch, it is 
marked as tolerant. Only operations that involve 
the entire edge can be conducted.

If this option is not selected and this Designer Ele-
ments program discovers a gap larger than speci-

to Analytics
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fied in the Maximum Heal Gap Size data field the 
following dialog box appears.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when stitching solids.

Using the Stitched Solid Tool
1. Select the Stitched Solid tool. The Message Line reads: Stitched Solid: Pick sur-

faces to create solid from. [Ctrl=Advanced] (Windows) or Option=Advanced 
(Macintosh) [Shift=Extend].

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the 
Stitching Options dialog box.

3. Specify the settings and click OK. Click Cancel to close the dialog box.

4. Hold down the SHIFT key and select the surfaces or drag a selection fence 
around them.

The surfaces are stitched into a solid.

There are no Status Line entries.

Geometric Characteristics
There are no characteristics listed in Edit Objects specific to a stitched solid.
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Thicken Solid Tool

The Thicken Solid tool allows you to thicken surfaces and solids. You specify the 
desired thickness. A positive or negative value determines the direction of the thick-
ening. The left graphic shows a surface and the right graphic shows the thickened 
surface, now a solid.

Using the Thicken Solid Tool
1. Select the Thicken Solid tool. The Message Line reads: Thicken Solid: Pick sur-

face or solid to thicken. [Ctrl or Option =Flip thickness side].

2. Type the desired thickness in the Thickness data field in the Status Line.

3. Select the surface or solid object to be thickened. This Designer Elements pro-
gram thickens the selected object.

By pressing the CONTROL or OPTION key you can toggle which side of the surface 
is thickened

While the object is still selected you can enter a new value in the Thickness data 
field and press ENTER (Windows) or RETURN (Macintosh) to change the thickness.

The Status Lines contains the Thickness value for the thickened object.

Geometric Characteristics
A thickened solid object is created by specifying a thickness and selecting the 
object. A thickened object is made up of the Thickness characteristic according to 
the Edit Objects dialog box. To modify the characteristics of the thickened object 
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select the object using the Design Explorer (Cobalt™ and Xenon™ only) and 
choose Window>Edit Objects or double-click on the face name.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

See Chapter 24 for more information on the Design Explorer.

Lofted Solid Tool

This tool creates a tangent solid between two neighboring solids using a specified 
bulge factor. The higher the bugle factor the more influential the slope of the tan-
gent for the selected solid. A loft solid with a bulge factor of zero (0) creates a dis-
continuous loft. The graphics below illustrate the effects of the bulge factor.

This tool does not support lofting if one of the solids is a sphere. If a sphere is 
selected no loft is created.

Bulge Factor = 0 Bulge Factor = 5

Bulge Factor 1 = 5; Bulge Factor 2 = 15 
(Set in Edit Objects)

Bulge Factor 1 = 8; Bulge Factor 2 = 10 
(Set in Edit Objects)
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Using the Lofted Solid Tool
1. Select the Lofted Solid tool. The 

Message Line reads: Lofted Solid: 
Pick two faces for lofted solid.

2. Enter a value in the Bulge data field. 

Be careful not to apply a bulge so large that it results in a self-intersecting body. 
If it does you will receive the following error message. 

Also be aware that bulge factors that are too small with respect to the solids 
may prevent later feature operations such as shelling and blending.

3. Select a solid face.

4. Select a face on the other solid.

One loft solid is created from the two solids using the shared faces for tangent 
conditions.

The Status Line contains the Bulge data field.

Geometric Characteristics
A lofted solid is created by selecting a face on two solids. It is made up of the fol-
lowing characteristics according to the Edit Objects dialog box: Bulge 1 and Bulge 
2. Bulge 1 applies to the bulge between the first face selected and the lofted solid. 
Bulge 2 applies to the bulge between the second face selected and the lofted solid. 
To display the Edit Objects dialog box for the lofted solid only, double-click the 
lofted solid item in the Design Explorer.
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Rib Solid Tool

The rib tool extrudes and thickens a closed or open profile into a base solid.  The 
profile is terminated up to the first face it reaches in the direction of the extrude.

Using the Rib Solid Tool
1. Select the Rib Solid tool. The 

Message Line reads: Rib Fea-
ture: Pick solid for rib.

2. Select the solid you want to add the rib to. The Message Line reads: Rib Fea-
ture: Pick rib profile. [Shift = Extend]

After you select the rib profile you need to specify the thick-
ness of the rib. This is done in the Status Line entry box pic-
tured here.

3. Once you select the rib profile The Message Line reads: Rib Feature: Specify 2 
points for rib direction.

For the tool to function correctly your direction should run into the solid you are 
adding the rib feature to.

If you want to edit the Thickness of the rib after you have placed the rib, you must 
go through the Design Explore and access the Edit Objects box associated with the 
Rib. The examples below show the tool use progression.
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Lip Solid Tool

The Lip Solid tool sweeps a profile about a collection of edges and either adds or 
subtracts the resultant sweep to or from the base solid.  The given profile is auto-
matically aligned perpendicular to the selected edge.  In addition, a reference point 
is specified such that the profile is translated from the reference point to the start 
position along the edge selected.   When the base solid is regenerated the profile is 
always translated from the reference position to that on the edge and then 
realigned.

Note: If you pick a face for the lip solid tool all edges of the selected face are used 
for the lip tool. 

The Lip Solid tool has two options in the Message Line, Add Feature 
and Remove Feature.

Using the Lip Solid Add FeatureTool

1. Select the Lip Solid tool. The Message Line reads: Lip Feature Add: Pick curves 
for lip profile. [Shift = Extend]

Lip Solid Add Feature Tool example.
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2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify 
profile origin.

The center of the circle is selected to be the origin in this example.

3. The Message Line reads: Lip Feature Add: Pick edges for profile to sweep. [Shift = 
Extend]

4. Pick the edges of the solid you want to add the lip feature to. In the example 
above, the edges of the green block were chosen.

Using the Lip Solid Remove Feature Tool.

1. Select the Lip Solid tool. The Message Line reads: Lip Feature Remove: Pick 
curves for lip profile. [Shift = Extend]

2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify 
profile origin.

The center of the circle is selected to be the origin in this example.

3. The Message Line reads: Lip Feature Remove: Pick edges for profile to sweep. 
[Shift = Extend]
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4. Pick the edges of the solid you want the lip feature profile to be removed from. 
In the example below, the edges of the green block were chosen.

Note: You cannot use the remove feature on both block edges at the same time.

Local Face Modeling Tools

The Local Face Modeling tool allows you to perform operations on faces indepen-
dently of how the part was created. This means you can bring in parts from other 
systems and still perform edits to the geometry. 
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This tool also includes an error detection routine. If your model contains a problem 
that prevents the completion of the local face modeling operation, an ACIS error 
dialog box appears with the problem location highlighted.

The Local Face Modeling tool offers six modeling 
options, as listed in the Message Line: Taper, Move, 
Offset, Remove, Replace and Match.

The Draft Face Tool

Choosing the Draft Face tool applies a draft to a group of selected faces. Positive 
tapers (draft) add material. Negative tapers (draft) remove material. The taper direc-
tion is relative to the pull-direction defined by the current work plane and a neutral 
point.

Rules
• The work plane cannot be parallel to the face or faces that you taper. The work 

plane defines the pull-direction or direction of draw, the direction the part would 
eject from a mold.

• The neutral point is the position on the face or edge that remains fixed while the 
face tapers.

• The taper is the angle that the face rotates relative to the neutral point. The value 
can be negative or positive and the rotation occurs relative to the work plane. 
Typically positive values add material and negative values remove material. The 
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Tech Note:

Make sure the face you 
choose is not normal to the 
z-axis. If it is, nothing will hap-
pen. Change the work plane 
and try again.
graphics here illustrate the relationship between that work plane and the taper 
angles.

Using the Draft Tool
1. Select the Draft Solid tool. The 

Message Line reads: Draft Solid: 
Pick reference face or edge for 
draft (click nothing for work plane].

2. Select the reference face, edge or work plane. This 
tells your Designer Elements program the pull direc-
tion of the normal for the taper.

When you select the reference an arrow displays indi-
cating the normal direction. An example is shown here.

The Message Line now reads, Draft Solid: Pick faces of 
a solid to draft [Shift=Extend].

3. Select a face or hold down the SHIFT key to select 
more than one face. The Message Line now reads, Draft Solid: Specify taper 
neutral position.

4. Click a point on the screen to serve as the neutral position. The neutral position 
will remain constant. 

Your Designer Elements program applies the taper or draft relative to a pull direc-
tion defined by the normal.
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While the solid is selected you can change the Draft angle in the Status Line. Press 
ENTER (Windows) or RETURN (Macintosh) and the taper updates.

The Status Line contains the Draft angle.

Modifying Drafted Solids
You can modify the draft angle of your solid by choosing the draft in the Design 
Explorer for the solid and displaying the Edit Objects dialog box. If you have more 
than one face drafted, you can specify a different draft for each one. Click Apply to 
accept the changes.

Geometric Characteristics
A draft solid is created by choosing a solid, specifying a draft, the face for the draft 
and the neutral point position. It is made up of these characteristics according to 
Edit Objects: Draft angle and the solid face list with the drafts. This list is only avail-
able if you select the operation in the Design Explorer first and then display the 
Edit Object dialog box. See Chapter 24 for more information on the Design 
Explorer.

The Match Face Tool

Choosing the Match Face tool matches the selected surface to a referenced surface. 
This tool only works if the referenced surface is analytical (planar or circular). A 
nurb surface is not an analytical surface.

Planar Example
This is an example of matching the top face of the 
right model to the top face of the left model, which 
acts as a reference. Imagine the top planar face of the 
left solid extended beyond its bounds, as shown in 
the left graphic here. When the operation is complete 
the nurb face of the right solid is replaced with the planar face, as shown in the 
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right graphic. The solid is extended to the imaginary intersection with the top pla-
nar face of the left solid. 

Here’s another example of the match face option. The left graphic shows a select 
face on a solid object. The right graphic shows the face matched to the sloped face.

Elliptical Example
This left graphic below shows an example of matching a side face of the rectangu-
lar solid to the elliptical solid, which acts as a reference. When the operation is 
complete the solid is extended to the elliptical solid and the planar face becomes an 

elliptical face, shown in the right graphic.

Using the Match Face Tool
1. Select the Match Face tool.The Message Line reads: Match Face: Pick face to 

modify.



Rib Solid Tool
2. Select the face of the solid you want to modify or match to another face. To 
select more than one face be sure to hold down the SHIFT key before selecting 
the first face.

The Message line now reads, Match Face: Pick face to match to.

3. Select the face of the solid that you want the selected face to match.

The face is matched.

The Status Line contains no entries.

Geometric Characteristics
A matched face has no specific characteristics. To modify the Display and Attribute 
characteristics of the matched face, select the face using the Design Explorer and 
choose Window>Edit Objects or double-click on the face name.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

See Chapter 24 for more information on the Design Explorer.

The Move Face Tool

Choosing Move Face tool moves the selected group of faces by a vector defined 
with the Drafting Assistant.

If moving more than one face the selected faces cannot be perpendicular to others. 
This tool is valuable for moving a flat face and fillet or a face and a hole.The graph-
ics here show just such an operation. The left graphic shows the original geometry 
with the selected faces and the right graphic shows the geometry with two faces 
moved.
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Using the Move Face Tool
1. Select the Move Face tool.The 

Message Line reads: Move Face: 
Pick faces of a solid to move 
[Shift=Extend].

2. Select the face(s) of the solid you want to move. To select more than one face 
hold down the SHIFT key before selecting the first face.

The Message Line now reads, Move Face: Pick two points for move. The points 
define a vector with DX, DY, DZ values. You can either click two points or enter 
the desired values in the Status Line. 

3. Select the two points to specify dX, dY, dZ values for the move. The order you 
select your points determines whether the value is positive or negative.

The selected face moves to the new location.

While the face is still selected you can enter new values in the dX, dY, or dZ data 
fields in the Status Line. Press ENTER (Windows) or RETURN (Macintosh) to update 
the move.

The Status Line contains the dX, dY and dZ values of the move.

Geometric Characteristics
A move face has no specific characteristics. To modify the Display and Attribute 
characteristics of the move face, select the face using the Design Explorer and 
choose Window>Edit Objects or double-click on the face name.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

See Chapter 24 for more information on the Design Explorer.
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Tech Note:

When using the Move Face 
option, you will receive an 
error if you try to move the 
whole face off a solid.
The Offset Face Tool

Choosing the Offset Face tool offsets the selected faces. Adjacent faces and edges 
are adjusted as necessary for the offset. The left graphic below shows the original 

object. The right graphic shows a positive offset of the left and top face.

Using the Offset Face Tool
1. Select the Offset Face Modeling tool.

2. The Message Line reads: Offset Face: Pick faces of a solid to offset [Shift=Extend].

3. In the Status Line enter a value in the data field. A positive value enlarges the 
object and a negative value reduces the object.

4. Select the face of the solid you want to offset. To select more than one face be 
sure to hold down the SHIFT key before selecting the first face.

The selected face moves the offset specified.

While the object is still selected you can enter new values in the data field. Press 
ENTER (Windows) or RETURN (Macintosh) to update the offset.

The Status Line contains the Offset value.

Geometric Characteristics
An offset face is defined by its offset value according to the Edit Objects dialog box. 
To modify the offset or the Display and Attribute characteristics of the offset face, 
select the face using the Design Explorer and choose Window>Edit Objects or 
double-click on the face name.
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Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On. See Chapter 24 for more information on the Design Explorer.

The Remove Face Tool

Choosing the Remove Face tool removes a face from a solid, extends the adjacent 
faces and relimits the solids as necessary. This is useful for removing holes and fil-
lets from geometry imported without a history tree. The left graphic shows the orig-
inal object. The right graphic shows the object with the holes and a fillet removed.

Using the Remove Face Tool
1. Select the Remove Face tool.

2. The Message Line reads: Remove 
Face: Pick faces of a solid to 
remove [Shift=Extend].

3. Select the face of the solid you want to remove. To select more than one face 
be sure to hold down the SHIFT key before selecting the first face.

The selected face is removed.

There are no Status Line entries.

Warning: A face can only be removed from a solid as long as the integrity of a 
solid is retained after the face removal. You cannot remove a face of a cube if the 
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cube has a blend, the blend can be removed. If you attempt to remove a face that 
will challenge the solid's integrity, the following error message appears.

Geometric Characteristics
A removed face has no specific characteristics.

The Replace Face Tool

Choosing the Replace Face tool replaces the selected face with the new face speci-
fied. The new face must have the same boundaries or edges as the original face.

Using the Replace Face Tool
1. Select the Replace Face tool.

2. The Message Line reads: Replace Face: Pick face to replace.

3. Select the face of the solid you want to replace. To select more than one face 
be sure to hold down the SHIFT key before selecting the first face.

The Message line now reads, Replace Face: Pick new surface.
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4. Select the replacement face.

The original face is replaced.

The Status Line contains no entries.

Replace Face Example
You have a block (below) and you want to replace the top face 
with a warped surface.

1. Select the Rectangle tool and trace over the top face of the 
block.

2. Select the Through Point B-Spline tool and create a three 
point spline from the midpoint of the of one edge to the 
midpoint of the opposite edge.

3. Using the Selection tool, drag select the center control point 
of the spline and drag it up along the z axis some distance.

4. Select the Net Surface tool.

5. Select the M curves consisting of the left edge, spline and 
right edge curves, (curves 1, 2 and 3 in the graphic).

6. Select the N curves consisting of the top and bottom curves 
(curves 1 and 2 in the graphic) two complete the net sur-
face.

7. Select the Replace Face tool.
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8. Select the top face of the block to replace.

9. Select the net surface you just created to replace the face.

The top face of the solids is replaced.

10. Now render the block.

Geometric Characteristics
An replace face has no specific characteristics. To modify the 
Display and Attribute characteristics, select the face using the 
Design Explorer and choose Window>Edit Objects or double-
click on the face name.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On. See Chapter 24 for more information on the Design Explorer.

Parting Line Solid Tool

The Parting Line tool automatically applies draft angles to a collection of upper and 
lower surfaces. These faces are determined by the location of the parting line curve. 
This Designer Elements program uses curves as the parting entity so you must cre-
ate the curves before using the tool.

Rules
• The work plane cannot be parallel to the face or faces that you taper. The work 

plane defines the pull-direction or direction of draw, the direction the part ejects 
from a mold.
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• The taper is an angle that the face rotates relative to the neutral point. The value 
can be negative or positive and the rotation occurs relative to the work plane. 
Typically, positive values add material and negative values remove material. The 
graphics here illustrate the relationship between that work plane and the taper 
angles.

• If you have difficulty placing a draft on a solid try changing the work plane and 
attempting the draft again.

The left graphic shows an object with a parting line curve. The right graphic shows 
the object after using the tool.
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Using the Parting Line Solid Tool
1. Select the Parting Line tool. The Message Line reads: Parting Line Solid: Pick 

solid for parting line.

2. Select the solid that you want to part. The Message Line reads: Parting Line 
Solid: Pick curves for parting line.

3. Select the parting line curves. To select more than one curve be sure to hold 
down the SHIFT key before selecting the first curve.

While the solid is still selected you can change the upper and lower taper values. 
Press ENTER (Windows) or RETURN (Macintosh) and the part updates.

The Status Line contains the Upper Taper and the Lower Taper angle for the solid.

Modifying Parting Line Solids
You can modify the taper angles of your solid by choosing the taper in the Design 
Explorer for the solid and displaying the Edit Objects dialog box. You can modify 
the taper angle for the Upper and Lower Tapers. Click Apply to accept the changes.

Geometric Characteristics
A parting line solid is created by choosing a solid, intersecting curve and the upper 
and lower taper. It is made up of these characteristics according to Edit Objects: 
Draft angle and the solid face list with the tapers. This list is only available if you 
select the operation in the Design Explorer first and then display the Edit Object 
dialog box. See Chapter 24 for more information on the Design Explorer.

Deform Face Tool

The Deform Face tool allows you to deform surfaces and solid faces. When you 
select the Deform Face tool, a subpalette appears in the Message Line containing 
three tools, Deform with Gain, Deform to Point and Deform to Curve.
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All deform face examples will use the solid block here to 
illustrate each Deform Face tool.

After you have used the Deform Face tool and continue 
building you model and then you decide you want to edit 
the deformed face you must access the Edit Objects dialog 
box through the Design Explorer.

The Deform Face Edit Objects box contains the following options:

Gain The gain value is similar to a constraint pressure 
applied to the surface.  Use positive gain to inflate 
the surface and negative to deflate.  Depending on 
the stiffness and resolution of the surface practical 
gains can range anywhere from 0 to 1000000.

Stretch Factor The stretch factor controls the deformable surface's 
resistance to stretching. A surface with a large 
stretch value is said to be stiff. Deformable sur-
faces with large stretch values act like soap bub-
bles seeking to always minimize their area. This 
results in flatter looking surfaces that allow regions 
of rapid bending.
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Bend Factor The bend factor controls the deformable surface's 
resistance to bending.  Deformable models with 
large bend values act like elastic beams attempting 
to distribute regions of bending over large areas 
and typically generate very fair shapes. 

Resolution The resolution slider controls the precision of the 
resultant deformed shape by inserting additional 
control points to the surface.   Higher resolution 
values will show more detail for the given defor-
mation values. Lower resolution values calculate 
faster but with less detail.  When using the tangent 
and curvature options, start with a resolution factor 
of 80 for best results.

The following options apply to only to pressure deformations, the first tool icon.  It 
does not apply to deformations to a point or curve.  Be sure to use higher resolu-
tions when using the below options to insure tangency and curvature precision 
with the results.

No Tangency The No Tangency option deforms the face and 
allows the shape at the edges to deform.

Local Face Tangent The Local Face Tangent option deforms the shape 
but preserves the existing tangencies of the face.

Shared Faces Tangent Shared Face Tangent will modify all faces that 
share edges with the face being modified.  The 
modification will impose tangencies at all shared 
edges.

Shared Faces Curvature The Shared Face Curvature option will modify all 
faces that share edges with the face being modi-
fied.  The modification will impose curvature con-
tinuity at all shared edges.

Shared Faces Tangent Fixed The Shared Face Tangent Fixed option will only 
modify the selected face to be tangent to all faces 
that share an edge with the selected face.

Shared Faces Curvature FixedThe Shared Face Curvature Fixed option will only 
modify the selected face to be curvature continu-
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ous to all faces that share an edge with the 
selected face.

Deform Face with Gain Tool

This tool applies a pressure gain (negative or positive) to 
the selected surface or face. The gain displays in the Status 
Line. Large gains distort the object while small gains barely 
move the object. The pressure applies to the entire surface 
or face. You cannot specify a location for the deformation. 
Use the Deform Face to Point tool for that ability. The 
graphic shows the top face deformed using this tool.

Using the Deform Face with Gain Tool
1. Select the Deform Face tool.

2. Select the Deform Face with Gain 
tool in the Message Line. The 
Message Line reads: Deform Face: Pick face to deform with pressure.

3. Type the desired pressure in the Gain data field of the Status Line.

The number can be a positive or negative value.

4. Select the face or surface that you want to deform. 

The object is deformed. Render your object using any render option other than 
wireframe to view the deformation.

While the object is still selected you can enter a new value in the Gain data field 
and press ENTER (Windows) or RETURN (Macintosh) to change the gain.

The Status Line contains the Gain value for the deformation. 

Deform Face to Point Tool

This tool applies a pressure gain (negative or positive) to the selected surface or 
face passing through a specific point in space. You choose a point on the object to 
begin the deformation and the point’s final location. The left graphic shows the ini-
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tial point on a solid face and its final location. The right graphic shows the rendered 
object and the point.

The pressure gain displays in the Status Line.

Using the Deform Face to Point Tool
If you want the deformation to pass through a point not already in your drawing, 
create the point before using this tool.

1. Select the Deform Face tool.

2. Select the Deform Face to Point tool in the Message Line. The Message Line 
reads: Deform Face: Pick face to deform.

3. Type the desired pressure in the Gain data field of the Status Line.

4. Select the surface or face that you want to deform.

The Message Line reads: Deform Face: Pick location to deform from.

5. Click a location on the selected surface/face to set the point from which the 
face deforms.

The Message Line reads: Deform Face: Pick location to deform to.

6. Click the final location for the face point where the deformation begins.

The object deforms. Render your solid using any render option other than wire-
frame to view the deformation.

While the surface or face is still selected you can enter a new value in the Gain data 
field and press ENTER (Windows) or RETURN (Macintosh) to change the gain. 

You can move the point later by dragging it to a new location or using the Edit 
Objects dialog box when the point is selected. The deformed object automatically 
updates.
23-33



Solid Utilities and Features

23-34
The Status Line contains the Gain value for the deformation. 

Deform Face to Curve Tool

This tool applies a pressure gain (negative or positive) to the selected surface or 
face attached to a specified curve. You create the curve before using this tool. The 
left graphic shows the object with the curve. The right graphic shows the rendered 
image and the curve.

The pressure gain displays in the Status Line. A high enough gain forces the surface 
or face to pass through the curve. The curve is associative to the deformation. Mov-
ing the curve changes the associated deformation.

Using the Deform Face to Curve Tool
If you want the deformation to use a curve not already in your drawing, create the 
curve before using this tool.

1. Select the Deform Face tool.

2. Select the Deform Face to Curve tool in the Message Line. The Message Line 
reads: Deform Face: Pick face to deform to curve.

3. Type the desired pressure in the Gain data field of the Status Line.

4. Select the surface or face that you want to deform.

The Message Line reads: Deform Face: Pick curve constraint.

5. Select the curve.

The object is deformed. Render your object using any render option other than 
wireframe to view the deformation.

While the object is still selected you can enter a new value in the Gain data field 
and press ENTER (Windows) or RETURN (Macintosh) to change the gain.
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The Status Line contains the Gain value for the deformation. 

Geometric Characteristics
A deformable surface or face is created by selecting object and using pressure, a 
point or curve. This deformed surface or face is made up of the following character-
istics according to the Edit Objects dialog box: Gain, Stretch Factor, Bend Factor 
and Resolution. The dialog box also contains the Keep Boundary Tangents option.

Gain This field displays the pressure applied to the sur-
face or face. You can enter a different gain and 
click Apply.

Stretch Factor This field sets the resistance of the surface or face 
to the stretching. Higher values result in a flatter 
surface. Lower values result in a smoother surface. 
Enter a value yourself or use the slide to specify a 
factor.

Bend Factor This field sets the surface or face resistance to 
bending. Higher values prevent sharp radical 
changes to the surface. Enter a value yourself or 
use the slide to specify a factor.

Resolution This field sets the number of internal grids used to 
calculate the deformation. Higher values increase 
the influence of the bend and stretch factors to 
pressure gains. Lower values decrease the influ-
ence, providing quick results but few discriminat-
ing features to your surface. Enter a value or use 
the slide to specify a resolution.

Keep Boundary Tangents This option determines whether the edges of the 
surface or face remain tangent. When selected, the 
edges are tangent. This left graphic here shows the 
top deformed solid face without tangent edges. 
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The right graphics shows the deformed face with 
tangent edges.

To modify the Display and Attribute characteristics of the deformed surface or face 
select it using the Design Explorer and choose Window>Edit Objects or double-
click on the item’s name.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

See Chapter 24 for more information on the Design Explorer.

Draft Evaluation Feature
This Designer Elements program gives you the ability to evaluate the drafts of an 
object for molding purposes. This feature is available through the Verify menu and 
the advanced rendering capabilities.
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Draft Evaluation through Verify Menu
The Draft Angle in the Verify menu 
allows you to quickly evaluate the draft 
angles of a model.

All analysis colors are preset with this 
commands. If you would like to define 
your own settings, use the draft evalua-
tion shader through the Advanced Ren-
dering feature. See “Draft Evaluation 
through Advanced Rendering” on 
page 40.

This command evaluates the drafts of an 
object. When you select this command, the Draft Angle dialog 
box appears with the draft angle analysis, containing the histo-
gram with the analysis, the color spectrum and histogram data 
fields.

The dialog box contains the following elements:

Histogram Located to the left of the 
color spectrum in the dialog 
box, these horizontal bars 
represent the frequency of a 
draft angle using the color 
spectrum. The length of the 
bar represents the frequency.

This Designer Elements pro-
gram calculates this histogram 
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and displays it so that the entire graph fits into the 
dialog box area.

Color spectrum bar The section displays the color septum used to cre-
ate the histogram.

Histogram data fields The data fields display the maximum and mini-
mum values used to calculate the histogram. When 
you initially select the command, this Designer Ele-
ments program scans the surface(s) and sets the 
min and max fields for the draft angle analysis.

If you enter different values in the fields such that 
a large number of values fall outside of the speci-
fied range a red line appears at the end(s) where 
the values fall. All values are still calculated, even 
though they are not displayed due to the specified 
range.

If you make changes to the values, this Designer 
Elements program waits for two seconds of non-
action before recalculating the histogram, giving 
you time to change the values before the image is 
rendered again.

You can return the range initially displayed by 
clicking on the selected option again. (The option 
does not deselect when you do this.) Windows 
users can also reset the maximum and minimum 
values by right mouse clicking near the respective 
end of the spectrum.
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The graphic here is an example of a draft angle analysis.

Using the Draft Angle Command
1. Select the object.

2. Choose Verify>Surface Analysis>Draft Angle.

The dialog box displays with the analysis. Your geometry also displays the anal-
ysis.

3. To display a certain analysis/color area, place the pointer at the location over 
the color spectrum and click the mouse.
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Notice that a triangular indicator appears at the selected location and the related 
color highlights in the histogram. The same color highlights in black on your 
object.

4. To remove the triangular indicator click in the dialog box outside of the color 
spectrum bar.

5. Change the histogram values in the data fields and the histogram and analysis 
automatically recalculates.

Draft Evaluation through Advanced Rendering 
Using the Advanced Rendering feature you can specify your own draft angle set-
tings. When you display the Render Material Settings dialog box and choose the 
draft angle evaluation type, the dialog box appears.

The draft evaluation type contains the following attributes:

pull direction This specifies the direction the object is pulled 
from the mold. Enter the values for the pull direc-
tion or drag in the drawing area to have the values 
automatically entered. The asterisk next to the dX, 
dY and dZ names indicate this ability.

draft angle This specifies the draft angle required to pull the 
object out. This angle is usually 1°. Entering a 0 
results in the fail color zone disappearing when 
the scene is rendered.
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tolerance angle This specifies the degree tolerance added to the 
draft angle that still allows the object to be pulled 
from a mold but with difficulty. Entering a 0 results 
in the warning color zone disappearing.

pass color This specifies the color of the object for those 
areas where the draft angles are satisfactory. The 
surface normals fall between 90°+ draft angle + tol-
erance angle and 180° with the pull direction.

warning color This specifies the color that appears on the object 
when the surface normals fall between 90°+ draft 
angle and 90°+ draft angle + tolerance angle.

fail color This specifies the color of the object in those areas 
where the object cannot be pulled from the mold. 
The surface normals fall between 90° and 90°+ 
draft angle.

overhang color This specifies the color that appears for any part of 
the mold overhanging the object. An overhang on 
the mold prevents the object from being pulled 
from the mold.

In the graphic here the pass color areas are medium gray, the overhang color areas 
are black and the warning color areas are light gray.

Using the Draft Evaluation Feature
1. Double click on the object you want to evaluate to display the Edit Objects dia-

log box.
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A material must already have been placed on the object.

2. Click the Advanced button to display the Render Material Settings dialog box.

3. Select draft angle evaluation from the Shader Types list.

4. Specify the settings for the attributes.

5. Click OK to close the dialog box and save the settings.

6. Render your object using one of the photorealistic commands.

The object displays using your specified draft evaluation colors and values.

Assembly Modeling Tools
This Designer Elements program provides you with tools for doing assem-
bly modeling. These tools are located in their own tool palette. Choose 
Window>Assembly to display the tool palette.

The Assembly Modeling tools include: Assembly Connect, Assembly Mate, 
Assembly Align and Assembly Insert.

Each tool performs a particular oper-
ation involving two solids. The fol-
lowing error appears if you attempt 
to perform an operation on a single 
solid.

Assembly Connect Tool

The Assembly Connect tool to connects one solid to another at a specified connec-
tion point. The resulting part is associative. When you move one solid the other 
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moves as well to maintain the connection. The left graphic shows two solid objects. 
The right graphic shows the solids after connecting them. 

This tool supports connection points along object edges including start, end and 
middle and on locations recognized by the Drafting Assistant (center, midpoint, 
endpoint, etc.). You cannot select more than one solid to connect at a time.

Using the Assembly Connect Tool
1. Select the Assembly Connect tool. The Message Line reads: Assembly 

Connect: Pick solid to move.

2. Select the solid.

The Message Line now reads, Assembly Connect: Pick the connection 
point location on selected solid to move.

3. Using the Drafting Assistant select the connection point on the 
selected solid model.

The Message Line reads: Assembly Connect: Pick solid to move to.

4. Select the solid to which you are moving the first solid.

The Message Line reads: Assembly Connect: Pick new location on the selected 
solid for first solid selected.

5. Using the Drafting Assistant select the connection point on the selected solid to 
which you want to move the first solid selected.

The two solids are connected.

The Status Line contains no entries.

Geometric Characteristics
A connected assembly is made up of two solids. It does not include an characteris-
tics that are unique. To modify Display and Attribute characteristics of an assembly, 
select the object using the Design Explorer and choose Window>Edit Objects or 
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double-click on the face name. See Chapter 24 for more information on the Design 
Explorer.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

Assembly Mate Tool

The Assembly Mate tool mates planar faces. You can specify an offset distance 
between mated faces. The normals of the mated faces point in opposite directions. 
This tool only ensures that the selected faces are co-planar. If you want to align the 
faces, use the Assembly Align tool. The left graphic shows the two solids. The right 
graphic shows the solids after mating them.

Using the Assembly Mate Tool
1. Select the Assembly Mate tool. The Message Line reads: Assembly 

Mate: Pick solid face to mate.

2. Select the solid face you want to mate.

The Message Line now reads, Pick solid face to mate with.

3. Select the solid face you want to mate with.

The two solids are now mated.

4. If you want the first solid offset a certain distance from the second, enter a 
value in the Status Line data field and press ENTER (Windows) or RETURN 
(Macintosh).
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The objects are offset the specified distance but are still co-planar.

The Status Line contains the Offset data field.

Geometric Characteristics
A mate assembly is made up of two mated solid objects and includes an Offset 
value according to the Edit Object dialog box. To modify the characteristics of a 
mate assembly, select the assembly using the Design Explorer and choose Win-
dow>Edit Objects or double-click on the face name. See Chapter 24 for more 
information on the Design Explorer.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

Assembly Align Tool

The Assembly Align tool aligns a face of two solid objects and supports cylindrical, 
spherical and planar faces. This tool reorients the parts so that the faces are aligned 
in the same direction. The left graphic shows the two solid. The right graphic shows 
the solids after aligning them.
23-45



Solid Utilities and Features

23-46
Using the Assembly Align Tool
1. Select the Assembly Align tool. The Message Line reads: Assembly 

Align: Pick solid face to align.

2. Select the solid face you want to align.

The Message Line now reads, Assembly Align: Pick solid face to align 
with.

3. Select the solid face to align with.

The two solids are now aligned.

The Status Line contains no entries.

Geometric Characteristics
An aligned object is made up of two aligned solids and includes an Offset value 
according to the Edit Object dialog box. To modify the characteristics of an aligned 
object, select the object using the Design Explorer and choose Window>Edit 
Objects or double-click on the face name. See Chapter 24 for more information on 
the Design Explorer.

Display contains settings for Iso Lines and Silhouette. You can display Iso Lines by 
entering the value in the U and V data fields and clicking Apply. A grid of U and V 
lines will display on the object. You have three Silhouette settings, Smart, Off and 
On.

Assembly Insert Tool

The Assembly Insert tool aligns and mates the faces of two solid objects. The align 
faces must be cylindrical and the mate faces must be planar. This tool is very useful 
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for inserting bolts into holes. The left graphic shows two bolts and another solid. 
The right graphic shows the bolts inserted into the solid.

In the example, the bolt cylinder is aligned with the circular hole and its planar face 
mated with the planar face of the other solid though which the hole passes.

Using the Assembly Insert Tool
1. Select the Assembly Insert tool. The Message Line reads: Assembly 

Insert: Pick solid face to align.

2. Select the solid face you want to align.

The Message Line now reads, Assembly Insert: Pick solid face to align 
with.

3. Select the solid face to align with.

The Message Line reads: Assembly Insert: Pick solid face to mate.

4. Select the solid face you want to mate.

The Message Line now reads, Assembly Insert: Pick solid face to mate with.

5. Select the solid face you want to mate with

The first solid is now inserted into the second solid.

6. If you want the first solid offset a certain distance from the second, enter a 
value in the Status Line data field and press ENTER (Windows) or RETURN 
(Macintosh).

The objects are offset the specified distance but are still co-planar.

The Status Line contains the Offset data field.
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Geometric Characteristics
An inserted object is composed of two aligned and mated solids and includes an 
Offset value according to the Edit Object dialog box. To modify the characteristics 
of an inserted object, select the object using the Design Explorer and choose Win-
dow>Edit Objects or double-click on the face name. See Chapter 24 for more 
information on the Design Explorer.

Display contains settings for Iso Lines and Silhouette. Display Iso Lines by entering 
the value in the U and V data fields and clicking Apply. A grid of U and V lines will 
display on the object. You have three Silhouette settings, Smart, Off and On.
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This Designer Elements program provides a variety of editing commands to enable 
you to edit your geometry quickly an easily. Some commands deal with the place-
ment or your geometry like Cut and Align. Some commands change the appear-
ance of your object like Change Resolution. Still others change your geometry like 
Change Object Type and Edit Objects.

The chapter includes these sections:

• Basic Editing Commands

• Advanced Editing Commands

• Object Commands

• Verify Menu

Basic Editing Commands
These commands provide some standard editing features like: Cut, Paste, Undo and 
Redo.

Cut - CTRL+X (Windows); z +X (Macintosh)
This command in the Edit menu removes the selected object(s) and places them on 
the Clipboard. Each selection you cut or copy to the Clipboard replaces the previ-
ous Clipboard contents.
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Tech Note:

Do not use Copy and Paste to 
create an instance of a solid. 
By doing so you will break the 
parent/child relationship. 
(Cobalt™ and Xenon™ 
only)Use the Move tool 
instead. See Chapter 25 for 
more information.
Cutting Objects
1. Select the object to be cut.

2. Choose Edit>Cut.

Once you cut a selection you can paste it. You can use Cut and Paste to move 
geometry or text around the document or from one document to another. You can 
even paste the cut selection onto a document in a different application.

Moving Geometry with the Cut Command
1. Select the object(s) you want to move.

2. Choose Edit>Cut.

3. Display the location where you want the selection to appear in the drawing 
area, scrolling if necessary.

4. Choose Edit>Paste. 

The object appears in the center of the drawing area on the original layer on which 
it was created or onto the work layer if it’s from a different application. The object 
is selected so you can move it, if you want.

Copy - CTRL+C (Windows); z +C (Macintosh)
This command in the Edit menu places a copy of the selection onto the Clipboard 
without deleting the original selection. You can paste the copy elsewhere in the 
current document or into a different document. You can even paste the copied 
selection into a document created with a different application.

Copying Objects
1. Select the object(s) to be copied.

2. Choose Edit>Copy.

The selection goes on the Clipboard and it remains in the current document.

Copy Pict/Copy Bitmap
By using the Copy Bitmap (Windows) or Copy Pict (Macintosh) command you can 
specify a region to copy as a Raster image. You can then paste the image back into 
the same document, another document or a different application.
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Tech Note:

You cannot use the Copy and 
Paste commands to copy 
entries in data fields like in 
the Status Line and dialog 
boxes. For Windows, press 
the right mouse button and 
use the commands in the 
menu. For Macintosh, use 
z +C to copy and z +V to 
paste.
Paste - CTRL+V (Windows); z +V (Macintosh)
This command in the Edit menu pastes a copy of the Clipboard contents onto the 
center of the drawing area. The Clipboard contents are not changed when you use 
the Paste command. 

You can also paste the selection into another document or into a document created 
with another application.

If you want to create an even distribution of geometry, use the Linear Duplicate tool 
or the Polar Duplicate tool both are located in the Transformation tools palette.

Rules:
1. If the object was cut or copied from a Designer Elements program document, 

when it is pasted into another Designer Elements program document it goes on 
the work layer regardless of the layer from which it was cut or copied. A pasted 
selection retains its original attributes.

2. Objects cut or copied from non-Ashlar-Vellum documents are pasted onto the 
work layer.

The Clipboard
The Cut and Copy commands place a copy of the selected object on the Clipboard. 
The Clipboard is a buffer—a temporary storage place that holds the last cut or cop-
ied selection. The contents of the Clipboard are objects, not bitmaps or picts (unless 
you chose Copy Bitmap/Pict).

Erasing/Deleting Geometry
This Designer Elements program provides two methods for erasing objects:

• You can select the object(s) then press the BACKSPACE (Windows) or DELETE 
(Macintosh) key. (You can retrieve what you deleted with the Undo command.)

• You can select the object(s) then choose Edit>Cut. (You can retrieve what you 
cut by using the Paste command, as long as you have not cut or copied anything 
else.)
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If you try to delete an object that is parent in a parent/child relationship, this warn-
ing message will appear (Cobalt™ and Xenon™ only):

When you delete objects in this Designer Elements program the data is still retained 
in the file until you delete again. If you delete objects before closing a file, perform 
the operation again to ensure that the data is removed.

Undo - CTRL+Z (Windows); z +Z (Macintosh)
This command in the Edit menu reverses the last action. You can undo an infinite 
number of times in this Designer Elements program. When you choose Undo the 
last action taken is displayed next to the command.

You can Undo actions that create and edit geometry and text but not actions that do 
not change the contents of the drawing such as resizing the window or quitting.

If you are using a tool which involves a multi-step process, such as creating a 3-
Entity Fillet, choosing Undo reverts to the beginning of the process. Some activities 
can be terminated by pressing the ESC key.

Redo
This command in the Edit menu reverses the Undo command. You can redo an infi-
nite number of times in this Designer Elements program. When you choose Redo, 
the last action taken is displayed next to the command.

You can Redo actions that create and edit geometry and text but not actions that do 
not change the contents of the drawing such as resizing the window or quitting.

Advanced Editing Commands
These commands provide more specific editing features/functions involving loca-
tion, selection and display.
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Change Resolution
This command, located in the Edit menu, changes the display resolution of curves, 
surfaces and solids.

A higher resolution means that this Designer Elements program uses more line seg-
ments to display curves on the screen so they look smoother but take longer to 
draw.

For surfaces and solids a higher reso-
lution also means that this Designer 
Elements program uses more facets 
to display the objects. You can con-
trol the number of isolines used to 
display surfaces with this command.

The dialog box contains the follow-
ing options:

Resolution This 
section contains radio buttons for five resolution 
types Course, Medium, Fine, Very Fine and Super 
Fine.

Iso Lines This section contains the data fields for U and V 
isopram (Iso) lines and the Force U=V check box.

The U and V data fields allow you to set the num-
ber of iso lines drawn for a surface. Iso lines are 
constant parameter curves that lie on a surface typ-
ically defined in parameter space. The parameter 
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space coordinate system uses U and V coordinates 
where U = horizontal and V = vertical. A zero (0) in 
both fields turns off Iso lines. The appropriate U/V 
values may enhance the visual appearance of the 
surface at the expense of drawing speed. The let-
ters, U and V are industry standard space coordi-
nates.

The Force U=V check box automatically sets equal 
number of U and V lines. Entering a new value in 
one automatically changes the other isoline value.

Show Silhouettes This check box controls whether this Designer Ele-
ments program draws the silhouette edges of 
objects. Silhouette edges are view dependent and 
can cause a significant reduction in drawing speed. 
A check in the box turns on the silhouette.

OK Click this button to close the dialog box and save 
the new settings.

Cancel Click this button to close the dialog box without 
saving the changes.

Using the Change Resolution Command
1. Select the object whose resolution you want to change.

2. Choose Edit>Change Resolution. The Object Resolution dialog box appears.

3. Select the desired resolution.

4. Click OK to save the resolution and close the dialog box.

Change Layer
This command in the Edit menu moves selected objects to a different layer and cre-
ates new layers.

Using the Change Layer Command
1. Select the object that you want to move to a different layer.
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2. Choose Edit>Change Layer. The following Change Layer dialog box appears:

Click on the pull-down menu and select the layer to which you want to move the 
selected object. If the layer doesn't exist click the Create New Layer button. A 
new layer appears in the layer field. Enter a new name if you wish.

Click OK to close the dialog box. The selected object is now placed on the 
selected layer.

Grouping Objects
A group is a collection of objects or short 
cuts that this Designer Elements program 
treats as one unit. When you move a 
group all members of the group move as 
a single unit. If you delete a group all 
members are deleted.

Group Command
This command located in the Layout 
menu includes a submenu with these 
commands: Group, Ungroup, Lock and 
UnLock.

Using the Group Command
1. Select the objects to be grouped.

2. Select Layout>Group>Group.

Creating temporary groups is useful when moving multiple objects. You can drag a 
selection fence around several objects to treat them as a single unit while they are 
selected.

This Designer Elements program supports nested groups. You can create a group 
and then include it in a second group with other objects or groups.

If you want to add new objects to an existing group you have two options. If you 
select the group and the new object and choose the Group command, this Designer 
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Elements program creates a group within a group. If you want all of the objects to 
be in a single group, follow these directions:

1. Select the group.

2. Choose Layout>Group>Ungroup. The geometry is ungrouped and the indi-
vidual objects remain selected.

3. Hold down the SHIFT key and select the geometry you want to add to the 
group.

4. Choose Layout>Group>Group.

You can follow a similar procedure to remove members from a group.

Grouping Rules
• Grouped objects cannot be extruded, revolved or modified.

• If you change the color of a group and then ungroup the objects, all individual 
objects retain the new color.

• When grouping objects the Group command now ignores objects that only have 
a point selected. In the graphic below, the three top objects are completely 
selected and only one control point for the bottom block. When you use the 
command the control point is ignored. This is helpful when you have many 
objects located so closely to each other that it might be difficult to select the 
desired objects without selecting portions of others.

• If you are grouping objects on different layers, the group layer is the current 
work layer. However, if you ungroup the objects, the objects return to their orig-
inal layer.
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Tip:

The lock command not only 
prevents any changes to the 
locked object, it prevents 
them from being selected.
Ungroup Command
The Ungroup command separates selected grouped objects or short cuts into their 
individual components. If the group contains objects that were originally on differ-
ent layers than the group layer. When ungrouped, the objects return to their origi-
nal layer.

Using the Ungroup Command
1. Select the group.

2. Choose Layout>Group>Ungroup.

Lock Command
You can lock any object or short cut. Once it is locked you cannot modify, select, 
translate, rotate or in any way change the position or shape of a locked object.

Using the Lock Command
1. Select the objects to be locked.

2. Choose Layout>Group>Lock.

If you want to protect an entire document from modification:

1. Choose Edit>Select All.

2. Choose Layout>Group>Lock.

Selected objects can also be locked by clicking the locked box in the Edit Objects 
dialog box.

Unlock Command
You can unlock any Designer Elements program object or short cut that has previ-
ously been locked.

1. Choose Layout>Group>Unlock.

2. Select the locked object by clicking on the object or dragging a selection fence 
around it. The locked object is unlocked and selected.

Arrange Command
The Arrange command in the Layout menu allows you reposition overlapping 
objects. This is a common command for graphics programs and is helpful in editing 
complicated drawings.
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This command displays a submenu of the following commands: Move Forward, 
Move to Front, Move to Back and Move Backward.

Move Forward Moves the selected object up one position in the 
display.

Move to Front Moves the selected object to the top (or in front) of 
all other objects in the display.

Move to Back Moves the select object to the back of the display.

Move Backward Moves the selected object down one position in 
the display.

Align Command

This command in the Transformation tool palette moves selected objects, including 
text, relative to other objects.

The Align command includes a submenu with these options, Left Sides, Right Sides, 
Tops, Bottoms, Centers Horizontal, Centers Vertical, To Grid, Spaced vertical and 
Spaced Horizontal.

The following figure illustrates each of these options.

Left Sides Aligns the left sides of selected objects.
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Right Sides Aligns the right sides of selected objects.

Tops Aligns the tops of selected objects.

Bottoms Aligns the bottoms of selected objects.

Centers Horizontal Aligns the center points of selected objects to the 
same x location.

Centers Vertical Aligns the center points of selected objects to the 
same y location.
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To Grid Aligns the left and bottom portion of an object to 
the closest grid point. The grid does not have to be 
displayed to use this option.

Spaced Vertical Equally distributes the selected objects relative to 
each other.

Spaced Horizontal Equally distributes the selected objects relative to 
each other.

Using the Align Command
1. Select the objects to align.

2. Then choose the alignment tool from the Transformation tool palette. The Mes-
sage Line reads: Enter Alignment Point.

3. Choose the point at which you want the objects to align.

Object Commands
These commands allow you to modify various aspects of your geometry including 
direction, type and size.

Change Direction
This command in the Edit menu reverses the orientation of curves and surfaces.

You may sometimes find it necessary to change the direction of curves to straighten 
twisted surfaces. Changing the direction of surfaces reverses their normals which 
can change the way rendered surfaces respond to lighting.
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Referral:

This command can impact 
the rendering of your object. 
See Rendering Options and 
Flip normals in Chapter 33 
for more information.
The graphic below shows the direction of a surfaces using the Edit>Change Direc-
tion command. The right graphic shows the changes made by using Change Direc-
tion.

Using the Change Direction Command
1. Select the object whose direction you want to change.

2. Click Edit>Change Direction.

This Designer Elements program displays temporary arrows along the object to 
show its direction. You can pick View>Redraw Screen to make disappear.

Change Object Type
This command in the Edit menu enables you to change an object's type. This is 
helpful for editing as well as exporting geometry to software that may not support a 
particular type of entity. After using this command for a particular operation, this 
Designer Elements program remembers the selected conversion type (Curves, Sur-
face, Mesh or Solids for a Solid object) until you change the option type.

With this command you can convert:

• Solids to meshes, surfaces or curves

• Surfaces to meshes, surfaces or curves

• Curves to lines, polylines or splines

When you select this command a dialog 
box similar to the one below appears:

The dialog box contains the following stan-
dard options:

Selected Object section This section contains the conversion options. The 
options differ depending on whether you select a 
wireframe, surface or solid object.

Delete Originals Selecting this box deletes the original objects fol-
lowing the object conversion.
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Use Work Layer Selecting this box places converted objects on the 
work layer.

OK Click this button to convert the object.

Cancel Click this button to Cancel the command.

If you are converting a model con-
taining links before the conversion 
proceeds, the following dialog box 
displays asking you to confirm your 
awareness that the links will be 
removed by completing the conver-
sion.

Changing Curves 
When you choose the Change Object Type 
command after selecting a curve this dialog 
box appears:

You have the option to convert your curve to 
Lines Splines. If you want to delete the origi-
nal curve click the Delete Originals check 
box.

Curves to Lines Option
When the Lines option is selected you 
can convert a curve or set of curves to 
lines. You can use this command to 
change a spline into a collection of lines 
or smart polygons into individual lines.

If the Delete Originals option is checked 
this Designer Elements program removes 
the parent curve after exploding it, leaving only the curves.
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Curves to Polylines Option
When the Polylines option is selected, you convert curves or a 
set of curves into polylines. The graphic here is an example of a 
circle converted into a polyline. Unlike the line option which 
would convert a circle into multiple line segments, this option 
converts the circle into one polyline.

Curves to Through Spline Option
When the Through Spline option is selected you convert a 
line, conic, arc, circle, or ellipse into a Through spline. A 
Through spline’s shape, slope and control points can be 
edited. This Designer Elements program fits the resulting 
spline to within a 0.001 drawing unit tolerance of the original 
curve. If the Delete Originals option is checked, this Designer 
Elements program removes the parent curve after exploding 
it, leaving only the splines.The graphic here is an example of 
a circle converted into a Through spline.

Curves to Vector Spline Option
When the Vector Spline option is selected you convert a line, conic, arc, circle, or 
ellipse into a vector spline. A vector spline’s shape, slope and control points can be 
edited. This Designer Elements program fits the resulting spline to within a 0.001 
drawing unit tolerance of the original curve. If the Delete Originals option is 
checked, this Designer Elements program removes the parent curve after exploding 
it, leaving only the splines.

The convert curve command is also useful for removing excessive numbers of con-
trol points from constrained splines. The left graphic below shows a spline contain-
ing 50 points. The Change Object Type command reduces that number to five while 
maintaining a tolerance of 0.001 inches shown in the right graphic.

After selecting a type click OK and the object will convert.
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Curves to Bezier Option
When the Bezier spline option is selected you convert a line, 
conic, arc, circle or ellipse into a bezier spline. The bezier 
splines shape can be edited by moving the control points and 
the slope of the spline at those points. If the Delete Originals 
option is checked, this Designer Elements program removes the 
parent curve after exploding it leaving only the splines.

Converting Text to Curves
1. Create text using one of the Text tools.

2. Choose Edit>Change Object Type.

3. In the Change Type dialog box choose 
curves.

4. Click OK.

Each letter of the text converts into a 
closed grouped curve. You can now 
perform any curve operation on the text 
curve.

Changing Surfaces
When you choose the Change Object Type command after selecting a surface, this 
dialog box appears:

Surface To Curves Option
If you select the Curves option this Designer Elements program converts the surface 
into a collection of editable vector splines. You can modify the shape, slope and 
location of the spline control points. If the Delete Originals option is checked, this 
Designer Elements program removes the parent surface after exploding it leaving 



Object Commands
only the curves. The resulting curves may consist of lines, arcs, circles, ellipses or 
splines.

Surface To Surfaces Option
Selecting the Surfaces option explodes a surface composed of multiple faces into 
discrete surfaces. Once the surface is exploded you can edit individual surfaces; 
move them to a different layer, transform or remove them.

Surface To Mesh Option
If you check the Mesh option the surface is converted to a triangular mesh. Meshes 
are useful for sharing this Designer Elements program data with applications that 
cannot import precise surfaces. Exploding surfaces to mesh allows you to edit indi-
vidual vertices. 

The precise mathematical representation of a solid or surface must often be con-
verted into a collection of imprecise planar facets. These facets, for example, may 
be used to export a model to the STL format, and when changing a solid or surface 
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(Edit>Change Object Type) to a mesh. The amount error that results from this 
conversion is controlled by the settings in the mesh parameters dialog box.

During the conversion vertex points are distributed on the surface or solid. These 
vertices are then grouped into 3-sided and 4-sided facets. The conversion is 
deemed acceptable when the generated vertices and facets satisfy the settings. The 
five available settings are: Surface Deviation, Normal Deviation, Edge Length, 
Aspect Ratio and STL Facets. These settings are defined in the sections below.

Change the facet settings as needed in the dialog and then click the Update button 
to see the number of facets and vertices generated. Determining the combination of 
settings that will work for a given situation can be a little bit of an art. If one setting 
becomes too tight the other settings will have no effect. If one setting becomes too 
loose, it will have no effect.

Keep in mind that under “real” circumstances the settings are used by the faceting 
algorithms if possible. It is often not possible to satisfy all settings simultaneously. 
In this situation the algorithm decides which settings to “loosen”.

When you explode a surface into a mesh, the mesh dialog box appears with charac-
teristics for specifying the resolution of the mesh.

The dialog box includes:

Aspect Ratio Sets the maximum ratio between triangle edges. It 
prevents forming long narrow triangles. Enter a 
value in the field or use the slide to set the value.

Surface Deviation Sets the maximum acceptable distance between 
the facet and the surface represented by the mesh. 
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Enter a value in the data field or use the slide to 
set the value.

Normal Deviation Sets the maximum angular deviation between adja-
cent facets. 20 degrees is the default. Use 10 for 
extremely dense meshes. Enter a value in the data 
field or use the slide to set the value.

Edge Length Sets the maximum acceptable edge length for fac-
ets. Enter a value in the data field or use the slide 
to set the value.

Mesh Count This section includes the Update button and infor-
mation on the Number of Facets and Vertices. Click 
the Update button to calculate the approximate 
number of facets based on mesh characteristics. 
The Number of Facets and Vertices information 
display questions marks until you click the Update 
button. The calculated values replace the question 
marks.

Smoothing Selecting this option creates facets that are regu-
larly spaced. The left graphic here shows an object 
without smoothing. The right shows the object 
with mesh smoothing.

Default Params Click this button to revert the mesh parameters to 
this Designer Elements program default values.

STL Facets This setting will force the facets generated to be 
suitable for stereolithography usage. This setting is 
usually used when exporting STL files.
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The mesh in the left graphic below was created with a Normal Deviation of 10 and 
a Max Edge Length of 0.1. The right graphic was created with a Normal Deviation of 
20 and a Max Edge Length of 0.

After setting the desired values, 
click OK and the object will con-
vert. If you select more than one 
surface to convert the following 
dialog box appears:

Click Yes to use the same mesh 
conversion values for all selected 
surfaces.

Changing Solids
When you choose the Change Object Type 
command after selecting a solid this dialog 
box appears:

Solid To Curves Option
If you select the Curves option, this Designer Elements 
program converts the solid into a collection of editable 
vector splines. You can modify the shape, slope and 
location of the spline control points. If the Delete Orig-
inals option is checked, this Designer Elements pro-
gram removes the parent solid after exploding it 
leaving only the curves. The resulting curves may be 
lines, arcs, circles, ellipses or splines.
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Solid to Surfaces Option
Selecting the Surfaces option explodes a solid into 
discrete surfaces. Once the solid is exploded you can 
edit individual surfaces, move them to a different 
layer, transform or remove them.

Solid To Mesh Option
If you check the Mesh option the solid converts to a 
triangular mesh. Exploding solids to meshes allows 
you to edit individual vertices. 

When you explode a solid into a mesh, the mesh dialog box appears with charac-
teristics for specifying the resolution of the mesh:

The dialog box includes:

Aspect Ratio Sets the maximum ratio between triangle edges. It 
prevents forming long narrow triangles. Enter a 
value in the data field or use the slide to set the 
value.
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Surface Deviation Sets the maximum acceptable distance between 
the facet and the surface represented by the mesh. 
Enter a value in the field or use the slide to set the 
value.

Normal Deviation Sets the maximum angular deviation between adja-
cent facets. 20 degrees is the default. Use 10 for 
extremely dense meshes. Enter a value in the data 
field or use the slide to set the value.

Edge Length Sets the maximum acceptable edge length for fac-
ets. Enter a value in the data field or use the slide 
to set the value.

Mesh Count This section includes the Update button and infor-
mation on the Number of Facets and Vertices. Click 
the Update button to calculate the approximate 
number of facets based on mesh characteristics. 
The Number of Facets and Vertices information 
display questions marks until you click the Update 
button. The calculated values replace the question 
marks.

Smoothing Selecting this option creates facets that are regu-
larly spaced. (See the graphic included with the 
Surface to Mesh conversion in an earlier section for 
a smoothing effect example.)

Default Params Click this button to revert the mesh parameters to 
this Designer Elements program default values.

STL Facets This setting will force the facets generated to be 
suitable for stereolithography usage. This setting is 
usually used when exporting STL files.
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After entering the desired values, click OK and the object will convert. If you select 
more than one solid to convert, the following dialog box appears:

Click Yes to use the same mesh conversion values for all selected solids.

Solids To Solids Option
You can use the Solids option to break one solid up into several smaller units. This 
option comes in handy if you want to edit only one part of a larger solid.

If you want to find out the mass properties of several solids as if they are combined 
into one, you can first unite them and analyze their properties. After your measure-
ment is completed use the Change Object Type Solid option to break the part back 
into individual pieces.

Change Dimensions
When you choose the Change Object Type 
command after selecting a dimension this 
dialog box appears.

Use this to change dimensions into lines and 
text. This is helpful when exporting files 
with dimensions that may not be supported 
by the other software.

Simplify Object
This command in the Edit menu will examine the selected objects and if the entity 
falls within tolerances, will do the following:

• Convert zero length curves to points

• Convert circular splines to arcs or circles

• Convert straight splines to lines
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• Convert NURB surface or solid faces to analytics

Potential NURB shapes converted to analytic shapes include cylinders, cones, 
speres, tori and planes. Candidate shapes for simplification include data imported 
via IGES, Step, Rhino and Alias. Also some surfaces created in this Designer Ele-
ments program are initially created as NURBS and may simplify to an analytic 
shape.

Some advantages of analytic representation of shapes over NURBS are analytic 
operations are considered exact whereas NURBS are precise. Analytic operations 
execure much faster internally and take up less memory in RAM and less space 
when the file is saved. For example, an IGES file can be reduced by half after using 
the Simplify Object command.

Note: Using the Simplify Objects command may cause loss of part history on com-
plex objects.

Edit Objects
This command in the Window menu edits selected objects by changing individual 
characteristics such as: weight, layer, resolution and other specifications. 

You can display the Edit Objects dialog box in two ways:

• Select the object and choosing Window>Edit Objects

• Double-click on the object.

Note: You cannot double-click on editing operations performed on a solid such as 
blending, placing holes, shelling etc. except from within the Design Explorer 
(Cobalt™ and Xenon™ only). (See a later section for information on the Design 
Explorer.)

Changes made through this dialog box can be reversed with the Undo command.

When you choose Edit Objects a dialog box similar to the one here displays con-
taining between two and four possible tabs: Geometry, Display, Attributes and Mate-
rial.



Object Commands
Geometry Tab
All tools that create geometry will include a 
geometry tab in the Edit Objects dialog box.

The specific characteristics listed depend on the 
object selected. The object selected in this case 
was a line and includes the following characteris-
tics: Length, Angle, End 1 (X, Y and Z values) and 
End 2 (X, Y and Z values). All values appear in 
this dialog box as whole numbers and decimals, 
depending on the decimal setting in Preferences.

Entering Values
You can enter values in this dialog box in any 
units desired. These will automatically be con-
verted into the units you set in Preferences. See 
Chapter 6.

When units are set to feet and inches (in the Prefernces dialog box) it’s important to 
be aware of the following rules:

• All numbers are assumed to be feet unless accompanied by the unit symbol like 
“ for inches. Entering a 1.5 in the field is read as 1.5 feet. If you want 1.5 inches, 
enter 1.5”, 1.5i, 1.5in, 1.5 inch, etc.

• If you want to enter fractions of inches, each entry must include the unit symbol. 
For example, 5 feet 6 5/8 inches must be entered 5 6” 5”/8. Internally this is con-
verted as 5’ + 6” + 5”/8. If the inch symbol is not included with the fraction, 5/8 
will be interpreted as a fraction of a foot.

Drawing views created for Layouts have their own Geometry page. Some editing 
operations like Split Solid contain no specific geometry characteristics and therefore 
do not have a Geometry page.

Every chapter in this manual that deals with this Designer Elements program objects 
includes a Geometric Characteristics section listing all characteristics specific to the 
object. Those features that do not have specific characteristics are noted accord-
ingly.
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Display Tab
This page in Edit Objects appears for surface and 
solid objects only.

The graphic shows the characteristics included in 
the Display page for a surface object and 
includes: Iso Lines and Silhouette.

The number of Iso Lines allows you to control 
the isopram lines drawn for a surface. These Iso 
(isopram) lines are constant parameter curves that 
lie on a surface, typically defined in parameter 
space. The parameter space coordinate system 
uses U and V coordinates, where U = horizontal 
and V = vertical. A zero (0) in both fields turns off 
Iso lines. The appropriate U/V values may 
enhance the visual appearance of the surface at the expense of drawing speed. The 
letters U and V are industry standard space coordinate identifiers.

The Silhouette option controls whether this Designer Elements program displays sil-
houette edges of objects. Silhouette edges are view dependent and can cause a sig-
nificant reduction in drawing speed. The pull-down menu displays the options: On, 
Off and Smart. Smart Silhouettes display a silhouette only if it does not degrade the 
display performance.

Attributes Tab
This tab displays a standard list of characteristics for 
the selected object.

The attributes include:

Name Displays the name of 
the object. You can 
enter a new name if 
you wish.

Resolution Displays the resolu-
tion setting for the 
object. You can 
select any of the 
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options listed in the pull-down menu. See the 
Object Resolution section for more information.

Color Displays the color of the selected object. You can 
choose any color for your object.

If you object is on a layer with an override color, 
the object will display in the override color but the 
Edit Objects color field will display the actual color 
of the object.

Control Pts Displays the status of the control points, hidden or 
visible. You can choose either setting.

Layer Displays the layer where the object is located. You 
can place the object on any available layer.

Locked Choosing this option locks the object preventing it 
from being selected or modified. This is same 
operation that occurs when choosing Lay-
out>Group>Lock.

For wireframe objects this tab also includes: Pattern, Weight, Arrow Start and Arrow 
End.

Material Tab
This tab appears for objects that have rendering mate-
rials applied to them. 

The material characteristics include the following:

Reflectivity This field sets the 
material’s reflectiv-
ity. Values can be 
entered between 
zero (0) and one (1). 
Entering a zero in 
the field renders a 
flat finish. Entering a 
one in the field ren-
ders a mirrored finish.
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Transparency This field sets the transparency of the material. Val-
ues can be entered between zero (0=transparent) 
and one (1=opaque). This option only works cor-
rectly when objects are rendered with ray trace 
rendering commands.

Roughness This field sets the roughness of the material. Values 
can be entered between zero (0) and one (1).

Scale This field sets the scale of the material. Typically 
scale increases the size of the detail. Values can be 
entered equal to or greater than zero (0).

Texture File This field displays the selected material. The pull-
down menu lists all images in the texture folder. 
For those materials that do not support textures 
this menu is not available.

Enable Shadow Cast This check box allows you to specify if an object 
casts shadows. This is valuable for reducing the 
shadows present in complex drawings. When 
checked the selected object casts shadows.

Enable Shadow Receive This check box allows you to specify whether an 
object will receive shadows from other objects. 
This ability is valuable for reducing the number of 
shadows present in complex drawings. When 
checked the selected object receives shadows.

Double Sided Facets This check box provides you with additional ren-
dering control for surfaces. Objects with normals 
facing away from the line of sight are not ren-
dered. When checked all objects are rendered 
regardless of the normal direction. 

Select this option for objects that cause light refrac-
tion like glass. When left unchecked facets on the 
back side of the glass are ignored resulting in an 
inaccurate rendering.

Is Backdrop Object This check box allows you to optimize rendering 
calculation time for an object like a wall, that func-
tions only as a backdrop for other objects. Since 
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the object automatically receives light due to its 
large size, this Designer Elements program does 
not need to spend much time performing light ray 
calculations.

Advanced button Clicking this button displays the Render Material 
Settings dialog box. Use this dialog to change the 
advanced rendering settings used on the selected 
object. See Chapter 33 for a detailed description of 
these settings

Using the Editing Objects Command
1. Select an object to edit.

2. Choose Window>Edit Objects and the dia-
log box appears.

The dialog box contains between two or four 
possible tabs depending on the object you 
select, Geometry, Display, Attributes or Materi-
als.

3. Click on the tab containing the desired infor-
mation.

4. Change the information in an entry box by 
double-clicking the entry data field and typ-
ing a new entry. Do not press ENTER (Win-
dows) or RETURN (Macintosh). Many data 
fields have pop-up menus for selection. Press the down arrow and then drag to 
the selection you want.

5. Make changes in other entry fields as required.

6. Click Apply and the changes automatically occur on your selected geometry.

7. Click Close to close the Edit Objects dialog box. 

You can use Undo or Redo to reverse changes made through this dialog box.

Coordinates are measured in the units set in the Units page of Preferences.

If you are doing a lot of editing you may want to leave the Edit Objects dialog box 
displayed. That way you can select the object, make the changes in the dialog box, 
click Apply and then go on to the next object. 
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If more than one object is selected when you choose Edit Objects, only the common 
information is displayed. Entries are blank when the information isn’t common. For 
example, if you select two concentric circles, the center will be displayed in the Edit 
Objects box but the diameter box will be blank.

If you select several objects and then choose Edit Objects, all of the objects will 
reflect the changes you make in the dialog box. For example, if you select all 
dimensions and change the text entry in the Edit Objects dialog box to 2, all the 
dimensions will display a 2.

Moving an Object to a Different Layer
1. Select the object(s) to be moved.

2. Choose Window>Edit Objects.

3. Click the arrow for the Layer entry field.

4. Pick the layer from the list.

5. Choose Apply.

Links
Many of the objects in this Designer Elements program are associated with other 
objects in parent-child relationships. Associative objects retain a history of how they 
were created and a set of rules that define their geometric description. If you mod-
ify a parent object (an object that defines another object), this Designer Elements 
program automatically regenerates the dependent or child object. For example, 
consider a skinned surface that is defined by two lines. If you modify one of the 
lines, the skinned surface will automatically regenerate.

This Designer Elements program provides two commands for dealing with Links: 
Resolve and Remove.

Resolve Links Command
This command is in the Edit menu. As you modify an entity that is part of a parent-
child relationship the word, Edit in the menu bar and the command, Resolve Links 
highlight in red.

In most cases, this Designer Elements program will resolve the links in a parent/
child relationship automatically and the words will un-highlight when finished. If 
the words stay red, select Edit>Resolve Links to force the program to resolve the 
relationship.
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Referral/Tech Note:

Do not use the Remove Links 
command to remove a fea-
ture from the history tree. 
This removes all parent/child 
associativity for your geome-
try. Use the Design Explorer 
instead. See a later section 
for information on the 
Design Explorer.
If you attempt to save a file containing links that are not resolved, the following 
warning appears:

Remove Links Command
The Remove Links command in the Edit menu deletes all associative links between a 
parent and child.

When you select the command the following warning appears:

This warning reminds you that the selected object has a parent/child relationship to 
another object and that deleting this object not only deletes the history tree but can-
not be undone.

Press the Yes button to continue the Remove Links command or No to discontinue.
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Design Explorer
This Designer Elements programs 
Design Explorer is a valuable 
feature for traversing your draw-
ing's design history. It offers a 
Windows-style tree structure with 
expandable branches that dis-
play, in a hierarchical fashion, 
the associative geometry used in 
the creation of all of the entities 
in the drawing.

The figure shows a solid cube with a hole in one face. The Design Explorer win-
dow identifies the entity as a part and shows that it consists of a block, the cube 
and a hole feature. As you click on items in the tree the corresponding part in the 
drawing will highlight.

If you select an item in the Design Explorer when the Edit Objects dialog box is dis-
played, the dialog box automatically updates to reflect the selected item.

Child Links
The child links feature organizes all persistent 
parts of your model in the Design Explorer. If 
you place material or decals on your model or 
create drawing views they group separately from 
any geometry operations under the Child Links 
category.

This frees you up to modify your part without 
having to replace material or recreate views.
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Design Explorer Commands
The Design Explorer also includes several of its 
own menu of commands. For Windows users, (and 
Macintosh users with a two button mouse) click the 
right mouse button on the feature name to display 
the menu. For Macintosh users, hold down the 
CONTROL key and click on the feature. Depending 
on where you right click and when, one of the fol-
lowing menus appear:

Rename
The Rename command lets you rename any of the entities. It displays this dialog 
box.

Enter the new name and click OK.

Suppress Feature/Unsuppress Feature
These commands allow you to turn off or on a particular feature in the solid history 
tree. They toggle between each other depending on whether an operation is sup-
pressed. 

When a feature is suppressed, this Designer Elements program rebuilds the solid as 
if the operation never occurred. This feature can be unsuppressed and reintegrated 
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into the part at a later time. The graphic below shows a part and the Design 
Explorer open. 

This next graphic shows the same part with all of the holes suppressed. Notice the 
“S” displayed over the operation icon in the Design Explorer.
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Some uses for feature suppression include the following:

• FEA Models: when creating FEA (Finite Element Analysis) models you may not 
want certain features included in the analysis.

• Part Regeneration: removing certain features may speed up rebuilding the part, 
including display time.

• Shelling: if a part fails to shell you can turn off blends and other features that 
may prevent a successful shelling operation. Then, using the Reorder Feature 
command, you can move the shelling operation before the suppressed feature in 
the history tree so that shelling succeeds. Finally, you can unsuppress the 
selected feature using the Unsuppress Feature command.

Using the Suppress Feature Command
1. Select the model which contains the feature you want to suppress.

2. Choose Window>Design Explorer to display the history tree.

3. Expand the tree to display the desired feature by clicking on the plus (+) sign 
to the left of the part name.

4. Select the desired feature.

The feature highlights.

5. Click the right mouse button (Windows) or 
press the CONTROL key (Macintosh) to dis-
play the Design Explorer menu.

6. Choose the Suppress Feature command.

The feature suppresses and your model 
regenerates without the feature. The 
Design Explorer now displays an “S” over 
the operation icon.
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Using the Unsuppress Feature Command
The Unsuppress Feature command replaces the Suppress Feature command in the 
Design Explorer menu for suppressed features only.

1. In the Design Explorer select the suppressed feature.

2. Click the right mouse button (Windows) or press the CONTROL key (Macin-
tosh) to display the Design Explorer menu.

3. Choose the Unsuppress Feature command.

The feature reappears and the model regen-
erates. The feature icon no longer displays 
an “S.”

Reorder Feature
Sometimes you may need to modify your part 
by rearranging its features. This command 
allows you to move features up or down in the 
history tree. In the graphic here, the shell oper-
ation occurred after the holes were placed.
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Tech Note/Tip:

You cannot move or reorient 
a feature to any side of a 
solid that is not visible. The 
operation automatically 
believes you are choosing 
one of the visible faces. 
Rotate the solid so that the 
face is visible before choosing 
the Move Feature command.
Using the Reorder command, the shelling operation was moved before the hole 
operation, resulting in the model shown here.

Using the Reorder Feature Command
1. Select the part.

2. Open the Design Explorer and display the tree to expose the feature you want 
to reorder.

3. In the Design Explorer menu select the Reorder Feature command.

The Message Line reads: Feature Reorder: Click on new location in Design 
Explorer.

4. Click on the operation below which you want to move the selected operation.

The operation moves and the part regenerates. 

Move Feature
The Move Feature command allows you to reposition holes and bosses within the 
assembly.

Using Move Feature Command
1. Select the feature in the Design Explorer that you want to move. The feature is 

selected in your drawing area.

2. Display the Design Explorer menu (Right mouse button - Windows, CON-
TROL+mouse button - Macintosh).
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3. Select the Move command. The Message Line tells you to select a new center for 
the feature.

4. Click a new center on your solid. The feature is repositioned.

Remove Feature
This command deletes a feature from the assembly.

Edit Parameters
This command displays the Edit Objects dialog box. You can also double-click any 
item in the tree to open Edit Objects.

Expand Item
This commands expands the part of the tree under the selected item.

Collapse Item
This command collapses the part of the tree under the selected item.

Expand Branch
This command expands the entire branch that includes the selected item.

Collapse Branch
This command collapses the entire branch that includes the selected item.

Close Window
This command closes the Design Explorer.

Force Resolve Links
This command resolves all unresolved child geometry. If you select the part and 
display the Design Explorer, a red “R” appears over any child operation icons that is 
not resolved.
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This will occur if you had turned off the Enable Auto Resolve option in the General 
page of Preferences. When activated, this Designer Elements program automatically 
resolves all child geometry when a parent is modified. When deactivated use the 
Force Resolve Links command to resolve child geometry.

Design Explorer Rules
• Within the Design Explorer you 

cannot select a curve within a 
profile and edit its length through 
the Edit Objects dialog box. This 
attempt will make a later opera-
tion invalid. The message here 
appears when you choose Apply 
in the Edit Objects dialog box.

Click OK to restore the original length.

For example, if you want to lengthen a line that has been extruded to a solid, the 
change in length does not affect the lines connected to the edited line. The closed 
profile would be destroyed. To lengthen a line use the Move tool and select the 
endpoint of the line and move it. By default, it will select and move the endpoints 
of all lines connected at that endpoint.

• The Design Explorer will only show one part at a time.

Verify Menu
The Verify menu gives you access to a variety of commands that provides informa-
tion about your file or about specific objects.
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X, Y, Z Command
The XYZ command displays the model coordi-
nate values of the selected point. You may edit 
and change a selected value.

Angle 3 Pts Command
The Angle 3 Pts command calculates the angle formed 
by three points that you choose.

Distance Pt-Pt Command
The Distant Pt-Pt command calculates the distance 
between two points taken from the drafting assistant.
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Minimum Distance Command
The Minimum Distance 
command calculates the 
smallest distance between 
two selected objects.

This command is useful 
for checking if two objects 
interfere with each other. 
It will calculate the mini-
mum distance between 
any combination of 
curves, surfaces or solids.

Length Command
This Length command calculates the length of a line, spline, arc, circle, conic, sur-
face and solids. In the case of surfaces and solids the command adds all edge 
lengths, providing a perimeter length value as shown in the graphic here.
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Area Command
The Area command calculates the area of closed curves or a surface. These curves 
include basic objects such as circles and ellipses but also splines connected to cre-
ate an enclosed area.

Volume Command
The Volume command calculates the volume of a closed object.
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Tech Note:

This material selected here is 
set separately from material 
hatching used for geometry 
in a section view. 

See Chapter 28 for more 
information on crosshatch-
ing and Chapter 36 for more 
information on section views.
Properties Command
The Properties command calculates a solid's volume, center of gravity, principle 
moments, or moments of inertia. 

The Properties dialog box includes the following sections:

Material This pull-down menu allows you to specify a 

material type. 

The menu includes User Defined, (Misc) Cast Iron 
(typical), Steel (SAE 1020, SAE 4130 normalized, 
SAE 4140, 18-8 stainless, Aluminum (2024-T3, 
2014-T6, 7075-T-6), Magnesium (M-1/Am35, 
AZ61A/AMC575), (Titanium) Titanium (typical), 
Wood (Birch grain W, Birch grain X, White Oak 
grain W, White Oak grain X, Douglas Fir grain W, 
Douglas Fir grain X, Souther Pine grain W, South-
ern Pine grain X), Ceramic (Brick Soft, Brick Hard, 
Sewer Pipe, Glass), Aggregate (Concrete low 
strength, Concrete medium strength, Concrete high 
strength).
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Select one of these materials and the associated 
density displays in the Density field. For the User-
defined material you can enter your own value.

Basic This section includes the volume, weight and den-
sity of the selected object. The density is based on 
the selected material.

Advanced This section includes the Center of Gravity, 
Moments of Inertia and axis information.

Create This section includes three check boxes: ASCII file, 
Point at C.G and Pr. Axis Lines.

ASCII File - Clicking in the check box allows you 
to export the information contained in this dialog 
box to an ASCII file. When you click OK to close 
the Properties dialog box, the Save document as 
window appears asking for a name and location 
for the ASCII file.

Point at C.G. - Clicking in this check box, places a 
point at the Center of Gravity for the selected 
object. Click OK to close the dialog box and a C. 
G. point appears. The style of the point is based 
on the selected style for the Point tool. See Chapter 
9 for more information.

Pr. Axis Lines - Clicking in this check box, gives 
you the axis direction vectors for the coordinate 
system where the products of inertia vanish.
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Interference Command
This command in the Verify menu checks the interface volume of two or more sol-
ids to determine an intersection or interference. If an interference is found the Inter-
ference Check Results dialog box appears:

The dialog box contains the interference list window: Keep intersection solids check 
box, and the Save, Print and Done buttons.

Interference window This window lists the interference between the 
selected solids and includes Solid 1 and Solid 2 
(the solids names), Interference (the interference 
solid name), Volume (the volume of the interfer-
ence solid), and the CG (the center of gravity for 
the interference solid - x, y and z location).

Keep intersection solids When checked this option retains the intersection 
solids in your drawing.

Save Click this button to save the interference data to a 
log file which can be opened in any text editor.

Print Click this button to print the interference data.

Done Click this button to close the dialog box.

Using the Interference Command
1. Display your model as a wireframe.
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2. Select the solids on which you want to perform the check.

3. Choose Verify>Interference.

If an interference is encountered the Interference Check Results dialog box 
appears listing the interference and displaying the interference solids in black on 
your model.

4. If you want to retain these interference solids in your model check the Keep 
intersection solids box.

5. Click Save or Print if you would like to save or print the log of the interference 
solids.

6. Click Done to close the dialog box.

If Keep intersection solids box is checked your model displays the intersection sol-
ids.

Example:

The model here displays three intersecting solids.

By choosing Verify>Interference on these selected models (shown below in 
wireframe), the Interference Check Results dialog box appears and the interfer-
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ence solids are shown in black.

If no interference is found the following dialog box appears.
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Object Counts Command
This command counts the number of objects in the 
current drawing.

For grouped objects, each individual object is 
counted as well as the group itself.

Check Object Command

The Check Object command examines an object for proper data structure, topology 
and issues geometric warnings associated with ACIS data.  This includes checks for 
curves, surfaces, and solids.   The tool is frequently used in conjunction with 
imported data created from non-ACIS kernels.  Some of the many items checked 
include:

Data Structure Checks 

• Entities have  has appropriate child-level entity; e.g.: body has lump. Face has 
edges, etc 

• Presence (non-NULL) and closure of back pointer from child to parent; e.g.: 
body's lump points to body. 

• The coedge on spline surface has pcurve. 
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• Pcurve indexing (0/+-1/+-2) is appropriate. 

• The pcurve has non-NULL 2D B-spline curve. 

• If edge has non-NULL curve, then curve must have equation. 

Topological Checks 

• Loops must be closed in both the next and prev directions. 

• Apex edge loops are correct. 

• Coedge has a partner, except apex coedge 

• All coedge partners point to same edge 

• Sequential coedges share a vertex 

• Edge is in exactly one of start and end vertex edge groups. For example, edge 
can be reached for 1 value of i using start()->edge(i)->coedge() and partner and 
next (or previous) pointers. 

Geometric Checks 

• Face gaps along shared edges and vertices

• Entities with geometry must have non-NULL geometry. For example, a face 
points to a surface. 

• Analyzes a curve or surface for C1/G1 discontinuties

• Self intersecting surfaces

• Analytic surfaces have valid definitions 

• Pcurve surface matches face surface (warning only if not equal since surface 
could be trimmed). 

• Pcurve form is agrees with curve form, e.g. closed, open, periodic. 

• Pcurve parameter period agrees with curve period. 

• Pcurve at points 0, 1/3, 2/3, and 1 way along curve must lie on the edge and tan-
gent directions at these points must roughly agree, i.e., have positive dot prod-
uct. This also tests the following: 

• Spline surface form is set correctly, e.g. surfaces closed in u report this. Checks 
the underlying 3D B-spline surface at 10 points along seam to verify form. 

• Checks that coedge vertices do not lie on spline surface singularities. 
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• Face normal is consistent with coedge direction.

• Start and end vertices of coedge lie on face.

• Edge lies on face. Checks at 10 points along edge.

• Start and end vertices lie on edge geometry. 

• Faces are ordered correctly around edge, according to sidedness. 

• Coedges are ordered correctly around edge, according to face curvature.

• Edge has same sense as curve (taking reverse bit into account).

• Checks curve has correct form. 

• Edge parameter range is good and agrees with start and end points. 

• Check edge for bad approximation direction.

• D3 checks on intcurve (option that can be turned on).

• No two vertices have the same location. 

• Optional face/face intersection checking (option check_ff_int).

You may select one or more objects with the Check Object command.  A report is 
presented in the above dialog box.  The dialog box has the following options:

• Save As: Saves the reported as an ASCII file.

• Repair: Attempts to repair any errors that were reported.

• Next Object: Step to the next item in the list.

• OK: Exit back to the program.
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This Designer Elements program provides tools and commands to transform your 
geometry with respect to scale, location and orientation.

This chapter covers the following topics:

• Transformation tools

• Transformation techniques

Transformation Tools

The tools on the Transformation tool palette include: move, rotate, expand or shrink 
and mirror objects, polar duplicate, linear duplicate and align. You can select the 
object you want to transform before or after you select a Transformation tool.

You can copy at the same time you transform objects by holding down the CTRL 
(Windows) or the OPTION (Macintosh) key while you specify the transformation.

When you press the SHIFT key you can select additional objects after you have 
selected a transformation tool (see the Message Line). As soon as you release the 
SHIFT key the Transformation tool is active again.

For each tool you can enter values in the Status Line to perform the operation 
either before or after the operation is complete. If you enter the values after you 
select the tool but before you perform the operation, your first click in the drawing 
area automatically registers all Status Line values. If you enter values after perform-
25-1



Transforming Geometry

25-2

Tech Note:

Use this tool to create an 
instance of a solid rather than 
cutting/copying and pasting 
which breaks the parent/child 
relationship. (Cobalt™ and 
Xenon™ only)

An instance is created when 
you perform an operation on 
a solid or surface and then 
move it to another location. 
This instance object displays 
its own unique Geometry page 

Tech Note:

Be aware that if you use this 
tool on an object that has had 
a subtraction boolean opera-
tion, you must also move the 
subtracted object. Other-
wise, you may alter or lose 
the subtraction operation.
ing the operation and while the object is still selected, pressing ENTER (Windows) 
or RETURN (Macintosh) updates the object to reflect the new values.

Geometric Characteristics
There are no geometric characteristics specific to these tools. The geometric charac-
teristics are based on the objects. For information on the geometric characteristics 
of an object, see its related chapter.

Move Tool

The Move tool moves selected objects, including control points to a new location. 
You can copy the selection by holding down the CTRL (Windows) or OPTION 
(Macintosh) key. If you select more than one object, they remain in the same posi-
tion relative to each other.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when moving objects with this tool.

Using the Move Tool 
You can select the object before or after selecting this tool. The Message Line 
adjusts to accommodate this ability.

1. Select the Move tool. 

2. Select the Move tool icon in the Message Line. The Message Line reads: Move: 
Select objects to move [Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

3. Select the object(s) to be moved.

The Message Line reads: Move: Select beginning reference point [Shift=Select, 
Ctrl=Copy (Windows) or Option=Copy (Macintosh)].

4. If necessary, use SHIFT-click to select more objects, and then pick a beginning 
point. The Message Line now reads, Move: Select ending reference point 
[Shift=Select, Ctrl=Copy (Windows) or Option=Copy (Macintosh)]. 

5. Click an ending reference point or drag the selected object(s) to a new location. 

The reference and destination points need not be on the object(s) you are moving. 
The move is performed relative to the specified points. 
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The Status Line contains the dX, dY and dZ values of the move distance and direc-
tion. 

After the move and while the object is still selected you can change a value in a 
data field and press ENTER (Windows) or RETURN (Macintosh) to accept the value.

Rotate Tools

When you select the Rotate tools icon a subpalette appears in the Message Line 
containing three tools, Rotate by Angle (or by one point) and Rotate by Three Points.

You can use them to rotate a selected set of objects around a point in any axis, or to 
create a circular array. 

When you rotate by one point or by three points, you can copy the selection by 
holding down the CTRL (Windows) or OPTION (Macintosh) key while you select 
the objects. If you select more than one object, they remain in the same position 
relative to each other.

Rotate 1 Pt Tool

This tool rotates one or more objects around a specified point. 
The Message Line contains a pull-down menu for specifying the 
rotation axis. The options include:

Work Pln Normal Rotates the objects about the 
normal vector of the work 
plane.

X-Axis Rotates the objects about the X axis.

Y-Axis Rotates the objects about the Y axis.

Z-Axis Rotates the objects about the Z axis.
25-3



Transforming Geometry

25-4
Arb. Axis Rotates the objects about an axis you specify by 
picking two points on screen.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when rotating objects with this tool.

Using the Rotate 1 Pt Tool
You can select the object before or after selecting this tool. The Message Line 
adjusts to accommodate this ability.

1. Select the Rotate tool. 

2. Select the Rotate 1 Pt tool in the 
Message Line. The Message Line 
reads: Rotate: Select items to rotate [Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

3. Select the objects that you want to rotate. 

The Message Line reads: Rotate 1 Pt: Enter location to rotate about [Shift=Select, 
Ctrl=Copy (Windows) or Option=Copy (Macintosh)].

4. Use SHIFT-click to select more objects. The Message Line also includes a pull-
down menu for choosing the rotation axis.

5. Select the rotation axis from the pull-down menu.

6. Specify the center of rotation.

The object is rotated.

The Status Line contains the X, Y and Z values of the rotation point and the rotation 
angle. After you complete the rotation click in any data field and enter a new value.
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Rotate 3 Pts Tool

The Rotate 3 Pts tool rotates an object based on three 
defining points, the center of rotation, a beginning 
reference point, and an ending reference point. This 
Designer Elements program determines the rotation 
angle from the two reference points. The two refer-
ence points need not be on the object.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when rotating objects with this tool.

Using the Rotate 3Pts Tool
You can select the object before or after selecting this tool. The Message Line 
adjusts to accommodate this ability.

1. Select the Rotate tool. 

2. Select the Rotate 3 Pts tool in the Message Line. The Message Line reads: Rotate: 
Select items to rotate [Shift = Extend].

If your objects are already selected, skip to step 3. The Message Line you see 
reflects the previous selection.

3. Select the objects that you want to rotate. 

The Message Line reads: Rotate: Select center of rotation [Shift=Select, Ctrl=Copy 
(Windows) or Option=Copy (Macintosh)]. If necessary, use SHIFT-click to select 
more objects. 

4. Click the rotation point. 

5. Click the first reference point.

6. Click the second reference point. 

The object is rotated. 

The Status Line contains the rotation angle.

After you complete the rotation and while the object is still selected you can enter a 
new value if necessary. Press ENTER (Windows) or RETURN (Macintosh) to accept 
the value. 
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Expand/Shrink and Scale Tool

The Expand/Shrink and Scale tool enlarges or reduces objects. 
The Message Line contains a pull-down menu with two options:

Uniform When selected, the tool is the 
Expand/Shrink tool. This tool maintains the pro-
portions of the stretched objects. This tool can be 
used for curves, surfaces and solids.

Differential When selected this tool is the Scale tool and allows 
you to specify separate scales in the X, Y and Z 
axes. This tool can be used for curves, surfaces 
and solids.

You can copy the selection as it is scaled by holding down the CTRL (Windows) or 
OPTION (Macintosh) key. If you select more than one object, they remain in the 
same position relative to each other. 

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when stretching objects.

Using the Uniform Option or the Expand/Shrink Tool 
This option/tool lets you expand or shrink your curves, sur-
faces and solids uniformly. You can select the object before 
or after selecting this option. The Message Line adjusts to 
accommodate this ability. The graphic here shows uniformly 
scaled curves.

1. Select the Expand/Shrink tool. In The Message 
Line reads: Expand/Shrink: Select items to scale 
[Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to scale. The option pull-down menu appears.

3. Select the Uniform option from the menu. When you move the pointer 
into the drawing area the pointer becomes the expand/shrink icon, 
shown here.
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Tech Note:

When you use this Differen-
tial option of the Expand/
Shrink tool for surfaces and 
solids, the stretched object 
displays its own Geometry 
page in Edit Objects.
The Message line now reads, Expand/Shrink: Select anchor point [Shift = Select, 
Ctrl = Copy (Windows) or Option = Copy (Macintosh)]. If you wish to select more 
objects, do so.

4. Click the anchor point on your geometry. This point remains fixed in the 
stretch. Use the SHIFT key to select more objects to stretch for this operation.

The Message Line now reads, Expand/Shrink: Select beginning reference point 
[Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

The beginning reference point is a point on your geometry used in conjunction 
with the ending reference point to set the scale of the operation. Rather than 
specifying reference points you can also just enter a value in the Scale data field 
and press ENTER (Windows) or RETURN (Macintosh) and the object will scale.

5. Click the beginning reference point.

The Message Line reads: Expand/Shrink: Select ending reference point 
[Shift=Select, Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

6. Click the ending reference point. The scale factor is calculated based on the 
beginning reference point and this point.

The selected object is resized. The Scale is displayed in the Status Line data field.

After you complete the scale and while the object is still selected you can enter a 
new value scale. Press ENTER (Windows) or RETURN (Macintosh) to accept the 
new value.

The Status Line contains the Scale factor. Entering a number between zero (0) and 
one (1) reduces the object. Entering a value above 1 enlarges the object. 

Using the Differential Option or the Scale Tool
This option/tool lets you scale your curves, surfaces and solids differentially. You 
can select the object before or after selecting this option. The Message Line adjusts 
to accommodate this ability. The graphic here shows a differentially scaled solid.
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1. Select the Expand/Shrink tool. In The Message Line reads: Expand/Shrink: Select 
items to scale [Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to scale.

The option pull-down menu appears.

3. Select the Differential option from the menu. When you move the 
pointer into the drawing area the pointer becomes the scale icon, 
shown here

The Message Line reads: Scale: Enter point to scale about [Shift = Select, Ctrl = 
Copy (Windows) or Option=Copy (Macintosh)]. If necessary, use SHIFT-click to 
select more objects.

4. Enter the X, Y and Z Scale values in the Status Line.

5. Click a point about which your object will be scaled. 

The Status Line contains the X-Scale, Y-Scale and Z-Scale data fields.

After you complete the scale, while the object is still selected, you can enter new 
values. Press ENTER (Windows) or RETURN (Macintosh) to accept the new values. 

Mirror Tool

The Mirror tool creates a mirror image of an object or objects 
on the opposite side of a reference line. You can copy the 
selection by holding down the CTRL (Windows) or OPTION 
(Macintosh) key. If you select more than one object they 
remain in the same position relative to each other. 

The Message Line contains a pull-down menu with five options 
for specifying the mirror reference line or plane.

2 Pts Mirrors the object around the ref-
erence created by the two specified points.



Transformation Tools

Tip:

When using the plane 
options, it may be helpful to 
display the Axis for reference. 
Choose Layout>Show Axis.
XY Plane Mirrors the object around the XY plane.

ZY Plane Mirrors the object around the ZY plane.

ZX Plane Mirrors the object around the ZX plane.

3 Pts Mirrors the object around the mirror plane speci-
fied by three points.

Important: (Windows users) Because the CTRL and SHIFT keys are programmed to 
perform specific operations for this tool, the Stroke Zoom function (CTRL+SHIFT 
keys) is not available when mirroring objects.

Using the Mirror Tool - 2 Pts Option
You can select the object before or after selecting this option. The Message Line 
adjusts to accommodate this ability.

1. Select the Mirror tool. The Mes-
sage Line reads: Mirror: Select 
items to mirror [Shift = Extend].

If your objects are already selected, skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to be mirrored.

An option pull-down menu appears.

3. Select the 2 Pts option in the pull-down menu. The Message Line reads: Mirror: 
Select beginning of reference line [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)].

If necessary, use SHIFT-click to select more objects.

4. Click a location to set the beginning of the reference line around which the 
object mirrors. The Message Line now reads, Mirror: Select end of reference line 
[Ctrl = Copy (Windows) or Option = Copy (Macintosh)].

If you drag you specify the beginning and endpoints and the object mirrors.

5. Click to locate the end of the reference line. 

The reference line need not be parallel to the object.

Using the Mirror Tool - XY Plane Option
You can select the object before or after selecting this option. The Message Line 
adjusts to accommodate this ability.
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1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror 
[Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to be mirrored.

An option pull-down menu appears.

3. Select the XY Plane option in the pull-down menu. The Message Line reads: 
Mirror 1 Pt: Enter 1 point for mirror origin [Shift=Select, Ctrl=Copy (Windows) 
or Option=Copy (Macintosh)].

Use SHIFT-click to select more objects.

4. Click a point in the XY plane to specify a reference point for the mirror.

Using the Mirror Tool - ZY Plane Option
You can select the object before or after selecting this option. The Message Line 
adjusts to accommodate this ability.

1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror 
[Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to be mirrored. An option pull-down menu appears.

3. Select the ZY Plane option in the pull-down menu. The Message Line reads: 
Mirror 1 Pt: Enter 1 point for mirror origin [Shift= Select, Ctrl=Copy (Windows) 
or Option=Copy (Macintosh)].

Use SHIFT-click to select more objects.

4. Click a point in the ZY plane to specify a reference point for the mirror.

Using the Mirror Tool - ZX Plane Option
You can select the object before or after selecting this option. The Message Line 
adjusts to accommodate this ability.

1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror 
[Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to be mirrored. An option pull-down menu appears.
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3. Select the ZX Plane option in the pull-down menu. The Message Line reads: 
Mirror 1 Pt: Enter 1 point for mirror origin [Shift=Select, Ctrl=Copy (Windows) 
or Option=Copy (Macintosh)].

Use SHIFT-click to select more objects.

4. Click a point in the ZX plane to specify a reference point for the mirror.

Using the Mirror Tool - 3 Pts Option
You can select the object before or after selecting this option. The Message Line 
adjusts to accommodate this ability.

1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror 
[Shift = Extend].

If your objects are already selected skip to step 3. The Message Line you see 
reflects the previous selection.

2. Select the object(s) to be mirrored.

An option pull-down menu appears.

3. Select the 3 Pts option in the pull-down menu. The Message Line reads: Mirror 
3 Pts: Enter 3 points for mirror plane [Shift=Select, Ctrl=Copy (Windows) or 
Option=Copy (Macintosh)].

Use SHIFT-click to select more objects.

4. Click three points to specify a reference plane for the mirror.

There are no Status Line entries for the Mirror tools.

Copy Along Path Tool

The Copy Along Path tool copies an object along a 
path by the number of times you set. The objects 
will be equally spaced along the curve.
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You can align your copies along the X, Y and Z 
axis (the alignment axis). The graphic here shows 
a polygon created in the Top plane with a Z 
alignment axis.

Using the Copy Along Path Tool 
You can select the object before or after selecting 
this tool. The Message Line adjusts to accommo-
date this ability.

1. Select the Move tool. 

2. Select the Copy Along Path tool in the Message Line. The Message Line 
reads: Copy Along Path: Select items to translate along path [Shift = 
Extend].

If your objects are already selected skip to step 3. The Message Line you 
see reflects the previous selection.

3. Select the objects to copy.

The Message Line now reads, Copy Along Path: Select the translation path for 
objects.

4. Enter the number of objects to copy in the Qty (Quantity) field of the Status 
Line.

5. Click the path curve. The Message Line reads: Copy Along Path: Enter copy ori-
gin.

6. Click the point where the copy should begin. The Message Line reads: Copy: 
Along Path: Enter two points for alignment axis.

You can align the copies along the X, Y or Z axis. Use the Drafting Assistant to 
choose the desired axis.

7. Pick two points on the screen to show your Designer Elements program where 
to align the object(s).

The Status Line contains the Qty (Quantity) field displaying the number of objects 
this Designer Elements program will create. You must set this value before copying 
the objects.
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Linear Duplicate Tool

The Linear Duplicate tool creates copies of an object in a 
rectangular array.

To complete the array, you set the 
number of horizontal rows and vertical 
columns and the amount of space 
between each object in the array. This 
is done through the Linear Duplicate 
dialog box.

The dialog box contains the following options:

Number per row (Columns section) This field sets the total number 
of objects per row. Be sure to include the selected 
object in this total count.

If you don’t know the number, you can use math 
operators to determine the number of copies. For 
example, if you want to place studs 16 inches 
apart on a 17 foot wall, you would enter (17*12)/
16. This Designer Elements program will truncate 
the result to 12 copies.

Offset X*, Y*, Z* (Columns section) These fields set the offset length 
in the X, Y or Z direction for the duplicated 
objects. These values work with the Total offset 
and Step offset options. Enter these values yourself 
or drag in the drawing area to enter the values.
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Total offset (Columns section) When selected, this option 
specifies that the offset values in the X, Y and Z 
fields are the total offset values from the selected 
object to the last copy.

Step offset (Columns section) When selected, this specifies 
that the values in the X, Y and Z fields are step off-
set values from the selected object to the first copy.

Number of rows (Rows section) This field sets the total number of 
rows.

Spacing* (Rows section) This field sets the perpendicular 
spacing for rows. This field operates with the Total 
spacing and Step spacing options. 

Total spacing (Rows section) When selected, this option specifies 
that the Spacing value is the total spacing from the 
selected object to the last copy. This option works 
with the Spacing field.

Step spacing (Rows section) When selected, this option specifies 
that the Spacing value is the distance from the first 
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selected object to the first copy. This option works 
with the Spacing field.

OK/Cancel Click OK to complete the operation. Click Cancel 
to discontinue the operation.

The asterisk (*) indicates that the value automatically fills in when you drag the 
pointer in the drawing area to indicate the offset or spacing.

Using the Linear Duplicate (Rectangular Arrays) Tool
You can select the object before or after selecting this tool. The Message Line 
adjusts to accommodate this ability.

1. Select the Move tool. 

2. Select the Linear Duplicate tool in the Message Line. The Message Line 
reads: Linear Duplicate: Select objects for linear duplicate [Shift = 
Extend].

If your objects are already selected the Linear Duplicate dialog box 
appears. Skip to step 3.

3. Select the object(s) to be duplicated. The dialog box appears. 

The Message Line now reads, Linear Duplicate: Specify parameters for linear 
duplicate.

4. Enter the number of columns in the Number per row data field.

5. Select offset option, either Total or Step.

6. If the Offset X* field is not selected, click in the field.

7. Move the pointer to the drawing area and drag to indicate the offset for the row 
of copies. Values automatically appear in the X*, Y* and Z* data fields.

8. Select the spacing option, either Total or Step.

9. If the Spacing* field is not selected, click in the field.

10. Move the pointer to the drawing area and drag to indicate the spacing for the 
spacing for the rows.

11. Click OK to close the dialog box and create the duplicates.

There are no Status Line entries.

Note: This Designer Elements program does not support using this tool for features.
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Polar Duplicate Tool

The Polar Duplicate tool copies a selection around a central point. The entities in 
the selection may be rotated as they are copied or remain upright. 

The number and location of duplicates are controlled through the Polar Duplicate 
dialog box.

The dialog box contains the following options:

Number (Duplicates section) This field sets the total num-
ber of objects. Be sure to include the selected 
object in this total count.

Center X*, Y*, Z* (Duplicates section) These fields set the X, Y and Z 
location for the center of the circular array. You 
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can enter these values yourself or click the place in 
the drawing area for the center.

Translate duplicates (Duplicates section) When selected, this option 
creates copies that are upright with respect to the 
original object. When this option is not selected, 
copies are rotated around the center you specified. 
The left graphic here shows an duplicated object 
when the option is selected. The right graphic 
shows a duplicated object when the option is not 
selected.

Ref X*, Y*, Z* (Duplicates section) These fields represent the ref-
erence point for the Translate duplicates option.

Ref X, Y and Z determine the imaginary point 
duplicated around the center you specified. The 
selected objects are reproduced in the same posi-
tion relative to each imaginary point duplicated. 
The imaginary Ref point and center point are indi-
cated in the example here.
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You can specify the Ref point by entering values or 
clicking at the desired location in the drawing area.

Angle (Rotation section) This field specifies the angle of 
rotation. This field operates with the Total angle 
and Step angle options.

Total angle (Rotation section) When selected, this option spec-
ifies that the angle value is the total number of 
degrees between the center of the selected object 
and the center of the last object. (If 360° is the 
specified angle, the last object is the selected 
object.)

Step angle (Rotation section) When selected this option speci-
fies that the angle value is the angle between the 
center of two adjacent objects.

OK/Cancel Click OK to complete the operation. Click Cancel 
to discontinue the operation.

The asterisk (*) indicates that the value automatically fills in when you drag the 
pointer in the drawing area to indicate the offset or spacing.

Using the Polar Duplicate Tool
You can select the object before or after selecting this tool. The Message Line 
adjusts to accommodate this ability.

1. Select the Polar Duplicate tool

2. The Message Line reads: Polar 
Duplicate: Select items to polar 
duplicate [Shift = Extend].

If your objects are already selected the Polar Duplicate dialog box appears. Skip 
to step 3.

3. Select the object to be duplicated. The dialog box appears.

The Message Lines reads, Polar Duplicate: Specify parameters for polar duplicate.

4. Enter the number of objects in the circular array.

5. If the Center X* data field is not selected, click in the field.

6. Move the pointer to the drawing area and click the center point of the array in 
the drawing area. Values automatically appear in the X*, Y* and Z* data fields.



Transformation Tools
7. If you want objects to be upright with respect to the selected objects, select the 
Translate duplicates option.

8. If you specified Translate duplicates, click a location for the reference point in 
the drawing area.

9. Select the angle option, Total or Step.

10. Enter the angle of rotation in the Angle field or drag in your drawing area along 
the desired angle using the Draft Assistant.

11. Click OK.

There are no Status Line entries. 

Note: This Designer Elements program does not support using this tool for features.

Align Objects Tool

With this Designer Elements program you have the ability to align any object cre-
ated using the Align command. This includes aligning text objects with other text 
objects and text objects with geometry.

Using the Align Command
1. Choose the Selection tool.

2. Hold down the SHIFT key and select the text and geometry you want to align.

3. Choose the align tool from the Transformation tool palette.

The objects align.

For more detailed information regarding the Align Tool refer to chapeter 24, The 
Align Command.
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Transforming Techniques
There are many ways to accomplish the same transformation task in this Designer 
Elements program. This section includes some of those ways.

Moving Objects with Tools
When an object is selected, move the pointer near the object until the 4-way Move 
symbol appears as shown below and drag the object to a new location.

Note: If the 4-way Move symbol doesn't appear, make sure you're in the Selection 
tool.

Using the Drafting Assistant for Moving
When the pointer becomes the 4-way Move symbol, you can drag the object around 
and see the Drafting Assistant’s notations relative to the object’s location when you 
press the mouse button. This way, if you move the pointer over a control point so 
the Drafting Assistant activates it, you can align the object you are moving with that 
point.

on

If you begin dragging when
the on notation is displayed...

...the alignment with the corner of
the rectangle occurs at the location
on the square where you pressed
the mouse button to begin dragging.
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Selected Move versus Move Tool
You can move objects either with the Selection tool or with the Move tool.

Moving with the Selection Tool

The move function of the Selec-
tion tool allows free movement 
of the selected object.

To move a circle from one location to another as shown above, use the Selection 
tool and the Drafting Assistant to align the 90° quadrant with the corner of the rect-
angle. The circles do not need to touch the rectangle to be aligned with it.

Moving with the Move Tool

The Move tool (in the Transformation subpalette) allows you to move the selection 
with reference to other geometry in the X, Y and Z direction.

With the endpoint notation displayed when you
press the mouse button, you can move the square
from here...

...to here, using the Drafting Assistant to align the
corners.

endpoint

endpoint
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Move a 1-inch square 2 inches in the X direction and 1 inch in the Y direction. See 
the following graphic.

1. Select the Move tool.

2. Select the square to be moved.

3. Click one corner of the square when the endpoint notation is displayed.

4. Enter 2 in the dX entry field on the Status Line and -1 in the dY entry field. A 
positive or negative value entered in the Status Line determines the direction 
along the X or Y axis. A negative value moves the object to the left or down on 
the screen and a positive value moves the object to the right or up.

5. Press the ENTER (Windows) or RETURN (Macintosh) key. The square is moved.

Moving Objects to Another Layer
1. Choose Window>Edit Objects.

2. In the Layer field, scroll down to the layer on which you want the object.

3. Click OK. The object is now located on the new layer.

Copying Objects with Tools
You can copy selections with the Copy command, as discussed earlier, or by hold-
ing down the CTRL (Windows) or OPTION (Macintosh) key using these tools:

• Selection tool

• Single Line tool

• Center-Point and Opposite-Point Circle tools

• Ellipse tools

• Conic tools

• Polygon tools

2X -1Y 0Z

endpoint
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• Project Curve tool

• Transformation tools

Copying with the Selection Tool
You can hold down the CTRL (Windows) or OPTION (Macintosh) key and drag a 
copy of the selection to a new location. 

When you use the Selection tool to copy a surface or solid using this technique you 
create an instance of the original object. All changes made to the original object are 
automatically reflected in the instance (Cobalt™ and Xenon™ only). If you do not 
want to create an instance, you can select the original object, choose Edit>Copy 
and then Edit>Paste. 

1. Choose the Selection tool.

2. Select the object(s) you want copied.

3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.

4. Drag a copy of the selection to a new location. The copy is placed on the cur-
rent work layer.

Copying with the Geometry Tools
You can make copies with the following drawing tools:

• Single Line tool

• Center-Point and Opposite-Point Circle tools

• Ellipse tools

• Conic tools

• Polygon tools

• Project Curve tool

To create a copy with the drawing tools proceed as follows:

1. Construct the geometry you want to copy.

2. Hold down the CTRL (Windows) or OPTION (Macintosh) key.

3. Click a new location. The click determines the location of the first point speci-
fied during the construction of the original geometry (the center of a Center-
Point Circle, for example).
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Copying with the Transformation Tools
You can hold down the CTRL (Windows) or OPTION (Macintosh) key while using a 
transformation tool to make a copy of the selected geometry.

1. Select one of the transformation tools.

2. Select the object you want to copy and transform.

3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.

4. Perform the transformation according to the directions in the Message Line.

Copy CTRL (Windows) or OPTION (Macintosh) versus Copy Command
Normally, using the copy option of a geometry tool is faster than using the Copy 
and Paste commands in the Edit menu. The Copy and Paste commands are useful 
for copying to a different document or application.

Sizing Objects with Tools
Normally you size an object with the Selection tool. In some cases it is useful to use 
the Move tool for sizing objects.

Sizing an Object with the Selection Tool
You can stretch objects by selecting a point and dragging it to a new location.

1. In the Edit menu, be certain that Selectable Points is set.

2. Click the Selection tool.

3. Drag a selection fence around the control points that represent the area you 
want to stretch.



Transforming Techniques
4. Drag the points to a new location.

Sizing an Object with the Move Tool
You can also size an object with the Move tool. Using the Move tool allows you to 
specify the distance the selected point(s) should be moved by specific values along 
the dX, dY  and dZ direction in the Status Line.

To move the corner of the single line rectangle in the next graphic with the Move 
tool, proceed as follows:

1. In the Edit menu, be sure that Selectable Points is set.

2. Click the Selection tool.

3. Drag a selection fence around the lower right corner of the rectangle.

4. Select the Move tool.

5. Enter +1 in the dX data field, a -1 in the dY field and a 0 in the dZ field.

Press the ENTER (Windows) key or the RETURN (Macintosh) key.

Intersecting lines can be dragged
to new lengths.

A line can be dragged to a new
length.
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The corner of the rectangle is moved the distance you specified in the Status Line.

Selected Sizing versus Expand/Shrink Tool
Dragging a control point of a selected object not only changes the size of the 
object, but distorts the object by changing the proportion between height and 
width. 

The Expand/Shrink tool on the Transformation subpalette enables you to resize 
geometry while maintaining its proportions.

In addition, you can specify proportions by clicking points on other geometry. For 
example, you can resize an object to fit within another object by clicking the 
boundary into which the resized object must fit.

Use the Scale tool to enlarge or shrink
a shape proportionally



Tech Note:

This Designer Elements pro-
gram does not support the 
importation of text docu-
ments.
Text
When you want to add some basic annotations to your drawing use one of the text 
tools. You can create and edit text. You can use the Text menu to set the character-
istics such as font, text size and case. The topics discussed in this chapter include:

• Text tools

• Text Commands

Text Tools

This Designer Elements program has three tools for creating text: Horizontal Text, 
Text Along a Curve and Text at an Angle. The text tools in this Designer Elements pro-
gram do not use text boxes. Simply click the cursor at the location you want the 
text to begin and start typing. Press ENTER (Windows) or RETURN (Macintosh) to 
end one text object and begin another. These text objects move independently.

Horizontal Text Tool

The Horizontal Text tool creates horizontal text at the location you specify.
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Tech Note:

This tool may not support all 
of your system’s fonts. True 
Type fonts that don’t form 
closed polygons are not sup-
ported.
Using the Horizontal Text Tool
1. Select the Horizontal Text tool from the main tool palette. The Mes-

sage Line reads: Enter location for text [Press Mouse to End].

2. Place the cursor at the beginning location for the text and click. The 
cursor becomes a text cursor.

3. Enter the desired text. If you press ENTER (Windows) or RETURN 
(Macintosh), you begin a new and separate line of text that is aligned left with 
the previous line.

Since this is a separate text line it can be moved independently.

Text Along a Curve Tool

The Text Along a Curve tool creates text along the curve you specify.

Using the Text Along a Curve Tool
1. Create the curve along which you want the text, placing the points in the order 

that you want the text placed. For a horizontal line created left to right, the text 
appears left to right. For a vertical line created top to bottom, the text appears 
top to bottom.

2. Select the Text Along a Curve tool from the main tool palette. The Message Line 
reads: Select path for text [Shift=Extend].

3. Select the curve you just created. The cursor becomes a text cursor placed at 
the start point of the curve.

4. Enter the desired text. It displays horizon-
tally.

5. Press ENTER (Windows) or RETURN (Macin-
tosh) and the text line molds to the curve.



Text Tools

Tip:

If you enter the angle in the 
Status Line after you type the 
text, you will have to hit 
ENTER (Windows) or 
RETURN (Macintosh) twice. 
The first time registers the 
values and the second 
changes the text angle to the 
new angle.
A parent/child relationship exists between the curve and the text. Any change that 
you make to the curve affects the text. Select any curve control point and drag it to 
a new location and the text updates.

If the curve is not long enough for the text, you can extend the curve by selecting a 
curve endpoint and dragging it to a new location.

This tool only supports one line of text per curve. You cannot move the text inde-
pendently of the curve. If you do not want to display the curve with the text, 
change the curve color to blend with your background or place the curve on the 
construction layer. Then you still have the ability to edit the text appearance on 
screen by editing the curve.

Text at an Angle Tool

The Text at an Angle tool creates text at the angle and location you specify.

1. Select the Text at an Angle tool from the main tool palette The Message Line 
reads: Enter location for text.

2. In the Status Line, enter the angle for the text in the Angle data field. Press 
ENTER (Windows) or RETURN (Macintosh) to register the value.

3. Place the cursor at the beginning location for the text and click. The cursor 
becomes a text cursor.

4. Enter the desired text. The text displays horizontally.

5. Press ENTER (Windows) or RETURN (Macintosh) and the text 
angle changes.

Geometric Characteristics
A text object is created by clicking the location of the start point of the text and typ-
ing the desired text. A text object is made up of the following characteristics accord-
ing to the Edit Objects dialog box: Text and Angle. To display the dialog box, select 
the text and choose Window>Edit Objects or double-click on the text.
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BoundingBox Text Tool

Bounded Box Text is defined by two diagonal points used to specify the width and 
height of a text box. Text is automatically wrapped to the width of the box. The text 
box also supports left, right and center justifications.

In addition, you can double click on the text to make edits directly on the screen. 
On screen editing supports cutting, pasting and copying into the text box. For 
example, you can copy of paragraph from Microsoft Word and paste it into a text 
box.

Text Commands
All Text commands are contained in the Text menu and 
include commands for changing the text font, size, style and 
case.



Text Commands
Font
This command in the Text menu changes the 
font for selected text or future text entries. 

The menu lists fonts installed on your computer 
and one Plotter font. Use the Plotter font when-
ever you are creating text for a drawing that 
you intend to send to a plotter, since plotting 
Postscript or TrueType fonts takes much more 
time and fonts may be substituted.

If you select text and change the font only the 
selected text is affected. If no text is selected 
and you change the font, you are setting the default font for future entries until you 
choose another font.

Special characters and accents are available as described in Appendix B.

Size
This command in the Text menu sets the font size for the 
selected text or for future text entries in the current docu-
ment.

If you select text and change the size only the selected 
text is affected. If no text is selected and you change the 
text size, you are setting the default size for future entries.

The size can be specified as either points (12 pt) or as 
units (.156 inches) as defined in the Units page of Prefer-
ences. If no unit is specified this Designer Elements pro-
gram picks the default unit.

Specifying a Non-standard Text Size as the Default 
Size
Choosing User from the Size submenu brings up a dialog box allowing you to spec-
ify the exact text size. You can choose a point size or the units you’ve set for your 
drawing. 

1. Choose Text>Size>User.
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2. Select the size option, either Points or Units by click-
ing in the appropriate radio button.

3. Enter the size you want. 

If you choose Model, the size is measured in the cur-
rent units as set in Units page of Preferences.

4. Click OK to accept the change and close the dialog 
box. Click Cancel to close the dialog box without 
accepting the changes.

The size you specify stays in effect until you choose another size.

Style
This command in the Text menu sets the style (such as Bold or Underline) for 
selected text or future text entries.

The style you specify stays in effect until you choose another default style. A check 
(✔) indicates the current style.

If you only want to change the style of one text line, select the text and choose 
Text>Style and the option you want. This does not affect the default style setting.

Case
This Designer Elements program supports three text cases: 
lower case, UPPER CASE and Title Caps.

lower case Displays text all in lower 
case letters.

UPPER CASE Displays text in upper case 
letters.



Text Handling

Tip:

If you want to change from 
UPPER CASE to Title Caps, you 
must first changes your text 
to lower case and then change 
the case to Title Caps.
Title Caps Displays the first letter of each word in upper case 
and the remaining letters in lower case.

You cannot set case as a default setting like font, size and style. It simply changes 
the case of any selected text.

Using the Case Options
1. Select a text line.

2. Choose Text>lower case, UPPER CASE or Title Caps.

Your text line changes to reflect your choice.

Text Handling
You may want to perform various operations on your text like editing, moving etc.

Editing Text
To edit text you've created, select the text line 
and choose Window>Edit Objects.

In the Text entry field, make any desired 
changes. Click Apply to accept the changes and 
then Close to exit the dialog box. Click Close 
without hitting Apply if want to close the box 
without making any changes.

Moving Text
To move text, choose the Selection tool, select 
the desired text and drag the text to a new 
location.

Screen Horizontal Text
As seen in the picture above, the Edit Objects dialog box contains a check box for 
keeping text horizontal to your screen. With the box checked your text will stay 
horizontal to your screen when you use the Trackball to rotate your drawing. With 
the box unchecked your text will stay horizontal to the plane it was created on. For 
example, if you create text in the top view and switch to the trimetric view you text 
will appear as if it were lying flat.
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Dimensions
This chapter explains how to use the dimension tools in this Designer Elements 
program. The following topics are covered:

• Dimension Menu

• Associative Dimensions

• Dimension tools

• Dimension Appearance

• Dimensions and Drawing Views

Dimension Menu
The Dimension menu contains commands for displaying the palette of dimension-
ing tools and for setting the format for dimensions. When you are ready to start 
dimensioning, choose the Dimension tool you want from the Dimension tool pal-
ette.

Like the other tool palettes, the Dimension palette is a floating tool palette. You 
select dimension tools in the same way you select tools from the main tool palette. The 
first two tools and the last tool have subpalettes which also work like the subpalettes of the 
main tool palette.
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Associative Dimensions
This Designer Elements program’ geometric dimensions are associative—when you make 
a change to the geometry, the dimension changes also. This is not true if you overwrite the 
# symbol in the data field or Edit Objects with a set value/text string.

This associativity is a tremendous time saver because dimensions automatically update 
whenever you make a change in the geometry (Cobalt™ and Xenon™ only). You can 
even change the units from English to metric (in the Units page of Preferences) and every 
dimension on your drawing will reflect the change.

When you extend a line by selecting the endpoint of the line and dragging it to a new posi-
tion the dimension changes also because the dimension has a control point at the same 
position of the line's endpoint. So when you select the endpoint of the line you also select 
the dimension control point.

Dimensions are associative relative to the points they measure. If you change the length of 
a line using Edit Objects, the dimension will not update because the point was not 
changed. To correct the dimension, select the dimension’s vertex point and drag it to the 
new endpoint of the line.

Dimension Tools
This Designer Elements programs dimensioning tools are on a floating palette which you 
can drag around the drawing area. These tools allow add basic dimensions to your draw-
ing.

40
Endpoints

Line

endpoint

Dimension control point



Dimension Tools
Show Palette
The Dimensions palette is located in the stan-
dard tools palette.

These tools can be used to measure either an 
object or the area between objects. Once you 
have dimensioned an object (or space), the 
dimensions update when you make changes to 
the geometry (Cobalt™ and Xenon™ only).

Some of the dimensioning tools, such as the 
Horizontal and Vertical tools, require that two 
points be selected; others, such as the Radial 
and Diameter, require only one. The location 
and the status (on/off) of the Dimension palette 
is automatically saved when you exit the pro-
gram.

Dimensions and the Work Plane
Dimensions appear in the current work plane 
of the active view. (They are defined by the 
coordinate system of the work plane at the 
time they are created.) Set the work plane to correspond to the view before you begin add-
ing text or dimensions in a view. 

For example, if the cur-
rent work plane is Top, 
dimensions appear paral-
lel to the work plane 
regardless of the view. 
See the graphic here. 

All point to point dimen-
sions are also placed par-

allel to the work plane. If you were working in the front plane and you were using the 
horizontal dimension tool, the dimension would be placed parallel to the front plane.

1.500

1.434

1.624
2.000
27-3



Dimensions

27-4
Dimension Smart Pointer
The dimension pointer is a smart pointer with a hot spot—the dot shows which side of the 
object to select first.

If you select as indicated by the position of the dot and cross hair, the text appears above 
or to the right of the leader. If you select in the opposite order, the text appears below or to 
the left of the leader.

Dimensioning Objects and Placement
1. Select the appropriate dimension tool.

2. Click the points you want to measure.

Dimensions automatically use the dimension pen style and current dimension text char-
acteristics. If you want to change the dimension pen color or weight, you can do so in 
the Dimension menu.

3. Move the dimension to a new location if its placement is not where you want it.

Moving the Dimension
After you place a dimension, you may want to reposition it relative to your geometry. The 
steps differ depending on the tool. You can reposition your dimension after it has been 
placed with the Selection tool.

1. Choose the Selection tool.

2. Place the Selection tool over the dimension text and it becomes the Move 
symbol.

3. Drag the dimension to the desired location.

If you want to select more than one dimension drag a 
selection fence around them.

You can also reposition the text along the dimension line 
by dragging it along the line.

For radial and diameter dimensions, you can also reposition the dimension’s control point 
by dragging a selection fence around the tip of the dimension line arrow.

1.524



Dimension Tools
Dimension Status Line Fields
The Horizontal, Vertical, Parallel, Angular, Center Mark and Balloon Dimension tools each 
have Status Line fields associated with them.

The Status Line field, similar to the one below, appears when one of these dimensioning 
tools is selected. Those Status Lines that differ are noted with the tools.

The # symbol in the text field indicates that the dimension is the actual value of the 
object’s measurement. If you delete this symbol the dimension will no longer be associa-
tive (that is, it won’t update if you change the geometry it measures).

You can also add text before or after the # symbol which will display with the dimension 
text.

Geometric Characteristics
Dimension text is created automatically when you dimension an object and is made up of 
one characteristic according to Edit Objects, Text.

Automatically Placing Dimensions on a Separate Layer
This Designer Elements program automatically creates a Dimension layer. Dimensions 
automatically go on that layer except in the case of dimensions placed in drawing tools. 
These drawing view dimensions go on the Sheet View layer. See Chapter 36 for informa-
tion about drawing views.

If you accidently delete the Dimension layer, 
This Designer Elements program automatically 
recreates the layer if you close and open the file. 
If you try to delete the Dimension layer and there 
are objects on it, this Designer Elements pro-
gram displays the following warning.

Dimensions and Edit Objects
In the Edit Objects dialog box the text characteristic field includes a # symbol for all 
dimensions, which indicates the dimension is the actual value of the object's measurement. 
If you delete the # symbol and enter another value, the dimension is fixed and will not 
update if you change the units or the size of the geometry. 
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Some of the dimensioning tools, such as the Radial tools, add a letter in the text status box 
which appears in the dimension itself.

You can add text before or after the # symbol. You can enter parentheses to enclose the 
resulting dimension in parentheses (#), or enter # 2 Plcs to display the dimension followed 
by the text 2 Plcs. When you include the # symbol, this Designer Elements program uses 
the measurement of the geometry as well as the text you add.

Edit Objects also includes dimension characteristics including a Units data field. This field 
allows you to set the units for a selected dimension to those in Preferences or another set-
tings. This allows you to dimension a part with mixed units. The graphic below shows an 
example of mixed units with the Edit Objects dialog box.

Dimension Surfaces and Solids
You can dimension surfaces and solids using the Horizontal, Vertical and Parallel dimen-
sion tools only. The Radial, Diameter and Angular Dimension tools can only be used for 
wireframe objects.



Horizontal Dimension Tools
Smart Dimension Tool

This tool in the Dimension tool pal-
ette allows you to quickly place 
horizontal, vertical, radial and 
diameter dimensions with a single 
click. These dimensions are asso-
ciative to the curves. As you 
change the curve, the dimension 
automatically updates (Cobalt™ 
and Xenon™ only). This tool is 
especially useful for drawing views.

Using the Smart Dimension Tool
1. Select the tool from the Dimension tool palette. The Message Line reads: 

Smart Dimension: Pick curve to dimension.

2. Select the curve.

The dimension appears. You can drag the dimension to a new location. Dimen-
sion and extension lines automatically redraw.

Horizontal Dimension Tools

These tools measure horizontal spaces or the distance between linear objects.

This tool dimensions objects or spaces horizontally. When you select 
the Horizontal Dimension tools, a subpalette appears in the Message 
Line containing three tools, Horizontal Dimension, Horizontal Base 
Line Dimension and Horizontal Chain Dimension.

.797
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Using the Horizontal Dimension Tool
1. Select the Horizontal Dimension tools. Choose the Horizontal 

Dimension tool from the Message Line. The Message Line reads: 
Horizontal: Pick first dimension point.

2. Click the left point of the geometry. 

The Message Line now reads, Horizontal: Pick next dimension point.

3. Click the right point. 

The dimension appears. You can drag it to a new location. Dimension and extension 
lines automatically redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.

Horizontal Base Line Dimension Tool

This tool dimensions objects or spaces from a base 
point.

Using the Horizontal Base Line Dimension 
Tool
1. Select the Horizontal Dimension tools. Choose 

the Horizontal Base Line Dimension tool. The 
Message Line reads: Horizontal Base Line: Pick first dimension point.

2. Click the base point of the geometry. 

The Message Line now reads, Horizontal Base Line: Pick next dimension point.

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears above the first mea-
sured from the base point. Continue clicking the points you want dimensioned. You 
can drag each dimension to a new location. Dimension and extension lines automati-
cally redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.



Vertical Dimension Tools
Horizontal Chain Dimension Tool

This tool dimensions objects or spaces from end to 
end, horizontally. 

Using the Horizontal Chain Dimension Tool
1. Select the Horizontal Dimension tools. Choose the Horizontal Chanin Dimension tool. 

The Message Line reads: Horizontal Chain: Pick first dimension point.

2. Click the first point on the geometry. 

The Message Line now reads, Horizontal Chain: Pick next dimension point.

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears measured from the 
last point clicked. Continue clicking all the points you want dimensioned. You can 
drag each dimension to a new location. Dimension and extension lines automatically 
redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.

Vertical Dimension Tools

These tools measure vertical space or the distance between vertical objects. When you 
select the Vertical Dimension tools, a subpalette appears in the Message Line containing 
three tools: Vertical Dimension, Vertical Base Line Dimension and Vertical Chain Dimen-
sion.

Vertical Dimension Tool

This tool dimensions an object or space vertically.

4.000
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Using the Vertical Dimension Tool
1. Select the Vertical Dimension tool. Choose the Vertical Dimension tool. The 

Message Line reads: Vertical: Pick first dimension point.

2. Click the top point of the geometry first.

The Message Line now reads, Vertical: Pick next dimension point.

3. Click the bottom point. 

The dimension appears. You can drag it to a new location. Dimension and extension 
lines automatically redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.

Vertical Base Line Dimension Tool

This tool dimensions objects or spaces from a base point.

Using the Vertical Base Line Dimension Tool
1. Select the Vertical Dimension tools. Choose the Ver-

tical Base Line Dimension tool. The Message Line 
reads: Vertical Base Line: Pick first dimension point.

2. Click the base point of the geometry. 

The Message Line now reads, Vertical Base Line: Pick next dimension point.

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears to the right of the first 
measured from the base point. Continue clicking all the points you want dimensioned. 
You can drag each dimension to a new location. Dimension and extension lines auto-
matically redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.

.424
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Vertical Dimension Tools
Vertical Chain Dimension Tool

This tool dimensions objects or spaces from end to end, 
vertically.

Using Vertical Chain Dimension Tool
1. Select the Vertical Dimension tools. Choose the Vertical 

Chain Dimension tool. The Message Line reads: Verti-
cal Chain: Pick first dimension point.

2. Click the first point on the geometry. 

The Message Line now reads, Vertical Chain: Pick next dimension point.

3. Click the point. The dimension appears.

4. Click the next place for the dimension. This dimension appears measured from the 
last point clicked. Continue clicking all the points you want dimensioned. You can 
drag each dimension to a new location. Dimension and extension lines automatically 
redraw.

Click the points in the opposite order if you want the dimension to display below the 
objects.

Oblique Dimension Tool

This tool measures space or objects parallel or point to point.

Using the Oblique Dimension Tool
1. Select the Oblique Dimension tool. The Message Line reads: 

Oblique: Pick first dimension point.

2. Click the left point of the geometry first.

The Message Line now reads, Oblique: Pick next dimension point.

3. Click the right point.

The dimension appears. You can drag it to a new location. Dimension and extension 
lines automatically redraw.

.313

1.096

.289

1.134
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Click the points in the opposite order if you want the dimension to display below the 
objects.

Ordinate Dimension Tools

This tool dimensions objects or spaces from a base point. 
Use the Selection tool to move, position or create an 
elbow ordinate.

Using the Horizontal Ordinate Dimension Tool

1. Select the Horizontal Ordinate Dimension tool from the Message Line. The Message 
Line reads: Horizontal Ordinate: Pick first dimension point.

2. Click the base point of the geometry. 

The Message Line now reads, Horizontal Ordinate: Pick second dimension point.

3. Click the next point. The dimension appears, measured from the base point.

4. Click the next point for the dimension. This dimension appears measured from the 
base point. Continue clicking all the points you want dimensioned. If you want to dis-
play a dimension at the base point, click the base point after you have dimensioned all 
other points.

You can drag each dimension to a new location. Dimension and extension lines automat-
ically redraw.

Using the Vertical Ordinate Dimension Tool
1. Select the Horizontal Ordinate Dimension tool. The 

Message Line reads: Vertical Ordinate: Pick first 
dimension point.

2. Click the base point of the geometry. 

The Message Line now reads, Vertical Ordinate: Pick 
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Vertical Dimension Tools
second dimension point.

3. Click the next point. The dimension appears, measured from the base point.

4. Click the next point for the dimension. This dimension appears measured from the 
base point. Continue clicking all the points you want dimensioned. If you want to dis-
play a dimension at the base point, click the base point after you have dimensioned all 
other points.

You can drag each dimension to a new location. Dimension and extension lines automat-
ically redraw.

Radial Arrow Out Dimension Tool

This tool measures the radius of a circle, arc, or fillet with the 
arrow on the side of the arc indicated when the arc is picked.

Using the Radial Arrow Out Dimension Tool
1.Select the Radial Arrow Out Dimension tool. The Message Line reads: 
Radial Arrow Out: Select arc/circle.

2.Click near the circle, arc or fillet you want to dimension.

The dimension is placed on the outside of the selected object. When the 
dimension appears the leader line is placed at the nearest 15° increment from 

the location you clicked. You can move the dimension by choosing the Selection tool, 
selecting the dimension, placing the pointer over the end of the leader line and when the 
pointer becomes the Move symbol, dragging the text to a new location.

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. This tool 
can only be used on curves, not surfaces or solids.

Radial Arrow In Dimension Tool

This tool measures the radius of a circle, arc, or fillet with 
the arrow inside the geometry.

R 2.741

R 2.385
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Using the Radial Arrow In Dimension Tool
1. Select the Radial Arrow In Dimension tool. The Message Line reads: Radial 

Arrow In: Select arc/circle.

2. Click near the circle, arc or fillet you want to dimension.

The dimension text appears inside the object. The arrow line starts from the arc 
center. When the dimension appears the leader line is placed at the nearest 15° 
increment from the location you clicked. You can move the dimension by choosing the 
Selection tool, selecting the dimension, placing the pointer over the end of the leader 
line and when the pointer becomes the Move symbol dragging the text to a new loca-
tion. 

For 3D geometry, radial dimensions are created in the plane of the arc or fillet. This tool 
can only be used on curves, not surfaces or solids.

Diameter Arrow In Dimension Tool

This tool measures the diameter of a circle.

Using the Diameter Arrow In Dimension Tool
1. Select the Diameter Arrow In Dimension tool. The Message Line reads: 

Diameter Arrow In: Select arc/circle.

2. Click near the circle or arc you want to dimension.

The dimension appears inside the object (depending on the circle and font 
size). When the dimension leader line is placed at the nearest 15° increment 
from the location you clicked. Move the dimension by choosing the Selection tool, 
selecting the dimension, placing the pointer over the end of the leader line and when the 
pointer becomes the Move symbol, dragging the text to a new location.

For 3D geometry, diametric dimensions are created in the plane of the circle. This tool can 
only be used on curves, not surfaces or solids.

Diameter Arrow Out Dimension Tool

This tool measures the diameter of a circle. 

Ø.838
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Using the Diameter Arrow Out Dimension Tool
1. Select the Diameter Arrow Out Dimension tool. The Message Line reads: 

Diameter Arrow Out: Select arc/circle.

2. Click near the circle or arc you want to dimension.

The dimension appears outside the object. When the dimension appears the 
leader line is placed at the nearest 15° increment from the location you 
clicked. You can move the dimension by choosing the Selection tool, selecting the 
dimension, placing the pointer over the end of the leader line and when the pointer 
becomes the Move symbol dragging the text to a new location.

For 3D geometry, diametric dimensions are created in the plane of the circle. This tool can 
only be used on curves, not surfaces or solids.

Angular Dimension Tool

This tool measures the angle between two lines.

Using the Angular Dimension Tool
1. Select the Angular Dimension tool. The Message Line reads: Angular: Pick 

first line.

2. Click on the first line near the endpoint from which you want the angle 
measured.

The Message Line now reads, Angular: Pick second line.

3. Click on the second line.

The inside angle is measured between the lines. This Designer Elements program 
always measures the smaller angle between the selected lines.

If you dimension intersecting lines don’t con-
fuse the intersection with the midpoint of the 
lines.

The Angular Dimension tool will not dimension 
angles over 180°. For 3D geometry, Angular 
dimensions are created in the plane of the two 
lines. This tool can only be used on curves not 
surfaces or solids.

45°

midpoints

intersection

To dimension this angle...

...you have to click here
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Center Mark Dimension Tool

This tool creates a center line mark for circles and arcs. The center mark 
overlap can be defined in the Status Line or the Edit Objects dialog box. 
The overlap units are based on those in the Units page of Preferences.

Using the Center Mark Dimension Tool
1. Select the Center Mark Dimension tool. The Message Line reads: Center 

Mark: Select circle for center mark [Shift = Extend].

2. Select the circle or arc you want to dimension. Hold down the SHIFT key if 
you want to dimension more than one object at the same time.

You can change the Axis overlap value in the Status Line. Type the value and 
press ENTER (Windows) or RETURN (Macintosh) and the overlap updates.

The Status Line contains the Axis overlap data field.

Balloon Dimension Tools

These tools dimension objects with a callout bal-
loons. You have nine balloon tools available in the 
Message Line: Circle, Rectangle, Triangle, Inverted 
Triangle, Octagon, Ob-round, Split Circle, Split Rect-
angle and Callout.

Use the Status Line or the Edit Objects dialog box to change the text or width of the bal-
loon dimension. The width units are based on those set in the Units page of Preferences.

Using a Balloon Dimension Tool
1. Select the Balloon Dimension tool. The Message Line reads: Balloon: Enter 2 points 

for balloon dimension.



Vertical Dimension Tools
2. Click the point on the geometry for the dimension arrow.

3. Click the second point to specify the location of the symbol.

The balloon symbol appears. 

4. Enter the text and frame width in the Status Line data fields. Press ENTER (Windows) 
or RETURN (Macintosh) to update the dimension.

You can move the dimension by choosing the Selection tool, selecting the dimension, 
placing the pointer over the end of the leader line and when the pointer becomes the 
Move symbol, dragging the text to a new location.

Balloon dimension text does not increment as you place additional balloons. If you want 
specific text in the balloon dimension, you must enter it yourself.

The Status Line contains Text and Width data fields.

Geometric Characteristics
According to the Edit Objects dialog box a balloon dimension includes the following char-
acteristics: Frame, Width, Text 1, Text 2 (when a split balloon is used) and Extension. The 
Frame pull-down menu lists all available balloon symbols. Width defines the symbol 
width. Text 1 sets the upper text in a split balloon. Text 2 sets the lower text in a split bal-
loon. 

The extension is the line distance from the symbol to the leader line. In 
the graphic here the horizontal line is the extension.

Length Along Curve Dimension Tool

This tool dimensions curved objects such as splines.

Using the Length Along Curve Dimension Tool
1. Select the Lingth Along Curve Dimension tool. The Message Line reads: Length 

Dimension: Specify two points along curve.

2. Click the first point along the curve.

3. Click the second point along the curve.
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GDT Feature Control Tool

Selecting this icon from the dimensioning tool palette activates the new GD&T tool. The 
prompt message requests the input of 2 leader points. The first point defines the arrow 
location. The second point defines the shoulder location. After the leader points have been 
specified, the Feature Control dialog box is displayed. This dialog box contains the Size 
and Feature Control tab pages.

Size Tab Page
The Size tab page is used to define the basic dimension and tolerance values along with 
other optional modifiers. This size specification is also known as the Limits of Size. 
Selecting one of the five Tolerance Layout radio buttons controls the tolerance style. The 
dialog controls are re-positioned to match the current Tolerance Layout selection.

Feature Control Page
The Feature Control tab page is used to define the geometric relationships for the dimen-
sioned feature. Selecting one of the four Frame Style radio buttons controls the layout for 
the feature control frames. The supported frame styles are: None, Single, Dual, and Com-
posite. The dialog controls are re-positioned to match the current Tolerance Layout selec-
tion. The Feature Control tab also uses 2 additional support dialogs; Unit Basis and Datum 
Reference. The Unit Basis dialog is displayed by clicking on the region of the dialog box. 
The Datum Reference dialog is displayed by clicking on the region of the dialog box.



Vertical Dimension Tools
Unit Basis Dialog
When appropriate for a feature, the Unit Basis Dialog defines the unit basis interval (sub-
region) over which the tolerance value is applied. The unit basis interval can be one of 
“None”, “Linear”, and “Area”. A “None” interval (the default) applies the allowed toler-
ance over the entire feature. A “Linear” interval applies the allowed tolerance per any lin-
ear sub-length along the feature. An “Area” interval applies the allowed tolerance per any 
rectangular sub-area of the feature. If a linear interval is defined, the Feature Control tab 
page will display a /L indicator. If an area interval is defined, the Feature Control tab page 
will display a /LxW indicator.

Datum Reference Dialong
When appropriate for a feature, the Datum Reference Dialog associates existing datum 
planes (local coordinate origin) with the dimension. A maximum of 3 datums (Primary, 
Secondary, Tertiary) can be associated with a feature control frame. A datum must be fully 
defined in order to add another datum reference. A datum consists of a datum letter (any 
combination of the letters A-H,J-N,P,R-Z. I,O, and Q are not allowed) and an optional 
modifier symbol. For a multiple datum, a second datum letter and optional modifier sym-
bol follow a dash.
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Tech Note:

The number of decimals dis-
played with your dimensions 
is not affected by the number 
of decimals specified for units 
in Preferences.
Dimension Appearance 
This Designer Elements program automatically creates dimen-
sions according to ANSI Y14.5, DIN, ISO or JIS standards. 
However, many companies and individuals have developed 
their own standards. The commands in the Dimension menu 
allow you to control virtually every aspect of the dimension 
appearance without having to construct dimensions manually 
and while retaining the associativity of Vellum’s smart dimen-
sions.

Settings made in the Dimension menu affect the currently 
selected dimension and all future dimensions.

Linear
This command in the Dimension menu allows you 
to set the decimal precision.

All dimensions in this Designer Elements program 
are displayed in decimals regardless of the units set 
in Preferences. 

If Feet/inches units is set in Preferences, objects 
over one foot in length will display both feet and 
inches.

This Designer Elements program does not support 
dimensioning in fractions. The default is three decimal places.

Linear Tolerance
The Linear command in the Dimension menu allows you to set the tolerance for the fol-
lowing Linear Dimension tools: Horizontal Dimension tool, Vertical Dimension tool, 
Oblique Dimension tool, Angular Dimension tool and Smart Dimension tool. Choose 
Dimension>Linear to select one of the seven tolerance options.

1’ - 7”



Dimension Appearance
The following graphic shows the appearance of each tolerance option if you entered the 
limits shown in the Status Line.

When you select a Dimension tool, such as the Horizontal Dimension tool, the Status Line 
includes data fields for the upper and lower tolerances, as shown here.
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To set the number of decimal places for the linear tolerance, choose Dimension>Linear 
Tol.

Angular 

This command in the Dimension menu 
allows you to set the format of Angular 
dimensions. 

You can set degrees, minutes and seconds 
for angular dimensions. The default for-
mat is degrees and minutes. 



Dimension Appearance
Text
This command in the Dimension menu allows you to 
specify the position and orientation of dimension 
text.

The default is Horizontal text. The Break-in, Over 
and Under options produce text that is aligned with 
dimension leader lines. Over and Under display text 
above or below leader lines while Break-in places the 
text between leader lines.
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Tip:

This command only affects 
dimensions.To change the 
font of other text objects, 
choose Text>Font.

The Font submenu in the Text 
menu has no effect on 
dimensions. 

Tip:

This command only affects 
dimensions. To change the 
size of other text objects, use 
Edit Objects or the Size sub-
menu from the Text menu.

The Size submenu from the 
Text menu has no effect on 
dimensions. 
Font
This command in the Dimension menu 
lets you pick the font for dimension text. 
The fonts in this list are the same as those 
available in the Font submenu from the 
Text menu. 

Size
This command in the Dimension menu lets you pick the 
size of dimension text only. The sizes in this list are the 
same as those available in the Size submenu from the 
Text menu.

Selecting the User option allows you to specify a non-
standard font size for dimension text.

Selecting the Model option displays the text size in the 
Units you specified in Preferences. Selecting the Points 
option, displays the point size of the text. Select the 
desired radio button, enter a value in the data field and 
click OK.



Dimension Appearance

Tip:

This command only affects 
dimensions. To change the 
style of other text objects, 
use the Style submenu from 
the Text menu.

The Style submenu from the 
Text menu has no effect on 
dimensions.

Tip:

This command only affects 
dimensions. To change the 
color of other objects, use 
Edit Objects or the Color 
submenu from the Pen menu.

The Color submenu from the 
Pen menu has no effect on 
dimensions. 
Style
This command in the Dimension menu lets you pick the 
style of dimension text, Normal, Bold, Italic and Under-
line. The styles in this list are the same as those available 
in the Style submenu from the Text menu. However, these 
settings do not affect those in the Text menu.

Color
This command in the Dimension menu allows you to 
specify the color of the dimension. The default color 
is blue.
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Tip:

This command only affects 
dimensions. To change the 
weight of other objects, use 
Edit Objects or the Weight 
submenu from the Pen menu.

The Weight submenu from 
the Pen menu has no effect 
on dimensions. 
Weight
This command in the Dimension menu allows you to spec-
ify the weight of dimension lines.

Dimension lines are typically drawn in the thinnest weight 
available. For this Designer Elements program, that is 
0.002" or 0.05mm. The default weight is 0.002" or 
0.05mm.

Layer
This command in the Dimension menu allows you to specify the 
layer on which dimensions are placed. This command does not apply 
to dimensions placed within drawing views. These are automatically 
placed on the Sheet View layer. See Chapter 36 for information on 
drawing views.

When you select this command the following dialog box appears:

Dimensions can be placed on any visible layer. In the pull-down menu you can select a 
layer for your dimensions. The default layer is the Dimension layer. 



Dimension Appearance

Tip:

This command only affects 
dimensions. To select the 
arrowhead type for lines or 
arcs, use the Arrowheads 
submenu from the Pen menu.

The Arrowheads submenu 
from the Pen menu has no 
effect on dimensions. 
You can place the dimensions on a new layer not yet created by clicking the Create New 
Layer button. The data field displays the new layer name. Give the layer a new name if 
desired. Click OK to save the change.

If the layer on which dimensions are to be placed is hidden or deleted, future dimensions 
will be placed on the current work layer.

Arrowheads 
This command in the Dimension menu allows you to spec-
ify the type of arrowhead used for dimensions. 

Arrow Size Command
This command in the Dimension menu lets you specify the 
size of the arrowhead that you have selected.
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When you select this command the following dialog box 
appears: This dialog box includes:

Diameter/Length This value is the diame-
ter or length of dots, 
slash and standard arrow 
styles. The value here 
affects all Length, Side 
and Angle fields. The 
value displayed is in the 
current units specified in 
the Units page of the 
Preferences dialog box.

Length This value is the length 
of the arrowhead as the horizontal distance from its tip 
to the furthest extension of its base.

Height This value is the height of the arrowhead as the vertical 
distance of its base.

Side This value is the edge length of the arrowhead.

Angle This value is the angle of the tip of the arrowhead.

If you change any value in the Length, Height, Side, or Angle entry fields, this Designer 
Elements program will change the values in the other entry fields accordingly.



Dimension Appearance

Tech Note:

The default dimension stan-
dard is ANSI. The actual set-
ting does not save with files.
Witness Lines
This command in the Dimension menu lets you specify 
which sides of the linear dimension should have witness 
lines. 

A check mark indicates that a witness line will be 
placed at the specified location. This option is useful to 
plot a drawing that contains baseline or chain dimen-
sions. By turning off one or more of the overlapping 
witness lines, you can prevent the plotter from drawing 
multiple witness lines when only one is needed.

The Start of a dimension is the first point clicked. The 
End of a dimension is the last point clicked. The default 
settings have witness lines at both the start and end of a 
dimension.

This command affects only linear dimensions. Radial and diametric dimensions are not 
affected by the settings made in the Witness Lines command.

Dimension Standards
The dimension standards feature has been modified to allow you to manage and define 
your own standards and specify which standard is used from the Standards submenu in the 
Dimension menu.

A user-defined standard contains all the current Dimension menu settings at the time the 
Standard Settings dialog box appears. This includes dimension text font, style and size. It 
does not include the Witness Line setting.
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Standards Settings Manager
Dimension standards are set through the Standards Settings dialog 
box displayed by choosing Dimension>Standards Settings.

Standard This pull-down lets you set the dimension standard. 
This Designer Elements program contains settings for 
ANSI, DIN, ISO, JIS and the new Architecture, Dual 
Side, Dual Stacked and Stacked Fraction default stan-
dards. These default standards cannot be altered. How-
ever you can create user-defined standards and save 
them under their own name. Examples of each default 
standard follow this section.

Text Offset This entry field controls the distance from the base of 
the dimension text to the leader lines. A positive entry 
places the text above the leader lines, and a negative 
value places it below the leader lines. A zero value 
places the text on the leader lines.

# Next Offset This entry field controls the perpendicular distance 
between subsequent leader lines.



Dimension Appearance
First Offset This entry field controls the perpendicular distance 
between the object being dimensioned and the leader 
line and dimension text.

Changes to this value only affect new dimensions.

Arrow Leader This entry field controls the distance the leader lines 
extend beyond the witness lines when the arrows 
appear outside of the witness lines.

Ext Over This entry field controls the distance the witness lines 
extend beyond the leader lines.

Ext Gap This entry field controls the distance between the 
dimension point and the witness lines.

Delete Click this button to delete a user-defined standard. 
(This button is unavailable for the ANSI, DIN, ISO, 
JIS, Architecture, Dual Side, Dual Stacked and 
Stacked Fraction default standards.)

Cancel Click this button to close the dialog box without 
accepting any changes.

Save As Click this button to save the settings for a user-defined 
standard under a new name.

Save Click this button to save changes to a user-defined 
standard. (This button is unavailable for the ANSI, 
DIN, ISO, JIS, Architecture, Dual Side, Dual Stacked 
and Stacked Fraction default standards.)

ANSI Standard DIN Standard

ISO Standard JIS Standard
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Setting the Standard
A Standards menu allows you to set the standard 
as the default or change the standard for a selected 
dimension. If you have created user-defined stan-
dards, they are also listed in the Standards menu.

Choosing a Standard
You can choose one of the predefined standards or 
a user-defined standard. Changing the standard 
will also change the Dimension menu settings. If 
no dimension is selected, you are setting the 
default standard. If one or more dimensions are 
selected, you are only changing the standard for 
the selected dimensions.

1. Choose Dimension>Standards.

2. In the Standards submenu, choose one of the 
listed standards.

3. Click OK to accept the standard as the default 
and close the dialog box.

Creating a User-defined Standard
1. Choose Dimension>Standards Settings.

2. Enter values in the desired fields.

3. Click Save As.

Architectural Standard Dual Side Standard

Dual Stacked Standard Stacked Fraction Standard



Dimensions and Drawing Views
An Input String dialog box appears with a Standard 
Name data field.

4. Enter a new name in the data field.

5. Click OK to close the dialog box and save the new stan-
dard.

You can later delete this user-defined standard through 
the Standards Settings dialog box. This standard also 
adds to the Standards menu.

Dimensions and Drawing Views
If dimensions in the drawing view go outside the bounds of the view so that you can’t see 
them, choose the Frame to Extent command in the Drawing View menu. You can also drag 
the view edge manually to completely display the dimension. See Chapter 36 for informa-
tion on drawing views.

Dimensions created in drawing views are placed on the Sheet View layer rather than the 
Dimension layer. This allows you to turn off all other layers including the Dimension layer 
when printing the sheet. This is helpful when you have dimensioned the original geometry 
and do not wish to print those dimensions.
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Tech Note:

Fill Pattern and Fill Color are 
not the same as Crosshatch-
ing or Solid Fills. Fill Pattern 
and Fill Color are predefined 
bitmaps and cannot be 
edited.
Fill and Crosshatching
This Designer Elements program provides you with the ability to apply fill to smart 
polygons and to apply crosshatching to your geometry. This is especially useful for 
setting certain objects apart visually.

This chapter covers the following topics:

• Fill Pattern and Fill Color

• Crosshatching

Fill Pattern and Fill Color
This Designer Elements program provides Fill Patterns and Fill Color for Smart 
Polygons created with the Polygon tools: Rectangle, Inscribed Polygon, Circum-
scribed Polygon, Arbitrary Polygon and Polygon from Curves. These patterns and col-
ors enable you to highlight the polygons or separate overlapping polygons visually 
in your drawing. After creating the polygon, you place a fill pattern and fill color in 
the polygon. If you make changes to the polygon the pattern and color automati-
cally update.
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In the Pen menu you will find the two fill commands—Fill 
Pattern and Fill Color.

These commands work with each other. Using the Fill Pattern 
command, choose the pattern for your polygon. Using the Fill 
Color command, choose the pattern color.

Fill Pattern
A wide variety fill patterns are available. Patterns appear 
parallel to the work plane and only in the view in which 
they were added. In other words, patterns are drawn cor-
rectly when viewed along the z-axis of the work plane.

When you select the Fill Pattern command a submenu dis-
plays. You have the option to choose None (for no fill) or 
one of eight patterns (including solid fill) as shown here.

If you select Pen>Fill Pattern>More, the Patterns option 
box appears providing you more patterns.



Fill Pattern and Fill Color
The patterns are enlarged below for clarity.

You cannot edit these patterns. They are predefined bitmaps. The default pattern is 
None.

Choosing a Fill Pattern
1. Choose the Selection tool.

2. Select the polygon that you want to display with a fill pattern.    Hold down the 
SHIFT key to select more than one polygon.

One example is displayed here.

3. Choose Pen>Fill Pattern and one of the fill pat-
terns.

(If you choose a fill pattern from the Patterns option 
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box, a selection box will appear around the pattern.)

The polygon is filled with the selected pattern.

Fill Patterns and Holes
This Designer Elements program does not support the placement of “holes” in poly-
gons. However, you can place a polygon within another polygon and choose a 
solid white fill to give the illusion of a hole.

Using the example above you would get the follow-
ing result.

Overlapping Objects and Patterns
Since you can have multiple objects with multiple 
patterns displayed in your drawing, there may be 
times when some overlapping occurs.

You can specify the order of the overlapping in two ways:

• Select the objects with the Selection tool in the reverse order that they are dis-
played on the screen

• Adjust the placement of the objects using the Arrange command in the Layout 
menu (see Chapter 24 for more information on using this command).

You can use the Group command in the Layout menu to keep the patterned objects 
in the specified ordered.

Changing the Existing Pattern of a Polygon
1. Select the existing polygon with the Selection tool.



Fill Pattern and Fill Color
2. In the Pen menu, choose a new pattern from the Fill Pattern submenu.

The fill pattern changes as you specified.

Removing the Fill Pattern
1. Select the existing polygon with the Selection tool.

2. In the Pen menu, choose None from the Fill Pattern submenu.

The fill pattern is removed.

You can also double-click the object to display the Edit Objects dialog box and 
change the Fill characteristic from Yes to No.

Fill Color
This command in the Pen menu works only with the Fill 
Pattern command.

The submenu displays the same colors available for cre-
ating geometry (see Chapter 5, “Pen Settings”).

You can choose a specific color for all fill patterns. The 
default color is black.

Choosing a Fill Color
1. Choose the Selection tool.

2. Select the polygon you want to fill.

Hold down the SHIFT key to select more than one 
polygon.

3. Select the fill color. The color displays.

4. Choose Pen>Fill Color and select the desired color.

The new fill pattern color is displayed in your polygon.

You cannot choose a fill color for a polygon that does not contain a pattern.

Changing the Color of an Existing Fill
1. Select the existing polygon by clicking it with the Selection tool.

2. In the Pen menu, choose a new color from the Fill Color submenu.

The fill pattern color changes as you specified.
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Crosshatching
This Designer Elements program can crosshatch any enclosed area in your drawing 
and then automatically update the crosshatching when you change the geometry. 
You can select a closed area containing a hole or cutout and this Designer Elements 
program accurately excludes the cutout area from the crosshatching. Crosshatching 
can also be applied to section cuts made through your geometry when using the 
drawing composition tools.

The Pen menu contains two crosshatching commands: Cross Hatch and Hatch. Use 
these to apply crosshatch patterns to your geometry.

Cross Hatch Patterns
You have a wide variety of crosshatch patterns available to you in both ISO and 
DIN styles. Choosing Pen>Cross Hatch brings up a dialog box. If no objects are 
selected the dialog box is called, Default Cross Hatch. If objects are selected, the 
dialog box is called Object Cross Hatch.

The dialog box contains the following options:

Standard This option sets the crosshatching standard. Select 
either the ISO (International Standards Organiza-
tion) standard or the DIN (German Standards Insti-
tute) standard from the pull-down menu.



Crosshatching
Category This section lists the hatch categories available for 
the selected standard.

Cross Hatch This section lists the crosshatch patterns available 
for the selected category.

Pattern Window This window, to the right of the Cross Hatch list, 
displays the selected crosshatch pattern.

Rotation (Settings) This field sets the rotation angle of the 
crosshatch pattern.

Scale (Settings) This field sets the scale of the crosshatch 
pattern.

Set Default (Default Cross Hatch dialog box) Click this button 
to set the default crosshatch pattern for your draw-
ing.

Apply (Object Cross Hatch dialog box) Click this button 
to apply the crosshatch pattern to the selected 
object.

ISO Patterns
If you choose the ISO standard the ISO categories and crosshatch patterns display 
in the dialog box.
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The categories for the ISO standard are:

Metals The patterns in this category include: Iron, Steel, 
Bronze/Copper, Zink, Aluminum and Titanium.

Masonry The patterns in this category include: Brick and 
Concrete.

Other The patterns in this category include: Rubber, Elec-
tric, Marble/Glass, Thread, Grass, Earth, Fabric, 
Insulation and Mud.

DIN Patterns
If you choose the DIN standard the DIN categories and crosshatch patterns display 
in the dialog box.

The categories for the DIN standard are:

Metals The patterns in this category include: Bronze, Steel 
(Alloy), Steel (Non-Alloy), Cast Iron, Metal (Light) 
and Metal (Heavy).

Minerals The patterns in this category include: Rock, Sand, 
Clay, Peat/Humus Soil, Coal, Salt and Sandstone.



Crosshatching
Plants The patterns in this category include: Wood (Hori-
zontal Grain), Wood (Vertical Grain), Wood (Mate-
rials), Wood (Cut) and Tar.

Other The patterns in this category include: Masonry 
(Brick Work), Masonry (Increased Strength), 
Masonry (Light Brick), Masonry (Pumice) Plaster 
Plate, Plaster (Mortar I), Plaster (Mortar II), Con-
crete (Reinforced), Concrete (Non-reinforced), 
Concrete (Pumice) and Concrete (Waterproof).

Crosshatch Command
This command in the Pen menu enables you to apply crosshatching to your geom-
etry.

Setting the Default Hatch Patterns
When no objects are selected, you can set the default crosshatch pattern for the cur-
rent session of this Designer Elements program.

1. Choose Pen>Cross Hatch. The Default Cross Hatch dialog box appears.

2. Choose the crosshatch standard from the pull-down menu.

3. Choose the category and the crosshatch pattern. The pattern appears in the pat-
tern window.

4. Specify a rotation angle and scale.

5. Click Set Default. The default crosshatch pattern is set.

6. Click the Close button (Windows) or the Close box (Macintosh) to close the 
dialog box.

If you choose the Hatch command in the Pen menu this default pattern is applied 
to your selected geometry.
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Applying a Crosshatch Pattern for an Object
If one or more objects are selected, you can choose a specific crosshatching for 
them without changing the default.

1. Select the object you want to crosshatch.

2. If you want to apply the default crosshatch, choose Pen>Hatch and the object 
is crosshatched.

If you want to apply a different crosshatch, choose Pen>Cross Hatch. The 
Object Cross Hatch dialog box appears.

3. Choose the crosshatch standard from the pull-down menu.

4. Choose the category and the crosshatch pattern. The pattern appears in the pat-
tern window.

5. Specify a rotation angle and scale.

6. Click Apply. The pattern is applied to the selected object.

7. Click the Close button (Windows) or the Close box (Macintosh) to close the 
dialog box.

Geometric Characteristics
According to the Geometry page of the Edit Objects dialog box, crosshatching has 
the following characteristics: Rotation and Scale. You can change the values and 
click ENTER (Windows) or RETURN (Macintosh) to alter the hatching.

Hatch Command
This command in the Pen menu crosshatches the selected objects using the default 
crosshatch pattern.

1. Select the object you want to crosshatch.

2. Choose Pen>Hatch.

The selected object crosshatches with the default pattern.

Editing Hatching
You can edit a crosshatch pattern for a selected object by changing the pattern, 
rotation or scale. 

To change the hatch pattern select the hatching within the object and choose 
Pen>Cross Hatch. Change the hatching and click Apply.



Crosshatching
To change the hatch pattern rotation angle and scale you can do so in the Object 
Cross Hatch dialog box or in the Edit Objects dialog box.

Crosshatching and Section Cuts
Crosshatching is especially valuable for sections cuts created using the drawing 
composition tools.

When hatching is placed in a section cut the default hatch pattern is used. Like any 
other crosshatch pattern, you can change the pattern, rotation and scale. You can 
also choose different hatch patterns for objects cut in the same section. See Chapter 
36, “Drawing Composition,” for information on sections and the drawing composi-
tion tools.
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Symbols
In this Designer Elements program, symbols are used to define 2D or 3D shapes 
that frequently occur throughout a drawing. They can be wireframe, surface or 
solid objects. When used properly, symbols and instances dramatically speed the 
design and drafting process while reducing your file size.

An instance is a copy of the original or master geometry. It is created when you 
place a symbol in your drawing or modify that symbol by moving, rotating or scal-
ing it.

A symbol consists of a master symbol composed of geometry (text and dimensions 
are not supported) which is instanced into a drawing by clicking the placement 
location. Once a symbol is placed you can use the Transformation tools to move, 
rotate, scale or mirror it.

Symbols are created and organized through the Symbol Manager. Once the symbols 
are created use the Symbol tools to place them into your drawing. 

The following topics are covered in this chapter:

• Symbol Palette

• Symbol Manager

• Creating Symbols

• Symbol Tools

• Symbol Example

• Transforming Symbols
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• Editing Symbols

• Symbols and Rendering

• Symbols and Files

Symbol Palette
The symbol tools are contained in the Symbol tool palette. To display the 
palette choose Window>Symbols.

The default status of the Symbol palette is closed and the default location is 
below the main tool palette. Like the other palettes, you can save the status 

and location of the palette anywhere in your drawing area.

There are two tools for placing symbols into your drawing, Symbol 1 Point and Sym-
bol 2 Point. Before you are able to use these tools, you must create the symbol 
through the Symbol Manager. Once you create your symbol, use one of these tools 
to place it into your drawing.

Symbol Manager
Use the Symbol Manager to 
create and organize symbols 
in your drawing file. To dis-
play the Symbol Manager 
select one of the symbol 
tools and press the CTRL key 
(Windows) or the OPTION 
key (Macintosh).

The Symbol Manager con-
tains the following elements:

Symbol Name This list displays the names of all master symbols 
contained in the file whether or not they are 
instanced into the drawing.

# Used Lists the number of times a master symbol is 
instanced into your drawing.



Creating Symbols
Preview Displays a 2D preview of the selected symbol in 
window.

Rename Allows you to rename any of the symbols in your 
drawing. When you initially create a symbol this 
Designer Elements program automatically provides 
a name.

To change the symbol name, select the symbol 
name from the list and enter a new name in the 
Rename data field. The name updates as you type.

New Opens the Edit Symbol drawing screen for creating 
a new symbol.

Edit Opens the Edit Symbol drawing screen to edit a 
selected symbol in the Symbol Name list.

Delete Deletes the selected symbol and all instances (cop-
ies) of the symbol is your drawing.

If you have instances 
of the symbol in 
your drawing when 
you click this button, 
the following dialog 
box appears.

Click Yes to delete the symbol and all instances or 
No to close the box and return to the Symbol Man-
ager.

Creating Symbols
Creating symbols is identical to creating any geometry in this Designer Elements 
program. Symbols cannot contain text or dimensions. When you create a symbol, 
you are creating a master. You place copies or instances of this symbol into your 
drawing using one of the symbol tools.

1. Select a symbol tool.

2. Press CTRL (Windows) or OPTION (Macintosh) to display the Symbol Manager.
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3. Click the New button. The Symbol Edit screen displays.

The screen is almost identical to the standard drawing area except for the EXIT 
Edit Symbol button and the Symbol Edit name in the Work Layer Indicator.

EXIT Edit Symbol Click this button in the upper right corner of the 
drawing area when you finish creating your sym-
bol geometry to return to the drawing area.

Symbol Edit This name in the Work Layer Indicator indicates 
you are in the Symbol Edit screen. This layer is not 
accessible in the Layer Manager.

The Axis is located at the origin for a master symbol. The origin is repre-
sented by this marker.

4. Create your symbol geometry. 

Use all of the tools and commands of this Designer Elements program.

5. When you complete your symbol geometry, click the EXIT Edit Symbol button 
to return to the standard drawing area.



Symbol Tools
Follow these steps to create more symbols for your file.

Like all other geometry, symbols are saved with your file. They do not become a 
part of a library for use with other files.

This Designer Elements program does not support text or dimensions with symbols.

Symbol Tools
This Designer Elements program include two symbol tools for instancing symbols 
into your drawing, Symbol 1 Point and Symbol 2 Points.

Symbol 1 Point Tool

The Symbol 1 Point tool places a copy of the selected symbol at the location you 
specify. The symbol x-axis is aligned with the x-axis of the work plane.

Using the Symbol 1 Point Tool
1. Select the Symbol 1 Point tool. The Message Line reads: Symbol 1 

Point: Enter location for symbol [Ctrl (Windows) or Option (Macin-
tosh) = Symbol Manager].

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display 
the Symbol Manager.

3. Select the symbol you want to place in your drawing.

4. Click OK to close the Symbol Manager dialog box.

The Message Line displays the name of the selected symbol.

5. Click in the drawing area to set the symbol's origin (as defined by the master). 

The symbol is placed in your drawing. You can place as many instances of the 
symbol as you desire.

Symbol 2 Points Tool

The Symbol 2 Points tool places a copy of the selected 
symbol at the origin and lever point you specify. The 

Origin Lever
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lever point defines a rotation for the inserted angle and represents the top right cor-
ner of the symbol. See the graphic here.

Using the Symbol 2 Points Tool
1. Select the Symbol 2 Points tool. The Message Line reads: Symbol 2 

Points: Enter symbol origin and lever point [Ctrl (Windows) or Option 
(Macintosh) = Symbol Manager].

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display 
the Symbol Manager.

3. Select the symbol you want to place in your drawing.

4. Click OK to close the Symbol Manager dialog box.

The Message Line displays the name of the selected symbol.

5. Click the location for the symbol origin. The location is the symbol origin 
defined by the master symbol.

6. Click the lever point. The symbol is placed in your drawing. 

You can place as many copies of the symbol is your drawing as you desire.

Symbol Example
Try this simple example of creating and placing a symbol.

1. Open a new file.

2. Choose Window>Symbols to display the Symbol tools palette, if it is not 
already displayed.

3. Select the Symbol 2 Points tool.

4. Press the CTRL key (Windows) or the OPTION key (Macintosh) to dis-
play the Symbol Manager.

5. Click on the New button. The Symbol Edit screen appears.

6. Create an object similar to the graphic here.



Symbol Example
7. Once you've completed your symbol, select the Symbol 2 Point tool and then 
click the EXIT Edit Symbol button in the upper right corner.

8. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the 
Symbol Manager.
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Your symbol geometry is displayed in the Preview window with a default name in 
the Symbol Name list.

9. In the Rename field, already highlighted, type BoomBox. As you type, the name 
is replaced in the Symbol Name list.

10. Click OK to accept the name and close the Symbol Manager.

The Message Line now includes the name, BoomBox. (If it does not click the Sym-
bol 2 Points tool again.)

11. In your drawing click to place the origin point.

12. Move the cursor to the right horizontally using the Drafting Assistant and click 
to place the lever point.

The BoomBox symbol is placed in your drawing. If you had clicked a level point 
at a 45° angle, the BoomBox Symbol would have been placed at that angle.

13. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the 
Symbol Manager. The # Used field shows that the symbols was instanced once 
in your drawing.

Using the Transformation tools you can now perform numerous operations on the 
symbol.

Transforming a Symbol
Once you place a symbol you can use the Transformation tools to do some manipu-
lation. You can move, rotate, scale or mirror the symbols. Follow the steps for using 
these tools in Chapter 25, “Transforming Geometry.”

You can also move a symbol with the arrow keys and the Selection tool. Select a 
symbol by dragging a selection fence around it.

Editing a Symbol
Symbols cannot be edited in your drawing area, only in the Symbol Edit screen.

1. Select a symbol tool.

2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Sym-
bol Manager.



Symbols and Rendering
3. Select the symbol you want to edit.

4. Click on the Edit button.

The Symbol Edit screen displays.

5. Make your changes.

6. Click the EXIT Edit Symbol button.

All symbol instances of the edited master symbol are updated.

Symbols and Rendering
This Designer Elements program does not support the rendering of symbols. If you 
want a symbol to render you must open the symbol through the Symbol Manager, 
copy the symbol and paste it into your drawing. Then the object, which is no 
longer a symbol, can be rendered.

Symbols and Files
Sometimes you may have symbols you want to use in more than one file or that 
were created elsewhere.

Using Symbols in Other Files
Symbols are file specific Symbols created in one file are not automatically available 
as a symbol for other files. However, if open the file in the Symbol Manager, you 
can copy and paste the geometry into a new Symbol Edit screen in another file. 
This way you won't have to recreate the geometry.

This Designer Elements program does not support Symbol libraries.

Importing
You can import drawing files into this Designer Elements program and then place 
that geometry within the Symbol Edit screen by copying and pasting. You can make 
additions to the symbol in the Symbol Edit screen.

This Designer Elements program does not automatically support importing symbols 
from Vellum 3D. Geometry from a symbol file can be imported into this Designer 
Elements program copied and then pasted into the Symbol Edit screen as men-
tioned above.
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Viewing Geometry
In this Designer Elements program you create your geometry in one model space 
and view it from many different angles and view scales as needed. A view describes 
the orientation of your eye position and direction toward your geometry.   You can 
use a number of tools and commands to help you to view your geometry. The fol-
lowing topics are covered:

• Zooming

• Panning

• View Displays

• View Rotation

• View Commands

• Views and Planes

• Views and Zoom Scale

Zooming 
This Designer Elements program gives you several ways to change the magnifica-
tion of your drawing by zooming in and out using commands, zoom tools, and 
strokes.
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Zoom Commands
Zoom In, Zoom Out, Zoom All, Zoom Previous, Zoom Window, Zoom Home and 
Zoom Ratio from the View menu change the view magnification of your geometry 
depending upon your selection and input. If you want to zoom a particular area, 
use the Stroke feature or the Zoom tool, described later in this chapter.

Zoom All - CTRL+F (Windows); z +(Macintosh)
This command in the View menu zooms in or out to make all objects on your draw-
ing fill the screen, regardless of the size of the objects. 

Zoom In - CTRL+] (Windows); z +] (Macintosh)
This command in the View menu zooms in to the screen center by a factor of two.

Zoom Out - CTRL+[ (Windows); z +[ (Macintosh)
This command in the View menu zooms out from the screen center by a factor of 
two. 

Zoom Previous
This command in the View menu zooms to the previous magnification.

Zoom Window - ALT+4 (Windows); z +4 (Macintosh)
This command in the View menu allows you to drag a selection fence around the 
desired view window (from the upper left to the lower right).

Zoom Home - ALT+6 (Windows); z +6(Macintosh)
This command in the View menu adjusts the view scale so that the origin of the 
drawing (0, 0, 0) is centered on the screen. 

Zoom Ratio Command
This command in the View menu displays an Input String dia-
log box. 

Enter a ratio in the data field. A value of .5 zooms out by a fac-
tor of two. A value of 2 zooms in by a factor of two. Click OK 
to close the dialog box and save the value. Your drawing scales to the value.



Zooming

Tip:

Using the CTRL (Windows) 
or the OPTION (Macintosh) 
key, you can toggle between 
the Zoom In and Zoom 
Out tool.
Zoom Tools 

The Zoom tools are located in the View tool palette. 

Using the Magnifying Glass Tool
With the Zoom tools you drag a selection fence around an area on the screen, so 
only that area is displayed. 

1. Select the Zoom tool from the tool palette. 

2. Drag a box around the area on the screen you want to magnify or reduce. 

3. Release the mouse button. The content of the dragged box is displayed.

Zoom Tool

This tool zooms in by the specified factor. The default factor is two. You can also 
specify a zoom scale (1 = full scale) in the Scale field of the Status Line. Zooming 
causes a visual rather than a physical change.

1. Choose the Zoom In tool. The Message Line reads: Zoom In: Pick area to 
enlarge [Ctrl (Windows) or Option (Macintosh) = Zoom Out].

If you want a specified zoom scale, enter the value in the Scale data field.

2. Click in the drawing area; that position is displayed in the center of the screen 
and the drawing is enlarged by a factor of two. You can also drag a selection 
fence around an area, so only that area is displayed.

The Status Line contains the Scale data field.

Pressing the CTRL (Windows) or the OPTION (Macintosh) key while using this tool 
causes it to change to the Zoom Out tool.

Using the Dynamic Pan Tool

This tool is located in the View tool palette at the bottom of the main tool palette. 
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Tech Note:

Windows users: The Stroke 
Zoom function is not acces-
sible for tools that already 
use the SHIFT and CTRL 
keys. This note is repeated in 
the chapters containing the 
tools to which this applies.
1. Select the Dynamic Pan tool. The Message 
Line reads: Dynamic Pan: Drag mouse to 
translate view.

The pointer becomes a hand icon.

2. Place your pointer over the section of the screen you want to move and drag.

When you release the mouse, the view has been repositioned. Notice that the 
scroll bars have adjusted accordingly. 

Dynamic Zoom Tool 

This tool zooms in or out by the amount specified by your stroke in the drawing 
area. 

1. Choose the Dynamic Zoom tool. The Mes-
sage Line reads: Dynamic Zoom: Drag 
mouse to zoom view. Move right zooms out.

2. Move the cursor to the drawing area. The cursor becomes the dynamic zoom 
icon. 

3. Drag the mouse to the right to zoom out or to the left to zoom in. The view 
scale changes according to your stroke.

Stroke Zoom 
You can use stroke commands to zoom—magnify or reduce your drawing. Stroke 
commands are useful because they don’t require you to get out of the tool you’re 
using in order to zoom. Hold down the SHIFT+CTRL keys (Windows) or the z  key 
(Macintosh) and drag diagonally across the screen as described below. The pointer 
takes on the z  shape when you hold down the SHIFT+CTRL (Windows) or the z 
key (Macintosh) keys.

This Designer Elements program remembers up to eight zoom strokes, enabling 
you to return to previous zoom magnifications.



Panning a View
Using Stroke Zoom 

Drag Diagonally Result 

Upper left to lower right Zoom-in enlargement: centered over the stroked 
area. 

Lower right to upper left Zoom Previous: Reverses Zoom In stroke to the 
previous magnification. 

Upper right to lower left Zoom-out reduction: the current screen reduces to 
the size of the area defined by the stroke. 

Lower left to upper right Zoom Previous: Reverses Zoom Out stroke to pre-
vious magnification. 

Note: For Zoom In and Zoom Out, the size and location of the stroke rectangle is 
important for determining the result of the Zoom operation. For Zoom Previous, the 
size and location of the stroke rectangle is irrelevant. All cases just give the previous 
magnification. 

Zooming and Views
This Designer Elements program retains the last zoom scale that you set in a partic-
ular view. When you zoom in a particular view, change views and zoom in the new 
view, the view scale in the previous view is not affected. 

Panning a View 
You may want to move your view around to better see your geometry. This 
Designer Elements program provides the Dynamic Pan tool that enables you to do 
this without using the scroll bars. Simply hold down the space bar, click on your 
geometry and drag to the desired location.

Drag the pointer
diagonally
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Tech Note:

An azimuth is an angle mea-
sured clockwise from the 
selected point to the vertical.
View Displays 
You have two view types in this Designer Elements program: pre-defined and user-
defined. Use these to set the view orientation of your geometry.

Pre-defined Views
This Designer Elements program provides five standard views: Side, Front, Top, Iso-
metric and Trimetric. Each view is defined by Eye Pt locations on the X, Y and Z 
axes or the Azimuth and Elevation. Changing the values in either Eye Pt or Azi-
muth/Elevation automatically changes the other fields.

You can change these values as desired. In File>Preferences>General, you can 
set the view definitions to Default or Aerospace. Included with each view is a 
description based on the view definition and its associated values. 

Side Default: The view of the y, z plane. The Eye Pt val-
ues are: X = 500, Y = 0.0, Z = 0.0. The Azimuth 
value is 0.0. The Elevation is 90.0. 

Aerospace: The view of the x, z plane. The Eye Pt 
values are: X = 0.0, Y = -500.0, Z = 0.0. The Azi-
muth value is 0.0. The Elevation is 90.0. 

Front Default: The view of the x, z plane. The Eye Pt val-
ues are: X = 0.0, Y = -500.0, Z = 0.0. The Azimuth 
value is 0.0. The Elevation is 90.0. 

Aerospace: The view of the y, z plane. The Eye Pt 
values are: X = -500.0, Y = 0.0, Z = 0.0. The Azi-
muth value is 0.0. The Elevation is 90.0. 

Top Default &Aerospace: The view of the x, y plane. 
The Eye Pt values are: X = 0.0, Y = 0.0, Z = 500.0. 
The Azimuth value is 0.0. The Elevation is 0.0. 



View Displays
Isometric The view of the axes is rotated as shown.  

Default: The Eye Pt values are: X = 500.0, Y = -
500.0, Z = 500.0. The Azimuth value is -45.0. The 
Elevation is 54.736. 

Aerospace: The Eye Pt values are:    X = -500.0,   Y 
= -500.0, Z = 500.0. The Azimuth value is -45.0. 
The Elevation is 54.736. 

Trimetric The view of the axes rotated as shown.

 Default: The Eye Pt values are:   X = 382.176,   Y 
= -256.20, Z = 195.712. The Azimuth value is -
33.837. The Elevation is 66.957. 

Aerospace: The Eye Pt values are: X = -382.176, Y 
= -256.20, Z = 195.712. The Azimuth value is 
33.837. The Elevation is 66.957. 

z

y

x

Isometric

Trackball

z

y

x

Trimetric

Trackball
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User-defined Views 
You have the ability to define any new view using the New View command or the 
Trackball. You also have the ability to modify these views using the Modify View 
command.

User-defined Views are saved with the current file. They are not saved as defaults 
for the program. 

New View Command 
The New View command, located in the View menu, 
allows you to specify a new view based on a current view 
or entirely independent of any of the available views.

Choosing the New View command brings up the dialog 
box and contains the following options: 

View Name Contains the name of the 
current view. 

Create By This field includes a pull-
down menu allowing you to choose how to spec-
ify your new view; Eye Pt/Reference Pt, Azimuth/
Elevation and Rotate Current View. 

Eye Pt/Reference Pt - Allows you to create a view 
based two sets of values. The Eye Pt refers to the 
location of the viewer's eye. The Reference Pt 
refers to an existing point on a model. An asterisk 
next to the fields denotes your ability to click the 
location in the drawing area and have the values 
automatically entered in the fields. 



View Displays
Azimuth/Elevation - Allows you to specify angle of 
the azimuth and the elevation of your eye with 
respect to the view.

Rotate Current View - Allows you to rotate the cur-
rent view by a specified amount. The values 
entered in these fields affect the related fields in 
the other Create By options. 

OK Click this button to save the new view and close 
the dialog box. 

Cancel Click this button to close the dialog box without 
saving the view.

Specifying a View with the New View Command 
1. Choose View>New View. 

The New View dialog box displays the name and loca-
tion of the current view with its corresponding values. 
The View Name is highlighted. 

2. Enter the new name for the view. 

3. Select one of the Create By methods for defining your 
view. 
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Tip:

If you change a view of your 
geometry but make no 
changes to your geometry, 
the Save command is unavail-
able. To save the view, create 
an object and then delete 
it.The Save command is now 
available and can be used to 
save your view with the file.
4. Enter the appropriate values according to the Create By option you choose. 

For the Eye Pt/Reference Pt method, you can also click the appropriate points in 
your drawing and the values will be entered automatically into the data fields. 

5. Click OK. The dialog box closes and the new view is defined. (Click Cancel to 
close the dialog box without saving the view.) 

Once you create a new view, you can select it by choosing View>User View and 
the view name or choosing the view in the Trackball pull-down menu. 

Be aware that simply rotating the view does not alter the orientation of the work 
plane in 3D space (except for the Side, Front and Top views). 

Trackball - Save Current View 
You can also define a view using the Trackball com-
mand, Save Current View, at the bottom of the Track-
ball pull-down menu.

1. Display the Trackball.

2. Rotate your view as desired. 

3. Click the view name on the Trackball to display 
the pull-down menu. 



View Displays
4. Select Save Current View and release the mouse. 
The new view saves. 

When you display the pull-down menu again, your 
new view is listed as User View1. 

You will also see the addition of a DynView, which 
is the current non-standard view. 

All views defined in this way are numbered sequen-
tially. You can rename these views by choosing 
View>Modify View.

Modifying a View
You can only modify User-defined views. You cannot 
modify a standard view. An attempt to do so creates a 
duplicate of the view except for the changes you 
made. This new view becomes a User-defined view 
which you can rename as desired. If you choose 
View>User View, the modified view will be displayed. 

To change the name or any coordinate locations for user-defined views, use the 
View Properties command in the View menu 

Using the Modify View Command 
1. Choose View>View Properties and select the view you want to change. The 

Modify View dialog box displays.  

This dialog box is identical to the New View dialog box except for its title. 
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2. Make all of the desired changes in the appropriate fields. (See the New View 
section earlier in this chapter for an explanation of the data fields.) 

3. Click OK. The dialog box closes and the new view is defined. (Click Cancel to 
close the dialog box without saving the view.) 

Deleting a View
You can delete any DynViews or user-defined views using the Delete command in 
the View menu. Choose View>Delete View and the view you want to remove.

You cannot delete the current view or the standard views. This command is unavail-
able if there are no user-defined views. 

View Rotation
You can choose views in a number of ways: 

• Choosing a standard view from the View menu or the Trackball 

• Choosing a user-defined view from the View menu or the Trackball 

• Choosing an undefined view by rotating the Trackball 

• Using the Dynamic Rotation tool 

• Using the SHIFT and Arrow keys



View Rotation
Choosing a Predefined View 
To use any of the five standard views mentioned earlier choose one in the View 
menu or in the Trackball pull-down menu.

See Chapter 7 for more information on using the Trackball. 

Choosing a User-defined View 
To use any of the user-defined views, choose one in the User View submenu of the 
View menu or in the Trackball pull-down menu.

The User View command in the View menu is not available when no user views 
have been defined. 

Choosing an Undefined View 
You can choose undefined views by using the Trackball to rotate the view to a new 
orientation. 

Notice that when you rotate the view with this method the view name changes to 
DynView. This view has been added to your Trackball pull-down menu and is a 
temporary view that will change as your rotate your view using the Trackball. One 
advantage of this feature is that you don't have to define this view but it will still be 
available to you until the next Trackball rotation. 
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Dynamic Rotate Tool 
The Dynamic Rotate tool, located in the View tool palette, allows you to rotate your 
view dynamically around any axis.

1. Select the Dynamic Rotate tool. The Message 
Line reads: Dynamic Rotate: Drag mouse to 
rotate view.

The cursor becomes a plus (+) sign. 

2. Drag your cursor to change the view. 

or 

Enter values in the Status Line if you want the view to rotate a specified angle. 

Press ENTER (Windows) or RETURN (Macintosh) and the view changes. 

Using the Shift and Arrow keys 
In any view you can hold down the SHIFT key and use the arrow keys to rotate 
your view. 

View Commands 

Redraw Screen - CTRL+R (Windows); z +R (Macintosh)
This command in the View menu refreshes the screen. When you make changes to 
your constructions the geometry may not be redrawn cleanly. 

Redrawing the Screen 
To redraw all of the geometry and remove extraneous geometry choose the Redraw 
Screen command from the View menu. 

Stopping a Screen Refresh
Windows: You can press the ESC or BREAK key to stop the redrawing of the screen. 
For interrupting long operations such as redraw or linear and polar duplicate, use 
the BREAK key. If the operation was initiated by a Control key command (such as 



View Commands
CTRL+R for redraw) the ESC key is read by MS-Windows and it brings up a task list 
at the end of the operation. 

Macintosh: You can press ESC or the z  (Command) key to stop the redrawing of 
the screen. 

View the Plane
This command located in the View menu, changes the view to your current work 
plane.

Show/Hide 
This command in the Window menu helps you manage the display of objects in 
your drawing. 

You can choose which objects display at a given time. When 
you choose Windows>Show/Hide, the following list of com-
mands appears.

Using the Hide Command 
1. Select the Hide command. The Message Line reads: Select 

entities to hide [Shift = Extend]. 

2. Select an object. The object hides from view. 

Using the Show Command 
1. Select the Show command. The Message Line reads: Select entities to show [Shift 

= Extend]. 

2. Select an object by clicking on the approximate location of the object or using a 
selection fence. The object shows on the screen. 

Using the Show ALL Command 
Select the Show ALL command to display all objects on active layers in your draw-
ing. 

Using the Invert Command 
Select on the Invert command to display all object currently hidden and hide all 
objects currently displayed.
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Using the Show Only Command 
1. Select the Show Only command. The Message Line reads: Select entities to show 

only [Shift = Extend]. 

2. Select the object that you want displayed. Hold down the SHIFT key to select 
more than one object. 

All other objects in your drawing are hidden. 

Tile
In some cases you may find you have multiple files open at the same time. Rather 
than having to switch back and forth between them, you can choose to display 
them all at once. In the Windows menu you have two commands to accomplish 
this: Tile Vertically and Tile Horizontally. (Windows Only)

Tile Vertically 
This command resizes the window for each file equally and arranges them vertically 
across your screen. The files are arranged left to right starting with the file most 
recently active. The view scale is changed to display all geometry in each file.



View Commands
Tile Horizontally 
This command resizes the window for each file equally and arranges them horizon-
tally down your screen. The files are arranged top to bottom starting with the file 
most recently active. The view scale is changed to display all geometry in each file.

Clicking on the Maximize button at the top right of your screen, resizes the selected 
file to full screen.
30-17



Viewing Geometry

30-18
Arrange Icons (Windows only)

On occasion you may have many open files reduced to their title bars but arranged 
haphazardly around your screen. 

Choose Window>Arrange Icons and your files will be neatly arranged in the 
lower left corner of your screen.

Open File Windows 
The bottom of the Window menu shows the names of all the open this Designer 
Elements program files. To bring a different document to the top choose it from the 
list.

Views and Planes 
When you want to view geometry in this Designer Elements program, you choose a 
particular view orientation as discussed in this chapter. When you want to create 
geometry you choose a particular plane on which to draw. 

To eliminate the potential confusion between work planes and view, this Designer 
Elements program has tied the Front, Side and Top views to their respective planes. 
For example, if you choose the Top view, the Top plane is selected in the Plane 
menu and all other planes are grayed out. See Chapter 32 for more information 
about Planes. 



Views and Zoom Scale
Views and Zoom Scale 
this Designer Elements program has linked the view to the zoom scale. Each view 
remembers the last zoom scale set in that view. You can change the view and alter 
the zoom scale and it won't affect the zoom scale of any other view.

Example: In the Top view set the zoom scale to 1:2. Choose the Isometric view and 
change the scale to 1:4. Return to the Top view and the scale returns to 1:2.
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Layers
You can think of visible layers as transparent pages and hidden layers as invisible 
pages. You can use layers to show and hide various components of your drawing. 
They are particularly useful in helping you view and print complex drawings. For 
example, when you dimension a part, the dimensions can be placed on a separate 
layer which you can display or not, as your needs require. Layers allow you to print 
different versions of the same document.

• You can hide the dimension layer to present a design to a planning team and 
show the dimensions when presenting the drawing to engineers. 

• You can hide some drawing components when you print or plot. For example, 
you can hide the construction layer so that construction lines and geometry don’t 
print but remain in the drawing ready for use when you want to alter them. 

• You can construct different layouts using one layer as the basis. For example, 
you can use one layer to define the basic shape of an object and then use other 
layers to try different methods of detailing.

In this Designer Elements program you can have up to 65,000 layers in 
your drawing. Layers must be visible to select objects on them. Layers do not have 
an orientation or origin in this Designer Elements program. 

The topics explained in this chapter include:

• Layer Manager

• Creating New Layers

• Creating New Sub Layers
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• Renaming Layers

• Deleting Layers

• Hiding Layers

• Displaying Layers

• Locking Layers

• Unlocking Layers

• Making a Layer the Active Work Layer

• Layers and Colors

• Layer and Copying/Pasting Objects

Layer Manager-CTRL+L(Windows);z +L(Macintosh)
The Layer Manager allows you to create, delete, hide, 
display and rename layers, as well as set layer specifi-
cations. The work layer is the active layer—on which 
geometry is created. There are Three ways to open 
the Layer Manager.

The Layer Manager dialog box is integrated with the 
Design Explorer dialog box.

1. Open the Design Explorer (Window>Design 
Explorer)

2. Choose Layout>Layer Manager:

3. Click on the Work Layer Indi-
cator to display the pop-up 
menu and choose the Layer 
Manager command



Layer Manager-CTRL+L(Windows);z+L(Macintosh)
The Layer Manager dialog box appears.

The Layer Manager contains the following elements

Active Work Layer This column sets your active work layer. To 
change your active work layer move the pencil 
icon to the layer you wish to add geometry to.

Layer list The Layer list displays all layers in the file.

Layer-Show/Hide This column shows whether a layer is visible or 
hidden. You cannot hide the active work layer.

If the Layer icon (see below) displays, a layer is 
visible (on).

Layer Lock If this column contains a lock icon (see below) 
next to a layer, the layer is locked.
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Objects on this layer cannot be selected or modi-
fied.

Layer Color This column sets the color for all objects on a 
layer. 
The original colors of objects are retained but they 
are displayed in the layer color as it takes prece-
dent.

Object Count This column displays the number of objects on the 
layer.

By right clicking on a layer the follwoing menu box pops up:

Move Up Choosing this option moves the selected layer up 
one position in the dialog box.

Move Down Choosing this option moves the selected layer 
down one position in the dialog box.

New Layer Choosing this option adds a new layer to the 
layer list. Layers are numbered sequentially, 
Layer 1, Layer 2, etc. This option also has a 
button at the bottom of the Layer Manager dialog 
box.

New Sublayer Choosing this option adds a sublayer to the 
selected layer. These layers are controled by 
their parent layer. If you show/hide the par-
ent the sublayer responds in kind. This option also 



Layer Manager-CTRL+L(Windows);z+L(Macintosh)

Tech Note:

Dimensions placed in draw-
ing views go on the Sheet 
View layer. See Chapter 36 
for more information.
has a button at the bottom of the Layer Manager 
dialog box.

Delete Layer Choosing this option deletes the selected 
layer. You cannot delete the active work 
layer.This option also has a button at the 
bottom of the Layer Manager dialog box.

Rename Choosing this option lets you rename the high-
lighted layer. You may also click twice on a layer 
name, once to select the layer and the second time 
to rename it.

Show All Choosing this option shows all layers.

Hide All Choosing this option hides all layers except the 
active work layer.

Lock All Choosing this option locks all layers including the 
active work layer.

Unlock All Choosing this option unlocks all layers.

Default Layers
When you open a new drawing the default layers include: Construction, Dimension 
and Layer 1.

Construction This layer automatically accepts all Construction 
lines created with stroke commands or with the 
Construction dialog box. If you accidentally delete 
this layer, it automatically recreates when you cre-
ate a construction line.

Dimension Dimensions are normally placed on the layer you 
select from the Layer list of the Dimension menu. 
The default layer is the Dimension layer. Gener-
ally, this layer should be reserved for dimensions.

Layer 1 This layer is the current work layer for new files. If 
the file only contains the default layers all geome-
try will normally be placed on Layer 1.

You can edit any geometry or text that is visible regardless of its layer. If you want 
to make some geometry unselectable but still visible use the Select Mask in the Win-
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Tip:

If the Selection Mask is open 
and you add a new layer, the 
Selection Mask automatically 
updates.
dow menu or lock the layer containing the geometry. You can also specify the 
selectability of layers with the Select Mask.

Creating New Layers
There are three ways you can create a new layer: using the Layer Manager, the Work 
Layer Indicator or the Isolate Layer command.

Using the Layer Manager
1. Display the Layer Manager dialog box.

2. Click the new layer button. A new layer is added to the layer list.

You may name the layer by clicking twice on the layer name, once to 
select the layer and the second time to rename it. You can have as many as 
32,700 layers. 

3. The new layer is added.

Using the Work Layer Indicator
1. Click on the Work Layer Indicator to dis-

play the pop-up menu.

2. Choose the New Layer command.

A new layer is created and automatically set 
as the active work layer.

Using the Isolate Layer Command - Alt+7 (Windows);
z +7(Macintosh)
1. Choose Layout>Isolate Layer.

The Isolate Layer dialog box appears.

2. Click Create New Layer.

A new layer is created and the name is placed in the entry field.



Renaming Layers
3. Click OK to close the dialog box and save the new layer. The layer is now the 
active work layer and all other layers are hidden.

Renaming Layers
1. Display the Layer Manager dialog box.

2. Click twice on the layer you wish to rename, once to select the layer and the 
second time to rename it.

Deleting Layers
1.Display the Layer Manager dialog box.

2.Select the name of the layer 
from the list box.

3. Click on the trash can in the lower right 
corner of the dialog box. The layer is 
deleted.

4. If the layer contains any geometry on it 
a warning appears.

Click OK to delete the layer or Cancel to close the warning box without deleting.

Hiding Layers
You can hide one layer at a time or all layers but the active work layer.

Hiding One Layer
1. Display the Layer Manager dialog box.

2. Click on the “eye” icon to the 
right of the layer name that 
you want to turn hide.

The eye icon disappears and 
the layer is now hidden.
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Hiding all Layers
1. Display the Layer Manager dialog box.

2. Right click on a layer name and choose Hide All.

3. Cloaw the Layer Manager dialog box.

Notes:

• You can't hide the active work layer

• If a layer is hidden and you choose Select All and delete, the objects on the hid-
den layer are not deleted.

Showing Layers
You can turn on one or all layers in your drawing.

Showing One Layer
1. Display the Layer Manager dialog box.

2. Click the box to the left of the layer name that you want to turn show.

A eye icon appears next to the layer’s name in the list.

Showing all Layers
1. Display the Layer Manager dialog box.

2. Right click on a layer name and choose Show All.

Locking Layers
1. Display the Layer Manager dialog box.

2. Click in the Lock Layer column next to the desired layer and the lock icon 
appears.

The layer locks.

Unlocking Layers
1. Display the Layer Manager dialog box.



Making a Layer the Active Work Layer
2. Click on the lock icon in Lock Layer column next of the desired layer. The lock 
icon disappears and the layer unlocks.

Making a Layer the Active Work Layer
You have number of ways to make a layer the active work layer. These include: 
using the Layer Manager, the Work Layer Indicator, the Isolate Layer command, the 
Increment Layer command or the Decrement Layer command.

Using the Layer Manager
1. Display the Layer Manager dialog box if it is not already displayed.

2. Click in the Work Layer column to the left of the desired layer.

The selected layer becomes the work layer as shown by the pencil icon.

3. Close the dialog box and save the change.

Using the Work Layer Indicator
1. Click on the Work Layer Indicator to display 

the menu.

2. Select the layer you want to make the active 
work layer

The layer you selected is now the active work 
layer.

Using the Isolate Layer Command - Alt+7 (Windows)z +7 
(Macintosh)
1. Choose Layout>Isolate Layer.

The Isolate Layer dialog box appears.

2. Click on the arrow in the Layer entry 
field to display all available layers.

3. Select the desired layer.

4. Click OK to save this layer as the work 
layer and close the dialog box. All 
other layers are hidden.
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Increment Layer - ALT+0 (Windows); z +0 (Macintosh)
Choosing this command in the Layout menu makes the next layer in the Layer Man-
ager dialog box the active work layer and hides all other layers. You cannot use this 
command if your active work layer is the last layer in the list.

Decrement Layer - ALT+9 (Windows); z +9 (Macintosh
Choosing this command in the Layout menu makes the previous layer in the Layer 
Manager dialog box the active work layer and hides all other layers. You cannot use 
this command if your current work layer is the first layer in the list.

Layers and Color
This Designer Elements program provides the ability to choose a color for all 
objects on a layer. You have nine color options: white, red, blue, green, cyan, 
gray1, purple, yellow and gray2.

Objects created on this layer use the current pen color but are displayed in the layer 
color.

Objects created on another layer and in another color placed on this layer have 
their color display overridden. They retain their original color but display in the 
layer color. If the object is moved to another layer with no color override, it dis-
plays in its own color.

Using the Layer Color Override
1. Display the Layer Manager dialog box if it is not already displayed.

2. Click in the Layer Color column next to the desired layer. A color patch appears 
displaying the first color available, white.

3. Click on the color patch to advance to the next patch color.

4. Select the desired color for the layer.



Layers and Copying/Pasting Objects
5. Click OK to close the dialog box and save the change.

Layer Color Warning
This Designer Elements program provides you with a Layer Color warning if you 
attempt to change the color of an object on a layer with a specified color. The fol-
lowing Change Color box appears:

As the box indicates, you cannot change the color unless you remove the color 
override for that layer.

Layers and Copying/Pasting Objects
When you copy objects on a specific layer in one file into another file containing 
those same layers, the objects are not automatically placed on the specific layer. 
The copied objects are placed on the work layer.
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Referral:

Planes can also be created by 
using the Infinite Plane 
tool in the Surfaces tool 
palette. See Chapter 16 for 
more information.
Planes
A plane is an infinite surface on which you can create geometry. This Designer Ele-
ments program provides predefined planes, Front, Side and Top and the ability to 
create user-defined planes.

If a plane is chosen as the work plane, all geometry created from that point on is 
placed on that plane. The work plane is an x, y plane with an origin of 0, 0, 0 for 
all data input. You can move the work plane as desired by creating your own or 
choosing one of the predefined planes.

As you learn to use this Designer Elements program, you should attempt to use the 
Z-Drafting Assistant without moving the work plane. Even though the Z-Drafting 
Assistant does a lot of the work for you the work plane is still an essential element 
of 3D modeling.

The Z-Drafting Assistant assumes that geometry is being created in the current work 
plane unless it snaps to an align:z or to a logical snap point that is not in the cur-
rent work plane.

You will need to use a work plane to properly position geometry in the following 
cases:

• To create geometry that is not parallel to the work plane and does not snap to 
one of the Drafting Assistant’s constraints like endpoint or midpoint.

• To create geometry that requires less than three points for their specification 
such as the Center-Point Circle, Rectangle or 2-Point Ellipse.
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Those tools which use three points for specification can be drawn non-parallel to 
the work plane.

The Plane menu and the Work Plane Manager, accessed through the coordinate sys-
tem axis, contain all of the commands for creating and setting the work plane.

The topics explained in this chapter include:

• Work Plane

• Work Plane and Views

• Work Plane and World Coordinates

Work Plane
The work plane is an important feature of any CAD program. In conventional CAD 
programs you have to specify both the orientation of the work plane and its exact 
location along the z-axis.

In this Designer Elements program you need only specify the orientation of the 
work plane. Once that is done, all parallel planes act equally as the current work 
plane (e.g. the Drafting Assistant identifies the location of the work plane automati-
cally).

Z
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Z

Y

X

X

Y

Z

X

Y

When you identify one point of an
object with the Drafting Assistant...

...the new object geometry  is created on
the plane of the identified object.

If you do not identify an object the new object
geometry is placed onto the work plane at the origin.

Grid
Origin

Work plane

midpoint

Grid
Origin

Parallel current work plane

align:y on

Grid
Origin

Work plane



Work Plane
Another way to explain the relationship presented in the graphics above is to 
remember the role of the Drafting Assistant. For new geometry to be placed on the 
same plane as another piece of geometry either create a user-defined work plane at 
that location or brush over that “old” geometry to wake up one of its control points 
like midpoint or endpoint. This Designer Elements program will then retain this 
plane information as you create the new geometry.

If no object exists or no geometry is referenced for plane information this Designer 
Elements program places the new object geometry onto the work plane.

Show Work Plane Command
Choosing this command in the Plane menu displays the work plane icon in your 
drawing. The left graphic below shows the work plane icon in the Top plane. The 
right graphic shows the icon in the Isometric view.

The work plane icon is a helpful reference for creating geometry on multiple 
planes.

Work Plane Manager
The work plane manager, accessed through the coordinate system icon in the Status 
Line, is a menu of commands that allow you to define, delete, display the proper-
ties of and save the current work plane. It also allows you to show or hide the work 
plane. 

Display this menu by clicking on the coordinate system axis icon to 
the left of the Status Line.

The work plane manager menu displays.
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New Command
This command, found in the Planes Menu (Planes>New Work Plane) allows you 
to define a new work plane. You can define an unlimited number of planes. When 
you choose this command the Define Work Plane dialog box appears.

The dialog box contains the following items.

Name Displays the work plane name. If you have not 
entered a unique name, the name field displays 
UserWorkPlane01 or some other numbered incre-
ment.

Origin These fields display the X, Y and Z coordinates for 
the origin of the work plane.

Right These fields display the DX, DY and DZ coordi-
nates for the right arm of the work plane. 

Up These fields display the DX, DY and DZ coordi-
nates for the up arm of the work plane.

The asterisk (*) next to the field indicates your ability to specify locations by click-
ing in the drawing area. You can also enter the values manually.

Using the New Command to Define a Work Plane
1. From the work plane manager menu, choose New. 

The Define Work Plane dialog box appears.

2. Enter the values for the origin, right and up arms of the work plane. You can 
also specify the locations by clicking in the drawing area.

3. Enter in name for the work plane in the Name data field.



Work Plane

Referral:

See Chapter 7 for informa-
tion on coordinates systems.
If you don’t enter a name, the default name displayed in the field will save with 
the work plane coordinates.

4. Click OK to save the new plane.

5. Display the work plane manager menu again.

Notice that the new work plane is listed and is the current work plane. You are 
now operating in the user-defined coordinate system.

Delete Command
Use this command, located in the Planes Menu (Planes>Delete Work Plane) to 
delete a user-defined work plane. You cannot delete the GlobalWorkPlane or Dyn-
WorkPlane items.

1. Select the user-defined work plane you want to delete.

2. Choose the Delete command. A warning box appears explaining that the opera-
tion cannot be reversed and asking for confirmation. 

3. Click Yes to delete the plane.

Properties Command
This command displays the properties of the selected work plane.

1. Choose a user-defined work plane.

2. Choose the Properties command. The Define Work Plane dialog box appears 
displaying the name and the X, Y, Z coordinates of the work plane.

3. Change any value and click OK to close the dialog box and save the changes.
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Tech Note:

If you are in the Front, Side or 
Top view, the work plane is 
already set to the respective 
plane and the other two pre-
defined planes in the Plane 
menu are unavailable.

Temporary planes created 
with the User View, 3 Pts, Pick 
Objects and Define com-
mands are not saved for 
future use.
Save Current Command
This command saves the current work plane and adds it to the list of work planes 
in the Work Plane manager. It is automatically titled with the next available default 
label. If there are no other user-defined planes using a default label, the plane is 
titled, UserWorkPlane01.

You can rename this plane by selecting the name and choosing the Properties com-
mand in the Work Plane manager.

Show Work Pln Command
This is the same command available though the Planes menu. Choosing the com-
mand displays the work plane icon in your drawing.

Work Plane Identification
You can determine if your current work plane is global or user-defined through the 
coordinate system/work plane icon displayed to the left side of the Status Line.

The Global Work plane icon is a miniature version of the axis 
icon. 

When a user-defined work plane or dynwork plane is chosen, an 
altered axis icon displays in the Status Line, as shown here.

Setting the Work Plane
In the Planes menu you have commands for setting the 
work plane. You may want to define a work plane other 
than the standard planes. For example, if you want to 
work on an angled face, you can reorient the work plane.

You can set the work plane six ways. From the Planes 
menu, choose a predefined plane, Front, Side or Top or 
use one of these commands, Use View, 3 Pts, Pick Objects 
and Define. As explained earlier, you can also define and 
set the work plane using the work plane manager menu.

Work planes created using the Use View, 3 Pts, Pick 
Objects and Define commands do not save for use later. 
They are only available until you set another work plane. 
Use the New command in the work plane manager to 
define and save a work plane with your file. If you have created objects on a tem-



Work Plane

Referral:

See Chapter 15 for informa-
tion on using the Infinite 
Plane tool.
porary work plane, you can use the Pick Objects command and select the objects on 
that plane to set the work plane to them. (See a later section on using the Pick 
Objects command.

Choosing a Predefined Plane
1. Click or drag on the Plane menu to display the submenu.

2. Select one of the predefined planes. 

All three predefined planes are only available when 
your view is set to Isometric, Trimetric or a User-
defined view.

The work plane has changed to the selected plane.

Choosing the Front plane sets the x-axis to 0, 1, 0 and the y-axis to 0, 0, 1. Choos-
ing the Side plane sets the x-axis to 1, 0, 0 and the y-axis to 0, 0, 1. Choosing the 
Top plane sets the x-axis to 1, 0, 0 and the y-axis to 0, 1, 0.

Choosing the Use View Command
This command sets the work plane to be coincident with the screen; the origin is in 
the center of the screen; the x-axis is coincident with the width of the screen; the y-
axis is coincident with the height of the screen.

This sets the plane to match the screen in all views which is particularly useful 
when you are moving from view to view while drafting.

Choosing the 3 Pts Command
This command sets a temporary work plane from the three points you specify. This 
command is especially helpful if you want to create non-parallel planes.

1. Choose Plane>3 Pts. The Message Line reads: Work Plane: Enter three points 
for work plane (1 origin, 2 x-axis, 3 y-axis).

Y

X

1
2

3If you  want to work 
on this face... 

Origin

...you have to click 
on points 1, 2, 3 
(3-point plane)
32-7



Planes

32-8

Tech Note:

This tool does not create a 
plane between curves on dif-
ferent planes. It only sets the 
plane to objects already in a 
plane.
2. Click in the drawing area to indicate the origin point for the new work plane.

3. Click a point to define the positive x-axis.

4. Click a point to define the positive y-axis.

A temporary work plane is created.

Choosing the Pick Objects Command
This command allows you to set the work plane based on selected objects. This 
includes selecting an infinite plane icon.

1. Choose Planes>Pick Objects. The Message Line reads: Work Plane: Select 
objects to set Work Plane [Shift = Select].

2. Select a curve or curves located in the plane that you want to set as the work 
plane.

The work plane changes to the plane of the objects. Choose Plane>Show 
Work Pln to verify that the new plane is selected.

You can also use this tool to set the work plane to the face of a solid object.

Using the Work Plane Manager to set the Work Plane
1. Click on the work plane icon at the left of the Status Line.

2. From the menu select a work plane. (This menu displays the glo-
bal work plane and any user-defined work planes.)

The selected work plane is now set.

Work Plane Snapping
A short cut was added to allow rapid work plane positioning and alignment.  This 
has been accomplished by further integration of the work plane with the Drafting 
Assistant.  By default the short cut is set to the “c” key.   When you hit the short cut 
key associated with work plane snapping you will see the following behavior:

• Work plane origin moves to drafting assistant snap location. Aligns to top plane.

• Second “c” hit changes from top to side work plane orientation.

• Third “c” hit changes from side to front work plane orientation.

• Fourth “c” hit changes from front to use view work plane orientation.

• Fifth “c” hit changes from use veiw back to top plane.



Work Plane
If you have the face snap options on, hitting the short cut key will automatically 
align with respect to the face normal.

Note: you must have an object selected in order for the work plance snapping short 
cut to work.

Work Plane Dimming
This menu command provides a means to dim objects that do not lie in the work 
plane.
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Tip:

Use the 3Pts command in the 
Planes menu if the new plane 
is not parallel.
Moving the Origin
Occasionally, you may simply want to move the 
origin of the work plane. This is especially useful 
for measuring distances. For example, you can 
open a document and start drawing without 
regard to the location of the origin, then move 
the origin to a convenient location for future ref-
erence. 

Set Origin
This command sets a new origin in the current 
work plane.

Specifying a New Origin
1. Choose Planes>Set Origin. 

2. Click in the drawing area to indicate the location for the new origin. 

The origin of the current work plane moves but the orientation of x, y, z 
remains the same. 

If you want to move the origin and change the orientation of the work plane, use 
either the 3 Pts command or the Define Plane command.

Offsetting the Work Plane 
As you’re using this Designer Elements program, you may want to move the work 
plane a certain distance normal to the current work plane so that new geometry will 
snap to it. The Offset command in the Planes menu gives you this ability. 

Using the Offset Command 
1. Display the work plane icon. (This is not required but it will help you visualize 

the offset.) 

2. Choose Planes>Offset. 

The origin might be
here to begin with...

...but you can move it here for
more convenient measurements



Work Plane and Views
The following dialog box displays.

3. Enter the distance to offset (negative or positive) the work plane in the data 
field. The units for the distance are based on the Units page of Preferences. 

4. Click OK to accept the value and close the dialog box.

The work plane has changed. Click Cancel to close the dialog box without 
accepting the value.

Work Plane and Views

Standard Views
When you want to create geometry you choose a particular plane on which to 
draw. When you want to view geometry in this Designer Elements program, you 
choose a particular view orientation. 

To eliminate the potential confusion between work planes and views this Designer 
Elements program has tied the Front, Side and Top views to their respective planes. 
For example, if you choose the Top view, the Top plane is selected in the Plane 
menu as the work plane and all other planes are unavailable.

See Chapter 30 for more information about Views.

View the Plane
This command in the View menu changes the view to the current work plane.

Work Plane and World Coordinates 
This Designer Elements program uses the world coordinate system (as opposed to 
the User Coordinate System) for defining planes.
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Tip:

When rendering geometry 
increasing the resolution on 
solid objects can improve the 
final image. This is especially 
helpful for round parts.
Rendering
After you create your geometry you can render it to display it more realistically. 
This Designer Elements program includes functionality for basic and advanced ren-
dering. Basic rendering allows you to visualize and construct your model in various 
display modes. Advanced rendering allows you to create photorealistic images. 

The topics covered in this chapter include the following:

• Lighting

• Basic Rendering

• Advanced Rendering

• Editing the Rendered Scene

• Photorealistic Rendering

• Animation

• Perspective Rendering

Lighting
When you render your model this Designer Elements program automatically pro-
vides default lights to display your objects. This Designer Elements program also 
allows you to design your own lighting using four types of light sources: three 
directional sources (distant, spot and point) and the ambient light source. Use these 
lights to define the lighting characteristics of the model.
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Directional Lighting
The distant light source, spot light source and point light source are directional 
sources. For each source you specify its location and direction. You place these 
lights in your drawing by using the Light tool palette. 

These light sources also support shadows when working within the advanced ren-
dering environment.

Light Palette
The Light tool palette does not automatically display when you launch 
this Designer Elements program. To display the palette choose Win-
dow>Lights.

The Light tool palette includes the Distant Light ( ), Spot Light ( ) 

and Point light ( ). Light sources placed using this palette contribute 
light color and intensity to all objects that lie within their influence and 
are used to define the light. 

Light sources appear in your drawing as symbols in the wireframe and basic render 
modes for construction purposes. The light source symbols do not appear when 
using the photorealistic rendering commands.

Light sources can be hidden using the Show/Hide command or moved to a separate 
layer and hidden. However both actions turn off the light.

Distant Light Source

A distant light source illumi-
nates a scene with parallel rays 
of light as if they emanate from 
a very distant light source. Like 
the sun, this source illuminates 
all parallel surfaces equally.



Lighting
Using the Distant Light Tool
1. Select the Distant Light tool. The Message Line reads: Distant Light: 

Enter location and direction positions.

2. Click a point to set the location of the light.

3. Click the next point to establish the direction of the light. 

The exact distance is not important. A distant light source 
symbol appears in your drawing composed of a cylinder with an 
arrow pointing along the source center-line.

If Show Points in the Edit menu is checked the center-line 
extends from the source location to the direction point, as in the 
graphic here.

Place more lights as desired. As you add lights you may want to render the 
model again to verify the lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page a distant light source is made up of 
the following characteristics: Type and Intensity. It also includes the Enable Light 
check box, Cast Shadows check box and its associated pull-down menu and the 
Cast Volumetric Shadows check box. The Attenuation menu is not available since a 
distant light source illuminates all surfaces equally.

The Enable Light check box gives you the ability to turn off a light while retaining 
the intensity, direction and location settings. When checked, the light is on. The 
default setting is on.

The Cast Shadows check box controls whether a shadow is cast by an object when 
a particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-
down menu, you also have the option of setting the type of shadow casting. You 
have four shadow type options: hard, medium, soft and blurry.

The ability to control shadow casting is especially valuable in a scene containing 
multiple light sources. Too many shadows can render a scene confusing. This check 
box setting only applies when rendering your scene with Preview Render (shadows 
on) or Raytrace Render (shadows on, Anti-Alias). See the “Photorealistic Rendering 
Commands” section later in this chapter.

The light source color is accessible through the Attributes page.
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Spot Light Source

A spot light source illuminates 
a scene with a cone of light 
emanating from a local source. 
This source functions similarly 
to a flashlight.

Using the Spot Light Tool

1. Select the Spot Light tool. 
The Message Line reads: Spot Light: Enter location and direction posi-
tions.

2. Click the first point to set the location of the light.

3. Click the next point to establish the direction of the light. 

Distance is only important if you want to set the light with an attenua-
tion (see the Geometric Characteristics section for information on atten-
uation). The default setting does not include attenuation. A spot light 
source symbol appears in your drawing, composed of an inner and 
outer cone and an arrow pointing along the source center-line.

If Show Points in the Edit menu is checked, the center-line 
extends from the source location to the direction point. The 
sides of the cone extend to a plane normal to the direction, 
and end at the direction point, as in the graphic here.

Place more lights as desired. As you add lights, you may want 
to render the model to verify the lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page, a spot light source is made up of the 
following characteristics: Type, Intensity, Attenuation, Cast Volumetric Shadows, the 
Cone Angle data field, Falloff Angle data field, Falloff Rate data field and the Slide 
check box. It also includes the Enable Light check box, Cast Shadows check box 
and its associated pull-down menu.



Lighting
The Enable Light check box gives you the ability to turn off a light while retaining 
the intensity, direction and location settings. 

The Cast Volumetric Shadows check box enables simulation of a full range of 
effects occurring in a participating medium, i.e. attenuation within the medium, 
light filtration through a colored medium and first order light scattering inside the 
medium with volumetric shadows.

The light scattering effects are modeled for all light shaders except "ambient", "eye" 
and "sky" (though are available in the "area sky" shader). The "first order scattering" 
mentioned above means that the shader visualizes direct the effect of scattering 
through the medium, scattered light coming to the observer but does not consider 
the secondary effect, multiple bounces of light within the medium or illumination of 
surfaces by scattered light. 

The shader performs attenuation of the original surface color according to given 
medium attenuation coefficient and medium color. As one could expect the longer 
the distance from the shaded point, the dimmer and more colored by the medium it 
becomes. In addition to attenuation it is also possible to specify the medium ambi-
ent light scattering, which gives the overall veiling effect. Finally the shader models 
scattered light from all the supported light sources if the "scattering" parameter of 
the source is set to TRUE. 

The Cast Shadows check box controls whether a shadow is cast by an object when 
a particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-
down menu, you also have the option of setting the type of shadow casting. You 
have four shadow type options: hard, medium, soft and blurry. This check box set-
ting only applies when rendering your scene with Preview Render (shadows on) or 
Raytrace Render (shadows on, Anti-Alias). See the “Photorealistic Rendering Com-
mands” section later in this chapter.

Attenuation Settings
Attenuation controls how quickly the light inten-
sity diminishes with the distance from the light. 
You have the following attenuation options:

None Light intensity 
does not change 
with distance.
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Clamped Linear Light intensity diminishes according to the follow-
ing formula, Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the follow-

ing formula, Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the follow-
ing formula, Intensity /distance.

Unclamped Quadratic Light intensity diminishes according to the follow-

ing formula, Intensity /distance2.

Use clamped attenuations in situations where the distance from a light source to an 
object is less than one 1” (25.4 mm). Clamped attenuations do not increase intensity 
when the distance is less than 1” (25.4 mm). Unclamped situations are more realistic 
and apply to most situations.

Cone Angle controls the maximum 
spread of the spot light. Objects that 
lay outside the area defined by the 
cone does not receive light. Objects 
that lay within the cone receives 
light according to the specified 
attenuation, falloff angle and falloff 
rate.

Falloff Angle controls the sharpness of the spot light’s edge. The smaller the angle is 
the sharper the edge. The light intensity diminishes from full intensity at the inner 
cone to zero at the outer cone. The value for the falloff angle ranges from zero (0) 
degrees to Cone Angle/2 degrees.
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Falloff Rate controls how light is 
distributed within the spot light’s 
cone. The intensity diminishes from 
the center line of the cone outward 
with the cosine of the angle raised 
to the power of the falloff rate. A 
falloff rate of zero (0) results in uni-
form light within the cone. Higher 
values produce more pronounced 
falloff. The falloff rate can be any 
value from zero (0) to ten (10). 

The graphic here shows the light 
attenuation and falloff rate for a 
spot light with an intensity of 24.

The Slide check box controls whether a spot light functions as a slide projector and 
projects an image on the scene. The example below shows the lighting scene with 
the spot light location and the lighting environment with and without the slide 
image.

The light source color is accessible through the Attributes page.

The scene Without slide image With slide image

p
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Point Light Source

A point light illuminates a scene 
with light emanating in all direc-
tions. A candle or a table lamp is 
a type of point light.

Using the Point Light Tool

1. Select the Point Light tool. 
The Message Line reads: Point Light: Enter location.

2. Click to set the source location of the light.

Distance is only important if you want to specify an attenuation (see 
the Geometric Characteristics section for information on attenuation). 
The default setting does not include attenuation. A point light source 
symbol appears in your drawing with arrows pointing outward If 
Show Points in the Edit menu is checked, the source location point displays.

Place more lights as desired. As you add lights, you may want to render the 
model again to verify the lighting effect.

Geometric Characteristics
According to the Edit Objects Geometry page, a point light source is made up of the 
following characteristics: Type, Intensity, Attenuation. It also includes the check 
boxes, Enable Light and Cast Shadows and its associated pull-down menu and the 
Cast Volumetric Shadows check box.

The Enable Light check box gives you the ability to turn off a light while retaining 
the intensity, direction and location settings. 

The Cast Shadows check box controls whether a shadow is cast by an object when 
a particular light is directed towards it. When checked, shadows are cast. When 
unchecked, no shadows are cast as a result of that light. With its associated pull-
down menu, you also have the option of setting the type of shadow casting. You 
have four shadow type options: hard, medium, soft and blurry. This check box set-
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ting only applies when rendering your scene with Preview Render (shadows on) or 
Raytrace Render (shadows on, Anti-Alias). See the “Photorealistic Rendering Com-
mands” section later in this chapter.

Attenuation Settings
Attenuation controls how quickly the light inten-
sity diminishes with the distance from the light. 
You have the following attenuation options:

None Light intensity does not change with distance.

Clamped Linear Light intensity diminishes according to the follow-
ing formula, Intensity /(distance+1).

Clamped Quadratic Light intensity diminishes according to the follow-

ing formula, Intensity /(distance2+1).

Unclamped Linear Light intensity diminishes according to the follow-
ing formula, Intensity /distance.

Unclamped Quadratic Light intensity diminishes according to the follow-

ing formula, Intensity /distance2.

Use clamped attenuations for situations were the distance from a light source to an 
object is less than 1” (25.4 mm). Clamped attenuations do not increase intensity 
when the distance is less than 1” (25.4 mm). Unclamped situations are more realis-
tic and apply to most situations.

The light source color is accessible through the Attributes page.

Ambient Lighting
Ambient light contributes light color and intensity to all objects in the scene. Ambi-
ent light penetrates all holes, indentations and cutouts of an object, illuminating all 
surfaces equally. Ambient light does not cast shadows. 
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Choose View> Ambient Light Settings to display the dialog box.

The dialog box contains the following options:

Color This area sets the ambient light color. You can 
either choose a color from the menu, enter a Red, 
Green, or Blue value in the respective data field or 
drag the RGB slides to the desired value. A color 
preview appears to the right of the sliders. The 
default ambient light color is white.

Intensity This option sets the ambient level. You can either 
enter the value in the data field or use the slide to 
set the intensity. Zero (0) is off.

After choosing your ambient settings, click OK. When you save your file, the ambi-
ent light setting is also saved.

Modifying the Lights
As you design your geometry and render it you may want to view it under various 
lighting conditions, either by changing the layout or editing the light source.

Modifying Ambient Light
Ambient light can modified through the Ambient Light Setting dialog box in the 
View menu. Adjust the color and intensity level and click OK to save the changes. 
Choose PhotoRender>Render to display your geometry with the new settings.

Modifying Directional Lights
You can modify directional lights (Distant, Spot and Point) in a number of ways 
including moving, deleting and changing the intensity and color.



Lighting
Moving a Light Source
Light sources are objects and can be moved 
like any other object. The Distant and Spot 
light sources have two control points, the 
source location and the source direction. You 
can move one or both points The Point light 
source has one control point, the source loca-
tion.

Moving the Entire Light Source
Select the source. Place the cursor over the source location point and drag it to the 
new location. Choose PhotoRender>Render to display the image with the new 
light setting.

Moving the Control Points
Select the source and choose Edit>Show Points to display the control points. Drag 
a selection fence around the desired point and move it to the new location. Choose 
PhotoRender>Render to display the model with the new light setting.

Editing a Directional Light Source
You can perform comprehensive editing on directional light sources through the 
Edit Objects dialog box. The options available depend on the light source.

Geometry Tab
Type You choose from the three lights available: Distant, 

Spot and Point.

Intensity You can change the light intensity. Any value 
equal to or greater than zero is valid. Zero (0) 
turns the light source off. 

Attenuation (Spot and Point lights only) Controls how quickly 
the light intensity diminishes with the distance 
from the light.

Enable Light This check box controls the activation of the light 
source. When checked, the light is on. This check 
box allows you to turn off a light while retaining 
the intensity, direction and location settings. The 
default setting is on.
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Cast Shadows This check box controls the display of shadows 
when a light shines on an object. A pull-down 
menu offers four shadow types: hard, medium, soft 
and blurry. This command works with Preview 
Render (shadows on) and Raytrace Render (shad-
ows on, Anti-Alias) rendering commands.

Cone Angle (Spot light only) Controls the maximum spread of 
the spot light.

Falloff Angle (Spot light only) Controls the sharpness of the spot 
light’s edge.

Falloff Rate (Spot light only) Controls how light is distributed 
within the spot light’s cone.

Slide (Spot light only) This check box controls whether 
a spot light functions as a slide projector and 
projects an image on the scene.

Attributes Tab
Name You can enter a specific name for the source.

Resolution This characteristic does not apply to light sources.

Color You can specify any color for your light source. 
The pull-down menu offers the standard colors 
and the More option, which displays the color pal-
ette when selected.

Control Pts You can display or hide the control points of the 
light source.

Layer You can place a light source on any layer. The 
menu displays all available layers.

Locked You can locked the light source to prevent modifi-
cation.

Click Apply to accept your changes and then Close to exit the dialog box. Choose 
PhotoRender>Render to display your geometry with the new light settings.

Deleting a Light Source
To delete a light source select the source and press the BACKSPACE key (Windows) 
or the DELETE key (Windows and Macintosh).
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Tech Note:

This Hidden Line mode is dif-
ferent from the hidden line 
images that appear in Draw-
ing Views when using the 
Model to Sheet command. 
See Chapter 36 for more 
information.
Default Lighting
This Designer Elements program provides default lighting for your geometry when 
you use the Render command. The default lighting is based on the viewer’s eye 
location and direction to provide a high quality rendering of your geometry. The 
default light source cannot be modified. However, you can specify your own ambi-
ent light with the default lighting. When you place your own light sources, the 
default light source deactivates.

User-Defined Lighting Layouts
If you create your own lighting layout, you can use that layout for other drawings 
by exporting the lights to a stand-alone Designer Elements program file. This light-
ing file can then be imported into other files. To export a lighting set, do the follow-
ing:

1. Select all the light sources by selecting each individually or using the Selection 
Mask.

2. Choose File>Export. 

3. Select the Designer Elements program format. 

4. Choose the Selected Only option.

5. Click OK and save the file as desired.

You can now import this lighting into other Designer Elements program files.

Basic Rendering
In this Designer Elements program you are able to design, display and edit your 
models in a wide range of visualization modes. These include the static and 
dynamic options, wireframe, Flat shading, Gouraud shading, Phong shading and 
Hidden Line modes (see the Render Options section for shading definitions). Basic 
rendering is implemented under Open GL available through your video card. You 
do not need to select the objects to render them.
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Shade Now - CTRL+T (Windows); z +T (Macintosh)
This Shade Now command in the View menu, 
displays your geometry using the Render Now 
setting selected in the Render Options dialog 
box (see the next section).

To use this command, choose View>Shade 
Now.

All surface and solid geometry in your draw-
ing renders.

Shade Options
This Designer Elements program pro-
vides a number of options for render-
ing your geometry.

When you choose View>Shade 
Options, the following dialog box dis-
plays.

The dialog box includes the following 
rendering categories:

Static Render This category defines how your geometry displays 
when the view is stationary. This Designer Ele-
ments program automatically repaints the object if 
this setting is changed and saved.

Dynamic Render This category defines how your geometry displays 
as you rotate the view. 

Render Now This category defines how your geometry displays 
when you choose View>Shade Now. 
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Tech Note:

If you set your Dynamic Ren-
der mode to Phong with 
Edges and notice that at time 
your model vanishes, that’s 
the result of light reflection. 
Adjust your light levels or 
location and render again.
When you click the arrow in a cate-
gory a pull-down menu appears.

You have the following rendering 
options:

Wireframe This option displays only the edges of 
the 3D model. This is the normal 
repaint display mode.

Flat This option displays your geometry with 
a painter’s algorithm using constant 
shading techniques.

Gouraud This option displays your geometry 
based on calculated light intensities at 
each vertex. This rendering method 
uses Open GL (Windows) or Quick-
Draw 3D (Macintosh). 

Gouraud w/Edges This option displays your model with 
face edge boundaries, silhouettes and 
isolines of a surface or solid on top of a 
rendered model. You can specify the 
edge color in the Display page of Preferences (see 
Chapter 6, “Preference Settings”).

Phong This option displays your geometry 
based on calculated light intensities at 
each pixel location.

Phong w/Edges This option displays your model with 
face edge boundaries, silhouettes and 
isolines of a surface or solid on top of a 
rendered model. You can specify the 
edge color in the Display page of Preferences (see 
Chapter 6, “Preference Settings”).
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Hidden This option displays only the visible 
edges of your geometry. Since this a 
rendering mode, any text present in 
wireframe does not display. Text and 
wireframe objects do not display in this-
mode.

Hidden w/Dimmed This option displays the visible edges 
with the hidden edges of your geometry 
dimmed. Since this is a rendering mode, 
any text present in wireframe does not 
display. Text and wireframe objects do not display 
in this mode.

The dialog box also includes another render option setting:

Flip Normals Placing a check mark in this box flips the light nor-
mal on objects. The Flip Normals box is checked 
by default. This Designer Elements program auto-
matically repaints the object if this setting is 
changed and saved.

When you display a rendered object, its appear-
ance is determined by the light locations and the 
object orientation. If light normals are pointed 
away from the viewer, the object will appear dark. 
This can happen when geometry is imported in 
from another program.

Flip Normal Example
If you import the following object and render it without the 
Flip Normal option checked parts of the object appear dark.

Check the Flip Normal option and render the object again. The 
normals pointing away from you are flipped and the darkened 
areas of the object render more acceptably. 

You can also choose Edit>Change Direction to flip the direction of the normals. 
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Setting the Shade Options
1. Choose View>Shade Options. The dialog box displays.

2. Select the render options you desire.

3. Click OK and the options are accepted. (Click Cancel to close the dialog box 
without saving the settings.) 

If you changed the Flip Normal or the Static Render settings this Designer Ele-
ments program automatically repaints. 

These settings save as the default settings when you exit the program.

If you’ve chosen Gouraud w/Edges or 
Phong w/Edges and you want to display 
your model with isolines or silhouette, dou-
ble-click on your model to open the Edit 
Objects dialog box. In the Display page, 
specify your desired settings and click 
Apply.

Z-Buffer Curves This option turns on or off OpenGL depth buffer-
ing of curves as they are displayed in context with 
surfaces and solids.  With this option on, curves 
behind surfaces or solids are hidden and visible 
when turned off.

Show Facet Edges The Show Facet Edges option turns on or off the 
edges of the display facets.  The facet density is 
determined by the entity resolution.

Use Clip Planes This option indicates whether to process clip 
planes for OpenGL rendering.  When turned on, 
all planes entities that are marked as clip planes 
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will clip the current view.  To mark a plane as a 
clip plane, right click over the entity and select the 
appropriate option in the menu.

Backface Culling Back face culling is an option that greatly 
enhances OpenGL performance.  When this option 
on, OpenGL ignores all facets from solids that have 
normals facing away from the viewing direction.  
Turn this feature off if you have hybrid solids that 
mix open surfaces with solids, otherwise the sur-
face may appear invisible in OpenGL display 
modes.

Anti-Alias This option tells the OpenGL drivers to enable anti 
aliasing of edges.

Clip At Eye Point The clip at eye point turns on or off clipping at the 
eye point.  If off, clipping is automatically deter-
mined based on the extents of the given model.

Use Transparency This option indicates whether to process objects 
marked with a transparency flag for OpenGL trans-
parency.  When turned on all surface and solid 
entities that are marked as transparent will clip the 
current view.  To mark an object as transparent, 
right click over the entity and select the transpar-
ent option from the menu. 

The slider value indicates a global transparency 
setting.  A setting of 100 implies no transparency 
and a value of 0 implies fully transparent. Below is 
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an example of an object containg transparent 
parts.

Render Option Combinations and View Rotation
Because the rendering options deal with the display of your geometry, the render-
ing categories operate with each other and are affected by the view.

Shade Options Example
1. Create some geometry. 

2. In the Shade Options dialog box, set Render Now to Hidden w/Dimmed and 
Static Render to Wireframe.

3. Click OK to save the setting and close the dialog box. 

4. Choose View>Shade Now and your geometry is displayed in Hidden w/
Dimmed view mode.

5. Rotate the view. The geometry is now displayed as wireframe because of the 
Static Render setting.

Other Shade Combinations
Here are a few render combinations.
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Static Render - Wireframe, Dynamic Render - Gouraud
As you rotate the view your geometry displays with Gouraud shading. When you 
complete the rotation the geometry displays as a wireframe.

Static Render - Gouraud, Dynamic Render - Gouraud
As you rotate the view your geometry displays with Gouraud shading. When you 
complete the rotation the geometry displays in Gouraud shading.

Render Options and Preferences
Render Options are saved automatically when you exit the program. They are writ-
ten out to the preferences file.

Basic Rendering and Lighting
All facets are illuminated according to how much light falls on their vertices (the 
intersection of perpendicular isolines). If a light source is positioned over a large 
flat surface (such as a floor), it will appear that the source is not casting light. Set 
the object resolution to Very Fine or Super Fine to increase the facet density and 
enhance the lighting result. See Chapter 24 for more information on resolution.

Advanced Rendering
This Designer Elements program provides you with advanced rendering tools that 
control the definition and generation of photorealistic images. Unlike the basic ren-
dering functionality, advanced rendering is not used during geometry construction 
and editing. Advanced rendering is a back-end tool that interacts with the geometry 
already created. Advanced rendering is implemented using the LightWorks render-
ing engine for both Windows and Macintosh.

The advanced rendering tools include the render library, advanced settings and ren-
dering modes. You do not need to select objects to render them.

Fine Resolution Very Fine Resolution Super Fine Resolution
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Render Library
This Designer Elements program 
comes with an extensive render 
library containing materials and 
decals that you can apply to 
objects and background and 
foreground properties that you can apply to the scene. This library is contained in 
the Render Library tool palette. Choose Window>Render Library to display the 
tool palette.

You can resize the palette hori-
zontally or vertically by dragging 
its edges or corners.

The palette contains the preview 
area, library type menu, cate-
gory menu and scroll bar. The 
type menu controls which 
library displays on the palette. 
The Decals library type is shown 
in the graphic here.

Render Library Items
The render library menu contains four render libraries: Backgrounds, Decals, Fore-
grounds and Materials. You can select any library by clicking on it or using the up 
or down arrow keys on your keyboard.

Backgrounds Contains pre-defined background effects that can 
be applied to a scene.
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Decals Contains pre-defined decals that can be applied to 
renderable objects.

Foregrounds Contains pre-defined foreground effects that can 
be applied to a scene.

Materials Contains pre-defined material properties that can 
be applied to renderable objects.

Within each library render images are divided into categories and displayed in the 
category menu. You can select any category within the category menu by clicking 
on it or using the up or down arrow keys on your keyboard. The Glass category for 
Materials is shown in the graphic here. 

In addition to the render image categories each library also includes two standard 
categories, [All] and [System].

[All] Selecting this category displays every image in the 
chosen library.

[System] Selecting this category displays images originally 
shipped with this Designer Elements program.

Most of the items in the Render Library define the color of your objects regardless 
of their pen color. However, to provide you with greater variety some materials use 
the object’s color. These include the following: Glass (Colored), Masonry (Brick-
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Colored), Metal (Polished), Misc. (Plain, Plain Rough, Plain Texture, Screen), Nature 
(Clouds), Patterns (Check Board, Cubes, Grid, Polka Dot Solid, Polka Dot 
Wrapped), Plastic (Clear Rough, Clear Texture, Opaque Rough, Opaque Texture, 
Stone (Marble), Wood (Simple) and Decals.

When you place one of these materials on an object, the material displays using the 
object’s color. For example: Brick-colored masonry placed on a blue object renders 
as blue masonry; Clear Rough Plastic placed on the yellow object renders with a 
yellow tint; Clouds placed on a red object renders as white clouds on a red object; 
Polka Dots placed on a green object renders as green dots on a white object.

Using the Materials Library
The Materials library contains materials you can apply to your model. A material 
defines the surface color, transparency, reflectivity and roughness properties of a 
model. You can produce a wide variety of visual appearances with different combi-
nations of these attributes.

The categories in the Materials library include Flooring, Glass, Masonry, Metal, Misc, 
Nature, Patterns, Plastic, Stone, Tiled Textures, Walls, Wood and Woven Textures.

Flooring Render images include: Tile 1, Tile 2, Tile 3, Tile 4, 
Tile 5, Tile 6, Tile 7, Wood Slats 1 and Wood Slats 
2.

Glass Render images include: Clear, Colored and Mirror. 
The Clear and Colored options only display cor-
rectly when using one of the ray trace rendering 
commands.

Masonry Render images include: Block Stone, Brick (Col-
ored), Brick (White), Brick (Peach), Cobble Stone, 
English 1, English 2, Flemish, Pavement (Gray), 
Pavement (Red), Rustic, Stone Wall.
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Tech Note:

If you’re using highly reflec-
tive material for an object in 
an empty space, the ren-
dered image may disappear 
since there is nothing to 
reflect. Add some surround-
ing environment and render 
again.
Metal Render images include: Aluminum, Aluminum (Cir-
cular Brushed), Aluminum (Linear Brushed), Chro-
mium, Cobalt, Copper, Gold, Graphite, Mercury, 
Nickel, Palladium, Platinum, Polished, Silver and 
Tungsten.

Misc Render images include: Bubble Wrap, Chisel, Plain 
Rough, Plain Texture and Screen.

Nature Render images include: Clouds, Clover, Grass, 
Leather, Skin, Sky 1, Sky 2 and Sponge.

Patterns Render images include: Checker Board, Cubes, 
Grid, Polka Dot Solid and Polka Dot Wrapped.

Plastic Render images include: Clear Rough, Clear Tex-
ture, Opaque Rough, Opaque Texture and Translu-
cent. The Clear Rough, Clear Texture and 
Translucent options only display correctly when 
using one of the ray trace rendering commands.

Stone Render images include: Conglomeration, Granite, 
Gravel, Limestone, Marble, Marble (Gray), Marble 
(Pink), Sand and Silt.

Tiled Textures Render images include: Knurl, Knurl 2, Mesh 1, 
Mesh 2, Pitted, Splatter, Swarf, VS Logo and Waffle.

Walls Render images include: Diamond Paper, Tile 1, 
Tile 2, Tile 3, Tile 4 and Tile 5.

Wood Render images include: Bark, Beech, Black Limb, 
Black Palm, Black Palm 2, Bocotec, Brazilian 
Ebony, Brazilian Rosewood, Bubingac, Canary, 
ChakteKok, Cocobola, Cork 1, Cork 2, CurlyKoac, 
Flamewood, Gabon Ebony, Goncalo Alvesc, Holly, 
Honduran Rosewood, Indonesian Rosewood, 
Kingwood, Lacewood, Lignum Vitae, Macassar 
Ebony, Madagascar Rosewood, Mahogany, Maple, 
Narrac, Pau Ferr, Pear, Pernambuco, Peroba Rosa 
2, Pine, Pink Ivory, Primavera, Satinwood, Saw-
dust, Sheduac, Simple, Spalted, Tulipwood, Vera-
wood, Walnut and Zebrawood.
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Tip:

If you want to apply different 
materials to different faces of 
a solid, convert the faces to 
surfaces using the Change 
Object Type command and 
apply the materials to each 
individual surface.
Woven Textures Render images include: Basket 1, Basket 2, Denim 
1, Denim 2, Dog Tooth, Hessian, Loop and Web-
bing.

The graphic shown is an example of Cobble Stone masonry 
applied to a block.

Applying Materials
1. Choose Window>Render Library to display the dialog box.

2. Select the materials library and desired category in their 
respective menus.

3. Place the pointer over the desired render image and drag. As the image is 
dragged over the drawing, the pointer becomes the material application sym-

bol.

4. Continue dragging to the object to which you want to apply the image. The 
object highlights. Release the mouse button.

You can apply a material to multiple objects simultaneously by selecting one or 
more objects while holding down the SHIFT key, position the cursor over the 
preview image (while still holding down the SHIFT key), then click the mouse 
button. 

A dialog box appears asking 
you to confirm the operation.

5. Apply more images to your 
objects as desired. Then ren-
der your drawing using one 
of the commands in the Ren-
der menu.

Geometric Characteristics
When you apply materials to an object, a Material page is added to the Edit Objects 
dialog box. Each material potentially has a large set of characteristics determined by 
the internal material definition. These characteristics have been mapped to a basic 
set or common characteristics and include the following items: Reflectivity, Trans-

Application Sym-
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parency, Roughness, Scale, Texture File, Enable Shadow Cast check box, Enable 
Shadow Receive check box, Double Side Facets check box and Is Backdrop Object 
check box. These characteristics are explained in the Material Editing section on 
page 38.

Removing or Replacing Material
To remove material from an object, drag the None symbol from the Ren-
der Library to the object and the material is removed. The symbol is 
shown here.

You can replace one material with another by simply dragging the new material 
image to the desired object. You can also replace a material by displaying the Edit 
Objects dialog box, selecting the Material page and from the Texture file pull-down 
menu, choose another texture.

See page 38 for more information about editing materials.

Using the Decals Library
The Decals library contains pre-defined decals that you can apply to your model. A 
decal overrides the local surface color properties of an object to which is it applied.

When applied to an object, the decal snaps to its surface and adjusts its shape (pla-
nar rectangle, cylindrical patch or spherical patch) according to the selected sur-
face. The decal shape is automatically determined by the surface curvature using 
one of this Designer Elements program internal wrap modes, Planar, Cylindrical or 
Spherical.

Planar Wrap This mode projects artwork along the 
decal’s normal vector and appears on 
the surface at the location you specify. 
The graphic shows a planar decal sym-
bol. The gray arrows indicate the nor-
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mal direction. The area defined by the artwork and 
the normals (the dotted lines) is the planar wedge.

The graphic shows planar 
wrapping for one object 
using two decals. One 
decal extends beyond the 
surface edge and wraps 
along the other adjacent 
surface as defined by the 
planar wedge. The object’s reflection appears in 
the mirror behind it.

Cylindrical Wrap This mode projects artwork along the surface nor-
mals of an imaginary cylinder that passes through 
the decal’s location point. The decal molds itself to 
the selected object adjusting to the object’s radius. 
The area defined by the artwork and the normals 
are the decal wedge area.

The graphic here shows a cylindrical 
decal symbol with the normal direc-
tion indicated by the arrows. Any por-
tion of the object that lies within the 
area bounded by cylindrical wedge 
(the dotted area in the graphic) and its normal dis-
plays the artwork. If the decal extends past the 
object edge, the decal will drag towards the center 
of the object.

The graphic here shows 
cylindrical wrapping for 
one object composed of 
a cylinder, bracket and 
block. The decal extends 
beyond the edge of the 
cylinder and bends toward the center of the cylin-
drical wedge, wrapping around the object. The 
object’s reflection appears in the mirror behind it.
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Tip:

To prevent a decal from 
showing through an object, 
select the decal and display 
the Edit Objects dialog box. 
Deselect the Auto Wrap 
option and select either the 
cylindrical or spherical wrap 
mode. 
Spherical Wrap This mode projects artwork along 
the surface normals of an imaginary 
sphere that passes through the 
decal’s location point. The decal 
molds to the selected object adjusting to the 
object’s radius. The graphic shows a spherical sym-
bol with the normal direction indicated by the 
arrows. Any portion of the object that lies within 
the spherical wedge (the dotted area in the 
graphic) and its normal displays the artwork.

The graphic shows spheri-
cally wrapping for one 
object composed of a 
sphere and a bracket.

The categories in the Decals library include Misc and Dig-
its.

Misc Render images include: Eroded. When an object is 
rendered with this decal, the object material 
appears to be wearing away.

Digits Render images include the numbers 0 through 9.

This graphic is another example of the decal wrap modes.

Applying Decals
1. Choose Window>Render Library to display the dialog 

box.

2. Select the desired library and category in their respective 
menus.

3. Place the pointer over the desired render image and drag. As the image is 
dragged over the drawing, the pointer becomes the decal symbol.

4. Continue dragging the decal to the object to which you want it applied. Use the 
axes included with the symbol for alignment. Release the mouse button.

Decal Symbol
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Apply more decals to your objects as desired. Then render your drawing using one 
of the commands in the Render menu.

Removing or Replacing Decals
To remove a decal from an object select the decal and delete it like any other 
object. You can replace one decal with another using the Edit Object dialog box.

Geometric Characteristics
A decal is considered an object in this Designer Elements program. When you apply 
a decal, the Edit Objects dialog box contains characteristics specific to a decal 
object. The characteristics include: Rotation, Width, Height, Wrap Mode, Auto Wrap 
check box, Lock Normal check box, Masking, Stencil and Logo.

Rotation This field sets the rotation angle of the decal. The 
default value is 0. Entering a new value (between 0 
and 360) and clicking Apply rotates the decal 
around the decal normal by the specified angle.

Width/Height These fields set the decal’s coverage area.The val-
ues are linear or arc lengths depending on the 
wrap mode.

Wrap Mode This field displays the decal wrap mode. It also 
includes a pull-down menu listing the three wrap 
modes, planar, cylindrical and spherical.

When Auto Wrap is not selected, use the wrap 
mode list to set the decal wrap mode. If the decal 
is moved to another object, the wrap mode does 
not change.

Auto Wrap This check box allows you to control the wrap 
operation. When this box is checked, the wrap 
mode is matched to the surface curvature of the 
underlying object. The computed wrap mode is 
displayed in the Wrap Mode field. If the decal is 
moved to another face of the object, the wrap 
mode is re-calculated.

When this box is left unchecked, the wrap mode is 
set using the Wrap Mode pull-down menu. 
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One possible application of this is when you want 
to apply a decal to a fillet. Uncheck auto wrap and 
lock normal and place the decal over the fillet.

Lock Normal This check box locks the normal of the decal. 
When this box is checked, the decal’s normal is 
always perpendicular to the object at the selected 
surface. When left unchecked, the decal can be 
placed at any angle with respect to the surface.

By selecting the decal 
and choosing 
Edit>Show Points, two 
control points display, 
the stencil control point 
and the normal point.

Select the stencil control 
point and drag it to a 
new angle. If you select Lock Normal again and 
click Apply, the decal snaps back to the normal 
location.

Radius (Cylindrical and Spherical wrap only) Specify a 
radius for the center point or the stencil control of 
the decal, different from the default value listed.

When placing a decal on a face it automatically 
projects through to the back face. Changing this 
value such that the radius falls within the body 
results in the decal appearing only on the face to 
which it was applied.

Masking This menu controls how a decal is applied on an 
object’s surface. You have two options, Stencil and 
Factor.
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Stencil masking uses an 
image file to define the 
regions of the decal art-
work that will show on an 
object’s surface. The 
graphic here uses a star 
stencil and mesh artwork. 

Factor masking is used to 
put a full image on an object surface. Where sten-
cil masking only places artwork on the object as 
defined by the stencil, factor masking places the 
entire artwork image on the object with no crop-
ping. This can be used for placing logos on objects 
or artwork on walls. 

The graphic here shows the 
same artwork with factor 
masking instead of stencil 
masking.

Stencil (Appears when Stencil Masking is selected) This 
field displays the name of the image file used. 
These stencil files are located in the Textures 
folder within the PhotoRender folder. If you want 
to use your own stencils in this Designer Elements 
program, place them in this folder.

When creating your own stencils it is important to 
know that a stencil is composed of pixels using the 
RGB color system. The red component (per RGB) 
of each pixel in the stencil image file is used as the 
color mix factor. A red value of 0.0 indicates that 
0% of the artwork color is used at the pixel loca-
tion. Thus, that pixel color is determined by the 
color of the object’s material. A red value of 1.0 
indicates that 100% of the artwork color is used at 
33-31



Rendering

33-32
the pixel location in place of the color of the 
object’s material. An intermediate value results in a 
mixture of the artwork color and the underlying 
material color.

Example: If you create a stencil that is 100% red 
(RGB), only the artwork color projected onto the 
object is used. If you lower the red percentage, 
some of the underlying material color mixes in. If 
you use black and red in your stencil, those areas 
that are black (or a 0% red value) use the underly-
ing material color when the artwork is projected. 
Any color other than black or red in the stencil is 
ignored.

Typically, a stencil file is composed of fully red 
and fully black pixels. This provides a clean crop-
ping of decal artwork. However, aged effects can 
be created using a stencil image file that consists of 
a mottled red patch on a black background.

In equation form, this combination translates into: 
SurfaceColor=ArtWorkColor*RedVal+Material-
Color*(1.0-RedVal). 

This formula shows how this Designer Elements 
program references the stencil file.

Factor slide (Appears when Factor Masking is selected) This 
slide allows you to set the value for Factor mask-
ing. Factor masking uses a single mix factor to 
compute the artwork material color combination. 
This masking is similar to Stencil masking except 
that there is only one value used for all pixels.

When the slider is set to the far left, representing 
0.0, the decal color is set by the object’s material. 
When the slider is set to the far right, representing 
1.0, the decal color is used. The left graphic below 
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has a 0.0 factor setting. The right graphic has a 1.0 
factor setting.

In equation form the combination translates into: 
Surface=ArtWorkColor*MixFactor+Material-
Color*(1.0-MixFactor). 

Logo This menu sets the source 
for the decal’s artwork. You 
have two options, Color 
and Image. In the example 
here, the DigitCourier2 is 
used as the decal stencil 
and a pebble image is used 
as the artwork.

Color logos use a solid color for the decal artwork. 
By default the color of the decal stencil is used 
when placed on an object. You can change the 
color of the decal by selecting it and choosing a 
different color in the Pen menu or on the 
Attributes page of the Edit Object dialog box.

Image logos use an image file for the decal art-
work.

Image (Appears when Image is selected from the Logo 
menu.) This pull-down menu lists the images avail-
able for decal artwork. These images are located in 
the Textures folder within the Photo Render folder. 
If you want to use your own images place them in 
this folder. See page 36 for more information.
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Using the Backgrounds and Foregrounds Libraries
Backgrounds and foregrounds can be used to set the overall scene. You can only 
use one foreground and one background per rendered drawing.

Backgrounds Library
The Backgrounds library contains pre-defined background effects you can apply to 
your model. Backgrounds control the appearance of those regions of a scene that 
do not contain objects.

The categories in the Backgrounds library include Images, Misc and Nature.

Images Render images include: VS Logo.

Misc Render images include: Graduated (Gray Black, 
Purple White, Red White, White Black, White Gray, 
White Purple, White Red) and Plain (Black, Gray, 
White).

Nature Render images include: Clouds.

The graphic shown is an example of a cloud background. 
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Foregrounds Library
The Foregrounds library contains pre-defined foreground effects you can apply to 
your model. Foregrounds effect the way the space between the eye point and the 
scene objects alter the rendering results.

The categories in the Foregrounds library include Misc and Nature.

Misc Render images include: Depth Cue (Black, Gray 
and White).

Nature Render images include: Fog (Heavy, Light), 
Ground Fog (Deep, Shallow) and Snow (Light, 
Heavy).

The graphic shown is an example of a snow foreground. 

Applying a Background or Foreground
1. Choose Window>Render Library to display the dialog box.

2. Select the desired foreground or background library.

3. Place the pointer over the desired render image and drag. As the image is 
dragged over the drawing, the pointer becomes the application symbol.

4. Drag to the drawing area and release the mouse button.

Removing or Replacing Backgrounds and Foregrounds
To remove a background or foreground from a scene drag the None sym-
bol from the Render Library to the object and the material is removed. The 
No Material symbol is shown here.

You can replace one background or foreground with another by dragging the new 
image to the scene.
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Geometric Characteristics
Foregrounds and Backgrounds have no geometric characteristics therefore are not 
accessible through the Edit Objects dialog box. However, they can be edited using 
the Edit Foreground or Edit Background commands in the Render menu. For infor-
mation, see “Background and Foreground Editing” on page 47.

User-defined Images
You can use your own material and decal images in this Designer Elements pro-
gram when used with the Edit Objects dialog box. This ability is useful if you have 
specific materials or decals unique to your company and industry. On possible use 
is the application of company logos to objects in your drawing.

To prevent distortion all texture images should be square. LightWorks, the render-
ing engine, maps textures to a 1” square when the scale is set to 1.0.

Creating your own Decals
If you want to apply your own decals you need create your own decal stencils and 
artwork. Since the artwork projects through the stencil, any bitmap image is accept-
able. Create your artwork image using any graphic program that supports bitmaps.

To create a stencil do the following:

1. Create the shape of your stencil.

2. Color your stencil using a percentage of red depending on the desired stencil 
affect.

Set the Red value (RGB color) to 255 or 100% red if you only want to project the 
artwork color onto the object without using the material’s color. Lower the Red 
value to mix some of the underlying material’s color with the artwork color. Use 
black in those areas where you only want to use the material’s color when the 
artwork is projected.

Applying User-defined Material Images
1. Create your own bitmaps images.

2. Place them in the Textures folder located within the PhotoRender folder stored 
with the program.

These textures will not appear as an image in the Render Library.

3. Apply a Designer Elements program supplied texture to your object.

4. Double-click on the object to display the Edit Objects dialog box.
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5. From the Texture file menu select the image you created.

6. Click Apply and render your scene.

Your own material is displayed on your object.

Applying User-defined Decal Images
1. Create your own bitmap images, both the decal stencil and the decal artwork.

Make sure you follow the stencil and artwork formulas as directed earlier in this 
chapter.

2. Place the stencils and image in the Textures folder located within the PhotoRen-
der folder stored with the program.

3. Double-click on the decal to display the Edit Objects dialog box.

4. From the Stencil menu in Edit Objects select the stencil image you created.

5. In the Logo menu choose the Image option.

6. From the Image menu, select the artwork image you created.

7. Click Apply and render your scene.

Your own decal is displayed in your scene.

Editing the Rendered Scene
This Designer Elements program now gives you access to Lightworks shader tech-
nology. Instead of one shader, you now have five different shaders to render your 
scene. You can change your object materials or the background and foreground 
images.

Once you have applied materials to your objects and applied a background or fore-
ground if desired, you can edit them.
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Tip:

When using materials such as 
polished metal setting the 
reflectivity to a value less 
than one may produce a bet-
ter rendering.
Material Editing
There are two levels of editing materials of an object; the first is through the Mate-
rial page in the Edit Objects dialog box; the second is through the Render Material 
Settings dialog box accessed through the Material page.

The Material page of the Edit Objects dialog box include the following characteris-
tics or options:

Reflectivity This field sets the material’s reflectivity. Values can 
be entered between zero (0) and one (1). Entering 
a zero in the field renders a flat finish. Entering a 
one in the field renders a mirrored finish.

Transparency This field sets the transparency of the material. Val-
ues can be entered between zero (0=transparent) 
and one (1=opaque). This option only works cor-
rectly when objects are rendered with ray trace 
rendering commands.

Roughness This field sets the roughness of the material. Values 
can be entered between zero (0) and one (1).
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Scale This field sets the scale of the of the material. Typ-
ically scale increases the size of the detail. Values 
can be entered equal to or greater than zero (0).

Texture File This field displays the selected material. The pull-
down menu lists all images in the texture folder. 
For those materials that do not support textures 
this menu is not available.

Enable Shadow Cast This check box allows you to specify if an object 
casts shadows. This is valuable for reducing the 
shadows present in complex drawings. When 
checked the selected object casts shadows.

Enable Shadow Receive This check box allows you to specify whether an 
object will receive shadows from other objects. 
This ability is valuable for reducing the number of 
shadows present in complex drawings. When 
checked the selected object receives shadows.

Double Sided Facets This check box provides you with additional ren-
dering control for surfaces. Objects with normals 
facing away from the line of sight are not ren-
dered. When checked all objects are rendered, 
regardless of the normal direction. 

Select this option for objects that cause light refrac-
tion, like glass. When left unchecked facets on the 
back side of the glass are ignored resulting in an 
inaccurate rendering.

Is Backdrop Object This check box allows you to optimize rendering 
calculation time for an object, like a wall, that 
functions only as a backdrop for other objects. 
Since the object automatically receives light due to 
its large size, this Designer Elements program does 
not need to spend much time performing light ray 
calculations.

Advanced button Clicking this button brings up the Render Material 
Settings dialog box. Use this dialog to change the 
advanced rendering settings used on the selected 
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object. See the next section for a detail description 
of these settings.

Render Material Settings
When you click the Advanced button on the Material page of the Edit Objects dia-
log box, the following dialog box appears.

The dialog box includes the following sections and options:

Shader Class This section displays the shader class. Select the 
class from the pull-down menu. You have five 
shader classes: Color, Displacement, Reflectance, 
Transparency and Texture Space. The shader 
types, their associated attributes and values vary 
with the shader class. Each shader class works 
independently of the others. The setting for one 
shader does not affect another. However, the set-
tings in each class work together to create the final 
object appearance when it’s rendered.

Shader Types This section lists the shader types for the selected 
class. Select the type from the list. Each set of 
types is unique to the class. Each type has its own 
set of attributes.

Attributes This section displays the attributes for the selected 
type. Select an attribute for the type from those 
listed. Each attribute has its own set of values.
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Attribute Value This section usually displays the values for the 
selected attribute. Choose or enter the attribute 
value. The value range appears at the lower left 
corner of the dialog box. The values can be 
numerical, an image file or a color setting. An Edit 
button displays in this section when a shader 
attribute is selected. Clicking this button displays a 
copy the dialog box allowing you to select the 
shader from the same shader type list as the origi-
nal dialog box.

Preview Sample This section displays the preview window shape 
list, preview window, the Auto option and an 
Update button.

The preview window shape list allows you to set 
the object shape shown in the window. There are 
five shapes available from the pull-down menu: 
cone, cube, cylinder, object and sphere. This fea-
ture allows you to see how the same shading char-
acteristics appear on different shapes. Object, 
which displays the actual shape, is the default 
shape.

The preview window displays the shape based on 
the shader class, type, attributes and values cur-
rently set.

The Auto option controls whether the preview 
image is automatically refreshed when a material 
setting changes. Checking this box results in an 
automatic refresh. When checked, the Update but-
ton is unavailable.

The Update button controls the manual refresh of 
the preview window. Click the button to refresh 
the preview window image after making a material 
setting change.

Range This area, at the lower left edge of the dialog box, 
displays the value range for the selected attribute.
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Tech Note:

If you enter values in the 
attribute value field and 
change to another shade 
type, those values are not 
retained. If you want to 
experiment with various set-
tings, record the values 
before changing shader 
types.
OK Click this button to close the dialog box and save 
the settings. The selected object automatically 
updates to reflect the changes.

Cancel Click this button to close the dialog box without 
saving the changes.

After you specify the settings for an object from the desired classes and types, this 
Designer Elements program combines the settings from all five shaders (Color, Dis-
placement, Reflectance, Transparency, Texture Space) to render the object with one 
of the photorealistic commands. The settings work together to create the final 
effect.

Color Class
Use this class to define the object color. The color shader types allow you to specify 
a color from one color to more complex patterns of color. The shader types are 
listed alphabetically. For the purposes of this explanation, the types are grouped 
into following categories:

Curvature These types use color to show the object’s curva-
ture and include: absolute, gaussian, geometric 
and mean.

Texture These types are 3D color shaders that give the 
object a specific appearance. The texture shaders 
include: birch, blue marble, cherry, chrome, 
maple, marble, oak, pine, plain, simple wood, 
solid clouds, solid polka and wood.

These shaders are different from image shaders in 
that they calculate a particular pixel color in 3D 
space for the object based on the type attributes. 
Imagine the object carved out of a block of the 
selected texture. In contrast, an image shader uses 
the associated 2D bitmap to determine the object 
color rather than individual pixels.

Evaluation These types use color to evaluate the selected 
object and include: draft angle and surface. See the 
Verify Menu section of Chapter 24 for information 
of surface and draft evaluation. You can also see 
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Chapter 21 for surface evaluation and Chapter 23 
for draft evaluation.

Wrapped Image These types use an associated 2D bitmap image to 
determine the object color. The image is wrapped 
around and mapped to the entire object. These 
types include: wrapped image and wrapped fil-
tered image. The available images are located in 
the Textures folder inside the PhotoRender folder.

Wrapped Textures These types are 2D color shaders that are wrapped 
around the object. Unlike wrapped image shaders, 
these shaders calculate the shader color based on 
the attribute values and are not associated with a 
bitmap image. These shaders include: birch floor, 
wrapped brick, wrapped checker, wrapped cherry 
floor, wrapped diagonal, wrapped grid, wrapped 
maple floor, wrapped oak floor, wrapped pine 
floor, wrapped polka, wrapped s stripe, wrapped t 
stripe, wrapped textured brick and wrapped wood 
floor.

Decal The decal shader type allows you to define the 
decal texture space, transparency and color.

Turbulent The turbulent shader type creates an agitated or 
turbulent effect using color and contrast.

All shader attributes are defined in Appendix G.

Displacement Class
Use this class to define the roughness of an object. The displacement shader types 
allow you specify a variety of roughness patterns. The shader types are listed alpha-
betically. For the purposes of this explanation, the types are grouped into following 
categories:

Displacement These types create a displacement calculated in 3D 
space using the pattern defined by the shader’s 
attributes and include: casting, flat, leather and 
rough. Like the Color texture shaders, imagine that 
the object is carved out of a displacement shader 
block.
33-43



Rendering

33-44

Tech Note:

Remember that by defini-
tion applying a reflectance to 
an object means that the 
object will have something to 
reflect. If there is no back-
ground on other object in 
the scene to reflect, when 
rendered the object may dis-
appear.
Wrapped Displacement These types create a displacement by wrapping the 
2D pattern defined by the type attributes around 
the object. The shaders include: wrapped dimple, 
wrapped knurl, wrapped leather, wrapped rough 
and wrapped tread plate.

Wrapped Image These types use an associated 2D bitmap image to 
determine the displacement and include: wrapped 
bump map and wrapped old bump map. When 
using an image for displacement, the shader exam-
ines the % color change from pixel to pixel to 
determine the displacement. For example, an 
image with black and white stripes might appear 
as a groove displacement. Gradual color changes 
in an image result in a more general displacement 
from pixel to pixel. The available images are 
located in the Textures folder inside the PhotoRen-
der folder.

None This type creates no displacement.

All shader attributes are defined in Appendix G.

Reflectance Class
Use this class to define the object’s reflectance. The reflectance shader types allow 
you specify a variety of reflectance values and patterns defining a surface’s finish. If 
no reflectance is specified for a material, the default Gouraud type finish is applied.

The shader types are listed alphabetically. For the purposes of this explanation, the 
types are grouped into following categories:

Standard These types are reflectance modelers that provide 
a particular appearance according to the shader 
selected. These shaders include: chrome 2D, con-
stant (color), matte finish, metal finish, multilayer 
paint, phong, plastic, translucency and translucent 
plastic.

Ray Trace These type modelers are reflectance simulations 
using ray tracing. They range in accuracy from 
approximations to physically accurate. These shad-



Editing the Rendered Scene
ers include: conductor (metallic), dielectric (glass), 
glass (approximation) and mirror, 

Wrapped These type reflectance shaders wrap the reflec-
tance image around the object creating the effect 
specified by the shader. These shaders include: 
wrapped anisotropic (parallel ridges), wrapped cir-
cular anisotropic (circular ridges), wrapped mirror 
map and wrapped woven anisotropic (woven 
threads).

Decal This reflectance shader allows you to define the 
decal and base color reflectance.

All shader attributes are defined in Appendix G.

Transparency Class
Use this class to define the transparency of the object. This shader types allow you 
to set transparent or opaque nature of an object. These shaders can create transpar-
ency effects which range from simple to complex and irregular. The shader types 
are listed alphabetically. For the purposes of this explanation, the types are 
grouped into following categories:

Standard These types create a transparent effect based on 
the shader selected and include: eroded, glow, 
plain (based on the red component of the color 
selected where red is transparent and black is 
opaque) and plain coverage (based on a value).

Wrapped These types create a transparent effect by wrap-
ping the effect around the object and include: 
wrapped checker, wrapped grid, wrapped mask 
and wrapped square.

Wrapped Image These types create a transparent effect by wrap-
ping a 2D image around the object and include: 
wrapped image and wrapped mask. The available 
images are located in the Textures folder inside the 
PhotoRender folder.

None This type creates no transparent effect.

All shader attributes are defined in Appendix G.
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Texture Space Class
Use this class to define the plane of the texture space or how textures are projected 
to the object. If no texture space is selected, the texture is projected down the z axis 
and uses the z plane. The types include the following:

arbitrary plane This type allows you to specify the vector along 
which the texture is projected.

auto axis This type automatically chooses either the x, y or z 
axis, depending on the normal of the object face.

cylindrical This type projects the texture image to a cylindrical 
space using the user-defined origin to set the tex-
ture’s starting point.

spherical This type projects the texture image to a spherical 
space around the radials.

uv This type projects the texture onto the object using 
the uv coordinate system.

x plane This type projects the texture to a constant x plane 
where the positive z axis is up.

y plane This type projects the texture to a constant y plane 
where the positive z axis is up.

z plane This type projects the texture to a constant z plane 
where the positive y axis is up.

All shader attributes are defined in Appendix G.

Using the Render Material Settings Dialog Box to Edit Your Object
1. Double click on the object you want to modify to open the Edit Objects dialog 

box.

Remember that a material must already have been applied to the object.

2. Select the Material page.

3. Click the Advanced button to display the Render Material Settings dialog box.

4. Select the desired settings for each shader class, as desired.

5. Preview your object using the Update button or the Auto option.
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6. Click OK when you are satisfied with the settings to close the dialog box and 
save the settings.

You can now select another object to edit or use the Eye Dropper tool to apply 
the same setting from this object to another object. The Eye Dropper tool copies 
object characteristics such as line font, color, pattern, arrow at start and end and 
render materials from one object to another. See the Chapter 4 for information 
on the Eye Dropper tool.

7. Render your scene with one of the photorealistic commands. You objects now 
appear based on the settings you specified for each object. 

See page 52 for information on using the photorealistic commands.

Background and Foreground Editing
To edit the background or foreground appearance already applied to your scene, 
choose PhotoRender>Edit Background or Foreground. (If you did not apply a 
background or foreground to your scene, no dialog box appears.) The Shader Set-
tings dialog box appears.

This dialog box is almost identical to the one that appears when editing object 
materials and is divided into the same sections, Shader Class, Shader Types, 
Attributes, Attribute Value and Preview Sample. See page 40 for a description of 
each section.

For certain shader types the Attribute value is the Edit button. Clicking the button 
opens another Shader Settings dialog box that is identical to the first. Select the 
shader type, attributes and attribute values and click OK. You are returned to the 
first Shader Settings dialog box.
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Background Settings
The Shader Settings dialog box contains only the Background class and its related 
types, attributes and values. The shader types are listed alphabetically and include:

clouds This shader type creates a cloudy background.

graduated This shader type displays a graduated background 
in the color you specify.

image This shader type applies a background from an 
image file. The available images are located in the 
Textures folder inside the PhotoRender folder.

mixed This shader type allows you to mix background 
shaders according to the mixing ratio. Ratios 
between 0 and .5 favor the base shader. Clicking 
on the Edit button in the Attribute Value section 
opens a second Shader Settings dialog box for 
choosing the shader.

none No background appears in your scene.

plain This shader type displays one color background.

ray cube This shader type displays a background using pri-
mary and secondary shaders to deal with refrac-
tions and reflections. One shader is used for 
background areas that are directly visible. The 
other shader is used for the refraction component. 
For example, if this Designer Elements program 
casts a ray that does not intersect any geometry, 
the primary shader is used. If the ray does intersect 
geometry the ray is reflected and uses the second-
ary shader.

scaled image This shader type applies the background from an 
image file which is scaled to fill the drawing win-
dow. The available images are located in the Tex-
tures folder inside the PhotoRender folder.

two planes This shader type applies a background using a 
back and front shader to deal with refractions and 
reflections. One shader is used for background 
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areas that are directly visible. The other shader is 
used for the refraction component. For example, if 
you have a mirrored object and set the front 
shader to one type and the back shader to another, 
the shaders are reflected on the object.

Foreground Settings
The Shader Settings dialog box contains only the Foreground class and its related 
types, attributes and values. The shader types are listed alphabetically and include:

depth cue This shader applies a background color with a lin-
ear attenuation of the color between a specified 
near and far value. 

fog The shader applies a gradual fog to the scene 
based of the color, density and distance specified 
by the user.

fog light This shader creates a light scattering effect when 
used with point and spot light sources.

ground fog This shader simulates fog that decreases gradually 
with altitude.

light scattering This shader creates an atmospheric scattering of 
light effect more general than that created by the 
fog light shader.

none No foreground appears in your scene.

scattering medium This shader simulates a dense scattering medium 
based on various settings including color, shad-
ows, attenuation and density.

snow This shader simulates the effect of falling snow.

Photorealistic Rendering
This Designer Elements program gives you the ability to photorealistically render 
your geometry. You can specify rendering settings and choose among various com-
mands before rendering your scene.
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Photorealistic Rendering Settings
You can change the low-level behavior of the rendering engine through the Photo 
Realistic Render Settings dialog box. Choose PhotoRender>Advanced Settings to 
display the dialog box.

The dialog box contains the following options:

Raytrace Max Reflections This setting controls the maximum number of 
bounces a ray travels. Once a ray has reached the 
specified limit no further color calculations occur 
for that ray. The images of a mirror-walled room, 
shown here, demonstrate the effect of changes in 
the value.

Raytrace Over-Sample This setting controls the threshold for adaptive 
image over-sampling. When the rendering opera-
tion encounters a significant color change in your 
image, it will be sampled until the largest of the 
red, green and blue components for the adjacent 
color samples do not differ by more than the spec-
ified value. The value can be between 0.0 and 1.0. 

Max Reflections = 2 Max Reflections = 6 Max Reflections = 16

 Cutoff
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Enter a value or use the slider to set the sampling 
limit. The default value is 0.1.

Use Anti-Alias Feature This check box controls the application of Feature 
Following. When checked, a second pass is made 
over an image bringing out small geometric feature 
details that may have been lost due to ray sam-
pling aliasing.

Use Transparency Shadows This check box controls the behavior of shadow 
generation for transparent objects. When checked, 
the transparent object casts a shadow as deter-
mined by its shape and color. When left 
unchecked, the transparent object casts an opaque 
shadow.

One example of this 
is a stained glass 
window. When 
checked, the win-
dow projects color 
shadows. Left 
unchecked, the win-
dow projects an 
opaque shadow.

Use View Clip Distances This check box controls the near and far clipping 
plane behavior. Near and far planes are normal to 
the view vector and are at a specified distance 
from the eye point (see Chapter 30 for information 
on eye points). Any objects or portions of objects 
that lie before the near clipping plane and after the 
far clipping plane are ignored. As implied, an 
object can be sliced if intersected by a clipping 
plane. 

When checked, the Near and Far data fields 
become available. Enter the Near and Far dis-
tances. The units are based on those set in Units 
page of Preferences. 

Following
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The graphic here shows 
an example of a clipped 
image.

When left unchecked, clipping planes are automat-
ically set to the near and far view extents of the 
model and the objects in view are rendered. This 
box is left unchecked by default.

OK Click this button to save the new settings and close 
the dialog box.

Cancel Click this button to exit the dialog box without 
saving the settings.

Defaults Click this button to return the settings to the fac-
tory state.

Photorealistic Rendering Commands
There are four render to window commands in this Designer Elements program: 
Preview Render (shadows off), Preview Render (shadows on), Raytrace Render 
(shadows off) and Raytrace Render (shadows on, Anti-Alias).

Preview Render This command creates a 
quality rendering of your 
scene. It renders most rap-
idly of all the commands 
since there are no ray tracing 
and shadow calculations.

Preview Render This command creates a 
more realistic rendering than 
Preview Render (shadows 
off) with shadows. It ren-
ders quickly since there is no 
ray tracing.

(shadows off)

(shadows on)
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Raytrace Render This command creates a high 
quality rendering of your 
scene. The processing time is 
extended with addition of 
the ray tracing operation.

Raytrace Render This command creates the 
highest quality rendering of 
your scene, eliminating 
jagged edges. It uses the 
accuracy of ray tracing with 
anti-alias over-sampling. 
The computational time is 
significantly longer. The 
Advanced Setting dialog box 
controls the sampling calculations.

When using a rendering command any objects with no specified material have a 
default material/shader applied to them the first time the scene is rendered. The 
default shader settings are as follows: Color shader - plain, Reflectance shader - 
Phong, Transparency shader - none and Displacement shader - none.

The DefaultVSMFile entry in the [RenderOptions] section of the Render.ini file con-
trols the default material. If the DefaultVSMFile entry is not found, the material 
specified by the MiscPlain material is used.

For more information on shader types, see the “Render Material Settings” section on 
page 40.

Rendering your Geometry
This Designer Elements program allows you to render your entire scene or a speci-
fied area.

Rendering your Entire Scene
This Designer Elements program enables you to ren-
der your entire scene with one command, showing 
you how the applied materials appear on your 
objects. The graphic is rendered using the Raytrace 
Render (shadows on, Anti-Alias).

1. Apply materials to the objects in your scene.

(shadows off)

(shadows on, Anti-Alias)
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Tech Note:

This Designer Elements pro-
gram does not support 
directly printing a photoreal-
istic image. Use the Render 
to File command on your 
image, open the file in a 
graphics application and print 
from there.
2. Choose PhotoRender> and the command.

Your scene renders.

Rendering an Area
When applying materials to your objects, you may 
want to see the results from one specific area of your 
scene. The area render feature gives you that ability. 
Using the CTRL (Windows) or OPTION (Macintosh) 
key, you can specify an area to render. In the 
graphic only the area around the left object is ren-
dered.

1. Apply materials to objects in your scene.

2. Hold down the CTRL (Windows) or OPTION (Macintosh) key and from the 
PhotoRender menu, select one of the photorealistic commands.

The Message Line reads: Advanced Render: Box area to render. 

3. While still holding down the CTRL (Windows) or OPTION (Macintosh) key, 
drag a selection fence to define the rendering area.

4. Release the CTRL (Windows) or OPTION (Macintosh) key and the mouse but-
ton.

The area renders.

Render to File
In addition to the commands for 
rendering your scene to a win-
dow, you can render your image 
to a file. Choose PhotoRen-
der>Render to File to display 
the dialog box.

The dialog box contains the fol-
lowing options:

Render Mode The pull-down list allows you to specify the render 
mode used in creating the file.

Image Type This section provides you with output file types. 
These include eight image format types: Windows 
bitmap (bmp), Targa (tga), TIFF (tif), JPEG (jpg), 
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Lightworks (lwi) and Encapsulated Postscript 
(eps).

Image Width/Height These data fields allow you to specify the image 
size in pixels. If you want a six inch wide image 
with 300 dpi, enter 6”*300 in the Width data field.

These fields function with the Match Width/Height 
to Drawing Window Aspect check box.

Match Width/Height to When checked, the image’s width to height ratio 
equals the drawing window’s width to height ratio. 
Entering a value in either the Width or Height field 
automatically enters a corresponding value in the 
other field. With the box unchecked, you can enter 
any value

Save Click this button to save the file and close the dia-
log box.

Cancel Click this button to exit the dialog box without cre-
ating a file.

Creating Image Files
This Designer Elements program allows you to create publication quality images 
with higher resolution images than produced on a typical computer monitor.

1. Create your drawing and apply the render materials to your objects.

2. Choose PhotoRender>Render to File.

3. Choose the render mode from the pull-down menu.

4. Choose the image file format 
you want to create.

5. Enter the desired width and 
height values. If the Match 
Width/Height to Drawing Win-
dow Aspect box is checked, 
you only have to enter a value 
in one field.

6. Click Save to create the file.

(Drawing Window Aspect)
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Display Last Image Command
Use this command in the Render menu to display your previously rendered scene 
without having to render your scene again. This command is helpful if a dialog box 
appears or you inadvertently click your mouse and lose the rendered image. This 
command saves time if you’ve rendered your scene with one of the photorealistic 
commands.

Note: If you rotate your geometry after rendering your scene and then use this com-
mand, the image that appears reflects your last rendering and not your current 
drawing orientation.

Rendering and Multi-processors
If your computer uses multi-processors and you are rendering an image with one of 
the photorealistic commands, this Designer Elements program will make use of 
those processors to separate the image into pieces and thus improve the rendering 
time.

Animation
This Designer Elements program provides the ability to create five types of movies. 
The animation features are available through the Render menu.

You can create five types of movies. The first three, Walk Through, Fly By and 
Paths, allow you to specify a path for the camera movement through a scene and 
require that QuickTime be installed on your Windows or Macintosh computer. The 
last two, Object VR and Panoramic VR, allow you to specify the pan or tilt of the 
camera but the camera path is predefined.

Note: Background images can be used for Walk Through, Fly By and Paths anima-
tions. They cannot be used for Object VR and Panoramic VR animations.
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QuickTime Movies with Camera Movement
The Walk Through, Fly By and Paths movies allow you to define the movement of 
the camera using a curve. As you proceed through the steps to create a movie two 
dialog boxes appear, the QT Movie dialog box and the Compressor dialog box. 
These are almost identical for all three of these movie types and allow you to spec-
ify the movie settings.

Curve Rules:

• One or more curves can be selected for a path.

• Although path curves should normally be connected, they do not need to be. 
Disconnected curves will result in a non-continuous jump in the movie.

• Curves cannot be grouped.

• Check the curve direction using Verify>Show Curvature to ensure that the 
direction is correct for the desired animation.

• Select the curves in the desired order.

The QT Walk Through Movie dialog box is shown here.

The dialog box includes the following options:

Render Mode The pull-down menu allows you to set the render 
mode for the movie. You have six options: Preview 
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(shadows off), Preview (shadows on), Raytrace 
(shadows off) and Raytrace (shadows on), Raytrace 
(Shadows off, Anti-Alias) and Raytrace (Shadows 
on, Anti-Alias).

Image Type This field displays the image type as mov (QT 
Walk Through Movie) and cannot be changed in 
this dialog box. It is set when you choose the ani-
mation type.

Image Width/Height These data fields allow you to specify the image 
size in pixels. If you want a six inch wide image 
with 300 dpi, enter 6”*300 in the Width data field.

These fields function with the Match Width/Height 
to Drawing Window Aspect check box.

Match Width/Height to When checked, the image’s width to height ratio 
equals the drawing window’s width to height ratio. 
Entering a value in either the Width or Height field 
automatically enters a corresponding value in the 
other field. With the box unchecked, you can enter 
any value

Description This field contains the movie description which 
displays when the movie is viewed. Enter your 
movie description.

Copyright This field contains the movie copyright which dis-
plays when the movie is viewed. Enter your copy-
right information.

Camera This section contains the FOV (Field of View) 
angle and the Frames for the movie. The FOV field 
sets the view angle for the camera. The default 
angle is 55°. The Frames field sets the number 
images you want generated for the movie. The 
default number is 10.

Save Click this button to save the file and close the dia-
log box.

Cancel Click this button to exit the dialog box without cre-
ating a file.

(Drawing Window Aspect)
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The Compressor Settings dialog box, shown here, includes the following options: 

Compressor Type The pull-down menu allows you to set the com-
pressor type. The types include Animation, BMP 
(Windows only), Cinepak, Component Video, DV - 
NTSC, DV - PAL, Graphics, H.261, H.263, Intel 
Indeo Video® 4.4 (Windows only), Intel Video® 
R3.2 (Macintosh only), Intel Raw (Macintosh only), 
Motion JPEG A, Motion JPEG B, None, Photo - 
JPEG, Planar RGB (Windows only), PNG, Sorenson 
Video, TGA (Windows only), TIFF (Windows only) 
and Video. The movie quality is affected by the 
compression setting.

Compressor Color From the pull-down menu you can choose a color 
option. The options vary according to the com-
pressor type chosen.

Quality This slider allows you to set the movie quality.

Motion This section includes the Frames per second data 
field and the key frame every x frames check box/
data field.
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Frames per second: Enter the number of frames per 
second or use the pull-down menu to specify the 
number.

Key frames every x frames: Enter a number in the 
data field to guarantee that a specific or key frame 
will be played back during a certain time frame. 
Playback speed is affected by the computer speed 
on which the movie is run. If you later want to 
sync sound to the movie track, a key frame pro-
vides some control. For example: if you create a 
movie set to 20 frames per second and a key frame 
every 100 frames, a key frame will be marked 
every 5 seconds. When the movie is played, the 
movie will skip frames so that every 5 seconds, the 
key frame is viewed. This allows a sound track to 
be synced to the movie using the key frame set-
ting.

This field only activates for the Animation, 
Cinepak, Graphics, H.261, H.263, Intel Indeo 
Video® 4.4 (Windows only), Intel Video® R3.2 
(Macintosh only), Intel Raw (Macintosh only), 
Sorenson Video, TGA (Windows only) and Video 
compressor types.

OK Click this button to generate the movie

Cancel Click this button to exit the dialog box without cre-
ating a movie.

Walk Through Animation
This animation command creates a walk through movie using a curve to define the 
camera path. The eye point is on the curve. As the camera moves along the curve, 
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its orientation is tangential to and along the curve at the eye point. The graphics 
illustrate the eye point and camera orientation at two locations along a curve.

Each movie frame is taken at a particular location on the curve based on the num-
ber of frames. If a curve slopes down, the camera follows the tangent and slopes 
down as well, resulting in the eye looking down at the angle specified by the tan-
gent. The up vector of the camera is always the z axis.

Creating a Walk Through Animation
1. Create a curve along which the camera will travel for the movie.

2. Choose Animation>Walk Through. The Message Line reads: Walk Through 
Animation: Pick curve for camera eye path [Shift=Extend].

3. Select the curve. (Hold down the SHIFT key to select more than one curve.)

The QT Walk Through Movie dialog box appears.

4. Choose your settings.

5. Click Save. The Save document As dialog box appears.

6. Type in the movie name and navigate to the location where you want to save 
the file.

7. Click Save. The Compression Settings dialog box appears. 

8. Specify your settings for the compressor.

eye point

Camera orientation:
tangent at the eye point
along the curve

z
y

x

eye point

Camera orientation:
tangent at the eye point
along the curve

z
y

x

33-61



Rendering

33-62
9. Click OK. A progress dia-
log box appears providing 
you with a preview movie 
window and information 
on the number of frames 
generated.

The Message Line provides 
you with information on 
the pass, time elapsed and 
time remaining to gener-
ate the movie.

You can click to end the operation before it’s complete. This Designer Elements 
program will finish generating the current frame and write out the movie at that 
frame. Once the movie is generated you cannot add more frames to it. The dia-
log box disappears when the movie generation is complete.

10. You can now view the movie using QuickTime player.

Fly By Animation
This animation command creates a fly by movie using a curve to define the camera 
path. The eye point is on the curve. The camera orientation is directed towards the 
reference point you specify. The up vector of the camera is always the z axis. The 
reference point never changes. The point can be in space or on an object. The 
graphics illustrate the eye point, camera orientation and reference point at two loca-
tions.

Creating a Fly By Animation
1. Create a curve along which the camera will travel for the movie.

eye point

z
y

x

reference point

Camera orientation:
towards the fixed
reference point

eye point

z
y

x

reference point

Camera orientation:
towards the fixed
reference point
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2. Choose Animation>Fly By. The Message Line reads: Fly By Animation: Pick 
curve for camera eye path [Shift=Extend].

3. Select the curve. (Hold down the SHIFT key to select more than one curve.)

The Message Line now reads, Fly By: Pick location for camera reference point.

4. Pick a reference point location towards which the camera will always be 
directed.

The QT Fly By Movie dialog box appears.

5. Choose your settings.

6. Click Save. The Save document As dialog box appears.

7. Type in the movie name and navigate to the location where you want to save 
the file.

8. Click Save. The Compression Setting dialog box appears.

9. Click OK. A progress dialog box appears providing you with a preview movie 
window and information on the number of frames generated. 

The Message Line provides you with information on the pass, time elapsed and 
time remaining to generate the movie.

You can click to end the operation before it’s complete. This Designer Elements 
program will finish generating the current frame and write out the movie at that 
frame. Once the movie is generated you cannot add more frames to it. The dia-
log box disappears when the movie generation is complete.

10. You can now view the movie using QuickTime player. 

Paths Animation
This animation command creates a paths movie using a curve to define the camera 
path and another curve to define the location of the reference point towards which 
the camera is directed. The eye point is on the first curve. The up vector of the 
camera is always the z axis.

Each of the curves are divided according to the number of frames specified for the 
movie. The first frame eye point on the camera path curve corresponds to the first 
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frame reference point on the reference path curve. The graphics illustrate the eye 
point, camera orientation and reference point at two locations.

Creating a Paths Animation
1. Create two curves, one to define the camera path and the other to define the 

reference point towards which the camera is directed.

2. Choose Animation>Path. The Message Line reads: Paths Animation: Pick 
curve for camera eye path [Shift=Extend].

3. Select the camera path curve. (Hold down the SHIFT key to select more than 
one curve.)

The Message Line now reads, Paths: Pick curve for camera reference path 
[Shift=Extend].

4. Select the reference point curve.

The QT Paths Movie dialog box appears.

5. Choose your settings.

6. Click Save. The Save document As dialog box appears.

7. Type in the movie name and navigate to the location where you want to save 
the file.

8. Click Save. The Compression Setting dialog box appears.

9. Click OK. A progress dialog box appears providing you with a preview movie 
window and information on the number of frames generated.

The Message Line provides you with information on the pass, time elapsed and 
time remaining to generate the movie.

You can click to end the operation before it’s complete. This Designer Elements 
program will finish generating the current frame and write out the movie at that 

eye point
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frame. Once the movie is generated you cannot add more frames to it. The dia-
log box disappears when the movie generation is complete.

10. You can now view the movie using QuickTime player.

Backgrounds and Movies
You can put in a background for Walk Through, Fly By and Paths animations.

1. Create your background image in a graphic software.

2. Place the image file in the Textures folder within the PhotoRender folder.

3. Display the Render Library.

4. Select the Backgrounds library and the Images category.

5. Apply the VS Logo image to your background.

6. Choose PhotoRender>Edit Background.

7. Select image in the Shader Types list.

8. From the Attribute Value pull-down menu, choose your image.

9. Click OK and render your scene.

QuickTime VR Movies
This Designer Elements program allows you to create to types of VR movies, Object 
and Panoramic.

QuickTime Object Movie
An object movie keeps the observation point fixed as the eye point is moved at a 
fixed distance about the observation point. This gives the visual effect of moving 
completely around an object on the surface of an invisible sphere.

The QuickTime movie options produce an interactive movie that can be viewed 
with a QuickTime player. (A player and browser Plug In can be obtained from the 
Apple web site.) Each movie is composed of many individual scene images ren-
dered from a slightly different point of view.

Creating an Object Movie
1. Create your drawing and apply the render materials to your objects.

2. Choose Animation>Object VR.
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The QTVR Object Movie dialog box appears.

The dialog box includes these additional options:

Description This field contains the movie description which 
displays when the movie is viewed. Enter your 
movie description.

Copyright This field contains the movie copyright which dis-
plays when the movie is viewed. Enter your copy-
right information.

Pan This section contains the fields for setting the pan 
frames and angle, where a zero angle represents 
the viewer’s eye normal to the model as currently 
displayed on the screen. Since the pan angle is 
based on the viewer’s eye, the current view of the 
model is irrelevant.

The Frames field sets the number of images gener-
ated around the sphere equator (latitude).

The Angle Min field sets the location of the mini-
mum pan angle. A zero in this field means the pan 
will include the 0° location in the pan.

The Max field sets the largest angle to include in 
the pan with 360° as the maximum.
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The Start field sets the starting angle location for 
the pan. The Start angle must be a value within the 
range set by the Angle Min and Max fields.

Tilt This section contains the fields for setting the tilt 
frames and angle, where zero represents the 
viewer’s eye normal to the model as currently dis-
played on the screen.

The Frames field sets the number of images gener-
ated from pole to pole for the movie.

The Angle Min field sets the location of the mini-
mum tilt angle. A zero in this field means the pan 
will include the 0° location. The minimum angle 
must be between -90° (looking straight up) and 
90° (looking straight down).

The Max field sets the highest tilt angle with a 
maximum angle of 90°.

The Start field sets the starting angle location for 
the tilt. The Start angle must be within the range 
set by the Angle Min and Max fields.

Camera This section contains the FOV (Field of View) 
angle, the eye (Eye X, Y and Z) and reference (Ref 
X, Y and Z) point coordinates for the movie.

The FOV field sets the view angle for the perspec-
tive. The standard angle is 60°. A greater angle 
produces greater distortion, especially when the 
eye point is within the scene (like a room).

The Eye X, Y and Z fields set the location for the 
eye point.

The Ref X, Y and Z fields set the location for the 
reference point.

The asterisk (*) next to the field indicates your ability to specify locations by 
clicking in the drawing area. You can also enter the values manually.

3. Enter the desired values.
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4. Click Save to create the movie.

QuickTime VR Panoramic Movie
A panoramic movie keeps the eye point fixed as the observation point is rotated 
360°. This gives the visual effect of turning 360° in place.

The QuickTime movie options produce an interactive movie that can be viewed 
with a QuickTime 3.0 player. (A player and browser Plug In can be obtained from 
the Apple web site.) Each movie is composed of many individual scene images ren-
dered from a slightly different point of view.

Creating a Panoramic Movie
1. Create your drawing and apply the render materials to your objects.

2. Choose Animation>Panoramic VR.

The QTVR Panoramic Movie dialog box appears.

The dialog box includes these additional options:

Description This field contains the movie description which 
displays when the movie is viewed. Enter your 
movie description.

Copyright This field contains the movie copyright which dis-
plays when the movie is viewed. Enter your copy-
right information.
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Tech Note:

Perspective settings do not 
save with a file. Be careful 
not to have two files open 
with different settings. If you 
do the last file overrides the 
first.
Pan The Frames field sets the number images you want 
generated for the movie. The default number is 32.

Camera This section contains the FOV (Field of View) 
angle, the eye (Eye X, Y and Z) and reference (Ref 
X, Y and Z) point coordinates for the movie.

The FOV field sets the view angle for the perspec-
tive. The standard angle is 60°. A greater angle 
produces greater distortion, especially when the 
eye point is within the scene (like a room).

The Eye X, Y and Z fields set the location for the 
eye point.

The Ref X, Y and Z fields set the location for the 
reference point.

The asterisk (*) next to the field indicates your ability to specify locations by 
clicking in the drawing area. You can also enter the values manually.

3. Enter the desired description and values.

4. Click Save to create the movie.

Perspective Rendering
This Designer Elements program provides you with the ability to render your model 
in perspective using the advanced rendering commands. This perspective capability 
is not available for the basic render modes.

The perspective commands include the Perspective ON/OFF check box that is in the 
modify view dialog box.
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File Management
Whenever you open this Designer Elements program or choose New from the File 
menu, a new document appears. You can open multiple files to work with as 
desired.

Each file supports the layers feature. This feature adds a great deal of flexibility to 
your documents. Layers allow you to see various parts of a document individually 
or as part of the whole. Each document is made up of layers which can be hidden 
or displayed as needed.

Consider file organization early. This is particularly important if you are sharing 
files with other people.

The following topics are covered in this chapter. 

• Using Documents, including starting this Designer Elements program, opening 
files, recent file list and saving
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• Files and Preferences

• Files and Locking

• File Size & Deleting

• Uninstalling this Designer Elements program on Windows

Using Documents
A drawing can be a simple part or a complex assembly. A new document opens as 
Untitled and remains untitled until you save it. Saving a drawing is explained later 
in this chapter.

File Use and Operation System Short Cuts
This Designer Elements program takes advantage of some features of your operat-
ing systems when working with files.

Windows
This Designer Elements program allows you to open files and start up the program 
within the Windows Explorer or other folders. It also supports the Drag and Drop 
functionality.

Windows Explorer and other Folders
You can open Designer Elements program files by double-clicking on the file icon 
in Windows Explorer, the Desktop or another folder. If this Designer Elements pro-
gram is not running, the program launches first and then opens the file.

If you want to open multiple files, hold down the CTRL key to select the files. Press 
the right mouse button and select the Open command. Each file opens in a separate 
drawing. If this Designer Elements program is not running, the program launches 
first, before the files open.

Drag and Drop
This Designer Elements program gives you the ability to manipulate files by drag-
ging and dropping them.

You can drag and drop files into this Designer Elements program to open the files.

• If you drag and drop one or more files into an open drawing, they are merged 
into the drawing.
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Referral:

Use the File>Import com-
mand if you want to use 
drawings of other format 
types, such as DXF, IGES, or 
SAT. See Chapter 35 for 
more information.
• If you drag and drop one or more files into this Designer Elements program 
when no files are open, each opens individually.

• If you hold down the SHIFT key before dropping multiple files into this Designer 
Elements program when no files are open, files are merged into a single new 
drawing.

• You can drag and drop one or more files onto the Designer Elements program 
desktop icon and the files open individually with the program open.

Macintosh
You have the ability to double-click on a Designer Elements program file to launch 
the program and open the file.

• If you drag and drop one or more files into an open drawing, they are merged 
into the drawing.

• If you hold down the SHIFT key before dropping multiple files into this Designer 
Elements program when no files are open, files are merged into a single new 
drawing.

• You can drag and drop one or more files onto the Designer Elements program 
desktop icon and the files open individually with the program open.

File Menu Commands
The File menu contains commands to manipulate documents, including, New, 
Open, Close, Save and Revert.

New - CTRL+N (Windows); z +N (Macintosh)
This command in the File menu creates a new Designer Elements program docu-
ment. The new document has no name (the title bar shows Untitled 1), and is set 
with the default options, such as pen style or grid display. 

If you open more than one new document, the subsequent documents are num-
bered sequentially until you name them by saving.

Open - CTRL+O (Windows); z +O (Macintosh)
This command in the File menu opens an existing Designer Elements program doc-
ument. Using this command you can also open Graphite files. A progress bar 
appears as the file is opening. This is especially helpful for large files. 
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Tech Note:

If you want to open a 
Designer Elements program 
file in prior versions of 
Ashlar-Vellum software, 
export the file using the 
appropriate export version. 
This Designer Elements pro-
gram embeds ACIS data in 
its binary files. Vellum Solids 
99 and 98 use an earlier 
ACIS version and ACIS is not 
backwards compatible.
The document appears in the drawing area maintaining the same settings as the last 
time you saved it. 

The dialog box allows you to specify the document you want and lets you change 
folders, if necessary.

Windows - If the Open as read only box is checked, the file can be opened and 
printed but not altered. Macintosh - If a file is locked, it can be opened and printed 
but not altered. You can unlock a file by selecting the file and choosing Get Info 
(Macintosh standard).

Opening a Document
1.Choose File>Open. 

The dialog box appears.

The current folder displays with the 
files and/or folders it contains.

2.Choose the appropriate folder con-
taining the document you want to 
open.

3.Click the File name you want to 
open in the list box.

4. Click OK. 

Recent File List
Another way to access files opened recently is through the Recent File List that 
appears in the File menu after the Exit command (Windows) or Quit command 
(Macintosh). This list contains the names and paths of the most recent files opened 
in this Designer Elements program.

The number of files displayed depends on the number selected in the Filing page of 
the Preferences dialog box. You can display as many as 20 files in this list.

To open a file from the Recent File List, select the file name from the File menu. If 
the file has been moved since it was last used and the path is no longer accurate, 
This Designer Elements program will ask you to locate the file by providing the 
standard Open dialog box.
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Tech Note:

If you try to save a file with 
the name of a locked file, a 
warning message will appear.

If you delete objects before 
saving a file, the data for that 
information may still be 
retained with the file. Per-
form the delete operation 
again to guarantee the data is 
removed.
Saving a Drawing
You can save a drawing by choosing File>Save or Save As. The file is stored on 
your computer in the folder you specify.

If you attempt to save a file containing links that are not resolved, the following 
warning appears:

Save - CTRL+S (Windows); z +S (Macintosh)
This command in the File menu saves the current Designer Elements program doc-
ument to its original folder. If you want to save it to a different folder or with a dif-
ferent name, choose Save As. If you choose Save and the document has not been 
saved previously, the Save As dialog box appears automatically, allowing you to 
name the document and specify the folder in which to save it.

If you don’t make a geometrical change to any object in your file, the Save com-
mand is not available. Changing an object’s layer is not recognized as a geometrical 
change. If you have named and saved the document before, a brief message 
appears when you choose Save. The program pauses while it updates the informa-
tion.

Note: You should save frequently. It is important to save before performing any 
intricate, multistep procedure. That way, if the result is not exactly what you had 
hoped, you can abandon the file by closing it without saving.

Save As
This command in the File menu saves the current document. A dialog box appears 
so you can name the current document, give it a different name, or save it to a dif-
ferent directory. You can use the Save As command to make a backup of a docu-
ment.

(Windows) You also have the ability of saving a file as a Read only file. Click the 
check box for that option.
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Tech Note:

Macintosh users: Although 
the .co, .xe, ar, .ne and .vs 
extension is not required for 
the file name, it is included to 
ease file transfer between 
Macintosh and Windows.
Saving in the Current Directory
1. Choose File>Save As.

The Save document as dialog 
box appears.

2. If necessary, display a different 
folder.

3. Type the name you want to 
use in the File name box.

4. Click OK.

The filename extension .vs is 
automatically appended 
to the filename.

Making a Backup
You should make a backup of your work in case you make many changes and want 
to go back to the original version. You can choose File>Save As and save the file 
with another name. 

Auto Save 
This command is found under File>Preferences>Filing and directs this Designer 
Elements program to save a backup copy of your work periodically. If your com-
puter hangs up for any reason, the work you did up to the last Auto Save will be 
recoverable.

You have the option to save after a certain number of commands or minutes. You 
can also specify the number of backup files created before reusing a backup file 
name. (See Chapter 6 for more information on setting up or using the Auto Save 
feature.) For Windows, files opened with the READ ONLY attribute are also 
autosaved.

Files saved using this feature are placed in the Backup folder within the Designer 
Elements program folder. 

If Auto Save is set to on in Preferences but you have not modified your geometry 
since the last autosave, the function does not activate.



Files and Preferences
Revert 
This command in the File menu deletes all changes made in 
the drawing since the file was last saved. 

1. Choose File>Revert. The following dialog box 
appears. 

2. Click OK to return to the original file opened and close the dialog box. (Click 
Cancel to close the dialog box without enabling the command.)

Close - CTRL+F4 (Windows);z +F4 (Macintosh) 
This command in the File menu closes the current Designer Elements program doc-
ument. If other Designer Elements program documents are open, they remain open 
when you close the current document. If you have made any changes since you last 
saved the current document, a dialog box allows you to save the changes. You can 
close the document with or without saving the changes. 

For Windows, you can also close the document by double-clicking the Control 
menu at the upper left corner of the title bar. For Macintosh, click the Close button 
in the upper left corner.

Exit - CTRL+Q (Windows); Quit - z +Q (Macintosh) 
This command in the File menu closes this Designer Elements program. If you have 
made changes since you last saved, a dialog box allows you to save the changes. If 
you have more than one document open, an alert message allows you to save 
unsaved documents. 

Files and Preferences 
In the Filing page of the Preferences dialog box you can choose settings for your 
this Designer Elements program files. These include options for saving native pic-
ture formats, clearing undo, compacting files, read-only network file sharing, recent 
files and auto save.

Files and Locking 
Both Windows and Macintosh operating systems provide you with the ability to 
lock files. Once locked these files can be opened and printed but not altered until 
unlocked. This feature is valuable when working on a network. When one person 
is working on the file, another person can open the file but is unable to make 
changes. See the User Guide for your system for more information.
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Tip:

If your system crashes with 
an open file, the file will lock. 
Unlock the file according to 
your system instructions. You 
can also save the file under 
the same name. As you save 
you will be prompted to 
confirm the overwriting of 
the locked file.
File Size & Deleting 
When you delete objects in this Designer Elements program, the object data is still 
retained until a second delete operation is performed. If your notice that your file 
size is large in comparison to the amount of geometry in the file, this may be the 
reason. Perform another delete operation (create a line and delete it), save the file 
and reopen it.

Uninstalling This Program on Windows
When you uninstall this Designer Elements program, the Prefs.ini file does not 
automatically uninstall since it was created after installation. This file is located 
within the Designer Elements program folder in the Environ folder.



Importing & Exporting
There are various reasons to use the import and export functions. You might want 
to bring a document in from another application to work on in this Designer Ele-
ments program. You might need to save a document in a format other than the this 
Designer Elements program format for use with another application. This Designer 
Elements program offers you a wide variety of options to accomplish this.

The following topics are covered in this chapter:

• Importing

• Exporting

Importing
This Designer Elements program allows you to import many different kinds of files. 
Some types include import options specific to the format.
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When you choose the Import command, the following dialog box appears.

The dialog box contains these options:

Import Type Lists the file formats that this Designer Elements 
program imports.

Import Options Includes the options that are available for the 
selected format.

OK Click this button to close the import dialog box 
and display the standard Open dialog box for 
locating the file.

Cancel Click this button to close the dialog box and ends 
the operation.

Supported Import Formats
This Designer Elements program imports these file formats: Cobalt, Vellum Solids, 
Graphite/Vellum 3D, DWG, DXF, IGES, STEP, ACIS SAT, Parasolid (Windows only), 
Facet, Truespace COB, BMP, Rhino 3DM, STL, Adobe Illustrator, 3D Studio, Catia v4, 
Spline, Text, Grid Surface, ProE/Granite (Windows only) and PICT (Macintosh 
only).

Vellum Solids
Selecting this type imports files created in Vellum Solids. There are no options for 
this import type. In order to read previous versions of Vellum Solids into this 
Designer Elements program, you must import the file using this format.
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Graphite/Vellum
Selecting this type imports files created in Graphite/Vel-
lum 3D. Graphite/Vellum 3D includes three options: Vel-
lum Layers, Auto Heal Bodies and Feature Recognition.

This translator imports horizontal, vertical, diameter and 
radial dimensions in addition to geometry.

Vellum Layers This section includes 
check boxes, Create, 
Create Empty and Display All.

Create - When checked, This Designer Elements 
program creates/imports the layers in the Vellum 
3D file and places geometry on their respective 
layers. If this box is not checked, all geometry is 
placed on the work layer.

Create Empty - When checked, this Designer Ele-
ments program creates layers that contain no 
geometry. If this box is not checked, layers that 
contain no geometry are deleted.

Display All - When checked, this Designer Ele-
ments program displays all objects on all layers. If 
this box is not checked, the import file determines 
which layers display.

Auto Heal Bodies When checked, this Designer Elements program 
applies auto-healing to imported surfaces. Auto-
healing attempts to find collections of surfaces that 
define closed volumes and convert them to solids. 
With this box checked, the Feature Recognition 
check box is enabled.

If this box is not checked, auto-healing is not be 
performed and the Feature Recognition check box 
is disabled.

Graphite/Vellum 3D Notations
• The Vellum 3D import translator does not support the following entities: work 

plane, fill, bitmap, balloon, hatch, sheet and view.
35-3



Importing & Exporting

35-4
• ACIS does not support skewed ellipses. Only ellipses created with the 2-Point 
Center Ellipse tool and the Opposite-Corner Ellipse tool in Vellum 3D can be 
imported in this Designer Elements program. 

• This Designer Elements program does not support models (model space). When 
you import a file with geometry in different models, each model is placed on its 
own layer.

• When you import a file into this Designer Elements program and you want to 
surface them to intersect with other objects or project curves onto them, use the 
Cover, Skin or Net Surface tools.

DWG
Selecting this type imports DWG files created in AutoCAD 
or other programs that support the DWG file format. The 
translator will read DWG files up to and including version 
R2000.

This translator imports horizontal, vertical, diameter and 
radial dimensions in addition to geometry.

DWG includes three options: DWG Layers, Feature Recog-
nition and DWG Units.

DWG Layers This section includes check boxes, Create, Create 
Empty and Display All.

Create - When checked, this Designer Elements 
program creates/imports the layers in the DWG file 
and places geometry on their respective layers. If 
this box is not checked, all geometry are placed on 
the work layer.

Create Empty - When checked, this Designer Ele-
ments program creates layers that contain no 
geometry. If this box is not checked, layers that 
contain no geometry are deleted.

Display All - When checked, this Designer Ele-
ments program displays all objects on all layers. If 
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left unchecked, the import file determines which 
layers display.

DWG File Units This list sets the units for the incoming file. The 
units include inches, feet, mm, cm and meters.

DWG Notations
The DXF/DWG translator does not support the following entities: Shape, 
Ole2frame, MLine, Leader, MText, ViewPort, Tolerance, Proxy, Hatch and Image.

If you import a DWG file that contains entities that are not supported, a warning 
box will appear telling you that the entities were not read.

See Appendix C for supported DWG entities.

DXF
Selecting this type imports DXF (AutoCAD’s Data 
eXchange Format) files. The translator will read DXF files 
up to and including version R2000.

This translator imports horizontal, vertical, diameter and 
radial dimensions in addition to geometry.

DXF includes three options: DXF Layers, Feature Recog-
nition and DXF Units.

DXF Layers This section includes check boxes, Create, Create 
Empty and Display All.

Create - When checked, this Designer Elements 
program creates/imports the layers in the DXF file 
and place geometry on their respective layers. If 
this box is not checked, all geometry is placed on 
the work layer.

Create Empty - When checked, this Designer Ele-
ments program creates layers that contain no 
geometry. If this box is not checked, layers that 
contain no geometry are deleted.

Display All - When checked, this Designer Ele-
ments program displays all objects on all layers. If 
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this box is not checked, the import file determines 
which layers display.

DXF File Units This pull-down list sets the units for the incoming 
file. The units include inches, feet, mm, cm and 
meters.

DXF Facet Files
In DXF and DWG files created prior to 
AutoCAD Release 13, surfaces were rep-
resented as a collection of facets. This 
Designer Elements program converts 
these surfaces to 3-Point mesh elements. 
This graphic shows an example of a DXF 
facet file that was imported into this 
Designer Elements program. 

DXF Notations
The DXF translator does not support the following entities: Shape, Ole2frame, 
MLine, Leader, MText, ViewPort, Tolerance, Proxy, Hatch and Image.

If you import a DXF file that contains entities that are not supported, a warning box 
will appear telling you that the entities were not read.

See Appendix C for supported DXF entities.

IGES
Selecting this type imports IGES files created by various 
CAD programs. IGES includes three options: Flavor, Auto 
Heal Bodies and Feature Recognition.

This translator also supports importing horizontal, verti-
cal, diameter and radial dimensions.

Flavor This section includes a pull-down menu allowing 
you to choose to import three different IGES fla-
vors: Generic, AutoCAD or SolidWorks. Use 
Generic if your specific IGES flavor is not listed.

Auto Heal Bodies When checked, this Designer Elements program 
box applies auto-healing to imported surfaces. 
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Auto-healing attempts to find collections of sur-
faces that define closed volumes and convert them 
to solids. With this box checked, the Feature Rec-
ognition check box is enabled.

If this box is not checked, auto-healing is not per-
formed and the Feature Recognition check box is 
disabled.

See Appendix D for supported IGES entities.

When you import an IGES file, an IGES Import box appears with the result of your 
import.

The box contains the following items:

Entity Type This column lists five entity types: Trimmed/
Bounded Surface, Manifold Solid (#186), Indepen-
dent Surface, Independent Curve and Independent 
Point.

Present This section displays the number of a particular 
entity in the file.

Converted This section displays the number of entities for the 
type that converted.

%(Conversion) This column displays the percentage conversion of 
the particular entity.
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Creator Information This section contains the name of the person who 
created the IGES file and system information.

ACIS SAT
Selecting this type imports SAT files created by various ACIS-based CAD programs. 
There are no options for this type.

Facet
Selecting this type imports ASCII Facet files created by various CAD programs. 
There are no options for this import type.

The facet file format was created by the United States Electromagnetic Code Con-
sortium and Lockheed Fort Worth. This file format provides an efficient means for 
transferring geometry models to a variety of government-sponsored signature pred-
ication codes. The format includes geometry definitions of 3- and 4-sided facets and 
material IDs for each facet. 

The graphic shows a facet file after it 
was imported into this Designer Ele-
ments program. Each shade represents 
a material to be analyzed by the signa-
ture predication code. The canopy and 
raydome are transparent, so they are 
not included in the signature model.

PICT (Macintosh only)
Selecting this type imports Pict files created by various programs. Pict is the Macin-
tosh native file format. There are no options for this import type.

Adobe Illustrator
Selecting this type imports Adobe Illustrator version 5.0 
through 8.0 files. Adobe Illustrator includes two options: 
Group curve segs and Polygon from fill.

Group curve segs This option sets how 
curves are imported. Illus-
trator creates curve seg-
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ments. When selected, separate segments are 
grouped into one curve. When this option is not 
selected, curves, like a circle are imported into this 
Designer Elements program as four arcs.

Polygon from fill This option sets whether fill is imported with 
curves if the objects contain fill. When selected, 
the fill and curves are imported. When this option 
is not selected, fill is not imported.

This translator also supports importing text.

Spline
Selecting this type imports ASCII Spline files created by various CAD programs. 
There are no options for this import type. See Appendix F for information on how 
to create spline file for import using a text editor.

Import Command
This command in the File menu imports a document and places it in the current 
file.

1. Choose File>Import.

The Import dialog box appears with all the import options.

2. Select the Import type from the list and the options for the type as desired.
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3. Click OK. The standard Open dialog box appears.

4. Navigate to the file you want to import.

(Windows users: If the Open as read only box is checked, the original file cannot 
be edited but the imported geometry can be.)

5. Click Open to import the file.

The file appears in the drawing area. If you want to save the file in its original for-
mat after editing, you must choose the Export command from the File menu.

Importing Splines
When you import a text file that contains the coordinates of a spline, Vellum will 
create the spline according to the imported coordinates.

1. Select File>Import.

The Import dialog box appears.

2. Specify the import option Spline.

3. Click OK. This Designer Elements program displays the standard Open dialog 
box.

4. Select a text file that contains the coordinates for the spline.

5. Click Open to import the file.

This Designer Elements program begins creating the spline.

See Appendix F for information on how to create a text file for importing a spline.
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Importing Tips and Notations
These tips and notations will help you successfully import files.

• Groups - This Designer Elements program can import grouped geometry and 
groups within groups.

• Layers and Color - Be careful importing geometry into a layer with a color over-
ride. Objects placed on that layer will be displayed in the color of the layer.

• ACIS Data - Surfaces and solids data is written out in DXF only.

• Smart Walls - This Designer Elements program does not support the Smart Walls 
feature of Graphite and prior versions of Vellum 3D. Smart walls imported into 
this Designer Elements program are converted into individual lines without 
attributes such as height and thickness.

• If this Designer Elements program displays geometry that was not in the original 
AutoCAD DXF file, go back to the original file in AutoCAD. Choose the PURGE 
command and purge any unnecessary blocks in the file. Then export the DXF file 
and import it into this Designer Elements program.

• If an error occurs when you try to import a file, this Designer Elements program 
creates a file log in the Designer Elements program folder. For example, if you 
try to import a file through the IGES translator and an error occurs, the file 
IGSRead is created.

• Importing an IGES, Vellum 3D, SAT, DXF or DWG file with the Feature Recogni-
tion checked - There may be times when the Feature recognition operation 
returns a successful code but no geometry displays. This gives the impression 
that no geometry was imported when in fact Feature Recognition failed and dis-
carded the geometry. Import the file with Feature Recognition off and the geom-
etry will successfully import.
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Exporting
This Designer Elements program allows you to export to many different kinds of 
files formats. Some types include export options specific to the format. When you 
choose the Export command, the dialog box appears.

The dialog box contains these elements:

Export Type Lists the file formats that this Designer Elements 
program exports.

Export Options Includes the options that are available for the 
selected format.

Selected Only With this option check marked, only selected 
geometry is exported.

MultiFile This option is useful when exporting files to prod-
ucts that do not have the ability to handle multiple 
objects within one file such as Pro/E and Solid-
Works. This option will create a file for each object 
in your drawing, its name will be the same as in 
the Design Explorer.

End of Line This menu allows you to choose an end of line 
structure for your exported file. You have three 
options: Mac (LF), PC (CR/LF) and Unix (CR).
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OK Click this button to close the Export dialog box 
and displays the standard Save as dialog box.

Cancel Click this button to close the dialog box and end 
the operation.

Supported Export Formats
This Designer Elements program exports these file formats: Cobalt,Vellum Solids, 
Graphite, DWG, DXF, IGES, STEP, ACIS SAT, Parasolid, EPS, CGM, Facet, VRML, 
RAW, STL, Adobe Illustrator, Catia v4, Text, ProE/Granite, Macrmedia, Viewpoint 
Media and PICT (Macintosh only).

Vellum Solids
Selecting this type exports files as a Vellum Solids file. You 
have four options: VS 2000, VS 2000 SP1, VS 99 SP1, VS99 
and VS 98.

VS 2000 This format exports Vellum 
Solids 2000 files. Use this 
format when exporting from 
a Vellum Solids 2000 service 
pack to be read into Vellum 
Solids 2000.

VS2000 SP1 This format exports Vellum Solids 2000 Service 
Pack 1 files.

VS 98 This exports the Vellum Solids 2000 file as a Vel-
lum Solids 98 file.

VS 99 This format exports Vellum Solids 99 files.

VS 99 SP1 This format exports Vellum Solids 99 Service Pack 
1 files.

Graphite/Vellum 3D
Selecting this type exports files as a Vellum 3D file. This translator exports text and 
horizontal, vertical, diameter and radial dimensions in addition to geometry. Angle 
center mark, ordinate and balloon dimensions are exploded into lines and text. 
There are no options for this type.
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DWG
Selecting this type exports DWG files compatible with 
AutoCAD and other programs that support the DWG 
file format. (DWG is the binary version of DXF.) DWG 
includes four format options, Version 12, Version 13, 
Version 14 and Ver. 2000.

This translator exports all dimension types: horizontal, 
vertical, diameter, radial, ordinate, angled, center mark 
and balloon dimensions. It also exports groups and 
bezier and vector splines. Hatching is converted into 
lines.

Warning: Layer names are limited to the following character set: ‘a’ through ‘z’, ‘A’ 
through ‘Z’, ‘0’ through ‘9’, ‘-’ and ‘_’. All other characters in a layer name convert 
into an underscore (_).

ACIS data cannot be exported using 
the DWG translator. If you attempt to 
use this translator on a file containing 
ACIS data, a warning dialog box 
appears asking if you want to export 
the file using the DXF translator.

Click Yes to create a DXF file or No to 
end the operation.

Version 12 This option exports the file as an R12 file. This 
does not support ACIS data. Ellipses, conics, 
splines are converted into polylines. ACIS curves 
are converted into b-splines. Surfaces and solids 
are converted into facets (Face3D).

Version 13 This option exports the file as an R13 file. Ellipses, 
splines and ACIS curves are supported. Conics are 
converted into polylines.

Version 14 This option exports the file as an R14 file. Ellipses, 
splines and ACIS curves are supported. Conics are 
converted into polylines.

Version 2000 This option exports the file as an R2000 file.
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Choose the DWG option based on the translator version supported by the program 
into which you want to import your file.

DXF
Selecting this type exports DXF files compatible with 
AutoCAD. DXF includes four format options: Version 
12, Version 13, Version 14 and Ver. 2000.

Choose the end of line structure (Mac (LF), PC (CR/LF) 
or Unix (CR)) from the End of Line pull-down menu.

This translator exports all dimension types: horizontal, 
vertical, diameter, radial, ordinate, angled, center mark 
and balloon dimensions. It also exports groups and 
bezier and vector splines. Hatching is converted into 
lines.

Warning: Layer names are limited to the following character set: ‘a’ through ‘z’, ‘A’ 
through ‘Z’, ‘0’ through ‘9’, ‘-’ and ‘_’. All other characters in a layer name convert 
into an underscore (_).

Version 12 This option exports the file as an R12 file. This 
does not support ACIS data. Ellipses, conics, 
splines are converted into polylines. ACIS curves 
are converted into b-splines. Surfaces and solids 
are converted into facets (Face3D).

Version 13 This option exports the file as an R13 file. Ellipses, 
splines and ACIS curves are supported. Conics are 
converted into polylines.

ACIS data for surfaces and solids are written out as 
SAT data (Spatial Technologies format). A program 
that supports these versions does not automatically 
support SAT data. Check your program manual or 
with the manufacturer to determine whether it can 
read SAT data. Geometry exported using these ver-
sions is considered more accurate than facet repre-
sentation.
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Version 14 This option exports the file as an R14 file. Ellipses, 
splines and ACIS curves are supported. Conics are 
converted into polylines.

ACIS data for surfaces and solids are written out as 
SAT data (Spatial Technologies format). A program 
that supports these versions does not automatically 
support SAT data. Check your program manual or 
with the manufacturer to determine whether it can 
read SAT data. Geometry exported using these ver-
sions is considered more accurate than facet repre-
sentation.

Version 2000 This option exports the file as an R2000 file.

Choose the DXF option based on the translator version supported by the program 
into which you want to import your file and the end of line setting.

IGES
Selecting this type, exports various versions of IGES files. 
IGES includes four format options: Flavor, Write MSBO 
#186, Write Nurbs #128 and Trimming Curve Prefs.

Choose the end of line structure (Mac (LF), PC (CR/LF) or 
Unix (CR)) from the End of Line pull-down menu.

This format also exports groups.

Flavor This section includes a 
pull-down menu allow-
ing you to export differ-
ent IGES flavors: 
Generic, AutoCAD, Solid-
Works, Vellum v3.0, Vel-
lum v2.7, Pro/E or Alias.

AutoCAD, R13: Certain MSBOs are not supported 
by AutoCAD. This flavor converts the MSBOs so 
they can be read in AutoCAD.

SolidWorks: This flavor does not support IGES 
Conic Arc (#104) which this Designer Elements 
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program uses to write an ellipse. Ellipses convert 
into nurb splines.

Vellum v3.0: All solids convert into surfaces.

Vellum v2.7: All solids and surfaces convert into 
curves.

Pro/E: Does not include the Trimming Curve Prefs 
options.

Alias: Includes all the options listed for the 
Generic flavor.

Use Generic if your specific IGES flavor is not listed.

Write MSBO #186 Check this box to export solids using this IGES5 
solid object type. (MSBO #186 is a Manifold Solid 
B-Rep entity.) If this box is not checked, only 3D 
parametric trimming curves for analytic surfaces 
are exported.

Write Nurbs #128 Check this box to export solids using this nurb sur-
face type.

Trimming Curve Prefs This section includes two check boxes 2D Para-
metric and 3D Model Space. Choose one option.

2D Parametric - Check this option to export 2D 
parametric trimming curves for analytic surfaces. 
This option is valuable to programs that can read 
only 2D data and need the 3D data mapped to a 
2D parametric.

3D Model Space - Check this option to export the 
actual 3D trim curve in the model space.

See Appendix D for the supported IGES entities.

STEP
Selecting this type exports a STEP file. STEP (STandard for the Exchange of Product 
model data) is a neutral file format used to export models among CAD, CAM and 
CAE applications.
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Tip:

This Designer Elements pro-
gram EPS exports an 
embedded post script file. 
This type is great for printing 
and embedding in such 
applications as Microsoft 
Word and PowerPoint.

This EPS export is different 
from the EPS export used in 
Vellum 3D which exports an 
Adobe Illustrator version of 
post script.
You can also choose the end of line structure (Mac (LF), PC (CR/LF) or Unix (CR)) 
for your file from the End of Line pull-down menu. There are no other options for 
this export type.

ACIS SAT
Selecting this type exports SAT files compatible with vari-
ous versions of ACIS. This format includes one option: Ver-
sion.

Version The option sets the ACIS 
export version. The pull-
down menu includes: 1.5, 
1.6, 1.7, 2.0, 2.1, 3.0, 4.0, 
5.0, 6.0 and 7.0.

This translator supports exporting curves, surfaces, solids and grouped objects. It 
does not support exporting layers.

EPS
Selecting this type exports an EPS (encapsulated postscript) file. There are no 
options for this type.

CGM
Selecting this type exports a computer graphics metafile. This format is a 2D data 
exchange format which allows graphical data to be stored and exchanged among 
graphics devices, applications and computer systems. This metafile is not a picture 
but a description of a picture. There are no options for this translator.

Facet
Selecting this type exports an ASCII Facet file. There are no options for this type.

STL
The precise, mathematical representation of a solid or surface must often be con-
verted into a collection of imprecise planar facets. These facets may be used to 
export a model to the STL format and when changing a solid or surface 
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(Edit>Change Object Type…) to a mesh. The amount of error that results from 
this conversion is controlled by the settings in the mesh parameters dialog box.

During the conversion, vertex points are distributed on the surface or solid. These 
vertices are then grouped into 3-sided and 4-sided facets. The conversion is 
deemed acceptable when the generated vertices and facets satisfy the settings. The 
5 available settings are Surface Deviation, Normal Deviation, Edge Length, Aspect 
Ratio, and STL Facets. These settings are defined in the sections below.

Change the facet settings as needed in the dialog and then click the Update button 
to see the number of facets and vertices generated. Determining the combination of 
settings that will work for a given situation can be a little bit of an art. If one setting 
becomes too tight, the other settings will have no effect. If one setting becomes too 
loose, it will have no effect.

Keep in mind that the settings are used by the faceting algorithms if possible. It is 
often not possible to satisfy all settings simultaneously. In this situation, the algo-
rithm decides which settings to “loosen”.

The Mesh Parameters dialog box contains the following options:

Surface Deviation This setting controls the maximum allowed dis-
tance between any point on the actual surface or 
solid and the facet representing that point. The 
exaggerated figure below shows the largest dis-
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tance between a patch on the actual surface (yel-
low) and the corresponding planar facet (brown).

Normal Deviation This setting controls the maximum allowed angular 
difference between any normal on the actual sur-
face or solid and the corresponding interpolated 
normal on the facet.

Edge Length This setting controls the maximum allowed edge 
length of any given facet.

Aspect Ratio This setting controls the maximum allowed aspect 
ratio of any given facet.

STL Facets This setting will force the facets generated to be 
suitable for stereolithography usage. This setting is 
usually used when exporting STL files.

VRML
Selecting this type exports virtual reality modeling language files. There are two 
options for VRML, Version 1.0 and Version 2.0.
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RAW
Selecting this type exports a raw file consisting 
of triangular vertices. These vertices define the 
x, y and z locations of the 3D faces which 
make up your model. There are no options for 
this type.

After exporting, a dialog box appears display-
ing the number of entities and vertices in the 
exported model.

You can view the raw file by opening it in any text editor.

Adobe Illustrator
Selecting this type exports an Illustrator file. This Illustrator file is compatible with 
Adobe Illustrator versions 5.0 through 8.0. This translator supports exporting the 
Hidden and Hidden w/dimmed render options. All dimensions are converted into 
lines and text. There are no options for this type.

Macintosh only: When you export an Illustrator file, this Designer Elements pro-
gram automatically displays it with an Illustrator icon. If you double-click the file, 
Adobe Illustrator launches.

Text
Selecting this option will export the text contained in the file along with a list of 
objects contained in the file.

Catia v4
Selecting this type exports a CATIA v4 file. You can choose to export only the 
selected items and have each item export into its own file with the MultiFile option 
checked.

ProE/Granite
Selecting this type exports a file that is based upon the Granite kernal that PTC uses 
in the Pro/E program. This provide a kernal to kernal export for more accurate 
translations. There are five options for this export option: Granite, Neutral, IGES, 
Step and VDA.
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Macromedia
Selecting this type exports a Macromedia file. You can choose the Geometry Quality 
and you have the option of creation a log file if you check the box.

ViewPoint Media
Selecting this export type exports a Viewpoint Media file with an .mts or .mtx file 
extension. The .mtx file contains the xml representations of each object as a mesh 
object, the .mts file contains a list of all objects that should be displayed along with 
their display status. For futher information please refer to the Viewpoint developers 
guide or examine the sample .html code generated by our 3D Web Publish com-
mand. To view the .mtx/.mts files you will need a viewpoint compatible 3D web 
creations product such as Adobe Atmosphere.

To skip the export and view this file type immediately choose File>3D Web Pub-
lish, your geometry will be displayed in your web browser.

PICT (Macintosh only)
Selecting this type exports Pict files, the Macintosh native file format. There are no 
options for this type.

Export Command
This command in the File menu saves a document in the format you specify. 

1. Choose File>Export.

The Export dialog box appears.

2. Select the export type and its options. If you wish to export only selected 
objects on the screen, rather than the entire document, click Selected Only.

3. Click OK. The standard Save document as dialog box appears prompting you 
for a name and location for the exported file.

Windows: The type of file you are exporting is indicated with the appropriate file-
name extension.

4. Enter the file name and click Save. The exported file is saved with the name 
and location entered.

Exporting Tips and Notations
These tips and notations will help you successfully export files.

• Windows - this Designer Elements program does not support exporting bitmaps.
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• When exporting files from this Designer Elements program for import into 
another program, determine what version of the translator is used by the other 
program. Choose the appropriate translator in this Designer Elements program. 
Be sure to check whether there are any tips or notations for a successful transla-
tion in this Designer Elements program or the other application.

• In general, it is best show all layers before you export from this Designer Ele-
ments program or from another program that you will import into this Designer 
Elements program, so that you know what you are exporting.

• AutoCAD does not like the & symbol in the layers table of the DXF file. Remove 
the symbol from your layer name in this Designer Elements program or AutoCAD 
will generate an error reading in the file.

• If line patterns do not import into AutoCAD accurately from a Designer Elements 
program DXF or DWG file, change the AutoCAD variable LTSCALE to display the 
patterns at an appropriate scale.
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Drawing Composition
This Designer Elements program allows you to quickly create 2D drawings from one or 
more surface or solid objects. The 2D drawing views are bi-directionally associative. 
Changes made to the objects automatically appear in the 2D drawings. Likewise, you can 
change objects in the 2D drawing by using the Edit Objects dialog box. These also update 
on your objects. The topics covered in this chapter include:

• Model to Sheet Command

• Drawing Views

• Undfolding Views

• Editing a Drawing View

• Layout Templates

• Printing the Layout
36-1



Drawing Composition

36-2

Tip:

If you turn on all layers and 
zoom out, your original 
geometry is visible in the Top 
view.
Model to Sheet Command
The Model to Sheet command, located in the Layout menu, 
automates the process of creating drawings through the use 
of templates. Templates are empty drawings with pre-
defined and pre-arranged drawing views set within draw-
ings borders. With this feature, this Designer Elements 
program creates 2D geometry from the 3D surface and 
solid models you selected and places them in drawing 
views on a new layer, called Sheet View. Your original 3D 
geometry remains.

Warning: You cannot use this command with curves or groups.

If your geometry contains objects or drawing border lines using the background color, this 
Designer Elements program automatically changes it to the foreground color. This capa-
bility is especially helpful when your background color is black. See Chapter 6 for infor-
mation on setting the background and foreground colors.

The new sheet view displays in the Top view. Drawing views placed on this sheet can only 
be selected when the view orientation is Top. The sheet is positioned at the origin using 
the lower left corner as the alignment reference.

Choosing the Model to Sheet command displays the following dialog box.

The dialog box contains these options:

Layouts This option sets the layout for displaying your geome-
try. These layouts are predefined and located in the 
Layout folder within the same folder as the Designer 
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Tech Note:

The hidden line settings for 
Edge display do not affect the 
Hidden Line render mode 
available in the Render 
Options dialog box. See 
Chapter 33 for information 
on the render modes.

Referral:

Drawing views are explained 
later in this chapter.
Elements application. The layouts contain drawing 
views and may contain title blocks and drawing size 
boundaries depending on the layout selected.

You can create or modify any of the templates based 
on your drawing layout preferences. See the “Layout 
Templates” section at the end of this chapter for more 
information.

Method This option sets how hidden edges display in the final 
drawing. You have five settings, Precise Curves 
(Slower), Polylines (Faster), Flat, Gouraud and Phong.

Pen Styles These option are covered in the Draw View Properties 
section of this chapter.

Scale This option sets the scale of the drawing.

OK, Cancel Clicking OK completes the Model to Sheet command 
and displays your geometry based on the specified set-
tings. Clicking Cancel, cancels the command and 
closes the dialog box.

Using the Model to Sheet Command
1. Select the models you want to display on the sheet.

2. Choose Layout>Model To Sheet.

The Model to Sheet dialog box displays.

3. Choose the Layout and Edge Display from their respective pull-down lists.

4. Enter a scale in the Scale field.

5. Click OK.

2D geometry is created from your 3D model, placed in the drawing views of the selected 
layout, and displayed in the Top view. A Sheet View layer is also created on which the 
drawing views containing your geometry are placed. 

If you selected a layout with a format, A, B, C, D or E, the format is also placed on the 
Sheet View layer. Choose Layout>Layer Manager to see the new layer and the num-
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Tech Note:

Drawing views operate differ-
ently from those in Vellum 3D. 
You are not looking at a 3D 
model in a drawing view but 
rather 2D wireframe object 
created from the 3D model. 
You cannot use the Trackball 
to rotate the view orientation 
of a specific drawing view or 
zoom in the drawing view. 
However, you can use the 
Change View command and 
Properties command in the 
Drawing View menu to make 
adjustments. See the “Draw-
ing View Menu” section later 
in this chapter.
ber of new 2D objects on that layer.

You can also see that the Sheet View layer is now the work layer and all other layers are 
turned off.

Undoing the Model to Sheet Command
If you inadvertently selected the Model to Sheet command or later want to remove the 
sheet, you can use the Undo command or the Layer Manager.

• Using Undo: Choose Edit>Undo (CTRL+Z (Windows) or z+Z (Macintosh). You may 
have to use the Undo command more than once depending on the number of operations 
conducted since the Model to Sheet command was chosen.

• Using the Layer Manager: Display the Layer Manager. Choose another layer as the 
work layer. Then select the Sheet View layer and delete it. Click OK to close the dialog 
box. Your view is still set to Top. Change your view and zoom scale to view your geom-
etry.

Drawing Views
(Cobalt™ and Xenon™ Only)A drawing view is a defined 
area into which the 2D geometry is placed when using the 
Model to Sheet command. The drawing view displays the 
geometry in a particular view orientation, like Top, Trimetric, 
etc. The example here shows a drawing view with a Trimetric 
view orientation.

Drawing views are created automatically using the Model to Sheet command or by using 
one of the Sheet tools. Drawing views are placed on top of the Sheet view layer rather than 
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Tech Note:

The Drafting Assistant only 
recognizes geometry within 
an active view.
on the layer. Each drawing view has its own work plane. Any additional objects, text or 
dimensions placed in the view appear only in that view on that work plane, set to Top.

The drawing view frame uses the foreground color set in Preferences. If the Show Triad 
command is activated, the Triad displays in each drawing view.

Spacing for crosshatching, dimensions, text, 
arrow size and line font in drawing views can 
now be set relative to the sheet through the 
Edit Objects dialog box, independent of the 
scale set in the drawing view. This allows you 
to set any scale for the view without concern-
ing yourself with how the item will appear.

Just double-click the item to display the Edit 
Objects dialog box. Select the Attributes page 
and the Ignore Scale option. Click Close or 
Apply to update the selected item.

Activating Views

Once you’ve created a drawing, you activate 
individual views by clicking in the rectangular region sur-
rounding the view. When activated, the view boundaries 
highlight in red.

You cannot activate drawing views if the sheet is dis-
played in any view other than Top. All geometry in the 
view becomes available for selection when the view is 
activated. The Drafting Assistant recognizes all snap 
points in the view. Click outside the area to deactivate the view.
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Drawing View Menu
Drawing views have specific com-
mands associated with them. These 
are accessible through a pull-down 
menu in the drawing view. Click the 
mouse in the upper left region of the 
view.

The view menu displays.

You can also display the view menu by clicking the right 
mouse button (Windows) or by holding down the CON-
TROL key and clicking the mouse button (Macintosh).

The view menu contains the following commands: Proper-
ties, Delete, Align, Center, Change View, Frame to Extents 
and Flatten View.

Properties Command
The Properties command gives you access to a set of properties that affect a drawing 
view’s display on the screen. When you choose the command, the following dialog box 
displays.

The dialog box contains the following options:
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Tech Note:

The hidden line settings for 
Edge display do not affect the 
Hidden Line render mode 
available in the Render 
Options dialog box. See 
Chapter 33 for information 
on the render modes.
Name This field allows you to specify the name that appears 
in the drawing view when you activate the Draw name 
check box in the dialog box.

Edges This option sets how hidden edges display in the final 
drawing. You have five settings, Precise Curves 
(Slower), Polylines (Faster), Flat, Gouraud and Phong.

Scale This field sets the scale of the drawing.

Dash Length This field sets the length of dashes when using either 
the Dash All Hidden (precise) or Dash Only Holes 
(precise) edge display options.

Frame Region This region defines the rectangular area of the selected 
drawing view and its location. The field values repre-
sent the view edge’s distance from the origin (where 
the sheet is automatically placed).

The Left field sets the distance from the left view edge 
to the origin (0,0,0). The Right field sets the distance 
from the right view edge to the origin (0,0,0). The Top 
field sets the distance from the top view edge to the 
origin (0,0,0). The Bottom field sets the distance from 
the bottom view edge to the origin (0,0,0).

Units are based on those set in Preferences.

Pen Styles Pen styles are used to define edge attributes options 
within a draw view.   Edge options include visible, hid-
den, holes, tangent and outline.  A pen style defines the 
pen weight, pattern and color.
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One advantage to using a pen style to define an edge 
attribute is the ease at which you can then explore dif-
ferent pen styles for all your draw views.   Any change 
to the master pen style will automatically update all 
edges that use that pen style.

For example, suppose you want your visible lines 
printed in a E size drawing at a heavier weight than an 
A size drawing.  In this case just change the Visible 
pen weight to your desired weight and print. 

Note:  You can also select "Use Object Color" which 
does not use a pen style but always follows the object 
color used to create the draw view.

Visible The Visible edge format is applied to edges that are not 
hidden.  However this excludes edges that are classi-
fied as tangent or outline.

Hidden The hidden edge format is applied to edges that are 
occluded. 

Holes The holes edge format is applied to edges that are hid-
den and cylindrical.

Tangent The tangent edge format is applied to edges that are 
shared by two faces that are tangent.  Fillet edges are 
examples of tangent curves. 

Outline An edge is classified as an outline if the normal to the 
face on one side of the edge points towards the eye and 
the normal to the face on the other side of edge points 
away from the eye.
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The following picture gives examples of how changing these parameters affect your 
model.

Transparent View This check box controls the whether the drawing view 
background is clear or opaque. When selected, the 
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background is clear and objects located underneath the 
view are visible through the view.

Remember that drawing views are placed on top of the 
Sheet view layer rather than on the layer. Geometry 
placed on the layer may fall underneath a view.

Frame view This check box controls the display of the drawing 
view frame. When selected, the view frame is visible.

Regen Manually This check box controls whether the view regenerates 
or updates automatically after making changes to your 
geometry. This control is helpful if you have a file that 
requires a long regeneration time. With this option 
selected, you can make a series of changes without 
having to deal with the delay of regeneration. If you 
want to regenerate one particular drawing view, toggle 
this option between on and off.

This option relates to the Manual View Regeneration 
tool in the Sheet tools palette which regenerates all 
views on the sheet.

2D Objects in View This check box controls the 3D nature of geometry 
within the drawing view. When checked, all geometry 
is flattened to 2D geometry. For example, an arc in a 
Trimetric drawing view becomes an ellipse in 2D when 
this option is checked. When left unchecked, no 
objects are flattened.

Draw name This check box controls the display of the text in the 
Name field. When selected, the text displays at the 
lower border of the frame, centered between the left 
and right edges.

Simplify Curves The simplify curve option will attempt to simplify 
splines into lines, arcs, or circles when appropriate.  
This is primarily useful if the objects used in the model 
to sheet consisted of splines instead of the typical ana-
lytics.

Auto Hatch (Only appears for section views) This check box con-
trols hatching for a section view. When selected, hatch 
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automatically appears within section geometry. This 
option uses the default hatch set in the Cross Hatch 
dialog box. See Chapter 28.

Area Hatch Only (Only appears for section views) This check box con-
trols the geometry that appears in the section view. 
When selected, only the geometry cut by the section 
displays. When not selected, the section view shows 
the section geometry and any portion of the geometry 
lying behind the section cut.

Delete Command
This Delete command removes the drawing view and its contents from the drawing. The 
original model remains.

Align Command
The Align command functions like a tool in this Designer Elements program in that the 
Message Line contains steps for its use. This command aligns an active view with another 
selected view. You can use the command on section views, general drawing views and 
auxiliary views. The left graphic here shows two views, the Top view of a CAM part with 
its associated auxiliary view. The right graphic shows the same two views aligned.

1. Select the view you want to align.

2. In the Drawing View menu, choose the Align command.

The Message Line reads: Align View: Pick parent view to align with.

3. Select the parent view.

The two views align.
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Center Command
The Center command centers the objects within the frame boundaries. This is especially 
helpful if you’ve moved the drawing view or changed the view orientation of the geome-
try.

Change View Command
The Change View command allows you to change the view orientation of the selected 
drawing view. You can change the view to one of the pre-defined or userdefined views or 
modify the view by specifying the Eye/Reference point, Azimuth/Elevation or rotation 
values.

When you choose this command, the 
Change Aux View dialog box appears.

The dialog box contains the following 
options:

View setting This setting displays the name of the current view and 
a pull-down list for selecting a different view. The 
views include Right Side, Left Side, Front, Back, Top, 
Bottom, Iso (Top Front Left), Iso (Top Front Right), 
Iso (Top Back Left), Iso (Top, Back Right), Iso (Bot-
tom, Front Left), Iso (Bottom Front Right), Iso (Bot-
tom Back Left), Iso (Bottom Back Right), Trimetric 
and any user-defined views.
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Modify View Choosing this button brings up the Modify View dialog 
box.

Change the Eye/Reference point, Azimuth/Elevation or 
rotation values for the view. You can also name the 
view. If you enter a name and want to display it in your 
drawing view, you must also enter the new name in the 
Draw View Properties dialog box. This view is specific 
to the drawing view and not available through the 
Trackball.

OK Click this button to close the dialog box and the view 
changes.

Cancel Click this button to close the dialog box without mak-
ing any changes.

Apply Click this button to change the view but keep the dia-
log box open.

Frame to Extents Command
The Frame to Extents command shrinks the frame to the size of the geometry in the view.
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Flatten View Command
The Flatten View command deletes the drawing view, projects all objects into 2D entities 
and places them on the sheet creating complete 2D geometry. This command destroys any 
associativity between the flattened objects and the 3D model that created them.

The objects are scaled according to the value set in the Properties dialog box for the view. 
If your view contains dimensions, they are flattened also. The dimension value from the 
original view is placed in the flattened view. If the view scale was set to anything other 
than 1.0, the actual measurement of the flattened object will be different than the dimen-
sion value. For example, if you dimensioned an object in a view that was 1.25 inches and 
shown at a scale of 2, the flattened dimension would still read 1.25. However, the actual 
length is 2.50. I

Important: Be sure to mark your drawings, “Not to Scale,” if flattening a view with any 
scale other than 1 so when people read the dimension value rather than measuring the 
object.

Since the geometry in the view is scaled, its size on the screen after being flattened, is the 
same as it was in the view. The left graphic here shows a selected view. The right graphic 

shows the same geometry flattened.

If you flatten a detail view, the detail view boundary is converted into a circle with a phan-
tom pen pattern and flattened onto the sheet with the geometry.

Zoom Extents Command
The Zoom Extents command changes the scale of the drawing view so the objects within it 
fill the drawing view. This command operates similarly to the Zoom All command except 
that it applies to a drawing view.
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Sheet Tools
After you’ve created the drawing, you may want to make some changes to the 
drawing to better illustrate certain aspects of your model. This Designer Ele-
ments program provides you with tools to create new views, modify a selected 
view and add auxiliary views, section views and details views to your drawing. 
These tools are available through the Sheet tools palette. The tools include Draw-
ing View, Auxiliary View, Section View, Detail View and Manual View Regenera-
tion. Choose Window>Sheet Tools to display the palette.

Drawing View Tool

This tool allows you to create empty drawing views. Use this 
tool to add drawing views to your current layout already con-
taining views or create customized layouts.

Using the Drawing View Tool
1. Select the Drawing View tool. The Message Line reads: Drawing View: Pick 

start position view frame.

2. Click the starting point position for the frame. The Message Line now reads: 
Drawing View: Pick end position view frame. 

Notice that as you move the pointer to select the ending position an outline of 
the frame appears.

3. Click the ending point position for the frame.

The new view appears with the frame edges. The view orientation is Front. 
Continue placing new views as desired. To activate the view, choose the Selection tool 
and select the frame

Adding Associative Geometry to Empty Drawing Views
This Designer Elements program allows you to add geometry (associative to the original 
3D geometry) to empty views. When changes are made to the geometry all associative 
geometry updates.

1. Turn on the layers containing the 3D geometry you want to place in the new view.
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Tech Note:

The font type, size or style of 
the dimension label cannot be 
changed. Use the Text tool to 
create to create your own 
labels.
2. Select the 3D geometry.

If you select geometry from an existing drawing view, you would only be copying 2D 
wireframe geometry.

3. Choose Edit>Copy.

4. Select the empty drawing view.

5. Choose Edit>Paste.

The geometry pastes into the new view. Use the Drawing View menu to center the 
geometry, change the view, etc.

Auxiliary View Tool

This tool allows you to create auxiliary views from a referenced drawing view. Auxiliary 
views dynamically align to that view and are associative to both the original view and the 
auxiliary dimension. Change the geometry and auxiliary view automatically updates. 
Move the dimension location in the original view and again the auxiliary view reflects the 
changes. Auxiliary dimension lines appear in the original view. These dimensions are 
placed on the Sheet View layer. The Auxiliary tool can only be used when a drawing view 
is present.

By default, auxiliary labels are alphabetical. If you place more than one auxiliary view in 
your drawing, the auxiliary view label automatically increments to the next letter. If you 
close the file containing auxiliary views and later reopen it and add another auxiliary view, 
the label increments to the next letter based on the last auxiliary label in the file. You can 
also enter any label text desired. However, user-defined label text does not automatically 
increment.

The left graphic here shows the refer-
enced view with auxiliary view dimen-
sion lines. The right graphic shows the 
auxiliary view.
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Using the Auxiliary View Tool
1. Select the Auxiliary View tool. The Message Line reads: Auxiliary View: Pick 

drawing view for auxiliary view.

2. Select the drawing view from which you want to create the auxiliary view.

The Message Line now reads: Auxiliary View: Pick start and end of folding 
line.

3. Click the start and endpoint locations that specify the folding line for the 
view. The points do not need to be located on the geometry.

The Message Line reads: Drag window to final position.

4. Drag the view to a new location and click the mouse button. Notice that as you move 
the pointer an outline of the frame appears.

The auxiliary view displays with a view label at the specified location. The auxiliary 
view dimension appears in the original view.

If you want to delete the view later, you must delete both the view and the dimension 
line in the original view. You may have to adjust the auxiliary labels to accommodate 
the deletion.

Changing the Direction or Label of the Auxiliary View
If you want to change the auxiliary view direction oppo-
site to that indicated by the view dimension, select the 
dimension and choose Window>Edit Objects. In the 
Geometry page, check the Flip Direction option and 
click Apply. The direction of the view changes.

You can also change the view label in this dialog box.
36-17



Drawing Composition

36-18

Tech Note:

The font type, size or style of 
the dimension label cannot be 
changed. Use the Text tool to 
create to create your own 
labels.

Tech Note:

You cannot paste solids into 
section views. If you want to 
add a solid, you must add it 
to the original view.
Section View Tools

These tools create horizontal, vertical and 2 point section views. Section view geometry is 
associative to the geometry in the view and the section dimension. Change the geometry 
and the section view automatically updates. Move the dimension location in the original 
view and again the section view reflects the changes. Section view dimensions are placed 
on the Sheet View layer.

The Section tools allow you to specify whether you only want to see the section cut or 
both the section cut and the geometry lying behind it. This ability is controlled in the Draw 
View Properties dialog box, accessed through the Drawing View menu. See the “Drawing 
View Menu” section earlier in this chapter.

By default, section labels are alphabetical. If you place more than one section view in your 
drawing, the section view label automatically increments to the next letter. If you close the 
file containing section views and later reopen it and add another section view, the label 
increments to the next letter, based on the last section label in the file. You can also enter 
any label text desired. However, user-defined label text does not automatically increment.

Section views also support crosshatching. These tools can only be used when a drawing 
view is present. The graphics here show a vertical section view.

When you select the Section View tool, a subpalette appears containing three tools: Verti-
cal, Horizontal and 2 Pt.



Sheet Tools
Vertical Section View Tool

This tool creates a vertical section view.

Using the Vertical Section View Tool
1. Select the Section View tool.

2. Select the Vertical Section View tool in the Message Line. The Message Line 
reads: Section View: Pick drawing view for section.

If a view is already selected, skip to step 3.

3. Select the drawing view.

The Message Line now reads: Section View: Pick location for vertical section.

4. Click a point on your geometry for the section.

The Message Line reads: Drag window to final position.

5. Drag the view to a new location and click the mouse button. Notice that as you move 
the pointer an outline of the frame appears.

The section view displays with the view label shown in the Status Line. If you want a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view.

If you want to delete the view later, you must delete both the view and the dimension 
line in the original view. You may have to adjust the section labels to accommodate the 
deletion.

The Status Line contains the section view label.

Horizontal Section View Tool

This tool creates a horizontal section view.

Using the Horizontal Section View Tool
1. Select the Section View tool.

2. Select the Horizontal Section View tool in the Message Line. The Message Line reads: 
Section View: Pick drawing view for section.
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If a view is already selected, skip to step 3.

3. Select the drawing view.

The Message Line now reads: Section View: Pick location for horizontal section.

4. Click a point on your geometry for the section.

The Message Line reads: Drag window to final position.

5. Drag the view to a new location and click the mouse button. Notice that as you move 
the pointer an outline of the frame appears.

The section view displays with the view label shown in the Status Line. If you want a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view.

If you want to delete the view later, you must delete both the view and the dimension 
line in the original view. You may have to adjust the section labels to accommodate the 
deletion.

The Status Line contains the Section view label.

2 Pt Section View Tool

This tool creates a section view based on the orientation of two user-defined points.

Using the 2 Pt Section View Tool

1. Select the Section View tool.

1. Select the 2 Pt Section View tool. The Message Line reads: Section View: Pick draw-
ing view for section.

If a view is already selected, skip to step 3.

2. Select the drawing view.

The Message Line now reads: Section View: Pick start and end of section orientation.

3. Click two points on your geometry to indicate start and end points for the section cut-
ting line.

The Message Line reads: Drag window to final position.

4. Drag the view to a new location and click the mouse button. Notice that as you move 
the pointer an outline of the frame appears.



Sheet Tools

Tech Note:

The crosshatching used for 
geometry in a section view 
must be set separately from 
the material set in the Mass 
Properties dialog box. See 
Chapter 24 for more infor-
mation on Mass Properties.
The section view displays with the view label shown in the Status Line. If you want a 
different label, enter it in the Section data field and press ENTER (Windows) or 
RETURN (Macintosh). The section view dimension appears in the original view. You 
may have to adjust the section labels to accommodate the deletion.

If you want to delete the view later, you must delete both the view and the dimension 
line in the original view.

The Status Line contains the Section view label.

Changing the Direction or Label of a Section View
If you want to change the section view direction oppo-
site to that indicated by the view dimension, select the 
dimension and choose Window>Edit Objects. In the 
Geometry page, check the Flip Direction option and 
click Apply. The direction of the view changes.

You can also change the view label in the dialog box.

Sections and Crosshatching
By default, section views automatically contain crosshatching. You can remove the cross-
hatching or change the hatch pattern for a selected view through the Cross Hatch dialog 
box.

You can also set the default hatch pattern through this dialog box. When nothing is 
selected, choose Pen>Cross Hatch. See Chapter 28 for more information on the dialog 
box and the hatches available.

If you have more than one object cut in the section, you can define separate hatch patterns.
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Tech Note:

The font type, size or style of 
the dimension label cannot 
be changed. Use the Text tool 
to create your own labels.
1. In the section view, select 
the hatch pattern.

2. Choose Pen>Cross 
Hatch. The following dia-
log box displays.

3. Select a category and Cross 
Hatch pattern from their 
respective lists.

4. Set the hatch rotation angle 
and scale.

5. Click Apply to change the 
selected hatch.

If you are not satisfied with the hatch pattern, choose another. You can also change the 
hatch patterns of any other section geometry in the view or in other views.

6. Click the Close button (Windows) or the Close box (Macintosh) to exit the dialog box 
when you’re finished.

Detail View Tool

This tool creates a detail view from a drawing 
view. Detail view geometry is associative to the 
geometry in original view and the detail dimen-
sion. Change the geometry within the area defined by the detail and the detail view auto-
matically updates. Move the dimension location or the size of the detail in the original 
view and again the detail view reflects the changes. Detail view dimensions are placed on 
the Sheet View layer.

By default, details dimensions are alphabetical. If you place more than one detail view in 
your drawing, the detail view dimension and label automatically increment to the next let-
ter. If you close the file containing detail views and later reopen it and add another detail 
view, the dimension and label increment to the next letter, based on the last detail label in 
the file. You can also enter any label text desired. However, user-defined label text does 
not automatically increment. The graphic here shows a drawing view and an associated 
detail view.

Once a detail view is created, you can move the detail view dimension in the original view 
from its default location, shown as A in the left graphic above. Select the label, choose 



Sheet Tools

Tech Note:

You cannot paste solids into 
section views. If you want to 
add a solid, you must add it 
to the original view.
Edit>Show Points and drag the control point/detail dimension to another location. The 
detail view label, shown as Detail A above, cannot be moved.

This tool can only be used when a drawing view is present.

Using the Detail View Tool
1. Select the Detail View tool. The Message Line reads: Detail View: Pick 

drawing view for detail view.

If a view is already selected, skip to step 3.

2. Select the drawing view.

The Message Line now reads: Detail View: Pick detail center.

3. Click the center point on your geometry for which you want a detail view.

The Message Line reads: Detail View: Pick detail edge pt.

4. Click the detail edge point.

The Message Line reads: Drag window to final position.

5. Drag the view to a new location and click the mouse button. Notice that as you move 
the pointer an outline of the frame appears.

The detail view displays with the view label and the scale shown in the Status Line If 
you want a different label or scale, enter the data in the appropriate data field and press 
ENTER (Windows) or RETURN (Macintosh). The detail view dimension appears in the 
original view.

If you want to delete the view later, you must delete both the view and the dimension 
line in the original view. You may have to adjust the detail labels to accommodate the 
deletion.

The Status Line contains the detail view label and Scale.
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Resizing the Detail View Dimension
You can change the diameter of the detail view dimen-
sion. Select the detail dimension and choose Edit>Show 
Points. Two controls point appear defining the center 
and edge of the dimension.

Select one of the control points and drag it to a new loca-
tion.

Manual View Regeneration Tool

This tool regenerates all drawing views on the sheet. This is useful if you have selected the 
Manually Regen option in a Draw View Properties dialog box for one or more views and 
made changes to them.

Using the Manual View Regeneration Tool
1. Select the Manual View Regeneration tool.

The Draw Views dialog box appears telling you the number of views that need 
to be regenerated.

2. Click Yes to regenerate all views. 

Click No to close the dialog box without regenerating the views.



Unfolding Views
Unfolding Views
You can quickly create new views from 
an existing drawing view by using an 
unfolding operation. The graphic here 
shows a center view unfolded in four 
directions.

1. Choose the Selection tool and acti-
vate you want to unfold.

2. Hold down the CTRL key (Win-
dows) or the OPTION key (Macin-
tosh) and drag the view to the left, 
right, top or bottom of the view.

A new view is created with the geometry rotated 90° from the selected view.

Editing a Drawing View

Adding Objects to a View
You can add objects in an existing or new view by either creating them using a drawing 
tool or by copying and pasting them into a view.

Creating Objects in a View
Once a view is activated, you can create additional wireframe and solid objects in the 
view. Since the Drafting Assistant functions inside the view, you can place the objects rel-
ative to the other objects already present.

You can also place dimensions and text in the view using the Dimension tools and the Text 
tools. All dimensions are placed on the Sheet View layer rather than the Dimension layer 
for drawing views. Since the drawing view work plane is set to top, all text and dimen-
sions appear correctly.

All entities created in an active view, display only in that view.

Copying and Pasting Objects into a View
You can also paste objects copied from another location into a selected view. When you 
paste the objects, this Designer Elements program examines the contents of the paste 
buffer and inserts it in the active view. The inserted object is associative to the original 
object. This feature is valuable when creating a new drawing view.
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If the objects were copied from a 3D 
model, the 2D objects created from them 
are associative to the model. You can 
change the view later and the geometry 
will display correctly. If you copy 2D 
objects from a view (regardless of 
whether they were created from a 3D 
model), these objects do not reference the 
3D model. Since this 2D geometry is not associative to a 3D model, changing the view 
may not create a complete view. The graphic here shows an example of this. The 2D 
geometry in the Trimetric view was pasted into the Right Side view.

Editing Objects in the View

Editing 2D Geometry created from 3D Geometry
You can edit your 2D geometry in a number of ways: changing the line characteristics, 
layers or modifying the geometry.

Changing Line Patterns and Layers
Since an object placed in the drawing views are true 2D wireframe, you can assign a dif-
ferent line pattern, color, weight or layer to the entities making up the object. To change a 
line characteristic, select the line in the view. In the Pen menu, choose a new pattern, color 
or weight. You can also change line characteristics through the Edit Objects dialog box.

To change the layer for the line, choose Edit>Change Layer and select the new layer. You 
can also change the layer through the Edit Objects dialog box.

Modifying 2D Geometry
Because the 2D geometry created from the 3D model is composed of individual curves, 
you cannot modify the length or the location of the curve by dragging a control point like 
you would in a normal model. If this were possible, the associativity of the model would 
be destroyed. For example, a line in a model may represent the visible edge of a cylinder 
which is not actually present in the 3D model. If this was changed, you would no longer 
have a cylinder.



Editing a Drawing View
If you attempt to modify the geometry, this Designer Elements program provides the fol-
lowing warning.

Given this, you have two ways to edit geometry, removing the links of the selected geom-
etry or editing the 2D geometry by changing the parent 3D geometry using the Design 
Explorer and the Edit Objects dialog box.

• Select the object and choose Edit>Remove Links. A warning appears reminding you 
that this command deletes all associative relationships and that you cannot undo this 
operation. Click OK and the object can now be changed.

• Select the object. Display the Design Explorer and open the history tree to show the 
parent geometry for the selected object. Double-click on that object to display the Edit 
Objects dialog box. Change the desired value and click OK. The 3D model and the 2D 
geometry updates. The graphic here shows a selected edge and the Design Explorer 
with the ACIS Solid parent.

Editing View Characteristics

Changing the Scale of a View
You have two methods for changing the scale within a view:
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• Choose the Properties command in the Drawing View menu and change the scale value 
within the dialog box.

• Select the drawing view boundaries by dragging a selection fence around the view 
rather than clicking on the view. Choose Window>Edit Objects and in the Geometry 
page, enter a new scale. Clicking the view activates the view but does not select just the 
view boundaries. The left graphic here shows the selected view boundary. The right 

graphic shows an activated view.

Select all drawing view boundaries in a layout by using the Selection Mask.

Resizing a Drawing View
You have three methods for resizing a drawing view:

• Dragging the view edge: Select the view and place the 
pointer on a control point of the edge you want to 
move. The pointer becomes a two directional arrow. 
Drag the edge to a new location. Place the pointer at a 
corner control point to resize two adjacent edges at the 
same time. The graphic shows the view control points 
and the directional arrow.

• Using the Properties command in the Drawing View menu

• Using the Frame to Extents command in the Drawing View menu

Dimensions and Drawing Views
If dimensions in the drawing view go outside the bounds of the view such that you can’t 
see them, choose the Frame to Extent command in the Drawing View menu. You can also 
drag the view edge manually to completely display the dimension. See Chapter 27 for 
information on the standard dimension tools.



Layout Templates
All dimensions placed in drawing views, go on the Sheet View layer rather than the 
Dimension layer. This enables you to turn off all other layers and still print the sheet with 
views containing dimensions.

Changing or Deleting View
The view orientation, scale and view properties can be changed through the Drawing View 
menu for each view. If you change the view orientation of a drawing view and cannot see 
all of the geometry in the view, choose the Center command or Frame to Extents command 
in the Drawing View menu. See the “Drawing View menu” section earlier in this chapter 
for more information.

You can delete a view through the Drawing View menu. You can delete all drawing views 
at once by selecting the Drawing view type in the Selection Mask, double-clicking on the 
Selection tool and pressing the BACKSPACE key (Windows) or the DELETE key (Macin-
tosh).

Moving a Drawing View
You have two methods for moving a drawing view:

• Dragging the View: Select the view. Place the pointer over a 
view edge, not a control point. The pointer becomes the move 
symbol. Select the top or bottom view edge to drag the view 
vertically. Select the left or right view edge to drag the view 
horizontally.

• Using the Properties command in the Drawing View menu

Drawing Views and the Edit Menu
If you notice that the Edit menu name is red as you work in a Sheet view, your drawing 
contains some unresolved links. This occurs when you move geometry or make some 
other change. Choose Edit>Resolve Links. The Edit menu name becomes black again.

Layout Templates
This Designer Elements program provides you with 14 layout templates. These include the 
following:

1ViewA (B, C, D or E).vs Displays Top view on the specified size sheet. 

4ViewA (B, C, D or E).vs Displays four views, Top, Front, Right Side and Tri-
metric on the specified size sheet.
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Design4.vs Displays four views, Tri-
metric, Top, Front and 
Right Side in drawing 
views and arranged in a 
design view layout (as 
shown here).

Draft4.vs Displays four views, 
Top, Front, Right Side and Trimetric in drawing views.

FrontRight.vs Displays two views, Front and Right in drawing views.

FrontTop.vs Displays two views, Front and Top in drawing views

Top.vs Displays the Top view in a drawing view.

Trimetric.vs Displays the Trimetric view in a drawing view.

You create change the views used in particular layout by using the Properties command in 
the Drawing View menu (see an earlier section) or create a layout with your own views. 
See the next section.

Creating your own Layout Templates
You can create your own templates from scratch or by modifying an existing template.

Modifying an Existing Template
All templates provided are Designer Elements program files that can be opened like any 
other file. 

1. Open one of the files in the Layouts folder. 

2. Make whatever changes you desire. You can adjust the format, add text to the title 
block, and add or remove drawing views.

3. Save the file under another name in the Layouts folder.

You can now select this template from the Layout pull-down menu in the Model to Sheet 
dialog box.

Creating a New Template
You can create a new template from scratch using a standard Designer Elements program 
file. 

1. Open a new file.

2. Set the view and plane to Top.



Printing the Layout
3. Create the title block and border for the layout and add text if desired.

4. Using the Drawing View tool, add drawing views.

5. Save the file in the Layouts folder.

You can now select this template from the Layout pull-down menu in the Model to Sheet 
dialog box.

Printing the Layout
If you want to print your layout with the views, turn off all layers other than the Sheet 
View layer. Make sure your Page Setup (Windows) or Print Setup (Macintosh) matches 
the layout.
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Page Setup and Printing
You've created all your geometry using the wireframe, surface and solids tools, con-
ducted various operations on it such as extruding, sweeping and blending and 
added some basic annotation to your drawing.

All during your design process, you did not have to worry about scaling or your 
paper size. Now that you're ready to print a hard copy, you'll need to set up the 
page according to a scale, paper format, orientation and your printer specifications.

This Designer Elements program prints and plots on most printers and plotters sup-
ported by your computer. After you have followed the manufacturer’s instructions 
for installing and setting up the printer or plotter, you can set up your page size as 
needed.

The following topics are covered:

• Drawing Size

• Printing a Drawing

• Print Window
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Print Layout Command
The Print Layout command, located in the File menu, dis-
plays the dialog box which allows you to set the page size, 
scale and other options.

When you select the command the Drawing Size dialog box appears. The graphic 
here shows the Advanced Setup mode.

The Drawing Size dialog box includes the standard buttons: OK, Close and Apply.

OK Click this button to accept all changes and close 
the dialog box

Close Click this button to ignore any changes made since 
you last clicked Apply and close the dialog box.

Apply Click this button to accept and register all entries 
made in the dialog box without closing it.



Print Layout Command
The Drawing Size dialog box includes the following sections: Setup Mode, Drawing 
Size, Scale, Preview and Utility Controls.

Setup Mode Section
The Drawing Size dialog box supports four setup modes; Single Page, Height and 
Width, Rows and Columns and Advanced.

For all setup modes, a drawing frame displays in the Preview window. The outer 
drawing frame represents the physical page size. The inner drawing frame repre-
sents the printable page area. The page settings are obtained from the current 
printer settings. Changed the printer settings by choosing File>Print Setup (Win-
dows) or Page Setup (Macintosh).

Single Page Mode
The Single Page mode is the simplest printing mode. It is the best mode to use 
when printing to a large format plotter or when you need a quick single page plot. 
As the printer settings are changed, the drawing frame updates to conform to the 
new settings. Selecting this mode displays the most basic Drawing Size dialog box.

You can set the plot scale by making a selection from the Scale drop down list or 
by changing the value in the Scale data field.

Use the Fit to Area button to automatically compute the scale that will fit the draw-
ing objects to the printable area.
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Height and Width Mode
The Height and Width mode is used to generate large standard or user defined plot 
sizes when using small format print devices (e.g. 8.5 x 11 laser or inkjet printer). 
Selecting this mode displays the format area of the Drawing Size section.

For drawing sizes larger than what your printing device allows, the drawing is tiled 
and can later be assembled into the large format plot. The Preview window displays 
the page tile edges within the drawing frame automatically.

You can specify a standard drawing size or a custom drawing size. You can set the 
scale in the Scale section or automatically compute the scale using the Fit to Area 
button.

Rows and Columns Mode
The Rows and Columns mode is used to force whole pages to be used for tiled 
plots. Unlike the Height and Width mode, this mode will use all the printable area 



Print Layout Command
available for the plot. However, the plot will not be a standard size. Selecting this 
mode displays the Tile area of the Drawing Size section.

You can specify the tile rows and columns by changing the values in the Rows and 
Cols data fields. The Overlap data field controls the how tile pages will overlap. The 
overlap region helps align the pages when assembling the final plot.

Advanced Mode
The Advanced mode provides access to all height, width, rows and columns plot 
settings. This mode permits complete control over all aspects of tiling. Selecting this 
mode displays the entire Drawing Size section.

You can specify any of the listed elements.
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Tech Note:

When you choose a drawing 
format size, be sure that you 
set the page orientation for 
your printer to the same 
orientation selected in the 
Drawing Size dialog box. 
Choose File>Print Setup 
or Page Setup to display 
the Printer dialog box to 
check your current page 
orientation.
Drawing Size Section
This section contains the drawing format sizes available and the height and width of 
the selected format size.

The format size field includes a pull-down menu listing 
all of the formats and their sizes.

You can choose any of the predefined sizes, A, B, C, D, 
E, F, G, H, J and K. Each format size includes a listing 
for portrait and landscape orientation. 

The units (inches or mm) are determined by your pref-
erence setting. When you select one of these pre-
defined formats, the size is displayed in the Width and 
Height fields.

You also have the ability to set your own drawing size 
by selecting the User Defined option in the list. When you choose this option, you 
enter the size in the Width and Height fields.

The drawing sizes displayed in the pull-down list are contained in the DrawSize.ini 
file in the Environ folder within the Designer Elements program folder. This file can 
be edited but keep it mind it may change or be overwritten by future Designer Ele-
ments program installations. If you do choose to edit the file, save the original ver-
sion under another name before doing so. Then you will have a copy in case you 
want to return to the default sizes.

If the page size is larger than the size supported by your printer, values are auto-
matically entered in the Tile area to accommodate the drawing and appears as such 
in the Preview window. (Choosing the Advanced mode shows the tiling specifics.) 
See the next section for more information on tiling.

Before choosing your size, you must determine what size format your printer or 
plotter can support.

Drawing size and page tiling are synchronized based on the scale. Values entered in 
the drawing size fields affect those in the page tiling and vice versa. Height affects 
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Rows and Width affects Cols. The last field in which you enter values controls the 
drawing dimension, represented by the activated field name. The associated field 
name is unavailable.

Setting the Format Size
1. Choose File>Print Layout.

2. Choose the Height and Width mode from the pull-down menu.

3. Display the pull-down menu for the drawing format size.

4. Select the desired size. 

The size is displayed in the Width and Height fields. 
If you selected the User Defined format size, enter the size in the Width and 
Height fields.

Page Tiling
This Tile area of the Drawing Size section allows you to set up your file so you can 
print a larger drawing in tiled sheets.

This area includes these elements:

Rows Represent the number used to print your file, 
based on the size supported by your printer driver 
and the drawing scale. A value automatically 
appears in this field when you select a drawing 
size larger than that which your printer supports.

If the exact drawing size is unimportant, just spec-
ify the number of rows. Since the number is syn-
chronized with the Height, entering a different 
value changes the height of your drawing.

Cols Represent the number of columns used to print 
your file, based on the size supported by your 
printer driver and the height of your drawing. A 
value automatically enters in this field when you 
select a drawing size. 
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If the exact drawing size is unimportant, just spec-
ify a number of columns. Since the number of col-
umns is synchronized with the Width, entering a 
different value changes the width of your drawing.

Overlap When tiling, you can specify a page overlap 
(between 0 and .75 inch or 20 mm). The overlap 
determines how much of the geometry repeats on 
the right and top area of each tile page. The over-
lap region can be used to align the tiles when join-
ing the pages.

This graphic shows an example of tiling with three rows and four columns.

Tiling operates independently of the page orientation.

Setting the Page Tiling
1. Choose File>Print Layout.

2. Choose the Rows and Columns mode from the pull-down menu.

3. Enter the desired values in the Rows and Cols fields. The drawing size fields 
adjust accordingly.

4. Specify the overlap for the tiled pages. The units are determined by your pref-
erences setting.
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Scale
This section allows you to specify the scale of your 
drawing. You can select a standard scale from the 
pull-down list or set your own scale in the data 
field.

Scale Options
The pull-down list provides you with these scaling options: User Defined, 5:1, 4:1, 
3:1, 2:1, 1:1, 1:2, 1:3, 1:4 and 1:5.

Choosing one of the standard scales enters a value in the data field. A 5:1 scale, 
enters 5.0 in the field. A 1:5 scale enters a 0.20 in the field.

If you want to specify your own scale, enter the value in the data field. The scale 
name changes to User Defined, regardless of the scale entered.

The drawing scales displayed in the pull-down list are contained in the Draw-
Size.ini file in the Environ folder within the Designer Elements program folder. This 
file can be edited but keep it mind it may change or be overwritten by future 
Designer Elements program installations. If you do choose to edit the file, save the 
original version under another name before doing so. Then you will have a copy in 
case you want to return to the default scales.

Setting the Scale
1. Choose File>Print Layout.

2. Display the pull-down list for the scale.

3. Select the desired scale. The scale appear in the edit field.

If you selected the User Defined scale option, enter the scale in the data field.
The left graphic below shows the Preview window of a rectangle at a scale of 
2:1. The right graphic shows the Preview window of an rectangle at a scale of 
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1:2.

Scaling does not change the actual dimensions of the part. Verify this by selecting 
an object and choosing Window>Edit Objects.

Preview Section
To assist you in choosing the correct format size for your drawing, This Designer 
Elements program includes the Preview section containing the Preview window and 
two check boxes, Overlay Drawing and Print Selected. 

Preview Window
A preview of the drawing appears in this sec-
tion of the Drawing Size dialog box.

The outer drawing frame represents the physi-
cal page size. The inner drawing frame repre-
sents the printable page area. The page 
settings are obtained from the current printer 
settings. If you change the drawing size, the 
Preview window still displays the last drawing 
size selected until you click Apply.

Only objects or part of objects that lie within 
the page bounds are printed.

The Preview window displays a rectangle, 
representing the drawing or the actual geometry. This display is determined by the 
Overlay Drawing setting. See the next section for more details.



Print Layout Command
The Axis displays in the Preview window only if it's displayed in your drawing area. 
The Axis does not print.

Overlay Drawing
This check box determines how your geometry appears in the Preview window. 
When the box is not checked, a red rectangle displays, representing the drawing 
area used by the objects (the graphic on the left below). When the box is checked, 

the actual geometry displays (the right graphic).

Print Selected
This check box allows you to specify which 
objects within the drawing bounds get printed. 
When the check box is empty, all geometry 
within the page bounds print. When the box is 
checked, only selected geometry within the 
page bounds prints and the view window 
zooms in on that area. In the graphic here, 
only the square prints.

In the graphic, all of the geometry displays. If 
you deactivate the Overlay Drawing check 
box, only the selected rectangle displays in the 
Preview window.

This check box only becomes available when you select geometry.
37-11



Page Setup and Printing

37-12
Preview Section Example
An example of using the option in this area might clarify how the Preview window 
and check boxes interrelate.

1. Draw some geometry.

2. Choose File>Print Layout. The Drawing Size 
dialog box displays. The Preview window shows 
a red rectangle representing the object area.

3. Check the Overlay Drawing box to display the 
actual geometry.

4. Click OK in the dialog box to close it.

5. Select an object within the page bounds.

6. Choose File>Print Layout to display the dialog 
box again.

7. Check the Print Selected box. The Preview win-
dow zooms in on selected object.



Print Layout Command
8. Click the Overlay Drawing check box to remove 
the check mark. Only the selected geometry dis-
plays.

Utility Controls
The Drawing Size dialog box contains utility controls 
for setting up your drawing. These include the Show 
Page Breaks in Drawing Window check box, the Fit 
to Scale button and the Fit to Area button.

Show Page Breaks in Drawing Window
This check box allows you to specify whether to display the page breaks/bound-
aries in your drawing area. When this box is checked, the page bounds display.

When you click OK and close the dialog box, you can move the page 
boundaries. Place the cursor over the marker at the lower left corner of the 
page boundaries. The cursor becomes the move symbol (shown to the 
right). Drag the page boundaries to the new location. See the “Move the Print 
Boundaries” section at the end of this chapter for more information.
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Fit to Scale
Clicking this button uses the current scale value and automatically changes the 
height, width and page boundaries to fit the geometry.

This button only displays with the Advanced mode.

Fit to Area
Clicking this button automatically computes the scale and page boundaries to fit the 
geometry to the entire tiled plot's printable area.

For a single page to print, set both Rows and Cols to 1 and press the Fit to Area but-
ton.



Printing a Drawing
Drawing Size and Short Cut Key
A new short cut key, Single Page, was added to Drawing Size category in the Short 
Cut Manager.

Using this key automatically chooses the Single Page mode, activates the Fit to Area 
function and Shows Page Breaks. You can assign whatever short cut key you desire.

Printing a Drawing
After you have set up your page you are ready to print. Choose File>Print Setup 
(Windows) or Page Setup (Macintosh).

Print Setup (Windows); Page Setup (Macintosh)
Choosing this command in the File menu displays your printer setup window.
37-15



Page Setup and Printing

37-16
Choose the necessary settings for paper size and page orientation to agree with 
your settings in the Drawing Size dialog box. Click OK to save settings. See your 
printer manual for information about setting your printer options.

Print Command - CTRL+P (Windows); z +P (Macintosh)
This command in the File menu prints or plots the current document as specified in 
the Drawing Size dialog box.

The area printed or plotted is the portion that fits on the page size specified in the 
Drawing Size dialog box. Choose File>Print Layout to scale your drawing to the 
appropriate size and reposition the print/plot region.

You can specify tiling (printing on several pages to be pasted together) by choosing 
File>Print Layout>Advanced. 

Print to a File
You can print to a file rather than to a plotter or printer. In that way, you don’t have 
to have a plotter attached to your computer. Someone else can plot the drawing 
without having this Designer Elements program on the plotter’s computer. The type 
of plotter you choose when setting up the page determines the format of the plot 
file.

If you choose a PostScript printer, the file format is Encapsulated PostScript; use the 
HPGL language when you select Hewlett Packard plotters. The computer that 
finally plots the file must have an application compatible with the file format of 
your printer or plotter.

Plotter Font
When you are using a plotter, you should specify the Plotter font for the text and 
dimensions on your drawing. You can also generate special characters and accents 
as described in Appendix B.

Printing/Plotting Region
When you choose File>Print only the geometry within the page boundaries prints. 
You can view those boundaries by choosing File>Print Layout. If your printer 
does not support the size, gray boundary lines are displayed in the window, repre-
senting the boundaries and the tiling feature activates. For all printers and plotters, 



Printing a Drawing
the plotting region is smaller than the actual page size because most printers and 
plotters cannot plot to the edge of the paper, allowing room for the margins.

The size of this region is based on the paper size and the printer or plotter driver 
currently selected.

Moving the Print Boundaries
If the geometry you want to print is not contained within the page boundaries you 
can move the page boundaries. 

1. Choose File>Print Layout.

2. Select the Show Page Breaks in Drawing Window check box.

3. Click OK. The dialog box closes and the page boundaries are displayed in your 
drawing.

4. Place the cursor over 
the marker at the lower 
left corner. It becomes 
the Move symbol.

5. Drag the boundaries to 
the new location.

Paper Size

Printing/Plotting Region

Vellum displays the Printing/Plotting region
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Printing and Rendering
This Designer Elements program prints both wireframe and rendered geometry. 
When you want to print rendered geometry, set the Static Render option in the Ren-
der Options dialog box to the desired mode.

If your printer supports color, Static Render must be set to Flat or Gouraud.

Print Window
The Print Window command in the File menu copies the 
image within the drawing screen and sends it to the printer.



Attributes and Bill of Materials
User Attributes and Bill of Materials provide a means to apply custom attributes to entities 
and display that data in a table or export it to an external application such as Microsoft 
Excel.

This tool is located in the Window menu (Window>Attributes and BOM). After select-
ing this tool the following dialog box appears:

The Bill of Materials dialog box contains a drop down menu of predefined attribute tem-
pletes and five button options.
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The predefined templets are:

Material Assigns a material to an entity.

Price Assigns a price to an entity.

Standard Assigns a part number and description to an entity.

Stock Size Assigns part number, stock size and description to an 
entity.

Vendor No. Assigns a part number, a vendor number and a descrip-
tion to an entity.

Perimeter Calculates the 2D perimeter for curves.

Volume Calculates the volume of a solid.

Weight Calculates the weight of a solid using the material 
assigned in the Verify>Mass Properties command.

Area Calculates the surface area of any polygon, surface or 
solid.

Area 2D Calculates the 2D area and centroid properties for 
curves.

Mass Properties Calculates the Mass Properties for a solid using the 
Verify>Mass Properties command.

The first five attribute templates require the user to supply all of the information associated 
with the attribute. The latter six automatically extract attribute information from the entity.

The five buttons on the Attributes/BOM dialog box have the following functions:

Apply To Selected This options applies the current BOM attribute to the 
selected entities.

Create BOM This option creates a Bill of Material Table using the 
attributes defined by the pull down menu. The user is 



Tip:
The Bill of Materials
function does not
incorporate the use
of Copy/Cut and
Paste.
prompted to enter text height, colun width and item 
order.

Create Balloons This option adds balloon item dimensions to geometry. 
This option requires an item number type be used with 
the attribute. All of the supplied attribute files have 
item numbers.

Export BOM This options creates a comma-delimited file that can be 
read into Microsoft Excell or other similar spreadsheet 
programs.

Update BOM This option updates the BOM table and the corre-
sponding balloons.

Graphic 2 equals Item Numbers Up
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BOM User Defined Templates
You can create user-defined templates by creating an attribute definition file.  Attribute 
definition files are located in the BOM folder of the install directory.  The first line of the 
file contains the attribute name.  This is the name that will appear in the attribute pull-
down menu.  The next lines contains two columns, the first column contains the attribute 
definition string, and the second column the attribute type. Commas separates each col-
umn

The following attribute types are supported:

Float User-assigned signed decimal value. 

Integer User-assigned signed integer value  

String User-assigned character string 

Area Calculates the entity area and assign.

Perimeter Calculates the entity perimeter and assign.

Volume Calculates the entity volume and assign.

Weight Calculates the entity weight and assign.

Qty Counts the number of occurrences this attribute is 
used. 

Index Index used to refer to the attribute in the BOM table or 
balloon callout.

Name Extracts the name from the entity.

CG-X Calculates the CG-X value from an entity.

CG-Y Calculates the CG-Y value from an entity.

CG-Z Calculates the CG-Z value from an entity.

Sum Sums the value the previous attribute.

Material Extracts the material type from the entity.
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Parametric Constraints (Cobalt Only)

Cobalt support 2D profile dimensional constraints. This feature provides a mechanism for 
dimensioning entities to define distances and angles in order to establish geometric con-
straints between curves.

To access the Constraint tools and enter a 2D Sketch Mode go to the Window menu and 
choose Constraints.

Sketch Mode
To enter the 2D Sketch Mode in the Parametric Constraint tool you must first 
choose the sketch tool.

Clicking on this tool expands the tool palette, showing the tools available while in 
sketch mode.

By entering the sketch mode the application knows to adjust the user interface in such a 
manner that creating 2D sketches is intuitive.  The sketch mode does the following auto-
matically when creating a new sketch or modifying an existing sketch:

1. Hides tool palettes such as surface and solid modeling which have no meaning in the 
2D sketch environment.

2. Adjusts the drafting assistant to always snap into the sketch plane and see only snaps 
in the sketch plane. This is accomplished by turning on the "Work Plane" and "Plane 
Only" options in the Snaps dialog box.

3. Turns on Auto Constraints.  Auto constraints will automatically create geometric rela-
tionships (coincident, tangent, concentric, perpendicular) as you create and modify 
geometry.  You can turn this off in sketch mode through the popup menu activated 
with right-click (Control + click on Mac).

4. Creates a set of layers for the sketch that includes the container layer, "Sketch 1" and 
sub layers that include construction, profile, constraints, and dimensions.  Note the 
geometry in the construction layer is ignored if the sketch is used in profile-based 
operations such as skinning, sweeping, lathing, or extruding. 

5. Show Dimming is turned on. This feature is useful when working on faces of solids 
where edges not in the sketch plane are dimmed.  In addition, if you modify a sketch 
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on the face of a solid, the part is rolled back to the point where the sketch was original 
created.

Exiting Sketch Mode
Exiting the sketch will restore the above settings back to the previous settings before the 
sketch was entered. One other advantage of the sketch mode is that it allows the ability to 
temporarily suspend the regeneration of a dependent feature.  This means that while in 
sketch mode you can perform a series of operations such as adding and removing curves to 
the sketch that would otherwise invalidate downstream operations.  However, when exit-
ing the sketch mode, you must resolve a valid profile such that dependent features can then 
be updated.

The tools available in Sketch Mode are listed below.

Sketch Tool Creates or Modifies an existing sketch.

Auto Constraints Tool The auto constraint tool automatically applies 
constraints to curves and dimensions selected 
by the user.

This tool is particularly useful when working with data created outside the sketch tool.  
The auto constraints tool will add the following constraints to the selected geometry: Hor-
izontal, Vertical, Tangent, Concentric and Coincident.

Horizontal Constraint Tool Adds a horizontal constraint to a line. You can 
select one or more curves to apply a horizontal 
constraint. Horizontal is defined by the work 
plane x-axis.  The two chosen points will have the 
same x value when completed.

In this tool, note the message line:

When applying a horizontal constraint, pressing the CONTOL key (OPTION on Mac) will 
give the user the option to align the geometry horizontally to a specific point on another 
line.  The two chosen points will, when completed, have the same x value.

Vertical Constraint Tool Adds a vertical constraint to a line. 

You can select one or more curves to apply a vertical constraint. Vertical is 
defined by the work plane y-axis.
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In this tool, note the message line:

When applying a vertical constraint, pressing the CONTROL key (OPTION on Mac) will 
give the user the option to align the geometry vertically to a specific point on another line.  
The two chosen points will have the same y value when completed.

Coincident Constraint Tool This tool adds a coincident constraint between 
two object positions.   

Objects that are recognized for coincident constraints include lines, arcs, circles, 
ellipses, splines, points, and edges of solids.  The point of coincidence to the object is 
automatically determined by use of the drafting assistant.  Referencing end points, mid-
points, vertex, centers, and point on are preserved.   In the case of point on (point along 
curve) the coincidence constraint may be anywhere along the curve.  All others are fixed to 
specific locations.   The floating coincident constraint is represented by a small triangle 
symbol whereas a fixed constraint is a small rectangle about the two shared points.

Some examples of coincident constraints:

The coincident constraint tool allows for several means of attaching relationships.  The 
first method is to follow the user prompts:
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1. Pick the first curve for coincident constraint.

2. Pick the position along the first curve using the drafting assistant.

3. Pick the second curve for the coincident constraint.

4. Pick the position along the second curve using the drafting assistant.

The second method for creating coincident constraints is to box select two or more curves 
at the first prompt.  In this case all curve end points that lie within 0.001 inches will be 
applied a coincident constraint.

In addition, the coincident constraint tool allows for pre selections.  If any curves are pre-
selected before you hit the tool palette icon, coincident relations are automatically applied 
to the selected objects.

Tangent Constraint Tool This tool creates a tangent constraint between 
two or more curves. 

To use the tangent constraint tool simply select the curves you would like to apply 
a tangent constraint. When selecting more than 2 curves, the tangent constraint tool only 
applies a constraint between curves that are already tangent within 1 degree.  This con-
straint draws a circle to represent the existence of a tangent constraint.

Parallel Constraint Tool The parallel constraint tool adds a parallel 
constraint between two lines.



Parametric Constraints (Cobalt Only)
Only lines can be used in this tool, arcs, circles, ellipses, splines are ignored.  The con-
straint symbology is two small parallel lines.

Note: The solver determines which line to move based on a set of rules involving the 
curve type, other curve relations and minimization of geometry movement.  Therefore the 
order in which you pick the curves is irrelevant as to which curve is actually moved.

 Perpendicular Constraint Tool The perpendicular constraint tool creates a 90° 
angle between a line and another curve. 

In the example below a coincident constraint is needed to attach the line to the cir-
cle.  As in other constraints the entity that moves is independent of selection order.

Fixed Constraint Tool The fixed constraint tool locks the entity from 
being moved by the solver.  
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The user is allowed to move the entity with the move or translate tools.  A fixed object 
uses the fixed display color which is by default gray and whose symbology consists of a 
collection of slanted lines.

Note: Attempting to dimension a fixed entity will result in the display of the dimension 
error dialog box.

This error message implies that the position, direction, and length are fixed due to the fix 
constraint previously applied.

Concentric Constraint Tool The concentric constraint tool creates a con-
straint that forces circles to share the same 
center point. 

This concentric tool recognizes circles and points as valid selectable entities.
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 Symmetric Constraint Tool This tool creates a symmetric constraint 
between entities of asimilar type and symme-
try line.

Note:  Use the mirror tool in the transformation tool palette while in the sketch mode to 
automaticaly apply mirror constraints at the time the mirror operation is performed.

Equal Constraint Tool The equal constraint tool applies an equal dis-
tant or radius constraint between two entities.

This tool works only with lines or circles.  When selecting two lines, the lengths are forced 
to be the same for the two entities.  In the case of circles, the same radius value is applied 
between the selected circles.  As with many constraints, this operation is independent of 
which curve is selected first due to the method in which the solver finds solutions.
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Colinear Constraint Tool The colinear constraint makes two lines colin-
ear.

Colinear implies that the two resulting lines have the same direction and line within the 
same line.  It does not imply anything regarding their lengths.

Offset Constraint Tool This tool adds an offset constraint between 
two lines or two circles.

The offset distance is specified through the status line.  In addition you can use the edit 
objects dialog to change an existing offset value.   Click on the constraint symbol to dis-
play this edit page.

Animating Dimensions Tool The animation tool will animate a sketch by 
modifying a dimension value through a range 
of values.  To use the animate tool, select a 
dimension that was used within a sketch and then 
choose the Animate Constraint tool.
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Note:  If you animate a sketch while in sketch mode, only the sketch is updated.  If you 
animate a sketch outside of the sketch mode, dependent surfaces and solids update accord-
ingly.

DCM Animation Settings Dialog

Changing the settings
The DCM Animations Settings dialog box is used to control the behavior of a sketch 
dimension animation. The available animation settings are Start, End, Steps, Delay, Loop, 
and Rebound.

The Animation Settings dialog contains the following options:

Start  Specifies the starting dimension value.

End  Specifies the ending dimension value.

Steps  Controls the number of intermediate steps to use when 
transitioning from the dimension Start value to the End 
value. For example, if Start is 1.0, End is 4.0, and 
Steps is 6, the dimension will animate with the values 
of 1.0, 1.5, 2.0, 2.5, 3.0, 3.5, and 4.0. The delta value is 
computed by:  (End - Start) / Steps.

Delay Controls the number of seconds to wait between sketch 
dimension animation “frames”.

Loop If checked, the animation will continue to play indefi-
nitely until stopped.

Rebound If checked, the dimension value will transition from 
Start to End in Step steps, and then continue by 
“rebounding” from End to Start in Step steps.
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Running the Animation
Once the settings are made, select the dimension you want to animate. The animation will 
start automatically. You may control the execution of the animation using the VCR style 
buttons in the dialog box.

Deleting Constraints
To delete any constraint, simply select the constraint symbol and hit the delete key or 
delete from the menu.

Verifying Constraint Relations
To confirm the entities used in a constraint relationship, simply move your cursor over the 
constraint symbol and pause for several seconds.  After several seconds the entities 
involved in the constraint relationship will highlight in red.

Constraint Preferences
The Preferences dialog box under the File menu contains a category for DCM (Dimension 
and Constraint Management).  The DCM Preference Settings includes options for setting:

Note: Avoid using the select color as a constraint color to minimize confusion between a 
constraint color and when an entity is selected.

Over-Defined Constraint Color Any entity in a sketch that has too many constraints or 
creates an ambiguity for the solver will display in the 
Over-Defined Constraint color.  It is best to resolve any 
over-defined sketch entities before exiting a sketch.

Under-Defined Constraint Color Entities that still have degrees of freedom remaining 
are displayed in the under-defined constraint color.
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Fully Defined Constraint Color Any entity whose position and size is fully defined is 
displayed in the fully defined constraint color.

Fixed Constraint Color Entities that have a fixed constraint associated with 
their definition are displayed in this color. 

Show Constraint Layer When the show constraint layer check box is enabled, 
new sketches will automatically turn on the sketch 
layer.  Sometimes complex sketches get visually com-
plicated when all the constraint symbology is dis-
played.

Reference Edges
When in Sketch Mode, edges of geometry that are not on the sketch plane can be projected 
onto the plane.  In sketch mode, simply select the Explode Edge tool:

Then click on the surface or solid edge you wish to project onto the sketch plane, and the 
exploded curve will appear on the sketch plane in the Fixed Constraint color.  This color 
means that the object is associatively tied to another piece of geometry.  Keep in mind that 
if you move the original geometry, the exploded curve will move as well.

Projecting a curve into a sketch
This is similar to exploding the edge of a surface or solid and projecting it onto the sketch 
plane, except that it will work for wireframe geometry.  The procedure is the same as for 
Reference Edges.  When in sketch mode, simply select the Explode Edge tool and choose 
the wireframe geometry you wish to project to the sketch plane.  Once again, this geome-
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try is associatively tied to the original curve, and is displayed in the Fixed Constraint 
color.

Dimension-Driven Geometry
Dimensions created in the sketch mode are by default driving dimensions.  This means 
that changing the dimensional value will force curves associated with the dimension to be 
updated to the new dimensional value.  A dimension that is driven by the curve is called a 
reference dimension.  Outside of the sketch mode, dimensions created are reference 
dimensions.  To change a dimension from dimension-driving to dimension-driven, right 
click over the dimension. 

Exiting Sketch Mode
Once a sketch is created and constrained, to exit Sketch Mode simply click the blue Exit 
icon in the lower right-hand corner of the drawing window:

Variables and Equations
This Designer Elements program supports the assigning of variables and equations to 
dimensions applied while in the Constraints Sketch Mode. When you have geometry that 



Variables and Equations
has been constrained using equations is an easy way to manipulate the geometry, see the 
examples below.
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To open the Equations dialog box go to the Window menu and 
choose Equations (Window>Equations).

The equations dialog box supports all manner of mathamatical 
expressions. If you want to use one dimension as a reference to 
the other be sure to use its name from the name field as in the 
previous example. For a list of Mathematical operators that can 
be used see Appendix A.

Using Equations
Once you have completed your parametrically constrained part 
you may then edit the dimensions applied to the part using the 
equations dialog box, seen below.

The Equations dialog contains the following options:

All Sketches This pull down menu contains the list of every sketch 
within the file.

Filter Allows you to sort what type of dimensions are shown 
in the equations dialog box.

Name The name of the dimension. You may change the name 
of the dimension by clicking once in this field and 
renaming the dimension.

Value Shows the current value for each dimension. By press-
ing on the mouse while in the value field yo may high-



Variables and Equations
light that value on your screen. This is helpful when 
you have numerous dimensions in your sketches.

Equation By clicking in this field you may enter the mathemati-
cal expression that will define the dimension.

Changing the Dimension Name
Use the following steps to change the name of the Dimensions.

1. Move your cursor to the Dimension Name field 
you want to change.

2. Click once on the Dimension Name, the dimen-
sion highlights.

3. Change the name.

Highlighting Dimensions in the Sketch
Use the following steps to highlight the dimension on the screen.

1. Move your cursor to the Dimension Value field you want to highlight

2. Click and hold down the mouse button

3. The dimension highlights.
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Adding Equations
Using mathematical expression or operators you can change or resolve the size of your 
part.

1. Click in the equation field of the dimension you would like to change.

2. Add your mathematical expression, such as D1*2/3.

3. Click Apply for your changes to take place.

Note: You cannot use the undo (Ctrl or Cmd + Z) for expressions applied in the equations 
dialog box. Repeat the steps above to change the dimension.



Appendix A: Mathematical Opera-
tors
This Designer Elements program data fields accept the following mathematical 
operators.

Addition x+y

Subtraction x-y

Multiplication x*y

Division x/y

x%y - modulo division which returns the remain-
der of x/y. The resulting value will always be from 
0 to y-1.

Angles this Designer Elements program accepts angle 
entries like the following: 45d30m30s, 45d30"30', 
45d30', 30"30', 30m30s, 30"30s and 45°30"30

Absolute Value abs(x) - absolute value of x

Arc tangent atan (degrees)

Arc sine asin(degrees)

Arc cosine acos(degrees)

Cosine cos(degrees)
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Sine sin(degrees)

Tangent tan(degrees)

Trigonometry trig functions

Smallest Larger Integer ceiling(x), or ceil(x) - returns a value representing 
the smallest integer that is greater than or equal to 
x.

Largest Smaller Integer floor(x) - returns a value representing the largest 
integer that is less than or equal to x.

Degrees to radians dtor(degrees)

Radians to degrees rtod(radians)

Factorials factorial(x), or fact(x) - factorial of x. (e.g. fact(4) = 
4*3*2*1)

Logorithms log(x)

ln(x) - base 10 log of x, natural ln of x

Exponentials exp(x) - e to the power of x where ln(exp(x)) = x.

x^y - exponentiation (x to the power of y)

Negatives neg(x) - negative of x

π pi

Round round(x) - rounds to the nearest whole value. For 
example, round(1.49) = 1.0, and round(1.51) = 2.0.

Random numbers rnd - random value between 0.0 and 1.0

Square root sqrt(x) - square root of x

Remove Fractional Part truncate(x)

trunc(x) - truncates to the whole value. For exam-
ple, trunc(1.01)= 1.0, and trunc(1.99) = 1.0.



Tech Note:

Numeric values must be 
entered with an enhanced 
101 keyboard using the sepa-
rate number pad.
Appendix B: Special Characters
You can use special characters and accents which are available with your computer. 
Usually these characters are described in an appendix of the user manual. Many 
symbols and characters are from the keyboard. 

Windows:
Unlock the keypad with the NUM LOCK key and then hold down the ALT key and 
enter the numeric code for the character you want.

The character appears in the current font (including the DE Plotter font). The fol-
lowing list includes common symbols which are available in all fonts:

Accent Key Combination

° ALT 0176

ø ALT 0216

± ALT 0177

Macintosh:
To see the characters associated with a particular font, choose Key Caps from the 
Apple menu and select the font from the Font menu. When you press the z  (Com-
mand), OPTION, SHIFT, or CONTROL key or a combination of these keys, the key-
board graphic changes to show which characters are available.

In addition to those characters you see in Key Caps, you can use the OPTION key 
to generate international accents in the current font, including the DE Plotter font.
B-1



Appendix B: Special Characters

B-2
Accent Key Combination

é OPTION+e then letter to be accented

è OPTION+` then letter to be accented

ñ OPTION+n then letter to be accented

ü OPTION+u then letter to be accented

The following list includes common symbols which are available in all fonts.

Accent Key Combination

° OPTION+ SHIFT 8

ø OPTION+ O (letter or number)

± OPTION+SHIFT =



Appendix C: DXF/DWG Translator
This Designer Elements program supports the AutoCAD DXF (drawing exchange 
file) and DWG format. DXF files are standard ASCII text files. DXF files can easily 
be translated to other CAD systems which likewise support the DXF format. DWG is 
the native AutoCAD file format. This Designer Elements program supports the fol-
lowing DXF/DWG entities:

Read DXF/DWG Description
3DFACE Four points defining the corners of a face.

POLYLINE A string of vertices defining a line.

LINE Two points defining a line.

CIRCLE Center point and circle radius.

ARC Center, radius, start angle and end angle.

POINT One point location in space.

TEXT Collection of characters defining text string.

BLOCK Symbol.

ACIS DATA Curves, surfaces, solids generated by ACIS.

ELLIPSE Valid for R13+.

LIGHTWEIGHT POLYLINE Valid for R14+.

MULTI-LINE Valid for R13+.
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SOLID A filled region defined by 4 points.

SPLINE Smooth spline curve valid for R13+.

LAYERS Layer names, colors and locking.

LINE TYPES Line font definition.

AutoCAD is a registered trademark of Autodesk Inc.



Appendix D: IGES Translator
This Designer Elements program supports importing and exporting IGES files. The 
list of supported entities appears below.

Importing
This list provides the IGES Entity number, Form and IGES Entity name.

IGES   Form IGES Entity Name
#100 0 Circular Arc

#102 0 Composite Curve

#104 0 Conic Arc General

#104 1 Conic Arc Ellipse

#104 2 Conic Arc: Hyperbola

#104 3 Conic Arc: Parabola

#106 11 Copious Data 2D Path

#106 12 Copious Data 3D Path

#106 63 Copious Data: Closed 2D Curve

#108 1 Plane Entity Bounded Face

#110 0 Line Straight

#112 0 Parametric Spline Curve
D-1



Appendix D: IGES Translator

D-2
#114 0 Parametric Spline Surface

#116 0 Point

#118 1 Ruled Surface

#120 0 Surface of Revolution

#122 0 Tabulated Cylinder Surface

#123 0 Direction Vector

#124 0 Transformation

#126 0 Rational B-Spline Curve

#128 0 Rational B-Spline Surface

IGES   Form IGES Entity Name
#130 0 Offset Curve

#140 0 Offset Surface

#141 0 Boundary Entity

#142 0 Curve on Parametric Surface

#143 0 Bounded Surface 

#144 0 Trimmed Surface

#186 0 MSBOBody

#190 0 Plane Surface

#112 0 Rt. Circular Cone

#194 0 Rt. Circular Conical Surf

#196 0 Spherical Surface

#198 0 Toroidal Surface

#502 1 Vertex List

#504 1 Edge List

#508 1 Loop

#510 1 Face

#514 11 Shell



Exporting
The list provides the number, this Designer Elements program/ACIS name, IGES 
Entity number, Form and IGES Entity name for exporting or writing out an IGES file.

VS/ACIS IGES     FORM IGES ENTITY NAME
Straight #110 0 Line

Ellipse #100 0 Circular Arc

#104 1 Conic Arc-Ellipse

#126 0 Rational B-spline Curve

#128 0 Rational B-spline Surface

#120 0 Surface of Revolution

Plane #190 0 Plane Surface

#122 0 Tabulated Cylinder 

#109 0 Plane - Unbounded 

Cone #192 0 Cylindrical Surface

#194 0 Conical Surface

#120 0 Surface of Revolution 

Sphere #196 0 Spherical Surface

VS/ACIS IGES     FORM IGES ENTITY NAME
#120 0 Surface of Revolution 

Straight #110 0 Line

Torus #198 0 Toroidal Surface

#120 0 Surface of Revolution 

Point #116 0 Point

Vector #123 0 Direction

Transf #124 0 Transformation

Vertex #502 1 Vertex

Edge #504 1 Edge
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Loop #508 1 Loop

#102 0 Composite Curve

#106 Copious Data

11 2D Path

12 3D Path

63 Closed Planar Curve

#142 0 Curve on Parametric Surface

Face #510 1 Face

#144 0 Trimmed Surface

Shell #514 1 Shell

Lump/Body #186 0 MSBO



Appendix E: Short Cuts
These are the short cut keys currently programmed in this Designer Elements pro-
gram. There are many short cuts actions in this Designer Elements program which 
you can program with specific keys. Choose File>Short Cuts to display the Short 
Cut Manager. See Chapter 6, “Preference Settings,” for information on how to pro-
gram the keys.

Short Cut - Key Action

Layout:Dec Display...{ Makes the previous layer visible and turns off all 
other layers except the work layer.

Layout:Inc Display...} Makes the next layer visible and turns off all other 
layers except the work layer.

Layout:Isolate Layer...i Brings up the Isolate Layer dialog box for setting 
the work layer.

Line:HorzConst...H Creates a moveable horizontal construction line at 
your pointer tip. Move the pointer to the desired 
location and click to place the construction line.

Line:VertConst...V Creates a moveable vertical construction line at 
your pointer tip. Move the pointer to the desired 
location and click to place the construction line.

Snap Alignments...A Toggles the Drafting Assistant alignment snaps, 
like align x, y and z, between on and off.
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Snap Centers...C Snaps to the center of an object.

Snap:Edges...E Snaps to the edges of an object.

Snap:Faces...F Snaps to the faces of a solid.

Snap:Intersections...I Snaps to the intersections of objects.

SnapOnOff...Q Toggles all Drafting Assistant snaps between on 
and off.

View:Front View...s Changes the view to Front.

View:ISO View...f Changes the view to Isometric.

View:Redraw Screen...r Redraws the screen.

View:Side View...a Changes the view to Side.

View:Top View...d Changes the view to Top.

View:TRI View...g Changes the view to Trimetric.

View:Zoom All...e Activates the Zoom All command.

View:Zoom In...] Activates the Zoom In command.

View:Zoom Out...[ Activates the Zoom Out command.

View:Zoom Window...w Activates the Zoom Window command allowing 
you to drag a selection fence to specify the zoom 
area.



Appendix F: Spline Text Files
You can create text files for importing Spline data into this Designer Elements pro-
gram.

Creating a Text File for Importing a Spline
1. Use a text editor, a word processor or a spreadsheet to create a text file.

2. Input X, Y and Z values for your spline coordinates.

The text file should be tab or space separated. Each line ends with a return. Line 
feeds after each return should have no effect.

The text file should conform to the following columnar format:

1 1 0

2 2 0

You are allowed to specify decimal coordinates as well:

1.33 1.1 0

2.4 2.5 3.5678

Be sure that you press ENTER (Windows) or RETURN (Macintosh) after the last 
coordinate. If not, this Designer Elements program will not import the coordi-
nates specified in the last line.

3. Save the file as Text only and import into this Designer Elements program using 
the Spline import format to create the spline.
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Appendix G:
Shader Attribute Definitions
This appendix defines shader attributes for all shader types. Although these terms 
may be used elsewhere in this Designer Elements program, these definitions only 
apply to the shader attributes.

Some shader attributes share a common base word like base color and decal color. 
In these instances, only the base word is listed and defined here. In this example 
mentioned, color is defined.

Information for these definitions was taken from LightWorks 5.0 Online Reference.

Color Class Attributes
amplitude Sets the magnitude of an attribute relative to 

another.

axis Sets the location of the axis for the attribute.

axis direction Sets the direction for the axis when applying the 
simple wood shader.

bands Sets the total number of bands around the evalua-
tion cylinder when analyzing a surface.

brick height Sets the brick height.

center Sets the center of an attribute.

color Sets the color of the attribute.
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color array Sets the colors used for curvature divisions.

coverage Sets the ratio of the area covered by the bands to 
the area not covered for a surface evaluation.

curvature Sets the degree of curvature to be mapped.

curvature division Sets the number of color divisions used for a cur-
vature evaluation.

curvature type Sets the type used in a geometric curvature evalua-
tion. You have three types: gaussian, mean and 
absolute.

decal texture space Sets the texture space for the attributes. Checking 
the Edit button displays a copy of the Render Mate-
rial Settings dialog box from which you can set the 
space.

decal transparency Sets the transparency from clear to opaque.

detail Sets the complexity of the texture where a value of 
1.0 results in a simple pattern and higher values 
result in a finer pattern.

draft angle Sets the draft angle required to pull the object out 
of a mold.

file name Sets the file name containing the image used for 
the shader.

fuzz Sets the band sharpness.

gnarl Sets the random roughness of the regular rings 
inside the trunk.

grain Sets the intensity of the random grain effect where 
0 (zero) equals no grain.

max cut off Set the maximum curvature value for evaluating an 
object.

min angle Sets the angle of the normal along the cylinder axis 
that defines the cylinder length and thus the reflec-
tion on the surface you are evaluating. Smaller val-
ues create longer cylinders.



min cut off Sets the minimum curvature value for evaluating 
an object.

mix Sets the mix ratio of attributes.

mortar size Sets the mortar size.

noise Sets the visibility of the tree rings for the simple 
wood shader.

offset Sets relative displacement of odd and even rows of 
the wood pattern.

plank length Sets the plank length of the wood shader.

plank variation Sets the brightness variation between wood 
planks.

plank width Sets the plank width for a wood shader.

point on axis Sets the point on the axis of the tree from which 
the wood is taken.

pull direction Sets the direction the object will be pulled from the 
mold.

radius Sets the radius of the attribute.

replication type Sets the pattern of the wrapped image.

ring fuzz grain Sets the intensity of the high frequency random 
roughness for the ring edges.

ring fuzz in Sets the sharpness of the inner ring edges near the 
trunk center.

ring fuzz out Sets the sharpness of the outer ring edge.

scale Sets the scale of the attribute.

separation Sets the distance between centers of adjacent 
spheres for the solid polka shader.

size Sets the attribute size.

softness Sets the softness of the feature used to define the 
shading.

strips Sets the count of the rectangle wood planks.
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tolerance angle Sets the degree tolerance added to the draft angle 
that allows the object to be pulled from a mold but 
with difficulty.

trunk direction Determines the direction of the trunk axis.

trunk center Specifies the center of the trunk.

vector Sets the direction of the attribute calculated in 
determining the appearance of a particular shader.

vein contrast Sets the color contrast of the marble veins where 
larger values produce a greater contrast.

width Sets the attribute width.

Displacement Class Attributes
amplitude Sets the magnitude of one attribute relative to 

another.

blend Sets the size of the blend between the sphere and 
the surface for the shader.

center depth Sets the depth of the spheres used for the dimple 
shader.

dented threshold Sets the relative contributions made by the dis-
placements and indentations for the casting shader.

detail Sets the complexity of the texture where a value of 
1 results in a simple pattern and higher values 
result in a finer pattern.

file name Sets the file name containing the image used for 
the shader.

frequency Sets the wavy or curving quality of edges.

irregularity Sets the pattern shape from a square to an irregular 
convex shape.

radius Sets the radius of the attribute.

scale Sets the scale of the attribute.

separation Sets the distance between the centers of adjacent 
spheres for the wrapped dimple shader.



sharpness Sets the sharpness of surface irregularities.

smooth max Sets the maximum smoothness of the edges when 
using the leather shader.

smooth min Sets the minimum smoothness of the edges when 
using the leather shader.

softness Sets the softness of the feature used to define the 
shading.

Reflectance Class Attributes
absorption Sets the amount of light absorbed.

ambient factor Sets the amount of ambient light reflected.

amplitude Sets the magnitude of one attribute relative to 
another.

bias Sets the contribution of the two thread directions 
for the wrapped woven anisotropic shader. A bias 
of 0.0 causes all reflectance to be provided by 
threads along one axis. A bias of 1.0 causes all 
reflectance to be provided by threads along the 
other axis.

chrome factor Sets the amount of chrome light reflected.

color Sets the color of the attribute.

cylinder distance Sets the distance between cylinders for the 
wrapped anisotropic shader. The distance deter-
mines the degree of anisotropy of the surface. A 
distance of 0.0 results in an isotropic (normal) 
reflection. A distance of 2.0 results in the maximum 
anisotropy.

decal texture space Sets the texture space for the attributes. Clicking 
the Edit button displays a copy of the Render Mate-
rial Settings dialog box from which you can set the 
space.

diffuse factor Sets the amount of diffuse light reflected.
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exponent Sets the sharpness of the specular reflection high-
lights.

file name Sets the file name containing the image used for 
the shader.

floor height Sets the height of the floor across the cylinders 
used for the wrapped anisotropic (grooved) 
shader. A value of 0.0 gives equals no floor. A 
value of 1.0 creates a flat, isotropic surface.

height Sets the height of the attribute.

metallic layer factor Sets the contribution of the metallic layer to the 
reflectance of the multilayer paint shader.

metallic flakes Sets the metal for the metal flakes in the paint 
shader.

mirror factor Sets the contribution made by light reflected in the 
mirror direction.

reflectance Sets the reflectance of the shader.

refraction Sets the amount of light refracted.

roughness Sets the sharpness of the reflectance. Smaller val-
ues, such as 0.1, produce a sharper reflection.

scale Sets the scale of the attribute.

selector Sets the shader used to calculate the decal reflec-
tance with respect to the base object. Clicking the 
Edit button displays a copy of the Render Material 
Settings dialog box from which you can set the 
shader.

shader Sets the shader.

sharpness Sets the sharpness of the surface.

softness Sets the softness of the feature used to define the 
shading.

specular factor Sets the amount of specular light reflected.

translucency factor Sets the degree of translucency.



transmission factor Sets the amount of light that passes though the 
shader.

transparency Sets the transparency of the shader.

width Sets the width of the attribute.

Transparency Class Attributes
coverage Sets the degree that an attribute covers the object 

with the associated shader.

color Sets the color of the attribute.

detail Sets the complexity of the attribute.

edge falloff Sets the transparency edge falloff rate.

file name Sets the file name containing the image used for 
the shader.

fuzz Sets the degree of fuzziness for the edges.

grid size Sets the size of the grid for the wrapped grid 
shader.

height Sets the height of the attribute.

noise density Sets the density of the roughness or irregularities.

scale Sets the scale of the attribute.

s fuzz Sets the softness of the s edge of the square for the 
wrapped square shader. The letter “s” is an identi-
fier used to refer to one side of the square.

size Sets the size of the attribute.

s max Sets the maximum s dimension of the square for 
the wrapped square shader. The letter “s” is an 
identifier used to refer to one side of the square.

s min Sets the minimum s dimension of the square for 
the wrapped square shader. The letter “s” is an 
identifier used to refer to one side of the square.

softness Sets the softness of the feature used to define the 
shading.
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t fuzz Sets the softness of the t edge of the square for the 
wrapped square shader. The letter “t” is an identi-
fier used to refer to one side of the square.

t max Sets the maximum t dimension of the square for 
the wrapped square shader. The letter “t” is an 
identifier used to refer to one side of the square.

t min Sets the minimum t dimension of the square for the 
wrapped square shader. The letter “t” is an identi-
fier used to refer to one side of the square.

transparency Sets the transparency of the shader.

width Sets the width of the attribute. 

zero angle Sets the angle between surface normal and view 
direction.

Texture Space Class Attributes
aspect ratio Sets the ratio of the texture space which is defined 

as one unit of its height divided by one unit of its 
width.

axis direction Sets the direction of the axis.

center point Sets the center point of the cylinder used for map-
ping a texture space.

origin Sets the origin point of the texture.

scale Sets the scale of the attribute.

scale along axis Sets the factor that an image is scaled along the 
axis.

scale around axis Sets the factor that an image is scaled around the 
axis.

vector Sets the direction of the attribute.

Background Class Attributes
angle Sets the angle (radians) over which the environ-

ment map is sampled for each background pixel 



allowing blurring. A 0 (zero) angle (default) means 
that the pixel’s center point determines the color.

color Sets the color of the attribute.

detail Sets the complexity of the attribute.

distance Sets the distance that the infinite planes are in front 
and back of the eye point. The two background 
images are placed on these infinite planes.

extrapolation Sets how the background will cover the back-
ground area. You have three options: none, smear 
and tile.

file name Sets the file name containing the image used for 
the shader.

intensity Sets the brilliance of the reflection to be altered. 
The color is calculated for each background pixel 
by multiplying it with the intensity.

keep aspect Sets the use of the pixel aspect ratio for the image. 
Images are automatically scaled to fit the viewport. 
Selecting True preserves the pixel aspect ratio.

keep texture Sets the use of the texture for the image. Selecting 
True results in the image and file name attributes 
being referenced when no texture has been cre-
ated yet.

missing ratio Sets the ratio for mixing two shaders.

rotation Sets the angle the image is rotated. The value must 
be either +/-90°, +/-180°, or +/-270°. Positive 
angles rotate the image clockwise. Negative angles 
rotate the image counter-clockwise.

scale Sets the scale of attribute.

shader Sets the shader.

softness Sets the softness used to define the shading.
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Foreground Class Attributes
AA level Sets the depth used for determining the number of 

samples. A value of zero results in no oversam-
pling. A value of one results in two times the num-
ber of samples as the maximum.

AA threshold Sets the limit value used to determine whether 
additional sampling calculations are performed to 
determine the light effect. If the scattered light at 
two sample points differ more than the threshold 
value, additional sampling occurs.

amplitude Sets the magnitude of one attribute relative to 
another.

bounds Sets the use of light scattering boundaries for cal-
culating the effect when unable to determine 
where the light source contribution is negligible. 
Selecting False results in no bounds.

bounds on Sets the use of light scattering boundaries for cal-
culating the effect when unable to determine 
where the light source contribution is negligible. 
Selecting False results in no bounds.

bounds volume Sets the volume of the boundary sphere used to 
calculate the scattering effect when unable to 
determine where the light source contribution is 
negligible.

color Sets the color of the attribute.

density Sets the density of the attribute.

distance Sets the distance used in calculating the closeness 
of the fog to the viewer.

eccentricity Sets the ellipse eccentricity used when calculating 
the light scattering effect for the Henyey-Green-
stein scattering model. It has no effect on any 
other light scattering model. A zero eccentricity 
results in an isotropic scattering. A positive eccen-



tricity results in a forward scattering. A negative 
eccentricity results in a backward scattering.

error bound Sets the limit for using the max lod attribute when 
calculating the detail effect using the scattering 
medium shader. The calculation time can become 
excessive depending on the detail level. This value 
determines the trade off point between calculation 
time and accuracy. The suggested range is 
between 0.0 and 1.0.

falloff threshold Sets the spherical area of influence of the light 
sources. Beyond a certain area the light contribu-
tion would be negligible, making a large number 
of samples unnecessary. The default threshold is 
0.001. The value’s effect depends on the size of the 
scene and light source intensity. Thresholds that 
are too high result in spotlight clipping.

far Sets the maximum distance for the foreground 
shader. Distances greater than the far value display 
the full background color.

flake size Sets the size of the flake for the snow shader.

fog height Sets the sets fog decrease rate.

ground normal Sets the normal for the ground fog shader.

ground point Sets the ground point for the ground fog shader.

ignore background Sets whether the fog effect is applied to the back-
ground. Selecting True results in no background 
fog effect.

max depth Sets the maximum distance used in calculating the 
light scattering effect. A smaller depth, near 0.0, 
results in an image lacking any volumetric effects. 
The default depth is 1000. The value’s effect 
depends on the size of the scene.

max lod Sets the maximum detail level for calculating scat-
tered light using the scattering medium shader.

medium ambient Sets a uniform light scattering through the medium.
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medium attenuation Sets the attenuation within the medium or how it 
absorbs light along the way.

medium density Sets the density of the medium through which scat-
tering occurs.

medium shadows Sets whether the medium received shadows.

min lod Sets the minimal detail level for calculating scat-
tered light using the scattering medium shader.

near Sets the minimum distance that a background color 
appears. Distances less than the near value will not 
display the color.

noise gain Sets the contrast in the noise. High values result in 
sharp transitions while low values result in smooth 
transitions.

noise octaves Sets the number of octaves (frequencies/scales) 
used to determine the detail of the noise in the 
light scattering.

samples Sets the number of samples taken to calculate the 
atmospheric scattering of light. A higher number 
results in greater accuracy but requires more calcu-
lation time.

scale Sets the scale of attribute.

scattering model Sets the model used for scattering the light. You 
have five options: isotropic, Rayleigh, Mie hazy, 
Mie murky and Henyey-Greenstein. Choosing Mie 
murky results in strong anisotropic forward scatter-
ing as would appear when looking directly at light 
sources.

source attenuation Sets the falloff value for the attribute. Small 
changes in the attenuation value greatly affect the 
light scattering effect. Values are typically between 
0.1 and 0.5.



Glossary
Accelerators Keyboard Equivalents that invoke commands 

rather than using the mouse to choose from 
menus.

Align These commands let you align objects, including: 
text along the left sides, right sides, tops, bottoms, 
centers horizontal, centers vertical, to grid and 
equally spaced vertically.

ACIS This Designer Elements program is based on this 
kernel, developed by Spatial Technologies.

Ambient Light This light source provides equal illumination on all 
sides independent of the light source normal.

Annotation Text on drawings, including notes, crosshatching 
and dimensions.

Alignment Angle The angle of the Drafting Assistant’s automatic 
construction lines. The specification is set in the 
Window>Snaps submenu.

Ambiguity Popup This popup menu appears when you attempt to 
select one object among objects so you can choose 
the desired object.

Anchor This point defines the direction when placing a 
distant light source in your drawing.
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Anti-Alias Feature This feature performs a ray trace operation to bring 
out small geometric details and produce smoother 
images.

Arrange This command in the Layout menu allows you to 
change the display of overlapping objects in your 
drawing.

Arrow Tool Used for selecting objects to be operated on with 
subsequent commands. Also used to move selected 
geometry.

ASCII An acronym for American Standard Code for Infor-
mation Interchange.

Aspect Ratio Refers to a mesh surface and specifies the maxi-
mum ratio between triangle edges.

Associativity A link between an object and its dimensions or 
parent/child objects. In the case of dimensions, if 
the object is changed, the dimensions automati-
cally change to match. In the case of parent/child 
objects, if the parent is changed the child also 
changes.

Attenuation The reduction of light intensity with the distance 
from the source.

Attributes The data fields associated with a particular object 
that define that object. This includes such as Layer 
Name, Pen Style, Color, X-Y-Z Coordinates. This is 
also a page in the Edit Objects dialog box.

Auto Heal Bodies This function finds collections of surfaces that 
define closed volumes and convert them into sol-
ids. This occurs when importing Vellum 3D and 
IGES files into this Designer Elements program.

Auxiliary View A view created from its parent view at the geome-
try location that the user specifies.

Axis Displays the current view orientation of the X, Y 
and Z axis in the center of your screen. 

Following



Bezier Curve A free form curve. NURB splines are a superset of 
Bezier curves.

Blend This is the filleting and rounding of solid edges.

Boolean Tools These tools allow you to add, subtract and inter-
sect solids.

Border A frame showing the boundary of a view.

Boss This is a cylinder extending from a solid and fil-
leted at the intersection of the two.

Boundary The geometry that defines the limits for operations 
such as trimming and relimiting.

CAD An acronym for Computer-Aided Design.

CADD An acronym for Computer-Aided Design and Draft-
ing.

CADD.LIN All line patterns are stored in this file in the Envi-
ron folder.

CAE An acronym for Computer-Aided Engineering.

CAM An acronym for Computer-Aided Manufacturing.

Case This refers to the text case options in this Designer 
Elements program and include lower case, UPPER 
CASE and Title Caps.

Center Mark A center-line dimension for circles and arcs.

Chamfer A beveled or sloping edges between two objects.

Characteristics See Attributes.

Child An object created from another object or an opera-
tion performed on an object.

Circumference The distance around a circle along its edge: =2 Pi r

Circumscribed Enclosing a circle. In circumscribed polygons, the 
midpoint of each side of the polygon touches an 
imaginary circle (i.e. the polygon exactly surrounds 
the circle).
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Clamped Linear Light intensity that diminishes according to the fol-
lowing formula, Intensity/(distance+1).

Clamped Quadratic Light intensity that diminishes according to the fol-

lowing formula, Intensity/(distance2+1).

Click To press and release the mouse button. When you 
are told to click an object, move the pointer to the 
object and press and release the button.

Clipboard The memory buffer where selections are stored 
when the Cut or Copy command is used.

Conic These objects are used in aerospace design field 
and create curves defined by start point, end point, 
shoulder and slope control points.

Construction Lines Lines, displayed as dotted or gray lines, that you 
use for exact alignment. The Drafting Assistant cre-
ates dynamic, temporary construction lines. You 
can also create permanent construction lines, 
which can be used in the geometry or used for 
alignment and then deleted.

Control Point The endpoint or midpoint of an object or “knot” 
point defining a spline. The Drafting Assistant indi-
cates these positions when the pointer is moved 
near them.

Coon Patch A nurb surface with three or four sides.

Coordinates Positions on axes that specify the point locations. 
Two-dimensional objects have x,y coordinates; 
three-dimensional objects have x,y,z coordinates.

Coplanar This refers to objects that lie in the same two 
dimensional plane.

Copy The command that places a duplicate of the 
selected geometry on the Clipboard. See the 
descriptions for the Polar Duplicate and Linear 
Duplicate tools and Transformation tools for addi-
tional copying methods.



Cover Surface A surface created from a profile.

Counter Bore A hole created from a hole and a bore where the 
bore is a straight sided cylinder with a diameter 
larger than the hole. The hole extends from the 
end of the bore into the solid to complete the 
counter bore.

Counter Sink A hole created from a hole and a sink. The sink is 
an angled hole with a diameter larger than the 
straight sided hole. The hole extends from the end 
of the sink into the solid to complete the counter 
sink.

Crayon Picker This is a Macintosh color display allows you to 
chose a color from the crayon box.

Custom Colors (Windows only) This button in the color display 
allows you to define 16 additional colors to show 
in the partial color display.

Cursor The I-beam position indicator in the text tool and 
boxes which use text. Elsewhere, the position indi-
cator is called a pointer. 

Curvature This command in the Verify menu displays a por-
cupine plot of selected curves or surfaces repre-
senting the direction and order of magnitude of the 
curvature.

Curvature Plot This analysis displays geometry in a Gaussian Cur-
vature plot which is the product (K1 - K2) of the 
principle curvatures at a point on a surface.

Curve A line, circle, arc, ellipse, or spline.

Cut The command to delete selected entities. The 
selection is placed on the Clipboard and can be 
pasted into the same or different documents or 
into documents created by other applications.

Cutout A profile that has been extruded through a solid 
and removes all intersecting material.
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CYMK Picker This is a standard color wheel for the Macintosh 
with the option to specify CYMK values.

Dashed A line pattern made up of dashes.

Default Built-in settings that are used by the system if you 
do not specify your own value or choice.

Defining Points The X, Y and Z coordinates for the specified points 
of splines, mesh and slab primitives.

Deformable Faces These are solid faces whose shapes can be modi-
fied by applying a gain pressure.

Degenerative An object such as a surface or chamfer where the 
its length at the beginning and/or ending is equal 
to zero.

Delete The command to erase selected geometry. The 
selection is not placed on the Clipboard; however, 
it can be retrieved within the limits of the Undo 
command.

Delta A change, usually in position.

Design Explorer This command displays a dialog box with the his-
tory tree of the selected object. It includes its own 
submenu of editing commands.

Detail View An enlarged view of a specific area of the geome-
try displayed in a drawing view.

Dialog Box A specification box that appears in response to cer-
tain commands. A dialog box allows you to pro-
vide information that qualifies the execution of 
those commands.

Diameter The distance across an arc or circle, passing 
through the center.

Differential Scaling Refers to the ability to use different scaling values 
for along different axes of a curve.

Dimension A graphic object that displays the distance between 
two points. A measurement of an object. 



Direction This command in the Verify menu displays the 
direction of the normals of an object. 

Distant Light This light source emits parallel rays of light, as if 
from a very distance source.

Divide To segment a line or curve into equal parts. This is 
also one of the Trim tools.

Double-click To press and release the mouse button twice, 
quickly. 

Drafting Assistant A unique feature which displays feedback nota-
tions and construction lines to aid with snap, align-
ment and constraint operations. The Drafting 
Assistant facilitates exact construction without 
requiring you to be exact. When the pointer is 
close enough to display feedback, the Drafting 
Assistant locks onto the exact location for you.

Drag To press and hold the mouse button, move the 
pointer to a new location, and release the button.

Draft A taper or a specific angle applied to a solid.

Draft Angle The subtraction or addition of material at a specific 
angle along a solid. Draft angles are used to facili-
tate the placement or removal of a part from a 
mold. Positive draft angles add material. Negative 
draft angles remove material.

DXF An acronym for Data Exchange Format-a format of 
AutoCAD files.

Drawing A drafted, 2-dimensional drawing of a model. Usu-
ally a drawing including an orthogonal view.

Drawing View A view containing 2D geometry created from a 3D 
model after choosing the Model to Sheet command. 

Dynamic Render The feature that displays your geometry in the 
selected render mode as you rotate the geometry.

DWG AutoCAD's native file format.
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Endpoint The first and last point of a line or curve. The 
Drafting Assistant indicates these positions when 
the pointer is moved near the endpoint of an 
object.

EPS Encapsulated PostScript format for printing to a 
PostScript printer and for importing into compati-
ble applications.

Estimate Count Refers to a button in the Mesh Parameter dialog 
box which calculates the approximate number of 
facets based on specified parameters. The dialog 
box appears when you using the Change Object 
Type command and convert a surface or solid to 
mesh.

Export To save a document in a file format that can be 
used by a different application program.

Extrude Creates a 3D object out of a 2D profile.

Expression Parsing Mathematical, trigonometric and exponential oper-
ators that can be used in the Status Line.

Face A surface of a solid.

Facet A way of representing surfaces in DXF and DWG 
files prior to release 13.

Falloff Angle The angle that controls the sharpness of a spot 
light’s edge.

Falloff Rate This light distribution for a spot light from the cen-
ter of the spot light cone to the outer edge.

Feature A set of operations that may add material to or 
subtract material from your solid including blend-
ing, chamfering, creating holes, bosses, cutout and 
protrusions.

Field of View The view angle for a perspective.

File An individual document.

Fill Color The color applied to a selected pattern for a smart 
polygon.



Fill Pattern The pattern applied to a smart polygon.

Fillet An arc of a specified radius tangent to entities. 

First Blind An option for the hole tools which will extend a 
hole to the first open face. 

Flatten View This command in the Drawing View menu flattens 
2D geometry within a view onto the Sheet View 
layer. This operation breaks the 2D geometry’s 
associativity to the 3D model.

Flat Shading Renders your object with a painter's algorithm 
using constant shading techniques.

Flavor The types of IGES files this Designer Elements pro-
gram can import and export.

Flip Normal When this option is checked in the Render Options 
dialog box, the normals of an object are flipped. If 
light normals are pointed away from the view 
when rendered, the object will appear dark.

Font The assortment of type used in text.

Gain Pressure applied to a solid face to deform it.

Geometry The objects used to construct parts.

Geometric Characteristics Characteristics that make up the geometry of an 
object like, length, radius, Defining Points and 
Rho.

Gouraud Shading Renders your geometry based on calculated light 
intensities at each vertex. It shades more quickly 
but with a lower quality than Phong shading. This 
rendering method uses Open GL (Windows) or 
QuickDraw 3D (Macintosh).

Gouraud w/Edges Shading Renders your geometry based on calculated light 
intensities at each vertex and displays the face 
edge boundaries in a specific color.

Gregory Surface A Nurb surface with more than four sides.
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Grid The rectangular array of lines that facilitates mea-
surement and alignment. The grid display can be 
turned on or off, and the spacing can be specified 
through the Layout menu.

Group To specify several entities as one unit that will be 
treated as a single object.

Helix A spiral curve.

Hidden A line pattern used to draw lines that would not be 
visible in a solid part. Drafters traditionally use hid-
den lines for geometry that is behind other geome-
try.

Hidden Shading Renders your geometry such that only visible 
edges are displayed.

Hidden w/Dimmed Renders your geometry such that the visible edges 
are displayed and the hidden edges are dimmed.

Hot Spot The point on the wireframe and dimension tool 
cursors that indicates the next point to click. The 
hot spot is represented by a dot with crosshairs on 
the cursor.

Histogram A bar graph representing the frequency of a curva-
ture smoothness (change in a curve over the 
change in curvature) using the color spectrum. The 
length of the bar represents the frequency.

Hit Radius The distance, in pixels, detectable by the Drafting 
Assistant between the object and the pointer.

HSL Picker This is a standard color wheel for the Macintosh 
with the option to specify Hue, Saturation and 
Lightness.

HSV Picker This is a standard color display for the Macintosh 
with the option to specify Hue, Saturation and 
Value.

IGES An acronym for Initial Graphics Exchange Specifi-
cation. The U.S. Department of Commerce, 
National Bureau of Standards issues IGES as the 



industry standard among CAD/CAM systems for 
data exchange in a neutral file format. 

Import To load or read in a non-Designer Elements pro-
gram file.

Infinite Plane A two dimensional surface with no defining 
boundaries.

Inflection A change in slope along a spline.

Influence The degree of impact a control point has on a 
spline.

Inscribed Within a circle. For polygons, all vertices touch the 
(imaginary) circle.

Instance Refers to an object that's moved to or placed in a 
different location after performing an operation on 
it. If you create a solid, add a blend and move it, 
the solid is now an instance. The original is still 
located in the previous position although it is not 
displayed. If you create a master symbol, an 
instance occurs when you place the symbol in 
your drawing. An instance is associative to the 
original geometry. Any change made to the origi-
nal is reflected in the instance. If you copy and 
pasted the object, the associativity is broken.

Intensity The lighting level for a light source set in the Edit 
Objects dialog box.

Interference The shared volume created by two or more inter-
secting objects.

Intersection The position where two lines or curves meet. The 
curves may actually touch or only intersect when 
they are extended. The Drafting Assistant indicates 
only actual intersections.

ISO Lines Control the isopram lines drawn for a surface. 
These Iso (isopram) lines are constant parameter 
curves that lie on a surface, typically defined in 
parameter space. The parameter space coordinate 
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system uses U and V coordinates. A 0 (zero) in 
both fields turns off Iso lines. The appropriate U/V 
values may enhance the visual appearance of the 
surface at the expense of drawing speed. The let-
ters, U and V are industry standard space coordi-
nate identifiers (U = horizontal, V = vertical).

Isopram The full name for ISO Lines.

Knot Points The points defining a spline, indicated as vertex 
points by the Drafting Assistant.

Lathe Revolve an object a certain angle.

Layer Analogous to transparent media used in conven-
tional manual drafting. Parts can be constructed on 
several layers which you can make visible or invis-
ible.

Line Pattern Manager Through this dialog box you can modify the scale 
of all available line patterns.

Linear Duplicate A feature that duplicates an object and places the 
copies in a line or in an array of multiple lines.

Links This is the associative relationship that exists 
between parent/child objects in which a modifica-
tion to the parent also modifies the child.

Local Face Modeling The ability to perform various operations on a spe-
cific face of a model including: drafts, move, offset, 
remove replace and match.

Lock The command to render a selection unchangeable.

Loft A surface that references another surface making it 
tangent to the referenced surface. Any surface can 
be used to create the surface.

MxN Curves The number of curves that define a net surface in 
two perpendicular directions.

Mask To select entities as a group, masking out all oth-
ers.



Masking The method used for applying a decal to an object, 
either stencil or factor.

Mate This operation matches the planar face of one 
object to the planar face of another object.

Math Operator The mathematical, trigonometric, or exponential 
expression used to indicate values. All value entry 
boxes in this Designer Elements program accept 
the math operators listed in Appendix A.

Max Edge Refers to a conversion of an object type to mesh. 
This sets the maximum acceptable length of facets.

Message Line The top line of the drawing area. It names the cur-
rent tool and provides instructions for using it.

Memory Indicator The indicator at the bottom left corner of the 
Designer Elements program window that displays 
how much RAM is allocated to this Designer Ele-
ments program.

Mesh Planar elements defined by nodes or 3D vertices 
that can be used to represent surfaces but are not 
surfaces themselves.

META The file format used by the Windows Clipboard.

Mnemonics The key sequence which invokes a command from 
a menu.

Model The model is your geometry.

Model Point The point you can specify in the View Rotation 
Options dialog box about which to rotate a view.

N# Sections The number (n) of cross sections used to define a 
skin surface.

Net Surface A surface defined by M (number) of rows and N 
(number) of columns. 

Non-planar Surfaces or points that do not lie in a two dimen-
sional plane.
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Normal A perpendicular to a tangent of a curve, surface or 
solid face.

Normal Deviation Refers to a conversion of an object type to mesh. 
This sets the maximum angular deviation between 
adjacent facets.

NURB Non-Uniform Rational B-splines—the type of 
splines this Designer Elements program creates. 
NURB splines are a superset of Bezier curves. 
NURB splines provide designers with two interre-
lated functions.

First, curvature continuity remains intact even 
when the curve is changed, so kinks won’t 
develop as the spline is altered. Second, localized 
control of a complex curve is provided. 

Object An individual piece of geometry, such as a line, 
arc, circle, surface or solid.

Object Extents The area defined by an object.

Object Type This refers to a specific kind of geometry and 
includes curves, surfaces and solids.

Offset The distance a curve or surface is placed from the 
original location.

Origin The 0,0,0 location on the drawing area. When a 
new document is opened, 0,0,0 is located in the 
middle of the screen. The coordinate symbol dis-
plays at the origin when the grid is turned on. You 
can change the origin at any time.

Pan A horizontal camera movement used when creat-
ing movies.

Palette A group of tools. The general tool palette is always 
displayed to the left of the drawing area.

Parent An object from which other objects are created or 
operations are performed.



Param The percentage point that a variable blend radius 
is placed along a solid edge.

Parent/Child The relationship created between an original 
object and subsequent objects such that any modi-
fications done on the parent affects the child.

Part A collection of entities representing an object or 
structure.

Parting Line A curve used with the Parting Line tool to divide a 
solid for applying a draft.

Paste To place the contents of the Clipboard in the cur-
rent document.

Perpendicular At a 90° angle. The Drafting Assistant displays a 
notation when the current construction is at a 90° 
angle to an object. 

Perspective Viewing 3D geometry on a two dimensional sur-
face as seen by normal binocular vision.

Phong Shading Renders your geometry based on calculated light 
intensities at each pixel location.

Phong w/Edges Shading Renders your geometry based on calculated light 
intensities at each pixel location and displays the 
face edge boundaries in a specific color.

Photorealistic Images resembling photography in the rendering 
quality.

Pick Box The area pixel area defined in Preferences that 
allows you to select an object.

Pick Objects This is the dialog box with the Ambiguity Popup 
menu.

PICT The Macintosh graphics file format which uses 
object-oriented bitmaps or resolution-independent 
graphics.

Pick To select a location or object by clicking it.
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Pipe Solid A solid created by with an inside and outside 
diameter using the Pipe Solid tool.

Pitch The distance between helix peaks.

Planar Surfaces or points that lie in a two dimensional 
plane.

Plot To draw a part on paper using a plotter.

Plotter A computerized drawing device for hardcopy out-
put.

Point A location for constructing geometry.

Point Light This light emits rays in all directions, like a candle 
or table lamp.

Pointer The position locator similar to a cursor. When a 
tool is in effect, the pointer takes on a representa-
tive shape while in the drawing area.

Polar Duplicate A feature that duplicates an object and rotates the 
copes around a reference point.

Press To press and hold down the mouse button. This 
action is most commonly used to view the contents 
of a menu.

Primitive A basic solid shape defined by linear or quadratic 
geometry like: block, cylinder, cone, etc.

Profile A closed curve or collection of curves connected 
end to end.

Protruded Feature Material projections from a solid.

Pull-direction The direction a part ejects from a mold.

QuickTime Object Movie A Quick Time movie that keeps the observation 
point fixed as the eye point is moved at a fixed dis-
tance about the observation point.

QuickTime VR Panoramic A QuickTime movie that keeps the eye point fixed 
as the observation point is rotated 360°.Movie



Radius Half the distance across an arc, starting from the 
center.

Rail A curve used to define a sweep direction and dis-
tance for a surface.

RAW This translator creates a file containing triangular 
vertices that define the x, y and z locations of the 
3D faces.

Raytrace The function that determines the visibility of 
objects in a scene by tracing rays from the eye to 
the objects. The raytrace function calculates the 
visibility by breaking the scene into smaller pixel 
areas, producing a photorealistic rendered images.

Redo The command that restores a previous operation. 
You can redo an infinite number of actions in a 
specific Designer Elements program session.

Redraw To refresh the screen, recreating all objects.

Reflectivity The ratio of the amount of light falling on a mate-
rial to the light reflected off it.

Relative Position A location specified as a certain distance from 
another location. It is often called the delta posi-
tion.

Relimit Lengthen or shorten lines to the specified object.

Render The command that shades your geometry in a 
specified mode.

Render Now The render option activated when you choose the 
Render command. You set the mode in the Render 
Options dialog box.

Render Options The dialog box that allows you to set the shading 
mode for your geometry.

Resolution The appearance of surfaces and solids when ren-
dered. You have five options: Super Fine,Very 
Fine, Fine, Medium and Coarse.
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Rho Used in defining a conic object, it is the ratio of the 
center point - shoulder point distance and the cen-
ter point - slope control point.

Right-hand rule A memory aid for the relative directions of the pos-
itive axes. With your right palm upturned, the 
thumb (X) points right, the index finger (Y) points 
straight ahead and the middle finger (Z) points up. 
If you move your hand to indicate the X and Y 
axes, you can easily see the direction of the Z axis.

SAT A file format for ACIS based programs.

Section View A view created by making a section cut through 
your geometry displayed in a drawing view.

Selection Fence A bounding box that temporarily appears as you 
drag the Selection tool cursor around an area in 
your drawing.

Setback The distance that a blend extends from three or 
more intersecting edges.

Short Cuts Key combinations for performing Designer Ele-
ments program operations, allowing you to cus-
tomize your program.

Shelled Solid A hollowed out solid object.

Shoulder control point A point used in defining a conic.

Silhouette A view of the object from the visible edges only. 
Silhouette edges are view dependent and can 
cause a significant reduction in drawing speed.

Simplify This option available in the Stitched Solid tool asks 
Designer Elements program to determine whether 
the solid can be defined by analytic surfaces, for 
which ACIS is optimized, rather than nurb surfaces.

Skin Surface Nurb patches fitted over a collection of curve 
cross-sections.

Slab A solid primitive created from three or more 
points, a height and draft angle.



Slope The change of x relative to y between two points 
on a line. In a spline, slope defines the vector of a 
line tangent to the spline at a particular knot point.

Slope control point A point used in defining a conic.

Smart Polygon A true polygon that is one object with length and 
width. This can be contrasted with a single line 
polygon composed of individual lines.

Smart Silhouette A silhouette that displays only if it does not 
degrade the performance of this Designer Elements 
program.

Snap The command allows you to set the specifications 
for the Drafting Assistant.

Sphere Trackball The standard trackball that allows you to rotate the 
view by dragging the cursor on the sphere.

Spline A smooth, free-form curve passing through speci-
fied points.

Spot Light This light emits a cone of light from a local source.

Static Render This render option defines how your geometry will 
display when the view is stationary.

Status Line The line at the bottom of the drawing area in 
which you can enter the specifications for the 
geometry you are creating.

Stencil An image that defines the regions through which 
artwork projects onto an object.

Step Trackball The trackball that allows you to rotate the view by 
clicking on a directional arrow.

Stitched Solid This is a solid created from joining surfaces 
together.

STL The file format creates stereolithography files.

Subtract Solid This solid is subtracted from another to create a 
final solid.
I-19



Glossary

I-20
Sweep Refers to the extrusion of a profile to a surface or 
solid.

Surface Non Uniform Rational B-Splines created for speci-
fied boundaries.

Surface Deviation Referring to the conversion of a surface or solid to 
a mesh, this sets the maximum acceptable distance 
between the facet and the surface represented by 
the mesh.

Symbol Objects that are created in the Symbol Manager are 
Master Symbols and can be instanced into the 
drawing at multiple locations.

Tangent The point where a line or curve touches a curve 
without intersecting it. The Drafting Assistant dis-
plays the tangent notation of a curve when the 
pointer nears it.

Taper Solid This is a solid created with draft angles or tapers.

Termination Type This defines the protrusion type used to create a 
feature on a solid.

3DMF The file format of QuickDraw 3D.

Tiling Breaks up a drawing into a multiple pages to print 
large drawings.

Tilt A vertical camera movement used when creating 
movies.

Torus A solid primitive generated by the revolution of a 
conic section, like a circle.

Transparency The amount that light can pass through a material.

Triad This illustrates the orientation of the x, y and z axis 
and the current work plane.

Toggle To switch between two conditions, for example, 
Hide Grid/Show Grid.

Transformation The tools to move, rotate, expand, shrink, or mir-
ror an object or group of entities.



Trim To shorten or remove a portion of a line.

Tube Surface A surface created in the shape of a tube.

Twist Angle The angle you want your solid to twist when 
sweeping a profile to a solid.

Unclamped Linear Light intensity that diminishes according to the fol-
lowing formula, Intensity/distance.

Unclamped Quadratic Light intensity that diminishes according to the fol-

lowing formula, Intensity/distance2.

Undo The command that reverses the last editing or cre-
ation action. You can undo an infinite number of 
actions in a specific Designer Elements program 
session.

Uniform Scaling Scales an object equally in all directions.

Units Measures used for construction (U.S. or metric).

Vector Splines The slope, shape, control points and control point 
influence can be modified for splines of this type.

Verify A menu listing commands for determining proper-
ties of selected objects.

Vertex The point at which the sides of an angle intersect 
or a knot point of a spline.

View Rotation Options This dialog box allows you to specify trackball 
rotation parameters.

VRML A file format for exporting virtual reality modeling 
language files.

Wrap The mode that artwork projects onto an object, 
planar, cylindrical or spherical when applying a 
decal.

Wireframe A 3-dimensional representation showing boundary 
lines, edges and intersections, but not surfaces.

World plane The work plane used at the beginning of the con-
struction of a model. Also known as the world 
coordinate system. 
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Work plane The x,y plane used for 2D objects which has an 
origin of 0,0,0 for all data input. Sometimes 
referred to as the user or work coordinate system.

Zoom The tool or command that allows you to magnify 
or reduce an image.



Symbols
% point  3-7, 6-8

Numerics
1 point

block primitive  18-6
cone primitive  18-12
cylinder primitive  18-9
prism primitive  18-18
pyramid primitive  18-21
rotate  25-3
sphere primitive  18-2
symbol  29-5
torus primitive  18-15

2 points
block primitive  18-7
center ellipse  11-2
cone primitive  18-13
conic  11-7
cylinder primitive  18-10
mirror  25-9
prism primitive  18-19
pyramid primitive  18-22
section view  36-20
sphere primitive  18-3
symbol  29-5
torus primitive  18-16

2-entity
chamfer  20-3
fillet  20-2

3 points
arc  10-3
center ellipse  11-4
circle  10-7
conic  11-8
mirror  25-11
rotate  25-5
work plane command  32-7

3-Corner Ellipse tool  11-5
3-Entity Fillet tool  20-3
4-Point Conic tool  11-9

A
ACIS SAT

export  35-18
import  35-8

add
boolean surface  21-9
union solid  23-2

Add Spline Control Point tool  13-9
Adobe Illustrator

export  35-21
import  35-8

advanced options
blend  22-2
chamfer  22-23

align  24-10
assembly  23-45
drawing view  36-11

Align Objects tool  25-19
alignment angles  3-7, 6-8
along curve

Bend solid  22-49
ambient lighting  33-9
ambiguity popup  4-6, 6-15
analysis

surface  21-22
analysis (surface)  21-23, 21-34
Angle 3 Pts command  24-40
angles (construction line)  3-11
angular

chamfer  20-4
dimension  27-15

Angular Dimension tool  27-20
animation  33-56

Fly By  33-62
Paths  33-63
VR Object  33-65
VR Panoramic  33-68
Walk Through  33-60

ANSI dimension standard  27-30, 27-31
anti-alias  33-51
Apply button  2-18
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Arbitrary Polygon tool  12-9
show frame  12-9

Arc tools  10-2
3-Point  10-3
Center-Point  10-2
Tangent-Point  10-5

Architecture dimension standard  27-30, 
27-32

Area command  24-42
area render  33-54
arrange

command  24-9
icons  30-18

arrays. See duplicate
arrow key (nudge distance)  6-12
arrowheads

dimension  27-27
pen  5-15

aspect ratio (mesh)  24-18, 24-21
Assembly Modeling tools  23-42

align  23-45
Connect  23-42
Insert  23-46
Mate  23-44
palette  23-42

associativity
dimension  27-2
features  22-1
parent/child  1-3
solid  17-6
surfaces  14-5

asterisks  2-18
attribute (shader)  33-40
Attributes and Bill of Materials  38-1

Apply To Selected  38-2
Area  38-2
Area 2D  38-2
Create Balloons  38-3
Create BOM  38-2
Export BOM  38-3
Mass Properties  38-2
Material  38-2

Perimeter  38-2
Price  38-2
Standard  38-2
Stock Size  38-2
Update BOM  38-3
User Defined Templates  38-4
Vendor No.  38-2
Volume  38-2
Weight  38-2

auto
decal wrap  33-29
hatch  36-10
heal bodies  35-3
layers  21-2
save  6-10

Auxiliary View tool  36-16
Axis

Bend solid  22-47
axis  2-2, 2-10

show/hide  7-14
azimuth (view)  30-9

B
backgrounds

applying  33-35
drawing window color  6-3
editing  33-47
library  33-21, 33-34
settings  33-48
types  33-48

backup files  34-6
Balloon Dimension tools  27-16
base line dimension

horizontal  27-8
vertical  27-10

Basic Rendering  33-13
bend (deform face)  23-35
Bend Solid Tool  22-46
Bend Solid tool

Along Axis  22-47
Along Curve  22-49
Center  22-48



Bezier Spline tool  13-6
blend (constant)

disjoint  22-12
edge to face roll  22-15
elliptical  22-7
mitered  22-10
multi-radius  22-10
radial  22-6
shared edges  22-11
vertex  22-9, 22-12

blend (variable)
by position  22-17
fixed width  22-20
hold line  22-21
law curve  22-18
linear  22-16

blend options (advanced)
chain select edges  22-3
cross section  22-4
feature interaction  22-3

Blend tools
Constant  22-6, 22-22
param  22-18, 22-34
Variable  22-16

Block Primitive tools  18-6
1 Point  18-6
2 Point  18-7
Diagonals  18-7

BOM User Defined Templates  38-4
Area  38-4
CG-X  38-4
CG-Y  38-4
CG-Z  38-4
Float  38-4
Index  38-4
Integer  38-4
Material  38-4
Name  38-4
Perimeter  38-4
Qty  38-4
String  38-4
Sum  38-4

Volume  38-4
Weight  38-4

Boolean Solid tools  23-2
Intersect  23-4
Subtract  23-3
union  23-2

Boolean Surface tools
add  21-9
Intersect  21-10
Subtract  21-9

Boss Feature tool  22-41
direction  22-41

branch (Design Explorer)
collapse  24-38
expand  24-38

bulge factor (lofted solid)  23-11
by position blend  22-17
by position variable chamfer  22-33

C
C2 continuous splines  13-6
camera (movie)  33-58, 33-67, 33-69
case (text)  26-6
Catia v4

export  35-21
Center

Bend solid  22-48
center

center mark dimension  27-16
Drafting Assistant snap  3-2
Drawing View command  36-12

center of gravity  24-44
Center/Axis Rectangle tool  12-4
Center/Corner Rectangle tool  12-2
center-point

arc  10-2
circle  10-5

CGM  35-18
chain (selection)  4-11
chain dimension

horizontal  27-9
vertical  27-11
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chain select edges blend  22-11
option  22-3

chain select edges chamfer  22-23
chamfer (constant)

length  22-25
length angle  22-27
mitered  22-29
two lengths  22-26
vertex  22-28

chamfer (variable)
by position  22-33
fixed width  22-34
four lengths  22-31
lengths  22-30
lengths angles  22-32

Chamfer Edge tools
Variable  22-30

chamfer options (advanced)
chain select edges  22-23
feature interaction  22-23

Chamfer tools  20-2
2-Entity  20-3
Angular  20-4

change
curves to lines  24-14
curves to splines  24-15, 24-16
dimension to lines  24-23
direction  24-12
drawing view  36-12
layer  24-6
object type  24-13
preferences  6-16
resolution  24-5
solid to curves  24-20
solid to mesh  24-21
solid to surfaces  24-21
solids to solids  24-23
surface to curves  24-16
surface to mesh  24-17
surface to surfaces  24-17
text to curves  24-16

check box  2-17

Check Object command  24-48
Circle tools  10-5

3-Point  10-7
Center-Point  10-5
Opposite-Point  10-7
Tangent-Point  10-7

Circumscribed Polygon tool  12-7
scribe type  12-8
show frame  12-8

clipboard  24-3
Close  19-19
close file  34-7
collapse (Design Explorer)

branch  24-38
item  24-38

color
ambient light  33-10
background  6-3
current pen  5-4
custom  5-5, 5-9
default dimension  6-17
default pen  6-17
define  5-4
dimension  27-25
fill  28-1, 28-5
foreground  6-3
grid  6-14
layer  31-4, 31-10
lighting  33-12
name  5-6, 5-9
palette  5-4
pen  5-4
preferences  6-3
selection  4-3
shader class  33-42
texture shader  33-42

compact files  6-9
compressor (movie)  33-59
Cone Primitive tools  18-12

1 Point  18-12
2 Point  18-13
Diagonal  18-14



Conic tools  11-6
2-Point  11-7
3-Point  11-8
4-Point  11-9
rho  11-7
shoulder point  11-7
slope control point  11-7

Connect Assembly tool  23-42
Connect Curve tool

Join  20-11
move curve point  20-10

Connect Surface tool  21-10
Connected Lines tool  9-3
constant blend

chain select shared edges  22-11
disjoint  22-12
edge to face roll  22-15
elliptical  22-7
extrapolation  22-15
mitered  22-10
multi-radius  22-10
one edge vertex  22-12
radial  22-6
two edge vertex  22-12
vertex  22-9
with cutouts  22-15

Constant Blend tool  22-6, 22-22
constant chamfer

length  22-25
length angle  22-27
mitered  22-29
two lengths  22-26
vertex  22-28

construction geometry  3-12
construction line

angles  3-9, 3-11
construction command  3-11
delete  3-13
Drafting Assistant  3-7
offset  3-11
parallel  3-12
pattern  5-15

permanent  3-9
control points

adding to spline  13-9
remove from spline  13-10
selecting  4-8
show  4-7
slope  11-7
spline  13-3, 13-4

control vertex modification  21-21
insert knot  21-20

convert
files (see export)
objects (see change object type)
text to curves  24-16

coordinate system  2-3
choosing  7-7
global  7-7
user-defined  7-7

Coordinate System Axis  2-10
copy

along path  25-11
bitmap  24-2
command  24-2
object characteristics  4-11
objects  25-22
objects/layer  31-11
pict  24-2
Status Line entries  2-9, 7-4

Corner Trim tool  20-9
count (layer objects)  31-4
Counter Bore tool  22-39
Counter Sink tool  22-40
Cover Surface tool  16-19

n-sided  16-19
Crayon Picker  5-7
cross section (blend)  22-4
crosshatching  28-6

auto hatch  36-10
command  28-9
DIN patterns  28-8
edit  28-10
ISO patterns  28-7
i-5



i-6
patterns  28-6
section cuts  28-11
section views  36-21

curvature plot  21-24
curve check

protruded feature  19-16
solid profiles  19-19

Curve Utility tools  20-12
Explode Edge  20-22
Extrude Curve  20-22
Offset Curve  20-12
Project Curve  20-17
Revolve Curve  20-17

Curve/Surface Intersection tool  21-7
Curve/Surface Projection tool  21-5
custom colors  5-5, 5-9
cut

command  24-1
solids  17-8
surface  14-5

Cutout Feature tool  19-13
Cylinder Primitive tools  18-9

1 Point  18-9
2 Point  18-10
Diagonals  18-11

cylindrical wrap (decals)  33-27
CYMK Picker  5-7

D
dcm

fixed constraint
preferences  6-4

fully defined constraint
preferences  6-4

over defined
preferences  6-4

over defined constraint
preferences  6-4

preferences  6-4
under defined constraint

preferences  6-4

DCM Animation Settings  38-13
Delay  38-13
End  38-13
Loop  38-13
Rebound  38-13
Running the Animation  38-14
Start  38-13
Steps  38-13

decals  33-22, 33-26
applying  33-28
auto wrap  33-29
creating  33-36
cylindrical wrap  33-27
images  33-33, 33-36
lock normal  33-30
masking  33-30
planar wrap  33-26
reflectance  33-45
rotation  33-29
shader  33-43
spherical wrap  33-28
stencil  33-31
user-defined  33-37

decimal places  2-9
decrement layer  31-10
default layers  31-5
define

color  5-4
defining spline point  13-4
work plane  32-4

definitions  I-1
Deform Face tool

bend  23-35
boundary tangents  23-35
gain  23-32
resolution  23-35
stretch  23-35
to curve  23-34
to point  23-32

degree (elevate surface)  21-21
delete

construction lines  3-13



drawing view  36-11
geometry  24-3
layer  31-5, 31-7
lighting  33-13
view  30-12
work plane  32-5

deselecting  4-11
Design Explorer  24-32

change item name  24-33
close window  24-38
collapse branch  24-38
collapse item  24-38
edit parameter  24-38
expand branch  24-38
expand item  24-38
move feature  24-37
remove feature  24-38
reorder feature  24-36
suppress feature  24-35
unsuppress feature  24-33, 24-36

Designer Elements window  2-1
axis  2-2, 2-10
coordinate system axis  2-3, 2-10
drawing area  2-2, 2-11
location indicator  2-2, 2-8
memory indicator  2-3, 2-12
menu bar  2-2, 2-12
Message Line  2-2, 2-8, 7-8
pointer  2-2
scroll bars  2-3, 2-11
Status Line  2-3, 2-8, 7-2
title bar  2-2, 2-3
tool palette  2-2
tool tip  2-2
Triad  2-2, 2-10
work layer indicator  2-3, 2-12

Detail View tool  36-22
diagonal primitive

block  18-7
cone  18-14
cylinder  18-11
prism  18-20

pyramid  18-23
sphere  18-3
torus  18-17

Diagonal Rectangle tool  12-3
dialog box  2-16

Apply button  2-18
asterisks  2-18
check box  2-17
list/entry box  2-17
Option button  2-17

Diameter Arrow Dimension tool
In  27-14
Out  27-14

dimension
angular appearance  27-22
arrowheads  27-27
associative  27-2
color  27-25
default settings  6-17
drawing view  27-33, 36-5
edit objects  27-5
font  27-24
layer  27-5, 27-26
linear appearance  27-20
menu  2-13, 27-1, 27-32
move  27-4
offset  27-30
palette  27-3
size  27-24
standards  27-29
style  27-25
text  27-23
tolerances  27-20, 27-21
units  27-6
weight  27-26
witness lines  27-29
work plane  27-3

dimension standard
ANSI  27-30, 27-31
Architecture  27-30, 27-32
choosing  27-32
creating  27-32
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DIN  27-30, 27-31
Dual side  27-30, 27-32
Dual stacked  27-30, 27-32
ISO  27-30, 27-31
JIS  27-30, 27-31
Stacked fraction  27-30, 27-32

Dimension tools
Angular  27-15, 27-20
Balloon  27-16
Center Mark  27-16
Diameter  27-14
Horizontal  27-7, 27-20
Oblique  27-11, 27-20
Radial  27-13
Smart  27-20
Vertical  27-9, 27-20

DIN crosshatching  28-8
DIN dimension standard  27-30, 27-31
direction

change  24-12
disjoint blend  22-12

edge to face  22-13
face to face  22-13

displacement
see also roughness
shader  33-43
wrapped  33-44

display
edit objects  24-26
isolines  6-6
preferences  6-5
resolution  6-5
silhouette  6-6

Display Last Image command  33-56
Distance Pt-Pt command  24-40
Distant Light tool  33-2
Divide at Location tool  20-10
Divide tool  20-8
documentation  1-1

margin notes  1-1
style conventions  1-2

draft angle

extrude solid  19-8
lathed solid  19-2

draft angle analysis  21-30
draft angle evaluation

advanced rendering  23-40
Verify menu  23-37

draft face
local face modeling  23-17

Draft Surface tool  16-32
draft. See also taper
Drafting Assistant  3-1

% point  3-7, 6-8
alignment angles  3-7, 6-8
axis locking  3-4
construction lines  3-7
creation angles  3-7, 6-8
customizing  3-4
hit radius  3-6, 6-7
permanent construction lines  3-9
preferences  3-6, 6-7
Snap command  3-4
snap options  3-4
snap points  3-2
snapping to geometry  3-2
solid  17-4

drawing
area  2-2, 2-11
Drafting Assistant  3-1
full scale  7-15
object creation methods  7-1
Status Line  7-2
techniques  7-1

drawing composition  36-1
drawing view  36-4
layouts  36-29
Model to Sheet command  36-2
Sheet tools  36-29
unfold views  36-25, 36-29

drawing size
format  37-7
page breaks  37-13
page tiling  37-7



scale  37-8
short cut  37-15

drawing view  36-4
activating  36-5
align  36-11
center  36-12
change  36-12
delete  36-11
dimension  27-33
edit objects  36-25
edit view  36-27
flatten view  36-14
frame to extents  36-13
menu  36-6
properties  36-6
right mouse button  7-20
scale  24-27, 36-5
tool  36-15

Dual side dimension standard  27-30, 
27-32

Dual stacked dimension 
standard  27-30, 27-32

duplicate
linear  25-13
polar  25-16

DWG
entities  C-1
export  35-14
import  35-4

DXF
entities  C-1
export  35-15
facet files  35-6
import  35-5

dynamic
Pan tool  30-3
render  33-14
Rotate tool  30-14
Zoom tool  30-4

E
edge

color  6-7
tolerant (stitched solid)  23-8

edge to face blend  22-13
edge to face roll blend  22-15
edit

background shader  33-47
crosshatching  28-10
drawing view  36-27
drawing view objects  36-25
foreground shader  33-47
lights  33-11
menu  2-13
parameter  24-38
pattern  5-13
render material  33-38
symbols  29-4, 29-8
text  26-7

edit objects
attributes  24-26
command  24-24
dimension  27-5
display  24-26
entering values  24-25
geometry  24-25
selecting  4-5

editing commands  24-1
Editing tools

Chamfer  20-2
Divide at Location  20-10
general  20-1
Join  20-11
solid  17-3
surface  21-1
trim  20-5

Elevate Curve tool  13-14
elevate degree (surface)  21-21
elevation (view)  30-9
Ellipse tools  11-2

2-Point Center  11-2
3-Corner  11-5
3-Point Center  11-4
modify ellipse  11-6
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Opposite-Corner  11-3
Ellipsoid Primitive tool  18-24

1 Point  18-24
2 Point  18-25
By diagonals  18-25

elliptical blend  22-7
endpoint  3-2
entire object extents (selection)  4-3
EPS export  35-18
erase geometry  24-3
escape key  7-16
evaluation

surface  21-22, 21-23, 21-34
exit  34-7
expand (Design Explorer)

branch  24-38
item  24-38

Expand/Shrink tool
differential  25-6
uniform  25-6

Explode Edge tool  20-22
export  35-12

ACIS SAT  35-18
Adobe Illustrator  35-21
Catia v4  35-21
CGM  35-18
command  35-22
DWG  35-14
DXF  35-15
end of line  35-12
EPS  35-18
Facet  35-18
Graphite/Vellum 3D  35-13
IGES  35-18
Macromedia  35-22
options  35-12
pict  35-22
ProE/Granite  35-21
Raw  35-21
solids  17-9
STL  35-18
surfaces  14-6

tips  35-22
type  35-12
Vellum Draft  35-14
Vellum Solids  35-13
ViewPoint Media  35-22
VRML  35-20

expression parsing  2-10
extrude

curve  20-22
mesh  15-5
solid  19-4

Eye Dropper tool  4-11

F
face

draft  23-17
match  23-19
move  23-21
offset  23-23
remove  23-24
replace  23-25
solids  17-1

face to face blend  22-13
facet

export  35-18
import  35-8

Fair Spline tool  13-15
feature

move  24-37
remove  24-38
reorder  24-36
suppress  24-35
unsuppress  24-33, 24-36

feature interaction
blend  22-3
chamfer  22-23

Feature tools  17-3
associative  22-1
Blends  22-2
Boss  22-41
Cutout  19-13
Holes  22-36



Protruded  19-14
file  35-9

auto save  6-10, 34-6
backup  34-6
close  34-7
compact  6-9
exit  34-7
lock  34-7
management  34-1
name  34-4
native picture formats  6-9
new  34-3
open  34-3
preferences  6-9, 34-7
progress bar  7-16
recent list  6-10, 34-4
revert  34-7
save  34-5
short cuts  34-2
size  34-8

fill
color  28-1, 28-5
holes  28-4
overlapping objects  28-4
pattern  28-1

Fillet Surface tool  16-34
Fillet tools

2-Entity  20-2
3-Entity  20-3

fixed width
variable blend  22-20
variable chamfer  22-34

flat render  33-15
flatten view  36-14
flip normals  33-16
Fly By animation  33-62
font  26-5

dimension  27-24
plotter  37-16

font (default)  6-17
foregrounds

applying  33-35

color  6-3
editing  33-47
library  33-22, 33-35
settings  33-49
types  33-49

format
drawing composition  36-29
drawing size  37-7

four lengths variable chamfer  22-31
Frame to Extents command  36-13
front view  30-6
full scale  7-15

G
G1 surface  21-14
G2 surface  21-16
gain (deform face)  23-32, 23-35
Gaussian plot  21-26
global

coordinate system  7-7
work plane  7-8

Glossary  I-1
Gouraud render  33-15
Graphite/Vellum 3D

export  35-13
grid

color  6-14
preferences  6-12
Show command  2-11
Snap command  2-11, 7-14
spacing  6-12

group
command  24-7
objects  24-7
selection  24-8

H
Hatch command  28-10
he  23-17
Helix Curve

creating a helix  13-8
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Helix Curve Tool  13-4
Helix Curve tool  13-8

pitch  13-8
hidden

lines  36-3, 36-7
render  33-16

hide
axis  7-14
command  30-15
layer  31-7
points  7-14
Triad  7-14
work plane  7-14

histogram  21-24
hit radius  3-6, 6-7
hold line blend  22-21
Hole Feature tools  22-36

Counter Bore  22-39
Counter Sink  22-40
direction  22-37
Simple  22-38
Through Types  22-36

Horizontal Dimension tools  27-7
Base Line  27-8
Chain  27-9
Horizontal  27-20
Ordinate  27-12

Horizontal Section View tool  36-19
Horizontal Text tool  26-1
hot spot  2-7
HPGL  37-16
HSL Picker  5-7
HSV Picker  5-7
HTML Picker  5-7
hue  5-5

I
IGES

entities  D-1
export  35-18
import  35-6

image (shader)  33-43, 33-44, 33-45

import  35-1
ACIS SAT  35-8
Adobe Illustrator  35-8
auto heal bodies  35-3
command  35-9
DWG  35-4
DXF  35-5
facet  35-8
IGES  35-6
options  35-2
pict  35-8
spline points  35-9
symbols  29-9
tips  35-11
type  35-2
Vellum 3D  35-3
Vellum Solids  35-2

increment layer  31-10
inertia (moment of)  24-44
Infinite Plane tool  16-2

3 Pts In Plane  16-4
Along Curve  16-4
Clipping Planes  16-6
Normal Location  16-4
X, Y, Z Station  16-3

influence (spline)  13-6
Inscribed Polygon tool  12-6

scribe type  12-7
show frame  12-7

insert knot  21-20
Insert tool (assembly)  23-46
instance  1-3

solid  17-6
intensity (lighting)  33-3
Interference command  24-45
intersect

curve/solid  21-8
curve/surface  21-8
Drafting Assistant  3-3
plane/curve  21-3
plane/solid  21-4
plane/surface  21-4



solids  23-4
surface/solid  21-7
surface/surface  21-7
surfaces  21-10

Invert command  30-15
ISO crosshatching  28-7
ISO dimension standard  27-30, 27-31
isolines  6-6, 24-5
isometric view  30-7
isopram lines  6-6, 24-5
item (Design Explorer)

collapse  24-38
expand  24-38

J
JIS dimension standard  27-30, 27-31
Join tool  20-11

K
key

arrow nudge distance  6-12
escape  7-16
short cut  6-17, 6-19

L
Lathed Solid tool  19-2
law curve blend  22-18
layer  31-1

auto  21-2
change  24-6
color  31-4, 31-10
copying/pasting  31-11
creating  31-6
decrement  31-10
default  31-5
delete  31-5, 31-7
dimension  27-5, 27-26
hide  31-7
increment  31-10
isolate  31-6, 31-9
lock  31-3, 31-8

manager  31-2
new  31-4
rename  31-5, 31-7
show  31-8
unlock  31-8
work  31-3, 31-9

layout  36-2
creating  36-30
lighting  33-13
menu  2-13
modify  36-30
printing  36-31
templates  36-29

length angle constant chamfer  22-27
Length command  24-41
lengths angles variable chamfer  22-32
library

Backgrounds  33-21, 33-34
Decals  33-22, 33-26
Foregrounds  33-22, 33-35
Materials  33-22
Render  33-21

Light tools
Distant  33-2
Point  33-8
Spot  33-4

lighting  33-1
ambient  33-9
attenuation  33-5
color  33-10, 33-12
delete  33-13
directional  33-2
edit  33-11
enable  33-3
intensity  33-3
layouts  33-13
modify  33-10
move  33-11
palette  33-2
render  33-20
shadows  33-3, 33-5, 33-8

LightWorks  33-20
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Line Pattern manager  5-12
Line tools  9-1

Connected Lines  9-3
Parallel Line  9-5
Point  9-5
Single Line  9-2

linear blend  22-16
linear duplicate  25-13
lines (modifying)  9-8
links  24-30

remove  24-31, 24-32
list/entry box  2-17
Local Face Modeling tool

draft  23-17
match face  23-19
Modifying Taper  23-23
move face  23-21
offset face  23-23
remove face  23-24
replace face  23-25

Local Face Modeling tools  23-16
Local Surface Tools

elevate degree  21-21
insert knot  21-20
untrim  21-21

Local Surface tools  21-14
Match Surface  21-14
Rebuild Surface  21-17

localization (preferences)  6-14
location indicator  2-2, 2-8
lock

files  34-7
layer  31-3, 31-8
normal (decals)  33-30
objects  24-9

Lofted  16-30
Lofted Solid tool  23-11

bulge factor  23-11
error  23-12

Lofted Surface tool  16-30
Lop Solid tool  23-14
luminance  5-5

M
Macintosh

color  5-7
page setup  37-15

Macromedia
export  35-22

Major/Minor Axis Rectangle tool  12-5
margin notes  1-1
masking (decals)  33-30
match face  23-19
Match Surface tool  21-14

G1 slope  21-14
G2 slope  21-16

Mate tool (assembly)  23-44
material

crosshatching  28-8
Properties command  24-43
Render library  33-22
user-defined  33-36

material editing  33-38
mathematical operators  A-1
memory indicator  2-3, 2-12
menu  1-1

choosing commands  1-1, 2-14
dimension  2-13
displaying  2-14
drawing view  36-6
Edit  2-13
Layout  2-13
Pen  2-13
PhotoRender  2-13
Planes  2-13
submenu  2-16
Text  2-13
toggling commands  2-18
Trackball  7-13
Verify  2-13
View  2-13
Window  2-13

menu bar  2-2
mesh



aspect ratio  24-18, 24-21
count  24-19, 24-22
normal deviation  24-19, 24-22
smoothing  24-19, 24-22
surface deviation  24-18, 24-22

Mesh tools
3 Pts  15-2
4 Pts  15-3
Curve  15-4
extrude  15-5
rendering  15-6
spacing  15-4

Message Line  2-2, 2-8, 7-8
method

drawing composition  36-3
midpoint  3-2
Minimum Distance command  24-41
Mirror tool  25-8

2 Pts  25-9
3 Pts  25-11
XY plane  25-9
ZX plane  25-10
ZY plane  25-10

mitered blend  22-10
mitered constant chamfer  22-29
Model to Sheet command  36-2

layouts  36-2
undoing  36-4

modeling
solid  17-1
surface  14-1
wireframe  8-1

Modify Slope tool  13-11
explicit  13-11
free  13-11
reference  13-11
reverse  13-11

modifying
ellipses  11-6
layout  36-30
lighting  33-10
lines  9-8

parting line solid  23-29
shell solid  22-44
tapered solid  23-23
view  30-11

moment of inertia  24-44
mouse  1-4

arrow pointer  1-4
click  1-4
double-click  1-4
drag  1-4
pointer  1-4
right button  7-16
selection arrow  1-4
smart pointer  2-7

Move  23-22
move

dimension  27-4
face  23-21
feature  24-37
light  33-11
objects  25-20
origin  32-10
text  26-7
tools  25-2

movie
Fly By  33-62
Paths  33-63
VR Object  33-65
VR Panoramic  33-68
Walk Through  33-60

multi-radius blend  22-10

N
n# sections  16-14
normal deviation (mesh)  24-19, 24-22
normals plot  21-31
n-sided  16-19
nurb splines  13-1

O
Object Counts command  24-48
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i-16
object type (preferences)  6-5
objects  30-16

align  24-10
area  24-42
arrange  24-9
change type  24-13
check  24-48
copy  25-22
count  24-48, 31-4
crosshatching  28-10
dimensions  27-4
direction  24-12
drawing view  36-25
edit  24-24
group  24-7
hide  30-15
interference  24-45
length  24-41
lock  24-9
move  25-20
properties  24-43
selecting  4-1
show  30-15
show All  30-15
sizing  25-24
transparency  33-51
ungroup  24-9
unlock  24-9
volume  24-42

Oblique Dimension tool  27-11, 27-20
offset

construction lines  3-11
curve  20-12
dimension  27-30
linear duplicate  25-13
shell solid  22-45
solid face  23-23
Surface tool  16-28
work plane  32-10

Offset Curve tool
by point  20-15
to value  20-13

one edge vertex blend  22-12
open file  34-3
Opposite-Corner Ellipse tool  11-3
Opposite-Point Circle tool  10-7
Option button  2-17
ordinate dimension

horizontal  27-12
orientation (blend)  22-4
origin

move  32-10
set  32-10

P
page breaks (drawing)  37-13
page setup  37-1
page tiling  37-7
palette  2-2

Assembly Modeling  23-42
Color  5-4
Dimension  27-1
floating  2-5
Lighting  33-2
Render library  33-21
selecting a tool  2-5
Sheet tools  36-29
Solid  17-2
subpalette  2-5
Surface  14-2
Symbols  29-2
tear away  2-6
Wireframe  2-5

pan
view  30-5

pan (movie)  33-66, 33-69
Parallel Dimension tool

see Oblique Dimension tool
Parallel Line tool  9-5
param (blend)  22-18
param (chamfer)  22-34
Parametric Constraints  38-5

Sketch Mode  38-5
Sketch Mode Exiting  38-6



parent/child  1-3
partial objects extents (selection)  4-3
Parting Line Solid tool  23-27

modifying  23-29
pull-direction  23-27
taper (draft)  23-28

paste
command  24-3
objects/layer  31-11
solids  17-8
Status Line entries  2-9, 7-4
surfaces  14-5

Paths animation  33-63
pattern

choosing pen  5-14
construction line  5-15
creating  5-13
crosshatching  28-6
DIN crosshatching  28-8
editing  5-13
fill  28-1
ISO crosshatching  28-7
manager  5-12
new  5-13
pen  5-11

pen
arrowheads  5-15
characteristics  5-2
color  5-4
default settings  6-17
menu  2-13
pattern  5-11
pattern manager  5-12
settings  5-1
style  5-2
weight  5-10

permanent construction lines  3-9
perpendicular  3-3
perspective render  33-69
photorealistic

commands  33-52
rendering  33-49

settings  33-50
pick box  4-3, 6-15
Pick Objects command (plane)  32-8
pict

export  35-22
import  35-8

pitch (helix)  13-8
pixels (pen weight)  5-10
planar wrap (decals)  33-26
plane  32-1

3 Pt  32-7
pick objects  32-8
views  30-18
work  32-2

plane (work)  7-8
Plane/Surface Intersection tool  16-5, 

21-2
Planes menu  2-13
Plotter fonts  37-16
point operations

selectable points  4-8
selecting  4-7
show/hide  4-7, 7-14

Point tools  9-5
Along a Curve  9-6
Along a Surface  9-7
At XYZ Location  9-6
Light  33-8
marker  9-6

pointer  1-4, 2-2
location indicator  2-8
smart  2-7
solids  21-2

polar duplicate  25-16
Polygon from Curves tool  12-10

show frame  12-11
Polygon tools

Arbitrary  12-9
Circumscribed  12-7
Inscribed  12-6
Polygon from Curves  12-10
Rectangle  12-2
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Single Line  12-1
Smart Polygon  12-1

PostScript  37-16
pre-defined views  30-6
preferences  6-1

changing settings  6-16
color  6-3
command  6-16
dcm  6-4

fixed constraint  6-4

fully defined constraint  6-4

over defined  6-4

over defined constraint  6-4

under defined constraint  6-4
display  6-5
Drafting Assistant  3-6, 6-7
file  34-7
filing  6-9
general  6-11
grid  6-12
localization  6-14
object type  6-5
render  33-20
resolution  6-5
selection  4-2, 6-15
short cut  6-17
units  6-16
user interface  6-11
view definitions  6-12

preview sample (shader)  33-41
primitive (ellipsoid)  18-24
Primitive tools  17-3

Block  18-6
Cone  18-12
Cylinder  18-9
Prism  18-18
Pyramid  18-21
Slab  18-4
Sphere  18-2
Torus  18-15

print  37-1

boundaries  37-17
command  37-16
layout  36-31
region  37-16
render  37-18
setup  37-15
to file  37-16
Window command  37-18

Print Layout Command  37-2
Prism Primitive tools  18-18

1 Point  18-18
2 Point  18-19
Diagonals  18-20

ProE/Granite
export  35-21

Profile Solid tools
curve checks  19-19
extrude  19-4
Lathed  19-2
Skinned  19-17
Swept  19-10

Profile tools  17-3
project

curve  20-17
curve/solid  21-6
curve/surface  21-5

Project Curve tool
plane options  20-18
projection options  20-20

Properties command  24-43
center of gravity  24-44
density  24-44
material  24-43
moment of inertia  24-44
volume  24-44
weight  24-44

Properties command (planes)  32-5
Protruded Feature tool  19-14

curve check  19-16
termination types  19-14

pull-direction (parting line solid)  23-27
Pyramid Primitive tools  18-21



1 Point  18-21
2 Point  18-22
diagonals  18-23

Q
quadrant  3-3
QuickTime movie

compressor  33-59
Fly By  33-62
Paths  33-63
VR Object  33-65
VR Panoramic  33-68
Walk Through  33-60
with camera movement  33-57

R
Radial Arrow Dimension tool

In  27-13
Out  27-13

radial blend  22-6
ratio (elliptical blend)  22-7
Raw export  35-21
ray cube (background)  33-48
ray trace

commands  33-53
reflections  33-50
shader  33-44

Rebuild Surface tool  21-17
recent file list  6-10, 34-4
Rectangle tools  12-2

Center/Axis  12-4
Center/Corner  12-2
Diagonal  12-3
Major/Minor Axis  12-5

redo  24-4
redraw screen  30-14
reflectance shader  33-44

decals  33-45
ray trace  33-44
wrapped  33-45

reflectivity  24-27, 33-38

Relimit tool  20-6
remove

control point (spline)  13-10
face  23-24
feature  24-38
links  24-31, 24-32

rename
rename (Design Explorer)  24-33

render  33-1
anti-alias  33-51
applying materials  33-25
Backgrounds library  33-21, 33-34
basic  33-13
copying characteristics  4-11
Decals library  33-22
display last image  33-56
Eye Dropper tool  4-11
Foregrounds library  33-22, 33-35
image files  33-55
library  33-21
lighting  33-1, 33-20
LightWorks  33-20
Materials library  33-22
menu  2-13
mesh  15-6
perspective  33-69
photorealistic  33-49, 33-52
preferences  33-20
print  37-18
ray trace  33-50
reflectivity  24-27, 33-38
roughness  24-28, 33-38
shade options  33-14
shader  33-40
shadows  24-28, 33-39
textures  24-28, 33-39
to file  33-54
transparency  24-28, 33-38, 33-51

render area  33-54
render options

dynamic  33-14
flat  33-15
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flip normals  33-16
Gouraud  33-15
hidden  33-16
static  33-14
view rotations  33-19

reorder feature  24-36
replace face  23-25
resolution

change  24-5
deform face  23-35
isolines  24-5
preferences  6-5
silhouettes  24-6
solid  17-5
surface  14-4
wireframe  8-4

revert file  34-7
Revolve Curve tool  20-17
Revolved Surface tool

About a Curve  16-22
About Two Points  16-21

RGB Picker  5-7
rho (conic)  11-7
Rib Solid tool  23-13
right mouse button  7-16

drawing view  7-20
over an object  7-18
over no object  7-17

right-hand rule  2-11
rotate

decals  33-29
dynamic (view)  30-14
view  30-9, 30-12

Rotate tools  25-3
1 Pt  25-3
3 Pts  25-5

roughness
Edit Objects  24-28, 33-38
see also displacement

rules
Design Explorer  24-39
grouping  24-8

local face modeling  23-17
relimit  20-7
right-hand rule  2-11
sweep surface  16-27

S
SAT

export  35-18
import  35-8

saturation  5-5
save  34-5

auto  6-10, 34-6
save as  34-5

scale
differential  25-6
drawing size  37-8
drawing view  36-5
expand/shrink  25-6
full  7-15
ignore  24-27
ignore (drawing view)  36-5
material  24-28, 33-39
sheet  36-5
uniform  25-6

Scale tool  25-6
screen horizontal

text  26-7
scribe type

circumscribed polygon  12-8
inscribed polygon  12-7

scroll bars  2-3, 2-11
Section View tools  36-18

2 Pts  36-20
crosshatching  28-11, 36-21
Horizontal  36-19
Vertical  36-19

Segment tool  20-10
selection

ambiguity popup  4-6, 6-15
chain  4-11
color  4-3
control point  4-8



deselecting  4-11
edit objects  4-5
fence  4-3, 6-15
Group command  24-8
hollow arrow  21-2
objects  4-2, 4-4, 4-9
pick box  4-3
points  4-7
preferences  4-2, 6-15
select all  4-9
selection mask  4-10
tool  2-5, 4-4

set origin  32-10
shade now  33-14

command
render

shade now  33-14
Shade Options  33-14
shader

attribute value  33-41
attributes  33-40, G-1
backgrounds  33-48
class  33-40
foregrounds  33-49
preview sample  33-41
texture projection  33-46
types  33-40

shader class  33-40
color  33-42
displacement  33-43
reflectance  33-44
texture space  33-46
transparency  33-45

shader types  33-40
shadow casting (lighting)  33-3, 33-5, 

33-8
Sheet tools  36-29

Auxiliary View  36-16
Detail View  36-22
drawing view  36-15
Model to Sheet command  36-2

Section View  36-18
Shell Solid tool

modifying  22-44
short cut

creating  6-19
file  34-2
list  E-1
preferences  6-17
view rotation  7-13

short cut (tool tip)  6-17
shoulder point (conic)  11-7
show

axis  7-14
command  30-15
control point  4-7
Dimension palette  27-3
layers  31-8
points  7-14
Show All command  30-15
Show Only command  30-16
silhouettes  24-6
Triad  7-14
work plane  7-14, 32-3

show frame
arbitrary polygon  12-9
circumscribed polygon  12-8
inscribed polygon  12-7
polygon from curves  12-11

show work plane  32-6
side view  30-6
silhouettes  6-6, 24-6
Simple Hole tool  22-38
Simple Trim tool  20-6
Simplify object

change  24-23
edit  24-23

simplify object
command  24-23

simplify surfaces (stitched solid)  23-8
Single Line tool  9-2
size

dimension  27-24
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objects  25-24
text  26-5

Sketch Mode  38-5
Animating Dimensions Tool  38-12
Auto Constraints Tool  38-6
Coincident Constraint Tool  38-7
Colinear Constraint Tool  38-12
Concentric Constraint Tool  38-10
Constraint Preferences  38-14
Deleting Constraints  38-14
Equal Constraint Tool  38-11
Exiting  38-6
Fixed Constraint Tool  38-9
Horizontal Constraint Tool  38-6
Offset Constraint Tool  38-12
Parallel Constraint Tool  38-8
Perpendicular Constraint Tool  38-9
Sketch Tool  38-6
Symmetric Constraint Tool  38-11
Tangent Constraint Tool  38-8
Verifying Constraint 

Relations  38-14
Vertical Constraint Tool  38-6

sketch spline
creating a spline  13-7

Sketch Spline tool  13-7
Skin Solid tool

guides  19-18
Skin Surface tool

basic  16-16
closed skin  16-15
guides  16-17
n# sections  16-14
standard  16-14

Skinned Solid tool  19-17
basic  19-17

Slab Primitive tool  18-4
slope (conic)  11-7
smart

hot spot (pointer)  2-7
pointer  2-7
polygon  12-1

Smart Dimension tool  27-20
Snap command  3-4
solid

associativity  17-6
cutting/pasting  17-8
display edges  17-4
Drafting Assistant  17-4
exporting  17-9
instances  17-6
modeling  17-1
resolution  17-5
tools  17-2

Solid Editing tools
Assembly Modeling  23-42
Boolean  23-2
Chamfer Edge  22-22
Features  17-3, 22-1

solid modeling
Ellipsoid Primitive tool  18-24
error messages  17-10

Solid Utility tools  23-1
Intersect Solid  23-4
Lip Solid  23-14
Local Face Modeling Tools  23-16
Lofted Solid  23-11
Parting Line Solid  23-27
Rib Solid  23-13
Split Solid  23-7
Stitched  23-7
Subtract Solid  23-3
Thicken Solid  23-10
Union Solid  23-2

Solids Creation tools
Primitives  17-3, 18-1
Profiles  17-3, 19-1

special characters  B-1
Sphere Primitive tools  18-2

1 Point  18-2
2 Point  18-3
Diagonals  18-3

spherical wrap (decals)  33-28
spline



control point  13-3, 13-4
creating text files  F-1
import points  35-9

Spline tools  13-1
Add Control Point  13-9
Bezier  13-6
Elevate Curve  13-14
Fair Spline  13-15
Helix Curve  13-8
influence  13-6
Modify Slope  13-11
nurbs  13-1
Remove Control Point  13-10
Sketch Spline  13-7
Through-Points B-Spline  13-3
Vector  13-4

Split Solid tool  23-7
Spot Light tool  33-4

cone angle  33-6
falloff angle  33-6
falloff rate  33-7

Stacked fraction dimension 
standard  27-30, 27-32

static render  33-14
Status Line  2-3, 2-8, 7-2

copying/pasting entries  2-9, 7-4
expression parsing  2-10
units  7-3
world coordinate system  2-9

stencil (decal)  33-31
Stitched Solid tool  23-7

gap size  23-8
options  23-8
simplify surfaces  23-8
tolerant edges  23-8

STL export  35-18
stretch (deform face)  23-35
stroke construction lines  3-9
stroke zoom  30-4
style

dimension  27-25
pen  5-2

text  26-6
submenu  1-1, 2-16
subtract

solid  23-3
surface  21-9

suppress feature  24-35
surface

associativity  14-5
Creation tools  16-1
cutting/pasting  14-5
Editing tools  21-1
evaluation  21-22
exporting  14-6
Mesh tools  15-1
modeling  14-1
resolution  14-4
tools  14-2

surface analysis
advanced rendering  21-34
curvature plot  21-24
draft angle  21-30, 23-37
Gaussian  21-26
histogram  21-24
normals plot  21-31
Verify menu  21-23
zebra plot  21-33

Surface Creation tools
Cover Surface  16-19
Draft Surface  16-32
Fillet Surface  16-34
Infinite Plane  16-2
Lofted Surface  16-30
Offset Surface  16-28
Sweep Surface  16-23
Tube Surface  16-27

surface deviation (mesh)  24-18, 24-22
Surface Editing tools

Boolean Surface  21-9
Connect Surface  21-10
Curve/Surface Intersection  21-7
Curve/Surface Projection  21-5
Plane/Surface Intersection  21-2
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Split Surface  21-11
surface evaluation  21-22
Surface/Surface Intersection  21-6
untrim  21-21

Surface From Curves Tools  16-9
Net Surface Tool  16-9
Surface Tools  16-9

Surface from Curves Tools
Net Surface  16-9

Surface/Surface Intersection tool  21-6
Sweep Surface tool

Along 1 Rail  16-24
Along 2 Rails  16-25

Sweep Surface tool Along 2 
Points  16-23

Swept Solid tool  19-10
symbol  29-1

1 Point tool  29-5
2 Point tool  29-5
creating  29-3
edit  29-4, 29-8
files  29-9
importing  29-9
manager  29-2
palette  29-2
transforming  29-8

T
tangent  3-3
Tangent Surface tool

bulge factor  16-30
tangent-point

arc  10-5
circle  10-7

taper
parting line solid  23-28

text
case  26-6
convert to curves  24-16
default settings  6-17
dimension font  27-24
dimension size  27-24

dimension style  27-25
dimension text  27-23
drawing view  36-5
editing  26-7
font  26-5
menu  2-13
move  26-7
screen horizontal  26-7
size  26-5
style  26-6

Text tools  26-1
Along a curve  26-2
At an angle  26-3
box  26-4
Horizontal  26-1

texture (shader)  33-43
texture projection shader  33-46
texture space shader  33-46
textures  24-28, 33-39
Thicken Solid tool  23-10
Through-Points B-Spline tool  13-3
tile

files horizontally  30-17
files vertically  30-16
page  37-7

tilt (movie)  33-67
tips

exporting  35-22
import  35-11
tool  2-2

title bar  2-2
close box  2-4
Control Menu button  2-3
Maximize button  2-4
maximize/restore  2-4
WindowShade  2-4
zoom box  2-4

toggling commands  2-18
tolerances (dimension)  27-20, 27-21
tool tip  2-2

short cut  6-17
tools



Arc  10-1
Circle  10-1
Conic  11-1
Ellipse  11-1
Line  9-1
Mesh  15-1
Polygon  12-1
Rectangle  12-2
Selection  4-4
solid modeling  17-2
Solid Utility  17-3
surface modeling  14-2
wireframe  8-2

top view  30-6
Torus Primitive tools  18-15

1 Point  18-15
2 Point  18-16
Diagonals  18-17

Trackball  7-8
Axis Locking  7-8
rotation options  7-9, 7-11
save view  30-10
Sphere  7-9
Step  7-10
view menu  7-13

Transformation tools  25-1
Align  25-19
Copy Along Path  25-11
Expand/Shrink  25-6
Linear Duplicate  25-13
Mirror  25-8
Move  25-2
Polar Duplicate  25-16
Rotate  25-3

transparency
Edit Objects  24-28, 33-38
shader  33-45
shadows  33-51
wrapped  33-45

Triad  2-2, 2-10
show/hide  7-14

trim operations

surface/curve  21-12
surface/solid  21-12
surface/surface  21-11

Trim Solid Tool  23-4
Trim tools  20-5

Corner  20-9
Divide  20-8
Divide at Location  20-10
Relimit  20-6
Segment  20-10
Simple Trim  20-6
Surface  21-11
untrim surface  21-21

trimetric view  30-7
Tube Surface tool  16-27
turbulent (shader)  33-43
twist angle (swept solid)  19-11
two edge vertex blend  22-12
two lengths constant chamfer  22-26

U
u/v lines  6-6, 24-5
undo  24-4
unfold view  36-25, 36-29
ungroup  24-9
uninstalling  34-8
units

mixed  27-6
pen weight  5-10
precision  2-9
preferences  6-16
setting  27-6
Status Line  7-3

unlock
layers  31-8
objects  24-9

unsuppress feature  24-33, 24-36
untrim surface  21-21
Use View command (plane)  32-7
user interface  6-11
user-defined

coordinate system  7-7
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standard  27-32
work plane  32-4

user-defined views  30-8
Utility tools (solid)  17-3
uv shader  33-46

V
variable blend

by position  22-17
fixed width  22-20
hold line  22-21
law curve  22-18
linear  22-16

Variable Blend tool  22-16
variable chamfer

by position  22-33
fixed width  22-34
four lengths  22-31
lengths  22-30
lengths angles  22-32

Variable Chamfer Edge tool  22-30
variable lengths chamfer  22-30
Variables and Equations  38-16

Adding Equations  38-20
Highlighting Dimensions in the 

Sketch  38-19
Using Equations  38-18

Vector Spline tool  13-4
Vellum 3D

import  35-3
Vellum Draft export  35-14
Vellum Solids

export  35-13
import  35-2

Verify commands
Angle 3 Pts  24-40
Area  24-42
Check Object  24-48
Distance Pt-Pt  24-40
Interference  24-45
Length  24-41
Minimum Distance  24-41

Object Counts  24-48
Properties  24-43
Volume  24-42
X,Y,Z  24-40

Verify menu  2-13, 24-39
vertex  3-3
vertex blend  22-9
vertex chamfer  22-28
Vertical Dimension tools  27-9

Base Line  27-10
Chain  27-11
Vertical  27-20

Vertical Section View tool  36-19
view

azimuth  30-9
delete  30-12
drawing  36-4
dynamic rotate  30-14
elevation  30-9
menu  2-13
Modify command  30-11
New View command  30-8
pan  30-5
planes  30-18
pre-defined  30-6
preferences  6-12
redraw screen  30-14
rotate  30-9, 30-12
rotation short cut  7-13
show/hide  30-15
Trackball  30-10
Trackball rotation  7-9, 7-11
unfold  36-25, 36-29
user-defined  30-8
view the plane  30-15
work plane  32-11
zoom  30-5, 30-19

ViewPoint Media
export  35-22

Views pop-up menu  7-13
Volume command  24-42
VR Object movie  33-65



VR Panoramic movie  33-68
VRML export  35-20

W
Walk Through animation  33-60
weight

dimension  27-26
pen  5-10

Window menu  2-13
Windows

color  5-4
on-line help  1-6
print setup  37-15
uninstalling  34-8

wireframe
Drafting Assistant  8-3
modeling  8-1
resolution  8-4
tools  8-2

witness lines  27-29
work layer  31-3, 31-9

indicator  2-3, 2-12, 31-6, 31-9
work plane  32-2

3 Pts  32-7
define  32-3, 32-4
delete  32-5
dimensions  27-3
dimming  32-9
global  7-8
new  32-4
offset  32-10
origin  32-10
pick objects  32-8
properties  32-5
save current  32-6
setting  32-6
show  32-3, 32-6
show/hide  7-14
snapping  32-8
use view  32-7
user-defined  32-4
view the plane  32-11

views  32-11
world coordinate system  32-11

world coordinate system
Status Line  2-9
work plane  32-11

wrap (decal)
auto  33-29
cylindrical  33-27
planar  33-26
spherical  33-28

wrapped
displacement  33-44
image  33-43, 33-44, 33-45
reflectance  33-45
texture  33-43
transparency  33-45

X
X,Y,Z command  24-40

Z
zebra plot  21-33
zoom

all  30-2
commands  30-2
dynamic  30-4
home  30-2
in  30-2

out  30-3
out  30-2
previous  30-2
ratio  30-2
stroke  30-4
tools  30-3
views  30-5, 30-19
window  30-2
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	First Look
	Parts of the Designer Elements Window
	Title Bar
	Tool Palette
	1. Position the arrow pointer on the icon of the tool you want to use.
	2. Click the mouse button.
	1. Position the arrow pointer on the tool.
	2. Press the mouse button.
	3. Drag the pointer to highlight the desired tool.
	4. Release the mouse button.

	Smart Pointer & Wireframe Tools
	Location Indicator
	Message Line
	Status Line
	Coordinate System Axis
	Axis
	Triad
	Drawing Area
	Scroll Bars
	Work Layer Indicator
	Memory Indicator

	Menu Bar
	1. Point to the menu name.
	2. Click on the name.
	1. Point to the menu name.
	2. Click on the name.
	3. Click on the command.
	1. Pull down the menu.
	2. Click on a command followed by an arrow symbol.
	3. Click on the submenu.
	4. Click the desired command.


	The Drafting Assistant
	Snapping onto Geometry
	Customizing the Drafting Assistant

	Drafting Assistant Construction Lines
	Using the Drafting Assistant’s Construction Lines
	1. Click a point to begin new geometry.
	2. Move the pointer away from the point horizontally, vertically, or at a 45° angle.
	3. While the construction line is visible and the Drafting Assistant displays on, click the next ...
	1. On selected geometry, without pressing the mouse button, move the pointer over an existing point.
	2. Move the pointer horizontally or vertically.
	3. While the construction line is visible and the Drafting Assistant displays on, click the desir...


	Permanent Stroke Construction Lines
	1. Hold down the SHIFT+CTRL keys (Windows) or the z key (Macintosh). The pointer becomes the stro...
	2. Move the pointer near the center of the circle.
	3. Drag the mouse vertically or horizontally away from the�midpoint.
	The Construction Command
	1. Click the Angle field.
	2. Drag a vector in the drawing area.
	1. Click the Offset field.
	2. Drag the offset distance in the drawing area.
	1. Click the X field.
	2. Enter new coordinates

	Creating Construction Geometry
	1. In the Layout menu, choose Layer Manager. (The dialog box will say Design Explorer because to ...
	2. Click in the work layer column just to the left of Construction. (Move the pencil to that layer.)
	3. Click OK. The Layer Manager closes and the Construction layer is now the work layer. You will ...
	4. Create the geometry you will use for construction.
	5. When the construction geometry is complete, make another layer�the work layer by changing the ...
	6. Continue your work.

	Removing Construction Lines

	Drafting Assistant and Display

	Selecting Objects
	1. Select the tool.
	2. Select the object to be modified.
	1. Select the object.
	2. Specify the action for the selected object.
	Objects
	Indicating Selection & Preferences
	Pick Box
	Select Fence
	Selection Color

	Selection Process
	Selecting Objects with the Selection Tool
	1. Click the Selection tool in the tool palette. The Message Line reads: Selection: Select [Shift...
	2. Move the pointer to an object and click. The object is selected, and any previously selected o...
	1. Choose the Selection tool in the tool palette.
	2. Move the pointer to an object and click.
	3. Press down the SHIFT key.
	4. While holding down the SHIFT key, click other objects to be selected.
	5. Release the SHIFT key.
	1. Click the Selection tool in the tool palette.
	2. Drag a selection fence around the objects you want to�select.

	Selecting Points
	1. Select the geometry.
	2. Choose Edit>Show/ Hide Points to toggle the display of points on and off.
	1. Chose the Selection tool.
	2. Drag a selection fence around the location of the point.

	Selecting Objects using Other Tools
	Selecting Objects with Commands
	1. Choose Window>Select Mask.
	2. Click the items you want to be able to select so they are highlighted.
	1. Select the beginning of a curve as shown by the arrow in the left graphic below.
	2. Choose Edit>Select Chain.
	3. All objects connected to the start or end are selected, as in the right graphic below.

	Deselecting

	Eye Dropper Tool
	Using the Eye Dropper Tool
	1. Select the Eye Dropper tool from the Selection tools palette. The Message Line reads: Eye Drop...
	2. Select the objects whose characteristics you want to change.
	3. If you do not want all object characteristics copied, press the CTRL (Windows) or OPTION (Maci...
	4. Deselect those items in the dialog box that you do not want copied.
	5. Select the object whose characteristics you want to copy.



	Pen Settings
	1. Select the object.
	2. Choose Pen>Color, Weight or Pattern and select the one you want for the selected object.
	Style
	Color
	Displaying the Color Palette
	1. Choose Pen>Color>More.
	2. You can choose to display 8, 16, 144 or the full 256 color palette. The default color palette ...

	Specifying the Color of the Current Pen
	1. Choose Pen>Color. The submenu appears.
	2. Choose the color you want.

	Defining Colors
	1. To define a new color, choose Pen>Color>More. The color palette displays.
	2. Double-click on one of the definable colors.
	3. Click the Define Custom Colors button to display the full color display.
	4. In the color palette on the right, place the pointer within the target cursor and drag to the ...
	5. Once you have chosen the color, click OK, the color display closes and you are returned to col...
	6. Double-click on the color name field, where the old name currently displays. The following dia...
	7. Enter the new name for the color and click OK.
	8. Repeat this process to define up to 239 colors.
	1. To define a new color, choose Pen>Color>More. The color palette displays.
	2. Double-click on one of the definable colors.
	3. Choose a color from the color display.
	4. Once you have chosen the color, click OK, the color display closes and you are returned to the...
	5. Double-click on the color name field, where the old name currently displays. The following dia...
	6. Enter the new name for the color and click OK.
	7. Repeat this process to define up to 239 colors.

	Add to Custom Colors (Windows only)
	1. Repeat steps 1 and 2 in the previous section, “Defining Colors,” to show the partial color dis...
	2. Place the pointer over one of the available boxes in the Custom colors area and click. A dotte...
	3. Click Define Custom Colors and the full color display appears.
	4. Move the pointer to the color palette and place it within the target area. Drag this to the co...
	5. Click Add to Custom Colors. The color appears in the Custom colors patch.
	6. To fill in the others boxes, go through the same process.


	Weight
	1. Choose Pen>Weight. The submenu appears.
	2. Drag to the weight you want.

	Pattern
	Line Pattern Manager
	New Patterns
	1. Quit your Designer Elements program, if it is running.
	2. Open the Cadd.lin file from the Environ folder in an ASCII text editor.
	3. After the last line pattern, enter the name of your new pattern. Give it a name not already used.
	4. In the same line, enter a descriptor string. This string is simply a visual representation of ...
	5. Begin the second line with a capital “A” followed by the length of the attributes. Each attrib...
	6. Save the file.
	7. Restart your Designer Elements program.
	1. Quit your Designer Elements program, if it is running.
	2. Open the Cadd.lin file, from the Environ folder, in an ASCII text editor.
	3. Make the desired changes to the patterns. If you have changed a default pattern, name or descr...
	4. Save the file.
	5. Restart your Designer Elements program.
	1. Choose Pen>Pattern>More. The Line Pattern Manager displays.
	2. Select the pattern you want to modify.
	3. Enter a value in the Scale field.
	4. Click OK to accept the changes or Cancel to close the Line Pattern Manager. All selected will ...
	1. Choose Pen>Pattern. The submenu appears.
	2. Drag to the pattern you want. The pen takes on the new pattern, selected in the submenu.
	1. Select the object.
	2. Choose Pen>Pattern.
	3. Drag to the pattern you want. The pen takes on the new pattern, selected in the submenu.

	Construction Line Pattern

	Arrowheads
	Arrowheads Type


	Preference Settings
	Preferences
	Colors
	1. Click New. The color palette is displayed.
	2. Choose the background color.
	3. Click OK. The new background displays in the view window with the color name. For colors other...
	1. Click New. The color palette is displayed.
	2. Choose the foreground color.
	3. Click OK. The new foreground displays in the view window with the color name. For colors other...

	Dimensional Constraint Manager (DCM) (Cobalt™ Only)
	Display
	Drafting Assistant
	Filing
	General
	Grid
	1. Click New to display the color palette.
	2. Select a color from the palette.
	3. Click OK to accept the color and return to the Grid page. The new color now displays in the gr...

	Localization
	Select
	1. Click New to display the color palette.
	2. Select a color from the palette.
	3. Click OK to accept the color and be returned to the Select page. The new color now displays in...

	Units
	Changing the Preference Settings with the Preferences Command
	1. Choose File>Preferences.
	2. Select the category you want to set.
	3. Make your desired changes.
	4. Select another category or click OK to close the dialog box.

	Changing the Preference Settings Manually
	1. Quit your Designer Elements program.
	2. Open the Preferences file, prefs.ini, in a text editor. The file is located in the Environ fol...
	3. Change the characteristics you want.
	4. Save and close the file.
	5. Relaunch your Designer Elements program.

	Preferences and Object Creation

	Pen and Dimension Preferences
	Short Cuts
	Creating a New Short Cut
	1. Choose File>Short Cuts.
	2. Select the desired category and command in the appropriate sections.
	3. Enter the key combination into the Shortcut key data field.
	4. Click Assign Key. The key combination displays next to the selected command.
	5. Continue entering all key combinations as desired.
	6. Click OK to save the new short cut keys and close the dialog box.



	Drawing Techniques
	Object Creation Methods
	Creating a Line by Clicking
	1. Click the Single Line tool in the main tool palette. The Message Line reads: Single Line: Pick...
	2. Move the pointer to the drawing area and click to set the starting point of the line.
	3. Move the mouse to the desired location for the endpoint of the line. As you do so, a rubberban...
	4. Click to set the endpoint.


	Status Line
	Status Line Entries and Tool Operations
	Using the Status Line with Drawing Tools
	1. Select the Single Line tool. The Message Line reads: Single Line: Pick beginning point [Ctrl =...
	2. Click two locations in the drawing area. The length (L) field automatically highlights in the ...
	3. Type 3. The 3 is entered directly in the L field.
	4. Press the TAB key to select the next status field. The angle (A) field now highlights. (If you...
	5. Enter 15.
	6. Press ENTER (Windows) or RETURN (Macintosh).
	1. With the Single Line tool still selected from the previous example, click 2 more points.
	2. Type 4.
	3. Press the TAB key and type 25 in the Angle field.
	4. Press ENTER (Windows) or RETURN (Macintosh). Another line is drawn.
	1. Choose the Selection tool so the Status Line clears.
	2. Click the Single Line tool again.
	3. Type 0.
	4. Press the TAB key. The Y data field highlights.
	5. Type 0.
	6. Press the TAB key. The Z data field highlights.
	7. Type 0.
	8. Press the TAB key.
	9. Type 2.
	10. Press the TAB key. The dY data field highlights.
	11. Type 2.
	12. Press the TAB key. The dZ data field highlights.
	13. Type 0.
	14. Press ENTER (Windows) or RETURN (Macintosh). The line is drawn.

	Creating Geometry Offset from a Point
	1. Select the tool you want to use.
	2. Move the pointer over the control point from which you�want the offset.
	3. Click once to lock onto that point.
	4. Finish creating the geometry.
	5. With the geometry still selected, click in the appropriate X, Y, or Z data field in the Status...
	6. Type the offset (such as + 3) and press ENTER (Windows) or RETURN (Macintosh).
	7. Continue with your construction.


	Coordinate System Axis
	Choosing a Coordinate System
	1. Choose the coordinate system by clicking on the coordinate system axis icon at the far left of...
	2. Choose the GlobalWorkPlane, DynWorkPlane or any user-defined work plane.
	3. Continue designing.


	Message Line
	Trackball
	Sphere Trackball
	1. Choose Window>Trackball.
	2. Drag the pointer on the Trackball to rotate the view.

	Step Trackball
	1. Choose Window>Trackball.
	2. Click on the arrow button on the right side of the Trackball title bar to change the display t...
	3. Click one of the directional arrows. The model rotates a specified number of degrees. Or...

	Trackball View Menu
	1. Move the pointer to the current view name displayed at the bottom of the Trackball window.
	2. Press the mouse button.
	3. Choose the view orientation you want to display in the current window.

	View Rotation Short Cut

	Drawing Display Commands
	Show/Hide Triad
	Show/Hide Axis
	Show/Hide Work Plane
	Show/Hide Points
	Grid

	Drawing at Full Scale
	1. Draw a line, specifying 83' for the length.
	2. Choose View>Zoom All.

	Default versus Selected Object Settings
	Escape Key
	Progress Bar
	Right Mouse Button
	Over No Object
	Over An Object
	Selected Drawing View


	Introduction to Wireframe Modeling
	Wireframe Tools
	Wireframes and the Drafting Assistant
	Wireframes, Selection and Display
	Changing an Object's Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.



	Line Tools
	Single Line Tool
	Using the Single Line Tool
	1. Select the tool. The Message Line reads: Single Line: Pick the beginning point. [Ctrl = Copy P...
	2. Click to place the first endpoint of the line.
	3. Move the cursor to a new location. As you do, a rubberband image appears that previews your co...
	4. Click to place the last point of the line.

	Drawing a Line Perpendicular to Another Object
	1. Construct the object.
	2. Move the pointer to the object until a Drafting Assistant on notation appears (endpoint, midpo...
	3. Drag straight away from the object in a perpendicular direction. A perpendicular line will app...
	4. Drag to the desired length.

	Drawing a Line Tangent or Perpendicular to an Arc, Circle or Ellipse
	1. Construct an arc, circle, or ellipse.
	2. Choose the Single Line tool.
	3. Move the pointer to the arc until a Drafting Assistant on notation appears (endpoint, midpoint...
	4. Drag in the appropriate direction (straight out for perpendicular or at an angle for tangent) ...
	5. When the Drafting Assistant locks on to perpendicular or tangent, drag the line around the arc...

	Geometric Characteristics

	Connected Lines Tool
	Using the Connected Lines Tool
	1. Select the tool. The Message Line reads: Connected Lines: Pick the beginning point.
	2. Click to indicate the endpoints of the line segments.
	3. Indicate the last point by double-clicking, hitting the ESC key or by choosing another tool.

	Geometric Characteristics

	Parallel Line Tool
	Using the Parallel Line Tool
	1. Select the tool. The Message Line reads: Parallel Line: Drag new line off existing line.
	2. Drag off the desired line and release to indicate the position for the new parallel line. A ru...

	Geometric Characteristics

	Point Tool
	Using the Point at an XYZ Location Tool
	1. Select the Point tool from the palette.
	2. Select the Point at an XYZ Location tool in the Message Line. The Message Line reads: Point: E...
	3. Click a point in the drawing area.

	Using the Points on a Curve Tool
	1. Select the Point tool from the palette.
	2. Select the Point on a Curve tool in the Message Line. The Message Line reads: Point on Curve: ...
	3. Enter the number of points you want distributed along the curve in the #Pts data field of the ...
	4. Select the curve. If you want to select more than one curve, hold down the SHIFT key before se...

	Using the Points on a Surface Tool
	1. Select the Point tool from the palette.
	2. Select the Points on a Surface tool in the Message Line. The Message Line reads: Point on Surf...
	3. Enter the number of points you want distributed along the surface in two perpendicular directi...
	4. Select the surface. If you want to select more than one surface, hold down the SHIFT key befor...

	Geometric Characteristics

	Modifying Lines

	Arc & Circle Tools
	Arc Tools
	Center-Point Arc Tool
	1. Select the tool. The Message Line reads: Center-Point Arc: Pick Center.
	2. Click the center point of the arc. The Message Line now tells you the next step in using the t...
	3. Click the beginning point of the arc which will also define the radius.
	4. As you move the cursor to place the final point, a rubberband arc appears. Click the final point.

	3-Point Arc Tool
	1. Select the tool. The Message Line reads: 3-Point Arc: Pick first point. [Ctrl = Tangent to obj...
	2. Click the first endpoint of the arc.
	3. Click the second point of the arc. A rubberband arc appears as you move the cursor to a third ...
	4. Click the last point of the arc. The arc is created.

	Tangent-Point Arc Tool
	1. Select the tool. The Message Line reads: Tangent-Point Arc: Pick beginning point of arc (tange...
	2. Click the starting point. This is both the starting point of the arc and the starting point of...
	3. Click the endpoint of the tangent line.
	4. Click the endpoint of the arc. The arc is drawn between the first and last point you click, ta...

	Geometric Characteristics

	Circle Tools
	Center-Point Circle Tool
	1. Select the tool. The Message Line reads: Center- Point Circle: Pick center. [Ctrl = Copy previ...
	2. Click the center of the circle. A rubberband circle appears guiding your construction as you m...
	3. Click the second point which determines the circle's radius.

	Opposite-Point Circle Tool
	1. Select the tool. The Message Line reads: Opposite- Point Circle: Pick first point on circle. [...
	2. Click two locations to indicate the diameter. After you click the first point, a rubberband ci...

	3-Point Circle Tool
	1. Select the tool. The Message Line reads: 3-Point Circle: Pick first point. [Ctrl = Tangent to ...
	2. Click the first point on the circle.
	3. Click the second and third points. After the second point a rubberband circle appears guiding ...
	1. Select the tool. The Message Line reads: Tangent Circle: Enter diameter then pick first tangen...
	2. You can enter a diameter for the circle in the Status Line data field.
	3. Click the objects to which the circle is to be tangent.



	Ellipse & Conic Tools
	Ellipse Tools
	2-Point Center Ellipse Tool
	1. Select the tool. The Message Line reads: 2-Point Center Ellipse: Pick center of ellipse. [Ctrl...
	2. Indicate the center of the ellipse.
	3. Indicate the corner of the rectangle defining the ellipse.

	Opposite-Corner Ellipse Tool
	1. Select the tool. The Message Line reads: Opposite-Corner Ellipse: Pick first corner of rectang...
	2. Indicate one corner of the rectangle defining the ellipse.
	3. Indicate the opposite corner of the defining rectangle.

	3-Point Center Ellipse Tool
	1. Select the tool. The Message Line reads: 3-Point Center Ellipse: Pick center of the ellipse. [...
	2. Pick the center of the ellipse.
	3. Pick the midpoint of the side of the control parallelogram defining the ellipse.
	4. Pick the corner of the control parallelogram defining the ellipse.

	3-Corner Ellipse Tool
	1. Select the tool. The Message Line reads: 3- Corner Ellipse: Pick first corner of control paral...
	2. Pick one corner of the parallelogram defining the ellipse.
	3. Pick another corner of the defining parallelogram.
	4. Pick the final corner of the defining parallelogram.

	Modifying Ellipses

	Conic Tools
	2-Point Conic Tool
	1. Select the tool. The Message Line reads: 2-Point Conic: Pick start point. [Ctrl = Copy previou...
	2. Pick the start point of the conic. As you move the cursor to place the second point, a rubberb...
	3. Pick the end point to complete the conic.

	3-Point Conic Tool
	1. Select the tool. The Message Line reads: 3-Point Conic: Pick start point. [Ctrl = Copy previou...
	2. Pick the start point of the conic.
	3. Pick the end point of the conic. Once you place this third point, a rubberband image appears.
	4. Pick the shoulder point to complete the conic.

	4-Point Conic Tool
	1. Select the tool. The Message Line reads: 4-Point Conic: Pick start point. [Ctrl = Copy previou...
	2. Pick the start point of the conic.
	3. Pick the end point of the conic.
	4. Pick the slope control point of the conic. Once you place this third point, a rubberband image...
	5. Pick the shoulder point to complete the conic.



	Polygon Tools
	Rectangle Tool
	Center/Corner Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Center/Corner Rectangle tool in the Message Line. The Message Line reads: Rectangle...
	3. Pick the center point of the rectangle. As you move the cursor, a rubberband image appears.
	4. Pick rectangle corner.

	Diagonal Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Diagonal Rectangle tool in the Message Line. The Message Line reads: Rectangle: Pic...
	3. Click one corner of the rectangle. As you move the cursor a rubberband image appears.
	4. Click the opposite corner of the rectangle.

	Center/Axis Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Center/Axis tool in the Message Line. The Message Line reads: Rectangle: Pick cente...
	3. Click the center point of the rectangle.
	4. Click the midpoint of the rectangle side. As you move the cursor a rubberband image appears.
	5. Click the corner of the rectangle.

	Major/Minor Axis Rectangle Tool
	1. Select the Rectangle tool from the palette.
	2. Select the Major/Minor Axis tool in the Message Line. The Message Line reads: Rectangle: Pick ...
	3. Click the first corner of the rectangle.
	4. Click the second corner of the rectangle. As you move the cursor, a rubberband image appears.
	5. Click the third corner of the rectangle.

	Geometric Characteristics

	Inscribed Polygon Tool
	Using the Inscribed Polygon Tool
	1. Select the tool. The Message Line reads: Inscribed Polygon: Pick center of polygon. [Ctrl = Co...
	2. Click the center of the polygon. The Message Line reads: Inscribed Polygon: Pick vertex of pol...
	3. Pick a point on the circumference of the circumscribing circle to complete the polygon.

	Geometric Characteristics

	Circumscribed Polygon Tool
	Using the Circumscribed Polygon Tool
	1. Select the tool. The Message Line reads: Circumscribed Polygon: Pick center of polygon. [Ctrl ...
	2. Click the center of the polygon and the midpoint of one of the sides (as directed by the Messa...

	Geometric Characteristics

	Arbitrary Polygon Tool
	1. Select the tool. The Message Line reads: Arbitrary Polygon: Pick first point. [Ctrl = Copy pre...
	2. Click the next point (as directed by the Message Line).
	3. Continue clicking points to complete the desired polygon. Single click the last point to close...
	Geometric Characteristics

	Polygon from Curves Tool
	1. Select the tool. The Message Line reads: Polygon from Curves: Select a collection of curves [S...
	2. Select all the desired curves. If you are selecting the curves individually, hold down the SHI...
	Geometric Characteristics


	Spline Tools
	Through-Points B-Spline Tool
	Using the Through-Points B-Spline Tool
	1. Select the tool. The Message Line reads: Through-Points B-Spline: Pick control points. (End = ...
	2. Click the points for the vectors of the spline.
	3. Double-click the last point or hit the ESC key.

	Geometric Characteristics

	Vector Spline Tool
	Using the Vector Spline Tool
	1. Select the tool. The Message Line reads: Vector Spline: Pick control points (End = ESC, Double...
	2. Click the points for the vectors of the spline.
	3. Double-click the last point.

	Geometric Characteristics

	Bezier Spline Tool
	Using the Bezier Spline Tool
	1. Select the tool. The Message Line reads: Bezier Spline: Pick control points (End = ESC, Double...
	2. Click the points of the spline.
	3. Double-click the last point.

	Geometric Characteristics

	Sketch Spline Tool
	Using the Sketch Spline Tool
	1. Select the tool. The Message Line reads: Sketch Spline: Press and drag mouse (Option=AutoClose).
	2. Click and drag the mouse on the screen.
	3. Release the mouse button to create the sketch spline.

	Using the Sketch on a Surface Tool
	1. Select the tool. The Message Line reads: Sketch on Surface: Select surface or solid to sketch ...
	2. Select the surface or solid to sketch on.
	3. Click and drag the mouse over the selected surface, keeping the points on the surface.
	4. Release the mouse button to complete the sketch.


	Helix Curve Tool
	Using the Helix Curve Tool
	1. Select the Helix Curve tool. The Message Line reads: Helix Curve: Pick start and end of helix ...
	2. The Status Line contains the Pitch, Diameter, Length and Draft Angle data fields.
	3. Pick the start and end point of the helix. A right handed helix is created.

	Geometric Characteristics

	Add Control Point Tool
	Using the Add Spline Control Point Tool
	1. Select the tool. The Message Line reads: Add Control Point: Select the spline to add point to ...
	2. Click on the spline to which you want to add a point.
	3. Pick the desired location(s) for the new control point(s).


	Remove Control Point Tool
	Using the Remove Control Point Tool
	1. Select the tool. The Message Line reads: Remove Control Point: Select the spline point to remo...
	2. If the control points of the spline are not displayed, select the spline and choose Edit>Show ...
	3. Pick the control point you want to remove.


	Modify Slope Tool
	Using the Modify Slope Tool - Free Option
	1. Select the tool. The Message Line reads: Modify Slope: Select spline slope(s) to free (Shift =...
	2. Choose the Free option in the pull-down menu of the Message Line.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show ...
	4. Pick the spline slope control endpoint you want to free.

	Using the Modify Slope Tool - Reference Option
	1. Select the tool. The Message Line reads: Modify Slope: Select the spline end to set slope at (...
	2. Choose the Reference option in the pull-down menu of the Message Line.
	3. If the control points of the spline that you want modified are not displayed, select the splin...
	4. Pick the spline want to modify. In the graphic here, it's the spline displaying points.
	5. Pick the curve, surface or solids whose slope you want to reference.
	6. Click on the endpoint of the curve you want to modify, (The curve and the reference object do ...

	Using the Remove Control Point Tool - Reverse Option
	1. Select the tool. The Message Line reads: Modify Slope: Select spline slope point to reverse (S...
	2. Choose the Reverse option in the pull-down menu of the Message Line.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show ...
	4. Pick the spline slope control endpoint you want to reverse, as in the left graphic below. The ...

	Using the Modify Slope Tool - Explicit Option
	1. Select the tool. The Message Line reads: Modify Slope: Select spline slope point for explicit ...
	2. Choose the Explicit option in the pull-down menu of the Message Line.
	3. If the control points of the spline are not displayed, select the spline and choose Edit>Show ...
	4. Pick the spline control endpoint you want to set. An Input String dialog box appears.
	5. Enter the Angle for the slope in the data field and click OK. The dialog box closes and the sl...

	Using the Modify Slope Tool - Free Magnitudes Option
	1. Select the tool. Choose the Free Magnitudes option in the pull down menu. The Message reads: M...
	2. If the control points of the spline are not diplayed, select the spline and choose Edit>Show P...
	3. Select the bezier curve control point you want to free.

	Elevate Curve Tool
	Using the Elevate Curve Tool
	1. Select the Elevate Curve tool. The Message Line reads: Elevate Curve: Pick curve to elevate [S...
	2. Select the curve to elevate.


	Fair Spline Tool
	Using the Fair Spline Tool
	1. Select the tool. The Message Line reads: Fair Spline: Select curve to fair.
	2. Click on the spline which you want to fair.



	Introduction to Surface Modeling
	Surface Modeling Tools
	Surface Primitive Tools
	Surface From Curves Tools
	Feature Surface Tools
	Surface Utilites Tools
	Local Surface Tools

	Surfaces, Selection and Display
	Changing an Object's Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.
	3. Enter the desired number of Iso lines. Check the Show Silhouettes box if desired.
	4. Click OK to close the dialog box and save the new settings.


	Surface Associativity
	Cutting and Pasting Surfaces
	Exporting Surfaces
	Objects Types and Edit Objects

	Mesh Creation Tools -
	Mesh 3 Pts Tool
	Using the Mesh 3 Pts Tool
	1. Select the tool. The Message Line reads: Mesh 3 Pts: Enter 3 locations for mesh.
	2. Click three points to define the mesh boundary.

	Geometric Characteristics

	Mesh 4 Pts Tool
	Using the Mesh 4 Pts Tool
	1. Select the tool. The Message Line reads: Mesh 4 Pts: Enter 4 locations for mesh.
	2. Click four points to define the mesh boundary.

	Geometric Characteristics

	Mesh Curve Tool
	Using the Mesh Curve Tool
	1. Select the tool. The Message Line reads: Mesh Curve: Select curves in order of meshing [Shift=...
	2. Select a mesh spacing option from the pull-down menu.
	3. The Status Line displays the N data field which represents the number of mesh segments lines t...
	4. Click two or more curves to define the mesh boundary. These curves should not be connected. If...

	Geometric Characteristics

	Mesh Extrude Tool
	Using the Mesh Extrude Tool
	1. Select the tool. The Message Line reads: Mesh Extrude: Select objects to extrude [Shift=Extend].
	2. The Status Line displays data fields allowing you to enter the delta values for the extrusion ...
	3. Click one or more curves to sweep. If you need to select more than one curve, hold down the SH...
	4. If you want a different value for the N segments than currently listed, select the field and t...
	5. Click two points to set the direction and the distance of the extrusion. The points do not hav...

	Geometric Characteristics

	Mesh and Rendering
	Mesh Notations

	Surface Creation Tools
	Infinite Plane Tool
	Using the Infinite Plane Tool for X-, Y- and Z-Station Planes
	1. Select the Infinite Plane tool.
	2. Pick X-, Y- or Z-Station from the drop down list on the Message Line. The Message Line reads: ...
	3. Click the point on the screen where you want the plane. An icon for the plane appears at that ...

	Using the Infinite Plane Tool to create a Normal and Location Plane
	1. Select the Infinite Plane tool.
	2. Pick Normal Loc from the drop down list on the message line. The Message Line reads: Infinite ...
	3. Click the point where you want the plane's normal to end, the point where you want the plane's...

	Using the Infinite Plane Tool to create a Three Point Plane
	1. Select the Infinite Plane tool.
	2. Pick 3 Pts In Plane option from the drop down list on the Message Line. The Message Line reads...
	3. Click three points. The plane icon at the specified location.

	Using the Infinite Plane Tool to create a Plane along a Curve
	1. Select the Infinite Plane tool.
	2. Pick Along Curve from the drop down list on the Message Line. The Message Line reads: Infinite...
	3. Click a curve on the screen. The Input String dialog box appears.

	Infinite Plane Tool - Along the Curve Option and the Plane/Surface Intersection Tool
	1. Select the Infinite Plane tool and select the Along Curve option.
	2. Create the planes along a curve adjacent to the solid model.
	3. Choose the Plane/Surface Intersection tool and pick the planes on the curve with which you wan...
	4. Select the solid. The Plane/Surface Intersection tool projects the planes through the solid. Y...
	5. The intersections displays.

	Clipping Planes
	1. Select the Infinite Plane tool. The Message Line reads: Infinite Plane: Pick location for plane.
	2. Place the Infinite Plane in your drawing.
	3. Right-Click on the infinite plane and select the “Use a Clip Plane” menu option.
	4. Use the Selection tool to dynamically drag the clip plane through the model.
	5. To change the direction that the plane clips choose Edit>Change Direction.

	Geometric Characteristics
	Sphere Primitive
	1. Select the Sphere Primitive tool. The Message Line reads: Sphere Primitive: Enter center and r...
	2. In the drawing area click the center point and radius point.

	Block Primitive
	1. Select the Block Primitive tool. The Message Line reads: Block Primitive: Enter center and len...
	2. In the drawing area click the center and length points for the block.

	Cylinder Primitive
	1. Select the Cylinder Primitive tool. The Message Line reads: Cylinder Primitive: Enter start an...
	2. In the drawing area click the start and end points for the cylinder.

	Pyramid Primitive
	1. Select the Surface Pyramid Primitive tool. The Message Line reads: Pyramid Primitive: Enter st...
	2. In the drawing area click the start and end points for the pyramid.

	Surface From Curves Tools.
	Net Surface Tool
	Using the Net Surface Tool
	1. Select the Net Surface tool. The Message Line reads: Net Surface: Pick (M) curves defining sur...
	2. Hold down the SHIFT key and pick two or more curves along one direction. The objects appear se...
	3. Hold down the SHIFT key once again, and pick two or more curves to complete the boundary for t...

	Geometric Characteristics
	Ruled Surface Tool
	1. Select the Ruled Surface tool. The Message Line reads: Ruled Surface: Pick curves for defining...
	2. If there are more than two curves being used for the ruled surface hold down the SHIFT key and...

	Geometric Characteristics

	Skin Surface Tools
	Standard Skin Surface
	Closed Skin Surface
	Skin Curve Surface Tool
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the sa...
	2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining s...
	3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
	4. Select the curves in the order that the surface is to be skinned. To select more than two curv...
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the sa...
	2. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining s...
	3. Select the Skin Curve Surface tool (the left tool) in the Message Line.
	4. (Windows) Select the curves in the order that the surface is to be skinned. To select more tha...

	Skin with Curve Guides Surface Tool
	1. Check curve directions of the profile curves by choosing Verify>Direction. If all of the curve...
	2. Create one or more guide curves.
	3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining s...
	4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message Line.
	5. Select the curves in the order that the surface is to be skinned. To select more than two curv...
	6. Select the guide curves.
	1. Check curve directions by choosing Verify>Direction. If all of the curves do not run in the sa...
	2. Create one or more guide curves.
	3. Select the Skin Surface tool. The Message Line reads: Skin Surface: Pick curves for defining s...
	4. Select the Skin with Guide Curves Surface tool (the right tool) in the Message Line.
	5. (Windows) Select the curves in the order that the surface is to be skinned. To select more tha...
	6. Select the guide curves.

	Geometric Characteristics

	Cover Surface Tool
	Using the Cover Surface Tool
	1. Select the Cover Surface tool. The Message Line reads: Cover Surface: Pick curves for cover su...
	2. If you want to select more than one curve hold down the SHIFT key before selecting the first c...
	3. Select the curves. Do not worry about the order you select them.

	Geometric Characteristics

	Revolved Surface Tool
	Revolved Surface about Two Points Tools
	1. Select the Revolved Surface tool.
	2. Select the Resolve Surface About Two Points tool in the Message Line. The Message Line reads: ...
	3. Enter the angle through which to revolve the curve in the Angle data field of the Status Line.
	4. Select the curve or curves to revolve.
	5. Click two points to define the Axis of Revolution.

	Revolved Surface about a Curve Tool
	1. Select the Revolved Surface tool.
	2. Select the Resolve Surface About Curve tool in the Message Line. The Message Line reads: Revol...
	3. Enter the angle through which to revolve the curve in the Angle data field on the Status Line.
	4. Select the curve or curves to revolve.
	5. Select the curve to use as the Axis of Revolution. If the Axis of Revolution crosses any of th...

	Geometric Characteristics

	Sweep Surface Tool - Along 2 Points
	1. Select the Sweep Surface Along 2 Points tool. The Message Line reads: Pick curve(s) to sweep [...
	2. Select the curve that you want to sweep. The Message Line reads: Sweep 2 Pts Surface: Enter tw...
	3. Click two points to define the vector. The order you click the points specifies the direction ...
	Sweep Surface Tool - Along 1Rail
	1. Select the Sweep Surface Along 1 Rail tool. The Message Line reads: Sweep 1 Rail Surface: Pick...
	2. Click the sweep curve. The Message Line reads: Sweep 1 Rail Surface: Pick sweep axis [Shift=Ex...
	3. Click the rail curve. The surface is created.

	Sweep Surface Tool - Along 2 Rails
	1. Select the Sweep Surface tool.
	2. Select the Sweep Surface Along 2 Rails tool in the Message Line. The Message Line reads: Sweep...
	3. Click the profile you want to sweep and then choose the two rails for the sweep path.

	Sweep Rules

	Tube Surface Tool
	Using the Tube Surface Tool
	1. Create a curve that would act as the center line for the tube.
	2. Select the Tube Surface tool. The Message Line reads: Tube Surface: Pick tube center line [Shi...
	3. Click the curve for the tube's center line.
	4. Enter a new tube radius in the data field on the Status Line, if required. Press ENTER (Window...

	Geometric Characteristics

	Feature Surface Tools
	Offset Surface Tool
	Using the Offset Surface Tool
	1. Select the Offset Surface tool. The Message Line reads: Offset Surface: Pick surfaces to offse...
	2. Enter an Offset distance in the data field of the Status Line.
	3. Click the parent surface. A duplicate surface appears at the offset distance.


	Lofted Surface Tool
	Using the Lofted Surface Tool
	1. Select the Lofted Surface tool. The Message Line reads: Lofted Surface: Pick edges for lofted ...
	2. Enter a new bulge factor in the Bulge data field in the Status Line, if desired. The bulge fac...
	3. Click an edge on each surface to be joined by the tangent surface. When you create a tangent s...


	Draft Surface Tool
	Using the Draft Surface Tool
	1. Select the Draft Surface tool. The Message Line reads: Draft Surface: Select curve on surface ...
	2. Enter a new angle and/or length in the data fields in the Status Line, if you so desire.
	3. Click a curve (edge) on the surface to draft or extend the surface. When you select the edge, ...


	Fillet Surface Tool
	Using the Fillet Surface Tool
	1. Select the Fillet Surface tool. The Message Line reads: Fillet Surface: Pick two surfaces to b...
	2. Select the two intersecting or connected surfaces that share an edge

	Tangent Cover Surface Tool
	1. Select the Tangent Cover Surface tool. The Message Line reads: Tangent Cover Surface: Pick fou...
	2. Select the surface edges and or curves. Select them inhead to tail fashion. The tangent cover ...



	Introduction to Solid Modeling
	Solid Modeling Tools
	Primitives
	Profiles
	Features
	Solid Utility Tools
	Local Solid Face Tools

	Drafting Assistant and Solids
	Solids, Selection and Display
	Displaying Solid Edges
	Object Resolution
	1. Select the object.
	2. Choose Edit>Change Resolution.
	3. Enter the desired number of Iso lines. Check the Show Silhouettes box if desired.
	4. Click OK to close the dialog box and save the new settings.


	Solid Associativity
	Solids and Instances
	Instances and Moving Solids
	Instances, Copying Solids and Associativity

	Cutting and Pasting Solids
	Cutting and Pasting on the Macintosh

	Exporting Solids
	1. You can convert the solid into polylines or meshes with the Change Object Type command in the ...
	2. If you are exporting to an application that supports ACIS, you can generate a SAT file. SAT fi...
	3. You can export solids through the IGES translator as solid entities or as a collection of trim...

	Object Types and Edit Objects
	Error Messages

	Solids Creation Tools - Primitives
	Sphere Primitive Tool
	Sphere 1 Point Tool
	1. Select the Sphere Primitive tool.
	2. Select the Sphere 1 Point tool in the Message Line. The Message Line reads: Sphere Primitive: ...
	3. Click a point in the drawing area.

	Sphere 2 Point Tool
	1. Select the Sphere Primitive tool.
	2. Select the Sphere 2 Point tool in the Message Line. The Message Line reads: Sphere Primitive: ...
	3. Click the center point and the radius point in the drawing area.

	Sphere by Diagonals Tool
	1. Select the Sphere Primitive tool.
	2. Select the Sphere by Diagonals tool in the Message Line. The Message Line reads: Sphere Primit...
	3. Click two points in the drawing area.The sphere is created.

	Geometric Characteristics

	Slab Primitive Tool
	Using the Slab Tool
	1. Select the Slab Primitive tool. The Message Line reads: Slab Primitive: Enter 3 or more points...
	2. Click the three or more points to describe the slab. (Be careful that the points are not overl...

	Geometric Characteristics

	Block Primitive Tool
	Block 1 Point Tool
	1. Select the Block Primitive tool.
	2. Select the Block 1 Point tool in the Message Line. The Message Line reads: Block Primitive: En...
	3. Click a point in the drawing area.

	Block 2 Point Tool
	1. Select the Block Primitive tool.
	2. Select the Block 2 Point tool in the Message Line. The Message Line reads: Block Primitive: En...
	3. Click two points in the drawing area.

	Block by Diagonals Tool
	1. Select the Block Primitive tool.
	2. Select the Block by Diagonals tool in the Message Line. The Message Line reads: Block Primitiv...
	3. Click two points in the drawing area to specify two diagonal corners of the block’s base.
	4. After the first two points are placed The Message Line reads: Block Primitive: Enter height.
	5. Drag to set the height of the block.

	Geometric Characteristics

	Cylinder Primitive Tool
	Cylinder 1 Point Tool
	Using the Cylinder 1 Point Tool
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder 1 Point tool in the Message Line. The Message Line reads: Cylinder Primiti...
	3. Click a point in the drawing area.

	Cylinder 2 Point Tool
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder Two Point tool in the Message Line. The Message Line reads: Cylinder Primi...
	3. Click two points in the drawing area.

	Cylinder by Diagonals Tool
	1. Select the Cylinder Primitive tool.
	2. Select the Cylinder by Diagonals tool in the Message Line. The Message Line reads: Cylinder Pr...
	3. Click two points in the drawing area to specify two diagonal corners of the cylinder base’s bo...
	4. The Message Line reads: Cylinder Primitive: Enter height.
	5. Drag to set the height of the cylinder.

	Geometric Characteristics

	Cone Primitive Tool
	Cone 1 Point Tool
	1. Select the Cone Primitive tool.
	2. Select the Cone 1 Point tool in the Message Line. The Message Line reads: Cone Primitive: Ente...
	3. Click a point in the drawing area.

	Cone 2 Point Tool
	1. Select the Cone Primitive tool.
	2. Select the Cone 2 Point tool in the Message Line. The Message Line reads: Cone Primitive: Ente...
	3. Click in the drawing area to set the start (center) point and the end (tip) point of the cone.

	Cone by Diagonals Tool
	1. Select the Cone Primitive tool.
	2. Select the Cone by Diagonals tool in the Message Line. The Message Line reads: Cone Primitive:...
	3. Click two points in the drawing area to specify two diagonal corners of the cone base’s boundi...
	4. Drag to set the height of the cone.

	Geometric Characteristics

	Torus Primitive Tool
	Torus 1 Point Tool
	1. Select the Torus Primitive tool.
	2. Select the Torus 1 Point tool in the Message Line. The Message Line reads: Torus Primitive: En...
	3. Click in the drawing area to set the center.

	Torus 2 Point Tool
	1. Select the Torus Primitive tool.
	2. Select the Torus 2 Point tool in the Message Line. The Message Line reads: Torus Primitive: En...
	3. Click the center point and the radius point in the drawing area.

	Torus by Diagonals Tool
	1. Select the Torus Primitive tool.
	2. Select the Torus by Diagonals tool in the Message Line. The Message Line reads: Torus Primitiv...
	3. Click twice to specify two diagonal corners of the torus’ bounding box.
	4. The Message Line reads: Torus Primitive: Enter height.
	5. Drag to set the height of the torus.

	Geometric Characteristics

	Prism Primitive Tool
	Prism 1 Point Tool
	1. Select the Prism Primitive tool.
	2. Select the Prism 1 Point tool in the Message Line. The Message Line reads: Prism Primitive: En...
	3. Click in the drawing area to set the base's center point.

	Prism 2 Point Tool
	1. Select the Prism Primitive tool.
	2. Select the Prism 2 Point tool in the Message Line. The Message Line reads: Prism Primitive: En...
	3. Click in the drawing area to set the start point (center) and the end point (height).

	Prism by Diagonals Tool
	1. Select the Prism Primitive tool.
	2. Select the Prism by Diagonals tool in the Message Line. The Message Line reads: Prism Primitiv...
	3. Click two points in the drawing area to specify two diagonal corners of the prism base’s bound...
	4. The Message Line reads: Prism Primitive: Enter height.
	5. Drag to set the height of the prism.

	Geometric Characteristics

	Pyramid Primitive Tool
	Pyramid 1 Point Tool
	Using the 1 Point Pyramid Tool
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid 1 Point tool in the Message Line. The Message Line reads: Pyramid Primitive...
	3. Click in the drawing area to set the center.

	Pyramid 2 Point Tool
	Using the 2 Point Pyramid Tool
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid Two Point tool in the Message Line. The Message Line reads: Pyramid Primiti...
	3. Click two points in the drawing area.

	Pyramid by Diagonals Tool
	1. Select the Pyramid Primitive tool.
	2. Select the Pyramid by Diagonals tool in the Message Line. The Message Line reads: Pyramid Prim...
	3. Click two points in the drawing area to specify two diagonal corners of the pyramid base’s bou...
	4. The Message Line reads: Pyramid Primitive: Enter height.
	5. Drag to set the height of the pyramid.

	Geometric Characteristics

	Ellipsoid Primitive Tool
	Ellipsoid 1 Point Tool
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid 1 Point tool in the Message Line. The Message Line reads: Ellipsoid Primi...
	3. Click a point in the drawing area.

	Ellipsoid 2 Point Tool
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid 2 Point tool in the Message Line. The Message Line reads: Ellipsoid Primi...
	3. Click the center point and radius point in the drawing area.

	Ellipsoid by Diagonals Tool
	1. Select the Ellipsoid Primitive tool.
	2. Select the Ellipsoid by Diagonals tool in the Message Line. The Message Line reads: Ellipsoid ...
	3. Click two points in the drawing area to specify two diagonal corners of the ellipsoid’s boundi...
	4. The Message Line reads: Ellipsoid Primitive: Enter height.
	5. Drag to set the height of the ellipsoid.

	Geometric Characteristics


	Solids Creation Tools - Profiles
	Lathed Solid Tool
	Using the Lathed Solid Tool
	1. Click the Lathe Solid tool. The Message Line reads: Lathed Solid: Select objects to lathe [Shi...
	2. The Status Line contains the Degree and Draft Angle fields. Enter the desired values for your ...
	3. Pick a curve or curves to lathe. If you are selecting more than one curve, hold down the SHIFT...
	4. Pick the line around which to rotate the curves and make the solid object.

	Geometric Characteristics

	Extrude Solid Tool
	Using the Extrude Solid Tool
	1. Click the Extrude Profile tool. The Message Line reads: Extrude Solid: Select close objects to...
	2. The Status Line contains the dX, dY and dZ values, the Distance of the extrusion vector and th...
	3. Pick one or more curves to extrude. As the Message Line indicates, they must be closed. If the...
	4. Pick two points on the screen. The extruded solid is created.

	Geometric Characteristics

	Swept Solid Tool
	Using the Swept Solid Tool
	1. Click the Swept Solid tool. The Message Line reads: Swept Solid: Select closed profile to swee...
	2. The Status Line contains the Twist Angle and Draft Angle data fields. Enter the twist angle th...
	3. Pick one or more curves for the profile. As the Message Line indicates, they must be closed. I...
	4. Pick the point on the screen where you want the sweep to begin.
	5. Pick the curve or curves along which to sweep the profile.

	Geometric Characteristics

	Sweep 2 Rail (Paths) Solid
	Using the Sweep 2 Rail Solid Tool
	1. Select the Sweep 2 Rail Solid tool. The Message Line reads: Sweep 2 Rail Solid: Pick curves or...
	2. Pick the curves or group that defines the profile you want to sweep.
	3. Choose the first rail that your profile will be swept along.
	4. Choose the second rail that your profile will be swept along.

	Geometric Characteristics

	Cutout Feature Tool
	Using the Cutout Feature Tool
	1. Create a 2D profile with a curve or polygon tool and place it on or in the solid where the cut...
	2. Select the Cutout Feature tool. The Message Line reads: Cutout Feature: Pick solid for cutout.
	3. Select the solid to be cut. The Message Line now reads, Cutout Feature: Pick closed curves or ...
	4. Select the profile previously created.
	5. Specify two points in the drawing area to indicate the direction and length of the cutout.

	Geometric Characteristics

	Protruded Feature Tool
	Using the Protruded Feature Tool - Vector Option
	1. Create a 2D profile where the protrusion will begin.
	2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: Pick solid for p...
	3. Select the Vector Termination Type from the pull-down menu in the Message Line.
	4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or polygon for a...
	5. Select the profile previously created.
	6. Specify two points for protrusion direction and length.

	Using the Protruded Feature Tool - Face Option
	1. Create a 2D profile where the protrusion will begin. (It need not be on the solid.)
	2. Select the Protruded Feature tool. The Message Line reads: Protruded Feature: Pick solid for p...
	3. Select the To Face Termination Type from the pull-down menu in the Message Line.
	4. Select a solid. The Message Line reads: Protruded Feature: Pick closed curves or polygon for a...
	5. Select the profile previously created.
	6. Select the face on the solid where you want the protrusion to end.
	7. Specify two points for the protrusion direction. Since you are specifying the direction, not t...

	Geometric Characteristics

	Cutout and Protruded Curve Checks
	Curve Gap Check
	Planar Curves Check

	Skinned Solid Tool
	Skin Curve Solid Tool
	1. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed curve(s) or ...
	2. Select the Skin Curve Solid tool in the Message Line.
	3. Hold down the SHIFT key and select the closed curves.

	Skin with Guide Curves Solid Tool
	1. Create the profile curves and curve guides.
	2. Select the Skinned Solid tool. The Message Line reads: Skinned Solid: Pick closed curve(s) or ...
	3. Select the Skin with Guide Curves Solid tool (the right tool) in the Message Line.
	4. Hold down the SHIFT key and select the closed curves.
	5. Select the guide curves.

	Geometric Characteristics

	Solids from Profiles Curve Checks
	Close Curves Check

	Pipe Solid Tool
	Using the Pipe Solid Tool
	1. Click the Pipe Solid tool. The Message Line reads: Pipe Solid: Select curve for pipe path [Shi...
	2. Enter values in the Status Line data fields.
	3. Select the curve. If you want to select more than one curve, hold down the SHIFT key before se...

	Geometric Characteristics


	General Editing Tools
	Fillet and Chamfer Tools
	2-Entity Fillet Tool
	1. Select the 2-Entity Fillet tool. The Message Line reads: 2-Entity Fillet: Pick first entity. [...
	2. Enter the arc radius you want in the Status Line. The default radius is .50 inch.
	3. Click the first curve. The Message Line reads: 2-Entity Fillet: Pick second entity. [Ctrl=No t...

	3-Entity Fillet Tool
	1. Select the 3-Entity Fillet tool. The Message Line reads: 3-Entity Fillet: Pick three entities ...
	2. Click the three objects you want to fillet.
	1. Select the 2-Entity Chamfer tool.
	2. In the Status Line specify the chamfer's distance from the corner. (The default distance is .5...
	3. Click the first curve. The Message Line reads: 2-Entity Chamfer: Pick second entity. [Ctrl=No ...

	Angular Chamfer Tool
	1. Select the Angular Chamfer tool. The Message Line reads: Angular Chamfer: Pick first entity [C...
	2. In the Status Line, enter the length for the intersection of the chamfer and the second line o...
	3. In the Status Line also enter the angle you want between the chamfer and the second side. The ...
	4. Click the first curve. The Message Line reads: Angular Chamfer: Pick second entity. [Ctrl=No t...


	Trim Tools
	Simple Trim Tool
	1. Select the Simple Trim tool. The Message Line reads: Simple Trim: Select boundaries for simple...
	2. Select the object that limits the trim.
	3. Click the section of the object to be discarded.

	Relimit Tool
	1. Select the Relimit tool. The Message Line reads: Relimit: Select boundaries for relimit [Shift...
	2. Select the object that limits the change.
	3. Click the section of the object that you want to retain.

	Segment Tool
	1. Select the Segment tool. The Message Line reads: Segment: Select boundaries for segment [Shift...
	2. Select the objects that limits the segmentation.
	3. Click the object to be segmented.

	Divide Tool
	1. Select the Divide tool. The Message Line reads: Divide: Pick curve to divide [Shift=Extend].
	2. Set the #Segs (number of segments) value in the Status Line.
	3. Select the object to divide.

	Corner Trim Tool
	1. Select the Corner Trim tool. The Message Line reads: Corner Trim: Pick portion of first entity...
	2. Select the first curve. The Message Line reads: Corner Trim: Pick portion of second entity to ...
	3. Select the second object.

	Divide at Location Tool
	1. Select the Divide at Location tool. The Message Line reads: Divide at Location: Pick curve to ...
	2. Select the curve. The Message Line reads: Divide at Location: Pick divide point.
	3. Choose the point on the curve where you want it divided.

	Connect Curve Tool
	1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select two curves to con...
	2. Select the first curve near the endpoint where you want to connect the curve.
	3. Select the second curve near the endpoint that you want to move.
	1. Select the Connect Curve tool. The Message Line reads: Connect Curve: Select two curves to con...
	2. If desired, specify a tolerance distance in the Status Line to which the resulting curves will...
	3. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and select the two curves.


	Curve Utility Tools
	Offset Curve Tool
	1. Select the Offset Curve tool.
	2. Select the Offset to Value tool in the Message Line. The Message Line reads: Offset Curve: Pic...
	3. Enter an offset distance in the Offset data field of the Status Line.
	4. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter offset direction.
	5. Pick a point on either side of the curve or edge to specify the offset direction. The offset d...
	1. Select the Offset Curve tool.
	2. Select the Offset to Value tool in the Message Line. The Message Line reads: Offset Curve: Pic...
	3. Enter an offset distance in the Offset data field of the Status Line.
	4. Select the curves or edges to offset. The Message Line reads: Offset Curve: Enter offset direc...
	5. Select the type of offset you desire.
	1. Select the Offset Curve tool.
	2. Select the Offset by Point tool in the Message Line. The Message Line reads: Offset Curve: Pic...
	3. Select the curve or edge to offset. The Message Line reads: Offset Curve: Enter offset point.
	4. Pick the desired point for the offset. Our Designer Elements program offsets the curve to that...
	1. Select the Offset Curve tool.
	2. Select the Offset by Point tool in the Message Line. The Message Line reads: Offset Curve: Pic...
	3. Select the curves to offset. The Message Line reads: Offset Curve: Enter offset point.
	4. Select the type of offset you desire.
	5. Pick the desired point for the offset. Our Designer Elements program offsets the curve to that...

	Extrude Curve Tool
	1. Click the Extrude Curve tool. The Message Line reads: Extrude Curve: Pick curves to extrude [S...
	2. Select the curve(s) to extrude. The Message Line reads: Extrude Curve: Specify two points for ...
	3. Click two points to indicate where the new extruded curve will be placed. The direction of the...

	Revolve Curve Tool
	1. Select the Revolve Curve tool. The Message Line reads: Revolve Curve: Pick curves to revolve [...
	2. Select the curve(s) to revolve. The Message Line reads: Revolve Curve: Specify revolution origin.
	3. Click a point about which to revolve the curve. The Message Line reads: Revolve Curve: Specify...
	4. Click two points to indicate the axis of revolution. The direction of the revolution is specif...

	Project Curve Tool
	1. Select the Project Curve tool. The Message Line reads: Project Curve: Pick curves to project [...
	2. From the pull-down menu in the Status Line choose the projection plane.
	3. Select the curves to project. Hold down the SHIFT key or drag a selection fence to select mult...
	4. Pick the point on the projection plane where the curves should be projected. The selected line...

	Explode Edge Tool
	1. Select the Explode Edge tool. The Message Line reads: Explode Edge: Pick edges to explode [Shi...
	2. Select the surface or solid edge or Iso line from which you want to create a curve.



	Surface Editing Tools and Features
	Solid Editing Tools
	Plane/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick ...
	2. Click the plane you want to use to intersect the curve. Hold down the SHIFT key to pick more t...
	3. Click the curves that you want to intersect with the plane.
	1. Select the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick ...
	2. Click the plane you want to use to intersect the surface. Hold down the SHIFT key to pick more...
	3. Click the surface that you want to intersect with the plane.
	1. Click the tool in the tool palette. The Message Line reads: Plane/Surface Intersection: Pick p...
	2. Click the plane you want to use to intersect the solid. Hold down the SHIFT key to pick more t...
	3. Click the solid that you want to intersect with the plane.

	Curve/Surface Projection Tool
	1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Projection: Pick cu...
	2. Click the curve to project onto the surface (it does not highlight). Hold down the SHIFT key t...
	3. Click the surface or solid onto which you want to project the curve.
	4. Enter 2 points for the projection vector as directed by the Message Line.
	1. Click the tool in the tool palette. The Message Line reads: Curve/Surface Projection: Pick cur...
	2. Click the curve to project onto the solid (it does not highlight). Hold down the SHIFT key to ...
	3. Click the solid onto which you want to project the curve.
	4. Enter 2 points for the projection vector as directed by the Message Line.

	Surface/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Surface/Surface Intersection: Pic...
	2. Click on the two surfaces. An intersection curve displays.
	1. Click the tool in the tool palette. The Message Line reads: Surface/Surface Intersection: Pick...
	2. Click the two surfaces. An intersection curve displays.

	Curve/Surface Intersection Tool
	1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersection: Selec...
	2. Click the curve to intersect the surface. Hold down the SHIFT key to pick more than one curve....
	3. Click the surface to intersect with the curve. The intersection points display.
	1. Select the tool in the tool palette. The Message Line reads: Curve/Surface Intersection: Selec...
	2. Click the curve to intersect the solid. Hold down the SHIFT key to pick more than one curve. T...
	3. Click the solid to intersect with the curve. The intersection points display.

	Boolean Surface Tools
	1. Select the Boolean Surface tool.
	2. Select the Add Boolean Surface tool in the Message Line. The Message Line reads: Boolean Surfa...
	3. Select the surface to which you will add another. The Message Line reads: Boolean Surface: Pic...
	4. Select the surface to be added.
	1. Select the Boolean Surface tool.
	2. Select the Subtract Boolean Surface tool in the Message Line. The Message Line reads: Boolean ...
	3. Select the surface from which you will subtract another. The Message Line reads: Boolean Surfa...
	4. Select the surface to be subtracted. One surface is subtracted from the other.
	1. Select the Boolean Surface tool.
	2. Select the Intersect Boolean Surface tool in the Message Line. The Message Line reads: Boolean...
	3. Select the surface with which you will intersect another. The Message Line reads: Boolean Surf...
	4. Select the surface to be intersected. The intersecting portion of the surfaces is displayed.

	Connect Surface Tool
	1. Click the Connect Surface tool in the tool palette. The Message Line reads: Connect Surface: P...
	2. Click the two surfaces that you want to connect. The surfaces become one surface but retain th...

	Split Surface Tool
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick...
	2. Select the surface that you want to split. The Message Line reads: Split Surface: Pick curves,...
	3. Select the entity that defines the trim area. Our Designer Elements program splits the surface...
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick...
	2. Select the surface that you want to trim. The Message Line reads: Split Surface: Pick curves, ...
	3. Select the entity that defines the trim area. Our Designer Elements program splits the surface...
	1. Select the Split Surface tool in the tool palette. The Message Line reads: Split Surface: Pick...
	2. Select the surface that you want to split. The Message Line reads: Split Surface: Pick curves,...
	3. Select the entity that defines the split area. Our Designer Elements program splits the surfac...

	Silhouette Curves Tool
	1. Select the Silhouette Curves tool, The Message Line reads: Silhouette Curves: Pick surface/sol...
	2. Select the objects on which you want silhouette curves. The message line now reads, Silhouette...


	Local Surface Tools
	Match Surface Tool
	1. Select the Match Surface tool.
	2. From the pull-down menu in the Message Line, select Match G1 Slope. The Message Line reads: Ma...
	3. Click on the edge of the surface you want to modify.
	4. Click on the surface edge to which you are matching the first surface.
	1. Select the Match Surface tool.
	2. From the pull-down menu in the Message Line, select Match G2 Slope. The Message Line reads: Ma...
	3. Click on the edge of the surface you want to modify.
	4. Click on the surface edge to which you are matching the first surface.

	Rebuild Surface Tool
	1. Select the Rebuild surface tool. The Message Line reads: Rebulid Surface:Pick surface to rebuild.
	2. Click the surface to rebuild.

	Untrim Surface Tool
	1. Select the Untrim Surface tool.
	2. From the pull-down menu in the Message Line, select Untrim Surface. The Message Line reads: Un...

	Elevate Surface Tool
	1. Select the surface to which you want to add control points.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Select the Elevate Surface tool.
	7. From the pull-down menu in the Message Line select: Elevate Degree. The Message Line reads: El...
	8. Select the surface.

	Insert Knot Tool
	1. Select the surface to which you want to add control points.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Select the Insert Knot tool.
	7. From the pull-down menu in the Message Line select Insert Knot. The Message Line reads: Insert...
	8. Select the surface. The Message Line now reads: Insert Knot: Specify location for new knot.
	9. Select a location along an edge of the surface for the new row or column of knots.


	Surface Control Vertex Modification
	Performing a Control Vertex Modification
	1. Select the surface you want to modify.
	2. Choose Window>Edit Objects to verify that the surface is a surface face.
	3. Choose Edit>Change Object Type.
	4. Select the Surface option and click OK.
	5. Choose Edit>Show Points to display the surface control points.
	6. Using the Selection tool, drag the control points as desired.


	Surface Evaluation
	Evaluation Through the Verify Menu
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Curvature.
	3. Select a Plot style, if the desired style is not already selected.
	4. To display a certain analysis/color area, place the pointer at the location over the color spe...
	5. To remove the triangular indicator click in the dialog box outside of the color spectrum bar.
	6. Change the histogram values in the data fields and the histogram and analysis automatically re...
	1. Select the object.
	2. Choose Verify>Surface Analysis>Draft Angle.
	3. To display a certain analysis/color area place the pointer at the location over the color spec...
	4. To remove the triangular indicator click in the dialog box outside of the color spectrum bar.
	5. Change the histogram values in the data fields and the histogram and analysis automatically re...
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Normals.
	1. Select the surface.
	2. Choose Verify>Surface Analysis>Zebra.

	Evaluation Through the Advanced Rendering Feature
	1. Select the surface.
	2. Double-click on the surface to display the Edit Objects dialog box.
	3. In the Material page of Edit Objects, click the Advanced button.
	4. From the Color class choose the surface evaluation type. The following window displays:
	5. Specify the value for each attribute.
	6. Click the Update button to preview your surface evaluation in the preview window.
	7. Click OK to save the changes and close the dialog box.
	8. Render your scene using one of the photorealistic commands in the Render menu.



	Solids Editing Tools - Features
	Blend Tools
	1. Create a curve along the z-axis.
	2. Select the Blend tool.
	3. In the Message Line select the Constant Blend tool and the Radial option for the pull-down men...
	4. Press CTRL (Windows) or OPTION (Macintosh) to display the Advanced Blend Options dialog box.
	5. Select the Specify Cross Section Orientation option and click OK to close the dialog box.
	6. Select the edge(s) for the blend.
	7. Select the curve.
	Constant Blend Tool
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend tool and the Radial option for the pull- down me...
	3. If you want a setback enter the value in the Status Line data field.
	4. Select the edge(s) and/or face(s) for the blend.
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend tool and the Elliptical option from the pull-dow...
	3. Enter a radius values for the ellipse, R1 and R2, in the Status Line data field. R1 is the maj...
	4. Select the edge(s) for the blend.
	1. Select the Blend tool.
	2. In the Message Line select the Constant Blend tool and the Vertex Blend option from the pull-d...
	3. Enter a radius in the Status Line data field.
	4. Select the vertex for the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down m...
	3. Press CTRL (Windows) or Option (Macintosh) to display the Advanced Blend Options dialog box.
	4. Turn off the Automatic Chain-select of Shared Edges option and click OK.
	5. Enter the desired radius in the Status Line.
	6. Select each of the edges individually to create a mitered intersection. (If you hold down the ...
	1. Select the object.
	2. Choose Window>Design Explorer.
	3. Expand the history tree to display the fillet blend.(Cobalt™ and Xenon™ only)
	4. Double-click on the fillet blend to display the Edit Objects dialog box.
	5. Select the edge with the radius you want to change. The radius value appears in the data field...
	6. Click Apply to accept the changes and your geometry updates.
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down m...
	3. Hold the SHIFT key down and select the objects. The Message Line now reads, Constant Blend: Sp...
	4. Click the help position location. (If the help position does not create the blend try another ...
	1. Select the Blend tool.
	2. In the Message Line, select the Constant Blend tool and the Radial option from the pull-down m...
	3. Enter the radius in the Status Line.
	4. Select the edge to blend.

	Variable Blend Tool
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Linear option from the pull-down m...
	3. Select the edge along which to make the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the By Position option from the pull-d...
	3. Select the edge along which to make the blend. The Message Line reads: Position Blend: Specify...
	4. Enter a radius in the R field of the Status Line.
	5. Specify the location(s) along the selected edge for the radius.
	6. Enter a new radius in the R field.
	7. Specify the location for this radius along the edge.
	1. Create the curve that will be referenced for the blend.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Radius Curve option from the pull-...
	3. Select the solid edge. The Message Line now reads, Radius Curve Blend: Pick radius curve (in p...
	4. Select the radius curve.
	1. Select the Blend tool.
	2. In the Message Line, select the Variable Blend tool and the Fixed Width option from the pull-d...
	3. Enter the fixed width for the blend in the Status Line.
	4. Select the edge for the blend.
	1. Create a hold line curve.
	2. Select the Blend tool.
	3. In the Message Line, select the Variable Blend tool and the Hold Line option from the pull-dow...
	4. Select the edge for the blend. The Message Line now reads, Hold Line Blend: Pick curve for hol...
	5. Select the hold line curve.


	Chamfer Edge Tools
	Constant Length Chamfer Tool
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length option from the pu...
	3. Enter a setback value in the Setback data field of the Status Line, if desired, for three or m...
	4. Select the edge(s) to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Two Lengths option from t...
	3. Enter L1 and L2 values in the Status Line.
	4. Select the edge(s) to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length Angle option from ...
	3. Enter an L1 and angle in the Status Line data fields.
	4. Select the edge(s) to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Constant Length Chamfer tool and the Vertex Chamfer option from...
	3. Enter an L1 value in the Status Line data field.
	4. Select the vertex to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Constant Length Chamfer tool and the Length option from the pu...
	3. Enter a setback value in the Setback data field.
	4. Hold down the SHIFT key and select the edges to chamfer them.
	5. Using the Design Explorer, double- click on the chamfer to display the Edit Object dialog box.
	6. In the edge list select an edge. It’s associated L1 value appears in the length data field.
	7. Enter a new value in the field.
	8. Click apply and the chamfer updates.

	Variable Chamfer Edge Tool
	You have five variable length options: Lengths, Four Lengths, Lengths Angles, By Position and Fix...
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the Lengths option from the p...
	3. Enter the L1 (the beginning setback length of the chamfer) and L2 (the ending setback length o...
	4. Select the edge to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Variable Length Chamfer tool and the Four Lengths option from t...
	3. Enter the L1 and L2 values for the beginning setback lengths of the chamfer and L3 and L4 valu...
	4. Select the edge(s) to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the Lengths Angles option fro...
	3. Enter an L1 and A1 (angle) for the beginning of the chamfer and L2 and A2 (angle) for the end ...
	4. Select the edge(s) to chamfer.
	1. Select the Chamfer Edge tool.
	2. In the Message Line, select the Variable Length Chamfer tool and the By Position option from t...
	3. Select the edge along which to make the chamfer. The Message Line reads: Position Chamfer: Spe...
	4. Enter a setback length in the Length field of the Status Line.
	5. Specify the location(s) along the selected edge for the chamfer.
	6. Enter a new length in the Length field.
	7. Specify the location for this length along the edge.
	1. Select the Chamfer Edge tool.
	2. In the Message Line select the Variable Length Chamfer tool and the Fixed Width option from th...
	3. Enter a width in the W data field of the Status Line.
	4. Pick the edge(s) for the chamfer.


	Hole Feature Tools
	Hole Direction
	Simple Hole Tool
	1. Select the Hole tool.
	2. In the Message Line select the Simple Hole tool. The Message Line reads: Simple Hole: Pick sol...
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message ...
	4. Select the face where you want to locate the hole.
	5. Select the location for the center of the hole.
	6. If you selected the 2-Pts direction click two points to specify the direction.

	Counter Bore Tool
	1. Select the Hole tool.
	2. In the Message Line select the Counter Bore Hole tool. The Message Line reads: Counter Bore: P...
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message ...
	4. Select the face to place the counter bore.
	5. Specify the location for the center of the counterbore hole.
	6. If you selected the 2-Pts direction click two points to specify the direction.

	Counter Sink Tool
	1. Select the Hole tool.
	2. In the Message Line select the Counter Sink Hole tool. The Message Line reads: Counter Sink Ho...
	3. Select a Through Type and Hole Direction from their respective pull-down menus in the Message ...
	4. Select the face where you want to locate the hole.
	5. Select the location for the center of the hole.
	6. If you selected the 2-Pts direction click two points to specify the direction.


	Boss Feature Tool
	Boss Direction
	Using the Boss Feature Tool
	1. Select the Boss Feature tool. The Message Line reads: Boss Feature: Pick solid face to place b...
	2. Select the boss direction from the pull-down menu.
	3. Select the face to locate the boss.
	4. Specify a location for the boss center.
	5. If you selected the 2-Pts direction click two points to specify the direction.

	Geometric Characteristics

	Feature Editing
	1. Create a block primitive.
	2. Fillet the block's edges.
	3. Place a boss at the block's center.
	4. Place a countersink hole at the boss' top center.
	5. Select a face or edge from the original block. Choose Window>Edit Objects and change the block...
	6. Select the block. Choose Window>Design Explorer. Click on the + sign to display the history tr...
	7. In the Design Explorer select one of the boss' face names. The Edit Object dialog box now disp...
	Shell Solid Tool
	1. Select the Shell Solid tool. The Message Line reads: Shell Solid: Pick solid to shell.
	2. In the Status Line, enter the desired offset or thickness of the shell.
	3. Select the solid. The Message Line reads: Shell Solid: Pick open faces [Shift=Extend].
	4. Select the face or faces that will be open. The object shells.
	1. Select the shelled solid.
	2. Choose Window>Design Explorer.
	3. Open the history tree for the solid by clicking on the + (plus sign).
	4. Select the shell operation.
	5. Choose Window>Edit Objects.
	6. Select the desired face. (As you move through the list of faces, the selected face is highligh...
	7. Make any desired modifications.
	8. Click Apply to accept the changes.

	Bend Solid Tool
	1. Click the Bend Solid tool. Select the first tool in the Message Line. The Message Line reads: ...
	2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired values for y...
	3. Pick the solid that you wish to bend
	4. The message line now reads, Bend Solid: Enter two points for bend axis. Specify two points for...
	5. The Message Line now reads, Bend Solid: Pick Solid to Bend [Option = Flip Material]. Hit the o...
	1. Click the Bend Solid tool. Select the first tool in the Message Line. The Message Line reads: ...
	2. The Status Line contains the Bend Radius and Bend Angle fields. Enter the desired values for y...
	3. Pick the solid that you wish to bend
	4. The message line now reads, Bend Solid: Enter two points for bend axis. Specify two points for...
	5. The Message Line now reads, Center Bend Solid: Pick Solid to Bend [Ctrl or Option = Flip Mater...
	1. Click the Bend Solid tool. Select the first tool in the Message Line. The Message Line reads: ...
	2. Pick the solid that you wish to bend
	3. The message line now reads, Bend Solid Along Path: Pick curve to bend solid to. Choose your cu...
	4. The Message Line now reads, Bend Solid: Enter two points for bend height axis. Specify two poi...
	5. The Message Line now reads, Bend Solid: Enter two points for alignment axis. Choose the points...



	Solid Utilities and Features
	Solid Utility Tools
	Boolean Tools
	1. Select the Boolean tool.
	2. In the Message Line select the Union Solid tool. The Message Line reads: Union Solid: Pick sol...
	3. Select the solid to which you want to add.
	4. Select the solid(s) that you want to add to the first solid. Hold down the SHIFT key before yo...
	1. Select the Boolean tool.
	2. In the Message Line select the Subtract Solid tool. The Message Line reads: Subtract Solid: Pi...
	3. Select the solid from which you want to subtract.
	4. Select the solid(s) that you want to subtract from the first solid. Hold down the SHIFT key be...
	1. Select the Boolean tool.
	2. In the Message Line select the Intersect Solid tool. The Message Line reads: Intersect Solid: ...
	3. Select the two solids to form the intersect solid.

	Trim Solid Tool
	1. Click the Trim Solid tool. The Message Line reads: Trim Solid: Pick curve, surface or solid to...
	2. The Message Line now reads, Trim Solid: Pick solid to trim [Crtl (Windows) or Option (Macintos...
	3. The solid is trimmed to the curve, removing the solid in the direction of the arrows.
	4. Press the Control or Option key if you want to change the material that is kept.

	Split Solid Tool
	1. Select the Split Solid tool. The Message Line reads: Split Solid: Pick solid to split.
	2. Select the solid. The Message Line reads: Split Solid: Pick surface for splitting solid.
	3. Select the infinite plane or surface to split the solid.

	Stitched Solid Tool
	1. Select the Stitched Solid tool. The Message Line reads: Stitched Solid: Pick surfaces to creat...
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Stitching Options dialog...
	3. Specify the settings and click OK. Click Cancel to close the dialog box.
	4. Hold down the SHIFT key and select the surfaces or drag a selection fence around them.

	Thicken Solid Tool
	1. Select the Thicken Solid tool. The Message Line reads: Thicken Solid: Pick surface or solid to...
	2. Type the desired thickness in the Thickness data field in the Status Line.
	3. Select the surface or solid object to be thickened. This Designer Elements program thickens th...


	Lofted Solid Tool
	Using the Lofted Solid Tool
	1. Select the Lofted Solid tool. The Message Line reads: Lofted Solid: Pick two faces for lofted ...
	2. Enter a value in the Bulge data field.
	3. Select a solid face.
	4. Select a face on the other solid.

	Geometric Characteristics

	Rib Solid Tool
	1. Select the Rib Solid tool. The Message Line reads: Rib Feature: Pick solid for rib.
	2. Select the solid you want to add the rib to. The Message Line reads: Rib Feature: Pick rib pro...
	3. Once you select the rib profile The Message Line reads: Rib Feature: Specify 2 points for rib ...
	Lip Solid Tool
	1. Select the Lip Solid tool. The Message Line reads: Lip Feature Add: Pick curves for lip profil...
	2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify profile or...
	3. The Message Line reads: Lip Feature Add: Pick edges for profile to sweep. [Shift = Extend]
	4. Pick the edges of the solid you want to add the lip feature to. In the example above, the edge...
	1. Select the Lip Solid tool. The Message Line reads: Lip Feature Remove: Pick curves for lip pro...
	2. Select the curves for the lip profile. The Message Line reads: Lip Feature: Specify profile or...
	3. The Message Line reads: Lip Feature Remove: Pick edges for profile to sweep. [Shift = Extend]
	4. Pick the edges of the solid you want the lip feature profile to be removed from. In the exampl...

	Local Face Modeling Tools
	1. Select the Draft Solid tool. The Message Line reads: Draft Solid: Pick reference face or edge ...
	2. Select the reference face, edge or work plane. This tells your Designer Elements program the p...
	3. Select a face or hold down the SHIFT key to select more than one face. The Message Line now re...
	4. Click a point on the screen to serve as the neutral position. The neutral position will remain...
	1. Select the Match Face tool.The Message Line reads: Match Face: Pick face to modify.
	2. Select the face of the solid you want to modify or match to another face. To select more than ...
	3. Select the face of the solid that you want the selected face to match.

	The Move Face Tool
	1. Select the Move Face tool.The Message Line reads: Move Face: Pick faces of a solid to move [Sh...
	2. Select the face(s) of the solid you want to move. To select more than one face hold down the S...
	3. Select the two points to specify dX, dY, dZ values for the move. The order you select your poi...
	1. Select the Offset Face Modeling tool.
	2. The Message Line reads: Offset Face: Pick faces of a solid to offset [Shift=Extend].
	3. In the Status Line enter a value in the data field. A positive value enlarges the object and a...
	4. Select the face of the solid you want to offset. To select more than one face be sure to hold ...
	1. Select the Remove Face tool.
	2. The Message Line reads: Remove Face: Pick faces of a solid to remove [Shift=Extend].
	3. Select the face of the solid you want to remove. To select more than one face be sure to hold ...
	1. Select the Replace Face tool.
	2. The Message Line reads: Replace Face: Pick face to replace.
	3. Select the face of the solid you want to replace. To select more than one face be sure to hold...
	4. Select the replacement face.
	1. Select the Rectangle tool and trace over the top face of the block.
	2. Select the Through Point B-Spline tool and create a three point spline from the midpoint of th...
	3. Using the Selection tool, drag select the center control point of the spline and drag it up al...
	4. Select the Net Surface tool.
	5. Select the M curves consisting of the left edge, spline and right edge curves, (curves 1, 2 an...
	6. Select the N curves consisting of the top and bottom curves (curves 1 and 2 in the graphic) tw...
	7. Select the Replace Face tool.
	8. Select the top face of the block to replace.
	9. Select the net surface you just created to replace the face.
	10. Now render the block.

	Parting Line Solid Tool
	1. Select the Parting Line tool. The Message Line reads: Parting Line Solid: Pick solid for parti...
	2. Select the solid that you want to part. The Message Line reads: Parting Line Solid: Pick curve...
	3. Select the parting line curves. To select more than one curve be sure to hold down the SHIFT k...

	Deform Face Tool
	1. Select the Deform Face tool.
	2. Select the Deform Face with Gain tool in the Message Line. The Message Line reads: Deform Face...
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the face or surface that you want to deform.
	1. Select the Deform Face tool.
	2. Select the Deform Face to Point tool in the Message Line. The Message Line reads: Deform Face:...
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the surface or face that you want to deform.
	5. Click a location on the selected surface/face to set the point from which the face deforms.
	6. Click the final location for the face point where the deformation begins.
	1. Select the Deform Face tool.
	2. Select the Deform Face to Curve tool in the Message Line. The Message Line reads: Deform Face:...
	3. Type the desired pressure in the Gain data field of the Status Line.
	4. Select the surface or face that you want to deform.
	5. Select the curve.


	Draft Evaluation Feature
	Draft Evaluation through Verify Menu
	1. Select the object.
	2. Choose Verify>Surface Analysis>Draft Angle.
	3. To display a certain analysis/color area, place the pointer at the location over the color spe...
	4. To remove the triangular indicator click in the dialog box outside of the color spectrum bar.
	5. Change the histogram values in the data fields and the histogram and analysis automatically re...

	Draft Evaluation through Advanced Rendering
	Using the Draft Evaluation Feature
	1. Double click on the object you want to evaluate to display the Edit Objects dialog box.
	2. Click the Advanced button to display the Render Material Settings dialog box.
	3. Select draft angle evaluation from the Shader Types list.
	4. Specify the settings for the attributes.
	5. Click OK to close the dialog box and save the settings.
	6. Render your object using one of the photorealistic commands.


	Assembly Modeling Tools
	Assembly Connect Tool
	1. Select the Assembly Connect tool. The Message Line reads: Assembly Connect: Pick solid to move.
	2. Select the solid.
	3. Using the Drafting Assistant select the connection point on the selected solid model.
	4. Select the solid to which you are moving the first solid.
	5. Using the Drafting Assistant select the connection point on the selected solid to which you wa...

	Assembly Mate Tool
	1. Select the Assembly Mate tool. The Message Line reads: Assembly Mate: Pick solid face to mate.
	2. Select the solid face you want to mate.
	3. Select the solid face you want to mate with.
	4. If you want the first solid offset a certain distance from the second, enter a value in the St...

	Assembly Align Tool
	1. Select the Assembly Align tool. The Message Line reads: Assembly Align: Pick solid face to align.
	2. Select the solid face you want to align.
	3. Select the solid face to align with.

	Assembly Insert Tool
	1. Select the Assembly Insert tool. The Message Line reads: Assembly Insert: Pick solid face to a...
	2. Select the solid face you want to align.
	3. Select the solid face to align with.
	4. Select the solid face you want to mate.
	5. Select the solid face you want to mate with
	6. If you want the first solid offset a certain distance from the second, enter a value in the St...



	Editing Commands
	Basic Editing Commands
	Cut - CTRL+X (Windows); z+X (Macintosh)
	1. Select the object to be cut.
	2. Choose Edit>Cut.
	1. Select the object(s) you want to move.
	2. Choose Edit>Cut.
	3. Display the location where you want the selection to appear�in�the drawing area, scrolling if ...
	4. Choose Edit>Paste.

	Copy - CTRL+C (Windows); z+C (Macintosh)
	1. Select the object(s) to be copied.
	2. Choose Edit>Copy.

	Copy Pict/Copy Bitmap
	Paste - CTRL+V (Windows); z+V (Macintosh)
	1. If the object was cut or copied from a Designer Elements program document, when it is pasted i...
	2. Objects cut or copied from non-Ashlar-Vellum documents are pasted onto the work layer.

	The Clipboard
	Erasing/Deleting Geometry
	Undo - CTRL+Z (Windows); z+Z (Macintosh)
	Redo

	Advanced Editing Commands
	Change Resolution
	1. Select the object whose resolution you want to change.
	2. Choose Edit>Change Resolution. The Object Resolution dialog box appears.
	3. Select the desired resolution.
	4. Click OK to save the resolution and close the dialog box.

	Change Layer
	1. Select the object that you want to move to a different layer.
	2. Choose Edit>Change Layer. The following Change Layer dialog box appears:

	Grouping Objects
	1. Select the objects to be grouped.
	2. Select Layout>Group>Group.
	1. Select the group.
	2. Choose Layout>Group>Ungroup. The geometry is ungrouped and the individual objects remain selec...
	3. Hold down the SHIFT key and select the geometry you want to add�to the group.
	4. Choose Layout>Group>Group.
	1. Select the group.
	2. Choose Layout>Group>Ungroup.
	1. Select the objects to be locked.
	2. Choose Layout>Group>Lock.
	1. Choose Edit>Select All.
	2. Choose Layout>Group>Lock.
	1. Choose Layout>Group>Unlock.
	2. Select the locked object by clicking on the object or dragging a selection fence around it. Th...

	Arrange Command
	Align Command
	1. Select the objects to align.
	2. Then choose the alignment tool from the Transformation tool palette. The Message Line reads: E...
	3. Choose the point at which you want the objects to align.


	Object Commands
	Change Direction
	1. Select the object whose direction you want to change.
	2. Click Edit>Change Direction.

	Change Object Type
	1. Create text using one of the Text tools.
	2. Choose Edit>Change Object Type.
	3. In the Change Type dialog box choose curves.
	4. Click OK.

	Simplify Object
	Edit Objects
	1. Select an object to edit.
	2. Choose Window>Edit Objects and the dialog box appears.
	3. Click on the tab containing the desired information.
	4. Change the information in an entry box by double-clicking the entry data field and typing a ne...
	5. Make changes in other entry fields as required.
	6. Click Apply and the changes automatically occur on your selected geometry.
	7. Click Close to close the Edit Objects dialog box.
	1. Select the object(s) to be moved.
	2. Choose Window>Edit Objects.
	3. Click the arrow for the Layer entry field.
	4. Pick the layer from the list.
	5. Choose Apply.

	Links
	Design Explorer
	1. Select the model which contains the feature you want to suppress.
	2. Choose Window>Design Explorer to display the history tree.
	3. Expand the tree to display the desired feature by clicking on the plus (+) sign to the left of...
	4. Select the desired feature.
	5. Click the right mouse button (Windows) or press the CONTROL key (Macintosh) to display the Des...
	6. Choose the Suppress Feature command.
	1. In the Design Explorer select the suppressed feature.
	2. Click the right mouse button (Windows) or press the CONTROL key (Macintosh) to display the Des...
	3. Choose the Unsuppress Feature command.
	1. Select the part.
	2. Open the Design Explorer and display the tree to expose the feature you want to reorder.
	3. In the Design Explorer menu select the Reorder Feature command.
	4. Click on the operation below which you want to move the selected operation.
	1. Select the feature in the Design Explorer that you want to move. The feature is selected in yo...
	2. Display the Design Explorer menu (Right mouse button - Windows, CONTROL+mouse button - Macinto...
	3. Select the Move command. The Message Line tells you to select a new center for the feature.
	4. Click a new center on your solid. The feature is repositioned.


	Verify Menu
	X, Y, Z Command
	Angle 3 Pts Command
	Distance Pt-Pt Command
	Minimum Distance Command
	Length Command
	Area Command
	Volume Command
	Properties Command
	Interference Command
	1. Display your model as a wireframe.
	2. Select the solids on which you want to perform the check.
	3. Choose Verify>Interference.
	4. If you want to retain these interference solids in your model check the Keep intersection soli...
	5. Click Save or Print if you would like to save or print the log of the interference solids.
	6. Click Done to close the dialog box.

	Object Counts Command
	Check Object Command


	Transforming Geometry
	Transformation Tools
	Move Tool
	1. Select the Move tool.
	2. Select the Move tool icon in the Message Line. The Message Line reads: Move: Select objects to...
	3. Select the object(s) to be moved.
	4. If necessary, use SHIFT-click to select more objects, and then pick a beginning point. The Mes...
	5. Click an ending reference point or drag the selected object(s) to a new location.

	Rotate Tools
	1. Select the Rotate tool.
	2. Select the Rotate 1 Pt tool in the Message Line. The Message Line reads: Rotate: Select items ...
	3. Select the objects that you want to rotate.
	4. Use SHIFT-click to select more objects. The Message Line also includes a pull- down menu for c...
	5. Select the rotation axis from the pull-down menu.
	6. Specify the center of rotation.
	1. Select the Rotate tool.
	2. Select the Rotate 3 Pts tool in the Message Line. The Message Line reads: Rotate: Select items...
	3. Select the objects that you want to rotate.
	4. Click the rotation point.
	5. Click the first reference point.
	6. Click the second reference point.

	Expand/Shrink and Scale Tool
	1. Select the Expand/Shrink tool. In The Message Line reads: Expand/Shrink: Select items to scale...
	2. Select the object(s) to scale. The option pull-down menu appears.
	3. Select the Uniform option from the menu. When you move the pointer into the drawing area the p...
	4. Click the anchor point on your geometry. This point remains fixed in the stretch. Use the SHIF...
	5. Click the beginning reference point.
	6. Click the ending reference point. The scale factor is calculated based on the beginning refere...
	1. Select the Expand/Shrink tool. In The Message Line reads: Expand/Shrink: Select items to scale...
	2. Select the object(s) to scale.
	3. Select the Differential option from the menu. When you move the pointer into the drawing area ...
	4. Enter the X, Y and Z Scale values in the Status Line.
	5. Click a point about which your object will be scaled.

	Mirror Tool
	1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	2. Select the object(s) to be mirrored.
	3. Select the 2 Pts option in the pull-down menu. The Message Line reads: Mirror: Select beginnin...
	4. Click a location to set the beginning of the reference line around which the object mirrors. T...
	5. Click to locate the end of the reference line.
	1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	2. Select the object(s) to be mirrored.
	3. Select the XY Plane option in the pull-down menu. The Message Line reads: Mirror 1 Pt: Enter 1...
	4. Click a point in the XY plane to specify a reference point for the mirror.
	1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	2. Select the object(s) to be mirrored. An option pull-down menu appears.
	3. Select the ZY Plane option in the pull-down menu. The Message Line reads: Mirror 1 Pt: Enter 1...
	4. Click a point in the ZY plane to specify a reference point for the mirror.
	1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	2. Select the object(s) to be mirrored. An option pull-down menu appears.
	3. Select the ZX Plane option in the pull-down menu. The Message Line reads: Mirror 1 Pt: Enter 1...
	4. Click a point in the ZX plane to specify a reference point for the mirror.
	1. Select the Mirror tool. The Message Line reads: Mirror: Select items to mirror [Shift = Extend].
	2. Select the object(s) to be mirrored.
	3. Select the 3 Pts option in the pull-down menu. The Message Line reads: Mirror 3 Pts: Enter 3 p...
	4. Click three points to specify a reference plane for the mirror.
	1. Select the Move tool.
	2. Select the Copy Along Path tool in the Message Line. The Message Line reads: Copy Along Path: ...
	3. Select the objects to copy.
	4. Enter the number of objects to copy in the Qty (Quantity) field of the Status Line.
	5. Click the path curve. The Message Line reads: Copy Along Path: Enter copy origin.
	6. Click the point where the copy should begin. The Message Line reads: Copy: Along Path: Enter t...
	7. Pick two points on the screen to show your Designer Elements program where to align the object...
	1. Select the Move tool.
	2. Select the Linear Duplicate tool in the Message Line. The Message Line reads: Linear Duplicate...
	3. Select the object(s) to be duplicated. The dialog box appears.
	4. Enter the number of columns in the Number per row data field.
	5. Select offset option, either Total or Step.
	6. If the Offset X* field is not selected, click in the field.
	7. Move the pointer to the drawing area and drag to indicate the offset for the row of copies. Va...
	8. Select the spacing option, either Total or Step.
	9. If the Spacing* field is not selected, click in the field.
	10. Move the pointer to the drawing area and drag to indicate the spacing for the spacing for the...
	11. Click OK to close the dialog box and create the duplicates.
	1. Select the Polar Duplicate tool
	2. The Message Line reads: Polar Duplicate: Select items to polar duplicate [Shift = Extend].
	3. Select the object to be duplicated. The dialog box appears.
	4. Enter the number of objects in the circular array.
	5. If the Center X* data field is not selected, click in the field.
	6. Move the pointer to the drawing area and click the center point of the array in the drawing ar...
	7. If you want objects to be upright with respect to the selected objects, select the Translate d...
	8. If you specified Translate duplicates, click a location for the reference point in the drawing...
	9. Select the angle option, Total or Step.
	10. Enter the angle of rotation in the Angle field or drag in your drawing area along the desired...
	11. Click OK.

	Align Objects Tool
	1. Choose the Selection tool.
	2. Hold down the SHIFT key and select the text and geometry you want to align.
	3. Choose the align tool from the Transformation tool palette.


	Transforming Techniques
	Moving Objects with Tools
	1. Select the Move tool.
	2. Select the square to be moved.
	3. Click one corner of the square when the endpoint notation is displayed.
	4. Enter 2 in the dX entry field on the Status Line and -1 in the dY entry field. A positive or n...
	5. Press the ENTER (Windows) or RETURN (Macintosh) key. The square is moved.

	Moving Objects to Another Layer
	1. Choose Window>Edit Objects.
	2. In the Layer field, scroll down to the layer on which you want the object.
	3. Click OK. The object is now located on the new layer.

	Copying Objects with Tools
	1. Choose the Selection tool.
	2. Select the object(s) you want copied.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Drag a copy of the selection to a new location. The copy is placed on the current work layer.
	1. Construct the geometry you want to copy.
	2. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	3. Click a new location. The click determines the location of the first point specified during th...
	1. Select one of the transformation tools.
	2. Select the object you want to copy and transform.
	3. Hold down the CTRL (Windows) or OPTION (Macintosh) key.
	4. Perform the transformation according to the directions in the Message Line.
	1. In the Edit menu, be certain that Selectable Points is set.
	2. Click the Selection tool.
	3. Drag a selection fence around the control points that represent the area you want to stretch.
	4. Drag the points to a new location.
	1. In the Edit menu, be sure that Selectable Points is set.
	2. Click the Selection tool.
	3. Drag a selection fence around the lower right corner of the rectangle.
	4. Select the Move tool.
	5. Enter +1 in the dX data field, a -1 in the dY field and a 0 in the dZ field.



	Text
	Text Tools
	Horizontal Text Tool
	1. Select the Horizontal Text tool from the main tool palette. The Message Line reads: Enter loca...
	2. Place the cursor at the beginning location for the text and click. The cursor becomes a text c...
	3. Enter the desired text. If you press ENTER (Windows) or RETURN (Macintosh), you begin a new an...

	Text Along a Curve Tool
	1. Create the curve along which you want the text, placing the points in the order that you want ...
	2. Select the Text Along a Curve tool from the main tool palette. The Message Line reads: Select ...
	3. Select the curve you just created. The cursor becomes a text cursor placed at the start point ...
	4. Enter the desired text. It displays horizontally.
	5. Press ENTER (Windows) or RETURN (Macintosh) and the text line molds to the curve.

	Text at an Angle Tool
	1. Select the Text at an Angle tool from the main tool palette The Message Line reads: Enter loca...
	2. In the Status Line, enter the angle for the text in the Angle data field. Press ENTER (Windows...
	3. Place the cursor at the beginning location for the text and click. The cursor becomes a text c...
	4. Enter the desired text. The text displays horizontally.
	5. Press ENTER (Windows) or RETURN (Macintosh) and the text angle changes.

	Geometric Characteristics
	BoundingBox Text Tool

	Text Commands
	Font
	Size
	1. Choose Text>Size>User.
	2. Select the size option, either Points or Units by clicking in the appropriate radio button.
	3. Enter the size you want.
	4. Click OK to accept the change and close the dialog box. Click Cancel to close the dialog box w...

	Style
	Case
	1. Select a text line.
	2. Choose Text>lower case, UPPER CASE or Title Caps.


	Text Handling
	Editing Text
	Moving Text
	Screen Horizontal Text


	Dimensions
	Dimension Menu
	Associative Dimensions
	Dimension Tools
	Show Palette
	Dimensions and the Work Plane
	Dimension Smart Pointer
	Dimensioning Objects and Placement
	1. Select the appropriate dimension tool.
	2. Click the points you want to measure.
	3. Move the dimension to a new location if its placement is not where you want it.

	Moving the Dimension
	1. Choose the Selection tool.
	2. Place the Selection tool over the dimension text and it becomes the Move symbol.
	3. Drag the dimension to the desired location.

	Dimension Status Line Fields
	Automatically Placing Dimensions on a Separate Layer
	Dimensions and Edit Objects
	Dimension Surfaces and Solids
	Smart Dimension Tool
	1. Select the tool from the Dimension tool palette. The Message Line reads: Smart Dimension: Pick...
	2. Select the curve.


	Horizontal Dimension Tools
	1. Select the Horizontal Dimension tools. Choose the Horizontal Dimension tool from the Message L...
	2. Click the left point of the geometry.
	3. Click the right point.
	Horizontal Base Line Dimension Tool
	1. Select the Horizontal Dimension tools. Choose the Horizontal Base Line Dimension tool. The Mes...
	2. Click the base point of the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears above the first measured from t...

	Horizontal Chain Dimension Tool
	1. Select the Horizontal Dimension tools. Choose the Horizontal Chanin Dimension tool. The Messag...
	2. Click the first point on the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears measured from the last point cl...


	Vertical Dimension Tools
	Vertical Dimension Tool
	1. Select the Vertical Dimension tool. Choose the Vertical Dimension tool. The Message Line reads...
	2. Click the top point of the geometry first.
	3. Click the bottom point.

	Vertical Base Line Dimension Tool
	1. Select the Vertical Dimension tools. Choose the Vertical Base Line Dimension tool. The Message...
	2. Click the base point of the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears to the right of the first measu...

	Vertical Chain Dimension Tool
	1. Select the Vertical Dimension tools. Choose the Vertical Chain Dimension tool. The Message Lin...
	2. Click the first point on the geometry.
	3. Click the point. The dimension appears.
	4. Click the next place for the dimension. This dimension appears measured from the last point cl...

	Oblique Dimension Tool
	1. Select the Oblique Dimension tool. The Message Line reads: Oblique: Pick first dimension point.
	2. Click the left point of the geometry first.
	3. Click the right point.

	Ordinate Dimension Tools
	1. Select the Horizontal Ordinate Dimension tool from the Message Line. The Message Line reads: H...
	2. Click the base point of the geometry.
	3. Click the next point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. C...
	1. Select the Horizontal Ordinate Dimension tool. The Message Line reads: Vertical Ordinate: Pick...
	2. Click the base point of the geometry.
	3. Click the next point. The dimension appears, measured from the base point.
	4. Click the next point for the dimension. This dimension appears measured from the base point. C...

	Radial Arrow Out Dimension Tool
	1. Select the Radial Arrow Out Dimension tool. The Message Line reads: Radial Arrow Out: Select a...
	2. Click near the circle, arc or fillet you want to dimension.

	Radial Arrow In Dimension Tool
	1. Select the Radial Arrow In Dimension tool. The Message Line reads: Radial Arrow In: Select arc...
	2. Click near the circle, arc or fillet you want to dimension.

	Diameter Arrow In Dimension Tool
	1. Select the Diameter Arrow In Dimension tool. The Message Line reads: Diameter Arrow In: Select...
	2. Click near the circle or arc you want to dimension.

	Diameter Arrow Out Dimension Tool
	1. Select the Diameter Arrow Out Dimension tool. The Message Line reads: Diameter Arrow Out: Sele...
	2. Click near the circle or arc you want to dimension.

	Angular Dimension Tool
	1. Select the Angular Dimension tool. The Message Line reads: Angular: Pick first line.
	2. Click on the first line near the endpoint from which you want the angle measured.
	3. Click on the second line.

	Center Mark Dimension Tool
	1. Select the Center Mark Dimension tool. The Message Line reads: Center Mark: Select circle for ...
	2. Select the circle or arc you want to dimension. Hold down the SHIFT key if you want to dimensi...

	Balloon Dimension Tools
	1. Select the Balloon Dimension tool. The Message Line reads: Balloon: Enter 2 points for balloon...
	2. Click the point on the geometry for the dimension arrow.
	3. Click the second point to specify the location of the symbol.
	4. Enter the text and frame width in the Status Line data fields. Press ENTER (Windows) or RETURN...

	Length Along Curve Dimension Tool
	1. Select the Lingth Along Curve Dimension tool. The Message Line reads: Length Dimension: Specif...
	2. Click the first point along the curve.
	3. Click the second point along the curve.

	GDT Feature Control Tool

	Dimension Appearance
	Linear
	Linear Tolerance
	Angular
	Text
	Font
	Size
	Style
	Color
	Weight
	Layer
	Arrowheads
	Arrow Size Command
	Witness Lines
	Dimension Standards
	1. Choose Dimension>Standards.
	2. In the Standards submenu, choose one of the listed standards.
	3. Click OK to accept the standard as the default and close the dialog box.
	1. Choose Dimension>Standards Settings.
	2. Enter values in the desired fields.
	3. Click Save As.
	4. Enter a new name in the data field.
	5. Click OK to close the dialog box and save the new standard.


	Dimensions and Drawing Views

	Fill and Crosshatching
	Fill Pattern and Fill Color
	Fill Pattern
	1. Choose the Selection tool.
	2. Select the polygon that you want to display with a fill pattern. Hold down the SHIFT key to se...
	3. Choose Pen>Fill Pattern and one of the fill patterns.
	1. Select the existing polygon with the Selection tool.
	2. In the Pen menu, choose a new pattern from the Fill Pattern submenu.
	1. Select the existing polygon with the Selection tool.
	2. In the Pen menu, choose None from the Fill Pattern submenu.

	Fill Color
	1. Choose the Selection tool.
	2. Select the polygon you want to fill.
	3. Select the fill color. The color displays.
	4. Choose Pen>Fill Color and select the desired color.
	1. Select the existing polygon by clicking it with the Selection tool.
	2. In the Pen menu, choose a new color from the Fill Color submenu.


	Crosshatching
	Cross Hatch Patterns
	Crosshatch Command
	1. Choose Pen>Cross Hatch. The Default Cross Hatch dialog box appears.
	2. Choose the crosshatch standard from the pull-down menu.
	3. Choose the category and the crosshatch pattern. The pattern appears in the pattern window.
	4. Specify a rotation angle and scale.
	5. Click Set Default. The default crosshatch pattern is set.
	6. Click the Close button (Windows) or the Close box (Macintosh) to close the dialog box.
	1. Select the object you want to crosshatch.
	2. If you want to apply the default crosshatch, choose Pen>Hatch and the object is crosshatched.
	3. Choose the crosshatch standard from the pull-down menu.
	4. Choose the category and the crosshatch pattern. The pattern appears in the pattern window.
	5. Specify a rotation angle and scale.
	6. Click Apply. The pattern is applied to the selected object.
	7. Click the Close button (Windows) or the Close box (Macintosh) to close the dialog box.

	Hatch Command
	1. Select the object you want to crosshatch.
	2. Choose Pen>Hatch.

	Editing Hatching
	Crosshatching and Section Cuts


	Symbols
	Symbol Palette
	Symbol Manager
	Creating Symbols
	1. Select a symbol tool.
	2. Press CTRL (Windows) or OPTION (Macintosh) to display the Symbol Manager.
	3. Click the New button. The Symbol Edit screen displays.
	4. Create your symbol geometry.
	5. When you complete your symbol geometry, click the EXIT Edit Symbol button to return to the sta...

	Symbol Tools
	Symbol 1 Point Tool
	1. Select the Symbol 1 Point tool. The Message Line reads: Symbol 1 Point: Enter location for sym...
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol you want to place in your drawing.
	4. Click OK to close the Symbol Manager dialog box.
	5. Click in the drawing area to set the symbol's origin (as defined by the master).

	Symbol 2 Points Tool
	1. Select the Symbol 2 Points tool. The Message Line reads: Symbol 2 Points: Enter symbol origin ...
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol you want to place in your drawing.
	4. Click OK to close the Symbol Manager dialog box.
	5. Click the location for the symbol origin. The location is the symbol origin defined by the mas...
	6. Click the lever point. The symbol is placed in your drawing.


	Symbol Example
	1. Open a new file.
	2. Choose Window>Symbols to display the Symbol tools palette, if it is not already displayed.
	3. Select the Symbol 2 Points tool.
	4. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager.
	5. Click on the New button. The Symbol Edit screen appears.
	6. Create an object similar to the graphic here.
	7. Once you've completed your symbol, select the Symbol 2 Point tool and then click the EXIT Edit...
	8. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager.
	9. In the Rename field, already highlighted, type BoomBox. As you type, the name is replaced in t...
	10. Click OK to accept the name and close the Symbol Manager.
	11. In your drawing click to place the origin point.
	12. Move the cursor to the right horizontally using the Drafting Assistant and click to place the...
	13. Press the CTRL key (Windows) or the OPTION key (Macintosh) to display the Symbol Manager. The...

	Transforming a Symbol
	Editing a Symbol
	1. Select a symbol tool.
	2. Press the CTRL key (Windows) or OPTION key (Macintosh) to display the Symbol Manager.
	3. Select the symbol you want to edit.
	4. Click on the Edit button.
	5. Make your changes.
	6. Click the EXIT Edit Symbol button.

	Symbols and Rendering
	Symbols and Files
	Using Symbols in Other Files
	Importing


	Viewing Geometry
	Zooming
	Zoom Commands
	Zoom Tools
	1. Select the Zoom tool from the tool palette.
	2. Drag a box around the area on the screen you want to magnify or reduce.
	3. Release the mouse button. The content of the dragged box is displayed.
	1. Choose the Zoom In tool. The Message Line reads: Zoom In: Pick area to enlarge [Ctrl (Windows)...
	2. Click in the drawing area; that position is displayed in the center of the screen and the draw...

	Using the Dynamic Pan Tool
	1. Select the Dynamic Pan tool. The Message Line reads: Dynamic Pan: Drag mouse to translate view.
	2. Place your pointer over the section of the screen you want to move and drag.

	Dynamic Zoom Tool
	1. Choose the Dynamic Zoom tool. The Message Line reads: Dynamic Zoom: Drag mouse to zoom view. M...
	2. Move the cursor to the drawing area. The cursor becomes the dynamic zoom icon.
	3. Drag the mouse to the right to zoom out or to the left to zoom in. The view scale changes acco...

	Stroke Zoom
	Zooming and Views

	Panning a View
	View Displays
	Pre-defined Views
	User-defined Views
	1. Choose View>New View.
	2. Enter the new name for the view.
	3. Select one of the Create By methods for defining your view.
	4. Enter the appropriate values according to the Create By option you choose.
	5. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close the dialog...
	1. Display the Trackball.
	2. Rotate your view as desired.
	3. Click the view name on the Trackball to display the pull-down menu.
	4. Select Save Current View and release the mouse. The new view saves.

	Modifying a View
	1. Choose View>View Properties and select the view you want to change. The Modify View dialog box...
	2. Make all of the desired changes in the appropriate fields. (See the New View section earlier i...
	3. Click OK. The dialog box closes and the new view is defined. (Click Cancel to close the dialog...

	Deleting a View

	View Rotation
	Choosing a Predefined View
	Choosing a User-defined View
	Choosing an Undefined View
	Dynamic Rotate Tool
	1. Select the Dynamic Rotate tool. The Message Line reads: Dynamic Rotate: Drag mouse to rotate v...
	2. Drag your cursor to change the view.

	Using the Shift and Arrow keys

	View Commands
	Redraw Screen - CTRL+R (Windows); z+R (Macintosh)
	View the Plane
	Show/Hide
	1. Select the Hide command. The Message Line reads: Select entities to hide [Shift = Extend].
	2. Select an object. The object hides from view.
	1. Select the Show command. The Message Line reads: Select entities to show [Shift = Extend].
	2. Select an object by clicking on the approximate location of the object or using a selection fe...
	1. Select the Show Only command. The Message Line reads: Select entities to show only [Shift = Ex...
	2. Select the object that you want displayed. Hold down the SHIFT key to select more than one obj...

	Tile
	Arrange Icons (Windows only)
	Open File Windows

	Views and Planes
	Views and Zoom Scale

	Layers
	Layer Manager-CTRL+L(Windows);z+L(Macintosh)
	1. Open the Design Explorer (Window>Design Explorer)
	2. Choose Layout>Layer Manager:
	3. Click on the Work Layer Indicator to display the pop-up menu and choose the Layer Manager command
	Default Layers

	Creating New Layers
	Using the Layer Manager
	1. Display the Layer Manager dialog box.
	2. Click the new layer button. A new layer is added to the layer list.
	3. The new layer is added.

	Using the Work Layer Indicator
	1. Click on the Work Layer Indicator to display the pop-up menu.
	2. Choose the New Layer command.

	Using the Isolate Layer Command - Alt+7 (Windows); z+7(Macintosh)
	1. Choose Layout>Isolate Layer.
	2. Click Create New Layer.
	3. Click OK to close the dialog box and save the new layer. The layer is now the active work laye...


	Renaming Layers
	1. Display the Layer Manager dialog box.
	2. Click twice on the layer you wish to rename, once to select the layer and the second time to r...

	Deleting Layers
	1. Display the Layer Manager dialog box.
	2. Select the name of the layer from the list box.
	3. Click on the trash can in the lower right corner of the dialog box. The layer is deleted.
	4. If the layer contains any geometry on it a warning appears.

	Hiding Layers
	Hiding One Layer
	1. Display the Layer Manager dialog box.
	2. Click on the “eye” icon to the right of the layer name that you want to turn hide.

	Hiding all Layers
	1. Display the Layer Manager dialog box.
	2. Right click on a layer name and choose Hide All.
	3. Cloaw the Layer Manager dialog box.


	Showing Layers
	Showing One Layer
	1. Display the Layer Manager dialog box.
	2. Click the box to the left of the layer name that you want to turn show.

	Showing all Layers

	Locking Layers
	1. Display the Layer Manager dialog box.
	2. Click in the Lock Layer column next to the desired layer and the lock icon appears.

	Unlocking Layers
	1. Display the Layer Manager dialog box.
	2. Click on the lock icon in Lock Layer column next of the desired layer. The lock icon disappear...

	Making a Layer the Active Work Layer
	Using the Layer Manager
	1. Display the Layer Manager dialog box if it is not already displayed.
	2. Click in the Work Layer column to the left of the desired layer.
	3. Close the dialog box and save the change.

	Using the Work Layer Indicator
	1. Click on the Work Layer Indicator to display the menu.
	2. Select the layer you want to make the active work layer

	Using the Isolate Layer Command - Alt+7 (Windows) z+7 (Macintosh)
	1. Choose Layout>Isolate Layer.
	2. Click on the arrow in the Layer entry field to display all available layers.
	3. Select the desired layer.
	4. Click OK to save this layer as the work layer and close the dialog box. All other layers are h...

	Increment Layer - ALT+0 (Windows); z+0 (Macintosh)
	Decrement Layer - ALT+9 (Windows); z+9 (Macintosh

	Layers and Color
	Using the Layer Color Override
	1. Display the Layer Manager dialog box if it is not already displayed.
	2. Click in the Layer Color column next to the desired layer. A color patch appears displaying th...
	3. Click on the color patch to advance to the next patch color.
	4. Select the desired color for the layer.
	5. Click OK to close the dialog box and save the change.

	Layer Color Warning

	Layers and Copying/Pasting Objects

	Planes
	Work Plane
	Show Work Plane Command
	Work Plane Manager
	1. From the work plane manager menu, choose New.
	2. Enter the values for the origin, right and up arms of the work plane. You can also specify the...
	3. Enter in name for the work plane in the Name data field.
	4. Click OK to save the new plane.
	5. Display the work plane manager menu again.
	1. Select the user-defined work plane you want to delete.
	2. Choose the Delete command. A warning box appears explaining that the operation cannot be rever...
	3. Click Yes to delete the plane.
	1. Choose a user-defined work plane.
	2. Choose the Properties command. The Define Work Plane dialog box appears displaying the name an...
	3. Change any value and click OK to close the dialog box and save the changes.

	Setting the Work Plane
	1. Click or drag on the Plane menu to display the submenu.
	2. Select one of the predefined planes.
	1. Choose Plane>3 Pts. The Message Line reads: Work Plane: Enter three points for work plane (1 o...
	2. Click in the drawing area to indicate the origin point for the new work plane.
	3. Click a point to define the positive x-axis.
	4. Click a point to define the positive y-axis.
	1. Choose Planes>Pick Objects. The Message Line reads: Work Plane: Select objects to set Work Pla...
	2. Select a curve or curves located in the plane that you want to set as the work plane.
	1. Click on the work plane icon at the left of the Status Line.
	2. From the menu select a work plane. (This menu displays the global work plane and any user-defi...

	Work Plane Snapping
	Work Plane Dimming
	Moving the Origin
	1. Choose Planes>Set Origin.
	2. Click in the drawing area to indicate the location for the new origin.

	Offsetting the Work Plane
	1. Display the work plane icon. (This is not required but it will help you visualize the offset.)
	2. Choose Planes>Offset.
	3. Enter the distance to offset (negative or positive) the work plane in the data field. The unit...
	4. Click OK to accept the value and close the dialog box.


	Work Plane and Views
	Standard Views
	View the Plane

	Work Plane and World Coordinates

	Rendering
	Lighting
	Directional Lighting
	Light Palette
	1. Select the Distant Light tool. The Message Line reads: Distant Light: Enter location and direc...
	2. Click a point to set the location of the light.
	3. Click the next point to establish the direction of the light.
	1. Select the Spot Light tool. The Message Line reads: Spot Light: Enter location and direction p...
	2. Click the first point to set the location of the light.
	3. Click the next point to establish the direction of the light.
	1. Select the Point Light tool. The Message Line reads: Point Light: Enter location.
	2. Click to set the source location of the light.

	Ambient Lighting
	Modifying the Lights
	Default Lighting
	User-Defined Lighting Layouts
	1. Select all the light sources by selecting each individually or using the Selection Mask.
	2. Choose File>Export.
	3. Select the Designer Elements program format.
	4. Choose the Selected Only option.
	5. Click OK and save the file as desired.


	Basic Rendering
	Shade Now - CTRL+T (Windows); z+T (Macintosh)
	Shade Options
	1. Choose View>Shade Options. The dialog box displays.
	2. Select the render options you desire.
	3. Click OK and the options are accepted. (Click Cancel to close the dialog box without saving th...
	1. Create some geometry.
	2. In the Shade Options dialog box, set Render Now to Hidden w/Dimmed and Static Render to Wirefr...
	3. Click OK to save the setting and close the dialog box.
	4. Choose View>Shade Now and your geometry is displayed in Hidden w/ Dimmed view mode.
	5. Rotate the view. The geometry is now displayed as wireframe because of the Static Render setting.

	Render Options and Preferences
	Basic Rendering and Lighting

	Advanced Rendering
	Render Library
	1. Choose Window>Render Library to display the dialog box.
	2. Select the materials library and desired category in their respective menus.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the dra...
	4. Continue dragging to the object to which you want to apply the image. The object highlights. R...
	5. Apply more images to your objects as desired. Then render your drawing using one of the comman...
	1. Choose Window>Render Library to display the dialog box.
	2. Select the desired library and category in their respective menus.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the dra...
	4. Continue dragging the decal to the object to which you want it applied. Use the axes included ...
	1. Choose Window>Render Library to display the dialog box.
	2. Select the desired foreground or background library.
	3. Place the pointer over the desired render image and drag. As the image is dragged over the dra...
	4. Drag to the drawing area and release the mouse button.
	1. Create the shape of your stencil.
	2. Color your stencil using a percentage of red depending on the desired stencil affect.
	1. Create your own bitmaps images.
	2. Place them in the Textures folder located within the PhotoRender folder stored with the program.
	3. Apply a Designer Elements program supplied texture to your object.
	4. Double-click on the object to display the Edit Objects dialog box.
	5. From the Texture file menu select the image you created.
	6. Click Apply and render your scene.
	1. Create your own bitmap images, both the decal stencil and the decal artwork.
	2. Place the stencils and image in the Textures folder located within the PhotoRender folder stor...
	3. Double-click on the decal to display the Edit Objects dialog box.
	4. From the Stencil menu in Edit Objects select the stencil image you created.
	5. In the Logo menu choose the Image option.
	6. From the Image menu, select the artwork image you created.
	7. Click Apply and render your scene.


	Editing the Rendered Scene
	1. Double click on the object you want to modify to open the Edit Objects dialog box.
	2. Select the Material page.
	3. Click the Advanced button to display the Render Material Settings dialog box.
	4. Select the desired settings for each shader class, as desired.
	5. Preview your object using the Update button or the Auto option.
	6. Click OK when you are satisfied with the settings to close the dialog box and save the settings.
	7. Render your scene with one of the photorealistic commands. You objects now appear based on the...
	Background and Foreground Editing

	Photorealistic Rendering
	Photorealistic Rendering Settings
	Photorealistic Rendering Commands
	1. Apply materials to the objects in your scene.
	2. Choose PhotoRender> and the command.
	1. Apply materials to objects in your scene.
	2. Hold down the CTRL (Windows) or OPTION (Macintosh) key and from the PhotoRender menu, select o...
	3. While still holding down the CTRL (Windows) or OPTION (Macintosh) key, drag a selection fence ...
	4. Release the CTRL (Windows) or OPTION (Macintosh) key and the mouse button.

	Render to File
	1. Create your drawing and apply the render materials to your objects.
	2. Choose PhotoRender>Render to File.
	3. Choose the render mode from the pull-down menu.
	4. Choose the image file format you want to create.
	5. Enter the desired width and height values. If the Match Width/Height to Drawing Window Aspect ...
	6. Click Save to create the file.

	Display Last Image Command
	Rendering and Multi-processors

	Animation
	QuickTime Movies with Camera Movement
	1. Create a curve along which the camera will travel for the movie.
	2. Choose Animation>Walk Through. The Message Line reads: Walk Through Animation: Pick curve for ...
	3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
	4. Choose your settings.
	5. Click Save. The Save document As dialog box appears.
	6. Type in the movie name and navigate to the location where you want to save the file.
	7. Click Save. The Compression Settings dialog box appears.
	8. Specify your settings for the compressor.
	9. Click OK. A progress dialog box appears providing you with a preview movie window and informat...
	10. You can now view the movie using QuickTime player.
	1. Create a curve along which the camera will travel for the movie.
	2. Choose Animation>Fly By. The Message Line reads: Fly By Animation: Pick curve for camera eye p...
	3. Select the curve. (Hold down the SHIFT key to select more than one curve.)
	4. Pick a reference point location towards which the camera will always be directed.
	5. Choose your settings.
	6. Click Save. The Save document As dialog box appears.
	7. Type in the movie name and navigate to the location where you want to save the file.
	8. Click Save. The Compression Setting dialog box appears.
	9. Click OK. A progress dialog box appears providing you with a preview movie window and informat...
	10. You can now view the movie using QuickTime player.
	1. Create two curves, one to define the camera path and the other to define the reference point t...
	2. Choose Animation>Path. The Message Line reads: Paths Animation: Pick curve for camera eye path...
	3. Select the camera path curve. (Hold down the SHIFT key to select more than one curve.)
	4. Select the reference point curve.
	5. Choose your settings.
	6. Click Save. The Save document As dialog box appears.
	7. Type in the movie name and navigate to the location where you want to save the file.
	8. Click Save. The Compression Setting dialog box appears.
	9. Click OK. A progress dialog box appears providing you with a preview movie window and informat...
	10. You can now view the movie using QuickTime player.
	1. Create your background image in a graphic software.
	2. Place the image file in the Textures folder within the PhotoRender folder.
	3. Display the Render Library.
	4. Select the Backgrounds library and the Images category.
	5. Apply the VS Logo image to your background.
	6. Choose PhotoRender>Edit Background.
	7. Select image in the Shader Types list.
	8. From the Attribute Value pull-down menu, choose your image.
	9. Click OK and render your scene.

	QuickTime VR Movies
	1. Create your drawing and apply the render materials to your objects.
	2. Choose Animation>Object VR.
	3. Enter the desired values.
	4. Click Save to create the movie.
	1. Create your drawing and apply the render materials to your objects.
	2. Choose Animation>Panoramic VR.
	3. Enter the desired description and values.
	4. Click Save to create the movie.


	Perspective Rendering

	File Management
	Using Documents
	File Use and Operation System Short Cuts
	File Menu Commands
	1. Choose File>Open.
	2. Choose the appropriate folder containing the document you want to open.
	3. Click the File name you want to open in the list box.
	4. Click OK.
	1. Choose File>Save As.
	2. If necessary, display a different folder.
	3. Type the name you want to use in the File name box.
	4. Click OK.
	1. Choose File>Revert. The following dialog box appears.
	2. Click OK to return to the original file opened and close the dialog box. (Click Cancel to clos...


	Files and Preferences
	Files and Locking
	File Size & Deleting
	Uninstalling This Program on Windows

	Importing & Exporting
	Importing
	Supported Import Formats
	Import Command
	1. Choose File>Import.
	2. Select the Import type from the list and the options for the type as desired.
	3. Click OK. The standard Open dialog box appears.
	4. Navigate to the file you want to import.
	5. Click Open to import the file.
	1. Select File>Import.
	2. Specify the import option Spline.
	3. Click OK. This Designer Elements program displays the standard Open dialog box.
	4. Select a text file that contains the coordinates for the spline.
	5. Click Open to import the file.

	Importing Tips and Notations

	Exporting
	Supported Export Formats
	Export Command
	1. Choose File>Export.
	2. Select the export type and its options. If you wish to export only selected objects on the scr...
	3. Click OK. The standard Save document as dialog box appears prompting you for a name and locati...
	4. Enter the file name and click Save. The exported file is saved with the name and location ente...

	Exporting Tips and Notations


	Drawing Composition
	Model to Sheet Command
	Using the Model to Sheet Command
	1. Select the models you want to display on the sheet.
	2. Choose Layout>Model To Sheet.
	3. Choose the Layout and Edge Display from their respective pull-down lists.
	4. Enter a scale in the Scale field.
	5. Click OK.

	Undoing the Model to Sheet Command

	Drawing Views
	Activating Views
	Drawing View Menu
	1. Select the view you want to align.
	2. In the Drawing View menu, choose the Align command.
	3. Select the parent view.


	Sheet Tools
	Drawing View Tool
	1. Select the Drawing View tool. The Message Line reads: Drawing View: Pick start position view f...
	2. Click the starting point position for the frame. The Message Line now reads: Drawing View: Pic...
	3. Click the ending point position for the frame.
	1. Turn on the layers containing the 3D geometry you want to place in the new view.
	2. Select the 3D geometry.
	3. Choose Edit>Copy.
	4. Select the empty drawing view.
	5. Choose Edit>Paste.

	Auxiliary View Tool
	1. Select the Auxiliary View tool. The Message Line reads: Auxiliary View: Pick drawing view for ...
	2. Select the drawing view from which you want to create the auxiliary view.
	3. Click the start and endpoint locations that specify the folding line for the view. The points ...
	4. Drag the view to a new location and click the mouse button. Notice that as you move the pointe...

	Section View Tools
	1. Select the Section View tool.
	2. Select the Vertical Section View tool in the Message Line. The Message Line reads: Section Vie...
	3. Select the drawing view.
	4. Click a point on your geometry for the section.
	5. Drag the view to a new location and click the mouse button. Notice that as you move the pointe...
	1. Select the Section View tool.
	2. Select the Horizontal Section View tool in the Message Line. The Message Line reads: Section V...
	3. Select the drawing view.
	4. Click a point on your geometry for the section.
	5. Drag the view to a new location and click the mouse button. Notice that as you move the pointe...
	1. Select the Section View tool.
	1. Select the 2 Pt Section View tool. The Message Line reads: Section View: Pick drawing view for...
	2. Select the drawing view.
	3. Click two points on your geometry to indicate start and end points for the section cutting line.
	4. Drag the view to a new location and click the mouse button. Notice that as you move the pointe...
	1. In the section view, select the hatch pattern.
	2. Choose Pen>Cross Hatch. The following dialog box displays.
	3. Select a category and Cross Hatch pattern from their respective lists.
	4. Set the hatch rotation angle and scale.
	5. Click Apply to change the selected hatch.
	6. Click the Close button (Windows) or the Close box (Macintosh) to exit the dialog box when you’...

	Detail View Tool
	1. Select the Detail View tool. The Message Line reads: Detail View: Pick drawing view for detail...
	2. Select the drawing view.
	3. Click the center point on your geometry for which you want a detail view.
	4. Click the detail edge point.
	5. Drag the view to a new location and click the mouse button. Notice that as you move the pointe...

	Manual View Regeneration Tool
	1. Select the Manual View Regeneration tool.
	2. Click Yes to regenerate all views.


	Unfolding Views
	1. Choose the Selection tool and activate you want to unfold.
	2. Hold down the CTRL key (Windows) or the OPTION key (Macintosh) and drag the view to the left, ...

	Editing a Drawing View
	Adding Objects to a View
	Editing Objects in the View
	Editing View Characteristics

	Layout Templates
	1. Open one of the files in the Layouts folder.
	2. Make whatever changes you desire. You can adjust the format, add text to the title block, and ...
	3. Save the file under another name in the Layouts folder.
	1. Open a new file.
	2. Set the view and plane to Top.
	3. Create the title block and border for the layout and add text if desired.
	4. Using the Drawing View tool, add drawing views.
	5. Save the file in the Layouts folder.

	Printing the Layout

	Page Setup and Printing
	Print Layout Command
	Setup Mode Section
	Drawing Size Section
	1. Choose File>Print Layout.
	2. Choose the Height and Width mode from the pull-down menu.
	3. Display the pull-down menu for the drawing format size.
	4. Select the desired size.
	1. Choose File>Print Layout.
	2. Choose the Rows and Columns mode from the pull-down menu.
	3. Enter the desired values in the Rows and Cols fields. The drawing size fields adjust accordingly.
	4. Specify the overlap for the tiled pages. The units are determined by your preferences setting.
	1. Choose File>Print Layout.
	2. Display the pull-down list for the scale.
	3. Select the desired scale. The scale appear in the edit field.
	1. Draw some geometry.
	2. Choose File>Print Layout. The Drawing Size dialog box displays. The Preview window shows a red...
	3. Check the Overlay Drawing box to display the actual geometry.
	4. Click OK in the dialog box to close it.
	5. Select an object within the page bounds.
	6. Choose File>Print Layout to display the dialog box again.
	7. Check the Print Selected box. The Preview window zooms in on selected object.
	8. Click the Overlay Drawing check box to remove the check mark. Only the selected geometry displ...

	Drawing Size and Short Cut Key

	Printing a Drawing
	Print Setup (Windows); Page Setup (Macintosh)
	Print Command - CTRL+P (Windows); z+P (Macintosh)
	Printing/Plotting Region
	Moving the Print Boundaries
	1. Choose File>Print Layout.
	2. Select the Show Page Breaks in Drawing Window check box.
	3. Click OK. The dialog box closes and the page boundaries are displayed in your drawing.
	4. Place the cursor over the marker at the lower left corner. It becomes the Move symbol.
	5. Drag the boundaries to the new location.

	Printing and Rendering

	Print Window

	Attributes and Bill of Materials
	BOM User Defined Templates
	Parametric Constraints (Cobalt Only)
	Sketch Mode
	1. Hides tool palettes such as surface and solid modeling which have no meaning in the 2D sketch ...
	2. Adjusts the drafting assistant to always snap into the sketch plane and see only snaps in the ...
	3. Turns on Auto Constraints. Auto constraints will automatically create geometric relationships ...
	4. Creates a set of layers for the sketch that includes the container layer, "Sketch 1" and sub l...
	5. Show Dimming is turned on. This feature is useful when working on faces of solids where edges ...
	1. Pick the first curve for coincident constraint.
	2. Pick the position along the first curve using the drafting assistant.
	3. Pick the second curve for the coincident constraint.
	4. Pick the position along the second curve using the drafting assistant.

	DCM Animation Settings Dialog
	Running the Animation
	Deleting Constraints
	Verifying Constraint Relations
	Constraint Preferences

	Variables and Equations
	Using Equations
	1. Move your cursor to the Dimension Name field you want to change.
	2. Click once on the Dimension Name, the dimension highlights.
	3. Change the name.
	1. Move your cursor to the Dimension Value field you want to highlight
	2. Click and hold down the mouse button
	3. The dimension highlights.
	1. Click in the equation field of the dimension you would like to change.
	2. Add your mathematical expression, such as D1*2/3.
	3. Click Apply for your changes to take place.



	Appendix A: Mathematical Operators
	Appendix B: Special Characters
	Windows:
	Macintosh:

	Appendix C: DXF/DWG Translator
	Read DXF/DWG Description

	Appendix D: IGES Translator
	Importing
	Exporting

	Appendix E: Short Cuts
	Short Cut - Key Action

	Appendix F: Spline Text Files
	1. Use a text editor, a word processor or a spreadsheet to create a text file.
	2. Input X, Y and Z values for your spline coordinates.
	3. Save the file as Text only and import into this Designer Elements program using the Spline imp...

	Appendix G: Shader Attribute Definitions
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